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1. Product Visualization
Product Visualization overview

Powered by the industry-standard JT™ file format, Teamcenter lifecycle visualization provides your entire
organization with the ability to view design data typically stored in CAD-data formats. It lets you
explore and validate product innovations and issues in a collaborative environment. When deployed in a
Teamcenter environment, the data is always current and up-to-date. Support for PLM XML also provides
a lightweight, extensible mechanism for sharing product data with other Siemens Digital Industries
Software products and supported third-party applications.

Teamcenter lifecycle visualization is available in multiple product configurations, giving you power and
flexibility to tailor your purchase to meet your organization's unique requirements.

For information on the supported versions of other Siemens Digital Industries Software file formats,
download the Teamcenter Interoperability Matrix spreadsheet found on the Support White Papers
Certifications page on Support Center.
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Visualization workflow

You can simplify the lifecycle process of your product design by quickly and easily accessing data,
analyzing it, and collaborating on your findings.

Access the
data

The 3D CAD models are translated from their native CAD-specific formats to the .jt
format either automatically using a translator in the CAD system or using an external
translator. The .jt files are much more efficient than the original. This means that you
can work with even the most complex assemblies quickly and easily.

Analyze the
data

You can perform many of the same analytical tasks that are found in expensive,
complicated CAD products. For example, with Teamcenter lifecycle visualization
base, you can measure and compare 2D drawings and measure 3D parts and create
cross sections.

Collaborate Whether you’re gathering information for a prospective client, leading a design
team, or manufacturing parts for a large customer, you can share your ideas with
colleagues.

Lifecycle Visualization viewers

The Lifecycle Visualization integration with Teamcenter supports the Teamcenter lifecycle visualization
standalone viewer and the Lifecycle Viewer within the rich client. In addition, many rich client
perspectives include embedded visualization components.

Standalone viewer

The standalone viewer, which runs outside of Teamcenter and is a separate installation, expands upon
Teamcenter's embedded visualization components with support for optional software modules such

1. Product Visualization
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as Concept, Visualization Illustration, Quality Producer, and Variation Analysis. Standalone Lifecycle
Visualization is integrated with Teamcenter, so you can send data from Teamcenter applications into the
standalone viewer, perform analysis, and then save your work back to the database.

Standalone Lifecycle Visualization is available in the following product configurations:

• Base

The Base product configuration enables you to view and mark up 2D images and perform basic 3D
analysis operations such as measurements and cross sections.

• Standard

The Standard product configuration provides many additional features, such as advanced navigation
capabilities, markup tools, and support for precise 3D measurements.

• Professional

The Professional product configuration adds analysis functionality such as 3D comparisons, as well as
the ability to manipulate and transform 3D models, create outline captures, and play motion files that
illustrate assembly sequences. You can optionally use add-on modules such as Animation, Concept,
and Visualization Illustration.

• Mockup

The Mockup product configuration provides all of the functionality from the other product
configurations and also includes advanced features such as 3D Clearance analysis, geometry
simplification, part groups, 3D filters, and movie captures. You can optionally use all of the available
add-on modules, including Quality Producer, Variation Analysis, Jack, and Path Planning.

Lifecycle Viewer

The Lifecycle Viewer is a full-fledged visualization client within Teamcenter. It provides nearly all of the
visualization tools offered by the standalone viewer, many of which are not available in the embedded
viewers within Teamcenter applications such as My Teamcenter.

The Lifecycle Viewer is available in the same product configurations as the standalone viewer, Base,
Standard, Professional, and Mockup. Features available vary depending upon the licensing level. The
Base configuration is automatically installed with the rich client.

Using the Lifecycle Viewer, you can:

• Work within a comprehensive user interface that provides access to many of the options previously
available only with the standalone products, including menus and views (the equivalent of Project
Workspace windows such as the Assembly).

• Insert or merge files within active Viewing windows.

Lifecycle Visualization viewers
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• Work with multiple open datasets.

• Preserve the state of your work with session files.

• Save data as PLM XML.

• Export 2D images and 3D models as supported datasets.

• Author visualization data such as motion files, swept volumes, and .vfz collaboration files.

Working with visualization data in the My Teamcenter viewer

The Viewer view in My Teamcenter displays content dependent on the type of object selected in the
current component view or in the Details view. Support for visualization data includes:

• If an item or item revision is selected, the viewer displays the associated image, printed circuit board,
schematic, or JT data.

• If an image, ECAD PCB, ECAD Schematic, or JT dataset is selected, the viewer displays the image,
printed circuit board, schematic, or model.

Visualization use cases

• View and markup of parts, printed circuit boards, schematics, drawings and images, without having to
launch the standalone viewer or the Lifecycle Viewer.

Visualization tools available

• 2D Markup

Create 2D markups.

• 2D Multipage

Navigate among pages in multiple-page 2D images or documents.

• 2D Viewing

Pan, zoom, rotate, and flip 2D images.

• 3D Markup

Create 3D markups.

• 3D Measurement

1. Product Visualization
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Perform 3D measurements.

• 3D Navigation

Pan, rotate, and zoom 3D models.

• 3D PMI

View and manipulate PMI in your model.

• 3D Section

Create 3D cross sections.

• 3D Selection

Select parts and pick part features.

• 3D Standard Views

Examine your model from preset viewing angles.

• ECAD Base

Manipulate the view of ECAD document layers, control layer color and visibility, search, and create
reports.

• ECAD Markup

Create ECAD markups.

• ECAD Multipage

Navigate among pages in multiple-page schematic documents.

• ECAD Viewing

Pan, zoom, rotate, and flip image.

• Print

Print documents.

Lifecycle Visualization viewers
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Structure Manager viewer

The viewer embedded in Structure Manager is available within the Viewer tab of the data pane. The
viewer allows you to view JT files attached to assemblies and components in the structure tree when you
are viewing and editing a product structure.

Visualization use cases

• View 3D assemblies or structures.

• View subcomponents in an assembly.

• Compare product structures.

• Create and save product views.

Visualization tools available

• 3D Alignment

Align parts with other parts in the viewing window.

• 3D Appearance

Change the appearance of 3D models.

• 3D Clearance

Check the clearance of parts in 3D models.

• 3D Comparison

Compare the geometry of two sets of parts.

• 3D Coordinate System

Create and align parts to local coordinate systems.

• 3D GDT Markup

Create 3D GD&T markups.

• 3D Manipulators

Transform 3D models.

1. Product Visualization

1-6  Visualization on Rich Client ─ Getting Started, Teamcenter 2412
© 2025 Siemens



• 3D Markup

Create 3D markups.

• 3D Measurement

Perform 3D measurements.

• 3D Movie Capture

Capture your actions in the 3D viewing window as movie files.

• 3D Navigation

Pan, rotate, and zoom 3D models.

• 3D PMI

View and manipulate PMI in your model.

• 3D Section

Create 3D cross sections.

• 3D Selection

Select parts and pick part features.

• 3D Standard Views

Examine your model from preset viewing angles.

• 3D Thrustline Editor

Create and manipulate thrustlines.

• 3D Visibility

Hide obscuring parts and clip areas of your model.

Multi-Structure Manager viewer

The viewer embedded in Multi-Structure Manager is available within the Object View tab of the data
panel. The viewer allows you to view associated 2D images and 3D models when you are viewing and
editing a product or process structure.

Lifecycle Visualization viewers
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Visualization use cases

• View product or process structures.

• View images associated with objects selected on the structure tab.

• View and create markups.

• Create and save product views.

Visualization tools available

• 2D Markup

Create 2D markups.

• 2D Multipage

Navigate among pages in multiple-page 2D images or documents.

• 2D Viewing

Pan, zoom, rotate, and flip 2D images.

• 3D Markup

Create 3D markups.

• 3D Measurement

Perform 3D measurements.

• 3D Navigation

Pan, rotate, and zoom 3D models.

• 3D PMI

View and manipulate PMI in your model.

• 3D Section

Create 3D cross sections.

• 3D Selection

1. Product Visualization
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Select parts and pick part features.

• 3D Standard Views

Examine your model from preset viewing angles.

Manufacturing Process Planner viewer

The viewer embedded in Manufacturing Process Planner is available within the Object View tab of the
data panel. The viewer allows you to view associated 2D images and 3D models when you are viewing
and editing a process structure.

Visualization use cases

• View product or process structures.

• View images associated with objects selected on the structure tab.

• View and create markups.

• Create and save product views.

Visualization tools available

• 2D Markup

Create 2D markups.

• 2D Multipage

Navigate among pages in multiple-page 2D images or documents.

• 2D Viewing

Pan, zoom, rotate, and flip 2D images.

• 3D Markup

Create 3D markups.

• 3D Measurement

Perform 3D measurements.

• 3D Navigation

Lifecycle Visualization viewers
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Pan, rotate, and zoom 3D models.

• 3D PMI

View and manipulate PMI in your model.

• 3D Section

Create 3D cross sections.

• 3D Selection

Select parts and pick part features.

• 3D Standard Views

Examine your model from preset viewing angles.

JT Preview view

The JT Preview view enables you to examine .jt parts associated with items, item revisions, and
datasets. When you select a compatible object, the .jt part is displayed in the view.

Visualization use cases

• Preview .jt parts.

Visualization tools available

• 3D Navigation

Pan, rotate, and zoom 3D models.

Image Preview view

The Image Preview view enables you to examine 2D raster images associated with items, item revisions,
and datasets. When you select a compatible object, the image is displayed in the view.

Visualization use cases

• Preview 2D raster images.

Visualization tools available

• None

1. Product Visualization
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Ways to access Lifecycle Visualization

You can access Lifecycle Visualization by:

• Starting the standalone viewer, where you access the files from a local or network drive.

• Accessing files from Teamcenter, and viewing them in one of the embedded viewers or sending them
to standalone Lifecycle Visualization.

Understanding Startup Accelerator

Teamcenter Visualization Startup Accelerator is a small Windows application that speeds up the initial
start of Teamcenter viewers by pre-loading key visualization dynamic link libraries (DLLs) when you start
your computer.

• The application is available only for Windows.

• Installing Startup Accelerator is an option when you install Teamcenter.

• When you install the application, a Startup Accelerator icon  appears in the Windows taskbar
notification area.

Startup Accelerator consumes a small amount of your system memory when it loads visualization DLLs.
If your computer is low on memory, you can stop Startup Accelerator to release the memory. You lose
the benefits of Startup Accelerator, but increase available memory.

Stop Startup Accelerator

In the Windows taskbar notification area, right-click the Startup Accelerator icon  and do any of the
following:

To Choose

Stop Startup Accelerator and unload the
DLLs from memory

Stop

Restart the Startup Accelerator
application after stopping

Start

To unload the DLLs and close the
Startup Accelerator application

Exit

The icon disappears from the Windows
taskbar.

Ways to access Lifecycle Visualization
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To Choose

Note:

To restart the Startup Accelerator
application after exiting, you
must restart your computer.

Note:

If your computer has adequate memory, you do not need to stop Startup Accelerator.

Graphics hardware requirements

For full confidence that all of the advanced features of Teamcenter lifecycle visualization are displayed,
including effects such as high-quality transparency, shadows, mirrors, CAE analysis results, intersection
volumes, and other features requiring advanced graphics capabilities, use a certified system. Siemens
Digital Industries Software and our OEM partners rigorously test specific graphics adapters and drivers
on a select set of workstations. Graphic adapters and drivers that pass are certified for use with a
particular version of Teamcenter lifecycle visualization.

For information about certified systems, download the Teamcenter Visualization Graphics Certifications
spreadsheet found on the Hardware and Software Certifications knowledge base article on Support
Center (scroll down to the Teamcenter Visualization Software Certifications heading).

Note:

Starting with Lifecycle Visualization version 2412, systems are required to have a GPU that
supports OpenGL 3.3 (required minimum) or OpenGL 4.6 (recommended minimum) or later. If
Lifecycle Visualization detects no GPU, or is unable to create a GL context that supports OpenGL
3.3, a warning dialog will display when opening a 3D document. OpenGL 4.6 is required for access
to all Lifecycle Visualization graphics features. If you work with large models, we recommend
graphics cards with 2GB or 4GB of GPU memory, or more. While exact memory requirements are
highly situation specific, a rough guideline for required graphics card memory is 1 GB of graphics
memory for every 2 GB of loaded geometry data.

Consumer line and 2D graphics adapters

We do not recommend consumer lines of graphics adapters. These adapters and drivers are designed for
playing games and emphasize frame rate over correctness. Drivers for consumer graphics are serviced by
driver development and ISV partner teams separate from those for professional 3D adapters.

However, even these video adapters, if you have the most current graphics driver, usually work at
a reduced effects level with Lifecycle Visualization. It may be necessary to reduce the performance
settings.
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Note:

When the OpenGL level of a graphics adapter is not capable of rendering an advanced visualization
effect, the visual effect is silently omitted.

Resolving graphics adapter issues

You are encouraged to report graphics display problems found on recommended and certified hardware
to Siemens Support Center. We attempt to reproduce the problem. If a reproducible problem is
determined to lie within Lifecycle Visualization software, we fix it directly; if a problem is found with
the graphics driver, we work with the graphics vendor to isolate the issue and assist them as necessary
to produce a driver patch.

We do not attempt to resolve problems that cannot be reproduced on recommended or certified
hardware; we advise you to take such issues directly to the graphics adapter manufacturer.

Graphics hardware requirements
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1. Product Visualization
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2. How do I?
How do I?

The following is a set of best practices for commonly asked questions gathered into one place for easy
access.

• Display 3D models

• Examine 3D models

• View 3D models from preset viewing angles

• Smooth the edges of 3D models

• Capture an image of a 3D model

• Create line drawings from 3D models

• View part properties

• Add text markups to the 3D scene

• Add callouts to parts

• Measure angles on 3D models

• Save 3D measurements

• Display Product Manufacturing Information (PMI)

• Change the color of a part

• Create 3D snapshots

• Create Visual Reports

• Email your work session

• View 2D images

• Compare 2D images

• Change 3D display modes
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• Create shortcuts to file locations

• Change the background color

Display 3D models

1. Open a 3D model.

2. In the assembly tree, click the + icon next to the name of the top-level assembly node.

The assembly expands to show additional levels of structure.

Tip:

When you first open a 3D model that consists of more than one part, only the assembly tree
is visible. You can use the tree to turn on the entire model or only the parts that you want to
view.

3. Select the check box next to the name of a subassembly or part.

The geometry is displayed in the Viewing window.

2. How do I?
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Examine 3D models

1. Open and display a 3D model.

2. Right-click the toolbar area of the application, and select 3D Navigation.

The 3D Navigation toolbar is displayed.

3. Rotate around the model.

a. On the 3D Navigation toolbar, click Examine .

b. To rotate freely around the model, in the center of the Viewing window, click and drag the
cursor.

The model appears to rotate across axes according to your mouse movements.

c. To constrain the model rotation, click and drag along the top, bottom, left, or right edge of
the Viewing window.

Examine 3D models
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If the cursor is near the left or right edge of the Viewing window when you begin, a horizontal
axis is used for rotation.

If the cursor is near the bottom edge, a vertical axis is used for rotation.

If the cursor is near the top edge, a perpendicular axis is used for rotation.

4. Pan across the model.

a. Click Pan .

b. In the Viewing window, click and drag in any direction.

The navigation camera pans across the model.

2. How do I?
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5. Zoom in or out on the model.

a. Click Navigate .

b. In the Viewing window, click and drag up toward the top of the Viewing window then down
toward the bottom.

The navigation camera zooms in and out on the model.

View 3D models from preset viewing angles

1. Open and display a 3D model.

2. Right-click the toolbar area of the application, and select 3D Standard Views.

The 3D Standard Views toolbar is displayed.

Standard, Professional, and Mockup

3. On the 3D Standard Views toolbar, click Align to Axis , and then choose a viewing angle.

View 3D models from preset viewing angles
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Smooth the edges of 3D models

1. Open and display a 3D model.

2. Turn on anti-aliasing.

a. Right-click a blank area of the Viewing window and choose Preferences.

b. On the General tab of the Preferences dialog box, select the Anti-aliasing check box.

c. From the No. of samples list, choose the number of samples for anti-aliasing.

2. How do I?

2-6  Visualization on Rich Client ─ Getting Started, Teamcenter 2412
© 2025 Siemens



Note:

A higher number of samples results in smoother edges. However, using a higher
number of samples may also impact the performance of your system.

d. Select the Set as default check box to automatically apply your anti-aliasing settings when
you open 3D models.

Smooth the edges of 3D models
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e. Click OK to close the preferences.

The anti-aliasing changes are applied to the model.

Capture an image of a 3D model

1. Open and display a 3D model.

2. Capture the 2D image.

a. Right-click the toolbar area of the application, and select Image Capture.

2. How do I?
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The Image Capture toolbar is displayed.

b. Stage the contents of the Viewing window as needed.

Tip:

A 2D image capture exactly matches what you see in the Viewing window, so you
may want to adjust the visibility and position of your model. You can also control the
dimensions of the image by changing the size of the Viewing window.

c. On the Image Capture toolbar, click Image Capture .

A 2D image capture of the Viewing window is created.

Capture an image of a 3D model
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3. Save the 2D image.

a. Choose File→Export Image.

b. In the Export Image dialog box, adjust the settings as needed.

Tip:

A resolution of 72 DPI is suitable for images to display on a monitor (email and web
pages). Use a resolution of at least 300 DPI for print content.

2. How do I?
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c. Click OK.

d. In the Export Image save dialog box, browse to the location where you want to save your
image, and click Save.

Capture an image of a 3D model
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Create line drawings from 3D models

1. Open and display a 3D model.

2. Create the outline capture.

a. Stage the contents of the Viewing window as needed.

Tip:

An outline capture includes only what you see in the Viewing window, so you may want
to adjust the visibility of your model. Since the capture is a vector image, the position of
the model within the boundaries of the Viewing window does not matter because you
can scale the image with no loss of image quality. Any part of the model that is turned
off or outside of the Viewing window is not included in the capture.

2. How do I?
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b. Choose Actions→Outline Capture→Current 3D Window.

The outline capture is created. The drawing of the model is placed on a unique layer in the
tree. Any 3D measurements or markups included in the capture are placed on separate layers.

3. Save the outline capture as a 2D vector image.

Create line drawings from 3D models

Visualization on Rich Client ─ Getting Started, Teamcenter 2412  2-13
© 2025 Siemens



a. Choose File→Layers→Save All Layers.

b. In the Save As dialog box, browse to the location where you want to save your image, and
click Save.

View part properties

You can view properties of an assembly or part in the Properties dialog box, and you can add an
attribute from the Properties dialog box to the Assembly view as a new column of information for
part and assembly nodes.

1. In the Assembly view, right-click a part or assembly and choose Properties.

2. How do I?
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2. In the Properties dialog box, view the part or assembly properties on the respective properties
page.

Attributes
Geometry
Extent

Attributes page

The Attributes page of the Properties dialog box displays any metadata associated with the part or
assembly.

Tip:

You can add an attribute from the Properties dialog box to the Assembly view as a new column of
information for part and assembly nodes.

1. On the Attributes page, in the Attribute column, select an attribute.

2. Click Add as Column.

View part properties
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A new column for the attribute appears in the assembly tree.

Geometry page

The Geometry page of the Properties dialog box displays Area, Volume, Density, Mass, and Center of
mass for the part or assembly. For each property, a numeric annotation within curly braces { } identifies
the source of the value.

2. How do I?
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{1} From model

The JT model contains specific properties that hold the exact measurements, and those are used to
populate the dialog box. These JT properties are:

JT Property Name Meaning

JT_PROP_MEASUREMENT_UNITS CAD Model Units

CAD_MASS_UNITS Units of mass

CAD_SURFACE_AREA Surface area of solids within a part

CAD_VOLUME Volume of solids within a part

CAD_DENSITY Density of solids within a part

While the single value implies uniform density, such may not
be the case.

CAD_MASS Mass or weight of solids within a part

CAD_CENTER_OF_GRAVITY Center of gravity of solids within a part

View part properties
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{2} Calculated

The JT model properties listed in {1} are not present. Therefore, an approximate value is calculated
from the polygonal data. The tilde ~ symbol appears in front of a calculated value. BREP data is not
used for the calculation.

{3} Default Measurement

The JT model property CAD_DENSITY is not present and the Density value has not been
manually entered. Therefore, the default density value as specified in the Calculations tab of the
Measurement Preferences dialog box is used.

{4} User-Defined

The Density value is manually entered.

Extent page

The Extent page of the Properties dialog box displays location and size information for the part or
assembly, including Min, Max, Center, Length X, Length Y, and Length Z.

Add text markups to the 3D scene

1. Open and display a 3D model.

2. How do I?
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2. Right-click the toolbar area of the application, and select 3D Markup.

The 3D Markup toolbar is displayed.

3. Add a comment to the 3D scene.

a. On the 3D Markup toolbar, click 3D Markup .

b. Click Text .

c. Click anywhere in the Viewing window.

d. In the Markup Text dialog box, type some text and click OK.

Add text markups to the 3D scene
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The text is displayed in the scene.

4. Create a text markup that is anchored to a part.

a. On the 3D Markup toolbar, click Anchor .

b. Click a part.

2. How do I?
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c. In the Markup Text dialog box, type some text and click OK.

A text markup that is anchored to the part is created.

Add text markups to the 3D scene
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5. Change the position of a text markup.

a. On the 3D Markup toolbar, click Select .

b. In the Viewing window, click and drag the markups to new locations.

The anchored text markup has a leader line connecting it to the part.

6. (Optional, anchored text) To add another leader to the markup, do the following:

a. Right-click the text markup and choose Add Leader. The add leader mode is enabled.

2. How do I?
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b. Click the next part, or another point on the same part, to which you want to add a leader.

A leader is added to the markup.

c. Disable the add leader mode by right-clicking the text markup again and choosing Add
Leader. The add leader mode is now toggled off.

7. Rotate your view to see how the two types of markups behave.

8. Save your markups with the model.

a. Choose File→Save Session.

Add text markups to the 3D scene

Visualization on Rich Client ─ Getting Started, Teamcenter 2412  2-23
© 2025 Siemens



b. In the Session Save As dialog box, click Browse to specify the location where you want to
save the session file.

c. Click Save.

Add callouts to parts

1. Open and display a 3D model.

2. Right-click the toolbar area of the application, and select 3D Markup.

The 3D Markup toolbar is displayed.

2. How do I?
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3. Set up the callouts.

a. On the 3D Markup toolbar, click Enable Markup .

b. Click Preferences .

c. In the Markup 3D Preferences dialog box, click the Text tab.

d. In the Bounding Shape section, select Circle from the list.

e. In the Pre-defined Text section, click Edit.

f. In the Edit Text dialog box, click <Callout>, click Add Key, and then click OK.

Add callouts to parts
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g. At the bottom of the Text tab, click Callouts.

h. In the Callouts dialog box, in the Default Callout Format section, choose Numeric.

i. In the Starting Value section, in Numeric, type 1.

2. How do I?
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j. Click OK twice to close the preferences.

4. Add the first callout.

a. On the 3D Markup toolbar, click the following buttons:

• Text 

• Anchor Mode 

• Use Pre-defined Text Mode 

b. In the Viewing window, pick a part.

The callout appears on the part.

Add callouts to parts
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5. Add more callouts.

a. Pick several more parts.

b. On the 3D Markup toolbar, click Select  and drag the callouts away from the parts.

6. Reset your markup preferences.

2. How do I?
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a. On the 3D Markup toolbar, click Preferences .

b. On the Text tab, set the Bounding Shape to Rectangle.

c. In the Pre-defined Text section, click Edit, delete <Callout>, and click OK.

Measure angles on 3D models

1. Open and display a 3D model.

2. Right-click the toolbar area of the application, and select the following:

• 3D Measurement

The 3D Measurement toolbar is displayed.

Mockup

• 3D Selection

Measure angles on 3D models
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The 3D Selection toolbar is displayed.

Standard, Professional, and Mockup

3. Measure the angle of a circular arc.

• Press Ctrl and on the 3D Selection toolbar, click Edge  to make it the only active selection
filter.

• On the 3D Measurement toolbar, click Single Measurement .

• In the Viewing window, click a curving edge.

The application measures the edge, displaying its center, radius, angle, and length.

4. Measure the angle between two surfaces.

• Press Ctrl and on the 3D Selection toolbar, click Surface  to make it the only active selection
filter.

• On the 3D Measurement toolbar, click Angle .

• In the Viewing window, click two surfaces.

2. How do I?
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The application measures the angle between the two surfaces.

Save 3D measurements

1. Open and display a 3D model.

2. Right-click the toolbar area of the application, and select 3D Measurement.

The 3D Measurement toolbar is displayed.

3. Right-click the toolbar area of the application, and select 3D Selection.

The 3D Selection toolbar is displayed.

Standard, Professional, and Mockup

Base

4. Specify the preference to include measurements in session files.

Save 3D measurements
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a. On the 3D Measurement toolbar, click 3D Measurement .

b. Click Preferences .

c. In the Measurement Preferences dialog box, click the General tab.

d. In the All Measurements section, click the following check boxes:

• Save to session files

• Restore during session load

e. Click OK to close the preferences.

5. Measure the distance between two points on your model.

a. On the 3D Measurement toolbar, click Distance .

2. How do I?
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b. On the 3D Selection toolbar, if Point is not the only active selection filter, press Ctrl and click
Point .

c. In the Viewing window, click two points on the model.

The measurement is created.

6. Save the measurement with a session file.

a. Choose File→Save Session.

b. In the Session Save As dialog box, click Browse to specify the location where you want to
save the session file.

c. Click Save.

7. Close and reopen the session file to restore your measurement.

a. Choose File→Close Session.

b. Choose File→Open.

c. In the Open dialog box, open your session file.

The saved measurement is automatically displayed in the Viewing window.

Save 3D measurements
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Display Product Manufacturing Information (PMI)

1. Open and display a 3D model that includes PMI.

2. Right-click the toolbar area of the application, and select 3D PMI.

The 3D PMI toolbar is displayed.

3. On the 3D PMI toolbar, click PMI .

4. Click Multiple Entity Mode .

5. In the Viewing window, click parts to display PMI.

The PMI is displayed in the Viewing window and in the PMI view.

2. How do I?
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Change the color of a part

1. On the 3D Appearance toolbar, click Quick Color Tool .

2. In the Viewing window or the assembly tree, select the part to change (or hold Ctrl and select
multiple parts).

3. In the Quick Color dialog box, choose a color from the color well.

Change the color of a part
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4. From the transparency list, select a level of transparency.

Create 3D snapshots

1. Open and display a model.

2. Choose Toolbars→Snapshots.

The Snapshots toolbar is displayed.

2. How do I?
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3. Create the snapshots.

a. Open the Snapshots view.

b. On the Snapshots toolbar, click Add .

A new snapshot is created in the Snapshots view.

c. Rotate the model view in the Viewing window.

d. On the Snapshots toolbar, click Add .

A snapshot capturing the new model orientation is created.

e. In the Viewing window, right-click a part and select Turn Off.

The part is no longer displayed.

Create 3D snapshots
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f. On the Snapshots toolbar, click Add .

A snapshot capturing the modified part visibility is created.

4. Apply the snapshots.

a. In the Snapshots view, double-click the first snapshot.

The Viewing window updates to match the snapshot.

b. In the Snapshots view, double-click the second snapshot.

The Viewing window updates to match the snapshot.

c. In the Snapshots view, double-click the third snapshot.

The Viewing window updates to match the snapshot.

Create Visual Reports

Note:

You can also use the Find command identify parts that match specified criteria.

2. How do I?
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1. Open and display a 3D model.

2. Right-click the toolbar area of the application, and select 3D Visual Report.

The 3D Visual Report toolbar is displayed.

3. Create a single rule report.

a. On the Visual Report toolbar, click Visual Report .

b. Click Single Rule Report .

The Single Rule Report dialog box is displayed.

4. Define the scope of the report.

a. In the Report Scope section, from the Source:Attribute list, choose From attribute.

Create Visual Reports
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The Attribute Selection dialog box is displayed.

2. How do I?
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b. In the Attribute Selection dialog box, click Execute.

Create Visual Reports
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The Attribute List is populated with data from the model.

c. Choose Category, and click OK.

2. How do I?
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d. The first part of the query is now displayed.

Create Visual Reports
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e. To specify the category value, from the second list, choose Select.

f. An error message is displayed because you must first specify the parts that you want to search
for attribute values. Click OK to close the message.

2. How do I?
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g. Right-click in the Viewing window, and choose Select All.

This selects all of the parts in the model.

h. In the Attribute Values dialog box, click Regenerate.

Create Visual Reports
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The attribute values available to the report are now displayed.

i. Select an attribute value, and then click OK.

2. How do I?
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The second part of the query is now displayed.

Create Visual Reports
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5. Apply the report.

In the Single Rule Report dialog box, click Apply.

All of the parts that match the query are displayed in red; unmatched parts turn semi-transparent
gray.

2. How do I?
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Email your work session

To send email from the viewer, through an MAPI email program like Microsoft Outlook, the viewer and
email program must have the same bitness. If one is 32-bit and the other is 64-bit, you get a warning
message and the email is not sent.

1. Open a 3D model and display the content that you want to include in the collaboration file, such as
parts, 3D markups, and groups.

Note:

Only what is visible in the Viewing window is included in the collaboration file. Snapshots
are not packaged in new collaboration files because they may reference parts that are not
currently visible, which may result in a reconcile problem for the recipient of the file.

2. Email the collaboration file.

a. Choose File→Send Mail→Collaboration File.

Your work session is packaged as a .vfz file and attached to a new email message.

b. Send the email to your recipient.

3. View the collaboration file.

a. Open the email with the collaboration file attachment.

b. Open the attachment to display the saved session in the viewer.

View 2D images

1. Open a 2D image.

2. Right-click the toolbar area of the application, and select 2D Viewing.

The 2D Viewing toolbar is displayed.

3. Zoom in on an area of the image.

a. On the 2D Viewing toolbar, click Zoom Area .

Email your work session
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b. In the Viewing window, click and drag a box around an area of the image.

The selected area fills the window.

4. Center the image on a specific point.

a. On the 2D Viewing toolbar, click Seek .

b. In the Viewing window, click anywhere.

The image is centered on the specified point.

5. Pan across the image.

a. On the 2D Viewing toolbar, click Pan .

b. In the Viewing window, click and drag across the image.

The image pans across the screen.

2. How do I?
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6. Fit the entire image in the Viewing window.

• On the 2D Viewing toolbar, click Fit All .

The image is scaled to fit within the Viewing window.

7. Flip the image horizontally and vertically.

• On the 2D Viewing toolbar, click Flip Horizontal .

View 2D images
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• On the 2D Viewing toolbar, click Flip Vertical .

8. Rotate the image.

• On the 2D Viewing toolbar, click Rotate Clockwise .

• On the 2D Viewing toolbar, click Rotate Counterclockwise .

2. How do I?

2-52  Visualization on Rich Client ─ Getting Started, Teamcenter 2412
© 2025 Siemens



Compare 2D images

1. Open the 2D images that you want to compare.

a. Choose File→Open and open the first image.

The image is displayed in the Viewing window. It also appears in the Base Document section
of the 2D tree.

b. Choose File→Insert and insert another version of the 2D image.

The second image overlays the base document image in the Viewing window. It also appears
in the Markup Layers section of the 2D tree.

Compare 2D images
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2. Perform the 2D comparison.

a. Right-click the toolbar area of the application, and select 2D Compare.

The 2D Compare toolbar is displayed.

b. On the 2D Compare toolbar, click Compare Layers .

The Compare Layer List Dialog dialog box opens.

c. From the First Layer list, choose one of the open images.

2. How do I?
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d. From the Second Layer list, choose the other image.

e. Click OK.

The image comparison is performed. A new layer called the compare layer is created. The
compare layer, which is black, shows only the common elements of the compared images.
The first layer image turns red; the second layer image turns green.

3. Review the results of the comparison.

• To display the first layer only, on the 2D Compare toolbar, click Display 1st Layer .

Compare 2D images

Visualization on Rich Client ─ Getting Started, Teamcenter 2412  2-55
© 2025 Siemens



• To display the second layer only, on the 2D Compare toolbar, click Display 2nd Layer .

2. How do I?
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• To display the compare layer only, on the 2D Compare toolbar, click Display Compare Layer
.

• To display all of the layers from the comparison, on the 2D Compare toolbar, click Display All
.

Compare 2D images
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Change 3D display modes

1. Open and display a 3D model.

2. Right-click the toolbar area of the application, and select 3D Display Modes.

The 3D Display Modes toolbar is displayed.

2. How do I?
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3. Change the display mode for individual parts.

a. In the Viewing window, select a part.

b. On the 3D Display Modes toolbar, click Draw tessellation lines .

c. The part is displayed in the Tessellation Lines display mode.

4. To reset the part appearance, click Clear display modes .

5. Change the display mode for the entire model.

a. To ensure that no parts are selected, click on a blank area of the Viewing window.

b. On the 3D Display Modes toolbar, click Draw feature lines .

Lines are displayed on the edges of the model.

Change 3D display modes
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c. To show only the feature lines, click Draw shaded model .

The model is displayed in the Feature Lines display mode.

d. To remove hidden lines from the model, click Hidden lines invisible .

2. How do I?
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Create shortcuts to file locations

1. Choose File→Open.

The Open dialog box is displayed.

2. Add a folder to your user areas.

a. Browse to a location you want to bookmark.

Create shortcuts to file locations
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b. On the Open dialog box, choose Tools→Add Current Location To User Areas.

A new folder appears in your user areas.

c. Name the folder.

d. Double-click the folder and open a file.

The user area is created.

e. Close the file.

3. Access a user area.

a. Choose File→Open.

b. On the left side of the Open dialog box, click User Areas.

Your user areas are displayed.

2. How do I?
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c. Double-click a folder to access your files.

Change the background color

1. Open and display a 3D model.

2. Right-click a blank area of the Viewing window and choose Preferences.

The Preferences dialog box is displayed.

Change the background color

Visualization on Rich Client ─ Getting Started, Teamcenter 2412  2-63
© 2025 Siemens



3. Specify a solid color for the background.

a. In the Window section, from the Background list, choose Solid.

b. Click the color well and choose the background color.

2. How do I?
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c. Click Apply.

4. Specify a color gradient for the background.

a. In the Window section, from the Background list, choose from the following gradients:

• Vertical — A two color vertical gradient.

• Horizontal — A two color horizontal gradient.

• Corners — A four color diagonal gradient.

b. Click the color wells and choose the gradient colors.

5. Save your settings.

Change the background color
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a. In the Window section, click the Set as default check box.

b. Click OK.

The background color settings are saved.

2. How do I?
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3. Exploring the Interface
Overview of the interface

The Lifecycle Viewer interface consists of a Teamcenter perspective, associated views, the Viewing
window, toolbars, and the Status bar. As you switch between different types of documents (2D, 3D, or
ECAD), the toolbars and menus update for the type of active document. The figure below shows the
default 3D interface, with two visible views: the Assembly and the Navigator views.

1 Views Enable you to perform such tasks as displaying the product
structure or showing and hiding 2D image layers.

2 Viewing window Displays your 3D model or 2D image. When you open
multiple files, the 3D model or 2D image associated with
each file appears in a separate Viewing window.

As you switch between viewing windows, the supporting
views update for the contents of the active viewing
window.

3 Status bar Displays information about the current state of the product,
including the amount of memory that is available for 3D
documents.
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Working with windows and views

Overview of visualization views and windows

Visualization views in the Lifecycle Viewer make up a view network where a primary view is always
active and may be implicitly associated with one or more secondary views. Primary views are the active
Viewing windows where you can interact with 2D images or 3D models. Secondary visualization views
display information about the 2D image or 3D model contained in the active primary view. Examples of
secondary visualization views include the Assembly, Snapshots, and PMI views.

You can open multiple visualization files at once, with each file residing in a unique primary view, only
one of which is active at a time. Secondary visualization views always display information related to the
active primary view. When you switch from one primary view to another, all secondary views update
automatically to reflect the newly active image or model. You cannot open more than one instance of
each secondary visualization view at a time.

1 Secondary visualization views Secondary visualization views display information about
the 2D image or 3D model contained in the active primary
view. This example shows the Assembly and Navigator
views, which are outlined in yellow to indicate their relation
to the active primary view.

2 Primary visualization views Primary visualization views are the main Viewing windows
where you can interact with 2D images or 3D models. This
example shows two primary views, each of which contains
a 3D model. The active view is outlined in yellow, which

3. Exploring the Interface
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matches the related Assembly and Navigator views. The
inactive view is outlined in blue and not currently related to
any secondary visualization views.

Move windows and views around your workspace

Do one of the following:

• Click the window or view header bar and drag the window around the interface.

• Right-click the view or window tab, choose Move and then select what you want to move from the
shortcut menu.

The window or view moves with your mouse pointer around the screen.

As you move the window or view the cursor changes to indicate where the view will be docked when
you release the mouse button. For example,  indicates that the view will be placed at the top of
the window.

Note:

The stack cursor  appears as you drag the view across other views indicating that you can
rearrange the views or move a view into the view group.

Control window and view docking

• Right-click the Viewing window or view, and select or clear Detached.

The window or view floats in the interface and you can move it anywhere in your screen area. When a
window or view is detached, a title bar appears.

Show or hide visualization views

You can show or hide secondary views, such as the Navigator and the Assembly view.

• Do any of the following:

To Do this
Display a
secondary view

• On the upper right side of a primary visualization view (the main Viewing
window that displays a 2D image or 3D model), click the arrow and select a
view.

Move windows and views around your workspace
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To Do this

Close a view Do one of the following:

• On the view tab, click X.

• Right-click the view tab and choose Close.

Note:

To reset the Lifecycle Viewer to its default state, choose Window→Reset Perspective.

List of visualization views

Assembly view

Use the Assembly  view to work with 2D images, 3D models, and ECAD documents in the Lifecycle
Viewer.

Compare view

Use the Compare  view to display ECAD document differences between two opened ECAD
documents. You can display differences from one design revision to other revisions, and you can

3. Exploring the Interface
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display differences between a PCB and its schematic design. When you highlight differences on the
Compare view, the ECAD object is centered and highlighted in the Viewing window. You can also
display differences by selecting View Differences from the compare shortcut menu.

Constraints view

Use the Constraints  view to work with constraints in the Lifecycle Viewer.

Constraints view
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Cross Sections view

Use the Cross Sections  view to work with 3D cross sections in the Lifecycle Viewer.

3. Exploring the Interface
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ECAD DFX view

Use the ECAD DFX  view to work with ECAD rules-based analysis in the Lifecycle Viewer.

ECAD Layer view

Use the ECAD Layer  view to show, hide, and otherwise manipulate ECAD layers in the Lifecycle
Viewer.

ECAD DFX view
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Groups view

Use the Groups  view to show, hide, and select part groups in the Lifecycle Viewer.

3. Exploring the Interface
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Navigator view

Introduction to the Navigator view

Use the Navigator  view to zoom in quickly for a closer look at 2D images and 3D models in the
Lifecycle Viewer.

Zoom to a portion of your image or model with the Navigator view

You can zoom and pan your view in the Viewing window by selecting a portion of the full view to display
in the Viewing window. The result is the same using Fit All and then Zoom Area in the Viewing window.

1. In the Navigator view, place the cursor over a portion of the image or model.

2. Hold the left mouse button and move the cursor.

The view box in the Navigator view is redrawn to enclose the area you have indicated. When you
release the mouse button, the portion of the image or model inside the view box in the Navigator
view is displayed in the Viewing window. A red view box in the Navigator view identifies the
portion of the image or model displayed in the Viewing window.

Change your lookat point with the Navigator view

You can pan your view in the Viewing window by picking a new lookat point in the full view without
zooming. This is similar to using Pan or Seek in the Viewing window, but with the Navigator view, you
can pick a lookat point that is outside of your Viewing window.

In the Navigator view, click the point that you want to center in the Viewing window.

The view box moves to the portion of the image or model you select, and the view in the Viewing
window changes.

Introduction to the Navigator view
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PMI view

Use the PMI  view to manipulate Product and Manufacturing Information (PMI) in the Lifecycle
Viewer.

Paths view

Use the Paths  view to work with motion documents in the Lifecycle Viewer.

3. Exploring the Interface
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Snapshots view

Use the Snapshots  view to activate and manipulate snapshots of your 2D image or 3D model in the
Lifecycle Viewer.

Snapshots view
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Image Preview view

Use the Image Preview  view to display 2D raster images associated with items, item revisions, and
datasets in My Teamcenter.

JT Preview view

Use the JT Preview  view to display .jt parts associated with items, item revisions, and datasets in My
Teamcenter.
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Viewing window

Send open 2D or 3D documents to new Viewing windows

You can create a new instance of the active visualization document view. When you have a single
document open in multiple views, while the session is active you can manipulate the model
independently in each Viewing window.

Example:

A single 3D model is displayed in two separate 3D views. Each view shows different parts from the
model, a different viewing angle, and unique 3D elements, such as a markup, a measurement, and
a cross section.

Send open 2D or 3D documents to new Viewing windows
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1. Click the 2D or 3D view that you want to send to a new window to make it active.

2. Choose Window→New Window.

A copy of the view is created.

Clone the 3D Viewing window

You can create an exact copy of the active visualization document view, including 3D elements such as
the current visibility state and markups.

1. Click the 3D view that you want to clone to make it active.

2. Choose Window→Clone Window.

A copy of the active 3D view is created.

Working with toolbars

Display or hide toolbars

• Choose Toolbars, and then select or clear the check box to the left of the toolbar name.

3. Exploring the Interface

3-14  Visualization on Rich Client ─ Getting Started, Teamcenter 2412
© 2025 Siemens



Note:

If the functions associated with a toolbar are not enabled, the toolbar buttons are grayed out.

Tip:

To change the display of all toolbars at once, choose Windows→Toolbars.

Move toolbars

1. Place the cursor on the handle of a visualization toolbar. The handle is the vertical line on the left of
the toolbar, as shown below:

2. Drag the toolbar to a new position within the toolbar area.

List of toolbars

2D Adjust toolbar

Use the command buttons on the 2D Adjust toolbar to adjust 2D markup layers and to align vector and
raster points associated with similar 2D files. The result of these 2D markup layer adjustments appear in
the Viewing window.

Use this option To do this

Enable Adjust Activate and deactivate the 2D markup layer feature.

Translate Pan or move the selected markup layer.

Scale Zoom in and out of the selected markup layer.

Rotate Rotate the selected markup layer.

Align Vector One Point Align a point on one markup layer with a point on another
layer.

Align Vector Two Points Align two points on one markup layer with two points on
another layer.

Move toolbars
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Use this option To do this

Align Raster One Point Align a point on one markup layer with a point on another
layer.

Align Raster Two Points Align two points on one markup layer with two points on
another layer.

Reset If you do this This happens

Insert or create the selected
2D image layer in the
current work session

All adjustments to the
markup layer are cleared
and the markup returns to
its original position.

Open the selected 2D image
layer by opening a session
(VF) file or a PVL file.

All adjustments made to
the opened sessions file
are cleared and the markup
returns to the saved sessions
file position.

Note:

Click Reset again to clear all the adjustments made
to the selected layer, including adjustments from the
saved session.

The markup layer returns to its original position.

Clicking Reset a third time returns the selected layer
back to the saved session position. In other words,
clicking Reset switches the markup layer between a
"clear" and an "as-loaded" state.

2D Compare toolbar

Use the option buttons on the 2D Compare toolbar to compare 2D image layers in the Viewing window.

Use this option To do this

Compare Layers Create a comparison layer.

Display 1st Layer Display only the first layer in a comparison.

3. Exploring the Interface
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Use this option To do this

Display 2nd Layer Display only the second layer in a comparison.

Display Compare Layer Display only the comparison layer.

The comparison layer shows either the common elements
from both comparison layers or the elements that are unique
to the first or second layers. This definition is set either in
preferences or by the Toggle Layer Definition command.

Display All Display both the first and second layers, and also the
comparison layer.

Clear Compare Clear the comparison layer.

Toggle Layer Definition Switch between either showing the common elements from
both comparison layers or the elements that are unique to
each of the layers.

Tip:

This sets the Show overlap or Show differences
option in the Compare Preferences dialog box.

Compare Preferences Specify compare preferences.

2D GD&T markup toolbar

You can use the GD&T Markup toolbar to insert 2D GD&T markups on 2D markup layers in the Viewing
window.

Use this option To do this

Enable GD&T Markup Activate and deactivate the 2D GD&T markup feature.

GD&T Annotation Editor Open the GD&T Annotation Editor dialog box.

Stack Mode Enable or disable Stack Mode.

Copy GD&T Annotation Copy a GD&T annotation.

Paste GD&T Annotation Paste a GD&T annotation.

2D GD&T markup toolbar
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Use this option To do this

New Layer Add a new GD&T markup layer.

GD&T Markup Preferences Specify GD&T annotation preferences.

2D Markup toolbar

You can use the markup option buttons on the 2D Markup toolbar to quickly mark up your 2D image.

You can also use the 2D Markup toolbar to access markup preferences.

Use this option To do this

Enable 2D Markup Display the Markup menu and begin to markup the 2D
image.

Select Select an existing markup displayed on the 2D markup layer
in the Viewing window.

Freehand Marker Draw a marker at a selected point on the selected 2D markup
layer.

Intersection Marker Draw a point at which two lines intersect on the selected 2D
markup layer.

Midpoint Marker Draw a midpoint of two points on the selected 2D markup
layer.

Centerpoint Marker Draw a centerpoint of a circle or arc on the selected 2D
markup layer.

Freehand Line Draw a freehand line on the selected 2D markup layer.

Leader Line Draw a leader line on the selected 2D markup layer.

Line Draw a straight line on the selected 2D markup layer.

Polyline Draw a polyline on the selected 2D markup layer.

Ellipse Draw an ellipse on the selected 2D markup layer.

Polygon Draw a polygon on the selected layer.
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Use this option To do this

Rectangle Draw a rectangle on the selected 2D markup layer.

Restricted Text Specify a bounding box you want your text to fit into.

Unrestricted Text Write text on the selected 2D markup layer.

Inset Image Inset a 2D image from a file onto the selected 2D markup
layer.

Rubber Stamp Write prepared text from a rubber stamp .TXT file on the
selected layer.

New Layers Add a new 2D markup layer.

Markup Preferences Specify the preferences of various 2D markups.

2D Measurement toolbar

You can use the measurement options on the 2D Measurement toolbar to make angle, radial, and
linear measurements on the base file or on 2D markup layers.

Use this option To do this

Enable Measurement Enable 2D measurements.

Calibrate Vector Calibrate the system for vector measurements.

Calibrate Raster Calibrate the system for raster measurements.

Vector Linear Measure a line by selecting points on the image.

Vector Radial Measure the radius of an arc or circle by selecting points on
the image.

Vector 3 Pt Angular Measure an angle by selecting three points on the image
(one endpoint, vertex, and then a second endpoint).

Vector 4 Pt Angular Measure the angle between two non-intersecting lines on
the image (both endpoints of one line, then both endpoints
of a second line).

2D Measurement toolbar
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Use this option To do this

Raster Linear Measure a line by selecting pixels.

Raster Radial Measure the radius of an arc or circle.

Raster 3 Pt Angular Measure an angle by selecting three points on the image.

Raster 4 Pt Angular Measure the angle between two non-intersecting lines.

New Layer Create a new markup layer.

Persist Measurements Maintain measurement results as markups.

Measurement Preferences Set 2D measurement preferences.

2D Multipage toolbar

Use the 2D Multipage toolbar to navigate among pages in multiple-page 2D images or documents.

Use this option To do this

First Page Go to the first page in a multiple-page image.

Previous Page Go to the previous page in a multiple-page image.

Next Page Go to the next page in a multiple-page image.

Last Page Go to the last page in a multiple-page image.

Go To Page Go to a specific page in a multiple-page image.

2D Viewing toolbar

Use the 2D Viewing toolbar to quickly manage or change how you view your image in the Viewing
window.
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Use this option To do this

Fit All Fit the entire image into the Viewing window.

Base View Size the view to the extent of the first layer in a series of
layers.

Note:

If you only have one layer in your Viewing window,
this option works the same as Fit All.

Browse • Select hyperlinks.

• Display screen tips.

• Display contents of PDF sticky notes.

Zoom Area Zoom to a specific area of the image.

Seek Center a point of the image.

Pan Move the image in the plane of the Viewing window.

Zoom Move closer to or farther from the image.

Zoom In Move closer to your image in the Viewing window.

Zoom Out Move farther from your image in the Viewing window.

Rotate Counterclockwise Rotate your image 90 degrees counterclockwise.

Rotate Clockwise Rotate your image 90 degrees clockwise

Flip Horizontal Flip your image 180 degrees horizontally.

Flip Vertical Flip your image to a vertical position.

Copy Image Copy the image in the Viewing window to the clipboard.

2D Viewing toolbar
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Use this option To do this

Copy Region Copy a section of the image to the clipboard.

Search When a PDF is opened in the viewer, search for text strings in
the document.

3D Alignment toolbar

Use the 3D Alignment toolbar to move individual parts or groups of parts and align them to other parts
in the Viewing window.

Use this option To do this

3D Alignment Activate and deactivate the alignment feature.

Preview Alignment Align the parts as specified by the constraints.

Accept Alignment Accept the current alignment and move the
part.

Next Alignment Display an alternate alignment that conforms
to the constraints.

Cancel Alignment Clear all alignment and return the part to its
original position.

Primary Constraints Set or change the primary alignment
constraints on parts.

Secondary
Constraints

Set or change the secondary alignment
constraints on parts.

Tertiary Constraints Set or change the tertiary alignment
constraints on parts.

3D Appearance toolbar

Use the 3D Appearance toolbar to work with part appearance.
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Use this option To do this

Quick Color Tool Display the Quick Color dialog box.

Edit Materials Display the Material page of the Appearance Editor.

Load Images Display the Image page of the Appearance Editor.

Edit Texture Coordinates Display the Texture page of the Appearance Editor.

Edit Lights Display the Light page of the Appearance Editor.

Material Palette Display the Material page of the Appearance Palette.

Image Palette Display the Image page of the Appearance Palette.

Texture Coordinate Palette Display the Texture Coordinate page of the Appearance
Palette.

Light Palette Display the Light page of the Appearance Palette.

Color Range Tool Display the Color Range Tool.

Appearance Preferences Display the Preferences dialog box.

3D CAE Viewing toolbar

Use the Render (3D) tab→CAE Viewing group to set display options for your 3D model as well as
annotation appearance preferences.

Use the 3D CAE Viewing toolbar to set display options for your 3D model as well as annotation
appearance preferences.

Use this option To do this

Enable CAE Results Viewing Activate and deactivate the 3D CAE viewing feature.

3D CAE Viewing toolbar
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Use this option To do this

Note:

If no CAE data exists in your model, a warning
message is displayed when you attempt to enable the
CAE functionality.

Display Options Set color bar, lighting, and results display options.

Identify Probe the 3D model for CAE results values at specific node or
element locations.

Annotations Annotate CAE results.

CAE Preferences Set appearance preferences for annotations.

3D Clearance toolbar

Use the Clearance toolbar to check the clearance of parts in your model.

Use this option To do this

Enable Clearance Analysis Start checking clearance.

Set Clearance Set a Clearance requirement.

Matrix Clearance Create a list of all elements that come within the Clearance
requirement of other elements.

Selected Clearance Identify elements that come within the Clearance
requirement of the selected elements.

All Elements Check the clearance of all elements in the file and whether
or not the elements are loaded.

Loaded Elements Check the clearance of elements that are loaded and
whether or not the elements are visible.

Visible Elements Check the clearance of visible elements.

Dynamic Clearance Identify elements that move to within the Clearance
requirement when the model is in motion.
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Use this option To do this

Previous Result Go to the previous result in the General Clearance Results
window or Clearance Navigation & Analysis dialog box.

Next Result Go to the next result in the General Clearance Results
window or Clearance Navigation & Analysis dialog box.

Previous Region Go to the previous region in the Clearance Navigation &
Analysis dialog box.

Next Region Go to the next region in the Clearance Navigation &
Analysis dialog box.

Analyze Clearance Navigate between Clearance results and their related contact
and penetration regions of violations using the Clearance
Navigation & Analysis dialog box.

Clear Analysis Clear all results in the General Clearance Results window.

Results Window Show or hide the General Clearance Results window.

Load Results Load a Clearance results file or a Clearance Database
Connection (.dbc) file.

Quick-load results Automatically load the last Clearance results file or Clearance
Database Connection (.dbc) file that was opened or saved.

Results Preferences Set preferences for Clearance results.

3D Comparison toolbar

Use the 3D Comparison toolbar to compare the geometry of two sets of parts or two or more models in
multiple Viewing windows.

Use this option To do this

Enable Comparison Activate and deactivate the comparison feature.

Set Part Group 1 Specify the first set of parts to compare.

Show Part Group 1 Display the parts of group 1.

Set Part Group 2 Specify the second group of parts to compare.

3D Comparison toolbar
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Use this option To do this

Show Part Group 2 Display the parts of group 2.

Multiple window
comparison

Start a side by side comparison of the contents of multiple
3D Viewing windows.

Synchronized Viewing Synchronize the navigation cameras for the Viewing
windows involved in the comparison.

Reposition Windows Re-tile the Viewing windows.

Tricolor Mapping Display the parts of group 1 in one color, the parts of group
2 in a second color, and the parts that are the same in a third
color.

Distance Mapping Display the parts in a range of colors that identify the
distance between the two parts.

Compare Preferences Change the colors of compared parts.

3D Constraints toolbar

Use the 3D Constraints toolbar to add constraints and manage constraint files.

Use this option To do this

Enable Constraints Activate and deactivate the constraints feature.

Open Constraint File Open an existing constraint file.

New Constraint File Open a new constraint file.

Create Constraint Add a constraint.

Save Constraint File Save the active constraint file.

Save As Constraint File Save the active constraint file and optionally specify a new
name and path.

Constraint Preferences Set constraint behavior and appearance preferences
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3D Coordinate System toolbar

Use the 3D Coordinate System toolbar to work with User Defined and PMI coordinate systems.

Use this option To do this

Create Coordinate System Create a new coordinate system.

Delete Selected Coordinate
System

Delete the selected coordinate system.

Manage Coordinate
Systems

Manage coordinate systems.

Manipulate Selected
Coordinate System

Use a manipulator to reposition the selected coordinate
system.

Edit Selected Coordinate
System

Edit the properties of a coordinate system.

Align View To Selected
Coordinate System

Align your view to the XY plane of a coordinate system.

Align Part To Selected
Coordinate System

Align a part or assembly to a coordinate system.

Coordinate System
Preferences

Change coordinate system preferences.

3D GD&T Markup toolbar

You can use the 3D GD&T Markup toolbar to quickly insert GD&T Markups on your 3D models.

Use this option To do this

Enable GD&T Markup Activate and deactivate the GD&T markup feature.

GD&T Annotation Editor Open the GD&T Annotation Editor.

Anchor Mode Select and clear Anchor Mode.

3D Coordinate System toolbar
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Use this option To do this

Stack Mode Select and clear Stack Mode.

Copy GD&T Annotation Copy a GD&T annotation.

Paste GD&T Annotation Paste a GD&T annotation.

New Layer Add a new GD&T markup layer.

GD&T Markup Preferences Specify GD&T annotation properties.

3D Groups toolbar

Use the 3D Groups toolbar to create and manage groups of parts.

Use this option To do this

Add Group (Visible) Create a group that includes all the visible parts.

Add Group (Selected) Create a group that includes all the selected parts.

Single Group Only Display only the groups that are checked.

Delete Group Remove the selected groups.

Replace Group (Visible) Replace the parts in the selected group with the parts that
are visible in the Viewing window.

Replace Group (Selected) Replace the parts in the selected group with the parts that
are selected in the Viewing window.

3D Markup toolbar

Use the 3D Markup toolbar to add text or graphical elements on your 3D model in the Viewing window.
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Use this option To do this

3D Markup Enable the 3D markup feature.

New Layers Create a new 3D markup layer.

Select Select an existing markup.

Freehand Draw a freehand line.

Line Draw a straight line.

Polyline Draw a polyline.

Ellipse Draw an ellipse or circle.

Polygon Draw a polygon.

Rectangle Draw a rectangle or square.

Inset Image Add an image.

Text Draw text.

In-Plane Mode Allows for precise tracking with the markup's original
position to the model, including model scaling.

Anchor Mode Attach the markups you draw to parts of the model.

Fill Mode Draw filled rectangle, polygon, ellipse, or text markups.

Auto Create Create anchored text which is added to either selected or
visible parts at once.

Predefined Text Add predefined text that needs to appear every time you add
a text markup.

Align Align multiple anchored text markups for readability

Distribute Distribute markups as needed to evenly space them.

Position Position anchored text markups precisely where you want
them.

Edit Properties Change specified properties of markups included in a filtered
set of all markups.

3D Markup toolbar
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Use this option To do this

Resequence Callouts Resequence the order callouts appear in the Viewing
window.

View Anchored with Part Associate the visibility of anchored markups with the
visibility of the parts they are attached to.

Remove All Remove all markups.

Manage Symbol Library Access the Symbol Manager dialog box.

Markup Preferences Change the colors, styles, and display of 3D markups.

3D Measurement toolbar

Use the 3D Measurement toolbar to measure your 3D model.

Use this option To do this

Enable 3D Measurement Activate and deactivate the 3D measurement feature.

Single Display information about a single part feature.

Double Measure between two part features.

Chain/Fan (Chain) Measure between a series of part features.

(Fan) Measure between a part feature and a series of other
part features.

Distance Measure the distance between two part features.

Angle Measure the angle between two edges or surfaces.

Radius Measure the radius of a circular edge or surface.
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Use this option To do this

Diameter Measure the diameter of a circular edge or surface.

Local Radius Measure the local radius of a point on edge or a point on
surface.

Minimum Distance Display the minimum distance when performing
measurements between part features.

Maximum Distance Display the maximum distance when performing
measurements between part features.

Part Summation
Measurement

Display the total area, volume, and mass of a selected set of
parts.

Bounding Box
Measurement

Display the bounding box for a selected set of parts, and
display the measurements of the bounding box.

Part Set Measurement Display the distance between two sets of parts.

Clear Clear all measurements.

Undo Pick Clear the last part feature you picked.

Reports Create measurement reports.

Note:

This button is only available if you have a product that
supports measurement reports.

Measurement Preferences Specify the 3D measurement preferences.

3D MMV toolbar

Use the 3D MMV toolbar to control which parts of the 3D model are fully loaded. When in MMV mode,
you can choose to load complete parts for the entire 3D model, visible parts only, or selected parts only.

3D MMV toolbar
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Use this option To do this

Exit MMV Fully load the entire 3D model.

Disable MMV Visible Fully load all visible parts.

Disable MMV Selected Fully load all selected parts.

3D Motion toolbar

Use the 3D Motion toolbar to manage motion documents.

Use this option To do this

Open Motion File Add a motion document to the current session.

New Motion File Create a new motion document.

Save Motion File Save the motion document.

Delete Remove the motion document from the current session.

New Path Create a new path and add it to the end of the current list of
paths in the motion document.

Insert Key Frame Insert a new key frame after the currently selected key frame
node.

Edit Key Frame Edit the currently selected key frame node.

Preview Quickly view the motion without modifying the play list.

Motion Playback Play motion documents and view the play list.

Reset All Parts Reset all parts to their original locations.

Motion Playback
Preferences

Specify default settings for motion documents.
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3D Movie Capture toolbar

Use the 3D Movie Capture toolbar to capture the contents of the Viewing window as you move the
camera around, show or hide parts, transform parts, play animation sequences, and play .vfm motion
files associated with your model.

Use this option To do this

Record Record a movie.

Stop Stop recording.

Movie Capture Preferences Set record and playback speeds and compression.

3D Navigation toolbar

Use the 3D Navigation toolbar to manipulate the 3D view.

Option name Use this button to

Examine Activate Examine mode.

Fly Activate Fly mode.

Explore Activate Explore mode.

Previous View Return to the last static view.

Next View Move to the next static view

Fit All Fit all visible parts of the model into the Viewing window.

Zoom Area Zoom to a specific area of the model.

Seek Center a point of the model. This point becomes the center of rotation.

3D Movie Capture toolbar
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Option name Use this button to

Rotate Rotate your model in the Viewing window.

Pan Pan the model in the plane of the Viewing window.

Navigate Move closer to or farther from the model.

Position Choose an Explore mode start position on a part surface.

Level Return your view to level in Fly and Explore modes.

Terrain
Following

In Fly or Explore mode, remain a specified distance above the "floor"
upon which you are flying or exploring.

Collision
Detection

In Fly or Explore modes, stop moving when you come into contact with
a part.

Go Home In Explore mode, return to the location and position you were at when
you last selected Set Home.

Set Home In Explore mode, make the current location and position your home
location.

Automatic
Motion

Continuously rotate the navigation camera around the model, creating
a spinning turntable effect.

Navigation
Preferences

Set 3D navigation preferences.

3D Standard Views toolbar

Use the 3D Standard Views toolbar to examine your model from different views.

Use this option To do this

Enable View Control Open the Rotate dialog box to view or rotate the model.

Standard Views Open the Standard Views dialog box to view or rotate the
model, or position the camera.

View Clipping Add a near and a far clipping plane to the Viewing window.
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Use this option To do this

Rotate Up Rotate the model up 90 degrees.

Rotate Down Rotate the model down 90 degrees.

Rotate Left Rotate the model 90 degrees to the left.

Rotate Right Rotate the model 90 degrees to the right.

Rotate Clockwise Rotate the model clockwise 90 degrees.

Rotate Counterclockwise Rotate the model counter-clockwise 90 degrees.

Align to Axis Align the plane to the positive or negative X, Y, or Z axis, or
Isometric view.

3D Part Edit toolbar

Use the 3D Part Edit toolbar to view and modify model LODs.

Use this option To do this

Enable Part Edit Activate and deactivate the part edit feature.

Control Control model LODs, and define a working set of parts for
use in geometry simplification.

B-Rep Reverse B-Rep face orientation.

Tessellation Tessellate parts.

Visibility Simplify parts based upon visibility.

Decimation Simplify parts based upon a specified triangle reduction.

Part Edit Preferences Specify Part Edit Preferences.

3D Part Manipulation toolbar

Use the 3D Part Manipulation toolbar to manipulate parts interactively.

3D Part Edit toolbar
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Use this option To do this

Enable Part Manipulation Activate and deactivate part manipulation mode.

Use Screen Coordinates Manipulate selected parts using the screen coordinate
system.

Use Global Coordinates Manipulate selected parts using the global coordinate
system.

Use Part Coordinates Manipulate selected parts using the part coordinate system.

X-Axis Translate selected parts along the X axis.

Y-Axis Translate selected parts along the Y axis.

Z-Axis Translate selected parts along the Z axis.

XY-Plane Translate selected parts along the XY plane.

XZ-Plane Translate selected parts along the XZ plane.

YZ-Plane Translate selected parts along the YZ plane.

Reset to Original Position Return selected parts to the original position.

3D Part Transformation toolbar

Use the 3D Part Transformation toolbar to translate, rotate, and scale parts in your model.

Use this option To do this

Add Part Display an interactive manipulator for the selected part.

Remove Remove the active manipulator.

Reset Manipulator Position Return the active manipulator to its original position.
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Use this option To do this

Transform Translate, rotate, and scale parts by using the using the Part
Transformation dialog box.

Relocate Move and rotate parts from one location to another.

3D Path Editor

This group is available from the Actions→Path Editor menu.

Use this option To do this

New Path Generate a new extraction path using key positions.

Edit Path Modify an extraction path.

Add Position Add a key position to an extraction path.

Replace Position Replace a key position with the current manipulator position.

Remove Position Remove a key position from an extraction path.

Path Editor Toolbar Activate or deactivate the floating Path Editor Toolbar.

Advanced Editor Add or modify key positions and review key position
statuses.

Motion Path Preview Preview the motion file associated with an extraction path.

Path Planning Generate an extraction path using automated algorithms.

User Aided Fitting Interactively generate extraction paths.

Unstick Resolve collisions in an extraction path at key positions.

Path Editor Preferences Customize the path planning default settings.

Collision Settings Define the acceptable collision clearance requirement
between parts, or for more specific clearance paths, define
collision sets.

Constraints Constrain target part translation and rotation.

3D Path Editor
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3D Performance toolbar

Use the 3D Performance toolbar to change the performance preferences for your 3D model.

Use this option To do this

Performance Setting 1 - 5 Save 1-5 performance settings that can be accessed by
selecting the specified options.

Stop Streaming Stop the loading of your 3D model.

Note:

This button is only active during loading.

Edit Performance Settings Set the performance for Culling, Rendering, Memory, and
change Toolbar options.

3D PMI toolbar

Use the PMI toolbar to display and control product and manufacturing information in your model.

Use this option To do this

Enable PMI Activate and deactivate the PMI feature.

Feature-based Multiple
Entity Mode

(For JT models containing feature level designs) PMI for all
faces and edges associated with the feature level.

Note:

If you use this option and the JT model does not
contain a feature level, PMI is displayed from the
selected face and all its edges.

Multiple Entity Mode Display all the PMI for a model.

Single Entity Mode Display each PMI one at a time.
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Use this option To do this

Previous Entity (For Single Entity Mode) Display the previous PMI.

Next Entity (For Single Entity Mode) Display the next PMI.

Filter Configuration Filter out specific types of PMI.

Text Orientation Change the orientation of PMI text.

Fit View to Selected Display all PMI in the PMI list, without changing the direction
or orientation of the camera.

Palette Display the Model View Palette.

Clear Entities Turn off the display of all PMI.

PMI Preferences Set PMI appearance and behavior preferences.

3D Section toolbar

Use the 3D Section toolbar to work with cross sections of your 3D model.

Use this option To do this

Enable 3D Section Enable the 3D Section functionality.

Create Section Create a cross section, normal to the Z-axis, in the current 3D
view.

Create Grid Create a grid, normal to the Z-axis, in the current 3D view.

Create Series Create multiple cross section views along an axis, along a
linear edge, or between two points.

Create Section Along Curve Create a cross section positioned along a curve.

Delete Section Delete the active cross section in the current 3D view.

Delete All Delete all cross sections.

3D Section toolbar
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Use this option To do this

Clip Near Clip away the near side of the model.

Clip Far Clip away the far side of the model.

Clip Both Clip away the model on both sides of the plane, leaving only
the section lines.

Plane View Align the view normal to the section plane.

Align To Feature Align the cross section plane to a feature of the model.

Position Plane Show or hide the Position Plane dialog box to position
section planes

3D Manipulator Show and hide a 3D manipulator to dynamically move and
rotate the section plane.

Show in Viewer Display the active section or section series in the Cross
Section Viewer.

Create Report Create cross section reports that can include analysis of
the section area or perimeter, moment of inertia, center of
gravity, and other calculated cross section properties.

Note:

Only Perimeter and Area are available if the model
does not contain B-Rep data.

Manual Update Update cross section rendering when the Fast Mode section
preference is active.

Update Parts Updates the cross section to include the selected parts.

Section Preferences Change the settings for general cross section features, the
grid, and clipping display.

3D Selection toolbar

Use the 3D Selection toolbar to pick part features.
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Use this option To do this

Point Pick a point on the part.

Vertex Pick a vertex on the part.

Arc Center Pick the center of an arc

Midpoint Pick the midpoint of a line or arc

Point on Edge Pick a point on an edge

Edge Pick an edge on the part.

Surface Pick a surface on the part.

Part Pick the entire part.

Disable Active Tool Disable the active tool, for example, 3D Measurement.

User Defined Point Type the coordinates of a point.

Construct Midpoint Pick a point midway between two points.

Intersection Pick the intersection of two edges.

3Point Circular Arc Pick the center of a circular arc you define by picking three
points.

Select Parts by Area Select parts within an area that you define.

Select Parts by Volume Select parts within a volume that you define.

Pick Through Unshaded
Parts

Pick geometry visible through parts displayed in the
tessellated or feature lines display modes.

Generate Selection Preview
Data

If it does not already exist, generate the data required for
part feature selection preview.

3D Selection Preferences Change the settings for selection and selection preview.

3D Display Modes toolbar

Use the 3D Display Modes toolbar to control the display mode of geometry in the 3D Viewing window.
You can display geometry as shaded, tessellated lines, feature lines, or any combination of the above.

3D Display Modes toolbar
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Tessellation or feature lines hidden by other geometry can be viewed as normal, semi-transparent, or
invisible.

Note:

Hidden lines invisible, Hidden lines ghosted and Hidden lines visible are only enabled if the
default display mode is set to Tessellation Lines, Feature Lines, or both. The default display
mode can be set on the Display page of the 3D Viewing preferences dialog box, or on the 3D
Display Modes toolbar when no parts are selected. If any parts are selected, changing the display
mode with the toolbar only changes the display mode for the selected parts.

Use this option To do this

Draw shaded model Display geometry in the shaded rendering style.

Display Construction
Geometry

Display wireframe construction geometry.

Display Construction
Geometry On Top

Display wireframe construction geometry on top of the
shaded geometry.

Draw tessellation lines Display geometry in the tessellation line rendering style.

Draw feature lines Display geometry in the feature line rendering style.

Hidden lines invisible Remove hidden tessellation or feature lines from view.

Hidden lines ghosted Display hidden tessellation or feature lines in a semi-
transparent rendering style.

Hidden lines visible Display hidden tessellation or feature lines in a fully visible
rendering style.

Clear All Reset the display modes for all parts, including model View
Style set by PMI.

See-Thru Solids Display all solid geometry as transparent.

3D Surface Analysis toolbar

Use the 3D Surface Analysis toolbar to evaluate part surfaces.
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Use this option To do this

Multi-Effect Display a combination of surface analysis effects.

Reflection Apply reflections to your part surfaces.

Flow Lines Apply flow lines to part surfaces.

Curvature Shade parts based upon the curvature values of their
surfaces.

Random Colors Apply random colors to part surfaces.

Hide Effects Hide surface analysis effects in the Viewing window.

Set Working Set Create a new working set of parts based upon part selection
or visibility in the Viewing window.

Workspace Manage surface analysis settings and effects.

Surface Analysis
Preferences

Adjust the surface analysis preferences.

3D Thrustline Editor toolbar

Use the 3D Thrustline Editor toolbar to create and manipulate thrustlines.

Use this option To do this

Enable Thrustline Activate and deactivate the thrustline feature.

Align to Part Feature Create a part feature aligned thrustline.

Delete Thrustline Delete the currently selected thrustline.

New Layer Create a new layer in the 3D scene.

Thrustline Preferences Edit thrustline preferences.

3D Thrustline Editor toolbar
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3D True Shading toolbar

Use the 3D True Shading toolbar to quickly change the appearance of 3D models via predefined visual
effects.

Use this option To do this

True Shading Activate and deactivate the true shading effects feature.

Global Materials Choose a predefined material that affects the appearance of
the entire model.

Global Reflections Choose a predefined reflection that affects the appearance of
the entire model.

Note:

Parts assigned True Shading materials such as rubber
are not included in global reflections.

Occurrence Specific
Materials

Choose a predefined material that affects the appearance of
selected parts or assemblies.

Backgrounds Choose a background color, gradient, or image.

Apply True Shading
Materials

Turn True Shading materials and global reflections on or off
in the Viewing window.

Show Floor Display a floor in the 3D scene.

Floor Grid Display a grid upon the floor in the 3D scene.

Show Floor Reflection Display a reflection of the 3D model upon the floor in the 3D
scene.

Floor Shadows Display a shadow of the 3D model upon the floor in the 3D
scene.

True Shading Editor Adjust True Shading settings in the True Shading Editor.

3D Visibility toolbar

Use the 3D Visibility toolbar to hide obscuring parts and clip areas of your model.
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Use this option To do this

Hide Obscuring Hide parts that obscure your view of specified parts by
making the obscuring parts transparent.

Add Clipping Manipulator Create manipulators to control the area of your model that
you want to hide.

Remove Clipping
Manipulator

Remove manipulators from your model.

Hide Manipulators Hide the manipulators and motion jacks.

Hide Jacks Hide the motion jacks, but not the manipulators.

Clip Inside Hide the area inside the manipulator.

Clip Outside Hide the area outside the manipulator.

View Properties Access the View Clipping Properties settings.

3D Visual Report toolbar

Use the 3D Visual Report toolbar options to create visual reports and apply them to the parts and
assemblies. For example, you can search the properties of parts and create a visual report that shows
all metal parts in a specific color. You can also reset the appearance of parts and assemblies, as well as
specify visual report preferences.

Use this option To do this

Enable Visual Report Activate and deactivate the Visual Report feature.

Apply Report Open the Apply Report dialog box.

Use the Apply Report dialog box to edit and load existing
visual reports.

Quick Report Open the Quick Report dialog box.

Use the Quick Report dialog box to quickly identify the parts
that match your metadata search query.

3D Visual Report toolbar
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Use this option To do this

Single Report Open the Single Rule Report dialog box.

Use the Single Rule Report dialog box to generate metadata
search conditions and to specify how you want matched and
unmatched parts displayed.

Multiple Reports Open the Multiple Rules Report dialog box.

Use the Multiple Rules Report dialog box to generate
multiple metadata search conditions.

Report Legend Display detailed information about completed visual reports.
This information includes details as the current rule name
and scope, names of parts, and the attributes and values
used in the report.

Explore Reports Open the Report Explore dialog box.

Use the Report Explore dialog box to set options for how
you view the results of your visual report.

Reset Reports Discard visual changes and return to the original visual
representation.

Find Open the Find dialog box.

Use the Find dialog box to find parts and assemblies with
property values that match a search pattern.

Visual Report Preferences Specify the default options for various visual reports
preferences.

ECAD Base toolbar

Use the ECAD Base toolbar to manage specific ECAD functionality such as specifying side views,
changing layer characteristics, navigating nets, creating reports, and setting cross probing for both the
PCB and schematic.

Use this option To do this

View Top and Bottom Side Specify the order in which you view document layers.

View Opposite Side View the top or bottom side depending on the side that is
currently showing.

Layer Color Change layer colors and layer visibility states. Use the Layer
Color dialog box to manage these options.

3. Exploring the Interface

3-46  Visualization on Rich Client ─ Getting Started, Teamcenter 2412
© 2025 Siemens



Use this option To do this

Search Search for objects by using the options associated with the
Search dialog box.

Create Report Open the Reports dialog box to create and run various ECAD
reports.

Cross Probe Explore both the PCB and schematic in one Viewing window.

Previous Move the net marker to the previous point in navigating the
net.

Next Move the net marker to the next point in navigating the net.

Visual Compare Compare the differences between two ECAD documents.

PCB Properties Display document property data by using the Properties
dialog box.

ECAD DFx toolbar

Use the DFx toolbar to manage how you want to evaluate and analyze your designs against
manufacturing rules.

Use this option To do this

Open Rules File Open the Open Rules dialog box and select a configuration
file containing the rules for evaluating the open PCB.

Edit Rules File Open the DFx Rule Set Editor dialog box to review and
modify Design for Assembly and Design for Test rules.

Open Results File Open a previously generated results file for the current PCB.

Save DFx Files Save the active rules file and results using the current dataset
name.

Save DFx Files As Save the active rules file and results. You will be prompted
for a new dataset name.

Run DFx Rules Start the design evaluation on the active PCB.

ECAD DFx toolbar
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Use this option To do this

Display DFx Summary
Report

Open the most recently saved summary results report for the
active PCB.

Display DFx Detail Report Open the most recently saved detail results report for the
active PCB.

Note:

Most of these options require a DFx authoring license.

ECAD Markup toolbar

Use the ECAD Markup toolbar options to manage how you want to mark up ECAD documents. In most
cases, markup support applies to both the PCB and schematic documents.

Use this option To do this

Enable Markup Activate and deactivate the ECAD markup feature.

Create New Markup Open the Markup Topic dialog box. After selecting this
option, click in the Viewing window and enter a markup
topic.

Select Markup Select a markup that is displayed in the Viewing window.

Freehand Line Draw a freehand line.

Leader Line Draw a straight line and optionally add leader ends to the
line.

Ellipse Draw an ellipse or circle on the ECAD document.

Polygon Draw a polygon on the ECAD document.

Rectangle Draw a rectangle or a square on the ECAD document.

Text Open the Text Editor dialog box and add text markups.

Rubber Stamp Open the Rubber Stamp dialog box. Select either
auto-translate selected predefined text or select existing
predefined text from a note file.
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Use this option To do this

Distance Measurement (PCB only) Measure the distance between one point to
another point, between one point to a specific location on
a line, or between one line and another line.

Radial Measurement (PCB only) Measure the radial distance on any ring or circle.

Clearance Measurement (PCB only) Measure the minimum distance between two
objects.

Manhattan Length (PCB only) Measure the distance between any point along
the trace and via contained within the same net.

Note:

Manhattan length refers to the sum of the X- and Y-
distances between the two selected points.

Routed Length (PCB only) Measure the distance between any point along
the trace and via contained within the same net.

Note:

Routed length refers to sum of each segment along
the trace between the two selected points.

Markup Log Open the Markup Log dialog box to display markup activity
related to the ECAD document.

Save Markups Save the markup in the established dataset.

Save Markups As Save the markup in a different dataset.

Markup Profile Preferences Display the Markup Profiles dialog box which contains
markup profile names and markup preferences.

ECAD Multipage toolbar

Use the ECAD Multipage toolbar to navigate among pages in a multipage ECAD document.

ECAD Multipage toolbar
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Use this option To do this

First Page Go to the first page in a multipage file.

Previous Page Go to the previous page in a multipage file.

Go To Page Go to a specific page in a multipage file.

Last Page Go to the last page in a multipage file.

Next Page Go to the next page in a multipage file.

ECAD Viewing toolbar

Use the ECAD Viewing toolbar to quickly manage or change how you view ECAD documents.

Use this option To do this

Fit All Fit the entire design into the Viewing window.

Base View Size the view to the extents of the PCB dimensions.

Browse Display the name of ECAD objects as you move the cursor
around the Viewing window.

Zoom Area Zoom to a specific area of the document.

Seek Center a point on the document.

Pan Move the document around the Viewing window.

Zoom Move closer to or farther from the document.

Zoom In Move the document closer to your view.

Zoom Out Move the document farther from your view.

Rotate Counterclockwise Rotate the document 90 degrees counterclockwise.

Rotate Clockwise Rotate the document 90 degrees clockwise.
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Use this option To do this

Flip Horizontal Flip the document 180 degrees horizontally.

Flip Vertical Flip the document to a vertical position.

Copy image Copy the image in the Viewing window to the clipboard.

Copy region Copy a section of the image to the clipboard.

Image Capture toolbar

You can use the Image Capture toolbar to capture the view of your image exactly as it is displayed in the
Viewing window, including all visible markups. The captured image appears in a new Viewing window.

Issues toolbar

Use the Issues toolbar to communicate design issues.

Use this option To do this

Add Create new visual issues.

Update Update the visual issue currently active in the Viewer.

Delete Delete the visual issue currently active in the Viewer.

Note:

If working with Teamcenter visual issues, the issue
report and issue report revision are deleted.

View Display the visual issues list in Issue Manager.

Printing toolbar

You can use the Printing toolbar to quick preview and print models and images.

Image Capture toolbar
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Use this option To do this

Print Current View Print your model or image.

Print Preview Preview the image before printing.

Reconcile toolbar

Use the Reconcile toolbar to resolve broken file references to parts and assemblies.

Use this option To do this

Enable Reconcile Activate and deactivate the file reconcile feature.

Validate All References Validate references in a file.

Reconcile Broken
References

Create or delete file mappings.

Reload Session Reload the file.

Import Load a mapping file.

Export Save a mapping file.

Reconcile Preferences Specify preferences.

Snapshots toolbar

Use the Snapshots toolbar to add and manipulate snapshots of your model or image.

2D and ECAD 3D
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Use this option To do this

Add Add a snapshot of the Viewing window.

Insert Insert a snapshot between two existing snapshots.

Delete Delete the selected snapshot.

Replace Replace the selected snapshot with a snapshot of the
Viewing window.

Toggle View (3D only) Display 3D snapshots as thumbnails or a list.

Snapshots Preferences (3D
only)

Specify 3D snapshot preferences.

Tree Control toolbar

Use the Tree Control toolbar to navigate the list in the Assembly view.

Use this option To do this

Collapse All Display only the first level of the list.

Collapse One Hide the lowest level of the list that is currently showing.

Expand One Display one more level of the list than is currently showing.

Expand All Display all levels of the list.

Find Item Search for a text string in the list.

Working with menus

Overview of menus

The menu bar provides access to much of the application's functionality. You can also right-click items
and areas to access shortcut menus.

Tree Control toolbar
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Note:

Menus are available only in the Lifecycle Viewer. You must use toolbars to access visualization
features when working in the viewers that are embedded within Teamcenter applications such as
My Teamcenter and Structure Manager.

List of menus

Actions menu

The Actions menu is on the Menu bar. Some options are available only when a 2D or 3D file is open.

Use this option To do this

Image Capture (2D and
3D)

Save the view of your 2D image in the Viewing window.

In Standard, Professional, and Mockup, save the view of your 3D model in
the Viewing window as a 2D image.

Compare (2D) Identify similarities and differences in 2D image layers.

• Use Compare Layers to specify which 2D images to compare.

• Use 1st Layer to display only the first image.

• Use 2nd Layer to display only the second image.
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Use this option To do this

• Use Compare Layer to display the first and second images simultaneously
and identify the differences between the images.

• Use Clear Compare to clear the comparison layer.

• Use Toggle Layer Definition to switch between either showing the
common elements from both comparison layers or the elements that are
unique to each of the layers.

• Use All to display all layers.

• Use Preferences to choose colors for the images.

Movie Capture (3D) Record the movements of your model in the Viewing window as a movie.

Note:

Only available in Professional and Mockup.

Outline Capture (3D) Create an outline drawing of your model.

Note:

Only available in Professional and Mockup.

Issues (2D and 3D) Communicate across a corporate intranet.

Note:

Not available in Base.

Part Manipulation
Mode (3D)

Drag parts interactively around the Viewing window.

Note:

Only available in Professional and Mockup.

Part Transformation
(3D)

Translate, rotate, and scale parts in 3D models.

Note:

Only available in Professional and Mockup.

Motion (3D) In Base and Standard, reset all transformed parts to their original positions.

Actions menu
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In Professional and Mockup, animate your 3D model.

Path Editor (3D) Generate extraction paths for parts or assemblies that need to be removed
from models for maintenance or replacement.

Note:

Only available in Mockup.

Swept Volume (3D) Create a graphical representation of the volume and path of a part as it
moves.

Note:

Only available in Mockup.

Quick Color (3D) Change the color and transparency of parts and part groups.

Coordinate Systems
(3D)

Create and work with coordinate systems.

Note:

Only available in Professional and Mockup.

Exploded View (3D) Move parts and groups of parts specified distances along the x, y, or z axis.

Note:

Only available in Professional and Mockup.

Filters (3D) Constrain which parts are loaded or displayed in the Viewing window.

Note:

Only available in Mockup.

View Zones (3D) Display the 3D zones defined by a zone (.ZN) file.

Note:

Only available in Mockup.

Inspector (3D) Examine and validate the data structure and integrity of .jt files.

Layer Filter (3D) Filter part visibility based upon the layer settings within the file.
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Reference Sets (3D) Change the active reference set.

True Shading (3D) Quickly change the appearance of 3D models via predefined visual effects.

Note:

Only available in Professional and Mockup.

Part Report (3D) Generate part reports to examine attribute information such as angles,
chordal lengths, and part names.

Note:

Not available in Base.

Adjust menu (2D)

Open a 2D image and then add a new layer to the Base Document. The Adjust menu appears on the
Menu bar when you enable Adjust from the Tools menu.

Use this option To do this

Translate Pan (move) the selected markup layer in the Viewing window.

Scale Zoom in and out of the selected markup layer in the Viewing window.

Rotate Turn the selected markup layer in the Viewing window.

Vector Alignment One Point – Align one point or position on one 2D vector markup layer with
a point on another vector 2D markup layer.

Two Points – Align two points on a vector 2D markup layer with two points
on another vector 2D markup layer.

Raster Alignment One Point – Align one point on a raster markup image layer with one point
on another raster markup layer.

Two Points – Align two points on a raster markup layer with two points on
another raster markup layer.

Reset If you This happens

Insert or create the selected 2D
image layer in the current work
session, and then click Reset.

All adjustments to the markup layer are
cleared and the markup returns to its
original position.

Open the selected 2D image
layer by opening a session (VF)

All adjustments made to the opened
sessions file are cleared and the markup

Adjust menu (2D)
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file or PVL file, and then click
Reset.

returns to the saved sessions file
position.

Note:

Click Reset again to clear all the
adjustments made to the selected
layer, including adjustments from
the saved session.

The markup layer returns to its
original position.

Click Reset a third time returns
the selected layer back to the
saved session position. In other
words, clicking Reset switches the
markup layer between a "clear"
and an "as-loaded" state.

Alignment menu (3D)

Use the Alignment menu to align parts of 3D models to other parts. The Alignment menu appears on
the Menu bar when you choose Alignment from the Tools menu.

Use this option To do this

Primary Constraints Set or change the first part feature you pick for alignment.

Secondary Constraints Set or change the second part feature you pick for alignment.

Tertiary Constraints Set or change the third part feature you pick for alignment.

Preview Alignment Align the parts when the entities have been picked.

Next Alignment View the other alignments that are possible with the same constraints.

Accept Alignment Move the parts to the positions displayed in the current alignment.

Cancel Alignment Return the parts to their previous positions and clear all constraints.

Preferences Change the colors, sizes, and display of coordinate systems during
alignment.
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Assembly menu

Use the Assembly menu to work with the assembly in the Assembly view. The Assembly menu is on
the Menu bar when you choose Assembly from the Tools menu.

Use this option To do this

Expand All Display all subassemblies and parts (3D model) or all layers (2D image).

Collapse All Hide all subassemblies and parts (3D model) or all layers (2D image).

Pack All Pack all occurrences of the identical objects within each assembly in the
structure as single lines.

Unpack All Unpack all packed lines to view each occurrence of all objects in the
structure as individual lines.

Find Find a text string in the assembly.

Retry Failed Attempt to load parts that failed to load.

Failure Report Generate a summary report of parts that failed to load.

Failure Preferences Specify the type of information that is displayed in your reports, as well as
disabling the Reports Wizard by using the options.

Create Alt Hierarchy Use options to create an alternate hierarchy.

Reconcile Hierarchy Use Reconcile Hierarchy to compare your assembly to the same assembly
saved in a session file.

Show Leaf Structure Use Show Leaf Structure to show or hide leaf component structure in the
assembly tree.

Preferences Specify how you want to display model parts that you select in the Viewing
window.

Save Indented Save the assembly as a text file.

CAE Viewing menu

The CAE Viewing menu appears on the Menu bar when you choose CAE Viewing from the Tools menu.

Use this option To do this

Display Options Set color bar and lighting options.

Identify Probe the 3D model for CAE results values at specific node or element
locations.

Annotations Annotate CAE results.

Preferences Set appearance preferences for annotations.

Assembly menu
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Clearance menu

Use the Clearance menu to identify the Clearance of elements in 3D models. The Clearance menu
appears on the Menu bar when you choose Clearance from the Tools menu.

Use this option To do this

Set Clearance Set the Clearance requirement between elements.

Dynamic Clearance Identify Clearance violations while playing a motion file or transforming
parts in the 3D Viewing window. To locate violations quickly, you can
highlight parts that move within the Clearance requirement of a selected
part. You can also indicate whether a results list is generated.

Stop on Collision Stop playback of a motion file if the selected part or parts moves within the
Clearance requirement of another part.

Note:

This option is available only if Dynamic Clearance is selected.

Matrix Clearance Generate a list of all elements within the Clearance requirement of any
element.

Note:

This option is not available if Dynamic Clearance is selected.

Group to Group
Clearance

Set up and compare multiple groups of data while avoiding checks between
elements within the same group or group set.

Selected Clearance Check for elements within the Clearance requirement of the selected part.

Scope Specify which parts to check when you check Clearance.

• All Elements checks all elements in your model file.

• Loaded Elements checks all elements in your model file that are loaded.

• Visible Elements checks all elements that are currently visible in the
Viewing window.

Visibility Action Specify the method used to visibly identify elements within the Clearance
requirement.

• No Action does not visibly identify elements within the Clearance
requirement.

• Show Elements displays elements within the Clearance requirement.
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• Hide Elements hides elements within the Clearance requirement.
Visibility of other elements is not affected.

• Select Elements highlights elements within the Clearance requirement.

• Visual Report displays the Clearance issues in a visual report on the
Viewing window.

Results Work with the element pair list in the General Clearance Results window.

• Results Window displays the General Clearance Results window.

• Legacy Filter changes the rows of information that appear in the General
Clearance Results window in accordance with filters you created.

• Find finds text strings in the results that are visible in the General
Clearance Results window.

• Clear Results List clears the list that appears in the General Clearance
Results window.

• Remove Annotations removes from the Viewing window the label that
identifies the element pair that is selected in the General Clearance
Results window.

• Save All saves the list that appears in the General Clearance Results
window, as well as any items that have been filtered, as a .txt file.

• Save Visible saves the list that appears in the General Clearance Results
window as a .txt file.

• Load opens a Clearance results list that has been saved in a previous work
session or a Clearance Database Connection (.dbc) file.

• Quick-load automatically opens the last Clearance results file or Clearance
Database Connection (.dbc) file that was opened or saved.

• Compare List to File compares the information in the General Clearance
Results window to Clearance results that have been saved in a file.

• Email All Owners sends an email message to the owners of all issues
listed in the General Clearance Results window.

Clearance menu
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• Recalculate Zones uses the zone file specified in the Clearance Zone
Preferences dialog box to recalculate the zones in your model and
identify which Clearance issues occur in which zones.

• Post All Issues posts all the issues listed in the General Clearance
Results window to the visual issues list on your Community Collaboration
site.

• Remove All Issues removes all the issues listed in the General
Clearance Results window from the visual issues list on your Community
Collaboration site.

• Preferences specifies your preferences for the General Clearance
Results window.

• Report saves the results list in the General Clearance Results window as
a standard or custom report.

Navigation Navigate to the Previous Result or Next Result in the General Clearance
Results window, or to the Previous Region or Next Region of contact or
penetration in the Clearance Navigation & Analysis dialog box.

Note:

Generate a results list containing multiple results for all elements
within a Clearance requirement or elements within a Clearance
requirement of a selected part to navigate between results. The
Clearance Navigation & Analysis dialog box must be open and
contain multiple regions of contact or penetration to navigate
between regions.

Preferences Change settings that control appearance, precision, and behavior when you
check Clearance.

• Calculator Settings specifies the precision and nature of the Clearance
check.

• Display Precision changes the number of decimal places to which
Clearance requirements are calculated.

• Show Estimated Time toggles display of time estimate during the
Clearance check.

• Email specifies when and to whom email messages are automatically sent
when clearance is checked.
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• Owner specifies the attribute that identifies the owner of a part.

• Part Creation Date specifies the attribute that identifies the creation date
of a part, as well as the format of the date.

• Zones specifies the list of zones that have been defined by your company
for the model.

• Attributes defines the attributes included in the General Clearance
Results list.

• Requirement Components specifies whether to use a Universal
Clearance Requirement or other requirements and conditions present in
the Oracle database.

• Result Components specifies whether to visually display results within
the application or upload the results to the Oracle database.

• Product Configurator loads the available variant rules and criteria for the
current product from Product Configurator allowing the user to select a
variant rule to be used during Clearance analysis.

Comparison menu

You can use the Comparison menu to display differences between two part sets or Viewing windows.

The Comparison menu is on the Menu bar when a 3D model file is in the active Viewing window and
you choose Tools→Comparison.

Use this option To do this

Geometry Display differences between two parts or two sets of parts.

• Set Part Group 1: Set your first set of parts for comparison.

• Show Part Group 1: Show the parts in Part Group 1.

• Set Part Group 2: Set your second set of parts for comparison.

• Show Part Group 2: Show the parts in Part Group 2.

• Tricolor Mapping: Display Part Group 1 and Part Group 2 in the same Part
Compare Viewing window and identify the similarities and differences
between the part sets.

Comparison menu
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• Distance Mapping: Display Part Group 1 and Part Group 2 in the same
Part Compare Viewing window and identify the extent of the differences
between the part sets.

Side by Side Visually inspect models side by side in two or more 3D Viewing windows.

• View Multiple Windows: Start a side by side comparison of the contents
of multiple 3D Viewing windows.

• Synchronized Viewing: Synchronize the navigation cameras for the
Viewing windows involved in the comparison.

• Reposition Windows: Re-tile the Viewing windows.

Preferences Specify the default behavior of 3D comparisons.

Concept menu

In Professional and Mockup, use the Concept menu to work with advanced appearance attributes.

Use this option To do this

Appearance Specify appearance options.

Behaviors Create and manage Behaviors.

Presenter Play presentations.

Desktop Display Set the desktop display mode.

Immersive Display Specify immersive display options.

Sensors Configure sensors.

Surface Analysis Evaluate part surface fairness.

Constraint menu

Use the Constraint menu to constrain parts in an assembly and manage constraint files. The Constraint
menu appears on the Menu bar when you choose Constraint from the Tools menu.

Use this option To do this

Open Constraint File Open an existing constraint (.plmxml) file.

New Constraint File Create a new constraint file.
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Save Constraint File Save the constraints to a constraint file. If you opened an existing constraint
file, save the changes to the same file.

Save As Constraint File Save the constraints to a constraint file. You can specify a new file name and
path.

Update Update

Create Constraint Create new constraints.

Create Mechanism
Link

Create a mechanism link for each component added to the mechanism.

Remove Mechanism
Link

Remove a mechanism link from the mechanism.

Preferences Set global constraint behavior and appearance preferences.

DFx menu

The DFx menu is accessible from the Tools menu when an ECAD image is opened in the Viewing
window.

Use this option To do this

Open Rules Open the Open Rules dialog box and select a configuration file containing
the rules for evaluating the open PCB.

Edit Rules Open the DFx Rule Set Editor dialog box to review and modify Design for
Assembly and Design for Test rules.

Open Results Open a previously generated results file for the current PCB.

Save Save the active rules file and results using the current dataset name.

Save As Save the active rules file and results. You will be prompted for a new dataset
name.

Run Start the design evaluation on the active PCB.

Summary Report Open the most recently saved summary results report for the active PCB.

Detail Report Open the most recently saved detail results report for the active PCB.

Edit menu

The Edit menu appears in the Menu bar when a file is open. Edit menu items are available when
markups are selected.

DFx menu
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Copy (2D, 3D) Copy a selected markup.

Copy Image (2D) Copy an image as it appears in the Viewing window, then paste the image
into another application that accepts bitmap images.

Copy Region (2D) Select a section of an image and copy it to the clipboard.

Cut (2D, 3D) Cut a selected markup.

Delete (2D, 3D) Delete a markup.

Options Modify Teamcenter options.

Paste (2D, 3D) Paste a cut or copied markup into the selected markup layer.

Redo (2D, 3D) Reverse an undo.

Select All (2D) Select all the markups on your image.

Undo Reverse the last action you performed.

User Settings Update your Teamcenter user settings.

Edit Text (2D) Update the text in a 2D file.

File menu

The File menu is on the menu bar.

Some options are available only when files of a particular type are open.

Use this option To do this

Attachments Save attachments, such as Microsoft Office documents, with your session
package.

Close Close the active file. If you have used the New Window option to create
additional views of your document, all views close. To close only one view,
close the window itself.

Convert Model Convert a 3D model file to .jt format.

Exit Close all files and exit the program.

Export (3D) Export 3D model files.

Export Image Save a 2D image of your current view, as a raster image.

Export Image View List
(2D)

Save 2D current view information as a file or macro.

Preferences Set your preferences when opening files.
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Print Print the image in the current Viewing window.

Print Preview View and manipulate your 2D image or 3D model, then print the view in the
Print Preview window.

Properties (2D) Display information about your 2D image.

You can display the name and location of your file, as well as the
dimensions, depth, and resolution of your image. You can also view any
metadata that has been stored with your image file.

Save All Layers (2D) Save your layers as separate CGM markup layers. If a layer has not been
saved, you will be prompted for a file name.

Save As (3D) Save 3D model files as .plmxml.

Save Combined Layers
(2D)

Save all selected layers as one CGM file.

Tip:

• You can select layers by clicking the layer name in the layer tree.

• You can select multiple layers by pressing the CTRL key while you
click.

Note:

If the environment variable EAI_EXPORT_COMBINED_VISIBLE is set to
YES, all visible layers are combined in this operation, whether or not
they are selected.

Save Layer Save the selected 3D layer.

Save Layer As Save the selected 3D layer with a new name.

Save Selected Layers
As (2D)

Save the selected layers as separate CGM markup layer.

Save Session Save a session file.

Send Mail (2D, 3D) Send an email message with a .png image capture of the contents of the
2D or 3D Viewing window or with a .vfz collaboration file that captures your
work session.

2D GD&T Markup menu

You can use the GD&T Markup menu to control how GD&T markups appear in the Viewing window. The
GD&T Markup menu appears on the Menu bar when you choose GD&T Markup from the Tools menu.

2D GD&T Markup menu
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GD&T Annotation
Editor

Open the GD&T Annotation Editor dialog box.

Stack Enable or disable Stack Mode.

Copy GD&T
Annotation

Copy a GD&T annotation.

Paste GD&T
Annotation

Paste a GD&T annotation.

New Layer Add a new GD&T markup layer.

Preferences Specify GD&T annotation preferences.

3D GD&T Markup menu

You can use the GD&T Markup menu to control how GD&T markups appear in the Viewing window. The
GD&T Markup menu appears on the Menu bar when you choose GD&T Markup from the Tools menu.

Use this option To do this

GD&T Annotation
Editor

Open the GD&T Annotation Editor dialog box.

Anchor Enable or disable Anchor Mode.

Stack Enable or disable Stack Mode.

Copy GD&T
Annotation

Copy a GD&T annotation.

Paste GD&T
Annotation

Paste a GD&T annotation.

New Layer Add a new GD&T markup layer.

Preferences Specify GD&T annotation preferences.

Groups menu

Use the Groups menu to create sets of visible parts (groups), and display, hide, or select each group.

The Groups menu appears on the first level of the Menu bar when you choose Tools→Groups to
activate the Groups menu.
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Add Selected Create a new group from the parts that are selected in the Viewing window.

Add Visible Create a new group from the parts that are currently visible.

Copy to Alt. Hierarchy Create an assembly of the active group in the Assembly tree.

Delete Delete the selected group from the Groups view.

Edit Group
Appearance

Change the appearance of the parts in the selected group.

Full Subtract Change the way group parts are hidden.

Rename Rename the selected group from the Groups view.

Replace Selected Replace the parts in the selected group with the parts that are selected in
the Viewing window.

Replace Visible Replace the parts in the selected group with the parts that are currently
visible in the Viewing window.

Single Group Mode Display, hide, or select the parts in only one group at a time.

Use Group Appearance Display the parts in groups with the appearance you set with the Edit Group
Appearance option.

Sort Sort groups in ascending or descending order.

Help menu

Use the Help menu to access the information you need to use the software.

Use this option To do this

Current Application Launch the online help for the active application.

Help Library Launch the full help library.

About Display version, copyright, and requirement information about the software.

Markup menu (2D)

The 2D Markup menu appears on the Menu bar when a 2D image file is in the active Viewing window
and you choose Markup from the Tools menu.

Help menu
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New Layer Create a new 2D markup layer on your 2D image.

Select Select individual markups to move them around the Viewing window and
between 2D markup layers.

Draw Select a type of markup to place on your 2D image. You can choose to create
markers, lines, shapes, and text. You can also select the options to insert
another 2D image or predefined data from a rubber stamp.

Bring to Front Move a 2D markup to the top of all other 2D markups on the 2D markup
layer.

Send to Back Move a 2D markup behind all other 2D markups on the 2D markup layer.

Bring Forward Move a 2D markup one position forward on the 2D markup layer.

Send Back Move a 2D markup one position back on the 2D markup layer.

Properties Change the characteristics existing 2D markups.

Preferences Specify the characteristics of new 2D markups.

Markup menu (3D)

The Markup menu appears on the menu bar when a 3D file is in the active Viewing window, and you
choose Tools→Markup.

Use this option To do this

New Layer Create a new 3D markup layer.

Layer Authoring Create authored layers to use during collaboration sessions.

Select Select an existing markup.

Draw Draw markups in the Viewing window.

Anchor Attach the markups you draw to parts of the model. Clear Anchor to draw
markups that are not attached to a part, but instead “float” in the Viewing
window.

Fill Draw filled rectangle, polygon, ellipse, or text markups. Clear Fill to draw
only the outline of a rectangle, polygon, ellipse, or text.

Auto Create Anchored
Text

Create anchored text which is added to either selected or visible parts at
once.

Use Predefined Text Add predefined text that needs to appear every time you add a text markup.

Align Align multiple anchored text markups for readability.

Distribute Distribute markups as needed to evenly space them.
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Position Anchored
Text

Position anchored text markups precisely where you want them.

Find Find and replace text in the current view's anchored and unanchored text
markups.

Edit Properties Change specified properties of a filtered set of markups.

Resequence Callouts Resequence the order callouts appear in the Viewing window.

Remove All Remove all 3D markups.

View Anchored with
Part

Associate the visibility of anchored markups with the visibility of the parts
they are attached to.

Manage Symbols Access the Symbol Manager dialog box.

Preferences Change the colors, styles, and display of 3D markups.

Measurement menu (2D)

The Measurement menu appears on the Menu bar when a 2D image is in the Viewing window and
when you choose Tools→Measurement.

Use this option To do this

New Layer Create a new markup layer.

Calibrate Vector Calibrate the measurement device between two points drawn on your base
file or markup layer.

Calibrate Raster Calibrate the measurement device between any two points (pixels) on your
base file or markup layer.

Vector Measurement Measure a drawn angle or radius, between two drawn points, or the angle
between two drawn lines on your base file or markup layer.

Raster Measurement Measure any angle or radius, between any two points, or between any two
lines on your base file or markup layer.

Persistent
Measurement

Maintain measurement results by saving the data as a base file or markup
layer.

Preferences Set precision, color, and text height for 2D measurements.

Measurement menu (3D)

The Measurement menu appears on the Menu bar when you open a 3D file and enable 3D
Measurement from the Tools menu.

Measurement menu (2D)
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Type In Standard, Professional and Mockup, select the type of 3D measurement
(single, double, chain, fan, distance, angle, radius, or diameter).

Clear Delete all 3D measurement display labels.

Undo Pick Clear your last measurement pick.

Create Part
Summation
Measurement

Display the total area, volume, and mass of a selected set of parts.

Create Bounding Box
Measurement

Display the bounding box for a selected set of parts, and display the
measurements of the bounding box.

Create Part Set
Measurement

Display the distance between two sets of parts.

Show Minimum
Distance Only

Display the minimum distance when performing measurements between
part features.

Show Maximum
Distance Only

Display the maximum distance when performing measurements between
part features.

Measure Surface
Centerline

Measure the centerline curve of a surface or calculate the cumulative length
of curves of multiple surfaces.

Use Approximate Disable NURBS measurement for some model files.

Preferences the units of measurement, precision, lines, edges, fill, and font displayed
in the measurement display labels. You can also choose to display arc and
circles with radius or diameter measurements, to measure the minimum or
maximum distance between parts, and to display XYZ delta measurements.

Reports Create and edit measurement reports.

Display Active
Measurement

Display information about the active double measurement in the upper left
corner of the Viewing window.

Measurement Logging Record initial information for all double measurements and log any
subsequent changes to double associative measurements as you play a
motion file or interactively move parts.

Navigation menu (3D)

The Navigation menu is on the Menu bar when a 3D file is open.

Some options are available only when you are working in a particular mode.
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Examine Mode Examine your model by panning, zooming, and rotating the navigation
camera.

Explore Mode Explore forward or back and look left or right as you move through your
model.

Fly Mode Move forward, back, left, right, up, and down through your model.

Previous View Return to the last static view.

Next View Move to the next static view.

Fit All Fit all the visible parts of your 3D model into the Viewing window.

Zoom Area Zoom to a specific portion of your 3D model.

Seek • Center a point of your 3D model in the Viewing window.

• View the normal of any face on your 3D model.

Automatic Motion Continuously rotate the navigation camera around the model, creating a
spinning turntable effect.

Rotate Rotate around a specific point on your 3D model.

Navigate Move closer to or farther from the model.

Pan Move the view of your 3D model in the plane of the Viewing window.

Position Choose your initial position in your model.

Level Return your view of the model to level.

Follow Terrain Remain a specified distance above the "floor" upon which you are moving.

Stop on Collision Stop moving through your model when you come into contact with a part.

Go Home Return to the location and position you were at when you last selected Set
Home.

Set Home Set the current location and position as the home location.

Preferences Set parameters for moving through your model.

Part Edit menu

The Part Edit menu is on the Menu bar when you choose Part Edit from the Tools menu.

Part Edit menu
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Control Control model LODs, and define a working set of parts for use in geometry
simplification.

B-Rep Reverse B-Rep face orientation.

Tessellation Tessellate parts.

Visibility Simplify parts based upon visibility.

Decimation Simplify parts based upon a specified triangle reduction.

Preferences Specify Part Edit Preferences.

PMI menu

The PMI menu is on the menu bar when a 3D model file is in the active Viewing window and you choose
PMI from the Tools menu.

Use the PMI menu to display product and manufacturing information (PMI) that is attached to your
model.

Use this option To do this

Feature-based
Multiple Entity Mode

(For JT models containing feature level designs) PMI for all faces and edges
associated with the feature level.

Note:

If you use this option and the JT model does not contain a feature
level, PMI is displayed from the selected face and all its edges.

Toggle Multiple Entity
Mode

Display all the PMI that pass the filter.

Previous Entity (For Single Entity Mode) Display the previous PMI, when you are cycling
through a series.

Toggle Single Entity
Mode

Display each PMI one at a time.

Next Entity (For Single Entity Mode) Display the next PMI, when you are cycling through
a series.

Model View Palette Open the Model View Palette.

Filter Configuration Choose which types of PMI are displayed.

Text Orientation Change the orientation of PMI text so it is displayed correctly.
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Fit View to Selected Display all PMI in the PMI list, without changing the direction or orientation
of the camera.

Clear Entities Clear all the PMI that are currently displayed.

Point Report Display a text dialog box that lists points and normals for selected
Measurement Point and Spot Weld PMI entities.

Preferences Set PMI preferences to control the appearance of PMI labels.

Reconcile menu

Use the Reconcile menu to resolve broken references to parts and assemblies. The Reconcile menu
appears in the Menu bar when you choose Reconcile from the Tools menu.

Use this option To do this

Validate All
References

Validate references in a file.

Reconcile Broken
References

Open the Reconcile Reference dialog box so you can manually reconcile
broken references.

Delete All Mapping
Rules

Removes all mapping rules from the session.

Note:

Mapping rules record of how the broken references were resolved, and
they are retained in session files. Resolving broken references for the
externally stored Visualization files such as VFM, Constraints, and VAN
files require mapping rules.

You can remove the mapping rules from the session file to reduce
the size of a session file. References that are already resolved in the
session will remain resolved, but removing the rules affects working
with the externally stored Visualization files such as motion (.vfm),
constraint (.plmxml), and animation (.van) files. For that reason, this
command should be used sparingly.

Import Mapping File Load a mapping file.

Export Mapping File Save a mapping file.

Preferences Specify reconcile preferences.

Reconcile menu
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Section3D menu

The Section3D menu appears on the Menu bar when a 3D model is in the active Viewing window and
you choose Section3D from the Tools menu.

Use this option To do this

Create Section Create a cross section that is normal to the X, Y, or Z axis.

Create Grid Create a cross section grid.

Create Series Create a series of equally spaced cross sections along an axis, along a linear
edge, or between two points.

Delete Delete the active cross section in the current 3D view.

Delete All Delete all cross sections.

Position Plane Show or hide the Position Plane dialog box or 3D manipulator for
positioning section planes.

Align Plane Align the active cross section plane in the current view normal to the X, Y, or
Z axis, or to a feature of the model.

Show in Viewer Show or hide the Cross Section Viewer for the active section.

Select Parts Select all parts in an existing cross section.

Update Parts Update a cross section after adding or removing parts.

Send to 2D Capture a cross section as a 2D image.

Send to 3D Capture a cross section as a 3D document.

Clipping Clip away the near or far side of the model, or clip away both sides to display
only the cross section edges.

Plane View Rotate the view to make it parallel to the active cross section plane.

Fix Label Orientation Correct the orientation of cross section grid labels.

Show Borders Display all cross section borders.

Hide Borders Hide all cross section borders.

Create Point Sheets Generate point sheets and display the points in the 3D scene.

Choose Section for points that are generated at the intersection of section
and grid lines parallel to the X, Y, or Z axes.

Choose Curve for points that are generated along a single curve or multiple
connected curves.

Preferences Specify appearance and behavior preferences for new cross sections.
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Use this option To do this

Update Update cross section rendering when the Fast Mode section preference is
active.

Report Create cross section reports that can include analysis of the section area or
perimeter, moment of inertia, center of gravity, and other calculated cross
section properties.

Note:

Only Perimeter and Area are available if the model does not contain
B-Rep data.

Snapshots menu

The Snapshots menu is on the Menu bar when you choose Snapshots from the Tools menu.

Note:

Menu options vary depending on the type of file you are working with. For example, when
you work with 3D snapshots you can cycle through the snapshots, change the view between
thumbnail images and a list, and set 3D snapshot preferences.

Use this option To do this

Cycle Cycle through a series of snapshots.

Note:

This feature is supported by 3D snapshots.

Add Add a snapshot of the Viewing window.

Insert Insert a snapshot between two existing snapshots.

Delete Delete the selected snapshot.

Replace Replace a snapshot with a new snapshot.

Recapture Image Recapture the image displayed in the Snapshots view.

Preferences Specify snapshot preferences.

Snapshots menu
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Use this option To do this

Note:

This feature is supported by 3D snapshots.

Toggle View Display snapshots as thumbnails or a list.

Note:

This feature is supported by 3D snapshots.

Tools menu

Use the Tools menu to enable and use various features of the software.

Some options are available only when files of a particular type are in the active Viewing window.

Use this option To do this

Adjust Translate, scale, or rotate your 2D image.

When you select Adjust, the Adjust menu appears on the Menu bar.

Note:

When you open a 2D image and add a layer, this menu option
becomes available.

Alignment Align 3D model parts.

When you choose Alignment, the Alignment menu appears on the Menu
bar.

Note:

When you open a 3D model, this menu option becomes available.

Assembly Work with the assembly of your 3D model.

When you select Assembly, the Assembly menu appears on the Menu bar.

Auto Correct Set up automatic correction and text replacement as you type in a technical
illustration.

CAE Viewing View CAE data exported as a .jt file from a supported application.
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Use this option To do this

Clearance Enable clearance checking of your 3D model.

When you select Clearance, the Clearance menu appears on the Menu bar.

Note:

When you open a 3D model, this menu option becomes available.

Color Palette Define and select colors for elements of a technical illustration.

Comparison Identify similarities and differences between sets of parts.

When you select Comparison, the Comparison menu appears on the Menu
bar.

Note:

When you open a 3D model, this menu option becomes available.

Custom Property Sets Define stencils that contain similar data types (such as names, ID, dates, or
descriptions), or add data sets to make the data fields consistent for each
shape.

GD&T Markup Create GD&T markups.

When you select GD&T Markup the GD&T Markup menu appears on the
Menu bar.

Groups Create sets of visible parts (groups), and display, hide, or select each group.

When you select Groups, the Groups menu appears on the Menu bar.

Markup Draw markups on your 2D image.

Draw markups on your 3D model.

When you choose Markup, the Markup menu appears on the Menu bar.

Measurement Measure your 2D image or 3D model.

When you select Measurement, the (2D) Measurement menu or (3D)
Measurement menu appears on the Menu bar.

Options Define specific Visio options for use in a technical illustration.

PMI Display product and manufacturing information (PMI) that is attached to
your model.

When you select PMI, the PMI menu appears on the Menu bar.

Tools menu
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Use this option To do this

Note:

When you open a 3D model, this menu option becomes available.

Part Edit View, create, and delete part Level of Details (LODs).

When you choose Part Edit, the Part Edit menu appears on the Menu bar.

Note:

When you open a 3D model, this menu option becomes available.

Reconcile Resolve broken file references to parts and assemblies.

When you select Reconcile, the Reconcile menu appears on the Menu bar.

Ruler and Grid Show, hide or change the grid or ruler measurement units in a technical
illustration.

Run Add-On Run a special program (add-on) to perform specific Microsoft Office Visio
tasks and operations in a technical illustration.

Section3D Create and work with cross section views of your 3D model.

When you select Section3D, the Section3D menu appears on the Menu
bar.

Snap and Glue Determine how shapes are aligned with other shapes and how shapes are
attached to each other.

Snapshots Create or work with snapshots to mark your place.

When you select Snapshots, the Snapshots menu appears on the Menu
bar.

Spelling Check the spelling in a technical illustration.

Thrustline Create thrustlines that show the order and relationship of parts in
assemblies.

When you choose Thrustline, the Thrustline menu appears on the Menu
bar.

Visual Report Create Visual Reports and apply them to your 3D models.

Use this feature to create a systematic auto-color distinction between parts
using a specific condition. For example, create a Visual Report that displays
parts that are in a working status as red and all other parts as green.

When you select Visual Report, the Visual Report menu appears on the
Menu bar.
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Thrustline menu

The Thrustline menu appears on the Menu bar when you open a 3D file and enable Thrustlines from
the Tools menu.

Use this option To do this

New Layer Create a new layer on the 3D scene.

New Thrustline Create a new thrustline.

Delete Thrustline Delete the currently selected thrustline.

Preferences Edit preferences for thrustlines.

View menu (2D)

Use the View menu to manage or change how you view 2D images in the Viewing window. A separate
menu is available for 3D viewing. Some options are available only when files of a particular type are
open.

Use this option To do this

Fit All Fit your entire 2D image into the Viewing window.

Base View Size the view to the extents of the first layer in a multi-layered 2D document.

Note:

If the 2D document that you are viewing only has one layer, this
option works the same as Fit All.

Browse • Select hyperlinks.

• Display screen tips.

• Display contents of PDF sticky notes.

Zoom Area Define an area of your 2D image and zoom to fit that area in the Viewing
window.

Seek Center a point of your 2D image in the viewing window.

Pan Move your 2D image around in the plane of the Viewing window.

Zoom Move closer to or farther from your 2D image.

Zoom Scale Zoom a proportional amount closer to or farther from your 2D image in the
Viewing window.

Thrustline menu
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Use this option To do this

• Use Zoom In to move closer to your 2D image in the Viewing window.

• Use Zoom Out to move farther from your 2D image in the Viewing
window.

Zoom - Drawing Scale Zoom to standard drawing scales, for example, 1:4, 1:2, 1:1, 2:1, and 4:1.

Orient Rotate or flip the view of your image.

• Rotate Counterclockwise: Rotate the view 90 degrees counterclockwise.

• Rotate Clockwise: Rotate the view 90 degrees clockwise.

• Flip Vertical: Flip the view vertically.

• Flip Horizontal: Flip the view horizontally.

Page Move to a different page in a 2D image file that contains multiple pages.

Preferences Specify Viewing window appearance and initial view preferences.

Full Screen Display Enable full screen display of 2D images.

Search Search for text strings in PDF files.

View menu (3D)

Use the View menu to manage or change how you view 3D images in the Viewing window. A separate
menu is available for 2D viewing. Some options are available only when files of a particular type are
open.

Use this option To do this

Standard Views Switch to a standard view.

Asterisks next to the view name indicates that view is the default view.

Rotate Use the Rotate control panel or rotate your 3D model specific ways in the
viewing window.

View Clipping Add a near and a far clipping plane to the 3D Viewing window. You can also
adjust the field of view for the perspective display mode.

Visibility Display or hide selected parts, vertices, and edges of 3D models.

• Control by Selected: Display or hide parts when you select them.

• All On: Display all parts.
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Use this option To do this

• All Off: Hide all parts.

• Selected On: Display parts that are selected in the assembly tree. (When
Control by Selected is not active.)

• Selected Off: Hide parts that are selected. (When Control by Selected is
not active.)

• Visited On: Display all parts that you have explicitly made visible during
the work session.

• Invert Visited: Swap the visibility state of parts that you have explicitly
made visible during the work session.

• Show Edges: Display feature or B-Rep edges for the selected parts.

• Show Vertices: Display B-Rep vertices for the selected parts.

• Hide Edged: Hide feature or B-Rep edges for the selected parts.

• Hide Vertices: Hide B-Rep vertices for the selected parts.

• Hide All: Hide all edges and vertices for all parts.

• Hide Obscuring: Hide parts that obscure your view of other parts.

• Clipping Volumes: Clip areas of a 3D model for a better view of a part or
assembly.

Select Select parts or part features in your model.

• All: Select all parts.

• None: Deselect all parts.

• Selection Filter: Specify Point, Vertex, Arc Center, Midpoint, Point on
Edge, Surface, or Part. Check marks  indicate part feature types that
are active for Smart Pick and QuickPick.

• Disable Active Tool: Cancel the operation that is expecting a part feature
selection, for example, 3D Measurement.

• Define Point: Specify User Defined Point, Midpoint, Intersection, or
Center of Three Point Arc.

View menu (3D)
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Use this option To do this

• Select Parts by Area: Select parts within an area that you define.

• Select Parts by Volume: Select parts within a volume that you define.

• Pick Through Unshaded Parts: Pick geometry visible through parts
displayed in the tessellated or feature lines display modes.

• Generate Selection Preview Data: Load the B-Rep data required for
previewing part feature selection.

Orthographic Display an orthographic view of your model.

Perspective Display a perspective view of your model.

Page Extents Enable page extents functionality to size 3D entities relative to a 2D space.

Preferences Specify 3D viewing and selection preferences.

Performance Change the 3D Viewing options to improve the viewing quality.

Part Display Modes Specify part display mode options.

• Clear display modes: Reset the display modes for all parts.

• Set all occurrences: Apply display modes to all instances of selected
parts.

• Show confirmation dialog: Confirm that you want to reset the display
modes for all parts.

Visual Report menu

Use the Visual Report menu options to create visual reports and apply them to the parts and
assemblies.

Use this option To do this

Apply Report Open the Apply Report dialog box.

Use the Apply Report dialog box to load and apply existing visual reports.

Quick Report Open the Quick Report dialog box.

Use the Quick Report dialog box to quickly identify the parts that match
your metadata search query.

Single Rule Report Open the Single Rule Report dialog box.
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Use this option To do this

Use the Single Rule Report dialog box to generate metadata search
conditions and to specify how you want matched and unmatched parts
displayed.

Multiple Rules Report Open the Multiple Rules Report dialog box.

Use the Multiple Rules Report dialog box to generate metadata search
conditions.

Results Legend Open the Results Legend dialog box.

Use the Results Legend dialog box to display detailed information about
processed visual reports. This information includes details as the current rule
name and scope, names of parts, and the attributes and values used in the
report.

Report Explore Open the Report Explore dialog box.

Use the Report Explore dialog box to set options for how you view the
results of your visual report.

Reset Appearance Discard visual changes and return to the original visual representation.

Preferences Specify the default options for various visual reports preferences.

Window menu

Use the options from the Window menu to create a new instance of the 2D or 3D Viewing window or
clone the 3D Viewing window.

Use this option To

New Window Open a copy of the active 2D or 3D Viewing window.

Note:

If you have created copies of the file with the New Window option,
and then you choose Close, all windows that contain the file in the
active window close. To close a Viewing window without closing other
Viewing windows that display the same file, click the X in the upper
right corner of the Viewing window.

Clone Window (3D) Create the same 3D view window as with New Window, but also apply
view-based information from the active 3D view being cloned.

Window menu
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Shortcut menus

Shortcut menus are accessed by right-clicking items in locations, such as the assembly view. They
provide quick access to much of the application's functionality.

Working with the status bar

Status bar overview

Located at the bottom of the interface, the Status bar displays information such as the following.

• The amount of memory that is available for 3D documents.

• The current number of anti-aliasing samples being used in the Viewing window.

• The loading progress of the 3D assembly. For example, when loading parts you will see file names
appear in the Status bar, and the number of remaining shapes to load (with a time estimate for
completion).

• Progress information for long running operations. The messages are not necessarily meant to provide
precise information on every step in a process, but to communicate that the process is moving
forward.

Due to the number of messages potentially displayed in the Status bar, these messages are not
documented.
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Choosing colors

When you select an option that involves choosing colors, you can choose from a palette of standard
colors or create custom colors.

Do one of the following when the standard color palette appears:

To Do this

Choose a color from the
standard color palette

Click a color.

Choose a color from a larger
color palette

1. Click Other to open the Color dialog box with a larger palette.

2. Click a color in the Basic colors area.

3. Click OK.

Create a custom color
interactively

1. Click Other to open the Color dialog box.

Choosing colors
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To Do this

2. In the color shader section, drag the mouse pointer until the color
preview displays the correct color (hue and saturation).

3. Drag the luminosity slider up and down until the color preview
displays the correct brightness.

4. (Optional) To save your custom color for use in the current work
session, click Add to Custom Colors.

The color appears in the Custom colors section.

5. Click OK.

Create a custom color by
typing color values

1. Click Other to open the Color dialog box.
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To Do this

2. Type values to define your custom color.

Hue: Enter a value from 0 to 239 to define the hue (color) of the
color.

Sat: Enter a value from 0 (gray) to 240 (intense) to define the
saturation of the color.

Lum: Enter a value from 0 (black) to 240 (white) to define the
luminosity (brightness) of the color.

Red: Enter a value from 0 to 255 to define the amount of red in
the color.

Green: Enter a value from 0 to 255 to define the amount of green
in the color.

Blue: Enter a value from 0 to 255 to define the amount of blue in
the color.

3. (Optional) To save your custom color for future use, click Add to
Custom Colors.

The color in the Color window appears in the Custom colors list
on the left side of the Color dialog box.

4. Click OK.

Choosing colors
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4. Previewing images and .jt parts
Image Preview and JT Preview views

Use the Image Preview and the JT Preview views to examine 2D raster images and .jt parts associated
with items, item revisions, and datasets. When you select compatible objects within the My Teamcenter
tree or the trees of other perspectives, the associated image or .jt part is displayed in the appropriate
preview viewer.

Note:

Images and parts are displayed according to the order specified in the tcgrb.properties file (for 2D
images) and the tctdv.properties file (for .jt parts).

Preview images

Preview 2D raster images in the Image Preview view.

1. (If you do not have a tab for the Image Preview view) Choose Window→Show
View→Other→Teamcenter→Image Preview.

2. Select an item, item revision, dataset, or other object associated with a 2D image.

The image is displayed in the Image Preview view.

Note:

• The Image Preview view supports raster images only, such as bitmap (.bmp), JPEG (.jpg,
jpeg), and TIFF (.tif, .tiff) files. Vector formats are not supported.

• The Image Preview view is displayed by default in the Relation Browser application.
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Tip:

The Image Preview view provides a basic preview of 2D raster images. To view vector images
or work with additional 2D visualization functionality, right-click the object and choose Send
To→Lifecycle Viewer.

Preview .jt parts

1. (If you do not have a tab for the JT Preview view) Choose Window→Show
View→Other→Teamcenter→JT Preview.

2. Select an item, item revision, dataset, or other object associated with a .jt file.

3. Do any of the following to examine your part:

To Do this

Rotate the camera around the
part

In the background of the view, drag the cursor.

Pan the camera along the
current plane

Press Ctrl and then in the background of the view drag the
cursor.

Zoom the camera Press Shift and then in the background of the view drag the
cursor.

Note:

• The JT Preview view can display only one .jt dataset at a time.

• The JT Preview view is displayed by default in the My Teamcenter application.

Tip:

• If a dataset is revised while active in the JT Preview view, right-click the dataset and
choose Refresh to see the latest changes.

• The JT Preview view provides a basic preview of .jt parts. To work with additional 3D
visualization functionality, right-click the object and choose Send To→Lifecycle Viewer.

4. Previewing images and .jt parts
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5. Opening files
Primary and secondary visualization documents

Visualization files in Teamcenter are always either primary or secondary documents. You can open
primary documents independently from other documents, while secondary documents are dependent
upon primary documents. For example, a JT file is a primary document, which you can view on its own
without any other file having to be open; a markup layer (VPL file), in contrast, cannot be viewed on its
own, and must be opened in the context of a primary document, such as a JT file.

A primary document:

• Can exist in the database on its own.

• Consists of data that has been translated from some master source data such as a CAD file.

• Consists of one file (for example, a 2D image) or a logical set of files (for example, assembly and part
files).

• Can be opened in a Lifecycle Visualization viewer independently of any other documents.

• May have secondary types of documents that depend on it, but may not be aware of these secondary
files.

A secondary document:

• Always relies on a primary document.

• Is only meaningful in the context of a primary document (for example, a 3D markup).

• Cannot be viewed in a Lifecycle Visualization viewer without a primary document.

• Is always aware of its primary document.

• May contain many types of data which may serve different purposes (for example, a snapshot consists
of layer data, view data, motion data, thumbnail data, and so forth).

• May capture additional information about the primary document.

Open visualization data from Teamcenter

You can open visualization data, including 2D images and 3D models, in the standalone viewer and the
Lifecycle Viewer.
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Note:

The options to send Teamcenter managed visualization data to the standalone viewer may
not be shown by default on the user interface of the rich client. For these options to be
displayed, you must enable them using the Lifecycle Visualization options in the rich client or
the TC_show_open_in_vmu_button preference.

Do any of the following:

To Do this

Send any of the following to the standalone
viewer:

• An item or item revision that includes
visualization data

• A BOM view

• Selected product structure

• Worksets

• A 3D dataset such as a JT file

• A 2D or ECAD dataset such as an image or PCB
file

Select the object and do one of the following:

• On the My Teamcenter toolbar, click Start/
Open In Lifecycle Visualization .

• Choose File→Open in Lifecycle Visualization.

Send any of the following to the Lifecycle Viewer:

• An item or item revision that includes
visualization data

• A BOM view

• Selected product structure

• Worksets

• A 3D dataset such as a JT file

• A 2D or ECAD dataset such as an image or PCB
file

Right-click the object and click Send To→Lifecycle
Viewer.

5. Opening files
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Working with product structure from Teamcenter

You can send a full or partial product structure from the Structure Manager to the Lifecycle Viewer or a
standalone viewer. Open the structure in a new Viewing window, insert the structure as a new assembly
in an active Viewing window, or merge the structure with an existing assembly in an active Viewing
window.

To send product structure to the visualization client, select the product structure within the Structure
Manager and then do one of the following:

• Click Start/Open In Lifecycle Visualization  to send the product structure to a standalone viewer.

• Right-click the product structure and choose Send To→Lifecycle Viewer to send the product structure
to the Lifecycle Viewer.

To send a full product structure to the visualization client, select the root or top line of the product
structure. To send a partial product structure, select any child nodes within the root product structure
hierarchy. Partial product structure consists of the lines representing the unique paths down to the
selected structure.

Note:

When working with partial product structures, the following limitations apply:

• You can expand only the child hierarchy of the launched lines.

• All viewer operations, such as filters and Clearance analysis, are applicable only for the launched
lines.

Note:

Teamcenter applications such as Structure Manager include view toggles that enable you to
see BOM lines that are configured out because of effectivity or variants. The view toggle Show
Suppressed Occurrences enables you to see BOM lines that are suppressed in the current
assembly arrangement. If you send an assembly to the standalone application viewer or the
Lifecycle Viewer when this view toggle is on, the suppressed structure elements are grayed out.
If you open a product view that captured suppressed occurrences, an inactive structure warning
is displayed. To avoid this problem, set the Product View Creation Preferences to prevent the
creation of product views when the Show Suppressed Occurrences view toggle is enabled.

Inserting and merging files

When you want to insert or merge a 2D, 3D, or ECAD file into an opened similar file format, the system
asks how you want to open the file. The following insert and merge options exist:

Working with product structure from Teamcenter
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• Insert the file into the current window.

• Merge the file into the current window.

• Insert or merge the file into a new Viewing window.

The steps required to insert or merge files vary slightly depending upon the applications involved.
When working with local data in the standalone viewer, you must use the Application toolbar
Menu→File→Insert or File→Merge commands. When working with Teamcenter managed data, you
send the data you want to insert or merge into the standalone viewer or the Lifecycle Viewer, and then
specify how you want to open the data in the Load Option Preferences dialog box.

Specify load option preferences

1. Choose File→Preferences→Load Options.

2. In the Load Option Preferences dialog box, choose from the following preferences:

• On the 3D tab:

In this
section Select this To

Product
Structure

Open document Do one of the following:

• Open the document in a new window.

• (If the document is already open in a
window) display the window.

Insert document into active
window

Insert the data into the currently active
window.

Merge document into active
window

Merge the data into the currently active
window.

Note:

You can merge product structure only
if the data being sent is compatible
with the contents of the active Viewing
window. For structure to merge, the
data being sent to the visualization
client and the data in the active Viewing
window must share the following
structure configuration properties:

5. Opening files
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In this
section Select this To

• Revision rule

• Root or top line

• Variant rule (if either set of data uses
a variant rule)

• Active assembly arrangement (if
either set of data uses arrangements)

Ask at load time Select your options each time you open a file.

Markups Open with markups Open markups associated with the data.

Ask at load time Select your options each time you open a file.

• On the 2D tab:

Select this To

Open document Do one of the following:

• Open the document in a new window.

• (If the document is already open in a
window) display the window.

Insert document into active window Insert the data into the currently active
window.

Ask at load time Select your options each time you open a file.

Open with markups Open markups associated with the data.

Ask at load time Select your options each time you open a file.

• On the ECAD tab:

Select this To

Open document Do one of the following:

• Open the document in a new window.

Specify load option preferences
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Select this To

• (If the document is already open in a
window) display the window.

Insert documents into active window Insert the data into the currently active
window.

Ask at load time Select your options each time you open a file.

Note:

• Selections are persisted each time the dialog box opens.

• The default settings for the Load Option Preferences dialog box are Ask at load time and
Merge document into active window.

• For 3D, for If merge is not possible the default is Open document.

• If you choose Ask at load time, you can use the load option preference to change how you
want to open files.

Open visualization data in My Teamcenter

1. In My Teamcenter, select an item, item revision, dataset, or other object associated with a 2D or 3D
file.

2. Select the Viewer view.

The visualization components load and the My Teamcenter embedded viewer opens.

Tip:

Right-click the embedded viewer toolbar area to turn on additional visualization toolbars.

Open visualization data in Structure Manager

1. In My Teamcenter, right-click an item, item revision, dataset, or other visualization-related object
that contains product structure and choose Send To→Structure Manager.

The Structure Manager opens and displays the product structure.

2. Choose View→Show/Hide Data Panel.

3. In the Data Panel, click the Viewer tab.

5. Opening files
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The visualization components load and the Structure Manager embedded viewer opens.

4. In the BOM Line, select the check box for the part or assembly you want to view.

Tip:

Right-click the embedded viewer toolbar area to turn on additional visualization toolbars.

View related documents in My Teamcenter

When viewing a 3D model, you can open the associated item revision in My Teamcenter to access
additional information or attachments.

1. Display the product structure or part.

2. In the Assembly view, right-click the product structure or parts and choose Send to My
Teamcenter.

-or-

In the Viewing window, right-click the geometry and choose Send to My Teamcenter.

The associated item revision is opened in My Teamcenter.

Specify open preferences for 2D or 3D files

Some CAD related file types can contain 2D or 3D data. You can set preferences to always open DWG/
DFX, IGES, and PRT files in a 2D Viewing window or a 3D Viewing window. Another option is to be
prompted to choose each time you open a file.

1. Choose File→Preferences→File Open.

2. In the File Open Preferences dialog box, choose one of the following for each file type:

• 2D

• 3D

• Prompt

Note:

• This functionality is supported in Standard service levels and above. For Base service levels,
these files always open as 2D file types.

View related documents in My Teamcenter
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• 3D IGES files are supported only in the standalone viewers.

Specify the PLM XML load preferences

1. Choose File→Preferences→PLM XML.

2. In the PLM XML Preferences dialog box, on the Load page, choose from the following
preferences:

Select this To

PLM XML Units Define the unit of measurement. By default, the unit of
measurement for PLM XML and Parasolid files is meters.
You can use the PLM XML Units setting to specify
another unit of measurement.

Note:

• The PLM XML Units setting is saved in session
files. If you change and save the model units
setting with a VF file, the specified model units
of the session file override the current PLM XML
Units setting.

• Session files referencing PLM XML models that
were created prior to Teamcenter lifecycle
visualization 5.1.0.2, do not contain the model
units specification. The software uses the
current PLM XML Units setting on the Load
page of the PLM XML Preferences dialog box
if you load the session file with a newer viewer.
This event may result in content displayed in the
wrong scale. The model units is always meters
for pre-5.1.0.2 PLM XML files.

As a work around, migrate the session file
to a Teamcenter lifecycle visualization 5.1.0.2
version. Load and save the file in Teamcenter
lifecycle visualization 5.1.0.2.

Apply the default product view on
load

(if unchecked, it will be added as a
snapshot)

Load the default product view when the PLM XML file is
loaded. If this option is not selected, the default product
view is not loaded but is added as a snapshot, which
reduces load time.

5. Opening files
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Configure updating session files in Multi-Site environments

When working in a Multi-Site Collaboration environment, Teamcenter lifecycle visualization session files
referencing dynamic 3D documents may not update correctly. This issue can appear under the following
conditions:

• The session file is created on the master site.

• The session file references dynamic 3D documents.

• The session file and all referenced data are replicated on another site in the network.

• The session file is loaded into Teamcenter lifecycle visualization from a replica site.

To prevent session update failures in Teamcenter lifecycle visualization, perform the following steps to
update the File Locate preferences:

1. Choose File→Preferences→File Locate.

2. In the AutoFile Search Preferences dialog box, click the Document Search Order tab.

3. In the search order list, select Relative File Directory Set.

4. Click Move Up to position Relative File Directory Set above Original File Directory Set in the list.

5. Click Auto Confirm.

Configure updating session files in Multi-Site environments
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6. Click OK.

5. Opening files
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6. Locating referenced data automatically
Overview of locating referenced data automatically

Some file types support references to external files. If the referenced files are moved, the AutoFile
Search tools attempts to locate the files automatically, in local directories as well as on remote servers.

You can specify AutoFile Search preferences for locating files referenced by high-level containers such
as session files or Technical Portfolios. You also can specify preferences for locating the 3D sub-part files
of assemblies. The AutoFile Search Preferences dialog box has four tabs:

• General

• Document Search Order

• Part Search Order

• Search Log

Specify general loading preferences

You can choose to display a file confirmation dialog box when attempting to load documents or parts.

1. Choose File→Preferences→File Locate.

2. On the General tab of the AutoFile Search Preferences dialog box, choose from the following:

To Do this

Always display the File
Usage Confirmation dialog
box

Choose Always ask.

Note:

For Directory Sets on the Document Search Order tab,
Always ask is superseded if Auto Confirm is turned on.

Display the File Usage
Confirmation dialog box
only when more than one
potential file is found

Choose Ask only when multiple matches are found.
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To Do this

Never display the File
Usage Confirmation dialog
box

Choose Never ask.

Do not load files that are
located on remote servers

Select the Ignore remote servers check box.

Confirm documents located automatically

Use the File Usage Confirmation dialog box to accept and load files identified by AutoFile Search. The
File Usage Confirmation dialog box is displayed based upon the general loading preferences and the
results of a file search operation.

Note:

• The File Usage Confirmation dialog box is displayed only for primary documents such as top
level assembly files that link to separate JT files, not to the shattered JT files themselves.

• For Directory Sets on the Document Search Order tab, if Auto Confirm is turned on, the File
Usage Confirmation dialog box is never displayed.

1. Specify general loading preferences to display the File Usage Confirmation dialog box when
locating files.

When you open a document that contains references to an external file that cannot be found, the
program searches for the file according to preferences specified on the Document Search Order
tab.

2. In the File Usage Confirmation dialog box, do any of the following:

To Do this

Display the search report Click Show Details.

Detailed search information is displayed.

Confirm located files Click Use Selected Location.

Manually locate files Click Browse, and locate the file that you want to load.

Cancel the file search
operation

Do one of the following:

• (To cancel for multiple files) Click Cancel All.

• (To cancel for a single file) Click Cancel.

6. Locating referenced data automatically
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Understanding Directory Sets

Directory Sets are collections of rules that produce locations where files may be located. You can change
the order in which Directory Sets are searched, turn them on or off, and specify to automatically load
files that are located within them.

Use Directory Sets to help locate documents and parts. Access Directory Sets from the Document
Search Order and Part Search Order tabs of the AutoFile Search Preferences dialog box.

Directory Sets for documents

Use this option To do this

Automatic Directory Set Search locations where files have been found and loaded via the File
Usage Confirmation dialog box. If the list becomes too long, older
locations are removed.

Current Location
Directory Set

Search the location of the last session file opened.

Examples Directory Set Search the location of the example files installed during the product
installation. This Directory Set assists you in resolving references to
example files from other example files.

Original Location
Directory Set

Search the original location of the file.

Palette Launch Rules
Directory Set

Search locations identified dynamically based on rules associated with
palette entries and the last opened session file. Its primary use is to help
resolve JT file references from palette entries.

Recent Hits Directory Set Search the locations of recently found files. This Directory Set, which
is dynamically built and reset each time the application starts, appears
on the Search Log tab and ensures that recently resolved searches are
included in the current search.

Relative File Directory
Set

Search the location of the target file relative to the base file (for example, a
JT file referenced by a session file).

Root Directory Set Search a location specified by your organization. This Directory Set is
available only if your System Administrator defines the location and
provides access to its preferences file. If the preferences file is not found,
the Directory Set is not displayed. For more information on defining root
directory sets, see Teamcenter lifecycle visualization Installation.

Special Files Directory
Set

Search locations where specialized files used by specific applications are
installed (for example, files used by Variation Analysis).

User-Defined Directory
Set

Search locations specified on the User-Defined tab.

Understanding Directory Sets
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Directory Sets for parts

Use this option To do this

Relative to Parent Location
and Original Location

Search locations dynamically identified according to references in JT or
PLM XML files. Searches are based upon the current location of the
parent file, and the original location of the parent file. This Directory Set
cannot be disabled or edited.

User-defined Directory Set Search locations specified on the Part Search Order tab.

Specify the document search order

Use the Document Search Order tab of the AutoFile Search Preferences dialog box to specify
preferences for locating files referenced by high-level containers such as session files or Technical
Portfolios.

Example:

If you save a session file that references a 3D model, and then move the model to another
location, the Document Search Order tab can help you find and access the model.

1. Choose File→Preferences→File Locate.

2. On the Document Search Order tab of the AutoFile Search Preferences dialog box, do any of the
following:

To Do this

Change the Directory Set
search order

Select a Directory Set, and click Move Up or Move Down.

Enable or disable a
Directory Set

Select the Directory Set, and click Enable / Disable.

Specify to load files
automatically from a
Directory Set if a match is
found

Select a Directory Set, and click Auto Confirm.

Note:

Auto Confirm supersedes the preferences specified on the
General tab.

Edit the User-defined
Directory Set

a. Select User-defined Directory Set, and click Edit.

b. Adjust the contents of the Directory Set.

6. Locating referenced data automatically
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To Do this

Edit the Automatic
Directory Set

a. Select Automatic Directory Set, and click Edit.

b. Adjust the contents of the Directory Set.

Reset the search order
preferences to the default
settings

Click Reset to Default.

Specify search locations for documents

You can search specific directories for file types. You also can change the order in which the directories
are searched.

1. Choose File→Preferences→File Locate.

2. On the Document Search Order tab of the AutoFile Search Preferences dialog box, select User-
defined Directory Set, and click Edit.

3. In the User-Defined Directory Set dialog box, do any of the following:

To Do this

Associate file types with
directories

a. In the Extensions section, click Add.

b. In the Add Extension dialog box, in the Enter new extension
box, type the file type extension that you want to associate
with the directory (for example, .jt), and click OK.

c. In the Extensions section, select the file type extension.

Note:

To specify directories that you want to search but do not
want to attach to a specific file type extension, select
Unatt (unattached).

d. In the Directories for Selected Extension section, click Add.

e. In the Select new directory dialog box, browse to the
location of the directory that you want to associate with the
selected file type, select it, and click OK.

Specify search locations for documents
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To Do this

The directory is added to the Directories for Selected
Extension list.

Add file types to the list of
extensions searched for in a
directory

a. In the Directories for Selected Extension section, select a
directory, and click Edit Extensions.

b. In the Edit Extensions Assigned To Directory dialog box, do
one of the following:

• In the Extensions section, type the file type extensions
that you want to look for in this directory, and click Add.
Separate multiple extensions with spaces.

• In the Vis Extensions section, select a file type, and click
Add.

The new extension appears in the Assigned Extensions
section.

c. (Optional) To remove an extension, in the Assigned
Extensions section, select the extension, and click Delete.

Automatically load files
when they are found in a
directory

In the Directories for Selected Extension section, select a
directory, and click Auto Confirm.

Note:

When you specify Auto Confirm for a directory, you are never
prompted to confirm the opening of any file of the specified
types in this directory, regardless of any other preferences
you have set.

Manage document locations

When you use the File Usage Confirmation dialog box to accept and load documents identified by
AutoFile Search, the file locations are added to the Automatic Directory Set. If you want to include a
location in future searches, you can add it to the User-defined Directory Set.

Tip:

As more file locations are added to the Automatic Directory Set, you can manually remove them
from the list. Older locations are automatically removed if the list becomes too long.

1. Choose File→Preferences→File Locate.

6. Locating referenced data automatically
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2. In the AutoFile Search Preferences dialog box, on the Document Search Order tab, select
Automatic Directory Set and click Edit.

3. In the Extensions section of the Automatic Directory Set dialog box, select a file type.

The Directories for Selected Extension section displays the directories where files of the selected
type were found.

4. Do any of the following:

To Do this

Add a location to the User-
defined Directory Set

Select a location, and click Move to User Set.

In the User-defined Directory Set, the location is added to the list
of directories to search.

Delete a directory from the
list

In the Directories for Selected Extension section, select a
location, and click Delete.

Delete the file type and all
associated directories

In the Extensions section, click Delete.

Delete all displayed
extensions and directories

In the Extensions section, click Clear All.

Specify the part search order

You can specify search behavior for locating part files within multi-site environments.

Example:

If you save a 3D model with sub-part assemblies as a shattered JT file, creating individual JT files
for each sub-part, and then move the sub-part files to another location, the Part Search Order
preferences can help you find and load the files.

1. Choose File→Preferences→File Locate.

2. On the Part Search Order tab of the AutoFile Search Preferences dialog box, do any of the
following:

To Do this

Change the Directory Set
search order

Select a Directory Set, and click Move Up or Move Down.

Enable or disable the User-
defined Directory Set

Select the User-defined Directory Set, and click Enable / Disable.

Specify the part search order
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To Do this

Edit the User-defined
Directory Set

a. Select User-defined Directory Set, and click Edit.

b. In the User-defined Part Loading Directory Set dialog box,
click Add, and add a location that you want searched for parts.

Reset the search order
preferences to the default
settings

Click Reset to Default.

Make temporary changes Select the Consider all changes to this tab as temporary (will be
reset after application exit check box.

View search results

Recent search results are displayed on the Search Log tab of the AutoFile Search Preferences dialog
box. You can access detailed information for each search operation. Search results are displayed with the
most recent search at the top of the list.

1. Choose File→Preferences→File Locate.

2. On the Search Log tab of the AutoFile Search Preferences dialog box, do one of the following:

To Do this

Display detailed search
information

a. Select an entry from the list of search results, and click Show
Details.

b. In the Search Trace dialog box, select an entry, and click
Show Details.

The details of your selection are displayed.

Export search results as an
XML file

a. Select an entry from the list of search results, and click Show
Details.

b. In the Search Trace dialog box, click Export.

c. In the Select file to save to dialog box, save the file.

Note:

Use the SearchTrace.xslt file included in the Examples
directory of your installation to view the XML file as in the
HTML format. Copy SearchTrace.xslt to the same directory

6. Locating referenced data automatically

6-8  Visualization on Rich Client ─ Getting Started, Teamcenter 2412
© 2025 Siemens



To Do this

as your XML file, and then open the XML file in an XSLT-
compatible browser.

Remove files from the list Select an entry from the list of search results, and click Delete.

-or-

Click Delete All.

Specify part logging preferences

You can specify to log detailed part loading information, such as file locations and moniker data.

Note:

Generating part logging information results in longer part loading times.

1. Choose File→Preferences→File Locate.

2. On the Search Log tab of the AutoFile Search Preferences dialog box, click Part Logging.

3. Choose any of the following:

To Do this

Log part loading
information for individual
parts

Choose one of the following:

• Nothing

• Only missing parts

• Only found parts

• All parts

Note:

To control the number of entries added to the search log,
in the Maximum number of logging events to record box,
type a value. Very large values may cause out of memory
errors.

Log additional information Select any of the following check boxes:

Specify part logging preferences
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To Do this

• Unique locations where parts were found

• Include moniker data where appropriate

Delete changes when
exiting the application

Select the Changes are temporary (will reset after application
exit) check box.

Disabling the File Locator search progress dialog

You can create an environment variable called TCVIS_DISABLE_SEARCH_PROGRESS with a value of
True to disable the File Locator progress dialog. This may be necessary if the dialog blocks the
Teamcenter authentication prompt.

Saving and loading AutoFile Search preferences

You can save your AutoFile Search preferences as a .vfp file, which you can distribute for use with other
installations.

Tip:

You also can save AutoFile Search preferences as an .xml file to review your current settings.
However, the application loads .vfp files only.

1. Choose File→Preferences→File Locate.

2. In the AutoFile Search Preferences dialog box, on the General tab, do one of the following:

To Do this

Save AutoFile Search
preferences

a. Click Save Preferences.

b. In the Select file to save to dialog box, save the file.

Load AutoFile Search
preferences

a. Click Load Preferences.

b. In the Select preference file to open dialog box, open a .vfp
file.

Note:

Loading a preferences file overwrites the current
preferences.

6. Locating referenced data automatically
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7. Understanding your work session
Working with session files

Overview of session files

Session files save the state of the viewer so you can resume your work later. Saving your work as a
session file enables you to preserve the following:

Note:

• To use sessions, your system administrator must define ACL (access control list) rules for
Vis_Session using Access Manager. For details, see Configure Teamcenter Lifecycle Visualization
sessions in Teamcenter Visualization Deployment and Administration.

• If a document has been inserted into the session file, the session file becomes a stand-alone
Lifecycle Visualization AppSession and is not interoperable. Stand-alone Lifecycle Visualization
AppSession can be identified in other applications, such as Active Workspace and NX, by the
following icon .

• Open files

• Inserted 2D and 3D models and documents

• Pruned structures

• Session package

• Snapshot information

• 3D preferences

• Alternate assembly hierarchies

• True Shading settings

• Cross sections

• 3D Measurements

• User Defined coordinate systems

• 3D layers
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• Teamcenter revision rules, effectivity, variant rules, active assembly arrangements, and other
configuration settings.

Example:

You are working with model1.jt, model2.jt, and image.tif. You have created snapshots, changed
background colors, and created markup layers. You then save your work as a .vf session file.

When you re-open the session file, the three files open, and the snapshots, background colors, and
markup layers appear as they were when you saved the session.

Primary and secondary documents

Session files reference primary and secondary documents. A session file can preserve the state of
multiple primary documents, and each primary document may be associated with multiple secondary
documents.

Static and configured product structure

In terms of session files, product structure is considered to be either static or configured. Static product
structure is a unique version of the document that is created at the time the session is saved. This type

7. Understanding your work session
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of data ensures that loading the session at a later time will result in the same product structure that
was loaded when the session was first saved. Configured product structure is dynamic and references
Teamcenter configuration settings. This type of data can be thought of as a recipe which can be used
later to get different document revisions.

What is the difference between worksets and session files?

Worksets are a collection of design components that may contain subsets, items, item revisions, BOM
view, and BOM view revisions that represent existing parts or assemblies.

Session files save the state of the viewer so you can resume work on your workset later. Sessions retain
the filters and configurations applied to the structure and may contain worksets, snapshots, and other
documents.

Save your work session

You can save your work as a .vf session file. When you open the session file later, your work is restored.

Under certain conditions, warning messages display when saving legacy session files (release 12.4 and
earlier). To avoid overwriting the legacy session file, which will cause issues with legacy viewers, on the
warning dialog click Save as and choose a different file location to create a new session file.

Note:

If you want updated layers to be saved as external files, save the layers first using Save All Layers
or Save Selected Layer. If you don't save modified layers before saving the session, the layers
become part of the session file and cannot be loaded independently.

1. Choose File→Save Session.

2. In Session Storage Location, click one of the following.

Use this option To do this
Attach to Base
Document

Save the session within the Item Revision of the base document.

Attach to Selected
Bomline

Save the session within the Item Revision of the selected BOM line in
the 3D assembly tree.

Alternate location Save the session to a different location. Click Browse, and then specify
the folder, Item, or Item Revision within which you want to save the
session.

3. To rename the session file or any secondary documents that you have created during your work
session and not yet saved, such as markup layers, double-click the default name of the document
and type a new name.

Save your work session
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Note:

You cannot use any non-ASCII character (including 8 bit accented Western European and
multi-byte characters) for a file name.

4. To save the session file in a format that has interoperability between other applications, such as NX
and Active Workspace, select the Save as a collaborative session check box.

This check box is not displayed under the following conditions:

• When saving to a local file path.
• If the session contains data that is not supported by the AppSession interoperability data

model.
• If the TCVIS_SHOW_APPSESSION_SAVE_OPTION is set to False.

Note:

If a document has been inserted into the session file, the session file becomes a stand-
alone Lifecycle Visualization AppSession and is not interoperable. Stand-alone Lifecycle
Visualization AppSession files can be identified in other applications, such as Active
Workspace and NX, by the following icon .

5. Click Save.

The session file is saved. Any new or unsaved secondary documents are also saved with the session
file to their specified locations.

Note:

• If you have unsaved clearance results, the Save Clearance Results As dialog box appears.
You must save to a .txt file to reference the results in a session file.

• If late loading product views are enabled, and the Vis_PV_LateLoadSaveOp preference is
set to Ask, a dialog box appears in which you must choose how to handle saving partially
loaded product views.

• By default, in a four-tier environment, when you launch stand-alone Lifecycle Visualization
from the Teamcenter rich client, the viewer and the rich client share the same tcserver
session. When you perform stand-alone viewer operations, such as saving a session file,
the rich client may appear to lock up until the viewer operation is finished. If this is
a problem, you can configure Teamcenter to create a separate tcserver session for the
stand-alone viewer.

7. Understanding your work session
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• Ensure that your administrator has related the Vis Session dataset to the specific item
revision type that you plan to use for sessions. This enables viewing the session saved in
stand-alone Lifecycle Visualization in Teamcenter rich client.

Session save options

You have a number of options for saving session data to different locations, depending upon whether
the session consists of local data only or includes data from Teamcenter.

If the session includes only data loaded from your local machine, you can save the session file to a
location on your local machine or network.

If the session includes Teamcenter-managed data, you can save the session file to the Teamcenter server
in the following ways:

• Attach to Base Document — Save the session file within the item revision of the primary document.

• Attach to Selected Bomline — Save the session file within the item revision of the selected BOM line
in the 3D assembly tree.

• Alternate Location — Save the session file to a different location. Click Browse, and then specify the
folder, item, or item revision within which you want to save the session.

Session files can be saved using either the Vis_session data model or the AppSession data
model. The Vis_session data model supports all features but is not interoperable with other
applications, such as NX and Active Workspace. The AppSession data model has limited feature
support, but is interoperable with the NX and Active Workspace applications. AppSessions that
contain an unsupported feature, such as a multi-document session, appear in other applications
with the following icon . Your administrator can define the TCVIS_APPSESSION_SAVE_DEFAULT
and TCVIS_SHOW_APPSESSION_SAVE_OPTION environment variables to determine the Session save
behavior for your environment.

Note:

You can use the Teamcenter Integration Session preferences to specify default session save
options.

Saving legacy sessions and layers

Note:

This topic applies to Teamcenter lifecycle visualization release 13.0 and above.

Session save options
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Warning messages display when saving legacy session and layer files (created in release 12.4 and
earlier). The warning dialogs prompt you to Save as and choose a different file location to create a new
session or layer file.

Caution:

Legacy viewers cannot open session or layer files created in release 13.0 or higher, so do not
overwrite legacy files if these files might be opened in legacy viewers.

If you select the Do not show this message again check box, that specific warning dialog will not
display again and the action defaults to Save As.

Layer Compatibility Warning during Layer Save

The Layer Compatibility Warning displays when saving legacy layers independent of a session.

Session Compatibility Warning during Session Save

The Session Compatibility Warning displays when a legacy session is loaded and you select Save
Session to overwrite the original file.

7. Understanding your work session
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Unsaved Layer Warning during Session Save

The Unsaved Legacy Layer Warning displays when a legacy layer is loaded and modified and you
select Save Session or Save Session As. The Unsaved Legacy Layer Warning is followed by a Session
Compatibility Warning when a legacy session references a legacy layer that was modified prior to
selecting Save Session.

Overview of static and configured product structure

Product structure from Teamcenter is either static or configured. Configured product structure is
dynamically built according to revision rules, effectivity, variant rules, active assembly arrangements,
and other settings, depending on how the structure is initially launched and how the visualization
session is subsequently authored.

Configured structure

The following scenarios result in a configured structure in the viewer:

• From My Teamcenter, launch a BOM view or BOM view revision (or any object that includes a BOM
view or BOM view revision, such as an item or item revision) into the standalone viewer or the
Lifecycle Viewer. The structure is configured in the viewer according to your default revision rule.

• From the standalone viewer, open a BOM view or BOM view revision (or any object that includes a
BOM view or BOM view revision, such as an item or item revision). The structure is configured in the
viewer according to your default revision rule.

• From Structure Manager, Multi-Structure Manager, or Manufacturing Process Planner in the rich client,
launch one or more BOM lines into the standalone viewer or the Lifecycle Viewer. The structure
is configured in the viewer according to whatever configuration is currently active in the launching
application.

Static structure

The following scenarios result in a static structure in the viewer:

• Perform any process that results in opening a PLM XML file in the standalone viewer or the Lifecycle
Viewer. For example, launching a QL file or a DirectModelAssembly dataset results in the loading of a

Overview of static and configured product structure
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PLM XML file into the viewer. The viewer treats these data types as static structure, since a session file
authored in the viewer references the static PLM XML.

• Open a VF session file that points to static PLM XML. This occurs under the following conditions:

• The Capture Static Structure check box is selected when the session file is authored.

• The structure in the viewer is saved as PLM XML (File→Save As) before the session is authored.

VF session files and configured or static structures

Opening a session dataset can result in the loading of a static structure or a configured structure,
depending upon the data and the conditions under which the session authored.

When you save a session referencing configured structure, the session preserves the product structure
configuration active in the viewer. However, if you select the Capture Static Structure check box in the
Session Save As dialog box, the viewer also saves the exact product structure you have open at the
time you save the session. When you load the session later, the viewer detects if this static structure
is available and asks you how you want to open it: as a static structure (the exact product structure
that was active in the viewer at the time the session was saved) or a configured structure (according to
the configuration settings in effect at the time the session was saved). Note that if the Capture Static
Structure check box is not selected when you initially save the session, when you open the session
later the structure is loaded dynamically based on the configuration in effect at the time the session was
saved.

You can set a Teamcenter Integration Preference to automatically handle this when loading a session.
You can choose to:

• Always load the static structure

• Always load the configured structure (the latest version of the structure according to the configuration
settings in effect at the time the session was saved)

• Ask how to load a structure at load time

Merge a saved session with an active session

1. Start a new work session or open a session file.

2. In My Teamcenter, right-click a session dataset and choose Send To→Lifecycle Viewer.

If the sessions can be merged, the Merge Sessions dialog box appears.

3. Click Merge.

The saved session is merged with the contents of the active session.

7. Understanding your work session
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Specify session preferences

1. Choose File→Preferences→Session.

2. In the Session Preferences dialog box, change any of the following settings:

In this
section

Use this
preference To

Session
Merge

Reuse existing
windows if
possible

When opening a session while another session is active, merge
the sessions in the active Viewing window.

Note:

If this option is not turned on, the sessions are opened in
separate Viewing windows.

Ask at load time When attempting to open a session while another session is
active, display the Merge Sessions dialog box, from which you
can specify to merge the session into a single Viewing window.

Session
Save

Enable password
protection for
session package

Apply password protection to .vfz session packages.

Maintain
dynamic
references when
possible

When session files are opened, attempt to update linked
references.

Show
compatibility
warning

When a legacy session is loaded and you select Save Session to
overwrite the original file.

Show legacy
layer resave
warning

When saving legacy layers independent of a session.

Save as
collaborative
session when
available

Save session using the collaborative AppSession data model,
which allows session file interoperability between applications
such as NX and Active Workspace.

If the features contained in the session file are not supported
by the AppSession data model, you will receive a session
interoperability warning message.

This checkbox is enabled only when the current contents
can be saved with the AppSession data model and the
TCVIS_SHOW_APPSESSION_SAVE_OPTION environment variable
is not set to False.

Specify session preferences
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3. Click OK.

Understanding the differences when saving session files or PLM
XML files

Understanding the differences between session files and PLM XML files

When you create alternate hierarchies, add 3D markups to your model, or create snapshots that contain
extended 3D information (for example, camera orientations or behaviors), you can save your work using
either the .vf or .plmxml file types. With .vf and .plmxml formats you can save the information that
cannot be included in file types that you initially read into the application, such as .jt files.

In Teamcenter lifecycle visualization, both .vf documents and .plmxml documents can contain extended
session data (for example, materials, markups, and sections) as well as product structure. However,
the .vf file type is a binary format that cannot be created or altered outside Teamcenter lifecycle
visualization, while the .plmxml file type is XML, and as long as the contents of the file are structured
according to the PLM XML schema it can be created using any text editor.

The following terms are related to saving your work within Teamcenter lifecycle visualization:

This term Can be defined as

Model The in memory equivalent of a file.

Example:

A single assembly within a JT file.

Extended
content

Any data that is not stored in the original 2D/3D files.

Example:

3D information, such as visibility, transforms, materials, lights, sections,
behaviors, and markups.

Snapshot A container for storing subsets of extended content.

Example:

Captured 3D information, such as visibility, transforms, materials, lights,
sections, behaviors, and markups.

Document A container for one or more models and (optionally) extended content associated with
those models.

7. Understanding your work session
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Example:

• A PLM XML file. A .plmxml document is product structure and (optionally)
extended content associated with that document.

• A session file. A .vf file is a collection of one or more documents, each
containing product structure and (optionally) extended content associated
with those documents.

Overview of options when saving session files or PLM XML files

You have many options for persisting product structure and extended 3D content, including:

• Standard session file with .jt product structure

• Standard session file with .plmxml product structure

• PLM XML session file with .jt product structure

• PLM XML session file with .plmxml product structure

• Session Package File

Session documents (.vf) can be saved from the File menu using the Save Session or Save Session As
options. PLM XML documents can be saved from the menu using the Save As and Export options. You
can use the Save As option to create a .plmxml file that preserves all supported content from the active
3D Viewing window. Use the Export option to increase control over what is persisted in the .plmxml
file. You can specify what supported content to include and what supported content to leave out of the
exported file.

When saving session files, any derived documents that have not been saved at the time of the session
save, such as markups layers or motion documents, are saved with the session file to the same location.

Working with session packages

Overview of session packages

Session packages are compressed file archives that enable you to package your work session with any
referenced files. When you create a session package, you can specify to include any files referenced by
your work session. Once the session package is created on your local machine, you can easily move your
work to another location.

Generally, the maximum size of a session package file is 4GB; however other system factors may impact
this limit. For example, since lengths and offsets within JT version 9.x files are 32-bits, the limitation for

Overview of options when saving session files or PLM XML files
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packages with these files is 2.1GB. Files of JT version 10 and later have 64-bit offsets, so packages with
these files do not have this limitation.

The number of files that can be included in the session file are:

• In a 64-bit OS: Approximately 64,000 files

• In a 32-bit OS: Approximately 16,000 files

Save a session package

Save all of the files referenced by your work session as a .vfz session package on your local machine.

1. (To password-protect your session package) Click File→Preferences→Session, and then select the
Enable password protection for session package check box.

2. Choose File→Save Session.

The Session Save As dialog box appears.

3. In Session Storage Location, click Alternate Location.

Note:

You must save session packages on your local network or file system.

4. Click Browse and select the folder on your local machine where you want to save the file.

5. Select the Save as Session Package check box.

In Files section, the Package column appears with a check box for the document in the session.

Note:

You can save attachments only as session packages. If you have added attachments to the
work session, the Save As Session Package check box is selected automatically.

6. If you do not want to include a document in the package, clear the check box  beside the
document in the Package column.

7. If you want to save the most recent version of configured product structure, select the Capture
static structure check box.

8. Click Save.
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9. (If you turned on password protection) In the Password Option dialog box, type a password and
then click OK.

The session package is created and saved on your local machine.

Add attachments to session packages

Save attachments, such as Microsoft Office documents, with your session package.

Note:

Visualization files active in the session, such as open 2D or 3D files and layers, are automatically
included in the session package and do not need to be manually attached. Attachments enable
you to include files that are related but not compatible with Teamcenter lifecycle visualization,
such as spreadsheets or product specifications. When the session package is opened, you can
launch the attachments in their respective applications.

1. Choose File→Attachments.

2. In the Attachments dialog box, click Add.

3. In the Choose attachment file location dialog box, choose the file you want to attach to your
session package, and click Open.

The name of the file appears in the attachment list.

Note:

To delete an attachment, select the attachment, and then click Remove.

Open session package attachments

1. Open a session package containing attachments.

2. Choose File→Attachments.

3. In the Attachments dialog box, select the attachment and then click Open.

The attachment opens in the application associated with the file type.

4. (Optional) To save a copy of the attachment, select the attachment and then click Save Copy.

Specify the File Locate preferences for session packages

1. Choose File→Preferences→File Locate.

Add attachments to session packages
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2. On the General tab of the AutoFile Search Preferences dialog box, click Ask only when multiple
matches are found.

3. On the Document Search Order tab, select Relative File Directory Set and click Move Up until
the selection is the first item in the list.

4. Click OK.

Resolving broken references

Overview of broken references

Session files, PLM XML files, Teamcenter product views, constraint files, motion files, and animation
files contain references to entities in the product structure. As the product structure evolves during
the design process, the entity references in your saved files may no longer be valid. There are many
structure editing scenarios that can result in broken references; for example, a part is removed from the
structure and replaced with different part, or a part is moved from one subassembly to another within
the structure.

When you open or load a file that references entities, the viewer attempts to automatically resolve any
broken references it finds, but there are cases where the system requires your help to determine how to
resolve broken references. In those cases, the Broken References Warning dialog box appears. You can
then:

• Open the Reconcile Reference Dialog dialog box to see list of broken references, find reconcile
candidates, and manually resolve the broken references.

• Use previously saved mapping files to resolve the broken references.

Once you have resolved the broken references, you can re-save the file. You can also export a mapping
file and use it to resolve broken references in other files.

Resolve broken references manually

To manually fix a broken reference, select an unresolved reference, select a reconcile candidate, and
update the reference. You can then save the updated references to a mapping file and use it to fix broken
references in other files that reference the same data.

1. Do one of the following:

To Do this

Check for and resolve broken
references

a. On the Reconcile toolbar, click Reconcile .
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To Do this

b. On the Reconcile toolbar, click Validate all
references .

Resolve references when the Broken
References Warning dialog box
appears

Select the Open the Reconcile Reference dialog check
box and click OK.

Open the Reconcile References
Dialog dialog box

a. On the Reconcile toolbar, click Reconcile .

b. On the Reconcile toolbar, click Reconcile Broken
References .

The Reconcile References Dialog dialog box appears. Broken references are shown in the tree.

Broken references Intermediate broken references

Tip:

Double click on the resolved assembly reference in the Reconcile Reference Dialog to load
the corresponding assembly tree in the Project Workspace.

Resolve broken references manually
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2. (If you have more than one document open in the session) In the Reconcile Scope section of the
dialog box, select the document to work with from the Document list.

3. (Optional) If the dialog box appears because of broken references in a snapshot or group, you can
select the Context only check box to filter the tree to show only broken references referenced by
the snapshot or group.

4. Select a broken reference in the tree.

A list of possible reconcile candidates appears for the selected broken reference.

5. Do one of the following:

• If the candidate is on the list, select it.

• If the candidate is not on the list, use Find to search for other candidates, and then select the
candidate.

• Select the candidate part or assembly in the Viewing window.

• Select the candidate part or assembly node in the assembly tree in the Project Workspace
window.
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• If the broken node is no longer needed, and you want to permanently delete the reference from
the tree and the session, click Ignore.

Note:

If you ignore an intermediate broken reference, its children are ignored if not already
resolved.

6. To resolve the broken reference by mapping it to the selected candidate, click Update.

Note:

If you resolve an intermediate broken reference, the system tries to resolve its children
automatically.

7. (Optional) To undo a resolved or ignored reference, select the node and click Restore Original.

8. (Optional) In the Tree Display Options section, select or clear the Resolved References check box
to show or hide the resolved references.

9. To resolve another broken reference, select the reference in the tree and repeat the process.

Tip:

You can click Next and Previous to navigate through the tree.

10. Do one of the following to apply the changes:

• Click Apply to apply the changes and continue resolving references.

• Click OK to apply the changes and close the dialog box.

11. (Optional) On Reconcile toolbar, click Export to save the mapping to a mapping file.

12. To apply the new mappings for motion, animation, and Clearance files, save the session, and then
reopen it.

Search for reconcile candidates

You can search for reconcile candidates by item name or part ID. In Mockup, you can also use an
attribute filter to find candidates.

1. Select a broken node in the broken references tree. The node name appears in the text search box
next to the Find button.

If the candidate does not appear on the candidate list, you can type a search string to find.

Search for reconcile candidates
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2. Type the search string in the text search box. It is not case sensitive. You can use * as a wild card.

3. (Optional) Do one of the following:

• To limit the search scope, on the Assembly page of the Project Workspace window, select a node
to search. Everything below the selected node will be searched.

• (If the assembly is loaded from Teamcenter) To search for the candidates in the Teamcenter, set
the Use Teamcenter to find candidates, if available reconcile preference.

4. Click Find.

The search results are displayed in the candidate list.

The scope of the search is shown in the Find Scope box.

If necessary, you can click Stop to cancel the search.

Note:

Clicking Stop does not immediately cancel the search, as Teamcenter-based searches can
only be canceled at certain points in the search process. Once Stop is clicked, the search will
be canceled at the next available opportunity for termination.

5. (Optional) In addition to displaying the search results in the candidate list, you have options to
identify the candidates in the Viewing window and assembly tree. Choose one of the following
from the Show candidates in view list:

Choose this option To

None Do to nothing in the 3D Viewing window or assembly
tree.

Show Only Show only the selected candidates in the Viewing
window and highlight them in the assembly tree.

Select Only Select only the selected candidates in the assembly tree
and the Viewing window, and deselect all other parts.

6. (Optional) If searching for name or ID does not find the required candidate, you can use an
attribute filter to search for candidates. If the attribute search finds suitable candidates, select the
candidate and update the broken reference in the Reconcile Reference Dialog dialog box.

Export mapping files

After resolving broken references in a file, you can export a mapping file, and then use it to automatically
resolve broken references in other files that reference the same data.

7. Understanding your work session
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1. Open a file containing broken references to parts and assemblies.

2. Resolve the broken references.

3. On the Reconcile toolbar, click Export .

4. In the Save As dialog box, enter a file name, and then click Save.

Resolve broken references automatically with mapping files

After resolving broken references in a file, you can export a mapping file. You can then import the
mapping file to have it automatically resolve broken references in other files that reference the same
data.

Note:

If you import a mapping file before you open a file with broken references, the mapping are
applied automatically. If you import a mapping file after opening a file with broken references,
save the session and reopen it to apply the mappings.

1. On the Reconcile toolbar, click Reconcile .

2. On the Reconcile toolbar, click Import .

3. In the Open dialog box, select the mapping file and click Open.

4. Do one of the following:

• Open a file with broken references.

• If you already opened a file with broken references, save the session and reopen it to apply the
mappings.

The mapping file is searched for matches for each broken reference. If a match is found, the part or
assembly loads without incident. If a match is not found, you can manually resolve any remaining
broken references.

Validate references

When working with files that contain references to parts or assemblies, you can validate the references
to ensure that they still function.

Resolve broken references automatically with mapping files
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Example:

If you use session files to preserve snapshots of geometry, if the geometry changes the references
may break. Validating the session file tells you if your snapshots work properly, without activating
each snapshot.

1. On the Reconcile toolbar, click Reconcile .

2. On the Reconcile toolbar, click Validate All References .

A progress bar displays the progress of the file validation.

Note:

Click Cancel if you want to stop the validation before it is finished. However, if you cancel a
validation check, your file may contain broken references. Saving a file with broken references
may result in the loss of data.

If your file does not contain broken references, a message informs you that your product structure
references are valid.

3. If your file contains broken references, resolve them before saving the file.

Specify Reconcile preferences

Use the Reconcile preferences to specify whether or not an error message is displayed when a broken
reference is detected, and to customize the handling of candidate references.

1. On the Reconcile toolbar, click Reconcile .

2. On the Reconcile toolbar, click Preferences .

3. In the Reconcile Preferences dialog box, specify the following settings:

Use this option To

Provide a warning when references
break

Display an error message when a broken reference to
a part or assembly is detected. The error message only
appears for the first broken reference found.

Provide Candidates Display a list of potential replacements.

Use candidate if only one is found Use the candidate to resolve the broken reference
automatically if only one potential replacement is found.
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Use this option To

Maximum number of candidate
character differences

Specify the maximum number of characters that can
differ in a part or assembly name. You can specify a
maximum number of differences from the beginning of
a name, and from the end of a name.

Use any combination of beginning
and end

If you specify different values for the options
from beginning and from end, make the values
interchangeable.

Use Teamcenter to find candidates,
if available

If the assembly is loaded from Teamcenter, have Find
search for candidates in Teamcenter.

4. Click OK.

Mapping file guidelines

Change Reconcile mapping files adhere to the following structure:

• Map file version

• Locale

• CADID string

• NGID string

For example, a mapping file created in the English locale would resemble this:

Vis Product Structure Mapping File: Version 2

C

"CHLD0000\x00fishing_reel.asm;0;0:\x00handle_assembly_1.asm;0;0:\x00\x00"
 
"CHLD0000\x00fishing_reel.asm;0;0:\x00yyy_handle_assembly_1.asm;0;0:\x00\
x00" "$$NGID<child>=0\x00$
$NGID<chain>=\x22JT_INST_REFID_PDM\x22\x000_TOP_ASM\ 
x001_YYY_HANDLE_ASM\x00$$NGID<chain>=\x22JT_PROP_NAME\x22\x00CHLD0000\ 
x00fishing_reel.asm;0;0:\x00yyy_handle_assembly_1.asm;0;0:\x00\x00"

Map file version

The first line of the mapping file must specify the map file version. The current version is 2. However,
the only difference between version 1 and 2 mapping files is the inclusion of NGID strings, which can
be created only with Teamcenter lifecycle visualization. If you are creating mapping files outside of the

Mapping file guidelines
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Teamcenter lifecycle visualization application, specify version 1. The first line of the mapping file should
look like this:

Vis Product Structure Mapping File: Version 1

Locale

The second line must specify the locale.

Use this abbreviation For this locale

C English

de German

es Spanish

fr French

it Italian

JaPCK Japanese

ko Korean

ZhBIG5 Chinese (Traditional)

ZhGBK Chinese (Simplified)

CADID string (old and new)

The third and following lines must contain a pair of CADID strings, one for the original reference and one
for the updated reference. Each CADID string in the pair must be enclosed in quotes and separated by a
space.

Here is an example of a correctly formatted CADID string:

"CHLD0000\x00fishing_reel.asm;0;0:\x00handle_assembly_1.asm;0;0:\x00\x00"
 
"CHLD0000\x00fishing_reel.asm;0;0:\x00yyy_handle_assembly_1.asm;0;0:\x00\
x00"

Mapping file CADID strings must adhere to the following rules:

• CADID strings must be enclosed in double quotes (“).

• CADID strings must be NULL delimited. The NULL delimiter is represented by \x00.

• CADID strings must end in two trailing NULL delimiters.
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• ASCII values from 0 - 31 (decimal) and 176 - 255 (decimal), all non-ASCII characters, and the character
“ (ASCII value 34 (decimal)), must be converted to the following format for inclusion in the mapping
file:

\xHH, where HH is the hexadecimal ASCII value of the character or the hexadecimal value of the
current byte in the multi-byte character. Thus, if a multi-byte character has two bytes there will be two
values printed out. For example, \xAA\xBB.

NGID string (version 2 mapping files only)

In addition to original and updated CADID strings, version 2 mapping files contain NGID strings. NGID
strings appear after each updated CADID string. NGID strings are enclosed in quotes, and share the same
formatting rules as CADID strings.

Mapping file guidelines

Visualization on Rich Client ─ Getting Started, Teamcenter 2412  7-23
© 2025 Siemens



7. Understanding your work session

7-24  Visualization on Rich Client ─ Getting Started, Teamcenter 2412
© 2025 Siemens



8. Saving files and visualization datasets
Exporting 3D models

Overview of exporting 3D models

You can export 3D models in a variety of 3D formats:

• JT files and datasets

• PLM XML files and datasets

• VRML files and datasets

• NASTRAN BULK files and datasets

• ROBFACE files and datasets

Exporting JT files

Overview of exporting JT files and datasets

You can export 3D models in the JT format. You also can set options that affect how the model is saved.

Note:

• Only visible parts and the assembly hierarchy of those parts are saved.

• Lights assigned to the root node (the "Models" node in the assembly tree) are not exported
when you save a model as a JT file. To save a light source that is assigned to the root node, you
must move it at least one level lower in the assembly tree.

• Materials and material assignments are saved. To save material assignments to faces to the
Direct Model file format, the version must be set to v10.5 or greater.

• If you have directories containing hundreds or thousands of files, it may take a while for the
complete list of files to appear in the Export dialog box. You can press Ctrl-Break to stop the file
listing at any point.

Export JT files and datasets

Export 3D models in the JT format.

1. Display the parts that you want to save.
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2. Choose File→Export.

3. In the Export dialog box, browse to the location where you want to save the file, and enter a name
for the file.

Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

4. From the File Format list, select DirectModel (*.jt).

5. (Optional) In the Hierarchy list, select an alternate assembly hierarchy or inserted model.

Note:

If the 3D model does not include an alternate assembly hierarchy, then the Hierarchy list
only includes one choice, Model, which represents the original assembly hierarchy. You can
create alternate hierarchies using the Assembly tool.

6. (Optional) Click Options to change settings that affect file content and structure, and then click
OK.

7. In the Affected Files and Directories dialog box, review the list of affected files and directories, and
then click OK.

A progress bar appears as the model is saved. Upon completion, a message informs you if the
model was successfully saved.

8. Click OK.

Specify JT export options

You can set options that affect how the model is saved as a JT file.

1. Choose File→Export.

2. From the File Format list, select DirectModel (*.jt).

3. Click Options.

4. In the JT Export Options dialog box, edit any of the following settings:
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In this section Use this option To do this

File contents
and structure

Saving Choose one of the following assembly structure settings:

• Both assembly structure and parts: Save both the
assembly structure and parts.

• Assembly structure only: Save only the assembly
structure.

• Parts only: Save only the parts.

File structure Choose one of the following file structure settings:

• Standard (single assembly file, multiple part files):
Save using the standard JT file structure (single
assembly file, multiple part files).

• Shattered (multiple subassembly files, multiple part
files): Save using a shattered file structure (multiple
subassembly files, multiple part files).

• Monolithic (all data saved to a single file): Save
using a monolithic file structure (all data saved to a
single file).

• Maintain the current file structure: Save using the
current file structure.

Optional data Include
wireframe

If the model has wireframe data, include it in the
exported model.

Include PMI If the model has PMI, include them in the exported JT file.

Note:

JT versions higher than 9.7 do not support older
legacy PMI. If you select this option and attempt to
export a model with legacy PMI, and you choose
a JT version higher than 9.7, a warning appears
about data that cannot be saved. If you need the
PMI data, you can cancel the export and re-export
using a lower JT version.

Include precise
geometry

If the model has precise geometry (B-Rep or NURBS data),
include it in the exported JT file.

File format JT Version Specify the JT version.

Specify JT export options
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In this section Use this option To do this

Note:

• JT features introduced in a particular release
are not supported in earlier versions of the
application. However, with later version JT files,
you still may be able to view the geometry in
an earlier Viewer, although the application will
disregard unsupported features.

• When exporting assemblies, if any part in the
assembly is a JT version 8.0 or above higher,
the entire assembly is exported in the latest JT
version present in the model.

• HDR images used in light maps are not saved in
JT files.

Advanced
Geometric
Compression

Use compression to lower the file size of the exported
model. Type a value between 0.0 and 1.0 or use the slider
bar to adjust the amount of compression applied to the
exported model.

Embed images
in JT files

Specify how to save images used in texture maps and
light maps. Do one of the following:

• Select the check box to embed the images in the JT file.

• Clear the check box to save images as separate files in
the same location as the JT file.

Fix non-standard
characters in
filenames

Replace non-standard characters in filenames with
underscores.

Exclude disabled
bodies from
export when
possible

Determines whether disabled, yet visible, structures are
included when the assembly is exported. This option
does not affect structures with leaf bodies that contain
assembly-level geometry or assembly PMI which must be
present if the parent assembly is exported.

Alternate
Hierarchy Units

Determines the units set on the alternate hierarchy
assembly file when it is exported.

5. Click OK.

8. Saving files and visualization datasets
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Understanding advanced geometric compression

Turning on advanced geometric compression can lower the file size of exported JT files. The amount
of compression applied to the exported model corresponds to a specified value from 0.0 up to 1.0,
with compression disabled at 0.0 and maximized at 1.0. You also can use the slider bar to adjust
the compression level, with less compression applied as you move the slider to the left and more
compression applied as you move the slider to the right.

Regardless of the type of data in the model (tessellated, semi-precise, or precise), all values above 0.0
use advanced geometric compression. Measurement accuracy usually begins to be affected at values of
0.2 or 0.3. Visual accuracy typically begins to be affected at values of 0.4 or 0.6. These values are not
exact due to possible differences in model geometry.

The table below provides generalized descriptions of the effects of advance geometric compression at
different values.

Compression value Effect on geometry

0.0 Lossless compression with no effect on the measurement accuracy and
appearance of geometry.

0.1 Minimal lossy compression with little if any effect on the measurement accuracy
and appearance of geometry.

0.5 Moderate lossy compression with a noticeable effect on the measurement
accuracy and appearance of geometry.

1.0 Aggressive lossy compression with an obvious effect on the measurement
accuracy and appearance of geometry.

Understanding the Ultra-Lightweight Precise (ULP) format

The Ultra-Lightweight Precise (ULP) format is a lightweight, semi-precise representation of 3D geometry
in JT files. Due to their smaller size, ULP files load much faster than JT files containing full B-Rep
information, and are nearly as accurate.

ULP data provides you with the following benefits:

• Smaller file sizes than JT files containing full B-Rep data.

• Semi-precise geometry with a measurement accuracy that is much greater than tessellated geometry
and very close to full B-Rep data. Semi-precise measurements typically achieve a measurement
accuracy of 1e-5 meters.

• High quality surface geometry with little deviation of the normal direction or curvature distribution
from the original B-Rep geometry.

• Support for per-face color specifications.

Understanding advanced geometric compression
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• Support for PMI markups.

ULP compression settings

When creating JT files containing ULP data, it is important to understand the four possible ULP
compression settings that impact the size and accuracy of an exported JT file:

ULP compression
setting

JT precision (in
meters) JT size

0.001mm accuracy 1.E-05 50% larger than 0.1mm accuracy

0.01mm accuracy 1.E-05 ~ 1.E-04 25% larger than 0.1mm accuracy

0.1mm accuracy 1.E-04 Smallest practical JT file size (up to 100 times
smaller than CAD formats)

1.0mm accuracy > 1E-03 meters Smallest possible JT file size (more than 100 times
smaller than CAD model in many cases)

Note:

Semi-precise measurements that use ULP data are indicated by a tilde and an equals sign (~=) in
the measurement display label.

Exporting PLM XML files

Overview of exporting PLM XML files and datasets

You can export product structure as PLM XML. You also can set options that affect how the product
structure is saved.

Note:

• 3D parts cannot be saved as PLM XML. Use the Absolute File Path or Relative File Path PLM
XML export options to reference the original locations of your JT files, or use the JT Geometry
Creation option to create new JT files.

• You also can save extended 3D content to session files.

• Materials and material assignments are saved, except when the initial JT has assembly-level
assignments not authored in Teamcenter lifecycle visualization. In that case, those assembly-
level material assignments are not saved.

8. Saving files and visualization datasets
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• If you have directories containing hundreds or thousands of files, it may take a while for the
complete list of files to appear in the Export dialog box. You can press Ctrl-Break to stop the file
listing at any point.

Export PLM XML files and datasets

Export product structure as PLM XML.

1. Choose File→Export.

2. In the Export dialog box, browse to the location where you want to save the file, and enter a name
for the file.

Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

3. From the File Format list, select Product Structure (*.plmxml).

4. (Optional) In the Hierarchy list, select an alternate assembly hierarchy or inserted model.

Note:

If the 3D model does not include an alternate assembly hierarchy, then the Hierarchy list
only includes one choice, Model, which represents the original assembly hierarchy. You can
create alternate hierarchies using the Assembly tool.

5. (Optional) Click Options to change settings that affect file content and structure.

6. Click OK.

7. In the Affected Files and Directories dialog box, review the list of affected files and directories, and
then click OK.

A progress bar appears as the model is saved. Upon completion, a message informs you if the
model was successfully saved.

8. Click OK.

Note:

• If you have unsaved Clearance results, the Save Clearance Results As dialog box appears.
You must save to a .txt file to reference the results.

Export PLM XML files and datasets
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• If you have unsaved motion files, a Warning dialog box appears asking if you want to save
the changes to a file.

Specify PLM XML export options

You can set options that affect how the product structure is saved as PLM XML.

1. Choose File→Export.

2. From the File Format list, select Product Structure (*.plmxml).

3. Click Options.

4. In the PLM XML dialog box, edit any of the following settings:

On this tab Use this option To do this

General Product Structure Data Include product structure.

Product View Data Include product view data.

Current State of
Document

Include the current state of the document.
Provided they are within the current session,
you can specify to include any of the following
3D elements:

• Jack

• Camera Orientation

• Part Display Mode

• Visibility

• Selection

• Active Hierarchy

• Markup Layers

• Transforms

• Behaviors

• Layer Filters

8. Saving files and visualization datasets
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On this tab Use this option To do this

• Reference Sets

• PMI

• Material Assignments

• Light Assignments

• Texture Coordinate Assignments

• CAE

• Visual Report

• True Shading

• Exploded Views

• Coordinate System

• Cross Sections

• Constraint

• Measurements

• Volume Clipping

• Hide Obscuring

Document Description Include a description.

Product
Structure

Export

Visible Product Structure Save visible product structure only.

Complete Product
Structure

Save all product structure contained within the
model.

Include late loaded
attributes

Include the assembly-level attributes from
Teamcenter even if you have not downloaded
them for viewing. If not checked, only
downloaded attributes are saved.

Export Partition Schemes

Specify PLM XML export options
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On this tab Use this option To do this

All

Active

None

Specifies which partition schemes to export.
You can export all existing partition schemes
for the model or the active partition schemes or
none.

External References

Absolute File Path Save references using absolute file paths.

Relative File Path Save references using relative file paths.

JT Geometry Creation Export a JT file for each part reference. JT files
created using this option are saved in the same
location as the exported .plmxml file.

Product View [a list of your snapshots] Specify which snapshots to save with your file.

5. Click OK.

The changes are saved to the registry on your local system and become the default settings.

Exporting VRML files

Overview of exporting VRML files and datasets

You can export 3D models in the VRML 1.0 format. You also can set options that affect how the model is
saved.

Note:

If you have directories containing hundreds or thousands of files, it may take a while for the
complete list of files to appear in the Export dialog box. You can press Ctrl-Break to stop the file
listing at any point.

Export VRML files and datasets

Export 3D models in the VRML 1.0 format.

1. Choose File→Export.

2. In the Export dialog box, browse to the location where you want to save the file, and enter a name
for the file.

8. Saving files and visualization datasets
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Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

3. From the File Format list, select VRML 1.0 (*.wrl).

4. (Optional) In the Hierarchy list, select an alternate assembly hierarchy or inserted model.

Note:

If the 3D model does not include an alternate assembly hierarchy, then the Hierarchy list
only includes one choice, Model, which represents the original assembly hierarchy. You can
create alternate hierarchies using the Assembly tool.

5. (Optional) Click Options to change settings that affect file content and structure.

6. Click OK.

7. In the Affected Files and Directories dialog box, review the list of affected files and directories, and
then click OK.

A progress bar appears as the model is saved. Upon completion, a message informs you if the
model was successfully saved.

8. Click OK.

Specify VRML export options

You can set options that affect how the model is saved as a VRML file.

1. Choose File→Export.

2. From the File Format list, select VRML 1.0 (*.wrl).

3. In the Save As VRML dialog box, edit any of the following settings:

Use this option To do this

LOD Select the amount of detail to be saved:

• LOD: All Level of Detail

• LOD: Highest Level of Detail

Specify VRML export options
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Use this option To do this

• LOD: Lowest Level of Detail

Bounding Box
Only

Save simplified geometry for testing or review.

Use VRML
Instancing

Save the model with VRML instancing.

Example:

If you want to save four identical wheels, you can save the geometry
of one wheel and use instancing to represent the others in the model.

Backface Culling Save the model with visible polygons (positive vector) only.

4. Click OK.

Exporting NASTRAN BULK files

Overview of exporting NASTRAN BULK files and datasets

You can export 3D models in the NASTRAN BULK format.

Note:

• For the NASTRAN BULK (BLK) format, Teamcenter lifecycle visualization turns polygons and
tristrips from visible parts into triangles, and then translates them into the CTRIA3 element type.
Polyline sets or point sets are ignored.

• Different parts are assigned different PIDs (property IDs) in the exported file.

• Material properties, load cases, and boundary conditions are ignored. This means that the
exported BLK file cannot be used directly by NASTRAN for analysis purposes without manually
adding additional information.

• Teamcenter lifecycle visualization cannot load BLK files. The application can only export them.

• If you have directories containing hundreds or thousands of files, it may take a while for the
complete list of files to appear in the Export dialog box. You can press Ctrl-Break to stop the file
listing at any point.

Export NASTRAN BULK files and datasets

Export 3D models in the NASTRAN BULK format.

8. Saving files and visualization datasets
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1. Choose File→Export.

2. In the Export dialog box, browse to the location where you want to save the file, and enter a name
for the file.

Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

3. From the File Format list, select NASTRAN BULK (*.blk).

4. (Optional) In the Hierarchy list, select an alternate assembly hierarchy or inserted model.

Note:

If the 3D model does not include an alternate assembly hierarchy, then the Hierarchy list
only includes one choice, Model, which represents the original assembly hierarchy. You can
create alternate hierarchies using the Assembly tool.

5. In the Save As NASTRAN BULK dialog box, click OK.

6. In the Affected Files and Directories dialog box, review the list of affected files and directories, and
then click OK.

A progress bar appears as the model is saved. Upon completion, a message informs you if the
model was successfully saved.

7. Click OK.

Exporting ROBFACE files

Overview of exporting ROBFACE files and datasets

You can export 3D models in the ROBFACE format. You also can set options that affect how the model is
saved.

Note:

• Teamcenter lifecycle visualization cannot load ASY files. The application can only export them.

• If you have directories containing hundreds or thousands of files, it may take a while for the
complete list of files to appear in the Export dialog box. You can press Ctrl-Break to stop the file
listing at any point.

Overview of exporting ROBFACE files and datasets
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Export ROBFACE files and datasets

Export 3D models in the ROBFACE format.

1. Choose File→Export.

2. In the Export dialog box, browse to the location where you want to save the file, and enter a name
for the file.

Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

3. From the File Format list, select ROBFACE (*.asy).

4. (Optional) In the Hierarchy list, select an alternate assembly hierarchy or inserted model.

Note:

If the 3D model does not include an alternate assembly hierarchy, then the Hierarchy list
only includes one choice, Model, which represents the original assembly hierarchy. You can
create alternate hierarchies using the Assembly tool.

5. (Optional) Click Options to change settings that affect file content and structure.

6. Click OK.

7. In the Affected Files and Directories dialog box, review the list of affected files and directories, and
then click OK.

A progress bar appears as the model is saved. Upon completion, a message informs you if the
model was successfully saved.

8. Click OK.

Specify ROBFACE export options

You can set options that affect how the model is saved as a ROBFACE file.

1. Choose File→Export.

2. From the File Format list, select ROBFACE (*.asy).

3. In the Save As ROBFACE dialog box, edit any of the following settings:

8. Saving files and visualization datasets
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Use this option To do this

Save assembly file Include the assembly file (.ASY).

Include metadata for all nodes Include the metadata for each node of the assembly.

Save part files Include the part file (.JT).

LOD Select the amount of detail to be saved:

• LOD: High Level of Detail

• LOD: Medium Level of Detail

• LOD: Low Level of Detail

4. Click OK.

Saving 3D documents as PLM XML

Overview of saving 3D documents as PLM XML

In Standard, Professional, and Mockup, you can save 3D documents as PLM XML. You can use the Save
As option to create a PLM XML file that preserves all supported content from the active 3D Viewing
window.

In Professional and Mockup, the following apply:

• Functionality persisted with PLM XML includes extended 3D content such as transformations and
camera orientations, 3D snapshots, and product structure. Also included are references to motion
files, Clearance results files, JT files, and other PLM XML files.

• Use the Export option to increase control over what is persisted in the PLM XML file. You can specify
what supported content to include and what supported content to leave out of the exported file.

Use the PLM XML preferences to change options for how PLM XML files are saved.

Note:

• 3D geometry cannot be saved as PLM XML. To save parts as a supported 3D format, you must
use the Export option.

• You can also save 3D snapshot information as session files.

Overview of saving 3D documents as PLM XML
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• Materials and material assignments are saved, except when the initial JT has assembly-level
assignments not authored in Teamcenter lifecycle visualization. In that case, those assembly-
level material assignments are not saved.

Save the active 3D document as PLM XML

In Base, do the following.

1. Choose File→Save As.

2. In the Save File dialog box, browse to the location where you want to save the file, enter a name
for the file, and click Save.

The model is saved as PLM XML.

Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

In Standard, Professional, and Mockup, do the following.

1. Choose File→Save As.

2. (Optional, if the PLM XML Preferences are set to appear when you save a PLM XML file) Adjust the
PLM XML Preferences, and then click OK.

3. In the Save File dialog box, browse to the location where you want to save the file, enter a name
for the file, and click Save.

The model is saved as PLM XML.

Note:

• You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

• If late loading product views are enabled, and the Vis_PV_LateLoadSaveOp preference is
set to Ask, a dialog box appears in which you must choose how to handle saving partially
loaded product views.

Export the active 3D model as a PLM XML file

1. Choose File→Export.

8. Saving files and visualization datasets
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2. In the Export dialog box, In the File section, browse to the location where you want to export the
file, and enter a name for the file.

Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

3. In the File format section, select Product Structure (*.plmxml).

4. (Optional) In the Hierarchy section, select an alternate assembly hierarchy.

Note:

If the 3D model does not include an alternate assembly hierarchy, then the Hierarchy list
only includes one choice, Model, which represents the original assembly hierarchy. You can
create alternate hierarchies using the Assembly tool.

5. (Optional) In the Hierarchy section, select an inserted model.

6. Click OK.

A progress bar appears as the model is saved. Upon completion, a dialog box appears indicating
that the model was successfully saved.

Specify PLM XML preferences

1. Choose File→Preferences→PLM XML.

2. In the PLM XML Preferences dialog box, on the Save tab, change any of the following options:

Use this option To do this

Save extended 3D content
into PLM XML

Include extended 3D information captured with snapshots.

Save the default snapshot Save the .plmxml file with or without the default product view.
When unselected, the .plmxml file is created without the default
product view, which provides a faster save time and a smaller file.

Save inserted models Include inserted models.

Copy parts locally Create local part copies in the JT format.

Retain references to original
Product Structure

Keep the model's original product structure.

Specify PLM XML preferences
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Use this option To do this

Include late loaded
attributes

Include all assembly-level attributes from Teamcenter even if you
have not downloaded them for viewing. If not checked, only
downloaded attributes are saved.

Always ask at save time Open the PLM XML Preferences dialog box when you use save a
session file.

Convert 3D files to DirectModel

If you have the appropriate optional translators installed and licensed, when you open a 3D model file in
the following formats, the file is translated to the .jt file format:

• VRML (.wrl, .vrml)

• STL (.stl, .sla)

• IGES (.igs, .iges)

• STEP (.stp)

• DXF (.dxf)

• DWG (.dwg)

For DWG, DXF, and IGES files, surfaces are the only 3D objects translated to the .jt format. You can open
DWG, DXF, and IGES files that contain line drawings as 2D images.

1. Choose File→Convert Model.

Tip:

If you have directories containing hundreds or thousands of files, it may take a while for
the complete list of files to appear in the Open File to Translate dialog box. You can press
Ctrl-Break to stop the file listing at any point.

2. In the Open File to Translate dialog box, browse to the file, and click Open.

3. In the Choose File to Translate to dialog box, type a name for the translated file and browse to the
location where you want to save it.

8. Saving files and visualization datasets

8-18  Visualization on Rich Client ─ Getting Started, Teamcenter 2412
© 2025 Siemens



Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

4. (To open the file) Select Open File After Translation.

5. Click Save.

The file is translated into a JT file.

Save 3D markup layers

1. In the Assembly view, select the layer you want to save, right-click and choose a save option from
the list.

2. Choose one of these options:

Choose this option To save

Save All Layers All markup layers associated with the base document.

Note:

Modified markup layers are saved to their associated markup
datasets. New layers are saved to a new markup dataset.

Save Selected Layer Highlighted markup layer associated with the base document.

Save Selected Layer
As

Highlighted markup layer as a new markup dataset associated with the
base document.

Under certain conditions, warning messages display when saving legacy layer files (release 12.4
and earlier). To avoid overwriting the legacy layer file, which will cause issues with legacy viewers,
on the warning dialog click Save as and choose a different file location to create a new layer file.

3. In the Save dialog box, select or type the name of the markup layer file to save.

Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

4. Click Save.

Save 3D markup layers
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(If you chose Save All Layers) A new Save dialog box appears for each markup that you save.

Note:

When you create or edit a 3D layer, a pen and arrow icon  appears before the name of the
markup layer in the Markup Layers list until you save the layer. When you save the layer, the icon
disappears until the layer is edited again.

Save an image of a 3D model

Capture and save an image of a 3D model in a 2D raster format.

1. Display the model parts to include in the view.

2. Navigate the model until the Viewing window displays the view you want to save.

3. Choose Actions→Image Capture.

A 2D image of your model appears in your Viewing window.

4. Save the image as a .bmp, .tiff, .png, or .jpg file.

Save your 3D assembly as a text file

When you can save the assembly as a text file, you can choose to include all parts in the model, or only
those parts that are currently displayed.

1. Choose Tools→Assembly.

2. Expand or collapse the assembly until it displays the level of detail you want to save.

3. Choose Assembly→Save Indented, then and select Visible or Full.

Use this option To do this

Visible Save a text file that includes only the nodes for parts that are currently displayed

Full Save a text file that includes nodes for parts that are hidden and displayed

4. In the Save or Save As dialog box, browse to the appropriate file path.

8. Saving files and visualization datasets
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Tip:

If you have directories containing hundreds or thousands of files, it may take a while for the
complete list of files to appear in the Save As dialog box. You can press Ctrl-Break to stop the
file listing at any point.

5. In File name, type a name for the text file.

Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

6. Click Save.

Save a graphic for Teamcenter Content Management

You can save 2D images or 3D models so that they can be used as 2D graphics in print and online
publications that are managed in Teamcenter Content Management.

If the 3D model changes, you can recapture the image in Teamcenter lifecycle visualization to update it
in Content Management.

1. In Teamcenter, send a 2D image or 3D model to the standalone application viewer or the Lifecycle
Viewer.

2. In Teamcenter lifecycle visualization, choose File→Publish 2D graphic to Teamcenter Content
Management.

Note:

This option is available only if the graphic is stored in Teamcenter.

3. In the Graphic Option dialog box, do the following:

For this option Do this

Name Type a name for the graphic.

Graphic Usage Do one of the following:

• Select the Use Graphic Usages from Graphics Mapping
check box to use the graphic usages defined in the
ctm0GraphicUsagePref preference.

Save a graphic for Teamcenter Content Management

Visualization on Rich Client ─ Getting Started, Teamcenter 2412  8-21
© 2025 Siemens



For this option Do this

• Select the graphic usages that you want to assign to this
graphic option:

Caution:

Each graphic option of the same graphic file must
have unique usages. For example, do not use
piston.png and piston.gif both with the VIEW option.

If the graphic will be used for
this purpose

Select this graphic
usage

Icon in published output. ICON

High-resolution graphic in
printed output.

PDF

Graphic in a resolution
appropriate for the printer where
it will be printed.

PRINT

Small-scale image. THUMBNAIL

Low-resolution image, typically
for viewing only.

VIEW

Image to appear in a Web
browser.

WEB

Graphic Attribute Select the appropriate graphic attribute defined by your
application administrator.

Graphic Classname Select one of the following:

• Graphic—for non-S1000D content.

• S1000D Graphic—for S1000D content.

Language Select the languages for the graphics being saved, or choose
Multilanguage if the graphics have no specific language
associated with them. A separate graphic option will be saved
for each language you choose.

Note:

For S1000D graphics, select the site master language.
The S1000D standard does not require you to associate
a language with graphics, and the S1000D graphic

8. Saving files and visualization datasets
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For this option Do this

attribute mapping that is provided with the Content
Management installation does not support multiple
languages for graphics.

Overwrite Mode Select one of the following:

Note:

If you select neither overwrite mode, the graphic will
be saved as a new graphic if a graphic option with the
same Original Imported Name property and graphic
usage does not already exist in the system.

• Skip existing

The graphics are not saved if they already exist in Content
Management.

• Overwrite existing

If the graphics already exist in Content Management, they
are overwritten.

If you select Overwrite existing, select one of the
following usage handling options:

Tip:

To view the usages associated with an existing
graphic option, right-click the graphic option
revision, and choose View Properties.

Note:

Edit, publish, and export functions always use the
latest revision of graphic options. If you revise a
graphic, the new revision appears in all content that
it is referenced in. If you want to change a graphic
but you do not want the graphic updated in all
content, you must save the changed graphic as a
new graphic with a different name.

• Keep

Save a graphic for Teamcenter Content Management
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For this option Do this

The usages of the existing graphics are retained.

• Merge

The usages of the existing graphics are retained, and
the new usages selected for this save are added to
the graphics. For example, if a graphic being saved
already exists with the VIEW and WEB usages, and the
selected usages in the Graphic Options dialog box are
THUMBNAIL and ICON, the graphic is saved with the
VIEW, WEB, THUMBNAIL, and ICON usages.

• Overwrite

The usages of the existing graphics are removed and
replaced by the usages selected in the Graphic Options
dialog box.

4. Click Next.

5. In the Export Image dialog box, adjust the settings as needed.

Tip:

A resolution of 72 DPI is suitable for images to display on a monitor (email and web pages).
Use a resolution of at least 300 DPI for print content.

6. Click Finish.

Note:

If your organization uses watermarks, a watermark page may appear before you can click
Finish.

The graphic is saved in Teamcenter.

7. In Content Management, search for the graphic, and then move it to the folder where you want to
store it.

8. Right-click the graphic option revision, and choose Copy For Editor→Graphic Content.

9. In the editing tool, right-click the valid position in the topic where you want to insert the graphic,
and choose Paste.

8. Saving files and visualization datasets
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The graphic reference is inserted in the topic’s XML, using the tag information from your Graphic
Link Clipboard preference and the identifying information for the graphic file.

Update a graphic for Teamcenter Content Management

If you add a Teamcenter lifecycle visualization graphic to a topic in Teamcenter Content Management
and the 2D image or 3D model changes, you can recapture the image to update the graphic in Content
Management.

This procedure is also useful if you use the graphic in translated content and need to associate the
graphic with a different language.

Note:

• If you update a graphic that is included in published content, you must republish the content for
the update to appear.

• Edit, publish, and export functions always use the latest revision of graphic options. If you revise
a graphic, the new revision appears in all content that it is referenced in. If you want to change
a graphic but you do not want the graphic updated in all content, you must save the changed
graphic as a new graphic with a different name.

1. In Teamcenter, send a 2D image or 3D model to the standalone application viewer or the Lifecycle
Viewer.

2. Choose File→Publish 2D graphic to Teamcenter Content Management.

Note:

This option is available only if the graphic is stored in Teamcenter.

3. In the Graphic Option dialog box, adjust the settings as needed.

Tip:

• If you are using the graphic in translated content and need to associate the graphic with a
different language, select the language from the Language list.

• To update an existing graphic with modifications you make to a 3D model, select
Overwrite existing under Overwrite Mode, and then select one of the following usage
handling options:

• Keep

The usages of the existing graphics are retained.

Update a graphic for Teamcenter Content Management
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• Merge

The usages of the existing graphics are retained, and the new usages selected for this
save are added to the graphics. For example, if a graphic being saved already exists with
the VIEW and WEB usages, and the selected usages in the Graphic Options dialog box
are THUMBNAIL and ICON, the graphic is saved with the VIEW, WEB, THUMBNAIL, and
ICON usages.

• Overwrite

The usages of the existing graphics are removed and replaced by the usages selected in
the Graphic Options dialog box.

4. Click Next.

5. In the Export Image dialog box, adjust the settings as needed.

Tip:

A resolution of 72 DPI is suitable for images to display on a monitor (email and web pages).
Use a resolution of at least 300 DPI for print content.

6. Click Finish.

Note:

If your organization uses watermarks, a watermark page may appear before you can click
Finish.

The graphic is saved in Teamcenter.

Save 2D layers

1. In the Assembly view, select the 2D layers you want to save.

2. From the File menu, choose an option:

Use this option To do this

Save All Layers Save each 2D layer independently.

Save Selected Layers
As

Save selected 2D layers with a new file name.

8. Saving files and visualization datasets
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Tip:

You can select layers by clicking the layer in the Assembly view.
To select multiple layers, hold the Ctrl key while you click.

Export Combined
Layers

Save all selected 2D layers as one 2D layer file.

3. In the Save dialog box, select or type a file name.

Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

4. In Save as type, choose a CGM version.

The 2D layer is saved with a .cgm file extension.

Note:

If you selected multiple 2D layers and chose the Save Selected Layers As option, you are
prompted with more than one Save As dialog box.

Export images, create watermarks, and save 2D images

1. Choose File→Export Image.

2. From the Export Image dialog box, choose from the following options:

On this tab Use this option To do this

Export Export Export your view as one of the following:

• Image – the application exports the entire
image, including markup layers. For example,
even if the Viewing window displays only
a portion of the complete image, the
application saves the complete image.

• View (WYSIWYG) – the application exports
just the viewable image from the Viewing
window only.

Export images, create watermarks, and save 2D images
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On this tab Use this option To do this

• Page Extents - the application exports what
is within the active page extents rather than
what is in the Viewing window extents.

This option is available when the Enable
Page Extents check box on the Page Extents
dialog box is selected.

• Document – the application exports the
entire document, including all pages and
markups as either PDF or CGM.

Note:

• When you export a PDF file as a PDF
file, an exact copy of the input PDF
file is exported. That is, the original
quality of the PDF is exported.

• When you export a PDF file as
a Document file, changes in text
output, for example background
color, are not supported.

Resolution Change the dots per inch (DPI).

Note:

Increasing the resolution does not
improve the quality of the output for 2D
raster files; it only increases the file size.

Retain dpi Check Retain dpi to store and retain your
selected dpi setting in the registry. This value
is recalled each time you navigate to Export
Image.

If the option is cleared, the application
calculates an appropriate dpi.

Units Choose the units of measurement in which to
export the image.

Ratio to Original Image Select the percentage of size the exported
image will appear compared to the original
image.

8. Saving files and visualization datasets
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On this tab Use this option To do this

Color Mode Select one of the following modes:

• Black and White

• Grayscale

• Color

Type Choose a file type from the list.

Note:

• Exporting TIFF images:

• To export 1-bit TIFF white-out layers,
from Type select tif, and from Color
Mode select Black and White.

Select Enable masking / white-out
to enable white-out effects. Clear
this option to bypass the white-out
capability.

• When you export an image to TIFF,
the output file conforms to TIFF 6.0
standards.

• If you select TIFF with a Black and
White Color Mode, the output file
compression standard is TIFF CCITT
Group 4.

• Exporting Color and Grayscale images:

• Color and Grayscale are supported
for JPEG files (.jpg). Color is
supported for JPEG 2000 (.pg2
and .jpc) files.

• Exporting HP RTL images:

• To export HP RTL images, from Type,
select hpgl.

• Exporting JPEG images:

Export images, create watermarks, and save 2D images
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On this tab Use this option To do this

• Select the quality level of an
exported JPEG by setting the value
from 1–100.

The default is set at 98. When you
increase the quality of the image
by increasing this value, you also
increase the size of the file. You
can often decrease the file size
and maintain acceptable results by
lowering the value.

Output Format Specify the type of PDF output. This option is
available only when PDF is selected in the Type
field.

Colorspace Specify which color model is used to create the
various printing colors for PDF/A output types.
This option is available only when one of the
PDF/A output types is selected in the Output
Format field.

Compression Specify a compression option for a color or
grayscale TIFF file.

Tip:

• From the list, click one of
these options; None, PackBits, or
Deflate(ZIP).

• Choose a compression standard that is
supported by your viewer.

Watermark Watermark Activate the watermark option.

Font Click one of the following:

• Select Font, to choose a font name, style,
size and color.

• Auto Scale Font Size, to automatically fit the
text to the available space.

Watermark Add watermark text.

8. Saving files and visualization datasets
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On this tab Use this option To do this

Note:

For additional watermark options, right-
click, point to Insert and choose one of
following:

• Date

• Time

• File

• Path and File

• UserID

• Page

Note:

If the administrator creates an MDS file,
the Watermark option is unavailable.

Watermark text location Choose the direction of the text.

Note:

The text can appear diagonally, from
lower left to upper right or upper left to
lower right, or it can appear horizontally
in the center of the document.

Opaque Render the text as solid.

Note:

• A watermark that covers the
underlying document appears on the
printed document.

• When you export a PDF file as
a Document file, opaque is not
supported.

Export images, create watermarks, and save 2D images
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On this tab Use this option To do this

Transparent Render the text as half tone.

Note:

• 50% of the underlying document
appears on the printed document.

• When you export a PDF file as a
Document file, transparent is not
supported.

Background Color Select a background color for your Watermark.

Note:

• By default, Background Color is
unchecked.

• By default, white is the selected
background color.

• When you export a PDF file as a
Document file, background color is not
supported.

3. Click OK.

A second Export Image dialog box appears.

4. (Optional) Specify a new file name and, if necessary, browse to a directory in which you want to
save the file.

Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

5. Click Save.

The 2D image is saved with the file name and extension you specified. The original image is
unchanged.

8. Saving files and visualization datasets
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Note:

You can use any of the following features when you export (save) a 2D image:

• Save the 2D image exactly as it is displayed in the Viewing window (a zoomed in view, for
example). You can also save the entire 2D image and any markup layers associated with it.

• Export the 2D image to other supported file format, for example export a TIFF file and convert it
to PDF.

• Create a Watermark that is placed on the 2D image. The watermark is saved on all pages of your
2D image.

• Export document files using PDF or CGM file type options. In each instance, you can export
multiple-page documents.

Export images, create watermarks, and save 2D images
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Vector images are not affected by resolution settings. Notice that Resolution has been removed
from the Output section of the Export Image dialog box for vector output.

8. Saving files and visualization datasets

8-34  Visualization on Rich Client ─ Getting Started, Teamcenter 2412
© 2025 Siemens



Creating uniform watermark stamps when exporting files

Save 2D layers using Image Capture

You can use Image Capture to capture the view of your image exactly as it is displayed in the Viewing
window, including all visible markups. The captured image appears in a new Viewing window. You can
then save this view.

1. Choose Actions→Image Capture.

2. Save the Image Capture in one of the following ways

Save 2D layers using Image Capture
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• Choose File→Save All Layers.

• After closing the Viewing window, click Yes when the application prompts you to save changes.

3. In the Save As dialog box enter a name for the file in File name.

Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

4. In Save as type, select the CGM version of your choice.

5. Click Save.

The application displays the saved Image Capture in the Viewing window.

Note:

For best results when viewing the image with markups, zoom the image to a 1:1 scale.

6. To save the image in Metaphase, choose File→Save All Layers.

7. The Save dialog box appears, prompting you to type a name for each layer file.

Note:

You cannot use any non-ASCII character, including 8 bit accented Western European and
multi-byte characters, for a file name.

8. Click Save All Layers.

The layer files are saved in Metaphase with a .png extension.

PVL files

Save 2D images as PVL files

You can save the currently displayed 2D image as a text file by generating a .pvl file or macro. You can
save the .pvl as a file on disk or you can automatically send it to a user-defined macro. The .pvl text file
gets binary or PDF data by pointing to or referencing the location of the source file.

1. Choose File→Export Image View List.

2. From the Export Image View List dialog box, select from the following options:

8. Saving files and visualization datasets
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Choose this option Then do this

Save to File a. In the Specify Filename dialog box, in
File Name, type a name for your file.

Note:

You cannot use any non-ASCII
character, including 8 bit accented
Western European and multi-byte
characters, for a file name.

b. In Save as type, select PVL Files (*.pvl).

c. Navigate to where you want to store the
file and click Save.

Execute Macro No further action is necessary.

Note:

• When you execute the macro, the
information is saved in a temporary
directory. This directory is then
emptied when you exit the program.

• If the EAI_SAVE_PVL_MACRO
environment variable is not defined,
you cannot execute the macro and an
error message will appear.

The .pvl file is generated.

Generated .pvl example

You can use the following .pvl text file to get an understanding of how these files are coded.

# ViewList { background job ... } # create ViewSet # # load the 
base layer document into the view: Sheet Open BaseLayer "C:\Program 
Files\EAI\OEV\Examples\2d\biggear1.dwg" # # load layer 1 into the 
view: Sheet Open Layer1 "C:\Temp\VisProd18027c\vvBGPrintTmp0\layer1.cgm" 
# # load layer 2 into the view: Sheet Open Layer2 
"C:\VisProd18027c\vvBGPrintTmp0\layer2.cgm" # # Open the document: 
ViewSet Open ThisViewSet BaseLayer Layer1 Layer2 # Viewport settings of 
the view: ViewSet Set Viewport ThisViewSet Absolute 8.956356 8.532558 
26.922378 22.564855# Base Layer Page: 1 of 1 # Base Layer Width: 
26.922378 # Base Layer Height: 22.564855 

Generated .pvl example
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Code explanation

• General Notes

• Comment records begin with the "#" character.

• In the following, the term "layer" refers to both the original and markup layers to be written to
the .pvl file from the Viewing window.

• # ViewList {comment text}

• This message must be the first line in a View List file and the syntax is specific.

• "comment text" can be any comment or nomenclature.

• The "{ background job ... }" string will identify .pvl files generated from the Export Image View List
command.

• # Sheet Open

• Each sheet will have a unique name and will identify one file.

• This command will appear for each layer that is to be written to the .pvl file from the active view.

• The base layer will be identified first, followed by the added markup layers.

• The markup layers are saved as temporary files and are automatically deleted when the application
exits.

• # ViewSet Open

• After opening an individual sheet for each layer in the view, this command combines the sheets
into a single view.

• Each ViewSet will have a unique name (up to 40 characters) and will reference all layers visible in
the view. For Export Image View List PVL files, this will always be "ThisViewSet."

• # ViewSet Set Viewport

• The name of the ViewSet is again identified.

• The key word "Absolute" identifies that the numbers that follow are real numbers that identify the
following coordinate pairs:

■ x and y coordinates for the center of the viewport (uses units from the sheet)

8. Saving files and visualization datasets
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■ x and y indicating the width and height of the viewport (uses units from the sheet)

• #Base Layer Page

• The page of the base layer currently being viewed

• #Base Layer Width

• The width of the base image.

• #Base Layer Height

• The height of the base image.

Setting PVL macro environment variables

Purpose

When you export an image to a macro, the program uses a .pvl file type. You declare which program
the .pvl file is passed to by setting the EAI_SAVE_PVL_MACRO environment variable. You can also
specify how you want the PVL layers to be processed by setting the EAI_SAVE_PVL_LAYERS
environment variable.

Add an environment variable

1. Choose Start Menu→Control Panel.

The Control Panel dialog box appears.

2. Select Performance and Maintenance and then select System, or just select System.

The System Properties dialog box appears.

3. Select the Advanced page.

4. Click Environment Variables.

The Environment Variables dialog box appears.

5. From User Variables, select New.

The New User Variable dialog box appears.

6. In Variable Name, type: EAI_SAVE_PVL_MACRO.

7. In Variable Value, type the value of the executable.

Setting PVL macro environment variables
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8. Click OK.

9. In the Environment Variables dialog box, click OK.

Set the environment variable for PVL layers

• The environment variable is EAI_SAVE_PVL_LAYERS.

• To add all layers

In Variable Value, type ALL.

• To add only visible layers

In Variable Value, type VISIBLE.

Sample .pvl file.

8. Saving files and visualization datasets
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9. Emailing your work
Capture and email an image of the Viewing window

Note:

To send email from the viewer through a MAPI email program like Microsoft Outlook, the MAPI
program must be 64-bit. If it is not, you get a warning message and no message is sent.

Choose File→Send Mail→Image Capture File.

A .png image capture of the Viewing window is created and attached to a new email message.

E-mailing your work session as a .vfz collaboration file

Overview of emailing your work session

You can package all of the files involved in your work session into a single .vfz collaboration file, which
you can email to other members of your organization. You can specify to package the session contents
of all open Viewing windows or only the contents of the active Viewing window.

Note:

• To create .vfz collaboration files, you must have the Professional or Mockup service level, along
with an additional .vfz collaboration file license.

• You can open .vfz collaboration files in any viewer service level.

• You can edit, repackage, and re-send the data from existing collaboration files if you have the
Standard, Professional, or Mockup service level.

• To send email from the viewer through a MAPI email program like Microsoft Outlook, the MAPI
program must be 64-bit. If it is not, you get a warning message and no message is sent.

Introduction to .vfz collaboration files

You can use the .vfz collaboration format to share your work with suppliers or other members of your
organization. A .vfz collaboration file consists of the visible contents of the active Viewing window or all
open Viewing windows, including externally referenced files and attachments.

It is important to understand the distinction between creating new .vfz collaboration files and editing
existing files. Creating entails opening, inserting, or merging 2D and 3D documents, which are packaged
as a new .vfz collaboration file and sent to collaborators; it requires the Professional or Mockup service
level, along with an additional .vfz collaboration file license. Editing consists of repackaging the data
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from an original .vfz file with new content, such as markups, snapshots, groups, and measurements; it
requires the Standard, Professional, or Mockup service level.

Creating .vfz collaboration files

After you open documents from your local file system or Teamcenter, you can package the data as a
new .vfz collaboration file and send it to your collaborators. Creating .vfz collaboration files requires the
Professional or Mockup service level, along with an additional .vfz collaboration file license.

The following components are included in collaboration files:

• Copies of 2D image files

• Copies of visible 3D parts

• Attachments

• A .vfz session file that includes an automatically generated snapshot

Note:

If you are working with files in multiple Viewing windows and the collaboration preferences are
set to package all views, a snapshot is included for each Viewing window. These snapshots
persist the state of the data visible in the Viewing windows. If you have created other
snapshots, they are not included in the packaged file because they may reference parts that
are not currently visible, which would result in a reconcile problem for the email recipient.
However, you can include new snapshots when editing an existing .vfz collaboration file.

Editing .vfz collaboration files

After you receive a .vfz collaboration file and review its contents in your visualization client, you can
edit the data from the file and then re-send it. Edits can consist of content such as markups, cross
sections, and groups. Because the scope of the data is limited, you also can include new snapshots in the
repackaged file. If you have the Standard, Professional, or Mockup service level, you can edit, repackage,
and re-send the data from existing collaboration files.

When you edit .vfz collaboration files, you cannot add new 2D or 3D documents to the session. This
invalidates the edits and disables the option for sending the file.

Example:

You receive a collaboration file, which you open in your Viewer. The file consists of a 3D model,
a 2D image, markups, and a snapshot. After creating new markups, performing measurements,
and capturing new snapshots, you choose File→Send Mail→Collaboration File. The data from
the original .vfz file is repackaged to include your edits and is attached to a new email message,
which you can send back to the person who initially sent you the file or to someone else.

9. Emailing your work
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Create and send .vfz collaboration files

1. In the 3D Viewing window, display the content that you want to include in the session package,
such as parts, 3D markups, and groups.

Note:

Only visible parts are included in the collaboration file. Snapshots are not packaged in new
collaboration files because they may reference parts that are not currently visible, which may
result in a reconcile problem for the recipient of the file.

2. Adjust the options for the creation of .vfz collaboration files:

a. Choose File→Preferences→Collaboration.

b. On the Packaged Collaboration File Preferences dialog box, choose one of the following
options to package the session contents of the active Viewing window only or the contents of
all open Viewing windows:

• Active View

• All Views

c. (Optional) Select the Enable password protection check box.

d. Click OK.

3. (Optional) Add attachments, such as Microsoft Office documents, to .vfz collaboration files:

a. Choose File→Attachments.

b. In the Attachments dialog box, click Add.

c. In the Choose attachment file location dialog box, choose the file you want to attach to your
work session or session package, and click Open.

Tip:

To view the contents an attached file, select the file in the Attachments dialog box and
click Open.

4. Choose File→Send Mail→Collaboration File.

Your work session is packaged as a .vfz file and attached to a new email message. If you turned on
password protection, a dialog box appears asking you to provide a password for the file before it is
created.

Create and send .vfz collaboration files
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5. Send the email message to your recipient.

Note:

To send email from the viewer through a MAPI email program like Microsoft Outlook, the MAPI
program must be 64-bit. If it is not, you get a warning message and no message is sent.

Open and view e-mailed .vfz collaboration files

When you receive an email message containing a .vfz collaboration file, you can open and view the work
session and any attachments.

1. Open the email message.

2. Double-click the attached collaboration file.

The work session opens in your Lifecycle Visualization viewer.

3. (Optional) To view any files attached to the session, do the following:

a. Choose File→Attachments.

b. Select the attached file and click Open.

Edit and re-send .vfz collaboration files

After receiving an email message containing a .vfz collaboration file, you can open work session, make
changes and additions, and then email a repackaged collaboration file.

1. Open the email message.

2. Double-click the attached collaboration file.

The work session opens in your Lifecycle Visualization viewer.

3. Add content that you want included in the repackaged collaboration file, for example, 3D markups,
groups, or snapshots.

Note:

When you edit a .vfz collaboration file, you cannot add new documents to the work session;
you can only edit documents included in the original file. A .vfz collaboration file license is
required to add new documents to an existing file.

4. When you are ready to re-send the updated work session, choose File→Send Mail→Collaboration
File.

9. Emailing your work
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The .vfz collaboration file is repackaged and attached to a new email message.

5. Send the message to your recipient.

Note:

To send email from the viewer through a MAPI email program like Microsoft Outlook, the MAPI
program must be 64-bit. If it is not, you get a warning message and no message is sent.

Specify output preferences for .vfz collaboration files

1. Choose File→Preferences→Collaboration.

2. On the Packaged Collaboration File Preferences dialog box, do any of the following:

To Do this

Include only the contents of the active
Viewing window in the .vfz file.

Choose Active View.

Include the contents of all of the open
Viewing windows in the .vfz file.

Click All Views.

Turn on password protection for .vfz
files.

Select the Enable password protection check box.

Note:

When you create a .vfz collaboration file, a dialog
box appears asking you to provide a password for
the file before it is created.

Show the data that will be included in
the .vfz file.

Select the Review content before sending check box.

3. Click OK.

Specify output preferences for .vfz collaboration files
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10. Printing
Overview of printing

You can print your current view of a 2D image or 3D model. In addition to using standard printing
functionality, you can do the following:

• Preview before printing.

• Configure page headers and footers.

• Add watermark stamps.

• Add date and time stamps.

• Print using the HP Raster Transfer Language (RTL).

Preview images and models before printing

You can preview images and models to display each page as they will look when printed.

1. On the Printing toolbar, click Print Preview .

A preview of what will be printed appears in the Print Preview dialog box.

2. (Optional) In the Viewing window, manipulate the model or image.

Changes are displayed in the Print Preview dialog box.

3. (Optional) To change the printer configuration and options, click Setup.

4. (Optional) Click Print.

Your file is sent to your specified printer.

Print your current 2D or 3D view

You can preview and print images and models that are displayed in the Viewing window.

1. (Optional) Preview documents to display as they look when printed.

2. From the Printing toolbar, click Print .

Visualization on Rich Client ─ Getting Started, Teamcenter 2412  10-1
© 2025 Siemens



3. In the Print dialog box, specify options in the following ways:

On this tab
Choose this

option Then do this

Print Name Select a printer to print the documents.

Tip:

Click Properties to view and modify available
printer options.

Tip:

To print embedded Hewlett Packard Raster
Transfer Language images, you must select an
HPGL printer or plotter.

Default print
settings

Select one of the following:

• To use the default print settings, click Print Defaults.

• To use the print settings used the last time you printed,
click Last Used.

• To save the current print settings, click Save As, and in
the Save Settings dialog box, type a name for the print
settings, and click Save.

Open
Documents

Select the names of open documents that you want to
print.

Tip:

You can also choose Select None to clear all
selections, or Select All to select all documents.

If your document is multipaged, you can use the Page
command button to display the Page Selection dialog
box. Use the Print Range you can choose to print All
pages, to print a range of Pages, or to print the Current
page.

Print Layout Orientation Select one of the following page layouts:

• Portrait

• Landscape

10. Printing
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On this tab
Choose this

option Then do this

• Best Fit

Note:

If you choose Best Fit, all pages print with the
same orientation.

Print Scale Select one of the following print scale options:

• Fit to Page

• 1:1 scale

• Scale

Tip:

Use the arrows to increase or decrease the scale
percentage, or type in a percentage.

Roll Plotter Select one of the following:

• Roll Paper Auto Size

The system calculates the paper length needed to fit
the plot. The limitation is the maximum length of a
custom page, which is 129 inches.

• Bypass Printer Driver

This option bypasses the Printer driver during the
printing process. The 129 inch limitation is removed,
but you may experience decreased image quality.

Printer
Language Note:

The Printer Language option is only available
when you select Bypass Printer Driver from Roll
Plotter.

Select one of the following:

Print your current 2D or 3D view
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On this tab
Choose this

option Then do this

Language Issues

PostScript PostScript data is not compressed, resulting
in larger data files.

HP-GL/2 None.

Calcomp Prints 906/907 with images.

C4 Prints monochrome color only.

MIL-R Prints monochrome color only.

CGM None.

TIFF Prints color.

Quality Do one of the following:

• Move the slider to improve the clarity or readability of
images previewed or printed.

• Print Image

Moving the slider to the right may improve the print
quality of some images.

• Preview Image

Moving the slider to the right may improve the
readability and clarity of some images.

Select Auto Calculate Print Quality to have the software
calculate a solid balance between printing speed and
quality for each print job.

Special Settings Select the following:

• Select Print as Monocolor to print any image (color or
grayscale) black and white.

• Select Print Full View to always print the entire image
even if you zoom in or out on the image.

Advanced Image
Alignment

Specify where you want an image placed (printed) on the
page.

Margins Set page margins before printing.
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On this tab
Choose this

option Then do this

Treat 2D Vector
as Raster

Select or clear letting the software handle how the text is
sent to the printer.

Note:

This setting is useful when printing Vector images
that contain font style and font characteristics that
are not supported by the local computer.

If the Vector image includes a font style that is not
supported by the local computer, the software tries
to select a close approximation of the font. This
may result in text output that is slightly off.

2D Line Font
Relative Spacing

Select this setting to print dashed lines.

Note:

The patterns of font lines are not a fixed size. They
are sized relative to the size of the output.

MDS File
Settings

Select Page Centric to set MDS position values to
absolute.

Example:

A starting point for copyright text is set to one inch
from the top left corner of the page.

The text will always be at this location regardless of
the size of the page.

Select Geometry Centric to scale the location and size of
the text with the rest of the image.

FlowCharter Don't print blank
pages

Specify printing fewer pages in long flow charts.

Single Flow
Chart

Specify printing a chart as a standalone entity.

Note:

If links to other charts exist, a displayed icon
represents the link to these charts.

Print your current 2D or 3D view
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On this tab
Choose this

option Then do this

Linked Flow
Chart

Specify printing multiple-linked flow charts side-by-side.

Header and
Footer

Font To make the Header or Footer section available, select
one or both of them.

Click Select Font, and then choose a font name, style,
size, and color.

Header Type the header text in the space provided.

• For additional header options, right-click, point to
Insert, and then choose one of following:

• Date

• Time

• File

• Path and File

• UserID

• Page

Footer Type the footer text in the space provided.

• To make the Header or Footer section available, select
one or both of them.

• For additional footer options, right-click, point to
Insert, and then choose one of following:

• Date

• Time

• File

• Path and File

• UserID

• Page
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On this tab
Choose this

option Then do this

Watermark Font Select Watermark to make these options available.

Choose Select Font to select a font name, style, size, and
color.

Select Auto Scale Font Size to automatically fit the text
to the available space.

Watermark Type the watermark text in the space provided.

• For additional watermark options, right-click, point to
Insert, and then choose one of following:

• Date

• Time

• File

• Path and File

• UserID

• Page

Note:

If the administrator creates an MDS file, the
Watermark option is unavailable.

The button to the
left of
Watermark text
location

Choose the direction of the watermark text.

Note:

Options include text that is displayed diagonally,
from lower left to upper right or upper left to lower
right, or horizontally in the center of the page.

Opaque No further action is required.

Note:

An opaque watermark can cover text and graphics.

Print your current 2D or 3D view
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On this tab
Choose this

option Then do this

Transparent No further action is required.

Note:

A transparent watermark lightly covers text and
graphics. About 50% of the covered data displays
on the printed document.

Background
Color

Check Background Color, and then select a color.

Note:

• By default, Background Color is unchecked.

• By default, the background color is white.

4. Click Print.

Note:

• If your administrator created a Watermark stamp or Header and Footer, the Watermark and the
Header and Footer tabs are unavailable.

• The FlowCharter tab only appears if you are printing a Flowcharter file.

Watermark page example

The following graphic illustrates the result of using various options from the Watermark page.
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Print HP Raster Transfer Language (RTL) embedded images

You can print Hewlett Packard © RTL embedded images to HP-GL printers and plotters. You can also
display selected embedded RTL images by exporting and saving the file for subsequent viewing.

1. Select a 2D image containing the Raster Transfer Language.

2. From the Printing toolbar, click Print .

3. In the Print dialog box, select an HPGL printer or plotter and click OK.

The file is sent to your printer.

Note:

• RTL is a subset of Hewlett Packard PCL (Print Command Language) and RTL is used to embed
true raster images (bitmaps) into plotter files.

• You can print HP RTL images in RGB color (color represented by 8-bits each of red, green and
blue), in indexed color (color represented by an 8-bit index that is stored in a table of RGB
colors), and in monochrome (color represented by a single bit – black and white).

• HP RTL images are compressed, which significantly reduces file size.

Print HP Raster Transfer Language (RTL) embedded images
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• Scaled images and 8-bit color output are not supported at this time. Also, unsupported
commands are skipped, and the application continues to process files. The application supports
only those HP RTL commands and compression methods necessary for output.

• Use Export Image to export and save the file. Later, you can open the file in the Viewing
window.

Creating text and watermark stamps using an MDS file

Overview of adding text and watermark stamps with an MDS file

As an administrator you can create an MDS stamp file to add a watermark and stamp text to all printed
images. You can specify a background color to the watermark, add headers and footers, and modify the
stamp further by using additional MDS commands. You write a text file that includes your MDS stamp
information and name it default.mds. Save this file in the \etc folder within the installation directory.

Note:

You use the MetaDataStamp Template to control the formatting styles used in text
and watermark stamps. The default MDS_default_styles_template.mds template file is
located in the TC_DATA directory in the RAC; it is imported to the database as a
dataset called MDS_default_styles_template. For information on importing a custom
MDS_default_styles_template.mds template file, see the MetaDataStamp_template preference.

Caution:

When you create and save the default.mds file, end-user watermark preferences become
unavailable.

The watermark MDS command operates differently from other MDS stamp commands.

• Only one \Watermark command is supported in an MDS file. However, you can enter several other
basic MDS commands that create useful watermark stamps.

• The beginning position of the watermark text always defaults to the center of the page. However, you
can modify the beginning position of the watermark by using the \Pos option.

Note:

• Type each MDS command on a separate line.

• Basic text and watermarks stamps support the following replacement strings:
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• %Date – date only

• %Time – time only

• %User – the user name

• %File – a file name

• %FilePath – a path and file name

• %Page – page number

• Invalid or non-supported MDS commands are ignored.

Create text and watermark stamps using an MDS file

1. Open a text editor and type in options from the following list:

Type this option To do this

\BackgroundColor
(Color or RGB value)

Set the background color for text lines, including Watermarks.

Example:

\BackgroundColor(Red)
\BackgroundColor(255,0,0)

• Control the background color value in one of these ways:

• Enter a standard RGB value.

• Enter the exact name of one of the following supported colors:

■ white

■ yellow

■ cornsilk

■ green

■ cyan

■ sky blue

Create text and watermark stamps using an MDS file
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Type this option To do this

■ blue

■ midnight blue

■ purple

■ magenta

■ red

■ orange

■ salmon

■ gray80

■ slate

■ gray

■ black

• For text without a background color use
\BackgroundColor(None).

\Char(size) Set the font size for text.

Example:

\Char(12)

\Color(color) Set the color for text.

Example:

\Color(Red)

\Date Display the system date and time.

\File Display the document path and file name.

\Font(name) Set the font.

10. Printing
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Type this option To do this

Example:

\Font(Courier)

\FooterLeft
\FooterCenter
\FooterRight

Enter text that is displayed at the bottom of the page.

Example:

\FooterCenter
Confidential

\Halftone(1.0 or 0.5) Set the halftone to opaque (a value of 1.0) or to transparent (a value of
0.5).

Example:

\Halftone(0.5)

\HeaderLeft
\HeaderCenter
\HeaderRight

Enter text that is displayed at the top of the page.

Example:

\HeaderCenter
Confidential 

\Pos(x,y) Set the beginning cursor position. The default cursor position is (36,36).

\Rotate(angle) Set the rotation angle of your text.

Example:

\Rotate(45)

\Rotate(-45)

\User Display the current user ID.

\Watermark Specify the watermark command on one line in the MDS file. The next
line of text includes your watermark message.

Example:

\Watermark(HORIZ,AUTO)
Sample Text

Create text and watermark stamps using an MDS file
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Type this option To do this

• The Orientation parameter supports the following values

• (LL2UR) – lower left to upper right

• (UL2LR) – upper left to lower right

• (HORIZ) – horizontal

If you do not specify a value, the default, HORIZ, is used.

• You can use the value AUTO to set watermark text to be as large as
possible. If AUTO is not specified, text size is determined by the last
value in \Char, or to the default value, \Char(12).

2. Name the MDS file, default.mds, and save it to the etc folder within your installation directory.

All printed images will now contain the watermark defined by the MDS file.

MDS text and watermark examples

An example using the \Halftone MDS command

\Color(Black) 
\Font(Arial) 
\Char(16) 
\Pos(20,20) 
\Halftone(0.5) 
\BackgroundColor(Red) 
Sample Text 
\BackgroundColor(None) 
Line of sample text. 
\BackgroundColor(Purple) 
\Char(36) 
\Watermark(HORIZ) 
6.0 Demo
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An example without using the \Halftone MDS command

\Color(Black)
\Font(Arial) 
\Char(16)
\Pos(-20,20) 
\BackgroundColor(Red) 
Sample Text 
\BackgroundColor(None) 
Line of sample text. 
\BackgroundColor(Purple) 
\Char(36) 
\Watermark(HORIZ) 
6.0 Demo

MDS text and watermark examples
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Set the beginning cursor position for stamps with MDS files

If you create additional detailed stamps for your files by using MDS stamps, use the MDS command /
Pos(x,y) to specify the beginning cursor position of the stamp. The numeric values, x and y are
measured in point-size, where one point is equal to 1/72 of an inch.

The default starting position for all MDS text entries is the upper-left corner of the page, or a position
equal to /Pos(36,36). This means the cursor begins at a point that is 1/2 inch from the top of the page
and 1/2 inch from the left edge of the page.

You can use these additional cursor position options, as needed:

Use this
option To do this

= Position the stamp outside the stamped image and into the margin. This position
indicator is only available for HPGL-based stamping and cannot be used with the !
position indicator. This may only be used for the vertical position.

! Measure the position in point sizes (1/72 of an inch or approximately 0.35 millimeters).
Without the symbol (!), the current operating coordinate system determines the units
of measure.

– Begin the cursor at the lower right-hand corner of the image. Without the symbol (–),
the position is measured from the upper left-hand corner.
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Note:

Allow enough space for the character size in the y direction to avoid truncating (cropping) the
stamp.

Example:

This example shows how to position the cursor 3 inches up from the bottom and 2 inches from the
right-hand edge of the page.

\pos(!-144,!-216)

Specify the orientation of text stamps with MDS files

1. Use the MDS Rotate command to specify how your stamp displayed on the page.

2. Use positive rotation values to rotate text counter-clockwise. The zero angle (or start) is the point of
intersection on the right side of a horizontal line crossing through the center of rotation. The center
of rotation is the midpoint of the height and the midpoint of the width before rotation.

Specify the orientation of text stamps with MDS files

Visualization on Rich Client ─ Getting Started, Teamcenter 2412  10-17
© 2025 Siemens



Example:

Type this To do this

\Rotate(45) Rotate the text 45 degrees counter-clockwise.

The text flows from the starting position on a lower left corner to the
upper right corner angle.

\Rotate(90) Rotate the text 90 degrees counter-clockwise.

The text flows from the starting position straight up the page on a
perpendicular angle.

\Rotate(-90) Rotate the text 90 degrees clockwise.

The text flows from the starting position straight down the page on a
perpendicular angle.

Tip:

• The angle value must be an integer.

• To prevent truncated or cropped text, be mindful of your text starting point, font size, and
rotation angle.

Add uniform watermark stamps when exporting files

As an administrator you can create an MDS stamp file to add a watermark and stamp text to all 2D
images created using Export Image. You write a text file that includes your MDS stamp information and
name it export.mds. Save this file in the \etc folder within the installation directory. You can also set a
background color to the watermark and modify the stamp further by using additional MDS commands.

Caution:

When you create and save the export.mds file, end-user watermark preferences become
unavailable.

The following apply:

• Type each MDS command on a separate line.

• Invalid or non-supported MDS commands are ignored.

• Only one \watermark command is supported in an MDX file.
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• The beginning position of the watermark text always defaults to the center of the page. However, you
can modify the beginning position of the watermark by using the \Pos option.

• Watermark stamps support the following replacement strings:

• %Date – date only

• %Time – time only

• %User – the user name

• %File – a file name; stamp.mds

• %FilePath – a path and file name; c:\etc\stamp.mds

• %Page – page number; 1 of 2

1. Open a new file in a text editor.

2. Select from the following:

Type this option To do this

\BackgroundColor (Color or
RGB value)

Set the background color for text lines, including Watermarks.

Example:

\BackgroundColor(Red)
\BackgroundColor(255,0,0)

• Control the background color value in one of these ways:

• Enter a standard RGB value.

• Enter the exact name of one of the following supported colors:

■ white

■ yellow

■ cornsilk

■ green

■ cyan

Add uniform watermark stamps when exporting files
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Type this option To do this

■ sky blue

■ blue

■ midnight blue

■ purple

■ magenta

■ red

■ orange

■ salmon

■ gray80

■ slate

■ gray

■ black

• For text without a background color use
\BackgroundColor(None).

\Char(size) Set the font size for text.

Example:

\Char(12)

\Color(color) Set the color for text.

Example:

\Color(Red)

\Date Display the system date and time.

\File Display the document path and file name.

\Font(name) Set the font.
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Type this option To do this

Example:

\Font(Courier)

\Halftone(1.0 or 0.5) Set the halftone to opaque (a value of 1.0) or to transparent (a
value of 0.5).

Example:

\Halftone(0.5)

\Pos(x,y) Set the beginning cursor position. The default cursor position is
(36,36).

\Rotate(angle) Set the rotation angle of your text.

Example:

\Rotate(45)

\Rotate(-45)

\User Display the current user ID.

\Watermark Specify the watermark command on one line in the MDS file. The
next line of text includes your watermark message.

Example:

\Watermark(HORIZ,AUTO)
Sample Text

• The Orientation parameter supports the following values

• (LL2UR) – lower left to upper right

• (UL2LR) – upper left to lower right

• (HORIZ) – horizontal

If you do not specify a value, the default, HORIZ, is used.

• You can use the value AUTO to set watermark text to be as large
as possible. If AUTO is not specified, text size is determined by the
last value in \Char, or to the default value, \Char(12).

Add uniform watermark stamps when exporting files
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3. Name the file, export.mds, and save it to the etc folder within your installation directory.

All images saved using Export Image are saved with the uniform watermark stamp.

Example:

This example shows the text of a watermark stamp that is embedded on all images saved by
Export Image.

\Color(0,255,0)
\Font(Arial)
\Char(18)
\BackgroundColor(white)
\Watermark(UL2LR)
%File: Restricted Document %Time

Printing a date and time

Overview of printing a date and time

When printing, you can add a date and time to headers, footers, watermarks, and MDS stamps.

The syntax for these options includes the following:

To print Type this

Today’s date %Date

Tomorrow’s date %Date(1)

Yesterday’s date %Date(-1)

30 days in the future %Date(30)

The current time %Time

The current time plus 30 minutes %Time(30)

The current time plus 2 hours %Time(120)

Note:

• Days and times in the future are positive; to set them to the past, use negative numbers.

• The date option limit is 5000 days in the future or in the past. The time option limit is 1500
minutes in the future or in the past.
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Add a date and time to headers and footers

Note:

You can type specific tokens (for example, %Date) into the appropriate field.

1. Choose File→Print.

2. In the Print dialog box, click the Header and Footer tab.

3. Select the Header check box, the Footer check box, or both and then select the location of the text
(left, center, or right).

4. To add a date, right-click in the selected location and choose Insert→Date.

To add a time, right-click in the selected location and choose Insert→Time.

5. Add the necessary text and date information for the header or footer.

In this example, the text used is Expires on %Date(30).

The image is printed with the header text in the top left corner of the page. A specific date is
printed 30 days from the date of printing the file.

Add a date and time to a watermark

1. Choose File→Print.

2. In the Print dialog box, click the Watermark tab.

Add a date and time to headers and footers
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3. Select the Watermark check box.

4. To add a date, right-click in the text box and choose Insert→Date.

To add a time, right-click in the text box and choose Insert→Time.

5. (Optional) Create the text and then insert the variables or insert the variables and create text
around them.

In this example, the watermark text is Expires on %Date(30) at %Time.

Add a date and time using an MDS file

When an MDS stamp is used to print files, watermark options are unavailable and the text associated
with the MDS file is used in all print jobs. For these reasons, usually an administrator creates the MDS
file.

1. Open a text editor and save the file as default.mds.

2. Add the replacement strings, %Date, %Time, or both as appropriate.

Use the syntax as described before.

3. Add additional MDS commands, as needed.
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4. Save the file, default.mds in the \etc folder.

Note:

Type each MDS command on a separate line.

For complete details about MDS stamp files, see Creating text and watermark stamps using an MDS
file.

System administrator reference for configuring default Windows
print preferences

Overview of system administrator reference for configuring default Windows
print preferences

As system administrator, you can modify the default print settings for Windows operating systems.
When the print dialog box appears, you can do the following:

• Run the print job. This action prints the job using the original default values.

• Modify the default settings temporarily by changing their values. For example, change the print
orientation from portrait (the default setting) to landscape for this specific print job.

Note:

The print default settings appear the next time you request a print job, unless you select Last
Used Print dialog box. Use Last Used to repeat a temporary change in default setting options.
For example, if you change print orientation from portrait to landscape the Print Default setting
generates a portrait print job and the Last Used settings prints landscape.

• Modify the default settings permanently.

How to change default print settings for Windows systems

1. Navigate to Initialization.xml, which is saved in the /etc subfolder of the Teamcenter lifecycle
visualization installation directory.

Overview of system administrator reference for configuring default Windows print preferences
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Example:

C:\Program Files\Siemens\Teamcenter<release_version>\Visualization\etc

2. Use a text editor to open, review, and change the values associated with this XML file. Once the
changes are made, save the modified Initialization.xml.

Tip:

For each section that you configure, be sure to configure the OverWrite preference to
“Yes” if the current value is set to “No”.

Here is sample section of an Initialization.xml that shows default print options and their values.

<Section_Printing>
        <!-- OverwriteDefaults: yes to set defaults each time app start, no 
to set defaults once
 if value not set yes is recommended -->
    <OverwriteDefaults state="no" />

    <PrintOptions>
      <NumCopies  value="1"/>
             <!-- Collate: "yes" "no" -->
      <Collate  state="no"/>
           <!-- FullPathNameFlag: "yes" "no" -->
      <FullPathNameFlag  state="no"/>
           <!-- PrintToFile: "yes" "no" -->
      <PrintToFile  state="no"/>
    </PrintOptions>
    <PrintLayout>
           <!-- Orientation: 0=Portrait  1=Landscape  2=Best Fit -->
      <Orientation  value="0"/>
           <!-- PrintScale: 0=Fit to Page  1=1:1 Scale  2=Scale -->
      <PrintScale  value="0"/>
           <!-- ScalePercentage: 1-100 -->
      <ScalePercentage  value="100"/>
             <!-- RollPaperAutoSize: "yes" "no" -->
      <RollPaperAutoSize  state="no"/>
           <!-- BypassPrinterDriver: "yes" "no" -->
      <BypassPrinterDriver  state="no"/>
           <!-- PrinterLanguage: 0=Post Script 1=HPGL 2=TIFF 3=C4 4=MILR -->
      <PrinterLanguage  value="0"/>
           <!-- PrintQuality: 0.0 - 100.0 -->
      <PrintQuality  value="0.0"/>
           <!-- PreviewQuality: 0.0 - 100.0 -->
      <PreviewQuality  value="0.0"/>
           <!-- AutoCalcPrintQuality: "yes" "no" -->
      <AutoCalcPrintQuality  state="yes"/>
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             <!-- PrintAsMonocolor: "yes" "no" -->
      <PrintAsMonocolor  state="no"/>
             <!-- PrintFullView: "yes" "no" -->
      <PrintFullView  state="no"/>
    </PrintLayout>
    <Advanced>
           <!-- ImageAlignment: 0 to 8 -->
      <ImageAlignment  value="4"/>
           <!-- UseWYSIWYG: "yes" "no" -->
      <UseWYSIWYG  state="yes"/>
      <LeftMargin  value="0"/>
      <RightMargin  value="0"/>
      <TopMargin  value="0"/>
      <BottomMargin  value="0"/>
           <!-- MarginUnits: 0=Inches  1=Millimeters -->
      <MarginUnits  value="0"/>
           <!-- TreatVectorAsRaster: "yes" "no" -->
      <TreatVectorAsRaster  state="no"/>
           <!-- RelativeLineFonts: "yes" "no" -->
      <RelativeLineFonts  state="no"/>
           <!-- MDSIsGeoCentric: no=Page Centric  yes=Geometry Centric -->
      <MDSIsGeoCentric  state="no"/>
    </Advanced>
  </Section_Printing>

How to change default print settings for Windows systems

Visualization on Rich Client ─ Getting Started, Teamcenter 2412  10-27
© 2025 Siemens



10. Printing

10-28  Visualization on Rich Client ─ Getting Started, Teamcenter 2412
© 2025 Siemens



11. Specifying preferences
Migrate user preferences when moving to a new version

If you saved user preferences, such as color and font preferences, in a previous version of the product,
you can migrate them for use with an updated version.

If settings from a previous version are detected, the Migrate Preferences dialog box appears when you
first start the product.

1. In the Migrate Preferences dialog box, click Yes or No.

Note:

If you want to stop the dialog box from appearing each time you start the application, select
the Do Not Ask Again check box. If you choose both No and Do Not Ask Again, migrating
your preference settings to your current version is no longer possible.

2. Click OK.

Setting higher security (FIPS)

Overview of setting higher security (FIPS)

You may need to set higher security standards when you work with government entities and other
similar organizations. The National Institute of Standards and Technology (NIST) developed Federal
Information Processing Standards (FIPS) for use government-wide. These standards relate to such
security features as the size of a public key, the strength of a cipher, and the way information must
be sent between computers.

Activate FIPS security standards

If your organization uses FIPS security standards, you must enable FIPS mode for the heightened security
to take effect in the application.

1. Use Microsoft guidelines to configure your computer to run in FIPS mode.

2. Choose File→Preferences→Use FIPS.

-or-

Set the TCCRYPTO_FORCE_FIPS_MODE environment variable to True.
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Note:

If the variable is set to true, the menu option Use FIPS will be unavailable. You will be unable
to turn FIPS on or off because your computer will always be configured FIPS mode.

Teamcenter Integration preferences

Overview of Teamcenter Integration preferences

Use the Teamcenter Integration Preferences to specify the default behavior of visualization
datasets in Lifecycle Visualization. In the standalone viewer or the Lifecycle Viewer, choose
File→Preferences→Teamcenter Integration to adjust any of the following preferences:

These preferences Do this

Teamcenter Integration
3D Loader preferences

Specify the unit of measurement for PLM XML and Parasolid files loaded
from Teamcenter. Also specify how to load 3D documents containing both
static and configured product structure.

Teamcenter Integration
Session preferences

Control the default save location for session files.

Teamcenter Integration
Markup preferences

Control how new markups are named and whether or not to display
messages during batch modifications.

Teamcenter Integration
Check Out preferences

Specify the default behavior when attempting to load checked out objects.

Teamcenter Integration
Attributes preferences

Control the display of Teamcenter and NX attributes present in visualization
datasets.

Teamcenter Integration
Snapshot preferences

Control how 2D snapshots and 3D product views are saved to Teamcenter.

Teamcenter Integration
Visual Issue preferences

Specify the default behavior for visual issue creation.

Teamcenter Integration
3D Save preferences

Specify how to save 3D documents with both configured and static product
structure.

Teamcenter Integration 3D Loader preferences

Use the Teamcenter integration 3D loader preferences to specify the unit of length for product structure
data sent as a new document to the Lifecycle Viewer or standalone application viewer. You can also
specify how to load 3D documents containing both static and configured structure.

1. Choose File→Preferences→Teamcenter Integration.

11. Specifying preferences

11-2  Visualization on Rich Client ─ Getting Started, Teamcenter 2412
© 2025 Siemens



2. Click the 3D Loader tab.

3. In the Document Units section, from the Document Units list, select a unit of measurement.

Note:

• The default unit of length for product structure data sent to the Lifecycle Viewer or the
standalone application viewer is meters.

• Changes to the Document Units preference do not apply to documents that are open
in the session. After modifying the preference, close and reopen your documents for the
change to take effect.

• The Document Units preference is not applicable for structure that is inserted or merged
into an existing document.

• The Document Units preference has no effect on static structure that is opened in the
Lifecycle Viewer or the standalone application viewer. The document unit of length for
static data is specified using the PLM XML units setting in PLM XML Preferences.

4. In the Product Structure section, choose one of the following:

To Do this

Open configured structure according to its
current state in Teamcenter. The most recent
structure configuration is loaded.

Click Configure an updated structure.

For 4GD subsets, replay the subset recipe
before opening the data.

a. Click Configure an updated structure.

b. From the Update subset on load list,
select one of the following:

• No Update

• Replay Recipe

When both configured and static product
structure are available, open the structure
according to its state at the time the session
was saved.

Click Load static structure (structure at time
of session save).

When both configured and static product
structure are available, choose how to load the
structure when you attempt to open it.

Click Ask at load time.

Teamcenter Integration 3D Loader preferences
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5. In the Partitions section, select the Show empty partitions check box if, when viewing partition
hierarchies in the assembly tree, you want to show partitions that have no design element
members. When this option is not selected, empty partitions do not appear.

Teamcenter Integration Session preferences

Use the Teamcenter Integration Session preferences to control how a session file is saved.

1. Choose File→Preferences→Teamcenter Integration.

2. Click the Session tab.

3. In the Default Storage Location section, do any of the following:

To Do this

Save session files with the base document. Click Attach to base document.

Save session files in a new location. Click Alternate location.

Teamcenter Integration Markup preferences

Use the Teamcenter Integration Markup preferences to control how new markups are named and to
display messages during batch modifications.

Note:

The Teamcenter site preference TC_Generate_Markup_Name determines whether dataset names
are hard-coded or generated. This controls the markup name only in Teamcenter. In standalone
Lifecycle Visualization, the generated markup name is always used.

1. Choose File→Preferences→Teamcenter Integration.

2. Click the Markup tab.

3. In the General section, do any of the following:

To Do this

Name new markup datasets as you create them Select the Show New Dataset selection dialog
check box.

Display warning messages during batch
operations

Select the Show warnings during batch
modifications check box.

Display errors that occur during batch
operations

Select the Show partial errors during batch
modifications check box.

11. Specifying preferences
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Teamcenter Integration Check Out preferences

Use the Teamcenter Integration Check Out Preferences to specify the default behavior when attempting
to load checked out objects.

1. Choose File→Preferences→Teamcenter Integration.

2. Click the Check Out tab.

3. In the Document Checked Out By section, do any of the following:

To specify how to load documents Do this

When the documents are checked out by
someone else

In the Different user section, choose from the
following options

• Load in read only mode

• Cancel load

• Show warnings

When you have opened the documents in
another application

In the Same User / Different Application
section, choose from the following options

• Load in read only mode

• Break lock and check out

• Cancel load

• Show warnings

When you have already opened the documents
in the viewer

In the Same User / Same Application section,
choose from the following options

• Load in read only mode

• Cancel load

• Show warnings

Teamcenter Integration Attributes preferences

Use the Teamcenter Integration Attributes Preferences to control the display of Teamcenter and NX
attributes present in visualization datasets.

Teamcenter Integration Check Out preferences
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Note:

This preference is applicable for assemblies only. It has no effect on individual JT datasets.

1. Choose File→Preferences→Teamcenter Integration.

2. Click the Attributes tab.

3. In the Teamcenter Attributes tab, select the attributes that you want to display.

Tip:

To select multiple adjacent attributes, click the first attribute, press Shift, and then click the
last attribute. To select multiple nonadjacent attributes, hold Ctrl as you click each item.

4. Click Add.

The selected attributes move to the Displayed Attributes section.

5. (Optional) Select the Use Display Names check box.

The attributes are shown using display names if your database administrator defined them.

6. Close and restart the application.

Note:

• You can also set the attributes to display within Teamcenter. Choose Edit→Options→Index, and
then search for Interop_Vis_Attributes.

• To display attributes that are longer than a single line, your system administrator must have
grouped them into a single, multiline attribute.

Teamcenter Integration Snapshot preferences

Use the Teamcenter Integration Snapshot Preferences to control how 2D and 3D snapshots are saved to
Teamcenter.

1. Choose File→Preferences→Teamcenter Integration.

2. Click the Snapshot tab.

3. In the 2D Snapshot section, do any of the following:

11. Specifying preferences
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To Do this

Enter form data on 2D
snapshots

Select the Show attributes form on save check box.

Note:

You can enter data for any custom form fields. Revision and Page
information is entered automatically.

Save a 2D geometry
asset

a. Select the Capture 2D geometry asset check box.

b. (Optional) Adjust the Geometry asset image quality slider.

Adjust the 2D
geometry asset image
quality

Use the slider bar to make adjustments in a range from Good, Better, or
Best.

4. In the Teamcenter Product View section, do any of the following:

To Do this

Add or update 3D
geometry asset for
product views

a. Select the Add or Update 3D Geometry Asset check box.

b. (Optional) Select the Draw Outline check box to generate an
outline of the 3D geometry asset.

Note:

If you do not see the Add or Update 3D Geometry Asset
check box, contact your administrator.

Create an image
capture of the product
view

a. Select the Image Capture check box.

b. (Optional) Select the Use image export dialog check box to
display the Export Image dialog box when you save the product
view. If this option is cleared, the application uses Teamcenter
preferences to control such image capture options as size, file type,
and resolution.

Note:

If you do not see the Image Capture check box, contact your
administrator.

Rename the product
view before saving it

a. Select the Show Snapshot Name Dialog check box to display the
New Teamcenter Product View Dataset dialog box.

Teamcenter Integration Snapshot preferences
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To Do this

b. In the New Teamcenter Product View Dataset dialog box, type a
new name for the product view.

Note:

• Use 3D Product View preferences to modify how Teamcenter product views are processed.

• The 3D Product View preferences are unavailable in the following conditions:

• When you do not send Teamcenter data to Lifecycle Viewer. That is, you must have an active
connection to a Teamcenter server.

• When the Teamcenter protection scope of the preferences is higher than your permission
scope. For example, if your administrator set the preference protection scope to SITE, and
your protection scope is set to USER, the 3D Product View options are unavailable.

• If you have permissions, when you change a product view preference in Lifecycle Viewer you
also change the corresponding Teamcenter preference on the server.

Teamcenter Integration Visual Issue preferences

Use the Teamcenter Integration Visual Issue Preferences to control the default behavior of visual issue
creation.

1. Choose File→Preferences→Teamcenter Integration.

2. Click the Visual Issue tab,

3. Do any of the following:

To Do this

Specify a visual report template From the Issue Type list, select a template.

Note:

Issue Report is the default issue type.
Your organization may also allow you to
choose from additional issue types.

Specify the issue relation to use for snapshots In the Issue Relation for Snapshots section,
choose one of the following:

11. Specifying preferences
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To Do this

• Snapshot Before Fix

• Snapshot After Fix

Specify the data type attached to the visual
issue

From the Data Type list, select one of the
following:

• Product View or 2D Snapshot

• Session File

Enter options for visual issue creation each time
an issue is created

Select the Ask at the time the Issue is created
check box.

Teamcenter Integration 3D Save preferences

Use the Teamcenter Integration 3D Save Preferences to specify how to save 3D documents that contain
both configured and static product structure.

1. Choose File→Preferences→Teamcenter Integration.

2. Click the 3D Save tab.

3. In the Product Structure section, do any of the following:

To Do this

Specify to save configured structure only Select Save only configured structure.

Specify to save both configured and static
representations of the current structure

Select Save configured and static
representations of the current structure.

Teamcenter Integration 3D Save preferences
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