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1. Getting started with Relation Browser
Getting started with Relation Browser overview

The Relation Browser application provides information about a currently selected object. The
information displays as nodes in a graphical form with several layouts available:

• Balloon

• Circular

• Hierarchical

• Organic

• Orthogonal

In Relation Browser, you can expand the nodes to see successor (children) or predecessor (parents)
nodes.

End users send objects to Relation Browser from many different Teamcenter applications.

Example:

You can send objects to Relation Browser from My Teamcenter, Structure Manager, or Systems
Engineering.

Before you begin

Setup information

Prerequisites You need no special privileges to use the Relation Browser application.

Note:

Access to the Relation Browser application may be restricted and you may
be unable to start it, even if you have administrator privileges.

Enable Relation
Browser

Relation Browser does not need to be enabled before you use it.

If you have trouble accessing Relation Browser, see your system administrator;
it may be a licensing issue.
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Note:

You can log on to Teamcenter only once. If you try to log on to more than
one workstation at a time, you see an error message.

Configure Relation
Browser

Relation Browser does not need to be configured. Preferences are available to
configure the graphic layout.

Start Relation
Browser

Click Relation Browser  in the navigation pane.

What are perspectives and views?

Within the rich client user interface, application functionality is provided in perspectives and views.

View The basic display component that displays related information in a UI window.

Perspective A collection of one or more views and their layout.

Some applications use a perspective with multiple views to arrange how functionality is presented.
Other applications use a perspective with a single view.

You can use the HiddenPerspectives preference to prevent the display of some Teamcenter perspectives
in the rich client.

If your site has online help installed, you can access the application and view help from the rich client
Help menu.

Relation Browser user interface

Relation Browser perspective

The Relation Browser perspective displays four views.
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1-2  Relation Browser on Rich Client, Teamcenter 2412
© 2025 Siemens



1 Relation Browser
view

When you send an item to the Relation Browser view, it
becomes the root node in that view.

2 Image Preview view When a selected node has an associated 2D preview image,
the preview image is displayed in the Image Preview view.

3 Graph Overview
view

When you zoom in on a complicated graph in the Relation
Browser view, the Graph Overview view shows your display
location within the graph. You can pan around the display in
the Graph Overview view to examine other objects.

4 Properties view When you select an object in the Relation Browser view, the
Properties view displays properties of the object.

Relation Browser view

The Relation Browser view provides the following features and functionality:

• When you select an object in the navigation pane, the Relation Browser view displays the newly
selected object as the root object, and the Properties view displays properties of the object.

• When you open an object in Systems Engineering, and activate the Relation Browser view, the object
you select appears in the Relation Browser view as the root object.

You can select any node to browse further related objects one level at a time.

Relation Browser view
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• Zoom in , zoom out , and fit content  buttons are available.

• Choose a context from the Relation Browser view menu .

Menu command Description

Contexts→Default View structure relations in the Relation
Browser view. In this context, defined
structure relations display when you show
successors or predecessors.

This is the default view context.

Contexts→Traceability View trace links in the Relation Browser view.
In this context, defined trace links appear
when you show successors.

Contexts→Genealogy When a requirement object is duplicated,
Teamcenter remembers its source. In this
context, you can view the source or duplicate
objects, if any, related to a requirement object
selected in the Relation Browser view.

To view the source of the selected
object, right-click and choose Hide/Show
Predecessors. To view the duplicate or
duplicates of the selected object, right-click
and choose Hide/Show Successors.

Note:

This feature is enabled by setting
IMAN_based_on as a shown relation for
the requirement revision item type.
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Menu command Description

1. In the toolbar, choose
Edit→Options→General→Item
Revision.

2. In the Options dialog box, General
tab:

a. Select Requirement Revision
in the Item Revision type
selected box.

b. Select Specifications in the
Default paste relation box.

c. Add the IMAN_based_on
relation type to the Shown
Relations list.

d. Click OK.

Note:

Context display is controlled by the TC_RelationBrowser_Context preference.

To view or edit preference information, use the rich client Edit→Options dialog box.

• Choose a layout orientation from the Relation Browser view menu .

Menu command Description

Hierarchical→  Top-to-
Bottom

Creates a graph beginning with a top node
and flowing to the bottom.

Note:

The structure in the preceding
example graphic uses the Top-to-
Bottom orientation. The requirement
specification appears at the top-level and

Relation Browser view
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Menu command Description

the associated requirements appear at a
lower level of the structure.

Hierarchical→  Right-to-
Left

Creates a graph beginning with node at the
right and flowing to the left.

Hierarchical→  Left-to-
Right

Creates a graph beginning with a node at the
left and flowing to the right.

Hierarchical→  Bottom-to-
Top

Creates a graph beginning with a node at the
bottom and flowing to the top.

Hierarchical→  Incremental Creates a graph beginning with a top node
in the upper-left corner and flowing to the
bottom and to the right.

 Circular Displays group and tree structures within a
network in a ring and star pattern.

 Orthographic Creates compact graphs with no overlaps,
few crossings, and few bends. It is most
appropriate for medium-sized sparse graphs.

 Organic Creates a layout with the nodes spaced as far
away from each other as possible, still while
minimizing this distance. It is most appropriate
for undirected, complex graphs.

 Balloon Creates a layout with a central node and child
nodes extending from this in a radial fashion.
It is most appropriate for large, hierarchical
structures.

• You can select any node to browse further related objects one level at a time.

• Each node has a type symbol and object string to represent the component on the graph. If any node
has an associated 2D preview image, the preview image can be displayed as a thumbnail image along
with the text string in the Relation Browser layout and is also displayed in the Image Preview view.

• When you right-click a node in the graph, the shortcut menu displays the same commands as when
you select a node on the navigation pane tree, based on the type of object.

• Each node can have predecessors and successors, based on the application with which the object is
associated. You can select an object and use the shortcut menu to expand or collapse predecessors
and successors. For example, an application can show predecessors as where-referenced objects and
can show successors by showing default children context.
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Image Preview view

When a selected node has an associated 2D preview image, the preview image is displayed in the Image
Preview view.

Note:

Display of thumbnail images in the graph view is controlled by the
TC_Graph_Node_Thumbnail_Shown preference.

To view or edit preference information, use the rich client Edit→Options dialog box.

Properties view

When you select an object in the navigation pane and send it to Relation Browser:

• The Relation Browser view displays the newly selected object as the root object.

• The Properties view displays properties of the object.

When you select a different node in the Relation Browser view, the Properties view displays properties
of the newly selected object.

Note:

The Properties view is intended primarily for diagnostic purposes. Use the Summary view, the
Viewer view, and the Properties dialog box to view and edit properties.

Graph Overview view

When you select an object in the navigation pane in an application that uses the Graph Overview, such
as the Relation Browser perspective, the Graph Overview view displays the newly selected object as
the root object.

If you zoom in on a complicated graph, the Graph Overview view shows your display location within
the graph. You can pan around the display in the Graph Overview view to examine other objects.

Basic concepts for using Relation Browser

The Relation Browser perspective offers an alternate to the typical tree view of data you see in other
perspectives.

• The Graph Overview view allows you to see the big picture and focus on a particular area of a large
layout.

• The Properties view allows you to view property values for any selected object.

Image Preview view
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• The Image Preview view allows you to view the 2D JT image, if one is provided for the selected
object.

Relation Browser is designed to help you access the data you need by displaying several views in one
perspective.

Basic tasks using Relation Browser

Use Relation Browser to:

• Traverse relationship hierarchies.

• Display properties of the selected object.

• Display a 2D preview image associated with the selected object.
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2. Open Relation Browser
You can display the Relation Browser perspective using one of the following methods:

• Click Relation Browser  in the navigation pane.

Note:

Depending on your configuration, Relation Browser may appear as an application button in the
navigation pane, an application icon in the application bar below the navigation pane, or as an
available application.

If an application button is not displayed for Relation Browser, you can add it using Configure
Applications  at the bottom of the navigation pane.

• Choose Window→Open Perspective→Relation Browser.

• Select an item in the Folders pane and right-click and choose Send To→Relation Browser.

The system displays the Relation Browser application.

Note:

In any perspective, you can choose the Window→Show View→Relation Browser view and any of
the associated Image Thumbnail Preview, Properties, and Graph Overview views.
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3. Working with Relation Browser
Relation Browser layout options

In Teamcenter, you send objects to Relation Browser to graphically display these objects and their related
items. There are five layout options available:

• Balloon

• Circular

• Hierarchical

• Organic

• Orthogonal

You can associate any of the image previews with the root node.

Send a structure to Relation Browser

1. Right-click an object and choose Send To→Relation Browser.

The Relation Browser perspective appears with the object and its first-level children displayed in a
graphical layout.

2. Choose a layout orientation from the Relation Browser view menu .

3. Click zoom in , zoom out , and fit content  buttons to adjust the view.

4. Double-click a node to expand one level down.

Optionally, right-click a node and choose Show Successors→1 Level to expand one level down.

2, 5, and all are other options on the Show Successors menu.

The node graphically expands to show the successors.

5. Right-click a node and choose Show Predecessors.

1, 2, 5, and all are options on the Show Predecessors menu.

The node graphically expands to show the predecessors.
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6. Right-click a node and choose Hide Successors or Hide Predecessors.

The node either graphically collapses to hide the successors or removes the link from the node’s
predecessor.

Browse trace link relations

1. Right-click an object with one or more trace links and choose Send To→Relation Browser.

The Relation Browser perspective appears with the object and its first-level children displayed in a
graphical layout.

2. In the Relation Browser view menu , choose Contexts→Traceability.

3. To view the complying or defining objects related to the object trace links:

• Right-click the node and choose Show Predecessors→1 Level to expand and view defining
objects for the trace link, one level up, for example.

• Right-click the node and choose Show Successors→1 Level to expand and view complying
objects, one level down, for example.

The node graphically expands to show the first-level trace link complying object or objects.

3. Working with Relation Browser
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Note:

Trace links on occurrence objects appear as a blue solid line. Trace links on absolute
occurrence objects appear as a blue dotted line. The trace link tooltip displays the trace
link name.

Note:

You cannot get information on the trace link context for an absolute occurrence object from the
Relation Browser view. The context information for a trace link on an absolute occurrence object
is available in the Trace Links view or the Traceability view.

View association

Change the view association

Do one of the following:

• In the secondary view, click the Associate button  and select the view to which you want to
associate the secondary view from a list of all primary views currently open.

• If you activate the Disable response to selections button , the Associate button is not available.

• If the Disable response to selections button is not available (if the secondary view is responding
to selections), when you change selection, the secondary view changes its content based on that
new selection in these cases:

■ The secondary view is not associated to any view.

■ The secondary view is associated to the active view (where the selection change occurred).

Change the view association
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■ The secondary view and the active view (where the selection change occurred) are both
associated to the same primary view.

• Select the line in the primary view to which you want to associate the secondary view, and click the
Set input to recent selection button  to set the scope for a secondary view.

You can use the Set input to recent selection button from any view, regardless of the association
state.

• If you set the scope from the primary view to which the secondary view is associated, the
secondary view is still associated to that primary view.

• If the secondary view is not associated to any primary view when you set the scope, Teamcenter
performs no association.

• If the secondary view is associated to primary view A and you set the scope from primary view B,
the secondary view is associated to primary view B.

Teamcenter associates the secondary view with the selected primary view.

Associate views

• Click Associate  and select an object in the list.

This secondary view is associated to the selected object in the primary view.

Disable and enable response to selection

In the secondary view, you can:

• Click Disable response to selection . The secondary view does not change when you select a
different object in the primary view.

• Click Enable response to selection . The secondary view changes when you select a different
object in the primary view.

Set input to recent selection

• Click Set input to recent selection .

The secondary view changes to the currently selected object in the primary view even if you have
disabled the response to the selection.
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4. Configuring Relation Browser
Relation Browser configuration preferences

Teamcenter provides several configuration preferences for the Relation Browser graphical layout.
Configuration preferences are available for these layouts:

• Balloon

• Circular

• Hierarchical

• Organic

• Orthogonal

Configure Relation Browser

1. Choose Window→Preferences.

The Preferences dialog box appears.

2. In the list of preference categories, select Graphical Relation Browser Layout.

The Graphical Relation Browser Layout pane appears with a tab for each layout.

3. Select a layout tab and change the desired preferences.

Note:

Each layout preference has a tooltip with more information about the preference behavior.

The following layouts are available in the tabs:

• Balloon

• Circular

• Hierarchical

• Organic

• Orthogonal
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4. Click Animate Changes to toggle the option.

Animate Changes is selected by default.

If the Relation Browser view is open, you see the graphical layout change.

• When the Animate Changes option is not selected and preferences are saved, changes to the
graphical layout are applied quickly without animation.

• When the Animate Changes option is selected and preferences are saved, changes to the
graphical layout such as node expansion and node collapse are animated.

Note:

When the Animate Changes option is selected, system performance can be impacted
when nodes are expanded and collapsed.

5. (Optionally) Click Restore Defaults.

The layout preferences return to their default values.

6. Click Apply.

The layout preferences apply to Relation Browser and the Graphical Relation Browser Layout pane
remains open.

7. Click OK.

The layout preferences apply to Relation Browser and the Graphical Relation Browser Layout pane
closes.

8. Click Cancel.

The layout preferences you set are not saved or applied and the Graphical Relation Browser
Layout pane closes.
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