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1. Overview of Vendor Management
What is Vendor Management?

To compete effectively in today’s marketplace, many companies outsource the manufacturing of the
component parts in their products in significant numbers. A rich ecosystem of suppliers, manufacturers,
and distributors (collectively referred to as vendors) support the outsourcing process by providing parts
to a manufacturing company. Vendors provide both direct materials (such as parts and assemblies) and
indirect materials (such as tooling in the manufacturing process). Managing vendor and vendor part
information is therefore critical to the outsourcing process. Using Teamcenter Vendor Management, you
can integrate your PLM system and process knowledge with your vendor supply chain.

You can model vendor contributions to a product by capturing information about vendors and the parts
that they provide to satisfy the form, fit, and function of commercial parts. You can also manage the
changes in vendor information over time. Vendor Management is available in the My Teamcenter and
Structure Manager applications. You require standard Teamcenter user and administrator accounts to
use Vendor Management.

Vendors, vendor parts, and commercial parts

Vendors

A vendor supplies one or more parts and can be a supplier, manufacturer, or distributor. For example,
Goodparts, a company that supplies parts to your company is a vendor. Two distinctive attributes of a
vendor are the company location and the vendor contacts or company contacts.

A vendor’s company location provides information about the vendor’s site or facility, including the
name (required), web site, address, region, location code, location type, and notes about that site. An
employee designated as the one-point contact in the vendor’s organization is referred to as a company
contact or vendor contact. A company location can be related to any number of company contacts.
However, a company contact can be related to only one company location.

Similarly, you can associate several company contacts with one vendor. For example, Natalie is a sales
person from Goodparts’ regional sales office in Detroit, MI, USA, and Sasha is a sales person from their
regional sales office in Stuttgart, Germany.

Vendor parts

The part that a vendor supplies is called a vendor part.

A vendor part:

• Is obtained from a single vendor, and not from multiple vendors. However, a vendor may supply
multiple vendor parts.
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• Can be associated with one or more commercial parts.

• Has a vendor part name assigned by the vendor or assumes the company’s name for the part.

• Has a vendor ID and vendor name, which identify the vendor supplying the part.

• Has a part number assigned by the manufacturer of the part.

• Is related to a vendor company location.

Vendor parts may also be classified based on their status, such as, preferred, backup, approved, or
obsolete. This allows your company to always use the best source of vendor parts. It also allows you to
grade the overall product bill of materials (BOM).

Note:

A VendorPart object cannot be sent to Structure Manager to be included in a product structure
unless the vendor part is related to an Item Revision by a Vendor Representation relation.
Additionally, you cannot add an object to a vendor part in the BOM structure because a vendor
part is always the leaf node (lowest level node) in the hierarchy.

Commercial parts

A commercial part is a part that is made externally by a vendor who resells, builds, or designs and
builds the part for your company. In this context, your company is referred to as the original equipment
manufacturer (OEM). Commercial parts can be off-the-shelf market parts or custom-designed parts.

The form, fit, and function of a commercial part can be satisfied by one or more vendor parts that
you may source from one or more vendors. Typically, a commercial part has one or more associated
VendorPart objects.

In Vendor Management, you can classify commercial parts by status such as preferred, approved, or
obsolete. This allows you to grade the overall product BOM.

1. Overview of Vendor Management
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Relation between vendors, vendor parts, and commercial parts

You can view vendor data from both — a vendor-centric and a part-centric point of view. You relate
vendors to the parts that they supply. Vendor parts in turn may be related to commercial parts. You can
use both commercial parts and vendor parts in your BOMs.

Vendors, vendor parts, and commercial parts
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Vendor Management process description and user roles

1. Overview of Vendor Management
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The following users are involved in the Vendor Management business process:

User role Responsibilities Tasks

Implementation Engineer Is responsible for the upkeep,
configuration, and reliable
operation of computer systems,
especially multiuser computers,
such as servers. Also responsible
for:

• Product installation (for
example, Teamcenter)

• Application installation
(for example, Vendor
Management)

• Upgrade from earlier releases

• Dispatcher installation

• Integrations

• Server and client installation

• FSC, and communications

• Multisite, and managing
servers

Install the Vendor Management
solution

Customize Vendor Management

Configure Vendor Management

Data Model Administrator Is responsible for the
configuration of the data model
to meet company requirements
and user needs. Also responsible
for:

• Data model configuration

• LOV definitions

• Condition behavior settings

• Rule configuration such as
naming rules and deep copy
rules

Configure the Vendor
Management data model

Vendor Management process description and user roles
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User role Responsibilities Tasks

Application Administrator Is responsible for the
configuration of software
and data to meet company
requirements and user needs.
Also responsible for:

• User and data security

• Data migration

• Data import and export

• Process configuration

• Smart folder configuration

• Document management
settings

• Publication structure
definition

Creating user groups

Creating vendor roles

Importing vendor data

Defining access permissions to
users on vendor data

Exporting vendor data for
reporting and validation
purposes

Process Engineer Is responsible for the
business process configuration
in the software and process
configuration. The process
engineer builds vendor
workflows and schedules as
required.

Building vendor workflow
processes to support business
processes

Building the schedule and
integrating it with the workflow

Vendor Manager Manages vendor process from
requests through selection.
Oversees the entire Vendor
Management process.

Tasks include:

• Registering vendors, creating
vendor parts, managing
make/buy decisions, and
importing vendor bulk data.

• Deciding the workflow
process to be used for the
bid process, creating bid
packages, submitting the bid
to a workflow, conducting

Register vendors

Qualify vendors

Maintain vendor data

Register vendor parts

Identify preferred vendor parts

Maintain vendor part data

1. Overview of Vendor Management
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User role Responsibilities Tasks

bid review meetings, and
monitoring the bid progress
and making improvements to
it.

• Coordinating the status of
vendor parts according to
the decision of the review
board and participating in the
workflow.

Understanding Vendor Management using an example

Let us consider a scenario where you are manufacturing the Nanobox,
a compact and flexible embedded industrial PC.

Considering various factors, you have decided to outsource the
connector and housing components of the Nanobox. You would
therefore need to create and maintain vendor and vendor part
information for these parts.

You have manufacturing plants for the Nanobox in Detroit, MI, USA,
and in Stuttgart, Germany. Considering this, you have identified some
new vendors. Bestparts and Goodparts are housing vendors, and
Patriot is the vendor for connectors.

You start by registering new vendors, qualifying them, and then
maintaining vendor data as needed.

You also register the vendor parts such as the connector and housing,
and identify preferred vendor parts based on your procurement team’s
input. You can then maintain the vendor part data as required.

Vendor Management in conjunction with other Teamcenter
applications

Vendor Management is available in the My Teamcenter and Structure Manager applications. It also
interacts with the following Teamcenter applications:

• Aerospace and Defense

Installing Vendor Management is a prerequisite if you implement the Aerospace and Defense solution.

• Industry-focused solutions such as Consumer Packaged Goods

Understanding Vendor Management using an example
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You can optionally use Vendor Management with other industry-focused solutions such as Consumer
Packaged Goods.

• Teamcenter Client for Microsoft Office

You may use Vendor Management with Teamcenter Client for Microsoft Office to import vendor data
in bulk as a spreadsheet, using Microsoft Excel.

• Teamcenter Integration Framework

You can optionally use Vendor Management with Teamcenter Integration Framework for exchanging
vendor data with Supplier Collaboration.

1. Overview of Vendor Management
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2. Creating and maintaining vendor and
vendor part data
Creating and maintaining vendor and vendor part data: process
overview and user role

The user role that creates and maintains vendor and vendor part data is:

User role Description Tasks

Vendor manager Manages the vendor process from
requests through selection. Oversees
the entire Vendor Management
process.

Tasks include:

• Registering vendors, creating
vendor parts, managing make/buy
decisions, and importing vendor
bulk data.

• Deciding the workflow process to
be used for the bid process, creating
bid packages, submitting the bid to
a workflow, conducting bid review
meetings, and monitoring the bid

Register vendors

Qualify vendors

Maintain vendor data

Register vendor parts

Identify preferred vendor parts

Maintain vendor part data
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User role Description Tasks

progress and making improvements
to it.

• Coordinating the status of
the vendor parts according to
the decision of reviewers and
participating in the workflow.

Procurement officer Manage procurement of parts from
vendors once the vendor parts have
been chosen.

Tasks include:

• Set the status of vendor parts so
Designers know the preferred parts
to use

• Keep list of vendor parts up to date

• Work with vendors on price,
part requirements, and engineering
change orders

Registering new vendors

Workflow for registering vendors

In the Nanobox example, Bestparts and Goodparts are the potential vendors for housings, and Patriot
is the potential vendor for connectors. You create these new vendors and associate locations with
them. For example, Bestparts operates from Denver, CO, USA and Pontiac, MI, USA, and Nuremberg in
Germany. Goodparts is located at Troy, MI, USA, and in Hanover, Germany. Patriot is located at Lincoln,
NE, USA and Mexico City in Mexico.

Your purchasing department is working with Bob from Bestparts, Gene from Goodparts, and Penny from
Patriot. They are your supplier contacts for these firms.

You can follow the sequence of steps given below to create the new vendors, that is, Bestparts,
Goodparts, and Patriot, in Vendor Management. To set up vendor information for new vendors,
associate the vendors with their locations. Create Bob, Gene, and Penny as vendor contacts for
Bestparts, Goodparts, and Patriot, respectively.

Optionally, you can attach quality documents to a vendor, and add files of a supported type by attaching
a dataset to a vendor. For example, you may attach the market research performed to identify the
vendor or attach other documents as required by your organization.

2. Creating and maintaining vendor and vendor part data
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The workflow to register new vendors in Vendor Management is as follows:

Create a vendor

(Optional) Create locations for the vendor

(Optional) Create vendor contacts

(Optional) Attach a file to a vendor

(Optional) Associate a quality document to a vendor

(Optional) Classify a vendor

Note:

When you use Vendor Management with Supplier Collaboration, you can classify vendors and
vendor parts into categories defined by your organization using the Teamcenter Classification
application. This helps to quickly identify vendors for a particular category of parts, for example,
plastics.

Create a vendor

1. In My Teamcenter, choose File→New→Vendor Management→Vendor.

Create a vendor
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2. In the New Item dialog box, in the Select Type step, select Vendor and click Next.

3. In the Enter Item Information step, type values for ID / Revision, Name, an optional Description,
and Unit of Measure, and click Next.

Note:

You can click Assign to automatically generate ID and Revision.

2. Creating and maintaining vendor and vendor part data
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4. (Optional) In the Enter Additional Item Information step, you can specify vendor contact
information such as Address, Contact, Email, Phone, and Web Site. Click Next.

5. Provide additional attribute values as needed and click Finish to create the vendor.

Click Close to close the dialog box.

When you create a vendor, the system creates organizational folders called pseudofolders  to
display the related commercial parts and vendor parts.

Create a company location

1. In My Teamcenter, open the vendor and select the Locations folder.

2. Choose File→New→Other.

Create a company location
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The system displays the New Business Object dialog box.

3. Select Company Location from the list of business objects and click Next.

4. Type the values for Name (required) and the following optional fields:

• Location Code

• Location Type

Select a value from the menu for Location Type:

• CAGE/Commercial and Government Entity

• GLN/Global Location Number

• Street

• City

• State/Province

• Postal Code

• Country

• Region

• URL

• Description

2. Creating and maintaining vendor and vendor part data

2-6  Vendor Management on Rich Client ─ Usage, Teamcenter 2412
© 2025 Siemens



5. Click Finish to create a company location.

Click Close to close the dialog box.

The company location is created under the selected Locations folder.

Create a company location
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If you do not select the Locations folder for a vendor when creating a company location, the company
location is created independently and not related to the vendor. In such a case, to relate the company
location to a vendor, drag the company location to the Locations folder of the vendor.

Create a vendor contact

1. In My Teamcenter, select the Contacts pseudofolder  for a vendor or company location.

2. Choose File→New→Other.

Select Company Contact from the list of business objects and click Next.

2. Creating and maintaining vendor and vendor part data
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The system displays the New Business Object dialog box.

3. Specify the required information in the New Business Object dialog box.

Create a vendor contact
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4. Click Finish to create a contact and click Close to close the dialog box.

The company contact is created under the selected Contacts folder.

2. Creating and maintaining vendor and vendor part data
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The system creates the contact object and associates it to the selected vendor or company location
using the ContactInCompany relation. To view the relation created, right-click the contact, and select
Properties On Relation. The Relation Type is displayed as ContactInCompany.

Note:

If you do not select the Contacts folder for a vendor when creating a company contact, the
company contact is created independently and not related to the vendor. In this case, to relate the
company contact to a vendor, drag the company contact to the Contacts folder of the vendor.

If you have installed Substance Compliance, you must add this contact either as material substance
declaration (MSD) contact or conflict mineral declaration (CMD) contact. The supplier declarations are
sent to the MSD or CMD contact when the compliance officer requests for material and substance
information.

To create a MSD or CMD contact:

1. Copy the company contact.

2. Select the vendor and click Edit→Paste Special.

3. In the Paste Special dialog box, select CMD Contacts or MSD Contacts.

4. Click OK.

Relate a vendor contact to a vendor location

1. In My Teamcenter, select the vendor and expand the Contacts  pseudofolder.

2. Open the Locations pseudofolder  under the vendor.

3. Drag the vendor contact from the Contacts pseudofolder  to the specific vendor location. For
example, if you have a vendor contact named John Doe, you can drag the contact to the Plano
pseudofolder.

Attach a file to a vendor, vendor part, or commercial part

You can attach files of supported data types to Vendor Management objects such as a vendor,
vendor part, or commercial part with the standard specified relations. Vendor Management provides
pseudofolders named Vendor Parts, Commercial Parts, Locations, Contacts, and Quality Documents
to attach the relevant documents.

1. Select a Vendor Management object such as a vendor, vendor part, or commercial part.

2. Choose File→New→Dataset.

Relate a vendor contact to a vendor location
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3. In the New Dataset dialog box, type a Name for the new dataset. Additionally, specify the
Description.

Select the type of file you want to attach from the Tool Used list or from the types displayed in the
left panel. Click More... in the left panel to view all the supported file types. The file type you select
is displayed in the left panel.

4. Click the (...) ellipsis button next to the Import field. In the Upload File dialog box, browse to select
the file and click Upload. Ensure that you select the same type of file as selected in the previous
step.

5. In the Relation list, select a relation that best describes what the file is. For example, if you are
attaching company information for your reference, you can select Reference as the Relation, or
if you are attaching quality documents for a particular vendor, select Quality Documents as the
Relation.

The dataset is displayed under the selected pseudofolder.

2. Creating and maintaining vendor and vendor part data
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Associate a quality document to a vendor

Place any object in the Quality Documents pseudofolder  to relate it to the vendor.

Classify a vendor

1. Select the vendor.

2. Right-click and choose Send To→Classification.

• If the vendor is already classified, you can view the classification parameters.

• If the vendor is not already classified, you must select a relevant class.

3. Expand the Classification Root and navigate to the appropriate category.

4. In the Properties tab, select the appropriate Vendor Status.

5. Specify up to three Vendor Contact Roles for the vendor from the three lists provided, and click
Save.

Associate a quality document to a vendor

Vendor Management on Rich Client ─ Usage, Teamcenter 2412  2-13
© 2025 Siemens



Qualifying vendors

After identifying potential suppliers, you may register them in Teamcenter. In Teamcenter you create a
vendor object for each vendor to store all relevant information.

After registering the potential vendors in Teamcenter, follow your organizational process to qualify
vendors. As part of the basic qualification process, you may perform a background check and review
the integrity and qualification of the vendor. Further, you may request vendors to provide information
on management system certificates or on corporate responsibility. You also request your vendors to
provide their consent to your organization’s code of conduct. The vendor selection process may involve
gathering pertinent information from vendors, using questionnaires or forms, interviews, or site visits.
You assess various aspects of a vendor’s business such as production capacity, financial data, product
and process quality, performance, adherence to environment and safety regulations, business stability
and sustainability, and risk evaluation. A vendor is scored based on these aspects and selected if the
score is acceptable. The status of a vendor qualified in this way is changed to approved. You can now
award the business to an approved vendor. Typically, businesses maintain a list of approved vendors
(Approved Vendor List, AVL).

Optionally, you may choose to register a supplier only after the supplier successfully passes the
qualification process.

Maintaining vendor data

Tasks involved in maintaining vendor data

Maintenance tasks may involve updating vendors, vendor roles, the company, or vendor contact
(company contact) information.

Updating vendor information Updating company
information

Updating vendor contact
information

Edit vendor properties Add a company location Add a company contact

Add or remove a vendor role Edit company location
properties

Edit a company contact

Delete a vendor Delete a location Delete a contact

In the Nanobox example, you have created vendors and set up the basic vendor information in Vendor
Management. Further, you have qualified the vendors. However, there may be changes in the business
environment that require corresponding updates to vendor data.

For example:

• Although Goodparts passed your vendor qualification process and is a qualified supplier for housings,
they have decided to stop manufacturing housings.

2. Creating and maintaining vendor and vendor part data
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In this case, you would remove Goodparts as the housing supplier and look for other suppliers to
supply housings.

• Bestparts shuts down operations in Denver, CO, to move to a new location.

In this scenario, you would update the vendor location.

• Penny leaves Patriot and moves to another organization.

In this case, Patriot nominates someone else as the vendor contact for your organization. You must
then create a new vendor contact to replace Penny.

Edit vendor properties

1. Right-click the required vendor and select Edit Properties.

2. In the Checking-Out... dialog box, specify a Change ID and Comments, and click OK.

3. In the Edit Properties dialog box, edit the properties and click Save and Check-In.

Edit vendor properties
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4. In the Checking-In... dialog box, select the vendor, and click OK.

Assign a role to a vendor or remove a role assigned to a vendor

You must not modify vendor roles using the standard Edit Properties dialog box. Add or remove a vendor
role such as Manufacturer, Distributor, or Supplier, from a Vendor revision object  as follows:

2. Creating and maintaining vendor and vendor part data
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1. In My Teamcenter, select a Vendor revision object.

2. Use the Tools→Vendor Management menu to choose Add Vendor Role or Remove Vendor Role.

3. Select the appropriate vendor role and click OK.

Assign a role to a vendor or remove a role assigned to a vendor
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Delete a vendor

1. In My Teamcenter, select the vendor you want to delete.

2. Choose Edit→Delete.

When a vendor is deleted, the associated locations and contacts are also deleted.

Edit company location properties

1. In My Teamcenter, select the Company Location object .

Note:

Checkin and checkout do not provide any revision mechanism for locations.

2. Choose View→Properties.

3. In the Properties dialog box for the company location, click Check-Out and Edit.

4. In the Checking-Out... dialog box, specify the Change ID, Comments, and select the vendor. Click
OK.

2. Creating and maintaining vendor and vendor part data
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5. In the Properties dialog box, edit the properties of the location.

6. Click Save and Check-In to check in the object.

Edit company location properties
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Delete a location

1. In My Teamcenter, expand the Locations folder under a vendor.

2. Select the location you want to delete.

3. Choose Edit→Delete.

This removes the location from the list of associated locations for the vendor from the database.

Edit a company contact

1. In My Teamcenter, select the Company Contact object.

Note:

Checkin and checkout do not provide any revision mechanism for the company contact.
When a property is updated, it overwrites the object with the new value.

2. Choose View→Properties.

3. In the Properties dialog box for the company contact, click Check-Out and Edit.

2. Creating and maintaining vendor and vendor part data
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4. In the Checking-Out... dialog box, specify the Change ID, Comments, and select the vendor. Click
OK.

Edit a company contact
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5. In the Edit Properties dialog box of the company contact, update the details.

6. Click Save and Check-In to check in the object.

Delete a contact

1. In My Teamcenter, expand the Contacts folder.

2. Creating and maintaining vendor and vendor part data
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2. Select the contact you want to delete.

3. Choose Edit→Delete.

This removes the contact from the list of associated contacts in the database.

Registering new vendor parts

Workflow for registering vendor parts

Continuing with the Nanobox example, let us assume that you have decided to outsource the Nanobox
connector and housing.

In the part structure for the Nanobox, the design engineers have created commercial parts to represent
the connector and housing to be sourced from suppliers. You can create vendor parts to represent
the connector and housing and relate them to the commercial parts that represent the housing and
connector. Alternatively, you may include the vendor parts in the part structure directly. You must create
a vendor part for the housing supplied by Bestparts and a different one for that supplied by Goodparts.

You can relate a location to a vendor part to indicate the manufacturing location. By doing so, you can
choose a vendor part that is manufactured closer to your manufacturing plant. For example, you may
choose to mark Bestpart’s housing from Nuremberg as a preferred part over Goodparts’ housing from
Hanover for your manufacturing plant in Stuttgart, Germany.

Similarly, you can mark parts manufactured in your country as preferred parts for that plant.

You can create a vendor part that is related to a commercial part included in the part structure.
Alternatively, you can create a vendor part that is directly included in the part structure.

The workflow for registering new vendor parts in Vendor Management is as follows:

Workflow for registering vendor parts
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Create a vendor part

(Optional) Relate a vendor part to a commercial part

(Optional) Relate a vendor part to a location

(Optional) Attach a file to a commercial part or vendor part

(Optional) Classify commercial parts and vendor parts

Create a vendor part

1. In My Teamcenter, select a folder and choose File→New→Part.

The system displays the New Part dialog box.

2. Creating and maintaining vendor and vendor part data
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Note:

To create a vendor part associated to a commercial part, select the Vendor Parts folder under
a Commercial Part Revision object and choose File→New→Part. The vendor part you create
is related to the selected revision of the commercial part.

2. Select Vendor Part and click Next.

3. In the Enter Part Information step, type values for ID / Revision - Vendor Part Name, or click
Assign to assign an ID and revision. Click Next.

4. In the Enter Additional Part Information step, specify the Vendor ID, Vendor Name, and
Location.

To choose a vendor from a list, click the  button next to the Vendor ID text box. In the Open
by Name dialog box that is displayed, specify Name or ID as the search criteria and click the Find
button. From the search results, double-click the required vendor.

Create a vendor part
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5. In the subsequent steps, provide additional attribute values as needed, and click Finish to create
the vendor part object.

Click Close to close the dialog box.

When you create a vendor part, information about related vendors, commercial parts, quality
documents, and vendor locations is organized into folders that the system creates. These
organizational folders are called pseudofolders.

2. Creating and maintaining vendor and vendor part data
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Note:

If you do not select the Vendor Parts folder under a Commercial Part Revision when
creating a vendor part, the vendor part is created independently and not related to the
commercial part revision. In such a case, to relate the vendor part to a commercial part
revision, drag-the vendor part to the Vendor Parts folder of the commercial part revision.

Relate a location to an existing vendor part

1. In My Teamcenter, select the Locations folder in the Vendors folder under a vendor part.

2. Drag a location from the vendor to the Provide From Locations folder  of the vendor part.

Relate a vendor part to a commercial part

Associate a Vendor Part object  to a Commercial Part revision object  as follows:

1. In My Teamcenter, select a Commercial Part revision.

2. Drag a vendor part to the Vendor Parts folder of the Commercial Part revision.

Attach a file to a vendor, vendor part, or commercial part

You can attach files of supported data types to Vendor Management objects such as a vendor,
vendor part, or commercial part with the standard specified relations. Vendor Management provides
pseudofolders named Vendor Parts, Commercial Parts, Locations, Contacts, and Quality Documents
to attach the relevant documents.

1. Select a Vendor Management object such as a vendor, vendor part, or commercial part.

2. Choose File→New→Dataset.

Relate a location to an existing vendor part
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3. In the New Dataset dialog box, type a Name for the new dataset. Additionally, specify the
Description.

Select the type of file you want to attach from the Tool Used list or from the types displayed in the
left panel. Click More... in the left panel to view all the supported file types. The file type you select
is displayed in the left panel.

4. Click the (...) ellipsis button next to the Import field. In the Upload File dialog box, browse to select
the file and click Upload. Ensure that you select the same type of file as selected in the previous
step.

5. In the Relation list, select a relation that best describes what the file is. For example, if you are
attaching company information for your reference, you can select Reference as the Relation, or
if you are attaching quality documents for a particular vendor, select Quality Documents as the
Relation.

The dataset is displayed under the selected pseudofolder.

2. Creating and maintaining vendor and vendor part data
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Classify commercial and vendor parts

When you use Vendor Management with Supplier Collaboration, you can classify vendor parts into
categories defined by your organization. This helps to quickly identify vendors for a particular category
of parts, for example, plastics.

1. Select the commercial part or vendor part.

2. Right-click and choose Send To→Classification.

• If the part is classified, the system displays the classification parameters.

• If the part is not already classified, the system prompts you to classify it. Select the particular
class where you want to classify that object.

3. Expand the Classification Root and navigate to the appropriate category.

4. In the Properties tab, select the appropriate Vendor Status.

5. In the Properties tab, specify up to three Vendor Contact Roles for the vendor from the three lists
provided.

6. Click Save.

Identify preferred vendor parts

You identify preferred vendor parts and set the status of a vendor part to preferred, backup, or
obsolete. You can set the status of one or more parts as preferred.

In the Nanobox example, you may choose to mark Bestpart’s housing from Nuremberg as a preferred
part for your manufacturing plant in Stuttgart, Germany as Nuremberg is closer to Stuttgart than
Hanover, where Goodparts manufactures housing, or because the quality of parts that come from
Bestpart’s Nuremberg location has been consistently good. You may want to mark Goodpart’s housing

Classify commercial and vendor parts
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as a backup part that you can order if Bestparts is unable to supply the required quantity or at the
required time.

However, if Goodparts decides to stop manufacturing housings, you would set the status of Goodparts
as obsolete.

1. In My Teamcenter, select a commercial part revision that has vendor parts associated with it. The
associated vendor parts are in the Vendor Parts folder under the housing revision.

2. Choose Tools→Vendor Management→Update Preferred Status.

The system displays the Preferred Status dialog box.

3. In the Preferred Status column, against each vendor part, set the status of each vendor part
associated with the selected commercial part revision. For example, in a standard Teamcenter
installation, you can set the status to Preferred, Backup, or Obsolete.

Note:

The available preferred status values are configured by your administrator and you cannot
enter other values.

2. Creating and maintaining vendor and vendor part data
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4. Click Apply and then click OK.

Maintain vendor part data

Maintaining vendor part data

The vendor manager is responsible for maintaining the vendor part information.

Updating vendor part
information

Updating the vendor Updating the location

Edit vendor part properties Copy vendor part data to a
new vendor

Add a location to a vendor part

Relate a vendor part to a
commercial part

Change the vendor of a vendor
part

Remove a location from a vendor part

Obsolete vendor parts no
longer in use

In the Nanobox example, you have created vendors and vendor parts and set up the basic vendor and
vendor part information in Vendor Management. However, there may be some changes in the business
environment that require corresponding updates to vendor part data.

For example:

• Requirements for the housing have changed.

In this case, the vendor parts for the housing provided by Goodparts and Bestparts may need to be
modified or you may want to obsolete them and replace them with new vendor parts.

• As Goodparts has decided to stop manufacturing housings, you have identified a new vendor, Parts
and More, to replace Goodparts.

In this case, you can copy the vendor part data to Parts and More as the specifications for the part
remain the same.

Maintaining vendor part data
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• Bestparts shuts down operations in Denver, CO, USA to move to a new location.

In this scenario, you remove Denver, CO, USA as the vendor part location from the Bestparts housing
part and add the new location to it.

Edit vendor part properties

1. Right-click the required vendor part and select Edit Properties.

2. In the Checking-Out... dialog box, specify a Change ID and Comments and select the vendor part.
Click OK.

3. In the Edit Properties dialog box, edit the properties and click Save and Check-In.

2. Creating and maintaining vendor and vendor part data
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4. In the Checking-In... dialog box, select the vendor part and click OK.

Relate a vendor part to a commercial part

Associate a Vendor Part object  to a Commercial Part revision object  as follows:

1. In My Teamcenter, select a Commercial Part revision.

2. Drag a vendor part to the Vendor Parts folder of the Commercial Part revision.

Relate a vendor part to a commercial part
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Obsolete vendor parts no longer in use

1. In My Teamcenter, select the commercial part revision.

2. Choose Tools→Vendor Management→Update Preferred Status.

3. Set the preferred status of each vendor part associated with the selected commercial part revision
to Obsolete.

Copy vendor part data to a new vendor

The VMS_Maintain_Vendor_History site preference controls whether the system moves or copies
the vendor parts. If the VMS_Maintain_Vendor_History site preference is set to TRUE, vendor
parts are moved to the new vendor but are not disassociated from the previous vendor. You
can change the vendor of a vendor part to copy the vendor part data to a new vendor if the
VMS_Maintain_Vendor_History site preference is set to TRUE.

1. Select a vendor part.

2. Choose Tools→Vendor Management→Change Vendor.

3. In the Change Vendor dialog box, type the New Vendor name.

To search for a vendor, click the  button next to the New Vendor box.

In the Open by Name dialog box, type either the Name or the ID of the vendor you are searching
for, and click Find. Double-click the required vendor from the displayed search results.

2. Creating and maintaining vendor and vendor part data
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The selected vendor is displayed in the Change Vendor dialog box.

4. Click OK.

Change the vendor of a vendor part

The VMS_Maintain_Vendor_History site preference controls whether the system moves or copies the
vendor parts. If the VMS_Maintain_Vendor_History site preference is set to the default value of TRUE,
vendor parts are copied to the new vendor but are not disassociated from the previous vendor. You can
change the vendor of a vendor part by copying the vendor part data to a new vendor.

If this preference is set to FALSE, vendor parts are moved to the new vendor and disassociated from the
previous vendor. You can change the vendor of a vendor part to another vendor when this preference is
set to FALSE.

1. Select one or more vendor parts.

2. Choose Tools→Vendor Management→Change Vendor.

Change the vendor of a vendor part
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3. In the Change Vendor dialog box, type the New Vendor name.

To search for a vendor, click the  button next to the New Vendor box.

In the Open by Name dialog box, type either the Name or ID of the vendor you are searching for
and click Find. Double-click the required vendor from the displayed search results.

The selected vendor is displayed in the Change Vendor dialog box.

4. Click OK.

2. Creating and maintaining vendor and vendor part data
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Relate a location to an existing vendor part

1. In My Teamcenter, select the Locations folder in the Vendors folder under a vendor part.

2. Drag a location from the vendor to the Provide From Locations folder  of the vendor part.

Remove a location from a vendor part

To remove locations from the list of associated locations for the vendor part:

1. In My Teamcenter, expand the Vendor Location folder under a vendor part.

2. Select the location you want to remove.

3. Choose Edit→Cut.

This only removes the association between the location and the vendor part. It does not delete the
location.

Relate a location to an existing vendor part
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