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1. About Partner Connect
Companies looking to reduce cost and overheads rely on outsourcing. One of the business models
that companies rely on when outsourcing is referred to as Contract Manufacturing. This is when a
company partners with a manufacturer to deliver an entire product or significant parts of the product.
The company owns the product design, while the manufacturing partner is responsible to deliver the
finished goods based on contractual obligations. This process requires tight collaboration between the
company and the partner to exchange product data, manage changes, and track related documentation.
Partner Connect helps companies, especially OEMs, work closely with their partners in an integrated
Teamcenter environment.

The Partner Connect process flow is as follows:

Using Partner Connect, a company can enable its partners to log on to their Teamcenter environment
and access only information that is relevant to the products that they are working on. The access is
controlled by using a partner contract, which allows a company to set time-bound access to specific
product information in Teamcenter. In the case of a company working with multiple partners, the
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partner contract also limits one partner from viewing information assigned to or managed by another
partner.

The role of Partner Connect in Teamcenter is as follows:

1. About Partner Connect
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2. Create a partner and assign a contract
To create a partner in Teamcenter, you designate a vendor as one. For this, you can either designate an
existing vendor as a partner or create a new vendor for this as follows:

1. Navigate to and open the folder where you want to create a vendor, for example, your Newstuff
folder.

2. Choose More commands  > New  > Create Vendor.

3. In the Create Vendor panel, select Vendor.

4. In the Properties section of the Create Vendor panel, enter the required vendor properties.

5. In the Locations section, click Add , and select Company Location.

6. Enter the required location properties and click Add.

7. Repeat the above steps until you complete adding the required locations.

8. In the Contacts section, click Add , and select Company Contact.

9. Enter the required company contact properties and click Add.

10. Repeat the above steps until you complete adding the required company contacts.

11. In the Partner Contracts section, click Add .

12. Specify the ID and Revision for the partner contract or accept the default values.
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2. Create a partner and assign a contract
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13. Specify a Name and Description for the partner contract.

14. Specify the period when the partner's contract is valid in the Start Date and End Date fields.

15. From the Locations list, select or type the location to be assigned to the partner contract.

16. In the Contacts list of the Partner Details section, select or type the company contact to be
assigned to the partner contract.

If you have selected a location, only company contacts from the location are available for selection.
If you have not selected a location, all company contacts are available for selection.

17. Click Add.

18. Click Create Vendor.

While creating a new vendor, if you add a partner contract and create the vendor, the partner
contract's status is Created . After the vendor is approved, you must assign a Teamcenter user
to a partner representative and then submit the partner contract to the Partner Contract
Qualification workflow for review and approval.
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2. Create a partner and assign a contract
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3. Designate an existing vendor as a
partner
To create a partner in Teamcenter, you designate a vendor as one. For this, you can either create a new
vendor or designate an existing vendor as a partner through the following actions:

1. Navigate to and open the folder where you have created the vendor, for example, your Newstuff
folder.

2. Select and open the vendor.

3. Click the Partner Contracts tab.

4. From the Work area toolbar, click Add .

5. Specify the ID and Revision for the partner contract or accept the default values.

6. Specify a Name and Description for the partner contract.

7. Specify the period for which the partner contract is valid in the Start Date and End Date fields.
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3. Designate an existing vendor as a partner
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8. From the Locations list, select or type the location to be assigned to the partner contract.

9. From the Contacts list of the Partner Details section, select or type the company contact to be
assigned to the partner contract.

If you have selected a location, only company contacts from the location are available for selection.
If you have not selected a location, all company contacts are available for selection.

10. Click Add.

In an approved existing vendor, the partner contract is automatically submitted for review and
approval through the Partner Contract Qualification workflow. The status of the contract is
updated to Approval Pending , and a signoff task is created in My Tasks. Now, you must assign
a Teamcenter user to a partner representative and then review and approve the partner
contract.
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3. Designate an existing vendor as a partner
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4. Assign a Teamcenter user account to a
partner representative
The representative of the partner assigned to the contract must be able to log on and access their
assigned product and part data. To enable this, you must assign a Teamcenter user account to the
partner representative.

Note:

After completing the assignment, share the assigned Teamcenter user account's credentials with
the partner representative.

The partner representative can then log on by using this Teamcenter user account's credentials and work
on the assigned product and part data.

To assign a Teamcenter user account to a partner representative, do the following:

1. Navigate to and open the folder where you created the partner, for example, your Newstuff folder.

2. Select and open the partner.

3. Click the Partner Contracts tab.

4. Select and open a partner contract whose status is Approval Pending .

For example, the Partner Contract for Housing partner contract's status is Approval Pending .

5. In the Company Contacts section, select the partner representative to provide access.

6. Choose More commands  > Manage > Add Partner User.

7. In the Add Partner User panel, search for and select the required Teamcenter user account.
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Caution:

You can assign a Teamcenter user account to only one partner representative at a time.

8. Click Add.

After assigning a Teamcenter user account, you must review and approve the partner contract.

9. To assign another Teamcenter user account to the partner representative, you must first remove the
existing Teamcenter user account as follows:

a. Choose More commands  > Manage > Remove Partner User.

b. In the confirmation dialog box, click Remove.

4. Assign a Teamcenter user account to a partner representative
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5. Activate a company contact
After you create a company contact and assign a partner user to it, you must activate it to make it
available. Submit the company contact to the Activate Company Contact workflow to activate it. Now,
the assigned partner user can log on to Teamcenter.

Note:

You can activate a company contact only if it is associated with an approved vendor.

1. Log on as a user with DBA privileges.

2. Navigate to and open the folder where you have created the vendor, for example, your Newstuff
folder.

3. Select and open the vendor.

4. In the Overview tab, in the Company Contacts section, select and open the required company
contact.

5. Choose More commands  > Manage > Submit to Workflow.

6. From the Template list, select Activate Company Contact, and click Submit.
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7. In the INBOX tile, select the select-signoff-team task, enter your comments in the Comments box,
and click Complete.

8. In the INBOX tile, select the perform signoffs task, and click Approve.

The company contact's Partner User Status is updated to 0 to indicate that the company contact is
active.

5. Activate a company contact
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6. Submit a partner contract for approval
1. Navigate to and open the folder where you created the partner, for example, your Newstuff folder.

2. Select and open the partner.

3. Click the Partner Contracts tab.

4. Select the partner contract that you want to submit for approval.

5. Choose More commands  > Manage > Submit to Workflow.

6. From the Template list, select Partner Contract Qualification, and click Submit.
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6. Submit a partner contract for approval
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7. Review and approve a partner contract
1. In the INBOX tile, select the perform signoffs task for the required partner contract.

2. In the Overview tab, click Approve to approve the partner contract.

The partner contract's status is updated to Approved  in the Partner Contract tab of the partner.
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7. Review and approve a partner contract
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8. Edit a partner contract to change the
validity, add or remove suppliers, and add
or remove locations
You can edit a partner contract only if the following prerequisites are met:

• The External Data ACL is installed.

• The partner contract is approved.

To edit a partner contract:

1. Navigate to and open the folder where you created the partner, for example, your Newstuff folder.

2. Select and open the partner.

3. Click the Partner Contracts tab.

4. Select an approved partner contract that you want to edit.

5. Choose More commands  > New  > Revise.

6. Enter the properties for the new revision and click Save.

The partner contract's revision is created and displayed in edit mode.

7. Make the required edits in the partner contract, and choose More commands  > Edit > Save
Edits.

The partner contract's status is Created . Now, you must submit the partner contract to
the Partner Contract Qualification workflow for review and approval. When you create a new
revision, the earlier partner contract revision's status is updated to Obsolete .
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8. Edit a partner contract to change the validity, add or remove suppliers, and add or remove locations
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9. Assign a partner contract to a configured
assembly or subassembly
1. Create the required variant rules in Teamcenter Structure Manager.

2. Apply a variant rule to the required assembly or subassemblies in the assembly to display the
required child items.

For example, you have a Baseplate Assembly where you have not applied any variant rules are
follows:

When you apply the variant rule to display the required child items, the Baseplate Assembly now
displays as follows:
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The Motor Electronics Assembly is removed from the Baseplate Assembly when you apply the
variant rule.

3. After applying the required variant rule, create a saved working context as follows:

a. Choose More commands  > New  > Working Context.

b. From the type of working context list, select Save Working Context.

c. In the Save Working Context pane, enter a name and a description.

d. Select the Allow others to view check box to grant read access to other users.

e. Click Save As.

4. In this saved working context, assign a partner contract as follows.

a. Select one or more required assembly or subassemblies in the assembly.

b. In the right pane, click the Partners tab.

c. Click Add Partner.

d. In the Add Partner panel, select the partner from the Vendor list.

This list displays only approved vendors who are partners.

9. Assign a partner contract to a configured assembly or subassembly
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e. From the Partner Contract list, select the applicable contract.

This list displays only approved and active partner contracts that are available for the selected
assembly or subassemblies in the assembly. If a partner contract is already assigned to the
selected assembly or subassemblies in the assembly, it does not appear in this list.

f. From the Preferred Status list, select the type of preference to assign to the partner contract.

g. To assign the partner contract to all child items in the selected assembly or subassemblies in
the assembly, select All Levels.

h. To send a notification email to the company contacts assigned to the partner contract, select
Notify Partner.

i. (Optional) Select Run in Background to continue working while the partner contract is
assigned to the selected assembly or subassemblies in the assembly.

j. Click Add.
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When the partner representative logs on and views the assigned parts, assembly, or
subassemblies in the assembly, they can view only those child items where they have access.
Inaccessible child items are indicated by UNREADABLE in the assembly.

9. Assign a partner contract to a configured assembly or subassembly

9-4  Partner Connect ─ Usage, Teamcenter 2412
© 2025 Siemens



10. Assign a partner contract to a part or an
unconfigured assembly or subassembly
1. Navigate to, open the required product, and select one or more required parts, assembly, or

subassemblies in the assembly.

2. In the right pane, click the Partners tab.

3. Click Add Partner.

4. In the Add Partner panel, select the partner from the Vendor list.

This list displays only approved vendors who are partners.

5. From the Partner Contract list, select the applicable contract.
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This list displays only approved and active partner contracts that are available for the selected parts,
assembly, or subassemblies in the assembly. If a partner contract is already assigned to the selected
parts, assembly, or subassemblies in the assembly, it does not appear in this list.

6. From the Preferred Status list, select the type of preference to assign to the partner contract.

7. If you try assigning the partner contract to an unconfigured assembly or subassemblies in the
assembly, you receive a warning. Click Assign in the warning to proceed with the assignment.

8. To assign the partner contract to all child items in the selected assembly or subassemblies in the
assembly, select All Levels.

9. To send a notification email to the company contacts assigned to the partner contract, select Notify
Partner.

10. (Optional) Select Run in Background to continue working while the partner contract is assigned to
the selected parts, assembly, or subassemblies in the assembly.

11. Click Add.

10. Assign a partner contract to a part or an unconfigured assembly or subassembly
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11. Manually assign partner contracts to
vendor parts
When you assign a partner contract to an assembly, by default, it is assigned to its child items,
subassemblies, and commercial parts. However, you can manually assign the partner contract to the
vendor parts in the commercial part depending on the settings configured for your site. If you are unable
to manually assign the partner contract to vendor parts, contact your administrator.

To manually assign a partner contract to the vendor parts in a commercial part, do the following:

1. Open the required product, and select the required assembly or subassembly that contains the
commercial part.

2. In the right pane, click the Partners tab and open the partner contract.

3. In the partner contract, click the Assignments tab.

4. In the Assigned Vendor Parts section, click Add to.

5. In the Add panel, from the Product list, select the commercial part that contains the associated
vendor parts.

The associated vendor parts are displayed.

6. Select the required vendor parts and click Add.

The selected vendor parts appear in the Assigned Vendor Parts section.
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11. Manually assign partner contracts to vendor parts
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12. Revoke the partner’s access from a part,
assembly, or subassembly
To revoke the partner's access, you must remove the partner contract from the required part, assembly,
or subassembly in the assembly.

1. Navigate to, open the required product, and select the required part, assembly, or subassembly in
the assembly.

2. In the right pane, click the Partners tab.

3. Select the required contract and click Remove.

4. In the Remove Partners panel, to remove the partner contract from all child items in the selected
assembly or subassembly, select All Levels.

5. To send a notification email to the assigned company contacts about the removal, select Notify
Partner.

6. (Optional) Select Run in Background to continue working while the partner contract is removed
from the selected assembly or subassembly.
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12. Revoke the partner’s access from a part, assembly, or subassembly
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13. Track changes to partner contract
assignments in a change notice
In a change notice, when you assign or remove partner contracts from the parent part of an assembly,
these changes are displayed as follows:

• Deleted partner contracts are highlighted with red strike-through.

• Added partner contracts are highlighted in green and are italicized.

Caution:

These changes are displayed only when you modify the partner contracts from the parent part of
an assembly.

You can track these changes to partner contracts in the following scenario:

1. Assign a partner contract to the parent part of the assembly and create a change notice for the
parent part.

2. Open the change notice and click the Affected Items tab.

3. In this tab, select the assembly in the Problem Items section and revise it to create a solution item
for the change notice.

4. Open the solution item and click the Partners tab to view the existing assigned partner contracts.

5. Add a new partner contract or remove an existing assigned partner contract.

The changes in the partner contract assignments are displayed in the Partners tab.
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If the change notice is released, these changes are not visible by default. Choose More commands
 > View > Show Redlines to display the changes.

13. Track changes to partner contract assignments in a change notice

13-2  Partner Connect ─ Usage, Teamcenter 2412
© 2025 Siemens



14. Managing the vendor lifecycle
Impact of the vendor lifecycle on its associated objects

When the status of the vendor changes, the statuses of its associated objects are also updated to ensure
that their statuses are in sync. This ensures data security for OEMs. A vendor’s associated objects are
company contacts, partner users, and partner contracts.

Retire a partner contract

If you want to discontinue a particular partner contract, you must first retire it, and then delete it. You
cannot retire a vendor if the vendor has approved partner contracts.

1. Navigate to and open the folder where you created the partner, for example, your Newstuff folder.

2. Select and open the partner.

3. Click the Partner Contracts tab.

4. Select a partner contract that you want to retire.
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5. Choose More commands  > Manage > Submit to Workflow.

6. From the Template list, select Retire Partner Contract, and click Submit.

The partner contract's status is updated to Obsolete . The partner users no longer have access to
the data that was available through the partner contract.

7. To delete the retired obsolete partner contract, select it and do the following:

14. Managing the vendor lifecycle
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a. Choose More commands  > Edit > Delete.

b. In the confirmation dialog box, click Delete.

Deactivate a company contact

If a company contact is no longer working for the vendor, you must deactivate it to remove its access.
Submit the company contact to the Deactivate Company Contact workflow to deactivate it. Now, the
company contact cannot log on to Teamcenter.

1. Log on as a user with DBA privileges.

2. Navigate to and open the folder where you have created the vendor, for example, your Newstuff
folder.

3. Select and open the vendor.

4. In the Overview tab, in the Company Contacts section, select and open the required company
contact.

5. Choose More commands  > Manage > Submit to Workflow.

6. From the Template list, select Deactivate Company Contact, and click Submit.

Deactivate a company contact
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7. In the INBOX tile, select the select-signoff-team task, enter your comments in the Comments box,
and click Complete.

8. In the INBOX tile, select the perform signoffs task, and click Approve.

The company contact's Partner User Status is updated to 1 to indicate that the company contact is
deactivated. Now, the company contact cannot log on to Teamcenter.

14. Managing the vendor lifecycle
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Retire a vendor

If a vendor no longer manufactures the parts that you require, you must retire it. Submit the vendor to
the Retire Vendor workflow to retire it.

Note:

You can retire vendors only if they do not have any approved partner contracts.

If the vendor has partner contracts that are in any status except Approved, then these partner
contracts are obsoleted by default when you retire a vendor.

1. Log on as a user with DBA privileges.

2. Navigate to and open the folder where you have created the vendor, for example, your Newstuff
folder.

3. Select and open the vendor.

4. Choose More commands  > Manage > Submit to Workflow.

5. From the Template list, select Retire Vendor, and click Submit.

Retire a vendor
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6. In the INBOX tile, select the select-signoff-team task, enter your comments in the Comments box,
and click Complete.

7. In the INBOX tile, select the perform signoffs task, and click Approve.

The vendor's Registration Status is updated to Obsolete to indicate that the vendor is retired. The
associated company contacts are deactivated.

14. Managing the vendor lifecycle
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