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1. Introduction to Simulation Process and
Data Management
About Simulation Process and Data Management

Design is an iterative process and often designs need to be modified due to manufacturing constraints or
conflicting requirements. It is possible to reduce costs and minimize the time spent on verification and
testing by arriving at a good design in the initial stages of product development and by continuously
validating the design throughout the product lifecycle. Simulation Process and Data Management is a
solution used for validating or improving a design in the early stages of the product lifecycle.

Where do I go from here?

 Simulation administrator See Simulation Process and Data Management ─
Deployment and Administration.

 Simulation analyst

I want to perform simulation
analysis in Active Workspace

See Simulation Process and Data Management on Active
Workspace ─ Usage.

Prepare the data for analysis You prepare the data for analysis by simplifying the CAD
geometry. After simplifying the CAD geometry by using
the appropriate software, you can launch a preconfigured
simulation tool to export the simplified CAD geometry. See
Prepare the data for analysis.

Create geometry revisions for the
components you want to analyze

You can create geometry revisions for the components you
want to analyze and upload the simplified CAD geometry
to the revision. The geometry revision is often different
from the product geometry. It may be a simplified or an
abstracted version, or an approximation when the product
geometry is not available. See Create geometry revisions in
My Teamcenter.

Create the simulation model and
define a mesh

While analyzing a large product structure with thousands
of components, you can create simulation models or model
structures using one of the following options:

• CAE Structure Map: Generate a model structure for a
specific type of analysis using predefined structure map
rules. See Create a model structure for a specific type of
analysis using structure map rules.

The lead analyst or the designated analyst creates
structure map rules.
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• Data Map: Some organizations prefer not to use structure
map rules. They prefer to create a model structure that
is an exact replica of the product structure using this
option. After creating this replica model structure, they use
predefined derivative rules and variant configuration rules
to quickly derive one or more structures relevant to their
analysis from the model structure. See Create a model
structure using data map rules.

The simulation administrator defines the data map rules.
Create the analysis model and
define load cases

The analysis model represents the specific analysis such as
thermal, structural, or fluid you want to perform. It includes
load cases, solver parameters, and boundary conditions.
After creating the analysis model or revision, you can select
the specific revision and launch a preconfigured simulation
to upload the load cases, solver parameters, and perform
the solve. See Create the analysis model and solve the
analysis.

Launch simulation tools Simulation Process and Data Management provides a
framework for launching simulation tools that include
preprocessors, solvers, postprocessors, and other tools. You
can launch simulation tools as a local launch, local detached
launch, remote launch, or server launch, depending on how
the administrator configures the launch parameters at your
site. See Launching simulation tools.

Solve the analysis You can solve the analysis by launching preconfigured
simulation tools. After capturing results from different solvers
and verifying results, the analysis data can be released
to production. The data is released by signing off from a
workflow. You can make recommendations while signing off
the workflow. See Capture results from different solvers
and verify results.

Derive structures You can use predefined derivative rules and variant
configuration rules to quickly derive one or more structures
relevant to your analysis from an existing structure.

The simulation administrator defines derivative rules and
variant configuration rules.

You can use these predefined rules to quickly derive one
or more simulation variants from an existing one. See Why
derive structures?.

Capture pedigree information Capturing the exact configuration of the product and
model structure is critical to understand what was analyzed
at a later time. Pedigree information captures the exact
configuration of various structures, including the revision
rule, effectivity, and variant rules, and persists that
information in the database. Therefore, as a simulation

1. Introduction to Simulation Process and Data Management
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analyst, you have clear traceability of what was analyzed. See
Why capture pedigree information?.

Use the simulation dashboard The simulation dashboard provides a clear view of the status
of all the models and analyses carried out by simulation
analysts at the program, milestone, group, or individual
user level. It allows decision makers to access the latest
information and make correct decisions. See Why use the
simulation dashboard?.

What is Simulation Process and Data Management?

The workflow for managing the simulation process is as follows:

Understanding Simulation Process and Data Management using an example

1. View the analysis request

Let us assume that you (as a simulation analyst) are an expert in simulated automobile crash
testing. The analysis request is to perform a simulated side-impact test for a design change made to
the driver-side door.

2. Prepare or refine the design data for analysis

Your first task is to import the product geometry and simplify it to make it relevant for the analysis.
The driver-side door has a speaker; switches for the door lock; power window; and electric mirror;
an intrusion beam; steel frames; door panels; and other parts. The speaker and switches are not
relevant for the simulated side-impact analysis. You import the complete product geometry and

What is Simulation Process and Data Management?
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use a simplification tool to remove the speaker and switches. Then, you create geometry revisions
for the intrusion beam, steel frame, and door panel, and save the simplified geometry for each
component.

3. Create models

The model you want to analyze includes the mesh definition, connections, and material and
physical properties. In this step, you create model revisions—in the context of the geometry
revisions—for the intrusion beam, steel frame, and door panel. Then, you select the appropriate
meshing tool to generate meshes for each component.

4. Create the analysis and solve the analysis

The analysis you want to perform includes load cases, solver parameters, and boundary conditions.
In this step, you create analysis revisions—in the context of the model revisions—for the intrusion
beam, steel frame, and door panel. Then, you select the appropriate solver tool to specify load
cases and solver parameters.

In this example, you create different analyses to vary the load cases, for example, a 3000 pound
SUV-like barrier hits the driver side door at 30 mph. You also create another analysis model to
change the barrier weight to 3200 pounds and the speed to 35 mph.

5. Evaluate the results and send recommendations

The intrusion beam acts as an energy-absorbing material during a side impact. The results show
that the intrusion beam cannot withstand forces of 3200 pounds at 35 mph. After evaluating
results from various scenarios, you sign off the workflow by suggesting a design change for the
intrusion beam.

Creating and managing CAE data in Teamcenter

Simulation Process and Data Management leverages Teamcenter to manage CAE/simulation data on a
centralized basis.

Simulation Process and Data Management leverages Teamcenter to manage CAE/simulation data on a
centralized basis. You can integrate data from a CAE system of your choice into the product lifecycle
management (PLM) environment. It is built as an extension of Teamcenter and, therefore, you have
access to the latest product structures and configurations. Moreover, the data model in Teamcenter has
been enhanced to include CAE-specific objects to improve simulation process and data management
capabilities using Simulation Process and Data Management.

You can use the CAE Manager application to create and manage CAE data in Teamcenter.

1. Introduction to Simulation Process and Data Management
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Simulation Process and Data Management is extremely flexible and depends on the procedures and
policies implemented at your site.

• Locate the data.

You can import and create data for your analysis, or you can search for data in Teamcenter to:

• Find an existing CAD model to perform analysis.

• Find a previous CAE analysis to reuse portions or modify the analysis.

• Find other data that can be used as inputs or contribute to a CAE analysis.

• Create and manage CAE structures.

You can use the Structure Map Designer view to define CAE structures. These structures are similar
to, and are often based on, product structures.

Your administrator can define structure maps to apply structure rules to support your analysis. For
example, you can define a structure rule that automatically removes connectors such as nuts, bolts, or
pins from the CAE structure. For impact analyses such as drop tests or crash tests, the structure map
might add parts to the structure, such as a barrier or crash test dummy.

Creating and managing CAE data in Teamcenter
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• Perform an analysis.

You can use CAE Manager to:

• Launch third-party Simulation Process and Data Management tools needed to mesh and prepare a
model for analysis.

• Import preprocessed models into Teamcenter.

• Create new item revisions.

To work with an existing item revision that is released, frozen, or locked, you must create a new
item revision. You may need to create item revisions at other times, depending on your organization’s
policies and procedures.

When you create a new item revision:

• The previous item revision is stored and managed as a separate entity.

• Related objects and object references are copied to the new revision according to the deep copy
rules configured at your site.

• Release data to production.

You release data by completing a workflow. Your administrator implements a workflow for the CAE
processes. When every member of the signoff team has signed off the workflow, the items in that
workflow are released, frozen, or locked.

• Any released, frozen, or locked item cannot be modified without a creating a new revision.

• The datasets under a released, frozen, or locked item also cannot be modified.

Basic tasks

• Locate data to perform an analysis

You can import and create data for your analysis, or you can search for data in Teamcenter to find:

• An existing CAD model to perform analysis.

• A previous CAE analysis to reuse or modify.

• Other data to use as input or contribute to a CAE analysis.

• Create CAE items to manage CAE information

1. Introduction to Simulation Process and Data Management
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CAE items are the fundamental workspace objects in Teamcenter and you can use them to maintain
the CAE representation of a product, part, or component. They also maintain the definition of the
analysis performed on these items, and the results of the analysis.

You can create CAE items in My Teamcenter and CAE Manager applications using the New CAE Item
dialog box.

• Use Simple Search from the main toolbar in CAE Manager to perform a simple search by specifying
the search criteria.

• Send data for analysis

1. Select the required non-CAE item or a CAE item in My Teamcenter or a product structure in
Structure Manager.

2. Right-click the non-CAE item or a CAE item and choose Send To→CAE Manager, or drag the
non-CAE item or the CAE item on CAE Manager  in the navigation pane of the rich client.

• Generate CAE model structures

You can view a non-CAE item revision in the Product view, apply data map or structure map
definitions to it, and generate corresponding CAE model structures.

• Launch simulation tools

You can launch simulation tools from Simulation Process and Data Management to send a product
structure to a preconfigured application for analysis. Analysis tools provide accurate results on design
behavior. After the analysis is complete, the results are imported back to Teamcenter. You can view
the results and make changes to the product structure as appropriate.

• Solve the analysis and postprocess the results

You can launch any preconfigured solver and when the solve is complete, you can use Teamcenter to
manage output files and share postprocessing displays.

• View the results and release the data when the analysis is complete

You can view postprocessing displays, access reports and presentations associated with the results,
and release the analysis data to production. You release data by signing off from a preconfigured
workflow.

Objects you work with

• Geometry revisions

Objects you work with
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The CAD model is used to define the geometry of a part or an assembly. During the final stages of the
design process, the geometry contains numerous details, such as sharp edges, bolt holes, or fillets,
which are not required for the analysis. The geometry used for simulation analysis is often different
from the product geometry. It may be a simplified or an abstracted version or an approximation when
the product geometry is not available. CAE 3D Geometry revisions are workspace objects for storing
the simplified geometry. Geometry revisions are created in the context of the item revisions in the
product structure.

• Model revisions

A mesh represents a geometric object as a set of finite elements. Finite element analysis (FEA) is a
computerized method for simulating how a part reacts to conditions such as force, heat, vibration,
and other physical effects in the real world. CAE 3D Model revisions are workspace objects for storing
the mesh definition, connections, and material and physical properties. Model revisions are created in
the context of geometry revisions.

• Analysis revisions

An analysis revision represents the specific simulation you want to perform. CAE 3D Analysis
revisions are workspace objects for including load cases, solver parameters, and boundary conditions.
Analysis revisions are created in the context of model revisions.

• Result revisions

A result revision represents the results of a simulation analysis. CAE 3D Result revisions are
workspace objects for storing the results of a solve. They may contain JT files or other visualization
files that are the results of a solve. Result revisions are associated with analysis revisions.

You can create the following CAE revisions in the context of other revisions along with relationships:

Context
revision

CAE revisions you can
create for the context
revision

Default relationships

Product
structure

CAE 3D Geometry TC_CAE_SOURCE and
TC_CAE_TARGET

CAE 3D Model

CAE 3D Analysis

CAE 3D
Geometry

CAE 3D Model TC_CAE_SOURCE

CAE 3D Analysis

CAE 3D Model CAE 3D Analysis TC_CAE_DEFINING

CAE 3D
Analysis

CAE 3D Analysis TC_CAE_INCLUDE

CAE 3D Result TC_CAE_RESULTS

1. Introduction to Simulation Process and Data Management

1-8  Simulation Process and Data Management on Rich Client ─ Usage, Teamcenter 2412
© 2025 Siemens



The following is an example of the default simulation data model.

Personalize the interface

Customize your I Want To links in the rich client

The I Want To links, which are both user specific and application specific, can provide quick access to the
tools you use to perform common tasks.

• When you create an I Want To action, you do so in the context of the currently active application.

• To create the same action in a different application, you must repeat the process.

The Create an Item, Create a Dataset, and Create a Workflow Process links are provided in your
Teamcenter installation.

Personalize the interface
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You can add links to other tasks, remove links to tasks, and organize the display order of tasks.

Customize CAE Manager I Want To links

1. Open CAE Manager.

2. From the Product, Model, or Analysis view, click View Menu , and choose I Want To (View
Level) to open the Customize I Want To dialog box.

3. To customize the I Want To links, expand the available options and use the navigation buttons to
add or remove the options.

Customize appearance of quick links

You can customize the appearance of Quick Links by adding My Projects to the quick links. You
can do this by editing the default values of the QuickLinksSection user preference to add the
MyProjectsSectionComponent value.

Set preferences to control the behavior and appearance of
Teamcenter

You can use preferences to control various aspects of Teamcenter's behavior and appearance.

For more information, see Teamcenter Preferences.

For information about retrieving a list of preferences, see Where can I get a list of preferences?

1. Introduction to Simulation Process and Data Management
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2. Prepare the data for analysis
Prepare the data for analysis

1. View the analysis request

An engineering manager reviews design requirements and assigns design changes for validation
to a simulation analyst using a workflow. The workflow contains the design requirements,
configuration information, subassembly, and components required for analysis.

To read your mail, in My Teamcenter, open your Mailbox folder, and click the envelope to display
the contents in the Viewer pane.

If your organization does not follow a workflow process, search for a target structure and select the
data for the analysis.

2. (Optional) Apply revision rules, variant rules, or effectivity

If you work in a product environment with a lot of variability, such as the automobile industry, you
can apply revision rules, effectivity, or variant rules to make the product structure relevant to your
analysis.

3. Create geometry revisions for components for which you want to simplify the CAD geometry

Create geometry revisions for the components for which you want to simplify the CAD geometry.
The geometry revision is often different from the product geometry. It may be a simplified or an
abstracted version, or an approximation when the product geometry is not available.
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4. Launch a preconfigured simulation tool to export and simplify the CAD geometry

The CAD model is used to define the geometry of a part or an assembly. During the final stages
of the design process, the geometry contains numerous details, such as sharp edges, bolt holes,
or fillets, which are not required for the analysis. You can launch a preconfigured simulation tool
to automatically export the CAD geometry. Then, you simplify the product geometry using a
simplification tool.

5. Upload the simplified geometry to the geometry revision you created

You can upload the simplified geometry to the geometry revision you created.

Performing CAE analysis

Using CAE Manager, you can define and manipulate hierarchical CAE models that can reference target
CAD models and source CAD or CAE geometry item revisions. It includes functionality to define and
manage CAE analysis objects that reference CAE models and solver parameters. You can use the CAE
analysis objects to manage analysis results.

You can perform the following tasks in CAE Manager:

• Identify the required product data for analysis and analyze CAE data.

• Verify the analysis tasks that are complete and those that remain to be done.

• Determine the portions of the model that will be included in analysis (CAE BOM).

• Streamline analysis processes by using structure maps (if implemented).

• Launch third-party authoring tools needed to mesh and prepare a model for analysis.

• Import preprocessed models into Teamcenter.

The CAE Manager perspective allows you to identify product data for analysis and create and manage
corresponding CAE data. The CAE Manager perspective consists of the following three primary views:

• Product enables you to interactively identify hierarchical product structures that are referenced by
CAE 3D Analysis item revisions.

• Model enables you to interactively define and manipulate hierarchical CAE models that can reference
target CAD models and source CAD or CAE geometry.

• Analysis enables you to interactively define and populate CAE 3D Analysis item revisions that can
reference a defining CAE 3D Analysis item revision. It lets you manage the solver execution results,
relate the results to a CAE 3D Analysis item, and assign solver parameters that define CAE analysis.

2. Prepare the data for analysis
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Additionally, you can use the Inspector view to evaluate the CAE 3D Analysis structure against the
product structure. You can view inconsistencies between the CAE 3D Analysis and product structures
based on some established criteria and select the inconsistencies that you want to correct.

Perform an advanced search to locate the data

You can import and create data for your analysis, or you can search for data in Teamcenter to find an
existing CAD model to perform analysis on, to find a previous CAE analysis to reuse or modify, or to find
other data that can be used as input or contribute to a CAE analysis.

1. Select Advanced from the search menu at the top of the navigation pane.

2. On the Search view toolbar, click  to select a search from the list of search types.

3. Click More and select one of the following:

• CAE 3D Analysis Revision, CAE 3D Analysis Revision, or CAE 3D Result Revision to find
analysis revisions, model revisions, or result revisions, respectively.

• CAE – Find Single-Level Related Model or CAE – Find Single-Level Related Analysis to find all
associated models or analyses of a specific product item revision.

In the CAD Item Revision ID query field, you can type a question mark (?) to query for all the
CAE models generated on the latest revision rather than all revisions.

• CAE – Find Multi-Level Related Models or CAE – Find Multi-Level Related Analysis to find
all associated models or analyses for the selected CAD at the components, subassemblies, and
variant levels. You can use this query to identify all models impacted by the design change of a
product item revision.

4. Enter the search criteria and click Search  to perform the search.

Viewing the product structure

Use the Product view to interactively identify hierarchical non-CAE item revisions that are referenced by
CAE 3D Model item revisions loaded in the Model view. The Product view contains read-only and BOM
view attributes. You can view and manage non-CAE item revisions, but you cannot create any new items
in this view.

While performing simulations on large and complex product structures, you must frequently build large
model structures. With large product or model structures, it is difficult to navigate through the entire
structure and find information. Similar to filtering data in spreadsheets, you can apply multiple filters to
large structures and view only those structure lines that are relevant to your simulation analysis.

Perform an advanced search to locate the data
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The CAE BOM Compare report is color coded. You can run this report to view and compare two
different simulation variants side-by-side to understand their differences. Similarly, you can compare
target references with associated product structures. The system applies color coding to highlight the
differences in the product structure. Even if you apply multiple filters after performing a BOM or target-
reference comparison, the system retains the color coding in the structure lines.

You can perform the following tasks in the Product view:

• View hierarchical non-CAE item revisions.

• View the composite structure of non-CAE item revisions in context of the derived CAE model
structure.

• Apply multiple filter criteria to filter structures and view only the structure lines that are relevant to
your simulation.

• View and manage configuration rules.

• Launch simulation tools.

• Create CAE packages.

• Generate consistent CAE model structures, using the data map or structure map function.

• View and manage attachments.

• Perform Where Used or Where Referenced searches.

• View an image of the selected line or structure, if the DirectModel dataset is available.

View the product structure in CAE Manager

1. Search for the product item revision in My Teamcenter.

2. Right-click the product item revision and choose Send To→CAE Manager, or drag the product item
revision on CAE Manager  in the navigation pane of the rich client.

Reorganize the product structure to make it suitable for simulation
analysis

As a simulation analyst, the product structure you receive may not have all the data or it may not
be organized in a manner that is suitable for simulation analysis. Before you start reorganizing the
structure, you require a collector item or a placeholder to store the new structure.

2. Prepare the data for analysis
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You can create CAE 3D Product Collector revision objects in Teamcenter to store the new structure.
The new structure you create using this revision object is called a product collector structure. It is similar
to the product structure.

You can create collector structures in different ways. For example, you can:

• Create a flat structure by copying only the leaf nodes and by ignoring all the intermediate
subassembly levels created by the designers.

• Organize the components differently under different subcollectors in a manner that is more efficient
for simulation analysis.

• Choose desired parts or subassemblies from more than one product structure.

1. Open one or more product structures in the Product view of CAE Manager.

2. Create CAE 3D Product Collector revision objects in the context of the open product structures.

3. Open the CAE 3D Product Collector revision in the Product view of CAE Manager.

4. Copy the required BOM lines with parts and subassemblies from the other product structures to the
product collector structure.

Reorganize the product structure to make it suitable for simulation analysis
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You can then reorganize the structure by adding, removing, or moving BOM lines from one level to
another.

5. Copy the positional information, if available, from the original product structures.

6. Save the structure and (optional) mark it as Precise for downstream analysis processes.

7. To create a model structure that is an exact replica of the product structure, click Generate CAE
Structure from Data Map on the view toolbar and choose the CAE domain.

This is the default domain. It maps the CAD assembly to the CAE model structure.

After creating the model structure, you can use predefined derivative rules to derive one more
structures.

8. To create a model structure that is an exact replica of the product structure with mapped JT files
from the source product collector, click Generate CAE Structure from Data Map on the view
toolbar and choose the CFD domain.

This domain maps JT files from the CAD assembly to the CAE model structure.

9. Click Generate CAE Structure from StructureMap on the view toolbar to create model structures
for specific types of analyses using predefined structure map rules.

10. Create analysis packages or CAE packages from predefined definitions.

11. Perform a solve by launching a simulation tool.

12. Capture results from the solver and verify results.

13. (Optional) Export the collector structure.

a. Select the root item of the structure and click Tools > Export > To PLMXML.

b. In the Export Directory area, click the Browse button select the directory to which you want
to export the collector structure.

c. Select the appropriate transfer mode, for example, CAEConfiguredDataFilesExportDefault.

d. To export the collector structure, click OK.

Open product, model, and analysis revisions in multiple views

• You can open multiple instances of Product and Model views in CAE Manager.

2. Prepare the data for analysis
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• If you load the same product, model, or analysis item revisions in multiple Product and Model views
and make change to item revisions, the system applies the changes to all open views.

• When you open multiple Product and Model views, the system displays them using the same column
configuration. If you change the column configuration in one of the views, the system applies the
changes to all open views.

• When you drag a CAE 3D Model or CAE 3D Analysis item revision in a view, the system loads the
item revision to replace the existing one in the current view, and uses the current revision rule to
configure the loaded item revision.

• When you open a CAE 3D Model item revision in an existing Model view, the system opens the
related product revision in a new Product view and a related CAE 3D Analysis revision in a new
Analysis view. This happens when a single unique product or a CAE analysis revision is identified by a
CAE Target or CAE Defining relationship respectively.

• You can configure the Product or Model view independently based on revision rules, effectivity dates,
snapshots, and variants.

• If you open a CAE 3D Model item revision with a CAE Target relationship, the system loads the
corresponding product item revision in an empty Product view or a new Product view, if you have
already opened an item revision in the Product view.

• If you open a CAE 3D Analysis item revision with a CAE Defining relationship, the system loads the
corresponding analysis item revision in an empty Analysis view or a new Analysis view, if you have
already opened an item revision in the Analysis view.

Configure the product structure

Configure the product structure

You can configure the product structure by applying revision rules, setting a configurator context, and by
configuring variants or applying saved variant rules. After you configure the product structure, you can
apply datamap and structure map rules to create a model structure.

You can open two or more product structures in the product view of CAE Manager. If you open two or
more structures, you can:

• Allow the Product views to reference the same configurator context for both the structures or
reference completely different configurator contexts.

• Apply variants to each of the structures using the Configure Variants or Apply Saved Variant Rules
commands, respectively.

Configure the product structure
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Note:

When you open multiple product structures, make sure that you do not open structures with
Product Configurator variant data and classic variant data in multiple views at the same time. If
you want to view both types of data, you must attach the configurator context to all the open
structures and restart CAE Manager.

1. Load an unconfigured BOM or a product structure in CAE Manager

The loaded product structure is already associated to the configurator context through the
Variability Scope relationship set by the designer. If the relationship is set up, the product view
header shows the associated Configurator Context information. If no context is associated, the
header shows Not Specified.

2. Set revision rules

Teamcenter provides some default revision rules. As an analyst, you can apply the default revision
rules or create your own revision rules and apply them in CAE Manager to configure the product
or the model structure.

3. Set the configurator context

You (as a simulation analyst) can set the default configurator context. All the Product and Model
views refer to this configurator context.

You can set the configurator context for a specific session. Further, if needed, you may remove the
default configurator context.

Note:

If you do not set the default configurator context, the resulting model structure does not
have any configuration context related to it. Further, none of the variant formula from the
source product structure is mapped to the model structure.

4. Author variant expressions for model structures

You can open the model structure in CAE Manager that has reference to the configurator context
and then select the BOM lines for which you want to author variant conditions.

5. Configure the product structure

You can configure the product structure by setting option values (configuring variants) or by
applying a saved variant rule.

2. Prepare the data for analysis
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Specify revision rules

Teamcenter provides some default revision rules. As an analyst, you can apply the default revision rules
or create your own revision rules and apply them in CAE Manager to configure the product or model
structure.

You can specify independent revision rules for product and model structures in the Product and Model
views in CAE Manager. The rules you specify in the Product and Model views are applied to all other
open Product and Model views respectively. By default, the Latest Working revision rule is applied to all
Product and Model views.

1. In CAE Manager, open a Product, Model, or Simulation Tool Configuration view.

2. Click the View Menu , and choose Revision Rule→View/Set Current.

3. Apply a default revision rule or create your own revision rules.

Default rule Description

Released revisions only: Name = Any
Status, No Working

Selects the latest released revisions; no working revisions
selected.

General: Name = Any Status;
Working

Selects the latest released revisions. If none exist, selects
working revisions.

Use this rule to configure a released structure and to be
aware of items that are used in the structure and are not
released yet.

Latest revisions: Name = Latest by
Creation Date

Selects the latest revisions according to the date they
were created, regardless of whether they are working or
released.

Latest revisions: Name = Latest by
Alpha Rev Order

Selects the latest revisions according to the revision ID,
regardless of whether they are working or released.

Precise revisions: Name = Latest
Working

Selects precise references if they exist. For imprecise
assemblies, selects the latest working revisions. If none
exist, selects the latest released revisions.

Precise revisions: Name = Precise;
Any Status, No Working

Selects the precise references to specific item revisions in
precise assemblies. If imprecise assemblies are present,
only working revisions are selected.

Associate a configurator context with a structure

To obtain the required variability data such as families, features, and rules from a configurator context,
you associate the configurator with the product structure.

Specify revision rules
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You can perform this association only if you have the Manage Variability privileges. To verify that you
do:

1. In My Teamcenter, right-click the topmost item of the product structure and click Access.

2. In the Access dialog box, verify that the Manage Variability privilege is enabled.

Note:

Using a mixture of legacy and product configurator variants can cause data corruption. By default,
the system uses the preference ME_EnableMixVariantModelCheck to prevent loading structures
that use a mixture of these variants. If you are using only one variant, or no workflow results
in mixed variants, change the value of ME_EnableMixVariantModelCheck to false. This value
enables the system to open structures without a check.

Associate a configurator context with a structure

1. In My Teamcenter, search for the structure and the configurator context.

2. Right-click the product structure and choose Paste. You cannot associate the configurator context
with the item revision of the structure.

To verify if the configurator context is associated with the structure, select the product structure
and click the Details view. The Relation column must show Variability Scope.

2. Prepare the data for analysis
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Only the configurator context associated with the topmost line item of the structure is considered
for authoring variant conditions.

Tip:

If you are likely to use this configurator context as the basis for several structures, set this as
the default context.

Set the default configurator context

When you set a specific configurator context as the default, it acts as the effective configurator context
for all structures that you open in CAE Manager.

1. In CAE Manager, choose Edit→Set as Default Configurator Context.

2. In the Set Default Configurator Context dialog box, search for the relevant configurator context
and click OK.

After setting the default configurator context, you must close CAE Manager and open it again from
the left navigation pane.

To verify whether the default configurator context is set, open a structure in CAE Manager. The CAE
Manager view displays the configurator context currently associated with the structure.

Remove the default configurator context

Consider a case where a structure is associated with a configurator context that is not the default
configurator context. On opening this structure in CAE Manager, a warning is displayed, specifying that
the associated and the default configurator contexts are different. In such cases, the default configurator
context is applied to the structure. For the associated configurator context to be applied to the structure,
you must remove the default configurator context. To do so, in CAE Manager, choose Edit→Unset as
Default Configurator Context.

Set the default configurator context
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For the associated configurator context to take effect, you must close CAE Manager and open it again
from the left navigation pane.

Author variant expressions

1. Open the product structure for which you want to author variant conditions in CAE Manager.

The product structure you open must have a reference to a configurator context.

Ensure that the Variant Formula property column is displayed in the product structure tree. This
property displays the variant condition and is not visible on the use interface by default.

2. Select the BOM line items for which you want to author the variant condition, for example, Engine.
Click Edit the variant condition . Alternatively, from the View menu, choose Edit→ Variant
Condition.

You cannot select a root BOM line to author variant conditions.

3. In the Variant Formula Expression Editor view, select the required options to define a variant
condition.

The area at the bottom of the view displays the variant condition based on your selection.

In the Variant Formula Expression Editor view, the first column lists the option values organized
by their families. You construct a variant condition by clicking the cells. Selections are indicated by
a check mark  or a circle backslash symbol  in a cell. The check mark  indicates that the
option is applicable. The circle backslash symbol  indicates that the option is not applicable to the
BOM line.

You can also edit an existing variant condition by changing any of the fields. Updated rules are
displayed but not saved instantly.

4. Click Save the current content  on the main toolbar to set the variant condition. You cannot
update this variant condition using classic or modular variants.

After you author variant expressions, configure the structure by setting variant rules.

Configure a structure by setting option values

1. Open the structure that you want to configure in CAE Manager.

2. Click Configure Variants on the view toolbar. Alternatively, click View
Menu→Variants→Configure Variants.

2. Prepare the data for analysis
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3. In the Variant Configuration View view, click Applies default to the configuration  to set the
variant option with their default values.

4. Select the required option values. Selections are indicated by a check mark  or a circle
backslash icon  in a cell. The check mark  indicates that the option is included in the
product configuration. The circle backslash icon  indicates that the option is excluded from the
configuration.

5. (Optional) To clear all the selections you have made, click the View  menu and choose Clear
Expression.

6. (Optional) To clear the saved variant rule you have applied, click the View  menu and choose
Clear Variant Rule.

7. (Optional) To clear unconfigured features, click the View  menu and choose Clear Un-
configured Feature.

The expression on the unconfigured feature in the view is removed. Also, the row holding the
unconfigured feature is removed.

8. Click Validate the Current Configuration  to validate if the selected options are applicable to
the structure.

Configure a structure by setting option values
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To view any informational messages, while the configuration is being validated, click Set Info level
violations to be fetched while applying validations . To view the warnings, click Set Warning
level violations to be fetched while applying validations .

9. Click Applies the current configuration to the associated structure  to apply the selected
options to the structure.

Applying the selected options to the structure creates a custom configuration.

If the Apply Constraints button is deselected while applying the configuration, only user selections
are applied on the content. However, if the Apply Constraints button is selected and the Allow
Validation Rules to Expand button is deselected, the validation rules are not considered while
applying the configuration. By default, Teamcenter displays the Variant Configuration view with
the Apply Constraints and Allow Validation Rules to Expand as selected.

You can save the custom configuration to create a saved variant rule, which you can use to
configure other structures.

Create saved variant rules

1. Click Save the current contents  on the toolbar.

2. In the Save As dialog box, enter the required information and click OK to create the saved variant
rule.

2. Prepare the data for analysis
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Field Action to perform

Item Revision Select this option to create the saved variant rule for the
current item revision.

Configurator Context Select this option to create the saved variant rule for all
structures associated with the current configurator context.

Name Enter the name of the saved variant rule.

Description Enter a short description for the saved variant rule.

Relation Type Choose a relation type if you selected Item Revision as
the variant rule scope. The variant rules are stored in the
top-level item revision of the structure.

Configure a structure by loading saved variant rules

1. Open the structure that you wish to configure in CAE Manager.

2. Click Open saved variant rules dialog  on the view toolbar.

This command is enabled only if a product or model structure is opened in the Product or Model
view, respectively.

Configure a structure by loading saved variant rules
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3. In the Load Variant Rule dialog box, select the variant rule filter.

• Select the Item Revision  check box to apply the saved variant rule to the current item
revision.

• Select the Configurator Context  check box to apply the saved variant rule to all the product
structures associated with the current configurator context.

4. Enter the text to filter the list of variant rules in Variant Rules.

5. Select the saved variant rule that you wish to use to configure the structure and click OK.

The system applies the variant rule on the loaded product BOM and updates the BOM window to show
only the BOM lines that are defined in the variant rule, that is, the 100% BOM. The BOM view header
shows the applied saved variant rule name.

Note:

If the BOM lines do not get updated, ensure that you select the Show Unconfigured Variants
option. Otherwise, the view shows all the BOM lines irrespective of the variant rule you apply.

2. Prepare the data for analysis
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Organize the product structure

Apply filters to the product structure

1. Start CAE Manager.

2. In the Home view, select a product structure (non-CAE item revision), right-click, and choose Send
To→CAE Manager.

3. To apply filters to the product structure and view only the structure lines that are relevant to your
simulation, click Show Filters  on the view toolbar.

Note:

When you enable filters, the Pack, Unpack, Pack All, and Unpack All options from the View
menu are disabled. This is because these options can slow down your system when you filter
large structures.

a. Select a filter criteria and the filter value.

b. (Optional) Select additional filter criteria and filter values.

c. (Optional) Click Unfilter the data by removing all filters to clear filters from the structure
while retaining both the filter criteria and filter values.

d. (Optional) Click Clear all filters to clear all filters from the structure, including the filter criteria
and filter values.

4. (Optional) To view all unique lowest lines:

a. Select a root item or one or more subassemblies.

Apply filters to the product structure
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b. Click View Menu , and choose Select Below→All Unique Lowest Lines

5. Click Show Data Panel  on the main toolbar to open the data view.

6. Click a tab in the data view to activate a view.

Confirmation messages for operations after applying filters on a BOM structure

Select Command Message after applying filters

A product
structure or a
model structure in
the Product view
or Model view,
respectively

Click Generate CAE
Structure from Data Map
from the view toolbar

The Data Map operation will be
executed on the entire BOM structure
and not on the filtered BOM
structure. Do you want to continue?

A product
structure or a
model structure in
the Product view
or Model view,
respectively

Click Generate CAE
Structure from
StructureMap from the
view toolbar

The StructureMap operation will
be executed on the entire BOM
structure and not on the filtered BOM
structure. Do you want to continue?

A product
structure or a
model structure in
the Product view
or Model view,
respectively

Click Open Secondary View
→ Inspector and choose
Load Inspector from the
Inspector view

This operation will be executed on
the entire BOM structure and not on
the filtered BOM structure. Do you
want to continue?

A product
structure or a
model structure in
the Product view
or Model view,
respectively

Click Open Secondary View
→ Inspector and choose
Load Inspector (unpacked)
from the Inspector view

This operation will be executed on
the entire BOM structure and not on
the filtered BOM structure. Do you
want to continue?

A model structure
in the Model view

Click Derive Structures
from the view toolbar

This operation will be executed on
the entire BOM structure and not on
the filtered BOM structure. Do you
want to continue?

A model structure
in the Model view

Click Open Secondary View
→ Simulation Dashboard

This operation will be executed on
the entire BOM structure and not on
the filtered BOM structure. Do you
want to continue?

2. Prepare the data for analysis
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Select Command Message after applying filters

A product
structure in the
Product view

Click Open Secondary View
→ Target References

This operation will be executed on
the entire BOM structure and not on
the filtered BOM structure. Do you
want to continue?

A product
structure or a
model structure in
the Product view
or Model view,
respectively

Click Open Secondary View
→ Composite

This operation will be executed on
the entire BOM structure and not on
the filtered BOM structure. Do you
want to continue?

A product
structure or a
model structure in
the Product view
or Model view,
respectively

Click Simulation Tools →
Tool_Name

The Input to the tool will be the
entire BOM structure and not on the
filtered BOM structure. Do you want
to continue?

Error messages for operations after applying filters on a BOM structure

View Command Error message after applying filters

Product view Select a BOM line, click
Open Secondary View →
Target References. In the
Target References view,
select a line, right-click,
and choose Select Related
BOM Line in... and choose
Model, Product, or Model
and Product

This operation cannot be performed
on a filtered BOM structure. Remove
the filter from BOM structure and try
again.

Product view Select a BOM line, right-
click, and choose Select
Related BOM Line in Model

This operation cannot be performed
on a filtered BOM structure. Remove
the filter from BOM structure and try
again.

Model view Select a BOM line, right-
click, and choose Select
Related BOM Line in
Product

This operation cannot be performed
on a filtered BOM structure. Remove
the filter from BOM structure and try
again.

Product view Select a BOM line, click
Tools → CAE BOM
Compare and click Add

This operation cannot be performed
on a filtered BOM structure. Remove
the filter from BOM structure and try
again.

Apply filters to the product structure
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View Command Error message after applying filters

Source for the Source
Structure box

Product view or
Model view

Select a BOM line, click
Tools → CAE BOM
Compare and click Add
Target for the Target
Structure box

This operation cannot be performed
on a filtered BOM structure. Remove
the filter from BOM structure and try
again.

Product view Select a BOM line, click
Tools → CAE Attribute
Compare and click Add
Source for the Product box

This operation cannot be performed
on a filtered BOM structure. Remove
the filter from BOM structure and try
again.

Model view Select a BOM line, click
Tools → CAE Attribute
Compare and click Add
Target for the Model box

This operation cannot be performed
on a filtered BOM structure. Remove
the filter from BOM structure and try
again.

Share your working design or save an interim version for future reference

During the development of a product's design, you may want to share your working design with other
users. You may also want to save an interim version of your design for future reference. To do this, you
can create a baseline of the work-in-progress (WIP) design. When you request a baseline, Teamcenter
creates a new revision for each unreleased revision in the structure and releases it with a predefined
status, for example, TC_Baseline.

1. Open the latest working revision of a product or model structure in the Product or Model view
respectively.

2. Click View Menu  in the view toolbar, and choose Baseline.

3. Select a baseline template, specify a baseline label, and optionally specify a job description.

4. (Optional) To create the baseline and open it automatically in a new Product or Modelview, select
Open On Create.

5. (Optional) To create a report, select Dry Run Creation.

6. (Optional) To create a precise baseline, select Precise Baseline.

2. Prepare the data for analysis
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Tip:

Your site may be configured to allow only precise baselines, depending on the setting of the
Baseline_precise_bvr preference.

Replace older revisions with approved revisions

By default, an occurrence automatically references a particular item revision, depending on the revision
rule currently in effect. Optionally, you can set the occurrence to unconditionally reference a precise
revision of the part. You can then detect any precise occurrences that reference an out-of-date revision
and manually upgrade each occurrence to an approved revision of the referenced part. This option is
available only with a precise structure.

When you create a new item revision and it is approved, the occurrences of older revisions are not
automatically updated with the new revision if the structure is precise. You must use the Show/Hide
Superseded Revisions command to identify superseded item revisions. While updating an occurrence
with an old revision to the new approved revision, you can update all the applicable occurrences in the
parent assembly or just the currently selected component.

1. Open a precise product or a model structure in the Product or Model view, respectively.

Alternatively, open a product or a model structure and apply a precise revision rule.

2. Click View Menu  in the view toolbar, and choose Edit→Show/Hide Superseded Revisions.

3. To replace selected product or model revisions with new approved versions, select the BOM lines
for which superseded revisions are available, right-click, and select Update Superseded.

You can select multiple BOM lines and update multiple revisions to the approved revisions in the
Update dialog box. To update multiple occurrences within the same parent, select the Adjacent
Occurrences option.

View all related analysis data of a product structure

1. In the Product view, open a product item revision.

2. Click Open Secondary Views  in the view toolbar, and choose Composite.

3. To view all CAE 3D Analysis item revisions at all levels, select the root item, right-click, and choose
Expand Below.

4. To view related CAE 3D Analysis item revisions at the root level, click View Menu  in the view
toolbar, and choose Show Related Analysis Root Only.

Replace older revisions with approved revisions
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5. To view all related CAE 3D Analysis item revisions, click View Menu  in the view toolbar, and
choose Show Related Analysis All.

For each CAE 3D Analysis item revision, the system displays the related CAE 3D Result item revision (if
available).

View and update references in a structure

View all references in a structure using the Composite view

Use the Composite view to view a hybrid structure of references for all the structure lines of a non-CAE
item revision, CAE 3D Model item revision, or a CAE 3D Analysis item revision at one time.

You can open the Composite view by choosing the Open Secondary Views and selecting Composite
from the Product, Model, or Analysis view.

You can perform the following tasks:

• View non-CAE item revisions and the CAE item revisions that have references to the non-CAE item
revisions, and filter references based on item types or relation types in the Product-Composite view.

• View CAE 3D Model item revisions, and the non-CAE item revisions and/or CAE item revisions that are
referenced by the CAE 3D Model item revisions. You can filter references based on relation types, add
or update references, and check for attachment changes, later revisions, and references for the item
revisions in the Model-Composite view.

• View CAE 3D Analysis item revisions and the non-CAE item revisions and/or the CAE item revisions
that are referenced by the CAE 3D Analysis item revisions. You can view attached datasets and filter
references based on relation types or dataset types in the Analysis-Composite view.

• In the Product-Composite, Model-Composite, or Analysis-Composite views, you can:

• Mark an item revision as up to date or mark all item revisions as up to date.

• Show removed attachments for item revisions.

• Show last-up-to date of an item revision.

• Select all item revisions with later revisions.

• Select all lines of same color.

• In the Model-Composite view, you can:

2. Prepare the data for analysis
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• Toggle Show Only Latest Revision to show only the latest revision related to the component in the
Composite view. The system filters out the older revisions.

• Toggle Show only in Product Context to show only those products related to the component that
are loaded in the associated Product view.

Filter references by relation, item, or dataset type

Filter references by relation type

1. Open a non-CAE item revision, CAE 3D Model item revision, or CAE 3D Analysis item revision in
the Product, Model, or Analysis view, respectively.

2. From the appropriate view toolbar, click Open Secondary Views , and choose Composite to
open the Composite view.

3. From the Relation Type list, select the required relation type.

Note:

The relation types that are available in a Composite view linked to a Model or Analysis
view correspond to the significant relation types configured for that object type by the site
administrator.

4. In the Product, Model, or Analysis view, click Reload in the view toolbar to display the references
with the specific relation types.

Note:

You can select multiple relation types at once. If you do not select any relation type, Teamcenter
displays the references with all the available relation types.

Filter item references to CAE items by item type

1. In the Product view, open a non-CAE item revision.

2. Click Open Secondary Views  in the view toolbar, and choose Composite.

3. From the Item Type list, select the required item type.

Teamcenter displays the non-CAE items that are referenced by the selected CAE items.

Filter references by relation, item, or dataset type
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Note:

You can filter references by item type only in the Product-Composite view.

Filter references by dataset type

1. In the Analysis view, create or open a CAE 3D Analysis item revision.

2. Click Open Secondary Views  in the view toolbar, and choose Composite.

3. From the Relation Type list, select the required type and click the Reload view toolbar icon.

Note:

You can filter references by dataset type only in the Analysis-Composite view.

Check for references and add or update latest references

• Check for references

• Add latest references

• Update latest references

Check for references

1. In the Model view, create or open a CAE 3D Model item revision.

2. Click Open Secondary Views  in the view toolbar, and choose Composite.

3. Click Check for References in the view toolbar.

Teamcenter displays references of each line of the loaded model structure in the following color scheme:

Note:

The color scheme depends on the colors set by the simulation administrator at your site.

• Red indicates the nonavailability of any references for a specific line.

• Yellow indicates the availability of at least one reference for a specific line, but the reference is not
loaded in the Product view.

2. Prepare the data for analysis
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• Green indicates the availability of at least one reference for a specific line and the reference is loaded
in the Product view.

Add latest references

1. In the Model view, create or open a CAE 3D Model item revision.

2. Click Open Secondary Views  in the view toolbar, and choose Composite.

3. In the Composite view, select one or more item revisions.

Alternatively, right-click, and choose Select All with Later Revisions.

4. Click View Menu  in the view toolbar, and choose Add Latest References.

Teamcenter adds references to the loaded model structure.

Update latest references

1. In the Model view, create or open a CAE 3D Model item revision.

2. Click Open Secondary Views  in the view toolbar, and choose Composite.

3. Select one or more item revisions in the Composite view.

Alternatively, right-click, and choose Select All with Later Revisions.

4. Click View Menu  in the view toolbar, and choose Update Latest References.

Teamcenter updates references of the loaded model structure to the latest revision.

Create different types of CAE revisions to manage your data

Creating CAE revisions

CAE items are the fundamental workspace objects in Teamcenter used to manage CAE information. You
can use them to:

• Maintain the CAE representation of a product, part, or component.

• Maintain the definition of the analysis performed on these items and the results of the analysis.

• Manage changes (revisions) to CAE items during the product design lifecycle.

Creating CAE revisions
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Use the New CAE Item dialog box in My Teamcenter, and CAE Manager to create CAE items. Based on
the application you select, the CAE items and item types in this dialog box appear differently. However,
the process of creating a CAE item remains the same across these applications.

This dialog box provides a wizard-like tool that enables you to create CAE items, define item and item
revision attributes, create alternate identifiers for the CAE item, assign the CAE item to a project, create
datasets and attach named references, add a reference to another item, and define options to display the
CAE item and alternate identifiers.

A red triangle indicates the steps that are mandatory to create a CAE item. After you perform these
mandatory steps, you can then continue through the remaining steps in order, select individual steps
from the list, or close the dialog box. It is not necessary to work through the steps sequentially nor is
it necessary to complete all the steps. If mandatory item master or item revision master attributes are
defined for the item type, you must enter the required values before Teamcenter can create the CAE
item. A red asterisk (*) in the upper right corner of a box indicates the mandatory attributes in the steps.

Create geometry revisions in My Teamcenter

The geometry used for simulation analysis is often different from the product geometry. It may be a
simplified or an abstracted version or an approximation when the product geometry is not available. CAE
3D Geometry revisions are workspace objects for storing the simplified geometry. Geometry revisions
are created in the context of the item revisions in the product structure.

You can create CAE 3D Geometry item revisions only in My Teamcenter and not in any of the CAE
Manager views.

1. Select a container for the item, such as a folder or an existing CAE 3D Geometry item revision.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select the CAE 3D Geometry item revision from the Most Recently
Used or Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

4. Click Next.

5. Specify information in the CAE Geometry area of the Object Create Information pane.

The Name and Description boxes display default values determined by the property rules
implemented at your site. You may replace such values, but you cannot specify a null value by
clearing the box. If you clear the box, the initial value is reapplied to the property when you save
the new CAE 3D Model item.

2. Prepare the data for analysis
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a. Type an item ID or click Assign to automatically assign an item ID.

b. Type a revision ID or click Assign to automatically assign a revision ID.

c. (Mandatory) Specify a name for the item revision.

d. (Optional) Enter a description for the item revision.

e. Click Finish to create the basic item revision.

(Optional) Select Additional CAE Geometry Information or CAE Geometry Revision
Information to specify information (see steps that follow).

Alternatively, click Next to specify additional information

6. (Optional) Specify information in the Additional CAE Geometry Information section.

a. Specify a project ID and other information as appropriate.

b. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information

7. (Optional) Specify information in the CAE Geometry Revision Information section.

a. From the Disciplines area, click Expand to modify, select a discipline from the list, and click
Add .

b. From the Analysis Types area, click Expand to modify, select an analysis type from the list,
and click Add .

c. From the Pre-Processor menu, select a preprocessor for the analysis type you selected.

d. Specify project ID and other information as appropriate.

e. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information

8. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To open the Enter CAE Attach Files Information pane, click Next.

Create geometry revisions in My Teamcenter
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b. To specify a list of datasets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Tip:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

c. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

d. (Optional) Click Finish to create the item revision.

Alternatively, click Next to specify additional information

9. (Optional) Specify information in the Define References pane.

You can specify references manually by typing the object ID, revision, object, and relation type or
using the Search dialog box.

a. To open the Define References pane, click Next.

b. Click Add and type an object ID, revision, object, and relation type or click Search to search for
references.

c. (Optional) Click Finish to create the item revision.

Alternatively, click Next to specify additional information

10. (Optional) Specify information in the Define Workflow Information pane.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

2. Prepare the data for analysis
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a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

11. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

b. Click Finish to create the item revision.

Create model revisions in My Teamcenter or CAE Manager

A mesh represents a geometric object as a set of finite elements. Finite element analysis (FEA) is a
computerized method for simulating how a part reacts to conditions such as force, heat, vibration,
and other physical effects in the real world. Model revisions are workspace objects for storing the
mesh definition, connections, and material and physical properties. They are created in the context of
geometry revisions.

You can create model revisions in My Teamcenter or CAE Manager.

1. Select a container for the CAE 3D Model item, such as a folder or another CAE item.

Alternatively, select a model revision in the Model view of CAE Manager.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select the CAE 3D Model item revision from the Most Recently Used or
Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

Create model revisions in My Teamcenter or CAE Manager
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4. Specify information in the CAE 3D Analysis area of the Object Create Information pane.

Note:

The Name and Description boxes display default values determined by the property rules
implemented at your site. You may replace such values, but you cannot specify a null value
by clearing the box. If you clear the box, the initial value is reapplied to the property when
you save the new CAE 3D Model item.

a. Type an item ID or click Assign to automatically assign an item ID.

b. Type a revision ID or click Assign to automatically assign a revision ID.

c. (Mandatory) Specify a name for the item revision.

d. (Optional) Enter a description for the item revision.

e. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

5. (Optional) Specify information in the Additional CAE Model Information area of the Object
Create Information pane.

This area is available only if it is configured in Teamcenter.

a. Specify a project ID and other information as appropriate.

b. (Optional) Click Finish to create the item revision.

Alternatively, click Next to specify additional information

6. (Optional) Specify information in the CAE Model Revision Information area of the Object Create
Information pane.

a. From the Disciplines area, click Expand to modify, select a discipline from the list, and click
Add .

b. From the Analysis Types area, click Expand to modify, select an analysis type from the list,
and click Add .

c. From the Solver menu, select a solver for the model type you selected.

d. Specify project ID and other information as appropriate.

2. Prepare the data for analysis
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e. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information

7. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To open the Enter CAE Attach Files Information pane, click Next.

b. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

c. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

d. (Optional) Click Finish to create a basic item revision.

8. (Optional) Specify information in the Define References pane.

You can specify references manually by typing the object ID, revision, object, and relation type or
using the Search dialog box.

a. To open the Define References pane, click Next.

b. Click Add and type an object ID, revision, object, and relation type or click Search to search for
references.

c. (Optional) Click Finish to create the item revision.

Alternatively, click Next to specify additional information

9. (Optional) Specify information in the Define Workflow Information pane.

Create model revisions in My Teamcenter or CAE Manager
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Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

10. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

b. Click Finish to create the item revision.

Create analysis revisions in My Teamcenter or CAE Manager

An analysis revision represents the specific simulation you want to perform. Analysis revisions are
workspace objects for including load cases, solver parameters, and boundary conditions. They are
created in the context of model revisions.

You can create analysis revisions in My Teamcenter or CAE Manager.

1. Select a container for the analysis item, such as a folder or another item revision.

Alternatively, select a CAE 3D Analysis item revision in the Analysis view of CAE Manager.

You can configure the product structure to create analysis item revisions with a CAE Target
relationship type. Then, while creating CAE 3D Analysis items using the New CAE Item Wizard

2. Prepare the data for analysis
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dialog box, the system automatically captures the pedigree information of the associated analysis
item.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select the CAE 3D Analysis item revision from the Most Recently Used
or Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

4. (Mandatory) Specify information in the CAE Analysis Information area of the Object Create
Information pane.

Note:

The Name and Description boxes display default values determined by the property rules
implemented at your site. You may replace such values, but you cannot specify a null value
by clearing the box. If you clear the box, the initial value is reapplied to the property when
you save the new CAE 3D Model item.

a. Type an item ID or click Assign to automatically assign an item ID.

b. Type a revision ID or click Assign to automatically assign a revision ID.

c. (Mandatory) Specify a name for the item revision.

d. (Optional) Enter a description for the item revision.

e. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

5. Specify information in the Additional CAE Analysis Information area of the Object Create
Information pane.

a. Specify the project ID and other information as appropriate.

b. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

6. Specify information in the CAE Analysis Revision Information area of the Object Create
Information pane.

Create analysis revisions in My Teamcenter or CAE Manager
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a. From the Disciplines area, click Expand to modify, select a discipline from the list, and click
Add .

b. From the Analysis Types area, click Expand to modify, select an analysis type from the list,
and click Add .

c. Specify the analysis type, solver name, project ID, and other information as appropriate.

d. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information

7. Specify information in the Enter CAE Analysis and CAE Result Templates Information pane.

a. In the CAE 3D Analysis Template area, click search and select an analysis template.

b. In the CAE 3D Result Template area, click search and select result templates.

8. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To open the Enter CAE Attach Files Information pane, click Next.

b. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

c. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

d. (Optional) Click Finish to create a basic item revision.

9. (Optional) Specify information in the Define References pane.

2. Prepare the data for analysis
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You can specify references manually by typing the object ID, revision, object, and relation type or
using the Search dialog box.

a. To open the Define References pane, click Next.

b. Click Add and type an object ID, revision, object, and relation type or click Search to search for
references.

c. (Optional) Click Finish to create the item revision.

Alternatively, click Next to specify additional information

10. (Optional) Specify information in the Define Workflow Information pane.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

11. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

b. Click Finish to create the item revision.

Create analysis revisions in My Teamcenter or CAE Manager
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Create analysis templates in My Teamcenter

You can create analysis templates to specify different load cases. After creating a template, you can
associate it to an analysis revision.

1. In My Teamcenter, select a container for the CAE 3D Analysis template, such as a folder or another
item revision.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select the CAE 3D Analysis Template revision from the Most Recently
Used or Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

4. Specify information in the CAE 3D Analysis Template area of the Object Create Information
pane.

a. Type an item ID or click Assign to automatically assign an item ID.

b. Type a revision or click Assign to automatically assign a revision.

c. (Mandatory) Specify a name for the analysis template.

d. (Optional) Enter a description for the item revision.

e. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information.

5. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To open the Enter CAE Attach Files Information pane, click Next.

b. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

2. Prepare the data for analysis
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Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

c. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

d. (Optional) Click Finish to create a basic item revision.

6. (Optional) Specify information in the Define Workflow Information pane.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

7. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

Create analysis templates in My Teamcenter
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b. Click Finish to create the item revision.

Create result revisions in My Teamcenter or CAE Manager

1. Select a container for the item, such as a folder, another result revision, an analysis revision in a
folder, or an analysis revision in the Analysis view in CAE Manager.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select the CAE 3D Result item revision from the Most Recently Used or
Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

4. Specify information in the CAE Result Information area of the Object Create Information pane.

a. Type an item ID or click Assign to automatically assign an item ID.

b. Type a revision ID or click Assign to automatically assign a revision ID.

c. (Mandatory) Specify a name for the item revision.

d. (Optional) Enter a description for the item revision.

e. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

5. Specify information in the Additional CAE Result Information area of the Object Create
Information pane.

a. Specify the project ID and other information as appropriate.

b. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

6. Specify information in the CAE Result Revision Information area of the Object Create
Information pane.

a. From the Disciplines area, click Expand to modify, select a discipline from the list, and click
Add .
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b. From the Analysis Types menu, select an analysis type.

c. Specify the project ID and other information as appropriate.

d. From the Solver Name menu, select a solver type.

e. Specify the analysis type, solver name, project ID, and other information as appropriate.

f. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information

7. Specify information in the Enter CAE Result Template Information pane.

a. Search for the result template by clicking Search and add it.

b. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information.

8. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

b. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

c. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information.

Create result revisions in My Teamcenter or CAE Manager
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9. (Optional) Specify information in the Define References pane.

You can specify references manually by typing the object ID, revision, object, and relation type or
using the Search dialog box.

a. To open the Define References pane, click Next.

b. Click Add and type an object ID, revision, object, and relation type or click Search to search for
references.

c. (Optional) Click Finish to create the item revision.

Alternatively, click Next to specify additional information

10. (Optional) Specify information in the Define Workflow Information pane.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

11. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.
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b. Click Finish to create the item revision.

Create result templates in My Teamcenter

You can create result templates to include different types of result criteria. After creating the template,
you can associate the template to a result revision.

1. In My Teamcenter, select a container for the result template, such as a folder or another item
revision.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select the CAE 3D Result Template revision from the Most Recently
Used or Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

4. (Mandatory) Specify information in the CAE 3D Result Template Information section.

a. Type an item ID or click Assign to automatically assign an item ID.

b. Type a revision ID or click Assign to automatically assign a revision ID.

c. (Mandatory) Specify a name for the result template.

d. (Optional) Enter a description for the template.

e. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information.

5. (Optional) Specify information in the CAE 3D Result Template Revision Information section.

a. Click Expand to modify, select the appropriate value from the list, and click Add to add the
value.

b. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information.

6. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Create result templates in My Teamcenter
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Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To open the Enter CAE Attach Files Information pane, click Next.

b. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

c. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

d. (Optional) Click Finish to create a basic item revision.

7. (Optional) Specify information in the Define Workflow Information pane.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.
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8. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

b. Click Finish to create the item revision.

9. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Tip:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

b. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files in the Named reference table, the system
populates all the files as named references of the selected dataset.

c. (Optional) Click Finish to create a basic item revision.

10. (Optional) Specify information in the Define Workflow Information pane.

This pane is available only if it is configured in Teamcenter.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Create result templates in My Teamcenter
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Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. Select a process template and apply a process template filter.

b. Select a process assignment list.

11. (Optional) In the Assign Project Page, select an available project.

12. Click Finish to create the result template.

Create product collector revisions in My Teamcenter

As a simulation analyst, the product structure you receive may not have all the data or it may not
be organized in a manner that is suitable for simulation analysis. Before you start reorganizing the
structure, you require a collector item or a placeholder to store the new structure. You can create CAE
3D Product Collector item revisions to store the new structure.

1. Select a container for the item, such as a folder or an existing CAE 3D Product Collector item
revision.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select the CAE 3D Product Collector item revision from the Most
Recently Used or Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

4. Click Next.

5. Specify information in the Object Create Information pane.

Note:

The Name and Description boxes display default values determined by the property rules
implemented at your site. You may replace such values, but you cannot specify a null value
by clearing the box. If you clear the box, the initial value is reapplied to the property when
you save the new CAE 3D Model item revision.

a. (Optional) Enter a description for the CAE 3D Product Collector item revision you want to
create.
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b. Type an item ID or click Assign to automatically assign an item ID for the CAE 3D Product
Collector item revision you want to create.

c. (Mandatory) Specify a name for the CAE 3D Product Collector item revision you want to
create.

d. Specify other values as appropriate.

e. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information.

6. (Optional) Specify information in the Define business object create information pane.

This area is available only if it is configured in Teamcenter.

a. (Optional) In the Disciplines list, click Expand to modify and select an appropriate value and
click Add.

You can select disciplines such as Durability, NVH, or Safety.

b. Specify other values or select options as appropriate.

c. (Optional) Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

7. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

b. To specify a list of data sets, click Add, and select appropriate options.

Create product collector revisions in My Teamcenter
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You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

c. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

d. (Optional) Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

8. (Optional) Specify information in the Define References pane.

You can specify references manually by typing the object ID, revision, object, and relation type or
using the Search dialog box.

a. Click Add and type an object ID, revision, object, and relation type or click Search to search for
references.

b. (Optional) Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

9. (Optional) Specify information in the Define Workflow Information pane.

This pane is available only if it is configured in Teamcenter.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. Select a process template and apply a process template filter.

b. Select a process assignment list.

c. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.
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10. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

b. Click Finish to create the item revision.

11. After creating the product collector revision object, open the product collector structure in the
Product view of CAE Manager, reorganize the structure by adding BOM lines or moving BOM
lines, and populate the structure with the parts and subassemblies selected from the original CAD
structures.

12. (Optional) Search for product collector revisions after creating them.

a. Select Advanced from the search menu at the top of the navigation pane.

b. On the Search view toolbar, click  to select a search from the list of search types.

c. Click More and select CAE 3D Product Collector Revision or CAE 3D Product Collector to
find all product collector revisions.

d. Enter the search criteria and click Search  to perform the search.

Create a CAE boundary condition in My Teamcenter

You can create a boundary condition to define the inputs for a simulation model. After creating the
boundary condition, you can associate the condition to an analysis revision.

1. In My Teamcenter, select a container for the result template, such as a folder or another item
revision.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select CAE 3D Boundary Condition from the Most Recently Used or
Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

Create a CAE boundary condition in My Teamcenter
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4. Type an item ID or click Assign to automatically assign an item ID.

5. Type a revision or click Assign to automatically assign a revision.

6. (Mandatory) Specify a name for the boundary condition.

7. (Optional) Enter a description for the boundary condition.

8. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

9. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To open the Enter CAE Attach Files Information pane, click Next.

b. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

c. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

d. (Optional) Click Finish to create a basic item revision.

10. (Optional) Specify information in the Define Workflow Information pane.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.
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Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

11. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

b. Click Finish to create the item revision.

Create structure map revisions in My Teamcenter

1. Select a container for the CAE Structure Map item, such as a folder or another item revision.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select the CAE Structure Map item revision from the Most Recently
Used or Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

4. (Mandatory) Specify information in the StructureMap Information area of the Object Create
Information pane.

Create structure map revisions in My Teamcenter
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Note:

The Name and Description boxes display default values determined by the property rules
implemented at your site. You may replace such values, but you cannot specify a null value
by clearing the box. If you clear the box, the initial value is reapplied to the property when
you save the new CAE 3D Model item revision.

a. Type an item ID or click Assign to automatically assign an item ID.

b. Type a revision or click Assign to automatically assign a revision.

c. (Mandatory) Specify a name for the item revision.

d. (Optional) Enter a description for the item revision.

e. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

5. (Optional) Specify information in the Additional StructureMap Information area of the Object
Create Information pane.

a. Specify the project ID and other details as appropriate.

b. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

6. (Optional) Specify information in the StructureMap Revision Information area of the Object
Create Information pane.

a. Click Expand to modify, select a discipline from the list, and click Add to include the
discipline.

b. (Mandatory) Select a domain. The default domain is CAE.

c. Specify other information as appropriate.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

7. (Optional) Specify information in the Enter CAE Attach Files Information pane.

2. Prepare the data for analysis
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Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To open the Enter CAE Attach Files Information pane, click Next.

b. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

c. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

d. (Optional) Click Finish to create a basic item revision.

8. (Optional) Specify information in the Define Workflow Information pane.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

Create structure map revisions in My Teamcenter
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9. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

b. Click Finish to create the item revision.

Create new revisions based on existing revisions

Create a new revision based on an existing revision

The Save As dialog box provides a wizard-like tool to create items, define item and item revision
attributes, create alternate identifiers for the item revision, assign the item revision to a project, and
define options for displaying the item and alternate identifiers.

A red triangle indicates the steps that are mandatory to create a CAE item. After you perform the
mandatory steps, you can then continue through the remaining steps in order, select individual steps
from the list, or close the dialog box. It is not necessary to work through the steps sequentially nor is
it necessary to complete all the steps. If mandatory item master or item revision master attributes are
defined for the item type, you must enter the required values before Teamcenter can create the CAE
item. A red asterisk (*) in the upper right corner of a box indicates the mandatory attributes in the steps.

You can create a new CAE item and item revision based on an existing CAE item revision and use the
Define Attached Data option to copy objects related to the item revision as references, new objects, or
not to copy them at all.

1. Create or open a CAE 3D Model or CAE 3D Analysis item revision in the Model or Analysis view in
CAE Manager.

2. Select the required item revision in the Model or Analysis view to be the basis of the new CAE item
and item revision.

3. Choose File→Save As to open the Save As dialog box.

The Enter Item Information step appears by default.

Note:

You can find initial values in the Name and Description boxes determined by the property
rules implemented at your site. You can replace such values, but you cannot specify a null
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value by clearing the box. If you clear the box, the initial value is reapplied to the property
when you save the new CAE item.

4. Click Assign to automatically generate the next available item ID and revision, or manually type an
item and revision ID.

Assign is active only if naming rules and automatic generation are implemented for the selected
object type.

5. (Optional) In the Description box, type a description for the new CAE item.

For any CAE item revision, the Unit of Measure list is disabled by default.

6. At this point, you have provided all the information necessary to create the CAE item.

7. Click Next to create the CAE item and proceed to another step or click Finish to create the CAE item
and return to the first step.

Enter item and item revision attributes for the new revision

1. Click the Enter Additional Item Information or Enter Additional Item Revision Information step
in the left pane.

Teamcenter displays the corresponding master form in the right pane.

2. Enter the information for the required attributes.

3. Click Next to create an alternate identifier, if active. Otherwise, select another step from the left
pane or click Finish.

Create an alternate identifier for the new revision

1. Click the Enter Identifier Basic Information step in the left pane.

Teamcenter displays the alternate identifier options in the right pane.

2. Select the context for the identifier.

The Select Context options are derived from rules set by your administrator.

3. Select the identifier type.

4. Type an item ID, revision, and name for the alternate ID, or click Assign to automatically generate
the item and revision identifiers.

Enter item and item revision attributes for the new revision
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Assign is active only if naming rules and automatic generation are implemented for the selected
object type.

5. Click Next to proceed to the next step.

Enter additional attribute information for the new revision

1. Click the Enter Additional ID Information or Enter Additional Rev Information step in the left
pane.

Teamcenter displays the corresponding master form in the right pane.

2. Enter the required attribute information.

3. Click Next to move to the next step in the revision process or click Finish to close the Revise dialog
box.

Note:

This feature is available only if attributes are defined for the selected alternate ID type.

Copy related objects for the new revision

1. Click the Define Attached Data step in the left pane.

Teamcenter displays the Source tree and Destination tree to define attached data.

• Source tree contains the objects related to the selected item revision. The symbols to the right of
the objects indicate the default copy option for that object.

• Destination tree contains the resulting item revision with the objects copied according to the
default copy option.

Note:

The default copy options are derived from site rules and can be overridden depending on site
implementation.

The following copy options can be applied to related objects:

• Copy as Object allows you to create a new object of the same type and relation to the parent
object. Objects created by this method are totally independent of the parent object. Therefore,
any changes to the copied object are not reflected in the original object. Copied objects appear
in bold in the Destination tree. The names of the attachments that are copied as objects are
generated at the server level and may be overridden, depending on the site implementation. If

2. Prepare the data for analysis
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you have the permission to edit the object name, you can double-click the node and type a new
name.

• Copy as Reference allows you to copy the existing object as a reference to the original object.
All changes to the reference copy affect the original object.

The names of attachments that are copied as references cannot be modified.

• Don't Copy allows you to selectively copy objects from one revision to another. Objects that have
been designated as Don't Copy appear with a line through them in the Destination tree.

2. To override the copy option for an object, click the button and select a different copy option.

If the buttons are disabled, you do not have permission to change the copy option for that object.

3. (Optional) Rename the related objects as follows:

a. Select the object in the Destination tree.

b. Press the F2 key.

c. Type the new name.

4. Click Next to assign the revision to a project or click Finish to return to the first item creation step.

Assign an item to projects for the new revision

Note:

You can assign objects to projects only if you are a privileged project team member.

1. Click the Assign to Projects step in the left pane.

Teamcenter displays the list of projects to which items can be assigned in the right pane.

2. From the Projects for Selection list, select one or more projects.

3. Move the projects to the Selected Projects list.

4. Click Next to define item options or click Finish to return to the first item creation step.

Define open and alternate ID display options for the new revision

1. Click the Define Options step in the left pane.

Assign an item to projects for the new revision
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Teamcenter displays the open and display options in the right pane.

2. Select Open on Create to open the CAE 3D Model item revision in your workspace after it is
created.

3. If you have created an alternate identifier for the CAE item, you can use this as the default display
object by selecting Use item identifier as default display and Use revision identifier as default
display.

4. Click Finish.

Teamcenter displays the newly created CAE item in the Newstuff folder in My Teamcenter.

2. Prepare the data for analysis
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3. Create structure map rules to generate
model structures for specific types of
analyses
What are structure maps?

You (as the simulation analyst) can use the CAE Manager to generate a CAE structure from an existing
product structure (bill of materials, or BOM). Typically the CAE structure is similar to, but not the same
as, the product structure.

You use structure maps to automate the creation of CAE structures. Structure maps allow you to:

• Remove BOM lines based on filter criteria. For example, you can automatically filter out connectors
such as bolts or pins, which will not be considered in the analysis.

• Reuse existing CAE 3D Model item revisions. If a part in the product structure has been previously
analyzed, the structure map can automatically include the corresponding CAE 3D Analysis item in the
new CAE structure.

• Add existing CAE 3D Model item revisions. You can include additional items in the CAE structure as
needed in your analysis, such as a fluid volume mesh for flow analysis.

• Create new CAE 3D Model item revisions where none currently exist.

Managing structure maps

Create structure map items

You can create and manage CAE Structure Map items with the required structure map attributes in
My Teamcenter or CAE Structure Map Configuration view in CAE Manager and use the CAE Structure
Map items to generate CAE model structures.

Use the New CAE Item dialog box to create the CAE Structure Map items in My Teamcenter or CAE
Structure Map Configuration view in CAE Manager.

If you create CAE Structure Map items in My Teamcenter, you can select them, and then right-click and
choose Send To→CAE Manager to open them in the CAE Structure Map Configuration view.

1. Choose File→New→CAE Item in My Teamcenter or CAE Structure Map Configuration view in
CAE Manager to open the New CAE Item dialog box.

2. Create a CAE Structure Map item.
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You can create a CAE Structure Map item only after you define a structure map dataset.

Open structure map item revisions

Use the CAE Structure Map Configuration view to open a CAE Structure Map item revision in CAE
Manager. You can type the required CAE Structure Map item ID and revision in the Item Id/Rev boxes.
You can also click Search to search and select the CAE Structure Map item revision.

Tip:

If you create CAE Structure Map items in My Teamcenter, you can select them, and then right-
click and choose Send To→CAE Manager to open them in the CAE Structure Map Configuration
view.

1. In CAE Manager, click CAE Configuration→CAE Structure Map Configuration on the main toolbar
to open the CAE Structure Map Configuration view.

2. Click Open selected line in a new window on the view toolbar to open the Structure Map Open
Item Revision dialog box.

3. Type the required CAE Structure Map item and revision identifiers in the Item Id/Rev boxes, or
click Search to search for the required CAE Structure Map item revision and populate the values in
these boxes.

4. Click Load.

Validate structure map rules

If the selected CAE Structure Map item revision contains a structure map file as a named reference, and
if the CAE Structure Map item revision appears invalid, you must first validate the structure map file.

1. Select the required CAE Structure Map item revision in the Structure Map Item Revisions tree.

Note:

The CAE Structure Map item revision must contain a structure map file as a named
reference.

2. To validate the structure map file, click the  view toolbar button.

Upload attachments to a structure map item

Use the Attachments pane to view and manage the named references attached to a selected CAE
Structure Map item revision.

3. Create structure map rules to generate model structures for specific types of analyses
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1. Select the required CAE Structure Map item revision in the Structure Map Item Revisions tree in
the CAE Structure Map Configuration view.

2. To activate the Attachments pane, right-click the CAE Structure Map item revision and choose
Open with Attachments.

3. In the Attachments pane, right-click the CAEStructureMap dataset associated with the
CAE Structure Map item revision, and choose Named References to open the Named
Referencesdialog box.

4. Open or upload named references for the CAEStructureMap dataset.

You can also export an existing named reference attached to the CAEStructureMap dataset to a
local directory in Teamcenter.

5. Click Close to close the Named References dialog box.

6. View the named reference attached to the CAEStructureMap dataset in the Attachments pane.

You can find the structure map file in the attached named reference.

Generate CAE model structures using structure maps

You can create a CAE model structure using the structure map rules created in the CAE Structure Map
Configuration view.

The CAE Structure Map item revision that you use to generate the CAE model structure must contain
a CAEStructureMap dataset and a valid named reference attached to it. The structure map rules are
stored in the named reference.

1. In the Product view, click Generate CAE Structure from CAE Structure Map on the view toolbar.

2. In the Select CAE Structure Map dialog box, type the required CAE Structure Map item and
revision identifiers in the Item Id/Rev boxes, or click Search to search for the required CAE
Structure Map item revision and populate the values in these boxes.

3. To create the CAE model structure map, click Execute.

Create structure map rules to generate CAE model structures

Create structure map rules

Analysts often use the product structure to create a simulation structure based on a functional
subsystem to include components relevant to their analysis. They identify such components by
reorganizing, grouping, and filtering out components from the product structure. Doing this manually
is time consuming. To simplify this process, the lead (or designated) analyst can use the CAE Structure

Generate CAE model structures using structure maps
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Map Configuration view to create structure map rules that can be used by other analysts in the group or
organization. Structure map rules help generate consistent CAE model structures for better analysis.

You can use the cae_validate_structuremap utility to validate the input structure map usage. For more
information, from a Teamcenter command prompt, type cae_validate_structuremap -h.

The process is as follows:

• The lead analyst:

1. Creates a CAE Structure Map item revision using the New CAE Item wizard.

2. Creates multiple structure map rules.

3. (Optional) Changes the sequence of the structure map rules and saves the structure.

The analyst:

1. Opens the product structure in the Product view.

2. Creates a CAE model structure using the structure map containing the structure map rules.

Teamcenter applies the structure map rules and loads the resulting structure in the Model view.

The lead analyst can create multiple rules for each rule type and specify an order of precedence when
there is more than one rule in the Structure Map Rules pane.

3. Create structure map rules to generate model structures for specific types of analyses
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When the analyst applies these structure map rules, they are executed with the following precedence:

• Filter

• Skip

• Include (when the IN option is selected in the Criteria Focus menu)

• Reuse

• Recycle

• Include (when the OUT option is selected in the Criteria Focus menu)

• Create Collector

• Move to Collector

• Remove Empty Sub-Assembly

• Collapse Single Component Sub-Assembly

In the CAE Structure Map Configuration view, click the Add CAE Structure Map Rule view toolbar
button. The CAE New Structure Map Rule dialog box provides a wizard-like tool to create structure map
rules. You can perform the following tasks in this dialog box:

• Select rule type and define rule information.

• Define detailed information for the rule type.

• View summary of the rule to be created.

A red triangle indicates the mandatory steps required to create a new rule. After you perform the
mandatory steps, you can continue through the remaining steps in order, select individual steps from
the list, or exit the wizard. It is not necessary to work through the steps sequentially, nor is it necessary
to complete all the steps. A red asterisk (*) in the upper-right corner of the field indicates the mandatory
attributes in the steps.

Create filter rules

Filter rule is a mechanism to filter or remove components from a structure.

Create filter rules
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Note:

Filter rules remove the identified component and its children from the resulting structure, if it is a
subassembly root.

1. In My Teamcenter or CAE Manager, from the Home view, select a CAE Structure Map item
revision, right-click and choose Send To→CAE Manager.

2. From the Structure Map Item Revisions tree, select the required CAE Structure Map item
revision.

3. Click the Add CAE Structure Map Rule  button.

4. In the CAE New Structure Map Rule dialog box, perform the following steps to select a rule type
and define the rule information:

a. From the SM Rule Types tree, select the Filter rule type.

b. In the Rule Name box, type a name for the Filter rule.

c. (Optional) In the Description box, type a description for the Filter rule.

5. Click Next or the Create Conditional Expression step in the left pane.

Teamcenter displays the options to create a conditional (or Boolean) criteria to identify the lines in
the input structure in the right pane.

6. Perform the following steps to create a conditional expression:

Note:

It is not essential to perform these steps in the order listed.

• Select an attribute.

• Select the Item, Item Revision, Form, or BOMLine class from the Class list.

• Based on the class you select, Teamcenter automatically displays the type options in
alphabetical order in the Types list.

Select the required type from the Types list.

• Based on the type you select, Teamcenter automatically displays the attribute options in
alphabetical order in the Attributes list.

3. Create structure map rules to generate model structures for specific types of analyses
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Select the required attribute from the Attributes list.

• Define a conditional expression.

• Select the required XSLT function in the XSLT Function tree.

Note:

An XSLT function is required to create a conditional expression that has a primary return
type, Boolean.

• Drag the selected XSLT function in the pane next to the XSLT Function tree.

• Provide values for the XSLT function in one of the following ways:

■ Type static values in the parameter box.

■ Drag the required attributes in the parameter box.

■ Select an XSLT function from the XSLT Function tree and drag it in the parameter box.

If you leave the mandatory parameter boxes empty, Teamcenter displays the following
message:

One or More than one Required Fields empty

• Click the  button or  button to add the rule condition to the set of conditions.

You can also use the  button to edit a rule condition,  button to remove a rule condition, or 
button to clear all rule conditions.

7. Click Next or the View Rule Summary step in the left pane.

Teamcenter displays the summary of the Filter rule that is to be created.

• The Name and Description boxes display the values that you provide in the Select Rule Type
step.

If you want to modify the values in the Name and Description boxes, click the Select Rule
Type step in the left pane, and modify the values in the Rule Name and Description boxes
accordingly.

• The Rule Preview box lets you preview the Filter rule that is to be created.

If you want to modify the Filter rule, click Back or the Create Conditional Expression step in
the left pane and modify the rule accordingly.

Create filter rules
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8. Click Finish to create a Filter rule.

Teamcenter displays the new Filter rule in the Rule Details pane.

Create include rules

Include rule is a mechanism to add and position an existing item revision as part of the output structure
that was not a part of the input structure.

1. In My Teamcenter or CAE Manager, from the Home view, select a CAE Structure Map item
revision, right-click and choose Send To→CAE Manager.

2. Select the required CAE Structure Map item revision in the Structure Map Item Revisions tree.

3. Click the Add CAE Structure Map Rule  button.

4. In the CAE New Structure Map Rule dialog box, perform the following steps to select a rule type
and define the rule information:

a. From the SM Rule Types tree, select the Include rule type.

b. In the Rule Name box, type a name for the Include rule.

c. (Optional) In the Description box, type a description for the Include rule.

5. Click Next or the Define Criteria Focus step in the left pane.

6. From the Criteria Focus menu, select one of the following options:

• IN to use item, item revision, form, or BOMLine attributes in the input structure, if they meet
specific criteria.

• OUT to use item, item revision, form, or BOMLine attributes in the output structure, if they meet
specific criteria.

7. Click Next or the Create Conditional Expression step in the left pane.

Teamcenter displays options to create a conditional (or Boolean) criteria to identify the lines in the
input structure in the right pane.

8. Perform the following steps to create a conditional expression:

Note:

It is not necessary to perform these steps in the order listed.

3. Create structure map rules to generate model structures for specific types of analyses
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• Select an attribute.

• Select the Item, Item Revision, Form, or BOMLine class from the Class list.

• Based on the class you select, Teamcenter automatically displays the type options in
alphabetical order in the Types list.

Select the required type from the Types list.

• Based on the type you select, Teamcenter automatically displays the attribute options in
alphabetical order in the Attributes list.

Select the required attribute from the Attributes list.

• Define a conditional expression.

• Select the required XSLT function in the XSLT Function tree.

Note:

An XSLT function is required to create a conditional expression that has a primary return
type, Boolean.

• Drag the selected XSLT function in the pane next to the XSLT Function tree.

• Provide values for the XSLT function in one of the following ways:

■ Type static values in the parameter box.

■ Drag the required attributes in the parameter box.

■ Select an XSLT function from the XSLT Function tree and drag it in the parameter box.

If you leave the mandatory parameter boxes empty, Teamcenter displays the following
message:

One or More than one Required Fields empty

• Click the  button and/or  button to add the rule condition to the set of conditions.

You can also use the  button to edit a rule condition,  button to remove a rule condition, or 
button to clear all rule conditions.

9. Click Next or the Enter Include Rule Context Information step in the left pane.

Teamcenter displays options to define information for the object to be included in the right pane.

Create include rules
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10. Perform the following steps to define information for the object to be included:

a. Select if the included item is inserted in the input or output structure from the Include Item
Focus list.

b. Select if the included item is a sibling or child of the structure line that meets the Include
Item Focus list conditional criteria from the Relation with conditional item list.

c. Search for the required item ID to be included in the Item Id box.

11. Click Next or the View Rule Summary step in the left pane.

Teamcenter displays the summary of the Include rule that is to be created in the right pane.

• The Name and Description boxes display the values that you provide in the Select Rule Type
step.

If you want to modify the values in the Name and Description boxes, click the Select Rule
Type step in the left pane, and modify the values in the Rule Name and Description boxes
accordingly.

• The Rule Preview box lets you preview the Include rule that is to be created.

If you want to modify the Include rule, click Back or the Create Conditional Expression step in
the left pane and modify the rule accordingly.

12. Click Finish to create a Include rule.

Teamcenter displays the new Include rule in the Rule Details pane.

Create reuse rules

Reuse rule is a mechanism to reuse item revisions that are already associated with an input item to be
used in an output structure, if they meet specific criteria.

Note:

Reuse rules provide a mechanism to use an existing CAE 3D Analysis item in the output structure
to represent a component from the input product structure rather than creating a new CAE 3D
Analysis item to represent that component.

Simulation Process and Data Management applies reuse rules at the subassembly level as well as
the component level.

1. In My Teamcenter or CAE Manager, from the Home view, select a CAE Structure Map item
revision, right-click and choose Send To→CAE Manager.

3. Create structure map rules to generate model structures for specific types of analyses
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2. Select the required CAE Structure Map item revision in the Structure Map Item Revisions tree.

3. Click the Add CAE Structure Map Rule  button.

4. In the CAE New Structure Map Rule dialog box, perform the following steps to select a rule type
and define the rule information:

a. From the SM Rule Types tree, select the Reuse rule type.

b. In the Rule Name box, type a name for the Reuse rule.

c. (Optional) In the Description box, type a description for the Reuse rule.

5. Click Next or the Enter Reuse Rule Search Parameters Information step in the left pane.

Teamcenter displays options to search for reuse objects in the right pane.

6. Perform the following steps to define the Reuse rule search parameters:

a. Select the required input class and type from the Class and Types list in the Input Details
Objects group.

b. Select the required relation for the reuse object from the Reuse Relation list.

c. Select the required output class and type from the Class and Types list in the Output Object
Details group.

7. Click Next or the Create Conditional Expression step in the left pane.

Teamcenter displays options to create a conditional (or Boolean) criteria to identify the lines in the
input structure in the right pane.

8. Perform the following steps to create a conditional expression:

Note:

You can perform these steps in random order.

• Select an attribute.

• Select the Item, Item Revision, Form, or BOMLine class from the Class list.

• Based on the class you select, Teamcenter automatically displays the type options in
alphabetical order in the Types list.

Select the required type from the Types list.

Create reuse rules
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• Based on the type you select. Teamcenter automatically displays the attribute options in
alphabetical order in the Attributes list.

Select the required attribute from the Attributes list.

• Define a conditional expression.

• Select the required XSLT function in the XSLT Function tree.

Note:

An XSLT function is required to create a conditional expression that has a primary return
type, Boolean.

• Drag the selected XSLT function in the pane next to the XSLT Function tree.

• Provide values for the XSLT function in one of the following ways:

■ Type static values in the parameter box.

■ Drag the required attributes in the parameter box.

■ Select an XSLT function from the XSLT Function tree and drag it in the parameter box.

If you leave the mandatory parameter boxes empty, Teamcenter displays the following
message:

One or More than one Required Fields empty

• Click the  button and/or  button to add the rule condition to the set of conditions.

You can also use the  button to edit a rule condition,  button to remove a rule condition, or 
button to clear all rule conditions.

9. Click Next or the View Rule Summary step in the left pane.

Teamcenter displays the summary of the Reuse rule that is to be created in the right pane.

• The Name and Description boxes display the values that you provide in the Select Rule Type
step.

If you want to modify the values in the Name and Description boxes, click the Select Rule
Type step in the left pane, and modify the values in the Rule Name and Description boxes
accordingly.

• The Rule Preview box lets you preview the Reuse rule that is to be created.

3. Create structure map rules to generate model structures for specific types of analyses

3-12  Simulation Process and Data Management on Rich Client ─ Usage, Teamcenter 2412
© 2025 Siemens



If you want to modify the Reuse rule, click Back or the Create Conditional Expression step in
the left pane and modify the rule accordingly.

10. Click Finish to create a Reuse rule.

Teamcenter displays the new Reuse rule in the Rule Details pane.

Create recycle rules

Recycle rule is a mechanism to recycle a newly created item revision in the current data mapping
execution rather than create a new item revision during the data mapping process. This existing item
revision, associated with an item revision in the input structure and used in the generated output
structure, is recycled if the item revision meets the relationship and input/output type criteria.

Note:

Recycle rules hold precedence over Reuse rules.

1. In My Teamcenter or CAE Manager, from the Home view, select a CAE Structure Map item
revision, right-click and choose Send To→CAE Manager.

2. From the Structure Map Item Revisions tree, select the required CAE Structure Map item
revision.

3. Click the Add CAE Structure Map Rule  button.

4. In the CAE New Structure Map Rule dialog box, perform the following steps to select a rule type
and define the rule information:

a. From the SM Rule Types tree, select the Recycle rule type.

b. In the Rule Name box, type a name for the Recycle rule.

c. (Optional) In the Description box, type a description for the Recycle rule.

5. Click Next or the Create Conditional Expression step in the left pane.

Teamcenter displays the options to create a conditional (or Boolean) criteria to identify the lines in
the input structure in the right pane.

6. Perform the following steps to create a conditional expression:

Note:

It is not essential to perform these steps in the order listed.

Create recycle rules
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• Select an attribute.

• Select the Item, Item Revision, Form, or BOMLine class from the Class list.

• Based on the class you select, Teamcenter automatically displays the type options in
alphabetical order in the Types list.

Select the required type from the Types list.

• Based on the type you select, Teamcenter automatically displays the attribute options in
alphabetical order in the Attributes list.

Select the required attribute from the Attributes list.

• Define a conditional expression.

• Select the required XSLT function in the XSLT Function tree.

Note:

An XSLT function is required to create a conditional expression that has a primary return
type, Boolean.

• Drag the selected XSLT function in the pane next to the XSLT Function tree.

• Provide values for the XSLT function in one of the following ways:

■ Type static values in the parameter box.

■ Drag the required attributes in the parameter box.

■ Select an XSLT function from the XSLT Function tree and drag it in the parameter box.

If you leave the mandatory parameter boxes empty, Teamcenter displays the following
message:

One or More than one Required Fields empty

• Click the  button and/or  button to add the rule condition to the set of conditions.

You can also use the  button to edit a rule condition,  button to remove a rule condition, or 
button to clear all rule conditions.

7. Click Next or the View Rule Summary step in the left pane.

Teamcenter displays the summary of the Filter rule that is to be created.

3. Create structure map rules to generate model structures for specific types of analyses

3-14  Simulation Process and Data Management on Rich Client ─ Usage, Teamcenter 2412
© 2025 Siemens



• The Name and Description boxes display the values that you provide in the Select Rule Type
step.

If you want to modify the values in the Name and Description boxes, click the Select Rule
Type step in the left pane, and modify the values in the Rule Name and Description boxes
accordingly.

• The Rule Preview box lets you preview the Recycle rule that is to be created.

If you want to modify the Recycle rule, click the Back button or the Create Conditional
Expression step in the left pane and modify the rule accordingly.

8. Click Finish to create a Recycle rule.

Teamcenter displays the new Recycle rule in the Rule Details pane.

Create skip rules

Skip rule is a mechanism to skip any level in a subassembly.

Note:

Skip rules skip one level of the product structure while continuing to process any children of the
identified level of the product structure.

1. In My Teamcenter or CAE Manager, from the Home view, select a CAE Structure Map item
revision, right-click and choose Send To→CAE Manager.

2. From the Structure Map Item Revisions tree, select the required CAE Structure Map item
revision.

3. Click the Add CAE Structure Map Rule  button.

4. In the CAE New Structure Map Rule dialog box, perform the following steps to select a rule type
and define the rule information:

a. From the SM Rule Types tree, select the Skip rule type.

b. In the Rule Name box, type a name for the Skip rule.

c. (Optional) In the Description box, type a description for the Skip rule.

5. Click Next or the Create Conditional Expression step in the left pane.

Teamcenter displays the options to create a conditional (or Boolean) criteria to identify the lines in
the input structure in the right pane.

Create skip rules
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6. Perform the following steps to create a conditional expression:

Note:

It is not essential to perform these steps in the order listed.

• Select an attribute.

• Select the Item, Item Revision, Form, or BOMLine class from the Class list.

• Based on the class you select, Teamcenter automatically displays the type options in
alphabetical order in the Types list.

Select the required type from the Types list.

• Based on the type you select, Teamcenter automatically displays the attribute options in
alphabetical order in the Attributes list.

Select the required attribute from the Attributes list.

• Define a conditional expression.

• Select the required XSLT function in the XSLT Function tree.

Note:

An XSLT function is required to create a conditional expression that has a primary return
type, Boolean.

• Drag the selected XSLT function in the pane next to the XSLT Function tree.

• Provide values for the XSLT function in one of the following ways:

■ Type static values in the parameter box.

■ Drag the required attributes in the parameter box.

■ Select an XSLT function from the XSLT Function tree and drag it in the parameter box.

If you leave the mandatory parameter boxes empty, Teamcenter displays the following
message:

One or More than one Required Fields empty

• Click the  button and/or  button to add the rule condition to the set of conditions.

3. Create structure map rules to generate model structures for specific types of analyses
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You can also use the  button to edit a rule condition,  button to remove a rule condition, or 
button to clear all rule conditions.

7. Click Next or the View Rule Summary step in the left pane.

Teamcenter displays the summary of the Filter rule that is to be created.

• The Name and Description boxes display the values that you provide in the Select Rule Type
step.

If you want to modify the values in the Name and Description boxes, click the Select Rule
Type step in the left pane, and modify the values in the Rule Name and Description boxes
accordingly.

• The Rule Preview box lets you preview the Skip rule that is to be created.

If you want to modify the Skip rule, click the Back button or the Create Conditional Expression
step in the left pane and modify the rule accordingly.

8. Click Finish to create a Skip rule.

Teamcenter displays the new Skip rule in the Rule Details pane.

Create collector rules

The create collector rule is a mechanism to create a predefined collector for the components (single
parts or subassemblies) you want to move.

Note:

The create collector rule provides a mechanism to create a new CAE 3D Analysis item that is
inserted as a child of the root of the resulting output structure and has no relationship to any
component in the input product structure.

1. In My Teamcenter or CAE Manager, from the Home view, select a CAE Structure Map item
revision, right-click and choose Send To→CAE Manager.

2. Select the required CAE Structure Map item revision in the Structure Map Item Revisions tree.

3. Click the Add CAE Structure Map Rule  button.

4. In the CAE New Structure Map Rule dialog box, perform the following steps to select a rule type
and define the rule information:

a. From the SM Rule Types tree, select the Create Collector rule type.

Create collector rules
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b. In the Rule Name box, type a name for the Create Collector rule.

c. (Optional) In the Description box, type a description for the Create Collector rule.

5. Click Next or the Enter Collector Details step in the left pane.

Teamcenter displays options to define basic information for the new collector item.

6. Perform the following steps to define basic information for the new collector item:

a. From the Collector Types tree, select an appropriate option.

b. In the Collector Name box, type a name for the Create Collector rule.

c. (Optional) In the Description box, type a description for the Create Collector rule.

7. Click Next or the Define Additional Item Information step in the left pane.

Teamcenter displays options to define additional item information.

(Optional) Enter Project ID, Previous Version ID, and data in other boxes as appropriate.

8. Click Next or the Define Additional Item Revision Information step in the left pane.

Teamcenter displays options to define additional item revision information.

(Optional) Select Solver Name, Analyses Types, and enter data in other boxes as appropriate.

9. Click Next or the View Rule Summary step in the left pane.

Teamcenter displays the summary of the Create Collector rule that is to be created in the right
pane.

• The Name and Description boxes display the values that you provide in the Select Rule Type
step.

If you want to modify the values in the Name and Description boxes, click the Select Rule
Type step in the left pane, and modify the values in the Rule Name and Description boxes
accordingly.

• The Rule Preview box lets you preview the Create Collector rule that is to be created.

If you want to modify the Create Collector rule, click the Back button or the steps in the left
pane and modify the rule accordingly.

10. Click Finish to create a Create Collector rule.

3. Create structure map rules to generate model structures for specific types of analyses
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Teamcenter displays the new Create Collector rule in the Rule Details pane.

Create move to collector rules

The move to collector rule is a mechanism to move components (single parts or subassemblies) to a
predefined collector node in the output structure based on user-specified criteria (item ID, item name,
attributes, and so on). It provides a mechanism to insert a CAE 3D Analysis item representing a
component in the input product structure into the resulting output structure as a child of a collector CAE
3D Analysis item defined by a create collector rule.

1. In My Teamcenter or CAE Manager, from the Home view, select a CAE Structure Map item
revision, right-click and choose Send To→CAE Manager.

2. Select the required CAE Structure Map item revision in the Structure Map Item Revisions tree.

3. Click the Add CAE Structure Map Rule  button.

4. In the CAE New Structure Map Rule dialog box, perform the following steps to select a rule type
and define the rule information:

a. From the SM Rule Types tree, select the Move To Collector rule type.

b. In the Rule Name box, type a name for the Move To Collector rule.

c. (Optional) In the Description box, type a description for the Move To Collector rule.

5. Click Next or the Enter Collector Details step in the left pane.

Teamcenter displays options to select the collector to which the component will be moved.

6. From the Available Collectors menu, select the appropriate collector.

7. Perform the following steps to create a conditional expression:

Note:

It is not necessary to perform these steps in the order listed.

• From the Criteria Focus menu, select one of the following options:

• IN to use item, item revision, form, or BOMLine attributes in the input structure, if they meet
specific criteria.

• OUT to use item, item revision, form, or BOMLine attributes in the output structure, if they
meet specific criteria.

Create move to collector rules
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• Select an attribute.

• Select the Item, Item Revision, Form, or BOMLine class from the Class list.

• Based on the class you select, Teamcenter automatically displays the type options in
alphabetical order in the Types list.

Select the required type from the Types list.

• Based on the type you select, Teamcenter automatically displays the attribute options in
alphabetical order in the Attributes list.

Select the required attribute from the Attributes list.

• Define a conditional expression.

• Select the required XSLT function in the XSLT Function tree.

Note:

An XSLT function is required to create a conditional expression that has a primary return
type, Boolean.

• Drag the selected XSLT function in the pane next to the XSLT Function tree.

• Provide values for the XSLT function in one of the following ways:

■ Type static values in the parameter box.

■ Drag the required attributes in the parameter box.

■ Select an XSLT function from the XSLT Function tree and drag it in the parameter box.

If you leave the mandatory parameter boxes empty, Teamcenter displays the following
message:

One or More than one Required Fields empty

• Click the  button and/or  button to add the rule condition to the set of conditions.

You can also use the  button to edit a rule condition,  button to remove a rule condition, or 
button to clear all rule conditions.

8. Click Next or the View Rule Summary step in the left pane.

3. Create structure map rules to generate model structures for specific types of analyses
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Teamcenter displays the summary of the Move To Collector rule that is to be created in the right
pane.

• The Name and Description boxes display the values that you provide in the Select Rule Type
step.

If you want to modify the values in the Name and Description boxes, click the Select Rule
Type step in the left pane, and modify the values in the Rule Name and Description boxes
accordingly.

• The Rule Preview box lets you preview the Move To Collector rule that is to be created.

If you want to modify the Move To Collector rule, click the Back button or the steps in the left
pane and modify the rule accordingly.

9. Click Finish to create a Move To Collector rule.

Teamcenter displays the new Move To Collector rule in the Rule Details pane.

Create remove empty subassembly rules

Remove empty subassembly rule is a mechanism to remove empty subassemblies from the output
structure after other rules are executed. It cleans up the resulting output structure by removing indicated
subassemblies that have no components due to other changes that have been made to the structure
through various structure map rules.

Note:

If you define a rule in the structure map to remove all empty subassemblies, Teamcenter ignores
any remaining remove empty subassembly rules.

1. In My Teamcenter or CAE Manager, from the Home view, select a CAE Structure Map item
revision, right-click and choose Send To→CAE Manager.

2. Select the required CAE Structure Map item revision in the Structure Map Item Revisions tree.

3. Click the Add CAE Structure Map Rule  button.

4. In the CAE New Structure Map Rule dialog box, perform the following steps to select a rule type
and define the rule information:

a. From the SM Rule Types tree, select the Remove Empty Sub-Assembly rule type.

b. In the Rule Name box, type a name for the Remove Empty Sub-Assembly rule.

Create remove empty subassembly rules
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c. (Optional) In the Description box, type a description for the Remove Empty Sub-Assembly
rule.

5. Click Next or the Remove Empty Sub-Assembly Scope Details step in the left pane.

Teamcenter displays options to define the empty subassembly to be removed.

6. (Optional) Select the Apply rule to ALL empty sub-assemblies in the output structure check box.

7. Perform the following steps to create a conditional expression:

Note:

You can create a conditional expression only if you deselect the Apply rule to ALL empty
sub-assemblies in the output structure check box.

It is not necessary to perform these steps in the order listed.

• From the Criteria Focus menu, select:

Note:

This menu is available only if you deselect the Apply rule to ALL empty sub-assemblies in
the output structure check box.

• IN to use item, item revision, form, or BOMLine attributes in the input structure, if they meet
specific criteria.

• OUT to use item, item revision, form, or BOMLine attributes in the output structure, if they
meet specific criteria.

• Select an attribute.

• Select the Item, Item Revision, Form, or BOMLine class from the Class list.

• Based on the class you select, Teamcenter automatically displays the type options in
alphabetical order in the Types list.

Select the required type from the Types list.

• Based on the type you select, Teamcenter automatically displays the attribute options in
alphabetical order in the Attributes list.

Select the required attribute from the Attributes list.

• Define a conditional expression.
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• Select the required XSLT function in the XSLT Function tree.

Note:

An XSLT function is required to create a conditional expression that has a primary return
type, Boolean.

• Drag the selected XSLT function in the pane next to the XSLT Function tree.

• Provide values for the XSLT function in one of the following ways:

■ Type static values in the parameter box.

■ Drag the required attributes in the parameter box.

■ Select an XSLT function from the XSLT Function tree and drag it in the parameter box.

If you leave the mandatory parameter boxes empty, Teamcenter displays the following
message:

One or More than one Required Fields empty

• Click the  button and/or  button to add the rule condition to the set of conditions.

You can also use the  button to edit a rule condition,  button to remove a rule condition, or 
button to clear all rule conditions.

8. Click Next or the View Rule Summary step in the left pane.

Teamcenter displays the summary of the Remove Empty Sub-Assembly rule that is to be created
in the right pane.

• The Name and Description boxes display the values that you provide in the Select Rule Type
step.

If you want to modify the values in the Name and Description boxes, click the Select Rule
Type step in the left pane, and modify the values in the Rule Name and Description boxes
accordingly.

• The Rule Preview box lets you preview the Remove Empty Sub-Assembly rule that is to be
created.

If you want to modify the Remove Empty Sub-Assembly rule, click the Back button or the steps
in the left pane and modify the rule accordingly.

9. Click Finish to create a Remove Empty Sub-Assembly rule.

Create remove empty subassembly rules
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Teamcenter displays the new Remove Empty Sub-Assembly rule in the Rule Details pane.

Create collapse single component subassembly rules

Collapse single component subassembly rule is a mechanism to collapse single component
subassemblies in the output structure after other rules are executed. When you collapse a single
component subassembly in the output structure, Teamcenter removes the root of the single component
subassembly and promotes the child single component one level higher in the structure hierarchy.

Note:

If you define a rule in the structure map to collapse all single component subassemblies,
Teamcenter ignores any remaining collapse single component subassembly rules.

1. In My Teamcenter or CAE Manager, from the Home view, select a CAE Structure Map item
revision, right-click and choose Send To→CAE Manager.

2. Select the required CAE Structure Map item revision in the Structure Map Item Revisions tree.

3. Click the Add CAE Structure Map Rule  button.

4. In the CAE New Structure Map Rule dialog box, perform the following steps to select a rule type
and define the rule information:

a. From the SM Rule Types tree, select the Collapse Single Component Sub-Assembly rule
type.

b. In the Rule Name box, type a name for the Collapse Single Component Sub-Assembly rule.

c. (Optional) In the Description box, type a description for the Collapse Single Component
Sub-Assembly rule.

5. Click Next or the Collapse Single Component Sub-Assembly Scope Details step in the left pane.

Teamcenter displays options to define the empty subassembly to be removed.

6. Perform the following steps to define the empty subassembly to be removed:

a. (Optional) Select the Apply rule to ALL single component sub-assemblies in the output
structure check box.

b. From the Criteria Focus menu, select:

3. Create structure map rules to generate model structures for specific types of analyses
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Note:

This menu is available only if you deselect the Apply rule to ALL single component
sub-assemblies in the output structure check box.

• IN to use item, item revision, form, or BOMLine attributes associated with an input item in
the input structure, if they meet specific criteria.

• OUT to use item, item revision, form, or BOMLine attributes associated with an input item
in the output structure, if they meet specific criteria.

7. Perform the following steps to create a conditional expression:

Note:

You can create a conditional expression only if you deselect the Apply rule to ALL single
component sub-assemblies in the output structure check box.

It is not necessary to perform these steps in the order listed.

• Select an attribute.

• Select the Item, Item Revision, Form, or BOMLine class from the Class list.

• Based on the class you select, Teamcenter automatically displays the type options in
alphabetical order in the Types list.

Select the required type from the Types list.

• Based on the type you select, Teamcenter automatically displays the attribute options in
alphabetical order in the Attributes list.

Select the required attribute from the Attributes list.

• Define a conditional expression.

• Select the required XSLT function in the XSLT Function tree.

Note:

An XSLT function is required to create a conditional expression that has a primary return
type, Boolean.

• Drag the selected XSLT function in the pane next to the XSLT Function tree.

• Provide values for the XSLT function in one of the following ways:

Create collapse single component subassembly rules
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■ Type static values in the parameter box.

■ Drag the required attributes in the parameter box.

■ Select an XSLT function from the XSLT Function tree and drag it in the parameter box.

If you leave the mandatory parameter boxes empty, Teamcenter displays the following
message:

One or More than one Required Fields empty

• Click the  button and/or  button to add the rule condition to the set of conditions.

You can also use the  button to edit a rule condition,  button to remove a rule condition, or 
button to clear all rule conditions.

8. Click Next or the View Rule Summary step in the left pane.

Teamcenter displays the summary of the Collapse Single Component Sub-Assembly rule that is
to be created in the right pane.

• The Name and Description boxes display the values that you provide in the Select Rule Type
step.

If you want to modify the values in the Name and Description boxes, click the Select Rule
Type step in the left pane, and modify the values in the Rule Name and Description boxes
accordingly.

• The Rule Preview box lets you preview the Collapse Single Component Sub-Assembly rule
that is to be created.

If you want to modify the Collapse Single Component Sub-Assembly rule, click the Back
button or the steps in the left pane and modify the rule accordingly.

9. Click Finish to create a Collapse Single Component Sub-Assembly rule.

Teamcenter displays the new Collapse Single Component Sub-Assembly rule in the Rule Details
pane.

Create inclusion and exclusion lists to filter out standard parts

Why create inclusion and exclusion lists?

While performing analysis on large product structures—for example, automotive vehicle level
computational fluid dynamics (CFD) analysis—analysts have to load these structures with graphics and
make interactive selections with the embedded visualization. As this is time consuming, analysts rely on
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Lifecycle Visualization to efficiently load and make selections on the components and subassemblies that
they want to include in the analysis.

Analysts can leverage the selections made in Lifecycle Visualization and use them in structure map rules
to quickly generate model structures. To do this, they must make some customizations. First, they must
create structure map rules based on the Lifecycle Visualization selections. Next, they must execute these
rules to create the model structure.

At your site, you may have a standard list of parts that are typically included or excluded while
performing simulations on various product structures from one or more vehicle programs. You can
create such inclusion or exclusion lists and apply them while running structure map rules. By doing so,
you eliminate the need for customizations. After creating them, you can associate them to structure map
rules. While creating model structures by using structure map rules, the system automatically includes or
excludes these standard parts.

Create an exclusion list

1. Create an exclusion list.

a. Create a plain text file with each line item in the following format:

“Class Name::Type Name::Attribute Name::Attribute Value”

To filter out a part with the name, Sunroof, add the following lines:

ItemRevision::ItemRevision::object_name::Sunroof

Similarly, to use other attributes, add the following lines:

• ItemRevision::ItemRevision::object_name::Moonroof
• ItemRevision::ItemRevision::item_id::94372773
• ItemRevision::ItemRevision::custom_attr1::Yes

You can use wildcards. The following is the syntax for ends with, begins with, and contains,
respectively:

• ItemRevision::ItemRevision::object_name::*Sunroof (an asterisk before Sunroof)
• ItemRevision::ItemRevision::object_name::Sunroof* (an asterisk after Sunroof)
• ItemRevision::ItemRevision::object_name::*Sunroof* (an asterisk before and after Sunroof)

Note:

:: is used as a separator. You cannot use a separator in the attribute name or attribute
value. Examples: object::name or Sunroof::Moonroof.

Create an exclusion list
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b. In CAE Manager, in the Home folder, click File→New→CAE Item and then select CAE
Structure Map Filter.

c. Click Assign to automatically assign an ID and revision number.

d. Specify a name and click Next.

e. Click Add to add a dataset type and then click Add to add a reference type. Click Browse to
add the text file containing the exclusion list.

f. To create the structure map filter, click Finish.

2. Associate the exclusion list to a structure map item revision.

a. From the Home folder, select a CAE Structure Map item revision, right-click, and choose
Send To→CAE Manager.

b. From the Structure Map Item Revisions tree, select the CAE Structure Map item revision.
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c. To create an exclusion list, click Manage Exclusion List.

d. Select CAE Structure Map Filter Item, select Latest Released Revision or Latest Working
Revision, and then click Search.

Alternatively, to select a specific revision, choose CAE Structure Map Filter Item Revision and
click Search.

e. Select the structure map filter you created earlier and click OK.

You can add multiple structure map filters to manage different exclusion lists.

Create an inclusion list

1. Search for the product item revision in My Teamcenter.

2. Right-click the product item revision and choose Send To→CAE Manager.

3. Specify visualization options.

a. Click Edit→Options and select Visualization.

b. Select Yes for both View NX .prt files as 2D images and Show "Open in Lifecycle
Visualization" command.

Create an inclusion list
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4. Create the inclusion list.

a. Select the product structure and click Start/Open in Lifecycle Visualization .

b. Expand the product structure and select the specific BOM lines you want to include. If you
select a child item, the system automatically select its immediate parent assembly and the
root structure.

c. Select File→Export.

d. In the Export dialog box, click Browse to set the location where you want to save the file,
select Product Structure (*.plmxml) as the file format, and click OK to complete the export.

e. In the Home folder of CAE Manager, select a folder and click File→New→CAE Item and then
select CAE Structure Map Filter.

f. In Object Create Information, specify a name and click Next.

3. Create structure map rules to generate model structures for specific types of analyses
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g. In the Enter CAE Attach Files Information, click Browse and specify the location where you
saved the exported file in step d.

Create an inclusion list
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You must choose *.plmxml while searching for the exported file.
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5. Click Finish to create the structure map filter.

Apply the exclusion or inclusion list

1. In My Teamcenter, search for the product item revision.

2. Right-click the product item revision and choose Send To→CAE Manager.

3. Click Generate CAE Structure from CAE Structure Map  in the view toolbar.

4. Select a structure map item revision from the Most Recently Used list or select CAE Structure Map
ID/Revision and search for a structure map item revision.

5. Select Select an existing CAE Structure Map Filter Revision and click Search to search for the
structure map filter containing the inclusion or exclusion list.

Alternatively, select Create a new CAE Structure Map Filter Revision with Inclusion List and
select and click Search to search for the structure map filter containing the inclusion or exclusion
list.

Apply the exclusion or inclusion list
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6. To create a model structure with the exclusion or inclusion list, click Execute.

Associate predefined simulation tools to structure map rules

After creating structure map rules, you can associate predefined simulation tools to the rules you have
created by using the Select Simulation Tool dialog box.

When the simulation analyst runs these structure map rules, the system creates a model structure and
launches the predefined simulation tools. The simulation analyst can then view the progress of the tools
in the Simulation Tool Progress Monitor dialog box.

1. Choose File→New→CAE Item in My Teamcenter or the Home view of CAE Manager.

3. Create structure map rules to generate model structures for specific types of analyses
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2. In the New CAE Item dialog box, select CAE Structure Map and click Next.

3. Specify a name and click Finish.

4. Select the structure map item revision you created, right-click, and choose Send To→CAE
Manager.

5. In the CAE Structure Map Configuration view, select the structure map item revision and create
structure map rules and an exclusion list as appropriate.

6. To configure a simulation tool after you create structure map rules, click Select Simulation Tool.

7. In the Select Simulation Tool dialog box, select simulation tools and the simulation tool launch
type.

Associate predefined simulation tools to structure map rules
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Note:

This dialog box displays only the simulation tool items for which the latest released revision
is configured. Additionally, the system does not enforce the access control rules from the
Simulation Tool Configuration view while displaying the simulation tool items.

3. Create structure map rules to generate model structures for specific types of analyses
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4. Create and manage model structures
Generate CAE model structures

Create models

1. Open the product structure you want to analyze

An engineering manager reviews design requirements and assigns design changes for validation
to a simulation analyst using a workflow. The workflow contains the design requirements,
configuration information, subassembly, and components required for analysis.

2. Configure the product structure

If you work in a product environment with a lot of variability, such as the automobile industry, you
can apply revision rules, effectivity, or variant rules to make the product structure relevant to your
analysis.
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3. Apply predefined data map rules

The simulation administrator defines the data map rules.

Based on these rules, the system creates model revisions for each generic item revision in the
product structure, names the resulting model revisions with the default CAE prefix, and defines
default relationships between product revisions, geometry revisions, and model revisions.

4. Apply predefined structure map rules

The lead analyst or the designated analyst creates structure map rules.

In an organization, different groups of analysts perform different types of analyses. There are
specialists for NVH analysis, thermal analysis, and durability analysis. The lead analyst creates many
types of structure map rules. You can use this option to create a model structure for a specific type
of analysis.

Typically, the model structure is similar to the, but not the same as the product structure. Structure
map rules allow you to remove BOM lines from the product structure based on filter criteria,
reuse existing model revisions for a part that has been previously analyzed, and create new model
revisions for the new parts you want to analyze. In addition, these rules help define default
relationships between product revisions, geometry revisions, and model revisions.

5. Create different simulation models

You can apply predefined structure map rules to the product structure to create different types
of models for different types analysis. You can create different models to perform NVH analysis,
thermal analysis, durability analysis, and so on.

6. Compare and update the model structure when the product structure changes

Let us assume a scenario where you (as a simulation analyst) receive a product structure for
analysis. You apply structure map rules to the product structure and create the CAE structure. You
also generate meshes with connections, define load cases, generate the deck, and perform a solve.

Later, you are notified that there are some minor changes to the product structure. Instead of
recreating the complete CAE structure, you decide to compare the existing CAE structure with
the changed product structure, understand the changes, and make updates to the existing CAE
structure. You use the Inspector view in CAE Manager to find if any new components are
added, removed, or revised, and update the CAE structure.

Then, you can use the CAE Attribute Compare feature to compare differences in the mapped
attributes (for example, material ID or transformation), review the report and optionally save it,
and finally propagate the changes on the CAE structure.

4. Create and manage model structures
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What are model structures?

Use the Model view to interactively define and manipulate hierarchical CAE models that can reference
target CAD models and source CAD or CAE geometry. It contains BOM view attributes. You can view,
create, and manage CAE 3D Model item revisions in this pane.

While performing simulations on large and complex product structures, you must frequently build large
model structures. With large product or model structures, it is difficult to navigate through the entire
structure and find information. Similar to filtering data in spreadsheets, you can apply multiple filters to
large structures and view only those structure lines that are relevant to your simulation analysis.

You can perform the following tasks in the Model view:

You can run the CAE BOM Compare report to view two different simulation variants side-by-side, and
compare them to obtain a visual understanding of their differences as they are color coded. Even if you
apply multiple filters after performing a BOM comparison, the system retains the color coding for the
structure lines.

• View, create, and manage CAE 3D Model item revisions.

• View and manage composite CAE model structures.

• Apply multiple filter criteria to filter structures and view only the structure lines that are relevant to
your simulation.

• Manage Target Product and Source Representation references for a CAE 3D Model item revision.

• Launch simulation tools.

• Create CAE packages.

• View and manage configuration rules that deal with CAE variant options.

• View and manage attachments.

• Perform Where Used or Where Referenced searches.

• View an image of the selected line or structure, if the DirectModel dataset is available.

After configuring the product structure, you can apply datamap and structure map rules to
create a model structure. If the Variants option is enabled by the simulation administrator in the
datamapping.xml file, then the configuration context is referenced by the model structure when you
apply the datamap and structure map rules. The variants are always referenced and never cloned
irrespective of its setting in the datamapping.xml file for the product configurator.

What are model structures?
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After you apply datamap and structure map rules to create a model structure, the resulting model
structure uses only the BOM lines that are available in the Product view after you have configured the
product structure. The model structure has its context set to the same configuration context as that of
the source product structure. If the default configuration context is set, the model structure references
the same context. Moreover, all the variant formula from the source product structure is mapped to the
model structure.

Note:

When you open multiple model structures, make sure that you do not open structures with
Product Configurator variant data and classic variant data in multiple views at the same time. If
you want to view both types of data, you must attach the configurator context to all the open
structures and restart CAE Manager.

Configure the model structure before generating it

After configuring the product structure, you can apply datamap and structure map rules to
create a model structure. If the Variants option is enabled by the simulation administrator in the
datamapping.xml file, then the configuration context is referenced by the model structure when you
apply the datamap and structure map rules. The variants are always referenced and never cloned
irrespective of its setting in the datamapping.xml file for the product configurator.

After you apply datamap and structure map rules to create a model structure, the resulting model
structure uses only the BOM lines that are available in the Product view after you have configured the
product structure. The model structure has its context set to the same configuration context as that of
the source product structure. If the default configuration context is set, the model structure references
the same context. Moreover, all the variant formula from the source product structure is mapped to the
model structure.

Note:

When you open multiple model structures, make sure that you do not open structures with
Product Configurator variant data and classic variant data in multiple views at the same time. If
you want to view both types of data, you must attach the configurator context to all the open
structures and restart CAE Manager.

Generate the CAE model structure

After configuring the product structure, you can apply datamap and structure map rules to
create a model structure. If the Variants option is enabled by the simulation administrator in the
datamapping.xml file, then the configuration context is referenced by the model structure when you
apply the datamap and structure map rules. The variants are always referenced and never cloned
irrespective of its setting in the datamapping.xml file for the product configurator.

After you apply datamap and structure map rules to create a model structure, the resulting model
structure uses only the BOM lines that are available in the Product view after you have configured the
product structure. The model structure has its context set to the same configuration context as that of

4. Create and manage model structures

4-4  Simulation Process and Data Management on Rich Client ─ Usage, Teamcenter 2412
© 2025 Siemens



the source product structure. If the default configuration context is set, the model structure references
the same context. Moreover, all the variant formula from the source product structure is mapped to the
model structure.

Note:

When you open multiple model structures, make sure that you do not open structures with
Product Configurator variant data and classic variant data in multiple views at the same time. If
you want to view both types of data, you must attach the configurator context to all the open
structures and restart CAE Manager.

You can view a product structure in the Product view, apply data map and structure map definitions to
it, and generate a CAE model structure in the Model view.

Using the data map and structure map functions in the Product view in Teamcenter, you can generate
CAE model structures based on input product structures and a defined set of structure rules.

Simulation analysts often use the product structure to create a simulation structure based on a
functional subsystem to include components relevant to their analysis. They identify such components
by reorganizing, grouping, and filtering out components from the product structure. Doing this manually
is time consuming. To simplify this process, the lead (or the designated) simulation analyst creates
structure map rules that consist of filter, skip, include, and other rules. The structure map rules can then
be used by other simulation analysts to create consistent CAE model structures for better analysis.

Note:

When you generate a model structure for a subassembly using a workflow process, the output
model structure does not include the equivalent of the root of the original structure. However,
when you select specific BOM lines of a product structure and apply structure map rules, the
structure map output includes the equivalent of the root of the original structure.

You can select the root BOM line of a product structure and create a model structure for the entire
product structure or select specific BOM lines of a product structure and create a model structure of the
selected BOM lines and its children. You can interactively select specific BOM lines especially when filter
or skip rules are not available but all other rules are available in the structure map rule.

Example:

Let us assume that there is a skip rule, for example, to ignore all bolts in a structure. While
interactively selecting BOM lines, even if you select a BOM line that has the bolt as its part by
mistake, the system does not process this BOM line while creating the model structure.

Example 1: If you select the root level structure, the system processes all the subassemblies and their
children at their levels.

Generate the CAE model structure
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Example 2: If you select a subassembly, the system processes all its children at all levels.

Example 3: If you select a subassembly and select some children, the system processes the selected
children and all other children in the same subassembly. It ignores all other children of other
subassemblies.

4. Create and manage model structures
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Example 4: If you select Child1 from subassembly1, even though the same child and subassembly
occurs in another assembly, the system filters out the other assembly.

Example 5: For the first BOM line selection, the system filters out Child2 and for the second selection,
generates both the child occurrences as expected. However, for the third selection, the system generates
both the child occurrences though you have selected only one. This is because the same subassembly,
containing similar child occurrences, is nested at the same level below the root.

Generate the CAE model structure
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Clone or reference variant information

You, as a simulation analyst, can use predefined data map rules and structure map rules to create a
model structure from the product structure. Also, you can use predefined derivative rules to derive
one or more structures from an existing model structure. Derivative rules use both the data map and
structure map rules to derive structures.

The source structure contains variant information such as variant conditions, variant options, saved
variant rules (SVRs), option defaults, and rule checks. By default, the system clones the variant options
and SVRs to the target structure and maps the rest of the variant information to the target structure.

Some companies may have business practices that prevent the cloning of variant information. In such
cases, the simulation administrator at your site configures the datamapping.xml file to reference the
variant information instead of cloning it.

Variant information (source structure) Variant information (target structure)

Variant options Cloned or referenced

Saved variant rules (SVRs) Cloned or referenced

Variant conditions Mapped

Option defaults Mapped

Rule checks Mapped

Note:

For derivative rules, the behavior is the same except that the source is a CAE structure and not a
CAD BOM.

4. Create and manage model structures
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While the reference method retains the same IDs for the source product BOM lines, the clone
method creates new IDs.

Example 1 (reference method): All the variant information is available on the opened source structure.

Example 2 (reference method): All the variant information is not available on the opened source
structure.

Clone or reference variant information
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Example 3 (clone method): All the variant information is available on the opened source structure.

4. Create and manage model structures
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Example 4 (clone method): All the variant information is not available on the opened source structure.

Clone or reference variant information
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Create a model structure using data map rules

You can create a model structure that is an exact replica of the product structure using data map rules.

1. In the Product view, open a product structure (non-CAE item revision).

2. (Optional) Select a structure line.

3. To view the available attributes and/or values of the selected line, click Generate Node XML  in
the main toolbar.

You can selecting one of the following options in the Node XML Information dialog box:

• List All Attributes to list all attributes available of the context BOM line item. This is the default
option.

• List Configure Attributes Only to list only configured attributes of the context BOM line item.

4. Create and manage model structures
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If you select this option, the system persists this selection when you open the Node XML
Information dialog box the next time.

You can view these attributes separately for each of the domains configured in the
NodeXMLConfig.xml file.

4. Click Generate CAE Structure from Data Map in the  view toolbar and select one of the
following options:

• CAE

This is the default domain.

Select this domain to generate a model structure from an existing product structure or product
collector structure.

The system creates a CAE-source_product_structure_name structure. This structure contains
a corresponding CAE-BOM_Line_Name item revision for each generic item in the product
structure.

• CFD

Select this domain to generate a model structure from an existing product structure or product
collector structure with mapping of DirectModel datasets (or JT files) from the source structure
to the output structure.

This domain option is similar to the default CAE option. It additionally maps the JT files.

The system creates a CFD-source_product_structure_name structure. This structure contains a
corresponding CFD-BOM_Line_Name item revision for each generic item in the product structure
with the JT mapping if the item revisions in the product structure contain the JT files.

The simulation administrator creates domains. Your company might have different CAE disciplines
for safety, durability, and so on. The company wants data mapping to be different for each
discipline, but there is only one data map XML file for the whole site. Domains are created to
handle data mapping differently in such situations.

5. (Optional) To export the model structure along with the associated JT files, select the
root item you want to export, click Tools → Export → ToPLMXML, and select the
CAEConfiguredDataFilesExportJTOnly transfer mode.

Note:

If the Variants option is disabled by the simulation administrator in the datamapping.xml
file, then the configuration context is not referenced by model structures during the datamap

Create a model structure using data map rules
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operation if the product structure you have opened is already associated to the configurator
context through the Variability Scope relationship.

Teamcenter displays a diagnostic log of the data mapping rules applied to the product structure to
generate a CAE model structure. It displays the generated CAE model structure in an empty Model view
or a new Model, if you have already opened a model structure in this view.

Note:

Alternatively, you can use the cae_execute_datamap utility to apply data mapping rules to an
input structure. To view the command line help for this utility, type cae_execute_datamap -h on
the Teamcenter command prompt.

Create a model structure for a specific type of analysis using structure map
rules

1. Open a product structure in the Product view.

2. (Optional) To make the product structure relevant to your analysis, configure the product
structure.

If you work in a product environment with a lot of variability, such as the automobile industry, you
can apply revision rules, effectivity, and variant rules to make the product structure relevant to your
analysis.

3. (Optional) To allow the system to process only specific subassemblies, select one or more BOM lines
corresponding to individual components.

The system processes only the corresponding components based on the BOM lines you select.

4. (Optional) To allow the system to process multiple subassemblies, select multiple BOM lines
corresponding to the subassemblies you want.

The system processes all the subassemblies and their children at all levels based on the BOM lines
you select.

4. Create and manage model structures
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5. (Optional) To view the available attributes and/or values of the selected line, select a structure line
and click Generate Node XML  in the view toolbar.

You can selecting one of the following options in the Node XML Information dialog box:

• List All Attributes to list all attributes available of the context BOM line item. This is the default
option.

• List Configure Attributes Only to list only configured attributes of the context BOM line item.

If you select this option, the system persists this selection when you open the Node XML
Information dialog box the next time.

You can view these attributes separately for each of the domains configured in the
NodeXMLConfig.xml file.

Create a model structure for a specific type of analysis using structure map rules
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6. Expand the product structure and select the desired components and sub-assemblies you want to
include in the analysis.

7. Apply structure map rules.

a. Click Generate CAE Structure from StructureMap  in the view toolbar.

b. Type the required CAE Structure Map item ID and revision in the Item Id / Rev boxes, or click
Search to search for the required identifiers.

c. Click Execute.

Alternatively, drag a CAEStructureMap item revision from the Home view to the Product
view, and click Execute.

If the lead simulation analyst has configured predefined simulation tools while creating structure
map rules, the system creates the model structure and executes the simulation tools defined as
part of the rules. The tool launch details are logged in the structure map log file. Additionally, the
Simulation Tool Progress Monitor dialog box displays the status of the tool launch.

Note:

Alternatively, you can use the cae_execute_structuremap utility to apply structure map
rules to an input structure. To view the command line help for this utility, type
cae_execute_structuremap -h on the Teamcenter command prompt.

If the Variants option is disabled by the simulation administrator in the datamapping.xml file, the
configuration context is not referenced by model structures during the structure map operation.

Generate a model structure using a preconfigured material revision mapping

You (as a simulation analyst) can use a preconfigured workflow process to create a model structure. This
workflow process uses a predefined structure map rule to create the model structure.

1. Open a product structure in the Product view.

2. (Optional) To make the product structure relevant to your analysis, configure the product
structure.

If you work in a product environment with a lot of variability, such as in the automobile industry,
you can apply revision rules, effectivity, and variant rules to make the product structure relevant to
your analysis.

3. Select the complete product structure or expand it, and select the desired components and sub-
assemblies you want to include.
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4. Click File→New→Workflow Process and specify the process name.

At your site, a user with DBA privileges may create multiple workflow process for different structure
map rules. Check with the administrator at your site for the workflow processes to use.

Generate a model structure using a preconfigured material revision mapping

Simulation Process and Data Management on Rich Client ─ Usage, Teamcenter 2412  4-17
© 2025 Siemens



5. After the workflow is initiated successfully, refresh the Newstuff and Mailbox folders.

The system creates the model structure in the Newstuff folder. Additionally, check your mail for the
execution summary notification.

6. (Optional) Verify whether structure map rules have been applied.

Open the model structure in the Model view. Verify if BOM lines have been removed based on the
filter criteria or item revisions reused, added, or created as per the predefined structure map rules.

7. (Optional) To verify if the owner of the model structure is as per the values specified in the
workflow action handler, select the root model item revision, right-click and choose Open
With→Summary. Verify the owner properties in the Overview tab.

8. (Optional) Verify pedigree information.

Select the root model item revision, right-click and choose Model Pedigree→View Pedigree
Details. Verify if the pedigree information from the product structure is captured.

4. Create and manage model structures
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9. (Optional) Verify the structure map log details

a. In the Mailbox folder, right-click and select Open With→Summary.

b. In the Overview tab, select More Properties.

c. In the Properties dialog box, double-click Execution Summary to view the structure map log
details.

Generate a model structure and export the material information

As a simulation analyst, you can generate a model structure from a product structure that contains
material revisions, export the material information, and use the exported material information to
perform a simulation analysis.

As a prerequisite, Teamcenter Materials Management must be installed and ready to use for exporting
material details.

The process flow for exporting material information is as follows:

Simulation administrator

1. Maps material revisions from the product structure
to the model structure by modifying the
datamapping.xml file.

2. Defines a simulation tool to export the material
information. This tool is configured for a specific solver
type, for example, Simcenter STAR-CCM+.

Simulation analyst

1. Generates the model structure from a product
structure by using data map or structure map rules.
The generated model structure references the material
revisions from the product structure.

2. Selects the generated model structure and runs
the preconfigured simulation tool. The material
information is exported.

3. Performs the analysis by running a preconfigured
analysis tool, for example, Simcenter STAR-CCM+. The
analysis tool uses the exported material information for
running the analysis.

4. Captures the results from the solver, verifies the
results, and sends recommendations.

Generate a model structure using preconfigured material revision mapping

1. Open a product structure that contains material revisions in the Product view.

2. (Optional) To make the product structure relevant to your analysis, configure the product
structure.

Generate a model structure and export the material information
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If you work in a product environment with a lot of variability, such as in the automobile industry,
you can apply revision rules, effectivity, and variant rules to make the product structure relevant to
your analysis.

3. To create a model structure by using data mapping rules, click Generate CAE Structure from Data
Map in the  view toolbar

OR

Create a model structure by using structure map rules, using the following procedure:

a. Click Generate CAE Structure from StructureMap  in the view toolbar.

b. Type the required CAE Structure Map item ID and revision in the Item Id / Rev boxes, or click
Search to search for the required identifiers.

c. Click Execute.

Alternatively, drag a CAEStructureMap item revision from the Home view to the Product
view, and click Execute.

The system creates the model structure.

d. Open the model structure and verify if the structure is created as per the data map rules.

e. (Optional) Open the model structure and verify if the system has created a reference
between the output model structure and the material revisions attached to the source product
structure.

f. Copy the material revision attached to the source product structure and paste it to the model
or geometry revision that has a Materials relation.

In the Enter the values for Properties on Relation dialog box, specify the mass and the unit
of measure, for example, grams.

4. (Optional) Revise or perform a Save As action on the model or the geometry revision that has the
Materials relation. The system references the material revision on the revised or cloned model or
geometry revision.

5. (Optional) To export the model structure along with the related material IDs and material
definitions, select the root item you want to export, click Tools → Export → ToPLMXML, and
select the CAEMaterialInfoExportDefault transfer mode.

Run a preconfigured simulation tool to export the material information

1. In the Model view, select the model revision you generated with material revisions.

4. Create and manage model structures
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2. Launch a preconfigured simulation tool for exporting material information.

3. After the tool is launched, the material file is exported to the same directory as the input files. The
log file of the material export is located in the logs directory of the scratch location.

4. Perform the analysis by running a preconfigured analysis tool, for example, Simcenter STAR-
CCM+. The analysis tool uses the exported material information for running the analysis.

5. Capture the results from the solver, verify the results, and send recommendations.

Generate a model structure containing CAE geometry and
relationships

Generate a model structure containing CAE geometry as secondary objects

While creating the model structure from a product structure, you must often simplify the CAD geometry
you receive prior to meshing. The CAD geometry might contain numerous details, such as sharp edges,
bolt holes, or fillets, which are not required for meshing. Simplifying CAD geometry manually is tedious
and time consuming. You can use data map rules to automate the creation of CAE geometry items with
the necessary relationships.

The simulation administrator defines the data mapping rules at your site. In CAE Manager, you can use
these rules to create a CAE model structure from an existing product structure. The rules determine the
creation and naming pattern of model items and item revisions from the product structure, the mapping
of the product items to the model items, and the relations between the product item revisions and
model item revisions. Depending on predefined rules, you can create a model structure with a primary
output object and a secondary output object with all the correct relationships. The secondary objects
contain the CAE geometry with the correct relationships.

Before creating a model structure for analysis, to enable traceability between the mesh or load case
revisions you have used and the model structure, you must apply the Precise revision rule. By default,
the Latest Working revision rule is applied to all Product and Model views. In some cases, you might
skip applying the Precise revision rule when you create a model structure for analysis. To avoid this,
instead of applying the revision rule, you can set the TC_BOM_Precision_Preference user preference to
Precise to always create a precise structure.

After you create a model structure, you can apply the structure map rules. You can create structure
maps to remove BOM lines based on filter criteria, reuse existing model item revisions, or add existing
model item revisions. For example, you can automatically filter out connectors, such as bolts or pins in
a structure, that are not needed in an analysis or include additional items needed for analysis, such as a
mesh for thermal analysis.

Generate the model structure containing the CAE geometry

1. In CAE Manager, open the required product structure in the Product view.

Generate a model structure containing CAE geometry as secondary objects
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2. To always create a precise structure, set the TC_BOM_Precision_Preference user preference to
Precise. By default, this preference is set to Imprecise.

Alternatively, from the View menu, choose Revision Rule→View/Set Current and then select the
Precise Only revision rule.

You might skip applying a revision rule each time you create a model structure. To avoid this, you
can set the user preference to always create a precise structure.

a. Choose Edit→Options, and then click Search.

b. In the Search on Keywords box, type the first few letters of the preference name, such as
tc_bom, select the preference, and then click Edit.

c. In the Value, type Precise, and then click Save.

3. Create a model structure containing secondary objects.

a. In the Model view, click the Generate CAE Structure from Data Map view toolbar button.

b. Select a domain, and then click Continue.

4. Apply structure map rules after the system creates the model structure.

a. In the Model view, click the CAE 3D Analysis from Structure Map view toolbar button.

b. Type the required CAE Structure Map item ID and revision in the Item Id / Rev boxes, or click
Search to search for the required identifiers.

c. Click Execute.

Manage model structures

Open a model structure, apply filters, and view attachments

1. Start CAE Manager.

2. In the Home view, select a CAE 3D Model item revision, right-click, and choose Send To→CAE
Manager.

3. To apply filters to the model structure and view only the structure lines that are relevant to your
simulation, click Show Filters  on the view toolbar.

4. Create and manage model structures
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Tip:

When you enable filters, the Pack, Unpack, Pack All, and Unpack All options from the View
menu are disabled. This is because these options can slow down your system when you filter
large structures.

a. Select a filter criteria and the filter value.

b. (Optional) Select additional filter criteria and filter values.

c. (Optional) Click Unfilter the data by removing all filters to clear filters from the structure
while retaining both the filter criteria and filter values.

d. (Optional) Click Clear all filters to clear all filters from the structure, including the filter criteria
and filter values.

4. (Optional) To view all unique lowest lines:

a. Select a root item or one or more subassemblies.

b. Click View Menu , and choose Select Below→All Unique Lowest Lines

5. (Optional) To copy the property values from a BOM line to another BOM line:

a. Place the cursor on the property column of a BOM line, right-click, and choose Copy.

b. Move the cursor to a similar property column of a different BOM line, right-click, and choose
Paste.

6. Click Show Data Panel  on the main toolbar to open the data view.

7. Click a tab in the data pane to activate a view.

For example, click the Attachments view in the data pane to activate the Attachments view.

Open a model revision related to the current product revision in context

You can use the Association to Product option to view all the models, analysis, and results associated
with multiple product item revisions (across revisions).

1. In the Product view, open a product item revision.

2. In the Model view, click Open Model on the view toolbar.

Open a model revision related to the current product revision in context
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3. In the Open CAE Model dialog, select the Association to Product option.

4. Choose the referenced CAE 3D Analysis item revision from the tree view, and click Load.

5. (Optional) In the Model view, revise the CAE 3D Analysis item revision and reference it to the
latest product item revision.

Replace a model revision with another model revision

You can replace an existing CAE 3D Model item revision in the Model view with another item revision.
You can search and type the name, item ID, or revision ID (for precise structures) of the item revision you
want to replace with.

During the analysis process, you (as an analyst) might want to make changes to a mesh assembly (CAE
structure) by swapping one mesh (CAE 3D Model item revision) with another, for example, replace a
coarse-mesh model with a fine-mesh model or replace an existing mesh of poor quality with a better
quality mesh. In such scenarios, you can use the Edit→Replace... command to search and view all
other related CAE 3D Model item revisions to the corresponding product item revision with a target
relationship and choose a model item revision to replace the one in the existing CAE structure.

You have the option to replace a single selected model item revision or all instances of that model item
revision in the immediate parent subassembly or all instances of the model item revision in the entire
CAE structure.

1. Start CAE Manager.

2. In the Home view, select a CAE 3D Analysis item revision, right-click, and choose Send To→CAE
Manager.

3. In the Model view, select a model line you want to replace, click View Menu , and choose
Edit→Replace... to open the Replace dialog box.

Note:

You cannot perform a replace of the item revision on the top line in the Model view.

4. Click Search and type the name or the ID of the item revision you want to replace with.

5. (Optional) Type a description for the item revision you want to replace the existing one with.

6. Select one of the following options:

• All in root assembly to replace all model lines in the root assembly referencing the same item
revision.
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• All in parent assembly to replace all model lines in the immediate parent assembly referencing
the same item revision.

• Single Component to replace the selected line.

Replace multiple model revisions with other matching model revisions

You can replace multiple existing CAE 3D Model item revisions in the Model view with other matching
item revisions by searching for them in a single dialog box.

1. In the Model view, select multiple model lines you want to replace, click View Menu , and
choose Edit→Replace... to open the Multiple-Replace Item Revision dialog box.

Do not select the top line in the Model view.

If you select only one CAE 3D Analysis item revision, the system opens the Replace dialog box.

2. To find matching item revisions, click Search and enter the search criteria in the Search new Item
Revisions section. If there is more than one matching item revision, the system prompts you to
select one in the Matching Item Revisions column.

3. For the replace method, select one of the following options:

• All in root assembly to replace all model lines in the root assembly referencing the same item
revision.

• All in parent assembly to replace all model lines in the immediate parent assembly referencing
the same item revision.

• Single Component to replace the selected line.

Manage references for model revisions

Use the Manage CAE References dialog box to manage CAE references for a CAE 3D Model item
revision. The dialog box consists of the following options:

• CAE Reference Type displays a list of CAE reference types. You can select the required reference type
from the list.

• CAE References Item ID / References lets you type the required CAE references item ID and revision
in the CAE References Item ID / References boxes, respectively. You can also click Search to search
and select the required information.

• List of CAE Item Revision References lets you add and/or manage the reference type and the
reference item revision.

Replace multiple model revisions with other matching model revisions
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1. In the Model view, create or open a CAE 3D Model item revision.

2. In the Model view, click Open Secondary Views  in the view toolbar, and choose
Attachments.

Alternatively, click Show Data Panel  on the main toolbar.

3. In the Attachments view, select the CAE 3D Model item revision.

4. To open the Manage CAE References dialog box, click Edit References in the view toolbar.

5. From the CAE Reference Type list, select the required reference type.

6. Type the required CAE references item ID and revision in the CAE References Item ID / References
boxes, or click Search to search and select the required information.

7. In the List of CAE Item Revision References table, add and/or manage references to the CAE 3D
Model item revision.

Click  to add a row. If you click this without any information in the CAE References Item ID /
References boxes, Teamcenter displays the following message:

Item ID of CAE Reference is null. Enter a valid Item ID.

You can use  to move a selected row upward,  to move a selected row downward,  to
remove a selected row, or  to clear all the rows.

8. Click OK.

Associate a product as the source or as the target for a model revision

You can use these options to create a target and/or source relationship between the product item
revision in the Product view and the CAE 3D Model revision item in the Model view.

1. In the Product view, open a product item revision.

2. In the Model view, create or open a CAE 3D Model revision item.

3. Right-click the CAE 3D Model revision item, and choose Associate Product as Source and/or
Associate Product as Target.

If you have more than one Product view open, the system prompts you to select the source item
revision in the Associate as Source or Associate as Target dialog box respectively.
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Simulation Process and Data Management creates a target and/or source relationship between the
product item revision in the Product view and the CAE 3D Model revision item in the Model view.

4. In the Model view, click Open Secondary Views  in the view toolbar, and choose
Attachments.

Alternatively, click Show Data Panel  on the main toolbar.

5. In the Attachments view, select the CAE 3D Model item revision.

6. Select the desired item revision you want to paste from the Home view and paste it in the
Attachments view linked to the desired Model view.

Import the model data

Use the Import Model Data Deck dialog box to create and manage CAESolver dataset and import
solver deck files for a CAE 3D Model item revision. This dialog box consists of the following options:

• CAESolver Dataset Name lets you type a new name for the CAESolver dataset.

By default, Teamcenter displays the CAE 3D Model item and revision identifiers in this box.

• Description lets you type a description for the CAESolver dataset.

• Tool Used lets you select the required tool from the list.

• Named References lets you add a reference, file name, file path, and include path. It consists of the
following options:

• Reference lets you select the required reference from the list.

• File Name and File Path let you type the solver deck file name and path in the relevant boxes or
import the required solver deck files.

• Include Path lets you type the include path associated to each value in the corresponding File
Name and File Path boxes. It is a path by which the currently imported file is added to a top-level
solver deck file.

1. In the Model view of CAE Manager, create or open a CAE 3D Model item revision.

2. In the Model view, click Open Secondary Views  in the view toolbar, and choose
Attachments.

3. In the Attachments view, select the CAE 3D Model item revision.

Import the model data
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4. Click View Menu  in the view toolbar, and choose Import Model Data Deck.

5. (Optional) In the CAESolver Dataset Name box, type a new dataset name.

6. (Optional) In the Description box, type a description for the dataset.

7. Select the required tool from the Tools Used list.

8. In the Named References table, add a reference, file name, file path, and include path.

You can place the cursor in the File Name, File Path, or Include Path and click Import to import
the required data.

You can use  to add a new row,  to remove a selected row, or  to clear all the rows.

9. Click OK.

Mark model revisions as up-to-date

In a complex product development environment, different analysts perform different tasks of the overall
analysis. For example, abstractions are delivered by one group, models built by another group, load
cases defined by another group, and solver ready decks are built by another group. In such scenarios, it
becomes critical to know when analysis data, possibly with multiple dependencies, is out of date. The
analyst can then act on it and ensure that the analysis is built with the correct set of data to deliver
accurate results.

In CAE Manager, analysts can check for later revisions of item revisions attached to CAE 3D Analysis
item revisions. They can also check for changes to any attachments of CAE 3D Analysis item revisions.

Note:

Only secondary attachments attached to the CAE 3D Analysis item revision with the relations
defined by the simulation administrator in the CAE_significant_relation_types_for_CAEModel
preference are considered while evaluating the out of date and up to date status.

Check for attachment changes

1. In the Model view, open a CAE 3D Model item revision.

2. Click Open Secondary Views  in the view toolbar, and choose Attachments.

3. In the Attachments view, click Check for Attachment Changes  in the view toolbar.

Out of date attachments are considered as follows.
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• Newly added attachments

If there is a new attachment in the CAE 3D Model item revision, then the attachment is
highlighted in red color. The item revision also displays the Out of Date icon  and the New
Attachments icon .

This is the default color for the Action box in the Edit → Options → CAE → General → Out-of-
date Highlights tab in CAE Manager.

The RGB value specified in the CAE_action_highlight_color user preference determines the
default color used by the Action box.

• Existing modified attachments

If an existing attachment is modified in the CAE 3D Model item revision, then the attachment is
highlighted in red color. The item revision also displays the Out of Date icon .

This is the default color for the Action box in the Edit → Options → CAE → General → Out-of-
date Highlights tab in CAE Manager.

The RGB value specified in the CAE_action_highlight_color user preference determines the
default color used by the Action box.

• Removed attachments

Mark model revisions as up-to-date
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If an attachment is removed from the CAE 3D Model item revision, then select the CAE 3D
Model item revision, right-click, and choose Show Removed Attachments. All the removed
attachments are shown in the Removed Attachments dialog box. The item revision displays the
displays the Out of Date icon  icon and the Removed Attachment icon .

Up to date attachments are considered as follows.

If an attachment is up to date, then it is highlighted in green color. The item revision also displays
the Up To Date icon .
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This is the default color for the No Action box in the Edit → Options → CAE → General → Out-of-
date Highlights tab in CAE Manager.

The RGB value specified in the CAE_no_action_highlight_color user preference determines the
default color used by the No Action box.

4. To mark a model revision as up to date, in the Attachments view select the CAE 3D Analysis item
revision and click Mark Up-To-Date  in the view toolbar.

All the attachments under the CAE 3D Analysis item revision are marked as up to date.

Tip:

By default, the first time you create a model item revision, it is marked as up-to-date.

5. After marking all attachments as up to date, in the Attachments view, select the CAE 3D Analysis
item revision and click Check for Attachment Changes  in the view toolbar.

All the attachments are highlighted in green color.

This is the default color for the No Action box in the Edit → Options → CAE → General → Out-of-
date Highlights tab in CAE Manager.

The RGB value specified in the CAE_no_action_highlight_color user preference determines the
default color used by the No Action box.

6. To show last up to date attachments, in the Attachments view, select the CAE 3D Analysis item
revision and click Show Last Up-To-Date in the view toolbar.

The system displays the last up-to-date information.

7. To show removed attachments, in the Attachments view, select the CAE 3D Analysis item revision
and click Show Removed Attachments in the view toolbar.

The system displays a message box with a list of removed attachments.

8. (Optional) Select a BOM line, right-click, and choose Select all lines of same color.

Mark model revisions as up-to-date
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Check for later revisions

1. In the Model view, open a CAE 3D Model item revision.

2. Click Open Secondary Views  in the view toolbar, and choose Attachments.

3. In the Attachments view, click Check for Later Revisions  in the view toolbar.

Note:

While checking for later revisions, the system does not consider baselined revisions.

• Attachment with later revision available

If the CAE 3D Model item revision has an attachment for which a later revision is available, then
the attachment is highlighted in red color. The item revision also displays the Later Revision icon

.

This is the default color for the Action box in the Edit → Options → CAE → General → Out-of-
date Highlights tab in CAE Manager.

The RGB value specified in the CAE_action_highlight_color user preference determines the
default color used by the Action box.

• Attachment with no later revision available

If the CAE 3D Model item revision has an attachment for which no later revision is available,
then the attachment is highlighted in green color.
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This is the default color for the No Action box in the Edit → Options → CAE → General → Out-
of-date Highlights tab in CAE Manager.

The RGB value specified in the CAE_no_action_highlight_color user preference determines the
default color used by the No Action box.

4. (Optional) Select the CAE 3D Model item revision, right-click, and choose Select All with Later
Revisions.

5. (Optional) Click View Menu  in the view toolbar, and choose Add Latest References or Update
Latest References.

Find represented product from the Model view

In the Model view, you can quickly identify the objects in the Product view that correspond to a
selection in the Model view, using the Select corresponding in Product option.

When you select this option, the system checks whether the CAE 3D Analysis item revision has a CAE
Target Occurrence relationship. If the relationship exists and if a product line is available on the loaded
model structure, the system selects the product line.

If the system does not find the CAE Target Occurrence relationship, it finds the related product line for
the CAE 3D Analysis item revision of the selected model using the CAE Target relationship, and selects
the product line.

1. In the Model view, select an item revision or multiple item revisions.

2. Right-click and choose Select corresponding in Product.

Share your working design or save an interim version for future reference

During the development of a product's design, you may want to share your working design with other
users. You may also want to save an interim version of your design for future reference. To do this, you
can create a baseline of the work-in-progress (WIP) design. When you request a baseline, Teamcenter
creates a new revision for each unreleased revision in the structure and releases it with a predefined
status, for example, TC_Baseline.

Find represented product from the Model view
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1. Open the latest working revision of a product or model structure in the Product or Model view
respectively.

2. Click View Menu  in the view toolbar, and choose Baseline.

3. Select a baseline template, specify a baseline label, and optionally specify a job description.

4. (Optional) To create the baseline and open it automatically in a new Product or Modelview, select
Open On Create.

5. (Optional) To create a report, select Dry Run Creation.

6. (Optional) To create a precise baseline, select Precise Baseline.

Tip:

Your site may be configured to allow only precise baselines, depending on the setting of the
Baseline_precise_bvr preference.

Replace older revisions with approved revisions

By default, an occurrence automatically references a particular item revision, depending on the revision
rule currently in effect. Optionally, you can set the occurrence to unconditionally reference a precise
revision of the part. You can then detect any precise occurrences that reference an out-of-date revision
and manually upgrade each occurrence to an approved revision of the referenced part. This option is
available only with a precise structure.

When you create a new item revision and it is approved, the occurrences of older revisions are not
automatically updated with the new revision if the structure is precise. You must use the Show/Hide
Superseded Revisions command to identify superseded item revisions. While updating an occurrence
with an old revision to the new approved revision, you can update all the applicable occurrences in the
parent assembly or just the currently selected component.

1. Open a precise product or a model structure in the Product or Model view, respectively.

Alternatively, open a product or a model structure and apply a precise revision rule.

2. Click View Menu  in the view toolbar, and choose Edit→Show/Hide Superseded Revisions.

3. To replace selected product or model revisions with new approved versions, select the BOM lines
for which superseded revisions are available, right-click, and select Update Superseded.

You can select multiple BOM lines and update multiple revisions to the approved revisions in the
Update dialog box. To update multiple occurrences within the same parent, select the Adjacent
Occurrences option.
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Viewing product structures represented by model structures

View model revisions related to product revisions

Viewing target references

Use the Target References view to view a structure of the non-CAE item revisions represented by the
CAE model structures loaded in the Model view.

The CAE Target relation type defines the relationship between the item revisions in the structure lines of
the Target References view and the item revisions in the lines of the CAE model structures.

You must have the following before you work in the Target References view:

• A CAE 3D Model item revision loaded in the Model view.

• A non-CAE item revision loaded in the Product view.

• A CAE Target relation type between the root item revision of the non-CAE item and the root item
revisions of the loaded CAE model structure.

Note:

If you open multiple CAE 3D Analysis item revisions not related to product revisions with the CAE
Target relationship in multiple Model views, the system displays the following error message:

No model view loaded with related CAE Model item revision in CAE Manager

Activate the Target References view

1. In the Product view, choose Open Secondary Views→Target References to open the Target
References view.

2. If you open multiple CAE 3D Analysis item revisions related to the product revision with the CAE
Target relationship in multiple Model views, the system prompts you to select the appropriate
model structure.

3. In the Select Model view to be Associated dialog box, select the appropriate model structure.

4. (Optional) To change the associated model structure, in the Target References view, click Change
Associated Model View in the view toolbar.

5. (Optional) To open a different product structure in the Target References view, choose Associate
this Secondary view to a different Primary view and select another Product view.

View model revisions related to product revisions
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Check for later revisions of a represented item in the target references
structure

You can use the Check for Later Revisions option to check whether any later revisions are available for
the represented item in the target references structure.

1. In the Product view, click Open Secondary Views  in the view toolbar, and choose
Composite.

2. Select a structure line in the Composite view.

3. Click Check for Later Revisions in the view toolbar.

The Check for Later Revision option checks each line of the target references structure to
determine whether a later revision of the represented item is available or not. Teamcenter displays
the results in green (used for no action), red (action required), and yellow (for caution) colors.

4. Select a BOM line, right-click, and choose Select all lines of same color.

Compare target references with the product structure at the leaf level

In some analysis processes, you might want to flatten CAE structures to reduce complexity by
representing only the leaf nodes (holding geometry) from the product structure and skip all the
intermediate subassembly nodes. Subsequently, when you want to compare the CAE structure with
product structure for changes, you are interested in comparing only the leaf nodes.

You can use the Compare Target References with Product at leaf level option to compare the
differences between the product structure and the model structure at the leaf level. When you perform a
comparison, the system highlights leaf nodes in the corresponding structure.

Leaf nodes are ... All related leaf BOM lines ...

Not present in the target references
structure

In the Product view are highlighted in red (action required)
color.

Present in the target references
structure

In the Product view are highlighted in green (no action)
color.

Present in the target references
structure, but not in the product
structure

In the Target References view are highlighted in red (action
required) color.

Present in the target references
structure, which are of a different
revision

In the Target References view are highlighted in yellow
(caution) color.

4. Create and manage model structures

4-36  Simulation Process and Data Management on Rich Client ─ Usage, Teamcenter 2412
© 2025 Siemens



1. In the Product view, click Open Secondary Views  in the view toolbar, and choose Target
References.

2. In the Target References view, click View Menu  in the view toolbar, and choose Compare
Target References with Product at leaf level.

Teamcenter displays the results in green (used for no action), red (action required), and yellow (for
caution) colors.

3. Select a BOM line, right-click, and choose Select all lines of same color.

4. Select a BOM line, right-click, and choose Select related BOM line in Model.

Find related components in product and model structures

You can find out which BOM lines in the product and model structures are represented by selected lines
in the Target References view using the Select corresponding in option. The CAE Target relationship
determines the item revisions you can find in the Target References view.

1. In the Product view, click Open Secondary Views  in the view toolbar, and choose Target
References.

2. Select one item revision node or multiple item revision nodes

3. (Optional) Right-click and choose Select corresponding in→Product.

If the systems finds any matching BOM lines in the Product view, it selects the matching BOM lines.

If the system does not find any matching BOM lines in the Product view, it displays the following
warning message:No component is represented in the Product view.

4. (Optional) Right-click and choose Select corresponding in→Model.

If the systems finds any matching BOM lines in the Model view, it selects the matching BOM lines.

If the system does not find any matching BOM lines in the Model view, it displays the following
warning message:No component is represented in the Model view.

5. (Optional) Right-click and choose Select corresponding in→Product and Model.

If the systems finds any matching BOM lines in the Product or Model view, it selects the matching
BOM lines.

Find related components in product and model structures
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If the system does not find any matching BOM lines in the Product or Model view, it displays the
following warning message: No component is represented in the Product or Model
view.

Find represented model from the Product view

In the Product view, you can quickly identify the objects in the Model view that correspond to a
selection in the Product view using the Select corresponding in Model option.

When you select this option, the system checks whether the BOM line has a CAE Target Occurrence
relationship. If the relationship exists and if a CAE 3D Analysis item revision is available on the loaded
model structure, the system selects the CAE 3D Analysis item revision.

If the system does not find the CAE Target Occurrence relationship, it finds the related CAE 3D Analysis
item revision for the product revision of the selected product line using the CAE Target relationship, and
selects the CAE 3D Analysis item revision.

1. In the Product view, select a BOM line or multiple BOM lines.

2. Right-click and choose Select corresponding in Model.

Compare target references with associated product structures

You can use the Compare Target References with Product option to compare the target references
with the associated product structures.

Note:

• The associated product structure is the BOM view related to the target non-CAE item revision for
the root CAE 3D Model item revision.

• Target references are the view of non-CAE item revisions that are related to the CAE model
structure lines through the target relationship.

1. In the Product view, click Open Secondary Views  in the view toolbar, and choose Target
References.

2. Select a structure line, click View Menu  in the view toolbar, and choose Compare Target
References with Product.

The Compare with Product option compares the structure lines in the Target References view
with the active product structure. Teamcenter displays the results in green (used for no action), red
(action required), and yellow (for caution) colors.

3. (Optional) Select a BOM line, right-click, select Select related BOM line in, and choose Model,
Product, or Model and Product.
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4. (Optional) Select a BOM line, right-click, and choose Select all lines of same color.

View associated references

You can view non-CAE item revisions that are associated with the structure lines of the CAE model
structure through the CAE Target relation type, and the related CAE 3D Model item revisions under
each line of the Target References view.

1. In the Product view, click Open Secondary Views  in the view toolbar, and choose Target
References.

2. Select a structure line, click View Menu  in the view toolbar, and choose Show Target.

Show Target is a toggle. When it is checked, Simulation Process and Data Management displays
not only the structure of target references but also the CAE 3D Analysis item revisions for which
they are targets.

Derive model structures to validate different simulation scenarios

Why derive structures?

You (as a simulation analyst) can use predefined derivative rules and variant configuration rules to
quickly derive one or more structures relevant to your analysis from an existing structure.

During the virtual validation of a vehicle, you may create hundreds of different deck structures or
simulation variants to understand the effects of different materials or to optimize the weight of the
vehicle. This is done by varying the load cases, materials, thickness, meshes, and geometry and then
generating results to validate the vehicle against these different load cases. Many variants are created for
this purpose, with each variant representing a load case.

The simulation administrator defines derivative rules and variant configuration rules. You can use these
predefined rules to quickly derive one or more simulation variants from an existing one. You can then
make modifications to the structure by varying load cases, meshes, or materials to evaluate different
options and can view the complete traceability between the different variants.

Note:

Derivative rules and variant configuration rules are defined at the site level by the simulation
administrator, at the group level by the group administrator, and at the user level by the analyst.

You apply derivative rules after configuring the product structure. After you load a model structure
that has a reference to a configurator context and derive one or more structures, the derived structures
have the context set to the same configuration context as that of the source model structure. Further, all
the variant formula from the source model structure is mapped to the derived structures.

View associated references
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Derivative rules

A derivative rule contains filter, skip, and clone rules to indicate which components of the source CAE
structure are used to create a derived CAE structure. Each rule may contain a conditional clause limiting
the rule to a specific item or item revision types. The conditional clauses may contain expressions based
on items, item revisions, or form attribute values. You can define any number of conditional clauses for
each derivative rule. Each conditional clause is evaluated against each component in the source CAE
structure. If components:

• Satisfy the conditional clauses, the system filters, skips, or clones the components in the derived CAE
structure.

• Do not satisfy the conditional clauses, the system directly references the components, along with
their children (if any), in the derived CAE structure.

Variant configuration rules

A variant configuration rule contains variant options and values to indicate which components of the
source structure are used to create a derived structure.

Consider the source structure as an unconfigured product structure (150% BOM) with a V8 or V6 engine,
an automatic or a manual gearbox, and 2 door or 4 door options. The simulation administrator can
create a variant configuration rule to derive two specific structures using the same rule: one for the V8
engine, automatic gearbox, and 4 door combination and another for the V6 engine, manual gearbox,
and 2 door combination.

Each variant option in the configuration details contains a value limiting the rule to derive a structure
containing only those values. You can override these values or add additional values before deriving a
structure.
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Prerequisites for deriving structures

You can derive structures by using Product Configurator variants if the Product Configurator for
Simulation Process Management template is installed at your site. This allows you to configure the
structure by using families, features, and configurator rules.

If this template is not installed, you can configure the structure by using classic variants, that is, options
and values.

The PSM_enable_Product_Configurator user preference enables the use of Teamcenter Product
Configurator variants to configure the variability of a structure. By default, this preference is set to
true.

The following is the command availability if Simulation Process and Data Management and Product
Configurator applications are installed at your site:

PSM_enable_Pro
duct_Configurato
r user preference
is set to:

Product
Configurator
for Simulation
Process
Management
template
installed?

Is the
configurator
context selected? Type of structure

Derive Structures
command
availability

true No No Product
Configurator

Not available.

true No Yes Product
Configurator

Not available.

true Yes No Product
Configurator

Not available.

You must
set a default
configurator
context.

true Yes Yes Product
Configurator

Available
with Product
Configurator
dialog.

true Yes Yes Legacy Command is
available but
derive execution
fails with an error.

Caution:

Do not use a
default

Prerequisites for deriving structures
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PSM_enable_Pro
duct_Configurato
r user preference
is set to:

Product
Configurator
for Simulation
Process
Management
template
installed?

Is the
configurator
context selected? Type of structure

Derive Structures
command
availability

configurator
context with
legacy
structures.

false No No Legacy Available with
legacy dialog

false Yes No Legacy Available with
legacy dialog

Derive a structure using a predefined derivative rule

When you derive a CAE structure, you can specify the number of cloned CAE structures and components
you want to create and persist them in the Teamcenter database with all the specifications as configured
in the derivative rule defined by the simulation administrator. The root CAE structure item and the CAE
3D Analysis item revision are pasted in the user’s Newstuff folder (default option) in Teamcenter and
to the clipboard if the number of derived structures is only one. In addition, a CAE structure cloning log,
if enabled by the simulation administrator, is imported into a dataset and the dataset is attached to the
root item revision of the CAE structure.

If you derive a master structure that has pedigree information, the system clones the pedigree
information to each of the derived structures. Additionally, if you derive deck_001 from the master
deck and revise it, the system considers revision B of deck_001 as a deck structure of the same master.
However, if you derive revision B of deck_001, the system renames it as deck_002.

You can also derive structures using the cae_execute_derive_structures command line utility. This
utility applies the derivative rule to an input structure when you provide the root item revision and the
configuration information of the input structure and pastes the output structures in the Teamcenter
NewStuff folder. To view the command line help for this utility, type cae_execute_derive_structures -h
on the Teamcenter command prompt.

Note:

If you set the PSEVariantsMode preference to the legacy mode, the system does not capture the
default or the derived variant option values during the pedigree operation. The system captures
only the variant conditions set by you. By default, this preference is set to hybrid mode.

1. In CAE Manager, choose the Model view.
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2. Select the root item revision and click Derive Structures  in the view toolbar.

Alternatively, select the root item revision, click View Menu , and click Derive Structures.

3. In the Derive CAE Structure dialog box, select a derivative rule.

Derive a structure based on variant options

1. In the Variant Options area, select Apply selected Variant Configuration or Based on applied
variant options in the Model view option.

2. Using selected variant configuration.

a. Select Apply selected Variant Configuration and click Select.

b. In the Select Variant Configurations dialog box, select a variant configuration item.

This dialog box displays all the available variant options from the model structure you wish to
derive.

Derive a structure using a predefined derivative rule
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c. (Optional) To interchange rows and columns before loading any variant configuration items,
click Transpose .

This option is disabled if you select any variant configuration item.

d. (Optional) Create a new derivative configuration.

A. Click Create Derivative Variant Configuration .

B. Select the scope (site or user).

C. (Optional) Assign an ID and revision.

D. (Mandatory) Specify a name.

E. (Optional) Type a description.

e. (Optional) To modify the description of a variant option, select an option from the list and
type a new description.

f. (Optional) To change a variant option value, select an option from the list and choose a
different value.

g. (Optional) To add a new row, click Add and select variant options.

h. (Optional) To remove an existing row of variant options, select a row and click Remove.

i. (Optional) To autofit columns, select the Auto-fit All Columns command available from the
title row or column of the table.

j. To clone a deck, select a row or column, right-click, and select Clone Deck command.

The system clones the current deck, that is, the same variant information, and appends the
table with the new deck.

This command is available only if the Select Variant Configurations dialog box is populated
with deck information.

k. To derive a new structure, click OK.

3. Using applied variant options.

a. Select Based on applied variant options in the Model view.

b. Specify the number of structures to derive.
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c. To derive a new structure, click OK.

Derive a structure based on name control

1. In the Name Control area, select Based on configured name pattern or Fixed Name option.

2. Using configured name pattern.

a. Select Based on configured name pattern.

b. Specify a base name.

You can specify a basename based on the configured name pattern specified by a user with
DBA privileges or specify a fixed name.

A user with DBA privileges configures a pattern for generating the name of a derived deck
with a unique number within the context of a master structure at the site level. This pattern
is specified as a combination of fixed strings, a base name keyword and the number of digits
keyword.

For example, if you specify the BASENAME as SV01 and select the unique auto-generated
option, the system generates the next unique number, 0001, and computes the name based
on the specified base name, for example, SV01-Deck0001.

If the user generates 5 decks, the next 4 decks are named automatically as SV01-Deck0002,
SV01-Deck0003, SV01-Deck0004, and SV01-Deck0005.

If there are existing decks, the counter starts from the next available number. For example,
if you derive 5 more decks, the next 5 decks are named from SV01-Deck0006 to SV01-
Deck0011.

c. (Optional) To overwrite the name of the derived structure in the derivative rule, type a new
name in the Base Name box.

d. Type a Starting Number or select Unique Auto-generated Number

Tip:

The Starting Number box is disabled if you specify the number of structures to derive
as 1 in variant options.

e. To derive a new structure, click OK.

3. Using fixed name.

a. Select Fixed Name.

Derive a structure using a predefined derivative rule
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b. If you do not want to use the preconfigured name pattern, specify a name in the Fixed Name
box.

c. To derive a new structure, click OK.

Derive a structure using preconfigured material revision mapping

If Teamcenter materials management is installed and an administrator (a user with DBA privileges) has
mapped material revisions from the product revision (source) to the derived structure (output), you
(as a simulation analyst) can derive model structures containing material revision mapping by using
data mapping and structure map rules. The system creates a reference between the derived structure
(output) and the material revisions attached to the product structure (source).

1. In CAE Manager, choose the Model view.

2. Select the root item revision and click Derive Structures  in the view toolbar.

Alternatively, select the root item revision, click View Menu , and click Derive Structures.

3. In the Derive CAE Structure dialog box, select a derivative rule.

4. Derive a structure based on variant options or name control.

5. Open the output deck structure and verify if the system has referenced the material revisions from
the product revision (source) to the derived structure (output).

4. Create and manage model structures
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5. Compare product and model structures
Compare model and product structures and update the model
structure

Why compare the CAE model structure and the product structure?

Use the Inspector view in CAE Manager to update a CAE model that comprises a structure of CAE model
components to reflect changes to the related product structure. Using this view, you can:

• Add or remove CAE model components if components are added to or removed from the product
structure.

• Revise a CAE model component and replace the BOM line with a later revision if components of the
product structure are revised.

• You can choose whether to make the necessary changes in the current revision of the CAE model or
in a future revision.

• Compare a CAE model structure and a product structure, and also update the CAE model structure
if necessary.

Compare and update the model structure

1. Select a CAE 3D Model item in a My Teamcenter folder or a collaboration context. Right-click, and
choose Send To→CAE Manager. CAE Manager displays it in the Model view.

2. Select a product item in a My Teamcenter folder or a collaboration context. Right-click, and choose
Send To→CAE Manager. CAE Manager displays it in the Product view.

3. Click Inspector  in the main toolbar.

4. In the Inspector view, click Load Inspector.

If you have more than one product or model revision open in multiple Product or Model views
respectively, the system prompts you to select the appropriate product and model structure in the
Load Inspector - Select Model and Product Structures dialog box.

CAE Manager loads the product and model structures in the Product and Model views,
respectively.

5. Choose the BOM lines you want to compare in the Product and Model views.
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Alternatively, select the Select All check boxes in the Product and Model views to compare all
BOM lines of the product or the model structure.

You can compare either the product structure against the model structure or vice versa by choosing
the Product or Model options respectively and clicking Compare Structure.

The BOM structures for both the product and model are evaluated and the results of the
comparison are displayed in the Decision tree. Each BOM line in the decision tree is marked as
Passed or Failed depending on the evaluation criteria. Each Failed BOM line displays the default
action and the available actions for that particular criteria.

The differences are displayed using color coding. Color coding is done only for the BOM structure
that is in focus. Color code specifications for the Decision tree branch are as follows:

• Green—the branch passed all criteria.

• Yellow—the branch failed a criteria and the default action is to do nothing.

• Red—the branch failed a criteria and the default action has an impact on the CAE 3D Model
revision and/or its structure.

Note:

Color coding in yellow and red depends on the settings your administrator has selected in
the CAE Tools — Inspector configuration options. If Do Nothing is selected as the default
action for product structure and simulation structure options, the branch with failed criteria
is displayed in yellow. If some other action is selected, the branch with failed criteria is
displayed in red.

You can choose the Show Only Red or Show Only Yellow option as appropriate. By default, it is
set to Show All. You can select the desired actions for each of the failed lines and execute the
changes.

6. Select the Product option and click Compare Structure.

The Execute Comparison dialog box opens.

7. Select one of the following options to start the comparison:

• Product With No Model to determine whether the product BOM line is not linked to any CAE 3D
Model BOM line in the model structure.

• Missing Model Components to determine whether the number of BOM lines for a CAE 3D
Model item revision is less than the number of BOM lines for the linked product item revision.

8. Select the branch with the failed criteria and select one of the following options:

5. Compare product and model structures
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The following table describes actions and inputs required for failed criteria.

Actions Description Input required in the Item ID
column

Do
Nothing

No action possible. No action possible.

Use new
Model

The corresponding component is replaced
with a revision of a new CAE 3D
Model item. Simulation Process and Data
Management creates a CAE 3D Model item
revision and adds a relationship between
the product item revision in the BOM line
and the newly created item revision.

If the simulation administrator has created
data mapping rules for secondary objects,
the system creates the secondary objects
(CAE 3D Geometry, CAE 3D Analysis,
or CAEMesh item revision) and adds
the necessary relationships between the
product item revision in the BOM line and
the newly created item revision.

No input required.

Simulation Process and Data
Management displays the item ID/Rev
of the CAE 3D Model item to be
created.

Use Model
Related to
Product
Item

The corresponding component is replaced
with an existing CAE 3D Model item
revision. Simulation Process and Data
Management creates a relationship if the
selected CAE 3D Model item revision does
not have a relationship to the product item
revision in the BOM line.

Select the appropriate item revision
from the list. Simulation Process and
Data Management populates the list
with all CAE 3D Model item revisions
for which there is a CAE Target
relationship with any item revision of
the product item represented in the
BOM line.

Use Model
Related to
Product
Revision

The corresponding component is replaced
with an existing item revision.

CAE 3D Model

Select the appropriate item revision
from the list. Simulation Process and
Data Management populates the list
with all CAE 3D Model item revisions
for which there is a CAE Target
relationship with the product item
revision in the BOM line.

Use
Revised
Model

The corresponding component is replaced
with a new revision of an existing CAE
3D Model item. Simulation Process and
Data Management creates a new revision
of the selected CAE 3D Model item and
adds a relationship between the product
item revision in the BOM line and the newly
created CAE 3D Model item revision.

Select the appropriate item revision
from the list. Simulation Process
and Data Management populates the
list with the latest revision of all
CAE 3D Model items that have an
item revision for which there is a
CAE Target relationship with any

Compare and update the model structure
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Actions Description Input required in the Item ID
column

item revision of the product item
represented in the BOM line.

9. (Optional) From the Domain menu, select the domain to apply data mapping rules specific to the
selected domain.

The simulation administrator creates various structure map domains in BMIDE and configures
data mapping rules for various domains. For example, your company might have different CAE
disciplines for safety, durability, and so on, and your company might want data mapping to be
different for each discipline. Domains help provide the flexibility to include different data mapping
methods for each discipline while revising the CAE model structure.

Note:

Deselect the Apply Data Mapping check box to avoid applying data mapping rules.

10. Click Execute.

The CAE Manager updates the simulation structure and displays it in the CAE Manager — Model
view.

Compare model and product structures and update the attributes
of the model structure

How to compare and update the model structure

You can use the CAE Attribute Compare feature in CAE Manager to compare attribute values between
related instances of a model structure and a product structure and propagate these changes.

Note:

You can also run this feature as a command utility. This utility is called
cae_execute_cae_accountability_check.

Let us assume a scenario where you (as analyst) receive a product structure for analysis. You apply
structure map rules to the product structure and create the CAE structure. You also generate meshes
with connections, define load cases, generate the deck, and perform a solve.

Later, you are notified that there are some minor changes to the product structure. Instead of recreating
the complete CAE structure, you decide to compare the existing CAE structure with the changed product
structure, understand the changes, and make updates to the existing CAE structure. You use the

5. Compare product and model structures
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Inspector view in CAE Manager to find if any new components are added, removed, or revised, and
update the CAE structure.

Then, you can use the CAE Attribute Compare feature to compare differences in the mapped attributes
(for example, material ID or transformation), review the report and optionally save it, and finally
propagate the changes on the CAE structure.

In CAE Manager, you can generate a CAE structure from an existing product structure. The data map,
configured by the simulation administrator, determines the default mapping of product items to CAE
items. By default, the data map creates a CAE 3D Analysis item for each generic item in the product
structure.

The simulation administrator defines one or more custom item types to handle the product structure
data as part of your company’s business model. For each custom product item type in your company’s
business model, the simulation administrator creates a mapping rule that determines the corresponding
CAE item type in the CAE structure. These rules are defined in a data map file.

In the data map file, the simulation administrator creates domains to define different rules. For example,
your company might have different CAE disciplines for safety, durability, and so on. Domains provide the
flexibility to include different data mapping methods for each discipline while running a CAE attribute
compare.

When you run a CAE attribute compare, you can choose only preconfigured items, item revisions,
forms, or BOM line attributes. The simulation administrator controls the required items, item revisions,
forms, or BOM line attributes using a configuration file. If the structures are very large, they impact the
performance and memory usage of the system. Therefore, the simulation administrator preconfigures
needed attributes that are required for processing and you can choose only those attributes.

In order to accurately compare a CAE structure against the product structure for changes, the CAE
Target relationship is not sufficient. In some cases, you use a flattened and reorganized CAE 3D
Analysis model structure or reorganize the CAE 3D Analysis instances differently compared to the
corresponding product instances. To handle such scenarios, the CAE Target Occurrence relation type is
used to define the relationship between an absolute occurrence of a CAE 3D Model item revision and an
absolute occurrence of an item revision in a BOM window. An absolute occurrence is a specific instance
of a component or assembly in a structure. It may be independent of the top-level assembly and only
meaningful in the context of a lower level assembly. For example, you may have four occurrences of a
wheel in the design of a vehicle; you can label one of those occurrences as left rear wheel, which is an
absolute occurrence of the wheel.

You can create the CAE Target Occurrence relation type property either:

• Automatically while creating a data map or a structure map.

You can compare some or all mapped attributes in a model structure to current values in
the product structure if the simulation administrator sets the MAPPED attribute to true in the
NodeXMLConfig.xml file.

• Manually in CAE Manager using trace links.

How to compare and update the model structure
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Create the CAE Target Occurrence relationship manually

You can use a trace link to create the CAE Target Occurrence relation type manually.

A trace link establishes a path in which one object takes precedence over another. The trace link creates
a directional relationship between the two objects, a relationship conveyed by the terms defining and
complying. The predecessor, the defining object, is the trace link source. The successor, the complying
object, is the target.

1. Enable trace links.

a. In My Teamcenter or CAE Manager, click Edit→Options.

b. Choose Systems Engineering and check the Trace Link Mode check box.

The trace link icons are enabled on the toolbar.

2. Open the product structure in the Product view.

3. Create a new CAE 3D Analysis item revision in the Model view.

4. Populate the CAE 3D Analysis item revision manually.

You can use the Composite and Summary views to see existing model details and copy and paste
them to the CAE 3D Analysis item revision.

5. Set the top-level product in context. In the Product view, right-click and choose Set In Context.

6. Set the top-level or the relevant CAE 3D Analysis item revision in context. In the Model view,
choose the appropriate item revision, right-click and choose Set In Context.

7. To start the trace link, in the Model view, choose the appropriate item revision and click the Start
Trace Link Creation icon on the toolbar.

8. To end the trace link:

a. In the Product view, choose the corresponding product item revision and click the End Trace
Link Creation with Subtype icon on the toolbar.

b. Choose the CAE Target Occurrence relation type.

9. To see trace links, in the Product or Model view, enable Trace Link and Trace Links columns.

You can right-click a column, and choose Insert column(s) to enable relevant columns. When you
enable columns in one view, the system automatically enables these columns in the other view.

5. Compare product and model structures
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10. To see the product item revisions to which the model item revisions are pointing, select the CAE 3D
Analysis item revision, right-click, and choose Trace Link→Traceability Report→Complying.

Compare and update attributes

1. Open the product structure in the Product view and model structure in the Model view.

2. Select the root level item revisions for both the views, and choose Tools→CAE Attribute Compare.

Note:

CAE Manager uses a common interface for CAE attribute compare and CAE BOM compare.
Some of the options in the Equivalence, Reporting, and Partial Match tabs in the CAE
Attribute Compare and CAE BOM Compare dialog boxes vary depending on the type of
compare you perform.

If you open more than one product and model structures in the respective views, you can do one of
the following:

• Select the root product revision in the appropriate Product view, click Add Target in the Model
box, and then select the root model revision from one of the open Model views.

• Select the root model revision in the appropriate Model view, click Add Source in the Product
box, and then select the root product revision from one of the open Product views.

3. To automatically propagate changes from the product structure to the model structure, check the
Automatically Propagate the Model Structure check box in the Reporting tab.

You can check the propagate results stored as an HTML dataset for details. By default, the name
of the HTML dataset starts with Attribute Propagate Summary. This depends on the Attribute
Propagate Summary Dataset Name preference value specified by the simulation administrator at
your site.

a. In the Model view, right-click the top level item revision, and choose Open
with→Attachments.

b. In the Attachments view, double-click the HTML dataset to open the CAE attribute propagate
results in a browser.

The CAE attribute propagate results is also available under the top level CAE 3D Analysis item
revision if you have write privileges or is available from the Newstuff folder in My Teamcenter. You
can double-click the HTML dataset to open the results in a browser.

4. To specify a report name, check the Printable Report Name check box in the Reporting tab and
type a name. The default report name is CAE Attribute Compare Report.

Compare and update attributes
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After you run a CAE attribute compare, this report is captured automatically as a spreadsheet
(Microsoft Excel format) in the database.

The report is available under the top level CAE 3D Analysis item revision if you have write
privileges or is available from the Newstuff folder in My Teamcenter. You can double-click the
report name to open the report in Microsoft Excel.

5. Select display options. You can choose the Full match check box or Partial match check box, or
both. You can also choose color options for the CAE attribute compare results using Browse next to
these display options.

• Full match means that there are no differences in mapped attribute values. The default color is
green.

• Partial match means that one or more mapped attribute values are different. The default color is
yellow.

6. Select the data mapping domain for attribute comparison.

a. Click the Partial match tab.

b. From the Domain menu, select a domain.

The domains available from this menu depend on the domains configured by the simulation
administrator.

Note:

You cannot change the domain if the CAE structure is generated by executing a
structure map and is associated with the CAE Generated By relationship. In such cases,
the domain value in the CAE attribute compare is automatically set to the domain of the
corresponding structure map.

7. Select a list of mapped properties for attribute comparison.

The simulation administrator controls the required items, item revisions, forms, or BOM line
attributes using the NodeXMLConfig.xml configuration file. If the structures are very large, they
impact the performance and memory usage of the system. Therefore, the simulation administrator
preconfigures needed properties that are required for processing, and you can choose only those
properties.

Note:

You get the No Mapped Attributes Found error message if the simulation administrator
has not properly configured data mapping. The simulation administrator must define the

5. Compare product and model structures
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NodeXMLConfig.xml file such that the appropriate types are set as STATUS=”ACTIVE” and
the appropriate attributes are defined as MAPPED=”true”.

8. After you select properties, click OK to run the CAE attribute compare.

The system displays the results in both views in CAE Manager and also displays a CAE Attribute
Compare view with the partial match results.

In the Product and Model views in CAE Manager:

• BOM lines with green color (default color for full match) indicate that there are no differences to
attribute values.

• BOM lines with yellow color (default color for partial match) indicate that there are differences to
attributes values.

Compare structures using a BOM compare report

Compare structures

During the virtual validation of a vehicle, to understand the effects of different materials or to optimize
the weight of the vehicle, you may create hundreds of different deck structures (simulation variants).
This is done by varying the load cases, materials, thickness, or meshes and geometry, and then
generating results to validate the vehicle against these different load cases. Many variants are created for
this purpose with each variant representing a load case.

To understand the effects of different simulation variants, you can select and compare them to
understand differences in input data or load cases and examine their corresponding results to determine
whether the simulation variants can be used in the next stage of the analysis process.

You can use Simulation Process and Data Management to quickly create one or more simulation variants
from an existing simulation variant, make modifications to the structure, and view the differences
between simulation variants. Typically, these simulation variants are complex and it is not possible to
compare more than two simulation variants at a time and understand their differences.

You can use CAE Manager to view two different simulation variants side-by-side and compare them,
get a visual understanding of their differences as they are color coded, and you can further investigate
differences in attributes such as thickness, associated files or load cases, and file content.

Run a CAE BOM compare report

You can compare two product or model structures loaded in separate Product or Model views or two
subassemblies loaded in separate Product or Model views. The source structure is the product or model
structure you select in the Product or Model view and the target structure is the product or model
structure in the other respective view. If you open two product and model structures in separate Product

Compare structures
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or Model views, the CAE BOM Compare dialog box automatically selects the source structure and target
structure. If you open more than two product or model structures in separate Product or Model views,
you must specifically select the target structure in the CAE BOM Compare dialog box. You can also
switch between the source structure and the target structure in the CAE BOM Compare dialog box. The
comparison results are displayed in the Product or Model view of the source structure.

Note:

CAE Manager uses a common interface for CAE attribute compare and CAE BOM compare. Some
of the options in the Equivalence, Reporting, and Partial Match tabs in the CAE Attribute
Compare and CAE BOM Compare dialog boxes vary depending on the type of compare you
perform.

1. In CAE Manager, open two product or model structures in Product or Model views.

2. Select the root structure or a child item in the product or model structure.

3. Choose Tools→CAE BOM Compare.

If you open more than two product or model structures in separate Product or Model views, you
must specifically select the target structure in the CAE BOM Compare dialog box. You specify a
target structure by selecting an open Product or Model view, and then choose the Add Target icon
in the CAE BOM Compare dialog box.

4. Specify equivalence criteria for comparing structures.

a. Click the Equivalence tab.

b. Choose one of the following equivalence options:

• Common Item uses the underlying item to establish equivalence for comparison between
the two lines.

• Find Number uses the find number of the product structure (BOM line) to establish
equivalence for comparison between the two lines.

A find number is a unique number assigned to each line in the product structure. When
users add an item to the product structure, the line receives the next available find number
in the defined sequence. Users can rearrange the structure in find numbers by clicking the
Find Number column header.

c. Choose a compare mode.

5. Compare product and model structures
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Mode Description

All Levels Compares the source and target structure at all levels.

All Visible Levels Compares the source and target structure at
expanded levels.

First Level Only Compares the source and target structure only at first
levels.

Leaf Level Only Compares the source and target structure at the leaf
levels.

This mode is not applicable for the Find Number
equivalence option.

Lowest Visible Level Only Compares the expanded source and target structure
only at the leaf levels.

5. Specify reporting and display options.

a. Click the Reporting tab.

b. To specify a report name, check the Printable comparison report name check box and type a
name. The default report name is CAE BOM Compare Report.

After you run a CAE BOM compare, this report is captured automatically as a spreadsheet
(Microsoft Excel format) in the database.

The report is available under the top level CAE 3D Analysis item revision if you have write
privileges or is available from the Newstuff folder in My Teamcenter. You can double-click the
report name to open the report in Microsoft Excel.

c. To select display options, select one of the following options:

Option Description

Full match Means that the item ID and revision ID are the same.

If the object (occurrence) in the source structure has one and
only one equivalent at the same level in the target structure,
both objects are set to the same background color.

The default color is green.

Partial match Means that the item ID is the same, but the revision ID is
different.

For Find Number, if you select the Apply configured
attribute values for partial match check box and if the item
ID is different:

Run a CAE BOM compare report
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Option Description

• If all the CAE BOM comparison properties selected by the
simulation administrator match, then the lines are marked
as partial match.

• If any one of the CAE BOM comparison properties selected
by the simulation administrator do not match, the line is
displayed as missing in source structure or missing in target
structure in the CAE BOM comparison report.

The default color is yellow.

Missing in source
structure

If the equivalent objects of the target structure are not found
in the source structure, the target objects are set to this color.

The default color is light blue.

Missing in target
structure

If the equivalent objects of the source structure are not found
in the target structure, the source objects are set to this color.

The default color is red.

6. To clear structure comparison results, choose Tools→Clear Compare Display.

5. Compare product and model structures
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6. Capture the pedigree or the
configuration information of a product or
a model structure
Why capture pedigree information?

During the virtual validation of a vehicle, analyst groups perform different types of analyses on multiple
variants of the product at different levels of maturity, using varied load cases. They perform these
analyses multiple times, for example, based on different levels of maturity, different load cases, or
different input geometry variations.

In such cases, capturing the exact configuration of the product and model structure is critical to
understand what was analyzed at a later time. Pedigree information captures the exact configuration of
various structures, including the revision rule, effectivity, and variant rules, and persists that information
in the database. Therefore, as a simulation analyst, you have clear traceability of what was analyzed.
The following is an example of how you can use the Pedigree Information option to track the exact
configuration of a product structure. You may specify Revision Rule=Released for CAE, Effectivity=Aug
31, 2015, variant=vxi (model type), type=sedan, safety=airbags, transmission=automatic, and
fuelType=petrol. Similarly, you may specify the exact configuration of the model structure: Revision
Rule=Released for Analysis, Effectivity=Aug 31, 2015, loadcase=frontal crash, and speed=40kmph.

You can apply the captured pedigree information anytime, for example, during design reviews, and
visualize the structures based on the captured configuration instead of manually setting up the
structures through multiple steps.

As the product and model structures evolve, this pedigree information helps you determine whether to
create or modify existing simulation models, and create or modify load cases to perform analyses again
for the changed product or model structures.
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6. Capture the pedigree or the configuration information of a product or a model structure
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View and apply pedigree information

The simulation administrator enables or disables pedigree related commands using the
CAE_enable_pedigree_operations preference. By default, this preference is enabled.

When you open a model item revision in an existing Model view, the system opens the related product
item revision in a new Product view and a related analysis item revision in a new Analysis view. This
happens when a single unique product or an analysis revision is identified by a CAE Target or a CAE
Defining relationship respectively. You can use pedigree-related commands only after all the related
views are open. Right-click the top-level item revision to capture pedigree, apply pedigree, or view
pedigree details as appropriate.

• When you create a model structure based on a product structure using data map or structure map
rules, the system automatically captures the pedigree information of the product structure as the
model pedigree.

After you capture the model pedigree, whenever you open the model structure, the system
automatically opens the associated product structure, applies the pedigree information and configures
the product structure.

Tip:

You can overwrite captured pedigree information by manually capturing the pedigree
information again.

• When you create an analysis structure based on the model structure, you must manually capture the
analysis pedigree information.

After you capture the analysis pedigree, whenever you open the analysis structure, the system
automatically opens the associated model structure, applies the pedigree information and configures
the model structure.

• If you open more than one Model or Analysis view, the system prompts you to select the model or
analysis structure for which you want to apply pedigree.

• If a model or analysis item is created through a simulation tool launch, the system automatically
captures the pedigree information.

Apply pedigree information on a product structure

1. Open the product structure in the Product view.

2. Depending on the type of analysis you want to perform, configure the product structure.

3. (Optional) To apply the product configuration to the product structure, select the root item of the
product structure, right-click, and choose Apply Pedigree.

View and apply pedigree information
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4. (Optional) Apply the pedigree of a model structure to a product structure.

Let us assume that you are performing a simulation analysis for a 2-door car model. You open an
unconfigured product structure that may have both 2-door and 4-door options. You configure the
product structure for the 2-door option and generate a model structure based on it.

Later, when you open the 2-door model structure, the product structure associated with it is an
unconfigured structure. You can apply the pedigree information from the model structure to the
product structure to see how the product was originally configured before the model structure was
created.

a. Open the model structure and the associated product structure.

b. To apply the pedigree of the model structure, select the root item of the product structure,
right-click, and choose Apply Pedigree.

If open more than one model structure, the system prompts you to select the appropriate
model structure.

Apply or override pedigree information on the model structure

1. Open the related model structure or create the model structure automatically by running
predefined data map rules or structure map rules.

2. Depending on the type of analysis you want to perform, configure the product structure.

3. To view pedigree information, select the root item in the structure, right-click, and choose View
Pedigree Details.

4. (Optional) To apply pedigree information from the product structure, select the root item in the
structure, right-click, and choose Apply Pedigree.

5. To override the existing pedigree information, select the root item in the structure, right-click, and
choose Capture Pedigree.

If Product Configurator is enabled, the model structure captures the pedigree information.
It captures the variant rules, configured variant options, and other product structure-related
information. If the model structure already has the pedigree information, the pedigree information
is updated to the current configuration of the product.

6. (Optional) Apply the pedigree of an analysis structure to the model structure.

Let us assume that you are performing a simulation analysis for a car door. You open an
unconfigured product structure that may have both 2-door and 4-door options. You configure the
model structure separately for the 2-door and 4-door options. You then create separate analysis
structures for both the 2-door and 4-door options.

6. Capture the pedigree or the configuration information of a product or a model structure

6-4  Simulation Process and Data Management on Rich Client ─ Usage, Teamcenter 2412
© 2025 Siemens



Later, when you open the 2-door analysis structure, the model structure related to it is
unconfigured. You can apply the pedigree information from the analysis structure to the model
structure to see how the model structure was originally configured before the analysis structure
was created.

a. Open the analysis structure and the related model structure.

b. To apply the pedigree of the analysis structure, select the root item of the model structure,
right-click, and choose Apply Pedigree.

If you open more than one analysis structure, the system prompts you to select the
appropriate analysis structure.

View or override pedigree information for the analysis structure

1. Open the related analysis structure or create an analysis structure based on the configured model
structure.

2. To view pedigree information, right-click and choose View Pedigree Details.

3. To override the existing pedigree information, select the root item in the structure, right-click, and
choose Capture Pedigree.

If Product Configurator is enabled, the analysis structure captures the pedigree information.
It captures the variant rules, configured variant options, and other model and BOM related
information. If the analysis structure already has the pedigree information, the pedigree is updated
to the current configuration of the model structure.

View pedigree information for derived structures

The pedigree of the derived structure is automatically captured during the derive operation. Both the
summary and detailed derive logs capture the configuration context, configuration option values, and
the variant rule applied on the source model structure. The detailed log captures the derive rules applied
for each BOM line.

When you derive a secondary-level structure from an existing first-level structure, then the pedigree
object available on the second-level structure is a cloned version of the pedigree object available on the
first-level structure. Moreover, both the pedigree objects point to the master pedigree object, that is, the
source model pedigree object.

Note:

The pedigree operation looks for the Based On relationship from the current or open model
structure to the secondary structure. The system does not capture the pedigree information if both
the Based On and Target relationships exist on the derived structure.

View or override pedigree information for the analysis structure
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1. Open the related model structure or create the model structure automatically by running
predefined data map rules or structure map rules.

2. Depending on the type of analysis you want to perform, configure the product structure.

3. Select the root of the model structure and choose Derive Structures.

4. Select the root of the derived model structure, right-click and then choose Model Pedigree→View
Pedigree Details.

5. To apply pedigree information, open a second-level structure without opening the first-level
structure, select the root item in the structure, right-click, and choose Apply Pedigree.

You can use this option to configure the master structure based on the pedigree information
available on the second-level structure.

View pedigree information on the simulation dashboard

1. Open a product structure and configure the product structure.

2. Create a model structure automatically by running predefined data map rules or structure map
rules.

The model structure captures the pedigree information from the product structure.

3. Select the root item of the model structure and select Simulation Dashboard.

4. Execute the dashboard using a predefined dashboard configuration.

5. In the dashboard, double-click an option value to open the Pedigree Information dialog box.

6. Capture the pedigree or the configuration information of a product or a model structure
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7. Create and manage analysis revisions
Create the analysis model and solve the analysis

1. Open the simulation model

Open the simulation model you created earlier.

2. Create the analysis

The analysis model represents the specific analysis such as thermal, structural, or fluid you want
to perform. It includes load cases, solver parameters, and boundary conditions. You create analysis
revisions mostly in the context of model revisions.

3. Perform the solve using a preconfigured simulation tool

After creating the analysis revision, you can select the specific revision and launch a preconfigured
simulation to upload the load cases and solver parameters. You can also specify the solver location
(local, remote, or server) and perform the solve.

What are analysis revisions?

An analysis revision represents the specific simulation you want to perform. CAE 3D Analysis item
revisions are workspace objects for including load cases, solver parameters, and boundary conditions.
Analysis revisions are created in the context of model revisions.

Use the Analysis view to interactively define and populate CAE 3D Analysis item revisions that can
reference a defining CAE 3D Model item revision. You can view, create, and manage CAE 3D Analysis
item revisions and their corresponding data in this pane.

You can perform the following tasks in the Analysis view:
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• View, create, and manage CAE 3D Analysis item revisions.

• View and manage composite CAE analysis structures.

• Manage Model reference, Result reference, Include reference, and Target Product references for a
CAE 3D Analysis item revision.

• View CAE 3D Analysis item revisions and their correlated CAE item revisions.

• Assign and manage solver parameters that define CAE analysis.

• Manage solver execution results and relate the results to a CAE 3D Analysis item revision.

• Launch simulation tools.

• Create CAE packages.

• View and manage attachments.

• Perform Where Used or Where Referenced searches.

• Displays data about a selected object or image files attached to a selected object.

Tip:

You cannot attach objects to CAE item revisions or detach associated objects with relations from
CAE item revisions without appropriate access privileges.

Create analysis revisions in My Teamcenter or CAE Manager

An analysis revision represents the specific simulation you want to perform. Analysis revisions are
workspace objects for including load cases, solver parameters, and boundary conditions. They are
created in the context of model revisions.

You can create analysis revisions in My Teamcenter or CAE Manager.

1. Select a container for the analysis item, such as a folder or another item revision.

Alternatively, select a CAE 3D Analysis item revision in the Analysis view of CAE Manager.

You can configure the product structure to create analysis item revisions with a CAE Target
relationship type. Then, while creating CAE 3D Analysis items using the New CAE Item Wizard
dialog box, the system automatically captures the pedigree information of the associated analysis
item.

2. Choose File→New→CAE Item or press Ctrl+E.

7. Create and manage analysis revisions
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3. In New CAE Item Wizard, select the CAE 3D Analysis item revision from the Most Recently Used
or Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

4. (Mandatory) Specify information in the CAE Analysis Information area of the Object Create
Information pane.

Note:

The Name and Description boxes display default values determined by the property rules
implemented at your site. You may replace such values, but you cannot specify a null value
by clearing the box. If you clear the box, the initial value is reapplied to the property when
you save the new CAE 3D Model item.

a. Type an item ID or click Assign to automatically assign an item ID.

b. Type a revision ID or click Assign to automatically assign a revision ID.

c. (Mandatory) Specify a name for the item revision.

d. (Optional) Enter a description for the item revision.

e. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

5. Specify information in the Additional CAE Analysis Information area of the Object Create
Information pane.

a. Specify the project ID and other information as appropriate.

b. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

6. Specify information in the CAE Analysis Revision Information area of the Object Create
Information pane.

a. From the Disciplines area, click Expand to modify, select a discipline from the list, and click
Add .

Create analysis revisions in My Teamcenter or CAE Manager
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b. From the Analysis Types area, click Expand to modify, select an analysis type from the list,
and click Add .

c. Specify the analysis type, solver name, project ID, and other information as appropriate.

d. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information

7. Specify information in the Enter CAE Analysis and CAE Result Templates Information pane.

a. In the CAE 3D Analysis Template area, click search and select an analysis template.

b. In the CAE 3D Result Template area, click search and select result templates.

8. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To open the Enter CAE Attach Files Information pane, click Next.

b. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

c. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

d. (Optional) Click Finish to create a basic item revision.

9. (Optional) Specify information in the Define References pane.

You can specify references manually by typing the object ID, revision, object, and relation type or
using the Search dialog box.

7. Create and manage analysis revisions

7-4  Simulation Process and Data Management on Rich Client ─ Usage, Teamcenter 2412
© 2025 Siemens



a. To open the Define References pane, click Next.

b. Click Add and type an object ID, revision, object, and relation type or click Search to search for
references.

c. (Optional) Click Finish to create the item revision.

Alternatively, click Next to specify additional information

10. (Optional) Specify information in the Define Workflow Information pane.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

11. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

b. Click Finish to create the item revision.

Create analysis revisions in My Teamcenter or CAE Manager
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Create analysis templates in My Teamcenter

You can create analysis templates to specify different load cases. After creating a template, you can
associate it to an analysis revision.

1. In My Teamcenter, select a container for the CAE 3D Analysis template, such as a folder or another
item revision.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select the CAE 3D Analysis Template revision from the Most Recently
Used or Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

4. Specify information in the CAE 3D Analysis Template area of the Object Create Information
pane.

a. Type an item ID or click Assign to automatically assign an item ID.

b. Type a revision or click Assign to automatically assign a revision.

c. (Mandatory) Specify a name for the analysis template.

d. (Optional) Enter a description for the item revision.

e. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information.

5. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To open the Enter CAE Attach Files Information pane, click Next.

b. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

7. Create and manage analysis revisions
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Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

c. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

d. (Optional) Click Finish to create a basic item revision.

6. (Optional) Specify information in the Define Workflow Information pane.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

7. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

Create analysis templates in My Teamcenter
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b. Click Finish to create the item revision.

Create a CAE boundary condition in My Teamcenter

You can create a boundary condition to define the inputs for a simulation model. After creating the
boundary condition, you can associate the condition to an analysis revision.

1. In My Teamcenter, select a container for the result template, such as a folder or another item
revision.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select CAE 3D Boundary Condition from the Most Recently Used or
Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

4. Type an item ID or click Assign to automatically assign an item ID.

5. Type a revision or click Assign to automatically assign a revision.

6. (Mandatory) Specify a name for the boundary condition.

7. (Optional) Enter a description for the boundary condition.

8. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

9. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To open the Enter CAE Attach Files Information pane, click Next.

b. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

7. Create and manage analysis revisions
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Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

c. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

d. (Optional) Click Finish to create a basic item revision.

10. (Optional) Specify information in the Define Workflow Information pane.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

11. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

Create a CAE boundary condition in My Teamcenter
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b. Click Finish to create the item revision.

Associate boundary conditions with an analysis revision

You can associate multiple boundary condition revisions with an analysis revision. Subsequently,
when you revise the analysis revision or save it as a different revision, the boundary condition
revisions are not copied across. However, you can import or export the analysis revision
with boundary conditions attached to it by using the CAEConfiguredDataFilesExportDefault or
CAEConfiguredDataFilesExportJTOnly transfer mode.

1. Open an analysis revision in the Analysis view of CAE Manager.

2. In the view toolbar, click Open Secondary Views  → Attachments.

3. In the view toolbar, click Edit References and from the CAE Reference Type menu, select Extract
Reference.

4. Search for the boundary condition.

a. Click Search and select the boundary condition.

b. In the Selected CAE Boundary Condition Revision list, click Add to add the boundary
condition, and click OK.

Note:

You cannot add a boundary condition revision to an analysis revision with the CAE
Extract relation if the boundary condition revision is already attached to a CAE 3D
Result or a CAE 3D Analysis item revision with the same relation.

5. To add the boundary condition as a reference type, in the Manage CAE References dialog box,
click Add.

The dialog box displays the Extract Reference reference type and the associated object, that is, the
boundary condition.

6. To create the reference, click OK.

7. To associate another boundary condition to the analysis revision, repeat steps 2 to 6.

Associate a boundary condition to a result revision

1. From the Home folder in CAE Manager or from an analysis revision in the Analysis view, copy a
boundary condition.

7. Create and manage analysis revisions
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2. Select a result revision in the Home folder or in a related view and select Edit→Paste Special.

Note:

You can copy a boundary condition revision to a result revision even if the result revision is
released or owned by a different group.

3. In the Paste Special dialog box, select Extract Reference.

The system pastes the boundary condition with the Extract Reference relation.

Associate result revisions to analysis revisions

1. From the Home folder in CAE Manager, copy one or more result revisions.

2. Select an analysis revision in the Home folder or in the Analysis view and select Edit→Paste
Special.

3. In the Paste Special dialog box, select the CAE Results relationship.

The system pastes the result revisions with the CAE Results relationship.

View analysis revisions

1. Start CAE Manager.

2. In the Home view, select a CAE 3D Analysis item revision, right-click, and choose Send To→CAE
Manager.

3. (Optional) To edit common properties of multiple objects:

a. Select multiple CAE 3D Analysis item revisions and click Edit → Properties.

b. Check out the objects and edit the values as appropriate.

c. To save and check in your changes, click Save and Check-In.

4. (Optional) Attach files to the analysis revision.

a. Drag the file from the operating system (for example, Windows Explorer) to the appropriate
analysis revision.

b. To attach the file, click OK in the New Datasets for Multiple Files dialog box.

Associate result revisions to analysis revisions
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5. To open a file attachment, expand the analysis revision, and double-click the dataset to open the
corresponding file.

6. Click Show Data Panel  on the main toolbar to open the data view.

7. Click a tab in the data pane to activate a view.

For example, click the Attachments view in the data pane to activate the Attachments view.

Create a defining relationship between an analysis revision and a
model revision

You can use this option to create a CAE Defining relationship between the CAE 3D Analysis revision
item in the Analysis view and the CAE 3D Model revision item in the Model view.

1. In the Model view, create or open a CAE 3D Model revision item.

2. In the Analysis view, create or open a CAE 3D Analysis revision item.

3. Right-click the CAE 3D Analysis revision item, and choose Associate Model as Defining.

If you open more than one Model view, the system prompts you to select a CAE model revision in
the Associate Model as Defining dialog box.

Simulation Process and Data Management creates a CAE defining relationship between the CAE 3D
Analysis revision item and the CAE 3D Model revision item and displays the relationship below the
CAE 3D Analysis revision item in the Attachments view associated with the Analysis view.

Manage references for analysis revisions

Use the Manage CAE References dialog box to manage CAE references for a CAE 3D Analysis item
revision. The dialog box consists of the following options:

• CAE Reference Type displays a list of CAE reference types. You can select the required reference type
from the list.

• CAE References Item ID / References lets you type the required CAE references item ID or revision in
the CAE References Item ID / References boxes. You can also click Search to search and select the
required information.

• List of CAE Item Revision References lets you add and/or manage the reference type and the
reference item revision.

1. In the Analysis view of CAE Manager, create or open a CAE 3D Analysis item revision.

7. Create and manage analysis revisions
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If the Analysis view is not open by default, click Analysis View in the view toolbar.

2. From the CAE 3D Analysis Item Revisions tree, select a CAE 3D Analysis item revision.

3. In the Analysis view, click Open Secondary Views  in the view toolbar, and choose
Attachments.

Alternatively, click Show Data Panel  on the main toolbar.

4. In the Attachments view, select the CAE 3D Analysis item revision.

5. To open the Manage CAE References dialog box, click Edit References in the view toolbar.

6. Select the required reference type from the CAE Reference Type list.

7. Type the required CAE references item ID and revision in the CAE References Item ID / References
boxes, or click Search to search and select the required information.

Select the required reference type from the CAE Reference Type list and type or search for
the corresponding CAE references item and revision identifiers in the CAE References Item
ID / References boxes. For example, select the Model reference reference type from the CAE
Reference Type list and type or search for a valid CAE 3D Model item and revision identifiers in the
CAE References Item ID / References boxes. If you type an item ID and revision of a different item
type, Teamcenter displays the following message:

Invalid Item Revision. Enter Valid Item ID and Revision.

8. Add and/or manage references to the CAE 3D Analysis item revision in the List of CAE Item
Revision References table.

Click  to add a row. If you click this option without the required information in the CAE
References Item ID / References boxes, Teamcenter displays the following message:

Item ID of CAE Reference is null. Enter a valid Item ID.

You can use the  to move a selected row upward,  to move a selected row downwards,  to
remove a selected row, or  to clear all the rows.

9. Click OK.

Import a solver deck to an analysis revision

Use the Import Solver Deck dialog box to create and manage the CAESolver dataset and import solver
deck files for a CAE 3D Analysis item revision. Optionally, you can also create and manage the CAE

Import a solver deck to an analysis revision
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Result dataset and import result files for the CAE 3D Analysis item revision. The Import Solver Deck
dialog box is divided into two panes:

• The top pane lets you create and manage the CAESolver dataset and attach solver deck files as named
references.

• The bottom pane lets you create and manage the CAE Result dataset and attach result files as named
references.

1. In the Analysis view of CAE Manager, create or open a CAE 3D Analysis item revision and select
the CAE 3D Analysis item revision.

2. Click Open Secondary Views  in the view toolbar, and choose Attachments.

3. Select the CAE 3D Analysis item revision.

4. Click View Menu  in the view toolbar, and choose Import Solver Deck.

5. (Optional) In the CAESolver Dataset Name box, type the new name for the CAESolver dataset.

6. (Optional) Type a description for the CAESolver dataset.

7. Select the required tool from the Tools Used list.

Note:

If you have a CAESolution dataset with more than one solver input file, the system
recognizes that there are multiple matching inputs and displays the Primary Input File
Conflict dialog box with a list of valid named references. In such cases, you must select a
valid option.

8. Add a reference, file name, file path, and include path in the Named References table.

You can place the cursor in the File Name, File Path, or Include Path box and click Import to
import the required data.

You can use  to add a new row,  to remove a selected row, or  to clear all the rows.

9. (Optional) Create a CAE Result dataset and upload result files as named references for the selected
CAE 3D Analysis item revision.

10. Click OK.

Teamcenter does the following:

• Creates and attaches a CAESolver dataset to the selected CAE 3D Analysis item revision.

7. Create and manage analysis revisions
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• Creates an XML file based on the values in the File Name and Include Path boxes. This is applicable
only if you specify an include path.

• Imports solver deck files to the dataset and the generated XML file as the named reference.

• (Optional) Creates and attaches a CAE Result dataset to the selected CAE 3D Analysis item revision,
and imports result files.

Mark analysis revisions as up-to-date

In CAE Manager, analysts can check for later revisions of item revisions attached to CAE 3D Analysis
item revisions. They can also check for changes to any attachments of CAE 3D Analysis item revisions.

Note:

Only secondary attachments attached to the CAE 3D Analysis item revision with the relations
defined by the simulation administrator in the CAE_significant_relation_types_for_CAEAnalysis
preference are considered while evaluating the out of date and up to date status.

Check for attachment changes

1. In the Analysis view, open a CAE 3D Analysis item revision.

2. Click Open Secondary Views  in the view toolbar and choose Attachments.

3. In the Attachments view, click Check for Attachment Changes  in the view toolbar.

Out of date attachments are considered as follows.

• Newly added attachments

If there is a new attachment in the CAE 3D Analysis item revision, then the attachment is
highlighted in red color. The item revision also displays the Out of Date icon  and the New
Attachments icon .

Mark analysis revisions as up-to-date
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This is the default color for the Action box in the Edit → Options → CAE → General → Out-of-
date Highlights tab in CAE Manager.

The RGB value specified in the CAE_action_highlight_color user preference determines the
default color used by the Action box.

• Existing modified attachments

If an existing attachment is modified in the CAE 3D Analysis item revision, then the attachment
is highlighted in red color. The item revision also displays the Out of Date icon .

This is the default color for the Action box in the Edit → Options → CAE → General → Out-of-
date Highlights tab in CAE Manager.

The RGB value specified in the CAE_action_highlight_color user preference determines the
default color used by the Action box.

• Removed attachments

7. Create and manage analysis revisions
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If an attachment is removed from the CAE 3D Analysis item revision, then select the CAE 3D
Analysis item revision, right-click, and choose Show Removed Attachments. All the removed
attachments are shown in the dialog. The item revision displays the displays the Out of Date
icon  icon and the Removed Attachment icon .

Up to date attachments are considered as follows.

If the attachment is up to date, then it is highlighted in green color. The item revision also displays
the Up To Date icon .

This is the default color for the No Action box in the Edit → Options → CAE → General → Out-of-
date Highlights tab in CAE Manager.

The RGB value specified in the CAE_no_action_highlight_color user preference determines the
default color used by the No Action box.

Mark analysis revisions as up-to-date
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4. To mark the analysis revision as up to date, in the Attachments view select the CAE 3D Analysis
item revision and click Mark Up-To-Date  in the view toolbar.

All the attachments under the CAE 3D Analysis item revision are marked as up to date.

Tip:

By default, the first time you create a analysis item revision, it is marked as up-to-date.

5. After marking all attachments as up to date, in the Attachments view, select the CAE 3D Analysis
item revision and click Check for Attachment Changes  in the view toolbar.

All the attachments are highlighted in green color.

This is the default color for the No Action box in the Edit → Options → CAE → General → Out-of-
date Highlights tab in CAE Manager.

The RGB value specified in the CAE_no_action_highlight_color user preference determines the
default color used by the No Action box.

6. To show last up to date attachments, in the Attachments view, select the CAE 3D Analysis item
revision and click Show Last Up-To-Date in the view toolbar.

The system displays the last up-to-date information.

7. To show removed attachments, in the Attachments view, select the CAE 3D Analysis item revision
and click Show Removed Attachments in the view toolbar.

The system displays a message box with a list of removed attachments.

8. (Optional) Select a BOM line, right-click, and choose Select all lines of same color.

Check for later revisions

1. In the Analysis view, open a CAE 3D Analysis item revision.

7. Create and manage analysis revisions
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2. Click Open Secondary Views  in the view toolbar and choose Attachments.

3. In the Attachments view, click Check for Later Revisions  in the view toolbar.

Note:

While checking for later revisions, the system does not consider baselined revisions.

• Attachment with later revision available

If the CAE 3D Analysis item revision has an attachment for which a later revision is available,
then the attachment is highlighted in red color. The item revision also displays the Later
Revision icon .

This is the default color for the Action box in the Edit → Options → CAE → General → Out-of-
date Highlights tab in CAE Manager.

The RGB value specified in the CAE_action_highlight_color user preference determines the
default color used by the Action box.

• Attachment with no later revision available

If the CAE 3D Analysis item revision has an attachment for which no later revision is available,
then the attachment is highlighted in green color.

This is the default color for the No Action box in the Edit → Options → CAE → General → Out-
of-date Highlights tab in CAE Manager.

Mark analysis revisions as up-to-date
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The RGB value specified in the CAE_no_action_highlight_color user preference determines the
default color used by the No Action box.

4. (Optional) Select the CAE 3D Analysis item revision, right-click, and choose Select All with Later
Revisions.

5. (Optional) Click View Menu  in the view toolbar, and choose Add Latest References or Update
Latest References.

7. Create and manage analysis revisions
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8. Create analysis packages for a specific
type of analysis
Why configure analysis packages or CAE packages?

Analyst groups in companies typically perform multiple types of analyses based on a product definition
or a set of requirements and validate them, for example, strength analysis, durability analysis, fluid
analysis, or crash analysis. They also perform analyses multiple times, for example, based on different
load cases or different input geometry variations. The processes and tools used and the input and output
may vary across analyses.

To create an analysis package for a specific type of analysis, the analysts must know which items,
datasets, and relationships to create and then create multiple CAE item revisions one at a time and
establish relationships between different item revisions. The simulation administrator or a user with
DBA privileges creates site-level package definitions, the group administrator creates group-level package
definitions, and individual users create user-level package definitions based on a common template and
save them to the database to make this process easier and more efficient.

Analysts can then use the package definitions created by the simulation administrator or the group
administrator to create their own CAE item revisions. They can use these packages to define input parts
(item revisions), output items, the relationships between the output item revision to their input parts,
and the output datasets within one or more output item revisions.

At a site, there can be different categories of analysis packages:

• Site-level package definitions.

These are standardized and approved package definitions created by the simulation administrator or
a user with DBA privileges and used by multiple analysts across the enterprise to create a set of CAE
item revisions for a specific analysis.

• Group-level package definitions.

These are standardized and approved package definitions created by the group administrator and used
by multiple analysts across the enterprise to create a set of CAE item revisions for a specific analysis.
Access to these are limited to members of that group.

• User-level package definitions.

These are created by an analyst and used only by this analyst.

Check with your site administrator for information about predefined packages that you can use to create
CAE packages.
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Analysts can use the Create CAE Packages wizard to create CAE packages. They can choose a package
definition from the available list that is preconfigured by the simulation administrator or the group
administrator and proceed to create the CAE package. The wizard guides the analyst through the process
of creating CAE packages in multiple steps.

Configure CAE packages

After configuring CAE packages, you can create CAE package definitions and execute them.

1. In CAE Manager, click the CAE Configuration  toolbar menu, and choose CAE Package
Configuration .

2. Select the USER option and click the Create CAE Package  icon.

3. (Optional) In the Create CAE Package dialog box, to assign an ID, click Assign in the ID box.

4. (Optional) To assign a revision number, click Assign in the Revision box.

5. (Mandatory) To specify a derivative rule name, type a unique name in the Name box.

6. (Optional) Type a description in the Description box.

7. Configure input parameters.

8. Create analysis packages for a specific type of analysis
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a. Click the Input Configuration tab.

b. (Optional) Enter a description for the CAE package in the Description box.

c. Click the Add button to add parameters.

d. In the Descriptor column, choose the default value or overwrite it with a unique value, and
from the Type column, select an appropriate item revision.

e. Click the Apply button.

8. Configure output parameters.

Configure CAE packages
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You can configure a CAE package containing a standalone output item (with or without datasets)
and multiple output items (with or without datasets) where one or more items are connected or
not connected to other items.

a. Click the Output Configuration tab, and click the Add button to add parameters.

b. (Optional) Clear the check boxes in the Paste in Output Folder column if you do not want to
paste the output items and item revisions to the default output folder.

Note:

For all migrated packages from previous releases, the check boxes remain selected, that
is, the system pastes the output items and item revisions to the default output folder.

c. In the Descriptor column, choose the default value or overwrite it with a unique value, and
from the Type column, select an appropriate option.

d. Specify appropriate values in the Item ID Pattern, Naming Pattern, and Item Description
Pattern columns.

• The item ID pattern must have the N keyword to generate an output item ID with a unique
value and with the next available number for the N keyword.

• If the output item is not associated to any input item by any relation, then the configured
pattern keywords are replaced with an empty value.

• If the output item ID pattern is not configured but N is configured on the other properties,
then the N keyword is not replaced with any counter value and is kept unchanged.

You can use these keywords individually or as a combination. When you specify a
combination, you must not repeat the keywords. You can use the following keywords as a
combination by including text in quotes (see examples that follow).

• The INPUTNAME pattern keyword is replaced with input item's name.
• The INPUTID pattern keyword is replaced with input item's ID.

8. Create analysis packages for a specific type of analysis
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• The INPUTREV pattern keyword is replaced with the input item's revision value.
• The N pattern keyword represents the next available number for the output item ID. It is

calculated at runtime when it is configured with the item ID pattern for the output item. If
the N pattern keyword is configured across the other properties for the output item or for
the item revision, the value is not recalculated. The value is repeated from the first usage,
which is calculated from the output item ID.

Example 1:

Item ID pattern
configuration for
CAE package

After the package is
executed with the
input item ID as
000387

After the package
is executed the
second time with
the same input
item ID

After the package
is executed with a
different input item
ID as 000341

CAE Analysis
is configured as
INPUTID".sim"N

Item ID for
CAE Analysis is
000387.sim1

Item ID for
CAE Analysis is
000387.sim2

Item ID for
CAE Analysis is
000341.sim1

CAE Model is
configured as
INPUTID".fem"N

Item ID for CAE
Model item ID is
000387.fem1

Item ID for
CAE Model is
000387.fem2

Item ID for
CAE Model is
000341.fem1

CAE Result is
configured as
INPUTID".res"N

Item ID for
CAE Result is
000387.res1

Item ID for
CAE Result is
000387.res2

Item ID for
CAE Result is
000341.res1

CAE Geometry
is configured as
INPUTID".i"N

Item ID for
CAE Geometry is
000387.i1

Item ID for
CAE Geometry is
000387.i2

Item ID for
CAE Geometry is
000341.i1

Example 2:

CAE package configuration for CAE
Analysis

After the package is executed with input
ID as 000387 and input item name as
NX_Numbers for CAE Analysis

The item ID pattern is configured as
INPUTID".sim"N.

The item ID is 000387.sim1

The name pattern is configured as
INPUTNAME".sim"N.

The item name is NX_Numers.sim1

The item description pattern is configured
as "Test Package for .sim - "N.

The item description is Test Package
for .sim - 1

Example 3:

Configure CAE packages
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CAE package configuration for CAE
Analysis

After the package is executed with input
ID as 000387 and input item name as
NX_Numbers for CAE Analysis

The item ID is not configured, that is, the
item ID pattern is empty.

The item ID is automatically generated by
the system.

The item name pattern is configured as
INPUTNAME".sim"N.

The item name is NX_Numers.simN

The item description pattern is configured
as "Test Package for .sim - "N.

The item name description is Test Package
for .sim - N

Example 4:

Item ID pattern
configuration for
CAE Geometry

Existing numbers in
the database for
the pattern N

Missing numbers in
the database for
the pattern N

Allocated
numbering for the
pattern N after
the package is
executed

INPUTID".i"N 1, 2, 3, 4, 5, 7, 9 6, 8 6, 8, 10, 11, and so
on

e. In the Item Attributes column, click the icon to the right of the column to open the Define
Attribute dialog box. Click the Add button to add parameters. In the Attribute Name column,
select an attribute name (for example, Name) and enter the value in the Value column.

(Optional) You can use keywords described in step d, for example, specify Attribute Name as
Project ID and Value as N"Proj001"N.

f. In the Revision Attributes column, click the icon to the right of the column to open the
Define Attribute dialog box. Click the Add button to add parameters. In the Attribute Name
column, select an attribute name, for example, Revision and enter the value in the Value
column.

(Optional) You can use keywords described in step d, for example, specify Attribute Name as
Solver Name and Value as INPUTID"Name"N.

g. Click the Apply button.

9. Define dataset parameters.

8. Create analysis packages for a specific type of analysis
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a. Click the Dataset Configuration tab, and click the Add button to add parameters.

b. In the Descriptor column, choose a default value.

This list contains all output items defined in the Output Configuration pane.

c. To add a dataset, click the Dataset Name column. Select a dataset from the Home view and
click the Add Dataset option. Alternatively, click the Search icon in the column and search for
a dataset.

d. In the Type column, select a dataset type, for example, CAEMesh.

e. In the Copy/Reference column, select Copy or Reference to allow analysts to copy or
reference existing datasets as part of output objects, respectively.

f. In the Naming Pattern column, enter a naming pattern.

Tip:

You can create multiple dataset naming patterns.

The naming pattern supports one of these or any combination of these:

• Constant string enclosed in double quotes

• ITEMREVID keyword

The item revision ID applied here is the item revision ID of the object to which the dataset is
going to be attached.

g. From the Relationship column, select the relevant option.

Configure CAE packages
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h. Click the Apply button.

Example:

Descriptor Dataset
Name

Type Copy/
Reference

Naming
pattern

Relationship

model_output dataset_-
name1

CAEMesh Copy “CAE-”-
ITEMREVID

IMAN_based_on or
NX Simulations

sim_output dataset_-
name2

CAE-
AnalysisDS

Reference “CAE-”-
ITEMREVID

CAE Target

10. (Optional) Define relationship parameters.

You can specify Generic Relationship Management (GRM) rules to apply constraints on the
relationship between two business objects. A GRM rule applies constraints on the relationship
between two business objects. When you create a GRM rule, you select the primary and secondary
business objects for the relationship, the relationship they have to one another, and the constraints
to be applied.

a. Click the Relationship Configuration tab, and click the Add button to add parameters.

b. From the Primary Object, Relationship and Secondary Object columns, select appropriate
options.

All the descriptors you created are available for selection in the Primary Object and
Secondary Object columns.

The column provides a list of values and displays the available relationships for the primary
object.

Example:

Primary object Relationship Secondary object

model_output CAE Target my_part (ItemRevision type)

sim_output CAE Defining model_output

Note:

You can have relationships between output and input, output and output, or input and
output. However, you cannot have a relationship between input and input or the same
descriptor as primary object and secondary object.

c. Click the Apply button to apply your data.

8. Create analysis packages for a specific type of analysis
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11. (Optional) Configure BOM view revisions.

A BVR is a workspace object that stores the single-level assembly structure of an item revision.
When you add a component to an assembly, you create an occurrence of that item or item revision
in the assembly, which is stored on the BVR. This occurrence is displayed as a BOM line. A BVR is
a single-level structure that contains occurrences of its immediate children. A multilevel structure
is constructed from several single-line BVRs. Any modification to the product structure (including
changing any of the occurrence attributes or adding a substitute) changes the BVR of the parent
assembly.

a. Click the BVR Configuration tab.

b. In the Parent Descriptor Table area, click the Add button to add parent descriptors.

c. From the Parent Descriptor and Relation columns, select appropriate options.

The Parent Descriptor list contains all input and output descriptors you have defined in the
Input Configuration and Output Configuration panes.

d. In the Child Descriptor Table area, click the Add button to add child descriptors.

12. To create a duplicate of an existing package configuration, click Clone CAE Package and specify a
name for the duplicate.

13. Click OK to save and exit the CAE Package Configuration dialog box.

Create CAE package definitions and execute them

After configuring CAE packages, you can create CAE package definitions and execute them using the
CAE package creation wizard or from the summary page of the item revision.

Using the CAE package creation Wizard

1. In CAE Manager, click the Open the CAE Package creation wizard  icon on the main toolbar.
Alternatively, click File→New→CAE Package.

Create CAE package definitions and execute them
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2. Choose the package and click Next.

3. Define the input item revision.

8. Create analysis packages for a specific type of analysis
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Note:

If the user preselects the exact number and type of objects expected for the input, the inputs
are populated on opening the dialog box.

a. Select the desired input row.

b. Search for the specific input item revision by searching for the item ID and revision.

c. Select the required item revision, click Adds a new row to the table , and click OK.

d. Click Next.

4. Define the output item revision.

Create CAE package definitions and execute them
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a. (Optional) Clear the check boxes next to the descriptors to disable them. You can optionally
click Finish to create the CAE package.

Alternatively, you can override the name if a naming pattern is not defined as part of the
package definition. To override the name, perform the steps that follow.

b. In the Item/Rev Information tab, use one of the following options:

• Assign to automatically generate an item ID and a revision, or manually enter an item and a
revision ID.

• Assign All to automatically generate an item ID, a revision ID, and a name for each selected
output object definition.

Note:

Some of the attributes displayed here are configured in the create style sheet of the
business object type. You can leave these fields as they are or change them.

c. In the Additional Item Information or Additional Item Revision Info tabs, type the required
attributes and enter other information as appropriate.

8. Create analysis packages for a specific type of analysis
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Note:

Some of the attributes displayed here are configured in the create style sheet of the
business object type. You can leave these fields as they are or change them.

d. Click Next.

5. Define the output dataset.

a. (Optional) Enable or disable check boxes corresponding to the dataset types you want to
create.

By default, these check boxes are enabled.

The dataset types and relationship type are prepopulated if the simulation administrator has
configured CAE packages at your site.

b. Click Next.

6. Define the BVR relations.

Create CAE package definitions and execute them

Simulation Process and Data Management on Rich Client ─ Usage, Teamcenter 2412  8-13
© 2025 Siemens



a. (Optional) Enable or disable check boxes corresponding to the BVR relations you want to
create.

By default, these check boxes are enabled.

The BVR relations are prepopulated if the simulation administrator has configured CAE
packages at your site.

b. Click Next.

7. Specify folder options for output objects.

8. Create analysis packages for a specific type of analysis
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a. In the Folder Information tab, select the Newstuff folder. Alternatively, select Alternate
Folder and click Search to locate the relevant folder in My Teamcenter.

Select appropriate options for creating output objects directly in the location folder or in a
subfolder under the location folder.

The system creates the subfolder with the same name as the package you execute. This
subfolder is created under the location folder you choose.

b. (Optional) To enable the creation of logs, select the Persist CAE Package Log option.

The CAE_package_log_dataset_name preference defines the default name for the CAE
packages detail log dataset name. The default value is CAE Package Summary Log.

c. (Optional) To select a signoff team for the workflow, select appropriate values from the
Process Template List and Process Assignment List.

By default these lists are left blank, which is consistent with the behavior of the Item Creation
wizard.

d. (Optional) To view summary information about the input item revisions, output item
revisions, and datasets and relationships applicable to the package summary, click the
Package Summary link.

Create CAE package definitions and execute them
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e. Click Finish.

8. View the CAE package execution summary.

a. View the input, output, dataset, and relationship summary.

b. (Optional) Click Back to change any information in the appropriate tabs.

c. Click Finish to create the CAE package.

From the summary page of the item revision

1. From the Summary page of the item revision.

a. In CAE Manager, choose the Home icon to open the Home folder.

b. Select an item revision with the CAE package execution link.

8. Create analysis packages for a specific type of analysis
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Consult your simulation administrator to find out which item revisions have CAE package
executions links. A user with DBA privileges at your site configures style sheets containing CAE
package execution links for frequently used item revisions.

c. In the Summary tab of the item revision, click the link to launch the Create CAE Packages
wizard.

The system automatically selects the package and displays the next panel.

2. Repeat step 3 to step 8.

Create CAE package definitions and execute them
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8. Create analysis packages for a specific type of analysis
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9. Specify key performance indicator (KPI)
values
Why specify KPI values?

You can specify key performance indicator (KPI) values such as maximum stress, minimum temperature,
or maximum displacement manually in an analysis revision or an analysis template. If you specify the
values in an analysis template, you can associate the template to an analysis revision.

You can also update KPI values automatically using a preconfigured simulation tool.

After specifying the KPI values, you can monitor these values on the simulation dashboard by
configuring the attributes to monitor.

• Specify KPI values manually

• Specify KPI values automatically using a preconfigured simulation tool

Specify KPI values manually

1. In My Teamcenter, select and check out an analysis revision or an analysis template.

2. Right-click the analysis revision or the analysis template and select Open with→Summary and click
the KPI tab.

3. To add a KPI value, click Add New and specify a name (mandatory).
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4. Specify other values as appropriate and click Finish.

5. To store the KPI values, check in the analysis revision or the analysis template.

Specify KPI values automatically using a preconfigured simulation
tool

The following procedure assumes that the simulation administrator has set up the sample configurations
by running the tcsim_quick_setup.pl script and that the default Extract KPI from Result tool is
available.

After you launch the preconfigured simulation tool, the system exports the results files, an attribute
XML file containing the KPI table attributes, the launch script, and the NX Open utility to the staging
directory. The system creates the KPITemplateFile subdirectory to which it exports the template XML
file. It then calls the launch script, which internally calls the NX Open utility with the path to the results
file, the path to the template XML file and the path to the output directory path as arguments. The
NX Open utility extracts the required KPI values from the results file based on the template XML file
and generates the output KPI text file. The system updates the KPI table in the attribute XML file and
populates the KPI table of the analysis revision.

9. Specify key performance indicator (KPI) values
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The preconfigured simulation tool is supported on launch methods such as local, remote, server, and
workflow process.

1. Open CAE Manager and from the Home view or from the Analysis view, select an analysis revision
containing results files.

2. From the main toolbar, choose Simulation Tools → Utilities → Extract KPI from Result.

3. (Optional) Click Browse to change the Default Scratch Location path.

4. (Optional) Choose a template by searching for the item revision that contains the template.

By default, the system displays the KPI/A;1-Thermal-Template item revision. This contains a
sample thermal template XML file dataset. This template file provides the names of the KPI values
that are associated with the results files.

5. (Optional) Choose one of the following options in Create Items and Create Datasets:

• As Needed to create items or file associations as needed when you execute the launch tool.

• Always to always create items or file associations when you execute the launch tool.

• Never to never create items or file associations when you execute the launch tool.

You can optionally override any of the options specified by the administrator while configuring
simulation tools.

6. To specify file upload options, select one of the following options:

• Prompt User to open the File Upload Conflicts dialog if the same output file exists in the
database. In such cases, you can select the Upload, Rename and Upload, or Skip option.

• Upload for the system to upload output files and create new versions of existing files with the
same name.

This is the default option.

• Rename and Upload for the system to automatically rename the output files with a suffix, if
similar filenames exist, and upload them to the database.

• Skip to avoid uploading the output files, if similar files exist in the database.

7. (Optional) Select the Display Progress Monitor on Launch option to monitor the progress of the
tool launch.

Specify KPI values automatically using a preconfigured simulation tool
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8. (Optional) Browse to the KPITemplateFile directory created by the system in the Default Scratch
Location path. The system exports the template XML file to this directory.

9. (Optional) Browse to the Default Scratch Location path and open the output KPI text file. The
name of the output text file is based on the name of the result file attached to the analysis
revision. For example, if the name of the result file is result.op2, the output text file is named as
result.op2.txt.

This directory also contains the Extract_KPI_from_Results.pl launch script and the
TC4SIM_KPI_EXTRACTOR.zip compressed file that contains the NX Open utility. The compressed
file contains a Help folder that includes tutorials, examples and a PDF document explaining the
functionality of NX Open utility and instructions on how to add new or edit existing KPI quantities.
These are the default files that are available with the preconfigured KPI extraction tool.

10. Right-click the analysis revision and choose Open with → Summary. Click the KPI table and verify
if the values have been automatically populated.

9. Specify key performance indicator (KPI) values
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10. Run simulations on local desktops
by downloading or uploading data
periodically
Run simulations locally

At some sites, not all simulation tools are integrated with Teamcenter. In such cases, you (as a simulation
analyst) can run the simulation tools on your local desktop and periodically upload or download the data
to or from Teamcenter.

You can use the File Explorer view in CAE Manager to upload or download analysis files to or from
Teamcenter based on the predefined file upload rules configured by the simulation administrator.

You can use the File Explorer view to:

• View and manage files in Teamcenter belonging to one or more item revisions (as analysis data
typically involves a large number of files).

• Upload or download multiple files from the desktop to or from multiple item revisions in Teamcenter,
using configuration rules that are consistent with the simulation tool launch process.

Download files from Teamcenter to the desktop using
preconfigured rules

1. In the Product, Model, or Analysis view in CAE Manager, click Open Secondary Views  in the
view toolbar, and select File Explorer.

2. (Optional) In the File Explorer view, you can:

• Click Filter in the view toolbar to open the Auto-filter dialog box and specify filter conditions.

• Click Check-Out History in the view toolbar to view the check out history of an item revision.

• Click Delete Files in the view toolbar to delete item revisions.

You can delete files only if you have write privileges to them.

• Click Associate this 'Secondary' view to a different 'Primary' view in the view toolbar to
associate the File Explorer view to another view, for example, the Home or Analysis view.

• Click View Menu and select Columns Management to manage columns in the File Explorer
view.
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3. Click Download File  in the view toolbar to open the File Download dialog box.

4. (Optional) In the Working Directory area, click Browse  to open a window displaying the folder
location of your files.

By default, this directory is populated based on the
CAE_file_configuration_windows_default_working_dir (Windows example) preference or based
on the last selected folder.

5. From Conflict Options, select one of the following options for each file you want to download:

• Rename and Download to rename the file, if the file is already available on your desktop. You
can specify a new name in the New OS File Name box corresponding to the file you want to
download.

• Skip to skip downloading this file.

• Overwrite to overwrite if the file is already available on your desktop.

6. To download files, click Execute.

7. (Optional) To check out the files you have downloaded, select Check-Out and enter a comment in
the Check Out Comments box.

You can view the comments later in the check out history.
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10-2  Simulation Process and Data Management on Rich Client ─ Usage, Teamcenter 2412
© 2025 Siemens



Upload files from the desktop to Teamcenter using preconfigured
rules

1. In the Product, Model, or Analysis view in CAE Manager, click Open Secondary Views  in the
view toolbar, and select File Explorer.

2. (Optional) In the File Explorer view, you can:

• Click Filter in the view toolbar to open the Auto-filter dialog box and specify filter conditions.

• Click Check-Out History in the view toolbar to view the checkout history of an item revision.

• Click Delete Files in the view toolbar to delete item revisions.

You can delete files only if you have write privileges to them.

• Click Associate this 'Secondary' view to a different 'Primary' view in the view toolbar to
associate the File Explorer view to another view, for example, the Home or the Analysis view.

• Click View Menu and select Columns Management to manage columns in the File Explorer
view.

3. Click Upload File  in the view toolbar to open the File Upload dialog box.

4. From the File Upload Rule Set list, select the appropriate rule.

5. In the Dataset Creation Options area, select one of the following options:

• As Needed to create datasets as needed while uploading files.

This is the default option.

• Always to create datasets each time while uploading files.

• Never to specify that datasets should not be created, but use existing ones that match the
configuration while uploading files.

6. (Optional) In the Working Directory area, click Browse  to open a window displaying the folder
location of your files.

By default, this directory is populated based on the
CAE_file_configuration_windows_default_working_dir (Windows example) preference or based
on the last selected folder.

Upload files from the desktop to Teamcenter using preconfigured rules
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All the files in the selected directory are automatically evaluated as per the selected File Upload
Rule (FUR).

The system color codes the files to give the user visual feedback:

• Files with a gray background are not eligible to be uploaded as per the selected FUR.

• Files with no background or white color are eligible to be uploaded without any ambiguity.

• Files with a green background are staged to be uploaded.

• Files with a red background are eligible to be uploaded to more than one selected BOM line.

For example, if you have a rule set to upload .txt files, only .txt files are selected. The system
ignores all other file types.

7. Click Auto-process  to automatically process all the listed operating system files by verifying
them with the predefined file upload rules.

If there is no ambiguity, the system adds the files to the respective item revisions. In the case of
ambiguity, the system displays an alert message to map the listed files manually.

10. Run simulations on local desktops by downloading or uploading data periodically
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When you select individual files with ambiguities and click on the Add button, the system displays
the following dialog box to select the destination item revision:

For the files you want to upload, you can view the details of the context item revision and the
target dataset.

If there are conflicts, you can select:

• Upload to upload the file and overwrite the file with the same file name.

• Rename and Upload to rename the file and upload it to the defined dataset.

• Skip to skip the upload of the file to Teamcenter.

8. (Optional) Check the Auto Check-in check box to automatically check in the dataset after
uploading the file.

9. (Optional) Check the Apply File Filter Rules for CAE Folders check box to apply filter rules while
uploading CAE folders.

This is applicable for CAE folders only.

10. To upload the files, click Execute.

Upload files from the desktop to Teamcenter using preconfigured rules
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Import a folder structure into Teamcenter using predefined rules

You can use predefined file upload rules to import a folder structure into Teamcenter. In the Home view
of CAE Manager, you can create a CAE Folder under a CAE item revision and use a predefined file upload
rule to populate this folder.

The system creates a CAE Folder in an item revision or another CAE Folder using the Has CAE Folders
relationship.

Create and manage folders

1. In CAE Manager, select an item revision in the Home view.

Note:

You cannot create a CAE Folder only in an item revision and not in regular folders such as
Newstuff.

2. To create a folder, click File→New→CAE Folder.

3. To create a subfolder in the parent folder, click File→New→CAE Folder.

You can create as many CAE Folder objects as you want at different levels of hierarchy and rename
them.

CAE folder names must be unique at the same level. However, CAE folders with the same name can
exist at different hierarchical levels.

10. Run simulations on local desktops by downloading or uploading data periodically
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Example 1:

A CAE folder with the same UID and the same object ID cannot exist at multiple levels of a CAE
folder structure. However, a CAE folder with the same name, but a different UID and object ID can
exist at multiple levels of a CAE folder structure.

Example 2:

Import a folder structure into Teamcenter using predefined rules
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4. To delete a CAE Folder, right-click the folder and choose the Delete Folder command or select the
folder and click Delete the selected object permanently  on the main toolbar.

When you delete a folder, the system removes the current folder, subfolders, and other files in the
folder. However, if the folder is referenced by other item revisions or other CAE folders, the system
displays a warning and does not delete the folder.

5. To save the CAE Folder as a new folder, click File→Save As and specify a name for the folder and
other options as appropriate.

6. To move a CAE Folder to another folder, right-click the folder you want to move, choose Cut, and
paste in another folder using the Paste command.

Similarly, you can use the Copy command to copy a folder to another item revision or folder. The
system copies and pastes (as a reference) the selected folder under the destination item revision or
CAE folder only if there is no conflict.

7. To check out or check in a folder, select the folder, right-click and choose Check-In/Out.

You can select multiple folders to check out or check in their contents.

8. To attach a CAE Folder to a workflow handler, use the CAE-attach-related-cae-folder-objects
action handler.

This action handler identifies any CAE Folder objects attached to the context target objects and
then identifies all the folders below it. It then attaches them as a target or a reference based on the
-attachment argument.

The -attachment argument is optional, and the default value is set to target if no argument is
specified on this handler.

10. Run simulations on local desktops by downloading or uploading data periodically
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Upload files to the CAE Folder

1. To set the default working directory, in My Teamcenter or CAE Manager, click
Edit→Options→CAE→File Explorer and specify a default working directory for the Windows or
Linux platform as appropriate.

2. In CAE Manager, click Open Secondary Views→File Explorer in the view toolbar.

3. In the File Explorer view, click Upload Files.

4. Select a predefined file upload rule set in the File Upload dialog box.

5. Select files and folders from the operating system directory.

If files or folders are not mapped to file upload rules, they are not available for selection. Moreover,
if there are no conflicts for the files or folder names, the system automatically marks them in green
color for import. If there are conflicts, the system displays the available resolution options. A new
file name is auto assigned by the system with a unique suffix and you can modify it, if needed. You
can then choose the Rename and Upload conflict option to upload the file with a new name, the
Skip option to skip the upload, or the Upload option to upload the file to the database as a new
version.

When the file upload is performed from a parent folder that has more than one single target object,
the File Upload dialog highlights the operating system files and folders in orange color. This color
indicates that the target objects to which the files or folders you want to upload are ambiguous.
In such cases, the system displays the Select Unique Item dialog box for you to select the unique
target object for uploading the files or folders.

6. (Applicable to CAE Folder only) Include or exclude files based on a user specified list.

a. Click File Extension.

Import a folder structure into Teamcenter using predefined rules
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b. In the File Extension dialog box, select Include and create an inclusion list, that is, the file
extension such as op2, f04, pdf.

c. Select Exclude and create an exclusion list of file extensions.

The file extension options and file extensions list are
determined by the CAE_folder_upload_include_or_exclude_option and
CAE_folder_upload_inclusion_or_exclusion_list user preferences.

7. To import files and folders, click Execute.

Upload files asynchronously using Data Share Manager

The Data Share Manager allows users to asynchronously upload and download files. It is a separate
executable with its own user interface and allows users to view large file uploads and downloads and to
manage them by pausing, resuming, or canceling the processes.

Contact your Teamcenter administrator for installing Data Share Manager on your client machine. The
administrator must also set the Use_DataShare_Manager site preference to true on the server. Doing
so activates Data Share Manager for file uploading and downloading.

The procedure for uploading folders or files using Data Share Manager is the same as Upload files to the
CAE Folder.

Attach the CAE Folder to a workflow handler

You can attach a CAE Folder to a workflow handler, using the CAE-attach-related-cae-folder-objects
action handler.

This action handler identifies any CAE Folder objects attached to the context target objects and then
identifies all the folders below it. It then attaches them as a target or a reference based on the
-attachment argument.
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The -attachment argument is optional and the default value is set to target if no argument is specified
on this handler.

Import a folder structure into Teamcenter using predefined rules
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11. Launch preprocessors, solvers,
postprocessors, and other simulation tools
Launching simulation tools

Simulation helps you design better products without having to build costly physical prototypes. You can
launch simulation tools from Simulation Process and Data Management to send a product structure to a
preconfigured application for analysis. Analysis tools provide accurate results on design behavior. After
the analysis is complete, the results are imported back to Teamcenter. You can view the results and make
changes to the product structure as appropriate.

Simulation Process and Data Management provides a framework for configuring and launching
simulation tools that can include preprocessors, solvers, postprocessors, and other tools. You can launch
simulation tools as a local launch, local detached launch, remote launch, or server launch, depending on
how the administrator configures the launch parameters at your site.

Note:

The local detached launch option has been deprecated and will be removed in a future version of
Teamcenter.

Remote launch is used for compute-intensive operations, such as meshing, solve execution, and
postprocessing. Such operations do not require interactive user input and can be executed as a batch
process on remote machines with load balancing capability and the ability to monitor and administer
request queues.

The simulation launch process is as follows:

• Select an item revision from the Product, Model, or Analysis view in CAE Manager and launch the
simulation tool. The process can be a local launch, local detached launch, remote launch, or server
launch depending on how the administrator configures it.

Note:

If you open a product or model structure that has Product Configurator variant data, then you
cannot open the Simulation Tool Configuration view. You must restart CAE Manager or attach
the configuration context to the root of the simulation tool configuration to open this view.

• Enter runtime parameter values, if applicable.

• Teamcenter exports primary input files and additional input files to the temporary folder for local
launch and the configured staging directory for the local detached, remote, and server launches.
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If the launch script is managed in a dataset attached to an item revision, Teamcenter exports all the
files of that dataset to the temporary folder at the time of launch.

• Simulation Process and Data Management displays a launch progress monitor dialog box if the
simulation administrator has configured the Display Progress Monitor on Launch option. You can
view the status of the tool launch from the Simulation Tool Progress Monitor dialog box.

This dialog box provides an option to open the associated temporary directory to gauge the progress
of the tool execution, or to examine the intermediate results. There is also an option to terminate the
process associated with the launch.

• When you import a file through the simulation tool launch, Teamcenter automatically checks out and
checks in the dataset in the file and adds the name of the tool in the checkout comment.

If you create a new dataset through simulation tool launch, Teamcenter sets the description of the
dataset to the name of the tool.

• For a remote launch, Teamcenter writes a launch tool file containing information about the tool
configuration details, environment values, and runtime input parameter values and sends this file as
input to create a translation request object.

• Teamcenter calls the startup script on the local, remote, or server machine.

• It uploads the result files as named references after the batch process is completed successfully.

• Teamcenter creates a summary report.

• It removes the temporary data for the local launch, if configured. For local detached, remote, or
server launches, temporary files are removed from the staging directory, if the Dispatcher Server is
configured to remove them.

• If the simulation administrator configures simulation tools for feedback options and selects the option
to notify the invoking user of the simulation tool, Teamcenter sends an email notification, including
the summary report.

• If you (as a simulation analyst) configure the product structure and the simulation administrator
enables the CAE_enable_pedigree_operations preference, the system captures the pedigree
information during a simulation tool launch.

• During the tool launch, if the input configuration has file-based additional inputs, then all
the named references related to the additional inputs are exported to the ESP folder. The
ESP_additional_inputs_list.txt file is created in the ESP_nn_LOGS directory. It contains the names
of all the files exported using additional inputs.

• During the tool launch, if the input configuration has PLM XML-based additional inputs, then all the
named references related to the additional inputs and the top level PLM XML file are exported to
the ESP folder. The ESP_additional_inputs_list.txt file is created in the ESP_nn_LOGS directory. It
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contains the names of all the files exported using additional inputs and the name of the top level PLM
XML file.

The system also creates various other log files in the same ESP_nn_LOGS directory.

Set favorite simulation tools

Analysts can add their favorite simulation tools to the Simulation Tools→Favorite Tools menu.

1. In Teamcenter or CAE Manager, choose Edit→Options to open the Options dialog box.

2. To specify favorite simulation tools, choose CAE Tools→Simulation Tools.

3. To add your favorite simulation tools to the Simulation Tools→Favorite Tools menu in CAE
Manager, select the configured tools from the My Favorite Simulation Tools area and click Add.

Validate simulation tools and provide feedback to the simulation
administrator

As a simulation analyst without DBA or simulation administrator privileges, you can test and validate the
in-progress simulation tools created by the simulation administrator and provide feedback regarding the
tool configuration. The simulation administrator can make changes based on your feedback and release
the tool to all users.

1. Choose Edit→Options to open the Options dialog box.

2. Choose CAE→Simulation Tools.

3. Select the appropriate revision rule to apply to tools in the Simulation Tools menu in CAE Manager.

The default revision rule is Any Status; No Working. The default value is determined by the
CAE_tool_menu_rev_rule user preference.

4. Launch the simulation process you want to test and provide feedback on the configuration.

Launch simulation tools

In some cases, instead of storing large result files in the database, organizations prefer storing the
generated result files on shared network folders. In such cases, the simulation administrator configures
output rules to create web link definitions to shared network folders and input rules to read the web link
definitions. As a simulation analyst, you can run predefined simulation tools with web link definitions,
and the system creates the web links for file extensions that match the configured input and output
rules. The web link definitions are supported on local, remote, server, and workflow launch processes.
For intermediate and final import, web links are supported only for the local launch.

Set favorite simulation tools
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The simulation administrator specifies the maximum file size for a simulation tool. When you launch this
tool, the system imports the file as an URL if the file size is bigger than the maximum file size specified by
the simulation administrator.

1. In CAE Manager, select an item revision from the Product, Model, or Analysis view.

Note:

If you open a product or model structure that has Product Configurator variant data, then
you cannot open the Simulation Tool Configuration view. You must restart CAE Manager or
attach the configuration context to the root of the simulation tool configuration to open this
view.

2. Click Simulation Tools→Favorite Tools→Tool_Name. The Launch Simulation Tool dialog box
opens.

Alternatively, click Simulation Tools→Tool_Name.

The name of the tool depends on the name specified by the administrator while configuring the
simulation tools.

The tool launch can be a local launch, local detached launch, remote launch, or server launch.

Note:

The local detached launch option has been deprecated and will be removed in a future
version of Teamcenter.

The availability of simulation tools depends on access control and context menu options set
by the administrator at your site.

The steps that follow assume the default simulation tool launch dialog box. These steps may
be different if a different dialog is configured by the simulation administrator for a particular
tool.

3. (Optional) Click Browse to change the Default Scratch Location path.

The default scratch location is the output directory for the launch tool. The path you specify is the
root directory for all of the process files, and named references of datasets, datasets associated with
item revisions, or item revisions created by Teamcenter.

The tool launch framework uses the default scratch location as the location to store all the input
and output files. However, if the staging location is configured, the tool launch uses the staging
location as the location for all the input and output files for the Local Launch and Server Launch
options.

11. Launch preprocessors, solvers, postprocessors, and other simulation tools
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Note:

This is applicable for server launch only.

Shared paths can be used for the default scratch location and the user staging location.

The OS user who is running the Teamcenter server should have the full control to share
access for the shared path.

Windows services do not support mapped drives. You must use a UNC path or a path that is
local to the machine for the shared staging location.

4. (Optional) Click Browse to override the User Staging Location path.

The user staging location is the output directory for the launch tool for a specific user. The path you
specify is the root directory for all of the process files, and named references of datasets, datasets
associated with item revisions, or item revisions created by Teamcenter.

The User Staging Location box is not available in the Launch Simulation Tool dialog box if the
simulation administrator has configured the launch type as Multiple Launch. In such a case, the
system uses the default location value that is configured.

The User Staging Directory box is a read-only field. It is a combination of the user staging location
folder and the folder naming pattern specified by you in the Options dialog box in Teamcenter or
CAE Manager.

You can use a shared staging location to avoid exporting the same result files across simulation
tools by multiple users. These result files can also be shared across multiple users.

Note:

This is applicable for server launch only.

Do not use the shared path for the default scratch location and the user staging location.
Instead, use the local path.

Windows services do not support mapped drives. You must use a UNC path or a path that is
local to the machine for the shared staging location.

5. (Optional) You can override the file names in the PLMXML Export File option.

Note:

This option is shown only if the simulation tool is configured to have such a file.

6. Enter runtime parameters as appropriate.

Launch simulation tools
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Parameters can be dynamic or static depending on how the administrator configures it. Dynamic
parameters are extracted from object attributes. The static parameters you enter at run time are
passed to the launch script.

• You can enter runtime parameters only if the administrator has selected the Runtime Parameter
check box in the Input Parameter pane while configuring the launch tools. The administrator
might choose to predefine runtime parameters for frequently used launch tools. In such cases,
you cannot overwrite runtime parameter values.

• You can use Edit in this field to enter the allowable values for both List of Values and Boolean
types. For Boolean types, only the first two entered values are considered.

In the default launch dialog box, the List of Values fields are presented as a list and the Boolean
fields are presented as a check box. The selected state corresponds to the first value in the
Boolean definition.

7. Specify optional inputs.

While configuring simulation tools, the simulation administrator cannot practically link all the
optional inputs to the primary input item revision and predefine the traversal path for all those
inputs that you (as simulation analyst) want to export in the tool configuration. For example, in
addition to the result files (primary input), you may want to select result templates (optional inputs)
and send them to a postprocessor. The result templates are not linked to the analysis item revision
that holds the result files. In such cases, the simulation administrator configures optional inputs for
you to select additional inputs such as result templates.

During the tool launch process, you can select the desired item revision for each available optional
inputs and use these templates, for example, to export only specific types of results.

8. (Optional) Choose one of the following options in Create Items and Create Datasets:

Note:

You can optionally override any of the options specified by the administrator while
configuring simulation tools.

• As Needed to create items or file associations as needed when you execute the launch tool.

• Always to always create items or file associations when you execute the launch tool.

• Never to never create items or file associations when you execute the launch tool.

9. (Optional) Select one of the following options:

11. Launch preprocessors, solvers, postprocessors, and other simulation tools
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Option Allows you to

Local Launch Launch simulation tools on the Teamcenter client.

You must keep the Teamcenter client running till the simulation process is
completed.

Local Detached
Launch

Launch simulation tools on the Teamcenter client.

You can exit the Teamcenter client after launching the simulation process.
The results are stored in Teamcenter.

Note:

This option has been deprecated and will be removed in a future
version of Teamcenter.

Remote Launch Launch simulation tools on a different machine or module. This machine
does not have the Teamcenter server installed on it, but has simulation
tools and Dispatcher components installed and configured to allow a
remote launch of simulation tools from Teamcenter clients.

Remote launch is ideal for compute-intensive operations, such as
meshing, solve execution, and post processing. Such operations do not
require interactive user input. You can execute them as a batch process
on remote machines with load-balancing capabilities and can monitor and
administer request queues.

When you launch simulation tools, the system exports the data (primary
input and additional input files) to the Dispatcher staging directory.

After launching simulation tools on a different module, you can exit the
Teamcenter client or even shut down the Teamcenter client. The results
are stored in Teamcenter.

Server Launch Launch simulation tools on the Teamcenter server.

After launching simulation tools on the server, you can exit the
Teamcenter client or even shut down the Teamcenter client. The results
are stored in Teamcenter.

Note:

Only valid options are shown in the dialog box by default. These options are available only if
the administrator has selected the relevant options while configuring the simulation tools.

Launch simulation tools
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10. To specify the file upload and URL create conflict options, select Prompt User or Auto-process.

If you select Auto-process, choose one of the following options:

• • Upload File/Update URL for the system to upload output files or update URLs. In the case of
files, the system creates new versions of existing files with the same name. This is the default
option.

• Rename and Upload File/Rename and Create URL for the system to rename and upload the
file or rename and create URLs. In the case of files, the system renames the output files with a
name provided by the user if similar filenames exist. It then uploads them to the database. The
system generates a new name for the URL and it is not editable.

• Skip to avoid uploading the output files or creating new URLs, if similar files or URLs with the
same name exist in the database.

If you select Prompt User, the system provides options to control each file or URL that is uploaded
or updated. If there are conflicts, the system displays the File Upload Conflict dialog box. The
options in the Action column are similar to the ones available for Auto Process. If you choose the
Rename and Upload File/Rename and Create URL option, you can provide a new name for the
URL.

11. Launch preprocessors, solvers, postprocessors, and other simulation tools
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11. To specify the file download options, select Prompt User or Auto-process.

If you select Auto Process, choose one of the following options:

• Skip to avoid uploading the output files to the User Staging Directory, if similar files with the
same names exist in the directory.

• Overwrite to overwrite to overwrite the existing files in the User Staging Directory.

If you select Prompt User, the system displays the Select Potential File Conflict Resolution dialog
box to control each file that is exported based on input rules. The options in the Action column of
this dialog box are the same as those in Auto Process.

12. (Optional) Select the Display Progress Monitor on Launch option to monitor the progress of the
tool launch.

Note:

In the progress monitor, the final status of the process is based on the status of the final
import. This is irrespective of the status of intermediate imports.

Status of jobs in Simulation Tool Progress Monitor

After the simulation tool launch, the Simulation Tool Progress Monitor opens by default if you have
selected the Display Progress Monitor on Launch check box while launching tools. Alternatively, you
can click Simulation Tool Progress Monitor on the main toolbar.

Status Description

Complete The job is complete and successful.

Disconnected A job is marked as disconnected if the job was in progress
while the user closes the rich client.

Note:

Disconnected is not supported if the simulation
administrator has selected the Multiple Launch
option while configuring simulation tools.

Duplicate Another tool launch has been started on the same input
object while an existing job is still in progress.

Failed The job has failed.

In Progress The job is being executed.

Initializing The job is being initialized.

Launch simulation tools
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Status Description

Intermediate Uploading The system is importing the intermediate results.

Terminated The job is terminated by the user from the Simulation Tool
Progress Monitor.

Uploading The system is importing the final outputs after exiting the
launch script successfully.

User Aborted Import The user aborted the import because of file upload conflicts.

No output files found (If output rules are defined) After the simulation tool
execution is complete, the system checks for any matching
output files. However, no output files are found.

No files uploaded or Web Links
created

(If output rules are defined) After the simulation tool
execution is complete, the system finds matching output
files. However, they are not imported.

This could be due to the following reasons:

• Selective Data Import is enabled and the import process
is canceled.

• For resolving file upload and URL create conflict options,
the Prompt User option is selected and the import is
skipped.

• For resolving file upload and URL create conflict options,
the Auto-Process and the Skip option is selected.

• Import only Modified files is selected but no output files
are modified.

This information is also displayed in the
simulation_process_launch.log file.

Processing After files are imported into the database, the system
performs a final verification and clean up before moving the
status to its final status.

Launch simulation tools using a preconfigured style sheet

The simulation administrator configures style sheets to launch various simulation tools. Consult your
simulation administrator for information about launching various simulation tools. When you launch
a simulation tools using a preconfigured style sheet, the latest released revision of the corresponding
simulation tool is launched.
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1. In CAE Manager, select a model or an analysis revision from the Model or the Analysis view,
respectively.

2. From the view toolbar, click Open Secondary Views  → Summary.

3. In the Overview tab, click More Actions and select the preconfigured simulation tool you want to
launch.

4. In the Launch Simulation Tool dialog box, select options as appropriate.

The name of the tool depends on the name specified by the administrator while configuring the
style sheet.

5. (Optional) Click Browse to change the Temporary OS Location path.

The temporary operating system (OS) location is the output directory for the launch tool. The
temporary path you specify is the root directory for all of the process files, and named references of
datasets, datasets associated with item revisions, or item revisions created by Teamcenter.

6. (Optional) Choose one of the following options in Create Items and Create Datasets:

Note:

You can optionally override any of the options specified by the administrator while
configuring simulation tools.

• As Needed to create items or file associations as needed when you execute the launch tool.

• Always to always create items or file associations when you execute the launch tool.

• Never to never create items or file associations when you execute the launch tool.

7. (Optional) Select one of the following options:

Option Allows you to

Local Launch Launch simulation tools on the Teamcenter client.

You must keep the Teamcenter client running till the simulation process is
completed.

Remote Launch Launch simulation tools on a different machine or module. This machine
does not have the Teamcenter server installed on it, but has simulation
tools and Dispatcher components installed and configured to allow
remote launch of simulation tools from Teamcenter clients.

Remote launch is ideal for compute-intensive operations, such as
meshing, solve execution, and post processing. Such operations do not

Launch simulation tools using a preconfigured style sheet
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Option Allows you to

require interactive user input and you can execute them as a batch
process on remote machines with load-balancing capabilities and the
ability to monitor and administer request queues.

When you launch simulation tools, the system exports the data (primary
input and additional input files) to the Dispatcher staging directory.

After launching simulation tools on a different module, you can exit the
Teamcenter client or even shut down the Teamcenter client. The results
are stored in Teamcenter.

Server Launch Launch simulation tools on the Teamcenter server.

After launching simulation tools on the server, you can exit the
Teamcenter client or even shut down the Teamcenter client. The results
are stored in Teamcenter.

8. To specify file upload options, select one of the following options:

• Prompt User to open the File Upload Conflicts dialog if the same output file exists in the
database. In such cases, you can select the Upload, Rename and Upload, or Skip option.

• Upload for the system to upload output files and create new versions of existing files with the
same name.

This is the default option.

• Rename and Upload for the system to automatically rename the output files with a suffix, if
similar filenames exist, and upload them to the database.

• Skip to avoid uploading the output files, if similar files exist in the database.

9. (Optional) Select the Display Progress Monitor on Launch option to monitor the progress of the
tool launch.

Note:

In the progress monitor, the final status of the process is based on the status of the final
import. This is irrespective of the status of intermediate imports.

10. Click OK to launch the simulation tool.

11. Launch preprocessors, solvers, postprocessors, and other simulation tools
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Launch simulation tools using a workflow process

Your site administrator creates process templates from workflow templates to launch various simulation
tools. Consult your site administrator for information about the process templates to launch various
simulation tools.

• The simulation tools specified by the administrator are launched when you use the process template.

• If the administrator at your site has not specified the –noref option while configuring the workflow
action handler, the workflow handler adds output objects as reference attachments in the Reference
folder in the CAE Manager view.

1. In CAE Manager, select one or more item revisions from the Product, Model, or Analysis view.

If you select a product, model, or analysis structure in any of the CAE Manager views, all the child
items within the structure are automatically selected for the workflow process launch.

2. Choose File→New→Workflow Process. The New Process Dialog box opens.

3. (Optional) In the Description box, type a description for the simulation tool you want to launch.

4. From the Process Template menu, choose the appropriate process template.

Note:

(Optional) In the Attachments pane, you can select an item revision from the available
targets and click the Cut icon to delete the item revision.

5. Click OK to launch the workflow process.

Automatically clear simulation jobs using preferences

You can set the following user preferences to automatically clear simulation jobs when a simulation
analyst uses simulation tools:

• CAE_Jobs_Clear_After_Size

• CAE_Jobs_Clear_Batch_Size

These user preferences work together and you must set both of them. The default values are 500 and
100, respectively.

Launch simulation tools using a workflow process
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Example:

Set the CAE_Jobs_Clear_After_Size and the CAE_Jobs_Clear_Batch_Size preference value as 50
and 10, respectively. After you set these preferences, the number of simulation jobs does not
exceed the sum of these preference values. Therefore, when you launch the 61st job, the system
clears the first 10 jobs in chronological order and they remain at 51 after the tool launch is
complete.

The Simulation Tool Progress Monitor displays the status of all tools. To view fewer jobs in the
Simulation Tool Progress Monitor, set lower values for these preferences. However, this impacts the
tool launch performance as the system has to clear jobs based on the values you have specified.

11. Launch preprocessors, solvers, postprocessors, and other simulation tools
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12. Analyze results
Capture results from different solvers and verify results

1. Create result revisions

You must create result revisions to manage analysis results from different solvers. The result
revision is associated with an analysis revision.

2. Upload results

When the solve is complete, you import the results to the result revision. You can also launch
a postprocessor and generate JT files or other visualization files and import them to the result
revision.

3. Verify results and send recommendations

After verifying the results, you can release the analysis data to production. You release the data by
signing off from a workflow. You can make recommendations while signing off the workflow.
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What are result revisions?

A result revision represents the results of a simulation analysis. CAE 3D Result item revisions are
workspace objects for storing the results of a solve. They may contain JT files or other visualization files
that are the results of a solve. Result revisions are associated with analysis revisions.

For more information, see Objects you work with.

Create result revisions in My Teamcenter or CAE Manager

1. Select a container for the item, such as a folder, another result revision, an analysis revision in a
folder, or an analysis revision in the Analysis view in CAE Manager.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select the CAE 3D Result item revision from the Most Recently Used or
Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

4. Specify information in the CAE Result Information area of the Object Create Information pane.

a. Type an item ID or click Assign to automatically assign an item ID.

b. Type a revision ID or click Assign to automatically assign a revision ID.

c. (Mandatory) Specify a name for the item revision.

d. (Optional) Enter a description for the item revision.

e. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

5. Specify information in the Additional CAE Result Information area of the Object Create
Information pane.

a. Specify the project ID and other information as appropriate.

b. Click Finish to create the item revision.

Alternatively, click Next to specify additional information

12. Analyze results
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6. Specify information in the CAE Result Revision Information area of the Object Create
Information pane.

a. From the Disciplines area, click Expand to modify, select a discipline from the list, and click
Add .

b. From the Analysis Types menu, select an analysis type.

c. Specify the project ID and other information as appropriate.

d. From the Solver Name menu, select a solver type.

e. Specify the analysis type, solver name, project ID, and other information as appropriate.

f. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information

7. Specify information in the Enter CAE Result Template Information pane.

a. Search for the result template by clicking Search and add it.

b. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information.

8. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

b. To specify named references, click Add, and select appropriate options.

Create result revisions in My Teamcenter or CAE Manager
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You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

c. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information.

9. (Optional) Specify information in the Define References pane.

You can specify references manually by typing the object ID, revision, object, and relation type or
using the Search dialog box.

a. To open the Define References pane, click Next.

b. Click Add and type an object ID, revision, object, and relation type or click Search to search for
references.

c. (Optional) Click Finish to create the item revision.

Alternatively, click Next to specify additional information

10. (Optional) Specify information in the Define Workflow Information pane.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

11. (Optional) Specify information in the Assign Project Page pane.

12. Analyze results
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Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

b. Click Finish to create the item revision.

Create result templates in My Teamcenter

You can create result templates to include different types of result criteria. After creating the template,
you can associate the template to a result revision.

1. In My Teamcenter, select a container for the result template, such as a folder or another item
revision.

2. Choose File→New→CAE Item or press Ctrl+E.

3. In New CAE Item Wizard, select the CAE 3D Result Template revision from the Most Recently
Used or Complete List list.

Note:

The administrator controls the item or item type and their attributes that analysts can view in
the New CAE Item dialog box.

4. (Mandatory) Specify information in the CAE 3D Result Template Information section.

a. Type an item ID or click Assign to automatically assign an item ID.

b. Type a revision ID or click Assign to automatically assign a revision ID.

c. (Mandatory) Specify a name for the result template.

d. (Optional) Enter a description for the template.

e. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information.

5. (Optional) Specify information in the CAE 3D Result Template Revision Information section.

a. Click Expand to modify, select the appropriate value from the list, and click Add to add the
value.

Create result templates in My Teamcenter
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b. (Optional) Click Finish to create a basic item revision.

Alternatively, click Next to specify additional information.

6. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To open the Enter CAE Attach Files Information pane, click Next.

b. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Note:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

c. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files into the Named reference table, the system
populates all the files as named references of the selected dataset.

d. (Optional) Click Finish to create a basic item revision.

7. (Optional) Specify information in the Define Workflow Information pane.

Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. To open the Define Workflow Information pane, click Next.

b. Select a process template and apply a process template filter.

12. Analyze results
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c. Select a process assignment list.

d. Click Finish to create the item revision.

Alternatively, click Next to specify additional information.

8. (Optional) Specify information in the Assign Project Page pane.

Projects represent and control access to a particular piece of work that may be accessible to
multiple organizations, such as project teams, development teams, suppliers, and customers.
Objects, such as items, item revisions, and datasets can be assigned to projects.

a. Select the project or projects from the Available Project list and move them to the Selected
Projects list using the right-arrow button. To select all projects in the list, click the double-
arrow button.

b. Click Finish to create the item revision.

9. (Optional) Specify information in the Enter CAE Attach Files Information pane.

Datasets manage data files, called named references, created by other software applications. A
default tool is associated with each dataset type.

a. To specify a list of data sets, click Add, and select appropriate options.

You can also drag files into the Dataset configuration table. Each file you drag is considered
as a single dataset, and each file is associated as a named reference.

Tip:

This association with a particular file depends on the
DRAG_AND_DROP_default_dataset_type preference set at your site, and this
preference is applicable only when you drag files.

b. To specify named references, click Add, and select appropriate options.

You can also drag files into the named reference table. When you select a dataset in the
Dataset configuration table and drag files in the Named reference table, the system
populates all the files as named references of the selected dataset.

c. (Optional) Click Finish to create a basic item revision.

10. (Optional) Specify information in the Define Workflow Information pane.

This pane is available only if it is configured in Teamcenter.

Create result templates in My Teamcenter
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Workflow process templates define the process flow, business rules, and signoff profiles of your
business processes. When an analyst initiates a workflow process, it is based on a selected process
template that contains a framework of tasks and signoff team profiles. This framework is used
to define the order of tasks and assign the responsibility of signing off tasks to other users.
The selected process template may include workflow handlers that automate some or all of the
assignments.

Process assignment lists are distribution lists associated with workflow process templates. These
lists assign resources to all tasks in a workflow process.

a. Select a process template and apply a process template filter.

b. Select a process assignment list.

11. (Optional) In the Assign Project Page, select an available project.

12. Click Finish to create the result template.

Solve, postprocess, view results, and release the analysis data

• Solve the analysis

When you are ready to solve your model, Teamcenter can launch the solver of your choice.

Your administrator configures the solvers at your site.

• Postprocess the results

• Import results to Teamcenter.

• Launch the postprocessor of your choice from Teamcenter.

• Generate JT files or other visualization files by using your postprocessor, and import them to
Teamcenter.

• Create reports and presentations, and import them to Teamcenter.

• View the results

You can view postprocessing displays, and access reports and presentations associated with the
results, provided that they are in a supported data format:

• You can view JT files and other common graphic formats (.gif, .jpg) directly in Teamcenter using
the embedded viewer.

• You can launch and view imported reports and presentations created in Word, Excel, or PowerPoint.

12. Analyze results
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• Release the analysis data to production

When an analysis is complete, you can release the analysis data to production. You release the data by
signing off from a workflow. Your administrator can implement a workflow for CAE processes.

Releasing analysis results is accomplished by applying a status on the items (CAE 3D Model, CAE 3D
Analysis, CAE 3D Result) used in the analysis.

• Any released, frozen, or locked item cannot be modified without creating a new revision.

• Datasets that are released, frozen, or locked cannot be modified.

Manage results in the database

You can manage results in the database. Alternatively, you can leave them where they are generated
such as shared network folders and create a symbolic URL link to the location in the database.

When results are managed in the database, they can take up significant space and volumes have to
be managed actively. You can periodically prune results from the database that are not modified, for
example, for the last six months. Even after the results are pruned, simulation analysts can use model
and input decks to regenerate the results again or they may have stored light weight results in JT
formats or reports.

To prune results with extensions such as *.op2, *.fil, and *.rst, you can use the Prune command in My
Teamcenter or use the prune_named_references command line utility if you are an administrative user.

Manage results in the database
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13. Using the simulation dashboard
Why use the simulation dashboard?

The simulation dashboard provides a clear view of the status of all the models and analyses carried
out by simulation analysts at the program, milestone, group, or individual user level. It allows decision
makers to access the latest information and make correct decisions.

The simulation dashboard:

• Displays the list and status of all models and analyses based on a query.

• Displays the status of models and analyses based on variants of the vehicle or master structure based
on the pedigree information.

• Presents the status of the results corresponding to the models and analyses.

• Monitors key performance indicator (KPI) values such as maximum stress, minimum temperature, or
maximum displacement from analysis revisions or analysis templates.

Display the results in the dashboard

1. Launch the simulation dashboard.

You can launch the simulation dashboard in multiple ways. Depending on the context, the system
opens the Model Dashboard or Analysis Dashboard.

Select one of the following options to launch the dashboard:

• Right-click a model revision in the Model view or analysis revision in the Analysis view and
select Simulation Dashboard. Select a predefined dashboard and click Continue.

The system displays the Model Dashboard or the Analysis Dashboard depending on the item
revision type you selected.

• Right-click a model revision or analysis revision from a folder in the Home view and select
Simulation Dashboard. Select a predefined dashboard and click Continue.

The system displays the Model Dashboard or Analysis Dashboard depending on your selection.

• Select a model revision or analysis revision from a folder in the Home view or from the Model
or Analysis view and click the Simulation Dashboard  icon on the main toolbar. Select a
predefined dashboard and click Continue.
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The system displays the Model Dashboard or Analysis Dashboard depending on your selection.

2. From the Input Method list, choose one of the following options:

• Model View or Analysis View to select all the valid item revisions in the respective view and
display them in the simulation dashboard.

• Folder to select the folder containing all the valid item revisions and display them in the
simulation dashboard.

• As Selected to select multiple item revisions from the Home folder, Analysis, or Model view
and display them in the simulation dashboard.

• Query and click Select to specify the query criteria. You can select one of the following options:

• CAE – Find Single-Level Related Model or CAE – Find Single-Level Related Analysis to find
all associated models or analyses of a specific product item revision.

In the CAD Item Revision ID query field, you can type a question mark (?) to query for all the
CAE models or analyses generated on the latest revision rather than all revisions.

• CAE – Find Multi-Level Related Models or CAE – Find Multi-Level Related Analysis to find
all associated models or analyses for the selected CAD at the components, subassemblies, and
variant levels. You can use this query to identify all models or analyses impacted by the design
change of a product item revision.

• (Specific to Model View) Select the CAE - Find Decks from Master query type to find all deck
structures associated to a master structure. You can then populate the model dashboard with
all the decks derived directly and indirectly from the master structure.

3. To display the results in the simulation dashboard, click Execute.

The system displays the file name or a green check. You can double-click the file name or the green
check to open the file with the preconfigured tool.

4. (Optional) To edit any displayed properties after executing the dashboard, click Edit Properties on
the view toolbar.

You can edit properties only in the green colored cells. After clicking a cell, you can change
its properties and press the Enter key or click on another cell to apply the changes. To discard
changes, press the Esc key.

When you check in the changes, the default checkout comment is Modified through Simulation
Dashboard. You can enter your own comment as needed.

After you modify multiple properties, click Save and Check-In on the view toolbar to save the
changes.

13. Using the simulation dashboard
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If there are any ambiguous files, the dashboard highlights them in the Status of Files Monitored
area. They are also shown in the respective column with a question mark. Hover over this question
mark to view the list of file names as a tool tip. Double-click this column to open the files in the
Open File dialog box.

In the following example, there are three ambiguous text files in the Text Files column.

5. (Optional) To open the Summary or the Details view, click Open Secondary Views  in the
view toolbar, and select the appropriate option.

In the Summary view, you can view the properties of a selected object and edit attributes such as
the name or description.

In the Details view, you can view the child properties of an object selected in the primary view in a
tabular format.

6. (Optional) To refresh the simulation dashboard, click Refresh  in the view toolbar.

If you select two analysis or model item revisions and then click Refresh, the system refreshes only
the selected item revisions.

An asterisk (*) is displayed after the Last updated Time value if the system has not refreshed all
item revisions.

7. (Optional) To filter the objects in the simulation dashboard, click Filter Management  in the view
toolbar and specify the filter conditions.

The filters you define are specific to each dashboard configuration and are persisted across sessions.

You can create filter conditions with two or more clauses based on:

• The same column and joined with AND/OR operators, for example, (body style = 4-door OR
status = failed).

Display the results in the dashboard
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• Different columns joined with AND/OR, for example, (body style = 4-door AND status = Failed
OR status = In-progress).

8. To generate a report of the dashboard, click Generate Simulation Dashboard Report  in the
view toolbar. The system displays the dashboard report in a spreadsheet format such as Microsoft
Excel.

You can optionally select the Create dataset option in the Export to Excel dialog box to specify a
dataset name. The system creates a dataset with the name you specify in the Newstuff folder. You
can double-click the dataset to open the simulation dashboard report in a spreadsheet format.

View pedigree information on the simulation dashboard

1. Open a product structure and configure the product structure.

2. Create a model structure automatically by running predefined data map rules or structure map
rules.

The model structure captures the pedigree information from the product structure.

3. Select the root item of the model structure and select Simulation Dashboard.

4. Execute the dashboard using a predefined dashboard configuration.

5. In the dashboard, double-click an option value to open the Pedigree Information dialog box.

13. Using the simulation dashboard
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View pedigree information on the simulation dashboard
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14. Troubleshooting
Simulation tools are not getting launched through TTLC due to the
wrong association of the .tcsimxml file

Issue

Simulation tools are not getting launched through Teamcenter Tool Launcher Client (TTLC) due to the
wrong association of the .tcsimxml file.

Issue details

Initially, the customer had an error related to the incompatibility of the TTLC version with the
Teamcenter server in the TTLC log. The correct TTLC version was reinstalled and then the tool launch
was attempted through TTLC. The .tcsimxml file opened with the Notepad application instead of the
tcsimtoollauncher.bat file. The tcsimtoollauncher.bat file calls TTLC and therefore the .tcsimxml file
has to be associated with this bat file. This association gets created in the registry when TTLC is installed.

Solution or Workaround

If the association of .tcsimxml file is wrongly created with another application instead of
tcsimtoollauncher.bat, then perform following steps to create the correct association:

1. Right click on any .tcsimxml file and go to properties.

2. Click the Change… button and select the tcsimtoollauncher.bat file from TTLC installation.
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Perl issue while executing the Extract KPI from Result tool

Issue

Perl issue while executing the Extract KPI from Result tool.

Issue details

A customer launched the Extract KPI from Result simulation tool from Active Workspace on CAEResult
object through TTLC. The sim_process_launch.log file showed that the tool launch failed. The launch
script output log showed the empty input arguments. The files were exported during tool launch, but
the launch script execution failed and status of tool was failed.

14. Troubleshooting
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Solution or Workaround

1. The launch script in this tool requires Perl installation. For Perl file to run, there is an entry in
registry as follows: HKEY_CLASSES_ROOT\pl_auto_file\shell\open\command.

The value of this entry should consist %* at the end. Otherwise, the input argument values
are shown as empty. Adding %* at the end of the value resolves the issue of the empty input
parameters.

2. If the above solution does not work, execute the following steps and verify if it resolves the issue:

a. Open a Command Prompt and select Run as Administrator.

b. To set up the correct registry values, type the following commands:

assoc .pl=PerlScript
ftype PerlScript=<path of the perl.exe> %1 %*

The Perl.exe path should be present inside the PATH system variable. The Perl installation should
contain XML::Simple and Archive::Zip folders.

For the customer mentioned above, this value was correct and executing the association steps also did
not work. The customer had multiple Perl installations on the machine. The Strawberry Perl installation
that was used to execute the launch script was not correct as mentioned in the executable path.

The customer was asked to remove the Strawberry Perl from his machine and install the correct Perl.
After installing ActiveState Perl and setting up the correct registry values as mentioned in step b and the
PATH system variable value, the customer was able to launch the tool successfully.

For more information about setting up Perl to execute the Extract KPI from Result tool, see Extract KPI
from Result Tool Integration PDF in the Teamcenter data (TC_DATA) directory.

Perl issue while executing the Extract KPI from Result tool
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Teamcenter does not recognize that the script has ended and the
process remains "in progress"

Issue

Teamcenter does not recognize that the script has ended and the process remains In Progress.

Issue details

Teamcenter does not recognize that the script has ended and the process remains In Progress and is not
switched to Completed.

The customer is using ANSYS Speos as an NX Plugin.

The requirement is that the tool launch must be offline, and Teamcenter should not wait for the
simulation to be finished. Getting the results back is a different process.

Approaches to writing scripts:

• Script 1: ANSYS SPEOS (as NX Plugin) Tool Launch:

REM ENTZIPPEN
echo %TIME%: ENTZIPPEN >> %2\script_output.log
call C:\Teamcenter\Tc12\bin\7za.exe x %input_file% -oC:\Temp\sim\
     staging\%item_id%_%rev_id% -r -y -bd
REM NX ASYNCHRON STARTEN
cd C:\Temp\sim\staging\%item_id%_%rev_id%\files
echo %TIME%: START NX ASYNCHRON>> %2\script_output.log
start "" "%arg2%\ugraf.exe" -retrieve:"SPEOS_for_NX.prt" 
REM Bath beenden
echo %TIME%: EXIT BATCH >> %2\script_output.log 
EXIT 0

• Script 2a:

echo %TIME%: Launching Word without input file >> %2\script_output.log
start "" "C:\Program Files (x86)\Microsoft Office\OFFICE15\Winword.exe"
echo %TIME%: end batch >> %2\script_output.log
EXIT 0 

• Script 2b:

echo %TIME%: Launching Word with input file >> %2\script_output.log
start "C:\Program Files (x86)\Microsoft 
Office\OFFICE15\Winword.exe"%input_file%
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echo %TIME%: end batch >> %2\script_output.log
EXIT 0

Solution or Workaround

Do not start command in the script file. Instead, use call to open the tool.

In addition, there were some issues reading the argument for the tool to be launched.

A sample working script can be as follows:

set input_file=%1
echo %TIME%: Launching notepad with input file : %input_file% >> 
script_output.log
call "C:\Windows\notepad.exe" %input_file%
echo %TIME%: end batch with input file %input_file% >> script_output.log
EXIT 0

For more details to write a script, refer the sample script files provided in the CAE_ESP_Sample_Files.zip
file in TC_DATA directory.

Simulation tool visibility in Active Workspace

Issue

Simulation tool visibility in Open in Simulation Tool panel in Active Workspace.

Issue details

If a user runs the simulation tool on an object and another user wants to run the same simulation
tool on the same object while the tool is running, the simulation tool does not appear in the Open in
Simulation Tool panel.

Solution or Workaround

The workaround can be applied by a DBA user. If analyst or designer users face this issue, they should
contact the DBA user.

Note:

Only a DBA user can perform the following procedure.

1. Opens Query Builder application and creates the Find Status Objects for a Simulation Tool query.

2. Selects the search type as CAE0SimProessStatus for the query.
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3. Adds the Tool Name search criteria for the query and clicks the Create button.

4. Opens CAE Manager application and opens Simulation Tool Configuration view.

5. Opens Print Object view and selects the simulation tool which needs to be searched.

6. Copies the UID of the simulation tool and pastes it in the query.
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7. Searches and deletes the status objects or asks the owning user to complete the job.

The simulation tool is now visible in the Open in Simulation Tool panel.

Simulation tool launch failure due to TTLC not finding the valid
certification path

Issue

Simulation tool launch failure due to TTLC not finding the valid certification path to the requested target.

Issue details

When trying to launch a simulation tool from Active Workspace, it results in an error and the tool is not
started.

To check this error, in File Explorer, navigate to %TEMP%/TcToolLaunchClientLog_<user> and open the
tctoolloaunchclient.log file. It displays the following error:

[main] [INFO] 2020-06-19 10:04:55,135 - Starting simulation tool launch 
operation.
log4j:WARN No appenders could be found for logger 
(com.teamcenter.soa.client.Connection).
log4j:WARN Please initialize the log4j system properly.
The server returned an internal server error.
Failed to send the service request, encountered an HTTP I/O error.
sun.security.validator.ValidatorException: PKIX path building failed: 
sun.security.provider.
     certpath.SunCertPathBuilderException: unable to find valid 
certification path to 
     requested target
The application will terminate.
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Solution or Workaround

Users who have TTLC installed based on Teamcenter 14.1 installed on their machine and are facing the
simulation tool launch failure due to TTLC not finding the valid certification path can apply this solution
or workaround.

1. Open Active Workspace in Google Chrome browser and click Not secure section.

2. In the Certificate dialog, click the Details tab, choose Copy to File, and click OK.
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3. Select the Base-64 encoded format and click Next.
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4. Specify a file path to export the certificate, click Next, proceed through the remaining steps, and
click Finish. The system displays a message saying that the export was successful.
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5. Navigate to the certificate and double click to install it.

6. Click Install Certificate.
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7. Specify the store location.
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8. Specify a location for the certificate and click Finish.
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9. Select Yes for the next few dialogs.

10. Change the file extension for the created certificate from .cer to .crt.

11. Start a command prompt as an administrator and navigate to the JAVA_HOME\jre\bin directory.

12. Run the following command:

keytool.exe -import -keystore cacerts -filepath to the generated certificate file -alias siemensrp
-storepasspassword

13. Ensure that the new certificate is added at JAVA_HOME Certificate Keystore by running the
command in the previously used command prompt:

keytool.exe -list -keystore JAVA_HOME\lib\security\cacerts >
Location_to_Generate_File\cacerts_listing.txt" -storepasspassword

14. Check the generated cacerts_listing.txt file to verify if the siemensrp certificate has been added.
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