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1. About Simulation Process and Data
Management
Design is an iterative process and often designs need to be modified due to manufacturing constraints or
conflicting requirements. It is possible to reduce costs and minimize the time spent on verification and
testing by arriving at a good design in the initial stages of product development and by continuously
validating the design throughout the product lifecycle. Simulation Process and Data Management is a
solution used for validating or improving a design in the early stages of the product lifecycle.

Where do I go from here?

 Simulation administrator See Simulation Process and Data Management ─
Deployment and Administration.

 Simulation analyst

I want to perform simulation
analysis in rich client

See Simulation Process and Data Management on Rich Client
─ Usage.

Which workspace to use? The Analyst workspace is the recommended workspace for
the simulation analyst role. See Using the Analyst workspace.

Prepare the data for analysis You prepare the data for analysis by simplifying the CAD
geometry. After simplifying the CAD geometry by using
the appropriate software, you can launch a preconfigured
simulation tool to export the simplified CAD geometry. See
Preparing the data for analysis.

Create geometry revisions for the
components you want to analyze

You can create geometry revisions for the components for
which you want to simplify the CAD geometry. The geometry
revision is often different from the product geometry. It may
be a simplified or an abstracted version, or an approximation
when the product geometry is not available. See Create
geometry revisions for the components you want to analyze.

Create the simulation model and
define a mesh

While analyzing a large product structure with thousands
of components, you can create simulation models or model
structures using one of the following options:

• CAE Structure Map: Generate a model structure for a
specific type of analysis using predefined structure map
rules.

The lead analyst or the designated analyst creates
structure map rules.

• Data Map: Some organizations prefer not to use structure
map rules. They prefer to create a model structure that
is an exact replica of the product structure using this
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option. After creating this replica model structure, they use
predefined derivative rules and variant configuration rules
to quickly derive one or more structures relevant to their
analysis from the model structure.

The simulation administrator defines the data map rules.

See Different ways to generate simulation models.
Create the analysis model and
define load cases

The analysis model represents the specific analysis such as
thermal, structural, or fluid you want to perform. It includes
load cases, solver parameters, and boundary conditions.
After creating the analysis model or revision, you can select
the specific revision and launch a preconfigured simulation to
upload the load cases, solver parameters, and perform the
solve. See Create analysis revisions and solve the analysis.

Launch simulation tools Simulation Process and Data Management provides a
framework for launching simulation tools that include
preprocessors, solvers, postprocessors, and other tools. You
can launch simulation tools as a local launch, local detached
launch, remote launch, or server launch, depending on how
the administrator configures the launch parameters at your
site. See Launch simulation tools.

Solve the analysis You can solve the analysis by launching preconfigured
simulation tools. After capturing results from different solvers
and verifying results, the analysis data can be released
to production. The data is released by signing off from a
workflow. You can make recommendations while signing off
the workflow. See Capture results from different solvers and
verify results.

Use the simulation dashboard The simulation dashboard provides a clear view of the status
of all the models and analyses carried out by simulation
analysts at the program, milestone, group, or individual
user level. It allows decision makers to access the latest
information and make correct decisions. See Why use the
simulation dashboard?

1. About Simulation Process and Data Management
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2. Introduction to Simulation Process and
Data Management
Simulation Process and Data Management workflow

The workflow for managing the simulation process is as follows:

Understanding Simulation Process and Data Management using an example

1. View the analysis request

Let us assume that you (as a simulation analyst) are an expert in simulated automobile crash
testing. The analysis request is to perform a simulated side-impact test for a design change made to
the driver-side door.

2. Prepare or refine the design data for analysis
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Your first task is to import the product geometry and simplify it to make it relevant for the analysis.
The driver-side door has a speaker; switches for the door lock; power window; and electric mirror;
an intrusion beam; steel frames; door panels; and other parts. The speaker and switches are not
relevant for the simulated side-impact analysis. You import the complete product geometry and
use a simplification tool to remove the speaker and switches. Then, you create geometry revisions
for the intrusion beam, steel frame, and door panel, and save the simplified geometry for each
component.

3. Create models

The model you want to analyze includes the mesh definition, connections, and material and
physical properties. In this step, you create model revisions—in the context of the geometry
revisions—for the intrusion beam, steel frame, and door panel. Then, you select the appropriate
batch meshing tool to generate meshes for each component.

4. Create the analysis and solve the analysis

The analysis you want to perform includes load cases, solver parameters, and boundary conditions.
In this step, you create analysis revisions—in the context of the model revisions—for the intrusion
beam, steel frame, and door panel. Then, you select the appropriate solver tool to specify load
cases and solver parameters.

In this example, you create different analyses to vary the load cases, for example, a 3000 pound
SUV-like barrier hits the driver side door at 30 mph. You also create another analysis model to
change the barrier weight to 3200 pounds and the speed to 35 mph.

5. Evaluate the results and send recommendations

The intrusion beam acts as an energy-absorbing material during a side impact. The results show
that the intrusion beam cannot withstand forces of 3200 pounds at 35 mph. After evaluating
results from various scenarios, you sign off the workflow by suggesting a design change for the
intrusion beam.

Objects you work with

• Geometry revisions

The CAD model is used to define the geometry of a part or an assembly. During the final stages of the
design process, the geometry contains numerous details, such as sharp edges, bolt holes, or fillets,
which are not required for the analysis. The geometry used for simulation analysis is often different
from the product geometry. It may be a simplified or an abstracted version or an approximation when
the product geometry is not available. CAE 3D Geometry revisions are workspace objects for storing
the simplified geometry. Geometry revisions are created in the context of the item revisions in the
product structure.

• Model revisions

2. Introduction to Simulation Process and Data Management
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A mesh represents a geometric object as a set of finite elements. Finite element analysis (FEA) is a
computerized method for simulating how a part reacts to conditions such as force, heat, vibration,
and other physical effects in the real world. CAE 3D Model revisions are workspace objects for storing
the mesh definition, connections, and material and physical properties. Model revisions are created in
the context of geometry revisions.

• Analysis revisions

An analysis revision represents the specific simulation you want to perform. CAE 3D Analysis
revisions are workspace objects for including load cases, solver parameters, and boundary conditions.
Analysis revisions are created in the context of model revisions.

• Result revisions

A result revision represents the results of a simulation analysis. CAE 3D Result revisions are
workspace objects for storing the results of a solve. They may contain JT files or other visualization
files that are the results of a solve. Result revisions are associated with analysis revisions.

You can create the following CAE revisions in the context of other revisions along with relationships:

Context
revision

CAE revisions you can
create for the context
revision

Default relationships

Product
structure

CAE 3D Geometry TC_CAE_SOURCE and
TC_CAE_TARGET

CAE 3D Model

CAE 3D Analysis

CAE 3D
Geometry

CAE 3D Model TC_CAE_SOURCE

CAE 3D Analysis

CAE 3D Model CAE 3D Analysis TC_CAE_DEFINING

CAE 3D
Analysis

CAE 3D Analysis TC_CAE_INCLUDE

CAE 3D Result TC_CAE_RESULTS

The following is an example of the default simulation data model.

Objects you work with
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Using the Analyst workspace

As a simulation analyst, you can access all the commands in the Default workspace, and some of these
commands are not relevant to mainstream CAE workflows. Instead, you can use the Analyst workspace.
It provides a simplified Home page with fewer tabs and commands. These are the ones that you typically
use. It contains simplified tabs, pages, and table columns. You can use this workspace to:

• Access the Subscription tile to view all the past and current alerts and logs generated during
simulation workflows.

• Launch simulation tools to complete tasks.

• View all the relevant CAE objects that you work with from the Gallery viewer.

The Analyst workspace is the recommended workspace for the simulation analyst role.

To access this workspace, set your Group to Engineering, Role to Analyst, and Workspace to Analyst.

2. Introduction to Simulation Process and Data Management
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Setting preferences to control the behavior and appearance of
Teamcenter

You can work with all Teamcenter preferences by using the Preferences page.

For information about retrieving a list of preferences, see Where can I get a list of preferences? in
Teamcenter Administration.

Setting preferences to control the behavior and appearance of Teamcenter
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3. Prepare the data for analysis
Preparing the data for analysis

1. View the analysis request

An engineering manager reviews design requirements and assigns design changes for validation
to a simulation analyst using a workflow. The workflow contains the design requirements,
configuration information, subassembly, and components required for analysis.

If your organization does not follow a workflow process, search for a target structure and select the
data for the analysis.

2. (Optional) Apply revision rules, variant rules, or effectivity

If you work in a product environment with a lot of variability, such as the automobile industry, you
can apply revision rules, effectivity, or variant rules to make the product structure relevant to your
analysis.

3. Create geometry revisions for components for which you want to simplify the CAD geometry

You create geometry revisions for the components for which you want to simplify the CAD
geometry. The geometry revision is often different from the product geometry. It may be a
simplified or an abstracted version, or an approximation when the product geometry is not
available.

In the simulated side-impact example, the driver-side door has a speaker; switches for the door
lock; power window; and electric mirror; an intrusion beam; steel frames; door panels; and other
parts. The speaker and the switches for door lock, power window, and electric mirror are not
relevant for the simulated side-impact analysis. You export the complete product geometry (next
step) and use a simplification tool to remove the speaker, switches, and the electric mirror.
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4. Launch a preconfigured simulation tool to export and simplify the CAD geometry

The CAD model is used to define the geometry of a part or an assembly. During the final stages
of the design process, the geometry contains numerous details, such as sharp edges, bolt holes,
or fillets, which are not required for the analysis. You can launch a preconfigured simulation tool
to automatically export the CAD geometry. Then, you simplify the product geometry using a
simplification tool.

5. Upload the simplified geometry to the geometry revision you created

You can upload the simplified geometry to the geometry revision you created.

View the analysis request or select the data for analysis

You can view the analysis request or select the data for analysis.

1. View the analysis request.

If your organization follows a workflow process, open the analysis request containing the design
requirements and the subassembly and components required for the analysis.

a. On the HOME page, click INBOX.

b. In My Tasks, select the task you want to perform.

c. Review any task instructions and the process description. If necessary, type additional
information into the box.

d. Complete the task instructions and click Complete.

2. Select the data for analysis.

If your organization does not follow a workflow process, search for a target structure and select the
data for the analysis.

You can obtain the data by opening the target structure as follows.

a. In the search box, type all or several characters of a word or value related to the objects you
want to search for.

b. (Optional) Restrict your search to those objects with a certain owner or of a particular type
category by clicking Any Owner or Any Category and choosing a value.

c. Click Search  or press Enter.

d. From Filters, select the Item Revision type.

3. Prepare the data for analysis
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e. Select the item revision from Search Filters, and click the Overview tab to find the related
CAE objects.

You can also perform a Perform a quick search to locate the data or Perform an advanced search to
locate the data.

Perform a quick search to locate the data

You can perform a quick search to locate the data required for simulation tasks.

Procedure

1. To search for data required for simulation tasks, start by typing the required search criteria into the
search box located in the top right corner.

2. Refine your search criteria by selecting Simulation from Filters.

3. Refine your search further by selecting other criteria from Filters.

Examples

• Search for CFD in the search box and refine your search further by selecting Simulation and
Discipline from Filters.

• Search for Thermal in the search box and refine your search further by selecting Simulation and
Solver Name from Filters.

• Search for the product structure. The results display the product structure along with the model
structures and the analysis revisions related to the product structure.

Perform an advanced search to locate the data

You can import and create data for your simulation analysis, or you can search for data in Teamcenter to
find an existing CAD model to perform analysis on, find a previous CAE 3D Analysis to reuse or modify, or
find other data that can be used as input for a CAE 3D Analysis.

Procedure

1. On the HOME page, click Advanced Search.

2. Click the Advanced tab, and type cae, and select a query.

Some query examples are as follows.

Perform a quick search to locate the data
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• Use CAE 3D Analysis Revision, CAE 3D Model Revision, or CAE 3D Result Revision to find
analysis revisions, model revisions, or result revisions, respectively.

• Use CAE – Find Single-Level Related Model or CAE – Find Single-Level Related Analysis
to find all associated models or analyses of a specific product item revision. In the CAD Item
Revision ID query field, you can type a question mark (?) to query for all the CAE models or
analyses generated on the latest revision rather than all revisions.

• Use CAE – Find Multi-Level Related Models or CAE – Find Multi-Level Related Analysis to find
all associated models or analyses for the selected CAD at the components, subassemblies, and
variant levels. You can use this query to identify all models or analyses impacted by the design
change of a product item revision.

3. To perform an advanced search, click Search.

Apply configuration rules to make the structure relevant for your
analysis

You can trim the product structure and make it relevant for your analysis. To do this, you can apply
revision rules and configure the product structure for a particular situation. Each revision rule selects
the appropriate revision of all the components in the structure for a particular situation. For example,
a design engineer may want to see the components specified by the Latest Working revision rule,
whereas a manufacturing engineer may require the components specified by the Latest Released
revision rule.

You can also apply effectivity and variant rules to further trim your product structure.

Note:

Do not apply revision rules, effectivity, or variant rules to a product structure or subassembly in a
saved working context.

Reorganize the product structure to make it suitable for simulation
analysis

As a simulation analyst, the product structure you receive may not have all the data or it may not
be organized in a manner that is suitable for simulation analysis. Before you start reorganizing the
structure, you require a collector item or a placeholder to store the new structure.

You can create CAE 3D Product Collector revisions to store the new structure. The new structure
you create using this revision object is called a product collector structure. It is similar to the product
structure.

The CAE 3D Product Collector workspace object is used to manage a collection of objects which are
used for 3D type CAE work. For example, if there are several CAD items (item revisions) or CAE 3D

3. Prepare the data for analysis
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geometries that are distributed through Teamcenter and are necessary to perform a CAE 3D analysis,
then analysts can utilize the CAE 3D product collector to group all these objects together. You can run
data map and structure map rules on the CAE 3D product collector object. Product collectors can also
be placed under other product collector objects similar to a parent-child relationship. A CAE 3D product
collector can collect the following objects: CAE 3D geometry, CAE 3D model, CAE 3D analysis, as well as
item revisions.

You can create collector structures in different ways. For example, you can:

• Create a flat structure by copying only the leaf nodes and by ignoring all the intermediate
subassembly levels created by the designers.

• Organize the components differently under different subcollectors in a manner that is more efficient
for simulation analysis.

• Choose desired parts or subassemblies from more than one product structure.

Create CAE 3D Product Collector revisions

1. On the HOME page, click the CREATE SIMULATION tile. From the TYPE menu, select CAE 3D
Product Collector.

Alternatively, click Folders, select a folder, and choose More Commands > New  > Add. In the
OTHER filter, type cae product collector and select CAE 3D Product Collector.

Reorganize the product structure to make it suitable for simulation analysis
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2. (Mandatory) Specify a name for the CAE 3D Product Collector revision.

3. (Optional) Select a discipline such as Durability, NVH, or Safety.

4. (Optional) To specify a project, click Add Project , search for a product item revision, select the
item revision, and add it.

5. To create the CAE 3D Product Collector revision, click Create.

Add a geometry, model, and analysis revisions to the product collector structure

The following procedure describes how to add a geometry revision with a product collector revision.
You can use similar procedures to add model and analysis revisions to the CAE 3D Product Collector
revision.

1. Open the CAE 3D Product Collector revision and click the Overview tab.

2. (Optional) To add a geometry revision, choose More Commands > New  > Create Simulation.

3. From the TYPE menu, select CAE 3D Geometry.

4. (Mandatory) Specify a name.

5. (Optional) Select an analysis type, preprocessor type, and discipline.

6. To create the revision, click Create.

The system automatically creates the source and target relationship with the product collector
revision.

Associate the product collector revision object with geometry, model, and analysis
revisions

The following procedure describes how to associate a product collector revision object with a geometry
revision. You can use similar procedures to associate model and analysis revisions.

1. Open a CAE 3D Geometry revision and click the Overview tab.

2. In the RELATED OBJECTS table, click Add Simulation .

3. In the TYPE filter of the Add Simulation panel, type CAE 3D Product Collector and select it.

4. Select the CAE 3D Product Collector from the Palette tab or type the search criteria in the Search
tab and click Add.

The system displays the object you added in the RELATED OBJECTS table.

3. Prepare the data for analysis
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5. (Optional) Click the Overview tab.

The system displays the object you added in the PRODUCT table.

Organize the product collector structure and create model structures

1. Open the CAE 3D Product Collector revision.

2. Organize the structure.

3. Generate a model structure.

a. Click the Content tab and choose More Commands > New  > Generate CAE Structure.

In the Generate CAE Structure panel, select one of the following options:

• Data Map to create a model structure that is an exact replica of the product structure
using data map rules.

After creating the model structure, you can use predefined derivative rules in CAE Manager
(rich client) to derive one more structures relevant to your analysis from an existing
structure.

• CAE Structure Map to create a model structure that is an exact replica of the product
structure using data map rules

b. Select a domain.

The default domain is CAE.

The simulation administrator creates domains. Your company might have different CAE
disciplines for safety, durability, and so on. The company wants data mapping to be different
for each discipline, but there is only one data map XML file for the whole site. Domains are
created to handle data mapping differently in such situations.

c. To generate a model structure, click Execute.

Create predefined analysis packages or CAE packages and analyze results

Analysts can use the package definitions created by the simulation administrator or the group
administrator to create their own CAE item revisions.

1. Open the CAE 3D Product Collector revision and click the Overview tab.

2. Choose More Commands > New  > CAE Package.

Reorganize the product structure to make it suitable for simulation analysis
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3. From the Results panel, open a site package.

4. Specify input, output, and other parameters as appropriate and click Execute.

5. Capture the results and verify the results.

View the product collector with the CAE Based On relationship

1. Create the CAE 3D Product Collector revision.

2. Attach a product revision to the product collector revision.

3. Create a model structure using data map rules.

4. Open the model structure you created and create a CAE 3D Analysis revision from the Overview
tab.

5. Click the Overview tab and open the product collector revision from the Product table.

6. Click the Relations tab and click Show All Incoming Relations.

7. Click the Relations Legend  to view the simulation objects and relations.

View traceability information

1. Create the CAE 3D Product Collector revision.

2. Open the CAE 3D Product Collector revision and click the Overview tab.

3. Select the model revision in the MODEL table.

The system displays the TRACEABILITY INFORMATION as CAE 3D Model Revision > CAE 3D
Product Collector.

4. Select the analysis revision in the ANALYSIS table.

The system displays the TRACEABILITY INFORMATION as CAE 3D Analysis Revision > CAE 3D
Product Collector.

5. Select the result revision in the RESULT table.

The system displays the TRACEABILITY INFORMATION as CAE 3D Result Revision < CAE 3D
Analysis Revision > CAE 3D Product Collector.

3. Prepare the data for analysis
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4. Create 1D model and 1D analysis objects
for simulations
Workflow for Simcenter Flomaster

Workflow for managing 1D data in Simcenter Flomaster

System simulation modeling is used to explore different concepts at the early stages of the design. This
is usually done even before any CAD geometry is available. The parameters for these models can be
refined, and the details can be added later when they are available. 1D models are precursors to the
detailed 3D CAE models in the entire design cycle.

You can create CAE 1D Model and CAE 1D Analysis revisions to capture model and analysis data for
Simcenter Flomaster integration. The CAE 1D Analysis revision must always be created in the context of
the CAE 1D Model revision.

The workflow for managing 1D data in Simcenter Flomaster is as follows:
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Create CAE 1D model revisions to capture 1D model data for Flomaster

You can create CAE 1D Model revisions to capture 1D model data for integrations such as Simcenter
Flomaster.

You can use the 1D model revision to manage templates for system simulation analysis activities,
for example, Amesim and Flomaster. When simulation analysts use templates to perform the system

4. Create 1D model and 1D analysis objects for simulations
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simulation work, they prefer to store them in Teamcenter. These 1D system simulation templates can
thereafter be used to create 1D system simulations. You can directly relate the CAE 1D model object to a
CAE 1D analysis as well as a physical test result. When connecting to these objects, all CAE 1D analyses
which were created based on the CAE 1D model object as a template can be quickly retrieved.

Prerequisites

The following procedures assume that the Simulation Process Management with Parameter
Management feature is installed at your site and the simulation administrator has run the quick setup
script (tcsim_quick_setup.pl) to create sample configurations that includes the required Simcenter
Flomaster tool.

Procedure

1. On the HOME page, click Create Simulation.

2. Select CAE 1D Model, specify a name for the 1D model revision, and click Create.

3. Create the input and output parameters for the 1D model by launching a preconfigured simulation
tool.

a. Select the 1D model revision, click Open>Open in Simulation Tool, and select Simcenter
Flomaster.

For more information about launching tools, see Launch simulation tools.

b. In the Launch Inputs tab, specify the launch method and other parameters as appropriate.

c. To create the input and output parameters for the 1D model, select the Create Model launch
type.

d. To launch the tool, click Open.

e. After the tool launch is complete, click the Parameters tab to verify the parameter values in
the Input Parameters and Output Parameters sections.

4. Update the input and output parameters for the 1D model by launching a preconfigured simulation
tool.

a. Select the 1D model revision, click Open>Open in Simulation Tool, and select Simcenter
Flomaster.

For more information about launching tools, see Launch simulation tools.

b. In the Launch Inputs tab, specify the launch method and other parameters as appropriate.

Create CAE 1D model revisions to capture 1D model data for Flomaster
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c. To update input and output parameters for the 1D model, select the Update Model launch
type.

d. To launch the tool, click Open.

e. After the tool launch is complete, click the Parameters tab to verify the updated parameter
values in the Input Parameters and Output Parameters sections.

5. Release the model revision.

After all the work related to model revision is complete, you can release the model revision using a
workflow.

a. Select the model revision you want to release and choose More Commands > Manage >
Submit to Workflow.

b. Select the TCM Release Process template and click Submit.

6. (Optional) To view related revisions, select the 1D model revision, and click the Overview tab.

7. Edit the properties of the 1D model revision.

a. Select the revision and click the Overview tab.

b. Choose More Commands > Edit > Start Edit.

c. Update the properties as appropriate.

d. To save the properties, choose More Commands > Edit>Save Edits.

8. (Optional) Create external links or folders for the 1D model revision.

a. Select the revision and click the Overview tab.

b. Click Add to  in EXTERNAL LINKS.

c. Select PROPERTIES, specify a name and the URL or a shared location, and then click Add.

d. To delete a web link, select the web link, click Edit, and select Delete External Links.

9. (Optional) Upload data using predefined rules.

You can upload data for integrations such as Simcenter Flomaster.

a. Select the revision and click the Files tab.

4. Create 1D model and 1D analysis objects for simulations
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b. Click Upload File, select a predefined file upload rule, and choose the file you want to upload.

c. Upload or download files using predefined rules (without Data Share Manager).

OR

Upload or download files using predefined rules (with Data Share Manager).

10. (Optional) To view relations between different objects, select the 1D model revision and click the
Relations tab.

It allows you to view and navigate the relations between different objects in a graph view.

11. (Optional) Make a copy of the 1D model revision.

a. Select the 1D model revision.

b. Choose More Commands > New   > Save As .

c. (Optional) Specify a new name if you want to create a copy and description.

d. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

e. To create a copy, click Save.

12. (Optional) Revise the 1D model revision.

a. Select the 1D model revision.

b. Choose More Commands > New   > Revise .

c. (Optional) Specify required information as appropriate.

d. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

Create CAE 1D model revisions to capture 1D model data for Flomaster
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A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

e. To revise, click Save.

Create CAE 1D analysis revisions to capture 1D analysis data for Flomaster

You can create CAE 1D Analysis revisions to capture 1D analysis data for integrations such as Simcenter
Flomaster.

You can use the 1D analysis revision to manage system simulation analysis activities, for example,
Amesim and Flomaster, and the associated data from those tasks. When simulation analysts perform
system simulation work, they prefer to store the data in Teamcenter. These 1D system simulation
templates can thereafter be used to create 1D system simulations. The CAE 1D analysis object can be
directly related to a CAE 1D model as well as the physical test result. When connecting to these other
objects, all CAE 1D analyses, which were created based on the CAE 1D model object template, can be
quickly retrieved.

A CAE 1D Analysis revision must always be created in the context of a CAE 1D Model revision.
When you create a CAE 1D Analysis in context, the system links the CAE 1D Analysis revision to
the CAE 1D Model revision and creates the CAE Defining Relationship. It also copies the input and
output parameters from the 1D model revision to the 1D analysis revision, and they are available in
the Parameters tab. The columns in the Parameters table for the 1D model revision are not editable,
whereas some columns are editable for the 1D analysis revision.

Prerequisites

The following procedures assume that the Simulation Process Management with Parameter
Management feature is installed at your site and the simulation administrator has run the quick setup
script (tcsim_quick_setup.pl) to create sample configurations that includes the required Simcenter
Flomaster tool.

Procedure

1. Log on by using the default workspace or the analyst workspace.

Note:

The Analyst workspace is the recommended workspace for the simulation analyst role.

2. Select the previously created CAE 1D Model revision and choose More Commands > New  >
Create Simulation.

3. Specify a name for the 1D analysis revision and click Create.

4. Create 1D model and 1D analysis objects for simulations
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4. Create the input and output parameters for the analysis by launching a preconfigured simulation
tool.

For more information about launching tools, see Launch simulation tools.

You launch a preconfigured simulation tool to perform the analysis. The analysis tool updates the
parameter information from the results to the JSON file format. The system rewrites the PLM XML
file with the updated parameter information. The results are then imported to Teamcenter from the
PLM XML file.

Note:

When you create a 1D analysis revision within the context of a 1D model revision, the system
automatically copies the input and output parameters from the 1D model revision to the 1D
analysis revision.

a. Select the 1D analysis revision, click Open>Open in Simulation Tool, and select Simcenter
Flomaster.

For more information about launching tools, see Launch simulation tools.

b. In the Launch Inputs tab, specify the launch method and other parameters.

c. Select the Create Analysis launch type.

d. To launch the tool, click Open.

5. After the tool launch is complete, to view the input and output parameters, click the Parameters
tab.

6. Execute the analysis in Simcenter Flomaster on the desktop by launching a preconfigured
simulation tool.

a. Select the previously created 1D analysis revision, click Open>Open in Simulation Tool, and
select Simcenter Flomaster.

For more information about launching tools, see Launch simulation tools.

b. In the Launch Inputs tab, specify the launch method and other parameters.

c. To perform an analysis, select the Update Analysis launch type since have the previously
created 1D analysis revision containing the input parameters.

d. To launch the tool, click Open.

Create CAE 1D analysis revisions to capture 1D analysis data for Flomaster
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e. To verify the changed parameter values, click the Parameters tab after the tool launch is
complete.

7. Release the analysis revision.

After all the work related to analysis revision is complete, you can release the analysis revision
using a workflow.

a. Select the analysis revision you want to release and choose More Commands > Manage >
Submit to Workflow.

b. Select the TCM Release Process template and click Submit.

8. (Optional) To view ID related models, select the 1D analysis revision, and click the Overview tab.

9. (Optional) Create external links or folders for the 1D analysis revision.

a. Select the revision and click the Overview tab.

b. Click Add to  in EXTERNAL LINKS.

c. Select PROPERTIES, specify a name and the URL or a shared location, and then click Add.

d. To delete a web link, select the web link, click Edit, and select Delete External Links.

10. (Optional) View traceability of simulation data using the Relations tab.

It allows you to view and navigate the relations between different objects in a graphical view.

11. Make a copy of the 1D analysis revision.

a. Select the 1D analysis revision.

b. Choose More Commands > New   > Save As .

c. (Optional) Specify a new name if you want to create a copy and description.

d. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

4. Create 1D model and 1D analysis objects for simulations
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e. To create a copy, click Save.

12. Revise the 1D analysis revision.

a. Select the 1D analysis revision.

b. Choose More Commands > New   > Revise .

c. (Optional) Specify required information as appropriate.

d. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

e. To revise, click Save.

Workflow for Amesim and System Architect

Workflow for managing 1D data in Simcenter Amesim or Simcenter System
Architect

One-dimensional computer-aided engineering (1D CAE) modeling is used to explore different concepts
at the early stages of the design. This is usually done even before any CAD geometry is available. The
parameters for these models can be refined, and the details can be added later when they are available.
1D models are precursors to the detailed 3D CAE models in the entire design cycle.

You can create CAE 1D Model and CAE 1D Analysis revisions to capture model and analysis data for
integrations such as Simcenter Amesim or Simcenter System Architect. The CAE 1D Analysis revision
must always be created in the context of the CAE 1D Model revision.

The workflow for managing 1D data in Simcenter Amesim or Simcenter is as follows:

Workflow for managing 1D data in Simcenter Amesim or Simcenter System Architect
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Create CAE 1D model revisions to capture 1D model data for Amesim or
System Architect

You can create CAE 1D Model revisions to capture 1D model data for integrations such as Simcenter
Amesim or Simcenter System Architect.

Create the CAE 1D model revision

1. In the default workspace or the analyst workspace, create a model revision in the context of a
design or item revision, project model revision, or NX P&ID Designer revision.

4. Create 1D model and 1D analysis objects for simulations
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• (Amesim or System Architect) Search for a design revision or item revision, open it, click the
Overview tab, and choose More Commands > New > Create Simulation > CAE 1D Model.

OR

• (System Architect) Search for a project model revision, open it, and choose More Commands >
New > Create Simulation > CAE 1D Model.

2. Specify a name for the 1D model revision and click Create.

3. (Optional) To view related objects, click the Overview tab.

The Related Objects section displays the source and target relationship between the object based
on which this model revision was created.

4. Export the Amesim or System Architect model file to the model revision by launching a
preconfigured simulation tool.

a. (Analyst workspace) Select the 1D model revision and choose Open in Simulation Tool .

(Default workspace) Select the 1D model revision and choose Open  > Open in Simulation
Tool .

b. Select a preconfigured simulation tool for Amesim or System Architect.

c. In the Launch Inputs tab, specify the launch method and other parameters.

d. In the Help tab, access the documentation for simulation tool configuration.

5. To view parameters after the tool launch is complete, click the Parameters tab.

The Input Parameters and Output Parameters sections display the various parameters of the
imported model.

The system copies the parameters to the 1D analysis revision when you create it in the context of
the 1D model revision.

6. (Optional) To view additional columns in the Input Parameters table, click Table Settings >
Arrange and add columns such as Formula, Max, Max Operator, Min, Min Operator, and Units.

Similarly, you can add additional columns to the Output Parameters table such as Goal, Goal File,
Max, Max Operator, Min, Min Operator, and Units.

7. To view all related test objects, click the Physical Test tab.

8. (Optional) Create external links or folders for the 1D model revision.

Create CAE 1D model revisions to capture 1D model data for Amesim or System Architect
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a. Select the revision and click the Overview tab.

b. Click Add to  in EXTERNAL LINKS.

c. Select PROPERTIES, specify a name and the URL or a shared location, and then click Add.

d. To delete a web link, select the web link, click Edit, and select Delete External Links.

9. Upload data using predefined rules.

You can upload data for integrations such as Amesim or System Architect.

a. Select the revision and click the Files tab.

b. Click Upload File, select a predefined file upload rule, and choose the file you want to upload.

c. Upload or download files using predefined rules (without Data Share Manager).

OR

Upload or download files using predefined rules (with Data Share Manager).

10. (Optional) To view relations between different objects, select the 1D model revision and click the
Relations tab.

It allows you to view and navigate the relations between different objects in a graph view.

11. Verify if objects are out-of-date.

a. Click the Overview tab.

The Out-of-Date Information and Objects section displays objects that are out-of-date.

b. To mark objects as up-to-date, select them and choose More Commands > Edit > Mark
Up-To-Date.

After the analysis is complete and the files are added, the status for these objects is displayed
as Added. You can mark them as up-to-date.

12. Release the 1D model revision after the work is complete..

13. Create CAE 1D analysis revisions to capture 1D analysis data for Amesim or System Architect.

Create a copy of the 1D model revision

You can optionally create a copy of the 1D model revision.

4. Create 1D model and 1D analysis objects for simulations
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1. Select the 1D model revision.

2. Choose More Commands > New   > Save As .

The Save As dialog opens.

3. (Optional) Specify a new name if you want to create a copy and description.

4. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As panel
indicates that folder.

a. Remove the Newstuff folder and click the Add button to select another folder.

b. Select the folder and click Add.

5. To create a copy, click Save.

Revise the 1D model revision

You can revise the 1D model revision.

The model revision is created in the context of a design revision or item revision, project model revision,
or NX P&ID Designer. When the original object based on which the model revision is created undergoes
changes, you can revise the model revision.

1. In the default workspace or the analyst workspace, select the 1D model revision.

2. Choose More Commands > New   > Revise .

3. (Optional) Specify required information as appropriate.

4. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As panel
indicates that folder.

a. Remove the Newstuff folder and click the Add button to select another folder.

b. Select the folder and click Add.

5. To revise, click Save.

Create CAE 1D model revisions to capture 1D model data for Amesim or System Architect
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6. (Optional) Select the model revision and click the Overview tab and remove or add files as per the
revision changes of the object on which this model revision is created.

7. Verify the CAE Status header. The model revision is displayed as out-of-date.

8. To update the status of the model revision, choose More Commands > Edit > Mark Up-To-Date.

Release the 1D model revision after the work is complete

You must release the CAE 1D Model revision after completing your work.

1. In the default workspace or the analyst workspace, open the CAE 1D Model revision you want to
release.

2. Choose More Commands > Manage > Submit to Workflow

3. Select the TCM Release Process template and click Submit.

Search for the input and output parameters for 1D model revisions

You can search for the input and output parameters for 1D model revisions.

1. In the default workspace or the analyst workspace, click Advanced Search and select the
Advanced Search tab.

2. Select CAE 1D Model Revision and specify the search criteria in the input parameter or output
parameter boxes and click Search.

Export the input and output parameters of the 1D model revision

You can optionally export the input and output parameters of the 1D model revision as PLM XML data.

For more information, see Exporting data as PLM XML.

1. In the default workspace or the analyst workspace, open the 1D model revision and choose More
Commands > Share  > PLM XML Export.

2. Select the CAEConfiguredDataFilesExportDefault transfer mode.

3. Specify the configuration rules to use when exporting the objects.

4. (Optional) Specify export languages to export as appropriate.

5. Click Export to create the exported PLM XML file. The export begins and you receive an alert when
the export is complete.

4. Create 1D model and 1D analysis objects for simulations
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Create CAE 1D analysis revisions to capture 1D analysis data for Amesim or
System Architect

You can create CAE 1D Analysis revisions to capture 1D analysis data for integrations such as
Simcenter Amesim or Simcenter System Architect.

A CAE 1D Analysis revision must always be created in the context of a CAE 1D Model revision.
When you create a CAE 1D Analysis in context, the system links the CAE 1D Analysis revision to
the CAE 1D Model revision and creates the CAE Defining relationship. It also copies the input and
output parameters from the 1D model revision to the 1D analysis revision, and they are available in
the Parameters tab. The columns in the Parameters table for the 1D model revision are not editable,
whereas some columns are editable for the 1D analysis revision.

Create the CAE 1D analysis revision

1. In the default workspace or the analyst workspace, select the previously created CAE 1D Model
revision and choose More Commands > New  > Create Simulation.

2. Specify a name for the 1D analysis revision and click Create.

3. (Optional) To view ID related models, select the 1D analysis revision, and click the Overview tab.

4. (Optional) To view the input parameters, click the Parameters tab.

The Input Parameters section displays the parameters that have been carried forward from the 1D
model revision to the 1D analysis revision.

5. (Optional) To view additional columns in the Input Parameters table, click Table Settings >
Arrange and add columns such as Formula, Max, Max Operator, Min, Min Operator, and Units.

1. To view all related test objects, click the Physical Test tab.

2. Perform an analysis by launching a preconfigured simulation tool for Amesim or System
Architect.

a. (Analyst workspace) Select the revision and choose Open in Simulation Tool .

(Default workspace) Select the revision and choose Open  > Open in Simulation Tool .

b. Select a preconfigured simulation tool.

c. In the Launch Inputs tab, specify the launch method and other parameters.

d. In the Help tab, access the documentation for simulation tool configuration.

3. To view the output parameters, click the Parameters tab.

Create CAE 1D analysis revisions to capture 1D analysis data for Amesim or System Architect
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The Output Parameters tab displays the parameters from the analysis.

4. (Optional) To view additional columns in the Output Parameters table, click Table Settings >
Arrange and add columns such as Goal, Goal File, Max, Max Operator, Min, Min Operator, and
Units.

5. To view the analysis related files and images, click the Overview tab.

The Files section displays the analysis related files and images.

6. Verify if the objects are out-of-date.

a. Click the Overview tab.

The Out-of-Date Information and Objects section displays objects that are out-of-date.

b. To mark objects as up-to-date, select them, and choose More Commands > Edit > Mark
Up-To-Date.

After the analysis is complete and the files are added, the status for these objects is displayed
as Added. You can mark them as up-to-date.

7. (Optional) Create external links or folders for the 1D analysis revision.

a. Select the revision and click the Overview tab.

b. Click Add to  in EXTERNAL LINKS.

c. Select PROPERTIES, specify a name and the URL or a shared location, and then click Add.

d. To delete a web link, select the web link, click Edit, and select Delete External Links.

8. (Optional) View traceability of simulation data using the Relations tab.

It allows you to view and navigate the relations between different objects in a graphical view.

9. Release the 1D analysis revision after the work is complete..

Make a copy of the 1D analysis revision

You can optionally make a copy of the 1D analysis revision

1. Select the 1D analysis revision.

2. Choose More Commands > New   > Save As .

4. Create 1D model and 1D analysis objects for simulations
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The Save As dialog opens.

3. (Optional) Specify a new name if you want to create a copy and description.

4. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As panel
indicates that folder.

a. Remove the Newstuff folder and click the Add button to select another folder.

b. Select the folder and click Add.

5. To create a copy, click Save.

Revise the 1D analysis revision

You can revise the 1D analysis revision.

The analysis revision is created in the context of the model revision. When the model revision undergoes
changes, you can revise the analysis revision.

1. In the default workspace or the analyst workspace, select the 1D analysis revision.

2. Choose More Commands > New   > Revise .

The Revise dialog opens.

3. (Optional) Specify required information as appropriate.

4. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As panel
indicates that folder.

a. Remove the Newstuff folder and click the Add button to select another folder.

b. Select the folder and click Add.

5. To revise, click Save.

6. (Optional) Select the 1D analysis revision, click the Overview tab, and remove or add files as per
the revision changes of the object on which this model revision is created.

Create CAE 1D analysis revisions to capture 1D analysis data for Amesim or System Architect
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7. Verify the CAE Status header. The model revision is displayed as out-of-date.

8. To update the status of the model revision, choose More Commands > Edit > Mark Up-To-Date.

Release the 1D analysis revision after the work is complete

You must release the CAE 1D Analysis revision after completing your work.

1. In the default workspace or the analyst workspace, open the CAE 1D Analysis revision you want
to release.

2. Choose More Commands > Manage > Submit to Workflow

3. Select the TCM Release Process template and click Submit.

Search for the input and output parameters for 1D analysis revisions

You can search for the input and output parameters for 1D analysis revisions.

1. In the default workspace or the analyst workspace, click Advanced Search and select the
Advanced Search tab.

2. Select CAE 1D Analysis Revision and specify the search criteria in the input parameter or output
parameter boxes and click Search.

Export the input and output parameters of the 1D analysis revision

You can optionally export the input and output parameters of the 1D analysis revision as PLM XML data.

For more information, see Exporting data as PLM XML.

1. In the default workspace or the analyst workspace, open the 1D analysis revision and choose
More Commands > Share  > PLM XML Export.

2. Select the CAEConfiguredDataFilesExportDefault transfer mode.

3. Specify the configuration rules to use when exporting the objects.

4. (Optional) Specify export languages to export as appropriate.

5. Click Export to create the exported PLM XML file. The export begins and you receive an alert when
the export is complete.

4. Create 1D model and 1D analysis objects for simulations
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Workflow for managing MBSE data mapping for Git integrations

Workflow for managing MBSE data through the GIT integration

After modeling engineers complete their work and the system simulation models are ready to be
released, simulation analysts can import the MBSE data from the Git repository to Teamcenter. The
data that is imported is the released data or the gold copy of the data. The gold copy in the Git
repository contains all the folders and the project files. The supported model files in the Git repository
are converted to CAE 1D models.

The workflow is as follows:

As a prerequisite, the Simulation Process Management with Git integration feature must be installed
using Teamcenter Environment Manager (TEM) or Deployment Center at your site. In addition, the
Teamcenter MBSE Integration Gateway desktop client must be installed and the post-installation
configuration tasks for the desktop client should be complete.

For more information about installing and configuring the desktop client, see Install the Teamcenter
MBSE Integration Gateway desktop client using TEM or Install the Teamcenter MBSE Integration Gateway
desktop client using Deployment Center.

Import the Git repository containing the model files

As a simulation analyst, you can import a gold copy of the model files from the Git repository to
Teamcenter, update the model files whenever a new gold copy is available, download the 1D models to a
local machine, and compare the 1D models.

The gold copy in the Git repository contains all the folders and the project files. The supported model
files in the Git repository are converted to CAE 1D models.

Examples of model files that are converted to CAE 1D models:

Workflow for managing MBSE data through the GIT integration
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• Matlab (*.mdl, *.slx) are generated in the CAE Matlab dataset attached to the CAE 1D Model
revision.

• Amesim (*.ame, *.bame) are generated in the CAE Amesim dataset attached to the CAE 1D Model
revision.

• GTPower (*.gtm, *.bgtm) are generated in the CAE GTPower dataset attached to the CAE 1D Model
revision.

Prerequisites

The following procedures assume that the Simulation Process Management with Git integration
feature and the Teamcenter MBSE Integration Gateway desktop client are installed. In addition, the
post-installation configuration tasks for the desktop client should be complete.

For more information, see Workflow for managing MBSE data through the GIT integration.

Procedure

1. In the default workspace or the analyst workspace, import a gold copy of the CAE 1D models from
the Git repository to Teamcenter.

a. Select or open a folder and choose More Commands > New > Import Model Collection.

The system starts downloading an .opr file.

b. After the download is complete, click to open the file.

The system displays the Import Model Collection dialog.

c. Specify the source link to the Git branch URL and the authentication information to log on to
Git.

The information about the model collection and revision are automatically populated.

The Git branch objects are uploaded to Teamcenter through the MBSE gateway.

d. Click Import.

After the import is successful, a link is displayed in the Import Model Collection dialog.

e. Click the link to open the objects in a new browser tab.

The structure is displayed in the Content tab. It is identical to the Git folder structure.

4. Create 1D model and 1D analysis objects for simulations
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The model files such as Amesim, Matlab, and GTPower are imported as CAE 1D models, the
Branch Folder as Model Collection Folder, and the Branch Revision as Model Collection.

f. To view the generated CAE 1D model files, click the Overview tab.

The Files section displays the CAE dataset containing the CAE 1D model files.

2. Update the 1D models from the Git repository to Teamcenter whenever a new gold copy is
available.

a. Select and open an existing model collection in the Content tab. A tree structure is displayed
and you can select the top level object.

b. Choose More Commands > Manage > Update Model Collection.

The system starts downloading an .opr file.

c. After the download is complete, click to open the file.

The system displays the Update Model Collection dialog.

d. Specify the source link to the Git branch URL and the authentication information to log on to
Git.

The information about the model revision is automatically populated.

The Git branch objects are updated to Teamcenter through the MBSE gateway.

e. Click Update.

After the update is successful, a link is displayed in the Update Model Collection dialog.

f. Click the link to open the objects in a new browser tab.

The structure is displayed in the Content tab. It is identical to the Git folder structure.

The model files such as Amesim, Matlab, and GTPower are updated as CAE 1D models, the
Branch Folder as Model Collection Folder, and the Branch Revision as Model Collection.

g. To view the generated CAE 1D model files, click the Overview tab.

The Files section displays the CAE dataset containing the CAE 1D model files.

3. Download the 1D models from Teamcenter to a local machine.

a. Select and open an existing model collection.

Import the Git repository containing the model files

Simulation Process and Data Management on Active Workspace ─ Usage, Teamcenter 2412  4-21
© 2025 Siemens



b. Choose More Commands > Share > Download Model Collection.

The system starts downloading an .opr file.

c. After the download is complete, click to open the file.

The system displays the Download Model Collection dialog. This dialog contains the link to a
local folder where the structure was downloaded.

d. Click the link to navigate to the folder where the structure was downloaded on the local
machine.

The system creates the appropriate folder structure corresponding to the structure locally in
the configured folder, for example, C:\bhm\staging. It is identical to the Git folder structure.

4. Extract the SSV parameters by using a preconfigured simulation tool.

SSV is a format for saving tabular data. It contains the attributes that can be extracted to the 1D
model revision.

Currently, the SSV files from Git are not automatically mapped to CAE 1D models. You must map it
manually.

a. Select and open an existing model collection.

b. (Optional) Select the CAE 1D Model revision from the Content tab.

c. Choose Open  > Open in Simulation Tool .

d. Select the Extract Parameters (SSV) tool and launch the tool.

For more information about launching tools, see Launch simulation tools.

5. Compare 1D models that you have downloaded from Teamcenter to the local machine.

For more information, see Compare structures using the guided update to view the differences
by generating a report.

Mark 1D model revisions as up-to-date for changes to attachments
and related revisions

As a simulation analyst, you can mark 1D model revisions as up-to-date for changes to attachments and
related revisions.

4. Create 1D model and 1D analysis objects for simulations
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In a complex product development environment, different analysts perform different tasks of the overall
analysis. For example, abstractions are delivered by one group, models built by another group, and load
cases defined by another group. In such scenarios, it becomes critical to know when the analysis data,
possibly with multiple dependencies, is out-of-date. The analyst can then act on it and ensure that the
analysis is built with the correct set of data to deliver accurate results.

If the related revisions of a 1D model revision undergo a revision change or updates to parameters or
materials, the CAE status of the 1D model revision shows as out-of-date. In such cases, you can use
the Mark Up-To-Date command to update to the latest revisions and mark the 1D model revision as
up-to-date.

You can also view the CAE status of released 1D model revisions if the
CAE_allow_cae_status_on_released_objects site preference is set to true at your site.

Procedure

1. Open a CAE 1D Model Revision from the appropriate folder in Explorer.

Alternatively, search for a 1D model revision and open it.

The header section displays the CAE status as Up-to-date or Out-of-date.

2. If the status is out-of-date, hover your mouse over the status. The system displays a tooltip.

The tooltip provides the reason for the revision being out-of-date.

Note:

Baselined revisions are not considered as newer revisions.

3. Click the Out-of-date hyperlink.

The system opens the Overview tab. The Out-of-Date Information and Objects section displays
the status and the reason why the related revision is out-of-date.

4. Click Edit  and select Mark Up-To-Date.

Mark 1D analysis revisions as up-to-date for changes to
attachments and related revisions

As a simulation analyst, you can mark 1D analysis revisions as up-to-date for changes to attachments
and related revisions.

In a complex product development environment, different analysts perform different tasks of the overall
analysis. For example, abstractions are delivered by one group, models built by another group, and load
cases defined by another group. In such scenarios, it becomes critical to know when the analysis data,

Mark 1D analysis revisions as up-to-date for changes to attachments and related revisions
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possibly with multiple dependencies, is out-of-date. The analyst can then act on it and ensure that the
analysis is built with the correct set of data to deliver accurate results.

If the related revisions of a 1D analysis revision undergo a revision change or updates to parameters or
materials, the CAE status of the 1D analysis revision shows as out-of-date. In such cases, you can use
the Mark Up-To-Date command to update to the latest revisions and mark the 1D analysis revision as
up-to-date.

You can also view the CAE status of released 1D analysis revisions if the
CAE_allow_cae_status_on_released_objects site preference is set to true at your site.

Procedure

1. Open a CAE 1D Analysis Revision from the appropriate folder in Explorer.

Alternatively, search for a 1D analysis revision and open it.

The header section displays the CAE status as Up-to-date or Out-of-date.

2. If the status is out-of-date, hover your mouse over the status. The system displays a tooltip.

The tooltip provides the reason for the revision being out-of-date.

Note:

Baselined revisions are not considered as newer revisions.

3. Click the Out-of-date hyperlink.

The system opens the Overview tab. The Out-of-Date Information and Objects section displays
the status and the reason why the related revision is out-of-date.

4. Click Edit  and select Mark Up-To-Date.

4. Create 1D model and 1D analysis objects for simulations
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5. Create geometry revisions for the
components you want to analyze
Create geometry revisions for the components you want to analyze

1. (Default workspace) Open the product item revision for which you want to create a corresponding
geometry revision, and click the Simulation tab.

(Analyst workspace) Open the product item revision for which you want to create a corresponding
geometry revision, and click the Overview or Simulation tab.

2. Choose More Commands > New  > Create Simulation.

3. Select CAE 3D Geometry and then type a name for the geometry revision.

4. (Optional) Select a preconfigured analysis type, for example, Structural or Thermal.

5. (Optional) Select a preprocessor, for example, NX or Catia.

6. (Optional) Specify a project ID or click Add Project  and select a project.

7. To create the geometry revision, click Create.

8. Create a geometry structure manually.

You can do this by creating a geometry structure manually by creating child geometry revisions as
appropriate.

Alternatively, you can automatically generate a geometry structure using data mapping rules.

a. Open the geometry revision and click the Content tab.

b. Choose More Commands > New  > Child.

c. (Mandatory) Specify a name for the child geometry revision.

d. (Optional) Select or specify other options as appropriate.

e. To create the child geometry revision, click the Add button.
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Generate a geometry structure using data mapping rules

You can generate a geometry structure from an existing product structure or a product collector that
contains CAD assemblies. You can do this by selecting the CAEGA domain while running data map
rules. The system creates a CAEGA-source_product_structure_name structure. This structure contains
corresponding CAEGA-BOM_Line_Name geometry items for each generic item in the product structure.

1. Generate a geometry structure from the product structure.

a. Search for and open the product structure (item revision).

b. (Optional) Apply configuration rules as appropriate to the product structure.

c. Choose More Commands > New  > Generate CAE Structure.

d. To generate a geometry structure, select the Data Map option, select the CAEGA domain, and
click Execute.

The default domain is CAE.

2. Generate a model structure from the geometry structure.

a. Open the geometry structure (item revision) in the Overview tab.

b. Choose More Commands > New  > Generate CAE Structure.

In the Generate CAE Structure panel, select one of the following options:

• Data Map to create a model structure that is an exact replica of the product structure
by using data map rules.

5. Create geometry revisions for the components you want to analyze
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After creating the model structure, you can use predefined derivative rules in CAE Manager
(rich client) to derive one more structures relevant to your analysis from an existing
structure.

• CAE Structure Map to create a model structure that is an exact replica of the product
structure by using data map rules.

c. Select the CAE domain. This is the default domain.

d. To generate a model structure, click Execute.

3. Generate a model structure with JT files mapped from the geometry structure.

a. Open the geometry structure (item revision) in the Overview tab.

b. Choose More Commands > New  > Generate CAE Structure.

In the Generate CAE Structure panel, select one of the following options:

• Data Map to create a model structure that is an exact replica of the product structure
by using data map rules.

After creating the model structure, you can use predefined derivative rules in CAE Manager
(rich client) to derive one more structures relevant to your analysis from an existing
structure.

• CAE Structure Map to create a model structure that is an exact replica of the product
structure by using data map rules.

c. Select the CFD domain.

When you choose the CFD domain, the JT files are mapped from the geometry structure to the
model structure.

d. To generate a model structure, click Execute.

4. Create analysis revisions from predefined analysis packages or CAE packages and analyze results.

a. Open the model structure (item revision) in the Overview tab.

b. Choose More Commands > New  > CAE Package.

c. From the Results panel, open a site package.

d. Specify input, output, and other parameters as appropriate and click Execute.

Generate a geometry structure using data mapping rules
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e. Capture and verify the results.

Import the product geometry using a preconfigured tool

1. Navigate to the CAE 3D Geometry item revision you have created, select it, and click Open .

(Optional) After you search for simulation item revisions, you can select multiple geometry item
revisions and launch a preconfigured tool to import the product geometry.

2. Click the Overview tab.

3. Access help for a launch tool.

a. (Analyst workspace) Choose Open in Simulation Tool .

(Default workspace) Choose Open  > Open in Simulation Tool .

b. Select the tool, click Open in New Tab , and click Help.

(Optional) To download the help, click Description File and select Download File.

4. Add a launch tool to your favorites.

a. (Analyst workspace) Choose Open in Simulation Tool .

(Default workspace) Choose Open  > Open in Simulation Tool .

b. Select the tool, click Open in New Tab , and click Manage  > Add to Favorites.

5. To import the product geometry using a preconfigured tool, launch a simulation tool.

Note:

If you do not have preconfigured simulation tools, import the product geometry from the
CAD model to a local machine, simplify the geometry using a simplification tool, and upload
it to the geometry revision you created.

Simplify the product geometry using a simplification tool

The CAD model is used to define the geometry of a part or an assembly. During the final stages of
the design process, the geometry contains numerous details, such as sharp edges, bolt holes, or fillets,
which are not required for the analysis. You can import the geometry and use any third-party tool to
simplify the geometry before defining a mesh.

5. Create geometry revisions for the components you want to analyze
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Create external links or folders for geometry revisions

You can create external links to files or folders that are managed outside the database but are tracked
from Teamcenter.

1. Navigate to the CAE 3D Geometry revision you have created, open it, and click the Overview tab.

2. Click Add to  in EXTERNAL LINKS.

3. Select PROPERTIES, specify a name and the URL or a shared location, and then click Add.

4. To delete a web link, select the web link, click Edit, and select Delete External Links.

Add a related revision to a geometry revision

1. Open a geometry analysis from the appropriate folder in Explorer.

Alternatively, search for a geometry revision and open it.

2. To view all related CAE revisions in the context of the geometry revision, click the Overview tab.

The Related Objects section displays a pie chart that summarizes the number and types of related
simulation objects and a table that displays all the related simulation objects.

You can hover over the pie chart slice to view the number of related simulation objects to the
simulation object you have selected. You can also select or deselect the appropriate related objects
under the pie chart to hide or display those objects from the chart.

Note:

The count displayed for various related simulation objects is based on the number of related
objects in the database. It does not change based on filtration.

You can filter the data within the table columns to see only the data that is relevant to you.

For more information, see Filter data in a table column in Active Workspace Fundamentals.

3. To view traceability information, select a related revision in the Related Objects table.

The TRACEABILITY INFORMATION section displays how the selected revision is related to other
revisions.

4. To view related revisions and their relationships, click the Overview tab.

Create external links or folders for geometry revisions
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5. To add a related object, click Add Simulation , select a revision from the Add Simulation panel,
and click the Add button.

View the associated material revisions of the product structure in a
geometry revision

You can view associated material revisions of the product structure in a geometry revision.

Procedure

1. Open a product structure with associated material revisions.

2. Generate a geometry structure by using data map rules.

a. Choose More Commands > New  > Generate CAE Structure.

b. To generate the geometry structure, select the Data Map option and the CAEGA domain.

3. Open the generated geometry structure, select a BOM line, and choose the Materials tab.

The system displays the material object related to the product structure. Open the material object
and choose the Where Used tab. It displays the geometry revision as one of the referenced items.

4. Open the generated geometry structure, select a BOM line, and choose the Relations tab.

The system displays the source and target relations of the material object to the geometry revision
and the related product structure.

Mark 3D geometry revisions as up-to-date for changes to
attachments and related revisions

If 3D geometry revisions and their related revisions undergo changes related to revisions, attachments,
parameters, or materials, you can use the Mark Up-To-Date command to mark the 3D geometry
revisions as up-to-date.

You can also view the CAE status of released 3D geometry revisions if the
CAE_allow_cae_status_on_released_objects site preference is set to true at your site.

Procedure

1. Open a 3D geometry revision and mark it as up-to-date.

a. Open a CAE 3D Geometry Revision from the appropriate folder in Explorer.

5. Create geometry revisions for the components you want to analyze
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Alternatively, search for a 3D geometry revision and open it.

The header section displays the CAE status as Up-to-date or Out-of-date.

b. If the status is out-of-date, hover your mouse over the status. The system displays a tooltip.

The tooltip provides the reason for the revision being out-of-date. For example, the dependent
attachment has been modified.

c. Click the Out-of-date hyperlink.

The system opens the Overview tab. The Out-of-Date Information and Objects section
displays the status and the reason why the related revision is out-of-date.

d. Click Edit  and select Mark Up-To-Date.

Note:

If attachments or related objects are attached with the relationship specified in
the CAE_significant_relation_types_for_CAEGeometry site preference and they get
updated, modified, or revised, then the CAE status on the 3D geometry revision changes
to out-of-date. The default values for this preference are CAE Source, CAE Target, NX
Simulations, and Specifications.

2. Search for multiple geometry revisions and mark them as up-to-date.

a. Search for multiple CAE geometry revisions.

b. Select the geometry revisions you want to mark as up-to-date and click Edit > Mark Up-To-
Date.

Make a copy of the 3D geometry revision or revise it

You can make a copy of the of the 3D geometry revision or revise it.

Procedure

1. Make a copy of the 3D geometry revision.

a. Select the 3D geometry revision.

b. Choose More Commands > New   > Save As .

The Save As dialog opens.

c. (Optional) Specify a new name if you want to create a copy and description.

Make a copy of the 3D geometry revision or revise it
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d. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

e. To create a copy, click Save.

2. Revise the 3D geometry revision.

a. Select the 3D geometry revision.

b. Choose More Commands > New   > Revise .

c. (Optional) Specify required information as appropriate.

d. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

e. To revise, click Save.

5. Create geometry revisions for the components you want to analyze
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6. Create the simulation model and define a
mesh
Create simulation models

1. Open the product structure you want to analyze

An engineering manager reviews design requirements and assigns design changes for validation
to a simulation analyst using a workflow. The workflow contains the design requirements,
configuration information, subassembly, and components required for analysis.

2. Configure the product structure

If you work in a product environment with a lot of variability, such as the automobile industry, you
can apply revision rules, effectivity, or variant rules to make the product structure relevant to your
analysis.

3. Apply predefined data map rules

The simulation administrator defines the data map rules.
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Based on these rules, the system creates model revisions for each generic item revision in the
product structure, names the resulting model revisions with the default CAE prefix, and defines
default relationships between product revisions, geometry revisions, and model revisions.

4. Apply predefined structure map rules

The lead analyst or the designated analyst creates structure map rules.

In an organization, different groups of analysts perform different types of analyses. There are
specialists for NVH analysis, thermal analysis, and durability analysis. The lead analyst creates many
types of structure map rules. You can use this option to create a model structure for a specific type
of analysis.

Typically, the model structure is similar to the, but not the same as the product structure. Structure
map rules allow you to remove BOM lines from the product structure based on filter criteria,
reuse existing model revisions for a part that has been previously analyzed, and create new model
revisions for the new parts you want to analyze. In addition, these rules help define default
relationships between product revisions, geometry revisions, and model revisions.

5. Create different simulation models

You can apply predefined structure map rules to the product structure to create different types
of models for different types analysis. You can create different models to perform NVH analysis,
thermal analysis, durability analysis, and so on.

Different ways to generate simulation models

If you are analyzing a small product structure with few components, you can create model revisions
individually for each component. However, if you are analyzing a large product structure with many
components, you can create the complete model structure using the Data Map or the CAE Structure
Map option.

• Create a model structure for a specific type of analysis, using the CAE Structure Map option.

The lead analyst or the designated analyst creates structure map rules.

In an organization, different groups of analysts perform different types of analyses. There are
specialists for NVH analysis, thermal analysis, and durability analysis. The lead analyst creates many
types of structure map rules. You can use this option to create a model structure for a specific type of
analysis.

Typically, the model structure is similar to the, but not the same as the product structure. Structure
map rules allow you to remove BOM lines from the product structure based on filter criteria, reuse
existing model revisions for a part that has been previously analyzed, and create new model revisions
for the new parts you want to analyze. In addition, these rules help define default relationships
between product revisions, geometry revisions, and model revisions.

6. Create the simulation model and define a mesh
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• Create a model structure that is an exact replica of the product structure, using the Data Map
option.

The simulation administrator defines the data map rules.

Based on these rules, the system creates model revisions for each generic item revision in the product
structure, names the resulting model revisions with the default CAE prefix, and defines default
relationships between product revisions, geometry revisions, and model revisions.

• Interactively select specific BOM lines.

Interactively select specific BOM lines, particularly when filter or skip rules are not available but all
other rules are available in the structure map rule.

When you select the Data Map or the CAE Structure Map option, the system asynchronously executes
this command on the Teamcenter server and you can continue working. The system sends an email
notification after successful completion or failure. If successful, the system creates the model structure
and places it in the configured output folder in the rich client. You can search for this structure and open
it.

Create model revisions manually

You can create model revisions manually and view and rearrange the model revision properties.

1. Create model revisions manually

a. Search for the geometry revision you created earlier, open it, and click the Overview tab.

b. Choose More Commands > New  > Create Simulation.

c. Select CAE 3D Model and type a name for the model revision.

d. (Optional) Type a description.

e. (Optional) Select a preconfigured analysis type, for example, Structural or Thermal.

f. (Optional) Select a preconfigured solver, for example, NXNastran or Ansys.

g. (Optional) Specify a project ID or click Add Project  and select a project.

h. To create the model revision, click the Add button.

2. View and rearrange the model revision properties

a. Open a model revision and click the Content tab.

Create model revisions manually
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b. Click the Configuration icon above the model revision table and select Arrange.

The properties that are available in the Content tab by default have a tick mark associated
with them.

c. (Optional) To include a property that is not available by default, select the property by
selecting it and click the Arrange button.

When you select a property, a tick mark appears beside it.

d. (Optional) To rearrange properties, select a property and click Move up or Move down and
click the Arrange button.

Generate a model structure for a specific type of analysis using
structure map rules

1. Open a product structure (item revision) by performing a search.

2. (Optional) Apply configuration rules as appropriate.

3. Choose More Commands > New  > Generate CAE Structure.

4. Select CAE Structure Map and click Add CAE Structure Map .

5. Select a structure map from the Palette and click Add.

Alternatively, click Search, search for a structure map, select it, and click Add.

6. To create a model structure for a specific type of analysis, click Execute.

If the lead simulation analyst has configured predefined simulation tools while creating structure
map rules, the system creates the model structure and executes the simulation tools defined as
part of the rules. The Simulation Tool Progress Monitor dialog box displays the status of the tool
launch.

Generate a model structure that is an exact replica of the product
structure

1. Search for and open the product structure (item revision).

2. (Optional) Apply configuration rules as appropriate.

3. Click the Content tab.

6. Create the simulation model and define a mesh
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4. Choose More Commands > New  > Generate CAE Structure.

5. Select Data Map and select one of the following domains.

• CAE

This is the default domain.

Select this domain to generate a model structure from an existing product structure.

The system creates a CAE-source_product_structure_name structure. This structure contains
a corresponding CAE-BOM_Line_Name item revision for each generic item in the product
structure.

• CFD

Select this domain to generate a model structure from an existing product structure with the
mapping of JT files from the source structure to the output structure.

This domain option is similar to the default CAE option. It additionally maps the JT files.

The system creates a CFD-source_product_structure_name structure. This structure contains a
corresponding CFD-BOM_Line_Name item revision for each generic item in the product structure
with the JT mapping, if the item revisions in the product structure contain the JT files.

• CAEGA

Select this domain to generate a geometry structure from an existing product structure or a
product collector that contains CAD assemblies.

Generate a model structure that is an exact replica of the product structure
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The system creates a CAEGA-source_product_structure_name structure. This structure contains
a corresponding CAEGA-BOM_Line_Name geometry item for each generic item in the product
structure.

For all the domain options, the system creates a TC_CAE_Target relationship between the source
and the output item revisions and a TC_CAE_Source relationship between the source and output
item revisions, if the output is not a subassembly.

The simulation administrator creates domains. Your organization might have different CAE
disciplines for safety, durability, and so on. The organization wants the data mapping to be different
for each discipline, but there is only one data map XML file for the whole site. Domains are created
to handle data mapping differently in such situations.

6. To create a model structure that is an exact replica of the product structure, click Execute.

7. (Optional) Create analysis revisions from predefined analysis packages or CAE packages and analyze
results.

a. Open the model structure (item revision) in the Overview tab.

b. Choose More Commands > New  > CAE Package.

c. From the Results panel, open a site package.

d. Specify input, output, and other parameters as appropriate and click Execute.

e. Capture the results and verify the results.

Generate a model structure by selecting specific BOM lines in a
product structure

You can interactively select specific BOM lines, particularly when filter or skip rules are not available but
all other rules are available in the structure map rule.

Example:

Let us assume that there is a skip rule to ignore all bolts in a structure. While interactively selecting
BOM lines, even if you select a BOM line that has the bolt as its part by mistake, the system does
not process this BOM line while creating the model structure.

1. Open a product structure (item revision) by performing a search.

2. (Optional) Apply configuration rules as appropriate.

3. Select the BOM lines for which you want to generate a model structure.

6. Create the simulation model and define a mesh
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• If you select the root level structure, the system processes all the subassemblies and their
children at their levels.

• If you select a subassembly, the system processes all its children at all levels.

• If you select a subassembly and select some children, the system processes the selected
children and all other children in the same subassembly. It ignores all other children of other
subassemblies.

• If you select Child1 from subassembly1, even though the same child and subassembly occurs in
another assembly, the system filters out the other assembly.

4. Choose More Commands > New  > Generate CAE Structure.

You can create a model structure by using data mapping rules or structure map rules.

5. Select one of the following options:

• Data Map to generate a model structure by using data map rules.

• CAE Structure Map to generate a model structure by using structure map rules.

6. To generate the model structure, click Execute.

Generate a model structure using preconfigured material revision
mapping and export material information

You can generate a model structure from a product structure that contains material revisions, export the
material information, and use the exported material information to perform a simulation analysis.

As a prerequisite, Teamcenter Materials Management must be installed for exporting material
information.

The process flow for exporting the material information is as follows:

Generate a model structure using preconfigured material revision mapping and export material information
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1. Generate a model structure using preconfigured material revision mapping.

The generated model structure references the material revisions from the product structure.

a. Open a product structure (item revision) with material revisions by performing a search.

b. (Optional) Apply configuration rules as appropriate.

c. Click the Content tab.

d. Choose More Commands > New  > Generate CAE Structure.

You can create a model structure by using data mapping rules or structure map rules.

e. Generate a model structure by using data map rules or by using structure map rules.

6. Create the simulation model and define a mesh
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f. Open the model structure and verify if the structure is created as per the data map rules or
structure map rules.

g. (Optional) Open the model structure and verify if the system has created references between
the output model structures and the material revisions attached to the source product
structure.

h. (Optional) Copy material revision properties.

A. Copy the material revision attached to the source product structure and paste it to the
model or the geometry revision that has a Materials relation.

B. In the Enter the values for Properties on Relation dialog box, specify the mass and the
unit of measure, for example, grams.

2. Run a preconfigured simulation tool to export the material information.

a. Open the model revision you generated with material revisions.

b. Launch a preconfigured simulation tool for exporting material information.

c. Open the log file and verify it.

After the tool is launched, the material file is exported to the same directory as the input files.
The log file of the material export is located in the logs directory of the scratch location.

3. Perform the simulation analysis with the exported material information and capture results.

The analysis tool uses the exported material information for running the analysis.

a. Perform the analysis by running a preconfigured analysis tool, for example, Simcenter
STAR-CCM+. The analysis tool uses the exported material information for running the analysis.

b. Capture the results from the solver, verify the results, and send recommendations.

Compare structures

Compare the model structure and the associated product structure

You can compare the model structure and the associated product structure and automatically update the
model structure or view the differences between them.

Let us assume a scenario where you receive a product structure for analysis. You apply data map rules to
the product structure and create the model structure or the mesh assembly. You also generate meshes
with connections, define load cases, and perform a solve.

Compare the model structure and the associated product structure
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Later, you are notified that there are some minor changes to the product structure. Instead of recreating
the complete model structure, you decide to compare the existing model structure with the changed
product structure, understand the changes, and make updates to the existing model structure. You
compare both structures to find if any new components are added, removed, or revised, and take
subsequent actions to update the model structure.

You can:

Compare structures using the guided update to view the differences by generating a report; OR

Compare structures and automatically update the model structure

Compare structures using the guided update to view the differences by
generating a report

You can compare the model structure and the associated product structure to view the differences
between them by using the Guided Update option to generate a report of the differences.

Procedure

1. Open the model structure and choose Compare > Simulation.

In the default workspace, the system automatically opens the associated product structure and
displays the model structure and the product structure side-by-side in Split View.

In the Analyst workspace, the comparison opens side-by-side in Split View in the Compare
Simulation location.

2. In the Comparison Setting panel, choose Guided Update and select comparison options as
appropriate.

Select this
option... To...
Select All Select all comparison options.
Model with
Newer Product
Revision

Determine if the model BOM line is linked to a newer revision of the product
BOM line. This is to find out if any CAE models are out-of-date based on
revision.

Model with
Additional
Components
than Product
Revision

Determine if the number of model BOM lines is more than the number of BOM
lines of the linked product structure.

Model without
Product Revision

Determine whether the model structure BOM lines are not linked to any
product structure BOM lines in the model structure. This is to find out if any
models do not contain any CAD data or deleted product item revisions.

6. Create the simulation model and define a mesh

6-10  Simulation Process and Data Management on Active Workspace ─ Usage, Teamcenter 2412
© 2025 Siemens



Select this
option... To...
Model with
updated Product
Revision

Determine whether the source product structure BOM has been updated. The
product is considered as updated if there are changes to the last modified date
in any of the BOM lines or to the transformation information in any of the
BOM lines or assembly components.

Note:

The initial values for the last modified date and transformation
information are stored within each BOM line of the model structure
when the model is created from the product structure using data
map rules. This information is stored on the model only when the
CAE_enable_mark_up_to_date option is set to True before running
data map rules on the product structure.

Product without
Model Revision

Determine whether the BOM lines in the product structure are not linked to
any BOM lines in the model structure. This is to find out if any source product
does not have a linked model.

3. Click the Compare option in the Compare Simulation panel.

The system displays a message saying that the process is initiated and an alert will be sent when
the process is complete.

4. Click Alerts and open Execution Summary when it is available.

Compare structures using the guided update to view the differences by generating a report
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5. Download the CAE BOM Compare Execution Summary report from the Target Object section of
Execution Summary and open it.

The report displays the names of the model and product structure, the time stamp, the total
lines processed and not processed. Additionally, it displays information about the failed criteria in
distinct colors. The actual comparison is displayed in the table of the report.

6. Create the simulation model and define a mesh
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Note:

If the CAE Model Structure has CAE boundary condition BOM lines, then those BOM lines
from the model structure are not considered for the BOM comparison. However, these BOM
lines are displayed in the comparison report with a white background.

6. (Optional) In the default workspace, to select another comparison option, click More Commands >
View > Compare Simulation, and choose the appropriate options from the Comparison Settings
panel.

In the Analyst workspace, click the Compare button above the structures in Split View.

Compare structures and automatically update the model structure

You can compare the model structure and the associated product structure and update the model
structure automatically by choosing the Automatic Update option.

Procedure

1. Open the model structure and choose Compare > Simulation.

Compare structures and automatically update the model structure
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In the default workspace, the system automatically opens the associated product structure and
displays the model structure and the product structure side-by-side in Split View.

In the Analyst workspace, the comparison opens side-by-side in Split View in the Compare
Simulation location.

2. To update the model structure automatically, select Automatic Update in the Comparison Setting
panel.

3. Accept the default selection for the Run Data Map check box for all the comparison scenarios.

4. Choose Select All to select all the comparison options with their default update actions.
Alternatively, select one of the following comparison options as described in the subsequent steps.

The AWC_CAE_Update_Structure_Default_Actions user preference determines the default
update actions for the comparison options.

6. Create the simulation model and define a mesh
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5. Select the appropriate update action based on the scenario.

Scenario Update action to perform
The BOM line in the source product
structure that has a newer revision and
the corresponding BOM line in the model
structure has an older revision.

To update the model and create a relation to
the newer revision of the product BOM line
without changing the revision of the model,
choose the Model with Newer Product
Revision comparison option and select the
Update and Sync Model update action.

Compare structures and automatically update the model structure
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Scenario Update action to perform
For more information, see Example 1:
Update and sync the model for a newer
product revision.
To revise the model and create a relation
to the newer revision of the product BOM
line, choose the Model with Newer Product
Revision comparison option and select the
Revise the Model update action.

For more information, see Example 2: Revise
the model for a newer product revision.
To create a new model and create a relation
to the newer revision of the product BOM
line, choose the Model with Newer Product
Revision comparison option and select the
Create a New Model update action.

For more information, see Example 3: Create
a new model for a newer product revision.

The BOM line in the source product structure
that has one of the attributes, such as
Description, updated and the corresponding
BOM line in the model structure does not
have a description.

To update the description in the BOM line,
choose the Model with Updated Product
Revision comparison option and select the
Sync Model update action.

For more information, see Example 4: Sync
the model for an updated product revision.

The source product structure has an
additional BOM line and that is not available
in the model structure.

To create a new model for the additional
BOM line in the product structure, choose
the Product without Model Revision
comparison option and select the New Model
update action.

For more information, see Example 5: Create
a new model for a product without the
model revision

The model structure has an additional BOM
line and the associated BOM line is not
available in the product structure.

To delete the model from the model
structure, choose the Model without
Product Revision comparison option and
select the Remove Model update action.

For more information, see Example 6:
Remove the model for a product without
the revision

The model structure has two BOM lines that
are associated to the same BOM line in the
product structure.

To delete the two models from the
model structure, choose the Model with
Additional Components than Product

6. Create the simulation model and define a mesh
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Scenario Update action to perform
Revision comparison option and select the
Remove Model update action.

For more information, see Example
7: Remove the model for additional
components than product revision.

The product structure has an additional
BOM line that is not available in the model
structure. Additionally, one of the BOM lines
in the product structure has a newer revision.

• To add the new BOM line to the model
structure, choose the Product without
Model Revision comparison option and
select the New Model update action.

• To update the relation of the model BOM
line to the product revision with the newer
revision, choose the Model with Newer
Product Revision comparison option and
select the Update and Sync Model update
action.

For more information, see Example 8: Create
a new model and update and sync the
model for a newer product revision and a
product without the model revision

6. To start the comparison and update actions, click Execute.

The comparison and update actions happen asynchronously.

7. Click Alerts and open Execution Summary when it is available.

Compare structures and automatically update the model structure
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8. Download the CAE BOM Compare Execution Summary report from the Target Object section of
Execution Summary and open it.

The report displays the names of the model and product structure, the time stamp, the total
lines processed and not processed. Additionally, it displays information about the failed criteria in
distinct colors. The actual comparison is displayed in the table of the report.

6. Create the simulation model and define a mesh
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9. To view the changes to the model structure, refresh the Compare > Split View by reloading the
page in the browser.

Example 1: Update and sync the model for a newer product revision

You can compare the model structure and the associated product structure and update the model
structure automatically by choosing the Automatic Update option.

In this comparison scenario, let us assume that there is a BOM line in the source product structure that
has a newer revision and the corresponding BOM line in the model structure has an older revision.

To update the model and create a relation to the newer revision of the product BOM line without
changing the revision of the model, choose the Model with Newer Product Revision comparison
option and select the Update and Sync Model update action.

Procedure

1. Open the model structure and choose Compare > Simulation.

Example 1: Update and sync the model for a newer product revision
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The system automatically opens the associated product structure and displays the model structure
and the product structure side-by-side in Split View.

2. Select the product BOM line that has a newer revision. Verify that the revision is B, for example.

3. Select the model BOM line corresponding to the product BOM line (revision B). Verify that the
revision is A, for example.

4. To verify the target relationship, click the Overview tab below the model structure and select the
object with the CAE Target relation in Related Objects.

The model BOM line has a CAE Target relation to the older product BOM line (revision A).

5. Select Automatic Update and accept the default selection for the Run Data Map check box.

6. Choose the Model with Newer Product Revision comparison option and select the Update and
Sync Model update action.

7. To start the comparison and update actions, click Execute.

The comparison and update actions happen asynchronously.

8. To verify that the comparison is complete, click Alerts and open Execution Summary when it is
available.

9. Refresh the Compare > Split View by reloading the page in the browser.

10. Select the model BOM line that corresponds to the product BOM line (revision B). Verify the revision
of the BOM line in the model structure. It is unchanged.

11. To verify the changed target relationship, click the Overview tab below the model structure and
select the object with the CAE Target relation in Related Objects.

The model BOM line has a CAE Target relation to the newer product BOM line (revision B).

Example 2: Revise the model for a newer product revision

You can compare the model structure and the associated product structure and update the model
structure automatically by choosing the Automatic Update option.

In this comparison scenario, let us assume that there is a BOM line in the source product structure that
has a newer revision and the corresponding BOM line in the model structure has an older revision.

To revise the model and create a relation to the newer revision of the product BOM line, choose the
Model with Newer Product Revision comparison option and select the Revise the Model update
action.

6. Create the simulation model and define a mesh
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Procedure

1. Open the model structure and choose Compare > Simulation.

The system automatically opens the associated product structure and displays the model structure
and the product structure side-by-side in Split View.

2. Select the product BOM line that has a newer revision. Verify that the revision is B, for example.

3. Select the model BOM line corresponding to the product BOM line (revision B). Verify that the
revision is A, for example.

4. To verify the target relationship, click the Overview tab below the model structure and select the
object with the CAE Target relation in the Related Objects section.

The model BOM line has a CAE Target relation to the older product BOM line (revision A).

5. Select Automatic Update and accept the default selection for the Run Data Map check box.

6. Choose the Model with Newer Product Revision comparison option and select the Revise Model
update action.

7. To start the comparison and update actions, click Execute.

The comparison and update actions happen asynchronously.

8. To verify that the comparison is complete, click Alerts and open Execution Summary when it is
available.

9. Refresh the Compare > Split View by reloading the page in the browser.

10. Select the model BOM line that corresponds to the product BOM line (revision B).

Verify that the revision has changed from A to B.

11. To verify the changed target relationship, click the Overview tab below the model structure and
select the object with the CAE Target relation in the Related Objects section.

The model BOM line has a CAE Target relation to the newer product BOM line (revision B).

Example 3: Create a new model for a newer product revision

You can compare the model structure and the associated product structure and update the model
structure automatically by choosing the Automatic Update option.

Example 3: Create a new model for a newer product revision
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In this comparison scenario, let us assume that there is a BOM line in the source product structure that
has a newer revision and the corresponding BOM line in the model structure has an older revision.

To create a new model and create a relation to the newer revision of the product BOM line, choose the
Model with Newer Product Revision comparison option and select the Create a New Model update
action.

Procedure

1. Open the model structure and choose Compare > Simulation.

The system automatically opens the associated product structure and displays the model structure
and the product structure side-by-side in Split View.

2. Select the product BOM line that has a newer revision. Verify that the revision is B, for example.

3. Select the model BOM line corresponding to the product BOM line (revision B).

Note down the ID of this BOM line. This BOM line is going to be replaced with a new model.

4. To verify the target relationship, click the Overview tab below the model structure and select the
object with the CAE Target relation in the Related Objects section.

The model BOM line has a CAE Target relation to the older product BOM line (revision A).

5. Select Automatic Update and accept the default selection for the Run Data Map check box.

6. Choose the Model with Newer Product Revision comparison option and select the New Model
update action.

7. To start the comparison and update actions, click Execute.

The comparison and update actions happen asynchronously.

8. To verify that the comparison is complete, click Alerts and open Execution Summary when it is
available.

9. Refresh the Compare > Split View by reloading the page in the browser.

10. Select the model BOM line that corresponds to the product BOM line (revision B).

Verify that a new model is created. The ID of the BOM line has changed.

The name is the same because it is generated using data map rules.

6. Create the simulation model and define a mesh
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11. To verify the changed target relationship, click the Overview tab below the model structure, select
the object with the CAE Target relation in the Related Objects section.

The new model BOM line has a CAE Target relation to the newer product BOM line (revision B).

Example 4: Sync the model for an updated product revision

You can compare the model structure and the associated product structure and update the model
structure automatically by choosing the Automatic Update option.

In this comparison scenario, let us assume that there is a BOM line in the source product structure
that has one of the attributes, such as Description, updated. The corresponding BOM line in the model
structure does not have a description. To update the description in the BOM line, choose the Model with
Updated Product Revision comparison option and select the Sync Model update action.

Procedure

1. Open the model structure and choose Compare > Simulation.

The system automatically opens the associated product structure and displays the model structure
and the product structure side-by-side in Split View.

2. Select the product BOM line that has the Description field updated and note down the description.

3. Select the model BOM line corresponding to the product BOM line with the Description field
updated. Verify that the field is empty.

4. Select Automatic Update and accept the default selection for the Run Data Map check box.

5. Choose Model with Updated Product Revision and select the Sync Model update action.

6. To start the comparison and update actions, click Execute.

The comparison and update actions happen asynchronously.

7. To verify that the comparison is complete, click Alerts and open Execution Summary when it is
available.

8. Refresh the Compare > Split View by reloading the page in the browser.

9. Select the model BOM line corresponding to the product BOM line with the Description field
updated.

Verify that the field is updated.

Example 4: Sync the model for an updated product revision

Simulation Process and Data Management on Active Workspace ─ Usage, Teamcenter 2412  6-23
© 2025 Siemens



Example 5: Create a new model for a product without the model revision

You can compare the model structure and the associated product structure and update the model
structure automatically by choosing the Automatic Update option.

In this comparison scenario, let us assume that there is an additional BOM line in the source product
structure and that is not available in the model structure. To create a new model for the additional BOM
line in the product structure, choose the Product without Model Revision comparison option and select
the New Model update action.

Procedure

1. Open the model structure and choose Compare > Simulation.

The system automatically opens the associated product structure and displays the model structure
and the product structure side-by-side in Split View.

2. Verify the product structure. It has an additional BOM line that is not available in the model
structure.

3. Select Automatic Update and accept the default selection for the Run Data Map check box.

4. Choose Product without Model Revision and select the New Model update action.

5. To start the comparison and update actions, click Execute.

The comparison and update actions happen asynchronously.

6. To verify that the comparison is complete, click Alerts and open Execution Summary when it is
available.

7. Refresh the Compare > Split View by reloading the page in the browser.

8. Verify the model structure.

The system creates a new model BOM line for the additional product BOM line.

9. To verify the target relationship for the new model BOM line, click the Overview tab below the
model structure and select the object with the CAE Target relation in the Related Objects section.

The model BOM line has a CAE Target relation to the additional product BOM line.

Example 6: Remove the model for a product without the revision

You can compare the model structure and the associated product structure and update the model
structure automatically by choosing the Automatic Update option.

6. Create the simulation model and define a mesh
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In this comparison scenario, let us assume that the model structure has an additional BOM line and
the associated BOM line is not available in the product structure. To delete the model from the model
structure, choose the Model without Product Revision comparison option and select the Remove
Model update action.

Procedure

1. Open the model structure and choose Compare > Simulation.

The system automatically opens the associated product structure and displays the model structure
and the product structure side-by-side in Split View.

2. Verify the model structure. It has an additional BOM line and the associated BOM line is not
available in the product structure.

3. Select Automatic Update and accept the default selection for the Run Data Map check box.

4. Select the Model without Product Revision comparison option and choose the Remove Model
update action.

5. To start the comparison and update actions, click Execute.

The comparison and update actions happen asynchronously.

6. To verify that the comparison is complete, click Alerts and open Execution Summary when it is
available.

7. Refresh the Compare > Split View by reloading the page in the browser.

8. Verify the model structure.

The system removes the additional BOM line from the model structure.

Example 7: Remove the model for additional components than product
revision

You can compare the model structure and the associated product structure and update the model
structure automatically by choosing the Automatic Update option.

In this comparison scenario, let us assume that the model structure has two BOM lines that are
associated to the same BOM line in the product structure. To delete the two models from the model
structure, choose the Model with Additional Components than Product Revision comparison option
and select the Remove Model update action.

Example 7: Remove the model for additional components than product revision
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Procedure

1. Open the model structure and choose Compare > Simulation.

The system automatically opens the associated product structure and displays the model structure
and the product structure side-by-side in Split View.

2. Verify the model structure. It has two BOM lines that are associated to the same BOM line in the
product structure.

3. Select Automatic Update and deselect the default selection for the Run Data Map check box.

4. Select the Model with Additional Components than Product Revision comparison option and
choose the Remove Model update action.

5. To start the comparison and update actions, click Execute.

The comparison and update actions happen asynchronously.

6. To verify that the comparison is complete, click Alerts and open Execution Summary when it is
available.

7. Refresh the Compare > Split View by reloading the page in the browser.

8. Verify the model structure.

The system removes the two BOM lines from the model structure.

6. Create the simulation model and define a mesh
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Example 8: Create a new model and update and sync the model for a newer
product revision and a product without the model revision

You can compare the model structure and the associated product structure and update the model
structure automatically by choosing the Automatic Update option.

In this comparison scenario, let us assume that the product structure has an additional BOM line that
is not available in the model structure. Additionally, one of the BOM lines in the product structure has
a newer revision. This means that the corresponding model BOM line has a relation with the previous
revision of the product BOM line.

In such a scenario, you have to choose two comparison options to update the model structure. To add
the new BOM line to the model structure, choose the Product without Model Revision comparison
option and select the New Model update action. To update the relation of the model BOM line to the
product revision with the newer revision, choose the Model with Newer Product Revision comparison
option and select the Update and Sync Model update action. However, this action does not change the
revision of the model BOM line.

Procedure

1. Open the model structure and choose Compare > Simulation.

The system automatically opens the associated product structure and displays the model structure
and the product structure side-by-side in Split View.

2. Verify the product structure. It has an additional BOM line and the associated BOM line is not
available in the model structure.

Example 8: Create a new model and update and sync the model for a newer product revision and a product

without the model revision
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3. Select the product BOM line that has the latest revision. Verify that the revision is D, for example.

4. Select the model BOM line corresponding to the product BOM line (revision D). Verify that the
revision is A, for example.

5. To verify the target relationship, click the Overview tab below the model structure and select the
object with the CAE Target relation in the Related Objects section.

The model BOM line has a CAE Target relation to the older product BOM line, that is, revision C.

6. Select Automatic Update and accept the default selection for the Run Data Map check box.

7. Select the Model with Newer Product Revision comparison option and choose the Update and
Sync Model update action.

8. Select the Product without Model Revision comparison option and choose the New Model
update action.

9. To start the comparison and update actions, click Execute.

The comparison and update actions happen asynchronously.

10. To verify that the comparison is complete, click Alerts and open Execution Summary when it is
available.

11. Refresh the Compare > Split View by reloading the page in the browser.

12. Verify the model structure.

The system creates a new model BOM line for the additional product BOM line.

13. Select the model BOM line corresponding to the product BOM line (revision D). Verify that the
revision is unchanged, that is, revision A.

14. To verify the target relationship, click the Overview tab below the model structure and select the
object with the CAE Target relation in the Related Objects section.

The model BOM line has a CAE Target relation to the latest product BOM line, that is, revision D.

Generate meshes using a preconfigured meshing application

1. Navigate to the CAE 3D Model revision you created earlier, open it, and click the Overview tab.

2. To generate meshes using a preconfigured meshing application, launch a simulation tool.

6. Create the simulation model and define a mesh
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If you do not have preconfigured simulation tools at your site, create the CAE 3D Model item
revision in the context of the CAE 3D Geometry item revision you created earlier, run the meshing
application to generate the mesh data and apply meshes, and then upload the mesh data to the
CAE 3D Model item revision.

3. Add a launch tool to your favorites.

a. (Analyst workspace) Choose Open in Simulation Tool .

(Default workspace) Choose Open  > Open in Simulation Tool .

b. Select the tool, click Open in New Tab , and click Manage  > Add to Favorites.

4. (Optional) Access help for a launch tool.

a. (Analyst workspace) Choose Open in Simulation Tool .

(Default workspace) Choose Open  > Open in Simulation Tool .

b. Select the tool, click Open in New Tab , and click Help.

(Optional) To download the help, click Description File and select Download File.

View and recapture the pedigree information of the product
structure as the model pedigree

If pedigree operations are enabled by the simulation administrator, when you create a CAE 3D model
structure based on a product structure using data map or structure map rules, the system automatically
captures the pedigree information of the product structure as the model pedigree. Pedigree information
captures the exact configuration of various structures, including the revision rule, effectivity, and variant
rules, and persists that information in the database. Therefore, as a simulation analyst, you have clear
traceability of what was analyzed.

1. View the pedigree information.

a. Navigate to the CAE 3D Model revision, open it, and click the Overview tab.

b. See the PEDIGREE INFORMATION section.

2. Recapture the pedigree information.

Let us assume a scenario where you create a CAE 3D model structure based on the product
structure by using data map rules or structure map rules. If pedigree operations are enabled by
the simulation administrator, the system automatically captures this information. Later, when the
revision rule or the effectivity of the product structure changes, you can recapture the pedigree
information as the model pedigree.

View and recapture the pedigree information of the product structure as the model pedigree
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a. Open the product structure, choose the Overview tab, and select the associated CAE 3D
Model Revision.

b. Select the Capture Pedigree option.

The pedigree information is updated.

The system enables this option only when you select the associated model revision.

Create external links or folders for model revisions

You can create external links to files or folders that are managed outside the database but are tracked
from Teamcenter.

1. Navigate to the CAE 3D Model revision you have created, open it, and click the Overview tab.

2. Click Add to  in EXTERNAL LINKS.

3. Select PROPERTIES, specify a name and the URL or a shared location, and then click Add.

4. To delete a web link, select the web link, click Edit, and select Delete External Links.

Update datasets and file names associated with the parent CAE
structure

As a simulation analyst, you can update datasets and file names associated with the parent CAE structure
as per the naming pattern specified by the simulation administrator at your site.

Prerequisites

This topic assumes that the simulation administrator at your site has edited the
CAE_renaming_pattern_for_dataset_and_file_names site preference to set a preference value. This
preference is used to specify the naming pattern for datasets and their related files at the site level. The
Update Dataset and File Name command is visible on the Files tab of the CAE object only when you
set a preference value.

Procedure

1. Open a CAE object such as CAE 3D Model and click the Files tab.

2. Select the root level of the CAE object in the File Containers view and select the Update Dataset
and File Name command in the File Contents secondary view.

If you select any other object, the command is not visible.

6. Create the simulation model and define a mesh
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The Update Dataset and File Name command is visible on the Files tab of the CAE object only
when you set a preference value.

Example:

The simulation administrator sets the preference value to
"object_name"_"object_desc"_"item_revision_id".

Consider a CAE 3D model revision with Revision as A, Name as Lower Arm 010, and
Description as IMW_Lower_Arm_010. In such a case, based on the preference value and the
value of the respective properties on the parent CAE object, the datasets and their related
files are renamed as Lower Arm 010_IMW_Lower_Arm_010_A.

All the datasets and file names associated with the parent CAE structure are renamed as per the
naming pattern.

The following are not renamed:

• Released datasets and their associated files.

• Datasets containing files with identical extensions.

• Datasets that are checked out.

Add a related revision to a model revision

1. Open a model revision from the appropriate folder in Explorer.

Alternatively, search for a model revision and open it.

2. To view all related CAE revisions in the context of the model revision, click the Overview tab.

The Related Objects section displays a pie chart that summarizes the number and types of related
simulation objects and a table that displays all the related simulation objects.

You can hover over the pie chart slice to view the number of related simulation objects to the
simulation object you have selected. You can also select or deselect the appropriate related objects
under the pie chart to hide or display those objects from the chart.

Note:

The count displayed for various related simulation objects is based on the number of related
objects in the database. It does not change based on filtration.

You can filter the data within the table columns to see only the data that is relevant to you.

Add a related revision to a model revision
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For more information, see Filter data in a table column in Active Workspace Fundamentals.

3. To view traceability information, select a related revision in the Related Objects table.

The TRACEABILITY INFORMATION section displays how the selected revision is related to other
revisions.

4. To view related objects and their relationships, click the Overview tab.

5. To add a related object, click Add Simulation , select a revision from the Add Simulation panel,
and click the Add button.

Mark 3D model revisions as up-to-date for changes to attachments
and related revisions

In a complex product development environment, different analysts perform different tasks of the overall
analysis. For example, abstractions are delivered by one group, models built by another group, and load
cases defined by another group. In such scenarios, it becomes critical to know when the analysis data,
possibly with multiple dependencies, is out-of-date. The analyst can then act on it and ensure that the
analysis is built with the correct set of data to deliver accurate results.

If a model revision undergoes changes related to attachments, you can use the Mark Up-To-Date
command to update to the latest revisions and mark the 3D model revision as up-to-date. Additionally, a
3D model revision has related revisions such as product, geometry, and analysis revisions. If the related
revisions undergo a revision change or updates for materials or parameters, the CAE status of the 3D
model revision shows as out-of-date. In such cases, you can use this command to update to the latest
revisions and mark the 3D model revision as up-to-date.

You can also view the CAE status of the released 3D model revisions if the
CAE_allow_cae_status_on_released_objects site preference is set to true at your site.

1. Open a 3D model revision and mark it as up-to-date.

a. Open a CAE 3D Model Revision from the appropriate folder in Explorer.

Alternatively, search for a 3D model revision and open it.

The header section displays the CAE status as Up-to-date or Out-of-date.

b. If the status is out-of-date, hover your mouse over the status. The system displays a tooltip.

The tooltip provides the reason for the revision being out-of-date. For example, the dependent
item revision has a newer revision.

6. Create the simulation model and define a mesh
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Note:

Baselined revisions are not considered as newer revisions.

c. Click the Out-of-date hyperlink.

The system opens the Overview tab. The Out-of-Date Information and Objects section
displays the status and the reason why the related revision is out-of-date.

d. Click Edit  and select Mark Up-To-Date.

2. Search for multiple model revisions and mark them as up-to-date

When you search for multiple model revisions and mark them as up-to-date, the system updates
only those revisions that are not up-to-date.

a. Search for multiple CAE model revisions.

b. Select the model revisions you want to mark as up-to-date and click Edit > Mark Up-To-Date.

3. Execute the dashboard and mark model revisions as up-to-date.

When you execute the dashboard and mark model revisions as up-to-date, the system updates only
those revisions that are not up-to-date.

a. Execute queries to view the dashboard results.

b. Select multiple model revisions and click Edit > Mark Up-To-Date.

4. Release model revisions by using a workflow and mark them as up-to-date.

If the administrator at your site has configured a workflow to release CAE objects and mark the
released objects as up-to-date, you can use this workflow to release CAE objects and the system
automatically marks them as up-to-date. After all the work related to analysis revisions is complete,
you can release the model revision using the workflow. When you use this workflow to submit a
model revision, the model revision and all the related analysis revisions are marked as up-to-date.

a. Select the model revision you want to release and choose More Commands > Manage >
Submit to Workflow.

b. Select the TCM Release Process template and click Submit.

c. In the Inbox, perform the task that was added by clicking Complete.

d. Open the model revision.

Mark 3D model revisions as up-to-date for changes to attachments and related revisions
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The system marks the model revision and all the related analysis revisions as up-to-date.

Make a copy of the 3D model revision or revise it

You can make a copy of the of the 3D model revision or revise it.

Procedure

1. Make a copy of the 3D model revision.

a. Select the 3D model revision.

b. Choose More Commands > New   > Save As .

c. (Optional) Specify a new name if you want to create a copy and description.

d. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

e. To create a copy, click Save.

2. Revise the 3D model revision.

a. Select the 3D model revision.

b. Choose More Commands > New   > Revise .

c. (Optional) Specify required information as appropriate.

d. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

6. Create the simulation model and define a mesh
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e. To revise, click Save.

View the associated material revisions of the product structure in a
model revision

You can view the associated material revisions of the product structure in a model revision.

Procedure

1. Open a product structure with associated material revisions.

2. Generate a model structure by using data map rules.

a. Choose More Commands > New  > Generate CAE Structure.

b. To generate a model structure, select the Data Map option and the CAE domain. This is the
default domain.

3. Open the generated model structure, select a BOM line, and choose the Materials tab.

The system displays the material object related to the product structure. Open the material object
and choose the Where Used tab. It displays the model revision as one of the referenced items.

4. Open the generated model structure, select a BOM line, and choose the Relations tab.

The system displays the source and target relations of the material object to the model revision and
the related product structure.

View the associated material revisions of the product structure in a model revision
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6. Create the simulation model and define a mesh
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7. Derive model structures to validate
different simulation scenarios
Why derive structures?

The process flow for deriving structures is as follows:

As a simulation analyst, during the virtual validation of a vehicle, you may create hundreds of different
deck structures or simulation variants to understand the effects of different materials or to optimize
the weight of the vehicle. This is done by varying the load cases, materials, thickness, meshes, and
geometry and then generating results to validate the vehicle against these different load cases. Many
variants are created for this purpose, with each variant representing a load case.

You can use predefined derivative rules and variant configuration rules to quickly derive one or more
structures relevant to your analysis from an existing structure. Derivative rules and variant configuration
rules are defined at the site level by the simulation administrator, at the group level by the group
administrator, and at the user level by the analyst. You can use these predefined rules to quickly derive
one or more simulation variants from an existing one. You can then make modifications to the structure
by varying load cases, meshes, or materials to evaluate different options and can view the complete
traceability between the different variants.

You apply derivative rules after configuring the product structure. After you load a model structure that
has a reference to a configurator context and derive one or more structures, the derived structures have
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the context set to the same configuration context as that of the source model structure. Further, all the
variant formula from the source model structure is mapped to the derived structures.

You can:

Derives structures based on a naming pattern by using predefined derivative rules. By selecting a
naming pattern, you can create the master and deck relationship.

OR

Derives structures based on a fixed name by using predefined derivative rules. The fixed name method
does not create the master and deck relationships.

Derive structures based on a naming pattern using predefined
derivative rules

You can derive structures based on a naming pattern by using predefined derivative rules. By selecting a
naming pattern, you can create the master and deck relationship.

1. Open a CAE model structure.

2. (Optional) To apply a variant rule, click Variant and select a variant rule.

3. Choose More Commands > New  > Derive CAE Structure.

4. (Optional) To add a derivative rule to the Favorites tab, choose the derivative rule and select the
Add to Favorites option.

5. To run the derivative rule, choose the derivative rule, and click Next.

6. Specify the number of structures you want to derive.

7. Select Naming Pattern.

8. To create the master and deck relationship while deriving structures, select Unique Auto-
generated number.

For example, if the Basename is SV01 and you select the unique auto-generated option, the
system generates the next unique number, 0001. The system computes the name based on the
base name, for example, SV01-Deck0001.

If you generate five decks, the next four decks are named automatically as SV01-Deck0002,
SV01-Deck0003, SV01-Deck0004, and SV01-Deck0005.

7. Derive model structures to validate different simulation scenarios
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If there are existing decks, the counter starts from the next available number. For example, if
you derive five more decks, the next five decks are named sequentially from SV01-Deck0006 to
SV01-Deck0011.

9. (Optional) Change the destination folder. By default, it is Newstuff.

10. To derive structures, click Derive.

The system executes the derive operation asynchronously on the server. An alert is triggered when
the operation is complete.

11. Click Alerts, open the alert, and view the details of the derive operation in the notification.

12. To access the output folder of the derive operation, in the notification, click the output folder link in
Related Objects.

The system provides up to five links to the output objects. You can find the remaining output by
clicking the link and accessing the output folder.

Structure type Indicator
Master structures

Derived structures

The visual indicators are displayed only after a master and deck relationship is created.

Alternatively, search for the derived structures by running the CAE – Find Decks from Master
query. You can see the same visual indicators for deck structures when you run this query.

13. To view the related simulation objects, open an output, and click the Overview tab.

If pedigree operations are enabled, you can view the pedigree information from the master
structure.

14. (Optional) To view the process log of the derive operation, click the Files tab and select the log.

15. To view the related simulation objects of the master structure, open an output and click the
Overview tab.

If pedigree operations are enabled, you can view the pedigree information from the master
structure.

Derive structures based on a naming pattern using predefined derivative rules
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16. To view the master and deck relationship, click the Relations tab.

It allows you to view and navigate the relations between different objects in a graph view.

Derive structures based on a fixed name using predefined
derivative rules

You can derive structures based on a fixed name by using predefined derivative rules. The fixed name
method does not create the master and deck relationships.

1. Open a CAE model structure.

2. (Optional) To apply a variant rule, click Variant and select a variant rule.

3. Choose More Commands > New  > Derive CAE Structure.

4. (Optional) To add a derivative rule to the Favorites tab, choose the derivative rule and select the
Add to Favorites option.

5. To run the derivative rule, choose the derivative rule, and click Next.

6. Specify the number of structures you want to derive.

7. Specify a fixed name.

The system populates the name of the topline element in the Fixed Name box.

8. (Optional) Edit the populated fixed name as appropriate.

9. (Optional) Change the destination folder. By default, it is Newstuff.

10. To derive structures, click Derive.

The system executes the derive operation asynchronously on the server. An alert is triggered when
the operation is complete.

11. To access the output folder of the derive operation, in the notification, click the output folder link in
Related Objects.

The system provides up to five links to the output objects. You can find the remaining output by
clicking the link and accessing the output folder.

Alternatively, search for the derived structures by running the CAE – Find Decks from Master
query.

7. Derive model structures to validate different simulation scenarios
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12. (Optional) To view the process log of the derive operation, click the Files tab and select the log.

13. To view the related simulation objects of the master structure, open an output and click the
Overview tab.

If pedigree operations are enabled, you can view the pedigree information from the master
structure.

14. To view the master and deck relationship, click the Relations tab.

It allows you to view and navigate the relations between different objects in a graph view.

Derive structures based on a fixed name using predefined derivative rules
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7. Derive model structures to validate different simulation scenarios
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8. Create the analysis and perform a solve
Create analysis revisions and solve the analysis

1. Open the simulation model

Open the simulation model you created earlier.

2. Create the analysis

The analysis model represents the specific analysis such as thermal, structural, or fluid you want
to perform. It includes load cases, solver parameters, and boundary conditions. You create analysis
revisions mostly in the context of model revisions.

3. Perform the solve using a preconfigured simulation tool

After creating the analysis revision, you can select the specific revision and launch a preconfigured
simulation to upload the load cases and solver parameters. You can also specify the solver location
(local, remote, or server) and perform the solve.

In the simulated side-impact example, different analysis models were used to vary the load cases.
For example, an analysis model to simulate a 3000 pound SUV-like barrier that hits the driver side
door at 30 mph. Similarly, another analysis model to change the barrier weight to 3200 pounds
and the speed to 35 mph.

Create CAE 3D analysis revisions

1. Search for the model revision you created, open it, and click the Overview tab.

2. Choose More Commands > New  > Create Simulation.

3. Select CAE 3D Analysis.

4. (Mandatory) Type a name for the analysis revision.

5. (Optional) Specify a description, analysis type, solution type, solver name, and project ID.
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6. (Optional) To specify a project, in PROJECTS, click Add Project  and select a project.

7. (Optional) To specify an analysis template, click Add Analysis Template  and select a template
from Palette, and click Add.

Alternatively, click Search, search for a template, and add it.

8. (Optional) To specify a result template, Add Result Template  and select a template from
Palette.

Alternatively, click Search, search for a template, and add it.

9. To create the simulation analysis revision, click Create.

10. Create external links or folders for analysis revisions

You can create external links to files or folders that are managed outside the database but are
tracked from Teamcenter.

a. Navigate to the CAE 3D Analysis revision you have created, open it, and click the Overview
tab.

b. Click Add to  in EXTERNAL LINKS.

c. Select PROPERTIES, specify a name and the URL or a shared location, and then click Add.

d. To delete a web link, select the web link, click Edit, and select Delete External Links.

11. To view all related CAE revisions in the context of the analysis revision, click the Overview tab.

The Related Objects section displays a pie chart that summarizes the number and types of related
simulation objects and a table that displays all the related simulation objects.

You can hover over the pie chart slice to view the number of related simulation objects to the
simulation object you have selected. You can also select or deselect the appropriate related objects
under the pie chart to hide or display those objects from the chart.

Note:

The count displayed for various related simulation objects is based on the number of related
objects in the database. It does not change based on filtration.

You can filter the data within the table columns to see only the data that is relevant to you.

For more information, see Filter data in a table column in Active Workspace Fundamentals.

8. Create the analysis and perform a solve
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12. To view traceability information, click the Overview tab and select a revision from the Related
Objects table.

The TRACEABILITY INFORMATION section displays how the selected revision is related to other
revisions.

13. View and add related objects.

a. To view related objects and their relationships, click the Overview tab.

b. To add a related object, click Add Simulation , select a revision from the Add Simulation
panel, and click the Add button.

14. To view all related test objects, click the Physical Test tab.

15. After creating an analysis revision, you can:

• Associate analysis templates, result revisions, and result templates to an analysis revision

• Create boundary conditions and associate them with an analysis revision

Create the analysis template

You can create analysis templates to specify different load cases. After creating a template, you can
associate it to an analysis revision.

You can create these templates to perform 3D analysis simulations, for example, CFD, FEA, or structural.
They contain setup files (like .sim files or macros) which you can use to enable a consistent simulation
workflow and ensure repeatable and consistent results. A template can be related directly to a 3D
analysis. All the CAE 3D analyses which are performed based on this template can be easily tracked in
Teamcenter.

1. On the HOME page, click CREATE SIMULATION.

2. In the Create Simulation panel, select the CAE 3D Analysis Template type.

3. (Mandatory) Specify a name for the analysis template.

4. (Optional) In PROJECTS, click Add Project  and select a project.

5. To create the template, click Create.

6. Open the template you created.

7. To add the required files for this template, in the Overview tab, click Add to  in FILES.

Create the analysis template
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8. Click Choose File and select the required file for this template.

9. Associate the analysis template you have created to an analysis revision.

Create boundary conditions and associate them with an analysis
revision

After creating boundary condition revisions, you can associate them with an analysis revision. When you
revise the analysis revision or save it as a different revision, the boundary condition revisions are not
copied across.

1. Create a CAE boundary condition revision.

a. On the HOME page, click CREATE SIMULATION.

b. In the Create Simulation panel, select the CAE 3D Boundary Condition type.

c. (Mandatory) Specify a name for the boundary condition.

d. (Optional) Click Add Project  and select a project.

e. To create the boundary condition, click Create.

f. Add boundary conditions.

A. Open the boundary condition you created.

B. In the Overview tab, click Add to  in FILES.

C. Click Choose File and select the file containing the simplified geometry.

2. Associate the boundary condition type to an analysis revision.

a. Navigate to an analysis revision, open it and click the Overview tab.

b. Click Add Simulation  in the RELATED OBJECTS table.

c. In the Add Simulation panel, select the CAE 3D Boundary Condition type, and select it from
Palette.

Alternatively, click Search, specify your search criteria, and select it.

d. From the Relation menu, select the CAE Include relationship or the CAE Extract relation.

The default relation is CAE Include relationship.

8. Create the analysis and perform a solve
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Note:

You cannot add a boundary condition revision to an analysis revision with the CAE
Extract relation if the boundary condition revision is already attached to a CAE 3D
Result or a CAE 3D Analysis revision with the same relation.

e. To include the boundary condition, click Add.

The Related Objects table displays the CAE boundary condition and the relation.

Mark boundary conditions as up-to-date for changes to
attachments and related revisions

You can mark boundary conditions as up-to-date for changes to attachments and related revisions such
as CAE 3D Analysis and CAE 3D Result.

In a complex product development environment, different analysts perform different tasks of the overall
analysis. For example, the CFD analysis is done by one group, and the heat flux load is sent to another
group as a boundary condition. Similarly, another group does structural analysis and this group receives
a boundary condition object from the program requirements group. In such scenarios, it becomes critical
to know when the analysis data, possibly with multiple dependencies, is out-of-date. The analyst can
then act on it and ensure that the analysis is built with the correct set of data to deliver accurate results.

You can create a CAE 3D Boundary Condition revision in the context of a CAE 3D Analysis or a CAE
3D Result revision. If any of these related revisions are changed, the status of the boundary condition
shows as out-of-date. Similarly, if any attachments are added or removed from the CAE 3D Boundary
Condition revision, the status of the boundary condition shows as out-of-date.

You can also view the CAE status of released 3D boundary conditions if the
CAE_allow_cae_status_on_released_objects site preference is set to true at your site.

Note:

The system evaluates CAE 3D Analysis revision changes for CAE0Extract relationship only.

Procedure

1. Open a CAE 3D Boundary Condition revision from the appropriate folder in Explorer.

Alternatively, search for a boundary condition and open it.

The header section displays the CAE status as Up-to-date or Out-of-date.

2. If the status is out-of-date, hover your mouse over the status. The system displays a tooltip.

Mark boundary conditions as up-to-date for changes to attachments and related revisions
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The tooltip provides the reason for the revision being out-of-date. For example, a dependent
attachment has been added.

3. Click the Out-of-date hyperlink.

The system opens the Overview tab. The Out-of-Date Information and Objects section displays
the status and the reason why the boundary condition is out-of-date.

4. To update the status, choose More Commands > Edit  and select Mark Up-To-Date.

Associate analysis templates, result revisions, and result templates
to an analysis revision

You can associate analysis templates, result revisions, and result templates to an analysis revision.

1. Associate analysis templates to an analysis revision.

a. Open the analysis revision you created.

b. Click the Overview tab.

c. From the Related Objects tab, click Add Simulation, and select CAE 3D Analysis Template.

d. Select an analysis template from the Palette tab.

Alternatively, click the Search tab, specify your search criteria, select an analysis template, and
click Add.

2. Associate result revisions to an analysis revision.

a. Open the analysis revision you created.

b. Click the Overview tab.

c. From the Related Objects tab, click Add Simulation, and select CAE 3D Result.

d. Select multiple result revisions from the Palette tab.

Alternatively, click the Search tab, specify your search criteria, select multiple result revisions,
and click Add.

The system adds the result revisions to the Related Objects table with the CAE Results
relation.

3. Associate result templates to an analysis revision

8. Create the analysis and perform a solve
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a. Open the analysis revision you created.

b. Click the Overview tab.

c. From the Related Objects tab, click Add Simulation, and select CAE 3D Result Template.

d. Select result templates from the Palette tab. You can select more than one template.

Alternatively, click the Search tab, specify your search criteria, select result templates, and
click Add.

The system adds the result revisions to the Related Objects table with the CAE Based On
relation.

Visualize result files such as JTs and images associated with
analysis revisions

You can use the universal viewer to view object attachments. The universal viewer is displayed in an
object's Overview tab if there are attachments for the object. The universal viewer supports file types
such as PDF, text, HTML, Microsoft Office files, images and Direct Model (JT) files.

Note:

It is recommended that you store one JT file per Direct Model dataset. The universal viewer does
not support multiple JT files in a single Direct Model dataset. In addition, CAE JT files containing
results quantities are not supported.

1. Select a CAE 3D Analysis or CAE MDAO Analysis revision that contains several secondary results
and reports as attachments.

2. Click the Overview tab for a preview of the selected file type.

The system displays a preview of the first file type attached to the revision.

3. To preview the next attached file type, click the Next button.

4. To navigate through a preview of attachments, click the Next or Previous button as appropriate.

Mark 3D analysis revisions as up-to-date for changes to
attachments and related revisions

In a complex product development environment, different analysts perform different tasks of the overall
analysis. For example, abstractions are delivered by one group, models built by another group, and load
cases defined by another group. In such scenarios, it becomes critical to know when the analysis data,

Visualize result files such as JTs and images associated with analysis revisions
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possibly with multiple dependencies, is out-of-date. The analyst can then act on it and ensure that the
analysis is built with the correct set of data to deliver accurate results.

A 3D analysis revision has related revisions such as product, geometry, analysis, and model revisions. If
the related revisions undergo a revision change or updates to parameters or materials, the CAE status of
the analysis revision shows as out-of-date. In such cases, you can use the Mark Up-To-Date command to
update to the latest revisions and mark the 3D analysis revision as up-to-date.

You can also view the CAE status of released 3D analysis revisions if the
CAE_allow_cae_status_on_released_objects site preference is set to true at your site.

1. Open a 3D analysis revision and mark it as up-to-date.

a. Open a CAE 3D Analysis Revision from the appropriate folder in Explorer.

Alternatively, search for a 3D analysis revision and open it.

The header section displays the CAE status as Up-to-date or Out-of-date.

b. If the status is out-of-date, hover your mouse over the status. The system displays a tooltip.

The tooltip provides the reason for the revision being out-of-date. For example, the dependent
item revision has a newer revision.

Note:

Baselined revisions are not considered as newer revisions.

c. Click the Out-of-date hyperlink.

The system opens the Overview tab. The Out-of-Date Information and Objects section
displays the status and the reason why the related revision is out-of-date.

d. Click Edit  and select Mark Up-To-Date.

2. Open multiple analysis revisions and mark them as up-to-date.

When you select multiple analysis revisions to mark them as up-to-date, the system updates the
status of only those revisions that have undergone changes to attachments or related revisions.

a. Open a CAD assembly and click the Overview tab.

The CAD assembly has a related model revision and related analysis revisions.

b. In the CAD assembly, select a related analysis revision.

8. Create the analysis and perform a solve

8-8  Simulation Process and Data Management on Active Workspace ─ Usage, Teamcenter 2412
© 2025 Siemens



The header section displays the CAE status as Out-of-date.

c. Hover your mouse over the status. The system displays a tooltip. The tooltip provides the
reason for the revision being out-of-date.

In this case, the tooltip displays the following message:

Dependent item revision(s) have a newer revision

d. In the Overview tab, select the related analysis revisions you want to mark as up-to-date and
choose More Commands > click Edit > Mark Up-To-Date.

The system updates the status of the revisions that have undergone changes to attachments
or related revisions.

3. Search for multiple analysis revisions and mark them as up-to-date.

When you search for multiple analysis revisions and mark them as up-to-date, the system updates
only those revisions that are not up-to-date.

a. Search for multiple CAE analysis revisions.

b. Select the analysis revisions you want to mark as up-to-date and choose More Commands >
Edit > Mark Up-To-Date.

4. Execute the dashboard and mark analysis revisions as up-to-date.

When you execute the dashboard and mark analysis revisions as up-to-date, the system updates
only those revisions that are not up-to-date.

a. Execute queries to view the dashboard results.

b. Select multiple analysis revisions and click Edit > Mark Up-To-Date.

5. Release CAE objects using a workflow and mark them as up-to-date.

Consider the administrator at your site has configured a workflow to release CAE objects and mark
the released objects as up-to-date. In such a case, you can use this workflow to release CAE objects
and the system automatically marks them as up-to-date. After all the work related to analysis
revisions is complete, you can release the model revision using the workflow. When you use this
workflow to submit a model revision, the model revision and all the related analysis revisions are
marked as up-to-date.

a. Select the model revision you want to release and choose More Commands > Manage >
Submit to Workflow.

Mark 3D analysis revisions as up-to-date for changes to attachments and related revisions
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b. Select the TCM Release Process template and click Submit.

c. In the Inbox, perform the task that was added by clicking Complete.

d. Open the model revision.

The system marks the model revision and all the related analysis revisions as up-to-date.

Make a copy of the 3D analysis revision or revise it

You can make a copy of the of the 3D analysis revision or revise it.

Procedure

1. Make a copy of the 3D analysis revision.

a. Select the 3D analysis revision.

b. Choose More Commands > New   > Save As .

The Save As dialog opens.

c. (Optional) Specify a new name if you want to create a copy and description.

d. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

e. To create a copy, click Save.

2. Revise the 3D analysis revision.

a. Select the 3D analysis revision.

b. Choose More Commands > New   > Revise .

The Revise dialog opens.

c. (Optional) Specify required information as appropriate.

8. Create the analysis and perform a solve
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d. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

e. To revise, click Save.

View and recapture the pedigree information of the model
structure as the analysis pedigree

If pedigree operations are enabled, the system captures the pedigree information when you create
an analysis revision in the context of a model revision. Pedigree information captures the exact
configuration of the model revision, including the target, revision rule, effectivity, variant rule, and
the configured variant rule option, and persists that information in the database. For example,
pedigree information in the form of Revision Rule=Released for Analysis, Effectivity=Aug 31, 2015,
loadcase=frontal crash, and speed=40kmph. This is captured in the analysis revision as the analysis
pedigree. Therefore, you have clear traceability of what was analyzed later.

1. View pedigree information.

a. Navigate to the CAE 3D Analysis revision, open it, and click the Overview tab.

b. See the PEDIGREE INFORMATION section.

2. Recapture pedigree information.

Let us assume a scenario where you create a CAE 3D analysis structure based on the model
structure by using derivative rules. If pedigree operations are enabled by the simulation
administrator, the system automatically captures this information. Later, if this information changes
in the model structure, you can recapture the pedigree information as the analysis pedigree.

a. Open the product structure, choose the Overview tab and select the associated CAE 3D
Analysis Revision.

b. Select the Capture Pedigree option.

The pedigree information is updated.

The system enables this option only when you select the associated analysis revision.

View and recapture the pedigree information of the model structure as the analysis pedigree
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Perform a solve using a preconfigured analysis tool

1. Navigate to the CAE 3D Analysis revision you have created, open it, and click the Overview tab.

2. Access help for a launch tool.

a. (Analyst workspace) Choose Open in Simulation Tool .

(Default workspace) Choose Open  > Open in Simulation Tool .

b. Select the tool, click Open in New Tab , and click Help.

(Optional) To download the help, click Description File and select Download File.

3. Add a launch tool to your favorites.

a. (Analyst workspace) Choose Open in Simulation Tool .

(Default workspace) Choose Open  > Open in Simulation Tool .

b. Select the tool, click Open in New Tab , and click Manage  > Add to Favorites.

4. To perform a solve using a preconfigured analysis tool, launch a simulation tool.

Note:

If you do not have preconfigured simulation tools, you must create the CAE 3D Analysis
item revision in the context of the CAE 3D Model item revision, define load cases, solver
parameters and boundary conditions, and manually run the solver application to perform the
solve.

8. Create the analysis and perform a solve
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9. Find recommended simulations based on
the data in a verification request
Find recommended simulations

In Model-Based Systems Engineering, verifications are done to evaluate whether a product, service, or
system complies with a regulation, requirement, specification, or other imposed condition.

As a simulation analyst, creating a new verification request requires extensive manual review of
requirements, CAD data, and input or output parameters before starting the simulation. Finding the
most relevant data based on simulation history is challenging, leading to varying success rates among
analysts.

You can use the Recommended Simulations tab to quickly find the simulation data with the parameters
that are most relevant to the verification request you are creating. This ensures that you have a
consistent set of comparable results to start your work.

When verification requests are created, the input and output parameters are automatically included
based on the selected object. These parameters have data types such as integer, double, boolean, string,
or point and properties such as goal, minimum, and maximum values. These properties are indexable.
The system periodically runs an indexer in the background to mark simulation objects that are associated
with verification requests containing these parameters.

The Recommended Simulations tab displays simulation objects and other subtypes that have the best
matches. They are presented in the order of their relevance based on the parameters from all verification
requests in the database.

Find a recommended simulation based on a verification request

You can quickly find a recommended simulation based on the data in a verification request.

Prerequisites

The Simulation Process Management with Measurable Attribute for Active Workspace feature must
be installed.

Procedure

1. Open a verification request.

2. Click the Recommended Simulations tab.
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The tab displays CAE objects and other subtypes that have the best matches in the order of their
relevance based on the parameters in the verification request.

3. Select the appropriate CAE object and open the related verification request.

4. Click the Overview tab and navigate to the Parameters section.

5. Click Open in the Related Verification Request section to verify if the parameters in the
verification or simulation request are similar to your assigned verification request or simulation
request.

9. Find recommended simulations based on the data in a verification request
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6. Select the appropriate CAE object and click Open in the Recommended Simulation section to
open the CAE object and verify if the parameters are similar based on the previous verification or
simulation request.

7. Copy the CAE object to your assigned verification or simulation request if the previous CAE work
can be reused, or if you can simply reference the legacy data and improve your current CAE work.

By leveraging historical data, you can make better and more consistent decisions based on the
lessons learned from the previous programs for which you have performed CAE work with similar
requirements.

Find a recommended simulation based on a verification request

Simulation Process and Data Management on Active Workspace ─ Usage, Teamcenter 2412  9-3
© 2025 Siemens



9. Find recommended simulations based on the data in a verification request
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10. Perform simulations using integrations
Set parameter values for analysis objects

The global parameter management solution allows you to define and manage different types of
parameters, including variables, characteristics, measurements, calibration, and configuration. You
maintain parameters in a single source dictionary that is shared across domains, applications, and life
cycles.

For more information about parameters, see About parameter management in Model-Based Systems
Engineering.

For using parameters in CAE task flows, you can set parameter values by using a preconfigured
simulation tool or set parameters values manually.

Set parameter values by using a preconfigured simulation tool

1. Create a CAE 3D Analysis revision to capture the artifacts of the simulation you want to perform.
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2. Copy the parameters and paste them to an analysis revision:

a. Search for the Parameter Project and open it.

b. Select the required parameters and click Copy .

c. Open the analysis revision to which you want to copy the parameters, click the Parameters
tab, and click Paste  at the top of the table.

3. To set the parameter definitions as input or output, select a parameter, click Set Usage at the top of
the table, and choose Input or Output as appropriate.

4. To specify the parameter values using a simulation tool, select the analysis revision and launch a
preconfigured simulation tool.

The system exports the input files and a PLM XML file of the input and output parameters, invokes
the launch script, and provides the exported inputs to the launch script. The launch script then
invokes the simulation tool to include the input files and parameters.

5. Perform the simulation (interactively or in batch), generate the output files, and create a PLM XML
file with output parameters containing names and values.

6. Exit the simulation tool and the launch script.

The system imports the configured output files and also imports the PLM XML file with the output
parameters. After the tool launch is complete, the system displays a notification.

7. Refresh the analysis revision and verify the parameter values.

8. (Optional) Select the analysis revision with the parameter values and click New  and choose
Revise. The parameter values are carried forward to the new revision.

9. (Optional) To view traceability or pedigree information, select or open the analysis revision with the
parameter values and click the Overview tab.

The TRACEABILITY INFORMATION and the PEDIGREE INFORMATION sections display the
respective information.

10. (Optional) If any parameter value is subsequently changed, open the analysis revision with the
parameter values.

The header section displays the CAE status as Up-to-date or Out-of-date.

The system marks an analysis revision as out-of-date if any of its corresponding input parameters
are modified since the last time the analysis was marked as up-to-date. 

10. Perform simulations using integrations
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For out-of-date analysis revisions, take appropriate action, for example, run the simulation tool
again.

Set parameters values manually

As a simulation analyst, you can set parameters in the CAE analysis objects as input and output manually
if simulation tools are not configured at your site. To do so:

1. Select the analysis revision or open the analysis revision and click the Parameters tab.

2. Add parameters.

a. Click  Add Parameter and select a parameter.

b. Specify values as appropriate and click Add.

3. Edit parameter values.

a. Select the parameter you want to edit and click Edit  > Start Edit .

b. Modify values as appropriate.

c. To save your changes, click Edit  > Save Edits .

4. To delete the parameter, select it, and click Edit  > Delete Parameter .

Update parameter values in analysis objects using Verification
Management

The Teamcenter Verification Management solution provides an integrated environment for verification
events, including simulated tests and physical tests. It links individual tests and analyses to the necessary
resources while providing full traceability across the lifecycle of the project.

For more information about design verification and validation, see Model-Based Systems Engineering.

The process is as follows:

Update parameter values in analysis objects using Verification Management
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Simulation analysts can open and review the verification request, copy the needed parameters, and
update the parameters based on simulations. To do so:

1. Open the verification request.

2. On the HOME page, click CREATE SIMULATION.

3. Click Add in the Simulation Analysis tab.

4. Select CAE 3D Analysis Revision, CAE 1D Analysis Revision, or CAE MDAO Analysis Revision
and click OK.

The system adds the object to the verification request. It also creates a relationship between the
verification request and the analysis revision.

5. To copy the parameters from the verification request to the analysis revision, select the Copy
Parameters option.

Alternatively, manually copy the parameters.

6. To update the measurement values inside the verification request, select the object added to the
request and launch a preconfigured simulation tool that can extract and write back the parameter
values. Alternatively, manually specify these values after the simulation is complete.

7. (Optional) To delink parameters from the analysis revision, select the analysis revision and remove
it from the verification request.

10. Perform simulations using integrations
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Perform simulations using Simcenter FLOEFD

Simcenter FLOEFD for NX provides fluid flow and thermal simulation capabilities. It works with NX
running both in native or managed mode. In managed mode, FLOEFD project data is saved together
with the NX geometry in Teamcenter. 

The simulation data model has been extended to capture project, simulation, and results data from
FLOEFD.

1. Launch NX in managed mode and open a CAD assembly.

2. Open the FLOEFD Simulation application and create a new project.

The system creates the new CAE 3D Analysis revision with a target relationship to the item
revision (product structure).

3. Save the project.

The system saves the project under CAE 3D Model revision in the CAE FloEFD dataset.

4. Perform the simulation and save the results.

Perform simulations using Simcenter FLOEFD
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The system saves the results files to the CAE FloEFD dataset in the CAE 3D Analysis revision.

5. To view the files stored in Teamcenter, open the CAE FloEFD dataset.

Publish Simcenter system simulation models from Git

After modeling engineers complete their work and the system simulation models are ready to be
released, the data is imported from the Simcenter Client for Git (SCG) repository to Teamcenter. The
data that is imported is the released data or the gold copy of the data. As a modeling engineer, you can
use the preconfigured CAE Review and Publish from Simcenter Client for Git and CAE Publish from
Simcenter Client for Git tools to publish the gold copies of system simulation models to Teamcenter
from the SCG repository.

The following procedure assumes that the simulation administrator has set up the sample configurations
by running the tcsim_quick_setup.pl script and that the default CAE Review and Publish from
Simcenter Client for Git and CAE Publish from Simcenter Client for Git tools are available.

The process is as follows:

10. Perform simulations using integrations
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1. (Modeling engineer) Create the CAE 1D Model revision.

a. On the HOME page, click CREATE SIMULATION.

b. Select CAE 1D Model revision and specify a name for the 1D model revision.

c. Select or specify values as appropriate in the other boxes and click OK to create the 1D model
revision.

2. (Modeling engineer) Select a workflow, assign an approver, and submit it to a workflow.

a. Select the 1D model revision and choose More Commands > Manage > Submit to
Workflow.

b. Select the CAE Review and Publish from Simcenter Client for Git workflow.

Publish Simcenter system simulation models from Git
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c. To assign the task to an approver, click Assignments and select the Review task.

d. From Users, select the appropriate group, drag-and-drop a user to the Task pane, and click
Modify.

e. To submit the workflow, click Submit.

The system sends the task control to the user who initiated the workflow.

3. (Modeling engineer) Provide the JSON token that contains the UID.

The publish utility reads the UID, selects the relevant system model from SCG, and publishes it to
Teamcenter.

a. To view tasks, click Inbox and open the Decode token and Update Model Attributes task.

b. Specify a valid token. Copy the token from SCG, paste it into the Comments box, and click
Complete.

The task invokes an action handler, and the control then passes to the approver.

4. (Approver) Approve the task.

a. To view tasks, click the Inbox and open the perform-signoffs task.

b. (Optional) In Targets, open the object, and verify the model version and model identifier that
was automatically decoded from the provided token.

c. Go back to Inbox.

d. In Action, optionally specify a comment and click Approve.

The task goes back to the modeling engineer who initiated the task.

5. (Modeling engineer) Complete the task.

a. Click Inbox and open Publish from Simcenter Client for Git.

b. Click Complete.

The preconfigured Publish from Simcenter Client for Git tool launches automatically.

c. Open Simulation Tool Progress Monitor and verify the task entry for Publish from
Simcenter Client for Git.

d. Browse to the temp directory of the simulation tool.

10. Perform simulations using integrations
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The git.attributes.xml file, the launch script, and a ZIP file are available.

The XML file has information about the UID and other attributes, and the ZIP file has the 1D
model along with its dependencies from SCG.

e. Open the CAE 1D Model revision you created.

f. Click the Overview tab.

In Properties in Work in Progress System, verify whether the model name, model creation
date, and other attributes are updated.

g. Click the Overview tab.

The ZIP file that has the 1D model from SCG is attached.

6. (Modeling engineer) Use the 1D model in a system simulation tool.

a. Select the CAE 1D Model revision and choose Open > Open in Simulation Tool > Simcenter
Amesim.

b. Extract the ZIP file and import it into the system simulation tool.

7. (Modeling engineer) Delete the mapping created by the export operation.

After the model collection is stored inside Teamcenter, the same model collection cannot be shared
with Teamcenter again. To share again, the Teamcenter mappings must be deleted inside SCG.

a. Select the CAE 1D Model revision and choose More Commands > Manage > Submit to
Workflow.

b. Select CAE Delete Attributes in Simcenter Client for Git and click Submit.

The system deletes the Teamcenter mapping in SCG.

Perform simulations using Simcenter System Architect

Optimize system integration with Simcenter System Architect

Simcenter System Architect helps enhance system integration, configuration, and simulation
architecture management. You can perform co-simulation of multiple heterogeneous models, enabling
collaboration across domain boundaries and silos. Product performance can be continuously monitored
throughout the design cycle by updating, exchanging, and reusing simulation assets as the design
evolves.

Optimize system integration with Simcenter System Architect
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You can perform simulations in a standalone mode without verification request or an integrated mode
with a verification request.

The process for a standalone mode without verification request is as follows:

The process for an integrated mode with verification request is as follows:

10. Perform simulations using integrations
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Perform standalone simulations without a verification request in Simcenter
System Architect

As a simulation analyst, you can perform standalone simulations without a verification request in
Simcenter System Architect.

Prerequisites

The following procedure assumes that the simulation administrator has set up the sample configurations
by running the tcsim_quick_setup.pl script and that the Simcenter System Architect - Create or
Modify Project and Simcenter System Architect - Execute Analysis (Batch) default tools are available.

Perform standalone simulations without a verification request in Simcenter System Architect
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Procedure

1. Create the CAE 1D Model revision to capture the Simcenter System Architect model.

a. On the HOME page, click CREATE SIMULATION.

b. Select the CAE 1D Model revision and specify a name for the 1D model revision.

c. Select or specify values as appropriate in the other boxes and click OK to create the 1D model
revision.

2. Launch the simulation tool to create a project.

a. Select the CAE 1D Model revision and choose Open > Open in Simulation Tool > Simcenter
System Architect - Create or Modify Project.

b. Select the Launch without configured Input option, and click Open to launch the simulation
tool.

Simcenter System Architect is launched, and an empty project is created.

3. View input and output parameters, and attached project files after the tool launch is complete.

a. Open the CAE 1D Model revision after the tool launch is complete.

Simcenter System Architect packages the data prepared, including all dependent models into
a sarpck package file.

b. To view the input and output parameters, click the Parameters tab.

The input and output parameters are displayed.

c. (Optional) To view additional columns in the Input Parameters table, click Table Settings >
Arrange and add columns such as Formula, Max, Max Operator, Min, Min Operator, and
Units.

Similarly, you can add additional columns to the Output Parameters table such as Goal, Goal
File, Max, Max Operator, Min, Min Operator, and Units.

d. To view the sarpck file and the Simcenter System Architect PNG file, click the Overview tab.

4. Create the CAE 1D Analysis revision in the context of the CAE 1D Model revision and capture the
key performance indicator (KPI) values.

a. Select the CAE 1D Model revision you created earlier.

10. Perform simulations using integrations
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b. Choose More Commands > New > Create Simulation.

c. Specify a name for the CAE 1D Analysis revision, select or specify values as appropriate for
the other fields, and click Create.

d. Click the Parameters tab, and edit the input parameters values.

The system automatically copies the parameters over to the CAE 1D Analysis revision.

5. Launch the simulation tool to run the analysis in batch mode and capture the results files and KPI
values.

a. Select the 1D analysis revision and choose Open > Open in Simulation Tool > Simcenter
System Architect - Execute Analysis (Batch).

b. Click Open to launch the simulation tool.

The analysis runs in batch mode.

6. View the results files and KPI values after the tool launch is complete.

a. Open the CAE 1D Analysis revision after the tool launch is complete.

b. To view the KPI values generated by the simulation tool, click the Parameters tab.

c. To view the results files, click the Overview tab.

The results are displayed as PNG files.

Perform simulations based on a verification request in Simcenter System
Architect

As a simulation analyst, you can perform integrated simulations based on a verification request in
Simcenter System Architect.

The requirements engineer gathers requirements and creates a requirement revision, which includes
input and output parameters such as acceleration, body mass, and spring stiffness. The system
engineer then generates a verification request from this requirement revision. The system automatically
copies the input and output parameters from the requirement revision to the verification request.
Subsequently, the system engineer creates a simulation request from the verification request, and the
system again copies the input and output parameters to the simulation request. As a simulation analyst,
you can perform simulations based on the simulation request attached to the verification request.

Perform simulations based on a verification request in Simcenter System Architect
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Prerequisites

The following procedure assumes the Simcenter System Architect (VR) - Create or Modify Project and
Simcenter System Architect (VR) - Execute Analysis (Batch) preconfigured tools are available.

The simulation analyst must ensure that the Simcenter Amesim installation directory is specified
correctly in Simcenter System Architect. For more information about specifying the installation directory
and other prerequisites, refer to the Simcenter System Architect tool help.

Procedure

1. Create the model.

a. Open the verification request and select the simulation request.

b. Choose Open > Open in Simulation Tool > Simcenter System Architect (VR) - Create or
Modify Project preconfigured tool.

This tool launches System Architect where you can create the project.

c. Specify the initial input and output parameters for the project in System Architect.

For more information, refer to the Simcenter System Architect tool help.

d. Save the project and close System Architect.

The parameter values are automatically populated on the simulation request and CAE 1D
Analysis and CAE 1D Model revisions when you save the project and exit the tool.

e. To view the status, open the Simulation Tool Progress Monitor in a separate tab of the
browser.

When the status is complete, the system displays the Teamcenter mapping gateway dialog
box.

f. To map the input and output parameters from the verification request and the parameters
created in System Architect, select the appropriate options in the Teamcenter mapping
gateway dialog box that opens on the client machine.

g. Click Save to save the mapping.

When you save the mapping, the system architect adds the parameter values to a JSON file.
The system converts the parameter values from the JSON file to a PLM XML file and imports
the data to Teamcenter. Additionally, the system automatically creates the CAE 1D Model and
CAE 1D Analysis revisions and attaches them to the simulation request.

10. Perform simulations using integrations
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h. To view the status, open the Simulation Tool Progress Monitor in a separate tab of the
browser.

When the status is complete, you can open the simulation request.

i. Open the simulation request.

In the Overview tab, you can view the mapped input and output parameters by clicking and
expanding each parameter. The mapped parameters follow the naming convention of the
simulation objects, which differs from the naming convention of the requirement revision. For
example, if Body Mass is the naming convention in the requirement revision, it appears as
Vehicle_Body_Mass for simulation objects.

j. In the Overview tab, select the CAE 1D Model revision, click Open, and choose the
Parameters tab.

This tab displays the input and output parameters that you created in System Architect.

k. To view the attached model file, click the Overview tab of the CAE 1D Model revision and
download the attached file from the Files area.

This contains the details of the model you created in System Architect.

l. In the Overview tab, select the CAE 1D Analysis revision, click Open, and choose the
Parameters tab.

This tab displays the input and output parameters that you created in System Architect.

2. Modify an existing model.

a. Open the verification request and select the simulation request.

b. Choose Open > Open in Simulation Tool > Simcenter System Architect (VR) - Create or
Modify Project preconfigured tool.

This tool launches System Architect where you can modify the project. You can modify the
input and output parameters you specified initially for the project. For more information, refer
to the Simcenter System Architect tool help.

c. Save the project and close System Architect.

The parameter values are automatically populated on the simulation request, 1D model and
1D analysis when you save the project and exit the tool.

d. To view the status in Active Workspace, open the Simulation Tool Progress Monitor in a
separate tab of the browser.

Perform simulations based on a verification request in Simcenter System Architect
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When the status is complete, the system displays the Teamcenter mapping gateway dialog
box.

e. Click Save to save the mapping for the parameter values that are changed.

When you save the mapping, system architect updates the changed parameters and values to
a JSON file. The system converts the parameters and values from the JSON file to a PLM XML
file and imports the data to Teamcenter.

f. To view the status in Active Workspace, open the Simulation Tool Progress Monitor in a
separate tab of the browser.

When the status is complete, you can view the modified parameters from the simulation
request.

g. Open the verification request and select the simulation request.

It contains the modified initial input and output parameters. You can view the modified input
and output parameters by clicking and expanding each changed parameter.

h. In the Overview tab, select the CAE 1D Model revision, click Open, and choose the
Parameters tab.

This tab displays the input and output parameters modified by you in System Architect.

i. In the Overview tab, select the CAE 1D Analysis revision, click Open, and choose the
Parameters tab.

This tab displays the input and output parameters modified by you in System Architect.

3. Create the analysis.

After creating the simulation model, you must perform the simulation analysis.

a. Open the simulation request in Active Workspace and choose Open > Open in Simulation
Tool > Simcenter System Architect (VR) - Execute Analysis (Batch) preconfigured tool.

Since this is a batch mode tool, the execution is performed in the background. After the
execution is complete, System Architect updates the JSON files with the parameter values. The
system converts the parameter values from the JSON file to a PLM XML file and imports the
data to Teamcenter.

b. To view the status in Active Workspace, open the Simulation Tool Progress Monitor in a
separate tab of the browser.

When the status is complete, you can open the simulation request.

10. Perform simulations using integrations
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c. Refresh the simulation request and click the Overview tab.

The Output Parameters table displays the measured values.

d. In the Overview tab, select the CAE 1D Analysis revision, click Open, and choose the
Parameters tab.

The Output Parameters table displays the measured values.

Perform simulations using MDAO

Optimize systems across engineering disciplines through simulation using
MDAO

Multidisciplinary Analysis and Optimization (MDAO) is a software-driven methodology that lets you
optimize systems through simulation and across engineering disciplines.

MDAO simulations can be run as a part of the larger Model Based System Engineering (MBSE) task flow.
This task flow involves creating requirements in Teamcenter, building system models in tools such as
System Modeling Workbench (SMW), and using this information to build MDAO models designed in
HEEDS. The results from the MDAO analysis are then analyzed to verify if the design or model meets the
set requirements.

To enable this task flow, it is important to have a mechanism in place that allows the transfer of
parameter values from requirements to simulation and vice versa. This is done using Teamcenter
Parameter Management and it has been enabled in CAE MDAO Model and CAE MDAO Analysis
revision objects. This allows for linking parameters coming from requirements or system definitions with
simulation parameters stored in MDAO objects.

As an MDAO analyst, you can capture HEEDS projects and studies for the analysis and perform the MDAO
analyses using the HEEDS desktop application or perform the MDAO analysis by using the web-based
HEEDS Connect application.

Task flow for performing the MDAO analysis using the HEEDS desktop application or using the web-
based HEEDS Connect application:

Optimize systems across engineering disciplines through simulation using MDAO
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Task flow for performing the MDAO analysis with the verification request:

10. Perform simulations using integrations
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Perform the MDAO analysis using the HEEDS desktop application

As an MDAO analyst, you can capture HEEDS projects and studies for the analysis and perform the MDAO
analyses using the HEEDS desktop application.

Perform the MDAO analysis using the HEEDS desktop application
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Prerequisites

The following procedures assume that the simulation administrator has run the quick setup script
(tcsim_quick_setup.pl) to create sample configurations and that the required HEEDS integration tools
are available.

Procedure

1. Create the MDAO model.

You can use the MDAO model to manage templates for performing multi-disciplinary analysis
optimization (MDAO) simulations, for example, HEEDS or Star-CCM+ optimizations. Analysts can
use this model to create templates of studies within HEEDS and return those updated models
and studies into Teamcenter. It can be related directly to an MDAO analysis such that the MDAO
analysis can use the templates from the MDAO model object to enable a consistent simulation
task flow that ensures repeatable and consistent results. It can also be used from a verification
request as part of a larger MBSE study that encompasses Teamcenter requirements, verification,
and simulation. All MDAO analysis studies which are based on an MDAO model can also be quickly
retrieved.

a. On the HOME page, click the CREATE SIMULATION tile. From the TYPE menu, select CAE
MDAO Model.

b. Specify the ID and Revision or accept the default values.

c. (Mandatory) Specify a name for the MDAO model and click Create.

2. Create the HEEDS project.

a. (Default workspace) Select the MDAO model and choose Open  > Open in Simulation Tool
.

b. Select the HEEDS - Create or Modify Template tool.

This is the tool to open the HEEDS application and create the HEEDS project.

You can create a new project or select an existing project on the local machine.

c. Perform the necessary steps in the HEEDS application, save the project, and close the
application.

The system exports the data to Teamcenter.

d. Navigate to the ESP_ROOT directory from the tool launch in the Simulation Tool Progress
Monitor tab and open the heeds.xml file.

10. Perform simulations using integrations
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This is the PLM XML file through which the data exchange happens. You can view the MDAO
model information and the exported parameters in this file. This XML file also contains the
HEEDS parameters.

e. To verify the status of the tool launch, open the Simulation Tool Progress Monitor tab.

f. To verify changes to attachments after the tool launch is complete, select the MDAO model,
and choose the Overview tab.

The HEEDS project and the snapshot of the project are displayed in this tab.

g. Select the MDAO model, and choose the MDAO Project tab.

The study names of the project, the input files, and the input and output parameters are
displayed in this tab.

3. Update the HEEDS project.

a. (Default workspace) Select the MDAO model, and choose Open  > Open in Simulation Tool
.

b. Select the HEEDS - Create or Modify Template tool.

This opens the HEEDS application with the existing project.

c. Make the necessary modifications to the project in HEEDS and click File > Save (Final).

The system exports the data to the heeds.xml file in the ESP_ROOT directory.

When you perform a Save (Final), the system automatically creates the CAE MDAO Analysis
and CAE 3D Analysis revisions.

The parameters are imported to the CAE MDAO Analysis revision. The CAE 3D Analysis
Revision contains all the HEEDS input files. These input files are references in the CAE MDAO
Analysis Revision in the Input Files table.

d. Navigate to the ESP_ROOT directory from the tool launch in the Simulation Tool Progress
Monitor tab and open the heeds.xml file. Verify whether the changes have been exported to
this file.

e. To verify the status of the tool launch, open the Simulation Tool Progress Monitor tab.

f. To view the created analysis revision after the tool launch is complete, select the CAE MDAO
Model revision, choose the Overview tab, and select the CAE MDAO Analysis revision under
the Related CAE MDAO Analysis section.

Perform the MDAO analysis using the HEEDS desktop application

Simulation Process and Data Management on Active Workspace ─ Usage, Teamcenter 2412  10-21
© 2025 Siemens



g. To view the CAE 3D Analysis revision that is automatically created, select the CAE MDAO
Analysis revision, and choose the Overview tab.

The 3D analysis revision is automatically created to capture the input files for the analysis
execution.

h. To view the input files for the analysis execution, open the CAE 3D Analysis revision and
choose the Overview tab.

i. Navigate back to the CAE MDAO Analysis revision and choose the Overview tab.

The HEEDS project and the snapshot of the project are displayed in this tab.

j. Choose the MDAO Study tab.

The HEEDS study name, the input files, and the input and output parameters are displayed
in this tab. The input files table displays the input file list and the dataset from the CAE 3D
Analysis revision to which it is referenced.

4. Perform the MDAO analysis.

You can use the MDOA analysis workspace object to manage multi-disciplinary analysis
optimization (MDAO) simulations and studies, for example, HEEDS or Star-CCM+ optimizations,
and their associated results. It is used to create studies within HEEDS and return those updated
models and studies into Teamcenter. This object can be related directly to a CAE 3D Analysis and
MDAO model such that the MDAO analysis can use the templates from the MDAO model object to
enable a consistent simulation task flow that ensures repeatable and consistent results.

a. (Default workspace) Select the CAE MDAO Analysis revision and choose Open  > Open in
Simulation Tool .

b. Select the HEEDS - Execute Analysis tool to open the HEEDS application, perform a study
run, save the analysis results, and close the HEEDS application.

c. To verify the status of the tool launch, open the Simulation Tool Progress Monitor tab.

d. To verify the best values for the parameters after the tool launch is complete, choose the
MDAO Study tab.

The best values for the parameters are displayed in the input and output parameters tables.

e. Verify the results of the analysis by choosing the Overview tab. All the results of the MDAO
analysis are imported back to Teamcenter and they are displayed in this tab.

10. Perform simulations using integrations
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Perform the MDAO analysis using the web-based HEEDS Connect application

As an MDAO analyst, you can perform the MDAO analyses by using the web-based HEEDS Connect
application.

HEEDS Connect is a web-based application that provides sharing, monitoring, and control of analysis
results from anywhere. Unlike desktop applications, it is a collaboration tool for multiple users across an
organization. HEEDS Connect can be used only to execute HEEDS studies and do the postprocessing. You
must use HEEDS MDAO to create HEEDS projects and studies.

Prerequisites

The following procedures assume that the simulation administrator has run the quick setup script
(tcsim_quick_setup.pl) to create sample configurations and that the required HEEDS integration and
HEEDS connect tools are available.

Procedure

1. Create the MDAO model.

a. On the HOME page, click the CREATE SIMULATION tile. From the TYPE menu, select CAE
MDAO Model.

b. Specify the ID and Revision or accept the default values.

c. (Mandatory) Specify a name for the MDAO model and click Create.

2. Create the HEEDS project.

a. (Default workspace) Select the MDAO model and choose Open  > Open in Simulation Tool
.

b. Select the HEEDS - Create or Modify Template tool.

This is the tool to open the HEEDS MDAO desktop application and create the HEEDS project.

You can create a new project or select an existing project on the local machine.

c. Perform the necessary steps in the HEEDS application, save the project, and close the
application.

The system exports the data to Teamcenter.

d. Navigate to the ESP_ROOT directory from the tool launch in the Simulation Tool Progress
Monitor tab and open the heeds.xml file.

Perform the MDAO analysis using the web-based HEEDS Connect application
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This is the PLM XML file through which the data exchange happens. You can view the MDAO
model information and the exported parameters in this file. This XML file also contains the
HEEDS parameters.

e. To verify the status of the tool launch, open the Simulation Tool Progress Monitor tab.

f. To verify changes to attachments after the tool launch is complete, select the MDAO model,
and choose the Overview tab.

The HEEDS project and the snapshot of the project are displayed in this tab.

g. Select the MDAO model, and choose the MDAO Project tab.

The study names of the project, the input files, and the input and output parameters are
displayed in this tab.

3. Update the HEEDS project.

a. (Default workspace) Select the MDAO model and choose Open  > Open in Simulation Tool
.

b. Select the HEEDS - Create or Modify Template tool.

This opens the HEEDS application with the existing project.

c. Make the necessary modifications to the project in HEEDS and click File > Save (Final).

The system exports the data to the heeds.xml file in the ESP_ROOT directory.

When you perform a Save (Final), the system automatically creates the CAE MDAO Analysis
and CAE 3D Analysis revisions.

The parameters are imported to the CAE MDAO Analysis revision. The CAE 3D Analysis
revision contains all the HEEDS input files. These input files are referenced in the CAE MDAO
Analysis revision in the Input Files table.

d. To verify the status of the tool launch, open the Simulation Tool Progress Monitor tab.

e. To view the created analysis revision after the tool launch is complete, select the CAE MDAO
Model revision, choose the Overview tab, and select the CAE MDAO Analysis revision under
the Related CAE MDAO Analysis section.

f. To view the CAE 3D Analysis revision that is automatically created, select the CAE MDAO
Analysis revision, and choose the Overview tab.

10. Perform simulations using integrations
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The 3D analysis revision is automatically created to capture the input files for the analysis
execution.

g. To view the input files for the analysis execution, open the CAE 3D Analysis revision and
choose the Overview tab.

h. Navigate back to the CAE MDAO Analysis revision and choose the Overview tab.

The HEEDS project and the snapshot of the project are displayed in this tab.

i. Choose the MDAO Study tab.

The HEEDS study name, the input files, and the input and output parameters are displayed
in this tab. The input files table displays the input file list and the dataset from the CAE 3D
Analysis revision to which it is referenced.

4. Perform the MDAO analysis.

a. (Default workspace) Select the CAE MDAO Analysis revision and choose Open  > Open in
Simulation Tool .

b. To perform the analysis, select the HEEDS Connect - Execute Analysis tool and click Open to
send the HEEDS study parameters to the HEEDS Connect application.

Note:

Verify if HEEDS Connect is up and running before performing this step.

c. To verify the status of the tool launch, open the Simulation Tool Progress Monitor tab.

d. Open HEEDS Connect in a browser to view the and run the study. After the study is
complete, postprocess the results as appropriate. After you are ready to upload the results
to Teamcenter, navigate back to the Home page of HEEDS Connect, right-click the study, and
select Upload to TcSim.

e. To verify the best values for the parameters after the tool launch is complete, choose the
MDAO Study tab.

The best values for the parameters are displayed in the input and output parameters tables.

f. Verify the results of the analysis by choosing the Overview tab. All the results of the MDAO
analysis are imported back to Teamcenter and they are displayed in this tab.

Perform the MDAO analysis using the web-based HEEDS Connect application
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Perform the MDAO analysis on the verification request

As an MDAO analyst, you can create a HEEDS project based on a verification request, capture the data
required for the analysis, and perform the analysis.

Prerequisites

The following procedures assume that the simulation administrator has run the quick setup script
(tcsim_quick_setup.pl) to create sample configurations and that the required verification scope tools
are available. It is also assumed that a Verification Request object has been created from a set of
requirements and system definition. Additionally, a Simulation Request object has been created under
the Verification Request to store and validate the simulation data.

Procedure

1. Create the HEEDS project.

a. (Analyst workspace) Select the simulation request and choose Open in Simulation Tool .

(Default workspace) Select the simulation request and choose Open  > Open in Simulation
Tool .

b. Select the HEEDS - Create Model (Verification Scope) tool.

This is the tool to open the HEEDS application and create the HEEDS project.

You can create a new project or select an existing project on the local machine.

c. Perform the necessary steps in the HEEDS application, save the project, and close the
application.

The system exports the data to Teamcenter.

d. To verify the exported data, navigate to the Temp\ESP_ROOT directory from the tool launch in
the Simulation Tool Progress Monitor tab and open the heeds.xml file.

This file displays details about the simulation request, the CAE MDAO Model revision, and the
exported parameters.

e. To verify the status of the tool launch, open the Simulation Tool Progress Monitor tab.

f. To verify if the newly created CAE MDAO Model object is attached to the Simulation Request
object after the tool launch is complete, select the Simulation Request object, and choose
the Overview tab.

10. Perform simulations using integrations
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The CAE MDAO Model object is attached to the Simulation Request object in the
SIMULATION MODELS section.

g. To verify the exported HEEDS data, open the simulation model, and choose the MDAO Project
tab.

This tab displays the HEEDS study names, input files, and HEEDS project level input and output
parameters.

h. To view the uploaded HEEDS project files, open the CAE MDAO Model revision and choose
the Overview tab.

2. Update the HEEDS project.

a. (Author workspace) Select the Simulation Request object containing the requirements,
system model definition, and their associated parameters, and choose Open  > Open in
Simulation Tool .

(Analyst workspace) Select the Simulation Request object containing the requirements,
system model definition, and their associated parameters, and choose Open in Simulation
Tool .

b. Select the HEEDS - Modify Model (Verification Scope) tool.

This opens the HEEDS application with the existing project.

c. Make the necessary modifications to the project and click File > Save (Final) in the HEEDS
application.

The system exports the data to the heeds.xml file in the ESP_ROOT directory.

In addition to the simulation request information, the MDAO model information also gets
exported to this file.

The system automatically creates the existing CAE MDAO Analysis and creates the CAE
3D Analysis revisions. The CAE MDAO Analysis revision contains the HEEDS study related
information including the input and output parameters, The CAE 3D Analysis revision
contains the HEEDS input files required for the HEEDS study. In addition, the system creates
relationships between existing and newly created objects. Both the CAE MDAO Model and
CAE MDAO Analysis revisions are placed under the Simulation Models section of the
Simulation Request object.

d. Navigate to the ESP_ROOT directory from the tool launch in the Simulation Tool Progress
Monitor tab and open the heeds.xml file. Verify whether the changes have been exported to
this file.

e. To verify the status of the tool launch, open the Simulation Tool Progress Monitor tab.

Perform the MDAO analysis on the verification request
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f. To verify the status of the newly created MDAO analysis revision after the tool launch is
complete, select the Simulation Request object and choose the Overview tab.

The SIMULATION MODELS section displays the newly created CAE MDAO Analysis revision.

g. Open the CAE MDAO Analysis revision and choose the Overview tab.

This tab displays the newly created CAE 3D Analysis revision.

h. To view the study names of the project, the input files, and the input and output parameters,
choose the MDAO Study tab. The input files table displays the input file list and the dataset in
the CAE 3D Analysis revision to which they are referenced.

i. To view the HEEDS project details and the related objects, choose the Overview tab.

j. To view the inputs required for the analysis, open the CAE 3D Analysis revision, and choose
the Overview tab.

3. Perform the analysis on the simulation request.

a. (Default workspace) Select the Simulation Request object and choose Open  > Open in
Simulation Tool .

b. Select the HEEDS - Execute Analysis (Verification Scope) tool to open the HEEDS
application, perform a study run, save the analysis results, and close the HEEDS application.

c. Verify the status of the tool launch in the Simulation Tool Progress Monitor tab. After the
tool launch is complete, select the Simulation Request object, and choose the Overview tab.

The input and output PARAMETERS section displays the parameters and the pass or fail status
of each parameter.

d. Verify the results of the analysis by choosing the Overview tab. All the results from the HEEDS
study are imported back to Teamcenter and they are displayed in this tab.

Perform simulations using Simcenter STAR-CCM+

Perform computational fluid dynamics analysis using Simcenter STAR-CCM+

Simcenter STAR-CCM+ is a software used for computational fluid dynamics (CFD) analysis. It helps
reduce simulation preparation time with automated meshing and preprocessing of complex geometries.

As a simulation analyst, you can use the Simcenter STAR-CCM+ application to connect to Teamcenter
(Active Workspace interface) and perform tasks such as create a new simulation in STAR-CCM+ based on
a CAE 3D analysis template in Teamcenter, open a simulation in STAR-CCM+ from an existing 3D analysis
revision in Teamcenter, and create a simulation template in STAR-CCM+ from a 3D analysis template in
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Teamcenter for performing analyses. You can then complete the analysis and import the files back to
Teamcenter by performing all the tasks in STAR-CCM+ application.

The task flow is as follows:

Perform the simulation based on a template using the STAR-CCM+
application

As a simulation analyst, you can create a new simulation in STAR-CCM+ application based on a CAE
3D analysis template in Teamcenter. Additionally, you import the required geometry and publish the
template to bring the changes back to Teamcenter.

Perform the simulation based on a template using the STAR-CCM+ application
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Prerequisites

The STAR-CCM+ application, the appropriate JDK version as required by STAR-CCM+, and Teamcenter
Tool Launcher Client (TTLC) must be installed on the client machine from where the integration is being
run.

Procedure

1. Create a new simulation in STAR-CCM+ application based on an analysis template in Teamcenter
and import the changes back to Teamcenter.

a. Launch the STAR-CCM+ application and click Connect > Teamcenter > Open Active
Workspace to log on to the embedded Active Workspace.

In the URL box, you must specify the Active Workspace URL followed by /tc, for example,
http://10.22.148.88:3000/tc

Contact the administrator at your site for the Active Workspace URL and the default port
number.

b. Search and open the appropriate CAE 3D Analysis Template revision having a simulation
template file (*.simt) attached to it.

c. Click More Commands > New > Create Simulation and select CAE 3D Analysis in embedded
Active Workspace view. Specify information as appropriate and create the 3D analysis revision.

d. In Explorer, select the analysis revision, and click Connect > Teamcenter > Create
Simulation.

e. To import the simulation back to Teamcenter from STAR-CCM+, click Connect > Teamcenter >
Publish Simulation.

f. To verify the import, select the CAE 3D Analysis revision and click the Overview tab in
embedded Active Workspace view.

The generated simulation file attached to the analysis revision is displayed in this tab.

2. Open a simulation in STAR-CCM+ application from an existing 3D analysis revision in Teamcenter,
import the required geometry, and publish the template to import the changes to Teamcenter.

a. Start the STAR-CCM+ application by running the .bat file and click Connect > Teamcenter >
Open Active Workspace to log on to the embedded Active Workspace.

b. Search and open an existing CAE 3D Analysis revision with the simulation file.

c. To create the simulation, click Connect > Teamcenter > Open Simulation.
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d. To import geometry for the simulation, select a CAD object such as a CAE 3D Geometry
revision in embedded Active Workspace view, click Connect > Teamcenter > Import
Geometry.

The geometry file is imported to STAR-CCM+ and the files are listed under the Parts folder.

e. Save the simulation.

f. To bring the changes in the modified simulation back to Teamcenter, select the CAE 3D
Analysis revision, and click Connect > Teamcenter > Republish Simulation

g. To verify the modified simulation, select the CAE 3D Analysis revision and click the Overview
tab in embedded Active Workspace view.

The modified simulation file attached to the analysis revision is displayed in this tab. Look at
the Date Modified information to verify this change.

3. Create a simulation template in STAR-CCM+ application from a 3D analysis template in Teamcenter,
import the required geometry, and import the template to bring the changes to Teamcenter.

a. Open a CAE 3D Analysis Template that does not have any simulation templates.

b. To create the simulation, click Connect > Teamcenter > Open Simulation.

c. To import geometry for the simulation, select a CAD object in the embedded Active
Workspace, click Connect > Teamcenter > Import Geometry.

The geometry file is imported to STAR-CCM+ and they are listed under the Parts folder.

d. To create the template, click Connect > Teamcenter > Publish As Template.

The template is imported back to Teamcenter.

e. Click the Overview tab in the embedded Active Workspace user interface.

The simulation file attached to the analysis template is displayed in this tab.

Perform the simulation without templates using STAR-CCM+ application

As a simulation analyst, you can create a new simulation in the STAR-CCM+ application and import the
simulation to Teamcenter. Additionally, you can import an unmanaged simulation from the application
to Teamcenter.

Perform the simulation without templates using STAR-CCM+ application
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Prerequisites

The STAR-CCM+ application, the appropriate JDK version as required by STAR-CCM+, and Teamcenter
Tool Launcher Client (TTLC) must be installed on the client machine from where the integration is being
run.

Procedure

1. Create a new simulation in the STAR-CCM+ application and import or publish the simulation to
Teamcenter.

a. Launch the STAR-CCM+ application and click Connect > Teamcenter > Open Active
Workspace to log on to the embedded Active Workspace.

In the URL box, you must specify the Active Workspace URL followed by /tc, for example,
http://10.22.148.88:3000/tc

Contact the administrator at your site for the Active Workspace URL and the default port
number.

b. Create a new CAE 3D Analysis revision in embedded Active Workspace view.

c. In STAR CCM+ application, click Connect > Teamcenter > Create Simulation.

Build the simulation file in STAR CCM+ application and save it locally.

d. To import the simulation file to Teamcenter, click Connect > Teamcenter > Publish
Simulation

2. Publish an unmanaged simulation to Teamcenter.

a. Start the STAR-CCM+ application by running the .bat file and click Connect > Teamcenter >
Open Active Workspace to log on to the embedded Active Workspace.

b. In STAR-CCM+, open a local or unmanaged (*.sim) file.

c. Build the simulation file in STAR CCM+ application and save it locally.

d. Create a new CAE 3D Analysis revision in embedded Active Workspace view.

e. To import the simulation file to Teamcenter, click Connect > Teamcenter > Publish
Simulation
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Perform simulations using STAR-CCM+ Design Manager

Perform design exploration studies using STAR-CCM+ Design Manager

STAR-CCM+ Design Manager provides an automated approach to running design exploration studies.
The performance assessment study runs a product through a predefined set of conditions to understand
the influence of key parameters on the performance of the product. The design optimization study
algorithm determines the input conditions automatically to improve the product for specific goals.

The process is as follows:

Perform the analysis using Design Manager

As an MDAO analyst, you can create the Design Manager project by launching a preconfigured
simulation tool, start a design study in Design Manager, and perform the analysis by launching a
preconfigured simulation tool.

Perform design exploration studies using STAR-CCM+ Design Manager

Simulation Process and Data Management on Active Workspace ─ Usage, Teamcenter 2412  10-33
© 2025 Siemens



Prerequisites

The following procedures assume that the simulation administrator has run the quick setup script
(tcsim_quick_setup.pl) to create preconfigured simulation tools and that the required Design Manager
integration tools are available.

Procedure

1. Create the MDAO model.

a. On the HOME page, click the CREATE SIMULATION tile. From the TYPE menu, select CAE
MDAO Model.

b. Specify the ID and Revision or accept the default values.

c. (Mandatory) Specify a name for the MDAO model and click Create.

2. Create the Design Manager project by launching a preconfigured simulation tool.

a. (Default workspace) Select the MDAO model you created in step 1 and choose Open  >
Open in Simulation Tool .

b. Select the STAR-CCM+ Design Manager - Create/Modify tool.

The system creates the Design Manager project (.dmprj file).

3. Create a design study in Design Manager.

a. Open the Design Manager project (.dmprj file created in step 2).

b. To provide a reference simulation file for the study, in Design Manager, choose Simulation,
right-click, select Read Reference Simulation > Browse, and provide the simulation file
(.sim).

Design Manager reads this file, and all the data and parameters required for the new study are
now available.

c. Specify the input parameters, responses, and scenes as appropriate.

The input parameters are already available from the .sim file selected for the project.

d. (Optional) Change the run settings as appropriate by choosing Settings > Run Settings. For
example, you can execute two jobs at a time and specify four compute processes.

e. To save the study, click Save in Design Manager.
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The Design Manager project file is saved.

f. Close Design Manager.

MDAO analysis objects are created automatically, and one object is created for each study.

The system imports the input files to Teamcenter, automatically creates the CAE 3D Analysis
revision, and the input files are mapped to it.

g. In Active Workspace, open the CAE MDAO Model revision and select the MDAO Project tab.

The revision is populated with the study information.

Only input files are shown and no parameters are imported.

h. To see the associated CAE MDAO Analysis revision that is automatically created by the
system, select the Overview tab.

The associated analysis revision is displayed with the name as the study name.

i. To view the study details, open the associated analysis revision and select the MDAO Study
tab.

The study status is displayed as Not Started.

j. View the input file (.sim) attached to the 3D analysis revision.

A. Select the Overview tab.

B. Open the CAE 3D Analysis revision from the Input Item Revisions section.

C. Choose the Overview tab to view the input file.

4. Modify the study you have created in Design Manager by creating a second study.

a. (Default workspace) Select the MDAO model you created in step 1 and choose Open  >
Open in Simulation Tool .

b. Select the STAR-CCM+ Design Manager - Create/Modify tool.

c. Add a second study and specify input parameters, responses, and scenes as appropriate.

d. To save the study, click Save in Design Manager.

The Design Manager project file is saved.

Perform the analysis using Design Manager
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e. Close Design Manager.

MDAO analysis objects are created automatically, and one object is created for each study.

The system imports the input files to Teamcenter, automatically updates the CAE 3D Analysis
revision, and the input files are mapped to it.

f. In Active Workspace, open the CAE MDAO Model revision and select the MDAO Project tab.

The revision is updated with the study information. You can view two studies in the Study
column and the study names are separated by commas.

g. To see the associated CAE MDAO Analysis revision that is automatically created by the
system, select the Overview tab.

The associated analysis revision for the second study is displayed with the name as the study
name.

h. To view the details of the second study, open the associated analysis revision and select the
MDAO Study tab.

The study status is displayed as Not Started.

i. View the input file (.sim) attached to the 3D analysis revision for the second study.

A. Select the Overview tab.

B. Open the CAE 3D Analysis revision for the second study from the Input Item Revisions
section.

C. Choose the Overview tab to view the input file.

5. Perform the analysis by launching a preconfigured simulation tool.

a. Select the CAE MDAO Analysis revision that was automatically created in step e and choose
Open  > Open in Simulation Tool .

b. Select the STAR-CCM+ Design Manager - Run Study tool.

Alternatively, you can select the STAR-CCM+ Design Manager - Run Study Batch tool to run
the Design Manager project in batch mode.

The system loads the Designer Manager project file associated with the MDAO model revision.
It starts the execution automatically since the study name and all other data are available.
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c. In Design Manager, verify the status of the design studies and wait for the execution of the
studies to be complete.

d. To save the results of the study, click Save in Design Manager.

e. Close Design Manager.

f. To view parameters based on the best design, in Active Workspace open the CAE MDAO
Analysis revision, and choose the MDAO Study tab.

The study status is displayed as completed and the Input Parameters and Output
Parameters sections are updated, for example, with minimum measured and maximum
measured values, value usage, and resolution.

g. (Optional) If you want to specify the file that is present on your desktop, you can select Input
File Path, choose More Options > New > Select Input File, and specify the complete file
path.

You can select datasets In Teamcenter or choose Outside Teamcenter. Choose the latter
option to specify the file path to the file on your desktop.

The system allows only datasets within Teamcenter or a file from outside Teamcenter.

h. To view the zip file of the Design Manager project and the design study, choose the Overview
tab.

The design study zip file contains the details of the design study.

i. View the results files.

A. In the Simulation Tool Progress Monitor, select STAR-CCM+ Design Manager - Run
Study tool, and choose Open Directory.

B. Select the ESP_ROOT > Design_Study folder.

The folder name and the compressed file have the same name as the Design Manager
project name.

The mesh information, scene, and plot files are available in this directory as STAR view
and PNG files.

j. View the log files.

A. In the Simulation Tool Progress Monitor, select STAR-CCM+ Design Manager - Run
Study tool, and choose Open Directory.

Perform the analysis using Design Manager
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B. Select the ESP_ROOT > ESP_LOGS directory.

The log files are available in this directory.

Perform simulations using Simcenter Studio

Create different system architectures using Simcenter Studio

Simcenter Studio is a web-based application for engineers and data scientists to create novel and
topologically different system architectures. It generates and evaluates system architectures during
the early concept phase. The software has a computational notebook that contains narrative text
and mathematical equations, code, models, model block diagrams, simulation as code, and result
visualization. All of these are combined in one document for easy usage. This integration is currently
manual.

The tool is based on the Jupyter framework. For more information, see https://jupyter.org/.

10. Perform simulations using integrations
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Create the computational notebook by using Simcenter Studio

As a system engineer, you can create a computational notebook by using the Simcenter Studio web
application. The computation notebook is for creating the mathematical equations, code, models, and
other data required for the simulation.

Procedure

1. Log on as a simulation analyst to the Analyst workspace.

2. Open the CAE 1D Model revision that contains the CAE Amesim file as per the requirement.

This is the input file for Simcenter Studio.

3. Create a computational notebook in the context of the 1D model revision. To do so:

a. Choose More Commands > New > Create Simulation > CAE Computational Notebook
revision.

b. Specify a name for the computational notebook and other details as appropriate, and click
Create.

c. (Optional) To view the relationship between the computational notebook and the 1D, select
the CAE Computational Notebook revision and choose the Relation tab. Expand the
outgoing relation and click the connector. The system displays the Include relationship.

4. Open the Simcenter Studio web application to create a computational notebook.

The notebook contains narrative text and mathematical equations, code, models, model block
diagrams, simulation as code, and result visualization

5. To download files from the Simcenter Studio web application, select the required files, click the File
menu, and choose Download.

The files are downloaded as a compressed file (*.nbzip).

6. Upload the files to Teamcenter.

a. In Active Workspace, navigate to the CAE Computational Notebook revision and choose the
Overview tab.

b. In the Files section, click Add to, choose the compressed file (*.nbzip), and click Add.

7. To upload input parameters for the simulation manually, choose the Parameters tab, click Quick
Add, and enter the data.
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8. (Optional) To delete the computational notebook, open the CAE 1D Model revision, select it from
the Notebook section in the Overview tab, and choose More Commands > Edit > Delete.

9. (Optional) Revise the computational notebook.

When you perform a revise operation, the compressed file (*.nbzip) included in the Attachment
tab is not carried forward to the new revision. The other files with Specification relation are carried
forward.

a. Open the CAE Computational Notebook revision and choose More Commands > New  >
Revise .

b. (Optional) Specify required information as appropriate.

c. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

d. To revise, click Save.

10. (Optional) Make a copy of the computational notebook.

When you make a copy, the compressed file (*.nbzip) included in the Attachment tab is not carried
forward to the new revision. The other files with Specification relation are carried forward.

a. Open the CAE Computational Notebook revision and choose More Commands >
New   > Save As .

b. (Optional) Specify a new name if you want to create a copy and description.

c. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

Create the computational notebook by using Simcenter Studio
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d. To create a copy, click Save.

Create the computational notebook run to perform simulations in Simcenter
Studio

As a simulation analyst, you can create a computational notebook run in Teamcenter and perform
simulations by using the Simcenter Studio web application.

Procedure

1. Log on as a simulation analyst to the Analyst workspace.

2. Create a computational notebook run.

a. Select a folder and choose More Commands > New > Create Simulation.

b. Select CAE Computational Notebook Run, specify a name (mandatory), and include other
information as appropriate.

c. Select CAE Computational Notebook and choose the computational notebook created by the
system architect in Create the computational notebook by using Simcenter Studio and click
the Create button.

3. Perform simulations from the Simcenter Studio web application.

a. Open the CAE Computational Notebook Run you created.

b. Choose the Overview tab and download the compressed file.

c. Open the Simcenter Studio web application and perform the simulation.

d. To download files with simulation results from the Simcenter Studio web application, select
the required files, click the File menu, and choose Download.

The files are downloaded as a compressed file (*.nbzip).

e. To upload the downloaded files with simulation results, choose the Overview tab. In the Files
section, click Add to, choose the compressed file, and click Add.

f. To specify the result parameters manually, choose the Parameters tab, click Quick Add and
enter the data.

4. (Optional) Revise the computational notebook run.

10. Perform simulations using integrations
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When you perform a revise operation, the compressed file (*.nbzip) included in the Attachment
tab is not carried forward to the new revision. The other files with Specification relation are carried
forward.

a. Open the CAE Computational Notebook Run revision and choose More Commands > New
 > Revise .

b. (Optional) Specify required information as appropriate.

c. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

d. To revise, click Save.

5. (Optional) Make a copy of the computational notebook run.

When you make a copy, the compressed file (*.nbzip) included in the Attachment tab is not carried
forward to the new revision. The other files with Specification relation are carried forward.

a. Open the CAE Computational Notebook Run revision and choose More Commands >
New   > Save As .

b. (Optional) Specify a new name if you want to create a copy and description.

c. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

d. To create a copy, click Save.

Create the computational notebook run to perform simulations in Simcenter Studio
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11. Create CAE analysis package definitions
for common simulation tasks
Create CAE packages based on a common template

Analyst groups in companies typically perform multiple types of analyses based on a product definition
or a set of requirements and validate them. Examples include strength analysis, durability analysis, fluid
analysis, or crash analysis. They also perform these analyses multiple times, for example, based on
different load cases or different input geometry variations. The processes and tools used and the input
and output may vary across analyses.

To create an analysis package for a specific type of analysis, the analysts must know which items,
datasets, and relationships to create and then create multiple CAE item revisions one at a time and
establish relationships between different item revisions.

At a site, analysts may have different categories of analysis packages. Based on a common template,
these different users (based on their roles) create different package definitions and save them to the
database to make this process easier and more efficient.

Analysts can use the package definitions created by the simulation administrator or the group
administrator to create their own CAE item revisions. They can use these packages to define input parts
(item revisions), output items, the relationships between the output item revision to their input parts,
and the output datasets within one or more output item revisions.

• Site-level package definitions.

These are standardized and approved package definitions created by the simulation administrator and
used by multiple analysts across the enterprise to create a set of CAE item revisions for a specific
analysis.

For more information, see Simulation Process and Data Management ─ Deployment and
Administration.

• Group-level package definitions.

These are standardized and approved package definitions created by the group administrator and used
by multiple analysts across the enterprise to create a set of CAE item revisions for a specific analysis.
Access to these are limited to members of that group.

For more information, see Simulation Process and Data Management ─ Deployment and
Administration.

• User-level package definitions.
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These are created by an analyst and used only by this analyst.

For more information about creating user-level packages in rich client, see Configure CAE packages in
Simulation Process and Data Management on Rich Client ─ Usage.

Create analysis revisions by executing predefined CAE packages

1. On the HOME page, click CAE PACKAGES.

2. From the displayed packages, open the package.

3. Specify the input.

If you select an input object, the system resolves the preconfigured keywords and updates the
property values of the output item.

The keyword examples for preconfigured input rules are as follows:

Example 1:

Item ID pattern
configuration for
CAE package

After the package is
executed with the
input item ID as
000387

After the package is
executed the second
time with the same
input item ID

After the package
is executed with a
different input item
ID as 000341

CAE Analysis
is configured as
INPUTID".sim"N

Item ID for
CAE Analysis is
000387.sim1

Item ID for
CAE Analysis is
000387.sim2

Item ID for
CAE Analysis is
000341.sim1

CAE Model is
configured as
INPUTID".fem"N

Item ID for CAE
Model item ID is
000387.fem1

Item ID for
CAE Model is
000387.fem2

Item ID for
CAE Model is
000341.fem1

CAE Result is
configured as
INPUTID".res"N

Item ID for CAE
Result is 000387.res1

Item ID for CAE
Result is 000387.res2

Item ID for CAE
Result is 000341.res1

CAE Geometry
is configured as
INPUTID".i"N

Item ID for
CAE Geometry is
000387.i1

Item ID for
CAE Geometry is
000387.i2

Item ID for
CAE Geometry is
000341.i1

Example 2:
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CAE package configuration for CAE
Analysis

After the package is executed with input
ID as 000387 and input item name as
NX_Numbers for CAE Analysis

The item ID pattern is configured as
INPUTID".sim"N.

The item ID is 000387.sim1.

The name pattern is configured as
INPUTNAME".sim"N.

The item name is NX_Numers.sim1.

The item description pattern is configured as
"Test Package for .sim - "N.

The item description is Test Package for .sim
- 1.

Example 3:

CAE package configuration for CAE
Analysis

After the package is executed with input
ID as 000387 and input item name as
NX_Numbers for CAE Analysis

The item ID is not configured, that is, item ID
pattern is empty.

The item ID is automatically generated by the
system.

The item name pattern is configured as
INPUTNAME".sim"N.

The item name is NX_Numers.simN.

The item description pattern is configured as
"Test Package for .sim - "N.

The item name description is Test Package
for .sim - N.

Example 4:

Item ID pattern
configuration for
CAE Geometry

Existing numbers in
the database for the
pattern N

Missing numbers in
the database for the
pattern N

Allocated numbering
for the pattern N
after the package is
executed

INPUTID".i"N 1, 2, 3, 4, 5, 7, 9 6, 8 6, 8, 10, 11, and so
on

For more information about keywords, see Configure CAE packages in Simulation Process and Data
Management on Rich Client ─ Usage.

a. In the Object column of the INPUTS table, click the box you want to edit and click Add .
Make the appropriate selection in the Add panel and choose the Add button.

b. (Optional) To remove the object, click Remove .

4. Specify the output.

When you select an output object, the system resolves the preconfigured keywords and updates the
property values of the output item.

Create analysis revisions by executing predefined CAE packages
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a. To add properties, in the OUTPUT table, click Add Properties . The system selects the first
row automatically and the table rows become non editable.

The Add Properties panel is pinned automatically and remains open. You must specify or
select the properties in the Add Properties panel.

b. To add an existing object for the output, click the box and click Add . Make the appropriate
selection from the Palette or the Search tab in the Add panel and click the Add button.

The system reuses existing objects while executing packages.

c. To edit another row, click the row without closing the Add Properties panel. Specify or select
properties as appropriate.

Repeat this step to edit other rows.

d. (Optional) To edit the Name, Item ID, or Description boxes directly, click the respective box
and specify the appropriate values.

e. To clear all the boxes in the OUTPUT table, click Clear All .

5. (Optional) Specify a destination folder for the system to create the output objects. By default, it is
Newstuff.

You can also specify a subfolder under the destination folder for the system to create the output
objects.

The system remembers the destination folder value when you execute a CAE package
subsequently.

6. To enable the creation of logs, select Persist Log.

By default, logs are disabled.

7. To create the package, click Execute.

You can execute, for example, a predefined CAE package to create analysis revisions and boundary
condition revisions with the CAE Extract relation.

8. To view the related revisions and the relations created by the CAE package, navigate to the output
folder, open the analysis revision, and click the Overview tab.

If you have executed a predefined CAE package to create analysis revisions and boundary condition
revisions with relations, the system displays the CAE Extract relation with the boundary condition
revisions for the analysis revision.

11. Create CAE analysis package definitions for common simulation tasks
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9. Open the package log file from the destination folder specified in step 5.

The log contains details of the existing output objects and details of the subfolder, if specified.

Create analysis revisions by executing predefined CAE packages
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12. Specify key performance indicator (KPI)
values for analysis revisions
Why specify KPI values?

As a simulation analyst, you can specify key performance indicator (KPI) values such as maximum
stress, minimum temperature, or maximum displacement manually in an analysis revision or an analysis
template. Alternatively, you can update the KPI values automatically using a preconfigured simulation
tool.

After the KPI values are specified manually or updated automatically, the simulation administrator can
monitor these values on the simulation dashboard by using queries.

Specify KPI values manually

You can specify KPI values manually in an analysis revision or an analysis template. If you specify the
values in an analysis template, you can associate the template to an analysis revision.

1. Open an analysis revision or analysis template and click the KPI tab.

2. Choose More Commands > Edit  > Start Edit.

3. Click Add.

4. In the KPI table, specify values as appropriate.

5. (Optional) To add another table row, click Add and specify the values.

6. Choose More Commands > Edit  > Save Edits.

Update KPI values automatically using a preconfigured simulation
tool

The following procedure assumes that the simulation administrator has set up the sample configurations
by running the tcsim_quick_setup.pl script and that the default Extract KPI from Result tool is
available.

After you launch the preconfigured simulation tool, the system exports the results files, an attribute XML
file containing the KPI table attributes, the launch script, and the NX Open utility to the staging directory.
The system creates the KPITemplateFile subdirectory to which it exports the template XML file. It then
calls the launch script, which internally calls the NX Open utility with the path to the results file, the path
to the template XML file and the path to the output directory path as arguments. The NX Open utility
extracts the required KPI values from the results file based on the template XML file and generates the
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output KPI text file. The system updates the KPI table in the attribute XML file and populates the KPI table
of the analysis revision.

The preconfigured simulation tool is supported on launch methods such as local, remote, and server.

1. Open a CAE 3D Analysis item revision containing results files and click the Overview tab.

2. (Analyst workspace) Choose Open in Simulation Tool .

(Default workspace) Choose Open  > Open in Simulation Tool .

3. Select Extract KPI from Result.

4. (Optional) Specify the Default Scratch Location.

5. (Optional) Choose a template by searching for the item revision that contains the template.

By default, the system displays the KPI/A;1-Thermal-Template template. This contains a sample
thermal template XML file dataset. This template file provides the names of the KPI values that are
associated with the results files.

6. (Optional) Select the Launch without configured input check box to run the tool without any
predefined inputs.

7. Resolve file upload conflict options by selecting one of the following options:

• Prompt User if you want the system to displays the conflicts in the Pending User Action tab of
the Simulation Tool Progress Monitor.

• Auto Process if you do want the system to display the conflicts. If you select this option, select:

Option Description
Upload File/Update
URL

The system uploads the output files and creates new versions of existing
files with the same name. This is the default option.

Rename and Upload/
Rename and Create
URL

The system automatically renames the output files with a suffix, if
similar filenames exist, and uploads them to the database.

Skip The system avoids uploading the output files, if similar files exist in the
database.

8. Select the Display Progress Monitor on Launch option to open the Simulation Tool Progress
Monitor in a separate tab of the browser.

9. To launch the tool, click Open.

12. Specify key performance indicator (KPI) values for analysis revisions
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Monitor the tool launch in the Simulation Tool Progress Monitor and verify if the tool launch
completed successfully.

10. (Optional) Browse to the KPITemplateFile directory created by the system in the Default Scratch
Location path. The system exports the template XML file to this directory.

11. (Optional) Browse to the Default Scratch Location path and open the output KPI text file. The
name of the output text file is based on the name of the result file attached to the analysis revision.
For example, if the result fie name is result.op2, the output text file is named as result.op2.txt.

This directory also contains the Extract_KPI_from_Results.pl launch script and the
TC4SIM_KPI_EXTRACTOR.zip compressed file that contains the NX Open utility. The compressed
file contains a help folder that includes tutorials, examples and a PDF document explaining the
functionality of NX Open Utility and instructions on how to add new or to edit existing KPI
quantities. These are the default files that are available with the preconfigured KPI extraction tool.

12. Open the analysis revision and click the KPI tab. Verify if the KPI table is automatically populated.

Update KPI values automatically using a preconfigured simulation tool
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13. Using the Teamcenter Simulation
desktop application
Why use the desktop application?

Not all simulation analysts are familiar with Teamcenter, and they need a simple application to
perform daily activities such as reviewing tasks and uploading and downloading files. The Teamcenter®
Simulation Software is a desktop application that allows simulation analysts to perform these activities.
This desktop application is available on the Windows and Linux operating systems.

As a simulation analyst, you can download this desktop application to your desktop and provide the
necessary connection details to connect to the Teamcenter server at your site. After logging on to the
desktop application, you can access the Home tab to view the tasks listed in the Inbox and the latest
files you have worked on in Recent Files.

Download, install, and specify the connection settings for the
desktop application

As a simulation analyst, you can download and install the Teamcenter® Simulation software desktop
application to perform daily activities such as reviewing tasks and uploading and downloading files.
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After you download the desktop application, you can install the desktop application and specify the
settings to connect to Teamcenter.

Procedure

1. Download the Teamcenter® Simulation Software from the following location:

Support Center > Downloads > Additional Downloads

You can download the desktop application with the following file extensions as appropriate:

• .exe file extension is an executable that runs on the Windows operating system.

• .rpm file extension is a Red Hat Package Manager that runs on the Red Hat Linux operating
system.

• .deb file extension is a Debian software file package that runs on UNIX operating systems such as
Ubuntu.

2. Run the executable to start the installation and select the appropriate options to proceed with the
installation.

The user who runs this executable should have read/write access to the installation directory.

3. After downloading and installing the desktop application, you can run the desktop application to
specify the settings to connect to Teamcenter. This is a one-time activity.

Note:

Contact the system administrator at your site for information about the Active Workspace URL
and the FMS URL. The FMS URL information is optional.

a. (Mandatory) In the Active Workspace URL box, specify the URL to the Active Workspace
server.

Example: 10.22.148.88:3000

In the above example, the Active Workspace URL is followed by 3000, which is the default
port number. This is the port on which the Gateway Service runs.

13. Using the Teamcenter Simulation desktop application
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b. (Optional) In the FMS URL box, specify the URL of the File Management Systems (FMS)
master.

Example: 10.22.148.88:4544

In the above example, 4544 is the default port number specified in the Fms_Bootstrap_Urls
site preference.

c. (Optional) Browse to the location you want to specify as the working directory.

4. (Optional) Use a different file upload rule.

a. Log out of the desktop application.

b. Open the \AppData\Local\Programs\Teamcenter Simulation\settings.json file and clear the
consolidatedFileUploadRuleSetId parameter.

{
  "activeWorkspaceUrl": "http://10.22.148.124:3000",
  "fmsUrl": "http://vc6s015:4544",
  "workingDirectory": "",
  "consolidatedFileUploadRuleSetId": ""
}

Download, install, and specify the connection settings for the desktop application
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Note:

If the consolidatedFileUploadRuleSetId parameter is not available, the system
automatically populates this field using a predefined rule for uploading the data for
default objects.

c. Replace the \AppData\Local\Programs\Teamcenter
Simulation\CAE_File_Upload_Rule_config.xml file with a new XML file containing the file
upload rules.

Note:

Contact the simulation administrator at your site for the XML file containing the file
upload rules.

d. Log on to the desktop application and upload the required files.

When you close the Simulation desktop application without logging out, it continues to run in
the system tray for the Windows operating system. However, this does not apply for the Linux
operating system.

Working with the desktop application

As a simulation analyst, you can use the Teamcenter® Simulation software desktop application to
perform daily activities such as reviewing tasks and uploading and downloading files.

Procedure

1. View assigned tasks and the recent files you have worked on.

a. To view tasks assigned to you, click the Home. Hover over the appropriate task and click Open
to view the task in a window embedded with Active Workspace user interface. The simulation
analyst can complete the required task in the Overview tab of the embedded viewer.

b. To view the recent files you have worked on, click the Home tab. Hover over the appropriate
file and click Open to view the selected file in a window embedded with Active Workspace
user interface. The simulation analyst can complete the required task in the Files tab of the
embedded viewer.

2. Download files.

a. To download files, click the Data tab.

b. To download multiple files, press CTRL on your keyboard, select multiple files, and click
Download All.

13. Using the Teamcenter Simulation desktop application
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c. To navigate quickly to the location where the file was downloaded, click the Go to Files
hyperlink.

3. Upload files.

Note:

Downloads and uploads can occur simultaneously. The progress monitor displays both.

a. To upload files, click the Transfers tab.

b. Drag and drop the files you want to upload.

When you drag and drop files to upload, you do not have to know the name of the file upload
rule. The system recommends the appropriate domain, internally evaluates the domain,
selects the correct upload rule, and uploads the file.

CAE object and their subclasses are categorized into a specific simulation domain and based
on the upload rules and the files being uploaded, the system automatically selects the best
domain. You can override the domain. The system shows only the CAE objects that are under
the specified simulation domain when you upload files.

Working with the desktop application
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Domain name
Objects that can be uploaded to this
domain

3D simulation CAE 3D Analysis, CAE 3D Model, CAE
3D Result, CAE Boundary Condition, CAE
Product Collector, CAE Notebook. CAE
Notebook Run, CAE Analysis Template,
CAE Result Template, and all subclasses of
these objects.

Multidisciplinary design analysis and
optimization

CAE MDAO Analysis, CAE MDAO
Template, and all subclasses of these
objects.

Physical testing CAE Physical Test Result Template, CAE
Physical Test Result, and all subclasses of
these objects.

Systems simulation CAE 1D Analysis, CAE 1D Model, and all
subclasses of these objects.

c. Select the target object recommended by the system. If it is not available, click the New
button to create a new target object.

d. Click Upload to upload the files.

e. (Optional) To verify if the files have been uploaded correctly, select the Data tab, select the
recent file you have uploaded, and click the Item Revision link.

13. Using the Teamcenter Simulation desktop application
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The system displays the embedded viewer with the Active Workspace user interface. You can
view the uploaded files under the appropriate object created in step c.

Working with the desktop application
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f. (Optional) To verify if the object has any related objects, click the View Traceability link.

13. Using the Teamcenter Simulation desktop application
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The system displays the embedded viewer with the Active Workspace user interface. You can
view the related data to the appropriate object created in step f.

Working with the desktop application
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4. To view AppData and log files, browse to the respective directory depending on the operating
system:

• Windows: %APPDATA%\teamcenter-simulation-app

• Linux: $HOME/.config/teamcenter-simulation-app

13. Using the Teamcenter Simulation desktop application
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14. Launch simulation tools
Launch simulation tools

Simulation Process and Data Management provides a framework for configuring and launching
simulation tools that include preprocessors, solvers, postprocessors, and other tools. You can launch
simulation tools as a local launch, local detached launch, remote launch, or server launch, depending on
how the administrator configures the launch parameters at your site.

Remote launch is used for compute-intensive operations, such as meshing, solve execution, and
postprocessing. Such operations do not require interactive user input and can be executed as a batch
process on remote machines with load balancing capability and the ability to monitor and administer
request queues.

In some cases, instead of storing large result files in the database, organizations prefer storing the
generated result files on shared network folders. In such cases, the simulation administrator configures
output rules to create web link definitions to shared network folders and input rules to read the web link
definitions. As a simulation analyst, you can run predefined simulation tools with web link definitions,
and the system creates the web links for file extensions that match the configured input and output
rules. The web link definitions are supported on local, remote, server, and workflow launch processes.
For intermediate and final import, web links are supported only for the local launch.

The default tool launch page might be customized at your site.

For more information, see About customizing the tool launch page in Simulation Process and Data
Management ─ Deployment and Administration.

One of the following launch methods might be available by default at your site if the simulation
administrator has selected it while configuring the simulation tools.

Launch
method Description
Local
Launch

Launches simulation tools in Active Workspace.

The Teamcenter Tool Launch Client or Data Share Manager must be installed and
configured to enable Local Launch.

Remote
Launch

Launches simulation tools on a different machine.

This machine does not have the Teamcenter server installed on it. However, it has
simulation tools and Dispatcher components installed and configured to allow a remote
launch of simulation tools.

This type of launch is ideal for compute-intensive operations, such as meshing, solve
execution, and post processing. Such operations do not require interactive user input.
You can execute them as a batch process on remote machines with load-balancing
capabilities and can monitor and administer request queues.
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Launch
method Description

Teamcenter Dispatcher must be installed and configured to use Remote Launch.
Server
Launch

Launches simulation tools on the Teamcenter server.

If your simulation administrator has enabled the Show Launch Simulation Tool Dialog option while
configuring the simulation tool, the system opens a new browser tab with Launch Inputs and Help tabs.
The Launch Inputs tab contains all the necessary launch information while the Help tab displays the
tool description and the help document for the specific tool. The options available in the Launch Inputs
tab depend on how the simulation administrator has configured the tool at your site.

If the simulation administrator has set the maximum file size for a simulation tool and a simulation
analyst launches this tool, the system imports the file bigger than the maximum file size as an URL.

Launch simulation tools locally using TTLC

The simulation analyst can launch simulation tools using Teamcenter Tool Launcher Client (TTLC) only if
the simulation administrator has configured simulation tools using the Local Launch option. TTLC is not
required for launch methods such as Remote Launch and Server Launch.

For information about installing this tool, see Install TTLC for Active Workspace.

The process flow is as follows:

14. Launch simulation tools
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Only Local Launch is supported using TTLC.

1. (Analyst workspace) Select a CAE item revision and choose Open in Simulation Tool .

(Default workspace) Select a CAE item revision and choose Open  > Open in Simulation Tool .

2. To select the launch method, choose Local Launch.

This option might be available by default if the simulation administrator has selected it while
configuring the simulation tools.

3. (Optional) Overwrite the Default Scratch Location with a location of your choice. This is the
location specified by the simulation administrator in the Options dialog box in CAE Manager.

The tool launch framework uses the default scratch location as the location to store all the input
and output files. However, if the user staging location is configured in CAE Manager, the tool
launch uses the staging location as the location for all input and output files for the Local Launch
and Server Launch options.

Launch simulation tools locally using TTLC
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4. (Optional) To run the tool without any predefined inputs, select the Launch without configured
input check box.

5. To open the Simulation Tool Progress Monitor in a separate tab of the browser, select the Display
Progress Monitor on Launch check box.

6. Specify optional inputs.

While configuring simulation tools, the simulation administrator cannot practically link all the
optional inputs to the primary input item revision and predefine the traversal path for all those
inputs that you, as a simulation analyst, want to export in the tool configuration. For example, in
addition to the result files (primary input), you may want to select result templates (optional inputs)
and send them to a postprocessor. The result templates are not linked to the analysis item revision
that holds the result file. In such cases, the simulation administrator configures optional inputs to
allow you to select additional inputs such as result templates. During the tool launch process, you
can select the desired item revision for each available optional inputs and use these templates, for
example, to export only specific types of results.

7. Resolve file upload and URL create conflict options.

a. Select Auto Process and choose one of the following options:

• Upload File/Update URL for the system to upload output files or update URLs. In the case
of files, the system creates new versions of existing files with the same name. This is the
default option.

• Rename and Upload File/Rename and Create URL for the system to rename and upload
the file or rename and create URLs. In the case of files, the system renames the output files
with a name provided by the user if similar filenames exist. It then uploads them to the
database. In the case of URLs, the system generates a new name for the URL and it cannot
be edited.

• Skip to avoid uploading the output files or creating new URLs, if similar files or URLs with
the same name exist in the database.

OR

b. Select Prompt User.

The system provides options to control each file or URL that is uploaded or updated,
respectively. In case there are conflicts, the system displays the Pending User Action tab
in the Simulation Tool Progress Monitor. The options in the Action column are similar to
the ones available for Auto Process. If you select the Rename and Upload File/Rename and
Create URL option, you can provide a new name for the URL.

8. Resolve file download conflict options.

14. Launch simulation tools
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The download conflict options are available only if the simulation administrator has enabled the
Use Staging Directory option while configuring simulation tools.

a. Select Auto Process and choose one of the following options:

• Skip to avoid uploading the output files to the User Staging directory, if similar files with
the same names exist in the directory.

• Overwrite to overwrite to overwrite the existing files in the User Staging directory.

OR

b. Select Prompt User.

The system displays the Select Potential File Conflict Resolution dialog box to control each
file that is exported with input rules. In the Actions column, you can select the same options
as those selected in Auto Process.

9. To launch the tool, click Open.

10. To view the status of your upload or download, access the Simulation Tool Progress Monitor.

The system sets the status as Uploading or Downloading as appropriate.

Launch simulation tools locally using DSM

The Teamcenter Data Share Manager (DSM) application provides a way for you to upload and download
large data files without interrupting your work.

Note:

You (or your administrator) must install Data Share Manager on your machine and you must have
a valid license key. Find Data Share Manager installation and detailed user instructions in System
Administration→File Management System in the Teamcenter documentation.

The administrator must also set the Use_DataShare_Manager site preference to true on the
server. Doing so activates Data Share Manager for file uploading and downloading.

Tip:

If users prefer to the synchronous import and export mechanism for file upload and download
instead of using Data Share Manager, they can set the Use_DataShare_Manager preference to
false with a User protection scope.

The process flow is as follows:

Launch simulation tools locally using DSM
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Only Local Launch is supported using Data Share Manager.

1. Select Data Share Manager user session values:

a. Click your user profile on the home page and click Manage Profile.

b. Under Data Share Manager, make sure that Data Share Manager is installed on this device
and Use Data Share Manager on this device check boxes are selected.

Note:

These values remain selected until you clear your browser cache or change browser
applications. If you clear your cache or switch to a different browser, you must select
these values again before using the Data Share Manager.

2. (Analyst workspace) Select a CAE item revision and choose Open in Simulation Tool .

(Default workspace) Select a CAE item revision and choose Open  > Open in Simulation Tool .

14. Launch simulation tools
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3. To select the launch method, choose Local Launch.

This option might be available by default if the simulation administrator has selected it while
configuring the simulation tools.

4. (Optional) Overwrite the Default Scratch Location with a location of your choice. This is the
location specified by the simulation administrator in the Options dialog box in CAE Manager.

The tool launch framework uses the default scratch location as the location to store all the input
and output files. However, if the user staging location is configured in CAE Manager, the tool
launch uses the staging location as the location for all input and output files for the Local Launch
and Server Launch options.

5. (Optional) To run the tool without any predefined inputs, select the Launch without configured
input check box.

6. To open the Simulation Tool Progress Monitor in a separate tab of the browser, select the Display
Progress Monitor on Launch check box.

7. Specify optional inputs.

While configuring simulation tools, the simulation administrator cannot practically link all the
optional inputs to the primary input item revision and predefine the traversal path for all those
inputs that you, as a simulation analyst, want to export in the tool configuration. For example, in
addition to the result files (primary input), you may want to select result templates (optional inputs)
and send them to a postprocessor. The result templates are not linked to the analysis item revision
that holds the result file. In such cases, the simulation administrator configures optional inputs to
allow you to select additional inputs such as result templates. During the tool launch process, you
can select the desired item revision for each available optional inputs and use these templates, for
example, to export only specific types of results.

8. Resolve file upload and URL create conflict options.

a. Select Auto Process and choose one of the following options:

• Upload File/Update URL for the system to upload output files or update URLs. In the case
of files, the system creates new versions of existing files with the same name. This is the
default option.

• Rename and Upload File/Rename and Create URL for the system to rename and upload
the file or rename and create URLs. In the case of files, the system renames the output files
with a name provided by the user if similar filenames exist. It then uploads them to the
database. In the case of URLs, the system generates a new name for the URL and it cannot
be edited.

• Skip to avoid uploading the output files or creating new URLs, if similar files or URLs with
the same name exist in the database.

Launch simulation tools locally using DSM
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OR

b. Select Prompt User.

The system provides options to control each file or URL that is uploaded or updated,
respectively. In case there are conflicts, the system displays the Pending User Action tab
in the Simulation Tool Progress Monitor. The options in the Action column are similar to
the ones available for Auto Process. If you select the Rename and Upload File/Rename and
Create URL option, you can provide a new name for the URL.

9. Resolve file download conflict options.

The download conflict options are available only if the simulation administrator has enabled the
Use Staging Directory options while configuring simulation tools.

a. Select Auto Process and choose one of the following options:

• Skip to avoid uploading the output files to the User Staging directory, if similar files with
the same names exist in the directory.

• Overwrite to overwrite to overwrite the existing files in the User Staging directory.

OR

b. Select Prompt User.

The system displays the Select Potential File Conflict Resolution dialog box to control each
file that is exported with input rules. In the Actions column, you can select the same options
as those selected in Auto Process.

10. To launch the tool, click Open.

11. View the status of your download.

Caution:

Do not cancel the transfer of a simulation output file in Data Share Manager. The tool launch
framework currently cannot handle this action.

a. To view the status, access the Simulation Tool Progress Monitor.

The system sets the status as Downloading.

b. Click the system tray of your computer, open Data Share Manager, and monitor the status of
your download.

14. Launch simulation tools
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12. View the status of your upload.

a. To view the status, access the Simulation Tool Progress Monitor.

The system sets the status as Uploading.

b. Click the system tray of your computer, open Data Share Manager, and monitor the status of
your upload.

Launch simulation tools using the Server or Remote method

While configuring simulation tools, the simulation administrator configures the Default Scratch
Location, Default User Staging Location, and the Default Shared Staging Location options.

• For the Server or Remote launch method, the system does not display the Default Scratch Location
option. Moreover, the User Staging Directory is not displayed if the simulation administrator has
enabled the Use Staging Directory option while configuring simulation tools in the Simulation Tool
Configuration view.

• For the Server launch method, the system considers the directory specified in Default Scratch
Location configured in the Simulation Tool Configuration view. If the above directory is not
configured, it uses the system TEMP directory. The values set for the UNIX or Windows preference in
the Default Scratch Location in the Edit→Options→CAE→Simulation Tools are also not considered.

• For the Remote launch method, it uses the system TEMP directory. It does not consider the
directory specified in Default Scratch Location configured in the Simulation Tool Configuration
view. The values set for the UNIX or Windows preference in the Default Scratch Location in the
Edit→Options→CAE→Simulation Tools are also not considered.

• The administrator also configures the Folder Naming Pattern. The system uses a combination of the
TEMP directory and the folder naming pattern for these launch methods. The TEMP directory depends
on how the TC_TMP_DIR environment variable is set at your site. This variable specifies where the
utilities should create temporary files. This value is typically C:\Temp on Windows and /tmp on Linux.

If the TC_TMP_DIR environment variable is not set at your site, the location is set by the TEMP
environment variable on your local system.

1. (Analyst workspace) Select a CAE item revision and choose Open in Simulation Tool .

(Default workspace) Select a CAE item revision and choose Open  > Open in Simulation Tool .

2. To select the launch method, choose Server Launch or Remote Launch.

One of these options might be available by default if the simulation administrator has selected it
while configuring the simulation tools.

Launch simulation tools using the Server or Remote method
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3. (Optional) To run the tool without any predefined inputs, select the Launch without configured
input check box.

4. To open the Simulation Tool Progress Monitor in a separate tab of the browser, select the Display
Progress Monitor on Launch check box.

5. Specify optional inputs.

While configuring simulation tools, the simulation administrator cannot practically link all the
optional inputs to the primary input item revision and predefine the traversal path for all those
inputs that you, as a simulation analyst, want to export in the tool configuration. For example, in
addition to the result files (primary input), you may want to select result templates (optional inputs)
and send them to a postprocessor. The result templates are not linked to the analysis item revision
that holds the result file. In such cases, the simulation administrator configures optional inputs to
allow you to select additional inputs such as result templates. During the tool launch process, you
can select the desired item revision for each available optional inputs and use these templates, for
example, to export only specific types of results.

6. Resolve file upload and URL create conflict options.

a. Select Auto Process and choose one of the following options:

• Upload File/Update URL for the system to upload output files or update URLs. In the case
of files, the system creates new versions of existing files with the same name. This is the
default option.

• Rename and Upload File/Rename and Create URL for the system to rename and upload
the file or rename and create URLs. In the case of files, the system renames the output files
with a name provided by the user if similar filenames exist. It then uploads them to the
database. In the case of URLs, the system generates a new name for the URL and it cannot
be edited.

• Skip to avoid uploading the output files or creating new URLs, if similar files or URLs with
the same name exist in the database.

OR

b. Select Prompt User.

The system provides options to control each file or URL that is uploaded or updated,
respectively. In case there are conflicts, the system displays the Pending User Action tab
in the Simulation Tool Progress Monitor. The options in the Action column are similar to
the ones available for Auto Process. If you select the Rename and Upload File/Rename and
Create URL option, you can provide a new name for the URL.

7. Resolve file download conflict options.

14. Launch simulation tools
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The download conflict options are available only if the simulation administrator has enabled
the Use Staging Directory options while configuring simulation tools. This is not applicable for
Remote launch.

a. Select Auto Process and choose one of the following options:

• Skip to avoid uploading the output files to the User Staging directory, if similar files with
the same names exist in the directory.

• Overwrite to overwrite to overwrite the existing files in the User Staging directory.

OR

b. Select Prompt User.

The system displays the Select Potential File Conflict Resolution dialog box to control each
file that is exported with input rules. In the Actions column, you can select the same options
as those selected in Auto Process.

8. To launch the tool, click Open.

9. To view the status of your upload or download, access the Simulation Tool Progress Monitor.

The system sets the status as Uploading or Downloading as appropriate.

Perform an intermediate import

Simulations, such as design optimization, are compute-intensive and time consuming. You can use the
intermediate import option to view the intermediate results generated by simulation tools.

Prerequisites

The following procedure assumes that a tool launch has been started successfully.

Procedure

1. Access the Simulation Tool Progress Monitor to view the status.

The system invokes the launch script and generates the intermediate outputs to the Scratch or the
Staging directory while the tool is running.

2. Select an in-progress job and select the Intermediate Import command.

3. Access the Simulation Tool Progress Monitor to view the status.

Perform an intermediate import
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The system sets the status as Intermediate Uploading.

After the intermediate import is complete, the system changes the status to In-progress.

Monitor simulation tools

You can open the Simulation Tool Progress Monitor in a separate tab of the browser to view the status
of the simulation tools you have launched.

1. On the home page, click the Tool Progress Monitor tile.

2. (Optional) To arrange columns, click Table Settings  > Arrange and make the appropriate
selections to add or remove columns.

3. (Optional) To sort columns, click the column you want to sort and select an appropriate option.

4. Click the Pending User Action tab to verify if there is any unfinished action.

The Status column shows Conflict or Selective Data Import.

• Conflict: Select the appropriate file, or select all files from the list of files to import and overwrite
existing files in the system.

• Selective Data Import: Select the appropriate file or select all files from the list of files to import.
This is applicable for Local Launch only.

Click Process  to import the files.

5. Click All Jobs to see the status of all simulation tools you have started. Similarly, you can click other
tabs to see completed, failed, in progress, and terminated tools.

The following are the status of jobs in various tabs of the Simulation Tool Progress Monitor:

Status Description
Complete The job is complete and successful.
Downloading The system is exporting input files.
Duplicate Another tool launch has been started on the same input object

while an existing job is still in progress.
Failed The job has failed.
In Progress The job is being executed.
Initializing The job is being initialized.
Intermediate Uploading The system is importing the intermediate results.
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Status Description
Selective Import Allows analysts to select the files to import to Teamcenter after

successfully launching a simulation tool.
Terminated The job is terminated by the user from the Simulation Tool

Progress Monitor.
Upload conflict During upload, if there are any conflicts that needs the user

to perform a pending action, the system waits until the user
resolves the conflicts and then proceeds to upload the files.

Uploading The system is importing the final outputs after exiting the
launch script successfully.

No output files found (If output rules are defined) After the simulation tool execution
is complete, the system checks for any matching output files.
However, no output files are found.

No files uploaded or Web
Links created

(If output rules are defined) After the simulation tool execution
is complete, the system finds matching output files. However,
they are not imported.

This could be due to the following reasons:

• Selective Data Import is enabled and the import process is
canceled.

• For resolving file upload and URL create conflict options, the
Prompt User option is selected and the import is skipped.

• For resolving file upload and URL create conflict options, the
Auto-Process and the Skip options are selected.

• Import only Modified files is selected but no output files are
modified.

This information is also displayed in the
simulation_process_launch.log file.

Processing After files are imported into the database, the system performs
a final verification and cleanup before moving the status to its
final status.

6. (Optional) To stop a job that is in progress, select the job, and click Terminate.

This command terminates Teamcenter from monitoring the launch script and returning any output
back. However, it does not terminate the processes started by the launch script.

7. (Optional) To clear a specific job, select the job, and click Clear Job.

To clear all jobs, select Clear All.

Monitor simulation tools
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8. (Optional) To refresh the progress monitor, click Refresh.

Launch and monitor simulation tools configured for HPC

As a simulation analyst, you can launch and monitor simulation tools configured for high-performance
computing (HPC).

Prerequisites

The following procedure assumes that an administrative user with DBA privileges has created HPC
connections and profiles. Additionally, the simulation administrator has configured the required
simulation tools and assigned the HPC configuration for them.

Procedure

1. In the analyst workspace, select a CAE 3D Analysis revision, choose Open in Simulation Tool ,
and select the configured Nastran simulation tool with HPC configuration.

2. Select the launch method as Server Launch, specify the appropriate options, and choose Open.

A tcsimxml file is generated and downloaded on the client machine. When you open this file, the
system executes the launch script on the client machine. The launch script authenticates the HPC
machine and submits the HPC job successfully on the HPC machine.

3. To view the simulation job status, open the Simulation Tool Progress Monitor in a separate tab of
the browser and choose the HPC Jobs tab.

4. (Optional) To refresh simulation jobs, choose another tab and select the HPC Jobs tab.

5. (Optional) Resume a simulation job.

After launching a simulation job, you can shut down the client machine if the simulation is going to
take a long time. When you shut down the client machine, the system puts the simulation job in In
Progress state. You can restart the client machine and resume the job.

To do so:

14. Launch simulation tools
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a. On the client machine, start Active Workspace, open the Simulation Tool Progress Monitor
in a separate tab of the browser, and choose the HPC Jobs tab.

b. Select the job that is In Progress and choose Resume.

A tcsimxml file is generated and downloaded on the client machine. When you open this file,
the system first checks the status of HPC job with the interval value (in minutes) specified in
the CAE_background_updater_hpc_job_interval preference.

If the HPC job is completed successfully on the HPC machine, the output files are imported
back to Teamcenter based on the configured output rules. The system then marks the
simulation job status as Completed.

c. To view the changed status of the job, choose the HPC Jobs tab and check the value in the
Status column.

6. (Optional) To end a simulation job, select it and click Terminate.

Automatically clear simulation jobs using preferences

You can set the following user preferences to automatically clear simulation jobs when a simulation
analyst uses simulation tools:

• CAE_Jobs_Clear_After_Size

• CAE_Jobs_Clear_Batch_Size

These user preferences work together and you must set both of them. The default values are 500 and
100, respectively.

Example:

Set the CAE_Jobs_Clear_After_Size and the CAE_Jobs_Clear_Batch_Size preference value as 50
and 10, respectively. After you set these preferences, the number of simulation jobs does not
exceed the sum of these preference values. Therefore, when you launch the 61st job, the system
clears the first 10 jobs in chronological order and they remain at 51 after the tool launch is
complete.

The Simulation Tool Progress Monitor displays the status of all tools. To view fewer jobs in the
Simulation Tool Progress Monitor, set lower values for these preferences. However, this impacts the
tool launch performance as the system has to clear jobs based on the values you have specified.

Automatically clear simulation jobs using preferences
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Create folders in the context of CAE workspace objects to manage
your simulation data

You can create a folder structure in the context of CAE workspace objects such as geometry, model,
analysis, and result revision to better manage your simulation data.

You can create an unlimited number of CAE Folder objects at various hierarchical levels and rename
them. CAE folder names must be unique within the same level. However, CAE folders with the same
name can exist at different hierarchical levels.

Prerequisites

The Teamcenter Data Share Manager (DSM) application must be enabled for uploading files after
creating folders.

Procedure

1. On the Home page, click the Create Simulation tile and create a CAE workspace object such as
geometry, model, analysis, or result revision.

2. Open the workspace object you created and click the Files tab.

3. To create a folder, click Add CAE Folder.

4. To create a subfolder, select the folder and click Add CAE Folder.

5. Upload files without preconfigured file upload rules.

a. Click your user profile on the home page and choose Manage Profile.

b. Under Data Share Manager, make sure that Data Share Manager is installed on this device
and Use Data Share Manager on this device check boxes are selected.

c. Select the folder to which you want to upload files and click Upload File.

d. Specify the working directory where you want to upload the file, click Choose File to select
the file you want to upload, and select Upload.

e. To see the status of your upload, click the system tray of your computer and open Data Share
Manager.

6. Copy and paste one or more folders.

a. Select the folders you want to copy and click Copy CAE Folder.

14. Launch simulation tools
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b. Select another item revision in the Tree view or another folder within the same CAE folder.

c. Select Paste CAE Folder.

7. Cut and move folders.

a. Select the folders you want to move and click Cut CAE Folder.

b. Select another item revision in the Tree view or another folder within the same CAE folder.

c. Click Paste CAE Folder.

8. To delete a CAE folder, select the folder you want to delete and click Delete CAE Folder.

9. To delete uploaded files, select the appropriate folder, select the files you want to delete in the File
Contents area, and click Delete Files.

10. To download files, select the appropriate folder, select the files you want to download in the File
Contents area, and click Download.

Convert NX managed mode files to the native mode

As a simulation analyst, you can launch a preconfigured simulation tool to convert NX managed mode
files to the native mode.

NX is used in managed mode at most sites to create and store CAD assemblies directly in Teamcenter.
Subsequently, these designs are then imported into simulation tools so they can be modified or used as
a starting point to run simulations. Since the assemblies are saved in NX managed mode, they cannot be
directly imported into simulation tools unless the assembly is translated from managed to native.

Prerequisites

The following procedure assumes that the Teamcenter administrator has set the
CAE_Export_NX_Native_Files preference to true to export the NX files to native mode and the
simulation administrator has configured simulation tools to convert the (.prt, .sim, and .fem) managed
files to the native mode.

Procedure

1. Ensure that the following environment variables are set on the client machine:

• UGII_BASE_DIR environment variable that points to the NX installation

• FMS_HOME environment variable that points to the FMS installation, for example,
FMS_HOME=C:\apps\tc\tc14\TR\tccs

Convert NX managed mode files to the native mode
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• UGII_UGMGR_COMMUNICATION=HTTP

• UGII_UGMGR_HTTP_URL=Tc_Server_Url/aiws/aiwebservice, for example,
UGII_UGMGR_HTTP_URL=http://vc6s004:7001/tc/aiws/aiwebservice

2. Launch a simulation tool that has been configured for .prt, .sim, and .fem files.

The system exports all the necessary files to the Scratch directory, invokes the ug_clone utility on
the client machine, converts managed mode files to the native mode in the Scratch directory, and
the simulation tool reads the native files.

After the tool launch is complete and the tool is closed, the system moves the files back to
Teamcenter.

3. Launch other simulation tools to import the native mode files and continue the analysis work.

14. Launch simulation tools
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15. Run simulations on local desktops
by downloading or uploading data
periodically
About uploading and downloading files or CAE folders

At some sites, not all simulation tools are integrated with Teamcenter. Simulation analysts may prefer to
run simulation tools on their local desktops and periodically upload and download the data to or from
Teamcenter as needed. Analysts can upload or download files or CAE folders by using predefined file
upload rules. Based on these rules, they can upload or download geometry files, mesh data, or analysis
data to or from Teamcenter. After uploading or downloading files or CAE folders, they can view files,
open selected files using registered tools, and rename or delete selected files in the Files tab.

The process flow is as follows:

As a simulation analyst, you can:

• Upload or download files using predefined rules (without Data Share Manager).

Usually, the browser upload size limit is 2 GB and files bigger than or equal to 2 GB cannot be
uploaded using the File Upload command. For more details, refer to the documentation for the
browser.

OR;

• Upload or download files using predefined rules (with Data Share Manager).

There is no file upload size restriction for uploading files using Data Share Manager.
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OR;

• Upload or download CAE folders using predefined rules.

TTLC and Data Share Manager are prerequisites for uploading CAE folders. There is no file upload
size restriction for uploading CAE folders using Data Share Manager.

Data Share Manager is required for downloading CAE folders as well. Without Data Share Manager,
only the files can be downloaded.

Set user preference to honor file naming pattern for file upload
rules

As a simulation analyst, you can set the AWC_CAE_file_upload_honor_file_naming_pattern user
preference to honor file naming pattern for file upload rules. This means that only the files that match
the pattern are uploaded to the parent item revision.

Procedure

1. Search for the AWC_CAE_file_upload_honor_file_naming_pattern user preference.

For information about retrieving a list of preferences, see Where can I get a list of preferences? in
Teamcenter Preferences.

2. Set to true for the system to honor file naming pattern for file upload rules. This means that only
the files that match the pattern are uploaded to the parent item revision.

By default, it is set to false. When set to false, the file naming pattern is not honored. In such cases,
all files are uploaded to the parent item revision.

3. Save your changes.

Upload or download files using predefined rules (without Data
Share Manager)

You can upload files from the operating system to Teamcenter or download them from Teamcenter to
the operating system based on predefined file upload rules.

The following procedure describes how to upload or download files without Data Share Manager.

Prerequisites

The administrator must have configured the Async service translator and Dispatcher services must be
running.

15. Run simulations on local desktops by downloading or uploading data periodically
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Procedure

1. Access the Files tab.

The Files tab is visible in the Analyst workspace if you select one or more non-CAE and CAE item
revisions. Similarly, the Files tab is visible in the Default workspace if you select CAE item revisions.

Select one of the following methods to access the Files tab:

a. Select one or more CAE item revisions and click the Files tab in the secondary work area.

b. In the Analyst workspace, select one or more CAE item revisions, and click the Files tab in the
secondary work area.

Alternatively, select one or more non-CAE item revisions and one or more CAE item revisions,
and click the Files tab.

When you select multiple item revisions, the system displays an extra column in the File
Contents table. The Context Item Revision column displays the owning item revision and
you can click the item revision to open it.

c. Search for CAE item revisions, select them, and click the Files tab.

d. Open a model structure, click the Content tab, select one or more model revisions, and click
the Files tab.

2. Upload files without using Data Share Manager.

a. Click Upload File  and select a preconfigured file upload rule.

The default upload size limit for FMS is 134 MB, and it is configurable.

The browser upload size limit is 2GB, and files bigger than or equal to 2GB cannot be uploaded
by using this command. Each browser has its own file upload limitations.

There is no file upload size restriction for uploading files using Data Share Manager.

b. Click Choose File, select the file, and click Upload.

If there are file conflicts, the system displays the Conflict page

c. To resolve file conflicts if files with the same names and types exist while uploading, select
one of the following options in the Conflict Option column and then click Upload.

Upload or download files using predefined rules (without Data Share Manager)
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For multiple item revisions, if the Filename to Item Revision Mapping dialog box is not
configured, then you can resolve item conflicts first. If file conflicts continue to exist, then the
system displays the file conflicts.

• Upload to upload the existing file with the same name to the database.

• Rename and Upload to upload the file with a new name to the database by specifying a
valid name.

• Skip to skip uploading the file to the database.

Note:

If the system displays file conflicts options, you must stay on this page to resolve
the conflicts and not perform any other actions. If you try to perform some other
action such as clicking a command in the navigation pane, refreshing the browser, or
executing a search, the system cannot display the file conflicts again.

3. Download files without using Data Share Manager.

a. Select the file you want to download, and click Download File .

b. To check out datasets, select Yes when prompted. Alternatively, select No if you do not want
to check out the datasets.

4. (Optional) Sort the data in the Files tab.

Upload or download files using predefined rules (with Data Share
Manager)

You can upload files from the operating system to Teamcenter or download them from Teamcenter to
the operating system based on predefined file upload rules.

The following procedure describes how to upload or download files with Data Share Manager:

1. Start Data Share Manager.

The Teamcenter Data Share Manager (DSM) application provides a way for you to upload and
download large data files without interrupting your work.

Note:

You (or your administrator) must install Data Share Manager on your machine and you
must have a valid license key. Find the Data Share Manager installation and detailed

15. Run simulations on local desktops by downloading or uploading data periodically
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user instructions in System Administration→File Management System in the Teamcenter
documentation.

The administrator must also set the Use_DataShare_Manager site preference to true on the
server. Doing so activates Data Share Manager for file uploading and downloading.

Tip:

If users prefer to use the synchronous import and export mechanism for file upload and
download instead of using Data Share Manager, they can set the Use_DataShare_Manager
preference to false with a User protection scope.

To select Data Share Manager user session values:

a. Click your user profile in the lower left corner of Active Workspace home page, and select
Profile.

b. Under Data Share Manager, make sure that the Data Share Manager is installed on this
device and Use Data Share Manager on this device check boxes are selected.

Note:

These values remain selected until you clear your browser cache or change browser
applications. If you clear your cache or switch to a different browser, you must select
these values again before using Data Share Manager.

2. Access the Files tab.

In the Analyst workspace, you can select one or more non-CAE and CAE item revisions. However,
in the Default workspace, you can select only CAE item revisions.

Select one of the following methods to access the Files tab:

a. Select one or more CAE item revisions and click the Files tab in the secondary work area.

b. In the Analyst workspace, select one or more CAE item revisions, and click the Files tab in the
secondary work area.

When you select multiple item revisions, the system displays an extra column in the File
Contents table. The Context Item Revision column displays the owning item revision and
you can click the item revision to open it.

c. In the Analyst workspace, select one or more non-CAE item revisions and one or more CAE
item revisions, and click the Files tab.

The Context Item Revision column is displayed in the File Contents table of the Files tab.

Upload or download files using predefined rules (with Data Share Manager)
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d. Search for CAE item revisions, select them, and click the Files tab.

e. Open a model structure, click the Content tab, select one or more model revisions, and click
the Files tab.

3. Upload files using Data Share Manager:

a. Click Upload File .

There is no file upload size restriction for uploading files using Data Share Manager.

b. Specify a working directory in the File Upload panel.

You can upload files from the specified working directory only. The system persists the
working directory for a subsequent upload operation.

c. Select a preconfigured file upload rule.

d. Click Choose File, select one or more files containing the data, and click Upload.

e. To resolve file conflicts if files with the same names and types exist while uploading, select
one of the following options in the Conflict Option column and then click Upload.

For multiple item revisions, if the Filename to Item Revision Mapping dialog box is not
configured, then you can resolve item conflicts first. If file conflicts continue to exist, then the
system displays the file conflicts.

• Upload to upload the existing file with the same name to the database.

• Rename and Upload to upload the file with a new name to the database by specifying a
valid name.

• Skip to skip uploading the file to the database.

Note:

If the system displays file conflicts options, you must stay on this page to resolve
the conflicts and not perform any other actions. If you try to perform some other
action such as clicking a command in the navigation pane, refreshing the browser, or
executing a search, the system cannot display the file conflicts again.

f. Open the Data Share Manager console to monitor the status of your uploads.

g. In the Files tab, click Refresh to verify whether the files have been uploaded.

4. Download files using Data Share Manager:

15. Run simulations on local desktops by downloading or uploading data periodically
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a. Press the Ctrl key and make the required selections. Alternatively, click Selection Mode and
select the appropriate check boxes corresponding to the item revisions for which you want to
download data.

b. Click Download File .

c. Specify a working directory in the File Download tab.

The system persists the working directory for a consecutive download operation.

d. To check out datasets, select the Check-out option in the File Download panel. Do not select
it if you do not want to check out the datasets.

e. Open the Data Share Manager console to monitor the status of your downloads.

f. Browse to the specified working directory and verify whether the files have been downloaded.

5. (Optional) Sort the data in the Files tab.

Upload or download CAE folders using predefined rules

You can upload CAE folders from the operating system to Teamcenter or download them from
Teamcenter to the operating system based on predefined file upload rules.

• TTLC and Data Share Manager are prerequisites for uploading CAE folders. There is no file size
restriction for uploading CAE folders using Data Share Manager.

• You can download CAE folders from the Files tab or the Overview tab. While the Files tab displays
the complete folder structure, the Overview tab displays only the first-level folder.

• Data Share Manager is a prerequisite for downloading CAE folders from the Files tab and the
Overview tab. However, without Data Share Manager, you can download individual files from the
Files tab.

1. Start Data Share Manager.

The Teamcenter Data Share Manager (DSM) application provides a way for you to upload and
download large data files without interrupting your work.

Note:

You (or your administrator) must install Data Share Manager on your machine and you must
have a valid license key. Find Data Share Manager installation and detailed user instructions
in System Administration→File Management System in the Teamcenter documentation.

Upload or download CAE folders using predefined rules
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The administrator must also set the Use_DataShare_Manager site preference to true on the
server. Doing so activates Data Share Manager for file uploading and downloading.

Tip:

If users prefer the synchronous import and export mechanism for file upload and download
instead of using Data Share Manager, they can set the Use_DataShare_Manager preference
to false with a User protection scope.

To select Data Share Manager user session values:

a. Click your user profile in the lower left corner of Active Workspace home page, and select
Profile.

b. Under Data Share Manager, make sure that the Data Share Manager is installed on this
device and Use Data Share Manager on this device check boxes are selected.

Note:

These values remain selected until you clear your browser cache or change browser
applications. If you clear your cache or switch to a different browser, you must select
these values again before using the Data Share Manager.

2. Upload CAE folders.

a. Open a CAE item revision or select one or more CAE item revisions and click the Files tab.

The system displays the File Containers tree containing the CAE folders and the datasets
under the selected item revisions. When you select a CAE Folder or Dataset, the system
displays the files inside the CAE folder or the dataset in the File Contents section.

b. To upload CAE folders, click Upload Folder, select a predefined file upload rule, and provide
the path of the folder you want to upload.

c. Click Upload.

The system resolves the folder conflicts for files within the CAE folder based on the
CAE_file_upload_default_conflict_resolution_option user preference.

3. Download CAE folders from the Files tab.

15. Run simulations on local desktops by downloading or uploading data periodically
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You can download files with or without DSM:

Download with
DSM

The complete folder structure is created and
preserved on the operating system.

Download
without DSM

Only the selected files are downloaded through
the browser and the folder structure is not
created or preserved.

a. Open a CAE item revision with CAE folders or select one or more CAE item revisions with CAE
folders.

b. To view files, click the Files tab.

The system displays the File Containers tree containing the CAE folders and the datasets
under the selected item revisions. When you select a CAE Folder or Dataset, the system
displays the files inside the CAE folder or the dataset in the File Contents section.

c. Select one or more files and click Download.

d. In the Download panel, specify the working directory and click Download.

4. Download CAE folders from the Overview tab.

a. Open a CAE item revision with CAE folders or select one or more CAE item revisions with CAE
folders and click the Overview tab.

The system displays the File Containers tree containing the first level of CAE folders and the
datasets under the selected item revisions. When you select a CAE Folder or Dataset, the
system displays the files inside the CAE folder or the dataset in the File Contents section.

b. Select one or more files and click Download Folder.

Upload or download CAE folders using predefined rules
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The system displays the .plmd file. When you click this file, the folder is downloaded to the
location based on the Default Download Folder preference specified in DSM.

Sort the data in the Files tab

You can sort the data in the Files tab after you Upload or download files without Data Share Manager
or Upload or download files with Data Share Manager.

1. Sort the File Contents columns using a date filter.

a. Click the table header of the Date Modified column you want to sort.

b. Specify a date range and click Filter.

2. Sort the File Contents columns using a text filter.

a. Click the table header of the column you want to sort.

b. Select an operator. The valid operators are Contains, Does not contain, Begins with, Ends
with, Equals, and Does not equal.

c. Type the text by which you want to filter the column contents and click Filter.

The text filter you specify is not case sensitive. For example, you can type cae to filter objects
names containing both CAE in upper case and cae in lower case.

After applying a text filter, when you hover your mouse over the Filter icon, the system
displays the text filter you have applied as a tool tip.

d. To do further sorting, select more column headers and select the appropriate sort options.

3. Sort the File Contents columns for common values by using facets.

a. Click the table header of the column you want to sort.

15. Run simulations on local desktops by downloading or uploading data periodically
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b. Enable Show Filters, select the specific objects you want to be displayed in the dashboard
column, and click Filter.

You can optionally first apply a text filter and then enable Show Filters to further filter the
column results.

Example:

In the Context Item Revision column, type Analysis in the text filter and then enable
Show Filters to display only names that have Analysis in this column.

4. To reset the filter criteria on a column, click the column header and click Clear.

5. To reset all filters, click  > Clear all filters.

6. To refresh the entire table, click Refresh  on the top of the table.

The system preserves the sorting order even after the dashboard is refreshed.

7. To refresh the selected objects, select one or more objects in the table and click Refresh  on the
top of the table.

The system preserves the sorting order even after the selected objects are refreshed.

8. Edit the data in the File Contents table:

a. Click Start Edit  without selecting any columns.

b. Click the cell you want to modify and make the changes.

c. Click Save Edits  to save your changes.

9. To delete data, press the Ctrl key or click Selection Mode  on the top of the table, select one or
more columns, and click Delete  on the top of the table.

The system prompts you to Cancel, Delete files only, or Delete files and empty datasets. Choose
the appropriate option.

You can delete files and datasets only if you have write permissions to them. You can change the
owner of an object if you have appropriate permissions.

10. (Optional) To rearrange columns, click  > Arrange and remove or add columns as appropriate.

Sort the data in the Files tab
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15. Run simulations on local desktops by downloading or uploading data periodically
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16. View the traceability of simulation data
When you execute the simulation processes and capture artifacts such as abstractions, models,
materials, load cases, solver input decks, results, and reports, they are stored in different business
objects with relationships. To view the traceability of simulation data, you can access the Overview tab
to view related objects in a table format or the Relations tab to view them in a graphical format.

The Relations tab provides a simulation-specific view in the context of CAE objects. In addition, you can
apply filters to both objects and relationships to view only relevant information and to navigate through
related CAE objects and view their traceability.

1. Open a CAE item revision and click the Relations tab.

2. Navigate through the related data by expanding incoming and outgoing relationships.

3. To filter the content, click Legend, choose the Views tab, and select the Simulation and Test view.
This is the default view.

The system updates the graphical view and shows the context object and the related matching CAE
objects.

a. Select the appropriate criteria from Objects and Relations.

b. (Optional) To view the corresponding CAE relation name, hover your mouse over a relation.

c. (Optional) To view the number of incoming or outgoing objects, select any CAE item revision
object.

d. (Optional) To view the incoming or outgoing objects, select the relation link of the CAE item
revision.
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4. To filter the content, click Legend and choose the Filter tab and select the appropriate criteria such
as reviewed, approved, status, owner, date modified, and last modifying user.

Example:

To view only revisions related to the CAE item revision you have opened, select the
appropriate revisions in the Type category.

16. View the traceability of simulation data
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17. Subscribe to simulation objects to track
status changes
As a simulation analyst, you can use simulation objects to create, execute, and track simulation-related
tasks. By subscribing to these simulation objects, you can monitor their status changes and receive
notifications when modifications occur.

Subscription objects also generate alerts for generating CAE structure, comparing CAE BOM,
deriving structures, creating CAE packages, generating dashboard reports, and other operations. This
functionality ensures you stay informed and can efficiently manage your simulation workflows.

Procedure

1. In EXPLORER or MY STUFF, select one or more simulation objects.

2. Choose More Commands  > Share > Follow.

Subscriptions are objects you are following using the Follow  command. For more information,
see Overview of subscriptions in Active Workspace Fundamentals.

3. In the Follow panel, specify the frequency and priority. You can also add other users as followers.

• Event Type

Note:

If you are already subscribed to an event type, it does not appear in the Event Type list.

• My Events

Select My Events to follow multiple events on an object.

• Name

An editable prepopulated field is displayed when you select a single object to follow.

• Frequency

Select from Immediately (not collated), Daily (daily digest), and Weekly (weekly digest). The
default is Immediately.

• Priority

Select from Normal, High, and Low. The default is Normal.
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• In the Followers section, click Add Follower  to add a follower. In the Users section, select the
user you want to add and click Add.

4. Click Follow to follow the object.

5. Verify that your subscription is created. From your Home page, click the SUBSCRIPTION tile to
display your subscriptions. Then, click the My Subscriptions tab, and select the object to which you
just subscribed.

17. Subscribe to simulation objects to track status changes
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18. Capture results and verify results
Capture results from different solvers and verify results

1. Create result revisions

You must create result revisions to manage analysis results from different solvers. The result
revision is associated with an analysis revision.

2. Upload results

When the solve is complete, you import the results to the result revision. You can also launch
a postprocessor and generate JT files or other visualization files and import them to the result
revision.

3. Verify results and send recommendations

After verifying the results, you can release the analysis data to production. You release the data by
signing off from a workflow. You can make recommendations while signing off the workflow.

In the simulated side-impact example, the results show that the intrusion beam cannot withstand
forces of 3200 pounds at 35 mph. After evaluating results from various scenarios, you sign off the
workflow by suggesting a design change for the intrusion beam.

Create CAE result revisions

To capture the simulation results, you must create CAE 3D Result revisions. You can use these revisions
to manage analysis results from different solvers.

1. Search for the analysis revision you created, open it, and click the Overview tab.

2. Choose More Commands > New  > Create Simulation.

3. Choose CAE 3D Result.

4. (Mandatory) Type a name for the result revision.

5. (Optional) Type a description.

Simulation Process and Data Management on Active Workspace ─ Usage, Teamcenter 2412  18-1
© 2025 Siemens



6. (Optional) Select a preconfigured analysis type, for example, Structural or Thermal.

7. (Optional) Select a preconfigured solver, for example, NXNastran or Ansys.

8. (Optional) Specify a project ID or click Add Project  and select a project.

9. (Optional) To specify a result template, click Add Result Template  and select a template from
Palette, and click Add.

Alternatively, click Search, search for a template, and add it.

10. To create the result revision, click Create.

Create results templates

You can use the CAE 3D Result Template workspace object for managing templates of results from a
3D analysis simulation, for example, CFD, FEA, or structural. It can be used to view all the CAE 3D result
objects that are based on the workspace object. In addition, this object enables customers to have a
consistent postprocessing workflow for CAE 3D results and enables a consistent, reliable, and traceable
method for reviewing CAE 3D results. It can be related to a CAE 3D result and CAE 3D analysis. When
related to a CAE 3D analysis, you can use the CAE 3D analysis for both storing simulation data as well as
the postprocessed data in the form of reports. In addition, you can use the templates from the CAE 3D
result template to generate the postprocessed data.

While configuring simulation tools, the simulation administrator cannot practically link all the optional
inputs to the primary input item revision and predefine the traversal path for all those inputs that you
(as simulation analyst) want to export in the tool configuration. For example, in addition to the results
file (primary input), you may want to select results templates (optional inputs) and send them to a
postprocessor. These templates are not linked to the analysis item revision that holds the results file.
In such cases, the simulation administrator configures optional inputs to allow you to select additional
inputs such as results templates.

During the tool launch process, you can select the desired item revision for each of the available optional
inputs and use these templates, for example, to export only specific types of results.

1. On the HOME page, click CREATE SIMULATION.

2. In the Create Simulation panel, select the CAE 3D Result Template type.

3. (Mandatory) Specify a name for the result template.

4. (Optional) In PROJECTS, click Add Project  and select a project.

5. To create the template, click Create.

6. Open the template you created.

18. Capture results and verify results
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7. To add the required files for this template, in the Overview tab, click Add to  in FILES.

8. Click Choose File and select the required file for this template.

Add boundary conditions to a results revision using a preconfigured
tool

You can use the 3D boundary condition workspace object to manage CAE 3D simulation boundary
conditions such as heat flux in CFD, forces in FEA or structural analysis, and electromagnetic forces
in an electrical analysis. This workspace object is used as the input for analysis in simulation tool
configurations for 3D applications such as Simcenter 3D, Ansys, and Star-CCM+. It can be related directly
to a CAE 3D result and a CAE 3D analysis. The boundary condition object can have an input relation to
the CAE 3D analysis when it is used to provide inputs to a CAE 3D analysis. On the other hand, if a CAE
3D analysis or a CAE 3D result generates some data which can be used for another 3D analysis as input,
this data can be maintained within a boundary condition object using an extract relationship.

Create a CAE boundary condition type

1. On the HOME page, click CREATE SIMULATION.

2. In the Create Simulation panel, select the CAE 3D Boundary Condition type.

3. (Mandatory) Specify a name for the boundary condition.

4. (Optional) Click Add Project  and select a project.

5. To create the boundary condition, click Create.

6. Add boundary conditions.

a. Open the boundary condition you created.

b. In the Overview tab, click Add to  in FILES.

c. Click Choose File and select the file containing the simplified geometry.

Associate the boundary condition type to a result revision

1. Navigate to a result revision, open it and click the Overview tab.

2. Click Add Simulation  in the RELATED OBJECTS table.

3. In the Add Simulation panel, select the CAE 3D Boundary Condition type, select it from Palette,
and click Add.

Add boundary conditions to a results revision using a preconfigured tool
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Alternatively, click Search, search for the boundary condition, and add it.

Mark boundary conditions as up-to-date for changes to
attachments and related revisions

You can mark boundary conditions as up-to-date for changes to attachments and related revisions such
as CAE 3D Analysis and CAE 3D Result.

In a complex product development environment, different analysts perform different tasks of the overall
analysis. For example, the CFD analysis is done by one group, and the heat flux load is sent to another
group as a boundary condition. Similarly, another group does structural analysis and this group receives
a boundary condition object from the program requirements group. In such scenarios, it becomes critical
to know when the analysis data, possibly with multiple dependencies, is out-of-date. The analyst can
then act on it and ensure that the analysis is built with the correct set of data to deliver accurate results.

You can create a CAE 3D Boundary Condition revision in the context of a CAE 3D Analysis or a CAE
3D Result revision. If any of these related revisions are changed, the status of the boundary condition
shows as out-of-date. Similarly, if any attachments are added or removed from the CAE 3D Boundary
Condition revision, the status of the boundary condition shows as out-of-date.

You can also view the CAE status of released 3D boundary conditions if the
CAE_allow_cae_status_on_released_objects site preference is set to true at your site.

Note:

The system evaluates CAE 3D Analysis revision changes for CAE0Extract relationship only.

Procedure

1. Open a CAE 3D Boundary Condition revision from the appropriate folder in Explorer.

Alternatively, search for a boundary condition and open it.

The header section displays the CAE status as Up-to-date or Out-of-date.

2. If the status is out-of-date, hover your mouse over the status. The system displays a tooltip.

The tooltip provides the reason for the revision being out-of-date. For example, a dependent
attachment has been added.

3. Click the Out-of-date hyperlink.

The system opens the Overview tab. The Out-of-Date Information and Objects section displays
the status and the reason why the boundary condition is out-of-date.

4. To update the status, choose More Commands > Edit  and select Mark Up-To-Date.

18. Capture results and verify results
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Link the results to the CAE result revisions

After you create the CAE 3D Result revision, create a web link or a shared location for the results of the
simulation analysis.

1. Navigate to the CAE 3D Result revision you have created, open it, and click the Overview tab.

2. (Optional) Upload the files.

a. Click Add to  in FILES.

b. Click Choose File and select the file to upload.

3. (Optional) Create external links to files or folders that are managed outside the database but are
tracked from Teamcenter.

a. Click Add to  in EXTERNAL LINKS.

b. In PROPERTIES, specify a name and the URL or shared location, and then click Add.

c. (Optional) To delete a web link, select it, and click Edit and choose Delete External Links.

View related revisions, file attachments, and external links

1. Open a result revision from the appropriate folder in Explorer.

Alternatively, search for the result revision and open it.

2. To view all related CAE revisions in the context of the result revision, click the Overview tab.

The Related Objects table displays all the related revisions.

3. To view traceability information, select a revision from the Related Objects table.

The TRACEABILITY INFORMATION section displays how the selected revision is related to other
revisions.

4. To view the status of the simulation process, click View  and select Show Progress Monitor to
open the Simulation Tool Progress Monitor in a separate tab of the browser.

5. To view files attached and external links created for this revision, click the Overview tab.

Link the results to the CAE result revisions
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Visualize result files such as JTs and images

You can use the universal viewer to view object attachments. The universal viewer is displayed in an
object's Overview tab if there are attachments for the object. The universal viewer supports file types
such as PDF, text, HTML, Microsoft Office files, images and Direct Model (JT) files.

Note:

It is recommended that you store one JT file per Direct Model dataset. The universal viewer does
not support multiple JT files in a single Direct Model dataset. Also, CAE JT files containing results
quantities are not supported.

1. Select a CAE 3D Result revision that contains several secondary results and reports as attachments.

2. Click the Overview tab to view a preview of the selected file type.

The system displays a preview of the first file type attached to the revision.

3. To preview the next attached file type, click the Next button.

4. To navigate through a preview of attachments, click the Next or Previous button as appropriate.

Make a copy of the 3D result revision or revise it

You can make a copy of the of the 3D result revision or revise it.

Procedure

1. Make a copy of the 3D result revision.

a. Select the 3D result revision.

b. Choose More Commands > New   > Save As .

The Save As dialog opens.

c. (Optional) Specify a new name if you want to create a copy and description.

d. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.
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B. Select the folder and click Add.

e. To create a copy, click Save.

2. Revise the 3D result revision.

a. Select the 3D result revision.

b. Choose More Commands > New   > Revise .

c. (Optional) Specify required information as appropriate.

d. (Optional) Select a new destination folder.

The Newstuff folder is populated by default. At your site, if a different folder is configured by
default where newly created objects are stored instead of the Newstuff folder, the Save As
panel indicates that folder.

A. Remove the Newstuff folder and click the Add button to select another folder.

B. Select the folder and click Add.

e. To revise, click Save.

Make a copy of the 3D result revision or revise it
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19. Create physical test results
Physical testing task flow

As part of product verification before it is released to the market, a physical test engineer performs
prototype testing. An example of this is attaching sensors to the chassis of a vehicle to test it for
shock, vibration, and other stresses in real world scenarios. The engineer acquires measured data using
software such as Simcenter Testlab.

Simcenter Testlab is a data acquisition and analysis software for noise, vibration, and durability testing.
It provides integrated testing, analytics, and modeling tools for a range of testing requirements.

In Teamcenter, the physical testing task flow is as follows:

1. (Simulation administrator) Runs the quick setup script (tcsim_quick_setup.pl) to set up the sample
Simcenter Testlab configurations and to create the sample Physical Test Engineer user account.

2. (Physical testing lead or the designated physical test engineer) Identifies the physical test templates
created in Simcenter Testlab (*.tpl files) and imports them to Teamcenter.

3. (Physical testing lead or the designated physical test engineer) Creates a Physical Test Result
Template revision and associates the revision to the Simcenter Testlab templates (*.tpl files).
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4. (Physical test engineer) Reviews the verification request and creates a Physical Test Result revision
based on the Physical Test Result Template revision.

Note:

We recommend creating a physical test result revision in the context of a physical test result
template.

5. (Physical test engineer) Manually uploads physical test results and reports from Simcenter Testlab
to the Physical Test Result revision.

OR

Uses the preconfigured simulation tool Launch Test Tools to upload physical test results and
reports from Simcenter Testlab.

6. (Physical test engineer) Completes the verification request and sends it back to the verification
manager.

Create physical test result template revisions

The Physical Test Result Template revision is a workspace object for storing physical test templates
from test tools such as Simcenter Testlab.

You can use this workspace object to manage templates for testing postprocessing activities, for
example, Simcenter Testlab processes and Excel macros. When test engineers perform postprocessing
of test data, they prefer to keep these templates stored in Teamcenter and this results in consistent
postprocessing workflow for test data. The physical test result template object can be directly related to
a physical test result object. This makes it easy to retrieve all the physical test result objects.

Prerequisites

The following procedure assumes that the simulation administrator has run the quick setup script
(tcsim_quick_setup.pl) to create sample configurations and the sample Physical Test Engineer user
account.

Procedure

1. Set your Group to Engineering, Role to Physical Test Engineer and Workspace to Physical Test
Engineer.

2. Click the Create Physical Test tile on the home page.

3. In the Create Physical Test pane, select Physical Test Result Template.

19. Create physical test results
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4. Specify a name for the physical test result template revision, select or specify other values as
appropriate, and click Create.

5. To view the physical test results, open the physical test result template you have created, and click
the Physical Test tab.

6. (Optional) To upload or download files by using file upload rules, open the physical test template
revision you created earlier, and click the Files tab.

You can associate the Simcenter Testlab templates (*.tpl files) to this physical test result template
by using a preconfigured file upload rule.

7. To view the Simcenter Testlab templates (*.tpl files), click the Overview tab.

8. (Optional) To view the traceability of simulation data, open the physical test result template you
have created, and click the Relations tab.

9. (Optional) To search for physical test result templates, click Advanced Search, select Physical Test
Result Template Revision from the Advanced tab, specify the search criteria, and click Search.

Create physical test result revisions

The Physical Test Result revision is a workspace object for storing physical test results from test tools
such as Simcenter Testlab.

You can use this workspace object to manage test data postprocessing and report creation activities, for
example, Testlab projects, PDF, PowerPoint, and Word reports. It can be directly related to a revision such
as 3D result, 3D analysis, item, 1D analysis, 1D model and the physical test result template. When test
engineers want to store test reports and any associated data on Teamcenter, as well as postprocess raw
data using applications like Testlab, it ensures traceability to the product design as well as simulation
which is being validated by testing. This object can be created based on templates to ensure a consistent
test processing workflow.

Prerequisites

The following procedure assumes that the simulation administrator has run the quick setup script
(tcsim_quick_setup.pl) to create sample configurations and the sample Physical Test Engineer user
account.

Procedure

1. Log on to Active Workspace.

2. Set your Group to Engineering, Role to Physical Test Engineer, and Workspace to Physical Test
Engineer.

Create physical test result revisions
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3. Search for the Physical Test Result Template revision, select it and click New > Physical Test
Result.

OR

Click New > Physical Test Result.

4. Specify a name for the physical test result revision, select or specify other values as appropriate,
and click Create.

If you create a physical test result in the context of a physical test result template, the test type and
tool name are automatically copied from the template.

Note:

We recommend creating a physical test result in the context of a physical test result template.
If you are creating a physical test result revision without selecting a physical test result
template, you must add the template by selecting the Add Physical Test Result Template
option.

5. Open the physical test result revision you created earlier.

6. (Optional) To create external links or folders for the physical test result revision, click the Overview
tab and Add to in EXTERNAL LINKS.

You can create external links to files or folders that are managed outside the database but are
tracked from Teamcenter.

7. To upload or download Simcenter Testlab files by using file upload rules, click the Files tab.

Alternatively, use the preconfigured simulation tool Launch Test Tools to upload Simcenter
Testlab files. To do so:

a. Select the Overview tab and choose More Commands > Open in Test Tool  > Simcenter
Testlab.

b. Specify launch inputs as appropriate.

c. (Optional) To include a CAE 3D result for testing, click the Value box in the Optional Inputs
section and specify the CAE 3D result object.

You need to select this option only if you have not associated a CAE 3D Result object with the
physical test result revision.

d. To launch the tool, click Open.
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19-4  Simulation Process and Data Management on Active Workspace ─ Usage, Teamcenter 2412
© 2025 Siemens



e. Monitor the tool launch in the Simulation Tool Progress Monitor and verify if the tool launch
is completed successfully.

If an optional CAE 3D Result revision is selected, the datasets from the optional inputs,
in addition to the datasets from the physical test object, are downloaded to the Scratch
directory. Any changes made to the physical test object and CAE 3D results files are then
automatically imported to Teamcenter and you can view them from the Overview tab.

8. To copy the test EBOM, open the verification request in the Content tab, select the test EBOM, click
Copy, select the physical test result, right-click and select Paste.

The EBOM is now displayed in the PRODUCT and TEST EBOM table on the Overview tab.

9. To view or add parameters to the physical test result revision, click the Parameters tab.

You can add or remove parameters in this tab.

a. To add parameters, click More Commands > Add.

b. In the Add panel, specify a name and other parameters as appropriate.

c. (Optional) To remove a parameter, select it and click Remove in the PARAMETERS table.

10. To import physical test data packages, click New > Import Physical Test Data, choose the file, and
click Import.

The import is done asynchronously and the system displays an alert when it is complete.

11. (Optional) To search for physical test result objects, click Advanced Search, select Physical Test
Result Revision from the Advanced tab, specify the search criteria, and click Search.

12. (Optional) To view related simulation objects, click the Overview tab.

The Related Objects section displays the related simulation objects.

13. To view traceability information of related simulation objects, click the Overview tab and select an
object, such as Result, Analysis, 1D Model, or Product and Test EBOM from the Related Objects
section. The TRACEABILITY INFORMATION section displays the traceability information.

If there are multiple interrelated objects within the Related Objects section, the Traceability
information section displays all of the revisions, names, and item IDs of the interrelated objects
as well as their relation to the physical test result object. The arrow denotes the direction of the
relationship. For example, a backward arrow indicates a primary to secondary object relationship.

14. View the relations and the objects related to the physical test results.

Create physical test result revisions
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a. Open the physical test result revision you have created and click the Relations tab.

b. Click Legend.

The Legend panel displays a list of all the supported relations. You can select the relations or
objects from this panel to see the highlighted view.

c. Select the Physical Test object to view the relation between the physical test result and the
associated physical test template objects.

d. Select the File object to view the relation to file objects attached to the physical test result.

e. Select the Correlation relation to view the relation between the associated 3D analysis
revision and the 3D result revision.

f. Select the Test Results relation to view the relation with the test EBOM.

g. Select the Input relation to view the relation with the 1D object.

h. Select the Based On relation to view the relation with the test result template.

15. To export physical test data from Teamcenter in a structured manner, use PLM XML export.

For more information, see Sharing data using PLM XML.

a. Open the physical test result revision.

b. Choose More Commands > Share  > PLM XML Export.

c. Select the CAEConfiguredDataFilesExportDefault transfer mode.

d. Select the appropriate language and click Export.

The export begins and you receive an alert when it is complete.

16. To import physical test data in a structured manner and create Teamcenter objects based on this
structure, use PLM XML import.

For more information, see Sharing data using PLM XML.

a. Select the folder into which you wish to import the contents of the .zip file.

b. Click New   > Import PLM XML to display the Import PLM XML panel.

c. Use Choose File to locate the .zip file on your local system.
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d. Select the transfer mode, for example, CAE_incremental_import containing the rules
appropriate to use when importing the file.

e. Click Import to import the objects in the .zip file.

The import begins and you receive an alert when it is complete.

Mark physical test revisions as up-to-date for changes to
attachments and related revisions

If a related analysis revision or a related result revision undergoes changes related to parameters or
attachments, you can use the Mark Up-To-Date command to mark the physical test revision as up-to-
date.

You can also view the CAE status of the released physical test revisions if the
CAE_allow_cae_status_on_released_objects site preference is set to true at your site.

Procedure

1. Open a physical test revision and mark it as up-to-date.

a. Open a physical test revision from the appropriate folder in Explorer.

Alternatively, search for a physical test revision and open it.

The header section displays the CAE status as Up-to-date or Out-of-date.

b. If the status is out-of-date, hover your mouse over the status. The system displays a tooltip.

The tooltip provides the reason for the revision being out-of-date. For example, the dependent
item revision has a newer revision.

c. Click the Out-of-date hyperlink.

The system opens the Overview tab. The Out-of-Date Information and Objects section
displays the status and the reason why the related revision is out-of-date.

d. Select Update Latest Reference or Add Latest Reference as appropriate.

e. Click Edit  and select Mark Up-To-Date.

Note:

If attachments or related objects are attached with the relationship specified in the
CAE_significant_relation_types_for_PhysicalTestResult site preference and they get

Mark physical test revisions as up-to-date for changes to attachments and related revisions
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updated, modified, or revised, then the CAE status on the physical test revision changes
to out-of-date. The default values for this preference are Correlation, Input, and
Specifications.

2. Search for multiple physical test revisions and mark them as up-to-date.

a. Search for multiple physical test revisions.

b. Select the physical test revisions you want to mark as up-to-date and click Edit > Mark
Up-To-Date.
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20. Using the simulation dashboard
Why use the simulation dashboard?

The simulation dashboard provides a clear view of the status of all the models and analyses carried
out by simulation analysts at the program, milestone, group, or individual user level. It allows decision
makers to access the latest information and make correct decisions.

The Simulation Dashboard:

• Displays the list and status of all models and analyses based on a query or based on the objects you
select, for example, model structure, analysis or model revisions, or folders containing analysis or
model revisions.

• Displays the status of all models based on variants of the vehicle or the status of the master structure
based on the pedigree information.

• Presents the status of the results corresponding to the models and analyses.

• Monitors key performance indicator (KPI) values such as maximum stress, minimum temperature, or
maximum displacement in an analysis revision or analysis template.

You can also export reports, if they are available, in spreadsheet format.

Open a model structure and view the dashboard results

The process flow is as follows:
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If the product structure data is configured by using classic variants, such data cannot be monitored in
the simulation dashboard when the Product Configurator mode is enabled. In such cases, the system
displays the Not Found value in the dashboard.

1. Open the model structure, click the Content tab, and select some child revisions in the Tree view.

2. Click Simulation Dashboard on the top of the content area.

3. In the Select Dashboard panel, select the All tab to view all the model dashboards.

Alternatively, select the Favorites tab to view all the model dashboards that you marked as
favorites.

4. Select a dashboard and click Execute.

20. Using the simulation dashboard
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Note:

When you execute the dashboard queries to display the results, the system considers the
root item of the model structure, irrespective of the child model revisions you select in the
structure.

5. (Optional) Sort and refresh the dashboard results.

6. (Optional) Edit the dashboard results.

7. (Optional) Generate the dashboard report.

8. (Optional) To view a summary of the dashboard, click Summary  on the top of the table.

9. (Optional) Launch simulation tools from the dashboard.

Select objects and view the dashboard results in the context of the
selected objects

1. Use one of the following methods to open the dashboard results:

• Select multiple model and analysis revisions and choose More Commands > View  >
Simulation Dashboard.

In the Select Dashboard panel, select the All tab to view both model and analysis dashboards.
Alternatively, select the Favorites tab to view both model and analysis dashboards that you
marked as favorites.

• Select multiple model or analysis revisions and choose More Commands > View  >
Simulation Dashboard.

In the Select Dashboard panel, select the All tab to view only model or analysis dashboards.
Alternatively, select the Favorites tab to view only model or analysis dashboards that you
marked as favorites.

2. Select a dashboard and click Execute.

3. (Optional) Sort and refresh the dashboard results.

4. (Optional) Edit the dashboard results.

5. (Optional) Generate the dashboard report.

6. (Optional) To view a summary of the dashboard, click Summary  on the top of the table.

Select objects and view the dashboard results in the context of the selected objects
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7. (Optional) Launch simulation tools from the dashboard.

Select folders and view the dashboard results in the context of the
selected folders

You can select folders and view the dashboard results in the context of the selected folders.

1. To open the Analyst workspace, log on as an analyst user.

This method of accessing the dashboards is available only in the Analyst workspace.

2. Select a folder that contains analysis or model revisions and choose More Commands > View  >
Simulation Dashboard.

Note:

To view all dashboards, select two or more folders containing model and analysis revisions,
respectively.

3. In the Select Dashboard panel, select the All tab to view model or analysis dashboards,
respectively.

Alternatively, select the Favorites tab to view model or analysis dashboards, respectively. The
dashboards that you marked as favorites are displayed here.

Tip:

All dashboards are displayed in these tabs if you select two or more folders containing model
and analysis revisions, respectively.

4. Select a dashboard and click Execute.

5. (Optional) Sort and refresh the dashboard results.

6. (Optional) Edit the dashboard results.

7. (Optional) Generate the dashboard report.

8. (Optional) To view a summary of the dashboard, click Summary  on the top of the table.

9. (Optional) Launch simulation tools from the dashboard.

20. Using the simulation dashboard
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Search for objects and view the dashboard results in the context of
the search

1. Search for model or analysis revisions.

2. Select the revisions and choose More Commands > View  > Simulation Dashboard.

3. In the Select Dashboard panel, select the All tab to view model or analysis dashboards,
respectively.

Alternatively, select the Favorites tab to view model or analysis dashboards, respectively. The
dashboards that you marked as favorites are displayed here.

4. Select a dashboard and click Execute.

5. (Optional) Sort and refresh the dashboard results.

6. (Optional) Edit the dashboard results.

7. (Optional) Generate the dashboard report.

8. (Optional) Launch simulation tools from the dashboard.

Execute queries to view the dashboard results

1. On the HOME page, click Simulation Dashboards.

2. Select a Model Dashboard or an Analysis Dashboard.

3. To execute a query, click Input .

4. In the Input panel, select a query from the list.

The system populates the list of valid queries depending on the type of dashboard you select.

5. Specify or select values as appropriate and click the Execute button.

6. (Optional) Sort and refresh the dashboard results.

7. (Optional) Edit the dashboard results.

8. (Optional) Generate the dashboard report.

9. (Optional) To export reports in Microsoft Excel or Microsoft Word format, select a revision or
multiple revisions, click Share  > Export. Select the appropriate options to export the data.

Search for objects and view the dashboard results in the context of the search
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10. (Optional) Launch simulation tools from the dashboard.

Launch simulation tools from the dashboard

1. Execute queries to view the dashboard results.

2. Select one or more objects from the dashboard.

3. (Analyst workspace) Choose Open in Simulation Tool .

(Default workspace) Choose Open  > Open in Simulation Tool .

4. Select a preconfigured launch tool.

5. Specify the required inputs and select a launch method.

Sort and refresh the dashboard results

Performing a sort of the dashboard results is useful for identifying unfinished tasks. Let us assume that
you are performing the design validation of a car assembly. After getting the workflow request, you
search for the product structure with the CAD data in Teamcenter, and you apply structure map rules
to create a model structure based on the product structure. You open the model structure, select the
meshing dashboard, and execute a query to view the dashboard results.

Example:

You can sort the FEM File column in the dashboard to find out which components or objects
have finite element mesh (.fem) files attached to them. If the dashboard objects have .fem files
attached to them, it means that they were analyzed previously. You can filter out the objects
with mesh files by typing Not Found in the text filter. The dashboard displays objects that do not
have .fem files attached to them. You can then launch simulation tools on such objects to start the
meshing process.

1. Execute queries to view the dashboard results.

2. Sort the dashboard columns using a text filter.

a. Click the table header of the column you want to sort.

b. Select an operator. The valid operators are Contains, Does not contain, Begins with, Ends
with, Equals, and Does not equal.

c. Type the text by which you want to filter the column contents and click Filter.

20. Using the simulation dashboard

20-6  Simulation Process and Data Management on Active Workspace ─ Usage, Teamcenter 2412
© 2025 Siemens



The text filter you specify is not case sensitive. For example, you can type cae to filter object
names containing both CAE in upper case and cae in lower case.

d. (Optional) After applying a text filter, hover your mouse over the Filter icon. The system
displays the text filter you have applied as a tooltip.

e. (Optional) Apply a filter criteria on a specific column and then sort the same column. The
system applies both the filter and the sort criteria and loads the results as per both the criteria.

f. To sort further, select more column headers and select the appropriate sort options.

Example:

In the Object column, select Contains and type CAE to show all objects with CAE in the
object name. For further text-based sorting, select Equals in the Mass column, and type
1000 KG to display only objects with a mass of 1000 kilograms.

3. Sort the dashboard columns for common values by using facets.

a. Click the table header of the column you want to sort.

b. Enable Show Filters, select the specific objects you want displayed in the dashboard column,
and click Filter.

You can optionally first apply a text filter and then enable Show Filters to further filter the
column results.

Example:

In the Name column, type kpi in the text filter and then enable Show Filters to display
only names that have kpi in this column.

4. To refresh the entire simulation dashboard, click Refresh  at the top of the table.

The system preserves the sorting order even after the dashboard is refreshed.

5. To refresh the selected objects, select one or more objects in the simulation dashboard and click
Refresh  at the top of the table.

The system preserves the sorting order even after the selected objects are refreshed.

6. To reset the filter criteria on a column, click the column header and click Clear.

7. To reset all filters, click  > Clear all filters.

8. To view a summary of the dashboard, click Summary  at the top of the table.

Sort and refresh the dashboard results
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When you refresh the simulation dashboard, the summary information is also refreshed.

9. Execute a query after sorting the dashboard.

a. Sort the dashboard.

b. To execute a query, click Input  at the top of the table.

c. Specify or select values as appropriate and click the Execute button.

The system preserves the sorting order even after you execute a query.

10. (Optional) Edit the dashboard results.

11. (Optional) Generate the dashboard report.

12. (Optional) Launch simulation tools from the dashboard.

Edit the dashboard results

1. Execute queries to view the dashboard results.

2. (Optional) Sort and refresh the dashboard results.

3. (Optional) To reset the filter criteria on a column, click the column header and click Clear.

4. To edit the dashboard, click  Start Edit on the top of the table.

5. Make the required changes to the properties displayed in the dashboard.

6. To save your changes, click Edit  > Save Edits.

7. (Optional) Generate the dashboard report.

Generate the dashboard report

1. Execute queries to view the dashboard results.

2. (Optional) Sort and refresh the dashboard results.

3. Click Generate Dashboard Report  on the top of the table.

The system generates the dashboard report as per the filter criteria you have applied.

4. Select a template for the report.

20. Using the simulation dashboard
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5. To save the report, select the Create Dataset check box and specify a report name.

6. Click the Generate Report button.

The system generates the report asynchronously and an alert is displayed when it is available. The
report is saved to the database and is available from the Newstuff folder.

If you have selected the Create Dataset check box, the report is saved in the database with the
report name you specified and is available from the Newstuff folder.

Generate the dashboard report
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