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1. Service Lifecycle Management
Service Planner

Capitalize on the re-use of product knowledge from engineering and manufacturing to improve service
planning and execution. Provide feedback to engineering to improve product designs for serviceability
and reliability. Communicate and coordinate operational activities for greater compliance, faster service,
and lower costs.

Service Lifecycle Management products

Select a link below to access the help documentation for each product.

Service Lifecycle Management on web client

Service Engineering

Service Work Instruction

Service Manager
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As-Built Manager

Service Planner

Maximo Integration

Microservices for Service Lifecycle Management Integration

1. Service Lifecycle Management
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2. What's new in Teamcenter Service
Planner
What's new in Service Planner 2412

You can now change the ownership of an assigned work card so another person can work on it to finish
the related service requirement.

• You can now change the ownership of the related data in a work card.

The utility Change Owner is available to Change the ownership of data in a work card.

What's new in Service Planner 2312

• Existing service plans that were created in Service Planner likely contain partitions, which are used to
group together service requirements within a service plan. Partitions are not applicable in the Active
Workspace web client and are replaced with containers.

The utility convert_partition_to_container is available to facilitate migrating partitions to
containers.

What's new in Service Planner 13.2

• Teamcenter Environment Manager (TEM) is deprecated and will be obsolete in a future version of
Teamcenter.

• You now can create service plans from configured neutral structures in Service Planner. You
apply variants to the service bill of materials to define configured product structures. The service
requirements in the service plan are based on the configured product structures.

What's new in Service Planner 13.1

• The Service Planner user interface is enhanced in Teamcenter 13.1 to make finding other part
occurrences much easier.

• The Advanced Accountability Check has been added to Service Planner in Teamcenter 13.1,
allowing the service technician verify that all parts from the engineering BOM (EBOM) that need
to be consumed in the SBOM are correctly copied.

• Service containers are added to Service Planner in 13.1. Service containers are similar to service
partitions but have additional benefits.

• They have improved performance.
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• Service containers an be revised.

• They are supported in Active Workspace.

• Service containers can be copied and pasted, along with their contents.

• Service plans often contain service requirements that are similar to or the same as service
requirements in other service plans.

Beginning with Teamcenter 13.1, you are able to clone service requirements and most of their
contents within a service plan, between service plans, and between partitions. The items contained
in a service requirement, by default, are cloned, with the exception of the consumed parts. For more
information see:

• Duplicating a service requirement behavior

• Duplicate a service requirement–Clone

• Duplicate a service requirement–Reference

2. What's new in Teamcenter Service Planner
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3. Getting started with Service Planner
Getting started with Service Planner

The Service Planner application supports service planning capabilities within Teamcenter. Service
Planner is a separately licensed application that is installed as an optional overlay on top of the standard
Teamcenter product. Service Planner lets users create and manage service plans, service requirements,
work cards, activities, and other information to support the service planning process.

You can use Service Planner to:

• Create and manage service plans for a neutral product.

• Create service partitions within a service plan to organize service requirements.

• Create and manage service requirements to define the maintenance that can be performed on a
product.

• Create service requirements to address particular fault codes.

• Define frequencies for service requirements to determine when the work needs to be done.

• Set up dependencies or relations between service requirements.

• Define applicability between service requirements and neutral parts.

• Create and manage work cards to determine how the work needs to be done.

• Manage the work process flow by sequencing work cards to be done in a particular order or determine
work that can be done in parallel.

• Create and manage activities that provide more detailed information about the planned work.

• Create characteristic definitions and attach them to neutral parts, work cards, or activities to define
data that should be recorded as part of the maintenance.

• Define the particular skill level needed to perform or sign off the service work.

• Define any expendable materials or tools needed to perform the service work.

• Create notices and attach them to work cards or activities to provide additional information, such as
any notes, warnings, or cautions related to the planned work.

• Manage the time estimates for the planned work.
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• Create and manage the work instructions.

• Import and export Service Planner data in PLM XML format.

• Manage Service Planner data in a Multi-Site Collaboration environment.

Before you begin

Prerequisites The Service Planner application requires a separate license
in addition to the standard Teamcenter product license. You
must obtain and install the appropriate license required to run
the Service Planner application.

Enable Service Planner Service Planner does not need to be enabled before you use
it, but you must select the appropriate components during
installation.

If you have trouble accessing Service Planner, see your system
administrator; it may be a licensing issue. The Service Planner
application requires a separate license in addition to the
standard Teamcenter product license.

Configure Service Planner There are additional steps that you can perform to configure
Service Planner before you can use it.

Start Service Planner Click Service Planner  in the navigation pane.

Service Planner interface

Service Planner perspective

Service Planner uses the Teamcenter rich client interface and provides the Service Planner and Plan
Details views. Interface items for Service Planner are described in the Service Planner menus and
buttons and symbols topics.

3. Getting started with Service Planner
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1 Teamcenter component pane Shows the Home view.

2 Base View tab Contains only the service plan and is used only for
reference. It is not used to manage the service plan. You
cannot expand the service plan in this tab.

3 Partition name tab Contains the service partitions and is used to create and
modify the service plans. You can expand the service plan
in this tab.

4 Service Planner view Contains the Service Plan tab that displays the service plan
and all related information.
Contains the Product tab that displays the as-maintained
neutral and physical structures.

5 Additional views Displays all the views pertaining to activities, time
management, variants, and work instructions.

6 Plan Details view Displays service plan details.

Service Planner perspective
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Service Planner menus

File menu

Command Description

New → Fault Code Creates a new fault code.

New → Dataset Creates a new dataset.

New → Service Plan Creates a new service plan.

New → Service Partition Creates a new service partition.

New → Service Requirement Creates a new service requirement.

New → Work Card Creates a new work card.

New → Activity Creates a new activity.

New → Frequency Creates a new frequency.

New → Skill Creates a new skill.

New → Notice Creates a new note, caution, or warning.

New → Life Characteristic Creates a new life characteristic.

New → Date Characteristic Creates a new date characteristic.

New → Observation
Characteristic

Creates a new observation characteristic.

Revise Revises the selected item.

Most Recently Used Structures Displays a list of structures that you recently closed. Use this as a
way to quickly open desired structures.

Open By Name → Open Product Browses for and opens a specific product by name.

Open By Name → Open CC Browses for and opens a specific collaboration context by name.

Open By Name → Open Structure
Context

Browses for and opens a specific structure context by name.

Close Closes the Service Planner application.

Unload All Removes all structures from the collaboration pane.

Exit Ends the rich client session.

3. Getting started with Service Planner

3-4  Service Planner, Service Lifecycle Management 2412
© 2024 Siemens



Edit menu

Command Description

Cut (Ctrl+X) Marks the selected lines for removal and copies the content to
the clipboard. Cut lines are only removed once pasted elsewhere
in the structure.

Copy (Ctrl+C) Copies the selected lines to the clipboard.

Paste (Ctrl+V) Inserts the Clipboard contents below the selected item.

Paste Special Pastes components on the clipboard to the selected assembly
(line).

Remove Removes the selected lines from the structure. The lines
removed by this method are not placed on the clipboard.

Delete Deletes the selected object from the database.

Properties Views and edits all properties of the selected line.

User Setting Displays the User Settings dialog box, where you can change
your group, role, or volume assignments, and your application
logging and journaling options.

Options Changes your user interface settings that affect all applications,
not only Service Planner.

Variant Condition Creates a variant condition on the selected line.

Show/Hide In-Context BOM Line Shows or hides the line that is the context of a particular in-
context edit.

View menu

Command Description

Refresh (F5) Updates the information displayed for a selected line and all of
its children.

Refresh Window Synchronizes the currently displayed structure with the
database. The displayed structure refreshes with changes that
have been made in other sessions and saved since you loaded
the currently displayed structure.

Open CC Tree Opens the collaboration context tree view.

Access Allows you to view, change, and apply access permissions for a
selected object.

Edit menu
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Command Description

Pack Unpack → Pack
(Ctrl+Shift+M)

Packs the selected lines so that all lines with the same item
revision and find number are displayed as a single line. The
actual quantity of lines appended to the node.

Pack Unpack → Pack All Packs all packable lines in the displayed structure.

Pack Unpack → Unpack
(Ctrl+Shift+N)

Unpacks the selected packed lines so that they are displayed as
separate lines, one for each occurrence.

Pack Unpack → Unpack All Packs all packable lines in the displayed structure.

Expand Options → Expand Expands the substructure immediately below the selected lines.

Expand Options → Expand Below Expands the complete substructure below the selected lines.

Expand Options → Expand
Below...

Expands the substructure below the selected lines to a user-
selected level. You can also collapse an expanded substructure
when you choose this option (hide certain child lines).

Expand Options → Expand to
Type

Expands the substructure below the selected lines to a user-
selected type.

Collapse Below Collapses the complete substructure below the selected lines
(hide all child lines).

Tools menu

Command Description

Check-In/Ou → Check-Out Checks a selected component out of the database.

Check-In/Ou → Check-In Checks a selected component into the database.

Check-In/Ou → Cancel Check-Out Cancels a request checkout action.

Check-In/Ou → Transfer Check-Out Transfers a selected, checked-out component to another user.

Check-In/Ou → Notification List Allows you to view or edit the list of users who are informed if
the selected component is checked in or checked out.

Check-In/Ou → Check-Out History Allows you to view the history of checkout actions for the
selected component.

Revision Rule → View/Set Current Allows you to view or set the revision rule for the currently
displayed structure.

Revision Rule → Set Date/Unit/End
Item

Sets the date, unit number, or end item to configure the
structure, if the current rule allows.

3. Getting started with Service Planner
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Command Description

Revision Rule → Set Override
folder

Sets an override folder to override item revisions that would
otherwise be selected by other criteria.

Revision Rule → Modify Current Modifies the current revision rule and apply the modified rule to
the current structure. You can save the change if you have write
access to the original rule.

Revision Rule → Create/Edit Creates or edits a revision rule.

Effectivity → Revision Effectivity Allows you to view, edit, create, or copy effectivity data for the
item revision of the selected line. You must have the appropriate
permissions to create or edit effectivity data.

Effectivity → Effectivity Mapping Allows you to view, edit, create, or copy effectivity mapping for
an end item. Effectivity mappings are needed if you implement
nested effectivity.

Multi-Site Collaboration Controls the data shared with participating sites in a distributed
network. Multi-Site Collaboration allows you to publish and
unpublish objects.

Variants → Configure Variants Allows you to configure or edit a variant structure for the
selected top-level module.

Variants → Only Configure Root Allows you to set to on to only display options for the top-level
module, regardless of the line selected. Set to off to configure
the structure for a lower level module.

Variants → Search Searches for an existing variant item.

Variants → Count Modules Counts the modules defined for the selected variant structure.

Variants → Count Modules Counts the modules defined for the selected variant structure.

Variants → Count Modules Counts the modules defined for the selected variant structure.

Export → Objects Exports selected objects in Teamcenter format, STEP format or
a new or available application interface. When you export an
object in Teamcenter or STEP format, you move all internal data
associated with that object.

Export → To PLMXML Exports the selected structure and its attachments in PLM XML
format to a selected export directory. You must choose the
appropriate transfer mode for the destination system.

If you export a structure in which substitute components are
defined, the substitutes are also exported.

Export → Objects to Excel Exports the selected structure lines to an Excel spreadsheet.

Import → Templates Imports a specification, object or excel template.

Tools menu
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Command Description

Import → Objects Imports objects in a Teamcenter format or STEP format to your
Teamcenter database.

Import → From PLMXML Imports objects in PLM XML format to your Teamcenter
database.

Import → Remote Imports objects from a remote site using Multi-Site
Collaboration.

Import → Objects Imports the selected structure and its attachments in PLM XML
format to a selected import directory. You must choose the
appropriate transfer mode for the destination system.

Setup Upgrade Defines an upgrade work card.

Define Part Applicability Defines part applicability for a service requirement.

Repairs Broken Links Identifies broken links and searches for possible repair
candidates.

Re-Sequence Structure Reorders the process to reflect a change in the process step
numbers.

Update Flows Updates PERT flows according to the find number of the selected
component's children, or in the case of multiple selections, of
the selected components.

Populate Allocated Time Updates the allocated time of all the descendants of the selected
process or operation.

Advanced menu

Command Description

Generate Portfolio Creates a technical portfolio that acts as a container for work
instructions or product manuals and supporting documents,
such as a table of contents, cover or trailer pages, and header
and footer information.

Service Planner buttons and symbols

Note:

You can add buttons that are not displayed on the main toolbar by right-clicking the toolbar,
choosing Customize, and selecting the buttons you want to add. Once you add buttons to the
toolbars, they are displayed in future sessions. Consider adding buttons that:
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• You use frequently.

• Provide a shortcut to menu commands that are not primary selections, for example,
Tools → Revision Rule → Set Date/Unit/End Item.

Button Purpose

These standard buttons are located on the main toolbar at the top of the Service Planner pane.

Soft abort If enabled, allows you to terminate the current
operation without closing Service Planner or losing
data.

Cut Cuts the selected lines from the structure and
places them on the clipboard.

Copy Copies the selected lines in the structure and places
them on the clipboard.

Paste Pastes the components from the clipboard as
children of the currently selected (assembly) line in
the structure.

Delete Deletes the selected object from the database.

Toggle in context mode Enables and disables in-context editing, allowing
creation of absolute occurrences for the selected
assembly.

Remove Removes the selected lines from the structure
completely and does not place them on the
clipboard.

Open Collaboration
Context Tree

Opens the Collaboration Context Tree view that
displays all the open structures. You can use this
view to make structures visible in the structure
pane or to unload structures.

Create a service plan Creates a new service plan.

Create a service partition Creates a new service partition.

Create a service
requirement

Creates a new service requirement.

Create a work card Creates a new work card.

Create an activity Creates a new activity.

Service Planner buttons and symbols
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Button Purpose

Create a frequency Creates a new frequency.

Create a skill Creates a new skill.

Create a notice Creates a new notice.

Create a fault code Creates a new fault code.

Set up upgrade Sets up an upgrade work card to identify a different
revision of the neutral product or an entirely new
neutral product that is defined for the parent
service requirement.

Resequence structure Reorders the work card to reflect a change in the
work card step numbers.

Edit variant condition Allows you to view or edit the variant condition on
the selected lines.

Pack selected line Packs the selected lines so that all lines with the
same item revision and find number are displayed
as a single line. The actual quantity of lines
appended to the node.

Unpack selected line Unpacks the selected packed lines so that they
are displayed as separate lines, one for each
occurrence.

Navigation Pane Displays or hides the navigation pane.

Advanced Search Allows you to select a search form that includes
multiple search criteria relevant to the type of
information or object being sought.

View/set current Allows you to view or set the revision rule on the
current line.

Configure variants Allows you to view and configure the variant option
values for the selected line.

Show/hide the
collaboration pane

Displays or hides the collaboration pane, which
provides advanced features for configuring
structures. These features relate primarily to Multi-
Structure Manager.

Show/hide the lower
structure pane

Displays a second structure pane below the first.
You can set the size of each structure pane by
moving the horizontal split bar between the panes.

3. Getting started with Service Planner

3-10  Service Planner, Service Lifecycle Management 2412
© 2024 Siemens



Button Purpose

If the second structure pane is displayed, this
button hides the lower pane.

Assign resource from
library/classification

Opens the Classification Search Dialog that you can
use to assign a specific resource to a selected line in
your structure.

Show/hide data pane Shows or hides the data pane containing, for
example, properties data or the embedded viewer.

Open By Name Browses for and opens a specific product,
collaboration context or structure context by name.

Most recently used (MRU)
list

Shows a list of your most recently accessed
structures. If you select an entry from the list,
Service Manager loads the structure into the
structure pane. You can configure the number of
entries shown in the MRU list by right-clicking
the button and moving the slider to the desired
number.

Manage global alternates Shows a list of the global alternates available for
the selected line. You can add alternates and select
a preferred alternate. The preferred global alternate
is indicated by an asterisk.

If your Teamcenter administrator has set the Incremental_Change_Management preference to
true, the incremental change toolbar is available and located at the bottom of the Service Planner
application window. The incremental change toolbar includes the following buttons.

Create an incremental
change context

Creates a new incremental change.

Select an incremental
change context

Searches for an incremental change order.

Most recently used
Incremental Changes

Displays the MRU list containing the most recently
used incremental changes.

View/edit most recent IC
information

Displays the incremental change Information
dialog box.

Clear IC context Clears the active incremental change and turns off
incremental change tracking.

The following buttons are located in the structure views.

Opens the Graphics view to display visualization
data associated with the structure.

Service Planner buttons and symbols
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Button Purpose

Shows lines that are hidden because they are
configured out using variants and options.

In a process structure view, shows lines that
are configured out because they are assigned
occurrences that are configured out for any reason
in the original structure.

Shows lines that are configured out because an
incremental change associated has an effectivity on
it and the lines are not currently effective.

Shows lines that are configured out because they
have an occurrence effectivity associated with them
and the lines are not currently effective.

Displays configuration information about the open
structure.

Enables you to show or hide any related occurrence
groups.

The following symbols are displayed at the bottom right corner of the product structure pane and
show the current status of the selected line.

Shows if you have write access permissions for the
selected line.

Shows if you have delete access permissions for the
selected line.

Shows if you have access permissions to change the
selected line.

Shows if the item revision represented by the line is
currently in a workflow process.

Shows if the item revision represented by the line is
currently checked in or checked out.

Shows if the item revision represented by the line is
currently released.

Shows if the item represented by the line is
currently published.

Shows if the item or revision represented by the
line is currently classified.
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What are perspectives and views?

Within the rich client user interface, application functionality is provided in perspectives and views.

View The basic display component that displays related information in a UI window.

Perspective A collection of one or more views and their layout.

Some applications use a perspective with multiple views to arrange how functionality is presented.
Other applications use a perspective with a single view.

You can use the HiddenPerspectives preference to prevent the display of some Teamcenter perspectives
in the rich client.

If your site has online help installed, you can access application and view help from the rich client Help
menu or by pressing F1.

Basic concepts for using Service Planner

To take full advantage of Service Planner, you should be familiar with the Teamcenter elements that are
used to define and present product structure and manage multiple product views.

Before creating or modifying the product structure, read Getting Started with Product Structure,
which describes the basic concepts behind product structure and includes advanced information on how
to use and administer it.

You use Service Planner to define how a neutral product will be serviced. It consists of the following
elements:

• The service plan for the neutral product to be serviced. A service plan is a high-level container for
service requirements for parts or assemblies in a neutral product structure. A neutral product can have
multiple service plans. For example, you can have one service plan for the entire parent assembly and
a separate service plan for an individual part of that assembly.

• When you create a service plan, there is one service partition created by default. A service plan has
only one root service partition. You can create one or more additional service partitions within the
root partition to organize service requirements that make up the service plan.

• The service requirements within a service plan. A service requirement defines maintenance for a
neutral part or assembly that needs to be performed on a scheduled or conditional basis. A service
requirement defines the type of service, when the service should occur, and other information for
fulfilling the requirement. You can set dependencies or relations between two service requirements,
such as defining that a particular service requirement has to be completed before another service
requirement is done or that the completion of one service requirement fulfills another service
requirement.

What are perspectives and views?
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• The frequency associated with each service requirement. The frequency determines when the service
work needs to be performed; on a scheduled or conditional basis.

• The work card attached to a service requirement to define how the work is to be done. Work cards
define information about the activities, effort and cost estimates, and required resources for the
service work.

• The activities attached to a work card to define breakdown of the work details. An activity defines a
specific step, or series of steps, required for completing all or part of a work card.

You can also assign resources to service requirements, work cards, and activities. Resources include
skills, part movements, expendable materials, and tools.

• A skill is a qualification that a person needs for performing or signing off service work. The skill level
assignment for a service requirement is the skill level needed for signing off the requirement. Work
cards and activities can have skill level assignments for performing or signing off the work.

• A part movement resource indicates whether a neutral item is installed, uninstalled, or replaced when
the maintenance is performed.

• An expendable material resource is any material needed to complete the work that will be consumed
during the process of performing the work, such as paper towels. An expendable material does not
become part of the configuration and is not tracked.

• A tool resource is any part or tool needed to complete the work that is not consumed during the
process of performing the work, such a screwdriver. A tool does not become part of the configuration
and is not tracked.

3. Getting started with Service Planner
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Search for Service Planner objects

You can search for the following Service Planner objects using advanced search:

• MRO Date Characteristics
• MRO Fault Code
• MRO Item
• MRO Life Characteristics
• MRO Neutral Part
• MRO Observation Characteristics
• MRO Service Partition
• MRO Service Plan
• MRO Service Requirement
• MRO Skill
• MRO Work Card

1. Choose Advanced from the quick Search menu at the top of the navigation pane.

Search for Service Planner objects
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2. On the Search pane toolbar, click  to select a search type.

3. Click More to display the system defined searches.

4. Under System Defined Searches, select the object you want to search for.

5. Click OK.

The dialog box that contains the object properties appears.

6. Type the values for the object properties that you want to search for.

7. Click the  button to search.

Basic tasks for using Service Planner

The basic tasks for using Service Planner are:

1. Configuring Service Planner LOVs.

2. Setting up and managing the service plans for a neutral product.

3. Optionally, setting up additional service partitions within the service plan to organize the service
requirements.

4. Creating and managing service requirements.

5. Creating and managing work cards.

6. Creating and managing activities.

7. Managing time estimates for service requirements, work cards, and activities.

8. Creating, viewing, and editing work instructions.

Service Planner process task flow

The following graphic shows the Service Planner process task flow.

3. Getting started with Service Planner

3-16  Service Planner, Service Lifecycle Management 2412
© 2024 Siemens



Service Planner process task flow
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4. Displaying information
Displaying information

You can display a variety of information in the primary and secondary views of Service Planner. Many of
the secondary views are only available if you select an object in a primary view that provides valid input.
For example, you can only open the Activities view if you select a work card.

Managing Service Planner data

Working with Service Planner views

Teamcenter presents Service Planner data in views, each view providing its own specific way of
managing or modifying the data. There are primary views and secondary views.

There are primary views and secondary views.

• A primary view shows one configurable structure. That structure can contain a base view and several
occurrence groups.

• A secondary view shows specific types of data related to the primary view with which it is associated.
It can, depending on your needs, change its content if you select a new object in a primary view.
Many of the secondary views are available only if you select an object in a primary view that contains
valid input.

In addition to primary and secondary views, you can use the following:

• Collaboration Context Tree view to show all loaded objects.

• Structure Search view that allows you to search for any object regardless of view.

• Graphics view to display any visualization data associated with the structure. The Graphics view is
closely associated with the primary view from which you open it.

You can open multiple views simultaneously. You can undock views and move them to a convenient
position. You can open the same structure multiple times in different views. To assist you in keeping
track of which views are associated, primary views and secondary views are color-coded. Primary and
associated secondary views have the same framed color. In addition, Teamcenter frames the active view
(the one in which you are currently working) in black.

Each view has a toolbar with buttons to execute the common tasks pertaining to that particular view.
The view menu contains additional menu commands pertaining to that view. More complex tasks or
tasks pertaining to several views simultaneously are found on the main application toolbar. The views
have some features in common, such as the ability to change the displayed columns or filtering the
results. You find these features in the view menu.

Service Planner, Service Lifecycle Management 2412  4-1
© 2024 Siemens



Behavior of selected objects in active views

If you select an object in the active view, the selections in the other views change as follows. This is
known as selection synchronization.

• Primary views can change their inner selection (highlight) to suit the active selection. The following
situations can cause them not to do so:

• The selection does not correspond to any object in the view.

• The corresponding object is not currently expanded, and the MEExpandToSelection preference is
set to false.

• An expensive search is required to find the corresponding line. In this case, use one of the Find
commands.

• Secondary views can change their inner selection (highlight) to suit the active section when that
selection occurs in a primary view or in another secondary view that is associated to the same primary
view. The following situations can cause them not to do so:

• The selection does not correspond to any object in the view.

• The Disable response to selections button  is turned on.

Managing loaded objects with the Collaboration Context Tree view

The Collaboration Context Tree view displays all structures that are loaded in your session. You can use
this view to load or unload structures or to make structures that have moved behind other structures
in the structure view area visible. Additionally, you can use this view to create structure contexts
from loaded structures, to create configuration contexts, and to save contexts into new or existing
collaboration contexts.

The Collaboration Context Tree view is not a primary or secondary view. It is not associated with other
views and does not respond to selection in other views. You can display this view by clicking the Open
CC Tree button  in the toolbar.

You can drag a collaboration context from your Home folder into the Collaboration Context Tree view.

Open the Graphics view

The Graphics view is associated with the structure view from which you open it. You cannot change this
association.

• In a structure view, click .

4. Displaying information
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Teamcenter opens the Graphics view displaying the structure. The Graphics menu is displayed in the
main menu bar if there is at least one Graphics view open.

• When you close the primary view from which you opened the Graphics view, the Graphics view
closes with it.

• If you unload data from the primary view, the Graphics view remains open, but empty.

• If you load a new structure into the primary view, the Graphics view is available, but the structure
is only loaded when you select a structure to view.

Display configuration information for a primary view

Do one of the following:

• Click  in a primary structure view to see configuration information about that structure.

The Configuration Information dialog box displays the following:

• The revision rule.

Display configuration information for a primary view
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• The effectivity.

• The variant rule or rules currently in effect.

• Which structure is configuring the current structure.

• In-context information.

• Currently active incremental change.

• Ensure that the MEShowConfigurationHeader preference is set to true. This displays the current
revision rule, effectivity, and variant rule at the top of the structure view. These entries are links that
you can click to open the dialog boxes used to change the configuration.

Modify the column display

1. Select a line in the table in which you want to modify the columns to make the table the active one
in the view.

This is important in views that contain multiple tables.

2. Click the Menu button  and choose Columns from the view menu commands located in the
top-right corner of the view.

Teamcenter displays the Column Management dialog box.

3. Select the desired columns from the Available Properties list and move them to the Displayed
Columns list with the right arrow.

4. (Optional) Modify the order the columns appear in the selected view table using the up and down
arrows.

5. Do one of the following:

• Click Apply to save the current state.

4. Displaying information
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• Click Save and type a name for the column configuration. You can restore a saved column layout
by choosing Apply Column Configuration from the view menu commands and selecting the
saved configuration from the list.

Find in display

1. Click the Menu button  and choose Find in Display from the view menu commands.

Teamcenter displays the Find in Display dialog box.

2. Click  to add a line to the table.

3. Double-click the BOM Line cell of the Property Name column and select the property name by
which to search from the list.

4. Double-click the equal sign to change the operator.

5. Type a value corresponding to the property name, for example, MEOP if you select Item Type as
the property name.

6. Click Find.

Teamcenter displays the number of matches in the bottom left of the dialog box.

7. Page through the matches using the right and left arrows, or display them all by clicking .

Teamcenter selects the matches in the view.

Sort data in view pane

1. Click the Sort button  at the top right of the view, or select Sort from the view menu commands.

Teamcenter displays the Sort dialog box.

2. Do one of the following:

a. Sort by default order by selecting Select default order.

b. Specify a different sort order.

A. Select Select below criteria.

B. In each of the three boxes, double-click in the box to select from a list of columns
available in the view table.

Find in display
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You can modify the column display by inserting or removing columns from tables.

C. Select whether to sort the column entries in ascending or descending order.

3. Click OK.

Teamcenter sorts the data in the selected table in the order specified.

Setting up the search for components in other structures

You can select one or more objects in the following areas of the user interface and search for them in a
different structure.

• Lines in a view

• Consumed parts in a process

• An object in the Navigation pane (Favorites, History, Open Items)

• Objects in the Home folder

• Objects in the My Worklist folder

• Items attached to a Teamcenter mail

• Lines in the Summary view

• Objects in the Graphics view

Whether you need to expand a target structure before choosing the Find in All Visible Views menu
command depends on the settings of the following two preferences:

MECopyIdInContextToAssignedLine
MECopyIdInContextLowerLevels

Note:

Whether you need to expand a structure before a found component can be highlighted within it
depends on the value of the MEExpandToSelection preference. If this preference is set to false,
you must manually expand the target structure to highlight lines found within that structure.

Find related part occurrences in loaded structures

Select one or more objects in different areas of the user interface listed below and search for them in
different structures.

4. Displaying information
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• Lines in a view

• Assigned parts in a service plan

• An object in the Navigation pane (Favorites, History, Open Items)

• Objects in the Home folder

• Objects in the My Worklist folder

• Items attached to a Teamcenter mail

• Lines in the Summary view

• Objects in the Graphics view

1. Right-click the part and select Find, to find other occurrences.

Note:

Service Planner displays all occurrences in structures that are loaded. If there are occurrences
in structures that are not loaded, they do not display for selection.

Find related part occurrences in loaded structures
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2. Select a specific structure or select Find in All Visible Views.

All occurrences in the structures that are loaded are highlighted. If the part occurrence is within a
structure that is collapsed, Service Planner expands the structure.

Expand and collapse a structure

1. Select an object in the loaded structure.

2. Do one of the following:

• Choose View → Expand Options → Expand to expand the structure to one level below the
selected line.

• Choose View → Expand Options → Expand Below to expand the entire structure below the
selected line.

Note:

This can be time-consuming in very large structures.

• Choose View → Expand Options → Expand Below... and select a level to which you want to
expand the structure.

• Choose View → Expand Options → Expand to Type.

Teamcenter displays the Expand to Type dialog box.

3. If you chose View → Expand Options → Expand to Type, in the Type list, select the type to which
you want to expand the structure.

The types listed are dependent on the type of selected object and the MEExpandToBaseTypes
preference. The MEExpandToBaseTypes preference is only applicable to selected processes.

4. Displaying information
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Selected object type Behavior

Process The list contains subtypes of both Process and
Operation.

Operation The Expand to Type command is unavailable.

Plant The list contains subtypes of Plant.

Product The list contains subtypes of Product.

4. If you chose View → Expand Options → Expand to Type, click OK after choosing a type.

Teamcenter expands the tree to the selected type.

• If the expand mechanism reaches the given type in a branch, it stops and moves to the siblings.

• If the expand mechanism does not find an object of the selected type in the tree, it does not
expand the tree.

• If the expand mechanism does not find an object of the selected type in a branch, the branch
remains collapsed.

5. (Optional) Collapse the structure by choosing one of the following:

• View → Collapse Below to collapse the entire structure.

• View → Expand Options → Expand Below... and selecting the Collapse lower level check box.

Tip:

Each of these commands are also available from the shortcut menu.

Load data to Service Planner

Do one of the following:

• Use the Send to menu command in any other application.

• Use the Open By Name buttons.

• Use the MRU (Most Recently Used Structures) button.

• Use the Quick Search feature.

• Use the Open Items list.

Load data to Service Planner
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The Open Items section of the navigation pane lists all items that are currently open in the
perspective.

• Use the History list.

The History list in the navigation pane displays links to objects that you opened. Links are displayed in
reverse order; the last object you opened is the first displayed in the list.

• Use the Favorites feature.

• Drag a collaboration context from your Home folder to the Collaboration Context Tree view.

Tip:

Use the Open Items list in the navigation pane to activate a structure that is already loaded but
not currently visible.

Unload data

• Select the structure in the Collaboration Context Tree view and choose Unload from the shortcut
menu or from the view menu.

This unloads the selected structure from the perspective.

• In the structure view, choose Unload from the view menu.

This unloads the selected structure from the perspective.

• In the Collaboration Context Tree view, choose Unload All from the view menu or File → Unload
All.

This unloads all structures from the perspective.

• In the Open Items section of the navigation pane, right-click the structure you want to unload and
choose Unload.

This unloads the selected structure from the perspective.

• In the Open Items section of the navigation pane, click Unload All to unload all the structures open
in the perspective.

This unloads all structures from the perspective.

4. Displaying information
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Note:

• When you close the primary view without unloading data, the structure is still open. You can
activate it from the Collaboration Context Tree view.

• You can only unload a structure context object separately if you loaded it separately. You can
unload only an entire collaboration context object—not parts of it.

Displaying activities in the Activities view

You display activities associated with a work card in the Activities view. Activities can have associated
objects such as other activities or attachments. You can filter out which types of attachments are
displayed in the Activities view using the MEOperationActivitiesFilteredComponents preference. To
see all attachments, you can open the Attachments view on an activity in the Activities view.

Open structure by name

You can search for and open a product, process or operation, work area, collaboration context or
structure context by name or object ID.

1. In the toolbar, click Open by Name .

2. Click one of the following:

Button To open a

Product

Process or operation

Work area

Collaboration context

Structure context

If a structure is currently open in a structure view, it is listed in the Association to box.

3. To find structures associated with the listed structure, select the Association to option and skip to
step 4, otherwise, do one of the following:

• If there is no structure identified or if you want to search for structures associated with a different
structure, select the new structure and click the Set to selected button .

You can use this option to search for structures that are not associated to loaded root structures.

Displaying activities in the Activities view
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• Select the Attributes option and type a structure name or ID.

Note:

You can type an asterisk (*) as a wildcard character if you do not know the entire name or
ID.

4. Click Search or press the Enter key.

All structures that match your search criteria are listed in a table in the open structure dialog box.

5. Double-click a structure in the table. It is opened in a structure view.

Opening the most recently used object

You can click the MRU (most recently used) button  to open any of the last few top-level structures
you opened. This list is saved across sessions and is an easy way to reopen structures you were
previously working on. Click an item revision in the MRU list to open it.

Note:

If the business object display rule for the Item business object is hidden in the Business Modeler
IDE, Service Plan does not show up in the most recently used (MRU) list.

Locking objects in the database

Locking objects

When you check out an object from the database, Teamcenter locks the object in the database so that
only you can change it. When you check in the object, it is unlocked and available for someone else to
check out.

The types of objects you can check out of the database are:

• Items and item revisions

• BOM views and BOM view revisions

• Folders

• Activities

• Datasets

4. Displaying information
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• Forms

• Occurrence groups

Manage checked-out objects

You manage checked out objects by doing one of the following:

• Check in the object by clicking Check In.

• Return the object to the database without saving any of the changes you made by clicking Cancel
Check Out.

• Transfer the checkout ownership to another user by clicking Transfer Check Out.

• If you have only one object selected, view a listing of previous checkout activity by clicking View
Check Out History.

Note:

You can configure the columns that appear in the Checked Out Objects dialog box and filter its
content.

Pack/Unpack a bill of materials

• Click one of the following two buttons on the toolbar to group or ungroup multiple, identical
components in one level of the assembly to pack and unpack the BOM.

• Click  to pack.

• Click  to unpack.

Note:

When lines are packed, one of the packed lines is always designated the master packed line. If
the TCVIS_Selection_From_Viewer preference is set to true, you can select packed objects in the
viewer using the buttons available in the 3D Selection toolbar. However, if you select the master
packed line, all packed lines are selected. If you do not want this behavior, you must unpack the
packed lines before selecting the individual objects in the viewer.

Manage checked-out objects
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Expand partially loaded structures

When Teamcenter displays a BOM or manufacturing view containing the results of a search, the siblings
of the node you searched for are hidden so the search results are displayed quickly. Each hidden node is
represented by a … symbol enclosed in a box. The ancestors of the found node are loaded and visible.

The following figure shows how a partly loaded structure displays in the BOM. In this example, three
nodes are hidden and these nodes are siblings of the 000227/A;1-Part4 node found by the search.

Partially loaded structure displayed as a result of a search

To expand this structure:

• Click .

Teamcenter expands the structure showing the siblings of the search result.

Expanded structure

4. Displaying information
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View only specific occurrence types

You can use the occurrence type filter to specify which occurrence types to display in the structure. The
occurrence type filter is available on all loadable structures.

1. Select the desired structure root (product, process, or plant).

2. Choose Select Occurrence Type Filters from the view menu.

3. Choose the types of occurrences that you want to appear in the selected structure.

4. Click OK.

Only the occurrence types that you selected are shown in the structure.

Note:

You can turn the filter on and off by choosing Apply Occurrence Type Filter from the view
menu or clicking  in the view toolbar.

Identify differences between two structures

About comparing structures graphically

You can compare two structures (BOMs) and view the results to identify differences. The BOMs can
contain different types of objects, such as mechanical parts, electrical parts, routes, and connections.
You can use the graphical comparison capability with released BOMs or with structures that are
configured by effectivity.

You can compare an assembly with an assembly, a part with a part, or two revisions of the same
assembly. If you compare two revisions of an assembly, Teamcenter identifies the following supersedure
information:

• Adds

These are objects that are in the target assembly but not in the source assembly. They have been
added to the assembly.

• Cancels

These are objects that are in the source assembly but not in the target assembly. They have been
removed from the assembly.

• Moves

View only specific occurrence types
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These are objects that are in different positions in the source assembly and target assembly. Any
object whose transform matrix differs between the source and target is identified as repositioned.

• Reshapes

These are objects that have alternate representations between the source assembly and target
assembly. Any object identified with a UG ALTREP note type is identified as reshaped.

• Common

These are objects that are in both the source assembly and target assembly.

Compare two BOMs

1. Apply any revision rules or effectivity needed to configure the structures you want to compare.

2. Choose Tools → Graphical BOM Compare.

Teamcenter displays the Graphical BOM Compare... dialog box listing all loaded structures in both
the First Structure and Second Structure boxes.

3. Select a first and second structure for compare from the lists and click OK.

Teamcenter analyzes the BOMs to identify any differences and displays the Graphical BOM
Compare dialog box containing a visual indication of those differences.

Depending on the type of comparison, you can use the tools and controls in the window to change
the view and examine differences more closely.

If you compare two versions of an assembly under change control (for example, a problem item
and an affected item of an engineering change), Teamcenter displays a list of supersedures.

4. Click Close to close the window on completion.

Set color options

You can change the default colors in which differences and supersedures are displayed in the Graphical
BOM Compare dialog box as follows:

1. Choose Edit → Options.

Teamcenter displays the Options dialog box.

2. Choose Change Management → BOM Tracking from the list of options.

Teamcenter shows the list of current colors assigned to the Graphical BOM Compare dialog box.

4. Displaying information
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3. To change the color assigned to a difference type, double-click the current color assignment.

Teamcenter displays the palette of available colors. Click the required new color and click OK or
Apply to change the color; alternatively, you can click Cancel to exit without changing the color.

Saving changes

Teamcenter saves changes to the structure automatically. You do not need to save them manually.

Saving changes
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5. Installing and configuring Service
Planner
Install Service Planner

As a system administrator, you must install and configure Service Planner using Teamcenter
Environment Manager (TEM). As the following figure shows, you install Service Planner on the server
and on the rich clients that use the application.

1. Start Teamcenter Environment Manager (TEM).

2. Select appropriate options until you reach the Features panel.

Note:

The configuration installed is dependent on the options that you choose in the Solutions
panel of the TEM installation windows, such as Corporate Server, Rich Client 2–Tier or Rich
Client 4–Tier, and Business Modeler IDE. You can also add any of the options available in
the Solutions panel from the Features panel.

3. In the Features panel, under Extensions, expand Service Lifecycle Management and select from
the following features.

Feature Description Prerequisite features

Service Planning Installs the Service Planner
functionality.

Teamcenter Foundation

Service Planning
and Service
Processing
Alignment

Installs the Service Planning and
Service Processing Alignment module
to support using discrepancies in
Service Planner.

Teamcenter Foundation
Service Planning
Service Event Management

Service Planner, Service Lifecycle Management 2412  5-1
© 2024 Siemens



4. If you want to configure your system using the Business Modeler IDE:

a. Click Next. Select appropriate options until you reach the Business Modeler IDE Templates
panel.

b. In the Business Modeler IDE Templates panel, select the following templates.

Template Description

Teamcenter Foundation Installs the Teamcenter Foundation template.

Service Planning Installs the Service Planner templates.

5. Click Next.

Select appropriate options until you complete the installation.

Configuring Service Planner

The Teamcenter administrator configures Service Planner according to company needs and organization
requirements as shown in the following figure.

You can configure lists of values (LOVs) that define the type of service to be done and the types of
notices to describe any notes, cautions, warnings, and hazardous materials associated to the planned
service work.

Setting Service Planner lists of values (LOVs)

To configure Service Planner lists of values (LOVs), an administrator creates and configures a custom
template based on the mrocore template that is provided with Service Planner. As an administrator,
you can set LOVs located in the LOV folder in the Extensions view. LOVs are commonly accessed by
Teamcenter users from a menu at the end of a data entry box. After you create a list of values, you
must attach it to a property on a business object. You use the Business Modeler IDE to set the LOVs in a
custom template that you define. You must deploy the custom template after making the changes.

5. Installing and configuring Service Planner

5-2  Service Planner, Service Lifecycle Management 2412
© 2024 Siemens



You can configure the following Service Planner LOVs:

• MRO Transaction Types

This list of values defines the type of service for the service requirement. This LOV is not editable, but
contains values for the following LOVs. The values for the MRO Transaction Types LOV correspond to
the Category attribute available.

• sem_inspection_types

Set this list of values to define the type of inspection.

• sem_overhaul_types

Set this list of values to define the type of overhaul.

• sem_repair_types

Set this list of values to define the type of repair.

• sem_other_types

Set this list of values to define the type of work that is not an inspection, overhaul, or repair.

• SmrOWarningType

This list of values defines the types of notices that can be attached to the service requirements, such
as any notes, cautions, warnings, and hazardous materials information.

• Smr0ActivityExecutionType

This list of values defines the activity execution types used for work cards or activities.

• SSP0AvailableDisciplines

This list of values defines the list of available disciplines used for skills.

Define the type of service

The MRO Transaction Types LOV is an uneditable list of valid types of service for the service
requirement. The service types, Inspection, Overhaul, Other, and Repair, are available as default
values for this LOV. You can define more specific types within these categories using the
sem_inspection_type, sem_other_type, sem_overhaul_type, and sem_repair_type LOVs. The values
for the MRO Transaction Types LOV are available as Requirement Type when creating a service
requirement.

Define the type of service
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LOV Description Default value

sem_inspection_types Specifies the type of inspection. Inspection

sem_other_types Specifies the user-defined type of
service.

Other

sem_overhaul_types Specifies the type of overhaul
service.

Overhaul

sem_repair_types Specifies the type of repair service. Repair

Define notices

As an administrator, you can set the SmrOWarningType LOV to define specific types of notices for a
service requirement. Notices are any notes, cautions, warnings, and hazardous materials associated to
the service requirement.

LOV Description Default value

SmrOWarningType Specifies the type of notice to
attach to the service requirement.

Smr0Caution

Smr0WarningValue

Smr0Note

Smr0HazardousMate
rial

Define activity execution types

As an administrator, you can set the Smr0ActivityExecutionType LOV to define the activity execution
types used for work cards or activities.

LOV Description Default value

Smr0ActivityExecutionType Specifies the activity execution
types used for word cards or
activities.

Smr0Perform

Smr0Sign-Off

Define available disciplines

As an administrator, you can set the SSP0AvailableDisciplines LOV to define the available disciplines
used for skills.

5. Installing and configuring Service Planner
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LOV Description Default value

SSP0AvailableDisciplines Specifies the available disciplines
used for skills.

NULL

Define available disciplines
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6. Creating characteristic definitions
What is a characteristic definition?

A characteristic definition is used to collect and record information during maintenance. You can create
characteristic definitions that contain information such as how many hours a part has been used, the
date the asset was put into commission, or the operating temperature of the part.

You can create characteristic definitions that define life, date, and observation characteristics. You can
also create derived characteristics which are characteristics values that are calculated by the system
based on formulas or expressions. Only life and observation characteristics can be defined as derived
characteristics by specifying the evaluation expression.

The characteristic definitions can be assigned to the following objects:

• Neutral parts

• Work cards

• Activities

Create a life characteristic

A life characteristic defines the individual characteristics that measure the life of a part.

Example:

You can track the number of landings for an aircraft using a life characteristic. When the number
of landings reaches a specific value, scheduled maintenance on the aircraft is performed.

1. From the navigation pane, click Service Planner.

2. Do one of the following:

• Select a folder where you want to create the new life characteristic.

• Select one or more neutral parts from your home folder or from the Service Planner view where
you want to assign the life characteristic.

• Select the work card that you want to relate the characteristic to.

• Select the activity that you want to relate the characteristic to.

3. Choose File → New → Life Characteristic.
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4. In the New Life Characteristic dialog box, enter the following information for the life
characteristic.

Field name Definition Format

Characteristic
Name

Name of the life characteristic. Alphanumeric (1–128
characters)

Unit Unit of measure for the recorded
value.

Alphanumeric (1–128
characters)

Precision The number of decimal places. Integer

5. In the Derived Expression box, type the expression or formula for the derived characteristic or
click the  button to use the wizard.

6. Click OK to create the life characteristic. Alternatively, click Cancel to exit.

Create a date characteristic

A date characteristic defines the date when a specific action occurred.

Example:

You can capture the commission date or warranty date.

1. From the navigation pane, click Service Planner.

2. Do one of the following:

• Select a folder where you want to create the new date characteristic.

• Select one or more neutral parts from your home folder or from the Service Planner view where
you want to assign the date characteristic.

• Select the work card that you want to relate the characteristic to.

• Select the activity that you want to relate the characteristic to.

3. Choose File → New → Date Characteristic.

4. In the New Date Characteristic dialog box, enter the following information for the date
characteristic.

6. Creating characteristic definitions

6-2  Service Planner, Service Lifecycle Management 2412
© 2024 Siemens



Field name Definition Format

Characteristic
Name

Name of the date characteristic. Alphanumeric (1–128
characters)

5. Click OK to create the date characteristic. Alternatively, click Cancel to exit.

Create an observation characteristic

An observation characteristic defines the operational characteristics observed during maintenance.

Example:

You can record any cracks or record the operating temperature during maintenance.

1. From the navigation pane, click Service Planner.

2. Do one of the following:

• Select a folder where you want to create the new observation characteristic.

• Select one or more neutral parts from your home folder or from the Service Planner view where
you want to assign the observation characteristic.

• Select the work card that you want to relate the characteristic to.

• Select the activity that you want to relate the characteristic to.

3. Choose File → New → Observation Characteristic.

4. In the New Observation Characteristic dialog box, enter the following information for the
observation characteristic.

Field name Definition Format

Characteristic
Name

Name of the observation
characteristic.

Alphanumeric (1–128
characters)

Unit Unit of measure for the recorded
value.

Alphanumeric (1–128
characters)

Precision The number of decimal places. Integer

5. In the Derived Expression box, type the expression or formula for the derived characteristic or
click the  button to use the wizard.

Create an observation characteristic
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6. Click OK to create the observation characteristic. Alternatively, click Cancel to exit.

Create a derived characteristic

Derived characteristic values are calculated by the system based on formulas or expressions. You can use
existing life or observation characteristics when you define the formula for the derived characteristic.

Example:

An aircraft engine can have different life characteristics, such as in-flight usage and number
of landings, while in use. The actual life of the engine is a combination of these values
based on some predefined formulas. You can define a formula to calculate the derived life
characteristic value based on the two base life characteristic values that you provide. The derived
life characteristic value can then be used for calculating maintenance schedules.

1. From the navigation pane, click Service Planner.

2. Create a new life or observation characteristic and enter information in the required fields.

Note:

If you want to use a life or observation characteristic in the formula for the
derived characteristic, you must create those characteristics before defining the derived
characteristic.

3. In the Derived Expression box, do one of the following:

a. Type the expression or formula for the derived characteristic.

b. Click the  button.

A. In the Expression dialog box, enter the following information.

Field name Definition Action

Characteristics Names of existing
life or observation
characteristics you
want to use in
the formula for the
derived expression.

Click the  button and select the life
or observation characteristic you want
to use in the expression. Click Append
to append the characteristic definition
in the Derived Expression box.

Operations The Boolean
operation you want
to use in the
expression.

Click the  button and select one of
the following operations to use in the
expression:

6. Creating characteristic definitions
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Field name Definition Action

• Select + for addition.

• Select – for subtraction.

• Select * for multiplication.

• Select / for division.

• Select ( or ) to group expressions.

Click Append to append the operation
in the Derived Expression box.

Derived Expression The derived
expression that is
used for the derived
characteristic.

Click Append next to the
Characteristics and Operations
boxes to create your expression or
type those values and any other
values needed to complete the
expression.

B. Click OK to create the derived characteristic.

4. Click OK to create the life or observation characteristic using the derived characteristic.

Create a derived characteristic

Service Planner, Service Lifecycle Management 2412  6-5
© 2024 Siemens



Assign characteristics to a neutral part

1. From the navigation pane, click My Teamcenter or Service Planner.

2. Select the characteristic definition in your home folder.

3. Right-click and choose Copy.

4. Select one or more neutral parts from your home folder or from the Service Planner view where
you want to assign the characteristic definition.

5. Right-click and choose Paste.

The characteristic definitions are related to the selected neutral parts, as shown in the following
figure:

 BH001–01–Bearing Housing Assembly
 BH001–01/A;1–Bearing Housing Assembly

 BH001
 EngineHours
 OperatingTemperature
 LastInspectionDate

Update characteristic definition properties

1. From the navigation pane, click My Teamcenter or Service Planner.

2. Select the characteristic definition.

3. Right-click and choose View Properties.

6. Creating characteristic definitions
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4. In the Properties dialog box, change the available properties.

5. Click OK or Apply to change the characteristic definition properties. Alternatively, click Cancel to
exit.

Set the tolerance for an observation characteristic

1. Select the work card or activity that has an observation characteristic.

2. In the Plan Details view, scroll to the Measurement Characteristics section, right-click an
assigned observation characteristic, and choose View/Define Characteristic Tolerance.

3. Set the minimum value and maximum value allowed for the characteristic and click OK.

Delete a characteristic definition

You can delete a characteristic definition if it is not attached to a neutral part.

1. From the navigation pane, click My Teamcenter or Service Planner.

2. Select the characteristic definition.

3. Choose Edit → Delete.

Set the tolerance for an observation characteristic
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7. Creating and managing service plans
Setting up and managing service plans

As a service planner, you create and manage the service plans related to the neutral parts.

Service plans contain information such as the service requirements, frequency of service, and service
activities that contain information about:

• The service to be performed.

• When the service should be performed.

• How the service should be performed.

• The resources that are required to perform the service.

You create service partitions to group together service requirements within a service plan.

Creating service plans

Service plan

A service plan is related to a neutral part and is the high-level container for the service partitions that
group together service requirements. A root partition is automatically created when you create the
service plan.

You can create multiple service plans for a neutral part.

The following figure shows an example of a turbo engine assembly that contains multiple service plans.
The service partitions group together all the service requirements for the turbocharger assembly.
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When you create the service plan, the following tabs are created:

• Base View

This tab contains only the service plan and is used only for reference. It is not used to manage the
service plan. You cannot expand the service plan in this tab.

• Plan/Partition name

This tab contains the service partitions and is used to create and modify the service plans. You can
expand the service plan in this tab.

7. Creating and managing service plans
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Create a service plan

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, click Open By Name  on the main toolbar at the top of the
Service Planner pane, to open the neutral structure or part.

3. Select the neutral part to relate to the service plan and do one of the following to create a new
service plan:

• Choose File → New → Service Plan.

• Click the New Service Plan button  at the top of the Service Planner pane.

• Right-click the neutral part and choose New → Service Plan.

4. In the New Service Plan dialog box, select Service Plan from the list and click Next.

Note:

If the business object display rule for the Item business object is hidden in the Business
Modeler IDE, Service Plan does not show up in the most recently used (MRU) list.

5. Enter the following information for the service plan.

Field name Definition Valid Values

ID The service plan ID (required).
Leave the field blank to
automatically assign an ID.

Alphanumeric string (1–
128 characters)

Revision The service plan revision
(required).
Leave the field blank to
automatically assign a revision.

Alphanumeric (1–32
characters)

Name The service plan name (required).
Leave the field blank to
automatically assign a name.

Alphanumeric string (1–
128 characters)

Description Description of the service plan. Alphanumeric string (1–
240 characters)

6. Click Finish.

The service plan and the root partition are created.

Create a service plan
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The following tabs are displayed:

• Base View
This tab contains the only the service plan.

• Partition name
This tab contains the service partitions. You can only expand the service plan in this tab.

Locate a service plan

1. From the navigation pane, click Service Planner.

2. Locate a service plan by doing one of the following:

• From the Service Planner view, click Open By Name  on the main toolbar at the top of the
Service Planner pane, to open the service plan.

• Using advanced search, search for the service plan. Right-click the service plan from the results
list and choose Send to → Service Planner.

3. From the Service Planner view, click the service plan name tab next to the Base View tab to
expand the service plan.

Locate all service plans related to neutral part

1. From the navigation pane, click My Teamcenter or Service Planner.

2. Search for the neutral structure or part where you want to find all related service plans.

3. Select the neutral or part.

4. Choose Window → Show View → Other.

5. In the Show View dialog, expand the Teamcenter folder and select Impact Analysis.

6. Click OK to show the view.

7. In the Impact Analysis view, choose References in the Where box.

7. Creating and managing service plans
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8. In the Depth box, choose Top Level.

The service plans related to the neutral part are displayed.

Update service plan properties

1. From the navigation pane, click My Teamcenter or Service Planner.

2. Locate and open the service plan that you want to update.

3. Select the service plan.

4. Right-click and choose Properties.

5. In the Properties dialog box, change the available properties.

6. Click OK or Apply to change the service plan properties. Alternatively, click Cancel to exit.

View plan details for a service plan

You can use the plan details view to display and edit information for a service plan.

The following information is displayed for a service plan:

• Item properties for the service plan.

• Attached files to the service plan.

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, open the service plan where you want to view the plan details.

3. In the Service Planner view, click the service plan name tab next to the Base View tab to expand
the service plan.

4. Select the service plan and do one of the following:

• Choose Window → Show View → Plan Details.

• Right-click the service plan and choose Show Plan Details.

The Plan Details tab is displayed.

Update service plan properties
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5. To edit properties of the service plan, click the Overview tab and click More Properties.

6. To add or remove attached files, click the Attached files tab and choose one of the following:

• Click Add New to add a new dataset.

• Click Paste to add a dataset that you have copied to the clipboard.

• Select a dataset and click Cut to remove a dataset.

Configure service plan based on conditions applied to consumed parts

Note:

You must set certain preferences to support this procedure. See Setting preferences for
configuring service plans.

1. Open a service bill of material (sBOM) and the service plan in Service Planner.

7. Creating and managing service plans
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In this example, the sBOM contains four parts, two of which have variants applied to them. The
service plan on the right contains service requirements for the first three parts.

Note:

The service plan is created from the sBOM before it is configured. You apply variants to the
sBOM to define configured product structures. The service requirements in the service plan
are based on the configured product structures.

2. Click View Menu  on the top tool bar of the sBOM window and select Configure Variants.

Note:

You can also configure variants by choosing Tools → Variants → Configure Variants.

3. Select the variant to apply to the sBOM and click Apply.

In this example, the variant Color1 is set to red.

Configure service plan based on conditions applied to consumed parts
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4. Click Show Unconfigured Variants  in the sBOM panel to deselect it.

This lets you see the configured sBOM.

Note:

The icon is outlined with a blue box when it is selected.

In this example, the part with the variant condition green, 000399/A;1-P1, is removed from the
sBOM.

5. Click Show Unconfigured Assigned Occurrences  in the service plan panel to deselect it.

This lets you see the configured service plan.

In this example, the part with the variant condition green, 000399/A;1-P1, is removed from the
configured service plan.

7. Creating and managing service plans
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Setting preferences for configuring service plans

You must set the following preferences to support the configuration described in Configure service
plan based on conditions applied to consumed parts:

Preference Value Impact
controllingOccsForProcessConfiguration MEAssign This preference controls automatic

configuration of operations and
processes. If no value is set, the
configuration of operations is not
affected by the configuration of
consumed items.

Accepts multiple strings as values.
Each string must be a valid
occurrence type.

typeAndRuleForProcessConfiguration SSPOServiceReq:One This preference configures process or
compositions in the bill of process.
See details for this preference below.

Preference typeAndRuleForProcessConfiguration details:

• This preference specifies which parent types in the process should be configured
out depending on the child occurrences of controlling types, as defined by the
controllingOccsForProcessConfiguration preference. You can also use this preference
to configure out processes based on child relationships. If you do this, the
controllingOccsForProcessConfiguration preference is ignored.

• Valid Values:

• parent-item-subtype—Specifies the item, operation, or process subtype as defined in the Business
Modeler IDE application. This value is case sensitive and must exactly match the business object
specified in Business Modeler IDE.

The second string after the colon must be one of the following:

■ One—The parent is configured out if any one of its controlling occurrences is configured out.

■ All—The parent is configured out only if all its controlling occurrences are configured out.

■ All Loaded—The parent is configured out only if all its loaded controlling occurrences are
configured out. Loaded occurrences are occurrences that are referenced from another top line
that is defined as the configuring structure. This parameter is not relevant for defining child
types.

Setting preferences for configuring service plans
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■ OneLoaded—The parent process is configured out if one of its loaded controlling occurrences is
configured out. This parameter is not relevant for defining child types.

• OCCType:occurrence-type | CHILD:child-type–Specifies that the filtering is based on the
designated occurrence types or the designated child types. You can enter multiple occurrence
types or multiple child types separated by a comma. Specifying this optional group of
values for the preference causes the configuration mechanism to ignore the value of the
controllingOccsForProcessConfiguration preference.

Advanced accountability check

Advanced accountability check

You can use the advanced accountability check to verify that all parts from the engineering bill of
materials (eBOM) that need to be consumed in the service bill of materials (sBOM) are correctly copied,
including the required properties. The results of an advanced accountability check identify full matches,
partial matches and missing parts in either the source or target structures.

If the advanced accountability check finds any differences during the comparison, that may indicate
problems that would impact manufacturing the product to its specification. However, differences
between the structures do not necessarily indicate a problem with the structure itself.

Running accountability checks

You can compare two structures to ensure all lines in the source structure are accounted for in the target
structure. For example, you can compare the EBOM structure to the SBOM structure to ensure all parts
and assemblies are assigned or compare the product structure and the service plan to ensure that all
occurrences of product components and features are used in the service plan as assigned, assembled,
or disassembled. You can compare the entire assembly or only a subassembly to the service plan. These
types of comparison are performed using an accountability check.

Any differences found during the comparison are reported, as they may indicate problems in
manufacturing the product to its specification. However, an imbalance between the structures may
not necessarily indicate a problem with the structure itself.

An accountability check or comparison:

1. Traverses the source structure.

2. For each line in the source, finds one or more matching lines in the target structure, according to
defined equivalence criteria.

3. For each pair of equivalent lines, identifies if there is a full match or a partial match. A partial match
exists if one or more aspects of the structures that you compare are not equal.
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4. Colors each line in the structures and, if you have the correct license, opens the Accountability
Check Result view displaying the full matches, partial matches, and unmatched lines.

The following differences are reported:

• Lines in the source structure that do not have counterparts in the target

• Lines in the source that have more than one counterpart in the target

• Lines in the target that do not have counterparts in the source

• Lines in the source whose counterparts in the target have some significant difference, for example, a
different quantity

The analysis is done on the structures as they are configured in the rich client. You can run the analysis
with any combination of configuration options on both structures.

When setting up the accountability check feature, a power user generally creates favorites—a collection
of typical options and settings for different situations. An administrator can publish these favorites for
different groups or roles so that regular users can then select one of them to quickly run the comparison.

Types of structures you can compare and propagate

Using an accountability check, you can compare the following pairs of source and target structures:

• EBOM and SBOM to see which of the EBOM parts are aligned to the SBOM

• Product and product

• Service plan and product to see if all parts are assigned, assembled, or disassembled

• Service plan to service plan

After comparison, you can propagate changes between the compared structures.

Note:

BOM-service plan propagation depends on the properties mentioned in the MEAssignProperties
preference.

Note:

You can compare two revisions of the same BOM or service plan. You can compare item IDs, item
revisions, item revision and BOM line attributes and properties, and quantity for pack/unpack lines.
This provides a better understanding of what has changed from one structure event to another,

Types of structures you can compare and propagate
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including which objects were added or changed, which were updated, and which remain the
same. To compare two revisions of the same structure, open each in its own structure and run an
advanced accountability check using the top lines as source and target.

Run an advanced accountability check

As an advanced user, you can set a variety of options before you run an advanced accountability check.
If you save these options as favorites, you can repeat the check using the same options.

Note:

To run an advanced accountability check, you must have two linked structures to compare, a
source structure and a target structure. In Service Planner, you need a source engineering bill
of materials (eBOM) generated from a CAD bill of materials (BOM) that is exported from a CAD
application such as NX or CATIA, and a target service BOM (sBOM) created for specific service
needs from the eBOM. When the eBOM is updated, the sBOM must be compared and updated as
well. This is the purpose of an Advanced Accountability Check: to help you make sure that the
two structures share equivalent BOM lines.

1. Select source and target objects in structure views and open the Advanced Accountability Check
dialog box by choosing Tools→Accountability Check→Advanced Accountability Check.
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Tip:

As long as the source and target views only are open, Service Planner auto-detects and adds
the correct source and target lines to the Source objects and Target objects boxes.

2. (Optional) Adjust the scope setting for either the source or target by selecting the line in the
applicable structure.

3. Confirm that you correctly selected the source and target objects. If needed, switch the source and
target by clicking the Switch Source Target button.

4. Click the Inclusion Rules tab, and do one of the following:

• Select Search currently expanded source lines to run the accountability check on the selected
lines and all visible lines below the selected lines. Additionally, you can select Compare lowest
visible level of source to run the accountability check on all the lowest visible (expanded) lines
under the selected scope line.

• Select Search lines per filtering rule to expand the source and target structures, and to consider
only a subset of the lines during the accountability check.

• Select the Source filtering rule. To see short descriptions of the filtering rules, move your mouse
over the list.

Run an advanced accountability check
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• To specify the level in a structure to which you want the accountability check to search, select
Limit search in source/target to first x levels and type a value for x.

Note:

For information about filtering rules, see Managing filter rules in the Sharing Data
documentation.

When you set these options, the values take effect in all applications that support
accountability checks.

5. (Optional) If you know the source and target scope lines to be different because these lines are
source-specific and target-specific, select the Do not compare selected lines  check box.

In the advanced accountability check results, the selected scope lines do not appear as missing in
the target and missing in the source.

6. Click the Reporting tab and set the result reporting options.

7. Click the Equivalence tab and set the equivalence options.

8. Click the Partial Match tab and specify the partial match criteria.

9. Click OK to run the accountability check.

Teamcenter displays the Accountability Check view.
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Note:

The number of lines returned in the accountability check is limited by the value of the
MEAccountabilityCheckAllowableReturnedLines preference. If the number of lines to
return exceeds the preference value, a message notifies you that there are more lines to
be returned, and that an Accountability Check Excel report has been created and stored.

10. After running the accountability check, examine the results and make any necessary modifications
to the structure.

11. Rerun the check using the same settings by clicking  in the Accountability Check view.

Rerunning an accountability check does not create a new accountability check report or a result
reported in an occurrence group.

For information about narrowing the scope of the accountability check, see the PLMXML Export Import
Administration Guide.

Set the result reporting options

The accountability check displays its results by highlighting the checked objects in the structure pane in
a variety of colors that you can change, if desired. To help users who cannot differentiate colors well, a
tool tip shows the name of the color. If the name is not available, the tooltip displays the RGB value.

1. Open the accountability check dialog box.

2. Click the Reporting tab.

3. Select one of the following:

• Report in occurrence groups

Teamcenter can store and display the result of the accountability check in an additional tab in
the structure pane grouped by anomaly. This result is only computed for the source item and is
stored in the database as a structure of UsageCompareResultView objects related to the item of
the source revision. You can specify the name for the result of the check. By default, it is named
Compare Result.

Set the result reporting options

Service Planner, Service Lifecycle Management 2412  7-15
© 2024 Siemens



• Report the selected check criteria

Teamcenter offers you two methods to visualize the results of the accountability check. You can
select one or both of the following:

• Select Color the compared objects to color the line and the matching lines according to the
match results and color scheme that you set in the Reporting section.

• Select Printable report to capture the results of the accountability check in an Excel
spreadsheet.

4. Check the display options you require:

Option Description

Full Match If the object (occurrence) in the source structure has one
and only one equivalent in the target structure, both
objects are set to the same background color. If you
also selected the Partial Match option, a full match also
means that all partial match criteria of the equivalent
objects match, for example, properties or relations, if you
use enterprise BOP structures. The default color is green.

Partial Match For equivalent objects (occurrences), if one or more
partial match criteria are not identical, both objects are
set to the same background color. The default color is
yellow.

Multiple Match If objects have more than a single equivalent in either
structure and all properties of the source objects are
identical to the properties of target objects, all objects
are set to the same background color. The default color is
orange.

Only available when you do not use net effectivity.

Multiple Partial Match If objects have more than a single equivalent in either
structure and in addition, one or more properties are
not identical, all objects are set to the same background
color. The default color is pink.

Only available when you do not use net effectivity.

Effectivity mismatch Only available when you use net effectivity.

For equivalent objects (occurrences), if the net
effectivities differ, both objects are set to the same
background color. The default color is orange.

Partial & effectivity mismatch Only available when you use net effectivity.
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Option Description

For equivalent objects (occurrences), if one or more
properties are not identical and the net effectivities differ,
both objects are set to the same background color. The
default color is pink.

Missing Target If occurrences of the source structure are not found in
the target, the source objects are set to this color. The
default color is red.

Missing Source If occurrences of the target structure are not found in the
source structure, the target objects are set to this color.
The default color is light blue.

5. (Optional) Change the default color by clicking  next to the color.

6. Set the colors by choosing a color swatch, and setting HSB (hue, saturation, brilliance) or RGB (red,
green, blue) values.

Set the equivalence options

1. Open the accountability check dialog box.

2. Click the Equivalence tab.

3. Select the comparison options you require:

Option Description
Equivalent
Logical
Designator

If you use enterprise BOP structures, the accountability check takes process
logical designators into consideration as an additional comparison criteria
when checking the process, operation, or partition lines for equivalence.

This check box is available only when both structures are enterprise BOP
structures.

Equivalent
PublishLink
Connection

If you use publish links, the accountability check highlights occurrences that
are mapped using publish links. If a part occurrence is set to not require
positioned design, it is also taken into consideration.

Note:

When checking accountability between structures, the direction of tracelinks is not
considered.

Set the equivalence options
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Specify partial match criteria

You can specify which data to compare between equivalent lines. You can choose to compare a specific
set of properties or, if you are comparing enterprise BOP structures, you can additionally compare any
relation type of these lines to other lines. For example, you can compare assignment or predecessor
relations.

1. Click the Partial Match tab.

2. On the Properties tab, select Consider values of properties when searching for a partial match.

3. Choose the properties that you want included in the accountability check by selecting them in the
Available Properties list and clicking  to move them to the Selected Properties list.

The accountability check matches lines in the source and target that have the same properties as
those you select in the Selected Properties list. Your administrator determines which properties
are available for selection in the AdditionalAccountabilityCheckProperties preference. Any
differences in the selected properties are identified as differences between the structures.

The values of the DefaultAccountabilityCheckProperties preference are ignored.

Viewing results in the Accountability Check view

About the Accountability Check view

When you run the accountability check, Teamcenter displays the results in the Accountability Check
view. This view lists the problematic lines in the source and target and provides a list of conflict details.
Lines that are colored in the source and target structures are also colored in the view. Fully matched
lines are not listed by default.

Note:

Displaying fully matched lines in large structures can clutter the view

Lines in the Accountability Check view behave in the same fashion as lines in the source and target
structures. If you remove a line in the view, Teamcenter removes the line from the source or target. You
can copy lines from the view into the clipboard, drag them to another structure, or send them to another
application.

When you select a source or target line that is marked as having net effectivity or being a partial match,
Teamcenter displays the conflicts in a third pane at the bottom of the view. The tabs shown in the
Partial Match section of the view are dependent on which partial match criteria you selected in the
Partial Match pane during the check. The table can display information about:

• Properties
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• Predecessors (enterprise BOP structures only)

• Assignments (enterprise BOP structures only)

• Hierarchy (enterprise BOP structures only)

When you select a line in the source section of the Accountability Check view, you can click the
Equivalent Lines tab in the target section of the view to find the lines in the target structure that match
the selected source line, and vice versa. These lines are then selected in the visible structure views.

When you work through the accountability check results, resolving conflicts, the accountability check
results are not updated—the lines remain highlighted in the original check colors. To update the lines,
you must rerun the accountability check. You can do this using the same settings by clicking  in the
Accountability Check view.

Note:

The Accountability Check view is not displayed when one or both of the structures being
compared is an intermediate data capture.

Display the partial compare results

After running an accountability check, you can view the partial compare results. Do one of the following:

• Select a partial match line in either the Source or Target section of the Accountability Check view.

Teamcenter displays the partial compare results in the Partial Match section at the bottom of the
view.

• Right-click a partial match line in the structure pane and choose Partial Compare Results, or choose
Tools→Accountability Check→Partial Compare Results.

Teamcenter displays the Partial Compare Results dialog box.

View settings used to run the accountability check

You can display a read-only listing of the settings in force when you ran the accountability check report.

• Click .

Teamcenter opens the Accountability Check Settings dialog box displaying the scope and
configuration in effect at the time the check was made. This is not necessarily the same as the
currently active configuration.

Display the partial compare results
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Filter accountability check results

When you run the accountability check, you can select check criteria in the Accountability Check dialog
box. After running the report, you may find that the Accountability Check view shows too many results
and the display is cluttered. You can filter out some of the check criteria in the view to make it more
readable without having to rerun the accountability check.

1. Click Filter.

2. Clear the categories that you want to hide in the view and click OK.

Teamcenter displays only those categories that are selected in the Filter dialog box. The filter button is
turned on when you remove the check mark from any categories to indicate that filtering is applied.

Clear display

You can reset all background colors on objects in the active window and their corresponding objects in
the process window to the default colors.

• Choose Tools→Accountability Check→Clear Accountability Check Display.

Note:

The command works only if either the source view or the target view is the active window.

Filtering and expanding source and target structures

You can narrow the scope of the accountability check by limiting it to only the lines pertinent to your use
case.

The filter mechanism is based on closure rules that traverse the structures and take only those objects
specified in the closure rules into consideration. The closure rules that are used in the accountability
check are referred to as inclusion rules and are not available to use for importing and exporting.

By default, Teamcenter presents you with a set of inclusion rules. Your administrator can modify these
inclusion rules or create new ones to suit your business needs.

Note:

When running the accountability check based on inclusion rules, there is no need to expand or
unpack any of the structures. This improves the performance of the check.

When running the accountability check without inclusion rules, you must first expand and unpack
the compared lines in the source structure.

For more information, see Expanding structures to check.
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Expanding a structure based on closure rules also plays a role in which objects are taken into
consideration in the accountability check. If you expand using an appropriate closure rule, you may
not have to set an inclusion rule when running an accountability check.

Specifying levels for comparison

If you use inclusion rules, you can limit the number of levels that the accountability check considers for
comparison. In the following figure, processes C1 (ID = 034730) and C2 (ID = 034731) are selected as
the source in an accountability check. To specify a level, run an advanced accountability check.

If you specify a level of 1, the accountability check considers the following items for comparison:

c11, c12

c21, c22

If you specify a level of 2, the accountability check considers the following items:

c11, c12, c21, c22

c111, c112, c121, c122, c211, c212, c221, c222

Accountability check of variant structure

If you optionally propagate rolled-up variant conditions from the EBOM to the SBOM or from the product
BOP to the plant BOP, the accountability check recalculates the rolled-up variant condition on the source
line and compares it with any occurrence variant condition already stored on the associated target line.
It then reports any partial match discrepancies between the variant conditions. To allow this check,
you must add the Variant Formula (bl_formula) property to the list of properties in the partial match

Specifying levels for comparison
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criteria in the MEAdditionalPropagatableProperties preference. The comparison is based on logical
equivalence and is not a string comparison, for example:

• If you compare Color=red & Size=medium with Size=medium & Color=red, these variant conditions
are logically equivalent.

• If you compare Color=red & Size=medium with Color=red & Size=medium & Color=red, these
variant conditions are logically equivalent.

In the following example, you assign the EBOM to the MBOM and roll up the variants:

EBOM:

EGen1.1  Load if Option A = “abc”
    EGen 1.1.1  Load if Option B = “fgh”
      Part 1
      Part 2
    EGen 1.1.2  Load if Option B = “ijk” 
      Part 3
      Part 4
EGen1.2  Load if Option A = “cde”
    EGen 1.2.1  Load if Option B = “fgh”
      Part 5
      Part 6
    Part 7  Load if Option B = “ijk”

SBOM:

Part 1  Load if Option A = “abc” AND Option B = “fgh”
Part 2  Load if Option A = “abc” AND Option B = “fgh”
Part 4  Load if Option A = “abc” AND Option B = “ijk”
Part 5  Load if Option A = “cde” AND Option B = “fgh”
MGen 1.1
  Part 3  Load if Option A = “abc” AND Option B = “ijk”
  Part 4  Load if Option A = “abc” AND Option B = “ijk”
  Part 7  Load if Option A = “cde” AND Option B = “ijk”

If you perform an accountability check and specify parts only, all colors except full match, and rolled up
variant condition as a partial match option, the result shows no differences.

You then modify the parts under EGen 1.1.2 in the EBOM as follows:

Egen 1.1.2  Load if Option B = “lmn” – changed the variant condition
  Part 3  Load if Option C = “opq” –added the variant condition
  Part 4 – no change
  Part 8 – added the line
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(You changed the variant condition to line 1, added the variant condition to part 3, made no changes to
part 4, and added part 8.)

If you now perform an accountability check, it identifies that Part 3 is a partial match, Part 4 is also a
partial match, and Part 8 is missing in the target. A tabular report shows the following results for the
checked objects.

Source Target Match
Variant condition
rollup

123456/A;1-Part 3 123456/A;1-Part 3 X X

123457/A 1-Part 4 123457/A 1-Part 4 X X

1234569/A 1-Part 8 *** Not Found X

The check assumes lines are equivalent due to a user performing an assign action (that is linking them)
and not simply by having the same in-context ID. When you run an accountability check on equivalent
lines with the same in-context ID, it considers rolled up variant conditions on the source line and
compares them with the occurrence variant condition on the target line. This may give unexpected
results when comparing the Variant Formula property, and you should take care when propagating
such differences.

For example, EBOM Top (000029) and SBOM Top (000035) are linked. The assigned line EBOM Sub
Assembly (000031) has a rolled-up variant condition.

If you change the in-context ID of Part1 in the MBOM to make it equivalent to SubAssembly in the
EBOM, the accountability check shows Part1 as a mismatched line, even though it is not assigned. This
occurs because the rolled up variant condition on the source line is compared with occurrence variant
condition on the target line. As the target line is not assigned, it does not have a rolled-up variant
condition.

Accountability check of variant structure
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If you select Part1 and choose to propagate differences from the source to the target, Part1 receives
the rolled-up variant condition of the source. This occurs because, although the line is not assigned, it
has the same underlying occurrence. Part1 is now configured but not with the variant configuration you
originally intended.

When Teamcenter calculates the variant condition when allocating from a product BOP to a generic BOP,
it only calculates for the line being allocated. Therefore, if you allocate a process with child processes
or operations, it does not calculate the rolled-up variant condition for any children of the process being
allocated. This results in a mismatch if you run an accountability check between the product BOP and the
plant BOP. You have two choices in this case:

• Do not run the accountability check for a level lower than the one you allocate.

• Propagate the mismatch between the children of the process from the product BOP to the plant BOP.

Expanding structures to check

Whether or not you need to expand a target structure before running an accountability check depends
on the settings of the following two preferences:

MECopyIdInContextToAssignedLine

MECopyIdInContextLowerLevels
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Note:

If there are packed lines in the source window, the accountability check may report incorrect
results for the quantity of an absolute occurrence of a component that is packed to a sibling. To
avoid this situation, always unpack all lines before starting an accountability check.

Expanding a structure based on closure rules also plays a role in which objects are taken into
consideration in the accountability check. If you expand using a closure rule, it may have the same
effect as setting an inclusion rule.

Inclusion rules

Inclusion rule Description

AccountabilityAll Includes all lines.

AccountabilityLeavesOnly Includes only leaf nodes; excludes all hierarchy nodes.

AccountabilityLinkedAssm
OrLeaves

Includes assigned assembly nodes but excludes their
children. If an assembly is not assigned, includes its leaf
nodes.

AccountabilityProcess
Consumption

Includes assigned nodes under a process or operation that
are of occurrence type MEConsumed. Excludes all process
and operation nodes.

AccountabilityProcess
Assignments

Includes assigned nodes (including work areas, parts,
and tools) under processes and operations. Excludes all
processes and operations nodes. If the assigned-from
structure is not loaded, those nodes are also excluded.

AccountabilityProcessAll
NoAssign

Include process and operation nodes.

AccountabilityProcessAll Include process and operation nodes and all of their
assigned nodes. If the assigned structure is not loaded, their
nodes are excluded.

AccountabilityProcessOnly
WithPA

Includes processes, operations, and process areas only.

ACPlantBOPDerivedProcesses
AndOps

Includes only operations and processes that are linked to the
source (for example, in a product BOP). This rule is used
when comparing a product BOP to a plant BOP and skips
plant-specific operations.

Inclusion rules
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Note:

None of the inclusion rules include occurrence group nodes, but they can include the children
under those nodes.

Creating service containers

Service containers

A service container is the hierarchical grouping of service requirements. A service plan can contain many
service containers. You can also nest service containers by creating service containers under another
service container.

The following figure shows an example of a service plan for a turbo engine assembly that contains
nested containers to group together the bearing housing assembly and turbine housing assembly
requirements for the turbocharger subassembly.
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Note:

Service containers are very similar to service partitions. However, service containers are more
beneficial than service partitions in several ways. Service containers:

• Have improved performance

• Can be revised

Service containers
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• Are supported in Active Workspace

• Can be copied and pasted, along with their contents

You can use either a service partition or a service container in a single structure, but not both.

Create a service container

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, open the service plan to which you want to add the service
container.

3. From the Service Planner view, click the service plan name tab next to the Base View tab, to
expand the service plan.

4. Right-click the service plan and choose New → Service Container.

5. In the New Business Item - Service Container Information dialog box, enter the following
information for the service container.

Field name Definition Valid Values

Name The service partition name
(required).

Alphanumeric string (1–128
characters)

Description Description of the service
partition.

Alphanumeric string (1–240
characters)

6. Click Finish.

The service container is created under the service plan.
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Update service container properties

1. From the navigation pane, click My Teamcenter or Service Planner.

2. Open the service plan that includes the container you want to update.

3. From the Service Planner view, click the service plan name tab next to the Base View tab, to
expand the service plan.

4. Select the container.

5. Right-click and choose Properties.

6. In the Properties dialog box, change the available properties.

7. Click OK or Apply to change the service partition properties.

Creating service partitions

What is a service partition?

A service partition is the hierarchical grouping of service requirements. A service plan has only one
root service partition, but the root service partition can have many service partitions. You can also nest
service partitions by creating service partitions under another service partition.

The following figure shows an example of a service plan for a turbo-engine assembly that contains
nested partitions to group together the bearing housing assembly and turbine housing assembly
requirements for the turbocharger subassembly.
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Create a service partition

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, open the service plan where you want to add the service partition.

3. From the Service Planner view, click the service plan name tab next to the Base View tab to
expand the service plan.

4. Select the service plan and do one of the following:

• Choose File → New → Service Partition.
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• Click the New Service Partition button  on the main toolbar at the top of the Service
Planner pane.

• Right-click the service plan and choose New → Service Partition.

5. In the New Service Partition dialog box, select Service Partition from the list and click Next.

6. Enter the following information for the service partition.

Field name Definition Valid Values

Name The service partition name
(required).

Alphanumeric string (1–128
characters)

Description Description of the service
partition.

Alphanumeric string (1–240
characters)

7. Click Finish.

The service partition is created under the service plan.

 Service plan
 Service partition

Update service partition properties

1. From the navigation pane, click My Teamcenter or Service Planner.

2. Open the service plan that contains the partition you want to update.

3. From the Service Planner view, click the service plan name tab next to the Base View tab to
expand the service plan.

4. Select the partition.

5. Right-click and choose Properties.

6. In the Properties dialog box, change the available properties.

7. Click OK or Apply to change the service partition properties. Alternatively, click Cancel to exit.

View plan details for a service partition

You can use the plan details view to display and edit information for a service partition.

Update service partition properties
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The following information is displayed for a service partition:

• Item properties for the service partition.

• Attached files to the service partition.

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, open the service plan that contains the partition where you want
to view the plan details.

3. In the Service Planner view, click the service plan name tab next to the Base View tab to expand
the service plan.

4. Select the service partition and do one of the following:

• Choose Window → Show View → Plan Details.

• Right-click the service partition and choose Show Plan Details.

The Plan Details tab is displayed.
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5. To edit properties of the service partition, click the Overview tab and click More Properties.

6. To add or remove attached files, click the Attached files tab and choose one of the following:

• Click Add New to add a new dataset.

• Click Paste to add a dataset that you have copied to the clipboard.

• Select a dataset and click Cut to remove a dataset.

Migrating service plans that contain partitions

Existing service plans that were created in Service Planner likely contain partitions, which are used to
group together service requirements within a service plan. Partitions are not applicable in the Active
Workspace web client and are replaced with containers.

The scope and limitations to this utility are:

• A service plan that has custom partitions does migrate, but the custom partitions are migrated as
out-of-the-box containers.

• Custom properties are not migrated and must be added to the new service container manually.

• Empty partitions do migrate.

The utility convert_partition_to_container is available to facilitate migrating partitions to containers.

Syntax

convert_partition_to_container -u=user-id -p=password -g=Engineering -inputfile=/path/filename

Arguments

-u

Specifies the user ID

-p

Specifies the password

-g

Specifies the group associated with the user.

-inputfile

Path and name of the file that contains the list of service plans you are migrating.

Migrating service plans that contain partitions
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Input file

The input file is a text file that contains a list of the service plans you want to migrate. Each service plan
is on its own line in the text file.

item_id=nnnnnnn
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8. Setting up and managing service
requirements
Setting up and managing service requirements

As a service planner, you create and manage the service requirements that are part of the service plan.
Service requirements determine what service must be performed. They define the maintenance that
can be performed on a part or assembly. Service requirements are grouped under service partitions or
service containers.

You create and manage service requirements by:

• Creating the service requirements.

• Creating service frequencies that determine the interval or period for performing maintenance.

• Creating required skills that determine who should perform or sign off on the service requirement.

• Assigning the neutral part occurrences that are impacted by the service requirement.

• Defining service requirement relationship dependencies.
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Creating service requirements

Service requirement

A service requirement is the maintenance requirement for an assembly or part. Service requirements are
grouped together under service partitions or service containers.

You can perform the following actions on service requirements:

• Assign states to a service requirement.

You can assign the following states to a service requirement by submitting it to an approval workflow:

• in-work

• approved

• deprecated

• Revise service requirements to create new revisions.

You can revise service requirements to create new revisions. If a work card is related to a service
requirement, those relations are carried forward when the new revision of the service requirement is
created. Only the latest approved service requirement is part of the active service plan.

• Use options and variants to configure a service requirement.

Example:

You may want to setup a variant to indicate whether the service requirements are war time or
peace time requirements.

The following figure shows an example of a turbo engine assembly that has multiple service
requirements for the bearing housing sub assembly. The service requirements include inspecting and
replacing the right turbine blade that is a component of the bearing housing assembly. The service
requirements for the bearing housing sub assembly are grouped together under the service partition or
container for the turbocharger assembly requirements.
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Create a service requirement

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, open the service plan to contain the service requirement.

3. Click the service plan name tab next to the Base View tab to expand the service plan.

4. Select the service partition or service container to contain the service requirement, and do one of
the following:

• Choose File → New → Service Requirement.

• Click the New Service Requirement button  at the top of the Service Planner pane.

Create a service requirement

Service Planner, Service Lifecycle Management 2412  8-3
© 2024 Siemens



• Right-click the neutral part and choose New → Service Requirement.

5. Select Service Requirement from the list and click Next.

6. In the New Service Requirement dialog box, enter the following information for the service
requirement.

Field name Definition Valid Values

ID The service requirement ID
(required).
Leave the field blank to
automatically assign an ID.

Alphanumeric string (1–
128 characters)

Revision The service revision (required).
Leave the field blank to
automatically assign a revision.

Alphanumeric string (1–
128 characters)

Name The service requirement name
(required).

Alphanumeric string (1–
128 characters)

Description Description of the service
requirement.

Alphanumeric string (1–
240 characters)

Requirement
Category

Category for service requirement
(read-only).
This field is populated after you
set the requirement type in the
Requirement Type field.

Alphanumeric string (1–
128 characters)

Requirement Type The type of service requirement
(required).

Valid values already
defined by the system:

• Inspection
• Repair
• Overhaul
• Other

Upgrade Defines if the service requirement
represents an upgrade or
modification to an existing
product (required).
If Upgrade is set to True, you can
indicate that the purpose of the
work card is to upgrade a physical
part from one configuration to
another. It also specifies that a
rebase of the impacted physical
part is to be performed as part of
the completion of the work card.

Boolean
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7. Click Finish.

The service requirement is created under the service partition or service container.

Duplicating a service requirement behavior

Service plans often contain service requirements that are similar to or the same as service requirements
in other service plans.

You are able to clone service requirements and most of their contents within a service plan, between
service plans, and between partitions. The items contained in a service requirement, by default, are
cloned, with the exception of the consumed parts.

Note:

You change the default behavior by adjusting the values of the preference SSP0ServicePlan.
SSP0ServicePlan.PasteDuplicateTemplate.

The preference SSP0ServicePlan.SSP0ServicePlan.PasteDuplicateTemplate is already defined in
the software. The values available include:

• *.*.Attribute.items_tag:Clone
• *.*.Attribute.structure_revisions:Clone
• *:*:Attribute.bom_view:Clone
• *.*.Attribute.parent_item:Clone
• *.class.SSP0WorkCardRevision:OccType.*.Clone
• *:class.SSP0FrequencyRevision:OccType.*:Clone
• *.class.SSP0SkillRevision:OccType.*.Reference
• *.class.Mfg0MEResourceRevision:OccType.*.Reference
• *.class.DocumentRevision:OccType.MEAssemble:Ignore
• *.class.DocumentRevision:OccType.MEDisassemble:Ignore
• *.class.DocumentRevision:OccType.SSP0Replace:Ignore
• *.class.DocumentRevision:OccType.Null:Reference
• *.class.DocumentRevision:OccType.*:Reference
• *:class.ItemRevision:OccType.*:Ignore
• *:*:Relation.IMAN_specification:Clone
• class.Folder:*:Attribute.contents:Reference
• *:*:Attribute.variant_expression_block:Clone
• *:class.PartRevision:OccType.*:Reference

Service Requirement contents

The following table shows the items that are contained within a service requirement and whether or
not the item is cloned when you perform a Copy and Paste Duplicate action. The actions listed are the
default actions and can be changed with the preference.

Duplicating a service requirement behavior
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Item Cloned
Service Requirements Yes
Work Cards Yes
Activities Yes
Part Consumed in the Service Requirement No

Note:

The cloned service requirement is a copy of the original. There is no association between
the original and the cloned service requirement. Any changes made to one of the service
requirements is not reflected in the other.

Duplicating service requirements options

The following scenarios are supported with the Paste Duplicate action.

Location of Service Requirement Target
Partition Partition within the same service plan
Partition Partition in a different service plan
Activities Yes
Part Consumed in the Service Requirement No

Duplicate a service requirement–Clone

You can use Copy and Paste Duplicate to clone a service requirement, saving time and promoting
consistency.

Note:

This example demonstrates copying a service requirement from one partition to another.

Please see Duplicating a service requirement behavior for a list of applicable sources and
targets.

In this example, the preference SSP0ServicePlan.SSP0ServicePlan.PasteDuplicateTemplate
includes the following values; *:class.SSP0WorkCardRevision:OccType.*:Clone and
*:class.SSP0FrequencyRevision:OccType.*:Clone which are set to clone.

Procedure

1. Arrange your workspace to display the source and target items.
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2. Select the service requirement 000755/A;1-General Inspection in the Inspection partition and
choose Copy.

3. Right-click the partition Overhaul and choose Paste Duplicate.

The service requirement 000755/A;1-General Inspection is copied from the Inspection partition
to the Overhaul partition and has a new item number 000763/A;1-General Inspection.

Because the preference values *:class.SSP0WorkCardRevision:OccType.*:Clone and
*:class.SSP0FrequencyRevision:OccType.*:Clone are set to clone, the work card 000755/A;1-
Inspect Pump Housing and the Frequency are both cloned and have been given new item IDs
(000764/A;1-Inspect Pump Housing and 000765/A;1-General Inspection Frequency, respectively).

Duplicate a service requirement–Clone

Service Planner, Service Lifecycle Management 2412  8-7
© 2024 Siemens



Duplicate a service requirement–Reference

You can use Copy and Paste Duplicate to clone a service requirement, saving time and promoting
consistency.

Note:

This example demonstrates copying a service requirement from one partition to another.

Please see Duplicating a service requirement behavior for a list of applicable sources and
targets.

In this example, the preference SSP0ServicePlan.SSP0ServicePlan.PasteDuplicateTemplate
includes the following values; *:class.SSP0WorkCardRevision:OccType.*:Reference set to
reference and *:class.SSP0FrequencyRevision:OccType.*:Clone set to clone.

Procedure

1. Arrange your workspace to display the source and target items.

2. Select the service requirement 000756/A;1-Impeller Inspection in the Inspection partition and
choose Copy.

3. Right-click the partition Overhaul and choose Paste Duplicate.

The service requirement 000756/A;1-Impeller Inspection is copied from the Inspection partition
to the Overhaul partition and has a new item number 000767/A;1-Impeller Inspection.
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Because the preference value *:class.SSP0WorkCardRevision:OccType.*:Reference is set to
reference, the work card 000766/A;1-Inspect Impeller is referenced in the Overhaul partition
and the item ID is not changed.

Update service requirement properties

1. From the navigation pane, click My Teamcenter or Service Planner.

2. In the Service Planner view, select the service requirement.

3. Right-click and choose Properties.

4. In the Properties dialog box, change the available properties.

5. Click OK or Apply to change the service requirement properties. Alternatively, click Cancel to exit.

Locate a service requirement

1. From the navigation pane, click Service Planner.

2. Locate a service requirement by doing one of the following:

a. From the Service Planner view, click Open By Name  on the main toolbar at the top of
the Service Planner pane, to open the service plan that contains the service requirement.

Update service requirement properties

Service Planner, Service Lifecycle Management 2412  8-9
© 2024 Siemens



A. From the Service Planner view, click the service plan name tab next to the Base View
tab to expand the service plan.

B. Expand the service partition that contains the service requirement.

b. Using advanced search, search for the service requirement. Right-click the service plan from
the results list and choose Send to → Service Planner.

Assign an impacted part occurrence to a service requirement

You can assign impacted neutral part occurrences to service requirements to identify the impacted
parts. The impacted part represents the part or assembly that is most directly impacted by the service
requirement. If there is no relationship created between a neutral part occurrence and a service
requirement, the impacted part is assumed to be the neutral part related to the parent service plan.

When you assign a neutral part occurrence to a service requirement, the Occurrence Type for the
neutral part is set to MEAssign.

1. From the navigation pane, click Service Planner.

2. Locate and open the neutral structure or part you want to assign as an impacted part to the service
requirement.

3. From the Product view, right-click the neutral part and choose Copy.

4. Locate and open the service requirement that you want to assign the neutral part occurrence to.

5. From the Service Plan view, right-click the service requirement and choose Paste or Paste
As → MEAssign.

The neutral part is assigned to the service requirement with the Occurrence Type set to MEAssign.

Process Structure Occurrence Type
 Service plan

 Service partition
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 Service requirement
 Neutral part MEAssign

Creating service requirement frequencies

Service requirement frequency

The frequency for a service requirement defines the interval or period for performing the maintenance.
It defines when the service needs to be performed.

Example:

You can create a frequency that specifies an inspection maintenance requirement be performed
every two months.

As the following figure shows, frequencies are associated to the service requirement with a Has
Frequencies relationship. After creating the frequency for a service requirement, the Occurrence Type
for the frequency is set to Has Frequency.

You create a frequency by defining an expression. The expression can be made up of keywords and
characteristic definitions. The evaluation of the frequency expression always returns a Boolean.

A frequency expression may contain more than one phrase using phrase separators such as AND or OR.

Keywords indicate whether a frequency is threshold or repetitive.

Example:

You use the keyword At to define that maintenance has to be performed at a specific date only.
You use the keyword Every to define that maintenance has to be performed every three days.

The characteristics values that are available to use in the frequency expression are determined by the
following:

Service requirement frequency
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• Any life, observation, or date characteristics related to the neutral parts assigned to the service
requirement with the MEAssign relationship are available as valid characteristics to use in the
frequency expression.

• Any life, observation, or date characteristics related to the neutral part assigned to the parent service
plan are available as valid characteristics to use in the frequency expression. This is only true if
there are no assigned or impacted parts assigned to the service requirement with the MEAssign
relationship.

Example:

You defined a life characteristic to record the engine hours for a turbo-engine. The turbo-engine
is assigned to a service requirement for inspection. You use engine hours in the frequency
expression to perform the inspection requirement every one thousand engine hours.

The system provides the following options in addition to any life, observation, or date characteristics:

• Calendar

Used for adding calendar time to the expression.

• Installation Date

Indicates that the installation time of a part in a structure should be used.

• Manufacturing Date

Indicates that the date of manufacture should be used.

• Days

Indicates the number of days.

• Months

Indicates the number of months.

• Years

Indicates the number of years.

Create a service frequency

1. From the navigation pane, click Service Planner.
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2. From the Service Planner view, select the service requirement where you want to add the
frequency and do one of the following:

• Choose File → New → Frequency.

• Click the Create a new Frequency button  on the main toolbar at the top of the Service
Planner pane.

• Right-click the service requirement and choose New → Frequency.

3. In the New Frequency dialog box, select Frequency from the list and click Next.

4. Enter the following information for the frequency.

Field name Definition Valid Values

ID The service frequency ID. Alphanumeric string (1–128
characters).

Name The service frequency name
(required).
The service frequency name
is automatically named with
the service requirement name
suffixed with the word
Frequency. You can use this
value or type in a new value.

Alphanumeric string (1–128
characters).

Description Description of the service
frequency.

Alphanumeric string (1–240
characters)

Phase Separator Conditional keywords that
separate the phrases. This
option is available when you
add a frequency expression
in the Frequency Expression
box.

Valid values are:

• And
• Or
• Then

Keywords Indicates whether the
frequency is a threshold or a
repetitive one.

Valid values are:

• Every
• Within
• When
• At

Value Numeric value used in the
expression. This field is only
available after you select the

Floating point value.

Create a service frequency

Service Planner, Service Lifecycle Management 2412  8-13
© 2024 Siemens



Field name Definition Valid Values

keyword in the Keywords
box.

Characteristics The life, observation, or date
characteristics used in the
expression.

The valid values depend on
the selected keyword in the
Keywords box.

Selected
Keyword

Valid Values

Every Any valid life
characteristic
value, Days,
Months,
Years.

Within Any valid life
characteristic
value.

When Any valid
observation
characteristic
value.

At Any valid life or
date
characteristic
value,
Calendar,
Days, Months,
Years, Install
Date, or
Manufacturin
g Date.

Date The date when the
maintenance should take
place. This field is only
available if a date
characteristic or the Calendar
option is selected in the
Characteristics box.

Date.
Click the  button to set the
date.
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Field name Definition Valid Values

Note:

The Calendar option is
only when Keywords is
set to At.

Operators Operator used in the
expression when Keywords is
set to When.

Valid values are < and >
(indicating less than and greater
than).

Value Numeric value to be used in
the expression. This field is
only available after you select
the operator in the Operators
box.

Floating point value.

5. Click Advanced to add the following optional information in the frequency expression.

Field name Definition Valid Values

Tolerance Tolerance value added to the
expression.

For the first field, valid values are:
+, .-, or +-.

Create a service frequency
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Field name Definition Valid Values

Type a numeric value for the
second field.
For the third field, valid values
are %.

After/Until Specifies if the maintenance
is performed after or until a
specific value.

Valid values are:

• After
• Until

Value Numeric value used in the
expression.

Floating point value.

Characteristics The life, observation, or date
characteristics used in the
expression.

Any valid life, date, or
observation characteristic value,
Calendar, Days, Months, Years,
Install Date, or Manufacturing
Date.

Date The date after or until the
maintenance takes place. This
field is only available if a date
characteristic or the Calendar
option is selected in the
Characteristics box.

Date.
Click the  button to set the
date.

Operators Operator used in the
expression when Keywords
is set to When and
Characteristics is set to an
observation characteristic.

Valid values are < and >
(indicating less than and greater
than).

Value Numeric value to be used in
the expression. This field is
only available after you select
the operator in the Operators
box.

Floating point value.
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6. For the Frequency Expression box, do one of the following:

• Click  to add the expression created from the values you selected in the previous step.

• Click  to remove the expression.

• Select the expressions you want to edit and click Edit. Edit the expression and click Save to save
the changed expression or click Cancel to cancel the changes.

• Select the expressions you want to group together using parentheses and click Group.

• Select the expressions that you want to remove from the group and click UnGroup.

Tip:

To select multiple expressions, press the Shift key and select the expressions.

7. Click OK to create the frequency.

The frequency is created for the service requirement with the Occurrence Type set to Has
Frequency.

Process Structure Occurrence Type
 Service plan

 Service partition
 Service requirement

 Frequency Has Frequency

Edit a service frequency

1. From the navigation pane, click Service Planner.

Edit a service frequency
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2. Select the service frequency to edit.

3. Right-click and choose Edit Frequency.

4. In the Edit Frequency dialog box, change the service frequency expression.

5. Click OK to change the service frequency. Alternatively, click Cancel to exit.

Assign a service frequency to other service requirements

1. From the navigation pane, click Service Planner.

2. Right-click the frequency you want to relate to the service requirement and choose Copy.

3. From the Service Planner view, right-click the service requirement to add the frequency to and
choose Paste.

The frequency is created for the service requirement with the Occurrence Type set to Has
Frequency.

Process Structure Occurrence Type
 Service plan

 Service partition
 Service requirement

 Frequency Has Frequency

Service frequency examples

The following table contains examples of service frequencies using the following keywords,
characteristics, and phrase connectors.

Keywords At, Every, Within, When, Install Date, Manufacturer Date,
Calendar

Characteristics defined Landings, Months, Flight Hours, Oil Pressure, Tire
Change

Phrase Connectors Or, Then, And

At 100 Landings +– 10 Landings

At 100 Landings Or At 2 Months

At 120 Months After Manufacture Date

At 10 Landings After Calendar "3/22/2010"
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At 10 Landings After Calendar "3/22/2010"

Within 50 Cycles After Oil Pressure > 1000 PSI

Within 50 Cycles After Calendar "3/22/2010"

Within 50 Cycles After Manufacture Date

Every 100 Flight Hours Until 10000 Flight Hours

Every 100 Flight Hours +– 10 Flight Hours Until 10000 Flight Hours

Every 100 Flight Hours +– 10 Flight Hours Until 10000 Flight Hours After Calendar "3/22/2010"

Every 100 Flight Hours +– 10 Flight Hours Until 10000 Flight Hours After Install Date

Every 100 Flight Hours Until 10000 Flight Hours Then Every 80 Flight Hours Until 20000 Flight
Hours

Every 100 Flight Hours Until 10000 Flight Hours

When Oil Pressure > 1000 PSI +–100 PSI And When Oil Pressure < 2000 PSI

Defining service requirement dependencies

Creating relations between two service requirements

You can define service requirement dependencies by creating relations between two service
requirements.

The following relations can be defined:

• Requires

This relation is used when one service requirement requires another service requirement.

Example:

You created a service requirement to change the oil every month in a service plan for a truck.
Another service requirement in the same service plan is defined to replace the oil filter which
is needed before changing the oil. You create a Requires relation between the requirement for

Creating relations between two service requirements
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changing the oil and the requirement to replace the oil filter to indicate the first requirement
requires the second.

• Satisfies

This relation is used when one service requirement satisfies another service requirement.

Example:

You created a service requirement to replace the brake pads every 1000 engine hours in a
service plan for a truck. Another service requirement in the same service plan is defined to
perform a complete brake system overhaul every 4000 engine hours, which includes changing
the brake pads. You create a Satisfies relation between the requirement for the brake overhaul
and the requirement to replace the brake pads to indicate the second requirement satisfies the
first.

Define a requires relation

1. From the navigation pane, click Service Planner.

2. Locate and open the service plan that contains the service requirements that you want to relate to
each other.

3. Press the Ctrl key and select the two service requirements you want to relate.

4. Right-click and choose Setup Requires Service Requirement Relation.

5. In the Setup Requires Service Requirement Relation dialog box, click Swap to change the order
of the service requirements.

6. Click OK to create the relation.

7. To display the relationship, select the service requirement and choose Window → Show View →
Plan Details or right-click the service requirement and choose Show Plan Details.

Define a satisfies relation

1. From the navigation pane, click Service Planner.
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2. Locate and open the service plan that contains the service requirements that you want to relate to
each other.

3. Press the Ctrl key and select the two service requirements you want to relate.

4. Right-click and choose Setup Satisfies Service Requirement Relation.

5. In the Setup Satisfies Service Requirement Relation dialog box, click Swap to change the order
of the service requirements.

6. Click OK to create the relation.

7. To display the relationship, select the service requirement and choose Window → Show View →
Plan Details or right-click the service requirement and choose Show Plan Details.

Remove service requirement dependencies

1. From the navigation pane, click Service Planner.

2. Locate and open the service plan that contains the service requirements that you want to delete
the dependencies.

3. Select one of the service requirements that contains a dependency.

4. Choose Window → Show View → Plan Details or right-click the service requirement and choose
Show Plan Details.

5. In the Plan Details dialog box, select the service requirement dependency.

6. Click Cut to remove the dependency.

The service requirement dependencies are removed.

Managing fault codes

What is a fault code?

A fault code is an identifier that indicates an itemized fault or problem that a manufacturer has identified
with a part. You can identify resolved fault codes that are rectified by the service requirement. If there is
an impacted neutral part assigned to the service requirement using the MEAssign relationship, the fault
code must be related to the impacted part. If there is no impacted part defined, the fault code must be
related to the neutral part assigned to the service plan.

Remove service requirement dependencies

Service Planner, Service Lifecycle Management 2412  8-21
© 2024 Siemens



Create a fault code

1. From the navigation pane, click Service Planner.

2. Select the folder where you want to create the new fault code and choose File → New → Fault
Code.

3. In the New Fault Code dialog box, select Fault Code from the list and click Next.

4. In the New Fault Code dialog box, enter the following information for the service partition.

Field name Definition Valid Values

Name The fault code name
(required).

Alphanumeric string (1–128
characters)

Description Description of the fault code. Alphanumeric string (1–240
characters)

5. Click OK to create the fault code.

Relate a neutral part to a fault code

1. From the navigation pane, click Service Planner or My Teamcenter.

2. Right-click the neutral part you want to relate to the fault code and choose Copy.

3. Right-click the fault code and choose Paste.

The neutral part is related to the fault code.

 Fault code
 Neutral part

Define a service requirement to resolve a fault code

1. From the navigation pane, click Service Planner.
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2. Locate and open the service requirement that you want to use to resolve the fault code.

3. From the Service Planner view, select the service requirement.

4. Right-click and choose Identify Resolved Fault.

5. In the Identify Resolved Fault dialog box, select the fault codes from the list of available fault
codes.

6. Click OK to create the relation.

7. To display the relationship, select the service requirement and choose Window → Show View →
Plan Details or right-click the service requirement and choose Show Plan Details.

Remove a fault code from a service requirement

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the service requirement to remove the fault code from.

3. Choose Window → Show View → Plan Details or right-click the service requirement and choose
Show Plan Details.

4. In the Plan Details dialog box, select the fault code under the Fault section.

5. Click Cut to remove the fault code.

Creating required skills

What is a required skill?

A required skill is the qualification that a person must have for performing or signing off on a service
requirement. The workflow that the workflow designer builds to approve or perform the service
requirement accesses the required skill to ensure the correct person performs or signs off on the service
requirement.

After you create the skill for a service requirement, the Occurrence Type for the skill is set to Required
Skill.

Remove a fault code from a service requirement
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Create a skill

1. From the navigation pane, click Service Planner.

2. Locate and open the service requirement where you want to relate the required skill.

3. From the Service Planner view, select the service requirement and do one of the following:

• Choose File → New → Skill.

• Click the Create a new Skill button  on the main toolbar at the top of the Service Planner
pane.

• Right-click the service requirement and choose New → Skill.

4. In the New Skill dialog box, select Skill from the list and click Next.

5. Enter the following information for the skill.

Field name Definition Valid Values

ID The skill ID (required).
Leave the field blank to
automatically assign an ID.

Alphanumeric string (1–128
characters)

Revision The revision of the skill
(required).
Leave the field blank
to automatically assign a
revision.

Alphanumeric (1–32 characters)

Name The name of the skill
(required).

Alphanumeric string (1–128
characters)
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Field name Definition Valid Values

Description Description of the skill. Alphanumeric string (1–240
characters)

Discipline Discipline associated with the
skill.

Valid values are the list of defined
disciplines.

6. Click Finish.

The skill is created for the service requirement with the Occurrence Type set to Required Skill.

Process Structure Occurrence Type
 Service plan

 Service partition
 Service requirement

 Skill Required Skill

Assign a skill to other service requirements

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, right-click the skill that you want to relate to the service
requirement and choose Copy.

3. From the Service Planner view, right-click the service requirement and choose Paste.

The skill is created for the service requirement with the Occurrence Type set to Required Skill.

Process Structure Occurrence Type
 Service plan

 Service partition
 Service requirement

 Skill Required Skill

Define part applicability

Part applicability is defined between a service requirement and an item or part. When the service is
performed, the items that are applicable to the service requirement are used to determine the physical
parts that have service requirements. If there are no applicable parts defined for the requirement, then
all serials numbers and part numbers of the impacted parts are used to identify the physical parts.

You can define part applicability by:

• Specifying the part number and the serial number ranges of the part.

Assign a skill to other service requirements
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The serial numbers in the specified range for the part number are identified as applicable parts for the
service requirement.

• Specifying the part number with no serial range.

All serial numbers for the part number are identified as applicable parts for the service requirement.

1. From the navigation pane, click Service Planner.

2. Locate and open the service requirement to assign the part applicability to.

3. From the Service Planner view, right-click the service requirement in the process view and choose
Define Part Applicability.

4. In the Define Part Applicability dialog box, click Add New to add a new part applicability.

5. Click and select one of the following values:

a. Properties to display the properties of the item that is contained in this field.

b. Add to search for an existing item.

A. In the Search dialog box, type the values for the properties to filter your search and click
Find.

B. Select the item in the search results list and click OK.

The part applicability dialog box reappears with the selected item.

c. Clear to clear any item that is contained in this field.
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d. Search Item in Structure to search for the item in a structure that is displayed and expanded
in the Product view.

Note:

This option is not available if there is no structure that is displayed in the Product view.

A. In the Search dialog box, double-click the Searching Value column and type a value.

You can use wild cards in this field.

B. Choose one of the following:

i. Click  to add an additional condition. The conditional separator used is AND.

ii. Click  to remove an existing condition.

iii. Click  to remove all conditions.

C. Select the item in the search results list and click OK.

6. In the Define Part Applicability dialog box, enter the following optional information to add the
new part applicability.

Field name Definition Valid Values

Serial Number
(Start)

The starting value for the
serial number range.
If you do not type an ending

Alphanumeric (1–128
characters)

Define part applicability
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Field name Definition Valid Values

value, only the starting serial
number is used.

Serial Number
(End)

The ending value for the serial
number range.

Alphanumeric (1–128
characters)
The number of digits for the
ending value must be the same
as the starting value.

7. Click OK.

8. In the Define Part Applicability dialog box, choose one of the following options:

a. Click Add New to add a new part applicability.

b. Select an existing part applicability and click Edit to edit an existing part applicability.

c. Select an existing part applicability and click Delete to delete the part applicability.

9. To display the relationship, select the service requirement and choose Window → Show View →
Plan Details or right-click the service requirement and choose Show Plan Details.

Edit part applicability

1. From the navigation pane, click Service Planner.

2. Locate and open the service requirement to edit the part applicability for.

3. Select the service requirement and do one of the following:

• Right-click the service requirement in the process view and choose Define Part Applicability.

• Choose Window → Show View → Plan Details or right-click the service requirement and choose
Show Plan Details. Click Define Part Applicability under the Define Part Applicability header.

4. In the Define Part Applicability dialog box, select an existing part applicability and click Edit to
edit the part applicability.

5. In the Edit Part Applicability dialog box, enter the following optional information.

Field name Definition Valid Values

Serial Number
(Start)

The starting value for the
serial number range.

Alphanumeric (1–128
characters)
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Field name Definition Valid Values

If you do not type an ending
value, only the starting serial
number is used.

Serial Number
(End)

The ending value for the serial
number range.

Alphanumeric (1–128
characters)
The number of digits for the
ending value must be the same
as the starting value.

6. Click OK.

7. In the Define Part Applicability dialog box, do one of the following:

• Click Add New to add a new part applicability.

• Select an existing part applicability and click Edit.

• Select an existing part applicability and click Delete.

8. To display the part applicability, select the service requirement and choose Window → Show View
→ Plan Details or right-click the service requirement and choose Show Plan Details.

Creating upgrade service requirements

An upgrade service requirement defines if the service requirement represents an upgrade or
modification to an existing product. You create an upgrade service requirement by setting the update
option to True.

When you create an upgrade work card related to an upgrade service requirement, the purpose of
the work card is to upgrade a physical part from one configuration to another. You can create only one
upgrade work card for an upgrade service requirement.

An upgrade service requirement also specifies that a rebase of the impacted physical part is performed
as part of the completion of the work card. Rebasing a physical part relates the physical structure to a
different configuration of a neutral structure. The new rebased structure uses the new configuration for
its structure context.

Example:

You create a variant for a bearing housing assembly to determine if a regular bearing housing
or heavy-duty bearing housing is used in a neutral structure. The neutral structure assigned to
the service plan has the variant set to use the regular bearing housing. However, the conditions
have changed requiring you to use the heavy duty bearing housing. If you plan to replace the

Creating upgrade service requirements
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regular bearing housing with the heavy duty bearing housing, you must create an update service
requirement and work card to set the variant to use the heavy duty bearing housing configuration.

View plan details for a service requirement

You can use the plan details view to display and edit information for a service requirement.

The following information is displayed for a service requirement:

• Service requirements that are satisfied by the service requirement.

• Service requirements that the service requirement satisfies.

• Service requirements that are required by the service requirement.

• Service requirements that the service requirement requires.

• Reference files for the service requirement.

• Fault codes that the service requirement.

• Part applicability for the service requirement.

The following table shows the available buttons when displaying property lists:

Button Purpose

Displays properties using a tree layout.

Displays properties using a table layout.

Displays properties using a list layout.

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the service requirement and do one of the following:

• Choose Window → Show View → Plan Details.

• Right-click the service requirement and choose Show Plan Details.

The Plan Details tab is displayed.
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3. Under the Satisfies Service Requirements, Satisfied By Service Requirements, Requires
Service Requirements, or Required By Service Requirements sections, select the requirement
dependency and click Cut if you want to remove the dependency.

4. Under the Fault section, select the fault code and click Cut if you want to remove the fault code
that resolves the service requirement.

5. Under the Part Applicability section, choose one of the following:

• Click Add Part Applicability to define a new part applicability.

• Select an existing part applicability and click Cut if you want to remove it.

6. Under the Specifications section, choose one of the following:

• Click Dataset to add a new dataset.

• Click Paste to add a dataset that you have copied to the clipboard.

• Select an existing dataset and click Cut if you want to remove it.

7. Under the References section, choose one of the following:

View plan details for a service requirement
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• Click Paste to add a reference that you have copied to the clipboard.

• Select an existing reference and click Cut if you want to remove it.
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9. Creating and managing work cards
Setting up and managing work cards

As a service planner, you create and manage the work cards that are related to service requirements.
Work cards define how you will address the service requirement.

You create and manage work cards by:

• Creating work cards that are related to service requirements.

• Sequencing work cards.

• Assigning resources to work cards such as:

• Required skills for a work card that determine who performs or signs off the work card.

• Part movements for a work card.

• Expendable materials to a work card.

• Tools to a work card.

• Defining characteristics for a work card.

• Generating work instructions for a work card.

• Defining notices for a work card.

• Defining time and cost estimates for a work card.

• Defining upgrade work cards.

Creating work cards

Work card

A work card defines how to accomplish a service requirement. The work card contains information about
the tasks, effort, and cost estimates and the resources required to perform the tasks. You can create
multiple work cards for a service requirement to define the tasks. You can optionally assign activities to
the work card to break down the tasks. If there are no activities, all the tasks are performed at the work
card level.
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You can perform the following actions on work cards:

• Assign states to a work card.

You can assign states to a work card by submitting it to an approval workflow. A work card can be
assigned the following states:

• in-work

• approved

• deprecated

• Revise work cards to create new revisions.

• Define the revision effectivity for a work card.

• Use options and variants to configure a work card.

For example, you may want to set an option or variant to distinguish work cards that are war time or
peace time work cards for a service plan assigned to a missile.

The following figure shows an example of a bearing housing assembly for a turbo engine that has a
service requirement to replace the rear turbine blade. Work cards are created to:

• Disassemble the turbine blade and other components of the bearing housing assembly that are in
close proximity to the blade.

• Assemble the replacement turbine.
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Create a work card

1. From the navigation pane, click Service Planner.

2. Locate and open the service requirement where you want to assign the work card.

3. Select the service requirement and do one of the following:

• Choose File → New → Work Card.

• Click the Create a new Work Card  button on the main toolbar at the top of the Service
Planner pane.

Create a work card
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• Right-click the neutral part and choose New → Work Card.

4. Select Work Card from the list and click Next.

5. In the New Work Card dialog box, enter the following information for the work card.

Field name Definition Valid Values

ID The work card ID (required).
Leave the field blank to
automatically assign an ID.

Alphanumeric string (1–
128 characters)

Revision The revision of the work card
(required).
Leave the field blank to
automatically assign an ID.

Alphanumeric string (1–32
characters)

Name The work card name (required). Alphanumeric string (1–
128 characters)

Activity Execution
Type

Defines if the assigned skill
resource will perform or sign off
on the work card.

Valid values are:

• Perform
• Sign-off

Description Description of the work card. Alphanumeric string (1–
240 characters)

Labor Cost The total labor cost for the work
card.

Number limited to two
decimal places

Material Cost The total material cost for the
work card.

Number limited to two
decimal places

Narrative Narrative description for the work
card. The narrative can be used as
input for work instructions.

Long string

6. Click Finish.

The work card is created under the service requirement.

 Service plan
 Service partition

 Service requirement
 Work card

After all work cards are added, the next step is to put them in sequence.
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Update work card properties

1. From the navigation pane, click My Teamcenter or Service Planner.

2. Select the work card.

3. Right-click and choose Properties.

4. From the Properties dialog box, change the available properties.

5. Click OK or Apply to change the work card properties. Alternatively, click Cancel to exit.

Locate a work card

1. From the navigation pane, click Service Planner.

2. Locate a work card by doing one of the following:

a. From the Service Planner view, click Open By Name  on the main toolbar at the top of
the Service Planner pane to open the service plan that contains the work card.

A. From the Service Planner view, click the service plan name tab next to the Base View
tab to expand the service plan.

B. Expand the service requirements to display the work card.

b. Using advanced search, search for the work card. Right-click the work card from the results list
and choose Send to → Service Planner.

Sequence work cards

After you create the work cards you can sequence the work cards in the order that they should be
performed.

As you sequence the work cards, identify:

• Preceding work cards (those that must be completed before others can be started).

• Parallel work cards (those that can be completed at the same time as others).

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, locate and open the service requirement that contains the work
cards you want to sequence.

Update work card properties
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3. Right-click the service requirement and choose Open with → Pert.

Each work card that exists as part of the service requirement is depicted in the PERT chart within its
own box or frame.

4. Click the Draw Flow  button on the Pert toolbar.

The draw flow mode is activated and the cursor changes to .

5. Click the first work card box.

6. Click the second work card box to draw the flow.

An arrow is drawn between the first box and the second box, showing the flow from the first work
card to the second work card.

7. Continue sequencing the work cards until the sequence is complete.

8. Exit the draw flow mode using one of the following methods:

• Press the ESC button.

• Click the Select button  on the PERT toolbar.

9. To close the Pert view, click the  button on the Pert tab.

Assign qualifications to a work card

You can assign qualifications to a work card to specify the skills, certificates, training, or other aspects
needed to perform the service work.

1. Either choose Tools → Assign Qualifications or right-click the work card and choose Assign
Qualifications.

2. Select the qualification and level that you want to assign to the work card.

3. Click the Assign button.

4. (Optional) Assign other qualifications and levels as necessary.

5. (Optional) To remove an assigned qualification from a work card, select it from the Existing
Qualifications list and click Remove.

6. Click OK.
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The qualifications are listed in the work card’s Plan Details view.

Assign work zone to a work card

You can assign a work zone, which is an occurrence group that identifies the area on the structure where
the maintenance occurs. You can specify more than one zone. The zone can be already defined on the
neutral product.

Note:

You must paste part of the neutral structure under the zone’s top level BOM line. If top level BOM
line does not have any children, the entire neutral structure is assigned as the zone to the work
card.

1. From the navigation pane, click Service Planner.

2. Locate the work zone occurrence group that you want to assign.

3. Right-click the work zone and choose Copy.

4. In the Service Plan view, right-click the work card where you want to apply the zone and choose
Paste As → Work Zone.

If you create a service schedule from the service requirements in a service plan, the work zone is
automatically transferred to the schedule job card. You cannot assign work zones to an activity, and
zones do not appear on job tasks.

Assigning resources to a work card

Types of resources you can assign to a work card

You can assign resources to a work card that are required to complete the work card. You assign
resources by relating an occurrence to the work card where the occurrence type represents the type and
usage of the resource.

As the figure shows, the following resources can optionally be assigned:

Assign work zone to a work card
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• Skills

You can assign skills to a work card, that determines who performs or signs off the work card.

• Part movements

You can create part movements for a work card to indicate whether a neutral item is installed,
uninstalled, or replaced.

• Tools

You can assign tools to a work card.

• Expendable materials

You can define expendable materials for a work card that are utilized during the tasks performed for
the work card, but not tracked when the operation is completed.

• Classified resources

You can assign resources that are classified using the Classification application.
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Create a skill

A required skill is the qualification that a person must have for performing or signing off on a work card.
The workflow that the workflow designer builds to approve or perform the work card tasks accesses the
required skill to perform the action.

After creating the skill for a work card, the Occurrence Type for the skill is set to Required Skill.

1. From the navigation pane, click Service Planner.

2. Locate and open the work card where you want to relate the required skill.

3. From the Service Planner view, select the work card and do one of the following:

• Choose File → New → Skill.

• Click the Create a new Skill button  on the main toolbar at the top of the Service Planner
pane.

• Right-click the work card and choose New → Skill.

4. In the New Skill dialog box, select Skill from the list and click Next.

5. Enter the following information for the skill.

Field name Definition Valid Values

ID The skill ID (required).
Leave blank to automatically
assign an ID.

Alphanumeric string (1–128
characters)

Revision The revision of the skill
(required).
Leave blank to automatically
assign a revision.

Alphanumeric (1–32 characters)

Create a skill
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Field name Definition Valid Values

Name The name of the skill
(required).

Alphanumeric string (1–128
characters)

Description Description of the skill. Alphanumeric string (1–240
characters)

Discipline Discipline associated with the
skill.

Valid values are the list of
defined disciplines.

6. Click Finish.

The skill is created for the work card with Occurrence Type set to Required Skill.

Process Structure Occurrence Type
 Service plan

 Service partition
 Service requirement

 Work Card
 Skill Required Skill

Define a part movement for a work card

You can create part movements for a work card to indicate whether a neutral item is installed,
uninstalled, or replaced. You relate the neutral item to the work card and assign the part occurrence
type as one of the following:

• MEDisassemble

Used to indicate the neutral item is uninstalled.

• MEAssemble
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Used to indicate the neutral item is installed.

• Replace

Used to indicate the neutral item is replaced.

The neutral items used to represent part movements must be contained within the neutral structure
related to the service plan. As the following figure shows, the shaft and rear turbine blade neutral parts
are assigned to the disassembly work card with the occurrence type set to MEDisassemble to represent
the part movements used for the disassembly of the turbine blade. The rear turbine and shaft are
components of the bearing housing assembly which is contained in the turbo-engine assembly assigned
to the service plan.

Note:

You cannot create part movements for a work card if there is life, observation, or date
characteristics assigned to the work card.

Define a part movement for a work card
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1. From the navigation pane, click Service Planner.

2. Locate and open the neutral part you want to assign to the work card to represent part movement.

Note:

You can only create part movements for neutral items that are components of the neutral
structure related to the service plan.

3. From the Product view, right-click the neutral part and choose Copy.

4. Locate and open the work card that you want to relate the part movement to.

5. From the Service Plan view, right-click the work card and choose Paste As and choose one of the
following:

• MEAssemble

Indicates the neutral item will be installed.

• MEDisassemble

Indicates the neutral item will be uninstalled.

• Replace

Indicates the neutral item will be replaced.

The neutral part is assigned to the work card with the Occurrence Type set to the part movement
occurrence type that you specified in the previous step.

Process Structure Occurrence Type
 Service plan

 Service partition
 Service requirement

 Work card
Neutral part MEAssemble

Change a part movement for a work card

1. From the navigation pane, click Service Planner.

2. Locate the work card to where you want to change the part movement.
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3. Select the neutral item that represents the part movement.

4. Click the cell under the Occurrence Type column.

5. Choose one of the following:

• MEAssemble

Indicates the neutral item will be installed.

• MEDisassemble

Indicates the neutral item will be uninstalled.

• Replace

Indicates the neutral item will be replaced.

The part movement is updated with the new value.

Define expendable material for a work card

An expendable material is used and may be consumed during the tasks performed for the work card,
but is not tracked when the operation is completed.

Example:

Shop towels or paint may be defined as expendable materials.

When you assign an expendable material to a work card, you set the occurrence type for the neutral item
to Expendable Material.

1. From the navigation pane, click Service Planner.

2. Locate and open the neutral structure or part that you want to assign as the expendable material.

Define expendable material for a work card
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3. From the Product view, right-click the neutral part and choose Copy.

4. Locate and open the work card that you want to relate the expendable material to.

5. From the Service Plan view, right-click the work card and choose Paste As → Expendable
Material.

The neutral item is assigned to the work card with the occurrence type set to Expendable
Material.

Process Structure Occurrence Type
 Service plan

 Service partition
 Service requirement

 Work card
Neutral part Expendable Material

Define tools for a work card

A tool identifies any item based resources such as hand tools.

When you assign a tool to a work card, you set the occurrence type for the neutral item to METool.

1. From the navigation pane, click Service Planner.

2. Locate and open the neutral structure or part that you want to assign as the tool.

3. From the Product view, right-click the neutral part and choose Copy.

4. Locate and open the work card that you want to relate the expendable material to.

5. From the Service Plan view, right-click and choose Paste → METool.

The neutral item is assigned to the work card with the occurrence type set to METool.

9. Creating and managing work cards

9-14  Service Planner, Service Lifecycle Management 2412
© 2024 Siemens



Process Structure Occurrence Type
 Service plan

 Service partition
 Service requirement

 Work card
 Neutral part METool

Defining resources for work cards using classification

You can classify resources such as tools, materials, and skills. You can assign these resources using the
Classification interface.

Relate resources to other work cards

1. From the navigation pane, click Service Planner.

2. Locate and open the work card that contains the resource you want to copy.

3. Right-click the resource and choose Copy.

4. Locate and open the work card where you want to copy the resource.

5. Right-click the work card and choose Paste.

The resource is assigned to the work card.

Adding characteristics to a work card

Define characteristics for a work card

A characteristic definition is used to collect and record information during maintenance. You can create
characteristic definitions that contain information such as how many hours a part has been used, the
date the asset was put into commission, or the operating temperature of the part. You can create and
assign life, observation, and date characteristic definitions to a work card.

The characteristic definitions that are available to be assigned are determined by the following:

• Any life, observation, or date characteristics related to the neutral parts assigned to the parent service
requirement with the MEAssign relationship are available as valid characteristics.

• Any life, observation, or date characteristics related to the neutral part assigned to the parent service
plan are available as valid characteristics. This is only true if there are no assigned or impacted parts
assigned to the parent service requirement with the MEAssign relationship.

Defining resources for work cards using classification

Service Planner, Service Lifecycle Management 2412  9-15
© 2024 Siemens



Note:

You cannot relate characteristics to a work card that contains part movements.

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the work card where you want to create the characteristic
and do one of the following to create the characteristic:

To create this type of
characteristic

Do one of the following

Life • Choose File → New → Life Characteristic.

• Right-click the work card and choose New → Life
Characteristic.

• Do the following:

• Right-click the work card and choose Show
Plan Details.

• In the Plan Details view under the
Measurement Characteristics section, click
Life Characteristic.

Observation • Choose File → New → Observation
Characteristic.

• Right-click the work card and choose New →
Observation Characteristic.

• Do the following:

• Right-click the work card and choose Show
Plan Details.

• In the Plan Details view under the
Measurement Characteristics section, click
Observation Characteristic.

Date • Choose File → New → Date Characteristic.

• Right-click the work card and choose New →
Date Characteristic.

• Do the following:
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To create this type of
characteristic

Do one of the following

• Right-click the work card and choose Show
Plan Details.

• In the Plan Details view under the
Measurement Characteristics section, click
Date Characteristic.

3. To display the characteristics assigned to the work card, select the work card and choose Window
→ Show View → Plan Details or right-click the work card and choose Show Plan Details.

Assign characteristics to a work card

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, right-click the work card and choose Assign Characteristics.

3. In the Assign Characteristics dialog box, select the characteristics you want to assign and click OK.

The characteristics are assigned to the work card.

4. To display the characteristics assigned to the work card, select the work card and choose Window
→ Show View → Plan Details or right-click the work card and choose Show Plan Details.

Remove an assigned characteristic

1. From the navigation pane, click Service Planner.

2. Select the work card that you want to remove the characteristic from.

3. Choose Window → Show View → Plan Details or right-click the work card and choose Show Plan
Details.

4. In the Plan Details dialog box under the Measurement Characteristics section, select the
characteristics that you want to remove.

5. Click Cut to remove the characteristic.

Assign characteristics to a work card
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Adding a notice to a work card

Define a notice for a work card

A notice is an informative message that identifies safety or hazardous material instructions. You can
define a notice for a work card.

The following notice types are available when you create a notice:

• Caution

• Warning

• Note

• Hazardous Material

1. From the navigation pane, click Service Planner.

2. In the Service Planner view, select the work card that you want to define the notice for and do one
of the following:

• Choose File → New → Notice or click the Create a new Notice  button on the main toolbar
at the top of the Service Planner pane.

• Right-click the work card and choose New → Notice.

• Right-click the work card and choose Show Plan Details. In the Plan Details view, click Notices.

3. In the New Notice dialog box, select Notice from the list and click Next.

4. Enter the following information for the notice.

Field name Definition Valid Values

Long Description The description of the notice. Alphanumeric string (1–128
characters)

Name The name of the notice
(required).

Alphanumeric string (1–128
characters)

Notice Type Type of notice. Valid values are:

• Caution
• Warning
• Note
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Field name Definition Valid Values

• Hazardous Material

5. Click Finish.

6. To display the notice, select the work card and choose Window → Show View → Plan Details or
right-click the work card and choose Show Plan Details.

Assign a notice for a work card

1. From the navigation pane, click Service Planner.

2. In the Service Planner view, select the work card that you want to assign the notice to and do one
of the following:

• Right-click the work card and choose Assign Notices.

• Right-click the work card and choose Show Plan Details. In the Plan Details view, click Assign
Notices.

3. In the Search dialog box, type the values for the properties to filter your search for the notices and
click Find.

The notices are assigned to the work card.

4. Select the notices from the results list and click Relate.

The notices are assigned to the work card.

Remove notices from work cards

1. From the navigation pane, click Service Planner.

2. Select the work card that you want to remove the notice from.

3. Choose Window → Show View → Plan Details or right-click the work card and choose Show Plan
Details.

4. In the Plan Details dialog box under the Notices section, select the notices you want to remove.

5. Click Cut to remove the notices.

The notices are removed from the work card.

Assign a notice for a work card
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Define time estimates for a work card

You can define time estimates for work cards for estimating the time it takes to perform the activities
related to the work card. You can refine the time information by defining activities for the work cards
that hold the time information. The time specified for the activities is rolled up into the total time for the
work card.

You can define the time as one of the following three types that your administrator can configure to suit
your needs:

• Value-added (VA)

• Non-value-added (NVA)

• Non-value-added, but required (NVABR)

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, locate and open the work card that you want to enter estimates
for.

3. Right-click the word card and choose Open with → Time.

The Time view appears.

4. From the Time view, enter the time estimates.

5. To close the Time view, click the  button on the Time tab.

Generate work instructions for a work card

Work instructions contain all the information necessary to perform the work. This may include
information about tools, setup, and any necessary actions to perform the work card. If the work area is
not explicitly defined, the requirements for the work area are specified as part of the work instructions.
You can create work instructions for a work card.

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, locate and open the work card that you want to generate work
instructions for.

3. Right-click the word card and choose Open with → Work Instruction.

The Work Instruction view appears.
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4. From the Work Instruction view, enter the work instructions.

5. To close the Work Instruction view, click the  button on the Work Instruction tab.

Change the ownership of data in a work card

You can change the ownership of an assigned work card so another person can work on it to finish the
related service requirement.

To do this, use the Change Owner option.

After you change the owner, you can change the related objects, such as time analysis.

Note:

The change ownership functionality is applicable to all service plan objects.

1. On the navigation pane, click Service Planner.

2. On the Service Planner view, locate the work card for which you want to change the owner.

3. Select the work card and from the top border bar, click Change Owner.

The Change Owner view appears.

4. From the Change Owner view, type or search for the name of the person to whom you want to
assign ownership.

5. Check the related objects section and mark the object list for which you want to change the
ownership.

6. Click Close  on the Change Owner tab to close the Change Owner view.

7. View the changed owner in the References section in the Attachments tab.

Define an upgrade work card

You can define work cards to specifically handle upgrades by identifying a different neutral configuration
assigned to the parent service requirement. Upgrades include upgrading to a different revision of the
same neutral product or to an entirely new neutral product.

When you create an update work card, you need to relate it to an upgrade service requirement. An
upgrade service requirement can only contain one upgrade card.

Change the ownership of data in a work card
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Example:

You create a variant for a bearing housing assembly to determine if a regular bearing housing
or heavy-duty bearing housing is used in a neutral structure. The neutral structure assigned to
the service plan has the variant set to use the regular bearing housing. However, the conditions
have changed requiring you to use the heavy duty bearing housing. If you plan to replace the
regular bearing housing with the heavy duty bearing housing, you must create an update service
requirement and work card to set the variant to use the heavy duty bearing housing configuration.

1. Locate and open the upgrade service requirement that you want to assign the upgrade work card
to.

2. Select the service requirement and create a new work card to define the upgrade or use an existing
work card.

3. In the Service Planner view, select the work card and do one of the following:

a. Choose Tools → Setup Upgrade or click the Setup Upgrade  button on the main toolbar at
the top of the Service Planner pane.

b. Right-click the work card and choose Setup Upgrade.

4. In the Setup Upgrade dialog box, choose one the following options:

a. To reconfigure the neutral structure using revision rule and variants configuration, perform
the following steps:

A. Click Reconfigure Neutral Item and click OK.

B. The neutral structure for the parent service plan appears in the Search` dialog box under
the Configure tab.

b. To search for a different neutral revision or configuration, perform the following steps.

A. Click Advanced.

B. Click Search New Neutral Item Revision and Configure and click OK.

C. In the Search dialog box, type the values for the properties to filter your search and click
Find

You can use wild cards in any of the property fields for searching.

D. Select the part revision from the results list and click Configure.
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c. To search for a different neutral configuration using the saved structure context name,
perform the following steps.

A. Click Advanced.

B. Click Search Saved Structure Context and click OK.

C. In the Search dialog box, type the structure context name and click Find.

You can use wild cards for searching.

D. Select the part from results list and click Configure.

5. Click Latest Working to optionally set a revision rule and click OK.

6. Select a part in the structure and click Click to add a variant rule to optionally set a variant rule
and click OK.

7. Click Finish to upgrade to a new revision of the neutral structure or a different neutral structure.

8. To display the properties of the upgrade work card, select the work card and choose Window →
Show View → Plan Details or right-click the work card and choose Show Plan Details.

View plan details for a work card

You can use the plan details view to display and edit information for a work card.

The following information is displayed for a work card:

• Characteristics assigned to the work card.

• Notices assigned to the work card.

• Reference files for the work card.

• Specifications for the work card.

• Upgrade configurations for the work card.

The following table shows the available buttons when displaying property lists:

View plan details for a work card
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Button Purpose

Displays properties using a tree layout.

Displays properties using a table layout.

Displays properties using a list layout.

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the work card and do one of the following:

• Choose Window → Show View → Plan Details.

• Right-click the work card and choose Show Plan Details.

The Plan Details tab is displayed.

3. Under the Measurement Characteristics section, choose one of the following:

• Click Life Characteristic to define a new life characteristic for the work card.

• Click Observation Characteristic to define a new observation characteristic for the work card.

• Click Date Characteristic to define a new date characteristic for the work card.

• Select a characteristic and click Cut if you want to remove it.

4. Under the Notices section, choose one of the following:
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• Click Notice to define a new notice for the work card.

• Click Assign Notice to assign an existing notice to the work card.

• Select a notice and click Cut if you want to remove it.

5. Under the References section, choose one of the following:

• Click Paste to add a reference that you have copied to the clipboard.

• Select an existing reference and click Cut if you want to remove it.

6. Under the Specifications section, choose one of the following:

• Click Dataset to add a new dataset.

• Click Paste to add a dataset that you have copied to the clipboard.

• Select an existing dataset and click Cut if you want to remove it.

7. Under the Upgrades section, select the upgrade work card and click Load Configuration to load
the upgraded configuration in the Service Planner view.

Add deliverables to a work card

You can add data collection objects to the work card as required deliverables. The objects can be
documents, workspace objects, forms, or datasets. These objects allow you to have a place to collect the
data you need to correctly service the part.

1. Right-click the work card and choose Show Plan Details.

2. In the Plan Details view under the Required Resulting Information section, you can either add a
new object or paste an object from the clipboard with the Paste button.

3. To create a new object, click Add New.

4. Select a business object type and click Next.

5. Type a name and fill in all other required information. Ensure that SSP0RequiredResultingInfo is
the selected relation.

6. Click Finish.

Add deliverables to a work card
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10. Creating and managing activities
Setting up and managing activities

As a service planner, you create and manage the activities that are related to work cards. Activities define
the specific steps for how to perform the service.

You create and manage activities by:

• Creating activities that are related to work cards.

• Sequencing activities.

• Assigning resources to activities such as:

• Required skills for an activity that determines who performs or signs off the activity.

• Part movements for an activity.

• Expendable materials for an activity.

• Tools for an activity.

• Defining characteristics for an activity.

• Defining notices for an activity.
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• Defining time and cost estimates for an activity.

• Defining signoff levels for an activity.

Creating activities

Creating activities

An activity defines the specific steps a service technician must perform to complete required service
tasks.

The activity is created as a child of the work card. You can also create subactivities that are children of a
parent activity.

Each activity is defined by its type, description, start time, and duration. An activity can also reference
Teamcenter objects. This allows you to attach any forms to the activity that represents features and their
associated tooling and instructions.

Note:

You cannot create revisions of activities.

The following figure shows an example of a bearing housing assembly for a turbo engine that has a
service requirement to replace the rear turbine blade. A work card is created to disassemble the turbine
blade and other components of the bearing housing assembly that are in close proximity to the blade.
The activities are created to disassemble the shaft first and then disassemble the turbine blade.
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Create an activity

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, locate and open the work card where you want to add the
activities.

3. Right-click the work card and choose Open with → Activities.

The Activities view appears.

4. From the Activities view, select the work card or an existing activity and do one of the following:

Create an activity
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• Choose File → New → Activity, or click the Create New Activity button  on the Activities
view toolbar.

• Right-click the parent object and choose New → Activity.

5. Select MEActivity from the list and click Next.

6. In the New Activity dialog box, enter the following information for the activity.

Field name Definition Valid Values

Name The activity name (required). Alphanumeric string (1–
128 characters)

Activity Execution
Type

Defines if the skill resource will
perform or sign off the activity.

Valid values are:

• Perform
• Sign-off

Start time The time the activity needs to
start.

Floating point value

Duration The total duration of the activity. Floating point value

Description The description of the activity. Alphanumeric string (1–
240 characters)

7. Click Finish.

The activity is created.

8. To close the Activities view, click the  button on the Activities tab.

After all activities are added, the next step is to put them in a sequence.

Update activity properties

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, locate and open the work card that contains the activity you want
to edit the properties for.

3. Right-click the work card and choose Open with → Activities.

The Activities view appears.

4. From the Activities view, select the activity.
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5. Right-click and choose Properties.

6. In the Properties dialog box, change the available properties.

7. Click OK or Apply to change the activity properties. Alternatively, click Cancel to exit.

8. To close the Activities view, click the  button on the Activities tab.

Edit start time and duration for an activity

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, locate and open the work card that contains the activity you want
to edit the start time and duration for.

3. Right-click the work card and choose Open with → Activities.

The Activities view appears.

4. From the Activities view, select the activity.

5. Double-click the cells containing the start and duration times.

6. Type the new value.

7. To close the Activities view, click the  button on the Activities tab.

Sequence activities

After you create the individual activities to be completed as part of an operation, you can modify the
sequence in which these activities are performed. This sequence is called the activity flow.

As you sequence the activity flow, identify:

• Preceding activities (those that must be completed before others can be started).

• Parallel activities (those that can be completed at the same time as others).

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, locate and open the work card that contains the activities you
want to sequence.

3. Right-click the work card and choose Open with → Activities.

Edit start time and duration for an activity
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The Activities view appears.

4. From the Activities view, right-click the root activity and choose Open with → Pert.

Each activity that exists as part of the root activity is depicted in the PERT chart within its own box
or frame. By default, the activities are sequenced in the order they are created.

5. To change the default sequence, perform the following:

a. From the Pert view, select the flow you want to change by clicking it.

b. Click the  button on the Pert toolbar to delete the flow.

c. Click the Draw Flow  button on the Pert toolbar.

The draw flow mode is activated and the cursor changes to .

d. Click the first activity box.

e. Click the second activity box to draw the flow.

An arrow is drawn between the first box and the second box, showing the flow from the first
activity to the second activity.

f. Continue sequencing the activities until the sequence is complete.

g. Exit the draw flow mode using one of the following methods:

• Press the ESC button.

• Click the Select button  on the PERT toolbar.

h. To close the Pert view, click the  button on the Pert tab.

Assign qualifications to an activity

You can assign qualifications to an activity to specify the skills, certificates, training, or other aspects
needed to perform the service work. Qualifications limit the users who can be assigned to the activity to
the ones who possess the required qualifications in Teamcenter.

1. Either choose Tools → Assign Qualifications or right-click the activity and choose Assign
Qualifications.

2. Select the qualifications and levels that you want to assign to the activity.
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3. Click the Assign button.

4. (Optional) Assign other qualifications and levels as necessary.

5. (Optional) To remove an assigned qualification from a work card, select it from the Existing
Qualifications list and click Remove.

6. Click OK.

The qualifications are listed in the activity’s Plan Details view.

Assigning resources to an activity

Assigning resources to an activity

You can assign resources to an activity that is required to complete the activity. In order to use a resource
for an activity, the resource must be created for the parent work card.

The following resources can optionally be assigned from the parent work card:

• Skills

Determines who performs or signs off the work card.

• Part movements

Indicates whether a neutral item is installed, uninstalled, or replaced.

• Expendable materials

Used and may be consumed during the tasks performed for the work card, but not tracked when the
operation is completed.

Assigning required skills

A required skill is the qualification that a person must have to perform or sign off on an activity. The
workflow that the workflow designer builds to approve or perform the activities accesses the required
skill to perform the action. When you create the activity, the activity type determines if it is a perform or
signoff action.

You can assign the required skills for the activity only if the skills are assigned to the parent work card.
After assigning the skill from the work card for an activity, the Occurrence Type for the skill is set to
Required Skill.

Assigning resources to an activity
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You assign the skill as you would assign any resource.

Assigning part movements for activities

You can assign part movements for an activity to indicate whether a neutral item is installed,
uninstalled, or replaced. You can assign the part movements for the activity only if the part movements
are assigned to the parent work card.

The following figure shows three part movements assigned to a work card. It contains three activities to
break down the tasks. The part movements assigned to the work card are each assigned to an individual
activity.

10. Creating and managing activities
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The following occurrences types are used:

• MEAssemble

Indicates the neutral item is installed.

• Replace

Indicates the neutral item is replaced.

• MEDisAssemble

Indicates the neutral item is uninstalled.

You assign the part movements as you would assign any resource.

Note:

You cannot create part movements for an activity if there are life, observation, or date
characteristics assigned to the activity.

Assigning expendable materials for activities

An expendable material is used and might be consumed during the tasks performed for an activity, but
is not tracked when the activity is completed.

Example:

Shop towels or paint can be defined as expendable materials.

You can assign the expendable materials for the activity only if the expendable materials are assigned to
the parent work card. After assigning the expendable materials from the work card for an activity, the
Occurrence Type for the skill is set to Expendable Material.

Assigning expendable materials for activities
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You assign the expendable materials as you would assign any resource.

Assigning tools for activities

A tool identifies any item-based resources such as hand tools.

You can assign the tools for the activity only if the tools are assigned to the parent work card. After
assigning the tools from the work card for an activity, the Occurrence Type for the skill is set to METool.

You assign the tools as you would assign any resource.

Assign or remove resources

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the parent work card that contains the activities where you
want to assign or remove resources.

3. Right-click the work card and choose Open with → Activities.

The Activities view appears.

4. Select the activity and click the Activity Assignments  button on the Activities view toolbar.

5. In the Activity Assignments dialog box, do one of the following:

• Select the resource from the work card and click the  button to assign the resource to the
activity.

• Click the  button to assign all resources from the work card to the activity.
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• Select the resource from the activity and click the  button to remove the assigned
resource.

• Click the  button to remove all assigned resources from the activity.

6. Click OK.

Defining characteristics for an activity

Define characteristics for an activity

A characteristic definition is used to collect and record information during maintenance. You can create
characteristic definitions that contain information such as how many hours a part has been used, the
date the asset was put into commission, or the operating temperature of the part. You can assign life,
observation, and date characteristic definitions to an activity.

In addition, any life, observation, or date characteristics related to the parent work card can be assigned
to the activity.

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the work card that contains the activity that you want to
define characteristics for.

3. Right-click the work card and choose Open with → Activities.

The Activities view appears.

4. From the Activities view, select the activity and do one of the following to create the characteristic:

To create this type of
characteristic

Do one of the following

Life • Choose File → New → Life Characteristic.

• Right-click the work card and choose New → Life
Characteristic.

• Do the following:

• Right-click the work card and choose Show
Plan Details.

Define characteristics for an activity
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To create this type of
characteristic

Do one of the following

• In the Plan Details view under the
Measurement Characteristics section, click
Life Characteristic.

Observation • Choose File → New → Observation
Characteristic.

• Right-click the work card and choose New →
Observation Characteristic.

• Do the following:

• Right-click the work card and choose Show
Plan Details.

• In the Plan Details view under the
Measurement Characteristics section, click
Observation Characteristic.

Date • Choose File → New → Date Characteristic.

• Right-click the work card and choose New →
Date Characteristic.

• Do the following:

• Right-click the work card and choose Show
Plan Details.

• In the Plan Details view under the
Measurement Characteristics section, click
Date Characteristic.

5. To display the characteristics assigned to the activity, select the activity and choose Window →
Show View → Plan Details or right-click the activity and choose Show Plan Details.

Assign characteristics for an activity

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the work card that contains the activity that you want to
assign characteristics for.
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3. Right-click the work card and choose Open with → Activities.

The Activities view appears.

4. From Activities view, right-click the activity and choose Assign Characteristics.

5. In the Assign Characteristics dialog box, select the characteristics you want to assign and click OK.

The characteristics are assigned to the activity.

6. To display the characteristics assigned to the activity, select the activity and choose Window →
Show View → Plan Details or right-click the activity and choose Show Plan Details.

Remove an assigned characteristic

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the work card that contains the activity that you want to
remove the characteristic from.

3. Right-click the work card and choose Open with → Activities.

The Activities view appears.

4. Select the activity.

5. Choose Window → Show View → Plan Details or right-click the activity and choose Show Plan
Details.

6. In the Plan Details dialog box under the Measurement Characteristics section, select the
characteristics that you want to remove.

7. Click Cut to remove the characteristic.

Adding a notice to an activity

Define a notice for an activity

A notice is an informative message that identifies safety or hazardous material instructions. You can
define a notice for an activity.

The following notice types are available when you create a notice:

• Caution

Remove an assigned characteristic
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• Warning

• Note

• Hazardous Material

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the work card that contains the activity that you want to
define a notice for.

3. Right-click the work card and choose Open with → Activities.

The Activities view appears.

4. Select the activity and do one of the following to create the notice:

• Choose File → New → Notice or click the Create a new Notice button  on the main toolbar
at the top of the Service Planner pane.

• Right-click the activity and choose New → Notice.

• Right-click the activity and choose Show Plan Details.

• In the Plan Details view, click Notices.

5. Select Notice from the list and click Next.

6. In the New Notice dialog box, enter the following information for the notice.

Field name Definition Valid Values

Long Description The description of the notice. Alphanumeric string (1–128
characters)

Name The name of the notice
(required).

Alphanumeric string (1–128
characters)

Notice Type Type of notice. Valid values are:

• Caution
• Warning
• Note
• Hazardous Material

7. Click Finish.
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8. To display the notice, select the activity and choose Window → Show View → Plan Details or
right-click the notice and choose Show Plan Details.

Assign a notice for an activity

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the work card that contains the activity that you want to
assign a notice to.

3. Right-click the work card and choose Open with → Activities.

The Activities view appears.

4. Select the activity and do one of the following:

• Right-click the activity and choose Assign Notices.

• Right-click the activity and choose Show Plan Details.

• In the Plan Details view, click Assign Notices.

5. In the Search dialog box, type the values for the properties to filter your search for the notices and
click Find.

6. Select the notices from the results list and click Relate.

The notices are assigned to the activity.

7. To display the notice, select the activity and choose Window → Show View → Plan Details or
right-click the notice and choose Show Plan Details.

Remove notices from activities

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the work card that contains the activity that you want to
remove a notice from.

3. Right-click the work card and choose Open with → Activities.

The Activities view appears.

4. Select the activity that you want to remove the notice from.

Assign a notice for an activity
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5. Choose Window → Show View → Plan Details or right-click the activity and choose Show Plan
Details.

6. In the Plan Details dialog box under the Notices section, select the notices you want to remove.

7. Click Cut to remove the notices.

The notices are removed from the activity.

Define time estimates for an activity

You can define time estimates for activities to estimate the time it takes to perform the activities related
to a work card. The time specified for the activities is rolled up into the total time for the work card.

You can define the time as one of the following three types that your administrator can configure to suit
your needs:

• Value-added (VA)

• Non-value-added (NVA)

• Non-value-added, but required (NVABR)

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the work card that contains the activity that you want to add
a time estimate.

3. Right-click the work card and choose Open with → Time.

The Time view appears.

4. To close the Time view, click the  button on the Time tab.

Defining signoff levels for activities

You can define signoff levels for activities by following this process:

1. Assign a required to skill to the activity.

The workflow that the workflow designer builds to approve or perform the activities accesses the
required skill to perform the action.

2. Set the Activity Execution Type when you create the activity to either Perform or Sign-off.
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This defines if the skill resource will perform or sign off on the activity.

View plan details for an activity

You can use the plan details view to display and edit information for an activity.

The following information is displayed for an activity:

• Item properties for the activity.

• Notices assigned to the activity.

• Characteristics assigned to the activity.

The following table shows the available buttons when displaying property lists:

Button Purpose

Displays properties using a tree layout.

Displays properties using a table layout.

Displays properties using a list layout.

1. From the navigation pane, click Service Planner.

2. From the Service Planner view, select the work card that contains the activity that you want to
view the plan details for.

3. Right-click the work card and choose Open with → Activities.

The Activities view appears.

4. Select the activity and do one of the following:

• Choose Window → Show View → Plan Details.

• Right-click the activity and choose Show Plan Details.

The Plan Details tab is displayed.

View plan details for an activity
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5. To edit properties for the activity, under the Properties section click More Properties.

6. Under the Measurement Characteristics section, choose one of the following:

• Click Life Characteristic to define a new life characteristic for the activity.

• Click Observation Characteristic to define a new observation characteristic for the activity.

• Click Date Characteristic to define a new date characteristic for the activity.

• Select a characteristic and click Cut if you want to remove it.

7. Under the Notices section, choose one of the following:

• Click Notice to define a new notice for the activity.

• Click Assign Notice to assign an existing notice to the activity.

• Select a notice and click Cut if you want to remove it.

Add deliverables to an activity

You can add data collection objects to the activity as required deliverables. The objects can be
documents, workspace objects, forms, or datasets. These objects allow you to have a place to collect the
data you need to correctly service the part.

1. Right-click the work card with the activity and choose Open with → Activities.

2. Right-click the activity and choose Show Plan Details.
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3. In the Plan Details view under the Required Resulting Information section, you can either add a
new object or paste an object from the clipboard with the Paste button.

4. To create a new object, click Add New.

5. Select a business object type and click Next.

6. Type a name and fill in all other required information. Ensure that SSP0RequiredResultingInfo is
the selected relation.

7. Click Finish.

Add deliverables to an activity
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11. Managing time
Managing time

Using the Time view, you can manage time information on activities, work cards, and service
requirements. You can start by estimating the time it takes to perform work cards. Later, you can refine
the time information by defining activities holding time information. You can define the category of
each activity, for example, Value Added or Non-Value Added, and later analyze how much time in your
overall service requirement structure (or any other service requirement level) is spent on each category.
This view also lets you roll up the time information from lower levels to upper levels and define the
allocated time of each of the leaves.

The Time view provides information specific to the service requirement or work card so that its
appearance varies depending on which of these you select.

Times are stored in the Time Analysis form on the service requirement or work card. Activity times
are stored as fields directly on the class. In contrast to service requirement or work card, there is no
additional activity time form. You can modify times in the Time view and these changes are then
reflected in the forms.

Time units are stored in seconds in the database. You can configure which units are shown in the Time
view.

Open the Time view

1. Select a service requirement or work card.

2. Choose Open with → Time.

Teamcenter opens the Time view.

• If a service requirement is selected, the Time view contains the Time Values and Time Analysis
sections.

Use this section To

Time Values Edit allocated, estimated and simulated times for a
service requirement or work card. Use the Calculate
button to populate the allocated time and roll up the
summary to upper levels.

Time Analysis See the analysis of the activities for the selected
object. The total work, total duration, and pie chart are
calculated for the activities of all descendents of the
selected service requirement or work card.
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• If a work card is selected, the Time view additionally contains the Work Content and Activities
sections.

Use this section To

Work Content Display the work content of the work card. This is
customer-specific information and is not used for any
calculation. You can expand or collapse this section to
suit your needs.

Activities Define activities with time information and classify
them into time categories.

Edit work card activities

Activities are intended to break down a work card to define its detailed time information. Each activity
can have the following time information:

• Code

The code of an activity is defined in a time standard or in your company’s standard.

• Unit Time

The unit time is the time it takes to perform this activity.

• Frequency

Frequency represents how many times this activity is performed. The default is 1.

• Work Time

The total time it takes to perform this activity. This work time is the result of multiplying the unit time
by the frequency.

• Category

The time category to which this activity belongs (for example, Value Added).

With the Time view open for a work card, do any of the following:

Use To

Add Below Add a new activity as a descendent of the selected activity.

Add After Create a new sibling activity after the selected activity.

11. Managing time
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Use To

Data Card Open the Data Card dialog box.

Time System Open the TiCon Search view to search for elements in the
TiCon time system.

Remove Delete an activity.

Properties Open the activities Properties form.

Move Up

Move Down

Change the order of the activities. This order is also reflected
in the Activity Flow PERT chart.

Note:

Use these buttons to change the order of a linear flow
of activities only. If you use these on parallel flows, the
changed order can lead to incorrect flows.

F2 key or select the cell Edit the cell contents, including the name.

Shortcut menu Obtain additional commands to perform on a selected
activity:

• Cut/Copy/Paste

• Expand

• Expand Below

• Collapse Below

• Refresh

• Properties

• Activity Assignments

Note:

If an activity in the Activities table of the Time view contains child activities, the time displayed
for it is the cumulative time of all the child activities. For this reason, you cannot use Add Below if
an activity already contains a time, and you cannot use Replace if the activity already has children.

Edit work card activities
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Performing a time analysis

When Teamcenter performs a time analysis, it calculates total work and total duration of descendents
of the selected object. In addition, it calculates the time required for each category of time and displays
these in a pie chart. By default, Teamcenter provides you with three categories of activities, value-added
(VA), non-value-added (NVA), non-value-added but required (NVABR). Your administrator can configure
these to suit your needs.

• If you select a work card, Teamcenter performs a time analysis automatically when you open the Time
view.

• If you select a service requirement, these calculations can be very time-consuming, so you must
initiate them manually by clicking Calculate.

Note:

Teamcenter caches the time analysis calculations for a service requirement but does not update
them automatically if any changes occur. If you make any changes that affect stored times, you
must click Calculate again to obtain the updated values.

Teamcenter does not save the time analysis information to the database, it only saves it in the
current session. It does this because a time analysis result depends on the current configuration of
the structure. You can generate a report of the time analysis which is saved as an attachment to
the service requirement.

Populate allocated time

Allocated time is the official time of each service requirement and work card. You can manually define
the allocated time or you can populate it from other time fields. You can choose the basis on which
to calculate the allocated time. This calculation updates the allocated time of all the descendents of
the selected service requirement or work card. The calculation is done from the lowest level upwards
(rollup).

1. Do one of the following:

• In the Time view, in the Time Values section, click Calculate.

• Choose Tools → Populate Allocated Time.

Teamcenter opens the Populate Allocated Time dialog box.

2. Select one of the following:

11. Managing time
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Use this option To calculate allocated time based on

Estimated Time Time information used in the preplanning stages, before
detailed time analysis data is available.

Simulated Time Time values that are determined as a result of a
simulation.

Time Analysis Duration The total duration as calculated in the Time Analysis
section.

Best Available Time The best time available on the service requirement or
work card.

• For a work card, the calculation uses the time available
on it in the following order: time analysis duration →
simulated time → estimated time.

• For a service requirement with no children, the
calculation uses the estimated time.

Filtering activity attachments from the structure

You can suppress the display of different types of attachments in the Activities section of the Time view
using the METimeTabFilteredComponents preference. If you want to see the attachments, open the
Attachments view on the work card activity.

Run a time report

When working in the Time view, you can run two reports:

• Time Analysis Report

This report summarizes the time analysis for the selected object and below that object. It includes the
time analysis information for each service requirement and work card. It contains the name of the
service requirement, work card or activity, code, unit time, frequency, work time, duration, and times
for different categories. You run this report from the Time Analysis section of the Time view.

• Allocated Time Report

This report contains the name of the service requirement or work card, allocated, estimated, and
simulated times and the duration. You run this report from the Time Values section of the Time view.

Teamcenter creates these reports as Excel files that are attached as datasets to the corresponding object.
You can customize the reports in the Report Builder application.

1. In the Time view, do one of the following:

Filtering activity attachments from the structure
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• In the Time Analysis section, click Report to create a time analysis report.

• In the Time Values section, click Report to create an allocated time report.

Teamcenter opens a dialog box where you can specify the name of the dataset.

• If the TC_CRF_overwrite_existing_dataset_content preference is set to true, Teamcenter
replaces the contents of the dataset.

• If the TC_CRF_overwrite_existing_dataset_content preference is set to false, Teamcenter
creates a new dataset.

2. Type a new name into the box, or click Replace to overwrite the dataset contents.

3. Click OK to close the resulting dialog box and open the report.

If you create a time analysis report, Teamcenter calculates and exports the time analysis values of
the selected object and all its descendents. If you generate an allocated time report, no calculation is
performed. The report reflects the current state of the data.

Customizing a time report

You can customize a time report in any of the following ways.

• Change the report to be used by changing the value of the METimeAnalysisReportDefinitionID or
MEAllocatedTimeReportDefinitionID preferences.

• Add one or more style sheet to the report definition by modifying the
METimeAnalysisReportStylesheet and MEAllocatedTimeReportStylesheet preferences.

• Customize the report contents in the Report Builder application.

• The SHOW parameter specifies which Teamcenter columns are displayed as rows in the report.

• The TRANSFER_MODE parameter specifies the name of the transfer mode to be used to export
additional data. You must customize the XSL style sheet to show the exported data.

Configuring the Time view

Configure the categories list

You add new categories in the Business Modeler IDE application.

1. Open the foundation template in the Business Modeler IDE application.

11. Managing time
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2. Choose Extension → LOV → Activity Category LOV.

Teamcenter displays a list of time categories.

3. Add a new category to the list.

4. (Optional) Choose a color for the new category.

Configure color categories

You can specify the color in which each time category appears. This category is reflected in the
Activities section of the Time view and in the colors of the pie chart in the Time Analysis section.

1. Choose Edit → Options.

Teamcenter opens the Options dialog box.

2. Click Manufacturing in the hierarchy tree.

3. Click the Time tab.

4. In the Colors Representing Time Analysis Types section:

• Click any of the displayed colors.

Teamcenter opens the Color Chooser dialog box.

• Click a new color.

• Click OK.

Configure time units

Change the time unit that appears in the Time Analysis section as follows:

1. Choose Edit → Options.

Teamcenter opens the Options dialog box.

2. Click Manufacturing in the hierarchy tree.

3. Click the Time tab.

4. Choose the time unit that you want to display in the Current Time Unit list. You can choose from
any of the following units:

Configure color categories
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Unit ID

Long display
name (localizable)

Short display
name (localizable) Multiplier to

seconds

1000th_min 1/1000 min 0.001m 0.06

100th_min 1/100 min 0.01m 0.6

10th_min 1/10 min 0.1m 6

FAC FAC FAC 0.18

MOD MOD MOD 0.129

TMU TMU TMU 0.036

day Day d 86400

hour Hour h 3600

minute Minute min 60

second Second sec 1

5. (Optional) Make further adjustments to the time units using the MEAvailableTimeUnits and
MECurrentTimeUnit preferences.

Managing process times with a Gantt chart

Understanding the Process Gantt view

The Process Gantt view displays service requirements and work cards and the relations between them
in a chart. A process Gantt chart is a bar chart that illustrates the work breakdown structure of a project.
It illustrates the start and finish times of the work cards or service requirements and summary elements
(work cards or higher level service requirements) of the project using a time line. The Gantt chart also
shows the dependency (sequence) relationships between the elements.

Using the Process Gantt view, you can:

• Create and remove flows.

• Change the duration of elements.

• Populate the duration time based on leaf elements.

• Show and hide the critical path.

• Expand and collapse elements within the chart.

11. Managing time
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• Zoom in and out of the chart.

Note the following about the Process Gantt view.

• The duration of an element in the Gantt chart represents its allocated time. You can also set the
allocated time in the Time view.

• You cannot set start times manually in the Process Gantt view. Start times are calculated based on
predecessor service requirements or work cards.

• To help you avoid making inadvertent changes to activity durations, the Process Gantt view is locked
in edit mode when you first open it. You must unlock this mode by clicking  before you can modify
duration times by dragging the time bar.

• If objects are configured out in the initiating service requirement structure, the Gantt chart ignores
them.

• You can drop a service requirement into the Gantt chart; the behavior is identical to dropping it in the
same position in the structure view.

• When you select a service requirement or time element in the Process Gantt view, the same service
requirement is selected in the structure view.

• You cannot delete a service requirement that has flows attached to it.

Open the Process Gantt view

1. Select a service requirement or work card in the structure tab.

2. Do one of the following:

• Choose Open With → Process Gantt from the shortcut menu.

• Choose Window → Show View → Process Gantt.

Teamcenter displays the process Gantt chart. The selected service requirement or work card is the root
node of the process tree. The pane on the right displays the start time and duration time for each line of
the process structure. You can open multiple Process Gantt views for comparison purposes.

Note:

You cannot manipulate start times in the Process Gantt view.

Change duration times

Do one of the following:

Open the Process Gantt view
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1. Make sure that the Lock editing button  is off.

2. Move the cursor over the end of the time bar until it changes to a double-ended arrow ↔.

3. Drag the end of the bar to the desired duration time.

-or-

1. Right-click the time bar and choose Show property dialog.

2. Type a new end time and click OK.

Teamcenter changes the length of the time element to reflect the new time.

Tip:

Teamcenter displays the duration time in a tool tip for the service requirement or work card, as
well as in the allocated_time column of the view navigation pane.

Reset the scope

1. Select a service requirement or work card in the structure view.

2. Click .

Teamcenter removes the current service requirement or work card from the Process Gantt view and
replaces it with the selected one.

Modify the view

Do one of the following:

Click To

Update the Gantt chart.

Scale the chart up or down to accommodate the entire
process flow.

Scale the chart up to show the currently selected time
element placed in the middle of chart and taking up most
approximately two thirds of the chart.

Reduce the scale of the chart by a factor of two.

Enlarge the scale of the chart by a factor of two.

11. Managing time
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Tip:

Use the Ctrl key to help you draw a box around a group of time elements to select multiple objects.

You can also use the following shortcut menu commands to help you modify the view:

Menu command Description

Collapse element Collapses the tree structure under the selected line. It also
collapse the corresponding time elements.

Expand element Expands the tree structure to one level under the selected
line. It also expands the corresponding time elements.

Create a flow

You can only create flows between service requirements or work cards at the same level in a structure
that have the same parent (sibling lines).

Do one of the following:

• Create a flow between elements by selecting at least two bars in the Gantt chart and click .

Teamcenter creates a flow between the elements in the order that you selected them.

• Create a flow by dragging one bar to another in the representation pane.

If, for example, you drag Process 1 to Process 2, Teamcenter creates a flow from Process 1 to Process
2.

• Select the desired nodes in the tree structure in the navigation pane and click .

Teamcenter creates a flow between the elements in the order that the nodes appear in the tree.

Tip:

Teamcenter displays the names of the source and target elements in a tool tip on the flow.

Delete a flow

Select the flow by clicking the line and do one of the following:

• Click .

• Choose Delete flow from the shortcut menu.

Create a flow
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• Press the Delete key.

Show/hide the critical path

The critical path is the sequence of service requirements or work cards that defines the longest path of
the project. The project cannot be completed in a shorter time than the critical path. A project might
have more than one critical path. In the case of a single critical path, if you make a modification that
shortens the duration of any of the elements, you shorten the overall duration of the project.

1. Click the Mark Critical Path button  to display or hide the critical path.

If there is more than one critical path in the Gantt chart or some alternative paths have the same
critical path length, Teamcenter shows all the critical paths.

2. (Optional) Click  to view the duration of the critical path.

Teamcenter displays the read-only Critical Path Length dialog box.

Understanding the calculated duration time

Duration of an element is the overall time it takes to perform its direct children. If all the children are
parallel (no flows between them), it is the length of the longest child. In the case where there are flows
between the children, it is the overall time it takes to perform the children according to the order (flows)
between them. Calculated duration of upper levels is based on the calculated duration of lower levels. If
the lower level has no children (for example, a service requirement that has no service requirements or
work cards below), its calculated duration is equal to its duration

• For a service requirement with only child work cards, the calculated duration is the length of the
longest path of work cards. If the work cards have flows between them, it is the overall time it takes to
perform them according to the flows.

• For a service requirement with child service requirements, Teamcenter first calculates the calculated
duration of each child service requirement containing only child work cards, and then calculates the
longest process duration of the service requirements based on the calculated duration time of the
sub-service requirements and work cards.

If there are, for example, four work cards with the same parent, having duration times of one second,
two seconds, three seconds, and four seconds, the calculated time for the parent service requirement
is four seconds. If, however, the second work card must be completed before the third, the calculated
duration time is 5 seconds for the parent service requirement.

Use the Show calc duration button  to show or hide the calculated duration time. Teamcenter shows
a bar across the top of each time element displaying the calculated duration path of the children of this
time element.
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Configure the Gantt

1. Choose Edit → Options.

Teamcenter displays the Options dialog box.

2. Select Manufacturing from the tree.

3. Click the Gantt tab and set any of the following preferences:

Option Description

Show calculated duration Specifies whether the calculated duration time is displayed by
default in the Process Gantt view.

This information is stored in the
MEGANTTDefaultDisplayMode preference.

Full edit mode Allows you to use drag options to edit and modify the
elements in the Gantt chart.

This information is stored in the MEGANTTDefaultEditMode
preference.

Zoom level Specifies the X-axis zoom level that is active when a Gantt
chart is opened.

Element height Specifies the height of one element of the Gantt chart in the
navigation and the representation area (the amount of pixels
that are used for one element). There is no space between
the elements (10 elements use 10 times the space of one
element).

This information is stored in the MEGANTTElementHeight
preference.

Element color Specifies the fill color of the elements in RGB code.

This information is stored in the
MEGANTTElementRGBfillColor preference.

Critical path element color Specifies the color of the critical path elements in the Process
Gantt view representation area.

This information is stored in the
MEGANTTDefaultMarkedColor preference.

Selection color Specifies the color of a selected element in the Process Gantt
view representation area.

This information is stored in the
MEGANTTDefaultMarkedColor preference.

Configure the Gantt
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Option Description

Calculated duration color Specifies the color of the duration time bar in the Process
Gantt view representation area.

This information is stored in the
MEGANTTDefaultDurationTimeColor preference.

Flow color Specifies the color of a flow in the Process Gantt view
representation area.

This information is stored in the MEGANTTDefaultFlowColor
preference.

Critical path flow color Specifies the color of critical path flow in the Process Gantt
view representation area.

This information is stored in the MEGANTTMarkedFlowColor
preference.

Implicit flow color Specifies the color of an implicit flow (created by Teamcenter
to retain necessary dependencies) in the Process Gantt view
representation area.

This information is stored in the MEGANTTImplicitFlowColor
preference.

These preferences are applied to any newly opened Process Gantt view.
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12. Creating, viewing, and editing work
instructions
Creating, viewing, and editing work instructions

You can create work instructions for the information contained in your service plan using Teamcenter
Publish. Teamcenter Publish enables you to author, distribute, and view the most current service
planning data. The main features of Teamcenter Publish include:

• Technical illustrations including text, 2D images, 3D graphics, table, text, and hyperlinks (for example,
a link to a movie file) to improve clarity and enhanced quality on the shopfloor.

• Easy update based on the most current planning data in Teamcenter, reducing rework and update
times.

• Batch processing and scheduling of reports.

• Familiar Microsoft Visio authoring environment allowing WYSIWYG editing.

Using Teamcenter Publish

To create or view work instructions using Teamcenter Publish, install Microsoft Visio before or after the
Teamcenter installation.

The administrator creates an alias file that determines the permissible contents of the documentation.
For example, if the administrator uses the default alias file, you can create work instructions and product
manuals, and a view for each of these is available.

When you first select a documentation view, Teamcenter loads the Visualization Illustration and Visio
components. Depending on your workstation, this process may take several seconds to complete and
Teamcenter displays a progress dialog box until it is complete.

Working with publishing tools

You can create publishing pages in the embedded viewer and collect them into portfolios. A typical
publishing page is a work instruction document, and a portfolio may contain all the work instructions
needed at a particular assembly station. By default after installation, Teamcenter provides you with
sample files. To use publishing tools in your environment, you must configure it to suit your needs.

Publishing pages are Visio files that are saved as datasets with the selected BOM line.

Visio documents are constructed using shapes that can appear as text and graphics. A rich library of
shapes are provided in the Visio installation.
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The Teamcenter publishing tools extend the shape library to include shapes called assets that you can
link to data in Teamcenter. Assets can display text, tables, images, or a link to a Microsoft Word file or
master form. For example, in Teamcenter you can configure a product assembly, view it, add markups,
and capture the graphics in a product view (snapshot) that you can then display in a 3D asset. If the data
in Teamcenter is subsequently updated, you can update the publishing page to show the changes.

You can organize collections of publishing pages into portfolios, which you can view, publish to HTML
for a Web server or publish to PDF, or print in My Teamcenter using the options that appear in the
Graphics view after you select the portfolio object. A portfolio can contain multiple work instructions,
generic pages, header and footer information, a table of contents, and cover and trailer pages.

Publishing page roles

Publishing page documents can be used for any number of purposes. By default, two roles are provided,
Work Instructions and, when a product structure is selected, Product Manual. Your database may be
configured to support any number of roles. This documentation refers to the Work Instructions role, but
the behavior of the pane is the same for each role.

Composing work instructions in publishing pages

Creating and editing publishing pages overview

When you first open the Work Instructions view, you see a blank page.

12. Creating, viewing, and editing work instructions
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You can immediately begin to create a work instruction on this page or you can load a template and
work from there.

The following is an overview of the process for creating a publishing page.

1. Add any static Visio shapes, text or graphics you need to the page.

2. Associate the page with an alias file.

Alias files tell Teamcenter what data to display in different assets on the page and how to find that
data. This step is optional; a default file is loaded.

3. Place the required assets on the page. These are placeholders. You can place the following objects
in a work instruction page, each embedded in an asset of the same name:

• Text that is bound to a property of an object in Teamcenter.

• Tables whose cells map to object properties in Teamcenter.

• 2D images (for example, BMP, GIF or JPEG files)

• 3D geometry assets

Creating and editing publishing pages overview
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These are objects that you create or view in the embedded viewer, such as a factory view or the
desired state of the product at a certain assembly station.

• 2D snapshots

These are dynamic objects that represent a 2D scene (a view of the base image and markups)
that are associated with a BOM line in your product structure.

• Links

You can create a link to a Microsoft Word file or text file.

4. Associate the asset with a transfer mode and an alias name.

The transfer mode and the alias tell Teamcenter how to find the data in the database that is
displayed in the asset.

5. (Optional) Save this page as a template for reuse.

6. Select one or more assets and an object in Teamcenter to populate the assets.

This step traverses the structure to find the desired data or files and places them in the selected
assets.

The objects used to populate assets depend on which structure line is selected.

Note:

Be careful when selecting new structures for populating assets. You must first click the Disable
response to selections button  and then select a different structure. If you do not, the scope of
the Work Instruction view changes and Teamcenter attaches the newly created work instruction
dataset to the newly selected structure.

Create a publishing page

1. Right-click the BOM line with which you want to associate the work instructions, for example, the
item revision of an assembly or operation, and choose Open with → Work Instructions.

The selected line is the scope for the work instruction that you create. The new work instruction is
attached to the line that you select here.

Note:

Be careful when selecting new structures. You must first click the Disable response to
selections button  then select a different structure. If you do not, the scope of the
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Work Instruction view changes and Teamcenter attaches the newly created work instruction
dataset to the newly selected structure.

2. From the menu commands in the Work Instructions view, choose File → New TI Dataset.

Teamcenter displays the New Dataset dialog box.

3. Type a name and description in the boxes at the bottom of the dialog box and click OK.

Teamcenter creates the new publishing page dataset.

4. To add data placeholders (assets) to the template:

Click To add

Data found in a text file attached to a structure line.

A collection of data found in various properties in tabular
form.

A link to a Microsoft Word file or a text file.

A 2D image or a 2D snapshot attached to a structure
line.

A 3D image attached to a structure line.

5. Drag these placeholders to the desired spot on the page, resizing if necessary.

6. Right-click the asset and choose Bind.

Teamcenter displays the Bind Table Placeholder dialog box.

7. Select the transfer mode and alias to use for the data to populate this asset and click OK.

Note:

The work instructions are attached to the BOM line with a IMAN_MEWorkInstruction
relation.

Connecting structure data to a publishing page

Binding assets overview

There are several different types of placeholders (assets) that you can place on a publishing page. Each
of these must be bound with data from a structure. When you bind the asset, the Bind dialog box

Binding assets overview
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contains a list of transfer modes and a number of choices, called aliases, from which you can select.
The choice you make for each asset defines how Teamcenter finds the data that is displayed in the asset
when you populate it.

Bind textual information

You can bind information found in the text field of an object's properties. You can enter free-form text
within the asset to complement the bound information. For example:

Operator must tighten &&SUM(<alias_1>)&& bolts with torque &&MAX(<alias_2>)&& and any 
other &&alias_3&&.

1. In the Work Instructions view, click .

Teamcenter creates a placeholder for the text on the work instruction page.

2. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

3. Click the Text Tool button  to add free-form text to the asset.

4. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Text Placeholder dialog box.

5. From the Transfer Modes list, select tcm_export transfer mode.

You can select only one transfer mode per text alias.

6. In the Aliases list, open the ObjectProperties entry and select the piece of textual information that
you want to embed. You can choose to manipulate the asset data using the list of simple formula.

Each piece of bound data is added to the end of the text asset. You may have to rearrange the
information after binding the data.

7. Click Add.

Tip:

• You can also type the binding directly into the text asset if you know the format.

• You can bind multiple times to create free-form text plus embedded text in one asset.
Switch back and forth between binding and typing free-form text by doing the following:
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• Click the Arrow Tool  button and right-click the text asset to access the bind dialog.

• Click the Text Tool button  and select the text asset to type free-form text.

8. Select the object in the structure view containing the text that you want to embed in the
Teamcenter window. For example, if you want to embed the description of a particular item
revision, select that item revision in the structure view.

9. In the Work Instruction view, with the text placeholder still selected, click the Populate Asset
button .

Teamcenter displays the specified text on the work instructions page.

Bind data to display in a table format

Use the table asset to embed multiple pieces of information about a selected object.

1. In the Work Instructions view, click .

Teamcenter creates a placeholder for the table on the work instruction page.

2. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

3. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Table Placeholder dialog box.

4. From the Transfer Modes list, select tcm_export transfer mode.

5. In the Aliases list, open the appropriate alias, and select the type of information you want in the
list and click the plus sign.

If you select multiple entries, the selected objects appear as columns of the table in the same order
as in the Aliases pane.

6. Click OK.

7. Select the revision in the structure view containing the objects that you want to embed in the
Teamcenter window. For example, if you want to embed the ID, name, and description of all
members of an assembly, select the assembly root structure in the structure view.

Bind data to display in a table format
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8. In the Work Instruction view, with the table placeholder still selected, click the Populate Asset
button .

Teamcenter displays the specified information on the work instructions page.

Bind linked data

To bind linked data, a dataset with a .txt file imported into it must exist. In addition, you must be able to
open this .txt file in an associated text editor.

1. In the Work Instructions view, click .

Teamcenter creates a placeholder for the link on the work instruction page.

2. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

3. Right-click the placeholder and choose Bind.

Teamcenter displays the Bind Link Placeholder dialog box.

4. From the Transfer Modes list, select the ExportGraphic transfer mode.

5. From the Aliases list, select LinkedDataset.

6. In the Attachment view, select the text dataset and click Populate in the Work Instructions view.

Teamcenter displays the link on the work instructions page.

Bind a 2D image

You can bind a 2D image that is attached to a revision.

1. In the Work Instructions view, click .

Teamcenter creates a placeholder for the image on the work instruction page.

2. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

3. Right-click the placeholder and select Bind.

12. Creating, viewing, and editing work instructions
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Teamcenter displays the Bind Image Placeholder dialog box.

4. From the Transfer Modes list, select ExportGraphic transfer mode.

5. In the Aliases list, open the 2DGraphic entry and select file.

6. Open the Attachments view.

7. Select the image that you want to embed.

8. In the Work Instruction view, with the image placeholder still selected, click the Populate Asset
button .

Teamcenter displays the selected image on the work instructions page.

Bind a 2D snapshot

If you embed a 2D snapshot, a 2D geometry asset must exist for it.

1. In the Work Instructions view, click .

Teamcenter creates a placeholder for the image on the work instruction page.

2. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

3. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Image Placeholder dialog box.

4. From the Transfer Modes list, select ExportGraphic transfer mode.

5. In the Aliases list, open the 2DSnapshot entry and select file.

6. Do one of the following to specify which 2D snapshot should be populated:

• In the Attachments view, select the snapshot.

• In the 2D Viewer view, open the 2D Snapshots Gallery dialog window and select an existing
snapshot.

• In the 2D Viewer view, arrange the snapshot. When you populate the asset, Teamcenter
automatically creates the snapshot for you.

Bind a 2D snapshot
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7. In the Work Instruction view, with the image placeholder still selected, click the Populate Asset
button .

Teamcenter displays the 2D snapshot on the work instructions page.

Note:

If you receive an error saying Failed to load Error document (2DSnapshot & file) when
populating a 2D asset, the 2D snapshot does not contain a 2D geometry asset.

Recapture the 2D snapshot with the option to capture 2D geometry asset data turned on.

Bind a 3D asset

1. Open a structure to which you want to attach a work instruction.

2. In the Work Instructions view, click the 3D Graphic button .

Teamcenter creates a placeholder on the work instruction page.

3. In the Work Instructions view, select File → Save TI Illustration.

You must save the work instruction once to create the dataset. If you do not save first, you receive
an error when populating the asset. Once the dataset exists, this step is no longer required, unless
you want to save changes to the work instruction page.

4. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Geometry Asset Placeholder dialog box.

5. From the Transfer Modes list, select ExportGraphic transfer mode.

6. In the Aliases list, open the 3DGeometryAsset entry and select file.

7. Do one of the following to specify which 3D geometry should be populated:

• In the Graphics view, open the 3D Product View Gallery dialog box, create a snapshot, then
select it.

Caution:

You must ensure that the Add or Update 3D Geometry Asset option is selected before
you create a snapshot.

• In the Attachments view, select the 3D snapshot.

12. Creating, viewing, and editing work instructions
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• In the Graphics view, arrange the snapshot. When you populate the asset, Teamcenter
automatically creates the snapshot for you.

8. In the Work Instruction view, with the placeholder still selected, click the Populate Asset button
.

Teamcenter displays the 3D geometry asset on the work instructions page.

Populate an empty asset

When you populate an asset, you associate Teamcenter data with it.

1. Select the asset.

2. Select the object in Teamcenter to which you want to link the asset.

3. Disable response to selections by clicking .

When selecting structures to populate assets, it is important to understand the role of the Disable
response to selections button. Clicking this button locks the view so that when you select a line in
a different structure, the scope of the view does not change and the work instruction dataset, when
created, is attached to the originally selected structure line. If the view is not locked (it responds to
selection), when you select a line in a different structure to populate an asset, the work instruction
dataset is attached to the newly selected structure line.

4. Click the Populate Asset button  or menu command.

Selecting structure lines for the populate action

When selecting structures to populate assets, it is important to understand the role of the Disable
response to selections button . Clicking this button locks the view so that when you select a line
in a different structure, the scope of the view does not change and the work instruction dataset, when
created, is attached to the originally selected structure line. If the view is not locked (it responds to
selection), when you select a line in a different structure to populate an asset, the work instruction
dataset is attached to the newly selected structure line.

Updating publishing pages

When an asset is populated, a reference to the selected Teamcenter populating object is stored in the
asset. If the data in Teamcenter changes, you can update the asset to show the changes. Updating is not
automatic; you must explicitly perform an update.

Take, for example, the TcPartList template’s table. Long after you create the publishing page and
populate the table asset, the product structure can be modified. Item names can change or BOM lines
can be added or removed from the line that was used to populate the table. After this happens, you can
update the publishing page to show the changes.

Populate an empty asset
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Update an asset

1. Open the page dataset in a publishing page viewer anywhere in Teamcenter.

2. Select the asset and choose Edit → Update Asset from the page viewer menu.

The new contents of the asset are displayed, along with a triangle indicating that the display shows
new (and so far unaccepted) data.

3. Switch between displaying the old and the new data by choosing Show Original Data and Show
New Data from the asset's shortcut menu. The asset is in an uncommitted state. You cannot
update the asset again or repopulate it while it is in this state.

4. Accept or reject the change by choosing Accept New Data or Accept Original Data from the
asset’s shortcut menu. All of the assets on a page can be updated at once using the publishing
page Edit → Update Technical Illustration menu. Other Edit menus let you toggle the display and
accept or reject the changes for all of the assets on the page at once.

Note:

You cannot update data in the database (other than the publishing page itself) by updating
an asset. Assets can only display what is already in the database. To update a 3D asset, you
must first update the snapshot dataset in the assembly viewer.

Repopulate an asset

An asset that has been populated can be repopulated with a different Teamcenter component.

1. Select the asset in the publishing page view.

2. Select the component in another view, and choose Edit → Populate Asset in the publishing page
view.

3. Switch between displaying the old and the new data by choosing Show Original Data and Show
New Data from the asset's shortcut menu. The asset is in an uncommitted state. You cannot
update the asset again or repopulate it while it is in this state.

4. Accept or reject the change by choosing Accept New Data or Accept Original Data from the
asset’s shortcut menu. All of the assets on a page can be updated at once using the publishing
page Edit → Update Technical Illustration menu command. Other Edit menus let you toggle the
display and accept or reject the changes for all of the assets on the page at once.

12. Creating, viewing, and editing work instructions
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Note:

You cannot update data in the database (other than the publishing page itself) by updating
an asset. Assets only can display what is already in the database. To update a 3D asset, you
must first update the snapshot dataset in the Graphics view.

View populating and end objects

The populating object is the one that was selected when the asset was populated. The end object is
the object that is actually displayed in the asset after it is populated. These can be the same object, or
different ones, depending on your alias definition.

You can view these objects.

1. Select the asset in the Work Instructions view.

2. Do one of the following:

• To show the populating object in My Teamcenter, choose Edit → Asset Components → Send to
My Teamcenter → Populating Components.

• To show the end object in My Teamcenter, choose Edit → Asset Components → Send to My
Teamcenter → End Object.

• To view the populating object in the default viewer without switching applications, choose
Edit → Asset Components → View Populating Components.

• To view the end object in the default viewer without switching applications, choose Edit →
Asset Components → View End Object.

Note:

These menu commands may not work depending on how the alias file is implemented. For more
information, contact your administrator.

Creating a publishing page template

Your site may provide publishing page templates whose content can be used as the starting point for the
creation of a new publishing page. A publishing page template is a publishing page dataset that is not
populated with actual data.

A page template may contain standard data such as a company logo, pictures, and required text. It may
also contain empty placeholders, whose content you must fill for each instance of a publishing page you
create from the template.

View populating and end objects
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You can classify templates in the Classification application for easy retrieval.

Create a publishing page from a template

1. If you know the name of the required template, type it in the Template name box.

If you do not know the name of the template, you can search the database for it. In the Templates
pane at the top of the dialog box, click the Find a Template by name button  next to the
Template name box.

Teamcenter displays the Find by Name dialog box, and you can search by part of the name and
with wildcard (*) characters.

If templates are classified, you can click Classification Search Dialog  to find the template you
require.

2. When you identify the publishing page you want to use as a template, double-click the name to
select it and return to the New Dataset dialog box.

3. (Optional) Click the Add To Favorites button to add the selected template to the list in the
Templates pane above it. Publishing pages for activities are tracked separately from other publish
pages.

4. (Optional) Click the Use as Default button to use the specified dataset as the default template if no
TI dataset is loaded.

5. In the File section, select Use Template.

6. Type a name and description in the relevant boxes.

7. Click OK.

Teamcenter creates the new publishing page dataset.

Create a new work instruction

1. Select the BOM line with which you want to associate the work instructions, for example, the item
revision of an assembly or operation.

2. Open the Work Instructions view.

3. In the Work Instructions view, choose File → New TI Dataset.

Teamcenter displays the New Document dialog box.

12. Creating, viewing, and editing work instructions
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4. If your site uses templates, select the name of a template, enter a dataset name, and click OK.

Note:

The work instructions are attached to the BOM line with a IMAN_MEWorkInstruction
relation.

Add new pages to the work instructions or product manual

• Choose Insert → New Page.

Teamcenter adds a new, blank page to the active work instructions or product manual. You can also
search for an existing page by name or use a Classification search to find a classified page.

Delete pages from the work instructions or product manual

1. Choose Edit → Delete Pages.

Teamcenter displays the Delete Pages dialog box containing a list of available pages.

2. Select the page to delete and click OK.

Teamcenter deletes the page from the work instructions or product manual.

Save changes to the work instructions or product manual

• Choose File → Save.

Teamcenter saves any changes that you made.

Reserve space for headers and footers

You reserve space for headers and footers on a publishing page. When you print or export the work
instructions or product manual, any shapes on the publishing page are clipped to the defined margins.

1. Open the work instructions.

2. Choose View → Page Margins.

Teamcenter adds a gray-shaded background at the top, bottom, left, and right of the page.

Add new pages to the work instructions or product manual
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Add export tags

You can add export tags to a page that are replaced with actual information when you print or export it.
For example, if you select page, the actual page number appears. Additional export tags include date,
long date, document file name, portfolio file name and total number of pages.

1. Open the work instructions or product manual.

2. Choose Insert → Portfolio Export Tag and select a tag from the displayed list. The tag you select
appears on the work instructions or product manual.

3. (Optional) Move or resize the export tag on the work instructions or product manual.

Navigate to another publishing page

Use one of the following methods to navigate to another publishing page:

1. Choose View → Page → Go to.

Teamcenter displays the Select Page dialog box.

2. Select the page to you want to navigate.

- or -

Use the navigation arrow buttons to browse through the available pages.

Export publishing pages to HTML

1. Choose File → Save as Web Page.

Teamcenter displays the Save As dialog box.

2. Type a name for the exported file and click Save.

Teamcenter displays the Save as Web Page dialog box.

3. Change settings for the following options:

12. Creating, viewing, and editing work instructions
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Tab Options Description

General tab Pages to Publish Choose Select All to print all pages or Select
Pages from and then type the page span.

Publishing options Select any of the publishing options, which
appear in the finished Web page to aid
navigation and searching.

Additional options Choose any of the following:

• Automatically open Web page in browser

• Organize supporting files in a folder

• Type text in the Page title box to name the
exported HTML output.

Advanced tab Output formats Select a format for the HTML output.

Provide alternate format
for older browsers

Choose a format from the list.

Target monitor Choose the monitor size.

Host in Web page Select a Web page from the list or browse to a
file.

Style sheet Select a style sheet from the list or browse to a
file.

4. Click OK.

Teamcenter displays the publishing pages as a Web page in your default browser.

Export publishing pages to PDF

You can print a portfolio to PDF in My Teamcenter. Before you do this, you must install third party
software capable of creating PDF output.

1. Create a portfolio.

2. Open My Teamcenter.

3. In the File menu on the viewer tab, choose Publish PDF to Database.

Export publishing pages to PDF
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Detach the Work Instructions tab

Detaching the Work Instructions tab allows you to change the source of the assets. Until you detach
this tab, all assets that you populate pertain to the originally selected structure line.

1. Right-click the tab on the data pane.

2. Choose Detach data tab.

Teamcenter separates the tab as a floating window on top of the application that you can enlarge
and reposition as necessary.

The detached tab remains visible unless you delete the component tracked by the tab or select
another component in the navigation tree. You can also close the detached window manually by
clicking the x button in the corner of the window. Teamcenter does not remember the selection of
detached tabs between sessions.

Collecting work instructions in a portfolio

About portfolios

Portfolios act as a container for work instructions or product manuals and supporting documents,
such as a table of contents, cover or trailer pages, and header and footer information. Portfolios may
contain a reference to a publishing page or generic page or to an embedded generic page. You can use
portfolios to store document structure information, print multiple publishing pages, and export portfolio
contents to HTML or PDF.

You generate portfolios in Manufacturing Process Planner, Part Planner, Multi-Structure Manager, Service
Planner, or Plant Designer. You manage portfolios in My Teamcenter only.

When managing a portfolio:

• Use container nodes to add an organizational hierarchy to the portfolio. Think of container nodes as
chapters in a book, in which you can separate and group documents. Container nodes are useful for
multiple levels in the table of contents.

• During printing operations, Teamcenter creates the table of contents information in a dynamic page.

• Create generic pages for any information page to add to the portfolio, such as cover or trailer pages.
Generic pages are not considered publishing pages and Teamcenter does not apply headers and
footers to them.

• Add header and footer information to portfolios by creating a special page. Teamcenter copies the
shapes in this page to the published pages during printing and export operations. The same header
and footer appears on every page.

12. Creating, viewing, and editing work instructions
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• When adding supporting documents to portfolios, choose from the following options:

• Insert Reference

Select a supporting document for the portfolio to reference.

• Create

Add a new supporting document that Teamcenter embeds in the portfolio. You can only create and
embed generic pages.

• Embed

Copy a supporting document into the portfolio.

Create a portfolio

1. Select the BOM line to which you want to associate the portfolio, which may be a configured item
or process revision or occurrence in the structure. The portfolio contains the publishing pages that
are attached to the BOM line’s child lines.

2. In the Teamcenter window, choose Tools → Generate Portfolio.

Teamcenter displays the Generate Technical Portfolio dialog box.

3. In the dialog box, enter a name and select a role such as Work Instructions and click OK.

Teamcenter creates a portfolio dataset that contains all of the appropriate pages. The portfolio
is created under an intermediate data capture (IDC). If a structure context is opened, the IDC is
attached to the structure context. Otherwise it is stored in the New Stuff folder.

4. (Optional) To view the portfolio, select it in My Teamcenter and click the viewer tab.

Tip:

Note the menu and toolbars in the Graphics view. These commands help you manage
portfolios.

Create container nodes

You can create one or more container nodes in the portfolio in My Teamcenter in the viewer.

1. Select the portfolio  in the Newstuff folder in My Teamcenter.

Teamcenter opens the viewer.

Create a portfolio
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2. Using the menu commands within the Viewer view, do one of the following:

• Choose Actions → Create and select Container Node.

• On the Technical Portfolio toolbar, click the Create container button .

Create the table of contents

You can create the table of contents for a portfolio in My Teamcenter in the viewer.

1. Select the portfolio  in the Newstuff folder in My Teamcenter.

Teamcenter opens the viewer.

2. Using the menu commands in the viewer, do one of the following:

• Choose Actions → Create and select Table of Contents Placeholder.

• On the Technical Portfolio toolbar, click the Create table of contents button .

Add a generic page

You can add a generic page to a portfolio in My Teamcenter in the Portfolio pane.

1. Select the portfolio  in the Newstuff folder in My Teamcenter.

Teamcenter opens the Portfolio pane.

2. Select an area to place the generic page.

3. Using the menu commands within the Portfolio pane, do one of the following:

• Choose Actions → Create, Actions → Insert Reference or Actions → Embed, and select
Generic Page.

Note:

You cannot search using the classification search if working in My Teamcenter.

• On the Technical Portfolio toolbar, click the Create generic page button .

12. Creating, viewing, and editing work instructions
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Create a header and footer page

You can create a header and footer page in a portfolio in My Teamcenter in the viewer. Teamcenter
copies the shapes in this page to the published pages during printing and export operations. The same
header and footer appears on every page.

1. Select the portfolio  in the Newstuff folder in My Teamcenter.

Teamcenter opens the viewer.

2. Select an area in the portfolio to place the header and footer page.

3. Using the menu commands within the viewer, do one of the following:

• Choose Actions → Create, Actions → Insert Reference or Actions → Embed, and select
Header/Footer Definition Page.

• On the Technical Portfolio toolbar, click the Create header/footer data button .

Teamcenter opens a new viewer window with a blank page.

4. Using the commands in the new window, choose t Insert → Portfolio Export Tag and select one of
the following:

• Date

• Long Date

• Document File Name

• Portfolio File Name

• Pages

• Total Number of Pages

Teamcenter creates a placeholder for the object on the page.

5. Move the placeholder to the desired position.

6. When you have placed all desired export tags, choose File → Post to Technical Portfolio.

7. Click Close.

8. In the viewer, click File → Save.

Create a header and footer page
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Modify header and footer information

1. Select the portfolio  in the Newstuff folder in My Teamcenter.

Teamcenter opens the viewer.

2. Right-click the header and footer page in the portfolio tree and choose Open.

3. Make any necessary changes.

4. Choose File → Post to Technical Portfolio.

5. Click Close.

6. In the viewer, click File → Save.

Add a work instruction

1. Select an area in the portfolio to place the work instructions.

2. Do one of the following:

• Choose Actions → Insert Reference and select Technical Illustration.

• On the Technical Portfolio toolbar, click the Technical Illustration button.

The system displays the Insert Page dialog box.

3. Click the Find a page by name button and type the name of the work instruction that you want to
add.

4. Click Open. The work instruction you chose appears in the tab.

Publish a portfolio to HTML

You can publish a portfolio on a Web server by exporting its contents in HTML format. This allows
consumer users access to work instructions or product manuals from any Web browser.

1. Choose File → Publish Zip to Database.

The system displays the Publish to HTML Options dialog box.

2. Edit the export options in these ways:

12. Creating, viewing, and editing work instructions
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Tab Options Description

General tab Destination Folder Specify the destination folder where the
export data is written by clicking Save.

Note:

Specifying the destination folder is
the only required selection in this
dialog box. All other options in
this dialog box are discretionary
selections.

Create zip file Create a ZIP file of all export data. Click the
Browse button to specify the location of
the ZIP file. Use this option to allow users
without access to Teamcenter to view the
data.

Use title page
template

Use a template file for the main HTML title
page. Click the Browse button to choose
the HTML file.

Replace or remove
logo

By default, the HTML output includes the
Siemens Digital Industries Software logo.
To replace the default Siemens Digital
Industries Software logo graphic, click the
Browse button to locate a replacement
graphic. To remove the default Siemens
Digital Industries Software logo graphic,
click the Remove button.

Export
Options tab

Stop if error occurs Stop the export operation if an error is
encountered.

Produce flat output Remove the portfolio structure and
document hierarchy.

Publishing options Indicate specific control panes to be
included in the HTML output for each
published page.

• Choose Show Details to display custom
shape properties.

• Choose Go to Page to include navigation
for multi-page work instructions or
product manual.

Publish a portfolio to HTML
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Tab Options Description

• Choose Search to enable the ability to
search shapes.

• Choose Pan and Zoom to enable
panning and zooming on a page.

Note:

The Publishing Options option is
only applicable if you select VML
for the Output format (VML is the
default). VML output only displays
Publishing Options if you use the
Internet Explorer browser.

Advanced
Options tab

Output formats Choose the primary output format for the
exported published pages.

Provide alternate
format for older
browsers

Indicate a secondary output format for
exported published pages, used for older
browsers.

Display options Select a target monitor size.

3. Click OK.

The Report Definition wizard displays the status of the export operation.

Note:

Name lists the supporting documents in the portfolio; Status indicates if the supporting
documents were exported.

4. Click Next.

The system displays the Create Report Output dialog box.

5. Create a standard or custom report output format.

Publish a portfolio to PDF

You can create a PDF file from the portfolio that is attached as a dataset provided you have Microsoft
Office installed.

1. Select the portfolio  in the Newstuff folder in My Teamcenter.
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Teamcenter opens the viewer.

2. Using the menu commands in the viewer, choose File → Publish PDF to Database

Teamcenter creates the PDF and attaches it to the portfolio dataset. You can view it in the viewer.

Processing multiple documents at once

Creating work instructions and portfolios in batch mode

You can create and update Teamcenter work instructions and portfolios in batch mode, processing
multiple documents using the Teamcenter Publish Batch dialog box. You do not need to process
individual documents manually. You can schedule these tasks to take place immediately or at a later
date.

Batch processing uses the Dispatcher infrastructure for scheduling create and update features.
Additionally, Dispatcher has built-in status, logging, and error reporting features.

Create or update publishing pages in batch mode

1. Select one or multiple lines in a structure.

These objects are typically processes, operations, items, or activities that can have publishing pages
associated with them. You can select one or more Teamcenter objects for direct batch processing or
specify that each object is to be treated as a root object and its children traversed.

2. In Service Planner, choose Advanced → Publish Batch.

Teamcenter opens the Publish Batch dialog box.

3. Enter the parameters for the Set Role and Scope step.

a. Select the paste relation used between the new page and its associated end object from the
Publishing Page Role list.

The roles available are set in the TCPUBLISH_BATCH_ROLE preference.

This information is required.

b. Select the type of action you want to perform from the Batch Task section.

• Select Create and Update to initiate a create task with an update option. The batch task
creates pages where they do not exist and updates pages that do exist.

• Select Update Only to only update existing pages.

Creating work instructions and portfolios in batch mode
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c. Specify the scope of the page creation in the Batch Process Scope section.

• Select Process entire structure to have the create task traverse the entire structure of each
selected structure, even if a child line of a structure is selected.

• Select Process selected lines to create a page for the selected object(s) only. If you want
to create a page for the selected object and all its child objects, additionally select Process
selected lines substructure.

4. Enter the parameters for the Set Update Parameters step.

• Select Update All to:

• Generate all missing pages.

Teamcenter generates a new page for each new object it encounters.

• Update populated assets.

Teamcenter checks that all assets display the most current data.

• Populate unpopulated assets.

Teamcenter associates data with any empty assets.

• Process all asset types.

Teamcenter performs these activities on all asset types found in the work instruction.

• Select Selective Update Options to only perform specific update actions.

5. Associate classes with templates in the Select Types and Templates step.

The Mark class types to process list displays the types of objects that can have publishing pages
associated with them.

The Mark templates to be used with list contains templates that you associate with a class or type
by selecting both the class and the template.

If you select None in the templates list, the class or type is not processed.

A type level association overrides the class level definition.

6. (Optional) Add more templates to the templates list.

a. Click Add Templates.

12. Creating, viewing, and editing work instructions
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b. Type a template name in the Template Name box.

c. Click Search by Name to search in the database for a template or Search by Class to search
the classification hierarchy for a classified template.

d. (Optional) If you are going to use this template repeatedly, add it to a favorites list by clicking
Add to Favorites.

e. Do one of the following:

• Click Add to add the current selection to the Mark templates to be used with class/type
list.

• Click OK to close the dialog box and keep changes to the favorites list.

• Click Cancel to close the dialog box without keeping changes to the favorites list.

7. (Optional) Enter the parameters for the Define Portfolio Parameters step.

A portfolio is a container for work instructions. You can use portfolios to store document structure
information, print multiple publishing pages, and export portfolio contents to HTML.

a. Select Generate a Portfolio.

b. Type a name for the portfolio in the Portfolio Name box.

c. Type a description of the portfolio in the Portfolio Description box.

d. (Optional) Select Use a template to select a template from the database.

For more information about using templates, see step 6.

8. Enter the parameters for the Schedule the Batch Process step.

You can schedule the batch process for a specific date and time.

• Select Immediate to initiate the task at the current date and time. Clicking Finish on any page
without previously selecting scheduling parameters also initiates the task immediately.

• Select Scheduled to select a specific start date and time.

• Select Periodical to schedule a task that recurs at a specific date and time. You can specify a
recurrence pattern on a daily, weekly, monthly, or yearly basis.

9. Click Finish.

Create or update publishing pages in batch mode
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Update a portfolio in batch mode from My Teamcenter

You can schedule a portfolio for updating in batch mode in My Teamcenter.

1. Open My Teamcenter.

2. Right-click a portfolio dataset and choose Batch Update Pages.

Teamcenter opens the Publish Batch dialog box where you can schedule the batch process for a
specific date and time.

3. Enter the parameters for the Schedule the Batch Process step.

• Select Immediate to initiate the task at the current date and time. Clicking Finish on any page
without previously selecting scheduling parameters also initiates the task immediately.

• Select Scheduled to select a specific start date and time.

• Select Periodical to schedule a task that recurs at a specific date and time. You can specify a
recurrence pattern on a daily, weekly, monthly, or yearly basis.

12. Creating, viewing, and editing work instructions
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Update a portfolio in batch mode from My Teamcenter
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13. Sharing Service Planner data
Export Service Planner data

A user such as a production planner can export Service Planner data from Teamcenter to other
Teamcenter sites or third-party systems.

Exporting Service Planner data

You can export the following Service Planner objects in PLM XML format:

• Service plan (with schema extension)

• Service requirement (with schema extension)

• Work card (with schema extension)

• Activity (no schema extension)

• Fault code (with schema extension)

• Notice (with schema extension)

• Skill (with schema extension)

1. Select the object to be exported.

2. Choose Tools → Export → To PLMXML.
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The system displays the PLMXML Export dialog box.

3. In the Export Directory box, select the directory in which to place the PLM XML file. Click Browse
to locate the directory.

4. Specify the name of the export file in the Export Filename box.

5. Select the ServicePlanningDataExport transfer mode from the Transfer Mode Name list. to
export service planning data.

6. (Optional) Click Select Languages to display the Language Selection dialog box for the languages
configured at your site.

a. Main Language is the site master language. This cannot be changed.

b. The Available Languages box lists the languages you can select as additional languages for
export.

c. The Select Additional Languages box lists the preconfigured languages for the selected
transfer mode.

d. To select additional languages for export, follow these steps:

A. Select a language in the Available Languages box.

B. Click the Add button .

i. The selected language is added to the Selected Additional Languages box.

ii. To reorder the languages in the Selected Additional Languages box, select a
language and use the move   buttons as required.

C. Click OK or Apply.

The languages selected for export are displayed in the Languages box.

Note:

If you change the transfer mode, the Languages entries remains unchanged. You can
use the Language Selection dialog box again to add or remove more languages.

7. (Optional) Select a revision rule to configure the assembly to be exported.

8. If you do not apply a revision rule, only the parent item revision is exported.

13. Sharing Service Planner data
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9. (Optional) Select Open PLM XML File to view the file when the export operation is complete.

10. (Optional) Select the View Log File check box to view the log file when the data translation is
complete.

11. (Optional) Select the Perform Export In Background check box to perform an asynchronous
export.

12. Click OK to export the objects in the Object List and close the dialog box.

Import Service Planner data

A user such as a production planner can import Service Planner data from Teamcenter to other
Teamcenter sites or third-party systems.

Importing Service Planner data

You can import Service Planner data into Teamcenter from any third-party system if it conforms to the
PLM XML schema.

Refer to the following table for PLM XML elements and the associated Teamcenter Service Planner
classes.

PLM XML element Teamcenter class

ServicePlan SSP0ServicePlan

ServicePlanRevision SSP0ServicePlanRevision

OccurrenceGroup SSP0ServicePartition

Import Service Planner data
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PLM XML element Teamcenter class

ServiceRequirement SSP0ServiceReq

ServiceRequirementRevision SSP0ServiceReqRevision

WorkCard SSP0WorkCard

WorkCardRevision SSP0WorkCardRevision

Frequency SSP0Frequency

FrequencyRevision SSP0FrequencyRevision

FaultCode FaultCode

Skill SSP0Skill

SkillRevision SSP0SkillRevision

Warning Smr0Warning

PartApplicabilityRelation SSP0PartApplicabilityData

1. Choose Tools → Import → From PLMXML.

The system displays the PLMXML Import dialog box.

2. Click Browse  to the right of the Importing Object box.

The Select Object dialog box appears.

3. Select PLM XML File (.xml) from the Files of type list.

4. Navigate to the directory containing the file and select the file.

The system displays the file name in the Directory name box.

5. Click Select.

The system displays the path to the selected file in the Importing Object box of the dialog box.

6. Select the transfer mode to be used to configure the import operation.

Note:

The ServicePlanningDataExport transfer mode is provided with Service Planner for
importing service planner data from a third party into Teamcenter.

13. Sharing Service Planner data
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7. (Optional) Select the View Log File check box to view the log file when the data transfer is
complete.

8. Click Apply to start the import operation and retain the dialog box, or click OK to start the import
operation and exit the dialog box.

The system imports the data as follows:

• By default, the imported object has no container reference. You can use relevant search criteria
to find the imported object and so you can copy it to a folder.

• To have Teamcenter import objects into your Newstuff folder, create the
PLMXML_put_objects_in_newstuff_on_import preference and set the value to TRUE. Imported
objects are placed in a folder with the same name as the imported XML file.

Note:

If object names or IDs are encountered that exceed the character limit for those fields in
Teamcenter, the name and/or ID is truncated when imported in to Teamcenter. Teamcenter
provides 128 bytes for item IDs and names.

Exchanging Service Planner data using Multi-Site Collaboration

Using Multi-Site Collaboration, you can share Service Planner data between multiple Teamcenter sites.
Each Teamcenter site has its own independent database with its own set of users and groups, data
model, business rules, and business processes.

Data sharing is done through object replication where an exact copy of an object is made at a remote
site using remote export and import functions. The replicas are synchronized when the master copy is
modified.

Exchanging Service Planner data using Multi-Site Collaboration
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The Object Directory Services server (ODS) site maintains a record of each object in the entire Multi-Site
Collaboration network.

The Integrated Distributed Services Manager (IDSM) provides the mechanism used to export an object
from the owning site, transmit it over the network, and import it into the destination site.

When you export Service Planner data using Multi-Site Collaboration, Data Exchange also exports the
relations and the related objects. The table summarizes which relations and corresponding related
objects are exported for each Service Planner object.

Exported Service
Planner object

Exported relation Exported related
object

Service plan (with
schema extension)

PS Occurrence Service requirement

SSP0ServicePlanForNeutralProduct Neutral item

Occurrence Group Service partition

Service requirement
(with schema extension)

PS Occurrence Work card

PS Occurrence Frequency

SSP0PartApplicability Neutral item

SSP0Satisfies Service requirement

13. Sharing Service Planner data
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Exported Service
Planner object

Exported relation Exported related
object

SSP0Requires Service requirement

SSP0Resolves Fault Code

PS Occurrence Skill

Work card (with schema
extension)

PS Occurrence Activity

SSP0HasWarning Notice

SSP0UpgradedConfiguration Structure context

PS Occurrence Skill

SSP0CollectsData Characteristic
definition

Activity (no schema
extension)

SSP0CollectsData Activity

Characteristic
definition

Fault code (with schema
extension)

SSP0Resolves Neutral part

Notice (with schema
extension)

Skill (with schema
extension)

Tag Discipline

Exchanging Service Planner data using Multi-Site Collaboration
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