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1. Service Lifecycle Management
Service Manager

Capitalize on the re-use of product knowledge from engineering and manufacturing to improve service
planning and execution. Provide feedback to engineering to improve product designs for serviceability
and reliability. Communicate and coordinate operational activities for greater compliance, faster service,
and lower costs.

Service Lifecycle Management products

Select a link below to access the help documentation for each product.

Service Lifecycle Management on web client

Service Engineering

Service Work Instruction

As-Built Manager
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Service Planner

Maximo Integration

Microservices for Service Lifecycle Management Integration

1. Service Lifecycle Management
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2. What's new in Teamcenter Service
Manager
What's new in Service Manager 2412

The disposition history displays the latest record of disposition. Additionally, if you are a production
planner, you can use the Dynamic Equivalence preference to compare one structure to another.

• The disposition history shows the latest record of disposition with Start Time as the selected time. For
more details, refer to What is disposition data?

• As a production planner, you can use the Dynamic Equivalence option to compare the structures
according to the list of properties specified under the preferences. For more details, see the following:

• Comparing structures with Dynamic Equivalence

• Matching Equivalence criteria

• Equivalence and partial match criteria preferences

• Compare neutral structure with physical structure

What's new in Service Manager 14.3

• If you rebase a physical structure, certain child parts are not identified as missing. The child parts
that are not serialized and whose lot property is set to false are not considered to be missing.

• In some implementations, you may need to use occurrence-specific properties to identify part status
after you rebase the physical structure.

• If you rebase the physical structure to a different neutral structure, Service Lifecycle Management
updates any occurrence specific properties that exist in both the initial neutral structure and the new
neutral structure.

What's new in Service Manager 14.1

• Beginning with Teamcenter 14.1, when you create an as-maintained structure from a neutral
structure, you can control the display of parts that have a quantity greater than one, in the
new structure. This becomes especially important when you work on very large structures and on
structures imported into Teamcenter from a CAD system.
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For example, a wheel assembly includes multiple nuts. When the structure is imported, each nut
is represented by a single line in the neutral structure. The existence of multiple lines for one part
clutters the structure, making it difficult to find specific parts throughout the structure.

• Create part logistics form with plf_attach utility.

What's new in Service Manager 13.2

• Teamcenter Environment Manager (TEM) is deprecated and will be obsolete in a future version of
Teamcenter.

• You now can create as-maintained structures from configured neutral structures in Service Manager.

• New in Teamcenter 13.2, you can rebase a physical part. Rebasing relates a released as-maintained
structure to a different configuration of a neutral structure. The new rebased structure uses the new
configuration for its structure context.

What's new in Service Manager 13.1

• The Service Manager user interface is enhanced in Teamcenter 13.1 so that you can easily record a
utilization against the new logical and textual observation characteristics.

2. What's new in Teamcenter Service Manager
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3. Getting started with Service Manager
Getting started with Service Manager

The Service Manager application supports as-maintained structure management and service event
management capabilities within Teamcenter. As-maintained management is the base functionality of
Service Manager and allows you to manage the as-maintained configuration of an asset over its lifetime.
As-maintained structures are generated from, and validated against, product definition structures, such
as design or planning structures. You can use the Service Manager as-maintained management to:

• Create the as-maintained physical product instantiation for any configured product definition
structure.

• Store and manage additional information about the as-maintained physical part structure that is not
tracked on the product definition structure, such as serial numbers and lot numbers.

• Reconcile the as-maintained structure with a configured product definition structure to identify parts
that are missing, alternates, substitutes, or deviations.

• Track part utilization, part usage, and disposition history.

• Manage physical locations and the assets in those locations.

• Manually update the as-maintained structure with changes that occur over the lifetime of the physical
asset.

• Compare the as-maintained structure to the product definition structure or to another as-maintained
structure.

• View the as-designed product structure and the as-maintained physical structure configuration side-
by-side or by using the embedded viewer available in the rich client.

• Import an as-maintained structure from an external manufacturing execution system (MES) or an
enterprise resource planning (ERP) system in PLM XML.

• Manage as-maintained structures in a Multi-Site Collaboration environment.

Service Event Management is a separately licensed extension of the Service Manager application that
allows you to manage service events that affect the as-maintained configuration. You can use Service
Manager with the Service Event Management extension to:

• Define service group structures to efficiently identify maintenance events that have occurred on an
asset.

• Record service events, such as an inspection, overhaul, repair, or other type of service.
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• Maintain service history by recording service event data such as work scope, approval, resource
information, maintenance times, and cost.

• Record and track part discrepancies and failures and the associated corrective action service events.

• Record part movement transactions such as install, uninstall, and replace for both tracked and
nontracked parts.

• Record utilization information (life, date, and observation characteristic values) on service events and
apply these values to the as-maintained structure upon approval of these service events.

• Apply configuration updates to the as-maintained structure driven by approved service events.

Before you begin

Prerequisites The Service Manager application and the Service Event
Management extension require separate licenses in addition
to the standard Teamcenter product license. You must obtain
and install the appropriate licenses required to run the Service
Manager application (as-maintained management) and the
Service Event Management extension.

Enable Service Manager Service Manager does not need to be enabled before you use
it, but you must select the appropriate components during
installation.

If you have trouble accessing Service Manager, see your
system administrator; it may be a licensing issue. The Service
Manager application (as-maintained management) and the
Service Event Management extension each require separate
licenses in addition to the standard Teamcenter product
license.

Configure Service Manager There are additional steps you must perform to configure
Service Manager before you can use it.

Start Service Manager Click Service Manager  in the navigation pane.

Install local HTML documentation

Siemens Digital Industries Software gives you the ability to install HTML documentation locally. By
installing the Siemens Documentation Server, you can host HTML documentation for multiple
languages on your local host or intranet.

There are four basic steps in the process:

3. Getting started with Service Manager
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• Access the local HTML help installation instructions on the Siemens Support Center.

Warning:

You must follow those instructions to perform these next three steps.

• Download the Siemens Documentation Server from the Siemens Support Center and install it.

Note:

Installing the Siemens Documentation Server does not automatically give you access to the
product documentation. You must download and install the product documentation after
installing the documentation server.

• Download the documentation zip file you need from the Siemens Support Center.

There is one zip file that contains the documentation for Service Lifecycle Management on
Teamcenter (docs-service-lifecycle-management-teamcenter-2412-en-US.zip) and one zip file that
contains the documentation for Service Lifecycle Management on Active Workspace (docs-service-
lifecycle-management-active-workspace-2412-en-US.zip).

The zip files are in the Downloads area of their respective products. Be sure to download the
appropriate zip file for your needs.

Caution:

You must download and install the English documentation package before installing the
documentation package of any other language.

• Install the HTML documentation using the installer in the zip file.

Access the local help installation instructions

The instructions for installing the documentation server and the documentation are contained in a
single document stored on the Siemens Support Center. It can be viewed in HTML format from the
Siemens Support Center or downloaded in PDF format.

1. Log on to the Siemens Support Center.

Install local HTML documentation
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If you do not have an account, click Register Now and fill out the information.

2. Once on Siemens Support Center, click Manage Products.

3. Scroll down and toggle On the Siemens Documentation Installer product.

3. Getting started with Service Manager
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The installer is added to your list of products.

4. Scroll back to the top and click Support Center in the bread crumb, to go back to see the products
you are tracking.

5. Click the Siemens Documentation Installer box.

6. Click Documentation.

Install local HTML documentation
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If you see a message about selecting a product version, click the X in the upper right to close the
message window.

7. In the drop-down list on the right, select the most recent Siemens Documentation Server listed.

8. Click the installation guide for your operating system.

The HTML version is displayed.

3. Getting started with Service Manager
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9. To view or download the PDF version, in the upper right, click View Document PDF.

10. Now, using either the HTML or PDF version, follow the instructions to download and install the
documentation server and documentation.

Install local HTML documentation
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Service Manager interface

Service Manager perspective

1 Teamcenter component pane Shows the Teamcenter folders and components.

2 Service Editor pane Allows you to view data about the selected line. To display
a different data pane, click its tab.

3 Service details and utilization
pane

Allows you to view the service details and utilization for the
selected line.

4 Physical part and disposition
history pane

Allows you to view the physical part and disposition history
for the selected line.

Service Manager uses the Teamcenter rich client interface and provides the Service Editor view. The
interface items for Service Manager are described in the Service Manager menus, buttons, and symbols
topics.

Not all of the following menu commands and buttons may be available on your system, as the
administrator can hide or reveal only those commands and buttons that are appropriate for your site.

3. Getting started with Service Manager
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Service Manager menus

File menu

Command Description

New → Item Creates a new item.

New → Folder Creates a new folder.

New → Dataset Creates a new dataset.

New → Workflow Process (Ctrl+P) Creates a new workflow process.

New → Log Book Creates a new log book.

New → Life Characteristic Creates a new life characteristic for a neutral part.

New → Date Characteristic Creates a new date characteristic for a neutral part.

New → Observation
Characteristic

Creates a new observation characteristic for a neutral part.

New → Physical Location Creates a new physical location.

New → Asset Group Creates a new asset group.

New → Disposition Type Creates a new disposition type.

New → Fault Code Creates a new fault code.

Note:

This menu command is available only if the Service Event
Management extension for Service Manager is installed
and licensed.

New → Service Discrepancy Creates a new service discrepancy.

Note:

This menu command is available only if the Service Event
Management extension for Service Manager is installed
and licensed.

New → Activity Entry Value Creates a new activity entry value.

File menu
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Command Description

Note:

This menu command is available only if the Service Event
Management extension for Service Manager is installed
and licensed.

New → Service Event Creates a new service event.

Note:

This menu command is available only if the Service Event
Management extension for Service Manager is installed
and licensed.

New → Service Group Creates a new service group.

Note:

This menu command is available only if the Service Event
Management extension for Service Manager is installed
and licensed.

New → Part Movement Creates a new part movement.

Note:

This menu command is available only if the Service Event
Management extension for Service Manager is installed
and licensed.

Duplicate As-Maintained
Structure

Creates a duplicate of the as-maintained physical structure.

Close Closes the Service Manager application.

Open (Ctrl+O) Opens the selected structure.

Exit Ends the rich client session.

3. Getting started with Service Manager
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Edit menu

Command Description

Cut (Ctrl+X) Marks the selected lines for removal and copies the content to
the clipboard. Cut lines are only removed once pasted elsewhere
in the structure.

Copy (Ctrl+C) Copies the selected lines to the clipboard.

Paste (Ctrl+V) Inserts the Clipboard contents below the selected item.

Paste Special Allows you to specify a relation type rather than using the
default paste relation when pasting an object reference into an
item or item revision.

Delete Deletes the selected object from the database.

User Setting Displays the User Settings dialog box, where you can change
your group, role, or volume assignments, and your application
logging and journaling options.

Options Changes your user interface settings that affect all applications,
not only Service Manager.

Toggle In-Context Mode Enables or disables editing in context mode, allowing creation of
absolute occurrences for the selected assembly.

View menu

Command Description

Properties (Alt+Enter) Shows the properties for the selected object.

Refresh (F5) Updates the information displayed for a selected line and all of
its children.

Refresh Window Synchronizes the currently displayed Service Manager structure
with the database. The displayed structure refreshes with
changes that have been made in other sessions and saved since
you loaded the currently displayed Service Manager structure.

Show Data Panel Shows or hides the data pane containing, for example,
properties data or the embedded viewer.

Show/Hide Second Structure
Panel

Shows or hides a second structure pane below the first. You can
set the size of each structure pane by moving the horizontal
split bar between the panes. If the second structure pane is
displayed, this command hides the lower pane.

Edit menu
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Command Description

Show/Hide Collaboration Panel Shows or hides the collaboration panel.

Expand Expands the substructure immediately below the selected lines.

Expand Below Expands the complete substructure below the selected lines.

Expand Below... Expands the substructure below the selected lines to a user-
selected level. You can also collapse an expanded substructure
when you choose this option (hide certain child lines).

Collapse Below Collapses the complete substructure below the selected lines
(hide all child lines).

Pack (Ctrl+Shift+M) Packs the selected lines so that all lines with the same item
revision and find number are displayed as a single line. The
actual quantity of lines appended to the node.

Unpack (Ctrl+Shift+N) Unpacks the selected packed lines so that they are displayed as
separate lines, one for each occurrence.

Pack All Packs all packable lines in the displayed structure.

Unpack All Unpacks all packable lines in the displayed structure.

Show Unconfigured Variants Shows or hides unconfigured variant components.

Show Unconfigured Assigned
Occurrences

Shows assigned objects that were configured out by the variant
rules of the structures from which the objects were assigned.
You can only use this command with composition structures.

Note:

This command does not automatically refresh. Any
changes to the assigned objects are not reflected in the
structure until you run this command again.

Show Unconfigured Changes Shows unconfigured changes. If you hide unconfigured changes,
only those changes configured by the current revision rule are
visible.

Show Unconfigured By
Occurrence Effectivity

Shows or hides components that are not configured when using
occurrence effectivity.

Show Untraced Parts Shows or hides the neutral parts that are not traceable in the
physical structure.
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Tools menu

Command Description

Check-In/Out → Check-Out Checks a selected component out of the database.

Check-In/Out → Check-In Checks a selected component into the database.

Check-In/Out → Cancel Check-out Cancels a request checkout action.

Check-In/Out → Transfer Check-
out

Transfers a selected, checked-out component to another user.

Check-In/Out → Notification List Allows you to view or edit the list of users who are informed if
the selected component is checked in or checked out.

Check-In/Out → Check-Out History Allows you to view the history of checkout actions for the
selected component.

Id Display Rule → View/Set
Current

Allows you to view the ID display rule currently applied to the
selected structure or set a different ID display rule.

Id Display Rule → Modify Current Modifies the ID display rule currently applied to the selected
structure.

Id Display Rule → Create/Edit Creates a new ID display rule or modify an existing ID rule.

Revision Rule → View/Set Current Allows you to view or set the revision rule for the currently
displayed structure.

Revision Rule → Set Date/Unit/End
Item

Sets the date, unit number, or end item to configure the
structure, if the current rule allows.

Revision Rule → Set Override
folder

Sets an override folder to override item revisions that would
otherwise be selected by other criteria.

Revision Rule → Modify Current Modifies the current revision rule and apply the modified rule to
the current structure. You can save the change if you have write
access to the original rule.

Revision Rule → Create/Edit Creates or edits a revision rule.

Variants → Configure Variants Allows you to configure or edit a variant structure for the
selected top-level module.

Variants → Only Configure Root Allows you to set to on to only display options for the top-level
module, regardless of the line selected. Set to off to configure
the structure for a lower level module.

Variants → Search Searches for an existing variant item.

Variants → Count Modules Counts the modules defined for the selected variant structure.

Tools menu
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Command Description

Arrangements → View/Set
Current

Allows you to view or set the current NX arrangements.

Export → Objects Exports selected objects in Teamcenter format, STEP format or
a new or available application interface. When you export an
object in Teamcenter or STEP format, you move all internal data
associated with that object.

Export → To PLMXML Exports the selected structure and its attachments in the PLM
XML format to a selected export directory. You must choose the
appropriate transfer mode for the destination system.

If you export a structure in which substitute components are
defined, the substitutes are also exported.

Export → Objects to Excel Exports the selected structure lines to an Excel spreadsheet.

Import → Templates Imports a specification, object, or Excel template.

Import → Objects Imports objects in a Teamcenter format or STEP format to your
Teamcenter database.

Import → From PLMXML Imports objects in the PLMXML format to your Teamcenter
database.

Import → Remote Imports objects from a remote site using Multi-Site
Collaboration.

Rebase Physical Part Updates the physical part to the latest design of the neutral
structure.

Compare Compares two as-maintained structures or compares the as-
maintained structure to the neutral product structure in
separate windows.

Clear Clears the results of comparing two structures.

Find in Other Structure Finds the selected object in another structure pane. The search
follows the closest match rule if it does not find an exact match.

Rename Physical Part Allows you to change the part number and serial number of a
physical part.

Assign Lot Assigns a lot number to the selected physical part.

Install Physical Part Adds or installs a copied physical part into the current as-
maintained structure.

Uninstall Physical Part Uninstalls and removes the selected lines from the as-
maintained structure completely and does not place them on
the clipboard.
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Command Description

Replace Physical Part Replaces a selected physical part in the current as-maintained
structure with a copied part.

Setup Deviation Opens the Setup Deviation wizard. Use the Setup Deviation
wizard to search for a deviation document to associate to the
physical part.

Generate As-Maintained
Structure

Creates a physical as-maintained structure from the selected
neutral structure.

Show Top Physical Part Displays the top-most physical part parent for the selected
physical part.

Change Disposition Changes the state of a physical part. These states are classified
as operational or nonoperational.

Record Utilization Allows you to add characteristic values to a physical part to
capture part utilization.

Move From Cuts the selected physical part from the current physical location
and places it on the clipboard.

Move To Moves the physical part from the current physical location into
the selected physical location.

Show Physical Part Usage History Displays the physical part usage history for the selected physical
part.

Show Disposition History Displays the history of disposition states for the selected physical
part.

Show Utilization Displays the utilization information for the selected physical
part.

Show Log Entries Displays the log entries for the selected physical part.

Generate As-Built Structure Generates an as-built structure from the selected as-maintained
structure.

Name Occurrence Assigns a name to the occurrence for the selected neutral part
using the predefined naming rules.

Set Preferred Location Sets the selected physical location as the preferred location.

Unset Preferred Location Changes the selected physical location so that it is no longer the
preferred location.

Show Contains View Displays the physical parts contained in the selected physical
location or the selected asset group.

Tools menu
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Service Manager buttons and symbols

Note:

You can add buttons that are not displayed on the main toolbar by right-clicking the toolbar,
choosing Customize, and selecting the buttons you want to add. Once you add buttons to the
toolbars, they are displayed in future sessions. Consider adding buttons that:

• You use frequently.

• Provide a shortcut to menu commands that are not primary selections, for example,
Tools → Revision Rule → Set Date/Unit/End Item.

Button Purpose

These standard buttons are located on the main toolbar at the top of the Service Manager structure
pane.

Soft abort If enabled, allows you to terminate the current operation
without closing Service Manager or losing data.

Cut Cuts the selected lines from the structure and places them
on the clipboard.

Copy Copies the selected lines in the structure and places them
on the clipboard.

Paste Pastes the components from the clipboard as children of
the currently selected (assembly) line in the structure.

Delete Deletes the selected object from the database.

Open Opens the selected structure line in a new window.

Show/Hide data pane Shows or hides the data pane containing, for example,
properties data or the embedded viewer.

Show/Hide the lower
structure pane

Displays a second structure pane below the first. You
can set the size of each structure pane by moving the
horizontal split bar between the panes. If the second
structure pane is displayed, this button hides the lower
pane.

Show/Hide the
collaboration pane

Displays or hides the collaboration pane, which provides
advanced features for configuring structures. These
features relate primarily to Multi-Structure Manager.

Show untraced parts Shows or hides the neutral parts that are not traceable in
the physical structure.
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Button Purpose

Create lot Allows you to create lot information when you select a
part defined as a lot part. Lot information includes lot
number, manufacturer ID, and lot size.

Create serial number
generator

Allows you to create numbering scheme information for
a serial number on a neutral part that is defined as
a serialized part. The numbering scheme information
is used for serial number generation on physical parts
generated from that neutral part. For example, you can
define a prefix, suffix, or maximum number for the serial
numbers generated.

Generate as-maintained
structure

Creates a physical as-maintained structure from the
selected neutral structure.

Name occurrence Assigns a name to the occurrence for the selected line
using the predefined naming rules.

View/set current Allows you to view or set the revision rule on the current
line.

Configure variants Allows you to view and configure the variant option values
for the selected line.

Refresh Updates the information displayed for a selected line and
all of its children.

Find selected in other
panel

When you select a component in the BOM in one structure
pane and click this button, you can search for the
component in the BOM in the other structure pane. The
search follows the closest match rule if it does not find an
exact match.

Pack selected line Packs the selected lines so that all lines with the same
item revision and find number are displayed as a single
line. The actual quantity of lines appended to the node.

Unpack selected line Unpacks the selected packed lines so that they are
displayed as separate lines, one for each occurrence.

Setup deviation Opens the Setup Deviation wizard. Use the Setup
Deviation wizard to search for a deviation document to
associate to the physical part.

Install physical part Adds or installs a copied physical part into the current
as-maintained structure.

Replace physical part Replaces a selected physical part in the current as-
maintained structure with a copied part.

Service Manager buttons and symbols
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Button Purpose

Uninstall physical part Uninstalls and removes the selected lines from the as-
maintained structure completely and does not place them
on the clipboard.

Navigation Pane Displays or hides the navigation pane.

Advanced Search Allows you to select a search form that includes multiple
search criteria relevant to the type of information or object
being sought.

The following buttons are located at the bottom left corner of the Service Manager structure
navigation tree pane.

Most recently used
(MRU) list

Shows a list of your most recently accessed structures. If
you select an entry from the list, Service Manager loads
the structure into the structure pane. You can configure
the number of entries shown in the MRU list by right-
clicking the button and moving the slider to the desired
number.

Open by name Browses for and opens a specific structure by name.

Open structure context
by name

Browses for and opens a specific structure context by
name.

Most recently used
(MRU) revision rules list

Selects a revision rule to apply to the current product
structure from a list of the rules you have used recently.
You can configure the number of entries shown in the
MRU by right-clicking the button and moving the slider to
the desired number.

List substitute
components

Adds or removes substitute components or set the
preferred substitute.

This button is enabled if the selected line may have
substitutes; otherwise, it is disabled.

Manage global
alternates

Shows a list of the global alternates available for the
selected line. You can add alternates and select a
preferred alternate. The preferred global alternate is
indicated by an asterisk.

Find in display Searches for matching lines (components) in the displayed
product structure by entering an expression. You can
search with any combination of the available properties.

The following symbols are displayed at the bottom right corner of the product structure pane and
show the current status of the selected line.
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Button Purpose

Shows if you have write access permissions for the
selected line.

Shows if you have delete access permissions for the
selected line.

Shows if you have access permissions to change the
selected line.

Shows if the item revision represented by the line is
currently in a workflow process.

Shows if the item revision represented by the line is
currently checked in or checked out.

Shows if the item revision represented by the line is
currently released.

Shows if the item represented by the line is currently
published.

Shows if the item or revision represented by the line is
currently classified.

What are perspectives and views?

Within the rich client user interface, application functionality is provided in perspectives and views.

View The basic display component that displays related information in a UI window.

Perspective A collection of one or more views and their layout.

Some applications use a perspective with multiple views to arrange how functionality is presented.
Other applications use a perspective with a single view.

You can use the HiddenPerspectives preference to prevent the display of some Teamcenter perspectives
in the rich client.

If your site has online help installed, you can access application and view help from the rich client Help
menu or by pressing F1.

What are perspectives and views?
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Basic concepts for using Service Manager

Product structure use in Service Manager

Before creating or modifying the product structure, read Getting Started with Product Structure,
which describes the basic concepts behind product structure and includes advanced information on how
to use and administer it.

To take full advantage of Service Manager, you should be familiar with the Teamcenter elements that
are used to define and present product structure and how to manage multiple product views. Product
structures are not created or modified in Service Manager, but these structures are used as the definition
for the as-maintained structure.

Service Manager as-maintained management elements

Element Description

As-maintained structure The representation of a physical configuration of a manufactured
product evolving through its serviceable lifetime. A single neutral
structure can result in many as-maintained structures, one for each
physical asset. The as-maintained structure contains additional asset-
specific information and records authorized differences from the
product definition and captures characteristics and the history of the
structural changes as it evolves over time.

Characteristics definition Information related to a neutral part that is important for service
organizations maintaining assets. You can create characteristic
definitions that contain information to be measured against the
physical part, such as how long a product has been in use. You can
also create characteristic definitions that contain data to be measured
against a physical part, such as temperature or oil pressure.

Deviation document A document that authorizes the installation of a physical part which
is a deviation from the design structure.

Deviated physical part A physical part installed in a physical structure which is not the
preferred part or designated as a valid alternate or substitute to the
preferred part.

Deviation workflow The process flow, reviewer’s list, and business validations required to
route a deviation document for review and approval.

Disposition Defines whether the physical part is in an operational or a
nonoperational state. For example, the part disposition can be
an operational disposition such as In-Service or a nonoperational
disposition such as In-Repair.

Log book A collection of log entries recorded against a specific physical asset. A
physical asset may have more than one associated log book.
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Element Description

Log entry A record of data collected about a physical asset and recorded by a
certain person at a certain time. The log entry is associated to a single
asset but may record characteristic values for several components
within that asset.

Lot Group of physical parts controlled by the same number. A lot number
is similar to a serial number. The difference between the two is that
the same lot number can identify multiple physical parts, but no
more than the total number of physical parts specified by the lot size.

Lot part Physical part or assembly identified by a lot number.

Neutral part An item defined in the neutral structure representing a part
definition. It can be a part object or any other item type configured as
a valid neutral item type in the Business Modeler IDE.

Neutral structure A hierarchy of neutral parts representing the asset independent
product definition structure, such as the manufacturing or design
structure.

Part logistics data Information added to the neutral part that will support the realization
of physical parts in Service Manager or as-maintained representations
of the product. For example, part logistics data determines whether
the part is traceable, serialized, or lot. Part logistics data is added to
each neutral part using the Part Logistics Form.

Physical location An area where physical parts are stored. A location can be a site,
region, inventory, customer, contractor, or shop.

Physical part The representation of a built or manufactured physical asset
realized from the neutral part. The physical part captures the asset
information such as its serial number, manufacturer, lot number. It
also inherits the part number from the neutral part from which it is
realized.

Physical structure A structure composed of physical parts.

Physical realization The relation between a physical part and the neutral part revision
that it was realized from.

Serial number generator A number generator that can be configured on a neutral part to
create serial numbers for every instance of a physical part. You can
set characteristics for the serial numbers, such as a prefix, suffix, the
number increment, and the maximum number of characters in the
serial number. During the instantiation of the physical structure from
the neutral structure, you can choose to automatically assign the
serial numbers to the newly created physical parts.

Service Manager as-maintained management elements
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Element Description

Serialized part Approved product structure that includes part information.

Usage Defines the position that the physical part occupies within the as-
maintained structure.

Service Manager service event management elements

Service event management is available only if you have installed and obtained the proper license for the
Service Event Management extension for Service Manager.

Element Description

Activity entry value A characteristic definition value logged to a service event to capture
life, date, or observation characteristics for the associated physical
part. Characteristic definitions are defined on the neutral structure.

Fault code An identifier that indicates an itemized fault or problem that a
manufacturer has identified with a part. Physical parts can also report
fault codes as a result of internal diagnostics.

Part movement A record of each physical part that is installed or uninstalled as
a result of a service event. Each installation or uninstallation of a
physical part must have a unique part movement record.

Service discrepancy An irregularity or observation discovered with regard to maintenance
of a physical part. Discrepancies can also identify if there was a failure
with the physical part.

Service event Informational data that is captured as a result of service activity that
is performed by an external source.

Service group Collection of service events and service discrepancies used to
organize the service records of one or more physical parts.

Search for Service Manager objects

You can search for the following Service Manager objects using advanced search:

• MRO Asset Group
• MRO Date Characteristics
• MRO Deviation Document
• MRO Disposition Types
• MRO Fault Code
• MRO Item
• MRO Life Characteristics
• MRO Log Book
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• MRO Lot
• MRO Observation Characteristics
• MRO Physical Location
• MRO Physical Part
• MRO Serial Number Generator
• MRO Service Discrepancy
• MRO Service Event
• MRO Service Group
• MRO Service Group and Event

1. Choose Advanced from the quick Search menu at the top of the navigation pane.

2. On the Search pane toolbar, click  to select a search type.

3. Click More to display the system defined searches.

4. Under System Defined Searches, select the object you want to search for.

5. Click OK.

The dialog box that contains the object properties appears.

6. Type the values for the object properties that you want to search for.

7. Click the  button to search.

Basic tasks for using Service Manager

The basic tasks for using Service Manager are:

1. Configuring Service Manager by setting global and business object constants, LOVs, and
preferences.

2. Creating the neutral structure definition.

3. Generating the physical structure from the neutral structure.

4. Setting up and configuring the physical structure.

5. Recording service done on the physical structure.

6. Evolving and managing the physical structure.

Basic tasks for using Service Manager
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Service Manager process task flow

The following graphic shows the Service Manager process task flow. The functionality for recording
service is available only if you have purchased and have a license for Service Event Management.
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4. Installing and configuring Service
Manager
Install Service Manager

As a system administrator, you must install and configure Service Manager using Teamcenter
Environment Manager (TEM). As the following figure shows, you install Service Manager on the server
and on the rich clients that use the application.

1. Start Teamcenter Environment Manager (TEM).

2. Select appropriate options until you reach the Features panel.

Note:

The configuration installed is dependent on the options that you choose in the Solutions
panel of the TEM installation windows, such as Corporate Server, Rich Client 2–Tier or Rich
Client 4–Tier, and Business Modeler IDE. You can also add any of the options available in
the Solutions panel from the Features panel.

3. In the Features panel, under Extensions, expand Service Lifecycle Management and select from
the following features.

Feature Description Prerequisite features

As-Maintained
Management

Installs the As-Maintained
Management functionality.

Teamcenter Foundation

As-Built and
As-Maintained
Alignment

Installs the operability functionality
between the As-Built Management
and As-Maintained Management
applications. This functionality

As-Maintained Management

As-Built Management
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Feature Description Prerequisite features

is available only if you have
purchased and have a license
for As-Built Management and As-
Maintained Management.

Service Event
Management

Installs the Service Event
Management functionality. This
functionality is available only if you
have purchased and have a license
for Service Event Management.

As-Maintained Management

4. If you want to configure your system using the Business Modeler IDE:

a. Click Next. Select appropriate options until you reach the Business Modeler IDE Templates
panel.

b. In the Business Modeler IDE Templates panel, select the following templates.

Template Description

Teamcenter Foundation Installs the Teamcenter Foundation template.

As-Maintained Management Installs the As-Maintained templates.

Service Event Management Installs the Service Event Management templates. This
template is available only if you have purchased and have
a license for Service Event Management.

As-Built and As-Maintained
Alignment

Installs the template for the operability functionality
between the As-Built Management and As-Maintained
Management applications. This template is available only
if you have purchased and have a license for As-Built
Management and As-Maintained Management.

5. Click Next.

Select appropriate options until you complete the installation.

Configuring Service Manager

The Teamcenter administrator configures Service Manager according to company needs and
organization requirements as shown in the following figure.

4. Installing and configuring Service Manager
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You can configure:

• Service Manager preferences.

• Global and property constants that control part logistics information, define part usage properties,
and set a default disposition.

• Business object constants that identify neutral item types and physical part types.

• Naming rules for occurrences.

• Lists of values (LOVs) that define physical location types, deviation authority documents, and status
lists. The Service Event Management extension for Service Manager also provides LOVs to define
service information, such as type of service, severity of a service discrepancy, and the new neutral
part class to use when creating a part movement.

• Workflows.

Note:

As a best practice, use command suppression to limit the use of the rebase command to Service
Lifecycle Management super users.

You use the Business Modeler IDE to configure global and property constants, business object constants,
naming rules, and LOVs. An administrator creates and configures a custom template based on the
As-Maintained Management, Service Event Management, or another template. You must deploy the
custom template after making the changes.

Configuring Service Manager
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Setting Service Manager preferences

As an administrator or Teamcenter user, you can set the Service Manager preferences according to your
needs. Preferences are special environment variables stored in the Teamcenter database and are read
during Teamcenter application usage.

Setting Service Manager global and property constants

Setting Service Manager global and property constants

Global constants provide consistent definitions that can be used throughout the system. These constants
have only one value, either the Default value or the value you set. You use the Business Modeler IDE
to configure the global constants in a custom template that you define. You must deploy the custom
template after making the changes.

You can configure the following Service Manager global constants:

• AutoCreatePartLogisticsForm

Set this value to automatically create part logistics forms and relate them to a neutral item.

• PartLogisticsFormNamePrefix

Set this value to automatically create a prefix in part logistics form names.

• PhysicalPartDefaultDisposition

Set this value to the default disposition for physical parts.

• UsageAttributeName

Set this value to the property of PSOccurrence that is to contain the value for the generated physical
part's usage.

• ReuseAuthorizedDeviation

Set this value to reuse an authorized deviation information when duplicating physical structures.

You can configure the following Service Manager property constant:

• InitialValue

Set this value to set the defaults for the properties of the part logistics form.

4. Installing and configuring Service Manager
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Set up automated creation of part logistics forms

As an administrator, you can set the AutoCreatePartLogisticsForm global constant to true to configure
part logistics forms to be automatically created and related to a neutral item during creation. The part
logistics form is related to the neutral item with a References relation.

Example:

Because a part object by default is classified as a neutral item, a part logistics form is automatically
created and related to a newly created part.

Global constant Default value

AutoCreatePartLogisticsForm True

Define default values for part logistics form

As an administrator, you can set the defaults for values contained in the part logistics form by setting the
property constant InitialValue for any of the properties of the PartLogisticsForm business object.

Example:

You may want to set the InitialValue for the IsSerialized property to True, to require all physical
parts to have a serial number on one system, but not on another system.

Define part logistics form name prefix

As an administrator, you can set the PartLogisticsFormNamePrefix global constant to a prefix that is
used for part logistics form names.

Example:

Because a part object by default is classified as a neutral item, a part logistics form is automatically
created and related to a newly created part.

Global constant Default value

PartLogisticsFormNamePrefix NULL

Define default disposition

As an administrator, you can set the PhysicalPartDefaultDisposition global constant to a default
disposition for the physical parts when generating an as-maintained structure. You must set a value
for this global constant before using Service Manager.

Set up automated creation of part logistics forms
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Example:

You may want to set the PhysicalPartDefaultDisposition global constant to In-Repair.

Global constant Default value

PhysicalPartDefaultDisposition In-Service

Define usage property

As an administrator, you can set the UsageAttributeName global constant to the property of
PSOccurrence that populates the value of the physical part's usage when the as-maintained physical
structure is generated.

Example:

You may want to set the UsageAttributeName global constant to ref_designator. When you set
the value of ref_designator to RD1234, the value of usage is populated with that same value
RD1234 for the generated physical part.

The allowed properties are:

• occurrence_name

• ref_designator

• seq_no

Note:

The seq_no property corresponds to the value for the Find No. property in the Service Manager
interface.

Global constant Default value

UsageAttributeName occurrence_name

Reuse an authorized deviation

As an administrator, you can set the ReuseAuthorizedDeviation global constant to True to reuse an
authorized deviation when duplicating a physical structure. If the value is set to True, the deviated and
extra to design parts from the original structure are copied to the duplicated structure.

4. Installing and configuring Service Manager
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Global constant Default value

ReuseAuthorizedDeviation True

Setting Service Manager business object constants

Setting Service Manager business object constants

Business object constants provide default values to business objects that define the behavior for a
specific business object. Because these constants are attached to business objects, they are inherited,
just like properties. These constants have only one value, either the default value or the value you set.
You use the Business Modeler IDE to configure the business object constants in a custom template that
you define. You must deploy the custom template after making the changes.

You can configure the following as-maintained business object constants:

• IsMRONeutralType

Set this value to automatically configure which items are defined as neutral items.

• PhysicalPartTypeForCreate

Set this value to the physical part type created from a neutral item.

Identify neutral item types

As an administrator, you can set the IsMRONeutralType business object constant to true to configure
which items are defined as neutral items. Physical parts are only generated from neutral items.

Example:

Because IsMRONeutralType is false for the document business object, physical parts cannot be
generated from documents.

Business object constant Default value

IsMRONeutralType false for business object item

IsMRONeutralType true for business object part

Define physical part types

As an administrator, you can set the PhysicalPartTypeForCreate business object constant to represent
the physical part type that is generated from a neutral item.

Setting Service Manager business object constants
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Example:

You may want to a create new neutral item called Aircraft to represent an aircraft assembly
and a new physical part subtype called PhysicalAircraft to represent a physical aircraft assembly.
If you set the PhysicalPartTypeForCreate business object constant to PhysicalAircraft for the
neutral item Aircraft, the physical part is set to the type PhysicalAircraft when the as-maintained
structure is generated.

Business object constant Default value

PhysicalPartTypeForCreate Physical Part for business object item

Setting up Service Manager naming rules

As an administrator, you can create naming rules that define the data entry format for a business object
property. A naming rule consists of rule patterns and a counter. Before creating a naming rule, you
should be familiar with the pattern and counter formats. After you create a naming rule, you must
attach it to the business object property. You use the Business Modeler IDE to create the naming rules in
a custom template that you define. You must deploy the custom template after making the changes.

You can configure the following Service Manager naming rules:

• Automatically name occurrences

You can optionally create a naming rule and attach it to the business object property
occurrence_name for the PSOccurrence business object. This rule automatically names occurrences
when a Teamcenter user chooses the Name Occurrence command. The naming rule can also be
based on conditions.

Setting Service Manager lists of values

Setting Service Manager lists of values (LOVs)

As an administrator, you can set LOVs located in the LOV folder in the Extensions view in the Business
Modeler IDE. LOVs are commonly accessed by Teamcenter users from a menu at the end of a data entry
box. After you create a list of values, you must attach it to a property on a business object. You use the
Business Modeler IDE to set the LOVs in a custom template that you define. You must deploy the custom
template after making the changes.

You can configure the following Service Manager global LOVs:

• MRO Valid Deviation Status List

Set this list of values to configure the approved status list for deviations.

4. Installing and configuring Service Manager
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• MRO Deviation Authority List

Set this list of values to configure items used to authorize a deviation.

• Physical Location Type

Set this list of values to define physical location types that are used when creating a physical location.

Additional LOVs are also available in the Service Event Management template available with the
Service Event Management extension for Service Manager. The Service Event Management extension
for Service Manager is a separately-licensed option.

If you have installed the Service Event Management extension for Service Manager and have obtained
the appropriate license, you can configure the following Service Event Management LOVs:

• MRO Transaction Types

This list of values defines the type of service performed on a physical part. This LOV is not editable,
but contains values for the following LOVs. The values for the Service Lifecycle Management
Transaction Types LOV correspond to the Category attribute available when you create a service
event.

• sem_inspection_types

Set this list of values to define the type of inspection performed on a physical part.

• sem_overhaul_types

Set this list of values to define the type of overhaul performed on a physical part.

• sem_repair_types

Set this list of values to define the type of repair performed on a physical part.

• sem_other_types

Set this list of values to define the type of work performed on a physical part that is not an
inspection, overhaul, or repair.

• MRO Severity

Set this list of values to define service discrepancy severity levels.

• MRO New Part Class

Set this list of values to define the type of neutral part to use when creating a new part movement.

Setting Service Manager lists of values (LOVs)
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Define valid deviation status list

As an administrator, you can set the MRO Valid Deviation Status List LOV to the list of status values
needed on the deviation authority to validate the authorized installation of a deviated part. The deviated
authority item must be at the approved status before a deviated physical part can be installed.

Example:

You may want to include an additional status value such as Complete to validate a deviation.

LOV Description Default value

MRO Valid
Deviation
Status List

Specifies the list of status values needed
on the deviation authority to validate the
authorized installation of a deviated part.

TCM Released

Define deviation authority list

As an administrator, you can set the MRO Deviation Authority List LOV to the list of item classes used
to authorize a deviation.

Example:

You may want to use a manufacturing document in addition to a deviation document to authorize
deviations. If you have installed Service Event Management, ServiceEvent is a valid deviation
authority.

LOV Default values Description

MRO Deviation Authority
List

DeviationDoc Deviation document

Cm0DevRqst Deviation request

ADc0DevRqst ADS deviation request

Service Event Service event

Define physical location types

As an administrator, you can set the Physical Location Type LOV to a list of valid physical location types
that are used when creating a physical location.

4. Installing and configuring Service Manager
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Example:

You may want to add a physical location type called Warehouse to represent physical parts stored
in a warehouse.

LOV Description Default values

Physical Location
Type

Specifies the type of physical location. Contractor

Customer

In-Service

Inventory

Region

Shop

Site

Define types of service

The MRO Transaction Type LOV is an uneditable list of valid types of service performed on
a physical part. The service types, Inspection, Overhaul, Other, and Repair, are available as
default values for this LOV. You can define more specific types within these categories using the
sem_inspection_type, sem_other_type, sem_overhaul_type, and sem_repair_type LOVs. The values
for the MRO Transaction Type LOV are available as Action Type when creating a service event.

Note:

The following LOVs are not available unless you have installed the Service Event Management
extension for Service Manager and have the appropriate license.

• Inspection type

As an administrator, you can set the sem_inspection_type LOV to define specific types of inspections
performed on a physical part.

LOV Description Default value

sem_inspection_types Specifies the type of inspection
performed on a physical part.

Inspection

• Other type

Define types of service
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As an administrator, you can set the sem_other_type LOV to specify user-defined types of service,
other than inspection, overhaul, or repair, performed on a physical part. The sem_other_type LOV is a
subset of the MRO Transaction Type LOV.

LOV Description Default value

sem_other_types Specifies the user-defined type
of service performed on a
physical part.

Other

• Overhaul type

As an administrator, you can set the sem_overhaul_type LOV to define specific types of overhaul
service performed on a physical part. The sem_overhaul_type LOV is a subset of the MRO
Transaction Type LOV.

LOV Description Default value

sem_overhaul_types Specifies the type of overhaul
service performed on a physical
part.

Overhaul

• Repair type

As an administrator, you can set the sem_repair_type LOV to define specific types of repair service
performed on a physical part. The sem_repair_type LOV is a subset of the MRO Transaction Type
LOV.

LOV Description Default value

sem_repair_types Specifies the type of repair
service performed on a
physical part.

Repair

Define service discrepancy severity

As an administrator, you can set the MRO Severity LOV to a list of valid severity levels for a service
discrepancy.

Note:

The following LOV is not available unless you have installed the Service Event Management
extension for Service Manager and have the appropriate license.

4. Installing and configuring Service Manager
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LOV Description Default values

MRO Severity Specifies the severity level of a
service discrepancy.

Critical

Major

Minor

Define neutral part class for a part movement

As an administrator, you can set the MRO New Part Class LOV to a list of valid types of neutral part
classes to use when creating a part movement.

Note:

The following LOV is not available unless you have installed the Service Event Management
extension for Service Manager and have the appropriate license.

LOV Description Default value

MRO New Part Class Specifies the type of neutral part
class to use when creating a new
part for tracking part movement.
The value used for this LOV
must be a valid Service Lifecycle
Management neutral part, so
IsMRONeutralType business object
constant must be set to true.

Part

Configuring Service Manager workflows

As an administrator, you can configure the following workflows to support your Service Manager
installation:

• Deviation workflow

The TCM Release Process workflow is provided with the Teamcenter Foundation feature. You can
configure this workflow or create your own to set up the process flow, reviewers, and business
validations required to route a deviation document for review and approval.

• Release workflow

The Release As-Maintained Structure workflow is provided with Service Manager. You can configure
this workflow or create your own to set up the process flow, reviewers, and business validations
required to release an as-maintained structure.

Define neutral part class for a part movement
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Allow editing of log entries

Set preference to enable editing of log entries

Before the user can edit log entries, the administrator must set the site preference
MROEnableEditLogEntry to True. The default setting is False.

1. Set this preference by choosing Edit → Options, and use the keyword search to find
MROEnableEditLogEntry.

2. Enter True in the Value field for the preference MROEnableEditLogEntry and press Enter.

3. Click Save.

Grant access to edit log entries

The option to edit log entries can be granted to everyone or only to certain roles within your
organization. You set the access from the Access Manager.

1. From the navigation pane, click Access Manager.

2. Expand Has Class( POM application object ).

3. Select Has Class( CharacteristicValue ) → Edit Log.

4. Enter Edit Log in the ACL Name: field.

4. Installing and configuring Service Manager
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Note:

Add as many rows as needed to define the specific roles and unique access scenarios for your
organization's needs.

5. In the first cell in the first row, select Role in Group.

6. In the first row in the second cell, select Validation Administrator in Validation Administration.

7. In the first row under the Edit icon , select the option to allow edit .

8. In the first cell in the second row, select World.

9. In the second row under the Edit icon , select the option to revoke edit .

10. Click Save .

Add user to Validation Administrator role

If necessary, add user or users to the Validation Administrator role.

1. Open the Organization application.

2. Expand Validation Administration.

3. Select Validation Administrator.

4. Click the Add User button.

5. Click Add existing user to the group/role or Add new user to the group/role.

Allow editing of log entries
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6. Click the Next button.

7. Select the user to add, and select the add icon .

8. Click the Finish button.
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5. Creating neutral structures
Creating neutral structures

The neutral structure is the item or part structure representing the asset-independent product definition
structure. It provides the basis for the physical structure that is generated from the neutral structure.
The neutral structure can be created with Structure Manager, Multi-Structure Manager, or imported from
your CAD system.

You can populate the neutral structure in a way that is useful for servicing your physical assets. After
populating the neutral structure, you can attach other items or datasets to these neutral structure
elements. For example, you can attach documents such as design documents, specifications, and service
bulletins.

As shown in the figure, the neutral structure tasks include:

• Creating the product structure with valid global alternate and substitute parts by a user such as a
design engineer.

• Creating and managing the part logistic data by a user such as a logistics engineer. Part logistics data
includes information such as serial and lot definitions and part usages.

• Creating the characteristic definitions by a user such as a logistics engineer.
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Creating product structures

Creating product structures

A user such as a design engineer creates the neutral product structure as well as any substitute or global
alternate parts. The following figure shows the product structure tasks.

A neutral structure is the product structure that you create with Structure Manager, Multi-Structure
Manager, or import from your CAD system. The product structure, is sometimes referred as the bill of
materials (BOM).

The following figure shows an example of a neutral structure for a bearing housing assembly.

Teamcenter allows you to view an indented listing of the assemblies and piece parts that comprise the
product structure; the indenting allows you to interpret the relationship between the assemblies and
piece parts. The physical structure is generated from the neutral structure.

You can specify global alternates of a component, one of which is designated as the preferred global
alternate. Global alternates may be used in any product and are not defined in the context of a particular
assembly. Global alternates do not require an authorized deviation when installed as a alternate physical
part in the as-maintained physical structure.

5. Creating neutral structures
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You can also specify substitute components, which are components that can be used interchangeably
within an occurrence, typically for manufacturing purposes. The preferred substitute is displayed in the
structure. In contrast with global alternates, substitutes may only be used in the context of a particular
assembly. Substitute parts do not require an authorized deviation when installed as a substitute physical
part in the as-maintained physical structure.

Creating neutral structures

You must create the neutral structure before you can generate the as-maintained physical structure.
After you create the structure, you modify it as necessary to reflect any changes to the product design.

Note:

Do not add physical parts to neutral structures in Structure Manager, Multi-Structure Manager, or
other BVR applications. Active Workspace cannot handle these types of structures and will produce
an error when trying to view them.

The following bill of material is an example of a neutral structure.

 BH001/A;1–BH Assembly (view)
 BH012/A;1–Blade Front

 BH013/A;1–Blade Rear

 BH014/A;1–Shaft

 BH015/A;1–Heat Shield

 BH016/A;1–B Housing

 BH017 /A;1–Cover Ring

 BH018 /A;1–Piston

 BH019/A;1–Journal Bearing X 2

 BH020A;1–Retaining Ring

Defining global alternates

A global alternate part is interchangeable with another part in all circumstances, regardless of where
the other part is used in the product structure. A global alternate applies to any revision of the part and
is independent of any views.

Creating neutral structures
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Note:

A global alternate part does not require an authorized deviation when installed as an alternate
physical part in the as-maintained physical structure.

Defining substitute parts

A substitute part is a part that is interchangeable with a particular component in an assembly.
Substitutes are often defined for manufacturing purposes, allowing use of the substitute if the preferred
part is unavailable, for example, due to a stock shortage.

Note:

A substitute part does not require an authorized deviation when installed as a substitute physical
part in the as-maintained physical structure.

5. Creating neutral structures
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Creating and managing part logistics data

Creating and managing part logistics data

Part logistics data is the logistical information defined for a neutral structure that is used by the
generated physical structure. Part logistics data includes information such as serial and lot definitions
and part usages. A user such as a logistics engineer populates the part logistic data before the as-
maintained physical structure is generated. The following figure shows the part logistic data tasks.

You can create and manage part logistics data by:

• Creating and managing part logistics forms attached to the neutral part.

• Overriding part logistics data in the context of a structure.

• Creating lot definitions for the neutral part used for the generated physical part.

• Creating serial number definitions for the neutral part used for the generated physical part.

• Defining occurrence information for the neutral part that is the part usage for the generated physical
part.

Managing part logistics forms

Part logistics form

The part logistics form contains some of the logistical information required for the neutral part. It must
be attached to the neutral part item using a References relation to generate a physical part.

Creating and managing part logistics data
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Note:

The part logistics form is automatically created and attached to a valid neutral item during neutral
item creation, if the AutoCreatePartLogisticsForm global constant is true. If this constant is
false, you must manually create and attach part logistics forms to the neutral parts that generate
physical parts.

Property Definition Default

Traceable Defines if a physical part will be generated from the neutral part. true

Serialized Defines if a physical part requires a serial number. false

Lot Defines if a physical part requires a lot number. false

Rotable Defines if a physical part can be easily repaired. false

Consumable Defines if a physical part can be used and discarded. false

Preserve
Quantity

Defines if one physical part with the quantity defined can
represent a multi-quantity neutral part.

false

Life Limited Defines if a physical part has a finite life. false

Asset Defines if a physical part can be tagged as an asset in Maximo
and other asset management systems.

Note:

This property is specific to an implementation that
includes an integration with IBM Maximo or another asset
management system.

false
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Manually create a part logistics form

Note:

The part logistics form is automatically created and attached to a valid neutral item during neutral
item creation if the AutoCreatePartLogisticsForm global constant is true. If this constant is
false, you must manually create and attach part logistics forms to the neutral parts that generate
physical parts.

1. From the navigation pane, click My Teamcenter.

2. Locate the neutral part you want to create a part logistics form for.

3. Select the neutral part and choose File → New → Form.

4. Select Part Logistics Form from the list of forms.

5. Enter the following information for the new form.

Field name Definition Valid values

Name Name for the part logistics form. Alphanumeric (1–128
characters)

Description Description of the new form
(optional).

Alphanumeric (1–240
characters)

6. Click OK or Apply to create the new form. Click Cancel to exit without creating a new form.

The part logistics form is related to the neutral part with a References relation.

Note:

If you created the part logistics form without selecting the neutral part, you must relate the form
to the neutral part.

Create part logistics form with the plf_attach utility

Sometimes items are created without a part logistic form (PLF). The plf_attach utility adds the PLF to
one or more items at once, which in the case of large structures saves significant time and effort.

In BMIDE, the constant IsMRONeutralType must be set to true for the item to be an MRO Neutral Type,
which is necessary to attach a PLF.

1. Create a text file.

Manually create a part logistics form
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Note:

The name of the file is not important but it does need to be included in the command line.

Either place the text file in the same location as the utility, or include the complete path for
the file.

2. Add all of the item_IDs of the parts to which you are adding PLFs.

Note:

• If you include a parent in the list of items, Service Lifecycle Management also adds the PLF
to the children.

• If any item in the list already has a PLF attached, it is not affected when the utility is
executed.

• You can include other multifield key (MFK) attributes.

3. Save the text file.

4. Open a Teamcenter command prompt window.

5. Enter the command to execute the plf_attach utility.

Sample command:

plf_attach -u=<username> -p=<password> -g=<group> -StructureAttributesDetailsFile=<item-id-
filename>.

A list of the PLFs created for the parts is displayed, confirming the command executed correctly.

Note:

To see the syntax for the plf_attach, see plf_attach utility documentation.

Controlling part definition in Maximo

The following Part Logistics Form property settings define how a physical part is identified in Maximo.

5. Creating neutral structures
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Part Logistic Form property settings Part Status in Maximo

If isTraceable = 1, and if isSerialized = 1,
or
if isTraceable = 1, and isAsset = 1

Asset

If isTraceable = 1, and if isSerialized = 0, and if isAsset = 0 Spare Part

If isTraceable = 0 Part ignored in Maximo

Display part logistics form properties

To view the part logistics form properties using the Properties dialog box:

1. From the tree pane or Details table, select the part logistics form that you want to display.

2. Double-click the part logistics form associated to the neutral part.

The properties are displayed.

To view the part logistics form properties using the Viewer pane:

1. Select the part logistics form.

2. Click the Viewer tab.

The system displays the properties of the part logistics form in the Viewer pane.

Edit part logistics form properties

1. From the tree pane or Details table, select the part logistics form that you want to display.

2. Double-click the form to display the properties.

3. Click Checkout and Edit.

4. Modify the form property values, as required.

5. Click Save and Check-In or Save.

Edit part logistics data

You edit part logistics data in Service Manager by selecting the BOM line for the neutral part and
changing the cell data containing the part logistic value. You can also change part logistics data by
editing the part logistic form properties.

Display part logistics form properties
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Using Service Manager, you can change the following part logistic values:

• Traceable

• Serialized

• Lot

• Rotable

• Consumable

• Preserve Quantity

• Life Limited

• Asset

1. Open the neutral structure in the Service Editor view by one of the following methods:

• From the navigation pane, click Service Manager, then from the Service Editor view, click
Open by Name .

• If you are viewing the structure in the Structure Manager view, right-click the structure parent
and choose Send to → Service Manager.

2. From the Service Editor view, select the BOM line containing the neutral part.

a. Double-click the cell containing the part logistics value.

b. Double-click the cell containing the part logistics value and type the new value.

Override part logistics data in context

You can override part logistics data in the context of the top-level or lower level neutral structures. For
example, you may override part logistic data to prevent the generation of a physical part in the context
of a specific neutral structure. To override the data, you set the neutral structure in context and override
the Traceable value from Y, which is true, to N, which is false for that neutral part in the structure.

The following part logistic values can be changed in the context of a neutral structure:

• Serialized

• Traceable

5. Creating neutral structures
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• Consumable

• Rotable

• Preserve Quantity

• Life Limited

• Asset

Note:

The part logistic value Lot cannot be changed in the context of a neutral structure.

1. Open the neutral structure in the Service Editor view.

2. From the Service Editor view, select the bill of materials (BOM) line containing the top-level or
lower level parent.

3. Right-click and choose Toggle in-Context Mode to set the structure in context.

4. From the Service Editor view, select the BOM line containing the neutral part.

• To override the Traceable value, double-click the Traceable cell. Type the new value.

• To override the Serialized value, double-click the Serialized cell. Type the new value.

Note:

A serial number generator may never be assigned to a non-serial part even though it may
be marked serialized in context.

• To override the Consumable value, double-click the Consumable cell. Type the new value.

• To override the Rotable value, double-click the Rotable cell. Type the new value.

• To override the Preserve Quantity value, double-click the Preserve Quantity cell. Type the new
value.

• To override the Life Limited value, double-click the Life Limited cell. Type the new value.

• To override the Asset value, double-click the Asset cell. Type the new value.

Override part logistics data in context
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Defining parts for tracking

To track physical parts, you must set the Traceable value to true to generate physical parts from neutral
parts. The value can be changed in the part logistics form.

Note:

Physical parts are not generated for traceable neutral parts that are children of nontraceable parts.

Create a lot definition

Create a lot to group physical parts that are associated in some way, for example, from a particular
manufacturer.

A lot contains a group of physical parts controlled by the same lot number. You can define the maximum
number of parts that a lot can contain. Based on this information, you can assign lot numbers to the
physical parts that make up the physical structure.

The lot usage value increments for every physical part assigned to that lot. When the lot usage is more
than the maximum number of parts available, the lot cannot be used further. You can also define an
expiration date for the lot.

Note:

Lots can be assigned only if the part logistics lot property is true for the neutral part.

1. Open the neutral structure in the Service Editor view.

2. From the Service Editor view, select the BOM line containing the neutral part.

3. Right-click and choose New → Lot.

The New Lot dialog box appears.

4. Enter the following information for the new lot.

Field name Definition Valid values

Lot Number Unique lot ID number Alphanumeric (1–32
characters)

Manufacturer's ID Lot manufacturer ID Alphanumeric (1–128
characters)

Lot Size Number of items in the lot Integer

5. Creating neutral structures

5-12  Service Manager, Service Lifecycle Management 2412
© 2024 Siemens



Field name Definition Valid values

Note:

If you set the lot size value to
0 (zero) or leave it blank, the
lot size is set to infinite.

Expiration Date Lot expiration date Click the Set Date  button
and select a date from the
calendar.

5. Click OK to create the lot under the New Stuff folder. Alternatively, click Cancel to exit.

 Newstuff
 BH020–01/RRLot01  Lot

Create a serial number generator

Serialized physical parts have a unique serial number for a given Manufacturer's ID. For example, you
may have two engines with the same serial number but are manufactured by different companies.

You can type the serial number for the physical part or you can optionally create a serial number
generator. The serial number generator is defined for the neutral parts and automatically assigns the
serial numbers to the newly created physical parts in the as-maintained physical structure.

Note:

Serial numbers can be assigned only if the part logistics serialized property is true for the neutral
part.

1. Open the neutral structure in the Service Editor view.

2. From the Service Editor view, select the BOM line containing the neutral part.

3. Right-click and choose New → Serial Number Generator.

The New Serial Number Generator dialog box appears.

4. Enter the following information.

Create a serial number generator
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Field name Definition Valid values

Series Prefix Prefix for the generated serial
number.

Alphanumeric (1–32
characters)

Series Suffix Suffix for the generated serial
number.

Alphanumeric (1–32
characters)

Series Current Starting numeric value for the
generated serial number.

Integer

Series Maximum Maximum numeric value for the
generated serial number.

Integer

Increment Increment between the generated
serial numbers.

Integer

Series Characters Number of characters for the
generated serial number. Numeric
values are preceded by zeros to
meet the character limit.

Integer

5. Click OK to create the serial number generator under the New Stuff folder. Alternatively, click
Cancel to exit.

 Newstuff
 BH014–nn-Shaft  Serial number generator

Set or unset generic serial number generator

Set a generic serial number generator

1. Search for an existing serial number generator using the global search.

2. Click Select a Search .

3. Select the MRO Serial Number Generator search from the list and click OK.
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4. Add search criteria in the MRO Serial Number Generator dialog box.

5. Click Execute Search .

6. Right-click the desired serial number generator and select Set As Generic Serial Number
Generator.

If a generic serial number generator is already set, it is now replaced.

Set or unset generic serial number generator
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Unset a generic serial number generator

1. Search for an existing serial number generator.

2. Right-click any serial number generator and select Unset Generic Serial Number Generator.

Note:

Selecting a generic serial number generator that is already set makes the Unset As Generic
Serial Number Generator option available.

Define part usage

The usage of a physical part in an as-maintained structure defines the position that the physical part
occupies within the structure. You define the usage of a physical part by:

• Entering a value for the neutral structure occurrence property used to define the physical part usage.
This can be defined by the UsageAttributeName global constant. The default property is set to
occurrence_name.

• Defining a naming rule to auto name the occurrences. The occurrence_name property can only be
used if a naming rule for occurrences has been created.

1. Open the neutral structure in the Service Editor view.

2. From the Service Editor view, select the BOM line containing the neutral part.
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3. • If you use an occurrence naming rule:

Right-click and choose Name Occurrence.

• If you do not use an occurrence naming rule:

Double-click the Occurrence Name cell and type the usage value.

Note:

The occurrence_name property is the default property used to set the usage for
the physical part. The ref_designator or seq_no properties can be used only if the
UsageAttributeName global constant is set to one of those values.

Creating characteristic definitions

Characteristic definition

A characteristic definition is information related to a neutral part that is important for service
organizations maintaining mission critical assets. You can create characteristic definitions that contain
information such as how many hours a part has been used, the date the asset was put into commission,
or the operating temperature of the part.

As the following figure shows, you can create characteristic definitions that define life, date, and
observation characteristics for a physical part. You can also create derived characteristics which are
characteristics values that are calculated by the system based on formulas or expressions. Only life
and observation characteristics can be defined as derived characteristics by specifying the evaluation
expression.

The characteristic definitions must be assigned to the neutral part. The generated physical part inherits
the characteristic definitions that are used for recording utilizations.

Characteristic definition
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Creating characteristic definitions

• Life characteristic definition

A life characteristic defines the individual characteristics that measure the life of a physical part and
are cumulated each time they are updated during the life of the physical part. Life characteristics can
be propagated throughout an entire physical structure providing the child physical parts share the
same life characteristic definitions.

• Date characteristic definition

A date characteristic defines a date when a specific action occurred on a physical part.

• Observation characteristic definition

An observation characteristic defines the operational characteristics observed about a physical part.

• Derived characteristic defintion

A derived characteristic value is calculated by the system, and is based on formulas or expressions.
You can use existing life or observation characteristics when you define the formula for the derived
characteristic.

Create a life characteristic

A life characteristic is used to record characteristics that measure the life of a physical part and are
cumulated each time they are updated during the life of the physical part.

Note:

Life characteristics are propagated to child parts and assemblies that have the characteristic. If an
assembly has a life characteristic, and one of its subassemblies does not have that characteristic

5. Creating neutral structures

5-18  Service Manager, Service Lifecycle Management 2412
© 2024 Siemens



but a child of that subassembly does, then the child part will not record a value because the
parent, the subassembly, breaks the propagation chain.

Example:

You may want to track the number of landings for an aircraft using a life characteristic. When the
number of landings reaches a specific value, scheduled maintenance on the aircraft is performed.

1. From the navigation pane, click Service Manager.

2. Choose one of the following methods:

• Select a folder where you want to create the new life characteristic.

• Select one or more neutral parts from your home folder or from the Service Editor view where
you want to assign the life characteristic.

3. Choose File → New → Life Characteristic.

The New Life Characteristic dialog box appears.

4. Enter the following information for the life characteristic.

Field name Definition Valid values

Characteristic
Name

Name of the life characteristic Alphanumeric (1–128
characters)

Unit Unit of measure for the recorded
value

Alphanumeric (1–128
characters)

Precision The number of decimal places Integer

5. Click OK to create the life characteristic. Alternatively, click Cancel to exit.

Create a date characteristic

A date characteristic is used to record certain operational characteristics that a technician observes
about a physical part. The value of this operational characteristic is a date.

Note:

Date characteristics do not propagate to child parts or subassemblies.

Create a date characteristic
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Example:

You may want to capture the commission date or warranty date of a physical part.

1. From the navigation pane, click Service Manager.

2. Choose one of the following methods:

• Select a folder where you want to create the new date characteristic.

• Select one or more neutral parts from your home folder or from the Service Editor view where
you want to assign the date characteristic.

3. Choose File → New → Date Characteristic.

The New Date Characteristic dialog box appears.

4. Enter the following information for the date characteristic.

Field name Definition Valid values

Name Name of the date characteristic Alphanumeric (1–128
characters)

5. Click OK to create the date characteristic. Alternatively, click Cancel to exit.

Create a numeric observation characteristic

A numeric observation characteristic is used to record certain operational characteristics that a
technician observes about a physical part. The value of this operational characteristic is numerical.

Note:

Numeric characteristics do not propagate to child parts or subassemblies.

Example:

You may need to record any cracks or record the operating temperature for a specific physical
part. When the gap distance or operating temperature exceed certain values, maintenance must
be performed.

1. From the navigation pane, click Service Manager.

2. Choose one of the following methods:
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• Select a folder where you want to create the new observation characteristic.

• Select one or more neutral parts from your home folder or from the Service Editor view where
you want to assign the observation characteristic.

3. Choose File → New → Observation Characteristic.

The New Observation Characteristic dialog box appears.

4. Enter the following information for the numeric observation characteristic.

Field name Definition Valid values

Characteristic
Name

Name of the observation
characteristic

Alphanumeric (1–128
characters)

Type of Value Numeric, Logical, or Textual

Unit Unit of measure for the recorded
value

Alphanumeric (1–128
characters)

Precision The number of decimal places Integer

5. In the Numeric Expression box, type the expression or formula for the derived characteristic or
click the  button to use the wizard.

6. Click OK to create the observation characteristic. Alternatively, click Cancel to exit.

Create a logical observation characteristic

A logical observation characteristic is used to record certain operational characteristics that a technician
observes about a physical part. The value of this operational characteristic is either a true or false
condition. For example, the value of this characteristic for a pump can be on or off.

Note:

Logical characteristics do not propagate to child parts or sub-assemblies.

1. From the navigation pane, click Service Manager.

2. Choose one of the following methods:

• Select a folder where you want to create the new observation characteristic.

• Select one or more neutral parts from your home folder or from the Service Editor view where
you want to assign the observation characteristic.

Create a logical observation characteristic
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3. Choose File → New → Observation Characteristic.

The New Observation Characteristic dialog box appears.

4. Enter the following information for the logical observation characteristic.

Field name Definition Valid values

Characteristic
Name

Name of the observation
characteristic

Alphanumeric (1–128
characters)

Type of Value Numeric, Logical, or Textual

Value True or False Alphanumeric (1–128
characters)

The default values, if no other
values are entered, are True
and False.

5. Click OK to create the logical observation characteristic. Alternatively, click Cancel to exit.

Create a textual observation characteristic

A textual observation characteristic is used to record certain operational characteristics that a technican
observes about a physical part. Predefined text strings are used to define the value of this operational
characteristic.

Note:

Textual characteristics do not propagate to child parts or subassemblies.
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Example:

A service engineer needs to record conditions that define a pump failure. Use the textual
observation to define a list of values (LOV) such as:

• No power

• Intake blockage

• Impeller frozen

• Motor failed

1. From the navigation pane, click Service Manager.

2. Choose one of the following methods:

• Select a folder where you want to create the new observation characteristic.

• Select one or more neutral parts from your home folder or from the Service Editor view where
you want to assign the observation characteristic.

3. Choose File → New → Observation Characteristic.

The New Observation Characteristic dialog box appears.

4. Enter the following information for the logical observation characteristic.

Field name Definition Valid values

Characteristic
Name

Name of the observation
characteristic

Alphanumeric (1–128
characters)

Type of Value Numeric, Logical, or Textual

Values Alphanumeric strings Alphanumeric (1–128
characters)

5. Click OK to create the textual observation characteristic. Alternatively, click Cancel to exit.

Create a derived characteristic

Derived characteristic values are calculated by the system, and are based on formulas or expressions.
You use existing life or observation characteristics when you define the formula for the derived
characteristic. If the expression contains one of the life characteristics, then the characteristic type is
life. Otherwise, the type is observation.

Create a derived characteristic
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Note:

Only derived characteristics that are of the type life are propagated. Also, life characteristics that
are included in the derived characteristics are propagated.

Example:

An aircraft engine can have different life characteristics, such as in-flight usage and number
of landings, while in use. The actual life of the engine is a combination of these values
based on some predefined formulas. You can define a formula to calculate the derived life
characteristic value based on the two base life characteristic values that you provide. The derived
life characteristic value can then be used for calculating maintenance schedules.

1. From the navigation pane, click Service Manager.

2. Create a new life or observation characteristic and fill in the required fields.

Note:

If you want to use a life or observation characteristic in the formula for the
derived characteristic, you must create those characteristics before defining the derived
characteristic.

3. In the Derived Expression box, choose the following methods:

a. Type in the expression or formula for the derived characteristic.

b. Click the  button.

The Expression dialog box appears.

A. Enter the following information.

Field name Definition Action

Characteristics Names of existing
life or observation
characteristics you
wish to use in
the formula for the
derived expression.

Click the  button and select the life
or observation characteristic you want
to use in the expression. Click Append
to append the characteristic definition
in the Derived Expression box.

Operations The Boolean
operation you want
to use in the
expression.

Click the  button and select one of
the following operations to use in the
expression:
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Field name Definition Action

• Select + for addition

• Select – for subtraction.

• Select * for multiplication.

• Select / for division.

• Select ( or ) to group expressions.

Click Append to append the operation
in the Derived Expression box.

Derived Expression The derived
expression is used
for the derived
characteristic.

Click Append next to the
Characteristics and Operations
boxes to create your expression or
type those values and any other
values needed to complete the
expression.

B. Click OK to create the derived characteristic.

4. Click OK to create the life or observation characteristic using the derived characteristic.

Assign characteristics to a neutral part

1. From the navigation pane, click My Teamcenter or Service Manager.

2. Select the characteristic definition in your home folder.

3. Right-click and choose Copy.

4. Select one or more neutral parts from your home folder or from the Service Editor view where you
want to assign the characteristic definition.

5. Right-click and choose Paste.

Note:

If you are in the Service Editor view, you can also choose Paste Characteristics to assign the
characteristics.

The characteristic definitions are related to the selected neutral parts, as shown below:

Assign characteristics to a neutral part
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 BH001–01–Bearing Housing Assembly
 BH001–01/A;1–Bearing Housing Assembly

 BH001
 EngineHours
 OperatingTemperature
 LastInspectionDate

Update characteristic definition properties

1. From the navigation pane, click My Teamcenter or Service Manager.

2. Select the characteristic definition.

3. Right-click and choose View Properties.

4. In the Properties dialog box, select Check-Out and Edit to access the Edit Properties dialog box.

5. In the Edit Properties dialog box, change the available properties as needed.

6. Click Save and Check-In.

Update observation characteristic definition properties

1. From the navigation pane, click My Teamcenter or Service Manager.

2. Select the observation characteristic definition.

3. Right-click and choose View Properties.

4. In the Properties dialog box, select Check-Out and Edit to access the Edit Properties dialog box.

5. In the Edit Properties dialog box, select the value to change, and click the Edit  icon.
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6. Enter a new value and click the Replace Selected Objects  icon.

7. Click Save and Check-In to change the observation characteristic definition properties.

Delete a characteristic definition

You can delete a characteristic definition if it is not attached to a neutral part.

1. From the navigation pane, click My Teamcenter or Service Manager.

2. Select the characteristic definition.

3. Choose Edit → Delete.

Delete a characteristic definition
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6. Generating as-maintained physical
structures
Generating as-maintained physical structures

A user, such as a production planner, generates the as-built physical structures.

Generating as-maintained physical structures tasks

A physical structure refers to an asset's product structure information. Each asset that your organization
manufactures or owns can be represented by one physical structure. An as-maintained physical structure
evolves as the asset changes over time. This physical structure contains other traceable physical parts
that represent the subassemblies and components that make up the asset. Each physical part within the
structure links back to the neutral part that provides its engineering and logistics definition. Part logistics
information includes if a part is traceable and should be included in the physical structure as well as if
the part should have a recorded serial number, lot number, or both.

The following figure shows an example of a physical structure for a bearing housing assembly. In this
example, all the physical parts are serialized.

Service Manager, Service Lifecycle Management 2412  6-1
© 2024 Siemens



An imprecise structural relationship exists between the as-maintained assembly and the components.
The physical parts are related back to the neutral parts with a PhysicalRealization relation.

Note:

Physical parts with a green background in the as-maintained structure belong to a precise neutral
structure.

The following tasks are required steps before generating an as-maintained physical structure:

• Creating the neutral structure and populating the part logistics information assigned to the neutral
parts.

• Defining disposition types by a user such as a logistics engineer.

• Managing the location structures by a user such as an operator.

A user, such as a production planner, can:

6. Generating as-maintained physical structures
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• Generate an as-maintained physical structure top down from the top-level neutral structure.

• Generate an as-maintained physical structure bottom up by installing physical parts at various levels in
the structure.

• Duplicate an as-maintained physical structure.

• Generate an as-maintained physical structure from an as-built physical structure if you have
purchased and have a license for both the As-Built Manager and the Service Manager (as-maintained)
applications.

• Generate an as-built physical structure from an as-maintained physical structure if you have
purchased and have a license for both the As-Built Manager and the Service Manager (as-maintained)
applications.

Note:

The sequence of the parts in the original structure is maintained in the new structure.

Structure alignment maintained from old structure to new
structure

There are a number of ways that you generate or duplicate a structure. The order of the parts in the
new structure is aligned with the order of the parts in the old structure. The Find No. is the value that
controls the order.

Methods to generate or duplicate a structure:

• Generate an as-built structure from a neutral structure

Structure alignment maintained from old structure to new structure
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• Generate an as-maintained structure from a neutral structure

• Generate an as-built structure from an as-maintained structure

• Generate an as-maintained structure from an as-built structure

• Duplicate an as-built structure

• Duplicate an as-maintained structure

The example shows an as-built structure and its duplicate. The order of the physical parts is maintained.

Quantity preserved from neutral structure to new structure

When you create an as-maintained structure from a neutral structure, you can control the display of
parts that have a quantity greater than one, in the new structure. This becomes especially important
when you work on very large structures and on structures imported into Teamcenter from a CAD system.

For example, a wheel assembly includes multiple nuts. When the structure is imported, each nut is
represented by a single line in the neutral structure. The existence of multiple lines for one part clutters
the structure, making it difficult to find specific parts throughout the structure.

6. Generating as-maintained physical structures
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Using the property Preserve Quantity, you control the way these occurrences are displayed when you
create a physical structure.

• If Preserve Quantity is set to True (1), the parts are displayed in the physical structure as one packed
node (2).

Note:

If Preserve Quantity is set to True on a parent node, all children nodes with multiple
occurrences are also packed because they inherit the value from the parent.

An as-maintained structure generated from a neutral structure with Preserve Quantity set to True on
the 029889/--A-Nut part:

• If Preserve Quantity is set to False, the parts are displayed with multiple nodes, one node for each
part occurrence.

Defining disposition types

Create a disposition type

Disposition types are classified as operational or nonoperational depending on the state of the physical
part. As an administrator, you define the disposition types for physical parts. For example, you may want

Create a disposition type
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to create a operational disposition type called Issueable and a nonoperational disposition type called
In-Repair.

A default operational disposition called In-Service is already predefined in the system.

1. From the navigation pane, click Service Manager.

2. Select a folder where you want to create the new disposition.

3. Choose File → New → Disposition Type.

The New Disposition Type dialog box appears.

4. Enter the following information for the new disposition type.

Field name Definition Valid values

Disposition Value Name of the disposition type. Alphanumeric (1–128
characters)

5. Select the Operational check box to specify the physical part is serviceable in the new disposition
state.

6. Select the Is Active check box to specify the disposition is an active disposition type and can be
used as a valid disposition type when generating an as-maintained structure.

7. Click OK to create the new disposition type. Alternatively, click Cancel to exit.

Update disposition type properties

1. From the navigation pane, click My Teamcenter or Service Manager.

2. Select the disposition type.

3. Right-click and choose View Properties.

4. In the Properties dialog box, change the available properties.

5. Click OK or Apply to change the disposition type properties. Alternatively, click Cancel to exit.

Delete a disposition type

You can delete a disposition if it is not referenced by a physical part.

6. Generating as-maintained physical structures
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1. From the navigation pane, click My Teamcenter or Service Manager.

2. Select the disposition type.

3. Choose Edit → Delete.

Managing physical location structures

Managing physical location structures

A physical location is an area where physical parts are stored. A location can be a site, region, inventory,
customer, contractor, or shop. Locations can be of various types and as an administrator, you define
location types based on your requirements. You can relate locations to one another because of their
structured nature. The locations are assigned to the physical parts when you create the as-maintained
structure. You must set preferred locations before generating the as-maintained physical structure.

The following figure shows an example of a location structure.

The following location types are provided with the As-Maintained Management application:

• Contractor

• Customer

• In-Service

• Inventory

• Region

• Shop

• Site

You can define additional physical location types by configuring the Physical Location Type LOV.

Managing physical location structures
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Creating physical locations and location structures

Creating physical locations

You create physical locations and physical location structures according to your requirements and assign
the physical parts to the locations when creating the as-maintained structure. A location structure is
comprised of sublocations created in the context of a parent location.

You can optionally link a physical location to a defined company location. The physical location will
display the properties of the company location such as Street, City, and State.

Create a physical location

1. From the navigation pane, click Service Manager.

2. Select the folder where you want to create the location.

3. Choose File → New → Physical Location.

The New Business Object dialog box appears.

4. Select Physical Location from the list and click Next.

5. Enter the following information for the physical location.

Field name Definition Valid values

ID Unique ID for the physical location
(required).

If blank, the ID is automatically
assigned.

Alphanumeric (1–128
characters)

Revision Revision for the physical location
(required).

If blank, the revision is
automatically assigned.

Alphanumeric (1–32
characters)

Location Name Name for the physical location
(required).

Alphanumeric (1–128
characters)

Location Type The type of physical location
(required).

Types are defined by the
Physical Location Type LOV.

Description Description of the physical location. Alphanumeric (1–240
characters)

6. Generating as-maintained physical structures

6-8  Service Manager, Service Lifecycle Management 2412
© 2024 Siemens



6. Click Finish to create the physical location.

Create a physical location structure

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

3. From the Service Editor view, click Open by Name  to open the physical location where you
want to create the sublocation.

4. Select the physical location where you want to add the sublocation.

5. Choose File → New → Physical Location.

The New Business Object dialog box appears.

6. Select Physical Location and click Next.

7. Enter the following information for the physical location.

Field name Definition Valid values

ID Unique ID for the physical location
(required).

If blank, the ID is automatically
assigned.

Alphanumeric (1–128
characters)

Revision Revision for the physical location
(required).

If blank, the revision is
automatically assigned.

Alphanumeric (1–32
characters)

Location Name Name for the physical location
(required).

Alphanumeric (1–128
characters)

Location Type The type of physical location
(required).

Types are defined by the
Physical Location Type LOV.

Description Description of the physical location. Alphanumeric (1–240
characters)

8. Click Finish to create the physical sublocation.

The sublocation is created under the parent location.

Create a physical location structure
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 Fort Chesternn

 Fort Chester Shopnn  sublocation

Link a company location to physical location

1. From the navigation pane, click My Teamcenter or Service Manager.

2. Select the company location you want to link to the physical location.

3. Right-click and choose Copy.

4. Select the physical location.

5. Right-click and choose Paste.

Physical Location Structure Street City
 Fort Chesternn 200 Fort Chester Lane New York

Set a preferred physical location

You must set a preferred location before generating the as-maintained physical structure. You can set
more than one preferred location.

1. Select the physical location by one of the following methods:

• From the navigation pane, click My Teamcenter.

• Select the physical location.

• Click Service Manager.

a. Choose Window → Show View → Service Editor.

b. From the Service Editor view, click Open by Name  to open the physical location.

c. Select the physical location.

2. Right-click and choose Set Preferred Physical Location.

Unset a preferred physical location

1. Select the physical location by one of the following methods:

6. Generating as-maintained physical structures
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• From the navigation pane, click My Teamcenter.

• Select the physical location.

• Click Service Manager.

a. Choose Window → Show View → Service Editor.

b. From the Service Editor view, click Open by Name  to open the physical location.

c. Select the physical location.

2. Right-click and choose Unset Preferred Physical Location.

Delete a location

You can delete a location if it has no sublocations or related physical parts.

1. From the navigation pane, click My Teamcenter or Service Manager.

2. Select the physical location.

3. Choose Edit → Delete.

Remove a location

You can remove a sublocation from a location structure.

1. From the navigation pane, click Service Manager

2. Choose Window → Show View → Service Editor.

3. Select the physical location structure where you want to remove a sublocation.

4. Right-click and choose Show in Service Editor.

5. From the Service Editor view, select the physical sublocation line in the containing the parent
physical location.

6. Right-click and choose Remove.

Generate a partial or entire as-maintained structure (top down)

1. Open the neutral structure in the Service Editor view.

Delete a location
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2. Configure the neutral structure by setting revision rules and/or variant rules.

3. From the Service Editor view, select the top-level part from the neutral structure.

4. Right-click and choose Generate As-Maintained Structure.

Teamcenter displays the Generate As-Maintained Structure dialog box.

5. Enter the following information.

Field name Definition Valid values

Serial Number Serial number for the generated
physical part.

This field is optional or unavailable
in the following situations:

• Optional if a serial number
generator or a generic serial
number generate is defined for
the neutral part.

Note:

See Serial number
generator and generic
serial number generator
for more information on
the behavior of these
number generators.

• Unavailable if the Serialized
property is set to false in
the part logistics form that is
attached to the neutral part.

Select Use Serial Number
Generator to generate the
serial number according to the
parameters of a serial number
generator.

Alphanumeric (1–128
characters)

Lot Number Lot number for the generated
physical part.

You must first create the lot for
the neutral part.

Alphanumeric (1–128
characters)

6. Generating as-maintained physical structures
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Field name Definition Valid values

The Lot list is unavailable if the Lot
property is set to false in the part
logistics form that is attached to
the neutral part.

Manufacturer's
ID

Manufacturer of the physical part.

The Manufacturer's ID box is
automatically populated if you
entered a lot number.

Alphanumeric (1–128
characters)

Structure Context
Name

The name of the structure context
used to store the neutral product
configuration information.
The structure context name is
automatically named with the part
number of the neutral part. If
the part is serialized and you
type the serial number in the
Serial Number box, the structure
context name is automatically
named using part number/serial
number. You can use these values
or type in a new value.

Alphanumeric (1–128
characters)

Manufacturing
Date

Manufacturing date for physical
structure. The manufacturing date
must be before the installation
date.

Click the Set Date  button
and select a date from the
calendar.

Installation Time Installation date for physical
structure. The installation date
must be after the manufacturing
date.

Click the Set Date  button
and select a date from the
calendar.

Location Name The location of the physical part. Alphanumeric (1–128
characters)

Disposition Value Disposition of the physical part.

Note:

If the
Disposition_Propagate_To_
Child preference is set to
true, the disposition is also
applied to the children parts
of the structure.

Alphanumeric (1–128
characters)

Generate a partial or entire as-maintained structure (top down)
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Field name Definition Valid values

Number of Levels Number of levels to be generated
for the physical structure. If you
want to generate physical parts for
the entire structure, type All in the
Number of Levels box.

Integer or All

Quantity Number of physical parts to
generate for the top-level part.

If it is a lot part, the quantity, if
a whole number, is deducted from
the lot. If the quantity is not a
whole number, it is not deducted
from the lot.

To set the quantity, the Preserve
Quantity property for the neutral
part must be set to true.

Number

6. If you have defined a serial number generator for the neutral part, select the Use Serial Number
Generators check box to enable it. The serial number generator automatically creates serial
numbers for all the parts within the as-maintained physical structure that have defined serial
number generators. If you have defined a generic serial number generator, the serial number will
be created for the serialized parts for which the serial number generator is not defined, and you will
be informed that generic serial number generator is being used.

6. Generating as-maintained physical structures
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7. Click OK to generate the as-maintained physical structure or click Cancel to exit.

The physical structure is generated from the neutral structure.

 BH001–nn/MTrucknn–A
BH012-nn/A

BH013-nn/A

BH014–nn/SHnn–001–A

BH015-nn/A

BH016-nn/A

BH017-nn/A

BH018-nn/A

BH019–nn/JBnn–001–A

BH019–nn/JBnn–002–A

BH020–nn/A

Generate a partial or entire as-maintained structure (top down)
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Serial number generator and generic serial number generator

A serial number generator applies unique serial numbers for a given manufacturer, for parts designated
as serialized. You can use either of the two types of number generators, the serial number generator or
the generic serial number generator. The two types of serial number generators are different in the way
that serial numbers are applied to newly created physical parts from neutral structures.

Serial number generator behavior

A serial number generator (SNG) is applied to an individual part in a neutral structure. If that part has
the serialized parameters set to true, the SNG is applied when you generate a physical structure.

(1) Part to which an SNG is applied.

(2) Physical part created with SNG applied.

(3) Serial number assigned via SNG.

Generic serial number generator behavior

A generic SNG, once set, is applied globally to all parts generated from the neutral structure.

Note:

If an individual part has an SNG applied and a generic SNG is subsequently set, the individual part
SNG takes precedent. Therefore it is important to apply SNGs for individual parts before you apply
a generic SNG.

6. Generating as-maintained physical structures
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(4) Neutral structure and a generic SNG has been set.

(5) Physical structure generated with a generic SNG set.

(6) Serial numbers assigned via generic SNG.

(7) Physical part created with generic SNG set; however, an SNG had previously been applied to the part
in the neutral structure.

Build an as-maintained physical structure (bottom up)

You can build an as-maintained physical structure by installing existing physical parts in the structure.

Create configured as-maintained structure using variants

Configure neutral structures

Service Lifecycle Management supports the creation of physical structures based on specific optional
product features. You use the Teamcenter Product Configurator to define various options.

Note:

To learn more about the Siemens Digital Industries Software Product Configurator, refer to the
documentation for the Product Configurator.

You create a configured neutral structure, or service bill of materials (sBOM), by applying variants before
you create as-built and as-maintained physical structures and service plans.

Build an as-maintained physical structure (bottom up)
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Once the physical structure is created, there is no association to the configured sBOM. This means that
any subsequent changes to the sBOM configuration are not reflected in the physical structure.

Create configured as-maintained structure

You create a configured as-maintained structure by first configuring variants on the neutral structure, or
service bill of materials (sBOM).

1. Open a neutral structure that contains variants in Service Manager.

2. Apply variants by choosing Tools → Variants → Configure Variants.

The Variant Configuration View (Structure Manager) page is displayed. It contains the variants
that are included in the sBOM.

3. Select the variants you want to apply, such as engine size, color, or model.

6. Generating as-maintained physical structures

6-18  Service Manager, Service Lifecycle Management 2412
© 2024 Siemens



4. Click the arrow  to apply the current configuration to the associated structure.

5. To update the sBOM to reflect the chosen variants, choose View and click Show Unconfigured
Variants to deselect it.

Create configured as-maintained structure
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6. To create the configured as-maintained structure, right click the root node of the sBOM, and choose
Generate As-Maintained Structure.

7. Enter the required information in the Generate As-Maintained Structure dialog box and click OK.

8. (Optional) Right-click the root node and choose Expand Below to see all of the parts in the
configured as-maintained structure.

Note:

The as-maintained structure configuration matches the configuration of the configured
sBOM.

Apply saved variant rules to the sBOM

You can also create a configured sBOM by applying saved variant rules.

1. Highlight the root node of the sBOM and choose Tools → Variants → Apply Saved Variant Rules.

The Search and Load Variant Rule(s) dialog box is displayed.

6. Generating as-maintained physical structures
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2. Enter search criteria and click Search.

3. Choose a saved variant rule and click OK.

The sBOM is configured according to the saved variant rule.

4. To create the configured as-maintained structure, highlight the root node of the sBOM and right-
click, and choose Generate As-Maintained Structure.

5. Enter the required information in the Generate As-Maintained Structure dialog box and click OK.

6. (Optional) Right-click the root node and choose Expand Below to see all of the parts in the
configured as-maintained structure.

Note:

The as-maintained structure configuration matches the configuration of the configured
sBOM.

View the neutral structure details

You can view the neutral structure and the structure context information from which the physical
structure is realized.

1. From the navigation pane, click Service Manager.

2. Click Open by Name  to open the physical structure or part.

3. Select the physical structure parent part.

4. Right-click the physical part and choose Open with → Details.

The Details pane appears at the bottom and displays the neutral structure and context information
used to generate the physical structure.

5. In the Details pane, select the neutral structure.

View the neutral structure details
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6. Right-click and choose View Properties.

The properties of the neutral structure from which the physical structure is realized, are displayed.

7. Click Cancel to close the properties window.

8. In the Details pane, select the structure context.

9. Right-click and choose Send to → Multi-Structure Manager.

The neutral structure is displayed in Multi-Structure Manager. Multi-Structure Manager displays the
configured variants and options that were used when generating the physical structure.

Duplicate an as-maintained structure

You can duplicate an as-maintained physical structure to create a copy of an existing physical structure.
The copied physical structure contains the installed alternate, substitute, deviated, and extra to design
parts from the original structure.

When you duplicate an as-maintained physical structure, the following occurs:

Note:

The sequence of the parts in the original structure is maintained in the new duplicated structure.

• The duplicate physical structure uses the same structure context as the original structure.

• The duplicate physical structure is validated for a unique serial number and manufacturing ID, if those
values are entered.

• The child parts of the duplicate physical structure inherit the manufacturing ID from the parent.

• The Part Used column for all the child parts of the duplicate physical structure is set to Missing except
in the following cases where the Part Used is set to Preferred:

• Parts that do not require a serial or lot number.

• Serialized parts that have a serial number generator.

• The deviated parts in the original structure are:

• Copied to the duplicate physical structure, if the ReUseAuthorizedDeviation global constant is set
to True, to reuse the same deviation.

• Ignored and the preferred parts are used in the duplicate physical structure, if the
ReUseAuthorizedDeviation global constant is set to False.

6. Generating as-maintained physical structures
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1. From the navigation pane, click Service Manager.

2. Click Open by Name  to open the as-maintained physical structure or physical part that you
want to copy.

3. Select the top-level part from the physical structure if you want to duplicate the entire structure or
select the physical part if you want to copy only the physical part.

4. Choose File → Duplicate As-Maintained Structure or right-click the physical part and choose
Duplicate As-Maintained Structure.

5. In the Duplicate As-Maintained Structure dialog box, enter the following information.

Field name Definition Valid values

Serial Number Serial number for the copied physical
structure or part.

This field is unavailable if the original
physical structure or part did not
require a serial number.

Alphanumeric (1–128 characters)

Lot Lot number for the copied physical
structure or part.

This field is unavailable if the original
physical structure or part did not
require a lot number.

Alphanumeric (1–128 characters)

Manufacturer's ID Manufacturer of the physical part.

The Manufacturer's ID box is
automatically populated if you
entered a lot number.

Alphanumeric (1–128 characters)

Manufacturing
Date

Manufacturing date for physical
structure. The manufacturing date
must be before the installation date.

Click the Set Date  button and
select a date from the calendar.

Installation Time Installation date for physical structure.
The installation date must be after the
manufacturing date.

Click the Set Date  button and
select a date from the calendar.

Location Name The location of the physical part. Alphanumeric (1–128 characters)

Disposition Value Disposition of the physical part.

Note:

If the
Disposition_Propagate_To_Chi

Alphanumeric (1–128 characters)

Duplicate an as-maintained structure
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Field name Definition Valid values

ld preference is set to true, the
disposition is also applied to the
children parts of the structure.

Number of Levels Number of levels to be generated for
the physical structure. If you want to
generate physical parts for the entire
structure, type All in the Number of
Levels box.

Integer or All

6. If you have defined a serial number generator for the neutral part, select the Use Serial Number
Generators check box to enable it.

The serial number generator automatically creates serial numbers for all the parts within the
as-built or as-maintained physical structure that have defined serial number generators. If you have
defined a generic serial number generator, then the serial number is created for the serialized parts
for which the serial number generator is not defined, and you are informed that generic serial
number generator is being used.

7. Click OK to duplicate the physical structure or part.

Generate an as-maintained structure from an as-built structure

If you have purchased and have a license for the As-Built Manager application, you can generate an
as-maintained structure from an as-built structure. The as-built structure must be at a Released state.

Note:

The sequence of the parts in the as-built structure is maintained in the new as-maintained
structure.

1. From the navigation pane, click As-Built Manager.

2. Click Open by Name  to open the released as-built physical structure.

3. Select the top-level part from the as-built physical structure.

4. Right-click and choose Generate As-Maintained Structure.

Teamcenter displays the Generate As-Maintained Structure dialog box.

6. Generating as-maintained physical structures
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5. Click Set Date  and select a date from the calendar when the as-maintained structure was
created.

6. Choose the location where the physical parts are stored.

7. Choose the disposition of the physical part.

Note:

If the Disposition_Propagate_To_Child preference is set to true, the disposition is also
applied to the children parts of the structure.

8. Type the number of levels you want to generate for the physical structure in the Number of Levels
box. If you want to generate physical parts for the entire structure, type All.

9. Click OK to generate the as-maintained physical structure or click Cancel to exit.

Generate an as-built structure from an as-maintained structure

If you have purchased and have a license for the As-Built Manager application, you can generate an
as-built structure from an as-maintained structure. The as-maintained structure must be at a Released
state.

Note:

The sequence of the parts in the as-maintained structure is maintained in the new as-built
structure.

1. From the navigation pane, click Service Manager.

2. Click Open by Name  to open the released as-maintained physical structure.

3. Choose Window → Show View → Service Editor to open the Service Editor view.

4. From the Service Editor view, select the top-level part from the as-maintained physical structure.

5. Right-click and choose Generate As-Built Structure.

Teamcenter displays the Generate As-Built Structure dialog box.

6. Click Set Date  to set the rebuild date.

7. Type the number of levels you want to generate for the physical structure in the Number of Levels
box. If you want to generate physical parts for the entire structure, type All.

Generate an as-built structure from an as-maintained structure
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8. Click OK to generate the as-built physical structure or click Cancel to exit.

Generate multiple physical parts in as-maintained structure

Before you can generate multiple physical parts to an as-maintained structure, you or your administrator
must set the preference MROAllowMultipleStructureGeneration to True. Once the preference is set
to True, the option Structures to be Generated and the Open Generated Structure(s) check box are
included on the Generate As-Maintained Structure dialog box.

1. Select a line in the neutral structure.

2. Right-click and choose Generate As-Maintained Structure.

Teamcenter displays the Generate As-Maintained Structure dialog box.

3. In the Generate As-Maintained Structure dialog box, enter the following information.

6. Generating as-maintained physical structures
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Field name Definition Valid values

Serial Number Serial number for the physical
structure or part.

This field is unavailable if the original
physical structure or part did not
require a serial number.

Alphanumeric (1–128 characters)

Lot Lot number for the physical structure
or part.

This field is unavailable if the original
physical structure or part did not
require a lot number.

Alphanumeric (1–128 characters)

Manufacturer's ID Manufacturer of the physical part.

The Manufacturer's ID box is
automatically populated if you
entered a lot number.

Alphanumeric (1–128 characters)

Manufacturing
Date

Manufacturing date for physical
structure. The manufacturing date
must be earlier than the installation
date.

Click the Set Date  button and
select a date from the calendar.

Installation Time Installation date for physical structure.
The installation date must be later
than the manufacturing date.

Click the Set Date  button and
select a date from the calendar.

Location Name The location of the physical part. Alphanumeric (1–128 characters)

Disposition Value Disposition of the physical part.

If the
Disposition_Propagate_To_Child
preference is set to true, the
disposition is also applied to any
children parts of the structure.

Alphanumeric (1–128 characters)

Number of Levels Number of levels to be generated for
the physical structure. If you want to
generate physical parts for the entire
structure, type All in the Number of
Levels box.

Integer or All

Structures to be
Generated

The number of physical structures you
want to generate.

Integer

Open Generated
Structure(s)

When you select this, each new
structure opens in a separate tab.

Select or clear the check box.

Generate multiple physical parts in as-maintained structure
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4. Click OK to generate the as-maintained physical structures or click Cancel to exit.

6. Generating as-maintained physical structures
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7. Setting up as-maintained physical
structures
Setting up as-maintained physical structures

A user such as production planner manages the as-maintained physical structure according to
organization needs and requirements as shown in the following figure.

You can set up and manipulate physical structures by:

• Updating physical part properties.

• Resolving missing parts by adding serial number, lot, or manufacturing information to the physical
part.

• Assigning lot numbers to physical parts.

• Renaming as-maintained physical parts.

• Installing and uninstalling physical parts from an as-maintained structure.

• Replacing physical parts in an as-maintained structure.
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• Rebasing physical parts in an as-maintained structure.

• Deleting physical parts from an as-maintained structure.

• Implementing deviations.

• Releasing the as-maintained physical structure.

• Updating the released as-maintained physical structure.

• Updating as-built physical structures using Excel Live.

• Viewing untraced structures.

Resolving missing parts

After you generate the as-maintained structure, a Missing status for the Parts Used column occurs if
there is missing information for the child physical parts. Missing information may include a missing serial
number, lot number or manufacturer id for the physical part. When you enter the missing information,
the Parts Used column is automatically changed to Preferred.

A physical part has the Parts Used column set to Missing for the following conditions:

• The lot number is missing for a lot physical part.

• The serial number is missing for a serialized physical part.

• The manufacturer ID is missing for a nonserialized, nonlot part.

• The lot number or serial number is missing for a serialized lot part.

• The child physical part has been uninstalled from the physical structure.

Managing physical part properties

Update physical part properties

You can update a physical part using either Service Manager or My Teamcenter. The physical part
properties that can be updated are shown in the following table.

7. Setting up as-maintained physical structures
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Editable property Property description Editable in Service
Manager

Editable in My
Teamcenter

Serial number Serial number of the
physical part.

Yes Yes

Manufacturer's ID Manufacturer ID of the
physical part.

Yes Yes

Lot number Lot number of the
physical part.

Yes Yes

Manufacturing date The date the physical
part was manufactured.

Yes Yes

Installation date The date the physical
part was installed.

Yes Yes

Physical Part UID Unique UID for the
physical part. Once the
UID is assigned, it
cannot be edited again.

Yes No

From My Teamcenter:

1. Search for the physical part.

2. Right-click the physical part in the results list and choose Edit Properties.

3. From the Checkout dialog box, click Yes to check out the physical part.

4. From the Edit Properties dialog box, modify the properties.

5. To save and check in the modified properties, click Save and Check-In.

From Service Manager:

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open By Name  to open the physical structure or part.

4. Select the BOM line containing the physical part.

5. Double-click the attribute column and type the new value.

Update physical part properties
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Assign a serial number

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the physical structure or part.

4. Select the BOM line containing the physical part.

5. To add a serial number, double-click in the Serial Number column and type the serial number.

The serial property for the serialized physical part is assigned and the Part Used column is set to
Preferred.

Assign a manufacturer ID

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the physical structure or part.
Select the physical part.

4. To add a manufacturer ID, double-click the Manufacturer's ID column and type the manufacturer
ID.

The manufacturer ID property is set for the physical part and the Part Used column is set to
Preferred.

Assign a lot number

In Service Manager, you can assign a lot number to a physical part or change a physical part lot number.

When you assign a lot number to a physical part, the physical part's manufacturer changes to the lot
manufacturer.

After you assign a lot number to a physical part, the lot usage property of the specified lot is also
updated. Lot usage is a property that tracks the number of physical parts associated to a specified lot.

7. Setting up as-maintained physical structures
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Note:

You must create a lot definition for the neutral part before you can assign a lot number to a
physical part.

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the physical structure or part.

4. Select the BOM line containing the physical part. Right-click and choose Assign Lot.

5. In the Assign Lot dialog box, select a lot number from the Lot Number list.

6. In the Quantity box, type the number of physical parts to assign to the lot.

If the part is a Preserve Quantity part, the quantity is checked against the expected quantity (the
quantity from the neutral structure and the nonmissing parts from the occurrence).

• If the quantity is the same as the expected quantity, Teamcenter assigns the lot and marks the
physical part as Preferred.

If the quantity is a whole number, it is deducted from the lot. If the quantity is not a whole
number, it is not deducted from the lot.

• If the quantity is less than expected, a missing part is generated with the remaining quantity.

• If the quantity is greater than expected, Teamcenter displays an error.

• If the identified (nonmissing) parts are installed under the selected missing part and the quantity
is not the expected quantity, Teamcenter displays an error.

• If you are assigning a new lot to the selected physical part that already has a lot assigned, the
quantity is not changed, only the lot information.

7. Click OK.

The lot property for the physical part contains the assigned lot and the Part Used column is set to
Preferred.

Assign a lot number
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Install a physical part

You can install an existing physical part in a physical location at a specified usage into an as-maintained
physical structure. If the installed physical part is not a valid preferred, alternate, or substitute, you must
set up a deviation to install the deviated part.

Note:

You cannot install a physical part under a released physical part.

To install a physical part, you simply copy the physical part you want to install, navigate to the as-
maintained structure where you want to install the physical part, and install the copied physical part into
the as-maintained structure.

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the physical structure or part you
want to install.

4. Choose one of the following methods to identify the physical part you want to install:

a. Copy the physical part you want to install.

A. Right-click the physical part and choose Copy.

B. Select the physical structure where you want to install the physical part.

C. Right-click the parent and choose Install Physical Part or click the Install Physical Part
button  on the main toolbar at the top of the Service Manager pane.

The Install Physical Part dialog box appears.

The To Be Installed Physical Part field is set to the copied physical part.

D. Select the usage name to set the usage for the installed physical part. If the physical part
is an addition to the physical structure, select Extra to Design as the usage.

b. Search for the physical part you want to install.

A. Select the physical structure where you want to install the physical part.

B. Right-click the parent and choose Install Physical Part or click Install Physical Part 
on the main toolbar at the top of the Service Manager pane.

7. Setting up as-maintained physical structures
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The Install Physical Part dialog box appears.

C. Select the usage name to set the usage for the installed physical part. If the physical part
is an addition to the physical structure, select Extra to Design as the usage.

D. Perform the following steps to search for the physical part to be installed:

i. Click  and select Add.

The Installable Physical Parts dialog box appears.

ii. Click the Search tab and enter the following information you want to use as filters
for searching.

Field name Definition Valid values

Part Number Part number of the
physical part.

Alphanumeric (1–128
characters)

Serialized Value of the serialized
property.
Click true to search for
serialized parts.

Boolean

Serial Number After Value of the serial
number to filter physical
parts with serial
numbers greater than
the value entered.

Alphanumeric (1–128
characters)

Serial Number Before Value of the serial
number to filter physical
parts with serial
numbers less than the
value entered.

Alphanumeric (1–128
characters)

Lot Value of the lot
property.
Click true to search for
lot parts.

Boolean

Lot number Lot number of the
physical part.

Alphanumeric (1–32
characters)

Manufacturer's ID Manufacturer of the
physical part.

Alphanumeric (1–128
characters)

Manufactured After Manufacturing date
used to filter
physical parts with

Click Set Date  and select
a date from the calendar.

Install a physical part
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Field name Definition Valid values

manufacturing dates
greater than the date
entered.

Manufactured Before Manufacturing date
used to filter
physical parts with
manufacturing dates
before the date entered.

Click Set Date  and select
a date from the calendar.

Location Name Location name of the
physical part.

Select one or more location
names.

Disposition Value Disposition values for
the physical part.

Select one or more
disposition values.

iii. Click Find.

7. Setting up as-maintained physical structures
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The results display the valid preferred, alternate, substitute and deviated physical
parts that can be installed.

iv. Select the physical part from the results and click OK.

The Install Physical Part dialog box reappears with the To be Installed Physical
Part field set to the selected physical part.

5. Click Set Date  to set the installation date when the installation occurred.

6. If the Usage Name is set to Extra to Design, in the Extra to Design Usage Name box, type the
usage name for the installed physical part.

1. Click OK to install the physical part.

If the installed Preferred part is a Preserve Quantity part, the quantity is checked against the
neutral structure.

Install a physical part
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• If the quantities match, the physical part is installed in the structure.

• If the quantity is greater than allowed, the installation is prevented.

• If the quantity is less than allowed, the installation is completed, and a missing part is generated
with the remaining quantity.

The Part Used column for the physical part is set to one of the following values after installing a physical
part:

• Preferred

If the newly installed physical part is a valid preferred physical part for the selected usage, the Part
Used column is set to Preferred.

• Substitute

If the newly installed physical part is a valid substitute, the Part Used column is set to Substitute.

• Alternate

If the newly installed physical part is a valid alternate, the Part Used column is set to Alternate.

• Deviated

If the newly installed physical part is an approved deviation from the design and is not a valid
substitute or alternate for selected usage, the Part Used column is set to Deviated.

• Extra to Design

If the newly installed physical part is an approved deviation and does not exist in the design structure,
the Part Used column is set to Extra to Design.

Uninstall a physical part

You can uninstall a child physical part from a parent physical part in the as-maintained structure.

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the physical structure where you
want to uninstall the physical part.

4. Select the child physical part. Right-click and choose Uninstall Physical Part.

7. Setting up as-maintained physical structures
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The Uninstall Physical Part dialog box appears.

5. Click Set Date  to set the uninstallation date when the uninstallation occurred.

6. Select the disposition value to set the disposition type for the uninstalled physical part.

7. Select the location name to set the physical location for the uninstalled physical part.

8. Click OK to uninstall the physical part.

The physical part in uninstalled from the structure and the Part Used column is set to Missing.

If there is more than one missing part, then a single missing part is created with the total allowed
remaining quantity, and the other missing parts are deleted.

If the uninstalled Preferred part is a Preserve Quantity part, the quantity is checked against the
neutral structure.

• If the quantities match, the physical part is uninstalled from the structure.

• If the quantity is greater than allowed, the uninstallation is prevented.

• If the quantity is less than allowed, the uninstallation is completed, and a missing part is
generated with the remaining quantity.

Note:

If the physical part to uninstall is set as Extra to Design, the uninstall action uninstalls
the selected physical part and removes the selected lines from the as-maintained structure
completely. Otherwise, the physical part is uninstalled and the Part Used is set to Missing.

As-Maintained Structure Part Used
 BH001–nn/MTrucknn–A Preferred

 BH012-nn/A Preferred

 BH013-nn/A Preferred

 BH014–nn/SHnn–001–A Preferred

 BH020–nn/A Missing

Uninstall a physical part
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Replace a physical part

You can replace an existing or missing physical part with a different physical part in an as-maintained
structure. When you replace a physical part, the following occurs:

• The original physical part is removed from the structure and replaced with the new physical part.

• The installation time on the replacement physical part is updated with the date the physical part was
replaced.

• The uninstall time on the original physical part is updated with the date the physical part was
replaced.

Note:

If the replacement part is not a valid preferred, substitute, or alternate part, you must set up an
authorized deviation.

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the physical structure where you
want to replace the physical part.

4. Choose one of the following methods to identify the physical part you want to use as the
replacement.

a. Copy the physical part you want to use as the replacement.

A. Click Open by Name  to open the replacement physical part.

B. Right-click the replacement physical part and choose Copy.

C. Right-click the physical part you want to replace and choose Replace Physical Part or
click Replace Physical Part  on the main toolbar at the top of the Service Manager
pane.

The Replace Physical Part dialog box appears.

The To Be Installed Physical Part field is set to the copied physical part.

b. Search for the physical part you want to use as the replacement.

7. Setting up as-maintained physical structures
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A. Right-click the physical part you want to replace and choose Replace Physical Part or
click Replace Physical Part  on the main toolbar at the top of the Service Manager
pane.

B. Perform the following steps to search for the physical part that will be used as the
replacement.

i. Click  and select Add.

The Installable Physical Parts dialog box appears.

ii. Click the Search tab and enter the following information you want to use as filters
for searching.

Field name Definition Valid values

Part Number Part number of the
physical part.

Alphanumeric (1–128
characters)

Serialized Value of the serialized
property.
Click true to search for
serialized parts.

Boolean

Serial Number After Value of the serial
number to filter physical
parts with serial
numbers greater than
the value entered.

Alphanumeric (1–128
characters)

Serial Number Before Value of the serial
number to filter physical
parts with serial
numbers less than the
value entered.

Alphanumeric (1–128
characters)

Lot Value of the lot
property.
Click true to search for
lot parts.

Boolean

Lot number Lot number of the
physical part.

Alphanumeric (1–32
characters)

Manufacturer's ID Manufacturer of the
physical part.

Alphanumeric (1–128
characters)

Manufactured After Manufacturing date
used to filter
physical parts with

Click Set Date  and select
a date from the calendar.

Replace a physical part
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Field name Definition Valid values

manufacturing dates
greater than the date
entered.

Manufactured Before Manufacturing date
used to filter
physical parts with
manufacturing dates
before the date entered.

Click Set Date  and select
a date from the calendar.

Location Name Location name of the
physical part.

Select one or more location
names.

Disposition Disposition values for
the physical part.

Select one or more
disposition values.

iii. Click Find.

The results display the valid preferred, alternate, substitute, and deviated physical
parts that can be used to replace the physical part.

7. Setting up as-maintained physical structures

7-14  Service Manager, Service Lifecycle Management 2412
© 2024 Siemens



iv. Select the physical part from the results and click OK.

The Replace Physical Part dialog box reappears with the To be Installed Physical
Part field set to the selected physical part.

5. Click Set Date  to set the replacement date when the replacement occurred.

6. Select the disposition value to set the disposition type for the replaced physical part.

7. Select the location name to set the physical location for the replaced physical part.

8. Click OK to replace the physical part,

If the installed Preferred part is a Preserve Quantity part, the quantity is checked against the neutral
structure.

• If the quantities match, the original physical part is replaced.

Replace a physical part
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• If the quantity is greater than allowed, the replacement is prevented.

• If the quantity is less than allowed, the replacement is completed, any existing missing parts are
deleted, and a missing part is generated with the remaining quantity.

Rebasing physical parts

Rebasing a physical part relates the as-maintained structure to a different configuration of a neutral
structure. The new rebased structure uses the new configuration for its structure context.

Note:

The physical part must have a Released status before you can rebase it.

The following applies to usages in the rebased physical configuration:

• If the component exists in the rebased neutral structure, the rebased physical part is assigned the
same usage as specified in the neutral structure.

• If the corresponding usage of a component is not present in the rebased neutral structure, the usage
of the rebased physical part is set to extra to design and requires no deviation authorization.

• If the component and usage is new in the rebased neutral structure, the usage of the physical part is
set to missing.

A rebase can be performed on any level within the physical and corresponding neutral structure.
However, the following two rebase scenarios cause a warning message to be displayed, although you
can proceed with the rebase action once you acknowledge the warning:

• If the selected neutral part is different from the selected physical part. For example, if you try to
rebase the old air conditioner to the new, redesigned air conditioner, which has a different part
number.

• If the occurrences between the selected neutral and physical part are different. For example, if you try
to rebase the left wheel occurrence to the right wheel occurrence.

Example:

You may want to rebase a physical structure to the same neutral structure, but with a different
variant.

The original physical structure was generated from the bearing housing assembly neutral structure
that contained the regular bearing housing. It was rebased to the bearing housing assembly
neutral structure with the heavy duty bearing housing. As the following figure shows, because
the rebased neutral structure contains the heavy duty bearing housing, the physical structure now
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contains a missing part for the heavy duty bearing housing and the regular bearing housing is
installed as extra to design.

When you rebase the top-level parent in a physical structure, the rebase action works on multiple levels
of the structure. For that reason, the physical structure modifications occur not only at the top level, but
also to any subassemblies and child parts.

Example:

The image below shows a neutral structure that was used to generate the physical structure in the
top pane, shown edited after the original physical structure was generated, and a rebased physical
structure in the bottom pane.

Rebasing physical parts
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• (1) The child part 029884/--A-Child_1 was part of the original neutral structure when the
physical structure was generated. After the physical structure was originally created, the child
part 029884/--A-Child_1 was removed from the neutral structure.

(2) Once the physical structure is rebased, the child part 029884/--A-Child_1 is marked as Extra
To Design.

• (3) The sub-assembly 029909/--A-Child_4 was not part of the original neutral structure when
the physical structure was generated. After the physical structure was originally created,
the sub-assembly 029909/--A-Child_4 was added to the neutral structure. Once the physical
structure is rebased, the sub-assembly 029909/--A-Child_4 is identified as a new part in the
rebased assembly.

• (4) The two parts, 029885--A-Child_2 and 029808--A-Child_3, have not changed in the neutral
part and therefore are not changed in the physical part.

Maintaining usage and common parts when rebasing with another
parent structure

When you create a new physical structure by replacing or copying some of the parts of an existing
structure, it is important to maintain the part numbers and usage for the parts that are not changed in
the new structure.

The example below shows the before and after rebasing condition of two structures that contain both
common and unique parts.
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Before the rebase action:

Note:

When you select the top nodes of both structures and select rebase, the following warning
message is presented. Choose Yes to continue the rebase action.

The selected Physical Part does not match the selected Neutral Part. Do you still want to
proceed with the Rebased action?

After the rebase action:

• (1) The part 029905/--A-Logo Sam, which was a part of the original neutral structure but was
replaced with (2) 029907/A;1-Delta_logo is identified as Extra to Design.

• (3) The main node part name, number, and usage are updated to reflect the new assembly.

Maintaining usage and common parts when rebasing with another parent structure
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• (4) The part 029907/A;1-Delta_logo, since it has been replaced is now identified as missing in the
neutral structure.

• (5) The parts 029901/--A-Display and 029904/--A-Body remain as is in the new structure and their
part numbers, revisions, and usage, remain the same as before the rebase action.

Rebased non-serialized parts with lot set to false

If you rebase a physical structure, certain child parts are not identified as missing. The child parts that are
not serialized and whose lot property is set to false are not considered to be missing.

Example:

In this example, a car is released and then a new engine is added to the neutral structure. Only
parts that are either serialized or are assigned a lot property are considered missing from the
original physical structure.

The car assembly 001636/A;1 includes the engine 001640/A;1. It is released and a physical structure
was created from it.

A new engine assembly, 001652/A;1, is added to the neutral structure. Notice the assembly itself is
serialized and has the lot property set to true. However, some of the child parts are either serialized or
have the lot property set to true, and one child is non-serialized and has the lot property set to false.
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When the physical structure is rebased to the revised neutral structure, only the child parts that are
both non-serialized parts and have the lot property set to false are identified as preferred. All others are
identified as missing.

Rebase a physical part

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

Rebase a physical part

Service Manager, Service Lifecycle Management 2412  7-21
© 2024 Siemens



3. From the Service Editor view, click Open by Name  to open the neutral part to be used to
rebase the physical part.

4. Click Open by Name  to open the released physical part to be rebased.

5. Click Show/Hide lower Structure Panel  located at the top of the application to display the
neutral part and physical part using split structure panes.

6. Select the neutral part.

7. Select the released physical part.

8. Choose Tools → Rebase Physical Part.

The Rebase Physical Part dialog box appears.

9. Click Set Date  to set the rebase date when the rebase occurred.

10. (Optional) Type the name of the structure context used to store the neutral product configuration
information in the Structure Context Name box or use the name that is automatically generated.

The structure context name is automatically created using the part number of the rebased neutral
part. If the physical part has a serial number, the structure context name is automatically named as
part number/serial number.

11. Click OK to rebase the physical part.

Teamcenter checks the quantities of the parts installed in the rebased structure.

• If the quantity is over the allowed limit, the part is changed to a Extra to Design part.

• If the quantity is under the allowed limit, the part is shown as installed in the correct position, but a
new missing part is generated with the remaining quantity.

Rebasing to a new parent with unique attributes

When you rebase a physical structure to a different parent, the default property used to determine if a
part is Preferred, Missing, or Extra To Design, is the part number.

However, in some implementations, you may need to use properties other than the part number to
identify the part status after you rebase the physical structure to a new parent.

You can set the preference SLMRebaseToNewParentOccProperties to the internal name of numerous
properties. Once configured, Service Lifecycle Management uses the properties specified instead
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of the part number. For example, to use the Occurrence Name to determine part status, enter
bl_occurence_name for the preference value.

Note:

Occurrence Name is applied to the neutral structure and Usage is applied to the physical
structure. Both are based on the internal name bl_occurence_name.

To see the available property values in Service Lifecycle Management, you right-click any column header
in the Service Editor panel and select Insert Column(s). Then you select the Show internal names
of properties option on the Change Columns dialog box to change from displayed names to internal
names, which allows you to see the preference values available to use for this preference.

Updating occurrence-specific property during rebase

When you create a physical structure from a neutral structure, any occurrence-specific properties in the
neutral structure are included in the physical structure.

If you rebase the physical structure to a different neutral structure, Service Lifecycle Management
updates any occurrence-specific properties that exist in both the initial neutral structure and the new
neutral structure.

For example, the physical structure 016895/--A was created from the neutral structure 016895/A;1-
Car_A.

Updating occurrence-specific property during rebase
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• (1) Neutral structure 016895/A;1-Car_A that is used to initially create the physical structure (2)
016895/--A.

• (3) Occurrence-specific properties in the neutral structure that are included in the (4) physical
structure.

The physical structure 016895/--A is rebased to a different neutral structure.
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• The physical structure (2) 016895/--A is rebased to a different (1) neutral structure, 016900/A;1-
Car_B.

• (4) Occurrence-specific properties in the physical structure are updated to reflect the properties in the
new (3) neutral structure.

Note:

If a physical part is included in an open service event and if the same physical part is rebased to a
new neutral part, then the rebase fails and results in the error Physical part cannot be rebased
because it has open service events.

You must approve all the service events that include the physical part before rebasing that physical
part to a new neutral part.

Delete a physical part

You can delete a physical part if it has no child physical parts. To delete a physical part with child physical
parts, you must delete the last child physical part first and work your way up to the parent physical part.

Note:

You can delete a physical part only from My Teamcenter.

Delete a physical part
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1. In My Teamcenter, select the physical part to delete.

2. Choose Edit → Delete.

Implementing deviations

Implementing deviations

Deviations occur when you install a physical part that is not a preferred, alternate, or substitute physical
part into an as-maintained structure. An authorized deviation can be used only once. If you uninstall and
reinstall a deviated physical part, a new authorization must be created.

The workflow to add a deviated physical part to your as-maintained structure is as follows:

1. Create the deviation authority item class for the physical part.

A deviation authority item class authorizes the installation of a physical part that is a deviation from
the design structure. The MRO Deviation Authority List LOV determines the list of item classes
that can be used to authorize a deviation.

By default, the item classes that can be used as a deviation authority item are:

• Deviation document
• Deviation request
• Service event
• Aerospace and Defense deviation request

2. Set up the deviation to specify the authorized deviation item class used for the deviated physical
part. The authorized deviation item must not be released to set up a deviation.

3. Route the authorized deviation item through the appropriate workflow.

4. Install the deviated physical part into your as-maintained structure.

Create a deviation authority item

1. Click My Teamcenter.

2. Choose File → New → Item.

3. From the New Item dialog box, select Deviation Document and click Next.

4. Enter information into all the required fields.

5. Click Finish.
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6. Click Close to close the screen or repeat steps 1–5 to create an additional deviation document.

Set up a deviation

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the deviated part.

4. Right-click the deviated part and choose Copy.

5. From the Service Editor view, click Open by Name  to open the physical structure where you
want to install the deviated part.

6. Right-click the parent physical part and choose Setup Deviation.

The Setup Deviation dialog box appears.

7. Click  to set the value of Document Id and select Add.

Note:

The deviation authority item must not be released to set up a deviation.

8. Search for the deviation authority item ID using the search dialog box. You can use wildcards for
searching.

9. Click OK to set up the deviation. Alternatively, click Cancel to exit.

Send the deviation authority item through the required workflow

1. Select the deviation authority item.

2. Choose File → New → Workflow Process.

3. In the New Process Dialog window, type the process name in the Process Name box.

4. From the Process Template list, select TCM Release Process.

Set up a deviation
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Note:

The TCM Release Process workflow is provided with the Teamcenter Foundation feature.
You can configure this workflow or create your own to set up the process flow, reviewers, and
business validations required to route a deviation document for review and approval.

5. Click OK. Alternatively, click Cancel to exit.

Install a deviated part

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the deviated part.

4. Choose one of the following methods to identify the deviated physical part you want to install:

a. Copy the deviated physical part you want to install.

A. Right-click the physical part and choose Copy.

B. Select the physical structure where you want to install the deviated physical part.

C. Right-click the parent and choose Install Physical Part or click the Install Physical Part
button  on the main toolbar at the top of the Service Manager pane.

The Install Physical Part dialog box appears.

The To Be Installed Physical Part field is set to the copied physical part.

D. Select the usage name to set the usage for the installed deviated physical part. If the
physical part is an addition to the physical structure, select Extra to Design as the usage.

b. Search for the physical part you want to install.

A. Select the physical structure where you want to install the deviated physical part.

B. Right-click the parent and choose Install Physical Part or click the Install Physical Part
button  on the main toolbar at the top of the Service Manager pane.

The Install Physical Part dialog box appears.

C. Select the usage name to set the usage for the installed deviated physical part. If the
physical part is an addition to the physical structure, select Extra to Design as the usage.
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D. Perform the following steps to search for the physical part to be installed:

i. Click  and select Add.

The Installable Physical Parts dialog box appears.

ii. Click the Search tab and enter the following information you want to use as filters
for searching.

Field name Definition Valid values

Part Number Part number of the
physical part.

Alphanumeric (1–128
characters)

Serialized Value of the serialized
property.
Click true to search for
serialized parts.

Boolean

Serial Number After Value of the serial
number to filter physical
parts with serial
numbers greater than
the value entered.

Alphanumeric (1–128
characters)

Serial Number Before Value of the serial
number to filter physical
parts with serial
numbers less than the
value entered.

Alphanumeric (1–128
characters)

Lot Value of the lot
property.
Click true to search for
lot parts.

Boolean

Lot number Lot number of the
physical part.

Alphanumeric (1–32
characters)

Manufacturer's ID Manufacturer of the
physical part.

Alphanumeric (1–128
characters)

Manufactured After Manufacturing date
used to filter
physical parts with
manufacturing dates
greater than the date
entered.

Click the Set Date 
button and select a date
from the calendar.

Install a deviated part
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Field name Definition Valid values

Manufactured Before Manufacturing date
used to filter
physical parts with
manufacturing dates
before the date entered.

Click the Set Date 
button and select a date
from the calendar.

Location Name Location name of the
physical part.

Select one or more location
names.

Disposition Value Disposition values for
the physical part.

Select one or more
disposition values.

iii. Click Find.

The results display the valid deviated physical parts that can be installed.

iv. Select the physical part from the results and click OK.

The Install Physical Part dialog box reappears with the To be Installed Physical
Part field set to the selected physical part.

E. Click the Set Date  button to set the installation date when the installation occurred.

F. If the Usage Name is set to Extra to Design, in the Extra to Design Usage Name box,
type the usage name for the installed physical part.

G. Click OK to install the deviated physical part.

The deviated physical part is installed in the structure.

View the deviation authorization information

You can view the authorizing deviation item for a deviated part.

1. From the navigation pane, click Service Manager.

2. Select the physical structure containing the deviated part and choose Send to → My Teamcenter.

3. Click the Details tab.

The Allowed Deviation relation is displayed.
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4. Select the deviated part.

5. Right-click and choose Properties on Relation....

The properties of the Allowed Deviation relation are displayed.

The Deviation Authority field shows the deviation authority item used to authorize the deviation.

View the deviation authorization information
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Release an as-maintained physical structure

You can release the as-maintained structure after you finish building it.

1. From My Teamcenter or Service Manager, select the as-maintained structure you want to release.

2. Choose File → New → Workflow Process.

3. In the New Process Dialog box, choose Release As-Maintained Structure from the Process
Template list.

Note:

The Release As-Maintained Structure option is the standard workflow provided with the As-
Maintained Management application. This workflow also validates for any missing physical
parts.

You can configure this workflow or create your own to set up the process flow, reviewers, and
business validations required to release an as-maintained structure.

4. Click OK. Alternatively, click Cancel to exit.

Support customer-defined release

To support customer-defined releases, you can add custom release value in the BMIDE business object
constant maturityStatuses.

Update a released as-maintained physical structure

You can update the as-maintained structure by changing the structure after releasing it. A new revision
is created when changes such as uninstalling, installing, replacing, or rebasing physical parts are made
within the structure. A new build record is created for the revised structure.

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the released physical structure.

4. Change the physical structure by uninstalling, installing, replacing, or rebasing the physical parts
within the structure.
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Rename a physical part

You can rename an existing physical part to change the following properties:

• Part number

• Serial number

When you rename a physical part, the following occurs:

• The new serial number is checked for uniqueness.

• If a physical part is renamed using a different part number, the system does not check the existence of
a neutral item with the new part number.

• The physical realization relation remains intact between the original physical part (before renaming)
and the original neutral part.

Note:

If you want to relate the physical part or structure to a different neutral configuration, you need
to rebase the physical part.

1. From the navigation pane, click Service Manager.

2. Click Open by Name  to open the physical part you want to rename.

3. Choose Tools → Rename Physical Part.

The Rename Physical Part dialog box appears.

4. Enter the following information.

Field name Definition Valid values

New Part
Number

New part number for the renamed
physical part.

Alphanumeric (1–128
characters)

New Serial
Number

New serial number for the
renamed physical part.

This field is unavailable if the part
did not require a serial number.

Alphanumeric (1–128
characters)

5. Click OK to rename the physical part.

Rename a physical part
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View untraced structures

You can display the parts in the neutral structure that are not traceable in the related physical structure.
Parts that are not traceable have the part logistics property Traceable set to False in context of the
parent physical structure and a physical part is not generated for that neutral part.

The following occurs when you display an untraced structure in Service Manager:

• The untraced parts are displayed as neutral parts in the physical structure.

• Any action that can be run on neutral parts is available on the displayed untraced parts.

When viewing an as-maintained structure using visualization, you can also display the untraced parts.

1. From the navigation pane, click Service Manager.

2. Click Open by Name  to open the physical structure that you want to display the untraced parts
for.

3. Select the parent part of the physical structure.

4. Choose View → Show Untraced Parts or click the Show Untraced Parts button  on the main
toolbar at the top of the Service Manager pane.

The untraced parts are displayed.

 BH001/InTest–A
 BH012/A

 BH013/A

 BH014/A

 BH015/A

 BH016/A  untraced part

Updating structures using Excel Live

You can update physical structures using Excel Live. Teamcenter Extensions for Microsoft Office provides
synchronous access to Teamcenter workspace objects through Microsoft Office Excel. With the live Excel,
Extensions for Office gives Excel direct connectivity to the Teamcenter server and allows you to edit
physical structures using Excel.

To generate a file in live Excel, you choose the related option when exporting data for selected objects in
the Teamcenter rich client. The following occurs after export:
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• The data exported to the output file consists of property values for the objects.

• The exported property values are synchronized with the corresponding values in Teamcenter.

• Values that you edit in the output file are changed interactively in Teamcenter.

Updating structures using Excel Live
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8. Viewing as-maintained physical
structures
Viewing as-maintained physical structures

You can view as-maintained physical structures by:

• Creating revision rules.

You can create and apply a revision rule to select and view the appropriate status and operational
state of the physical parts in an as-maintained physical structure. A revision rule sets the criteria for
selecting the revision such as whether to load working revisions or released revisions or whether
the physical structure is operational. By specifying a time in history, you see the physical structure
effective at that time. For example, you may want to view only the released physical parts in the
structure on a specified date.

If no revision rule is specified, the current revision and configuration of the physical structure is
displayed.

• Viewing the top physical part.

You can view the top physical part for a selected physical part. The system displays the topmost
physical part parent for the selected physical part and all its intermediate parents in a tree structure.

Managing revision rules

When you create a revision rule for an as-maintained structure, you can set up rules for each or a
combination of the following conditions:

• Display the as-maintained structure at a specified date.

• Display the physical parts that are operational or nonoperational. When you set up a revision rule to
see only the operational structure, the system does not display the structure if the top-level physical
part is in a nonoperational state.

• Display the physical parts at a specified status.

After you create the revision rule, you must set the revision rule to apply the rule to your structure.

Create or edit a revision rule

1. From the navigation pane, click Service Manager.
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2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the structure that you want to
apply the revision rule to.

4. Select any BOM line in the physical structure.

5. Choose Tools → Revision Rules → Create/Edit.

The View/Set Current Revision Rule dialog box appears.

6. Choose Create.

The New Revision Rule dialog box appears.

7. Enter the following information for the new revision rule.

Field name Definition Valid values

Name Name for the revision rule. Alphanumeric (1–128
characters)

Description Description of the revision rule.
(optional).

Alphanumeric (1–240
characters)

8. Click the Set Date  button to set the effective date for the configuration. Select the Current
check box to set the current date.

9. Select the Show only Operational Configuration check box to display only operational structures.

10. Select the status for the state of the configuration you want to display. Select the Any check box to
display all the states.

11. Click OK to create the revision rule. Alternatively, click Cancel to exit.

The View/Set Current Revision Rule dialog box appears.

12. (Optional) Click Apply Rule if you want to set the revision rule.

13. To edit revision rules:

a. From the Rules pane in the View/Set Current Revision Rule dialog box, select the revision
rule you want to edit. Click Modify.

The Modify Revision Rule dialog box appears.
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b. Change the fields as required. Click OK to save the changes. Alternatively, click Cancel to exit.

14. To delete revision rules:

• From the Rules pane in the View/Set Current Revision Rule dialog box, select the revision rule
you want to delete. Click Delete.

Set the revision rule

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the structure that you want to
apply the revision rule to.

4. Select any BOM line in the physical structure.

5. Choose Tools → Revision Rules → View/Set Current.

The View/Set Current Revision Rule dialog box appears.

6. From the Rules pane in the View/Set Current Revision Rule dialog box, select the revision rule you
want to set.

7. Click OK or Apply to set the revision rule.

Set the revision rule date

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the structure that you want to
apply the revision rule to.

4. Select any BOM line in the physical structure.

5. Choose Tools → Revision Rules → Set Date.

The Set Date dialog box appears.

6. Click the Set Date  button to set the effective date for the configuration or select the Current
check box to set the current date.

Set the revision rule
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7. Select the Show only Operational Configuration check box to display only operational structures.

8. Click OK to set the date. Alternatively, click Cancel to exit.

Modify the current revision rule

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the structure that you want to
apply the revision rule to.

4. Select any BOM line in the physical structure.

5. Choose Tools → Revision Rules → Modify Current.

The Modify Current Revision Rule dialog box appears.

6. Change the fields as required. Click OK to save the changes. Alternatively, click Cancel to exit.

Show the top physical part

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the physical structure or physical
part.

4. Select the BOM line of the physical part.

5. Right-click and choose Show Top Physical Part.

The top-level parent and intermediate parents are displayed.

8. Viewing as-maintained physical structures
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9. Managing as-maintained physical
structures
Managing as-maintained physical structures

Users such as operators and asset managers maintain the as-maintained physical structure according to
organization needs and requirements as shown in the following figure.

You can manage as-maintained structures by:

• Managing physical part location movement by moving physical parts from one physical location to
another.

• Managing part disposition data by changing part dispositions and viewing disposition history to track
when a physical part changed dispositions.

• Tracking and recording part utilization.

• Tracking physical part usage.

• Managing assets by a user such as a asset manager that includes the following tasks:

• Creating asset group hierarchies and asset groups.

• Adding physical parts to asset groups.
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Move a part to another physical location

You can move a physical part from one physical location to another. The utilization information records
the physical location movements by capturing the time when the physical part is placed in a location
and when it is removed.

Note:

If the physical part is installed in a physical structure and is not the top-level parent, you cannot
move the physical part to a different location.

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From your home folder or from the Service Editor view, select all the physical parts you want to
change the location for.

4. Right-click and choose Move From.

5. Select the physical location.

6. Right-click and choose Move to.

7. Click the Set Date  button to set the move date when the physical part was moved to the new
location.

8. Click OK. Alternatively, click Cancel to exit.

Display physical location members

You can display the physical parts that are contained in the physical location. The locations are assigned
to the physical parts when you generate the as-maintained physical structure or when you move
physical parts from one location to another location.

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open By Name  to open the physical location.

4. Select the physical location.

5. Right-click and choose Show Contains View.

9. Managing as-maintained physical structures
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The Contains pane appears.

6. Click  next to the column and select a value to filter the results. You can filter the results by one or
more of the following properties:

• Object Name

• Type

• Part Number

• Serial Number

• Lot

• Manufacturer's ID

Managing physical part disposition data

What is disposition data?

Disposition data captures different states of a physical part. These states are classified as operational or
non-operational.

You can manage part disposition data by:

• Changing the disposition for a physical part. For example, you may want to change the disposition
from a operational disposition such as In-Service to a non-operational disposition such as In-Repair.

• Viewing the disposition history that is tracked for the physical part.

The following information is displayed in the disposition history view for the physical part.

Disposition history column name Description

Disposition Type Specifies the disposition of the physical part.

Operational Specifies whether the physical part at that
disposition was operational.

Disposition Start Time Specifies the date when the disposition type
was assigned.

Disposition End Time Specifies the date when the disposition type
was removed or changed.

What is disposition data?
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• The Disposition history shows the latest record of disposition with Start Time as selected time. When
you change the manufacturing date for the part, the first disposition Start Time is also updated with
the changed manufacturing date.

The second disposition onwards, the disposition start and end time for all other actions is intact even
of you change the manufacturing time.

Change part disposition

To change the disposition of a part, navigate to the Service Manager and make necessary changes in
the Service Editor view.

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From your home folder or from the Service Editor view, select all the physical parts you want to
change the disposition for.

If you select a parent part and the Disposition_Propagate_To_Child preference is set to true, the
disposition change is also applied to the child parts.

4. Right-click and choose Change Disposition.

The Change Disposition dialog box appears.

5. Select the new disposition value.

6. Click the Set Date  button to set the disposition date when the disposition changed.

7. Click OK to change the disposition. Alternatively, click Cancel to exit.

View disposition history

Navigate to the Service Editor view using the Service Manager to view the disposition history.

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the physical structure or physical
part.

4. Select the physical part.

9. Managing as-maintained physical structures
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5. Right-click the physical part BOM line and choose Show Disposition History.

The Disposition History pane appears.

Tracking part utilization

Tracking part utilization

A user such as an operator can record and track part utilization information based on life, observation
and date characteristic definitions defined for the neutral part. You can record values for the physical
part for all the characteristics related to the related neutral part. If you have purchased and have a
license for Service Event Management, utilization values are automatically recorded by creating service
events and activity entries; otherwise, you manually enter the values by using the Record Utilization
menu command.

Life characteristics are cumulated for the physical part and can be propagated throughout the entire
physical structure if any of the child physical parts share the same life characteristics. Date and
observation characteristics are not cumulated or propagated.

You must create a logbook before recording utilization information. The recorded information is stored
in the logbook log entries.

Create a logbook

1. From the navigation pane, click Service Manager.

2. Select a folder where you want to create the new logbook.

3. Choose File → New → Log Book.

4. In the New Log Book dialog box, enter the following information for the new logbook.

Field name Definition Valid values

Log Book Name The name of the logbook. Alphanumeric (1–128
characters)

Description The description of the logbook. Alphanumeric (1–240
characters)

5. Click OK to create the logbook. Alternatively, click Cancel to exit.

Record a utilization

1. From the navigation pane, click Service Manager.

Tracking part utilization
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2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the physical structure or physical
part.

4. Select the BOM line of the physical part you want to record the utilization for.

5. Right-click and choose Record Utilization.

The Record Utilization dialog box appears.

6. Select the log book to record the utilization entries.

7. Enter the following information for the utilization.

Field name Definition Valid values

Log Book Available log book values Available log book values

Description Description of the utilization Alphanumeric (1–240
characters)

Captured by User who captured the utilization
information

Alphanumeric (1–128
characters)

8. Click the Set Date  button and select a date from the calendar.

9. Select the Propagate check box to propagate the same data to any child physical part that shares
the same life characteristic definitions.

10. Supply the characteristic values to record the utilization.

• For a life characteristic, type the value.

• For an observation characteristic, select the value.

• For a date characteristic, click the Set Date  button and select a date from the calendar.

9. Managing as-maintained physical structures
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11. Click OK to record the utilization. Alternatively, click Cancel to exit.

View the part utilization data

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the physical structure or physical
part.

4. Select the BOM line of the physical part you want to view the utilization for.

5. Right-click and choose Show Utilization.

The Show Utilization pane appears and shows the utilization data.

Column name Description

Characteristics Name Specifies the name of the characteristic definition.

Unit Specifies the unit used for the characteristic
definition.

Time Since New Specifies the sum of all recorded values for a life
characteristic definition. If a revision rule is being
used, the value is the sum of all recorded values
since the revision rule date.

View the part utilization data
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Column name Description

Last Value Specifies the latest recorded value for an observation
characteristic definition or the latest date for a date
characteristic definition.

Last Utilization Date Specifies the latest date the utilization values were
recorded.

Time on Parent Specifies the accumulated life characteristic values
for a physical part since it was installed on the
parent.

Time Since Repair Specifies the accumulated life characteristic values
for a physical part since the last repair event.

Time Since Overhaul Specifies the accumulated life characteristic values
for a physical part since the last overhaul event.

View log entries

When you view the log entries for a physical part, the following information is displayed:

Column name Description

Log Entry Name of the log entry.

Recording Time Date and time that the utilization was recorded.

Captured By User who captured the utilization information.

Log Book Name of the log book.

Characteristic Name Name of the recorded life, observation, and date
characteristic.

Derived Is characteristic of derived type?

Value Value of the recorded life, observation, and date
characteristic.

Unit Unit of measure used for the recorded life and
observation characteristic.

Value Captured By User who captured the utilization formation.

Last modifying User User who entered or invalidated the data.

Creation date Date and time when value was first entered.

1. From the navigation pane, click Service Manager.

9. Managing as-maintained physical structures
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2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open By Name  to open the physical structure or physical
part.

4. Select the BOM line of the physical part you want to view the log entries for.

5. Right-click and choose Show Log Entries.

The Log Entries pane appears.

6. Expand the log entry to view all the characteristic definitions and their values.

Edit log entries

Before you can edit log entries, your administrator must set the site preference
MROEnableEditLogEntry to True. The default setting is False.

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

3. From the Service Editor view, click Open by Name  to open the physical structure or physical
part.

4. Right-click the BOM line of the physical part for which you want to view the log entries, and choose
Show Log Entries.

The Log Entries pane appears.

5. Expand the log entry to view all the characteristic definitions and their values.

6. Click in the row for the Log Entry for which you need to edit a value.

Log Entries tab information overview:

Edit log entries
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1. Value Editable
2. Value Captured By Editable
3. Derived Not Editable
4. History Not Editable

7. Edit the Utilization Characteristics as needed.

Allow a user to invalidate a log entry

The administrator can do the following to allow any user to update a log entry.

9. Managing as-maintained physical structures
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1. Add an ACL rule for the CharacteristicValue business object from Access Manager.

2. Give write privilege to desired users or roles, and restrict privileges for the world.

3. Update the value of the site preference MROEnableEditLogEntry to true.

Update a log entry

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

3. From the Service Editor view, click Open by Name  to open the physical structure or physical
part.

4. Right-click the BOM line of the physical part for which you want to view the log entries, and choose
Show Log Entries.

The Log Entries pane appears.

5. Expand the log entry to view all the characteristic definitions and their values.

6. Double-click the characteristic value to be invalidated.

The Update Utilization dialog box appears.

7. To update the utilization, enter the following:

Captured by = user who captured utilization, up to 128 Alphanumeric characters

8. Select the Propagate check box to propagate the same data to any child physical part that shares
the same life characteristic definitions.

9. Update the characteristic values to invalidate the old value and record the new utilization.

Update a log entry
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• For a life characteristic or an observation characteristic, type the value.

• For a date characteristic, click Set Date  and select a date from the calendar.

10. Click OK to record the utilization.

View physical part usage history

You can the display part usage information for a physical part. Usage information includes when a
physical part was installed, uninstalled, or replaced or when the location of a physical part was changed.

The following part usage information is displayed when you show the usage for a physical part.

Column name Description

Parent/Location Specifies the parent physical part in a physical
structure for physical part installation history.

Specifies the name of the physical part location for
physical part location history.

Type Specifies the usage type. If Type is set to
PhysicalPartRevision, you see the physical part
installation usage history.

If Type is set to PhysicalLocation, you see the
physical part location history.

Usage Specifies the physical part usage. The Usage is only
valid for physical part installation history.

In Time Specifies the installation time for physical part
installation history.

Specifies the time when the physical part was placed
in the location for physical part location history.

Out Time Specifies the uninstallation time for physical part
installation history.

Specifies the time when the physical part was
removed from the location for physical part location
history.

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

9. Managing as-maintained physical structures
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3. From the Service Editor view, click Open by Name  to open the physical structure or physical
part.

4. Select the BOM line of the physical part you want to view the part usage for.

5. Right-click and choose Show Physical Part Usage History.

The Physical Part Usage History pane appears.

Managing assets

What are asset groups and asset hierarchies?

Asset groups are collections of physical assets that define a logical grouping of physical parts. For
example, you may want to create an asset group defining a fleet of aircraft or ships.

Asset hierarchies are used to build a nested hierarchy of asset groups within asset groups. The following
figure shows an example of an asset hierarchy.

Create an asset group

1. From the navigation pane, click Service Manager.

2. Select a folder where you want to create the new asset group.

3. Choose File → New → New Asset Group.

The New Asset Group dialog box appears.

4. Enter the following information for the new asset group.

What are asset groups and asset hierarchies?
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Field name Definition Valid values

Asset Group
Name

Name of the asset group Alphanumeric (1–128
characters)

Description Description of the asset group Alphanumeric (1–240
characters)

5. Click OK to create the asset group. Alternatively, click Cancel to exit.

Create an asset group hierarchy

1. From My Teamcenter, select the parent asset group where you want the nested asset group.

2. Choose Send to → Service Manager.

3. Choose Window → Show View → Service Editor to open the Service Editor view.

4. Select the line containing the parent asset group.

5. Choose File → New → Asset Group.

The New Asset Group dialog box appears.

6. Enter the following information for the new asset group.

Field name Definition Valid values

Asset Group
Name

Name of the asset group Alphanumeric (1–128
characters)

Description Description of the asset group Alphanumeric (1–240
characters)

7. Click OK to create the asset group. Alternatively, click Cancel to exit.

Add a part to an asset group

1. From the navigation pane, click My Teamcenter or Service Manager.

2. Select the physical part that you want to add as a member of the asset group.

Note:

You must select the physical part, not the physical part revision.

9. Managing as-maintained physical structures
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3. Right-click and choose Copy.

4. Select the asset group you want the physical part to be a member of.

5. Right-click and choose Paste.

Display asset group members

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor to open the Service Editor view.

3. From the Service Editor view, click Open by Name  to open the asset group.

4. Select the asset group.

5. Right-click and choose Show Contains View.

The Contains pane appears.

6. To filter the results, click the  button next to the column in the Contains pane.

Display asset group properties

1. From the navigation pane, click My Teamcenter.

2. Select the asset group.

3. Right-click and choose Properties.

Delete an asset group

You can delete an asset group if it is not the parent of a nested asset group and does not contain any
physical parts.

1. From the navigation pane, click My Teamcenter.

2. Select the asset group you want to delete.

3. Choose Edit → Delete.

Display asset group members
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10. Managing service data
Managing service data

Service Event Management is a separately installed and licensed add-on to Service Manager that allows
you to capture information about external service for your physical assets.

You can use the Service Event Management extension for Service Manager to:

• Create service groups and service group structures to organize the service performed on the physical
parts in your organization.

• Create and manage service events to track service history.

• Capture irregularities or discrepancies for physical parts and create associated corrective action service
events for those discrepancies.

• Record utilization information (activity entry values) on service events.

• Track physical parts installed and uninstalled in the physical structure as a result of service performed.

• Approve service events to apply any associated changes to the as-maintained structure.

You must install the appropriate components and licenses for Service Manager (as-maintained
management) and Service Event Management and perform any configuration tasks prior to using
this functionality. You must also perform any tasks needed to create your neutral structure and as-
maintained structure prior to recording any service data.
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Managing service groups

What is a service group?

A service group is a collection of service events and service discrepancies that you can create to organize
service data for one or more physical parts. You can create a single service group or a hierarchy of
service groups called a service group structure by creating one or more service groups within a service
group. You can create a service group without a relation to a physical part, or you can create a service
group and relate it to one or more physical parts.

Create a service group

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

3. From the Service Editor view, create a service group in one of the following ways:

• Select the folder where you want to create the new service group or select the physical part to
relate to the service group and choose File → New → Service Group.

• Right-click the physical part to relate to the service group and choose New Service Group.

Note:

You can also select an existing service group to create this new service group in to create a
service structure hierarchy.

4. Complete the following information for the service group.

Field name Definition Valid values

Contained In Parent service group to associate to this
service group.

Click and select one of the
following values:

• Add allows you to search
for an existing service group
to associate with this service
group.

• Clear clears any service group
that is contained in this field.

Name Name of the service group (required). Alphanumeric string (1–128
characters).

10. Managing service data
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Field name Definition Valid values

ID Identification number of the service group
(required).

Alphanumeric string (1–20
characters).

Description Description of the service group. Alphanumeric string (1–240
characters).

Purpose Purpose of the service group. Alphanumeric string (long
string).

In Progress
Physical Parts

Physical part or physical parts associated
with this service group.

Click and select one of the
following values:

• Add allows you to search for a
physical part to associate with
this service group. You can
associate one or more physical
parts to a service group.

• Clear clears any service group
that is contained in this field.

5. Click Finish to create the service group. Alternatively, click Cancel to exit.

Edit a service group

1. From the Service Editor view, select the service group to edit.

2. Edit the service group in one of the following ways:

• Choose View → Update Properties.

• Right-click the service group and choose Update Properties.

3. Edit the information for the service group.

4. Click Finish to apply the changes. Alternatively, click Cancel to exit.

Managing service events

Service event

A service event is informational data that is captured as a result of service activity that an external source
performs on a physical part. A service event captures information such as the service type, work scope,
resource information, maintenance time, and cost.

Edit a service group
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When you create a service event, you can associate it to a service group or create it without a parent
service group, but you must associate it to a single physical part. After a service event is approved, you
can edit it, but you cannot delete it or add service data to it.

Create a service event

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

3. From the Service Editor view, click Open By Name  to open the physical structure or physical
part.

4. From the Service Editor view, create a service event in one of the following ways:

• Select the folder where you want to create the new service event or select the physical part or
service group to relate to the service event and choose File → New → Service Event.

• Right-click the physical part or service group to relate to the service event and choose New
Service Event.

5. Complete the information for the service event.

Field name Definition Valid values

Contained In Parent service group to associate to this
service event.

Click and select one of the
following values:

• Add allows you to search
for an existing service group
to associate with this service
event.

• Clear clears any service group
that is contained in this field.

Name Name of the service event (required). Alphanumeric string (1–128
characters).

ID Identification number of the service event. Alphanumeric string (1–32
characters).

Activity
Number

Activity number of the service event. Alphanumeric string (1–32
characters).

Description Description of the service event. Alphanumeric string (1–240
characters).

10. Managing service data
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Field name Definition Valid values

Purpose Purpose of the service event. Alphanumeric string (long
string).

Category Category of the service event. Noneditable property.

Action Type Type of service completed for this service
event.

Select one of the following
values:

• Overhaul
• Inspection
• Repair
• Other

Authorized By Name of the person that authorized the
service.

Alphanumeric string (1–40
characters).

Work Start Date Date that the work starts. Click the Set Date  button and
select a date from the calendar.

Needed By Date Date that the work needs to be complete. Click the Set Date  button and
select a date from the calendar.

Zones Zone where the service event occurred. Alphanumeric string (1–256
characters).

Job Cards Job cards associated to the service event. Alphanumeric string (long
string).

Work Location Location that the work occurred. Alphanumeric string (long
string).

Signed Off By Name of the person that signed approval
for the service.

Alphanumeric string (1–40
characters).

Actual Labor
Cost

Actual cost of the labor. Numeric (float).

Actual Labor
Hours

Actual hours of labor. Numeric (float).

Actual Material
Cost

Actual cost of the material. Numeric (float).

In Progress
Physical Part

Physical part associated with this service
event (required).

Click and select one of the
following values:

• Add allows you to search for a
physical part to associate with
this service event.

Create a service event

Service Manager, Service Lifecycle Management 2412  10-5
© 2024 Siemens



Field name Definition Valid values

• Clear clears any physical part
that is contained in this field.

Note:

The fields on the Create Service Event dialog box can be modified using Business Modeler
IDE functionality.

6. Click Finish to create the service event. Alternatively, click Cancel to exit.

Edit a service event

1. From the Service Editor view, select the service event to edit.

2. Edit the service event in one of the following ways:

• Choose View → Update Properties.

• Right-click and choose Update Properties.

3. Edit the information for the service event.

4. Click Finish to apply the changes. Alternatively, click Cancel to exit.

Create an activity entry value

You can capture life, date, or observation characteristic type data on a service event for an associated
physical part. You must create characteristics definitions on the neutral structure before you can capture
this information on a service event. These characteristics are referred to as activity entry values on
a service event and record utilization information for the associated physical part. The utilization
information for the physical part is not updated until the service event is approved. An activity entry
value can only be contained within a service event.

1. From the Service Editor view, select the service event to add the activity entry values to.

2. Create the activity entry values in one of the following ways:

• Choose File → New → Activity Entry Value.

• Right-click and choose New Activity Entry Value.

3. Add the following information for the activity entry value.

10. Managing service data
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Field name Definition Valid values

Service Event Parent service event associated to this
activity entry value (required).

Click and select one of the
following values:

• Add allows you to search for
an existing service event to
associate with this activity
entry value.

• Clear clears any service
event that is contained in
this field.

Name Name of the activity entry value (required). Click and select the activity
entry name.

Description Description of the activity entry value
(required).

Alphanumeric string (1–240
characters).

Characteristic
Value

Name of the characteristic value associated
to this activity entry value.

Alphanumeric string (1–40
characters).

Characteristic
Date

Date that the characteristic was observed
during maintenance.

Click the Set Date  button
and select a date from the
calendar.

Propagate Determines whether to propagate the
collected values down the physical part
structure.

true (default value) or
false.

4. Click Finish to apply the changes. Alternatively, click Cancel to exit.

Display utilization values using Show Utilization

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

3. From the Service Editor view, click Open by Name  to open the physical structure or physical
part.

4. Select the BOM line of the physical part you want to view the utilization for.

5. Right-click and choose Show Utilization.

The Show Utilization view appears.

Display utilization values using Show Utilization
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Note:

The Last Observation column includes numeric, logical, and textual observations when present.

In the Utilization tab, the Last Observation column (1) shows the latest observation values for
the most recent log entry (2) for the selected part.

Tracking actual time and cost for service events

You can capture actual time and cost information for a service event. Use Access Manager to allow only
authorized users to view or update the actual time and cost information for a service event.

Managing service discrepancies

Service discrepancies and fault codes

Discrepancies are irregularities or observations about the maintenance of assets or physical parts.
Discrepancies can also identify if there was a failure with the physical part. You must create an
associated corrective action service event to address each service discrepancy. You can associate one
or more fault codes to a discrepancy. When you create a service discrepancy, you must relate it to a
physical part, parent service group, or a service event.

A service discrepancy can also contain fault information about the part. This fault information, or fault
code, identifies an itemized fault or problem that a manufacturer has identified with a part. Physical
parts can also report fault codes as a result of internal diagnostics.

10. Managing service data
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Create a service discrepancy

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

3. From the Service Editor view, click Open by Name  to open the physical structure or physical
part.

4. From the Service Editor view, create a service discrepancy in one of the following ways:

• Select the folder where you want to create the new service discrepancy or select the physical
part, service group, or service event to relate to the service discrepancy and choose File → New
→ Service Discrepancy.

• Right-click the physical part, service group, or service event to relate to the service discrepancy
and choose New Service Discrepancy.

5. Complete the following information for the service discrepancy. Some values may already be
supplied.

Field name Definition Valid values

Contained In Parent service group or service event to
associate to this service discrepancy.

Click and select one of the
following values:

• Add allows you to search for
an existing service group or
service event to associate with
this service discrepancy.

• Clear clears any service group
or service event that is
contained in this field.

Name Name of the service discrepancy
(required).

Alphanumeric string (1–128
characters).

ID Identification number of the service
discrepancy (required).

Alphanumeric string (1–32
characters).

Activity
Number

Activity number of the service discrepancy
(required).

Alphanumeric string (1–32
characters).

Description Description of the service discrepancy. Alphanumeric string (1–240
characters).

Create a service discrepancy
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Field name Definition Valid values

Initiation Date Date that the discrepancy is first recorded. Click the Set Date  button and
select a date from the calendar.

Severity Severity level of the discrepancy. Select one of the following
values:

• Critical
• Major
• Minor

Is Failure Determines whether this discrepancy is a
part failure.

true or
false (default value).

Discovered By Name of the person that discovered the
discrepancy.

Alphanumeric string (1–40
characters).

Discovery Date Date that the discrepancy was discovered. Click the Set Date button and
select a date from the calendar.

Due Date Date that the corrective action work needs
to be complete.

Click the Set Date  button and
select a date from the calendar.

Physical Part In
Progress

Physical part associated with this service
discrepancy (required).

Click and select one of the
following values:

• Add allows you to search for a
physical part to associate with
this service discrepancy.

• Clear clears any physical part
that is contained in this field.

Fault Code Associated fault codes for this service
discrepancy.

Click and select one of the
following values:

• Add allows you to search for
a fault code to associate with
this service discrepancy.

The Fault Codes tab displays
all fault codes that are
attached to the neutral part
from which the physical part
is realized. Click the Search
tab to look for other fault
codes, which are displayed on
the Search Results tab.
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Field name Definition Valid values

• Clear clears any fault code
that is contained in this field.

6. Click Finish to create the service discrepancy. Alternatively, click Cancel to exit.

Edit a service discrepancy

1. From the Service Editor view, select the service discrepancy to edit.

2. Edit the service discrepancy in one of the following ways:

• Choose View → Update Properties.

• Right-click and choose Update Properties.

3. Edit the information for the service discrepancy.

4. Click Finish to apply your changes. Alternatively, click Cancel to exit.

Create a corrective action service event

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

3. From the Service Editor view, select the service discrepancy to associate with the new corrective
action service event.

4. Create a corrective action service event in one of the following ways:

• Choose File → New → Service Event.

• Right-click and choose Corrective Action Service Event.

5. Complete the information for the corrective action service event.

6. Click Finish to create the corrective action service event. Alternatively, click Cancel to exit.

Create a fault code

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

Edit a service discrepancy
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3. From the Service Editor view, create a fault code in one of the following ways:

• Select the folder where you want to create the new fault code or select the physical part or
service discrepancy to relate to the fault code and choose File → New → Fault Code.

• Right-click the physical part or service discrepancy to relate to the fault code and choose New
Fault Code.

4. Complete the following information for the fault code.

Field name Definition Valid values

Service
Discrepancy

Parent service discrepancy associated to
this fault code (required).

Click and select one of the
following values:

• Add allows you to search
for an existing service
discrepancy to associate with
this fault code.

• Clear clears any service
discrepancy that is contained
in this field.

Name Name of the activity entry value (required). Alphanumeric string (1–128
characters).

Description Description of the activity entry value. Alphanumeric string (1–240
characters).

5. Click Finish to create the fault code. Alternatively, click Cancel to exit.

Managing part movement

What is part movement?

Part movement is a record of each physical part that is installed, replaced, or uninstalled as a result of a
service event.

You can create the following types of part movements.

10. Managing service data

10-12  Service Manager, Service Lifecycle Management 2412
© 2024 Siemens



Type of Part Movement Description

Uninstall An uninstall part movement uninstalls a physical part from
the physical structure.

Install An install part movement installs an existing or new
physical part into the physical structure.

Replace A replace part movement uninstalls a part from a physical
structure and installs an existing or new replacement
physical part into the physical structure.

Part movements can be categorized as traceable or untraceable. Traceable part movements are
necessary for parts that affect the physical structure. The changes to the physical structure from a
traceable part movement are not applied until the parent service event is approved. Untraceable part
movements capture only the part number and serial number of the physical part and are used for parts
that do not affect the physical structure, such as a filter change.

Part movements must be approved to execute the changes to the physical structure. If the approval
fails, all changes are rolled back and the process is terminated.

The install and replace part movement records contains a Is New option.

• If the Is New option is set to a value of true, you need to specify an existing neutral part to be used
as the basis for the new physical part. After approval, the new physical part is created and used for the
installation or replacement.

• If the Is New option is set to a value of false, you need to specify an existing physical part. After
approval, the specified physical part is used for the installation or replacement.

Create part movement – uninstall

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

3. From the Service Editor view, select the service event or physical part to associate with the new
part movement.

4. Create a part movement in one of the following ways:

• Choose File → New → Part Movement.

• Right-click and choose New Part Movement.

Create part movement – uninstall

Service Manager, Service Lifecycle Management 2412  10-13
© 2024 Siemens



5. In the Create Part Movement dialog box, complete the following information for the part
movement.

Field name Definition Valid values

Parent Parent service event associated with this
part movement (required).

Click and select one of the
following values:

• Add allows you to search
for an existing service event
to associate with this part
movement.

• Clear clears any service event
that is contained in this field.

Name The name of the part movement
(required).

Alphanumeric string (1–128
characters).

Description The description of the part movement. Alphanumeric string (1–240
characters).

Part Movement
Type

The type of part movement (required). Select Uninstall to create an
uninstall part movement.

Is Traceable Determines whether this part movement
is for a part that affects the physical
structure. If set to false, the system
only captures the part number and
serial number of the physical part being
uninstalled.

true (default value) or
false.

Action Date The date of the part movement.

Note:

If you do not enter a value for the
action date, the date is set from
the current date/time on the server
where the part movement is created.

Click the Set Date  button and
select a date from the calendar.
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6. Click Show As-Maintained Structure to open the Maintenance tree pane and load the as-
maintained physical structure related to the service event.

Create part movement – uninstall
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7. From the Maintenance tree pane, select the physical part you want to uninstall.

Note:

If a part in the physical structure is missing and has no generated physical part, the part is
highlighted in red and is represented by a neutral part. You cannot select that part for the
uninstallation.

8. Click OK. Alternatively, click Close to exit.

The following occurs:

• The Parent Physical Element field now contains the physical structure parent part.

• The Usage Name field now contains usage of the selected physical part.

9. Complete the following information for the uninstall part movement.

Field name Definition Valid values

Part Number The part number of the new physical part.
The part number is valid only if the field
Is Traceable is set to false indicating the
part you are uninstalling does not exist as a
neutral part in the database.

Alphanumeric string (1–128
characters).

Serial Number The serial number of the new physical part.
The part number is valid only if the field
Is Traceable is set to false indicating the

Alphanumeric string (1–128
characters).
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Field name Definition Valid values

part you are uninstalling does not exist as a
neutral part in the database.

Manufacture
ID

The manufacturer ID of the new physical
part. The part number is valid only if the
field Is Traceable is set to false indicating
the part you are uninstalling does not exist
as a neutral part in the database.

Alphanumeric string (1–128
characters).

Lot Number The lot number of the new physical part.
The part number is valid only if the field
Is Traceable is set to false indicating the
part you are uninstalling does not exist as a
neutral part in the database.

Alphanumeric string (1–128
characters).

Uninstall
Location

The physical location of the uninstalled
part.

Click and select one of the
following values:

• Add to select the physical
location from the displayed list
of preferred physical locations.

• Clear to clear the physical
location that is contained in
this field.

Create part movement – uninstall
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10. Click Finish to create the uninstall part movement. Alternately, click Cancel to exit.
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The applicable part movement changes are not applied to the physical structure until the parent
service event is approved. After approval, the physical part is uninstalled from the structure.

Create part movement – install or replace

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

3. From the Service Editor view, select the service event or physical part to associate with the new
part movement.

4. Create a part movement in one of the following ways:

• Choose File → New → Part Movement.

• Right-click and choose New Part Movement.

5. In the Create Part Movement dialog box, complete the following information for the part
movement.

Field name Definition Valid values

Parent The parent service event associated to this
part movement (required).

Click and select one of the
following values:

• Add allows you to search
for an existing service event
to associate with this part
movement.

• Clear clears any service event
that is contained in this field.

Name The name of the part movement
(required).

Alphanumeric string (1–128
characters).

Description The description of the part movement. Alphanumeric string (1–240
characters).

Part Movement
Type

The type of part movement (required). Select Install to create an install
part movement.

Select Replace to create a
replacement part movement.

Is Traceable Determines whether this part movement
is for a part that affects the physical

true (default value) or
false.

Create part movement – install or replace
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Field name Definition Valid values

structure. If set to false, the system
only captures the part number and
serial number of the physical part being
installed.

Is Approved
Deviation

Determines whether this part movement is
an approved deviation.

true or
false (default value).

Is Extra to
Design

Determines whether this part movement is
extra to design.

true or
false (default value).

Action Date The date of the part installation.

Note:

If you do not enter a value for the
action date, the date is set from
the current date/time on the server
where the part movement is created.

Click the Set Date  button and
select a date from the calendar.
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6. Click Show As-Maintained Structure to open the Maintenance tree pane and load the as-
maintained physical structure related to the service event.

Create part movement – install or replace
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7. From the Maintenance tree pane:

• If the Part Movement Type field is set to Install, select the physical part to identify the usage of
the part you want to install.

• If the Part Movement Type field is set to Replace, select the physical part to identify the usage
of the part you want to uninstall and replace.

Note:

If the Part Movement Type field is set to Replace, you cannot select a part for
replacement that is uninstalled or missing.

Note:

• If Is Extra to Design is set to true, select the physical part parent of the structure where
you want to install the extra to design part.

• If a part in the physical structure is missing and has no generated physical part, the part
is highlighted in red and is represented by a neutral part. You cannot select that part for
replacement.

8. Click OK. Alternatively, click Close to exit.

The following occurs:

• The Parent Physical Element field now contains the physical structure parent part.

• The Usage Name field now contains usage of the selected physical part.
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9. From Create Part Movement pane, complete the following information for the part movement.

Field name Definition Valid values

Is New Determines whether this part exists as a
neutral part in the database and does not
have a realized physical part.

true or
false (default value)

Neutral Part The neutral part that is used to create the
new physical part to be installed.

Note:

This field is only valid if Is New is
set to true indicating the neutral
part does not have a realized physical
part.

Click and select one of the
following values:

• Add allows you to search for
an existing neutral part.

• Clear clears any neutral part
that is contained in this field.

Physical Part The physical part to install.

Note:

This field is only valid for the
following conditions:

• The field Is New is set to
false indicating the physical part
selected for the install already
exists.

• The field Is Traceable is set to
true indicating it is traceable part
movement.

Click and select one of the
following values:

• Add allows you to search for
an existing physical part to
install.

The search results display
the valid preferred, alternate,
substitute, and deviated
physical parts that can be
installed.

• Clear clears any physical part
that is contained in this field.

Part Number The part number of the new physical part.
The part number is valid only if the field
Is Traceable is set to false indicating the
part you are installing does not exist as a
neutral part in the database.

Alphanumeric string (1–128
characters).

Serial Number The serial number of the new physical part.
The part number is valid only if the field
Is Traceable is set to false indicating the
part you are installing does not exist as a
neutral part in the database.

Alphanumeric string (1–128
characters).

Manufacture ID The manufacturer ID of the new physical
part. The part number is valid only if the

Alphanumeric string (1–128
characters).
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Field name Definition Valid values

field Is Traceable is set to false indicating
the part you are installing does not exist as
a neutral part in the database.

Lot Number The lot number of the new physical part.
The part number is valid only if the field
Is Traceable is set to false indicating the
part you are installing does not exist as a
neutral part in the database.

Alphanumeric string (1–128
characters).

Uninstall
Location

The physical location of the uninstalled
part.

Note:

This field is only available if the
Part Movement Type field is set to
Uninstall or Replace.

Click and select one of the
following values:

• Add to select the physical
location from the displayed list
of preferred physical locations.

• Clear to clear the physical
location that is contained in
this field.
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10. Click Finish to create the install part movement. Alternately, click Cancel to exit.

Create part movement – install or replace
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The applicable part movement changes are not applied to the physical structure until the parent
service event is approved. After approval, the physical part is uninstalled from the structure.

Approve service data

Service data must pass an approval process to perform operations to the physical structure such as
part movements or activity entry value updates. You can approve service data manually, or you can
submit the service data through an approval workflow process. If any errors are encountered during the
approval, all changes made during the approval process are rolled back and the process is terminated.

The following service data must be approved:

• Service groups

When you approve a service group, the approval process is applied to all of the service groups, service
events, and service discrepancies contained within that parent service group.

• Service events

If a service event is part of a service group, it can be approved as part of the approval process for the
parent service group.

• Service discrepancies

If a service discrepancy is related to a service group or service event, it can only be approved by
approving the parent service group or service event. A service discrepancy that does not have an
associated corrective action service event cannot be approved.

Note:

Service groups, service events, and service discrepancies can only be approved by a user that
shares the same role as the creating user. Users outside the role of the creating user cannot
approve the object.

If the service data objects are part of a service group structure, you can only approve the top level
of the structure. Approval of leaf nodes is not permitted. You can approve the above service data
objects individually if they are not part of a service group structure. When service data objects are
approved, they are locked, and you cannot add additional information.

To approve service data, do one of the following:

• Right-click the service group, service event, or service discrepancy that you want to approve and
choose Approve.

• Route the service group, service event, or service discrepancy that you want to approve to
a workflow created in Workflow Designer that uses the SERVICEPROCESSING-approve-service-
structure workflow handler for approval.
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After the above service data is approved, the following occurs:

• All related operations such as part movements are performed.

• The approval attribute for the approved service data is set to Approved.

• The In-Process relationship between each transaction element and the related physical part master is
removed and a Completed relationship is added to the physical part revision.

• The related physical structure is released.

• If the category of a service event is set to Overhaul, the date and time of the last overhaul is set to the
completion date and time of the service event.

• If the category of a service event is set to Repair, the date and time of the last repair is set to the
completion date and time of the service event.

• The service data objects are locked, and you cannot add additional information.

View service details

You can display service details to view the following information:

• Property details

Details that display the properties of the service event management object.

• Service event information and status

Properties of the service event and whether the service event is in progress or completed.

• Part movement information

Part movement information for service events.

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

3. From the Service Editor view, select the service event object that you want to display the service
details for.

4. Choose Window → Show View → Service Details.

The Details tab appears at the bottom of the window.

View service details
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5. To display service events that are in progress for a physical structure or part, click  next to the 
button in the Service Details window and select Show In-Progress.

All service events that are in progress are displayed.

6. To display service events that are completed for a physical structure or part, click  next to the 
button in the Service Details window and select Completed.

All service events that are completed are displayed.

7. To display part movement information for a service event, click  next to the  button in the
Service Details window and select Show Part Movements.

The information about the part movements is displayed.
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11. Comparing structures
Comparing structures with Dynamic Equivalence

Comparing structures with Dynamic Equivalence

As a production planner, you can use the Dynamic Equivalence option to compare the structures
according to the list of properties specified under the preferences. You must select the Dynamic
Equivalence check box.

For example, if you have the BOMLine properties that you want to use to compare the SLM neutral or
physical structures, use the Dynamic Equivalence preference.

Using this preference, you can specify the list of properties you want to compare for the source and
target structures. The differences are displayed using colors that indicate partial matches or no matches
between the structures.

Matching Equivalence criteria

As a production planner, you can use the equivalence criteria on the structures to compare them.

Full match criteria
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You can specify the equivalence criteria to evaluate Full Match. You must define the properties
with the preference MEAccountabilityCheckDynamicIDICForSLM when you compare the neutral
structures with the physical structures or the physical structures with the physical structures.

If all the property values specified under this preference are the same across the source and target
parts, then the match is a full match. If a property value specified under the above preference is
different, then the match is a no-match and the lines are displayed in red, which indicates that either
the source or the target is missing.

Partial match criteria

You can use the equivalence criteria to evaluate Partial Match. If the full match criteria is satisfied,
then the partial match criteria is evaluated for both source and target BOM lines.

When you compare an as-built structure with a neutral structure, the partial match
criteria is evaluated according to the property values specified under the preference
DefaultAsBuiltAccCheckProperties. See the following image.
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Equivalence and Partial Match criteria preferences

As a production planner, you can use the equivalence criteria to compare the structures.

When evaluating the equivalence and partial match criteria, the compare engine uses preferences that
are based upon the source and target structure type that you select. You must set the preferences
correctly, according to the source and target type. The physical structure is either an As-Built structure
or an As-Maintained structure. The neutral structure is a manufacturing bill of materials (MBOM) or
another part or item structure.

Equivalence criteria

Source Target Preference Name
Physical Physical MEAccountabilityCheckDynamicIDICForSLM
Physical Neutral MEAccountabilityCheckDynamicIDICForSLM
Neutral Physical MEAccountabilityCheckDynamicIDICForSLM
Neutral Neutral MEAccountabilityCheckDynamicIDICProperties

Similarly, you can set preferences to evaluate the partial match.

Partial Match criteria

Source Target Preference Name
As-Built As-Built DefaultAsBuiltAccCheckProperties
Neutral As-Built DefaultAsBuiltAccCheckProperties
As-Built Neutral DefaultAsBuiltAccCheckProperties
As-Maintained As-Maintained DefaultAsMaintainedAccCheckProperties
As-Maintained Neutral DefaultAsMaintainedAccCheckProperties
Neutral As-Maintained DefaultAsMaintainedAccCheckProperties
Neutral Neutral AWBPropertiesToCompare.BVR

Note:

• When you compare the neutral structure with any other physical or neutral structure, the
properties specified under the preferences above must be defined on a BOMLine runtime
business object for a neutral structure. Similarly, the same properties must be defined on a
PhysicalBOMLine, or AsBuiltBOMLine/AsMaintainedBOMLine, business object for a physical
structure.

• A property that you specify is evaluated for both the target and the source BOMLine. For
example, if you specify bl_quantity, the same property must be available for the source and the
target. If the property is not defined or property values are empty or null, then the property is
treated as No Match.

Equivalence and Partial Match criteria preferences
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• When you attempt to compare one property on a neutral BOMLine with another property on
a physical BOMLine, the comparison is not supported. For example, you cannot compare the
Item_id property on a neutral line with the phbl_part_number on a physical BOMLine. But you
can define a custom property and can use that custom property to compare.

Compare neutral structure with physical structure

You can compare neutral and physical structures in the Service Editor view using two separate panes.

1. Set the list of properties you want to compare under the preference
MEAccountabilityCheckDynamicIDICForSLM. In the below example, a custom property
smr1bgPartNumber is used.

2. Set the DefaultAsBuiltAccCheckProperties preference value to bl_quantity.

3. Create a neutral structure.

4. Generate an As-Built structure from the neutral structure.
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5. To revise the neutral structure, delete the component Battery, add a new component called
New_Battery, and change the camera quantity to 2.

The revised structure is revision B.

6. Open the neutral structure, which is revision B, and the physical structure in Active Workspace
client.

7. Click Compare and select all match criteria as shown.

Compare neutral structure with physical structure
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8. Review the comparison.

These are the results:

• The equivalence criteria is satisfied for CircuitBoard and Display, because the bg Part Number is the
same for both. The partial match criteria is also satisfied, because the bl_quantity is the same for
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CircuitBoard and Display part in both the neutral and the As-Built structure. Hence, these two parts
are displayed as a full match.

• The equivalence criteria is satisfied for Camera, because the bg Part Number is the same across
both the structures. The partial match criteria is not satisfied for Camera because the bl_quantity is
different across both the structures. Hence, it is a partial match, with an orange line beside Camera
under Compare.

• The equivalence criteria is not satisfied for New Battery and Battery because the bg Part Number is
different across the structures. Hence, it is not a match, and includes a red line beside New Battery
under Compare.

Compare neutral structure with physical structure
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12. Comparing as-maintained structures
Comparing as-maintained structures

As shown in the following figure, a user such as a production planner can compare two physical
structures or a physical structure with a neutral structure to identify changes or differences between two
product structures.

Comparing as-maintained structures

For example, you can compare the neutral structure and the physical structure to highlight the missing
and nontraceable parts or compare two different installations of the same physical structure to show
differences. The differences are displayed using colors that represent full, partial, or no matches between
the structures. You can also optionally generate a report summarizing the differences.

Comparing structures with or without context

Comparing with context

As-maintained structures can be compared with or without context.

If you select the Compare (with context) option, you are comparing the parts in position in the physical
or neutral structures. For example, you can use compare with context to determine if the left and right
engines were swapped. A compare without context would not detect those differences.

For this comparison to work properly, you must set a value in the ID in Context column in the Service
Editor window for the parts in the neutral structure. This comparison is similar to an accountability
check between structures using Multi-Structure Manager. You can select additional properties for
comparison and set the context ID to match any source and target line that have the same absolute
occurrence identifier.
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Set compare with context preferences

To specify the default and additional properties used for comparing as-maintained
structures with context, an administrator sets the DefaultAsMaintainedAccCheckProperties and
AdditionalAsMaintainedAccCheckProperties preferences.

Preference Default values

DefaultAsMaintainedAccCheckProperties phbl_part_number

phbl_part_used_is

phbl_design_rev_id

AdditionalAsMaintainedAccCheckProperties phbl_part_usage_name

Perform compare with context

You compare two as-maintained structures in the Service Editor view using two separate panes.

1. From the navigation pane, click Service Manager to open the source structure in the bottom pane
and the target structure in the top pane.

• From the navigation pane, click Service Manager.

• From the navigation pane, click Service Manager.

• From the Service Editor view, click Open by Name  to open the source structure.

• From the Service Editor view, click Open by Name  to open the source structure.

• Click Open by Name  to open the second structure in the top pane.

2. After you open the as-maintained structures in the appropriate panes, configure them by setting
the revision rule and/or variant rule in each pane.

3. Expand and collapse assemblies to define the scope of the comparison.

4. Choose Tools → Compare.

The Compare dialog box appears.

5. Do one of the following:

• If you want to reverse source and target as-maintained structures, select Flip source and target.
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• To compare as-maintained structures with context, select Compare (with context).

6. Select Display Options to change comparison color scheme. When you compare two structures,
the results are displayed in a variety of colors that you can change using the display options. To
help users who cannot differentiate colors, a tool tip shows the name of the color. If the name is
not available, the tool tip displays the RGB (red, green, blue) value.

• Check the display options you require.

Display option Description

Full match If all properties of a source object are identical to the
properties of a target object, both objects are set to the same
background color. The default color is green.

Partial match If some of the properties of a source object is identical to the
properties of a target object, both objects are set to the same
background color. The default color is yellow.

Multiple match If the properties of a source object are identical to the
properties of target objects, all objects are set to the same
background color. The default color is orange.

Multiple partial
match

If some of the properties of a source object is identical to the
properties of target objects, all objects are set to the same
background color. The default color is pink.

Missing target If the properties of a source object are not found by target
objects, the source object is set to this color. The default
color is red.

Missing source If the properties of a target object do not meet properties of
any source objects, the target object is set to this color. The
default color is white.

• Change the default color by clicking  next to the color. Set the colors by selecting a color
swatch, and setting HSB (hue, saturation, brilliance) or RGB (red, green, blue) values.

7. Select Compare Options to change properties.

• To compare any source line and target line that have the same absolute occurrence identifier,
select the Treat same ID in context as same check box. If not selected, the compare does not
match lines with different absolute occurrences, even if they share the same absolute occurrence
identifier.

• To match lines in the source and target that have the same properties as those you choose in the
Selected Properties list, select the Compare Additional Properties check box. If not selected,
the compare includes only those default options defined by your administrator.

Perform compare with context
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• Use the  button to select the properties from the Available Properties list and move
them to the Selected Properties list. Use the  button to remove the properties from the
Selected Properties list and move them back to the Available Properties list.

8. Click Check to begin the comparison. Alternatively, click Cancel to exit.

Comparing without context

As-maintained structures can be compared with or without context.

If you choose the Compare (without context) option, you can compare structures at the at the
assembly or subassembly levels and set the level or mode of comparison. This comparison is similar to
comparing two structures in the Structure Manager view using Structure Manager. When Teamcenter
compares the displayed product structures (BOMs); it compares each level that is visible. Consequently,
you can compare different views or configurations by expanding the structure to the desired level.
Also, if you collapse assemblies in the product structure, the comparison excludes the content of those
assemblies. You can use this feature to limit the scope of a comparison.

Set compare without context preferences

• Property preferences

To specify the default and additional properties used for comparing as-maintained structures
without context, an administrator sets the sets the DefaultAsMaintainedCompareProperties and
AdditionalAsMaintainedCompareProperties preferences.

Global constant Default values

DefaultAsMaintainedCompareProperties phbl_part_number

phbl_part_usage_name

AdditionalAsMaintainedCompareProperties phbl_part_used_is

phbl_design_rev_id

• Display preferences

Because the display options are unavailable when comparing without context, an administrator can
change the colors displayed for added and changed occurrences by setting the PSEAdditionColorPref
and PSEChangedColorPref preferences. No colors are displayed for full matches.

Preference Default value

PSEAdditionColorPref red

PSEChangedColorPref orange

12. Comparing as-maintained structures
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Perform compare without context

You compare two as-maintained structures in the Service Editor view using two separate panes.

1. From the navigation pane, click Service Manager to open the source structure in the bottom pane
and the target structure in the top pane.

• From the navigation pane, click Service Manager.

• Choose Window → Show View → Service Editor to open the Service Editor view.

• From the Service Editor view, click Open by Name  to open the source structure.

• Click Show/Hide lower structure panel  located at the top of the application window to
create a new empty (target) pane. The source structure appears in the bottom pane.

• Click Open by Name  to open the second structure in the top pane.

2. After you open the as-maintained structures in the appropriate panes, configure them by setting
the revision rule and/or variant rule in each pane.

3. Expand and collapse assemblies to define the scope of the comparison.

Note:

You compare only the visible structures displayed in the panes.

4. Choose Tools → Compare.

The Compare dialog box appears.

5. Do one of the following:

• If you want to reverse source and target as-maintained structures, select Flip source and target.

• To compare as-maintained structures without context, select Compare (without context).

6. Select Compare Options to change compare modes.

• Select the compare mode to set the level of comparison.

Perform compare without context
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Mode Description

Single Level Compares only the first levels of the product structures.

Multi Level Performs a single-level comparison at the top level, and then
starts further single-level comparisons on any subassemblies
that match between the two product structures. This process is
repeated successively down the product structure.

Lowest Level Compares only the lowest level items of the product structures,
ignoring all intermediate assemblies. This is useful for verifying
that piece parts are consistent.

7. If you want to display a report window summarizing the differences between the structures, select
the Report check box.

The Print window appears after the compare is complete.

8. To print the report, choose Print the file . To save the report to a local text file, from the report
window, choose Saves to a user specified file . To close the window, choose Close.

• In single-level mode and lowest level mode, the reports are flat lists of differences.

• In multilevel mode, the report is an indented output is produced, showing the parent assemblies
of any changed items.

9. Click Check to begin the comparison. Alternatively, click Cancel to exit.

Note:

Because the display options are unavailable when comparing without context, an
administrator can change the colors displayed for added and changed occurrences by setting
the PSEAdditionColorPref and PSEChangedColorPref preferences. No colors are displayed
for full matches.

Clear comparison

• To clear the highlighting colors, choose Tools → Clear.

Note:

If you start a new comparison before clearing the results of the previous comparison, the
existing results are automatically cleared.

12. Comparing as-maintained structures

12-6  Service Manager, Service Lifecycle Management 2412
© 2024 Siemens



Comparing a neutral structure to a physical structure

Comparing as-maintained physical structure to neutral structure

You can compare an as-maintained neutral structure with an as-maintained physical structure. For
example, you may want to highlight the following as differences:

• Nontraceable parts

• Missing physical parts

• Substitute parts

• Deviated parts

• Global alternate parts

To compare a neutral structure with a physical structure with context, set up the comparison as
described in Perform compare with context.

To compare a neutral structure with a physical structure without context, set up the comparison as
described in Perform compare without context.

Compare with context example between a neutral structure and a physical
structure

The following compare information and figure show the result of a compare with context between the
neutral structure and the physical structure for the bearing housing assembly.

• Source structure: physical structure in the top pane for the bearing housing assembly.

• Target structure: neutral structure in the bottom pane for the bearing housing assembly.

• All the display options are selected.

Comparing as-maintained physical structure to neutral structure
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Comparing as-maintained physical and neutral structures with context

The color green indicates a full match. The following parts show differences.

Part ID Structure Color Why?

BH014 Neutral Yellow indicating a partial
match

Some properties are identical
because the alternate part for
the shaft was installed in the
physical structure.

BH014A Physical Light blue indicating the
physical part is an alternate

The alternate part for the
shaft was installed in the
physical structure.

BH015 Neutral Yellow indicating a partial
match

Some properties are identical
because the substitute part
for the shaft was installed in
the physical structure.

12. Comparing as-maintained structures
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Part ID Structure Color Why?

BH015S Physical Royal blue indicating the
physical part is a substitute

The substitute part for the
shaft was installed in the
physical structure.

BH021 Neutral Light blue indicating a
missing source.

The physical part for the
hardware is missing from the
source physical structure.

Compare without context example between a neutral structure and a
physical structure

The following compare information and figure show the result of a compare without context between
the neutral structure and the physical structure for the bearing housing assembly.

• Source structure: neutral structure in the top pane for the bearing housing assembly.

• Target structure: physical structure in the bottom pane for the bearing housing assembly.

• Display options:

• Set to Multi Level.

Compare without context example between a neutral structure and a physical structure
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Comparing as-maintained physical and neutral structures without context

No color indicates a full match. Because compare without context compares the parts that are visible
and does not compare properties, the following parts show differences.

Part ID Structure Color Why?

BH014 Neutral Red indicating no match The alternate part for the
shaft was installed in the
physical structure.

BH014A Physical Cyan indicating the physical
part is an alternate

The alternate part for the
shaft was installed in the
physical structure.

BH015 Neutral Red indicating no match The substitute part for the
shaft was installed in the
physical structure.

12. Comparing as-maintained structures
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Part ID Structure Color Why?

BH015S Physical Royal blue indicating the
physical part is a substitute

The substitute part for the
shaft was installed in the
physical structure.

BH021 Neutral Red indicating no match The hardware does not exist
in the physical structure.

Comparing two physical structures

Comparing two as-maintained physical structures

You can compare two as-maintained physical structures. For example, you may want to highlight the
differences between two installations of the same physical structure.

To compare two physical structures with context, set up the comparison as described in Perform
compare with context.

To compare two physical structures without context, set up the comparison as described in Perform
compare without context.

Compare with context example between two physical structures

The following figure shows the result of a compare with context between two physical structures for the
bearing housing assembly.

• Source structure: The bearing housing assembly in the bottom pane used in the missile truck. The
serial number is set to MTruck.

• Target structure: The bearing housing assembly in the top pane used in the supply truck. The serial
number is set to STruck.

• All display options are selected.

Comparing two as-maintained physical structures
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Comparing two as-maintained physical structures with context

The color green indicates a full match. The following parts show differences.

Part ID Structure Color Why?

BH014 MTruck Yellow indicating a partial
match

Some properties are identical
because the alternate part for
the shaft was installed in the
physical structure used in the
supply truck.

BH014A STruck Cyan indicating the physical
part is an alternate

The alternate part for the
shaft was installed in the
physical structure used in the
supply truck.

BH015 MTruck Yellow indicating a partial
match

Some properties are identical
because the substitute part
for the shaft was installed in

12. Comparing as-maintained structures
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Part ID Structure Color Why?

the physical structure used in
the supply truck.

BH015S STruck Royal blue indicating the
physical part is a substitute

The substitute part for the
shaft was installed in the
physical structure used in the
supply truck.

BH016 STruck Light blue indicating a
missing source.

The regular bearing housing
does not exist in the source
physical structure used in the
missile truck.

BH016HD MTruck Red indicating a missing
target.

The heavy duty bearing
housing does not exist in the
target physical structure used
in the supply truck.

BH020D MTruck Yellow indicating the physical
part is a deviation

The deviated redesigned part
for the retaining ring was
installed in the physical
structure used in the missile
truck.

BH020 STruck Yellow indicating a partial
match

Some properties are identical
because the deviated
redesigned part for the
retaining ring was installed in
the physical structure used in
the missile truck.

Compare without context example between two physical structures

The following figure shows the result of a compare without context between two physical structures for
the bearing housing assembly.

• Source structure: The bearing housing assembly in the bottom pane used in the missile truck. The
serial number is set to MTruck.

• Target structure: The bearing housing assembly in the top pane used in the supply truck. The serial
number is set to STruck.

• Display options:

• Set to Multi Level.

Compare without context example between two physical structures

Service Manager, Service Lifecycle Management 2412  12-13
© 2024 Siemens



Comparing two as-maintained physical structures without context

No color indicates a full match. Because compare without context compares the parts that are visible
and does not compare properties, the following parts show differences.

Part ID Structure Color Why?

BH014A STruck Cyan indicating the physical
part is an alternate

The alternate part for the
shaft was installed in the
physical structure used in the
supply truck.

BH014 MTruck Red indicating no match The alternate part for the
shaft was installed in the
physical structure used in the
supply truck.

BH015S STruck Royal blue indicating the
physical part is a substitute

The substitute part for the
shaft was installed in the

12. Comparing as-maintained structures
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Part ID Structure Color Why?

physical structure used in the
supply truck.

BH015 MTruck Red indicating no match The substitute part for the
shaft was installed in the
physical structure used in the
supply truck.

BH016 STruck Red indicating no match The heavy duty bearing
housing is installed in the
physical structure used in the
missile truck.

BH016HD MTruck Red indicating no match The regular bearing housing
is installed in the physical
structure used in the supply
truck.

BH020 STruck Red indicating no match The deviated redesigned part
for the retaining ring was
installed in the physical
structure used in the missile
truck.

BH020D MTruck Red indicating no match The deviated redesigned part
for the retaining ring was
installed in the physical
structure used in the missile
truck.

Compare without context example between two physical structures
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13. Visualizing as-maintained physical
structures
Visualizing as-maintained physical structures

You can visualize the neutral and as-maintained physical structures from the Service Editor view with
the embedded viewer. You can also view any untraced parts for the as-maintained physical structure.
When you visualize the as-maintained physical structure, you are looking at the data associated with
its linked neutral structure. The visualization data is only associated to the design parts of the neutral
structure and not to the related as-maintained physical structure.

You use the embedded viewer in the Service Editor view in the same way as the embedded viewer in
the Structure Manager view. If you want to use the enhanced capabilities of Lifecycle Visualization or
the embedded viewer, you must purchase and install the necessary additional licenses.

Note:

Physical parts with Part Used status set to Missing do not display any visualization.

The following figure shows an example where you can visualize both the neutral and physical structures
in the Service Editor view with a split window. You may want to use a split window to see what the
missing physical parts look like by viewing the visualization of their related neutral part item revisions.
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Visualizing as-maintained neutral and physical structures

Associating image file datasets

To visualize the neutral or as-built physical structure, you must create DirectModel datasets containing
the image (JT) files. You attach the datasets with the Rendering relationship to the neutral part
item revisions that compose the neutral structure. When you visualize the physical structure, you are
accessing the same datasets attached to its linked neutral structure. A DirectModel dataset can contain
several JT files with different names, so you should set rules that determine the file to display.

Visualize the as-maintained structure model

1. From the navigation pane, click Service Manager.

2. Choose Window → Show View → Service Editor.

3. From the Service Editor view, click Open By Name  to open the as-maintained physical
structure or neutral structure.

To display split structure panes for two structures, click Show/Hide lower Structure Panel 
located at the top of the application.

13. Visualizing as-maintained physical structures
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4. Choose View → Show Data Panel, or click the Show/Hide Data Panel button  on the toolbar.

5. Click the Assembly Viewer tab to visualize the 3D models for the structure.

Visualization window layout

The lines in the project workspace are shown with a check box to the left of the part. You select the
check boxes next to the part and assembly names in the assembly tree to choose which parts and
assemblies to load and make visible. By default, they are all clear.

Visualization screen layout

1 Project workspace Displays the product structure.

2 Navigation toolbar Toolbar used to navigate the 3D model.

3 Graphical viewing window Displays the 3D model associated with the product
structure.

Visualization window layout
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Change visibility

• To display or hide entire models, assemblies, or individual parts, you can do any of the following:

To Do this

View the entire structure Select the check box for the top-level line in the structure to
load the graphics for every line in the structure.

View a selected part of the
structure

Select the check boxes only for those lines for which you want
to load the graphics.

View only the part Select the check box for the line for a part.

View an assembly Select the check box for a line representing the assembly.

Hide the entire structure Clear the check boxes.

Using the graphics menu

The Graphics menu appears when you click the Assembly Viewer tab.

Command Description

Selection → Select All Selects all the objects displayed in the viewer.

Selection → Select None Clears any objects currently selected in the viewer.

Selection → Reverse Selection Selects all objects not selected in the viewer, while
simultaneously unselecting any objects currently selected in the
viewer.

Visibility → View Selected Blanks and unblanks objects loaded in the viewer.

Note:

The term loaded refers to an object whose JT file has been
loaded in the viewer. A loaded object may or may not
be visible, depending on whether it has been blanked or
unblanked.

Visibility → Blank Selected Makes any objects selected in the viewer invisible.

Visibility → Blank All Makes all objects in the viewer invisible.

Visibility → Unblank All Makes all objects loaded in the viewer visible.

13. Visualizing as-maintained physical structures
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Command Description

Visibility → Reverse Blank All Makes any currently visible objects invisible, while
simultaneously making visible any loaded objects which are
currently invisible.

Visibility → Unload Selected Unloads any objects selected in the viewer.

Edit Color/Translucency Modifies the color, transparency, and shine of selected objects
in the viewer. These settings only apply to the currently loaded
objects. The next time the edited object is loaded, the settings
revert to the default color and translucency.

Insert Allows you to insert JT, stereolithography (.stl), and VRML (.wrl)
files as reference graphics.

Insert → Insert from File Inserts a reference graphic from the operating system, using the
Open by Name dialog box.

Insert → Insert from Clipboard Inserts a reference graphics object from the clipboard.

Note:

Only item revisions (not items) can be displayed as
reference graphics.

Views → Views Control Creates, edits, and displays standard views, using the Rotate and
Standard Views dialog boxes.

Draw Children Displays the components of a subassembly. You can also access
this command if you right-click in the BOM.

Show Subcomponents Breaks down solids in the corresponding monolithic JT files
and make the subcomponents independently controllable. This
function is available only for only leaf and unpacked BOM line
nodes.

Hide Subcomponents Removes all merged subcomponents and the one-level tree from
the tree. You can load or unload the monolithic JT file related to
this BOM line node in the normal way.

Export 3D File Exports the current visible objects to a STEP or VRML file.

Replace JT File Replaces the JT file that represents an item revision. You can
choose a replacement file from one of the JT files associated with
the current BOM line item.

Transformation → Temporary
Transformation

Generates an exploded view for use in technical illustrations.

Transformation → Persistent
Transformation

Modifies the physical location of a part (or set of parts) in an
owning assembly.

Using the graphics menu
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Command Description

Clearance → Preferences → Calcu
lator Settings

Specifies the precision and nature of the clearance check.

Clearance → Preferences → Clear
ance Requirements

Defines the clearance conditions based on the metadata of the
structure or elements.

Clearance → Preferences → Clear
ance Results

Adjusts the clearance results preferences to change the
appearance and behavior of clearance results.

Clearance → Preferences → Toggl
e Results Window

Displays the clearance results window.

Performance Sets rendering, culling and general performance preferences.

Preferences Sets clearance analysis and general viewer preferences.

Navigating the 3D model

When you visualize the 3D model associated to the physical or neutral structure. the 3D navigator
toolbar appears at the top of the Assembly Viewer window. It is used to manipulate the 3D view.

Option name Mode Use this button to

Examine
Fly Explore Enable Examine mode.

Fly
Examine Explore Enable Fly mode.

Explore
Examine Fly Enable Explore mode.

Previous View
Examine Fly
Explore

Return to the last static view.

Next View
Examine Fly
Explore

Move to the next static view

Fit All Examine Fly
Explore

Fit all visible parts of the model into the viewing
window.

Zoom Area Examine Fly
Explore

Zoom to a specific area of the model.

seek Examine Fly
Explore

Center a point of the model. This point becomes the
center of rotation.

13. Visualizing as-maintained physical structures
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Rotate Examine Rotate your model in the viewing window.

Pan Examine Fly
Explore

Pan the model in the plane of the viewing window.

Zoom Examine Move closer to or farther from the model.

Position Explore Choose your position in the model.

Level Fly Explore Align the view to the up vector.

Terrain Following Fly Explore Remain a specified distance above the floor upon
which you are moving.

Collision Detection Fly Explore Stop moving through your model when you come into
contact with a part.

Go Home Explore Return to the location and position you were at when
you last selected Set Home.

Set Home Explore Set the current location and position as the home
location.

Preferences Examine Fly
Explore

Set mode preferences.

Navigating the 3D model
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14. Sharing Service Manager data
Sharing Service Manager data

You can share Service Manager data by:

• Importing as-maintained physical structures and service event management data from third-party
systems or other Teamcenter sites into Teamcenter using the PLM XML format.

• Exporting as-maintained physical structures and service event management data from Teamcenter to
other Teamcenter sites or third party systems using the PLM XML format.

• Using Multi-Site Collaboration to share Service Manager data between multiple Teamcenter sites.

Exporting Service Manager data

A user such as a production planner can export Service Manager data from Teamcenter to other
Teamcenter sites or third party systems.

You can export as-maintained physical structures in the PLM XML format.
Exported data includes:

• Physical parts with revisions.

• Physical realization information.

• As-maintained structures including installation dates.

• Physical alignment relations.
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• Lot information if assigned to a physical part.

• Deviation information.

• Physical disposition information including disposition types.

• Utilization information which includes:

• Characteristics
• Characteristic values
• Log book
• Log entries

You can export the following service event management objects in the PLM XML format:

• Service group
• Service event
• Service discrepancy
• Fault codes
• Part movements

Export Service Manager data

You can export Service Manager data from Teamcenter to PLM XML by performing the following steps:

1. Select the object to be exported.

2. Choose Tools → Export → To PLMXML.

The system displays the PLM XML Export dialog box.

3. In the Export Directory box, select the directory in which to place the PLM XML file. Click Browse
to locate the directory.

4. Specify the name of the export file in the Export Filename box.

5. Select the transfer mode to be used to configure the export operation.

a. Select AsMaintainedDataExport to export an as-maintained structure.

b. Select SEM_PLMXMLDataExport to export service event management data.

6. (Optional) Click Select Languages to display the Language Selection dialog box for the languages
configured at your site.

a. Main Language is the site master language. This cannot be changed.

14. Sharing Service Manager data
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b. The Available Languages box lists the languages you can select as additional languages for
export.

c. The Select Additional Languages box lists the preconfigured languages for the selected
transfer mode.

d. To select additional languages for export, follow these steps:

A. Select a language in the Available Languages box.

B. Click the Add button .

i. The selected language is added to the Selected Additional Languages box.

ii. To reorder the languages in the Selected Additional Languages box, select a
language and use the move   buttons as required.

C. Click OK or Apply.

The languages selected for export are displayed in the Languages box.

Note:

If you change the transfer mode, the Languages entries remains unchanged. You can
use the Language Selection dialog box again to add or remove more languages.

7. (Optional) Select a revision rule to configure the assembly to be exported.

8. If you do not apply a revision rule, only the parent item revision is exported.

9. (Optional) Select Open PLM XML File to view the file when the export operation is complete.

10. (Optional) Select the View Log File check box to view the log file when the data translation is
complete.

11. (Optional) Select the Perform Export In Background check box to perform an asynchronous
export.

12. Click OK to export the objects in the Object List and close the dialog box.

Export Service Manager data
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Importing Service Manager data

Importing Service Manager data

A user such as a production planner can import Service Manager data from Teamcenter to other
Teamcenter sites or third party systems.

You can import as-maintained and service event management data into Teamcenter from any third-party
system if it conforms to the PLM XML schema.

When you import as-maintained structures, the following information is also imported:

• Disposition information.

• Log book and log entry information.

• Utilization information such as characteristics definitions and values.

Refer to the following table for PLM XML elements and the associated Teamcenter as-maintained classes.

PLM XML element Teamcenter class

RealizedProduct Physical Part

RealizedProductRevision PhysicalPartRevision

RealizedFromRelation Physical Realization (relation)

AllowedDeviationRelation Allowed Deviation (relation)

Lot, LotRevision Lot

Deviation DeviationDocument
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PLM XML element Teamcenter class

DeviationRevision DeviationDocumentRevision

CharacteristicDefinition,
CharacteristicDefinitionRevision

CharacteristicDefinition

CharacteristicValue CharacteristicValue

CharacteristicValueForRealised
ProductRelation

PhysicalCharacteristics (relation)

Fleet Asset Group

Service Lifecycle ManagementLocation PhysicalLocation

Service Lifecycle
ManagementLocationRevision

PhysicalLocationRevision

Service Lifecycle
ManagementLocationRelation

PhysicalLocationUsage (relation)

Because the physical structure does not have one-to-one mapping in PLM XML, the following combined
PLM XML elements provide the information for the entire physical structure:

• InstanceGraph

• ProductRevisionView

• RealisedProductInstance

In addition, note the following when importing an as-maintained physical structure:

• Before you import an as-maintained structure, the neutral structure and the part logistics information
must exist on the importing site.

• If the occurrence information is provided along with the occurrence name, the alignment relation is
created. If the occurrence name is not provided or the occurrence name does not match the neutral
part occurrence name, PLM XML processes the structure relationship without the alignment relation.

• If the lot information is provided and the lot is not defined in Teamcenter, PLM XML creates and
assigns the physical part to the new lot. If the lot exists, the physical part is assigned to the existing
lot.

• When importing a part movement using PLM XML, the Uninstall Location field is blank and the
following values are used:

• The value of the PartMovementDefaultRemoveLocation preference, if this preference is set.

Importing Service Manager data
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• The first value of the Service Lifecycle ManagementDefaultLocations preference, if the
PartMovementDefaultRemoveLocation preference is not set.

Refer to the following table for PLM XML elements and the associated Teamcenter service event
management classes.

PLM XML element Teamcenter class

ServiceGroupType ServiceGroup

ServiceDiscrepancyType ServiceDiscrepancy

TCServiceEventType ServiceEvent

PartMovementType PartMovement

FaultCodeType FaultCode

ActivityCostType ActivityCost

ActivityEntryValueType ActivtyEntryValue

Import Service Manager data

Note:

Before you import an as-maintained structure, the neutral structure and the part logistics
information must exist on the importing site.

You can import Service Manager data (as-maintained or service event management) into Teamcenter
from a third-party system using PLM XML by performing the following steps:

1. Choose Tools → Import → From PLMXML.

The system displays the PLM XML Import dialog box.

2. Click Browse  to the right of the Importing Object box.

The Select Object dialog box appears.

3. Select PLM XML File (.xml) from the Files of type list.

4. Navigate to the directory containing the file and select the file.

The system displays the file name in the Directory name box.

5. Click Select.

14. Sharing Service Manager data
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The system displays the path to the selected file in the Importing Object box of the dialog box.

6. Select the transfer mode to be used to configure the import operation.

• Select AsMaintainedDataImport to import an as-maintained structure.

• Select ConfiguredDataImportDefault to import service event management data.

7. (Optional) Select the View Log File check box to view the log file when the data transfer is
complete.

8. Click Apply to start the import operation and retain the dialog box, or click OK to start the import
operation and exit the dialog box.

The system imports the data as follows:

• By default, the imported object has no container reference. You can use relevant search criteria
to find the imported object and so you can copy it to a folder.

• To have Teamcenter import objects into your Newstuff folder, create the
PLMXML_put_objects_in_newstuff_on_import preference and set the value to TRUE. Imported
objects are placed in a folder with the same name as the imported XML file.

Note:

If object names or IDs are encountered that exceed the character limit for those fields in
Teamcenter, the name and/or ID is truncated when imported in to Teamcenter. Teamcenter
provides 128 bytes for item IDs and names.

Import as-maintained structure behavior

When you import an as-maintained structure into Teamcenter from a third-party system and the physical
part parent is at a status of released in Teamcenter, the revision of the parent is revised only if there are
structural additions to the existing structure.

As the following figure shows, because the parent physical part Aircraft #100 has a status of released
before the import, it is revised after the import because Engine #300 was added to the structure in a
different position.

Import as-maintained structure behavior
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Released parent physical part revision is revised in Teamcenter after structural addition

Re-import as-maintained structure behavior

When you re-import an as-maintained structure into Teamcenter from a third-party system, be aware of
the following behaviors:

• Re-import after the physical part is added to the as-maintained structure on third-party systems.

As the following figure shows, when the third-party as-maintained structure is re-imported with the
newly added physical part Pump #300, the additional part is imported into Teamcenter.

14. Sharing Service Manager data
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Re-import into Teamcenter with additional physical part

• Re-import after the physical part is deleted from the as-maintained structure on third-party systems.

As the following figure shows, when the third-party as-maintained structure Aircraft #100 is re-
imported to Teamcenter with the physical part Pump #300 removed, the physical part is not removed
in Teamcenter.

Re-import as-maintained structure behavior
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Re-import into Teamcenter with physical part removed

Sharing Service Manager data using Multi-Site Collaboration

Managing Service Manager data for Multi-Site Collaboration

Using Multi-Site Collaboration, you can share Service Manager data between multiple Teamcenter sites.
Each Teamcenter site has its own independent database with its own set of users and groups, data
models, business rules, and business processes.

Data sharing is done through object replication where an exact copy of an object is made at a remote
site using remote export and import functions. The replicas are synchronized when the master copy is
modified.

14. Sharing Service Manager data

14-10  Service Manager, Service Lifecycle Management 2412
© 2024 Siemens



The Object Directory Services server (ODS) site maintains a record of each object in the entire Multi-Site
Collaboration network.

The Integrated Distributed Services Manager (IDSM) provides the mechanism used to export an object
from the owner’s site, transmit it over the network, and import it into the destination site.

Multi-Site Collaboration support for as-maintained structures

When you export as-maintained structures and related Service Manager data using Multi-Site
Collaboration, Data Exchange also exports the relations and the related objects. The table summarizes
which relations and corresponding related objects are exported for each Service Manager object and
whether the related object is optional or required.

Exported Service Manager
object

Exported relation Exported related
object

Optional or
required

Item IMAN references Part logistics form Optional

Has characteristics Characteristic
definitions

Optional

Physical part Physical
characteristics

Characteristic
values

Required

Multi-Site Collaboration support for as-maintained structures
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Exported Service Manager
object

Exported relation Exported related
object

Optional or
required

Physical part
revision (by
creation date)

Optional

Allowed deviation Physical part
(child)

Required

Contains Asset group Required

Physical part in
location

Physical location Required

Disposition
applicability

Disposition Required

Characteristic value Tag Characteristic
definition

Required

Log entry Tag Log book Required

Log book Tag Physical part Required

Allowed deviation Tag Deviation
document

Required

Physical part revision Tag Physical part Required

Physical realization Item revision Optional

Physical context Structure context Required

Tag Lot Required

As-maintained
structure

Physical part Optional

Physical structure Physical structure
alignment

Occurrence Optional

Lot Tag Item Required

Asset group Contains Asset group Optional

Contains Physical part Optional

Physical location None Physical location
revision by
creation date

Optional
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Exported Service Manager
object

Exported relation Exported related
object

Optional or
required

Physical location revision Tag Physical location Required

As-maintained
structure

Physical location Optional

Service Manager actions on stub and replica objects

Data sharing in Multi-Site Collaboration is done by replicating objects to remote databases through
export and import functions. In addition, during Multi-Site Collaboration import, Teamcenter uses the
persistent object model (POM) to create stubs for all referenced instances on the object. The following
table shows the Service Manager actions that can be performed on object replicas and stubs.

Actions Stub Replica Exceptions

Name occurrence No No

Create lot No Yes

Create serial number
generator

No No

Generate as-maintained
structure

No Yes If any stubs are found in the neutral
structure during generation, the action
exits and does not process any partial
structures.

Install physical part No No

Uninstall physical part No No

Setup deviation No No

Assign lot No No

Compare No Yes The compared structures should not have
any stubs.

Visualization No Yes Visualization is not supported for stubs
within the neutral or physical structures.

Display as-maintained
structure

Yes Yes Stubs are displayed as remote lines.
Structures below stubs are not displayed.

Display location structure Yes Yes Stubs are displayed as remote lines.
Structures below stubs are not displayed.

Display asset group structure No Yes

Service Manager actions on stub and replica objects
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Actions Stub Replica Exceptions

Set default location No Yes The compared structures should not have
any stubs.

Display utilization No Yes Characteristic values that are stubs are not
displayed.

Record utilization No Yes Structure must be transferred with
ownership. If the structure has a replica or
a stub, values should not be propagated.

Release physical structure No Yes Structure must be transferred with
ownership.

Where installed No Yes

View disposition history No Yes

Display usage history No Yes

Multi-Site Collaboration support for Service Event Management data

When you import service event management objects using Multi-Site Collaboration, you must set the
Include Reference option to import the following related objects. The option is set by clicking the
Advanced tab in the Import Remote Options dialog box. The table summarizes which relations and
corresponding related objects are imported for each service event management object and whether the
related object is optional or required.

Imported Service Event
Management object Imported relation Imported related object

Optional or
required

Service object Completed Physical part Optional

CorrectiveAction Service event that
completes a service
discrepancy

Optional

HWSOStructure Children of the selected
service object

Optional

Service event MovedPart Physical part for an
approved part movement

Optional

Service Event Management is a separately licensed extension of the Service Manager application.
You must obtain and install the appropriate licenses required to run the Service Event Management
extension.
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A. Service Manager preferences
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AdditionalAsMaintainedAccCheckProperties

DESCRIPTION

Specifies the additional as-maintained accountability check properties.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid BOM line property and a valid
as-maintained BOM line property.

DEFAULT VALUES

phbl_part_usage_name

DEFAULT PROTECTION SCOPE

Site preference.

A. Service Manager preferences
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AdditionalAsMaintainedCompareProperties

DESCRIPTION

Specifies the default as-maintained compare properties.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid BOM line property and a valid
as-maintained BOM line property.

DEFAULT VALUES

phbl_part_used_is

DEFAULT PROTECTION SCOPE

Site preference.

AdditionalAsMaintainedCompareProperties
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DefaultAsMaintainedAccCheckProperties

DESCRIPTION

Specifies the default as-maintained accountability check properties.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid neutral BOM line property and a valid
as-maintained BOM line property.

DEFAULT VALUES

phbl_part_number
phbl_part_used_is

DEFAULT PROTECTION SCOPE

Site preference.

A. Service Manager preferences
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DefaultAsMaintainedCompareProperties

DESCRIPTION

Specifies the default as-maintained compare properties.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid neutral BOM line property and a valid
as-maintained BOM line property.

DEFAULT VALUES

phbl_part_number
phbl_part_usage_name

DEFAULT PROTECTION SCOPE

Site preference.

DefaultAsMaintainedCompareProperties
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Disposition_Propagate_To_Child

DESCRIPTION

Determines if the disposition defined during the generation or duplication of the as-maintained structure
is propagated to all of the children parts generated.

VALID VALUES

One of any logical pairs (true or false, on or off, 0 or 1).

true Propagates the disposition to all child parts of the structure.

false Applies the disposition only to the top part of the structure.

DEFAULT VALUES

false

DEFAULT PROTECTION SCOPE

Site preference.
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Service Lifecycle ManagementConfigRuleName

DESCRIPTION

Specifies the default configuration rule to use when opening as-maintained physical part revisions. If this
rule does not exist, the system defaults to Today Serviceable.

VALID VALUES

Accepts a string as a value. Each string must be a valid as-maintained revision rule name.

DEFAULT VALUES

Today Serviceable

DEFAULT PROTECTION SCOPE

Site preference.

Service Lifecycle ManagementConfigRuleName
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Service Lifecycle Management Default Locations

DESCRIPTION

Specifies the default locations to use for the Generate As-Maintained Structure and Un-Install
Physical Part actions.

VALID VALUES

Accepts one or more strings as values. Each string must be a valid location name from the physical
location object.

DEFAULT VALUES

None.

DEFAULT PROTECTION SCOPE

Site preference.

A. Service Manager preferences
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PhysicalLocation_CompanyLocation_default_relation

DESCRIPTION

Defines the default relationship between a company location and a physical location.

VALID VALUES

Accepts one or more strings as a value. Each string must be a valid Teamcenter object.

DEFAULT VALUES

PhysicalLocationDetails

DEFAULT PROTECTION SCOPE

Site preference.

PhysicalLocation_CompanyLocation_default_relation
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PhysicalLocationContainsColumnsShownPref

DESCRIPTION

Specifies the columns displayed in the Contains view when the selected component is a physical
location.

VALID VALUES

Accepts one or more stings as values.

DEFAULT VALUES

partNumber
serialNumber
lotNumber
manufacturerOrgId
manufacturingDate

DEFAULT PROTECTION SCOPE

Site preference.
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PhysicalLocation_DefaultChildProperties

DESCRIPTION

Defines the default child properties for a physical location.

VALID VALUES

Accepts one or more strings as values. Each string must be a valid Teamcenter property name.

DEFAULT VALUES

IMAN_master_form
bom_view_tags
revision_list
IMAN_requirement
IMAN_manifestation
IMAN_reference
IMAN_MEView
IMAN_vi_sos
IMAN_external_object_link
PhysicalElementOwner
PhysicalLocationDetails

DEFAULT PROTECTION SCOPE

Site preference.

PhysicalLocation_DefaultChildProperties
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ServiceManagerAssetGroupColumnsShownPref

DESCRIPTION

Specifies the list of columns displayed for an asset group in Service Manager in left to right order.

VALID VALUES

Accepts one or more strings as values. Each string must be a valid asset group property.

DEFAULT VALUES

object_name
object_desc

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceManagerAssetGroupColumnWidthsPref

DESCRIPTION

Specifies the column widths displayed for an asset group in Service Manager in left to right order.

VALID VALUES

One or more integers as values; each integer defines the column width in characters. The
first value set in this preference defines the column width of the first value set in the
ServiceManagerAssetGroupColumnsShownPref user preference and so forth.

DEFAULT VALUES

20
20

DEFAULT PROTECTION SCOPE

Site preference.

ServiceManagerAssetGroupColumnWidthsPref
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ServiceManagerColumnsShownPref

DESCRIPTION

Specifies the columns displayed for physical parts opened in Service Manager in left to right order.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid as-maintained BOM line property.

DEFAULT VALUES

bl_indented_title
bl_item_object_type
phbl_part_used_is
phbl_part_usage_name
phnl_serial_number
phbl_lot_number
phbl_part_number
phbl_installation_time
phbl_mfg_date
phbl_mfgr_org_id
phbl_physical_quantity
phbl_physical_uid
bl_item_item_id

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceManagerShownColumnWidthsPref

DESCRIPTION

Specifies the column widths displayed for physical parts in Service Manager in left to right order.

VALID VALUES

One or more integers as values; each integer defines the column width in characters. The
first value set in this preference defines the column width of the first value set in the
ServiceManagerShownColumnWidthsPref user preference and so forth.

DEFAULT VALUES

20
10
10
10
10
10
10
15
15
10
10
15
10

DEFAULT PROTECTION SCOPE

Site preference.

ServiceManagerShownColumnWidthsPref
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ServiceManagerPhysicalLocationColumnsShownPref

DESCRIPTION

Specifies the columns displayed for a physical location.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid as-maintained BOM line property.

DEFAULT VALUES

plbl_location_name
plbl_location_description
plbl_location_type

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceManagerPhysicalLocationColumnWidthsPref

DESCRIPTION

Specifies the column widths displayed for the physical location in left to right order.

VALID VALUES

One or more integers as values; each integer defines the column width in characters. The
first value set in this preference defines the column width of the first value set in the
ServiceManagerPhysicalLocationColumnWidthsPref user preference and so forth.

DEFAULT VALUES

20
20
20

DEFAULT PROTECTION SCOPE

Site preference.

Service event management preferences
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ActivityCost.RENDERING

DESCRIPTION

Determines the registration of the viewer style sheet for activity cost objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ActivityCost

DEFAULT PROTECTION SCOPE

Site preference.
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ActivityCost.SUMMARYRENDERING

DESCRIPTION

Determines the registration of the summary style sheet for activity cost objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ActivityCostSummary

DEFAULT PROTECTION SCOPE

Site preference.

ActivityCost.SUMMARYRENDERING
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ActivityEntryValue.Service Lifecycle ManagementCREATERENDERING

DESCRIPTION

Determines the registration of the create style sheet for activity entry value objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ActivityEntryValueCreate

DEFAULT PROTECTION SCOPE

Site preference.
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ActivityEntryValue.RENDERING

DESCRIPTION

Determines the registration of the viewer style sheet for activity entry value objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ActivityEntryValue

DEFAULT PROTECTION SCOPE

Site preference.

ActivityEntryValue.RENDERING
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ActivityEntryValue.SUMMARYRENDERING

DESCRIPTION

Determines the registration of the summary style sheet for activity entry value objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ActivityEntryValueSummary

DEFAULT PROTECTION SCOPE

Site preference.
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FaultCode.Service Lifecycle ManagementCREATERENDERING

DESCRIPTION

Determines the registration of the create style sheet for fault code objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

FaultCodeCreate

DEFAULT PROTECTION SCOPE

Site preference.

FaultCode.Service Lifecycle ManagementCREATERENDERING
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FaultCode.RENDERING

DESCRIPTION

Determines the registration of the viewer style sheet for fault code objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

FaultCode

DEFAULT PROTECTION SCOPE

Site preference.

A. Service Manager preferences
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FaultCode.SUMMARYRENDERING

DESCRIPTION

Determines the registration of the summary style sheet for fault code objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

FaultCodeSummary

DEFAULT PROTECTION SCOPE

Site preference.

FaultCode.SUMMARYRENDERING
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Service Lifecycle ManagementDefaultLogBook

DESCRIPTION

Determines the registration of the create style sheet for service discrepancy objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ServiceLogBook

DEFAULT PROTECTION SCOPE

Site preference.
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PartMovement_DefaultChildProperties

DESCRIPTION

Defines the default child properties for part movement objects.

VALID VALUES

Accepts multiple strings as values.

DEFAULT VALUES

MovedPart

DEFAULT PROTECTION SCOPE

Site preference.

PartMovement_DefaultChildProperties
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PartMovementDefaultRemoveLocation

DESCRIPTION

Determines the default physical location to use when you create a service event that is related to a part
movement.

VALID VALUES

A valid physical location.

DEFAULT VALUES

None.

DEFAULT PROTECTION SCOPE

Site preference.
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PartMovement.ENABLE_PROPERTIES_EDIT

DESCRIPTION

Allows edits to the part movement properties. To allow edits, set the value to false.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

false

DEFAULT PROTECTION SCOPE

Site preference.

PartMovement.ENABLE_PROPERTIES_EDIT
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PartMovement.Service Lifecycle ManagementCREATERENDERING

DESCRIPTION

Determines the registration of the summary style sheet for part movement objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

PartMovementCreate

DEFAULT PROTECTION SCOPE

Site preference.
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PartMovement.RENDERING

DESCRIPTION

Determines the registration of the viewer style sheet for part movement objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

PartMovement

DEFAULT PROTECTION SCOPE

Site preference.

PartMovement.RENDERING
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PartMovement.SUMMARYRENDERING

DESCRIPTION

Determines the registration of the summary style sheet for part movement objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

PartMovementSummary

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceAction.RENDERING

DESCRIPTION

Determines the registration of the viewer style sheet for service action objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ServiceAction

DEFAULT PROTECTION SCOPE

Site preference.

ServiceAction.RENDERING
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ServiceAction.SUMMARYRENDERING

DESCRIPTION

Determines the registration of the summary style sheet for service action objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ServiceActionSummary

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceDiscrepancy_DefaultChildProperties

DESCRIPTION

Defines the default child properties for service discrepancy objects.

VALID VALUES

Accepts multiple strings as values.

DEFAULT VALUES

CorrectiveAction
InProgress
fault_code

DEFAULT PROTECTION SCOPE

Site preference.

ServiceDiscrepancy_DefaultChildProperties
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ServiceDiscrepancy.ENABLE_PROPERTIES_EDIT

DESCRIPTION

Allows edits to the service discrepancy properties. To allow edits, set the value to true.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

false

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceDiscrepancy_FaultCode_default_relation

DESCRIPTION

Defines the relationship between a service discrepancy and a fault code.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

fault_code

DEFAULT PROTECTION SCOPE

Site preference.

ServiceDiscrepancy_FaultCode_default_relation
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ServiceDiscrepancy.Service Lifecycle ManagementCREATERENDERING

DESCRIPTION

Determines the registration of the create style sheet for service discrepancy objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ServiceDiscrepancyCreate

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceDiscrepancy.RENDERING

DESCRIPTION

Determines the registration of the viewer style sheet for service discrepancy objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ServiceDiscrepancy

DEFAULT PROTECTION SCOPE

Site preference.

ServiceDiscrepancy.RENDERING
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ServiceDiscrepancy_ServiceEvent_default_relation

DESCRIPTION

Defines the relationship between a service discrepancy and a service event.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

CorrectiveAction

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceDiscrepancy_ServiceGroup_default_relation

DESCRIPTION

Defines the relationship between a service discrepancy and a service group.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

InvalidRelation

DEFAULT PROTECTION SCOPE

Site preference.

ServiceDiscrepancy_ServiceGroup_default_relation
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ServiceDiscrepancy.SUMMARYRENDERING

DESCRIPTION

Determines the registration of the summary style sheet for service discrepancy objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ServiceDiscrepancySummary

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceEvent_DefaultChildProperties

DESCRIPTION

Defines the default child properties for service event objects.

VALID VALUES

Accepts multiple strings as values.

DEFAULT VALUES

Completed
InProgress
CorrectiveAction
HMSOStructure
activity_entry_value

DEFAULT PROTECTION SCOPE

Site preference.

ServiceEvent_DefaultChildProperties
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ServiceEvent.ENABLE_PROPERTIES_EDIT

DESCRIPTION

Allows edits to the service event properties. To allow edits, set the value to true.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

false

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceEvent.Service Lifecycle ManagementCREATERENDERING

DESCRIPTION

Determines the registration of the create style sheet for service event objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ServiceEventCreate

DEFAULT PROTECTION SCOPE

Site preference.

ServiceEvent.Service Lifecycle ManagementCREATERENDERING
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ServiceEvent.RENDERING

DESCRIPTION

Determines the registration of the viewer style sheet for service event objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ServiceEvent

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceEvent.SUMMARYRENDERING

DESCRIPTION

Determines the registration of the summary style sheet for service event objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ServiceEventSummary

DEFAULT PROTECTION SCOPE

Site preference.

ServiceEvent.SUMMARYRENDERING
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ServiceGroup.ENABLE_PROPERTIES_EDIT

DESCRIPTION

Allows edits to the service group properties. To allow edits, set the value to true.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

false

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceGroup.Service Lifecycle ManagementCREATERENDERING

DESCRIPTION

Determines the registration of the create style sheet for service group objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ServiceGroupCreate

DEFAULT PROTECTION SCOPE

Site preference.

ServiceGroup.Service Lifecycle ManagementCREATERENDERING
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ServiceGroup.RENDERING

DESCRIPTION

Determines the registration of the viewer style sheet for service group objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ServiceGroup

DEFAULT PROTECTION SCOPE

Site preference.
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ServiceGroup.SUMMARYRENDERING

DESCRIPTION

Determines the registration of the summary style sheet for service group objects.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

ServiceGroupSummary

DEFAULT PROTECTION SCOPE

Site preference.

ServiceGroup.SUMMARYRENDERING
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TransactionElement.COLUMNS_SHOW

DESCRIPTION

Determines which columns are displayed in the transaction element structure in left to right order.

VALID VALUES

Accepts multiple strings as values.

DEFAULT VALUES

object_name
transaction_id

DEFAULT PROTECTION SCOPE

Site preference.
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TransactionElement.COLUMNS_WIDTH

DESCRIPTION

Determines the widths for the columns displayed in the transaction element structure in left to right
order.

VALID VALUES

Accepts multiple strings as values.

DEFAULT VALUES

20
20

DEFAULT PROTECTION SCOPE

Site preference.

TransactionElement.COLUMNS_WIDTH
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TransactionElement_DefaultChildProperties

DESCRIPTION

Defines the default child properties for transaction element objects.

VALID VALUES

Accepts multiple strings as values.

DEFAULT VALUES

InProgress
HWSOStructure

DEFAULT PROTECTION SCOPE

Site preference.
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TransactionElement_Document_default_relation

DESCRIPTION

Defines the relationship between a transaction element and a document.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

IMAN_reference

DEFAULT PROTECTION SCOPE

Site preference.

TransactionElement_Document_default_relation
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TransactionElement_DocumentRevision_default_relation

DESCRIPTION

Defines the relationship between a transaction element and a document revision.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

IMAN_reference

DEFAULT PROTECTION SCOPE

Site preference.
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TransactionElement_PhysicalElement_default_relation

DESCRIPTION

Defines the relationship between a transaction element and a physical element.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

InProgress

DEFAULT PROTECTION SCOPE

Site preference.
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TransactionElement_PhysicalElementRevision_default_relation

DESCRIPTION

Defines the relationship between a transaction element and a physical element revision.

VALID VALUES

Accepts a single string as a value.

DEFAULT VALUES

InvalidRelation

DEFAULT PROTECTION SCOPE

Site preference.
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