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1. Service Lifecycle Management
As-Built Manager

Capitalize on the re-use of product knowledge from engineering and manufacturing to improve service
planning and execution. Provide feedback to engineering to improve product designs for serviceability
and reliability. Communicate and coordinate operational activities for greater compliance, faster service,
and lower costs.

Service Lifecycle Management products

Select a link below to access the help documentation for each product.

Service Lifecycle Management on web client

Service Engineering

Service Work Instruction

Service Manager
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Service Planner

Maximo Integration

Microservices for Service Lifecycle Management Integration

1. Service Lifecycle Management
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2. What's new in As-Built Manager
What's new in As-Built Manager 14.1

• Beginning with Teamcenter 14.1, when you create an as-built structure from a neutral structure, you
can control the display of parts that have a quantity greater than one, in the new structure. This
becomes especially important when you work on very large structures and on structures imported
into Teamcenter from a CAD system.

For example, a wheel assembly includes multiple nuts. When the structure is imported, each nut
is represented by a single line in the neutral structure. The existence of multiple lines for one part
clutters the structure, making it difficult to find specific parts throughout the structure.

What's new in As-Built Manager 13.2

• Teamcenter Environment Manager (TEM) is deprecated and will be obsolete in a future version of
Teamcenter.

• You now can create as-built structures from configured neutral structures in As-Built Manager.
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3. Getting started with As-Built Manager
Getting started with As-Built Manager

As-Built Manager is a separately licensed application that is installed as an optional overlay on top of
the standard Teamcenter product. This application allows you to manage the as-built configuration of an
asset realized from a product definition structure, such as a design or manufacturing structure. You can
use As-Built Manager to:

• Create the as-built physical product instantiation for any configured product structure.

• Store and manage additional information about the as-built physical part structure that is not tracked
on the product definition structure, such as serial numbers and lot numbers.

• Reconcile the as-built structure with a configured product definition structure to identify parts that are
missing, alternates, substitutes, or deviations.

• Compare the as-built structure to the product definition structure or to another as-built structure.

• View the as-designed product structure and the as-built physical structure configuration side-by-side
or by using the embedded viewer available in the rich client.

• Import an as-built structure from an external manufacturing execution system (MES) or an enterprise
resource planning (ERP) system in PLM XML.

• Export an as-built structure to an Teamcenter Enterprise Service Lifecycle Management system using
Data Exchange.

• Manage as-built structures in a Multi-Site Collaboration environment.

Before you begin

Prerequisites The As-Built Manager application requires a separate license
in addition to the standard Teamcenter product license. You
must obtain and install the appropriate licenses required to
run the As-Built Manager application.

Enable As-Built Manager As-Built Manager does not need to be enabled before you
use it, but you must select this feature and the associated
components during installation.

If you have trouble accessing As-Built Manager, see your
system administrator; it may be a licensing issue. The As-Built
Manager application requires a separate license in addition to
the standard Teamcenter product license.
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Configure As-Built Manager There are additional steps you must perform to configure As-
Built Manager before you can use it.

Start As-Built Manager Click As-Built Manager  in the navigation pane.

As-Built Manager interface

As-Built Manager perspective

1 Teamcenter component pane Shows the Teamcenter folders and components.

2 Data pane Allows you to view data about the selected line. To display
a different data pane, click its tab.

As-Built Manager uses the Teamcenter rich client interface.

Not all of the following menu commands and buttons may be available on your system, as the
administrator can hide or reveal only those commands and buttons that are appropriate for your site.

3. Getting started with As-Built Manager
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As-Built Manager menus

File menu

Command Description

New → Workflow Process (Ctrl+P) Creates a new workflow process.

New → Item Creates a new item.

New → Folder Creates a new folder.

New → Dataset Creates a new dataset.

Duplicate As-Built Manager
Structure

Creates a duplicate of the as-built physical structure.

Close Closes the As-Built Manager application.

Open (Ctrl+O) Opens the selected structure.

Exit Ends the rich client session.

Edit menu

Command Description

Cut (Ctrl+X) Marks the selected lines for removal and copies the content to
the clipboard. Cut lines are only removed once pasted elsewhere
in the structure.

Copy (Ctrl+C) Copies the selected lines to the clipboard.

Paste (Ctrl+V) Inserts the Clipboard contents below the selected item.

Paste Special Allows you to specify a relation type rather than using the
default paste relation when pasting an object reference into an
item or item revision.

Delete Deletes the selected object from the database.

User Setting Displays the User Settings dialog box, where you can change
your group, role, or volume assignments, and your application
logging and journaling options.

Options Changes your user interface settings that affect all applications,
not only As-Built Manager.

Toggle In-Context Mode Enables or disables editing in context mode, allowing creation of
absolute occurrences for the selected assembly.

File menu

As-Built Manager, Service Lifecycle Management 2412  3-3
© 2024 Siemens



View menu

Command Description

Refresh (F5) Updates the information displayed for a selected line and all of
its children.

Refresh Window Synchronizes the currently displayed as-built structure with the
database. The displayed structure refreshes with changes that
have been made in other sessions and saved since you loaded
the currently displayed as-built structure.

Properties Displays the properties for the selected item.

Access... Displays the user access for the selected item.

Show Data Panel Shows or hides the data pane containing, for example,
properties data or the embedded viewer.

Show/Hide Second Structure
Panel

Displays a second structure pane below the first. You can set the
size of each structure pane by moving the horizontal split bar
between the panes. If the second structure pane is displayed,
this button hides the lower pane.

Show/Hide Collaboration Panel Shows or hides the collaboration panel.

Expand Expands the substructure immediately below the selected lines.

Expand Below Expands the complete substructure below the selected lines.

Expand Below... Expands the substructure below the selected lines to a user-
selected level. You can also collapse an expanded substructure
when you choose this option (hide certain child lines).

Collapse Below Collapses the complete substructure below the selected lines
(hide all child lines).

Pack (Ctrl+Shift+M) Packs the selected lines so that all lines with the same item
revision and find number are displayed as a single line. The
actual quantity of lines appended to the node.

Unpack (Ctrl+Shift+N) Unpacks the selected packed lines so that they are displayed as
separate lines, one for each occurrence.

Pack All Packs all packable lines in the displayed structure.

Unpack All Packs all packable lines in the displayed structure.

Show Unconfigured Variants Shows or hides unconfigured variant components.

Show Unconfigured Assigned
Occurrences

Shows assigned objects that were configured out by the variant
rules of the structures from which the objects were assigned.
You can only use this command with composition structures.

3. Getting started with As-Built Manager
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Command Description

Note:

This command does not automatically refresh. Any
changes to the assigned objects are not reflected in the
structure until you execute this command again.

Show Unconfigured Changes Shows unconfigured changes. If you hide unconfigured changes,
only those changes configured by the current revision rule are
visible.

Show Unconfigured By
Occurrence Effectivity

Shows or hides components that are not configured when using
occurrence effectivity.

Show Untraced Parts Shows or hides the neutral parts that are not traceable in the
physical structure.

Tools menu

Command Description

Check-In/Out → Check-Out Checks a selected component out of the database.

Check-In/Out → Check-In Checks a selected component into the database.

Check-In/Out → Cancel Check-out Cancels a request checkout action.

Check-In/Out → Transfer Check-
out

Transfers a selected, checked-out component to another user.

Check-In/Out → Notification List Allows you to view or edit the list of users who are informed if
the selected component is checked in or checked out.

Check-In/Out → Check-Out History Allows you to view the history of checkout actions for the
selected component.

Id Display Rule → View/Set
Current

Allows you to view the ID display rule currently applied to the
selected structure or set a different ID display rule.

Id Display Rule → Modify Current Modifies the ID display rule currently applied to the selected
structure.

Id Display Rule → Create/Edit Creates a new ID display rule or modify an existing ID rule.

Revision Rule → View/Set Current Allows you to view or set the revision rule for the currently
displayed structure.

Revision Rule → Set Date/Unit/End
Item

Sets the date, unit number, or end item to configure the
structure, if the current rule allows.

Tools menu
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Command Description

Revision Rule → Set Override
folder

Sets an override folder to override item revisions that would
otherwise be selected by other criteria.

Revision Rule → Modify Current Modifies the current revision rule and apply the modified rule to
the current structure. You can save the change if you have write
access to the original rule.

Revision Rule → Create/Edit Creates or edits a revision rule.

Variants → Configure Variants Allows you to configure or edit a variant structure for the
selected top level module.

Variants → Only Configure Root Allows you to set to on to only display options for the top-level
module, regardless of the line selected. Set to off to configure
the structure for a lower level module.

Variants → Search Searches for an existing variant item.

Variants → Count Modules Counts the modules defined for the selected variant structure.

Arrangements → View/Set
Current

Allows you to view or set the current NX arrangements.

Export → Objects Exports selected objects in Teamcenter format, STEP format or
a new or available application interface. When you export an
object in Teamcenter or STEP format, you move all internal data
associated with that object.

Export → To PLMXML Exports the selected structure and its attachments in the PLM
XML format to a selected export directory. You must choose the
appropriate transfer mode for the destination system.

If you export a structure in which substitute components are
defined, the substitutes are also exported.

Export → Objects to Excel Exports the selected structure lines to an Excel spreadsheet.

Import → Templates Imports a specification, object, or Excel template.

Import → Objects Imports objects in a Teamcenter format or STEP format to your
Teamcenter database.

Import → From PLMXML Imports objects in the PLMXML format to your Teamcenter
database.

Import → Remote Imports objects from a remote site using Multi-Site
Collaboration.

Rebase Physical Part Updates the physical part to the latest design of the neutral
structure.

3. Getting started with As-Built Manager
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Command Description

Compare Compares two as-built structures or compares the as-built
structure to the neutral product structure in separate windows.

Clear Clears the results of comparing two structures.

Find in Other Structure Finds the selected object in another structure pane. The search
follows the closest match rule if it does not find an exact match.

Rename Physical Part Allows you to change the part number and serial number of a
physical part.

Create Lot Allows you to create lot information when you select a part
defined as a lot part. Lot information includes lot number,
manufacturer ID, and lot size.

Create Serial Number Generator Allows you to create numbering scheme information for a serial
number on a neutral part that is defined as a serialized part.
The numbering scheme information is used for serial number
generation on physical parts generated from that neutral part.
For example, you can define a prefix, suffix, or maximum
number for the serial numbers generated.

Generate As-Built Manager
Structure

Creates a physical as-built structure from the selected neutral
structure.

Name Occurrence Assigns a name to the occurrence for the selected neutral part
using the predefined naming rules.

Assign Lot Assigns a lot number to the selected physical part.

Install Physical Part Adds or installs a copied physical part into the current as-built
structure.

Uninstall Physical Part Uninstalls and removes the selected lines from the as-built
structure completely and does not place them on the clipboard.

Replace Physical Part Replaces a selected physical part in the current as-built structure
with a copied part.

Setup Deviation Opens the Setup Deviation wizard. Use the Setup Deviation
wizard to search for a deviation document to associate to the
physical part.

Rebuild Physical Structure Creates a new build revision of a physical part.

Generate As-Maintained
Structure

Generates an as-maintained physical structure from an as-built
physical structure.

Tools menu
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As-Built Manager buttons and symbols

Note:

You can add buttons that are not displayed on the main toolbar by right-clicking the toolbar,
choosing Customize, and selecting the buttons you want to add. Once you have added buttons to
the toolbars, they are displayed in future sessions. Consider adding buttons that:

• You use frequently.

• Provide a shortcut to menu commands that are not primary selections, for example,
Tools → Revision Rule → Set Date/Unit/End Item....

Button Purpose

These standard buttons are located on the main toolbar at the top of the as-built structure pane.

Soft abort If enabled, allows you to terminate the current operation
without closing As-Built Manager or losing data.

Cut Cuts the selected lines from the structure and places them
on the clipboard.

Copy Copies the selected lines in the structure and places them on
the clipboard.

Paste Pastes the components from the clipboard as children of the
currently selected (assembly) line in the structure.

Delete Deletes the selected object from the database.

Show/Hide data pane Shows or hides the data pane containing, for example,
properties data or the embedded viewer.

Show/Hide the lower
structure pane

Displays a second structure pane below the first. You can
set the size of each structure pane by moving the horizontal
split bar between the panes. If the second structure pane is
displayed, this button hides the lower pane.

Show/Hide the
collaboration pane

Displays or hides the collaboration pane, which provides
advanced features for configuring structures. These features
relate primarily to Multi-Structure Manager.

Create lot Allows you to create lot information when you select a part
defined as a lot part. Lot information includes lot number,
manufacturer ID, and lot size.

Show untraced parts Shows or hides the neutral parts that are not traceable in the
physical structure.

3. Getting started with As-Built Manager
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Button Purpose

Create serial number
generator

Allows you to create numbering scheme information for a
serial number on a neutral part that is defined as a serialized
part. The numbering scheme information is used for serial
number generation on physical parts generated from that
neutral part. For example, you can define a prefix, suffix, or
maximum number for the serial numbers generated.

Generate as-built
structure

Creates a physical as-built structure from the selected neutral
structure.

Name occurrence Assigns a name to the occurrence for the selected line using
the predefined naming rules.

View/Set current Allows you to view or set the revision rule on the current
line.

Configure variants Allows you to view and configure the variant option values
for the selected line.

Refresh Updates the information displayed for a selected line and all
of its children.

Find selected in other
panel

When you select a component in the BOM in one structure
pane and click this button, you can search for the component
in the BOM in the other structure pane. The search follows
the closest match rule if it does not find an exact match.

Pack selected line Packs the selected lines so that all lines with the same item
revision and find number are displayed as a single line. The
actual quantity of lines appended to the node.

Unpack selected line Unpacks the selected packed lines so that they are displayed
as separate lines, one for each occurrence.

Install physical part Adds or installs a physical part into the current as-built
structure.

Uninstall physical part Uninstalls and removes the selected lines from the as-built
structure completely and does not place them on the
clipboard.

Replace physical part Replaces the physical part into the current as-built structure.

Setup deviation Opens the Setup Deviation wizard. Use the Setup Deviation
wizard to search for a deviation document to associate to the
physical part.

Rebuild physical structure Creates a new build revision of the physical structure.

Navigation Pane Displays or hides the navigation pane.

As-Built Manager buttons and symbols
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Button Purpose

Advanced Search Allows you to select a search form that includes multiple
search criteria relevant to the type of information or object
being sought.

The following buttons are located at the bottom left corner of the as-built structure navigation tree
pane.

Most recently used
(MRU) list

Shows a list of your most recently accessed structures. If
you select an entry from the list, As-Built Manager loads
the structure into the structure pane. You can configure the
number of entries shown in the MRU list by right-clicking the
button and moving the slider to the desired number.

Open by name Browses for and opens a specific structure by name.

Open structure context
by name

Browses for and opens a specific structure context by name.

Most recently used
(MRU) revision rules list

Selects a revision rule to apply to the current product
structure from a list of the rules you have used recently. You
can configure the number of entries shown in the MRU by
right-clicking the button and moving the slider to the desired
number.

List substitute
components

Adds or removes substitute components or set the preferred
substitute.

This button is enabled if the selected line may have
substitutes; otherwise, it is disabled.

Manage global alternates Shows a list of the global alternates available for the selected
line. You can add alternates and select a preferred alternate.
The preferred global alternate is indicated by an asterisk.

Find in display Searches for matching lines (components) in the displayed
product structure by entering an expression. You can search
with any combination of the available properties.

The following symbols are displayed at the bottom right corner of the product structure pane and
show the current status of the selected line.

Shows if you have write access permissions for the selected
line.

Shows if you have delete access permissions for the selected
line.

Shows if you have access permissions to change the selected
line.

3. Getting started with As-Built Manager
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Button Purpose

Shows if the item revision represented by the line is currently
in a workflow process.

Shows if the item revision represented by the line is currently
checked in or checked out.

Shows if the item revision represented by the line is currently
released.

Shows if the item represented by the line is currently
published.

Shows if the item or revision represented by the line is
currently classified.

What are perspectives and views?

Within the rich client user interface, application functionality is provided in perspectives and views.

View The basic display component that displays related information in a UI window.

Perspective A collection of one or more views and their layout.

Some applications use a perspective with multiple views to arrange how functionality is presented.
Other applications use a perspective with a single view.

You can use the HiddenPerspectives preference to prevent the display of some Teamcenter perspectives
in the rich client.

If your site has online help installed, you can access application and view help from the rich client Help
menu or by pressing F1.

Basic concepts for using As-Built Manager

Before creating or modifying the product structure, read Getting Started with Product Structure,
which describes the basic concepts behind product structure and includes advanced information on how
to use and administer it.

To take full advantage of As-Built Manager, you should be familiar with the Teamcenter elements that
are used to define and present product structure, the basic process of creating product structure, and
how item revisions relate to how you manage default and multiple product views. Product structures
are not created or modified in As-Built Manager, but these structures are used as the definition for the
as-built structure.

The following are elements of As-Built Manager:

What are perspectives and views?
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Element Description

As-built structure The representation of an individual physical asset. A single neutral
structure can result in many as-built structures, one for each
physical asset. The as-built structure contains additional asset-specific
information and records authorized differences from the product
definition.

Deviation document A document that authorizes the installation of a physical part which
is a deviation from the design structure.

Deviated physical part A physical part installed in a physical structure which is not the
preferred part or designated as a valid alternate or substitute to the
preferred part.

Deviation workflow The process flow, reviewer’s list, and business validations required to
route a deviation document for review and approval.

Lot Group of physical parts controlled by the same number. A lot number
is similar to a serial number. The difference between the two is that
the same lot number can identify multiple physical parts, but no
more than the total number of physical parts specified by the lot size.

Lot part Physical part or assembly identified by a lot number.

Neutral part An item defined in the neutral structure representing a part
definition. It can be a part object or any other item type configured as
a valid neutral item type in the Business Modeler IDE.

Neutral structure A hierarchy of neutral parts representing the asset independent
product definition structure, such as the manufacturing or design
structure.

Part logistics data Information added to the neutral part that will support the realization
of physical parts in as-built or as-maintained representations of the
product. For example, part logistics data determines whether the part
is traceable, serialized, or lot. Part logistics data is added to each
neutral part using the part logistics form.

Physical part The representation of a built or manufactured physical asset
realized from the neutral part. The physical part captures the asset
information such as its serial number, manufacturer, lot number. It
also inherits the part number from the neutral part from which it is
realized.

Physical structure A structure composed of physical parts.

Physical realization The relation between a physical part and the neutral part revision
that it was realized from.

Serial number generator A number generator that can be configured on a neutral part to
create serial numbers for every instance of a physical part. You can
set characteristics for the serial numbers, such as a prefix, suffix, the
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Element Description

number increment, and the maximum number of characters in the
serial number. During the instantiation of the physical structure from
the neutral structure, you can choose to automatically assign the
serial numbers to the newly created physical parts.

Serialized part Approved product structure that includes part information.

Usage Defines the position that the physical part occupies within the as-built
structure.

Search for As-Built Manager objects

You can search for the following As-Built Manager objects using advanced search:

• MRO Deviation Document
• MRO Item
• MRO Lot
• MRO Neutral Part
• MRO Physical Part
• MRO Serial Number Generator

1. Choose Advanced from the quick Search menu at the top of the navigation pane.

2. On the Search pane toolbar, click  to select a search type.

3. Click More to display the system defined searches.

4. Under System Defined Searches, select the object you want to search for.

5. Click OK.

The dialog box that contains the object properties appears.

6. Type the values for the object properties that you want to search for.

7. Click the  button to search.

Basic tasks for using As-Built Manager

The basic tasks for using As-Built Manager are:

1. Configuring As-Built Manager by setting global and business object constants, LOVs, and
preferences.

Search for As-Built Manager objects
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2. Creating the neutral structure definition.

3. Generating the physical structure from the neutral structure.

4. Setting up and configuring the physical structure.

As-Built Manager process task flow

3. Getting started with As-Built Manager
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4. Installing and configuring As-Built
Manager
Installing As-Built Manager

As a system administrator, you must install and configure As-Built Manager using Teamcenter
Environment Manager (TEM). As the following figure shows, you must install As-Built Manager on the
server and on the rich clients that use the application.

Install As-Built Manager

As a system administrator, you must install and configure As-Built Manager using Teamcenter
Environment Manager (TEM). As the following figure shows, you must install As-Built Manager on the
server and on the rich clients that use the application.

For more information about planning your installation and installing Teamcenter, see Teamcenter Server
Installation on Linux or Teamcenter Server Installation on Windows.
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1. Start Teamcenter Environment Manager (TEM).

For more information about launching Teamcenter Environment Manager, see the Teamcenter
Server Installation on Linux or the Teamcenter Server Installation on Windows.

2. Select the appropriate options until you reach the Features panel.

Note:

The configuration installed is dependent on the options that you choose in the Solutions
panel of the TEM installation windows, such as Corporate Server, Rich Client 2–Tier, and
Business Modeler IDE. You can also add any of the options available in the Solutions panel
from the Features panel.

3. In the Features panel, under Extensions — Service Lifecycle Management, select the following
features.

Feature Description Prerequisite features

As-Built
Management

Installs the As-Built Management
functionality.

Teamcenter Foundation

4. If you want to configure your system using the Business Modeler IDE:

a. Click Next. Select appropriate options until you reach the Business Modeler IDE Templates
panel.

b. In the Business Modeler IDE Templates panel, select the following templates.

Template Description

Teamcenter Foundation Installs the Teamcenter Foundation template.

As-Built Management Installs the As-Built templates.

For more information about installing the Business Modeler IDE, see Teamcenter Server
Installation on Linux or Teamcenter Server Installation on Windows.

5. Click Next.

Select appropriate options until you complete the installation.

For more information, see Teamcenter Server Installation on Linux or Teamcenter Server
Installation on Windows.

4. Installing and configuring As-Built Manager
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Configuring As-Built Manager

The Teamcenter administrator configures the As-Built Manager according to company needs and
organization requirements as shown in the following figure.

You can configure:

• As-Built Manager preferences.

• Global and property constants that control part logistics information and define part usage properties.

• Business object constants that identify neutral item types.

• Naming rules for occurrences.

• Lists of values (LOVs) that define deviation authority documents and status lists.

• As-Built Manager workflows.

You use the Business Modeler IDE to configure global and property constants, business object constants,
naming rules, and LOVs. An administrator creates and configures a custom template based on the
As-Built Manager or other templates provided with the As-Built Manager application. You must deploy
the custom template after making the changes.

Setting as-built preferences

As an administrator or Teamcenter user, you can set the Service Lifecycle Management and As-Built
Manager preferences according to your needs. Preferences are special environment variables stored in
the Teamcenter database and are read during Teamcenter application usage.

Configuring As-Built Manager
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Setting as-built global and property constants

Setting as-built global and property constants

Global constants provide consistent definitions that can be used throughout the system. These constants
have only one value, either the default value or the value you set. You use the Business Modeler IDE
to configure the global constants in the custom template that you define. You must deploy the custom
template after making the changes.

You can configure the following as-built global constants:

• AutoCreatePartLogisticsForm

Set this value to automatically create part logistics forms and relate them to a neutral item.

• PartLogisticsFormNamePrefix

Set this value to automatically create a prefix in part logistics form names.

• UsageAttributeName

Set this value to the property of PSOccurrence that is to contain the value for the generated physical
part's usage.

• ReuseAuthorizedDeviation

Set this value to reuse an authorized deviation information when duplicating physical structures.

You can configure the following as-built property constant:

• InitialValue

Set this value to set the defaults for the properties of the part logistics form.

Set up automated creation of part logistics forms

As an administrator, you can set the AutoCreatePartLogisticsForm global constant to true to configure
part logistics forms to be automatically created and related to a neutral item during creation. The part
logistics form is related to the neutral item with a References relation.

Example:

Because a part object by default is classified as a neutral item, a part logistics form is automatically
created and related to a newly created part.

4. Installing and configuring As-Built Manager
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Global constant Default value

AutoCreatePartLogisticsForm True

Define default values for part logistics form

As an administrator, you can set the defaults for values contained in the part logistics form by setting the
property constant InitialValue for any of the properties of the PartLogisticsForm business object.

Example:

You may want to set the InitialValue for the IsSerialized property to True, to require all physical
parts to have a serial number on one system, but not on another system.

Define part logistics form name prefix

As an administrator, you can set the PartLogisticsFormNamePrefix global constant to a prefix that is
used for part logistics form names.

Example:

If you want part logistics form names to contain the prefix PL, set PartLogisticsFormNamePrefix
to PL.

Global constant Default value

PartLogisticsFormNamePrefix NULL

Define usage property

As an administrator, you can set the UsageAttributeName global constant to the property of
PSOccurrence that populates the value of the physical part's usage when the as-built physical structure
is generated.

Example:

You may want to set the UsageAttributeName global constant to ref_designator. When you set
the value of ref_designator to RD1234, the value of usage is populated with that same value
RD1234 for the generated physical part.

The allowed properties are:

• occurrence_name

• ref_designator

Define default values for part logistics form
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• seq_no

Note:

The seq_no property corresponds to the value for the Find No. property in the Service Manager
interface.

Global constant Default value

UsageAttributeName occurrence_name

Reuse an authorized deviation

As an administrator, you can set the ReuseAuthorizedDeviation global constant to True to reuse an
authorized deviation when duplicating a physical structure. If the value is set to True, the deviated and
extra to design parts from the original structure are copied to the duplicated structure.

Global constant Default value

ReuseAuthorizedDeviation True

Setting as-built business object constants

Setting as-built business object constants

Business object constants provide default values to business objects that define the behavior for a
specific business object. Because these constants are attached to business objects, they are inherited,
just like properties. These constants have only one value, either the default value or the value you set.
Use the Business Modeler IDE to configure the business object constants in the custom template that you
define. You must deploy the custom template after making the changes.

You can configure the following as-built business object constants:

• IsMRONeutralType

Set this value to automatically configure which items are defined as neutral items.

• PhysicalPartTypeForCreate

Set this value to the physical part type created from a neutral item.

4. Installing and configuring As-Built Manager
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Identify neutral item types

As an administrator, you can set the IsMRONeutralType business object constant to true to configure
which items are defined as neutral items. Physical parts are only generated from neutral items.

Example:

Because IsMRONeutralType is false for the document business object, physical parts cannot be
generated from documents.

Business Object Constant Default value

IsMRONeutralType false for business object item

IsMRONeutralType true for business object part

Define physical part types

As an administrator, you can set the PhysicalPartTypeForCreate business object constant to represent
the physical part type that is generated from a neutral item.

Example:

You may want to create a new neutral item called Aircraft to represent an aircraft assembly and a
new physical part subtype called PhysicalAircraft to represent a physical aircraft assembly. If you
set the PhysicalPartTypeForCreate business object constant to PhysicalAircraft for the neutral
item Aircraft, the physical part is set to the type PhysicalAircraft when the as-built structure is
generated.

Business object constant Default value

PhysicalPartTypeForCreate Physical Part for business object item

Setting up as-built naming rules

As an administrator, you can create naming rules that define the data entry format for a business object
property. A naming rule consists of rule patterns and a counter. Before creating a naming rule, you
should be familiar with the pattern and counter formats. After you create a naming rule, you must
attach it to the business object property. You use the Business Modeler IDE to create the naming rules in
a custom template that you define. You must deploy the custom template after making the changes.

You can configure the following as-built naming rules:

• Automatically name occurrences

Identify neutral item types
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You can create a naming rule and attach it to the business object property occurrence_name for the
PSOccurrence business object. This rule automatically names occurrences when a Teamcenter user
chooses the Name Occurrence command. The naming rule can also be based on conditions.

Setting as-built lists of values (LOVs)

Setting as-built lists of values (LOVs)

As an administrator, you can set LOVs located in LOV folder in the Extensions view. LOVs are commonly
accessed by Teamcenter users from a menu at the end of a data entry box. After you create a list of
values, you must attach it to a property on a business object.You use the Business Modeler IDE to set
the LOVs in a custom template that you define. You must deploy the custom template after making the
changes.

You can configure the following as-built global LOVs:

• MRO Valid Deviation Status List

Set this list of values to configure the approved status list for deviations.

• MRO Deviation Authority List

Set this list of values to configure items used to authorize a deviation.

Define valid deviation status list

As an administrator, you can set the MRO Valid Deviation Status List LOV to the list of authorized status
values used for deviations. The deviated authority item must be at the approved status before a deviated
physical part can be installed. You can also configure LOVs.

Example:

You may want to include an additional status value such as Complete to validate a deviation.

LOV Default value Description

MRO Valid Deviation
Status List

TCM Released Released status

Define deviation authority list

As an administrator, you can set the MRO Deviation Authority List LOV to the list of item classes used
to authorize a deviation. You can also configure LOVs.

4. Installing and configuring As-Built Manager
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Example:

You may want to use a manufacturing document in addition to a deviation document to authorize
deviations.

LOV Default values Description

MRO Deviation Authority
List

DeviationDoc Deviation document

Cm0DevRqst Deviation request

ADc0DevRqst ADS deviation request

Service Event Service event

Configuring as-built workflows

As an administrator, you can configure the following workflows to support your as-built installation:

• Deviation workflow

The TCM Release Process workflow is provided with the Teamcenter Foundation feature. You can
configure this workflow or create your own to set up the process flow, reviewers, and business
validations required to route a deviation document for review and approval.

• Release as-built structure workflow

The Release AsBuilt Structure workflow is provided with the As-Built Manager feature. You can
configure this workflow or create your own to set up the process flow, reviewers, and business
validations required to release an as-built structure.

Configuring as-built workflows
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5. Creating neutral structures
What is the neutral structure?

The neutral structure is the item or part structure representing the asset-independent product definition
structure. It provides the basis for the physical structure that is generated from the neutral structure.
The neutral structure can be created with Structure Manager, Multi-Structure Manager, or imported from
your CAD system.

You can populate the neutral structure in a way that is useful for servicing your physical assets. After
populating the neutral structure, you can attach other items or datasets to these neutral structure
elements. For example, you can attach documents such as design documents, specifications, and service
bulletins.

As shown in the figure, the neutral structure tasks include:

• Creating the product structure with valid global alternate and substitute parts by a user such as a
design engineer.

• Creating and managing the part logistic data by a user such as a logistics engineer. Part logistics data
includes information such as serial and lot definitions and part usages.

• Creating the characteristic definitions by a user such as a logistics engineer.
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Creating product structures

Creating product structures

A user such as a design engineer creates the neutral product structure as well as any substitute or global
alternate parts. The following figure shows the product structure tasks.

A neutral structure is the product structure that you create with Structure Manager, Multi-Structure
Manager, or import from your CAD system. The product structure, is sometimes referred as the bill of
materials (BOM).

The following figure shows an example of a neutral structure for a bearing housing assembly.

Teamcenter allows you to view an indented listing of the assemblies and piece parts that comprise the
product structure; the indenting allows you to interpret the relationship between the assemblies and
piece parts. The physical structure is generated from the neutral structure.

You can specify global alternates of a component, one of which is designated as the preferred global
alternate. Global alternates may be used in any product and are not defined in the context of a particular
assembly. Global alternates do not require an authorized deviation when installed as a alternate physical
part in the as-maintained physical structure.

5. Creating neutral structures
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You can also specify substitute components, which are components that can be used interchangeably
within an occurrence, typically for manufacturing purposes. The preferred substitute is displayed in the
structure. In contrast with global alternates, substitutes may only be used in the context of a particular
assembly. Substitute parts do not require an authorized deviation when installed as a substitute physical
part in the as-maintained physical structure.

Creating neutral structures

You must create the neutral structure before you can generate the as-built physical structure. After you
create the structure, you modify it as necessary to reflect any changes to the product design.

Note:

Do not add physical parts to neutral structures in Structure Manager, Multi-Structure Manager, or
other BVR applications. Active Workspace cannot handle these types of structures and will produce
an error when trying to view them.

The following bill of material is an example of a neutral structure.

 BH001/A;1–BH Assembly (view)
 BH012/A;1–Blade Front

 BH013/A;1–Blade Rear

 BH014/A;1–Shaft

 BH015/A;1–Heat Shield

 BH016/A;1–B Housing

 BH017 /A;1–Cover Ring

 BH018 /A;1–Piston

 BH019/A;1–Journal Bearing X 2

 BH020A;1–Retaining Ring

Defining global alternates

A global alternate part is interchangeable with another part in all circumstances, regardless of where
the other part is used in the product structure. A global alternate applies to any revision of the part and
is independent of any views.

Creating neutral structures
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Note:

A global alternate part does not require an authorized deviation when installed as an alternate
physical part in the as-maintained physical structure.

Defining substitute parts

A substitute part is a part that is interchangeable with a particular component in an assembly.
Substitutes are often defined for manufacturing purposes, allowing use of the substitute if the preferred
part is unavailable, for example, due to a stock shortage.

Note:

A substitute part does not require an authorized deviation when installed as a substitute physical
part in the as-maintained physical structure.

5. Creating neutral structures
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Creating and managing part logistics data

Creating and managing part logistics data

Part logistics data is the logistical information defined for a neutral structure that is used by the
generated physical structure. Part logistics data includes information such as serial and lot definitions
and part usages. A user such as a logistics engineer populates the part logistic data before the as-
maintained physical structure is generated. The following figure shows the part logistic data tasks.

You can create and manage part logistics data by:

• Creating and managing part logistics forms attached to the neutral part.

• Overriding part logistics data in the context of a structure.

• Creating lot definitions for the neutral part used for the generated physical part.

• Creating serial number definitions for the neutral part used for the generated physical part.

• Defining occurrence information for the neutral part that is the part usage for the generated physical
part.

Managing part logistics forms

Part logistics form

The part logistics form contains some of the logistical information required for the neutral part. It must
be attached to the neutral part item using a References relation to generate a physical part.

Creating and managing part logistics data
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Note:

The part logistics form is automatically created and attached to a valid neutral item during neutral
item creation, if the AutoCreatePartLogisticsForm global constant is true. If this constant is
false, you must manually create and attach part logistics forms to the neutral parts that generate
physical parts.

Property Definition Default

Traceable Defines if a physical part will be generated from the neutral part. true

Serialized Defines if a physical part requires a serial number. false

Lot Defines if a physical part requires a lot number. false

Rotable Defines if a physical part can be easily repaired. false

Consumable Defines if a physical part can be used and discarded. false

Preserve
Quantity

Defines if one physical part with the quantity defined can
represent a multi-quantity neutral part.

false

Life Limited Defines if a physical part has a finite life. false

Asset Defines if a physical part can be tagged as an asset in Maximo
and other asset management systems.

Note:

This property is specific to an implementation that
includes an integration with IBM Maximo or another asset
management system.

false

5. Creating neutral structures
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Manually create a part logistics form

Note:

The part logistics form is automatically created and attached to a valid neutral item during neutral
item creation if the AutoCreatePartLogisticsForm global constant is true. If this constant is
false, you must manually create and attach part logistics forms to the neutral parts that generate
physical parts.

1. From the navigation pane, click My Teamcenter.

2. Locate the neutral part you want to create a part logistics form for.

3. Select the neutral part and choose File → New → Form.

4. Select Part Logistics Form from the list of forms.

5. Enter the following information for the new form.

Field name Definition Valid values

Name Name for the part logistics form. Alphanumeric (1–128
characters)

Description Description of the new form
(optional).

Alphanumeric (1–240
characters)

6. Click OK or Apply to create the new form. Click Cancel to exit without creating a new form.

The part logistics form is related to the neutral part with a References relation.

Note:

If you created the part logistics form without selecting the neutral part, you must relate the form
to the neutral part.

Controlling part definition in Maximo

The following Part Logistics Form property settings define how a physical part is identified in Maximo.

Manually create a part logistics form

As-Built Manager, Service Lifecycle Management 2412  5-7
© 2024 Siemens



Part Logistic Form property settings Part Status in Maximo

If isTraceable = 1, and if isSerialized = 1,
or
if isTraceable = 1, and isAsset = 1

Asset

If isTraceable = 1, and if isSerialized = 0, and if isAsset = 0 Spare Part

If isTraceable = 0 Part ignored in Maximo

Display part logistics form properties

To view the part logistics form properties using the Properties dialog box:

1. From the tree pane or Details table, select the part logistics form that you want to display.

2. Double-click the part logistics form associated to the neutral part.

The properties are displayed.

To view the part logistics form properties using the Viewer pane:

1. Select the part logistics form.

2. Click the Viewer tab.

The system displays the properties of the part logistics form in the Viewer pane.

Edit part logistics form properties

1. From the tree pane or Details table, select the part logistics form that you want to display.

2. Double-click the form to display the properties.

3. Click Checkout and Edit.

4. Modify the form property values, as required.

5. Click Save and Check-In or Save.

Edit part logistics data

You edit part logistics data in As-Built Manager by selecting the BOM line for the neutral part and
changing the cell data containing the part logistic value. You can also change part logistics data by
editing the part logistic form properties.

5. Creating neutral structures
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Using As-Built Manager, you can change the following part logistic values:

• Traceable

• Serialized

• Lot

• Rotable

• Consumable

• Preserve Quantity

• Life Limited

• Asset

1. Open the neutral structure in the As-Built Manager view by one of the following methods:

• From the navigation pane, click As-Built Manager, then from the As-Built Manager view, click
Open by Name .

• If you are viewing the structure in the Structure Manager view, right-click the structure parent
and choose Send to → As-Built Manager.

2. From the As-Built Manager view, select the BOM line containing the neutral part.

a. Double-click the cell containing the part logistics value.

b. Double-click the cell containing the part logistics value and type the new value.

Override part logistics data in context

You can override part logistics data in the context of the top-level or lower level neutral structures. For
example, you may override part logistic data to prevent the generation of a physical part in the context
of a specific neutral structure. To override the data, you set the neutral structure in context and override
the Traceable value from Y, which is true, to N, which is false for that neutral part in the structure.

The following part logistic values can be changed in the context of a neutral structure:

• Serialized

• Traceable

Override part logistics data in context
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• Consumable

• Rotable

• Preserve Quantity

• Life Limited

• Asset

Note:

The part logistic value Lot cannot be changed in the context of a neutral structure.

1. Open the neutral structure in the As-Built Manager view.

2. From the As-Built Manager view, select the bill of materials (BOM) line containing the top-level or
lower level parent.

3. Right-click and choose Toggle in-Context Mode to set the structure in context.

4. From the As-Built Manager view, select the BOM line containing the neutral part.

• To override the Traceable value, double-click the Traceable cell. Type the new value.

• To override the Serialized value, double-click the Serialized cell. Type the new value.

Note:

A serial number generator may never be assigned to a non-serial part even though it may
be marked serialized in context.

• To override the Consumable value, double-click the Consumable cell. Type the new value.

• To override the Rotable value, double-click the Rotable cell. Type the new value.

• To override the Preserve Quantity value, double-click the Preserve Quantity cell. Type the new
value.

• To override the Life Limited value, double-click the Life Limited cell. Type the new value.

• To override the Asset value, double-click the Asset cell. Type the new value.

5. Creating neutral structures
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Defining parts for tracking

To track physical parts, you must set the Traceable value to true to generate physical parts from neutral
parts. The value can be changed in the part logistics form.

Note:

Physical parts are not generated for traceable neutral parts that are children of nontraceable parts.

Create a lot definition

Create a lot to group physical parts that are associated in some way, for example, from a particular
manufacturer.

A lot contains a group of physical parts controlled by the same lot number. You can define the maximum
number of parts that a lot can contain. Based on this information, you can assign lot numbers to the
physical parts that make up the physical structure.

The lot usage value increments for every physical part assigned to that lot. When the lot usage is more
than the maximum number of parts available, the lot cannot be used further. You can also define an
expiration date for the lot.

Note:

Lots can be assigned only if the part logistics lot property is true for the neutral part.

1. Open the neutral structure in the As-Built Manager view.

2. From the As-Built Manager view, select the BOM line containing the neutral part.

3. Right-click and choose New → Lot.

The New Lot dialog box appears.

4. Enter the following information for the new lot.

Field name Definition Valid values

Lot Number Unique lot ID number Alphanumeric (1–32
characters)

Manufacturer's ID Lot manufacturer ID Alphanumeric (1–128
characters)

Lot Size Number of items in the lot Integer

Defining parts for tracking
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Field name Definition Valid values

Note:

If you set the lot size value to
0 (zero) or leave it blank, the
lot size is set to infinite.

Expiration Date Lot expiration date Click the Set Date  button
and select a date from the
calendar.

5. Click OK to create the lot under the New Stuff folder. Alternatively, click Cancel to exit.

 Newstuff
 BH020–01/RRLot01  Lot

Create a serial number generator

Serialized physical parts have a unique serial number for a given Manufacturer's ID. For example, you
may have two engines with the same serial number but are manufactured by different companies.

You can type the serial number for the physical part or you can optionally create a serial number
generator. The serial number generator is defined for the neutral parts and automatically assigns the
serial numbers to the newly created physical parts in the as-maintained physical structure.

Note:

Serial numbers can be assigned only if the part logistics serialized property is true for the neutral
part.

1. Open the neutral structure in the As-Built Manager view.

2. From the As-Built Manager view, select the BOM line containing the neutral part.

3. Right-click and choose New → Serial Number Generator.

The New Serial Number Generator dialog box appears.

4. Enter the following information.

5. Creating neutral structures
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Field name Definition Valid values

Series Prefix Prefix for the generated serial
number.

Alphanumeric (1–32
characters)

Series Suffix Suffix for the generated serial
number.

Alphanumeric (1–32
characters)

Series Current Starting numeric value for the
generated serial number.

Integer

Series Maximum Maximum numeric value for the
generated serial number.

Integer

Increment Increment between the generated
serial numbers.

Integer

Series Characters Number of characters for the
generated serial number. Numeric
values are preceded by zeros to
meet the character limit.

Integer

5. Click OK to create the serial number generator under the New Stuff folder. Alternatively, click
Cancel to exit.

 Newstuff
 BH014–nn-Shaft  Serial number generator

Set or unset generic serial number generator

Set a generic serial number generator

1. Search for an existing serial number generator using the global search.

2. Click Select a Search .

3. Select the MRO Serial Number Generator search from the list and click OK.

Set or unset generic serial number generator
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4. Add search criteria in the MRO Serial Number Generator dialog box.

5. Click Execute Search .

6. Right-click the desired serial number generator and select Set As Generic Serial Number
Generator.

If a generic serial number generator is already set, it is now replaced.

5. Creating neutral structures
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Unset a generic serial number generator

1. Search for an existing serial number generator.

2. Right-click any serial number generator and select Unset Generic Serial Number Generator.

Note:

Selecting a generic serial number generator that is already set makes the Unset As Generic
Serial Number Generator option available.

Define part usage

The usage of a physical part in an as-maintained structure defines the position that the physical part
occupies within the structure. You define the usage of a physical part by:

• Entering a value for the neutral structure occurrence property used to define the physical part usage.
This can be defined by the UsageAttributeName global constant. The default property is set to
occurrence_name.

• Defining a naming rule to auto name the occurrences. The occurrence_name property can only be
used if a naming rule for occurrences has been created.

1. Open the neutral structure in the As-Built Manager view.

2. From the As-Built Manager view, select the BOM line containing the neutral part.

Define part usage
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3. • If you use an occurrence naming rule:

Right-click and choose Name Occurrence.

• If you do not use an occurrence naming rule:

Double-click the Occurrence Name cell and type the usage value.

Note:

The occurrence_name property is the default property used to set the usage for
the physical part. The ref_designator or seq_no properties can be used only if the
UsageAttributeName global constant is set to one of those values.

5. Creating neutral structures
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6. Generating as-built physical structures
Generating as-built physical structures

A user, such as a production planner, generates the as-built physical structures.

A physical structure refers to an asset's product structure information. Each asset that your organization
manufactures or owns can be represented by one physical structure. An as-built physical structure
evolves as the asset changes over time. This physical structure contains other traceable physical parts
that represent the sub-assemblies and components that make up the asset. Each physical part within the
structure links back to the neutral part that provides its engineering and logistics definition. Part logistics
information includes if a part is traceable and should be included in the physical structure as well as if
the part should have a recorded serial number, lot number, or both.

The following figure shows an example of a physical structure for a bearing housing assembly. In this
example, all the physical parts are serialized.
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The as-built physical structures are precise structures comprising physical part revisions. The physical
parts are related back to the neutral parts with a PhysicalRealization relation.

The following tasks are required steps before generating an as-built physical structure:

• Create the neutral structure.

• Populate the part logistics information assigned to the neutral parts.

A user such as a production planner can:

• Generate an as-built physical structure top down from the top-level neutral structure.

• Generate an as-built physical structure bottom up by installing physical parts at various levels in the
structure.

• Duplicate an as-built physical structure.

6. Generating as-built physical structures
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• Generate an as-maintained physical structure from an as-built physical structure if you have
purchased and have a license for both the As-Built Manager and the Service Manager (as-maintained)
applications.

• Generate an as-built physical structure from an as-maintained physical structure if you have
purchased and have a license for both the As-Built Manager and the Service Manager (as-maintained)
applications.

Note:

The sequence of the parts in the original structure is maintained in the new structure.

Structure alignment maintained from old structure to new
structure

There are a number of ways that you generate or duplicate a structure. The order of the parts in the
new structure is aligned with the order of the parts in the old structure. The Find No. is the value that
controls the order.

Methods to generate or duplicate a structure:

• Generate an as-built structure from a neutral structure

• Generate an as-maintained structure from a neutral structure

• Generate an as-built structure from an as-maintained structure

• Generate an as-maintained structure from an as-built structure

Structure alignment maintained from old structure to new structure
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• Duplicate an as-built structure

• Duplicate an as-maintained structure

The example shows an as-built structure and its duplicate. The order of the physical parts is maintained.

Quantity preserved from neutral structure to new structure

When you create an as-built structure from a neutral structure, you can control the display of parts that
have a quantity greater than one, in the new structure. This becomes especially important when you
work on very large structures and on structures imported into Teamcenter from a CAD system.

For example, a wheel assembly includes multiple nuts. When the structure is imported, each nut is
represented by a single line in the neutral structure. The existence of multiple lines for one part clutters
the structure, making it difficult to find specific parts throughout the structure.

Using the property Preserve Quantity, you control the way these occurrences are displayed when you
create a physical structure.

• If Preserve Quantity is set to True (1), the parts are displayed in the physical structure as one packed
node (2).

6. Generating as-built physical structures
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Note:

If Preserve Quantity is set to True on a parent node, all children nodes with multiple
occurrences are also packed because they inherit the value from the parent.

An as-built structure generated from a neutral structure with Preserve Quantity set to True on the
030979/--A-Nut part:

• If Preserve Quantity is set to False, the parts are displayed with multiple nodes, one node for each
part occurrence.

Generate a partial or entire as-built structure (top down)

1. Open the neutral structure in the As-Built Manager view by one of the following methods:

• From the navigation pane, click As-Built Manager. Click Open By Name  to open the
structure.

• If you are viewing the structure in the Structure Manager view, right-click the structure parent
and choose Send to → As-Built Manager.

2. Select the top-level part from the neutral structure.

Generate a partial or entire as-built structure (top down)
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3. Right-click the top-level part and select Generate As-Built Structure or click the Generate As-Built
Structure button  on the main toolbar at the top of the As-Built Manager pane.

Teamcenter displays the Generate As-Built Structure dialog box

4. Enter the following information:

Field name Definition Valid values

Serial Number Serial number for the generated
physical part.

This field is optional or unavailable
in the following situations:

• Optional if a serial number
generator is defined for the
neutral part.

• Unavailable if the Serialized
property is set to false in
the part logistics form that is
attached to the neutral part.

Alphanumeric (1–128
characters)

Lot Number Lot number for the generated
physical part.

You must first create the lot for the
neutral part.

The Lot list is unavailable if the Lot
property is set to false in the part
logistics form that is attached to
the neutral part.

Alphanumeric (1–128
characters)

Manufacturer's
ID

Manufacturer of the physical part.

The Manufacturer's ID box is
automatically populated if you
entered a lot number.

Alphanumeric (1–128
characters)

Structure
Context Name

The name of the structure context
used to store the neutral product
configuration information.

The structure context name is
automatically named with the part
number of the neutral part. If
the physical part is serialized and
you are not using a serial number
generator, the structure context

Alphanumeric (1–128
characters)

6. Generating as-built physical structures
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Field name Definition Valid values

name is automatically named
using part number/serial number.
You can use these values or type in
a new value.

Manufacturing
Date

Manufacturing date for physical
structure. The manufacturing date
must be before the installation
date.

Click the Set Date  button
and select a date from the
calendar.

Installation
Time

Installation time and date for
physical structure. The installation
time and date must be after the
manufacturing date.

Click the Set Date  button
and select a date from the
calendar.

Number of
Levels

Number of levels to be generated
for the physical structure. If you
want to generate physical parts for
the entire structure, type All in the
Number of Levels box.

Integer or All

Quantity Number of physical parts to
generate for the top-level part.

If it is a lot part, the quantity, if a
whole number, is deducted from
the lot. If the quantity is not a
whole number, it is not deducted
from the lot.

To set the quantity, the Preserve
Quantity property for the neutral
part must be set to true.

Number

5. If you define the serial number generator in the neutral part, click True to enable it. The serial
number generator automatically creates serial numbers for the entire as-built physical structure. If
you have defined a generic serial number generator, then the serial number will be created for the
serialized parts for which serial number generator is not defined, and you will be informed that the
generic serial number generator is being used.

6. Click OK to generate the as-built physical structure or click Cancel to exit.

The physical structure is generated from the neutral structure.

 BH001–nn/InTestnn–A
BH012-nn/A

BH013-nn/A

Generate a partial or entire as-built structure (top down)
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BH014–nn/SHnn–001–A

BH015-nn/A

BH016-nn/A

BH017-nn/A

BH018-nn/A

BH019–nn/JBnn–001–A

BH019–nn/JBnn–002–A

BH020–nn/A

Create configured as-built structure using variants

Configure neutral structures

Service Lifecycle Management supports the creation of physical structures based on specific optional
product features. You use the Teamcenter Product Configurator to define various options.

Note:

To learn more about the Siemens Digital Industries Software Product Configurator, refer to the
documentation for the Product Configurator.

You create a configured neutral structure, or service bill of materials (sBOM), by applying variants before
you create as-built and as-maintained physical structures and service plans.

Once the physical structure is created, there is no association to the configured sBOM. This means that
any subsequent changes to the sBOM configuration are not reflected in the physical structure.

Create configured as-built structure

You create a configured as-built structure by first configuring variants on the neutral structure, or service
bill of materials (sBOM).

1. Open a neutral structure that contains variants in As-Built Manager.

6. Generating as-built physical structures
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2. Apply variants by choosing Tools → Variants → Configure Variants.

The Variant Configuration View (Structure Manager) page is displayed. It contains the variants
that are included in the sBOM.

3. Select the variants you want to apply, such as engine size, color, or model.

Create configured as-built structure
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4. Click the arrow  to apply the current configuration to the associated structure.

5. To update the sBOM to reflect the chosen variants, choose View and click Show Unconfigured
Variants to deselect it.

6. Generating as-built physical structures
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6. To create the configured as-built structure, right click the root node of the sBOM, and choose
Generate As-Built Structure.

7. Enter the required information in the Generate As-Built Structure dialog box and click OK.

8. (Optional) Right-click the root node and choose Expand Below to see all of the parts in the
configured as-built structure.

Note:

The as-built structure configuration matches the configuration of the configured sBOM.

Apply saved variant rules to the sBOM

You can also create a configured sBOM by applying saved variant rules.

1. Highlight the root node of the sBOM and choose Tools → Variants → Apply Saved Variant Rules.

The Search and Load Variant Rule(s) dialog box is displayed.

2. Enter search criteria and click Search.

Create configured as-built structure
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3. Choose a saved variant rule and click OK.

The sBOM is configured according to the saved variant rule.

4. To create the configured as-built structure, highlight the root node of the sBOM and right-click, and
choose Generate As-Built Structure.

5. Enter the required information in the Generate As-Built Structure dialog box and click OK.

6. (Optional) Right-click the root node and choose Expand Below to see all of the parts in the
configured as-built structure.

Note:

The as-built structure configuration matches the configuration of the configured sBOM.

Build an as-built physical structure (bottom up)

You can build an as-built physical structure by installing existing physical parts in the structure.

View the neutral structure details

You can view the neutral structure and the structure context information from which the physical
structure is realized.

1. From the navigation pane, click As-Built Manager.

2. Click Open by Name  to open the physical structure or part.

3. Select the physical structure parent part.

4. Right-click the physical part and choose Open with → Details.

The Details pane appears at the bottom and displays the neutral structure and context information
used to generate the physical structure.

6. Generating as-built physical structures
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5. In the Details pane, select the neutral structure.

6. Right-click and choose View Properties.

The properties of the neutral structure from which the physical structure is realized, are displayed.

7. Click Cancel to close the properties window.

8. In the Details pane, select the structure context.

9. Right-click and choose Send to → Multi-Structure Manager.

The neutral structure is displayed in Multi-Structure Manager. Multi-Structure Manager displays the
configured variants and options that were used when generating the physical structure.

Duplicate an as-built structure

You can duplicate an as-built physical structure to create a copy of an existing physical structure. The
copied physical structure contains the installed alternate, substitute, deviated, and extra to design parts
from the original structure.

When you duplicate an as-built physical structure, the following occurs:

Note:

The sequence of the parts in the original structure is maintained in the new duplicated structure.

• The duplicate physical structure uses the same structure context as the original structure.

• The duplicate physical structure is validated for a unique serial number and manufacturing ID, if those
values are entered.

• The child parts of the duplicate physical structure inherit the manufacturing ID from the parent.

• The Part Used column for all the child parts of the duplicate physical structure is set to Missing except
in the following cases where the Part Used is set to Preferred:

• Parts that do not require a serial or lot number.

• Serialized parts that have a serial number generator.

• The deviated parts in the original structure are:

• Copied to the duplicate physical structure, if the ReUseAuthorizedDeviation global constant is set
to True, to reuse the same deviation.

Duplicate an as-built structure
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• Ignored and the preferred parts are used in the duplicate physical structure, if the
ReUseAuthorizedDeviation global constant is set to False.

1. From the navigation pane, click As-Built Manager.

2. Click Open by Name  to open the as-built physical structure or physical part that you want to
copy.

3. Select the top-level part from the physical structure if you want to duplicate the entire structure or
select the physical part if you want to copy only the physical part.

4. Choose File → Duplicate As-Built Structure or right-click the physical part and choose Duplicate
As-Built Structure.

5. In the Duplicate As-Built Structure dialog box, enter the following information.

Field name Definition Valid values

Serial Number Serial number for the copied physical
structure or part.

This field is unavailable if the original
physical structure or part did not
require a serial number.

Alphanumeric (1–128 characters)

Lot Lot number for the copied physical
structure or part.

This field is unavailable if the original
physical structure or part did not
require a lot number.

Alphanumeric (1–128 characters)

Manufacturer's ID Manufacturer of the physical part.

The Manufacturer's ID box is
automatically populated if you
entered a lot number.

Alphanumeric (1–128 characters)

Manufacturing
Date

Manufacturing date for physical
structure. The manufacturing date
must be before the installation date.

Click the Set Date  button and
select a date from the calendar.

Installation Time Installation date for physical structure.
The installation date must be after the
manufacturing date.

Click the Set Date  button and
select a date from the calendar.

Number of Levels Number of levels to be generated for
the physical structure. If you want to
generate physical parts for the entire

Integer or All

6. Generating as-built physical structures
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Field name Definition Valid values

structure, type All in the Number of
Levels box.

6. If you have defined a serial number generator for the neutral part, select the Use Serial Number
Generators check box to enable it.

The serial number generator automatically creates serial numbers for all the parts within the
as-built or as-maintained physical structure that have defined serial number generators. If you have
defined a generic serial number generator, then the serial number is created for the serialized parts
for which the serial number generator is not defined, and you are informed that generic serial
number generator is being used.

7. Click OK to duplicate the physical structure or part.

Generate an as-maintained structure from an as-built structure

If you have purchased and have a license for the As-Maintained Management application, you can
generate an as-maintained structure from an as-built structure. The as-built structure must be at a
Released state.

Note:

The sequence of the parts in the as-built structure is maintained in the new as-maintained
structure.

1. From the navigation pane, click As-Built Manager.

2. Click Open by Name  to open the released as-built physical structure.

3. Select the top-level part from the as-built physical structure.

4. Right-click and choose Generate As-Maintained Structure.

Teamcenter displays the Generate As-Maintained Structure dialog box.

5. Click Set Date  and select a date from the calendar when the as-maintained structure was
created.

6. Choose the location where the physical parts are stored.

7. Choose the disposition of the physical part.

Generate an as-maintained structure from an as-built structure
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Note:

If the Disposition_Propagate_To_Child preference is set to true, the disposition is also
applied to the children parts of the structure.

8. Type the number of levels you want to generate for the physical structure in the Number of Levels
box. If you want to generate physical parts for the entire structure, type All.

9. Click OK to generate the as-maintained physical structure or click Cancel to exit.

Generate an as-built structure from an as-maintained structure

If you have purchased and have a license for the As-Maintained Management application, you can
generate an as-built structure from an as-maintained structure. The as-maintained structure must be at a
Released state.

Note:

The sequence of the parts in the as-maintained structure is maintained in the new as-built
structure.

1. From the navigation pane, click Service Manager.

2. Click Open by Name  to open the released as-maintained physical structure.

3. Choose Window → Show View → Service Editor to open the Service Editor view.

4. From the Service Editor view, select the top-level part from the as-maintained physical structure.

5. Right-click and choose Generate As-Built Structure.

Teamcenter displays the Generate As-Built Structure dialog box.

6. Click Set Date  to set the rebuild date.

7. Type the number of levels you want to generate for the physical structure in the Number of Levels
box. If you want to generate physical parts for the entire structure, type All.

8. Click OK to generate the as-built physical structure or click Cancel to exit.

6. Generating as-built physical structures
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7. Setting up as-built physical structures
Setting up as-built physical structures

A user such as production planner manages the as-built physical structure according to organization
needs and requirements as shown in the following figure.

You can set up and manipulate physical structures by:

• Updating physical part properties.

• Resolving missing parts by adding serial number, lot, or manufacturing information to the physical
part.

• Assigning lot numbers to physical parts.

• Installing and uninstalling physical parts from an as-built structure.

• Renaming as-built physical parts.

• Replacing physical parts in an as-built structure.

• Rebasing physical parts in an as-built structure.

• Deleting physical parts.
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• Implementing deviations.

• Releasing as-built physical structures.

• Rebuilding as-built physical structures.

• Updating as-built physical structures using Excel Live.

• Viewing untraced structures.

Resolving missing parts

After you generate the as-built structure, a Missing status for the Parts Used column occurs if there
is missing information for the child physical parts. Missing information may include a missing serial
number, lot number or manufacturer id for the physical part. When you enter the missing information,
the Parts Used column is automatically changed to Preferred.

A physical part has the Parts Used column set to Missing for the following conditions:

• The lot number is missing for a lot physical part.

• The serial number is missing for a serialized physical part.

• The manufacturer ID is missing for a nonserialized, nonlot part.

• The lot number or serial number is missing for a serialized lot part.

• The child physical part has been uninstalled from the physical structure.

Update physical part properties

You can update a physical part using either As-Built Manager or My Teamcenter. The physical part
properties that can be updated are shown in the following table.

Editable property Property description Editable in As-Built
Manager

Editable in My
Teamcenter

Serial number Serial number of the
physical part.

Yes Yes

Manufacturer's ID Manufacturer ID of the
physical part.

Yes Yes

Lot number Lot number of the
physical part.

Yes Yes

7. Setting up as-built physical structures
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Editable property Property description Editable in As-Built
Manager

Editable in My
Teamcenter

Manufacturing date The date the physical
part was manufactured.

Yes Yes

Installation date The date the physical
part was installed.

Yes Yes

Physical Part UID Unique UID for the
physical part. Once the
UID is assigned, it
cannot be edited again.

Yes No

From My Teamcenter:

1. Search for the physical part.

2. Right-click the physical part in the results list and choose Edit Properties.

3. From the Checkout dialog box, click Yes to check out the physical part.

4. From the Edit Properties dialog box, modify the properties.

5. To save and check in the modified properties, click Save and Check-In.

From As-Built Manager:

1. From the navigation pane, click As-Built Manager.

2. Choose Window → Show View → As-Built Manager to open the As-Built Manager view.

3. From the As-Built Manager view, click Open By Name  to open the physical structure or part.

4. Select the BOM line containing the physical part.

5. Double-click the property cell and type the new value.

Assign a serial number

1. From the navigation pane, click As-Built Manager.

2. Choose Window → Show View → As-Built Manager to open the As-Built Manager view.

3. From the As-Built Manager view, click Open by Name  to open the physical structure or part.

Assign a serial number
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4. Select the BOM line containing the serialized physical part with the missing serial number.

5. To add a serial number, double-click the Serial Number cell and type the serial number.

The serial property for the serialized physical part is assigned and the Part Used column is set to
Preferred.

Assign a manufacturer ID

1. From the navigation pane, click As-Built Manager.

2. Choose Window → Show View → As-Built Manager to open the As-Built Manager view.

3. From the As-Built Manager view, click Open by Name  to open the physical structure or part.
Select the physical part.

4. To add a manufacturer ID, double-click the Manufacturer's ID cell and type the manufacturer ID.

The manufacturer ID property is set for the physical part and the Part Used column is set to
Preferred.

Assign a lot number

In As-Built Manager, you can assign a lot number to a physical part or change a physical part lot number.

When you assign a lot number to a physical part, the physical part's manufacturer changes to the lot
manufacturer.

After you assign a lot number to a physical part, the lot usage property of the specified lot is also
updated. Lot usage is a property that tracks the number of physical parts associated to a specified lot.

Note:

You must create a lot definition for the neutral part before you can assign a lot number to a
physical part.

1. From the navigation pane, click As-Built Manager

2. Choose Window → Show View → As-Built Manager to open the As-Built Manager view.

3. From the As-Built Manager view, click Open by Name  to open the physical structure or part.

4. Select the BOM line containing the lot physical part with the missing lot number. Right-click and
choose Assign Lot.

7. Setting up as-built physical structures
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5. In the Assign Lot dialog box, select a lot number from the Lot list.

6. In the Quantity box, type the number of physical parts to assign to the lot.

If the part is a Preserve Quantity part, the quantity is checked against the expected quantity (the
quantity from the neutral structure and the nonmissing parts from the occurrence).

• If the quantity is the same as the expected quantity, Teamcenter assigns the lot and marks the
physical part as Preferred.

If the quantity is a whole number, it is deducted from the lot. If the quantity is not a whole
number, it is not deducted from the lot.

• If the quantity is less than expected, a missing part is generated with the remaining quantity.

• If the quantity is greater than expected, Teamcenter displays an error.

• If the identified (nonmissing) parts are installed under the selected missing part and the quantity
is not the expected quantity, Teamcenter displays an error.

• If you are assigning a new lot to the selected physical part that already has a lot assigned, the
quantity is not changed, only the lot information.

7. Click OK.

The lot property for the physical part contains the assigned lot and the Part Used column is set to
Preferred.

Rename a physical part

You can rename an existing physical part to change the following properties:

• Part number

• Serial number

Note:

You cannot rename a physical part that is released.

When you rename a physical part, the following occurs:

• The new serial number is checked for uniqueness.

Rename a physical part

As-Built Manager, Service Lifecycle Management 2412  7-5
© 2024 Siemens



• If a physical part is renamed using a different part number, the system does not check the existence of
a neutral item with the new part number.

• The physical realization relation remains intact between the original physical part (before renaming)
and the original neutral part.

Note:

If you want to relate the physical part or structure to a different neutral configuration, you need
to rebase the physical part.

1. From the navigation pane, click As-Built Manager.

2. Click Open by Name  to open the physical part you want to rename.

3. Choose Tools → Rename Physical Part.

The Rename Physical Part dialog box appears.

4. Enter the following information.

Field name Definition Valid values

New Part
Number

New part number for the renamed
physical part.

Alphanumeric (1–128
characters)

New Serial
Number

New serial number for the
renamed physical part.

This field is unavailable if the part
did not require a serial number.

Alphanumeric (1–128
characters)

5. Click OK to rename the physical part.

Install a physical part

You can install an existing physical part in a physical location at a specified usage into an as-built
physical structure.

Note:

• If the installed physical part is not a valid preferred, alternate, or substitute, you must set up a
deviation to install the deviated part.

• You cannot install a physical part under a released physical part.
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1. From the navigation pane, click As-Built Manager.

2. From the As-Built Manager view, click Open By Name  to open the physical structure where
you want to install the physical part.

3. Choose one of the following methods to identify the physical part you want to install:

a. Copy the physical part you want to install.

A. Click Open By Name  to open the physical part you want to install.

B. Right-click the physical part and choose Copy.

C. Select the physical structure where you want to install the physical part.

D. Right-click the parent and choose Install Physical Part or click the Install Physical Part
button  on the main toolbar at the top of the As-Built Manager pane.

The Install Physical Part dialog box appears.

The To Be Installed Physical Part field is set to the copied physical part.

E. Select the usage name to set the usage for the installed physical part. If the physical part
is an addition to the physical structure, select Extra to Design as the usage.

b. Search for the physical part you want to install.

A. Select the physical structure where you want to install the physical part.

B. Right-click the parent and choose Install Physical Part or click the Install Physical Part
button  on the main toolbar at the top of the As-Built Manager pane.

The Install Physical Part dialog box appears.

C. Select the usage name to set the usage for the installed physical part. If the physical part
is an addition to the physical structure, select Extra to Design as the usage.

D. Perform the following steps to search for the physical part to be installed:

i. Click  and select Add.

The Installable Physical Parts dialog box appears.

Install a physical part
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ii. Click the Search tab and enter the following information you want to use as filters
for searching.

Field name Definition Valid values

Part Number Part number of the
physical part.

Alphanumeric (1–128
characters)

Serialized Value of the serialized
property.
Click true to search for
serialized parts.

Boolean

Serial Number After Value of the serial
number to filter physical
parts with serial
numbers greater than
the value entered.

Alphanumeric (1–128
characters)

Serial Number Before Value of the serial
number to filter physical
parts with serial
numbers less than the
value entered.

Alphanumeric (1–128
characters)

Lot Value of the lot
property.

Click true to search for
lot parts.

Boolean

Lot number Lot number of the
physical part.

Alphanumeric (1–32
characters)

Manufacturer's ID Manufacturer of the
physical part.

Alphanumeric (1–128
characters)

Manufactured After Manufacturing date
used to filter
physical parts with
manufacturing dates
greater than the date
entered.

Click the Set Date 
button and select a date
from the calendar.

Manufactured Before Manufacturing date
used to filter
physical parts with
manufacturing dates
before the date entered.

Click the Set Date 
button and select a date
from the calendar.

iii. Click Find.
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The results display the valid preferred, alternate, substitute, and deviated physical
parts that can be installed.

iv. Select the physical part from the results and click OK.

The Install Physical Part dialog reappears with the To be Installed Physical Part
field set to the selected physical part.

4. Click the Set Date  button to set the installation date when the installation occurred.

5. If the Usage Name is set to Extra to Design in the Extra to Design Usage Name box, type the
usage name for the installed physical part.

6. Click OK to install the physical part.

If the installed Preferred part is a Preserve Quantity part, the quantity is checked against the
neutral structure.

Install a physical part
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a. If the quantities match, the physical part is installed in the structure.

b. If the quantity is greater than allowed, the installation is prevented.

c. If the quantity is less than allowed, the installation is completed, and a missing part is
generated with the remaining quantity.

The Part Used column for the physical part is set to one of the following values after installing a
physical part:

a. Preferred

If the newly installed physical part is a valid preferred physical part for the selected usage, the
Part Used column is set to Preferred.

b. Substitute

If the newly installed physical part is a valid substitute, the Part Used column is set to
Substitute.

c. Alternate

If the newly installed physical part is a valid alternate, the Part Used column is set to
Alternate.

d. Deviated

If the newly installed physical part is an approved deviation from the design and is not a valid
substitute or alternate for selected usage, the Part Used column is set to Deviated.

e. Extra to Design

If the newly installed physical part is an approved deviation and does not exist in the design
structure, the Part Used column is set to Extra to Design.

Uninstall a physical part

You can uninstall a child physical part from a parent physical part in the as-built structure.

1. From the navigation pane, click As-Built Manager.

2. Choose Window → Show View → As-Built Manager to open the As-Built Manager view.

3. From the As-Built Manager view, click Open by Name  to open the physical structure where
you want to uninstall the physical part.

7. Setting up as-built physical structures
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4. Select the child physical part. Right-click and choose Uninstall Physical Part.

A dialog box is displayed asking you if you are sure you want to uninstall the physical part.

5. Click Yes to uninstall the physical part.

The physical part is uninstalled from the structure and Part Used column is set to Missing.

If there is more than one missing part, then a single missing part is created with the total allowed
remaining quantity, and the other missing parts are deleted.

As-Built Structure Part Used
 BH001–nn/MTrucknn–A Preferred

 BH012-nn/A Preferred

 BH013-nn/A Preferred

 BH014–nn/SHnn–001–A Preferred

 BH020–nn/A Missing

Replace a physical part

You can replace an existing or missing physical part with a different physical part in an as-built structure.
When you replace a physical part, the following occurs:

• The original physical part is removed from the structure and replaced with the new physical part.

• The installation time on the replacement physical part is updated with the date the physical part was
replaced.

• The uninstall time on the original physical part is updated with the date the physical part was
replaced.

Note:

If the replacement part is not a valid preferred, substitute, or alternate part, you must set up an
authorized deviation.

1. From the navigation pane, click As-Built Manager.

2. From the As-Built Manager view, click Open by Name  to open the physical structure where
you want to replace the physical part.

Replace a physical part
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3. Choose one of the following methods to identify the physical part you want to use as the
replacement:

a. Copy the physical part you want to use as the replacement.

A. Click Open by Name  to open the replacement physical part.

B. Right-click the replacement physical part and choose Copy.

C. Right-click the physical part you want to replace and choose Replace Physical Part or
click the Replace Physical Part icon  on the main toolbar at the top of the As-Built
Manager pane.

The Replace Physical Part dialog box appears.

The To Be Installed Physical Part field is set to the copied physical part.

b. Search for the physical part you want to use as the replacement.

A. Right-click the physical part you want to replace and choose Replace Physical Part or
click the Replace Physical Part icon  on the main toolbar at the top of the As-Built
Manager pane.

The Replace Physical Part dialog box appears.

B. Perform the following steps to search for the physical part to be installed:

i. Click  and select Add.

The Installable Physical Parts dialog box appears.

ii. Click the Search tab and enter the following information you want to use as filters
for searching.

Field name Definition Valid values

Part Number Part number of the
physical part.

Alphanumeric (1–128
characters)

Serialized Value of the serialized
property.
Click true to search for
serialized parts.

Boolean

Serial Number After Value of the serial
number to filter physical

Alphanumeric (1–128
characters)
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Field name Definition Valid values

parts with serial
numbers greater than
the value entered.

Serial Number Before Value of the serial
number to filter physical
parts with serial
numbers less than the
value entered.

Alphanumeric (1–128
characters)

Lot Value of the lot
property.
Click true to search for
lot parts.

Boolean

Lot number Lot number of the
physical part.

Alphanumeric (1–32
characters)

Manufacturer's ID Manufacturer of the
physical part.

Alphanumeric (1–128
characters)

Manufactured After Manufacturing date
used to filter
physical parts with
manufacturing dates
greater than the date
entered.

Click the Set Date 
button and select a date
from the calendar.

Manufactured Before Manufacturing date
used to filter
physical parts with
manufacturing dates
before the date entered.

Click the Set Date 
button and select a date
from the calendar

iii. Click Find.

The results display the valid preferred, alternate, substitute, and deviated physical
parts that can be used to replace the physical part.

Replace a physical part
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iv. Select the physical part from the results and click OK.

The Replace Physical Part dialog box reappears with the To be Installed Physical
Part field set to the selected physical part.

7. Setting up as-built physical structures
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4. Click the Set Date  button to set the replace date when the replacement occurred.

5. Click OK to replace the physical part.

If the installed Preferred part is a Preserve Quantity part, the quantity is checked against the
neutral structure.

a. If the quantities match, the original physical part is replaced.

b. If the quantity is greater than allowed, the replacement is prevented.

c. If the quantity is less than allowed, the replacement is completed, any existing missing parts
are deleted, and a missing part is generated with the remaining quantity.

Rebasing physical parts

Rebasing a physical part relates the as-built structure to a different configuration of a neutral structure.
The new rebased structure uses the new configuration for its structure context.

Note:

The physical part must have a Released status before you can rebase it.

The following apply to usages in the rebased physical configuration:

• If the component exists in the rebased neutral structure, the rebased physical part is assigned the
same usage as specified in the neutral structure.

Rebasing physical parts
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• If the corresponding usage of a component is not present in the rebased neutral structure. the usage
of the rebased physical part is set to extra to design and requires no deviation authorization.

• If the component and usage is new in the rebased neutral structure, the usage of the physical part is
set to missing.

Example:

You may want to rebase a physical structure to the same neutral structure but with a different
variant.

The original physical structure was generated from the bearing housing assembly neutral structure
that contained the regular bearing housing. It was rebased to the bearing housing assembly
neutral structure with the heavy duty bearing housing. As the following figure shows, because
the rebased neutral structure contains the heavy duty bearing housing, the physical structure now
contains a missing part for the heavy duty bearing housing and the regular bearing housing is
installed as extra to design.
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Rebase a physical part

1. From the navigation pane, click As-Built Manager.

2. Choose Window → Show View → As-Built Manager to open the As-Built Manager view.

3. From the As-Built Manager view, click Open by Name  to open the neutral structure or part to
be used to rebase the physical structure or part.

4. Click Open by Name  to open the released physical structure or part to be rebased.

5. Click Show/Hide lower Structure Panel  located at the top of the application to display the
neutral and physical parts or structures using split structure panes.

6. Select the neutral part. If you are rebasing a physical structure to a different neutral structure,
select the neutral structure parent part.

7. Select the released physical part. If you are rebasing a physical structure, select the physical
structure parent part.

8. Choose Tools → Rebase Physical Part.

The Rebase Physical Part dialog box appears.

9. Click the Set Date  button to set the rebase date when the rebase occurred.

10. In the Structure Context Name box, type the name of the structure context used to store the
neutral product configuration information or use the name that is automatically generated.

The structure context name is automatically created using the part number of the rebased neutral
part. If the physical part has a serial number, the structure context name is automatically named as
part number/serial number.

11. Click OK to rebase the physical part.

Teamcenter checks the quantities of the parts installed in the rebased structure.

• If the quantity is over the allowed limit, the part is changed to a Extra to Design part.

• If the quantity is under the allowed limit, the part is shown as installed in the correct position,
but a new missing part is generated with the remaining quantity.

Rebase a physical part
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Delete a physical part

You can delete a physical part if it has no child physical parts. To delete a physical part with child physical
parts, you must delete the last child physical part first and work your way up to the parent physical part.

Note:

You can delete a physical part only from My Teamcenter.

1. In My Teamcenter, select the physical part to delete.

2. Choose Edit → Delete.

Implementing deviations

Implementing deviations

Deviations occur when you install a physical part that is not a preferred, alternate, or substitute physical
part into an as-built structure. An authorized deviation can be used only once. If you uninstall and
reinstall a deviated physical part, a new authorization must be created.

The workflow to add a deviated physical part to your as-built structure is as follows:

1. Create the deviation authority item class for the physical part.

By default, the item classes that can be used as a deviation authority item are:

• Deviation document
• Deviation request
• Service event
• Aerospace and Defense deviation request

A deviation authority item class authorizes the installation of a physical part that is a deviation from
the design structure. The MRO Deviation Authority List LOV determines the list of item classes
that can be used to authorize a deviation.

2. Set up the deviation to specify the authorized deviation item class used for the deviated physical
part. The authorized deviation item must not be released to set up a deviation.

3. Route the authorized deviation item through the appropriate workflow.

4. Install the deviated physical part into your as-built structure.

7. Setting up as-built physical structures
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Create a deviation authority item

1. Click My Teamcenter.

2. Choose File → New → Item.

3. From the New Item dialog box, select Deviation Document and click Next.

4. Enter information into all the required fields and click Finish.

5. If you do not want to create another deviation document, click Finish.

If you want to create another deviation document, repeat steps 2–4.

Set up a deviation

1. From the navigation pane, click As-Built Manager.

2. Choose Window → Show View → As-Built Manager to open the As-Built Manager view.

3. From the As-Built Manager view, click Open by Name  to open the deviated part.

4. Select the deviated part. Right-click and choose Copy.

5. From the As-Built Manager view, click Open by Name  to open the physical structure where
you want to install the deviated part.

6. Right-click the parent physical part and choose Setup Deviation or click the Setup Deviation
button  on the main toolbar at the top of the As-Built Manager pane.

The Setup Deviation dialog box appears.

7. Click  to set the value of Document Id and select Add.

The Search dialog appears.

Note:

The deviation authority item must not be released to set up a deviation.

8. Click Find to search for the deviation authority item ID using the search dialog box. You can use
wildcards for searching.

Create a deviation authority item
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9. Click OK to set up the deviation. Alternatively, click Cancel to exit.

Send the deviation authority item through the required workflow

1. From the navigation pane, select the deviation authority item.

2. Choose File → New → Workflow Process.

3. In the New Process Dialog box, type the process name in the Process Name box.

4. From the Process Template list, select TCM Release Process.

Note:

The TCM Release Process workflow is provided with the Teamcenter Foundation feature.
You can configure this workflow or create your own to set up the process flow, reviewers, and
business validations required to route a deviation document for review and approval.

5. Click OK. Alternatively, click Cancel to exit.

Install a deviated part

1. From the navigation pane, click As-Built Manager.

2. From the As-Built Manager view, click Open by Name  to open the deviated part.

3. Choose one of the following methods to identify the deviated physical part you want to install:

a. Copy the deviated physical part you want to install.

A. Right-click the physical part and choose Copy.

B. Select the physical structure where you want to install the deviated physical part.

C. Right-click the parent and choose Install Physical Part or click the Install Physical Part
button  on the main toolbar at the top of the Service Manager pane.

The Install Physical Part dialog box appears. The To Be Installed Physical Part field is
set to the copied physical part.

D. Select the usage name to set the usage for the installed deviated physical part. If the
physical part is an addition to the physical structure, select Extra to Design as the usage.

b. Search for the physical part you want to install.

7. Setting up as-built physical structures
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A. Select the physical structure where you want to install the deviated physical part.

B. Right-click the parent and choose Install Physical Part or click the Install Physical Part
button  on the main toolbar at the top of the Service Manager pane.

The Install Physical Part dialog box appears.

C. Select the usage name to set the usage for the installed deviated physical part. If the
physical part is an addition to the physical structure, select Extra to Design as the usage.

D. Perform the following steps to search for the physical part to be installed:

i. Click  and select Add.

The Installable Physical Parts dialog box appears.

ii. Click the Search tab and enter the following information you want to use as filters
for searching.

Field name Definition Valid values

Part Number Part number of the
physical part.

Alphanumeric (1–128
characters)

Serialized Value of the serialized
property.
Click true to search for
serialized parts.

Boolean

Serial Number After Value of the serial
number to filter physical
parts with serial
numbers greater than
the value entered.

Alphanumeric (1–128
characters)

Serial Number Before Value of the serial
number to filter physical
parts with serial
numbers less than the
value entered.

Alphanumeric (1–128
characters)

Lot Value of the lot
property.

Click true to search for
lot parts.

Boolean

Lot number Lot number of the
physical part.

Alphanumeric (1–32
characters)

Install a deviated part
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Field name Definition Valid values

Manufacturer's ID Manufacturer of the
physical part.

Alphanumeric (1–128
characters)

Manufactured After Manufacturing date
used to filter
physical parts with
manufacturing dates
greater than the date
entered.

Click the Set Date 
button and select a date
from the calendar.

Manufactured Before Manufacturing date
used to filter
physical parts with
manufacturing dates
before the date entered.

Click the Set Date 
button and select a date
from the calendar.

iii. Click Find.

The results display the valid deviated physical parts that can be installed.

iv. Select the physical part from the results and click OK.

The Install Physical Part dialog box reappears with the To be Installed Physical
Part field set to the selected physical part.

E. Click the Set Date  button to set the installation date when the installation occurred.

F. If the Usage Name is set to Extra to Design, in the Extra to Design Usage Name box,
type the usage name for the installed physical part.

G. Click OK to install the deviated physical part.

The deviated physical part is installed in the structure.

View the deviation authorization information

You can view the authorizing deviation item for a deviated part.

1. From the navigation pane, click As-Built Manager.

2. Select the physical structure containing the deviated part and choose Send to → My Teamcenter.

3. Click the Details tab.

7. Setting up as-built physical structures

7-22  As-Built Manager, Service Lifecycle Management 2412
© 2024 Siemens



The Allowed Deviation relation is displayed.

4. Select the deviated part.

5. Right-click and choose Properties on Relation....

The properties of the Allowed Deviation relation are displayed.

View the deviation authorization information
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The Deviation Authority field shows the deviation authority item used to authorize the deviation.

Release an as-built physical structure

You can release the as-built structure after you finish building it.

1. From the navigation pane, select the as-built structure you want to release.

2. Choose File → New → Workflow Process.

3. In the New Process Dialog box, choose Release AsBuilt Structure from the Process Template list.

Note:

The Release AsBuilt Structure option is the standard workflow provided with As-Built
Manager. This workflow also validates for any missing physical parts.

You can configure this workflow or create your own to set up the process flow, reviewers, and
business validations required to release an as-built structure.

4. Click OK. Alternatively, click Cancel to exit.

Rebuilding an as-built structure

You can rebuild an as-built physical structure to create a new revision. The new revision of the physical
structure represents a new refurbished build of the physical asset. New build revisions are created when
the physical parts are at a Released state.

Note:

The MaturityStatuses constant defines the release status for rebuilding an as-built physical
structure.

When you select a child part of a physical structure for rebuild, the following scenarios apply:

• The structure is traversed upward and new build revisions are created for each parent physical part
that is displayed in As-Built Manager and is released.

The following figure shows the shaft as the selected part for rebuild. The parent physical parts for the
turboengine and bearing housing are created with a new build revision B.
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• While traversing the displayed physical structure upward in As-Built Manager, if any of the physical
parts are not released, the rebuild will not traverse above the unreleased part revision.

• While traversing the displayed physical structure upward in As-Built Manager, and a parent physical
part is not released, the unreleased revision of the parent will be related to the new build revision
of the child part. The previous relationship between the child part and the unreleased parent will no
longer exist.

The following figure shows the bearing housing as the selected part for rebuild. The parent physical
part for the turboengine is not released. A new relationship is created between the new revision B of
the bearing housing and the unreleased revision A of the turboengine.

Rebuilding an as-built structure
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Rebuild an as-built structure

1. From the navigation pane, click As-Built Manager.

2. Click Open by Name  to open the released as-built physical structure or physical part that you
want to rebuild.

3. Select the part from the physical structure.

4. Choose Tools → Rebuild As-Built Structure or click the Rebuild As-Built Structure button  on
the main toolbar at the top of the As-Built Manager pane.

The Rebuild As-Built Structure dialog box appears.

5. If you select a child part of the physical structure, the following dialog box appears:
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Click Yes to continue.

6. Click the Set Date  button to set the rebuild date when the new revision of the physical
structure was created.

7. Click OK to rebuild the physical structure.

View untraced structures

You can display the parts in the neutral structure that are not traceable in the related physical structure.
Parts that are not traceable have the part logistics property Traceable set to False in context of the
parent physical structure and a physical part is not generated for that neutral part.

The following occurs when you display an untraced structure in As-Built Manager:

• The untraced parts are displayed as neutral parts in the physical structure.

• Any action that can be run on neutral parts is available on the displayed untraced parts.

When viewing an as-built structure using visualization, you can also display the untraced parts.

1. From the navigation pane, click As-Built Manager.

2. Click Open by Name  to open the physical structure that you want to display the untraced parts
for.

3. Select the parent part of the physical structure.

4. Choose View → Show Untraced Parts or click the Show Untraced Parts button  on the main
toolbar at the top of the As-Built Manager pane.

The untraced parts are displayed.

 BH001/InTest–A
 BH012/A

 BH013/A

 BH014/A

View untraced structures

As-Built Manager, Service Lifecycle Management 2412  7-27
© 2024 Siemens



 BH015/A

 BH016/A  untraced part

Updating structures using Excel Live

You can update physical structures using Excel Live. Teamcenter Extensions for Microsoft Office provides
synchronous access to Teamcenter workspace objects through Microsoft Office Excel. With the live Excel,
Extensions for Office gives Excel direct connectivity to the Teamcenter server and allows you to edit
physical structures using Excel.

To generate a file in live Excel, you choose the related option when exporting data for selected objects in
the Teamcenter rich client. The following occurs after export:

• The data exported to the output file consists of property values for the objects.

• The exported property values are synchronized with the corresponding values in Teamcenter.

• Values that you edit in the output file are changed interactively in Teamcenter.
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8. Comparing as-built structures
Comparing as-built structures

As shown in the following figure, a user such as a production planner can compare two physical
structures or a physical with a neutral structure to identify changes or differences between two product
structures.

For example, you can compare the neutral structure and the physical structure to highlight the missing
and nontraceable parts or compare two different installations of the same physical structure to show
differences. The differences are displayed using colors that represent full, partial, or no matches between
the structures. You can also optionally generate a report summarizing the differences.

Comparing structures with or without context

Comparing with context

As-Built structures can be compared with or without context.

If you select the compare (with context) option, you are comparing the parts in position in the physical
or neutral structures. For example, you can use compare with context to determine if the left and right
engines were swapped. A compare without context would not detect those differences.

For this comparison to work properly, you must set a value in the ID in Context column in the As-Built
Manager window for the parts in the neutral structure. This comparison is similar to an accountability
check between structures described in the Multi-Structure Manager Guide. You can select additional
properties for comparison and set the context ID to match any source and target line that have the same
absolute occurrence identifier.
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Set compare with context preferences

To specify the default and additional properties used for comparing as-built structures with context, an
administrator sets the DefaultAsBuiltAccCheckProperties and AdditionalAsBuiltAccCheckProperties
preferences.

Global constant Default value

DefaultAsBuiltAccCheckProperties phbl_part_number

phbl_part_used_is

AdditionalAsBuiltAccCheckProperties phbl_part_usage_name

Perform compare with context

You compare two as-built structures in the As-Built Manager view using two separate panes.

1. From the navigation pane, click As-Built Manager to open the source structure in the bottom pane
and the target structure in the top pane.

• From the navigation pane, click As-Built Manager.

• Choose Window → Show View → As-Built Manager to open the As-Built Manager view.

• From the As-Built Manager view, click Open by Name  to open the source structure.

• Click Show/Hide lower structure panel  located at the top of the application window to
create a new empty (target) pane. The source structure appears in the bottom pane.

• Click Open by Name  to open the second structure in the top pane.

2. After you open the as-built structures in the appropriate panes, configure them by setting the
revision rule and/or variant rule in each pane.

3. Expand and collapse assemblies to define the scope of the comparison.

4. Choose Tools → Compare.

The Compare dialog box appears.

5. Do one of the following:

• If you want to reverse source and target as-built structures, select Flip source and target.

8. Comparing as-built structures
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• To compare as-built structures with context, select Compare (with context).

6. Select Display Options to change comparison color scheme. When you compare two structures,
the results are displayed in a variety of colors that you can change using the display options. To
help users who cannot differentiate colors, a tool tip shows the name of the color. If the name is
not available, the tool tip displays the RGB (red, green, blue) value.

• Check the display options you require.

Display option Description

Full match If all properties of a source object are identical to the
properties of a target object, both objects are set to the same
background color. The default color is green.

Partial match If part of the properties of a source object is identical to the
properties of a target object, both objects are set to the same
background color. The default color is yellow.

Multiple match If the properties of a source object are identical to the
properties of target objects, all objects are set to the same
background color. The default color is orange.

Multiple partial
match

If part of the properties of a source object is identical to the
properties of target objects, all objects are set to the same
background color. The default color is pink.

Missing target If the properties of a source object are not found by target
objects, the source object is set to this color. The default
color is red.

Missing source If the properties of a target object do not meet properties of
any source objects, the target object is set to this color. The
default color is white.

• Change the default color by clicking  next to the color. Set the colors by selecting a color
swatch, and setting HSB (hue, saturation, brilliance) or RGB (red, green, blue) values.

7. Select Compare Options to change properties.

• To compare any source line and target line that have the same absolute occurrence identifier,
select the Treat same ID in context as same check box. If not selected, the compare does not
match lines with different absolute occurrences, even if they share the same absolute occurrence
identifier.

• To match lines in the source and target that have the same properties as those you choose in the
Selected Properties list, select the Compare Additional Properties check box. If not selected,
the compare includes only those default options defined by your administrator.

Perform compare with context
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• Use the  button to select the properties from the Available Properties list and move
them to the Selected Properties list. Use the  button to remove the properties from the
Selected Properties list and move them back to the Available Properties list.

8. Click Check to begin the comparison. Alternatively, click Cancel to exit.

Comparing without context

As-Built structures can be compared with or without context.

If you choose the Compare (without context) option, you can compare structures at the at the
assembly or subassembly levels and set the level or mode of comparison. This comparison is similar
to comparing two structures in the Structure Manager view described in the Structure Manager Guide.
When Teamcenter compares the displayed product structures (BOMs); it compares each level that is
visible. Consequently, you can compare different views or configurations by expanding the structure to
the desired level. Also, if you collapse assemblies in the product structure, the comparison excludes the
content of those assemblies. You can use this feature to limit the scope of a comparison.

Set compare without context preferences

• Property preferences

To specify the default and additional properties used for comparing as-built structures
without context, an administrator sets the DefaultAsBuiltCompareProperties and
AdditionalAsBuiltCompareProperties preferences.

Global constant Default value

DefaultAsBuiltCompareProperties phbl_part_number

phbl_part_usage_name

AdditionalAsBuiltCompareProperties phbl_part_used_is

• Display preferences

Because the display options are unavailable when comparing without context, an administrator can
change the colors displayed for added and changed occurrences by setting the PSEAdditionColorPref
and PSEChangedColorPref preferences. No colors are displayed for full matches.

Global constant Default value

PSEAdditionColorPref red

PSEChangedColorPref orange

8. Comparing as-built structures
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Perform compare without context

You compare two as-built structures in the As-Built Manager view using two separate panes.

1. From the navigation pane, click As-Built Manager to open the source structure in the bottom pane
and the target structure in the top pane.

• From the navigation pane, click As-Built Manager.

• Choose Window → Show View → As-Built Manager to open the As-Built Manager view.

• From the As-Built Manager view, click Open by Name  to open the source structure.

• Click Show/Hide lower structure panel  located at the top of the application window to
create a new empty (target) pane. The source structure appears in the bottom pane.

• Click Open by Name  to open the second structure in the top pane.

2. After you open the as-built structures in the appropriate panes, configure them by setting the
revision rule and/or variant rule in each pane.

3. Expand and collapse assemblies to define the scope of the comparison.

Note:

You compare only the visible structures displayed in the panes.

4. Choose Tools → Compare.

The Compare dialog box appears.

5. Do one of the following:

• If you want to reverse source and target as-built structures, select Flip source and target.

• To compare as-built structures without context, select Compare (without context).

6. Select Compare Options to change compare modes.

• Select the compare mode to set the level of comparison.

Perform compare without context
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Mode Description

Single Level Compares only the first levels of the product structures.

Multi Level Performs a single-level comparison at the top level, and then
starts further single-level comparisons on any subassemblies
that match between the two product structures. This process is
repeated successively down the product structure.

Lowest Level Compares only the lowest level items of the product structures,
ignoring all intermediate assemblies. This is useful for verifying
that piece parts are consistent.

7. If you want to display a report window summarizing the differences between the structures, select
the Report check box.

The Print window appears after the compare is complete.

8. To print the report, choose Print the file . To save the report to a local text file, from the report
window, choose Saves to a user specified file . To close the window, choose Close.

• In single-level mode and lowest level mode, the reports are flat lists of differences.

• In multilevel mode, the report is an indented output is produced, showing the parent assemblies
of any changed items.

9. Click Check to begin the comparison. Alternatively, click Cancel to exit.

Clear comparison

• To clear the highlighting colors, choose Tools → Clear.

Note:

If you start a new comparison before clearing the results of the previous comparison, the
existing results are automatically cleared.

Comparing a neutral structure to a physical structure

Comparing as-built physical structures to neutral structures

You can compare an as-built neutral structure with an as-built physical structure. For example, you may
want to highlight the following as differences:

• Nontraceable parts

8. Comparing as-built structures
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• Missing physical parts

• Substitute parts

• Deviated parts

• Global alternate parts

Compare with context example between a neutral structure and a physical
structure

The following compare information and figure show the result of a compare with context between the
neutral structure and the physical structure for the bearing housing assembly.

• Source structure: physical structure in the top pane for the bearing housing assembly.

• Target structure: neutral structure in the bottom pane for the bearing housing assembly.

• All the display options are selected.

Compare with context example between a neutral structure and a physical structure

As-Built Manager, Service Lifecycle Management 2412  8-7
© 2024 Siemens



Comparing as-built physical and neutral structures with context

The color green indicates a full match. The following parts show differences.

Part ID Structure Color Why?

BH014 Neutral Yellow indicating a partial
match

Some properties are identical
because the alternate part for
the shaft was installed in the
physical structure.

BH014A Physical Cyan indicating the physical
part is an alternate

The alternate part for the
shaft was installed in the
physical structure.

8. Comparing as-built structures
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Part ID Structure Color Why?

BH015 Neutral Yellow indicating a partial
match

Some properties are identical
because the substitute part
for the shaft was installed in
the physical structure.

BH015S Physical Royal blue indicating the
physical part is a substitute

The substitute part for the
shaft was installed in the
physical structure.

BH021 Neutral Light blue indicating a
missing source.

The physical part for the
hardware is missing from the
source physical structure.

Compare without context example between a neutral structure and a
physical structure

The following compare information and figure show the result of a compare without context between
the neutral structure and the physical structure for the bearing housing assembly.

• Source structure: physical structure in the top pane for the bearing housing assembly.

• Target structure: neutral structure in the bottompane for the bearing housing assembly.

• Display options:

• Set to Multi Level.

Compare without context example between a neutral structure and a physical structure
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Comparing as-built physical and neutral structures without context

No color indicates a full match. Because compare without context compares the parts that are visible
and does not compare properties, the following parts show differences.

Part ID Structure Color Why?

BH014 Neutral Red indicating no match The alternate part for the
shaft was installed in the
physical structure.

BH014A Physical Cyan indicating the physical
part is an alternate

The alternate part for the
shaft was installed in the
physical structure.

8. Comparing as-built structures
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Part ID Structure Color Why?

BH015 Neutral Red indicating no match The substitute part for the
shaft was installed in the
physical structure.

BH015S Physical Royal blue indicating the
physical part is a substitute

The substitute part for the
shaft was installed in the
physical structure.

BH021 Neutral Red indicating no match The hardware does not exist
in the physical structure.

Comparing two physical structures

Comparing two as-built physical structures

You can compare two as-built physical structures. For example, you may want to highlight the
differences between two installations of the same physical structure.

Compare with context example between two physical structures

The following figure shows the result of a compare with context between two physical structures for the
bearing housing assembly.

• Source structure: The bearing housing assembly in the bottom pane used in the missile truck. The
serial number is set to MTruck.

• Target structure: The bearing housing assembly in the top pane used in the supply truck. The serial
number is set to STruck.

• All display options are selected.

Comparing two as-built physical structures
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Comparing two as-built physical structures with context

The color green indicates a full match. The following parts show differences.

Part ID Structure Color Why?

BH014 MTruck Yellow indicating a partial
match

Some properties are identical
because the alternate part for
the shaft was installed in the
physical structure used in the
supply truck.

BH014A STruck Cyan indicating the physical
part is an alternate

The alternate part for the
shaft was installed in the
physical structure used in the
supply truck.

8. Comparing as-built structures
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Part ID Structure Color Why?

BH015 MTruck Yellow indicating a partial
match

Some properties are identical
because the substitute part
for the shaft was installed in
the physical structure used in
the supply truck.

BH015S STruck Royal blue indicating the
physical part is a substitute

The substitute part for the
shaft was installed in the
physical structure used in the
supply truck.

BH016 STruck Light blue indicating a
missing source.

The regular bearing housing
does not exist in the source
physical structure used in the
missile truck.

BH016HD MTruck Red indicating a missing
target.

The heavy duty bearing
housing does not exist in the
target physical structure used
in the supply truck.

BH020D MTruck Yellow indicating the physical
part is a deviation

The deviated redesigned part
for the retaining ring was
installed in the physical
structure used in the missile
truck.

BH020 STruck Yellow indicating a partial
match

Some properties are identical
because the deviated
redesigned part for the
retaining ring was installed in
the physical structure used in
the missile truck.

Compare without context example between two physical structures

The following figure shows the result of a compare without context between two physical structures for
the bearing housing assembly.

• Source structure: The bearing housing assembly in the bottom pane used in the missile truck. The
serial number is set to MTruck.

• Target structure: The bearing housing assembly in the top pane used in the supply truck. The serial
number is set to STruck.

• Display options:

Compare without context example between two physical structures
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• Set to Multi Level.

Comparing two as-built physical structures without context

No color indicates a full match. Because compare without context compares the parts that are visible
and does not compare properties, the following parts show differences.

Part ID Structure Color Why?

BH014A STruck Cyan indicating the physical
part is an alternate

The alternate part for the
shaft was installed in the
physical structure used in the
supply truck.

BH014 MTruck Red indicating no match The alternate part for the
shaft was installed in the

8. Comparing as-built structures
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Part ID Structure Color Why?

physical structure used in the
supply truck.

BH015S STruck Royal blue indicating the
physical part is a substitute

The substitute part for the
shaft was installed in the
physical structure used in the
supply truck.

BH015 MTruck Red indicating no match The substitute part for the
shaft was installed in the
physical structure used in the
supply truck.

BH016 STruck Red indicating no match The heavy duty bearing
housing is installed in the
physical structure used in the
missile truck.

BH016HD MTruck Red indicating no match The regular bearing housing
is installed in the physical
structure used in the supply
truck.

BH020 STruck Red indicating no match The deviated redesigned part
for the retaining ring was
installed in the physical
structure used in the missile
truck.

BH020D MTruck Red indicating no match The deviated redesigned part
for the retaining ring was
installed in the physical
structure used in the missile
truck.

Compare without context example between two physical structures
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9. Visualizing as-built physical structures
Visualizing as-built physical structures

You can visualize the as_built neutral and physical structures from the As-Built Manager view with the
embedded viewer. You can also view any untraced parts in the as-built physical structure. When you
visualize the as-built physical structure, you are looking at the data associated with its linked neutral
structure. The visualization data is only associated to the design parts of the neutral structure and not to
the related as-built physical structure.

You use the embedded viewer in the As-Built Manager view in the same way as the embedded viewer
in the Structure Manager view. If you want to use the enhanced capabilities of Lifecycle Visualization or
the embedded viewer, you must purchase and install the necessary additional licenses.

Note:

Physical parts with Part Used status set to Missing do not display any visualization.

The following figure shows an example where you can visualize both the neutral and physical structures
in the As-Built Manager view with a split window. You may want to use a split window to see what the
missing physical parts look like by viewing the visualization of their related neutral part item revisions.
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Visualizing as-built neutral and physical structures

Associating image file datasets

To visualize the neutral or as-built physical structure, you must create DirectModel datasets containing
the image (JT) files. You attach the datasets with the Rendering relationship to the neutral part
item revisions that compose the neutral structure. When you visualize the physical structure, you are
accessing the same datasets attached to its linked neutral structure. A DirectModel dataset can contain
several JT files with different names, so you should set rules that determine the file to display.

Visualize the as-built structure model

The lines in the project workspace are shown with a check box to the left of the part. You select the
check boxes next to the part and assembly names in the assembly tree to choose which parts and
assemblies to load and make visible. By default, they are all unchecked.

9. Visualizing as-built physical structures
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1 Project workspace Displays the product structure.

2 Navigation toolbar Toolbar used to navigate the 3D model.

3 Graphical viewing window Displays the 3D model associated with the product
structure.

1. Open the structure in the As-Built Manager view by one of the following methods:

• From the navigation pane, click As-Built Manager and click Open by Name  to open the
structure.

• If you are viewing the structure in the Structure Manager view, right-click the structure parent
and choose Send to → As-Built Manager.

2. Choose View → Show Data Panel, or click the Show/Hide Data Panel button  on the toolbar.

3. Click the Assembly Viewer tab to visualize the 3D models for the as-built assembly structure.

4. (Optional) To view a split window, click Show/Hide lower Structure Panel  located at the top of
the application.

Visualize the as-built structure model

As-Built Manager, Service Lifecycle Management 2412  9-3
© 2024 Siemens



5. To display or hide entire models, assemblies, or individual parts, you can do any of the following:

To Do this

View the entire structure Select the check box for the top-level line in the structure to
load the graphics for every line in the structure.

View a selected part of the
structure

Select the check boxes only for those lines for which you want
to load the graphics.

View only the part Select the check box for the line for a part.

View an assembly Select the check box for a line representing the assembly.

Hide the entire structure Clear the check boxes.

Using the graphics menu

The Graphics menu appears when you click the Assembly Viewer tab.

Command Description

Selection → Select All Selects all the objects displayed in the viewer.

Selection → Select None Clears any objects currently selected in the viewer.

Selection → Reverse Selection Selects all objects not selected in the viewer, while
simultaneously unselecting any objects currently selected in the
viewer.

Visibility → View Selected Blanks and unblanks objects loaded in the viewer.

Note:

The term loaded refers to an object whose JT file has been
loaded in the viewer. A loaded object may or may not
be visible, depending on whether it has been blanked or
unblanked.

Visibility → Blank Selected Makes any objects selected in the viewer invisible.

Visibility → Blank All Makes all objects in the viewer invisible.

Visibility → Unblank All Makes all objects loaded in the viewer visible.

Visibility → Reverse Blank All Makes any currently visible objects invisible, while
simultaneously making visible any loaded objects which are
currently invisible.

Visibility → Unload Selected Unloads any objects selected in the viewer.

9. Visualizing as-built physical structures

9-4  As-Built Manager, Service Lifecycle Management 2412
© 2024 Siemens



Command Description

Edit Color/Translucency Modifies the color, transparency, and shine of selected objects
in the viewer. These settings only apply to the currently loaded
objects. The next time the edited object is loaded, the settings
revert to the default color and translucency.

Insert Allows you to insert JT, stereolithography (.stl), and VRML (.wrl)
files as reference graphics.

Insert → Insert from File Inserts a reference graphic from the operating system, using the
Open by Name dialog box.

Insert → Insert from Clipboard Inserts a reference graphics object from the clipboard.

Note:

Only item revisions (not items) can be displayed as
reference graphics.

Views → Views Control Creates, edits, and displays standard views, using the Rotate and
Standard Views dialog boxes.

Draw Children Displays the components of a subassembly. You can also access
this command if you right-click in the BOM.

Show Subcomponents Breaks down solids in the corresponding monolithic JT files
and make the subcomponents independently controllable. This
function is available only for only leaf and unpacked BOM line
nodes.

Hide Subcomponents Removes all merged subcomponents and the one-level tree from
the tree. You can load or unload the monolithic JT file related to
this BOM line node in the normal way.

Export 3D File Exports the current visible objects to a STEP or VRML file.

Replace JT File Replaces the JT file that represents an item revision. You can
choose a replacement file from one of the JT files associated with
the current BOM line item.

Transformation → Temporary
Transformation

Generates an exploded view for use in technical illustrations.

Transformation → Persistent
Transformation

Modifies the physical location of a part (or set of parts) in an
owning assembly.

Clearance → Preferences → Calcu
lator Settings

Specifies the precision and nature of the clearance check.

Clearance → Preferences → Clear
ance Requirements

Defines the clearance conditions based on the metadata of the
structure or elements.

Using the graphics menu
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Command Description

Clearance → Preferences → Clear
ance Results

Adjusts the clearance results preferences to change the
appearance and behavior of clearance results.

Clearance → Preferences → Toggl
e Results Window

Displays the clearance results window.

Performance Sets rendering, culling and general performance preferences.

Preferences Sets clearance analysis and general viewer preferences.

9. Visualizing as-built physical structures
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10. Navigating the 3D model
When you visualize the 3D model associated to the physical or neutral structure. the 3D navigator
toolbar appears at the top of the Assembly Viewer window. It is used to manipulate the 3D view.

Option name Mode Use this button to

Examine
Fly Explore Enable Examine mode.

Fly
Examine Explore Enable Fly mode.

Explore
Examine Fly Enable Explore mode.

Previous View
Examine Fly
Explore

Return to the last static view.

Next View
Examine Fly
Explore

Move to the next static view

Fit All Examine Fly
Explore

Fit all visible parts of the model into the viewing
window.

Zoom Area Examine Fly
Explore

Zoom to a specific area of the model.

seek Examine Fly
Explore

Center a point of the model. This point becomes the
center of rotation.

Rotate Examine Rotate your model in the viewing window.

Pan Examine Fly
Explore

Pan the model in the plane of the viewing window.

Zoom Examine Move closer to or farther from the model.

Position Explore Choose your position in the model.

Level Fly Explore Align the view to the up vector.

Terrain Following Fly Explore Remain a specified distance above the floor upon
which you are moving.

Collision Detection Fly Explore Stop moving through your model when you come into
contact with a part.
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Go Home Explore Return to the location and position you were at when
you last selected Set Home.

Set Home Explore Set the current location and position as the home
location.

Preferences Examine Fly
Explore

Set mode preferences.

10. Navigating the 3D model
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11. Sharing As-Built Manager data
Sharing As-Built Manager data

You can share As-Built Manager data by:

• Importing as-built physical structures from third-party systems or other Teamcenter sites into
Teamcenter using PLM XML format.

• Exporting as-built physical structures data from Teamcenter to other Teamcenter sites or third-party
systems using PLM XML format.

• Using Multi-Site Collaboration to share As-Built Manager data between multiple Teamcenter sites.

Export an as-built structure

A user such as a production planner can export as-built data from Teamcenter to other Teamcenter sites
or third-party systems.

Exported data includes:

• Physical parts with revisions.

• Physical realization information.

• As-built structures including installation date.
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• Physical alignment relations.

• Lot information if assigned to a physical part.

• Deviation information.

1. Select the physical structure to be exported.

2. Choose Tools → Export → To PLMXML.

The system displays the PLM XML Export dialog box.

3. In the Export Directory box, select the directory in which to place the PLM XML file. Click Browse
to locate the directory.

4. Specify the name of the export file in the Export Filename box.

5. Choose a transfer mode from the Transfer Mode list.

The transfer mode AsBuiltDataExport is provided with As-Built Manager for exporting as-built
structure information.

6. (Optional) Click Select Languages to display the Language Selection dialog box for the languages
configured at your site.

• Main Language is the site master language. This cannot be changed.

• The Available Languages box lists the languages you can select as additional languages for
export.

• The Select Additional Languages box lists the preconfigured languages for the selected transfer
mode.

To select additional languages for export, follow these steps:

a. Select a language in the Available Languages box.

b. Click the Add button .

• The selected language is added to the Selected Additional Languages box.

• To reorder the languages in the Selected Additional Languages box, select a language
and use the move   buttons as required.

c. Click OK or Apply.

11. Sharing As-Built Manager data

11-2  As-Built Manager, Service Lifecycle Management 2412
© 2024 Siemens



The languages selected for export are displayed in the Languages box.

Note:

If you change the transfer mode, the Languages entries remains unchanged. You can
use the Language Selection dialog box again to add or remove more languages.

7. (Optional) Select a revision rule to configure the assembly to be exported.

8. If you do not apply a revision rule, only the parent item revision is exported.

9. (Optional) Select Open PLM XML File to view the file when the export operation is complete.

10. (Optional) Select the View Log File check box to view the log file when the data translation is
complete.

11. (Optional) Select the Perform Export In Background check box to perform an

12. Click OK to export the objects in the Object List and close the dialog box.

Importing as-built structures

Importing as-built structures

A user such as a production planner can import as-built data from a third-party systems or other sites
into Teamcenter.

You can import as-built physical structure data into Teamcenter from any third-party system
if it conforms to the PLM XML schema. Data Exchange creates the as-built structure

Importing as-built structures
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using the RealizedProduct, RealizedProductRevision, Lot, LotRevision, RealizedProductUsage,
AllowedDeviation, Deviation, and DeviationRevision elements. Before you import an as-built
structure, the neutral structure and the part logistics information must exist on the importing site.

If the occurrence information is provided along with the occurrence name, the alignment relation is
created. If the occurrence name is not provided or the occurrence name does not match the neutral part
occurrence name, Data Exchange processes the structure relationship without the alignment relation.

If the lot information is provided and the lot is not defined in Teamcenter, Data Exchange creates and
assigns the physical part to the new lot. If the lot exists, the physical part is assigned to the existing lot.

Import an as-built structure

Note:

Before you import an as-built structure, the neutral structure and the part logistics information
must exist on the importing site.

You can import an as-built structure into Teamcenter from a third-party system by performing the
following steps:

1. Choose Tools → Import → From PLMXML.

The system displays the PLM XML Import dialog box.

2. Click Browse  to the right of the Importing XML File box.

The system displays the Select Object dialog box.

3. Navigate to the directory containing the file and select the file.

The system displays the file name in the Directory name box.

4. Click Select.

The system displays the path to the selected file in the Importing Object box of the dialog box.

5. Select the transfer mode to be used to configure the import operation.

Note:

The transfer mode AsBuiltDataImport is provided with As-Built Manager for importing as-
built structure information from a third-party system into Teamcenter.

11. Sharing As-Built Manager data
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6. (Optional) Select the View Log File check box to view the log file when the data transfer is
complete.

7. Click Apply to start the import operation and retain the dialog box, or click OK to start the import
operation and exit the dialog box.

The system imports the data as follows:

• By default, the imported object has no container reference. You can use relevant search criteria
to find the imported object and so you can copy it to a folder.

• To have Teamcenter import objects into your Newstuff folder, create the
PLMXML_put_objects_in_newstuff_on_import preference and set the value to TRUE. Imported
objects are placed in a folder with the same name as the imported XML file.

Note:

If object names or IDs are encountered that exceed the character limit for those fields in
Teamcenter, the name and/or ID is truncated when imported into Teamcenter. Teamcenter
provides 128 bytes for item IDs and names.

Import as-built structure exceptions

When you import an as-built structure into Teamcenter from a third-party system and a physical part has
a status of released in Teamcenter, the import fails for that physical part. The relationship is not created
between the as-built structure parent and the child physical part that is released. The import continues
for the remaining components.

As the following figure shows, the relationship between the parent physical part Aircraft #100 and the
physical part Engine #200 is not created in Teamcenter because Aircraft #100 has a status of released.

Import as-built structure exceptions
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Component physical part is released in Teamcenter

Re-import as-built structure behavior

When you re-import an as-built structure into Teamcenter from a third-party system, be aware of the
following behaviors:

• Re-import after physical part is added to as-built structure on third-party system.

As the following figure shows, when the third-party as-built structure is re-imported with the newly
added physical part Pump #300, the additional part is imported into Teamcenter.

11. Sharing As-Built Manager data
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Re-import into Teamcenter with additional physical part

• Re-import after physical part is deleted from as-built structure on 3rd party system.

As the following figure shows, when the third-party as-built structure Aircraft #100 is re-imported
to Teamcenter with the physical part Pump #300 removed, the physical part is not removed on
Teamcenter.

Re-import as-built structure behavior
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Re-import into Teamcenter with physical part removed

Managing As-Built Manager data for Multi-Site Collaboration

Managing As-Built Manager data for Multi-Site Collaboration

Using Multi-Site Collaboration, you can share As-Built Manager data between multiple Teamcenter sites.
Each Teamcenter site has its own independent database with its own set of users and groups, data
model, business rules, and business processes.

Data sharing is done through object replication where an exact copy of an object is made at a remote
site using remote export and import functions. The replicas are synchronized when the master copy is
modified.

11. Sharing As-Built Manager data
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The Object Directory Services server (ODS) site maintains a record of each object in the entire Multi-Site
Collaboration network.

The Integrated Distributed Services Manager (IDSM) provides the mechanism used to export an object
from the owning site, transmit it over the network, and import it into the destination site.

Multi-Site Collaboration support for as-built structures

When you export as-built structures and related As-Built Manager data using Multi-Site Collaboration,
Data Exchange also exports the relations and the related objects. The table summarizes which relations
and corresponding related objects are exported for each As-Built Manager object and whether the
related object is optional or required.

Exported As-Built Manager
object Exported relation

Exported related
object

Optional or
required

Item IMAN references Part logistics form Optional

Has characteristics Characteristic
definitions

Optional

Physical part Physical
characteristics

Characteristic
values

Required

Multi-Site Collaboration support for as-built structures
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Exported As-Built Manager
object Exported relation

Exported related
object

Optional or
required

Physical part
revision (by
creation date)

Optional

Allowed deviation Physical Part
(Child)

Required

Contains Asset group Required

Physical part in
location

Physical location Required

Disposition
applicability

Disposition Required

Allowed deviation Tag Deviation
document

Required

Physical part revision Tag Physical part Required

Physical realization Item revision Optional

Physical context Structure context Required

Tag Lot Required

As-built structure Physical part Optional

Physical structure Physical structure
alignment

Occurrence Optional

Lot Tag Item Required

Physical location Physical location
revision by
creation date

Optional

Physical location revision Tag Physical location Required

As-built structure Physical location Optional

As-Built Manager actions on stub and replica objects

Data sharing in Multi-Site Collaboration is done by replicating objects to remote databases through
export and import functions. In addition, during Multi-Site Collaboration import, Teamcenter uses the
persistent object model (POM) to create stubs for all referenced instances on the object. The following
table shows the As-Built Manager actions that can be performed on object replicas and stubs.

11. Sharing As-Built Manager data
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Actions Stub Replica Exceptions

Name occurrence No No

Create lot No Yes

Create serial number
generator

No No

Generate as-built structure No Yes If any stubs are found in the neutral
structure during generation, the action
exits and does not process any partial
structures.

Install physical part No No

Uninstall physical part No No

Setup deviation No No

Assign lot No No

Compare No Yes The compared structures should not
have any stubs.

Visualization No Yes Visualization is not supported for stubs
within the neutral or physical structures.

Display as-built structure Yes Yes Stubs are displayed as remote lines.
Structures below stubs are not displayed.

Release physical structure No Yes Structure must be transferred with
ownership.

Where installed No Yes

As-Built Manager actions on stub and replica objects
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AsBuiltManagerColumnsShownPref

DESCRIPTION

Specifies the columns displayed in the As-Built structure table.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid BOM line property and a valid As-Built
BOM line property.

DEFAULT VALUES

bl_indented_title
bl_item_object_type
phbl_part_used_is
phbl_part_usage_name
phnl_serial_number
phbl_lot_number
phbl_part_number
phbl_installation_time
phbl_mfg_date
phbl_mfgr_org_id
phbl_physical_quantitiy
phbl_physical_uid
bl_item_item_id

DEFAULT PROTECTION SCOPE

Site preference.

A. As-Built Manager preferences
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AsBuiltManagerShownColumnWidthsPref

DESCRIPTION

Specifies the column widths displayed in the As-Built structure table.

VALID VALUES

One or more integers as values; each integer defines the column width in characters. The
first value set in this preference defines the column width of the first value set in the
AsBuiltManagerShownColumnWidthsPref user preference, and so forth.

DEFAULT VALUES

20
10
10
10
10
10
10
15
15
10
10
15
10

DEFAULT PROTECTION SCOPE

Site preference.

AsBuiltManagerShownColumnWidthsPref
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DefaultAsBuiltCompareProperties

DESCRIPTION

Specifies the default As-Built compare properties.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid BOM line property and a valid As-Built
BOM line property.

DEFAULT VALUES

phbl_part_number
phbl_part_usage_name

DEFAULT PROTECTION SCOPE

Site preference.

A. As-Built Manager preferences
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AdditionalAsBuiltCompareProperties

DESCRIPTION

Specifies the default As-Built compare properties.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid BOM line property and a valid As-Built
BOM line property.

DEFAULT VALUES

phbl_part_used_is

DEFAULT PROTECTION SCOPE

Site preference.

AdditionalAsBuiltCompareProperties
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DefaultAsBuiltAccCheckProperties

DESCRIPTION

Specifies the default As-Built accountability check properties.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid BOM line property and a valid As-Built
BOM line property.

DEFAULT VALUES

phbl_part_number
phbl_part_used_is

DEFAULT PROTECTION SCOPE

Site preference.

A. As-Built Manager preferences
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AdditionalAsBuiltAccCheckProperties

DESCRIPTION

Specifies the additional As-Built accountability check properties.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid BOM line property and a valid As-Built
BOM line property.

DEFAULT VALUES

phbl_part_usage_name

DEFAULT PROTECTION SCOPE

Site preference.

AdditionalAsBuiltAccCheckProperties
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HierarchicalWSO_HierarchicalWSO_default_relation

DESCRIPTION

Specifies the default relation between two hierarchical workspace objects.

VALID VALUES

Accepts one or more strings as a value. Each string must be a valid Teamcenter object.

DEFAULT VALUES

HWSOStructure

DEFAULT PROTECTION SCOPE

Site preference.

B. SLM core preferences
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Item_CharacteristicDefinition_default_relation

DESCRIPTION

Specifies the default relation created when a characteristics definition object is pasted under an item
object.

VALID VALUES

Accepts one or more strings as a value. Each string must be a valid Teamcenter object.

DEFAULT VALUES

NeutralCharacteristics

DEFAULT PROTECTION SCOPE

Site preference.

Item_CharacteristicDefinition_default_relation
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ItemRevision_CharacteristicDefinition_default_relation

DESCRIPTION

Specifies the default relation created when a characteristics definition object is pasted under an item
revision object. The default value for this preference is InvalidRelation to disallow creating a relation
between an item revision object and a characteristics definition object.

VALID VALUES

Accepts one or more strings as a value. Each string must be a valid Teamcenter object.

DEFAULT VALUES

InvalidRelation

DEFAULT PROTECTION SCOPE

Site preference.

B. SLM core preferences
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LogBook_PhysicalPart_default_relation

DESCRIPTION

Defines the default relationship between a log book and a physical part.

VALID VALUES

Accepts one or more strings as a value. Each string must be a valid Teamcenter object.

DEFAULT VALUES

physicalAssetTag

DEFAULT PROTECTION SCOPE

Site preference.

LogBook_PhysicalPart_default_relation
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LogBook_WorkspaceObject_default_relation

DESCRIPTION

Defines the default relationship created when workspace object is pasted under a log book. The default
value of this preference is InvalidRelation to disallow the creation of any relation with a log book.

VALID VALUES

Accepts one or more strings as a value. Each string must be a valid Teamcenter object.

DEFAULT VALUES

InvalidRelation

DEFAULT PROTECTION SCOPE

Site preference.
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Lot.SUMMARYRENDERING

DESCRIPTION

Specifies the lot objects summary style sheet registry.

VALID VALUES

Accepts a single string as a value, which must be a valid dataset name.

DEFAULT VALUES

LotSummary

DEFAULT PROTECTION SCOPE

Site preference.

Lot.SUMMARYRENDERING
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Lot_DefaultChildProperties

DESCRIPTION

Specifies a list of properties that can be used for Lot children.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid Teamcenter relation object.

DEFAULT VALUES

designItemTag

DEFAULT PROTECTION SCOPE

Site preference.

B. SLM core preferences
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MRONeutralColumnsShownPref

DESCRIPTION

Specifies the columns displayed in the Service Lifecycle Management neutral item structure table.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid neutral BOM line property.

DEFAULT VALUES

bl_indented_title
bl_item_object_type
bl_occurrence_name
bl_quantity
bl_uom
npbl_is_item_serialized
npbl_is_item_lot
npbl_is_item_traceable
npbl_preserve_quantity
npbl_is_item_rotable
npbl_is_item_consumable

DEFAULT PROTECTION SCOPE

Site preference.

MRONeutralColumnsShownPref
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MRONeutralShownColumnWidthsPref

DESCRIPTION

Specifies the column widths displayed in the Service Lifecycle Management neutral item structure table.

VALID VALUES

One or more integers as values; each integer defines the column width in characters. The first value set
in this preference defines the column width of the first value set in the MRONeutralColumnsShownPref
user preference, and so forth.

DEFAULT VALUES

20
15
12
10
10
10
10
10
10
10
10

DEFAULT PROTECTION SCOPE

Site preference.
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ManufacturingIdCharsForPhysicalPartIdPref

DESCRIPTION

Specifies the number of characters to use from the manufacturing ID when generating the physical part
item ID. The physical part item ID is a combination of characters from part number, serial number, and
manufacturing ID properties. The total number of characters for the physical part item ID should not
exceed 128 characters. The first entry in the preference is the number of characters to use from the
manufacturing ID property for the physical part item ID. The second entry in the preference indicates
whether to use the characters from the beginning of the manufacturing ID (a value of 0) or from the end
of the part number (a value of 1).

If this preference is not found, the last 40 characters of the manufacturing ID are used.

VALID VALUES

Any positive integers.

DEFAULT VALUES

40
1

DEFAULT PROTECTION SCOPE

Site preference.

ManufacturingIdCharsForPhysicalPartIdPref
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MROAlternateColorPref

DESCRIPTION

Specifies the color to use when displaying an alternate physical part.

VALID VALUES

The value can be a standard supported string, an octal number, or a hexadecimal number. The standard
strings supported are black, white, lightGray, gray, darkGray, red, pink, orange, yellow, green,
magenta, cyan, and blue. An example of a hexadecimal number is #50b080, which represents sea
green.

DEFAULT VALUES

cyan

DEFAULT PROTECTION SCOPE

Site preference.

B. SLM core preferences
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MRODeviatedColorPref

DESCRIPTION

Specifies the color to use when displaying a deviated physical part.

VALID VALUES

The value can be a standard supported string, an octal number, or a hexadecimal number. The standard
strings supported are black, white, lightGray, gray, darkGray, red, pink, orange, yellow, green,
magenta, cyan, and blue. An example of a hexadecimal number is #50b080, which represents sea
green.

DEFAULT VALUES

yellow

DEFAULT PROTECTION SCOPE

Site preference.

MRODeviatedColorPref
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MROExtraToDesignColorPref

DESCRIPTION

Specifies the color to use when displaying a physical part that is extra to design.

VALID VALUES

The value can be a standard supported string, an octal number, or a hexadecimal number. The standard
strings supported are black, white, lightGray, gray, darkGray, red, pink, orange, yellow, green,
magenta, cyan, and blue. An example of a hexadecimal number is #50b080, which represents sea
green.

DEFAULT VALUES

orange

DEFAULT PROTECTION SCOPE

Site preference.

B. SLM core preferences

B-14  As-Built Manager, Service Lifecycle Management 2412
© 2024 Siemens



MROMissingColorPref

DESCRIPTION

Specifies the color to use when displaying a missing physical part.

VALID VALUES

The value can be a standard supported string, an octal number, or a hexadecimal number. The standard
strings supported are black, white, lightGray, gray, darkGray, red, pink, orange, yellow, green,
magenta, cyan, and blue. An example of a hexadecimal number is #50b080, which represents sea
green.

DEFAULT VALUES

red

DEFAULT PROTECTION SCOPE

Site preference.

MROMissingColorPref
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MROSubstituteColorPref

DESCRIPTION

Specifies the color to use when displaying a substitute physical part.

VALID VALUES

The value can be a standard supported string, an octal number, or a hexadecimal number. The standard
strings supported are black, white, lightGray, gray, darkGray, red, pink, orange, yellow, green,
magenta, cyan, and blue. An example of a hexadecimal number is #50b080, which represents sea
green.

DEFAULT VALUES

blue

DEFAULT PROTECTION SCOPE

Site preference.
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PartLogisticsForm.SUMMARYRENDERING

DESCRIPTION

Determines the registration of the summary style sheet for part logistics form objects.

VALID VALUES

Accepts a string as a value. Each string must be a valid style sheet dataset object name.

DEFAULT VALUES

PartLogisticsFormSummary

DEFAULT PROTECTION SCOPE

Site preference.

PartLogisticsForm.SUMMARYRENDERING
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PartNumberCharsForPhysicalPartIdPref

DESCRIPTION

Specifies the number of characters to use from the part number when generating the physical part
item ID. The physical part item ID is a combination of characters from part number, serial number, and
manufacturing ID properties. The total number of characters for the physical part item ID should not
exceed 128 characters. The first entry in the preference is the number of characters to use from the part
number property for the physical part item ID. The second entry in the preference indicates whether to
use the characters from the beginning of the part number (a value of 0) or from the end of the part
number (a value of 1).

If this preference is not found, the last 40 characters of the part number are used.

VALID VALUES

Any positive integers.

DEFAULT VALUES

40
1

DEFAULT PROTECTION SCOPE

Site preference.
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PhysicalContext_relation_primary

DESCRIPTION

Specifies the valid primary object types list for the physical context relation.

Note:

All <relation_business_object>_relation_primary preferences are obsolete and are replaced by
relation properties. Use the Business Modeler IDE to create and manage relation properties.

For more information about relation properties, see Configure your business data model in BMIDE.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid Teamcenter object.

DEFAULT VALUES

PhysicalPartRevision

DEFAULT PROTECTION SCOPE

Site preference.

PhysicalContext_relation_primary
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PhysicalElement_Company_default_relation

DESCRIPTION

Defines the default relationship created when company object is pasted under a physical element class
object.

VALID VALUES

Accepts one or more strings as a value. Each string must be a valid Teamcenter object.

DEFAULT VALUES

PhysicalElementOwner

DEFAULT PROTECTION SCOPE

Site preference.
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PhysicalPart_Company_default_relation

DESCRIPTION

Defines the default relationship created when company object is pasted under a physical part.

VALID VALUES

Accepts one or more strings as a value. Each string must be a valid Teamcenter object.

DEFAULT VALUES

PhysicalPartManufacturer

DEFAULT PROTECTION SCOPE

Site preference.

PhysicalPart_Company_default_relation
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PhysicalPart_DefaultChildProperties

DESCRIPTION

Defines the list of properties that can be displayed as children of a physical part.

VALID VALUES

Accepts one or more strings as a value. Each string must be a valid Teamcenter property name.

DEFAULT VALUES

AllowedDeviation
IMAN_master_form
bom_view_tags
revision_list
IMAN_requirement
IMAN_manifestation
IMAN_reference
IMAN_MEView
IMAN_vi_sos
IMAN_external_object_link
PhysicalElementOwner
PhysicalPartManufacturer
TC_WorkContext_Relation
TC_AuditLog
TC_sst_record

DEFAULT PROTECTION SCOPE

Site preference.
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PhysicalPartRelationsToExport

DESCRIPTION

Defines the relations that are exported with a physical part when the physical part is secondary in the
relation.

VALID VALUES

Accepts one or more strings as values. Each string must be a valid relation class name.

DEFAULT VALUES

Values are added by dependent templates.

The asmaintained template adds the following value:

AssetContains

DEFAULT PROTECTION SCOPE

Site preference.

PhysicalPartRelationsToExport
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PhysicalPart.SUMMARYRENDERING

DESCRIPTION

Determines the registration for the physical part object's summary style sheet.

VALID VALUES

Accepts a single string as a value, which must be a valid dataset name.

DEFAULT VALUES

PhysicalPartSummary

DEFAULT PROTECTION SCOPE

Site preference.
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PhysicalPartRevision_DefaultChildProperties

DESCRIPTION

Determines the properties that can be used as children for the indicated type.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid Teamcenter relation object.

DEFAULT VALUES

PhysicalContext
PhysicalRealization

DEFAULT PROTECTION SCOPE

Site preference.

PhysicalPartRevision_DefaultChildProperties
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PhysicalPartRevision.SUMMARYRENDERING

DESCRIPTION

Registers the physical part revision object's summary style sheet.

VALID VALUES

Accepts a single string as a value, which must be a valid dataset name.

DEFAULT VALUES

PhysicalPartRevisionSummary

DEFAULT PROTECTION SCOPE

Site preference.
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PhysicalRealization_relation_primary

DESCRIPTION

Specifies the valid primary object types list for the physical realization relation.

Note:

All <relation_business_object>_relation_primary preferences are obsolete and are replaced by
relation properties. Use the Business Modeler IDE to create and manage relation properties.

For more information about relation properties, see Configure your business data model in BMIDE.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid Teamcenter object.

DEFAULT VALUES

PhysicalPartRevision

DEFAULT PROTECTION SCOPE

Site preference.

PhysicalRealization_relation_primary
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SerialNumberCharsForPhysicalPartIdPref

DESCRIPTION

Specifies the number of characters to use from the serial number when generating the physical part
item ID. The physical part item ID is a combination of characters from part number, serial number,
and manufacturing ID properties. The total number of characters for the physical part item ID should
not exceed 128 characters. The first entry in the preference is the number of characters to use from
the serial number property for the physical part item ID. The second entry in the preference indicates
whether to use the characters from the beginning of the part number (a value of 0) or from the end of
the serial number (a value of 1).

If this preference is not found, the last 40 characters of the serial number are used.

VALID VALUES

Any positive integers.

DEFAULT VALUES

40
1

DEFAULT PROTECTION SCOPE

Site preference.
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SerialNumberGenerator_DefaultChildProperties

DESCRIPTION

Specifies the properties list that can be used as children for the indicated type.

VALID VALUES

Accepts one or more stings as values. Each string must be a valid Teamcenter relation object.

DEFAULT VALUES

designItemTag

DEFAULT PROTECTION SCOPE

Site preference.

SerialNumberGenerator_DefaultChildProperties
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SerialNumberGenerator.SUMMARYRENDERING

DESCRIPTION

Registers the serial number generator objects' summary style sheet.

VALID VALUES

Accepts a single string as a value, which must be a valid dataset name.

DEFAULT VALUES

SerialNumberGeneratorSummary

DEFAULT PROTECTION SCOPE

Site preference.
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TransactionElement_Dataset_default_relation

DESCRIPTION

Specifies the default relation when a dataset is associated with a transaction element.

VALID VALUES

Accepts a single string as a value. It must be a valid Teamcenter relation business object.

DEFAULT VALUES

TC_Attaches

DEFAULT PROTECTION SCOPE

Site preference.

TransactionElement_Dataset_default_relation
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UtilizationViewColumnsShownPref

DESCRIPTION

Specifies the columns displayed in the Utilization view in left to right order.

VALID VALUES

Accepts one or more strings as values. The strings are property names from the utilization object.

DEFAULT VALUES

util_characteristic_name
util_unit
util_time_since_new
util_last_value
util_last_recorded_date

The asmaintained template adds the following value:

util_time_on_parent

The serviceeventmanagement template adds the following values:

util_time_since_repair
util_time_since_overhaul

DEFAULT PROTECTION SCOPE

Site preference.
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