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1. Resource Manager topics
About Resource Manager

About Resource Manager

• What is Resource Manager?

• Basic setup

Getting started

• Resource Manager interface, commands,
and buttons

• Working with Resource Manager views

• Displaying Resource Manager data

• Viewing images and datasets

• Searching for resources

Resource Manager processes

Creating resources

• Creating resources and
adding value for
downstream applications

• Creating new resources
based on existing ones

• Enabling, creating, and
opening tool setup sheets

• Automatically assembling
resources in Resource
Manager

• Leveraging MRL resources in
NX CAM

Adding vendor catalogs

• Using the Manufacturing Resource Library

• Using a tool vendor catalog

• Import GTC Package with 3D and mapping

• Import DIN Package

• Import tool vendor product data

• Import vendor catalog items with
connection codes

• Import vendor 3D models

• Cloud access to the Generic Tool Catalog in
Resource Manager

• Understanding the linking mechanism for
vendor data

Creating
,
viewing,
and
editing
manufac
turing
docume
ntation

• About
manu
factur
ing
docu
ment
ation

• Teamc
enter
Publis
h

Administration

Administering Resource
Manager

Administering Resource Manager continued

• Setting up and customizing setup sheets
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• Setting access rights

• Install NX templates

• Store the machining data
library in Teamcenter

• Synchronize attribute values
from NX to Teamcenter

• NX/Teamcenter attribute
mapping file

• Enable graphics creation

• Enable tool retrieval from
Teamcenter to NX

• Setting up site-specific properties to search
resources by site

• Setting up the NX search dialogs to include
new classification classes and attributes

• Manually extend the Classification hierarchy
with a new class

• Structure Manager alignment

• Preferences required for the Manufacturing
Resource Library

• Part Manufacturing BMIDE template

1. Resource Manager topics

1-2  Resource Manager on Rich Client, Teamcenter 2412
© 2025 Siemens



2. About Resource Manager
What is Resource Manager?

Resource Manager lets NC programmers, process planners, and tool designers store, modify, retrieve,
and manage resource data to create:

• Fixture assemblies, machine setups, and NC programs for machine tools, robots, and measuring
devices.

• Tool assemblies that combine machine tools and robots with their devices.

• Setup sheets for the complete operation.

Resource data can include classification information, Teamcenter items, and additional data such as
associated imported files and links to context information. You define the data using hierarchically
organized class definitions. Each class defines a set of values, or attributes, that typically specify
characteristics of an object.

Example:

The diameter, weight, and length of a tool.

Use class hierarchies to organize and search for your resources as a hierarchically organized collection
that is independent of product structure.

• Resource Management

• Tools

■ Assemblies

◊ Turning Tools

◊ Milling Tools

◊ Drilling Tools

Basic concepts

Use Resource Manager to:

• View resource components and their associated attributes using a variety of views or perspectives.
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• Create detailed classification structures of manufacturing data such as tools, machines, fixtures,
assemblies, and components.

• Create structured resource assemblies used in your manufacturing tasks, propagate component
attributes to your resource assembly, assign workflows to resources, and attach notes and graphics to
resources.

• Classify and search for resource assemblies and resources using the Teamcenter quick search, Object
ID search, or Classification Search Dialog.

• Create and edit manufacturing documentation to support rich work instructions and collaboration
between departments.

Basic setup

If you want to classify your resources, your classification administrator must have already created a
classification hierarchy in the Classification Admin application.

If you have trouble accessing Resource Manager, see your system administrator; it may be a licensing
issue.

To view formats other than GIF and JPG in the instance viewer, you must install Lifecycle Visualization.

2. About Resource Manager
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3. Getting started
Resource Manager interface, commands, and buttons

Resource Manager interface

1 Resource view Displays a tree hierarchy representing the logical built-up
structure of the assembly. The root node represents the
assembly itself. The subnodes are links to the components
that make up the assembly. All node names contain the
object ID and, optionally, a textual description that you can
use to identify the object.

2 Classification Properties view Displays attributes and values of the component selected in
the Resource view or the Classification Table view.

3 Class viewer Displays a class image of the selected object's class, if one is
attached to the class.

4 Instance viewer Displays an image or other document associated with the
selected instance.

5 Classification Table view Displays multiple search results in tabular form.
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Resource Manager menu commands

Menu command Purpose

File→New→Resource Creates the root node for a new resource in the Resource
view.

File→New→Dataset Creates a new dataset and attaches it to the selected object
in the resource structure. You can see the new dataset in the
Attachment view.

File→New→Workflow Process Creates a new workflow process with attachments and an
associated process template and allows you to assign tasks
to specific users.

File→Search→Search by
Classification Dialog

Opens the Classification Search Dialog to help you find a
classified resource. Results are displayed in the Table view.

File→Search→Search by ID Runs an object ID search that searches through the entire
database for the specified resource and opens the results in
the Classification Table view.

File→Close Closes the Resource Manager application.

File→Open Opens the selected object.

File→Save As Saves the selected item revision as a new revision with a
new name and a revision ID.

File→Revise Creates a new item revision of the selected line.

File→Revise (incl. Super-Assemblies Revises a component including all latest revisions of super-
assemblies containing that component.

File→Unload All Closes all structure panes and unloads them from Resource
Manager.

File→Exit Closes the Teamcenter application.

Edit→Cut Cuts the selected lines from the resource and places them on
the clipboard.

Edit→Copy Copies the currently selected resource to the clipboard.

Edit→Paste Pastes the contents of the clipboard underneath the
currently selected resource.

Edit→Delete Deletes the current resource from the database.

Edit→User Setting Changes your group, role, or volume assignments, and your
application logging and journaling options.

Edit→Options Changes user interface settings that affect all applications.

3. Getting started
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Menu command Purpose

Edit→Edit Resource Activates edit mode so you can make changes to the current
resource.

Edit→Save Resource Saves the current resource.

Edit→Cancel Edit Returns the display to show mode by canceling edit mode
and deleting all changes made in the edit session.

Edit→Delete ICO for current resource Deletes the classification object from the selected resource.
This does not delete the item.

Edit→Add Classified Component Opens the Classification Search Dialog so you can add a new
component to the current resource.

Edit→Guided Component Search Runs a guided component search.

Edit→Remove Removes the current line from the resource. This does not
remove the component from the database.

View→Show/Hide CSYS Lines Displays and hides the coordinate system lines in the
structure.

View→Show GCS Connection Points Displays and hides the plug and socket symbols from which
you can start a guided component search. You can choose to
display all connection points or only those that are not yet
connected to a component.

View→Properties Views and edits all properties of the selected line.

View→Notes Views and edits all notes for the selected line.

View→Pack Packs the selected lines so that all lines with the same item
revision and find number are displayed as a single line. The
actual quantity of lines is appended to the node.

View→Unpack Unpacks the selected packed lines so that they are displayed
as separate lines, one for each occurrence.

View→Propagation Start Point Assigns a propagation start point to the currently selected
resource. Attributes are propagated from the propagation
start point up the hierarchy to the root of the structure. Only
one propagation start point is allowed per structure.

If you choose this menu command a second time, the
propagation start point is removed.

View→Refresh Window Reads information from the database and updates the
information displayed in the workspace area.

View→Expand Below Expands the complete substructure below the selected lines.

Resource Manager menu commands
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Menu command Purpose

View→Collapse Below Collapses the complete substructure below the selected lines
(hides all child lines).

Tools→Project→Assign Assigns the selected structure to a predefined project.

Tools→Project→Remove Removes the selected structure from a project to which it is
assigned.

Tools→Revision Rule→View/Set
Current

Views or sets the revision rule for the currently displayed
structure.

Tools→Revision Rule→Set Date/
Unit/End Item

Sets the date, unit number, or end item to configure the
structure, if the current rule allows.

Tools→Revision Rule→Set Override
Folder

Sets an override folder to override item revisions that would
otherwise be selected by other criteria.

Tools→Revision Rule→Modify Modifies the current revision rule and applies the modified
rule to the current structure. You can save the change if you
have write access to the original rule.

Tools→Revision Rule→Create/Edit Creates or edits a revision rule.

Tools→Import Imports objects into the database using PLM XML format.

Tools→Export Exports the selected structure and its attachments in PLM
XML format to a selected export directory. You must choose
the appropriate transfer mode for the destination system

Tools→Create Graphics Creates graphics based on a part family template or Tcl
macro.

Tools→Import catalog 3D model for
current resource

Imports a STEP 3D model from a vendor tool catalog.

Tools→Create/Update NX Tool
Assembly Part File

Creates or updates the NX tool assembly part file after you
create a tool assembly.

Tools→Map ICO Maps a resource from one class to another.

Tools→Create Item for ICO Creates an item for a classification object. Choosing this
menu command automatically classifies the new item.

Tools→Classify Item Classifies the item of the selected line, if it is not already
classified.

Tools→Classify Item Revision Classifies the selected item revision, if it is not already
classified.

3. Getting started
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Menu command Purpose

Note:

The Graphics menu appears only if you open the Graphics view.

Graphics→Selection→Select All Selects all the objects displayed in the viewer.

Graphics→Selection→Select None Clears any objects currently selected in the viewer.

Graphics→Selection→Reverse
Selection

Selects all objects not selected in the viewer, while
simultaneously unselecting any objects currently selected in
the viewer.

Graphics→Visibility→View Selected Blanks and unblanks objects loaded in the viewer.

Note:

The term loaded refers to an object whose JT file has
been loaded in the viewer. A loaded object may or may
not be visible, depending on whether it is blanked or
unblanked.

Graphics→Visibility→Blank Selected Makes any objects selected in the viewer invisible.

Graphics→Visibility→Blank All Makes all objects in the viewer invisible.

Graphics→Visibility→Unblank All Makes all objects loaded in the viewer visible.

Graphics→Visibility→Reverse Blank
All

Makes any currently visible objects invisible, while
simultaneously making visible any loaded objects that are
currently invisible.

Graphics→Visibility→Unload
Selected

Unloads any objects selected in the viewer.

Graphics→Edit Color/Translucency Modifies the color, transparency, and shine of selected
objects in the viewer. These settings only apply to the
currently loaded objects. The next time the edited object
is loaded, the settings revert to the default color and
translucency.

Graphics→Insert Allows you to insert JT, stereolithography (.stl) and VRML
(.wrl) files as reference graphics.

Graphics→Insert→Insert from File Inserts a reference graphic from the operating system, using
the Open by Name dialog box.

Graphics→Insert→Insert from
Clipboard

Inserts a reference graphics object from the clipboard.

Resource Manager menu commands
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Menu command Purpose

Note:

Only item revisions (not items) can be displayed as
reference graphics.

Graphics→Views→View Control Creates, edits, and displays standard views, using the Rotate
and Standard Views dialog boxes.

Graphics→Draw Children Displays the components of a subassembly. You can also
access this command if you right-click in the BOM.

Graphics→Show Subcomponents Breaks down solids in the corresponding monolithic JT files
and make the subcomponents independently controllable.
This function is available only for leaf and unpacked BOM
line nodes.

Graphics→Hide Subcomponents Removes all merged subcomponents and the one-level tree
from the tree. You can load or unload the monolithic JT file
related to this structure line node in the normal way.

Graphics→Export 3D File Exports the current visible objects to a STEP or VRML file.

Graphics→Replace JT File Replaces the JT file that represents an item revision. You can
choose a replacement file from one of the JT files associated
with the current structure line item.

Graphics→Clearance→ Preferences Sets clearance analysis and preferences.

Graphics→Clearance→Toggle Results
Window

Shows clearance results in a separate window.

Graphics→Performance Sets rendering, culling, and general performance
preferences.

Graphics→Preferences Sets clearance analysis and general viewer preferences.

The following menu commands are shown in the view menu of the primary resource view.

Menu command Purpose

Show Graphics Opens the Graphics view that displays visualization data
associated with the selected structure. The Graphics view
remains associated with the primary view from which it is
opened.

Show Information Displays configuration information about the open
structure.

3. Getting started
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Menu command Purpose

View/Set Current Revision Rule Views or sets the revision rule on the currently selected line.

Set In Context Enables you to set the currently selected structure as the
context for additional information set on child objects. For
example, you can add an occurrence note to a child line
in the structure that is only pertinent in the context of the
currently selected structure line.

Unload Unloads the current structure.

Show/Hide CSYS Lines Displays and hides the coordinate system lines in the
structure.

Show/Hide GCS Connection Points Displays and hides the plug and socket symbols from which
you can start a guided component search. You can choose
to display all connection points or only those that are not yet
connected to a component.

Show Suppressed Occurrences Displays and hides lines that are hidden by
variant settings, configuration, or explicitly setting the
bl_occ_is_suppressed property.

Resource Manager buttons

Button Description

If enabled, allows you to terminate the current operation without closing
Resource Manager or losing data.

Cuts the selected lines from the resource and places them on the clipboard.

Copies the currently selected resource to the clipboard.

Pastes the contents of the clipboard underneath the currently selected
resource.

Deletes the current resource from the database.

Creates new resource.

Activates edit mode so you can make changes to the current resource.

Saves the current resource.

Returns the display to show mode by canceling edit mode and deleting all
changes made in the edit session.

Deletes the classification object from the selected resource. This does not
delete the item.

Resource Manager buttons
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Button Description

Classifies the item of the selected line, if it is not already classified.

Classifies the selected item revision, if it is not already classified. Note

Opens the selected resource in new Resource view.

Opens the Classification Search Dialog so you can add a new component to
the current resource.

Runs a guided component search.

Removes current line in resource. This does not remove the component
from the database.

Assigns a propagation start point to the currently selected resource.
Attributes are propagated from the propagation start point up the hierarchy
to the root of the structure. Only one propagation start point is allowed per
structure.

Adds notes to the currently selected resource.

Maps a resource from one class to another.

Creates graphics based on part family template or Tcl macro.

Imports 3D data from a vendor catalog for the currently selected
component.

Creates or updates the NX tool assembly part file after you create a tool
assembly.

Opens the Classification Search Dialog to help you find a classified resource.

Runs an object ID search that searches through the entire database for the
specified resource and opens the results in the Classification Table view.

Lists the most recently used resources.

The following buttons are found in each Resource view.

Opens the Graphics view to display visualization data associated with the
selected resource.

Displays configuration information about the open resource.

The following buttons are found in the Classification Table view.

Assists you in moving back and forth between search results in the
Classification Table view. You can either move using the navigation
buttons or type a value in the box.

3. Getting started
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Classification Search Dialog buttons

Button Description

Opens the Classified Object Type dialog box where you can filter your
search to only include classifying objects, non-classifying objects, or objects
of a specific type.

Searches the hierarchy tree for the class that you enter in the adjoining box.

Active unit: Sets the active unit of measurement. If you are paging through search
results, this button indicates if the currently displayed ICO is saved in a
different unit than is active. Click this button to convert the ICO attribute
values between systems of measurement. This button has several states:

•

The attributes are displayed and stored in a metric system of
measurement.

•

The attributes are displayed in a metric system of measurement but are
stored in a nonmetric system and are converted for display.

•

The attributes are displayed and stored in a nonmetric system of
measurement.

•

The attributes are displayed in a nonmetric system of measurement but
are stored in a metric system and are converted for display.

Searches for all class members in the class selected in the hierarchy tree.

Removes all entries from the attribute boxes on the Properties tab.

Displays only the attributes relevant to the selected applications.

Highlights attributes relevant to the selected applications in bold and
displays the application symbol beside the attribute.

Displays attributes relevant to NX CAM.

Changes the search scope to either search in the selected class and all its
children in the hierarchy or in the selected class only.

Resource Manager buttons
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Button Description

Specifies in which unit of measure you search. You can search in one of the
following:

• Classes containing only the currently active system of measure.

• Classes containing both metric and nonmetric values.

Maps the ICOs from one class to a different class.

Searches for the corresponding class in a source structure. Use this button
when you are filling a target (for example, customer) hierarchy with
components from a source (for example, catalog) hierarchy.

Imports 3D data from a vendor catalog for the currently selected
component.

Copies the data selected in the table to the clipboard.

Sends the table data to the printer.

Helps you navigate the search results through paging forward or backward
or jumping to the beginning or end of the results.

Creates graphics based on part family template or Tcl macro.

Loads the next page of search results.

Loads all the search results

Stops loading the search results.

Working with Resource Manager views

Overview of views in Resource Manager

Resource Manager allows you to view a resource structure and all the attributes associated to each
line in the structure. You can open multiple resources simultaneously. Teamcenter presents Resource
Manager data in views, each view providing its own specific way of managing or modifying the data. Use
the views to the right of the resource view to display additional information about the open resources
and their components. There are primary views and secondary views.

• A primary view contains data for which details are displayed in secondary views. Resource Manager
displays two types of primary views: the Resource view and the Classification Table view.

• A secondary view shows specific types of data related to the primary resource view with which it is
associated. It can, depending on your needs, change its content if you select a new resource view.
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In addition to primary and secondary views, you can use the Graphics view to display any visualization
data associated with the structure. The Graphics view is closely associated with the primary view from
which you open it.

You can open multiple structures simultaneously. You can undock views and move them to a convenient
position. You can open the same structure multiple times in different views. To assist you in tracking
which views are associated, primary views and secondary views are color-coded. Primary and associated
secondary views have the same framed color. In addition, Teamcenter frames the active view (the one in
which you are currently working) in black.

Each view has a toolbar with buttons to execute the common tasks pertaining to that particular view.
The view menu contains additional menu commands pertaining to that view. More complex tasks or
tasks pertaining to several views simultaneously are found on the main application toolbar. The views
have some features in common, such as the ability to change the displayed columns or filtering the
results. You find these features in the view menu.

Understanding selection synchronization

If you select an object in the active view, the selections in the other views change as follows:

• Primary views can change their inner selection (highlight) to suit the active selection. This does not
happen if the selection does not correspond to any object in the view.

• Secondary views can change their inner selection (highlight) to suit the active section when that
selection occurs in a primary view or in another secondary view that is associated to the same primary
view. The following situations can cause them not to do so:

• The selection does not correspond to any object in the view.

• The Disable response to selections button  is available.

Open the Graphics view

The Graphics view is associated with the structure view from which you open it. You cannot change this
association.

• In a structure view, click .

Teamcenter opens the Graphics view displaying the structure. The Graphics menu is displayed in the
main menu bar if there is at least one Graphics view open.

• When you close the primary view from which you opened the Graphics view, the Graphics view
also closes.

• If you unload data from the primary view, the Graphics view remains open, but empty.

Understanding selection synchronization
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• If you load a new structure into the primary view, the Graphics view is available, but the structure
is only loaded when you select a structure to view.

Display configuration information for the resource view

Do one of the following:

• Click  in a primary structure view to see configuration information about that structure.

The Configuration Information dialog box displays the following:

• Ensure that the MEShowConfigurationHeader preference is set to true. This displays the current
revision rule, effectivity, and variant rule at the top of the structure view.

Working with the Classification Table view

The Classification Table view displays the results of the object ID search in tabular form. You can
navigate through the search results and more details about each instance is displayed in other views.
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• Click a line in the table or move from line to line with the arrows to view the properties in the
Classification Properties view.

• Double-click a line to open the resource in the Resource view. Only classifying instances can be
opened in the Resource view.

Resource Manager views and tabs

• The Resource view displays the assembly structure of the currently open resource. This is a primary
view. It contains one configurable structure. You can open multiple resources in separate Resource
views.

• The Classification Properties view displays:

• Textual attributes and values of the selected component.

If the selected component is the root node of the resource structure, the attributes assigned to the
assembly class are displayed in this view. Any attributes that are populated to the assembly level
from individual components within the structure are displayed with italic font. The values that are
input into these attributes can vary depending on the location of a propagation start point within
the structure.

For propagated attribute values to be available, your administrator must mark the values as
Propagated when creating the assembly class in the Classification Admin application.

• A class image of the selected object's class, if one is attached to the class. This image is displayed
in the upper-right corner of the view in the class viewer. It is usually a schematic drawing of the
objects in the selected class.

• An image or other document associated with the selected instance. This image or document
is displayed in the lower-right corner of the view in the instance viewer. The instance viewer
displays documents attached to the classified workspace object of the selected ICO, such as BOM
assemblies, monolithic JT files, Word documents, or GIF images. If the attached image is a JT file,
you can manipulate the image in the instance image window using rotate, pan, zoom, and other
functions.

Note:

For the viewer to work, you must have the Teamcenter Visualization for Rich Client software
installed. If you have not installed this viewer, only image files (for example, JPG or GIF) are
displayed in the top viewer window.

The information displayed in the Classification Properties view is determined by the type of object
selected in the assembly structure displayed in the Resource view to which the Classification
Properties view is associated.

• If you select a component, all attributes of the component are shown.

Resource Manager views and tabs
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• If you select the root node, the attributes of the assembly are shown. For assemblies, these
attributes can consist of:

■ Base attributes assigned to the assembly.

■ Propagated attributes that have been propagated to the assembly from components within the
assembly. Propagated attributes are displayed in italic.

• The Classification Table view presents the results of an Object ID search or multiple results from the
Classification Search Dialog in tabular format. You can page through these results, or double-click a
resource to open it in a Resource view.

• The Attachments view displays any revisions or attachments of the resource object currently selected.
This view contains the same revision and attachment information that is available in the My
Teamcenter application.

• The Impact Analysis view identifies any other database objects that reference the selected resource
object.

This view also displays any assemblies in which the selected object appears.

• The Report view allows you to create reports with Report Generator.

• The Work Instructions view allows you to create manufacturing documents such as work instructions
or product manuals and to view and edit existing documents.

Additionally, the Classification Search Dialog contains the following tabs and panes:

• The Hierarchy pane displays the classification hierarchy.

• The Graphical Browser tab shows a hierarchy of the tree structure symbols and allows you to enlarge
them easily with a slider. You can switch back and forth between the tree structure in the Hierarchy
tab and the graphical browser.

• The Search tab allows you to enter search criteria to help find a required resource.

• The Properties tab allows you to enter search criteria to help find a required resource.

Displaying Resource Manager data

Displaying the hierarchy in the Classification Search Dialog

The classification hierarchy shows a tree structure of nested classes. It provides an overview of all
classification classes contained in the database. These classes contain a compilation of attributes related
to a group of objects.
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1. Click Search by Classification Dialog or ID  to open a resource that already exists in the
database.

-or-

Click Add component to the resource  to add a component to an existing resource assembly.

2. Double-click the root node of the hierarchy.

3. Move down the hierarchy by clicking the plus sign (+) in front of the name of the class you want to
open. You can right-click any class and choose Expand All to open all child classes.

Change the display of the hierarchy

When you first expand the classification hierarchy, the class names include a number in brackets beside
them. This number represents the number of instances contained within that class and all its subclasses.

The number of instances displayed represents all instances in the database, including both metric and
nonmetric ICOs, as well as ICOs to which you do not have read access.

• If you search for only metric or only nonmetric instances, the number of matches is smaller if your
database contains instances in both systems of measurement.

• Teamcenter does not check for read access to ICOs until you perform a search. For this reason, a class
can display 100 instances in the hierarchy, but when you search the class, you find only 80 matches.
This is because you do not have read access to the other 20 ICOs.

Change the display of the hierarchy

Resource Manager on Rich Client, Teamcenter 2412  3-15
© 2025 Siemens



You can specify when the ICOs are filtered for read access in the ICS_search_filter_by_read_access
preference.

You can additionally or alternatively display the groups and classes.

• Right-click the root node of the classification hierarchy and choose Show Node IDs.

To turn off the display of the instance count, right-click the root node of the classification hierarchy and
choose Show Instance Count.

Display information in the Properties pane

You only see information in the Properties pane once you select a class in the hierarchy.

• Double-click a storage class in the hierarchy.

• Right-click a class from the hierarchy and choose Select.

Display information in the Table pane

The Table tab is not available until you select a class in the hierarchy and search for ICOs in the
Properties pane.

1. Double-click a storage class in the hierarchy.

2. Right-click a class from the hierarchy and choose Select.

3. Getting started

3-16  Resource Manager on Rich Client, Teamcenter 2412
© 2025 Siemens



3. Search for the desired ICOs.

4. Click the Table tab.

Teamcenter lists the first five matches in the Table pane.

Working with measurement units

Measurement units overview

Classification classes can contain only metric ICOs, only nonmetric ICOs, or both. If your Classification
administrator specifies that a class can contain both, you can search for an object using either of the unit
systems you define, and the search mechanism finds a match, regardless of the unit in which the object
is stored. For example, if you search for a bolt with a width of 5/8th inches, the classification search
mechanism finds a bolt that is stored with a width of 1.6 centimeters.

Teamcenter displays the unit of an attribute value as a hyperlink beside the value. You can change this
unit for viewing or searching purposes. If a unit is not hyperlinked, Teamcenter cannot find the unit in
the Unit Definition class. If the attribute is not yet used in any classes, the classification administrator
can change the unit in the attribute dictionary or add the new unit definition to the Unit Definition
class.

The unit in which you save an ICO is referred to as the storage unit. Teamcenter displays the storage unit
in bold type in the list of available units.

When working with legacy data, Classification searches for the object ID of the unit or, if it does not find
that, the display name. If it finds a match, then it displays the hyperlinked unit label. If Teamcenter does
not find a match, it displays the legacy unit label that you cannot change.

Tip:

Type the unit in the attribute value box along with the value. Teamcenter changes the unit for you
automatically.

If your administrator enables optimization for attribute values, these are displayed using the most
readable unit with the least number of leading or trailing zeros.

Change the active measurement system

When displaying ICOs in the Properties pane (view mode), you can change the measurement system
that is displayed.

• Click the Active unit button and select the measurement system.

Measurement units overview
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Note:

You can do this only if your administrator has specified that the class can contain both metric and
nonmetric values.

Change the displayed units of measure

You can change the displayed unit of measure; Teamcenter converts these values for you. Teamcenter
distinguishes internally between show mode and edit mode during this activity. You can only change
the displayed units of measure in show mode. If you are in edit mode, Teamcenter changes the value
you enter.

• Click the hyperlinked measurement unit and select a new unit.

• If you are in show mode, Teamcenter immediately converts the unit for display purposes.

• If you are in edit mode, Teamcenter assumes you want to change the attribute value. It first
internally converts the value you enter to the storage unit, and then converts to the desired unit.

If the storage unit is formatted in such a way that this conversion cannot take place (for example,
not enough decimal places), Teamcenter cannot continue with this conversion and an error
message occurs. If, for example, you are editing the following value, and want to enter the value in
m, not mm, you cannot simply change the unit from mm to m as in show mode.
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If you attempt to do this, Teamcenter tries to convert 40 meters to the storage unit, which is
millimeters. This results in a very large value of 40,000 millimeters. Because the mm storage unit
specifies that this unit can only have three decimal places before and after the zero, Teamcenter
cannot complete the conversion and displays the following error message:

The entered value 40 m (40000 mm) cannot be formatted with the REAL(3,3) format 
because there are too many digits before the decimal point.
The attribute can have a value of 0 or a range between 0.001 and 999.999 mm.
Note:
The attribute's storage unit is mm. During conversion, values are first converted 
to mm.

Instead, enter the value with the correct unit. In this case, that is 0.04m.

Caution:

Teamcenter always converts between the metric and nonmetric formats that you specify in
the attribute dictionary. If, during conversion, the converted value’s number of digits is larger
than the specified target format allows, Teamcenter truncates the excess digits and displays
an erroneous value. For example, an attribute has a nonmetric format with REAL(3.5) and
a metric format of REAL(4.3). If you try to convert 622 inches to a metric value, the correct
converted value is 15,800 millimeters. Teamcenter, however, truncates the converted value
to 1580 to fit the defined format (REAL(4.3)).

If a class is set to both (metric and nonmetric), and if any of the attributes do not have a unit definition
for both metric and nonmetric, Teamcenter uses the available unit for both unit systems. This behavior
supports use cases where certain attributes may not have different metric and nonmetric units, such as
time.

Viewing the Unit Definition class

The Unit Definition class contains all the units available for attribute definition in the Classification
Admin application. Only an administrator should change this class.

Searching in multi-unit classes

If the active unit of measurement is metric, you can search for a nonmetric ICO using metric attribute
values, and vice versa. Teamcenter converts the value to the other unit system and performs the search.
When you do this, however, you must be aware of the following information.

Viewing the Unit Definition class
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For the search to find an ICO with a particular attribute value, the value must be an exact match.
Because Teamcenter converts the value to the other unit system, be sure to enter enough digits after the
decimal point to avoid rounding errors.

Make the panes larger or smaller

• Click Maximize/Restore panel  on the right side of the pane's title bar.

View the tree graphically

You can use a graphical browser to navigate through the classification hierarchy. This browser shows
a hierarchy of the tree structure symbols and allows you to enlarge them easily with a slider. You can
switch back and forth between the tree structure and the graphical browser. The class that is currently
highlighted in the graphical browser is then highlighted in the tree and vice versa. If you select a class in
the hierarchy tree, it is also selected in the graphical browser when you open it.

1. Turn on the graphical browser using the ICS_enable_graphical_browser preference.

2. In the hierarchy pane, click the Graphical Browser tab.

3. Navigate through the classes.

The graphical browser shows two sets of graphics. The top set, a horizontal list of graphics, is the
hierarchy list. This represents the path you have taken down the classification tree from parent to
child node. The second set of graphics represents all the members of the current class, that is,
the last class shown in the hierarchy list. Leaf classes are displayed with a blue border around the
graphic.

• To move one level down in the tree, click the graphic.

• To move one level up the tree, click the second-to-the-last graphic in the list of graphics at the
top.

• To select a class, click the link below the graphic of the class you want to open. If the class you
are selecting is a leaf node, clicking the link also selects it.

• To move to any class in the hierarchy list, click the class.

• To select a leaf class (a graphic with a blue border), click the class or click the link below the
graphic.

4. Modify the graphic size by moving the slider at the right of the browser pane to the right to enlarge
the graphics and moving it to the left to make them smaller.
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Viewing attribute values

Attributes are placeholders for values that distinguish one instance of a class from another. For
example, within the Sheet Metal Screws class, the length, diameter, and thread attributes are used
to distinguish one sheet metal screw from another. Attributes and their values are displayed in the
Properties pane.

In addition to the list of attributes that is displayed when you select a class, your administrator may have
added custom attributes that are listed in a tool tip in the Properties pane.

There may be restrictions set by your administrator on what attribute values you can modify or what
values you can enter. For example, an attribute value may not be modifiable because your administrator
has set a default value, or you can only enter attributes between a certain range. In addition, the display
of the values can be changed. For example, by modifying the ICS_display_unformatted_numbers
preference, you can add or remove the leading zeros.

Teamcenter provides you visual aid to see the restrictions set on an attribute. If you are in edit mode, you
may see the following indicators.

Symbol Restriction

Attribute property is set to Protected or a
default value is set to Fixed.

Attribute property is set to Mandatory.

Whether you can save an ICO without setting
mandatory attribute values is controlled by
the ICS_force_mandatory_attribute_check
preference.

Attribute property is set to Mandatory and
Protected.

Attribute value is set to Auto Computed.
Note the gray frame. This value is calculated
automatically based on external logic.

Attribute value is displayed in centimeters.
To display the value in a different unit, click
the unit and select the desired display unit.
This does not change the storage unit in the
database.

If the unit is not hyperlinked, it means that
Teamcenter cannot find the given unit in the
Unit Definition class.

Notice that the cm entry is in bold type.
This indicates that the storage unit for this
attribute is centimeters.

Viewing attribute values
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Symbol Restriction

Tip:

Type the unit in the attribute value
box along with the value. Teamcenter
changes the unit for you automatically.

Attribute value is restricted to a specific
range.

Attribute value falls outside of allowable
range.

Key-LOV value 03 No Trans Guns is
deprecated and should no longer be used.

Attribute value is localized. Click  to enter
or view values in other supported languages.

Preview available attribute values

You can activate a filter that allows you to preview those attribute values available in the currently
selected class. This is especially useful when you are searching as you can select an existing value and
search for it.

Note:

The autofilter is not displayed for reference attributes.

1. Select a class in the classification hierarchy.

Teamcenter displays the attributes in the Properties pane.

2. Click the Autofilter button.

Teamcenter displays the List of Values dialog box containing a list of attribute values stored for this
attribute. When you search, all attribute values stored for this attribute are displayed, provided you
have not yet set any other attribute values. As you constrain your search criteria by setting other
attribute values, the List of Values dialog box only shows the attribute values that are valid given
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the current search criteria (helping you efficiently narrow your search and choose valid values that
will find classified objects).

The attribute preview indicates whether the value is stored as a metric  or nonmetric  unit.

3. Do one of the following:

a. Select a value and click ok.

Teamcenter closes the List of Values dialog box and populates the attribute value box with
the selected value.

Note:

If you are in search mode and use the autofilter on string attributes, Teamcenter places
the value in quotation marks. This way, you can use dashes inside the attribute values,
and they are not interpreted as a range.

b. Click clear.

Teamcenter closes the List of Values dialog box and removes any value that was in the
attribute value box.

c. Click cancel.

Teamcenter closes the List of Values dialog box without making any changes to the attribute
value box.

Preview available attribute values
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Displaying a subset of the hierarchy

Set a node as root

In a complex classification hierarchy, you can select any point in the hierarchy and set that node as the
root node, blending out all the node's ancestor classes and groups. You can store any number of classes
in the options list to change the hierarchy root node at your convenience.

1. In the title bar of the hierarchy pane, click  to display the root node selection. By default,
this list contains only Classification Root. You can configure the entries in this list in the
ICS_default_root_selector_entries preference.

2. Select the node that you designate as the new root node in your classification tree.

Teamcenter displays the name and symbol of the new root class in the title bar.

3. (Optional) Display the full tree again by selecting Classification Root from the options list.

Store nodes for subsequent selection as root

1. Select the class in the hierarchy that you want as the new hierarchy root node.

2. In the title bar of the hierarchy pane, click  to display the root node selection list.

3. Choose Add Current Class.

- or -

1. Modify the entries in the ICS_default_root_selector_entries preference.

These entries are then available the next time you open the root node selection list.

Delete stored nodes from the list

1. In the title bar of the hierarchy pane, click .

The root node selection list appears.

2. Right-click the class that you want to remove from the list and choose Remove.

Display a node as temporary root

1. Right-click the class in the hierarchy that you want as the temporary hierarchy root node and
choose Set Root Node.
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Teamcenter displays this class as the root node but does not add the class name to the root node
selection list.

2. (Optional) Return to viewing the complete tree by selecting Classification Root from the root node
selection list.

Refresh the hierarchy tree

The classification hierarchy does not always update automatically. In certain situations, such as the
following, you must update the tree manually:

• A class is moved to a new group or to see a change to the hierarchy.

• Objects are classified. The ICO count does not update automatically.

To manually refresh the classification hierarchy:

• Right-click the root node or affected branch, and choose Refresh.

Teamcenter refreshes all branches beneath the selection, as well as the selection itself.

If you add attributes in Classification Admin to a class that you are currently viewing in Classification,
you must refresh the class in Classification using the Refresh button or by selecting another class and
returning to the viewed class to see the newly added attributes.

Note:

The Refresh menu command is not available if you are in edit mode.

View object properties

1. In the Table pane, select an ICO that classifies a workspace object.

2. Click the Properties button .

Teamcenter opens the Properties form displaying the properties of the selected workspace object.

3. (Optional) Check the form out of the database to modify it.

Refresh the hierarchy tree
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View attributes applicable to a specific application

In some cases, you may want to highlight a specific set of attributes that are relevant to a particular
application. If a class contains a long list of attributes, it is often not easy to spot these attributes in
the Classification Properties view or the Search pane of the Classification Search Dialog. You can view
which attributes are relevant to a particular application if this feature is enabled in the Classification
Admin application. You can choose to mark all relevant attributes or, additionally, you can hide attributes
that are not relevant. Alternately to highlighting attributes, you can filter the display of the attributes so
that only the applicable attributes are visible.

Your administrator enables applicable attributes in the Classification Admin application.

1. In the Classification Properties view or the Search or Properties pane, click the button
representing the application for which you want to see the relevant attributes.

Teamcenter displays the application symbol beside each of the relevant attributes and highlights
the attributes in bold.
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You can click more than one application button.

2. Switch between highlighted and filtered attributes.

•

View attributes applicable to a specific application
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The attributes that are pertinent to the selected applications are highlighted in bold and the
application symbol is shown beside them.

•

The attributes are filtered so that only the attributes relevant to the selected applications are
visible.

Understanding show versus edit modes

Classification distinguishes between show mode and edit mode when working in Classification.

Show mode You cannot edit the object. The Save button is unavailable.

Edit mode You can make changes to the object’s attributes. The Save button is available to save
these changes.
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Teamcenter sometimes behaves differently, depending on whether you are in save mode or edit mode.
For example, when working with measurement units, you can change the displayed unit in show mode,
but if you make the same changes in edit mode, you change the attribute value.

Viewing images and datasets

Viewing images and datasets associated with the workspace object

Resource Manager allows you to view images and other types of file-based data associated with a
specific class or ICO. There are two viewers in the Classification Properties view that allow you to see
this data.

• Class viewer

Shows an image associated with a class.

• Instance viewer

Shows documents or images associated with the classified workspace object (for example, item or
item revision) of the ICO. This includes a multitude of data types, such as GIF or JPEG images, JT
image files, HTML files, Microsoft Office documents, or NX part files.

Note:

For the viewer to work, you must have the Teamcenter Visualization for Rich Client software
installed. You must purchase this software separately. If you have not installed this viewer, only
image files (for example, JPG or GIF) are displayed in the top viewer window.

To enlarge the viewers to full-tab size, click the Maximize/Restore Panel button . Clicking this button
again restores the pane to its original size.

Viewing class images

Class images show an overview of the currently selected class. These are shown in the class viewer that
appears in the upper right corner of the Classification Properties view. You associate these images with
the class from within the Classification Admin application.

The g4mClassViewer.VIEWERCONFIGTOLOAD preference specifies which type of viewer is
used to display different types of attachments. By default, this preference points to the
g4mViewerConfig.VIEWERCONFIG preference that contains a list of viewers and attachment types.

Viewing documents associated with an ICO

The instance viewer, located at the bottom right of the Classification Properties view, allows you to
see documents attached to the classified workspace object of the selected ICO, such as BOM assemblies,

Viewing images and datasets associated with the workspace object

Resource Manager on Rich Client, Teamcenter 2412  3-29
© 2025 Siemens



monolithic JT files, Word documents, or GIF images. These documents are attached to the workspace
object as a named reference in a dataset.

The documents available for viewing display as tabs at the side of the viewer. Only those documents that
the viewer is able to display appear as tabs.

The following table lists some of the tabs the viewer displays.

Tab Description

Opens a GIF image.

Opens an NX part file.

Opens a JT file.

Opens a Microsoft Word document.

Opens an assembly.

Move the cursor over the tab; the tool tip tells you what document is available.

Note:

The instance viewer is functional only if you have installed Teamcenter Visualization for Rich
Client.

You can alter the behavior of the instance viewer using the following preferences:

• ICS_presented_instance_documents contains a list of those named references you want to have
available for the viewer to display. The system searches through all datasets of the workspace object
for these named references and presents a tab for each one.

• ICS_default_instance_document controls which of the available documents is displayed by default
when you view an ICO. Using this preference, you can, for example, specify that assembly JT files
are not shown by default but must be expressly selected to appear. This can save time when
paging through ICOs of large assemblies. If none of the document types listed in this preference
are associated with the ICO, the viewer displays no attachment. It can still, however, contain tabs for
other available documents.

• ICS_max_number_of_components controls the number of assembly components to be shown
without warning.

• g4mInstanceViewer.VIEWERCONFIGTOLOAD specifies which type of viewer is used to
display different types of attachments. By default, this preference points to the
g4mViewerConfig.VIEWERCONFIG preference that contains a list of viewers and attachment types.
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To view NX parts in the instance viewer, add the following values to the
g4mViewerConfig.VIEWERCONFIG preference:

UGMASTER.DirectModelViewer=UGPART

UGPART.DirectModelViewer=UGPART

Tip:

To ensure that the instance viewer displays the same attachments as the Teamcenter viewer,
you can set the value of the g4mInstanceViewer.VIEWERCONFIGTOLOAD preference to
defaultViewerConfig.VIEWERCONFIG. If, however, you have added any special attachment
types to the instance viewer g4mViewerConfig.VIEWERCONFIG preference, you must also add
these types to the defaultViewerConfig.VIEWERCONFIG preference.

Note:

The symbols used for these tabs are found in
com\teamcenter\rac\classification\common\images. You can customize the symbols in the
com\teamcenter\rac\classification\common\common.properties file.

Attaching documents and images

If documents or image datasets are attached to a workspace object with a rendering relation, and that
object is classified, you can view the documents or images in the viewer. Teamcenter searches only for
datasets attached to a revision object or, in the case of classified items, to the latest revision.

To see which documents are added as named references, right-click the dataset in the Attachment
pane and choose Named References. The Named References dialog box displays the list of named
references for the dataset.

Suppress images in viewers

• Clear the Show Image option to suppress the display of images.

Attaching documents and images
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This option is on by default. However, suppressing the display of images, particularly in the instance
viewer, can improve performance when viewing search results.

Searching for resources

Searching for resources overview

There are many ways to find a resource in Resource Manager.

• You can use the Teamcenter quick search.

With the Teamcenter quick search in the navigation pane you can search the database for a resource
based on various criteria. If you receive multiple matches, Teamcenter displays these in a table. It
opens the desired resource in a new resource view.

• You can search for resources using the Object ID search.

• You can search for resources using the Classification Search Dialog.

Find a resource using the Object ID search

If you know at least a portion of the object ID of a resource, you can use the object ID search feature.
An object ID search encompasses the entire classification hierarchy and is not limited to the contents of a
particular class or subclass.

1. Click Search by ID .

Teamcenter displays the Search by ID dialog box.

2. Type the exact object ID or partial object ID and wildcard characters and click OK to close the dialog
box or Apply to keep the dialog box open.
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• If there is only a single match, Teamcenter opens a new resource view displaying this match.

• If there are multiple matches, Teamcenter displays them in the Classification Table view where
you can double-click the desired resource and it opens in a new resource view.

Note:

If you want to additionally narrow down the search by type, use the object ID search in the
Classification Search Dialog.

Searching for resources using the Classification Search Dialog

It is often necessary to search for resources stored in the database. Searching the classification hierarchy
to locate a specific resource, class, or group can be a time-consuming task. The Classification search
features save you time by enabling you to focus your search using familiar criteria, such as name or ID.

You search for resources using the Classification Search Dialog.

• You know all or part of the object ID. In this case, you can use the object ID search feature. You can
narrow this search using the search by type function. This allows you to search, for example, only for
ICOs that classify something, or only for ICOs that do not classify anything.

• You want to search within a specific group or class. For this, you must know how to select a class.
From within this class, you can either search all resources in the class or search for objects matching
specific criteria.

• You know that the resource should possess specific attribute values. Use the attribute value search to
perform this search. You can narrow this search by first selecting a class or specifying all or part of an
object ID.

• You want to search all assemblies for one containing a specific component. Use the search assembly
by component search for this. You can combine this type of search with the attribute value search,
meaning that you can look for a component containing specific criteria.

Note:

There are two search buttons in the Properties pane:

• The Search button  to the right of the Object ID box searches the entire classification
hierarchy. You can narrow down this search by entering a component ID or component class ID,
or entering a search type.

• The Search button  at the bottom of the Search pane searches within a selected
class.

Searching for resources using the Classification Search Dialog
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This type of search can include any search refining features, such as object ID, attribute value, or
search by type.

In addition, there is another search button below the hierarchy tree. This is the quick search
button.

• When searching the hierarchy, you can:

• Search for a specific ID or part of an ID.

• Search for groups or classes.

• Search for objects possessing specific criteria.

• Navigate through the search results.

• Select the resource you want.

Search by object ID

If you know at least a portion of the object ID of a resource, you can use the object ID search feature. An
object ID search encompasses the entire classification hierarchy and cannot be limited to the contents of
a particular class or subclass.

1. Click the Search pane located to the right of the hierarchy tree.

2. Type the exact object ID or partial object ID in the Object ID box, located at the top of the Search
pane.

3. (Optional) Type a component ID or component class ID.

4. (Optional) Narrow your search using the search by type feature.

5. (Optional) Click the revision rule hyperlink on the title bar to apply a revision rule for the search. If
you enter a specific revision in the Object ID box, the search ignores the revision rule. If a revision
rule is already set, it is displayed in the revision rule link.

6. Press Enter or click the Search button  to the right of the Object ID box.

The object ID search returns the ICOs found in alphabetical/numeric order by object ID. The first
resource found is displayed in the Properties pane. When navigating through the resources, the
class and subclass to which the resource belongs are highlighted in the classification tree. The total
number of resources found is displayed in the Search Results box.

7. Navigate through the search results.
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8. Select the desired resource and transfer it to Resource Manager.

9. (Optional) Perform subsequent searches by clicking the Search tab, clicking  and
proceeding from step 1.

Search by type

You can search the classification hierarchy for resources classifying specific workspace object types.

1. In the classification tree, expand the desired class and select it by either:

• Double-clicking if it is a leaf node.

• Right-clicking and choosing Select if it is not a leaf node.

The class names are highlighted in the tree.

2. Type an ID, a class ID, or attribute values.

3. Click the Classified Object Type button . A list of workspace object types follows.

Click To

Search among all classification instances. This is the default
search method.

Search among all classification instances that classify a
workspace object.

Search among all classification instances that do not classify a
workspace object.

Generic and Needs → Search among all classification instances that are classified as
generic.

Generic and Needs → Search among all classification instances that are classified as
need.

Generic and Needs → Search among all classification instances that are classified as
generic and need.

Search among all classification instances that classify an item.

Search among all classification instances that classify an item
revision.

Search among all classification instances that classify a process.

Search by type
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Click To

Search among all classification instances that classify a process
revision.

Search among all classification instances that classify a resource.

Search among all classification instances that classify a resource
revision.

Search among all classification instances that classify a NC Tool.

Search among all classification instances that classify a NC Tool
Revision.

Search among all classification instances that classify a NC
Machine.

Search among all classification instances that classify a NC
Machine Revision.

Note:

The types available in this list are configurable.

4. Click the Resource Type button  and select a type of workspace object to narrow your search.
Only resources classifying this type of workspace object are found in the search.

5. Select a type of workspace object to narrow your search. Only resources classifying this type of
workspace object are found in the search.

6. (Optional) Click the revision rule hyperlink on the title bar to apply a revision rule to the search. If
you search by a type that excludes revisions (for example, item or process), the search ignores the
revision rule. If a revision rule is already set, it is displayed in the revision rule link.

7. Click Search at the bottom of the Search pane to list all matching instances within the class.

The total number of instances that match the search criteria is displayed at the bottom of the
Search pane.

Note:

The Search pane displays no values upon completion of the search. You must switch to the
Properties or Table pane to navigate through the results and display the values for a specific
instance.

8. View the search results using one of the following methods:

• In the Table pane, double-click the instance to be viewed.
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Its attributes are displayed in the Properties pane. The classification tree is updated to show the
class of the selected object.

• In the Properties pane, use the navigation arrows at the bottom of the pane to browse forward
and back through the list of items that matched your search criteria. As different objects are
selected, the classification hierarchy is updated to show the class of the selected object.

Two modes are used for updating the classification hierarchy when displaying the search results:

a. Click the View in class stored button  to display the class in which the item is stored.

b. Click the View in class searched button  to display the class that you selected as a basis
for the search.

By default, View in class stored is active.

As you view your search results, also use the Viewer pane to display any image associated with the
current item. If you select multiple objects in the table and switch to the Viewer pane, only these
objects are available in the viewer.

Selecting a class

The first step in searching the classification hierarchy is to find a class in which to search. There are three
methods to select a group or class:

• Navigate through the classification hierarchy manually, clicking the groups and classes until you find
your desired class.

• Use the quick search feature.

• Use the Search Class dialog box.

You can search for a class using any of the alias names shown in the class tool tip.

Use the quick search feature to select a class

1. In the search box located beneath the hierarchy tree in the Classification Search Dialog, type text
corresponding to the name of the group or class that you want to locate. You can also search by ID
by typing id=xxx in the box, where xxx is the class ID.

The search text can be the exact name or ID of the group or class you are looking for, a class alias
name, or you can use character strings combined with wildcard characters.

2. Press Enter to start the search.

Selecting a class
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The hierarchy tree expands to display the first object in the hierarchy that matches the search
criteria. The path of the group, class, or subclass is indicated in bold text. If multiple objects are
found, the arrow buttons at the bottom of the hierarchy tree are enabled.

3. Click the left-arrow and right-arrow buttons  to display the matching objects, one at a
time. This highlights the classes found in the hierarchy tree. The right-arrow button moves down
the hierarchy tree, and the left-arrow key moves up the tree.

Note:

If you prefer to view a list of the results, you can display the Search Class dialog box by
clicking the magnifying glass button located beneath the hierarchy tree.

4. Right-click the class in the hierarchy tree within which you want to search.

5. Choose Select.

The Search pane displays the attributes associated with the selected class, and the images appear
in the class image window.

Note:

If the class or subclass you select is a leaf node (lowest level node) in the hierarchy, you
can double-click the node to display it in the Search pane, rather than use the right mouse
button.

Use the Search Class dialog box to select a class

1. Click the Find Class button  located beneath the hierarchy tree.

The Search Class dialog box is displayed at the bottom of your window. To move the dialog box,
double-click the title bar and drag it to another location on your desktop.

2. Define the search criteria by performing the following steps:

a. Select a property from the list at the upper-left corner of the dialog box. The available
properties are Class ID, Name, Alias Names, Attribute ID, Attribute Name, User data 1, and
User data 2.

Note:

You can use the Name and Class ID properties to search for groups and classes. When
searching by attribute, the results include the class in which the attribute is defined and
any subclasses in which the attribute is used. Classes that inherit the attribute are not
included in the results.
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b. Type search text corresponding to the selected property.

The search text can be the exact name or ID you are looking for, or you can use character
strings combined with wildcard characters. Using a wildcard is restricted to string attribute
fields only.

Note:

The search box is case sensitive.

3. (Optional) If localization is enabled, select the language in which you want to search.

4. To start the search, either click the magnifying glass button located in the upper-right corner of the
dialog box or press Enter.

Teamcenter displays the results of the search in the message area of the dialog box, sorted in the
same order as the hierarchy tree display.

5. To display an object in the tree, double-click the entry in the results list.

The hierarchy tree expands to display the selected group, class, or subclass. The path to the object
is indicated in bold text.

6. Click the left and right arrow keys beneath the class hierarchy tree  to move through the
search results to locate the desired class or group.

7. Right-click the class in the hierarchy tree within which you want to search.

8. Choose Select.

The Search pane displays the attributes associated with the selected class, and the images appear
in the graphics window.

Note:

If the class or subclass you select is a leaf node (lowest level node) in the hierarchy, you
can double-click the node to display it in the Search pane, rather than use the right mouse
button.

Search all resources in a selected class

1. Select the class in the hierarchy tree within which you want to search for resources.

2. (Optional) Click the revision rule hyperlink on the title bar to apply a revision rule to the search. If
you search by a type that excludes revisions (for example, item or process), the search ignores the
revision rule. If a revision rule is already set, it is displayed in the revision rule link.

Search all resources in a selected class
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3. Determine the scope of the search by clicking the Search Scope button. By default, the scope is set
to Hierarchy.

a. Choose Hierarchy  to search within the selected class and all related child classes.

b. Choose Class  to search only within the selected class.

4. If you work in a multilanguage environment, select the language in which to search.

Caution:

Changing the language also changes the value of the TC_language_search preference
interactively, which affects all Teamcenter localization.

5. Click one of the following at the bottom of the pane to narrow the search.

Click To

Search only for metric ICOs.

Search only for nonmetric ICOs.

Search for both metric and nonmetric ICOs.

Caution:

If you are searching in a different unit of measurement than the one that you use to enter
the attribute value, be sure to enter enough digits after the decimal point to avoid rounding
errors.

6. Click Search  at the bottom of the Search pane to list all search matches within the
class.

The total number of resources that match the search criteria is displayed at the bottom of the
Search and Properties pane.

Note:

The Search pane displays no values upon completion of the search. You must switch to the
Properties or Table pane to navigate through the results and display the values for a specific
instance.

7. Navigate through the search results.

8. Select the desired resource and transfer it to Resource Manager.
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9. Select the desired resource and transfer it to your application.

10. (Optional) Perform subsequent searches within the same class or subclass by clicking the Search
tab  and repeating the process.

Search for resources by attribute value

1. Select the class in the hierarchy tree within which you want to search for resources.

2. Type values, including relational operators and wildcard characters where applicable, in the boxes
corresponding to the attributes by which you want to search.

You can:

• Narrow your search by specifying search criteria for multiple attributes.

• Change the displayed unit of the value by clicking it or typing the unit in the dialog box along
with the value.

Teamcenter changes the unit for you automatically.

Note:

If the attribute or attribute value by which you want to search is not available for
searching, one of the following reasons may apply:

• It is a reference attribute.

• It may already have a default value assigned in Classification Admin.

• It may be encrypted in the database.

• One or more of the key-LOV's values may be deprecated.

3. (Optional) Click the revision rule hyperlink on the title bar to apply a revision rule to the search. If
you search by a type that excludes revisions (for example, item or process), the search ignores the
revision rule. If a revision rule is already set, it is displayed in the revision rule link.

4. Determine the scope of the search by clicking the Search Scope button. By default, the scope is set
to Hierarchy.

a. Click Hierarchy  to search within the selected class and all related child classes.

b. Click Class  to search only within the selected class.

5. If you work in a multilanguage environment, select the language in which to search.

Search for resources by attribute value
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Caution:

Changing the language also changes the value of the TC_language_search preference
interactively, which affects all Teamcenter localization.

6. Click one of the following to narrow the search.

Click To
Search only in metric classes.
Search only in nonmetric classes.
Search in both metric or nonmetric classes.

Caution:

If you are searching in a different unit of measurement than the one that you use to enter
the attribute value, be sure to enter enough digits after the decimal point to avoid rounding
errors.

7. Click Search  at the bottom of the Search pane to list all search matches within the
class.

The total number of ICOs that match the search criteria is displayed at the bottom of the Search
and Properties pane.

Note:

The Search pane displays no values upon completion of the search. You must switch to the
Properties or Table pane to navigate through the results and display the values for a specific
instance.

8. Navigate through the search results.

9. Select the desired resource and transfer it to Resource Manager.

10. Select the desired resource and transfer it to your application.

11. (Optional) Perform subsequent searches within the same class or subclass by clicking the Search
tab  and repeating the process.

Search for resources based on site-specific properties

Resources can be filtered based on site-specific data in all places where you can query for classification
properties. The following are typical places to search for resources with site properties:
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• Classification

• In the Classification Search Dialog in Resource Manager

• NX CAM to retrieve tools using the NX Library dialogs  

1. Find the Site Specific Data section of the search pane.

By default, you can search for the Resource Location and Resource Status site-specific properties
for the Tool (Assemblies and Components) and Machine (Devices and Machine Tools) classes.

To search for other site-specific properties, you must first set them up.

2. Select the desired search criteria and click Search.

Note:

If there are multiple site-specific data entries, when you display the search results in Show mode
or in the table, Teamcenter displays one of the data entries. It may not be the entry for which you
searched.

Search assemblies by component

Perform the following steps to search for all assemblies containing a specific component or component
class:

1. Select the assembly class in the hierarchy tree within which you want to search for resources
containing specific components.

2. On the Search pane, you can search assemblies using the component ID or component class ID.

• To search for a specific component ID:

a. Type the ID in the Component ID box.

b. If you are unsure of the ID of the component, click the  button beside the box.

A new Classification Search Dialog opens where you can search for the name of the
component. Use wildcard characters, if necessary.

Search assemblies by component
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• To search for a specific class ID:

a. Click the Component ID button.

The text on the button changes to Component Class ID. The plus button beside the entry
box changes to a classification tree button .

b. Type the component class ID for which you are searching.

c. If you do not know the name of a class for which you want to search:

A. Click the classification tree button .

The Classification Information dialog box is displayed.

B. Navigate through this hierarchy until you reach the class for which you want to search.

C. Select the class.

Caution:

You cannot use the AND or OR operator multiple times in the assembly search.

3. Determine the scope of the search by clicking the Search Scope button. By default, the scope is set
to Hierarchy.

• Choose Hierarchy  to search within the selected class and all related child classes.

• Choose Class  to search only within the selected class.

4. Click one of the following to narrow down the search:

Click To
Search only in metric classes.
Search only in nonmetric classes.
Search in both metric or nonmetric classes.

5. Click Search  at the bottom of the Search pane to list all search matches within the
class.

The total number of ICOs that match the search criteria is displayed at the bottom of the Search
and Properties pane.
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Note:

The Search pane displays no values upon completion of the search. You must switch to the
Properties or Table pane to navigate through the results and display the values for a specific
instance.

6. Navigate through the search results.

7. Select the desired ICO and transfer it to Resource Manager.

8. (Optional) Perform subsequent searches within the same class or subclass by clicking the Search
tab  and repeat the process.

Find a resource in the source class

If you map classes from one branch of the hierarchy to another, and use the source classes to populate
the target classes, you can search for a corresponding resource in the source structure if you are
currently in the target structure. If you then want to create a new resource based on an existing one,
map the resource from the source structure to the target structure.

If you do not find an appropriate component in the target hierarchy:

1. Click the Map ICO button .

Teamcenter opens the corresponding source hierarchy to those classes that match your current
search criteria.

2. Select the appropriate resource.

Apply a revision rule

You can apply revision rules to searches. This narrows down the number of search results so that
Teamcenter returns only the revisions you require. You can control the default behavior of the revision
rules with the following preferences:

• ICS_search_default_revision_rule_<application_name>

Sets the default revision rule for the specified application.

• ICS_search_use_revision_rule

Enables or filters out revision rules for classification searches.

1. In the Search pane, click the Revision Rule hyperlink. This link shows the name of a revision rule, if
one is set, or simply states Click to add a revision rule.

Find a resource in the source class
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The View/Set Current Revision Rule dialog box is displayed containing all existing revision rules.

2. Select the appropriate revision rule and click OK.

3. Click  beside the revision rule hyperlink.

A list with configuration options appears.

4. Select one of the following:

Configuration
options

Description

Use revision
rule

Enables or filters out the currently selected revision rule for the
search.

Save as
default

Saves the currently selected revision rule as the
default rule for this application. Teamcenter saves it
in the ICS_search_default_revision_rule_<ResourceManager>
preference. The default revision rule is directly selected and enabled
for the search the next time you launch the application.

Restore
default

Selects and enables the saved default revision rule. The Use Revision
Rule menu command is also automatically selected.
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Using relational operators

Use the following relational operators to perform Classification attribute searches:

Relational
operator

Definition For example, if you type

= Equal to = 3.0 in the Corner Radius attribute box of the Taper Shank End Cutter
subclass, all resources within the subclass with a corner radius equal to
3.0 are found. You can achieve the same behavior by typing a number.
If no value is given after the equal sign, the system searches for all
instances where no value is set for the attribute.

Note:

If you want to find an entry that contains the character that
Teamcenter uses as the wildcard character (for example, *), enter
= and the string containing the character for which you are
searching, such as = shaft*01. This search finds shaft*01, not
shafts01, or shaft101, or shaft201.

> Greater than > 3.0 in the Corner Radius attribute box of the Taper Shank End Cutter
subclass, all resources within the subclass with a corner radius greater
than 3.0 are found.

< Less than < 3.0 in the Corner Radius attribute box of the Taper Shank End Cutter
subclass, all resources within the subclass with a corner radius less than
3.0 are found.

>= Greater than
or equal to

>= 3.0 in the Corner Radius attribute box of the Taper Shank End
Cutter subclass, all resources within the subclass with a corner radius
greater than or equal to 3.0 are found.

<= Less than or
equal to

<= 3.0 in the Corner Radius attribute box of the Taper Shank End
Cutter subclass, all resources within the subclass with a corner radius less
than or equal to 3.0 are found.

!= Not equal to != 15.00 in the Diameter attribute box, all resources with a diameter not
equal to 15.00 are found.

If no value is given after the equal sign, the system searches for all
instances where any value is set for the attribute.

~ Like ~ Walt* in the Vendor attribute box of a class, all resources within that
class beginning with Walt, such as Walter, Waltmann, or Walthouse are
found.

!~ Not like !~ Walt* in the Vendor attribute box of a class, all resources within that
class except for those beginning with Walt are found.

Using relational operators
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Relational
operator

Definition For example, if you type

– Range 10.00 – 20.00 in the Diameter attribute box, all resources with a
diameter within the range of 10.00 to 20.00 (including the values 10.00
and 20.00) are found. A blank space must precede and follow the
hyphen.

| OR Walter | Kennametal in the Vendor attribute box of the Taper Shank
End Cutter class, all resources within the class with a vendor of Walter or
Kennametal are found.

You can use the wildcard character (*) in this type of statement.

“” Exact string “blue or green”, Teamcenter searches for the string blue or green. If
you type “4 – 10”, Teamcenter searches for the string 4 – 10, not the
range 4–10.

Note:

You cannot use exact string relational operators in combination
with other relational operators.

& AND blue & green, Teamcenter searches for strings that contain at least one
instance of both the string blue and the string green.

Note:

• You cannot use relational operators when searching for attributes with multiple values. You can
only use the equal and wildcard operators.

• Wildcard characters are permissible for string attributes only.

Using wildcard characters

Resource Manager employs the standard wildcard characters defined for your site. You can use these for
any string attribute. Wildcard characters are not permissible for integer or real attributes.

By default, you can use the * character.

Search and download ToolsUnited GTC package

If you do not find a suitable tool component in the database, you can search for it in an external vendor
catalog. Teamcenter has a seamless integration of search capabilities with the ToolsUnited database
from CIMSOURCE GmbH containing over 550,000 components from a variety of tool vendors that you
can import into the vendor hierarchy.
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You can browse the ToolsUnited catalog content using a guest account. To download tool components,
an account is required. This is not free of charge. Contact Cimsource (at http://www.cimsource.de/en/
home) for more information (http://www.toolsunited.com).

Note:

Be sure to include https://www.toolsunited.com in your list of trusted sites for Internet Explorer.

1. In Resource Manager you can search and build your tool assembly by adding components using the
Classification search dialog. See Working with resource structures for more information.

2. If this is your first time using the ToolsUnited search in the current Teamcenter session, enter your
login information.

The ToolsUnited view opens displaying the search results.

Search and download ToolsUnited GTC package
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Tip:

When performing a ToolsUnited search, select a leaf class or storage class to perform the
search on. The ToolsUnited search does not work on super or parent classes.

3. Select the tool components that you want to use in Resource Manager and do one of the following:

a. If you select one tool component only, click the Siemens Export button above the tool
graphic.

You can directly choose the directory on your operating system to which you export the tool
component.

b. If you select multiple components from the list:

A. Click the Siemens Export button above the table.

B. Click Export Overview .

ToolsUnited displays a list of packages that you have exported so far.
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C. Select the package that you want to download and click Download export file .

D. Save the export package to your local directory.

4. Import GTC Package with 3D and mapping

Warning:

Before a ToolsUnited GTC Package can be imported, your administrator must first import the
ToolsUnited GTC class hierarchy. The ToolsUnited GTC class hierarchy package can be found
on the Siemens Digital Industries Software page of the ToolsUnited website.

Navigating the matches

Viewing search results in the Properties pane

When you view a resource in the Properties pane, the class it belongs to is highlighted in the hierarchy.
Two modes are used for updating the classification hierarchy when displaying the search results:

• Click the View in class stored button  to display the class in which the item is stored.

• Click the View in class searched button  to display the class that you selected as a basis for the
search.

You can see the active unit of measurement in the attribute values title bar in the Properties pane using
the following symbols.

Symbol Description

The ICO is currently displayed and stored in a metric system of measurement.

The ICO is currently displayed and stored in a nonmetric system of measurement.

Viewing search results in the Properties pane
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Symbol Description

The ICO is currently displayed in metric, but was originally stored in a nonmetric
measurement system.

The ICO is currently displayed in a nonmetric measurement system, but was originally
stored in a metric system.

View search results in the Table pane

You can view the data of the resources found in the search collectively using the Table pane. If the
measurement unit symbol at the beginning of each row contains an exclamation mark, the resource is
displayed in a unit system other than the one in which it was stored. For example, if the symbol  is
displayed, the resource was stored in a nonmetric unit system but is currently displayed in a metric unit.

1. Perform one of the following actions:

a. Click  to load the next page of found resources into the table.

The resources are appended to those currently displayed.

Note:

By default, the number of resources displayed on a page is set to 5. Your administrator
can change the default display by modifying the ICS_table_pagesize preference.

b. Click  to load all matches into the table.

2. (Optional) Sort the table data; double-click the column header corresponding to the property to
switch between ascending, descending, and natural sort order.

Teamcenter can display different units of measurement in the same column. The displayed unit
depends on the optimized unit for each of the attribute values. Teamcenter sorts these columns
based on the attribute values in the storage unit. The table header always shows the unit (if
available), but for optimized values, the header shows the unit in italic and the cell contains the
unit as well (as the unit can change). For nonoptimized values, the unit is not attached to the value
and shown only in the header (nonitalic).

3. (Optional) Select one or multiple lines in the Table pane and click  to copy the contents of the
selected line to the clipboard. You can paste these contents in an external application.

4. (Optional) Select one or multiple lines in the Table pane and click .
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Teamcenter opens the Print dialog box where you can choose to open the data in a Web browser,
print it, or save it.

5. (Optional) Select a line in the Table pane and click  to view the properties of the associated
workspace object.

6. (Optional) Select one or multiple lines in the Table pane and click  to map from one class to
another.

7. Double-click a resource in the table to view it.

The system opens the resource in the Properties pane and highlights its class in the tree.

Viewing the results in the Viewer pane

You can view all search results in the Viewer pane. You can move backward and forward in the match
list using the navigation buttons.

Note:

If the ICO does not have an item attached, or if the item does not contain a graphic, no image
appears in the Viewer pane.

Select the desired resources

After you navigate through the search matches, you can select one or several resources to return to
Resource Manager.

1. Click the Properties, Table, or Viewer tabs.

Note:

The Viewer pane is only active for an ICO that has an item attached.

2. Navigate to the desired resource.

• In the Properties or Viewer pane, use the navigation arrows. The system shows all attributes
and values for each resource.

• In the Table pane, do one of the following:

a. Select the resource by clicking it.

b. Double-click the resource.

c. Select multiple resources.

Viewing the results in the Viewer pane
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Teamcenter switches to the Properties pane and shows all attributes and values for the
selected resource.

3. Click OK to close the dialog box or Apply to keep it open.

The item or item revision classified by the ICO is displayed in Resource Manager. If an ICO has no
item or item revision attached, the system creates one so that it can open that item in Resource
Manager.

If you open multiple resources at once by selecting several ICOs in the Classification Search Dialog,
they are all transferred to the Resource view. The selected resources are displayed in the resource
structure in the order in which they appear in the Classification Search Dialog table.

View results in the Classification Table view

If an object ID search or a search in the Classification Search Dialog returns multiple matches,
Teamcenter displays these in the Classification Table view. In this view, you can:

• Use the arrows to step through the found resources. The properties of each match are displayed in the
Classification Properties view.

• Perform one of the following actions:

• Click  to load the next page of found resources into the table.

The resources are appended to those currently displayed.

Note:

By default, the number of resources displayed on a page is set to 5. Your administrator can
change the default display by modifying the ICS_table_pagesize preference.

• Click  to load all matches into the table.

• (Optional) Sort the table data; double-click the column header corresponding to the property to
switch between ascending, descending, and natural sort order.

• View whether the resource is displayed in a unit system other that the one in which it is stored.

If the measurement unit symbol at the beginning of each row contains an exclamation mark, the
resource is displayed in a unit system other than the one in which it was stored. For example, if the
symbol  is displayed, the resource is stored in a nonmetric unit system but is currently displayed
in a metric unit.

• Click a resource in the table or navigate through the resources using the arrow buttons.

3. Getting started
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Teamcenter displays the properties of each resource in the Classification Properties view.

• Double-click a resource in the table.

Teamcenter opens the resource in a new Resource view and displays its properties in the
Classification Properties view. You can only open classifying instances in a Resource view.

• (Optional) Select one or multiple lines in the Table pane and click  to copy the contents of the
selected line to the clipboard. You can paste these contents in an external application.

• (Optional) Select one or multiple lines in the Table pane and click .

Teamcenter opens the Print dialog box where you can choose to open the data in a Web browser,
print it, or save it.

• (Optional) Select a line in the Table pane and click  to view the properties of the associated
workspace object.

• (Optional) Select one or multiple lines in the Table pane and click  to map from one class to
another.

View results in the Classification Table view
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4. Creating resources
Creating resources and adding value for downstream applications

Creating resources

Create new resources

1. Choose File→New→Resource, or click the Create a new Resource button  on the toolbar.

The New Resource dialog box opens.

2. Fill in the Item Details information for the new resource.

Item ID This information is required.

Type the ID number to be assigned to this new resource.

To let Resource Manager automatically assign a unique ID, click Assign.

Revision • If this is a new resource, type A.

• If this is a revision of an existing resource, type the next consecutive revision
number.

• To let Resource Manager automatically assign a unique revision number,
click Assign.

Name Type the name of the new resource or resource revision. Make it unique so it is
easier to search the database using this term.

Description (Optional) Type a description of the new resource.

Item Type Select the item type of the new resource.

The following four types are generally used to create new resource:

• Resource – for resources

• NC Tool – for tools

• NC Machine – for machines (do not confuse with NC Machining
Operation)

• Equipment – for use with Tecnomatix applications
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Teamcenter stores the default value of this entry in the MRMItemTypes
preference.

3. Click OK.

Teamcenter automatically classifies the resource in the class that was previously selected. This is
listed in the top line of the Classification Properties view. If no class was previously selected, the
resource is classified in the New Resource class.

Note:

• If you are not using the resource kit and have no New Resource class, your Classification
administrator can change the default class by adding the following entry to the
mrm_user.properties file:

defaultClass=your_class_ID

• It is recommended you use the MRL template parts, mrl_step_template_metric
andmrl_step_template_inch, for the GTC 3D model import. The templates are installed
when you run the Configure TCL Graphic Macros"/"Configure Graphics Builder option in
the MRL installer. The templates have the correct item type NC Tool

• If you want another item type you can create custom template parts using these file
names, custom_step_template_metric and custom_step_template_inch.

4. (Optional) If the resource was incorrectly classified in the previous step, classify it in the appropriate
class.

5. If this resource is the root node upon which a resource structure is to be built, add components to
this root to build the resource structure.

6. Click Save  on the toolbar to save the new resource.

Create new tool component resource

This option streamlines the process of creating a new tool resource by automatically classifying it as a
tool.

1. Choose File→New→Tool Assembly, or click Create new Tool Component  on the toolbar.

The Classification Information dialog box opens to the Components branch of the Hierarchy
Tree.

4. Creating resources
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Note:

This option is only available if the preference MRMCreateToolAssemblyAndComponent is
set to True.

2. Navigate through the classes and double-click the classification to which the new item is being
assigned.

The New Tool Component dialog box appears.

3. Enter Item Details information for the new resource.

Item ID This information is required.

If the preference MRMToolAssemblyAndComponentIDAutoGenerated is set
to True, the ID number is automatically generated according to site-specific
settings.

If the preference MRMToolAssemblyAndComponentIDAutoGenerated is set
to False, the ID number can be assigned by the user, or you can let Resource
Manager automatically assign a unique ID, by clicking Assign.

Revision • If the resource is new, type A.

• If it is a revision of an existing resource, type the next consecutive revision
number.

• To let Resource Manager automatically assign a unique revision number,
click Assign.

Name Type the name of the new resource or resource revision. Make it unique so you
can easily search for it.

Description (Optional) Type a description of the new resource.

Item Type The Item Type MENCTool is automatically selected.

4. Click OK.

5. (Optional) If the resource is incorrectly classified in the previous step, classify it in the appropriate
class.

Note:

If you change the Item Type for a resource that has an ID that was automatically generated,
the ID remains the same.

6. Click Save  on the toolbar to save the new resource.

Create new tool component resource
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How to build a resource assembly

1. Create a new item that represents the root of the new assembly structure by choosing
File→New→Resource or clicking .

2. Specify the item type for the new resource.

The following four types are generally used to create a new resource.

• NC Tool — for tools

• NC Machine — for machines (do not confuse with NC Machining Operation)

• Resource — for resources

• Equipment — for use with Tecnomatix applications

Teamcenter stores the default value of this entry in the MRMItemTypes preference.

3. Search for components to build the tool structure. You must start with the machine-side
component—that is, a machine adapter or tool holder—and work toward the cutter or workpiece
side.

a. Select the parent component below which you want to add the next component.

b. Search for the next component using the Classification Search Dialog  and click OK.

Note:

Turn on the graphical browser for a more visual search experience.

Teamcenter displays the new component as a child of the selected component.

Each component added to an assembly gets a unique find number. It is recommended
that users do not manually change the find number. Doing so can negatively impact
the display of the resource structure.

4. (Optional) If you put a component in the wrong position in the hierarchy, or prefer to search in a
different order from the assembly structure (for example, search for the cutter first), cut and paste
components to the correct position in the tool assembly.

5. Attach the propagation start point (PSP) to the cutter by selecting the cutter and clicking .

4. Creating resources
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6. Click Save .

Teamcenter saves the assembly and propagates the defined attribute values from all components,
starting at the propagation start point (in this case, the cutter), to the assembly root node. The following
figure shows the propagated attributes in italic font.

How to build a resource assembly
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Note:

This procedure works correctly for all existing tool assembly classes in the Manufacturing Resource
Library. If, however, your administrator adds new classes to the classification hierarchy, the
class in which you classify the resource assembly must be specified as an assembly class in the
Classification Admin application. In addition, the attributes that you want to propagate to the
root node must have the Propagated Property option selected in the resource assembly class in
Classification Admin.

Creating resource assemblies

In addition to individual components, Resource Manager manages the resource assemblies that are used
by manufacturing tasks. Classified resource components are used to build these resource assemblies.

Generally, tool components cannot be used in a manufacturing process by themselves, so they are
assembled using Resource Manager into resource assemblies. These assemblies are then used in the
manufacturing production process. For example, parts are added to a resource assembly by a tool
designer and then used in a manufacturing process created by a process planner.

There are three main features of a resource assembly:

• Assembly structure

The assembly structure is displayed in a tree hierarchy on the left side of the Resource Manager
application window in the resource view. The tree hierarchy shows the logical structure of how the
different components are assembled to make up the structure. The root node represents the assembly.
Additional components are added to the root node to build the structure.

You can use cut, copy, paste, or drag-and-drop functions to organize components within the structure
hierarchy.

• Assembly attributes

If its root node is selected in the assembly structure, its attributes are shown on the Classification
Properties view. If subassembly or component nodes are chosen, the attribute list in the
Classification Properties view changes and the attributes of the selected object are displayed.

• Graphical representation

The Classification Properties view has two viewing windows on its right-hand side. The upper
window displays an image associated with its class, while the lower window shows an image
associated to the instance, if available.

Create new tool assembly resources

1. Choose File→New→Resource, or click Create a new Tool Assembly  on the toolbar.

Creating resource assemblies
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The Classification Information dialog box opens to the Assemblies branch of the Hierarchy Tree.

Note:

This option is available only if the preference MRMCreateToolAssemblyAndComponent is
set to True.

2. Navigate through the classes and double-click the classification to which the new item is being
assigned.

The New Tool Assembly dialog box appears.

3. Enter the Item Details information for the new resource.

Item ID This information is required.

If the preference MRMToolAssemblyAndComponentIDAutoGenerated is set
to True, the ID number is automatically generated according to site-specific
settings.

If the preference MRMToolAssemblyAndComponentIDAutoGenerated is set
to False, the ID number can be assigned by the user, or you can click Assign to
let Resource Manager automatically assign a unique ID.

Revision • If the resource is new, type A.

• If it is a revision of an existing resource, type the next consecutive revision
number.

• To let Resource Manager automatically assign a unique revision number,
click Assign.

Name Type the name of the new resource or resource revision. Make it unique so you
can easily search for it.

Description (Optional) Type a description of the new resource.

Item Type The Item Type MENCTool is automatically selected.

4. Click OK.

5. (Optional) If the resource is incorrectly classified in the previous step, classify it in the appropriate
class.

Note:

If you change the Item Type for a resource that has an ID that was automatically generated,
the ID remains the same.

4. Creating resources
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6. If this resource is the root node upon which a resource structure is to be built, add components to
this root to build the resource structure.

7. Click Save  on the toolbar to save the new resource.

Auto-generate new resource Item ID

Set preferences to auto-generate Item ID

If your company has specific conventions for assigning Item IDs in Resource Manager, you can use
an option to have the Item ID auto-generated for the Create new Tool Assembly and Create new
Tool Component commands. Set your preferences to determine whether and how the Item ID is
auto-generated.

1. Set the preference for MRMToolAssemblyAndComponentIDAutoGenerated.

Note:

If this preference is set to True, the Item ID is automatically provided in the New Tool
Component or the New Tool Assembly dialog box. If this preference is set to False, you can
enter the Item ID manually or select Assign.

2. Set the preference for MRMToolAssemblyAndComponentIDCounterFormat to control the
number of digits in the Item ID when auto-generated.

Note:

The auto-generated numbers and format in the Item ID are associated with the specific class.
See the examples below.

Resource Class New Tool Component Class New Tool Assembly Class
Initial Item ID auto-generated TUR0001

TUR = site-specific prefix

0001 = 4-digit auto-generated
number

TRNA001

TRNA= site-specific prefix

001 = 3-digit auto-generated
number

Next Item ID auto-generated TUR0002

0002 = next number in this
class

TRNA002

002 = next number in this class

3. Set the preference for ICS_available_languages.

Auto-generate new resource Item ID
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Note:

When this preference is defined with the value Resource_ID_Prefix, you can define a specific
prefix in Classification Admin.

Add a site-specific prefix

1. While in Classification Admin, select the class to which you want to add a specific prefix.

Note:

You can add a specific prefix for a class at any level of the hierarchy. When Resource Manager
checks for a specific prefix, it searches the current class level first. If it can't find the prefix, it
will search in the next level up in the class hierarchy.

2. Click Edit current Instance .

The Abstract Class dialog appears.

3. Be sure Resource_ID_Prefix is selected and enter the site-specific prefix.

4. Creating resources
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4. Click Add .

5. Click Save .

Using tracking points for milling and drilling tools

A tracking point is the internal reference point on the tool that NX uses to calculate tool paths. When
you choose a tracking point, the milling and drilling processors use the associated data to determine cut
regions, collision detection, tool paths, in process workpiece, and to position to avoidance geometry.

To ensure tracking points are transferred properly to NX, it is important to define the Tool Tip and Step
1.

• To define one mill or drill tracking point for NX CAM, define a tracking point with 0 Tool Tip that
specifies the tool tip position. Then define a second tracking point with 1 Step 1 which defines the real
tracking point.

• To define two or more tracking points in NX CAM, you can add more tracking points and enter 1 Step
1for each new tracking point.

Creating and maintaining resource structures

Create resource structures

1. Create a new or open an existing component that represents the root of the new structure.

Using tracking points for milling and drilling tools
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Note:

If you are working on an existing resource structure, you must click the Edit button  on the
toolbar first.

2. Add additional components to build up the structure hierarchy. If you add a subassembly as an
assembly component, it appears with a different background color to differentiate it from other
components. If you loaded the Manufacturing Resource Library:

a. Begin your search for new components in the customer hierarchy.

b. If you do not find a required component in the customer hierarchy, search for it in the catalog
hierarchy and map the desired ICO to a customer class.

3. (Optional) Click Propagation  to populate the top-level assembly class with specific attributes of
individual components within the resource structure.

4. If you are modifying an existing resource, save your changes with Save  or discard the changes
with Cancel Edit .

Add components to a structure

After a root component is specified in the assembly structure, add components to the root to build up
the resource structure.

1. Select the root component in the Resource view.

2. Click the Edit button  on the toolbar to enter edit mode.

3. Choose Edit→Add Classified Component, or click the Add Classified Component button  on
the toolbar.

The Classification Search Dialog opens.

4. Search for a resource to add to your structure.

If you use the Manufacturing Resource Library:

a. Begin your search for new components in the customer hierarchy.

b. If you do not find a required component in the customer hierarchy, search for it in the catalog
hierarchy and map the desired ICO to a customer class.

5. After you select the object, click OK in the Classification Search Dialog.

4. Creating resources
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The Classification Search Dialog closes and the object is added as a child component of the root in
the assembly structure.

Note:

You can select more than one item simultaneously to add multiple components to the
resource structure at one time.

6. Click Save .

You can select assemblies as components to add in a resource structure. If you do, each subassembly is
shown with a different background color.

Repeat these steps to add additional components to the structure.

Open existing resources

Resource Manager provides you with several ways to open existing resources. You can:

1. Use the Classification Search Dialog.

a. Click the Classification Search Dialog button in the toolbar.

The Classification Search Dialog appears.

2. Use the object ID.

a. Click the Object ID button  in the toolbar.

b. Type the object ID of a resource in the dialog box. You can use wildcard characters, if
necessary.

c. Press the Enter key.

If your search returns more than one result, Teamcenter displays the result in the
Classification Table view.

3. Use the quick search.

a. Type a string in the search box at the top of the Teamcenter navigation pane.

4. Open from another application.

a. Open the item from another application.

Open existing resources
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b. Use the shortcut menu or a drag-and-drop function to send it to Resource Manager on Active
Workspace.

Working with revisions

A resource structure is a hierarchy of item revisions. Item revisions allow you to capture the state of a
component or the entire assembly at a specific point in time.

Resource Manager always saves resources using the Precise revision rule. When you open an assembly,
you see exactly those revisions of components that were used at the time it was saved. For best results,
you should always view resource assemblies using the Precise revision rule.

When creating a new resource revision, Resource Manager can automatically revise all resource
assemblies containing this revision.

Revising resources

In Resource Manager you can revise and save individual resource components with several options.

Note:

Resource Manager always saves resources using the Precise revision rule. When you open an
assembly, you see exactly those revisions of components that were used at the time it was saved.
For best results, you should always view resource assemblies using the Precise revision rule.

Revise individual resource components

1. Open the individual resource component as the root component.

2. Follow standard revision procedures.

Revise individual resource components, including all assemblies in which this resource is
contained

The Revise (incl. Super-Assemblies) option in Resource Manager allows you to revise a component,
in addition to all latest revisions of super-assemblies containing that component. Consider an example
where you have three resource assemblies, Assembly 1/C, Assembly 2/A and Assembly 3/F. Each of these
three assemblies contains multiple components, but all assemblies contain Component 3/A. If you revise
Component 3/A using the Revise (incl. Super-Assemblies), the resulting assemblies are as follows:

Before revisioning After revisioning

Assembly 1/C
                Component 1/A

Assembly 1/D
                Component 1/A

4. Creating resources
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Before revisioning After revisioning

                Component 2/A
                Component 3/A

                Component 2/A
                Component 3/B

Assembly 2/A
                Component 1/A
                Component 3/A
                Component 4/D

Assembly 2/B
                Component 1/A
                Component 3/B
                Component 4/D

Assembly 3/F
                Component 3/A

Assembly 3/G
                Component 3/B

All original items in the database remain unchanged. Resource Manager creates three new assembly
item revisions containing the revised components.

Revise individual resource components including super-assemblies

1. Open the resource that you want to revise as the root node. This resource can be a resource
assembly.

2. Choose File→Revise (incl. Super-Assemblies).

If the resource that you are revising is contained in the latest revision of other assemblies, Resource
Manager lists these and asks if you want to continue to revise all super-assemblies.

• When you click Yes, the resource is revised. Resource Manager also saves all super-assemblies
as new revisions that you can find using the Classification Search Dialog. The new assembly
revisions contain the revised component.

• When you click No, Resource Manager only saves the selected resource. The new item revision is
not contained in any super-assembly.

Assign workflows to resources

You can initiate a workflow for your resources to have them, for example, reviewed, approved, or
released, depending on the needs of your company. For sample purposes, TCM Release Process adds a
status of TCM Released to your resource. Your system administrator can use this process as a basis to
help configure a workflow that suits your needs and associate access permissions based on the status.

To assign a TCM Released status to a resource:

1. Select the resource for which you want to initiate the workflow.

2. Choose File→New→Workflow Process.

3. Select TCM Release Process from the Process Template list.

Assign workflows to resources
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4. Click OK.

5. Select the resource and choose Refresh from the shortcut menu.

A flag beside the resource indicates that it has a status, in this case, TCM Released.

Display connection point information in the hierarchy tree

To display or hide the connection point information, in the View menu, choose Show/Hide GCS
Connection Points.

Hide the display of coordinate systems

A single resource can contain multiple coordinate systems that are all displayed as a line in the tree
structure. You can hide these lines.

• Choose View→Show/Hide CSYS Lines or choose Show/Hide CSYS Lines from the view menu in the
resource view.

The following shows a resource with coordinate system lines hidden.

The following shows a resource with coordinate system lines displayed.

4. Creating resources
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Remove components from a structure

1. If you are not already in edit mode, click the Edit button  on the toolbar.

2. Click the Remove a Line button  to remove the component from the current resource structure.

Warning:

If you click the Delete button  instead of the Remove a Line button, the resource is
deleted from the database.

3. Click Save .

When you remove a component that satisfies one more multiple guided component search
connection points from a resource assembly using the Cut or Remove a line command,
Teamcenter updates the previously satisfied connection points and removes the connection
information from the connection points.

Attach notes to a component

1. From the assembly structure, select the component to which notes are being added.

2. Click Edit  on the toolbar.

3. Click the Notes button  on the toolbar.

The Notes dialog box appears.

4. In the Create list, select the type of note.

Remove components from a structure
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5. Type a note description in the description entry area.

6. Click OK. The note is added to the selected resource.

7. Click Save .

Edit notes attached to a component

1. From the assembly structure, select the component for which notes are to be edited.

2. If you are not already in edit mode, click the Edit button  on the toolbar.

3. Click the Notes button  on the toolbar.

The Notes dialog box appears. The existing notes are displayed.

4. In the Existing Notes list, select the note to be edited.

5. Modify the note as necessary.

6. Click OK. The note is edited.

7. Click Save .

Delete notes attached to a component

1. From the assembly structure, select the component for which the notes are being deleted.

2. If you are not already in edit mode, click the Edit button  on the toolbar.

3. Click the Notes button  on the toolbar.

The Notes dialog box appears. The existing notes are displayed.

4. In the Existing Notes list, select the note to be deleted.

5. Click Remove.

The note is deleted.

6. Click Save .

4. Creating resources
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Create graphics for a resource

When an object is classified under a storage class that is associated with an NX part family template or
template part, you can create a part family member and related graphics corresponding to the ICO.

Perform the following steps to create a new part family member and/or graphic for a resource:

1. Click the Create/Update graphic from ICO button .

Teamcenter displays the Create/Update Graphic dialog box.

2. Click the Part family template or Template part tab, depending on the type of template you are
using.

3. Select the template from the Template list.

Caution:

Teamcenter lists any mapped attributes that have not been assigned a value. You must assign
values to the listed attributes to create graphics from them.

4. Select Create part file to create a PRT file.

5. Select Create JT file to create a JT file.

Note:

If you do not choose to create the part or JT files at this time, Teamcenter creates a new part
family member and adds it to the template. You can create the files in a subsequent session
using Teamcenter Integration for NX.

6. Click Create/Update.

The system creates a new item and an item revision that contains the part files. The name of this
new item is the same as the object ID of the newly created ICO. The newly created ICO classifies the
item revision.

If you create graphics based on part family templates and you revise the item that contains the part
file, you must revise all part family members so that the members all have the same revision as the
top item.

There are several considerations when you are updating template parts.

Create graphics for a resource
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Update a graphic based on a template part

1. Open the ICO that you want to update, make any necessary changes to the attribute values, and
save the ICO.

2. Click the Create/Update graphic from ICO button .

The Create/Update Graphic dialog box is displayed.

3. Select one of the following:

• Refresh member part

Updates the geometry of an existing member part with the modified attribute values from the
ICO.

Refreshing a member part retains changes made manually to the member part in NX.

• Recreate from template

Discards the member part geometry and uses the geometry from the template part to re-create
the member part geometry.

Any manual changes made to the member part are lost.

Refreshing versus re-creating a template part

When you update graphics using the Create/update graphic from ICO command, it is important to
understand the difference between the Refresh member part and the Recreate from template options
to allow you to make the correct decision when creating graphics.

4. Creating resources
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In this example, a part for a flute drill is used as a template part. In Teamcenter, the tip angle is modified
and a member part is generated.

These two steps represent the most common workflow. At this point, if you modify any parameters
in Teamcenter, it makes no difference whether you select Refresh member part or Recreate from
template. The result is the same.

If, however, you modify the member part in NX, there is a difference between the two options. For
example, if the member part is modified in NX so that the tool holder is green and the tool width is
changed in Teamcenter, when the Refresh member part option is chosen, the graphics are created
taking both the changes to the member part in NX and the modified attribute values in Teamcenter into
consideration.

Selecting Recreate from template, however, discards any changes you made to the member part in NX
and creates the graphics based on the template part and the values in Teamcenter. Because the template
part in this example still has a gray holder, when you select Recreate from template, the drill holder is
now gray again.

Refreshing versus re-creating a template part
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Create graphics for multiple resources

1. With search results displayed in the Table view, select all instances in the table for which you want
to create graphics.

2. Click  at the bottom of the Table view.

Teamcenter displays the Create Graphics for Selected ICOs dialog box. If no part family template
(PFT) is defined for one of the instances listed, that line is highlighted in red.

If there are multiple PFTs assigned to a class, the background color is yellow. The default PFT is
selected. If you want to use a different PFT for the selected ICOs listed in the dialog box, click the
down arrow beside the name of the PFT and select a different PFT.

Note:

This PFT is used to generate graphics for all instances listed in the Create Graphics for
Selected ICOs dialog box. If you want to use different PFTs to generate graphics for ICOs in
the same class, you must select the ICOs accordingly in the Table view.

3. (Optional) Select Create part file and Create JT file.

Check box states Action

Teamcenter adds the ICO values to the PFT spreadsheet
and creates a part file.

Teamcenter adds the ICO values to the PFT spreadsheet
and no graphics are created. In this case, the JT check
box is unavailable.

Teamcenter adds the ICO values to the PFT spreadsheet
and creates a part file and a JT file. You can create JTs
only if the Create part file check box is enabled (default
state).

4. Click Create/Update.

4. Creating resources
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Teamcenter opens the Create Graphics Progress Results dialog box listing each ICO and the status
of the graphics creation. At the bottom of the dialog box, Teamcenter provides an explanation for
each failed generation attempt.

Classifying resources

Classify resources

Classifying a resource allows you to associate it with a class and assign to it the attributes of that class.

1. Select the root node of the assembly structure in the Resource view.

2. Click the Edit button in the toolbar, if you are not already in edit mode.

3. Click the hyperlink that displays the class name in the Classification Properties view.

Classify resources
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The Classification Information dialog box appears.

If this is the first time that you are classifying a resource in a session, the classification tree opens
the New Resource directory. If you already classified resources in a session, the system displays the
classification of the last item classified or loaded.

4. Expand the classification root to navigate through the classes and double-click the classification to
which the new item is being assigned.

There are two ways to assign an item to a classification class:

a. Double-click the desired class.

b. Right-click the desired class and choose Select.

When you select the classification class, attributes of the selected class are displayed in the
Classification Properties view.

5. Enter the attribute values of the new resource in the Classification Properties view.

6. Click Save .
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The resource is saved as a classified item.

If you specify that the root node of the resource structure is an assembly class, it can inherit propagated
attributes from the components within the structure.

Classifying resource assemblies

Resource assemblies that you create can be stored in the database as classified assemblies. If stored in an
assembly class, propagated attributes of the components in the resource hierarchy are also stored in the
assembly objects.

Your system administrator must create an assembly class through the Classification Admin application.

Resource Manager stores the resource data with classification information as objects in the database.
The classification information is managed in the Classification application and is displayed in a tree-type
hierarchy, called the classification hierarchy, consisting of nested classes. Each class contains a set
of attributes. The attributes are the characteristics of the resource class. This attribute information
typically contains the specification of characteristics of an object. For example, it may include values for
physical characteristics such as diameter, weight, or length. This classification information is stored in a
classification object referred to as an ICO. Each ICO is unique. When you classify a resource or resource
assembly, an ICO is attached to it.

You define the class hierarchy that categorizes your resources in the Classification Admin application.
This classification information enables you to search in both a hierarchical and product-independent
structure for resources.

Applying and inheriting attributes

About attribute inheritance

When creating a classification structure, administrators assign attributes to the different classes in the
hierarchy. These attributes describe each class and all subclasses of that class. Each subclass inherits
all the attributes that are contained in the parent class. Setting up the attributes in this way makes
searching more effective. You can select a top class and search for a tool within that class using a
particular value knowing that that attribute is also contained in all the child classes of the class. In the
figure below, you can see that only Attribute E is assigned to the Twist Drills class. All other attributes
are inherited from the parent classes.

Classifying resource assemblies
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Edit assembly attributes

1. Select the root node in the assembly structure.

2. Click the Edit button  on the toolbar.

3. In the Classification Properties view, edit the attribute values for the resource.

4. Click Save .

Edit the attributes of individual components

When you edit individual components, the component is modified in every assembly in which it occurs.
Because any edits made to component attributes are propagated throughout every assembly in which
the component appears, a security check is added to the application to make you reconsider your
decision to modify a component before you actually make the change. This security check requires that
you open the component in the BOM by itself so it displays as the root-level component.

1. Right-click the component to be edited in the assembly structure.

2. Do one of the following:

a. Choose Send to→Classification.

4. Creating resources
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b. In the Classification application, click Edit .

c. Modify the values as necessary.

d. Click Save .

e. Return to the Resource Manager application.

f. If necessary, refresh the component to see the changes.

-or-

a. Choose Send to→Resource Manager.

Note:

You must save the assembly before you do this.

Teamcenter opens the component in a new Resource view where it becomes the root node.

b. Click the Edit button  on the toolbar.

c. Edit the attribute values displayed in the Classification Properties view.

d. Click Save .

Teamcenter propagates the values of the modified component to all assemblies that use the
component.

e. Return to the assembly by displaying its Resource view.

Propagating component attributes to the resource assembly

About attribute propagation

Attribute propagation allows you to automatically populate the values for an assembly from the
structure, instead of manually re-entering component attribute values in each new assembly.

Teamcenter copies attribute values from individual components, which you specify as propagation start
points (PSP), to the root node of the assembly. In the example below, the Tip Angle attribute associated
with the Drill is propagated to the Tool assembly, because it is identified as the PSP.

About attribute propagation
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You can then focus your Classification searches on the assembly class and more quickly find the resource
data you need to manufacture a particular process or operation. Because selected component attributes
are stored in the assembly class, you do not need to search the entire component list to find the attribute
information you need.

PSPs define at which component in the resource structure attribute propagation begins. Only one PSP
is allowed per structure unless you are working with a multitool assembly. See Working with multitool
assemblies. You can set a PSP at any level in the resource assembly structure. When the assembly
is saved, Resource Manager identifies the PSP in the structure and looks to that component for the
attribute value to propagate. If the attribute is not found in that component, the application moves up
the structure hierarchy toward the root node one component at a time, until it finds the attribute. After
the attribute is found, its value is added to the root node and saved with the assembly.

Any attributes that are shown in the Properties view in italic are propagated attributes. This means that
Teamcenter searches for the component in the structure that is marked as the PSP  and displays that
value. In the above example, when determining which value to display for Adaptor Diameter in the tool
assembly, Teamcenter looks down the structure until it finds the component marked as the PSP, in this
case, the drill. It then searches first for the Adaptor Diameter attribute in the drill. The attribute is not
in the drill, so Teamcenter moves up the hierarchy and looks for the attribute in the adaptor. Teamcenter
finds the attribute, so it displays its value (10 mm) in the Adaptor Diameter box in the tool assembly.

Tip:

Click the NX CAM button  in the Properties view to see all the attributes that are applicable to
NX CAM. These are also the propagated attributes.
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The MRMPropagationAlternateAttributes preference allows you to specify alternate attributes for
propagation.

About attribute propagation
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Reverse attribute propagation

In some cases, the highest component in the structure contains the attribute that should be propagated
to other components in the structure. You can use a particular preference to identify specific attributes
that should propagate downward rather than upward. See About reverse attribute propagation.

Understanding propagated attributes

The following table demonstrates attribute propagation. In this example, the user, while in Classification
Admin, specifies the Test Assembly 1 class as an assembly class. Furthermore, in the assembly class,
Attributes 1–5 have the Propagated Property option selected.

Note:

For specific cases that include attributes at the upper levels of a structure that need to be
propagated downward, see About reverse attribute propagation.

When Teamcenter propagates attributes, it begins at the propagation start point (PSP), and then
travels upward through the parent levels looking for attributes to propagate. In the example, the first
component it looks at is Component 4. The component contains Attribute 4, which is a propagated
attribute, so Teamcenter propagates Attribute 4 to the resource assembly, Test Assembly 1. Teamcenter
then looks at the parent of Component 4, which is Component 3, and finds two attributes to
propagate. It then looks at the parent of Component 3, which is Component 1, and finds Attribute
2 to propagate. Component 1 also contains Attribute 1, but this value has already been populated
by Component 3. When Teamcenter is finished with propagating attributes, the top-level resource
assembly, Test Assembly 1, shows the following attribute values:

Attribute Propagated from

Attribute 1 Component 3

Attribute 2 Component 1
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Attribute Propagated from

Attribute 3 Component 3

Attribute 4 Component 4

Attribute 5 contains no value. Although there is a value assigned to this attribute in Component
2, Component 2 does not lie within the propagation path as it is not a parent or grandparent of
Component 4, the PSP. Similarly, Components 6 and 7 do not lie within the propagation path.

A gray PSP indicates that this PSP is defined in the context of a subassembly. It is not taken into
consideration in the current tool assembly. Subassemblies are highlighted with a colored background in
Resource Manager.

Creating an assembly class that contains propagated attribute values

Before attribute values can be propagated from individual resource structure components to the top-
level resource assembly, the class in which the assembly is stored must be classified as an assembly class
within the Classification Admin application.

The assembly class defines which attributes can be propagated from the resource structure components.
As you create the assembly class with the Classification Admin application, choose the Assembly option
on the Class Details tab. As you create the class attributes on the Class Attributes tab, choose the
Propagated Property option for every attribute of the class that has its value propagated from within
the resource structure.

Add a propagation start point

1. Select the component in the hierarchy to which you are adding a propagation start point.

2. Click the Edit button  on the toolbar.

3. Choose View→Propagation Start Point, or click the Propagation Start Point button  on the
toolbar.

The propagation start point is added to the resource structure. The  symbol displays next to
the selected component of the active propagation start point. Any propagation points defined in
subassemblies are inactive and display the  symbol.

4. Click Save .

Remove a propagation start point

1. Select the component in the hierarchy from which you are removing a propagation start point.

2. Click the Edit button  on the toolbar.

Creating an assembly class that contains propagated attribute values
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3. Choose View→Propagation Start Point, or click the Propagation Start Point button  on the
toolbar.

The propagation start point is removed from the resource structure.

Note:

When you remove a propagation start point, the propagated values are not deleted. The
values remain visible in the attribute fields, and you can modify them if necessary. If you do
not want the values, you must remove them manually from each field.

4. Click Save .

About reverse attribute propagation

By default, assembly attributes are propagated bottom-up. Starting from the propagation start point
(PSP) , the components are checked up to the root component to find specific attribute values.
The first component closest to the PSP provides the value applied to each component above it in the
structure. Reverse propagation works in a similar way, but the attributes are propagated downward from
the first component after the PSP.

You can control which attributes are propagated downward by adding the attribute title to the
preference MRMPropagationReverseAttributes. All attributes listed in the preference propagate in
the opposite order: For these attributes, the system checks from the component closest to the root
component down the structure to the component with the PSP. In this case, the value of the component
closest to the root are propagated downward.
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Editing propagated attributes

If any component in a resource assembly contains a propagation start point, you cannot edit the
propagated attribute. If, however, attributes in the class are marked as Propagated, but no propagation
start point is assigned, you can enter a value for the propagated attribute values. If, subsequently, you
assign a propagation start point, the propagated values overwrite any values you manually entered at a
higher level.

When you remove a propagation start point, the propagated values are not deleted. The values remain
visible in the attribute fields, and you can modify them if necessary. If you do not want the values, you
must remove them manually from each field.

Assigning site-specific properties to resources

About site-specific properties

Some organizations maintain statuses for tools in their databases such as:

• Trial

• Phased in

• Operational

Editing propagated attributes
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• Phased out

• Obsolete

These statuses can also be dependent on location. For example, a tool assembly may be operational in
the American plants but already be phased out in the Chinese plants.

You can manage these such statuses using site-specific properties. The general procedure for doing this
is as follows:

Note:

Your administrator must set up the site-specific properties

1. Assign site-specific properties to a resource.

You do not need to edit a resource to add site-specific properties to it. This has the advantage that
you can add site-specific data to a resource to which you do not have write access.

2. Search for a resource by site.

Assign site-specific properties to a resource

1. Open a resource in the Resource view.

2. Click the Create/update site specific data for resources button at the top of the Resource view.

3. In the resource site data dialog, click the Create site data  button.
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4. Select the appropriate attribute values. If there are multiple visible tabs, select the correct tab
before creating the data.

Working with multitool assemblies

Overview of multitool assemblies

Multitools are tool assemblies that have more than one cutter.

Overview of multitool assemblies
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Multitools save costs by reducing the need for extra tool components, and save setup time between
operations that use different cutters. Using Resource Manager, you can create multitools in a way similar
to the methods for creating other tools. Resource Manager displays the multiple cutters in one assembly.
Each cutter is assigned its own tool type and is able to have its own attribute propagation start point
(PSP) in the resource BOM structure.

You can also search specifically for multitools in NX CAM and retrieve them from the MRL tool library.
The required tool parameters are passed from Teamcenter to each cutter in the multitool assembly. The
multitool is then used to create and simulate the tool path.

Multitool classification

Multitools are stored in the existing tool assembly classes. In support of multitools, the following
multitool attributes are available in the assembly classes:

• Multitool MT: Identifies a multitool

• Cutter ID CID: Unique cutter identifier used for multitools

• Cutter Name CNA: Description for a cutter typically used in a multitool

• Index Notch INN: Rotation angle around tool axis to position tool cutter

• Turret Rotation TUR: Incremental turret rotation angle to position tool cutter

Note:

The attributes Multitool and Cutter ID are set to read-only. These attributes are automatically
updated by the system.
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How Resource Manager handles cutter IDs for multitools

Resource Manager manages multiple cutters by assigning unique cutter IDs for each cutter in the
multitool assembly.

Example:

The multitool with the item revision ID nxt_multi_04_00815/B has three cutters assigned:

• ID classification object (ICO) is nxt_multi_04_00815/B#1

• ICO is nxt_multi_04_00815/B#2

• ICO is nxt_multi_04_00815/B#3

When you create multitools, the system first checks if the existing tool has multitool classification objects
attached, and determines the appropriate cutter ID. The default cutter ID is 2, unless more than one
cutter is already in the assembly. If more than one cutter is present, the next cutter added is assigned the
next available cutter ID number. The assigned cutter ID is stored in the attribute Cutter ID.

ICO assignment for multitools

When you create a multitool assembly, a new ICO is created and attached to the same classified tool item
or revision as the original tool assembly.

By default, the new ICO resides in the same class as the original tool assembly. All shared values
are copied into the new cutter ICO, while all other fields remain initially empty. One exception is the
NX-Tool-Type, which is initialized according to the default value for this class.

Note:

The above condition results in tools having multiple classifications defined to attach cutter ICOs.
We do not recommend that you use multiple classification with tool assemblies in other scenarios.

Create a multitool assembly

1. Assemble a new tool assembly, or open an existing tool assembly that contains multiple cutters.

Create a multitool assembly
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2. In Cutter Name, type a name for each cutter.

3. (Optional) Change or assign other cutter attributes as needed, for example Index Notch or Turret
Rotation.

4. Set the Propagation Start Point (PSP) for the first cutter.

5. (Optional) Change the classification for each cutter as needed by selecting the corresponding tool
tab, and edit the classification.
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The attributes for the new classifications are loaded.

6. Click Save .

The attributes are propagated from the components to the tool assembly.

Since multitools contain multiple cutters, you can define tool-specific attribute values for each
cutter. This is possible because Resource Manager adds a tab for each tool at the bottom of the
Classification Properties tab.

7. Select the assembly and choose File→New→Multitool Cutter, or click the Add Multitool Cutter
 on the toolbar.

Note:

The option to create multitools is available only if a resource is loaded in Resource Manager.

Note:

The Multitool MT attribute is automatically set to Yes.

8. You can now add a PSP for each cutter.

Create a multitool assembly
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Note:

When you define the multitool, the PSP indicator text changes from black to red . This indicates
the tool is part of a multitool. Additionally, only the PSP indicator of the active tool continues
to have a yellow background. The PSP indicators for other tools that are not active have a gray
background .

Deleting multitool cutters

When you delete a multitool classification object (ICO) using , Resource Manager deletes only
the currently selected cutter ICO. If the cutter you delete is the second to last cutter, the system
automatically cleans up the multitool status information.

The attribute Multitool is set to O:No and only one ICO remains with the tool assembly. Once a multitool
cutter ICO is deleted, the system removes the related PSP.

Building tool assemblies overview

When building new tool assemblies in Resource Manager, search first in your customer hierarchy to find
existing components that you can reuse. If you do not find any, continue to search in the vendor catalog,
and then map that component to the customer hierarchy.

The following chart shows the approach that enables the maximum amount of reuse of existing
material.
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Creating new resources based on existing ones

Map ICOs from one class to another

If you want to create a new classification object based on an existing one, you can copy the attribute
values to the target class using the map feature. For example, if your classification structure contains
both a vendor and a customer hierarchy, you may want to map ICOs from a vendor class to a customer
class.

Map ICOs from one class to another
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Your classification administrator must set up mapping definitions in the Classification Admin application
before you can perform mapping procedures.

Caution:

You cannot map a metric ICO to a nonmetric ICO and vice versa.

1. In the Classification Search Dialog, select the source class in the hierarchy that you want to map
to another (target) class.

2. Select the appropriate ICO from the source class.

3. Click .

The New Item dialog box is displayed.

4. Type a unique identifier for the new item in the Item ID box or let Teamcenter automatically create
a name for you by clicking Assign.

5. Type a name in the Name box.

6. Select the item type of the new resource.

The following four types are generally used to create a new resource:

• Resource – for resources

• NC Tool – for tools

• NC Machine – for machines (do not confuse with NC Machining Operation)

• Equipment – for use with Tecnomatix applications

Teamcenter selects the default value of this entry based on the definition in the MRMItemTypes
preference.

7. Select the Copy datasets from source item option to copy attachments such as 3D models from
the source item, for example, a vendor tool class, to the target item such as a customer class.

8. Select the Import Model to Target Item option if you are mapping from a vendor catalog to a
customer class and want to import the 3D models directly from the vendor catalog.

9. Click OK.

If there are multiple possible target classes specified in the mapping definition, the Target Class
Selection dialog box is displayed:
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a. Choose the desired target class from the list.

b. Click OK.

The New Item dialog box is displayed.

c. Enter the required information and click OK.

Teamcenter creates a new ICO and item in the target class and maps attributes from the source
class to attributes in the target class as specified by the mapping definition in Classification Admin.
The new ICO is displayed in the target class, and its attributes are shown in the Classification
Properties view.

Map multiple ICOs

You can only map multiple ICOs when all the selected ICOs in the search results belong to the same
class.

1. Search for the desired ICOs.

2. Display the search results in the classification table.

3. Select all desired ICOs and click .

If there are multiple possible target classes specified in the mapping definition, the Target Class
Selection dialog box is displayed:

a. Choose the desired target class from the list.

b. Click OK.

The New Item dialog box is displayed.

c. Enter the required information and click OK.

Teamcenter creates new ICOs and items in the target class and maps attributes from the source
class to attributes in the target class as specified by the mapping definition in Classification Admin.
It assigns IDs automatically.

Map multiple ICOs
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Enabling, creating, and opening tool setup sheets

Create tool setup sheets

A tool engineer creates tool setup sheets to communicate to the tool room personnel what components
to assemble and how to set up the tool assemblies required for each manufacturing job. Tool engineers
create setup sheets for a number of different purposes:

• To define the shape and properties of tool assemblies that are required for specific manufacturing
jobs. 

• To describe the shape and properties of tool components that make up such assemblies.

• To convey the shape of a tool through one or more parametric drawings.  The tool properties provide
the parameter values for such drawings.

• To list the tool components required to create the tool assembly for a manufacturing job.

You can use several different procedures to create tool setup sheets.

Create tool setup sheets with Resource Manager on Active Workspace

You can create tool setup sheets in Resource Manager

1. Select the root node of an assembly resource.

2. Click Create setup sheets .

3. Click OK.

Create tool setup sheets with NX Tool Assembly Part File

You can create tool setup sheets in the NX Tool Assembly Part File dialog box.

1. Select a tool assembly part file.

2. On the Resource Manager toolbar, click Create/update NX tool assembly part file .

3. Select the Create Setup Sheets  check box.

4. Click OK.

4. Creating resources

4-44  Resource Manager on Rich Client, Teamcenter 2412
© 2025 Siemens



Create tool setup sheets in Classification Table view

You can create tool setup sheets in the Classification Table view.

1. In the Classification Table view, select the rows containing the tools that you will create tool setup
sheets for.

2. Click Create setup sheets .

3. Click Yes in the Create Setup Sheets dialog box.

Tool setup sheet files

The setup sheets function creates a PDF file, NX drawing file, and a CMG file.

Note:

• The create setup sheets function uses the graphics builder. If the graphics builder is not yet
running, you may experience a short delay while the graphics builder starts in the background
before the function is complete.

• The tool attribute values are always transferred in the ICO's unit.

• If the tool assembly is an inch assembly, the inch values are entered in the setup sheet.

• If the tool assembly is a metric assembly, the metric values are entered in the setup sheet.

Open an assembly tool setup sheet

You can open a tool setup sheet from either of these views.

Open from the Classification Properties view

1. Load a tool in Resource Manager.

2. Click the Classification Properties view.

In the instance viewer, the setup sheet is shown as a tab. Click .

Open from the Attachments view

1. Load a tool in Resource Manager.

2. Click the Attachments view.

Open an assembly tool setup sheet
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3. Double-click a tool setup sheet dataset.

The tool setup sheet opens in the viewer associated with the dataset type.

Automatically assembling resources in Resource Manager

Automatic resource assembly overview

Resource Manager uses coordinate systems to position components at the correct location when
creating tool assemblies. These coordinate systems are defined in the part family templates in the
Manufacturing Resource Library or imported from NX. When you create graphics for the part family
template components, these coordinate systems are created and then saved to Teamcenter when you
save the part file. When you add a component to an existing one, either manually or using the guided
component search (GCS), Teamcenter checks the coordinate systems and aligns them according to
preset rules.

You can see the correctly assembled tools in the Graphics view.

By default, Teamcenter uses two types of coordinate systems as specified in the DIN4003 tooling
standard: the machine-side coordinate system (MCS) and the coordinate system workpiece-side (CSW).
Each component has one MCS and any number of CSWs. If the component has multiple CSWs, they
follow a naming scheme.

When Teamcenter builds the assembly, it always moves the component containing the CSW to the
part containing the MCS. The transformation matrix of the component BOM line containing the CSW is
updated whereby that of the component containing the MCS remains unchanged.

When you create a tool assembly, there are different methods to add components to build the assembly.
You can use the Add Classified Component command, paste a component from the clipboard, or use
the guided component search. The method available for you to use to add components depends on the
object in the existing hierarchy that you select. The figure illustrates the different options available.
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When you select one of these
Use these commands to add a component

Tool component Add Classified Component
or

PasteCoordinate system

Connection point Guided Component Search

Where in the tool assembly hierarchy the component is added is also affected by:

• Which object you select to add a component.

• Which method you use to add the component.

When adding a new component, Teamcenter determines where in the hierarchy to add the component.

Connection
point

Coordinate
system Direction Direction in the hierarchy

 Plug MCS Machine-side  Up

 Socket CSW Workpiece-side  Down

When joining the two components, Teamcenter joins a CSW to the MCS. If there are multiple possible
CSWs, the user must determine which coordinate system to use.

If, for example, you have this assembly:

You want to add this new component:

Automatic resource assembly overview
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If you select the CSW in the assembly and use the Add Classified Component command, Teamcenter
searches for the MCS in the component to be added and adds it below the selected CSW in the hierarchy
(the down direction).

If, however, you select the MCS in the assembly, Teamcenter finds three CSWs in the component to be
added. You must select the correct coordinate system to use, and then Teamcenter adds the component
above the component with the selected MCS (the up direction) in the assembly. In this example, the new
component, C2 is added above C1.

If your company uses custom names for coordinate systems, your administrator can modify the
coordinate system names in the following preferences:

• MRMPlugCSYSPrefixes

• MRMSocketCSYSPrefixes

• MRMNeutralCSYSPrefixes

Add a component by selecting a connection point

1. In the resource you are modifying, select a connection point (plug or socket) and choose
Edit→Guided Component Search or click . You can select one or multiple connection points
of the same type (either only plugs or only sockets). If you select multiple connection points, these
must:

• Have the same shape.
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• Have the same connection type.

• Belong to the same connection point definition.

• Belong to the same component.

Teamcenter displays the Classification Search Dialog with a limited number of matching results.

2. Search for a suitable component in the Classification Search Dialog and add it to the existing
hierarchy.

Teamcenter adds this component to the assembly. The new component is added above or below the
component with the selected connection point, depending on whether you initially selected a plug or a
socket. The component containing the CSW (representing the socket connection point) is moved to the
component with the MCS.

If you select multiple connection points, an occurrence of the new component is added to each of these
connection points.

Add a component by selecting a coordinate system

1. In the resource you are modifying, select a coordinate system (MCS or CSW) and choose Add a
Classified Component or click .

2. Search for a suitable component in the Classification Search Dialog and add it to the existing
hierarchy.

Teamcenter checks for matching coordinate systems. If you select an MCS and there are multiple
CSWs in the component being added, Teamcenter requests that you select the correct coordinate
system to align.

Teamcenter adds this component to the assembly. The new component is added above or below the
component with the selected coordinate system, depending on whether an MCS or CSW was initially
selected. The component containing the CSW is moved to the component with the MCS.

Note:

If you have a suitable component in the clipboard, you can also use Paste to add a component.

Add a component by selecting a component in the assembly

1. In the resource you are modifying, select a component and choose Add a Classified Component or
click .

2. Search for a suitable component in the Classification Search Dialog and add it to the existing
hierarchy.

Add a component by selecting a coordinate system
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Teamcenter checks for matching coordinate systems. If there are multiple CSWs in the component
being added, Teamcenter requests that you select the correct coordinate system to align.

If you configured the guided component search, Teamcenter performs some of the decision-
making for you. It searches for components that fit the given criteria. If you begin by loading
a holder, and then work toward the tooltip using the Add Classified Component or Paste
commands, Teamcenter uses the guided component search (GCS) information to determine which
coordinate system to use to position the new component. If the component you want to add
does not contain GCS data, Teamcenter asks you which coordinate system to use to position
the component. If you select a coordinate system or a connection point to add a component,
Teamcenter positions the part automatically.

Teamcenter adds this component to the assembly. The new component is always added below the
selected component when using this method. The component containing the CSW is moved to the
component with the MCS.

Note:

If you have a suitable component in the clipboard, you can also use the Paste command to add a
component.

Assemble and prepare a part file for NX CAM

After you create a tool assembly, Teamcenter assists you in creating or updating the NX tool assembly
part file. This procedure sets CAM-related tool information required by the machine tool builder in NX so
this tool can later be used for tool path simulation.

This feature uses the graphics builder to communicate with NX and it is, therefore, important that the
graphics builder is correctly installed and configured on your system.

1. Select the root node of the tool assembly.

2. Choose Tools→Create/Update NX Tool Assembly Part File or click .

Teamcenter displays the NX Automatic Tool Assembly dialog box.

3. Select the desired options.

Option Description

Set tool
junctions

The tooltip and tool mount junctions are added to the assembly part file.

Identify cutting
and non-

The solids in the tool components are added to the CUTTING or NON_CUTTING
groups in NX.

4. Creating resources
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Option Description

cutting
geometry

These are displayed in the machine tool builder and saved in the assembly part file
in NX.

Generate
spinning
geometry

The CUTTING_SPUN and NON_CUTTING_SPUN geometry are saved with the tool
assembly for milling and drilling tools. The information for this geometry comes
from the CUT and NOCUT information of the tool components that are used in the
tool assembly.

This option is not available for turning tools.

Assemble and prepare a part file for NX CAM
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Option Description

Write NX part
attributes for
tracking points

If the tool mount and tooltip junctions are defined in the assembly part file, NX
calculates the setup offsets based on these two junctions and writes them into the
part properties in the part file, setting the CAM_TOOL_ATT_X, CAM_TOOL_ATT_Y,
and CAM_TOOL_ATT_Z properties.

Additionally, NX system tracking points are imported into the resource for milling
and drilling tool assembly classes.

Create Setup
Sheets

Setup sheets are generated based on templates that are saved with the class.

Extract Holder
Data

Tool holder parameters that are required by NX to calculate collision avoidance are
automatically imported into Teamcenter.

4. Click OK.

An NX assembly part file is created in which all tool components are correctly positioned and
includes the additional tooling information. The part properties are mapped to Teamcenter as
follows:

CAM_TOOL_ATT_X is mapped to the resource library attribute -45002 Nomin. Setup X.

CAM_TOOL_ATT_Y is mapped to the resource library attribute -45003 Nomin. Setup Y.

CAM_TOOL_ATT_Z is mapped to the resource library attribute -45002 Nomin. Setup X (for
turning tools).

Note:

The NX part attribute to Classification mapping must be configured.

Your tooling administrator must enable the synchronization of Setup X, Setup Y, and
Setup Z attribute values to use this feature.

About NX system tracking points

In resource assembly classes, there are two blocks of attributes pertaining to tracking points:

• Tool tracking points that you manually enter.

4. Creating resources
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• System tracking points that you import from NX using the Create/Update NX Tool Assembly Part
File feature and that you should not modify manually.

The following values are imported from NX to Teamcenter when you select the Write NX part attributes
for tracking points option:

Name
Sequence
Nominal Setup X
Nominal Setup Y

You can modify the Sequence number to change the order in which the system tracking points are
displayed in NX.

You must add the following values manually:

Nominal Setup Z
Adjust
Cutcom

The following values are passed back from Teamcenter to NX:

Sequence
Nominal Setup Z
Adjust
Cutcom

System tracking points are available in the following classes:

About NX system tracking points
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• The Drilling root class, TAG003_DRILL, where it is inherited by all drilling views. The array size for step
drills (TA_DRILL_20_30) is 8.

• The Milling root class, TAG002_MILL, where it is added to the following assembly milling views:

TA_MILL_40: slotting cutters
TA_MILL_50: angle mills
TA_MILL_60: round profile cutter
TA_MILL_70: thread mills
TA_MILL_90_90: special mills

For this mechanism to function properly, there are several prerequisites:

• Version 4.0 of the Manufacturing Resource Library (MRL) must be installed.

• The CAM setup must be loaded using the MRL installer (Populate database→Import MRL NX Seed
Parts→Template parts for temporary tool retrieval(

• The NX attribute mapping must be in place.

• The tool must be properly defined so that the tool retrieval in NX functions correctly.

Create and publish a coordinate system in NX

If you use the Manufacturing Resource Library, the coordinate systems for each component are defined
in the part family templates. In a manual configuration, you must perform the following steps to publish
the coordinate systems from NX to Teamcenter:

1. In NX, create a coordinate system of the Datum CSYS type and give it a name that conforms to the
DIN4003 naming standard.

2. Add the coordinate system to the product interfaces by choosing Tools→Product Interface.

3. Choose File→Options→Save Options and select Save JT Data.

Tip:

Confirm the auto-position setting in NX: File→Utilities→Customer Defaults→Teamcenter
Integration→General→Feature→Product Interfaces is set to Relations.

4. Creating resources
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DIN4003 coordinate system naming scheme

The DIN4003 standard defines how 3D graphic models for different tool component classes must be
designed. This standard also defines the coordinate systems in the tool components using the following
naming scheme:

MCS

Machine-side coordinate system

CSW

Coordinate system workpiece-side

A tool component always has one MCS and any number of CSWs, depending on its design. If it has
a single CSW, the coordinate system is called CSW. If it has multiple CSWs and dedicated steps (see
example), the coordinate systems are additionally numbered in ascending order, using a system that
is dependent on the shape of the component. The examples provide an introduction to the naming
convention.

Tool component MCS CSW

Insert: DIN4003_76_01
[TC_INSERT_10_00_100]

Pointing toward the
holder

None

DIN4003 coordinate system naming scheme

Resource Manager on Rich Client, Teamcenter 2412  4-55
© 2025 Siemens



Tool component MCS CSW

Holder: DIN4003_90_02
[TC_TURN_40_00_100]

Pointing toward the
machine adapter

CSW pointing toward the insert

Tool component MCS CSW

Drill: DIN4003_86_04
[TC_DRILL_20_20_100]

Pointing toward the
machine adapter

CSW_1 pointing toward the insert

CSW_2 pointing toward the insert

4. Creating resources
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Tool component MCS CSW

Step drill: DIN4003_86_05
[TC_DRILL_20_20_110]

Pointing toward the
machine adapter

First step: CSW1_1, CSW1_2 (pointing
toward the inserts)

Second step: CSW2_1, CSW2_2 (pointing
toward the inserts)

Third step: CSW3_1, CSW3_2 (pointing
toward the inserts)

Fourth step: CSW4_1, CSW4_2 (pointing
toward the inserts)

DIN4003 coordinate system naming scheme
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Tool component MCS CSW

Shell end mill:
[TC_MILL_20_20_120]

Pointing toward the
machine adapter

CSW_1, CSW_2, CSW_3, CSW_4, CSW_5,
CSW_6, CSW_7, CSW_8 (all pointing
toward the inserts)
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Tip:

Confirm the auto-position setting in NX: File→Utilities→Customer Defaults→Teamcenter
Integration→General→Feature→Product Interfaces is set to Relations.

DIN4003 coordinate system naming scheme
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Configure the graphics builder for NX automatic tool assembly

Before you assemble a part file for NX, you must ensure that the graphics builder is correctly configured.

1. Install and configure the graphics builder as explained in Basic Classification ─ Deployment and
Administration.

Note:

Do not use the method described in Using Tcl scripts to install the graphic macros. Proceed to
the next step instead.

2. Install the graphic macros required by NX as explained in Getting started with administering
Manufacturing Process Planning ─ Deployment and Administration.

Note:

The name of the option in the manufacturing installation has changed from Configure
Fixture TCL Graphic Macros to Configure TCL Graphics Macros.

3. Install and configure the MRM seed parts from MRL setup.exe

4. Creating resources
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Extract tool holder data

In NX CAM, the tool path calculation can take the shape of the tool holder into consideration. A larger
tool holder results in a bigger tool offset to the part being machined. For this calculation, NX uses tool
holder attribute values. However, NX does not use holder values from the 3D geometry for tool path
generation. It uses attributes that it imports from Teamcenter. If these values do not exist in Teamcenter,
the NX CAM user must measure the holder manually, which can be very time-consuming.

You can automatically import the tool holder attribute values from the 3D geometry into Teamcenter,
saving you the time required to fill out the holder attribute array manually, ensuring a more accurate
holder definition, and reducing the chance of holder collisions when running the tool path on the
machine.

The tool holder parameters are measured only up to the tool mount junction.

Extract tool holder data
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Teamcenter supports holders with up to 23 steps. If the holder has more than 23 steps, the 23rd step
is set to a cylinder with the widest diameter of the remaining steps and a length up to the tool mount
junction.

For this mechanism to function properly, there are several prerequisites:

• Version 4.0 of the Manufacturing Resource Library (MRL) must be installed.

• The CAM setup must be loaded using the MRL installer (Populate database→Import MRL NX Seed
Parts→Template parts for temporary tool retrieval).

• The NX attribute mapping must be in place.

• The tool must be properly defined so that the tool retrieval in NX functions correctly.

• The MRMHolderData preference must be set to true.

To extract tool holder parameters:

1. Create or open a tool assembly containing 3D components.

2. Select the tool's root node and do one of the following:

a. Click the tool holder data extraction button on the menu bar.

Or

a. Click .

Teamcenter displays the NX Automatic Tool Assembly dialog box.

b. Select the Extract Holder Data option and click OK.

The tool holder parameters are imported into the resource.

To calculate the holder start value, the Teamcenter adds the cutting component's protruding length
(LPR/-40183) to the negative tool tip's nominal setup X value (X/-45002), unless the provided
protruding length is greater than the overall length of the cutting component. In this case, Teamcenter
computes the overall length of the cutting tool component by adding up the NX cutter's tool height
(PARAM_TL_HEIGHT_INDEX), shank length (PARAM_TL_TAPERED_SHANK_LENGTH_INDEX), and up

4. Creating resources
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to two shank segments (SL/-45262:2, -45262:3) that can be defined in Teamcenter, which are then
added to the negative tool tip's nominal setup X value.

When NX CAM retrieves the tool assembly, it can sometimes calculate a positive holder offset value (OS)
to correct the display position of the parametric holder by the length that the cutting component is
embedded into the tool holder. This is usually the difference between the overall length of the cutting
component and its protruding length. If the calculated holder offset is null, the parametric holder is
displayed right above the cutting component and does not overlap with it.

Occasionally, due to a manual adjustment of the offset value or unavailability of attribute values, the
holder is displayed in the incorrect position. If this occurs, manually adjust the holder offset value.

Leveraging MRL resources in NX CAM

Using resources in NX CAM

If you run NX CAM in native mode, but want to use tools that are managed in Resource Manager,
you need access to DEF and DAT files that contain the most up-to-date classification and resource
information. You can export the classification hierarchy and the information about classified resources
using the mrm_export_resources utility. Optionally, you can also export attached documents.

To run the NX CAM Integration (managed mode), your environment must first be configured.

Fixture and machine modules

Prior to Teamcenter 13.2, the module {MACH} Machines and Devices contained a simple class structure
of eight and four classes.

Beginning in Teamcenter 13.2, machine classes are in the {MAC} Machines module and the devices
are in the {FIX} Fixtures and Devices module. These modules are robust and are based on industry
standards.

Machines module setup

The {MAC} Machines module released in Teamcenter 13.2 is a replacement for the existing {MACH}
Machines and Devices machine classification.

It is possible to use both machine class structures in the same database.

There are three ways you can set up your system:

• New customers use the new machine classes.

• Existing customers use the old machine classes.

• Use both machine classes to facilitate a migration from old to new.

Using resources in NX CAM
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There are three machine definition files for the NX library machine search included in the 6.2
Manufacturing Resource Library (MRL). These definition files are copied to the folder %UGII_BASE_DIR%
\MACH\resource\library\machine\inclass when you select the Configure NX-CAM option when you use
the MRL setup.

You can decide which libraries are included in the NX machine search:

By default the dbc_inclass_mach_en.def definition file is used.

• To show only the new machine classes, choose the dbc_inclass_mach_en_MRL6.2.def definition file.
Then rename the file dbc_inclass_mach_en_MRL6.2.def to dbc_inclass_mach_en.def.

• To show only the old machine classes, choose the dbc_inclass_mach_en_MRL6.0.def definition file.
Then rename the dbc_inclass_mach_en_MRL6.0.def to dbc_inclass_mach_en.def

• To show both the old and the new classes, choose the dbc_inclass_mach_en.def definition file.

Devices module setup

The {FIX} Fixtures and Devices module released in Teamcenter 13.2 is a replacement for the existing
{MACH} Machines and Devices device classification.

It is possible to use both device class structures in the same database.

There are three ways you can set up your system:

• New customers use the new device classes.

• Existing customers use the old device classes.

• Use both device classes to facilitate a migration from old to new.

There are three device definition files for the NX library device search included in the 6.2
Manufacturing Resource Library (MRL). These definition files are copied to the folder %UGII_BASE_DIR%
\MACH\resource\library\device\inclass when you select the Configure NX-CAM option when you use
the MRL setup.

You can decide which libraries are included in the NX device search:

By default the dbc_inclass_device_en.def definition file is used.

• To show only the new device classes, choose the dbc_inclass_device_en_MRL6.2.def definition file.
Then rename the file dbc_inclass_device_en_MRL6.2.def to dbc_inclass_device_en.def.

• To show only the old device classes, choose the dbc_inclass_device_en_MRL6.0.def definition file.
Then rename the dbc_inclass_device_en_MRL6.0.def to dbc_inclass_device_en.def

4. Creating resources

4-64  Resource Manager on Rich Client, Teamcenter 2412
© 2025 Siemens



• To show both the old and the new classes, choose the dbc_inclass_device_en.def definition file.

Setting options for checking tool attribute values for NX CAM

Tools and tool components can contain many attributes, depending on the tool class. Not all of these
attributes are mandatory for using these tools in NX CAM. Teamcenter automatically checks that all
required attributes are filled in when you save an assembly. Additionally, you can manually initiate a
check to ascertain that all values required for successfully using resources in NX CAM are filled in.

Note:

The tool attribute check only works for MRL tool assemblies.

• A check is run automatically whenever a resource assembly is saved unless the No checking option is
selected in the Set Default Criteria dialog box.

• You can initiate a manual check at any time.

Two settings affect the contents of the report:

• Display errors

Displays a list of mandatory attributes that are not filled in.

• Display errors and information

Displays a list of mandatory attributes that are not filled in, and lists the optional attributes that do not
have values assigned and for which default values are being used.

Two types of checks are available. You can choose one or both options.

• Check NX CAM tool retrieve verifies that the tool created by the tooling engineer in Teamcenter is
retrieved in NX CAM properly.

Note:

The Configure the graphics builder for MRL and NX 12.0.2 MP3, or newer must be installed and
configured to use this option.

• Check NX CAM tool parameters verifies that the parameters specified with the tool contain
associated non-zero values.

Note:

This option does not require NX or the Graphics Builder.

Setting options for checking tool attribute values for NX CAM
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Teamcenter runs the check and reports the errors or information in the Tool Checker Results dialog
box. You can use this information to add values to the required attributes. If you select the Errors and
information level of checking, Teamcenter informs you of instances where it uses a default value or
uses one of several alternate attribute values.

These report examples are based on both checks being performed:

• No issues with either check

• Parameter check is successful, but the retrieve check is not

• Multitool check with both options is successful

4. Creating resources
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Manually check tool attribute values for NX CAM

Initiate a manual tool check.

1. With a tool assembly in view mode selected, click  or choose Tools→Tool Checker→Check Tool
Attributes.

2. In the Check Tool Attributes dialog box, select the level of reporting.

• Display errors

• Display errors and information

3. Select one or both types of check.

• Check NX CAM tool retrieve

• Check NX CAM tool parameters

4. Click OK.

5. Review the report and correct any data issues found.

Automatically check tool attribute values for NX CAM

Set the criteria for checking tool attribute values.

Note:

With the criteria set, Teamcenter runs the automatic check when you save a tool resource
assembly.

1. Choose Tools→Tool Checker→Set Default Criteria.

2. Select the desired reporting level.

Tip:

Select No checking if you do not want Teamcenter to perform an automatic check.

• Display errors

• Display errors and information

3. Select the type of check.

Manually check tool attribute values for NX CAM
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• Check NX CAM tool retrieve

• Check NX CAM tool parameters

4. Click OK.

5. After you save a tool resource assembly, review the report and correct any data issues found.

4. Creating resources
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5. Adding vendor catalogs
Using the Manufacturing Resource Library

To assist you in filling the classification hierarchy with data, you can use the Manufacturing Resource
Library. When you install this library, the data is organized in a detailed classification structure of
manufacturing data such as tools, machines, fixtures, assemblies, and components, including tool
graphics.

The tooling classification tree contains two hierarchies:

• An initially empty catalog hierarchy (Vendor Catalogs) that can contain tool components found in
major tool vendor catalogs

• A customer hierarchy (Tools) that contains the components and assemblies used at your site

You can copy relevant components from the catalog into the customer hierarchy using the mapping
definitions that are delivered with the vendor catalog tooling library. After installing the Manufacturing
Resource Library, you can install vendor catalogs from various tool vendors to fill the catalog hierarchy.

Note:

Vendor catalogs are provided separately and are not part of the Manufacturing Resource Library
installation kit. Contact your Siemens Digital Industries Software representative for more details.

Warning:

Do not modify the catalog data as these changes are lost when the vendor catalogs are updated.
Save all your customer-specific components and assemblies in the customer hierarchy.

Part family templates that you can use to quickly create graphics are included in some component
classes. To find the classes to which part family templates are assigned, search the class hierarchy for the
DIN4003 alias name using the quick search feature.

The Manufacturing Resource Library is provided with the Teamcenter installation image. It is updated
regularly.

Using a tool vendor catalog

You can import tool vendor catalogs directly into Teamcenter. These catalogs use the Generic Tool
Catalog (GTC) format based on ISO 13399 tooling standards. When tool vendors deliver their tool
catalogs in this format, you can import them into a vendor tooling hierarchy in the Manufacturing
Resource Library. You can then select tool components in the vendor catalogs and map them to a
customer branch of the hierarchy. The tool components you choose are automatically mapped to
existing Manufacturing Resource Library tool classes. If there are any attachments (for example, 3D
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models) with the vendor components, you can import these as well. You can build a tool assembly based
on these components, create graphics for it, send it to NX, and use it to machine parts in NX. A variety of
tooling vendors provide data in the generic tool catalog format that can be used with Resource Manager.
Contact your Siemens Digital Industries Software representative for more information.

Perform the following tasks to begin using a vendor catalog.

Role Task Application

Tooling/classification administrator Imports the vendor catalog hierarchy into
the database.

Classification Admin

Tooling/classification administrator/
Resource author/Tooling engineer

Imports vendor product data (part of or
complete vendor catalog).

Classification Admin, Classification,
Resource Manager, or using the
import_step_part21_files utility.

Resource author/Tooling engineer Imports vendor 3D models. Classification or Resource Manager

Resource author/Tooling engineer Creates tool assemblies using the
components in the customer hierarchy.

Resource Manager

Part planner Assigns resources to the manufacturing
process.

Part Planner

NC programmer Uses resources in the CAM area. NX

Import GTC Package with 3D and mapping

Note:

The preference MRMGTCProductIDVendorAcronymSeparator controls the separator for the GTC
(generic tool catalog) product id and vendor acronym, if a specific character or string does not
allow using Naming rules then you can use any other separator.

You can import a GTC (generic tool catalog) package along with 3D data (STEP files) and map imported
data to the vendor component all within one function. If you choose not to perform one of the options
(import 3D models or mapping) you can use the manual process for each.

1. Obtain a copy of the tool vendor catalog from the tool vendor (website download, email, etc.) and
save the file to a location that you will use to retrieve the file.

In the Resource Manager view initiate the import function by using one of the following methods:

• In the toolbar, click 

• In the menu bar select Tools→Import GTC package

2. In the Import GTC Package dialog box, select the package to import.

5. Adding vendor catalogs
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You can select a file on the client or the server. If you select a client file, the file is copied to the
server and unpacked on the server. Selecting a file on the server saves this step.

If you enter values in the MRMGTCPackageClientDir and MRMGTCPackageServerDir preferences,
these locations are displayed automatically in the Client and Server boxes.

3. In the Import Vendor Products dialog box, the GTC package(s) are displayed. You can hover over
the package to view additional information, select Import to continue.

4. Once the import is complete, the importing of 3D model data will begin if the action was selected.
Once completed, click Next.

5. If Map products to MRL classes action was selected, the Map Selected ICOs dialog box will
display. Click Map ICOs to map generic tool catalog (GTC) products to manufacturing resource
library (MRL) tool components.

6. The Mapping ICOs Progress Results dialog box will display the progress of the mapping, once
complete click Next to display a import summary.

In the Classification Table view you can view a table of the imported and mapped products.

Import GTC Package with 3D and mapping
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Note:

When you import a library that has tools that do not map directly to existing classes, the
discrepancies are highlighted in a summary report.

• If the Source Class maps directly to a single Target Class, the row will be white.

• If no Target Class is found to match the Source Class, the row will be red.

• If there are multiple Target Classes the Source Class can map to, the row is yellow and there is
a menu to choose the desired Target Class.

Once complete, you can review the mapping of the ICOs.

5. Adding vendor catalogs
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Import DIN Package

You can import a DIN package along with 3D data (STEP files) and map imported data to the vendor
component all within one function.

Note:

• The preference MRMGTCProductIDVendorAcronymSeparator controls which separator is used
for the GTC and DIN product ID and vendor acronym, if a specific character or string does not
allow using Naming rules then you can use any other separator.

• The DIN formats supported for tool vendor catalog packages are DIN 26100:2017-11 and DIN
26100:2021-05.

1. Obtain a copy of the DIN package from a tool vendor and save the file to a location that you will use
to retrieve the file, for example, C:\GTCPackageDownloads.

In the Resource Manager view, initiate the import function by using one of the following
methods:

• In the toolbar, click 

• In the menu bar select Tools→Import DIN package

Import DIN Package
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2. In the Import DIN Package dialog box, select the package to import. You can select a file on the
client or the server.

If you select a client file, the file is copied to the server and unpacked on the server. Selecting a file
on the server saves this step.

If you enter location values in the MRMGTCPackageClientDir and MRMGTCPackageServerDir
preferences, these locations are displayed automatically in the Client and Server boxes.

3. In the Import DIN Products dialog box, the DIN packages are displayed. You can hover over the
package to view additional information, or select Import Products to continue.

When the import is complete, the importing of 3D model data begins if the Import 3D Models
option is selected.

5. Adding vendor catalogs
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4. Click Next.

The Map Selected ICOs dialog box displays.

5. Click Map ICOs to map the products to the Manufacturing Resource Library (MRL) tool
components.

The Mapping ICOs Progress Results dialog box displays the progress of the mapping.

6. Click Next to display a import summary.

Import DIN Package

Resource Manager on Rich Client, Teamcenter 2412  5-7
© 2025 Siemens



7. Click OK.

In the Classification Table, the imported and mapped products are displayed.

8. When the import is complete, you can review the mapping of the ICOs.

5. Adding vendor catalogs
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Note:

When you import a library that has tools that do not map directly to existing classes, the
discrepancies are highlighted in a summary report.

Import DIN Package
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• If the Source Class maps directly to a single Target Class, the row is white.

• If no Target Class is found to match the Source Class, the row is red.

• If there are multiple Target Classes the Source Class can map to, the row is yellow and there is
a menu to choose the desired Target Class.

Import tool vendor product data

Vendor product data consists of tool components such as drills, holders, inserts, and adapters. You can
import vendor product data using two methods:

• Import the data from the rich client using the Classification, Classification Admin, or Resource
Manager applications.

• Import the data using the import_step_part21_files utility.

To import using the rich client:

1. In the Classification Search Dialog, right-click a class at any level in the vendor hierarchy and choose
Import Vendor Product Data.

The class you select determines what packages are imported. Teamcenter imports all product data
from the selected class downwards.

2. In the Import Vendor Products dialog box, select the package that you want to import from the list
of available Generic Tool Catalog packages.

Teamcenter imports the product data to the selected classes.

3. Click Import.

4. (Optional) Open the resulting log file to view the import state of individual components.

5. Adding vendor catalogs
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Caution:

Depending on the size of the package you select, this action can take several hours to complete.

Import vendor catalog items with connection codes

You can import a vendor catalog item to the correct MRL class in the Generic Tool Catalog (GTC) and
include the vendor connection code data.

1. Select a tool from the vendor catalog and select  Map ICO.

Notice the Object ID of the tool selected from the vendor library is based on the tool vendor
convention.

Note:

Sometimes the vendor tool can be mapped to more than one class, for example, in both
a single row end mill and a multiple row end mill. In that case, the following dialog box
appears and you must select the class into which you import the tool.

Import vendor catalog items with connection codes
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2. Type the Item ID, Revision ID, and a Name.

Optionally, you can select the Import Catalog 3D Model  check box to also import the 3D model.

3. Click OK.

Notice the Object ID is updated to reflect your company convention. The vendor information is also
maintained for future reference. The tool is now part of the correct class in the GTC.

5. Adding vendor catalogs

5-12  Resource Manager on Rich Client, Teamcenter 2412
© 2025 Siemens



Import vendor 3D models

Tool vendors deliver 3D models with their product data in the STEP file format. You can import this data
in Classification and Resource Manager when performing any of these tasks:

• Importing to the vendor catalog product.

• Importing while mapping from the catalog to the customer class. If a 3D model was already imported
into the vendor catalog product, you can simply copy the existing 3D model.

• Importing to a previously mapped component in a customer class.

When you import 3D models, the STEP files are converted to PRT and JT files internally. Therefore, NX
and the graphics builder must be installed on the Teamcenter server to proceed with this activity.

You import a 3D model by performing one of the following steps:

• Open a tool component in a vendor or customer class and click  in the toolbar.

• Select one or more lines in the classification table and click  at the bottom of the table.

• Click  at the bottom of the Properties or Table tab in the Classification Search dialog box.

• Right-click a resource in the Resource Manager resource view and choose Import catalog 3D model
for current resource.

Teamcenter imports the 3D models. If the tool component to which the 3D model belongs is a
standalone ICO, Teamcenter creates an item for the ICO and attaches the datasets to the item. If you are
importing for a single resource or ICO, the JT file is displayed in the viewer.

STEP format excludes indexable cutting tools

The STEP file format supports the definition of various individual tooling components. The components
consist of the assembly construction, NOCUT component, and Cut component. Resource Manager
manages tool assemblies and assembly construction by combining specific NOCUT and CUT geometry.

The vendor catalog assembly contains a master insert that is not likely to be what you need. For that
reason, the STEP import does not include the master insert, the CUT geometry. You can add the specific
insert you need to the assembly. This is also true for multitool assemblies, when a master insert is
provided with the vendor assembly.

This is a vendor assembly example:

Import vendor 3D models
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This is the same assembly with the master insert removed:

Cloud access to the Generic Tool Catalog in Resource Manager

When working in Resource Manager, if you do not find a suitable tool component in the database,
you can search for it in external vendor catalogs in a cloud. Teamcenter has a seamless integration of
search capabilities with the ToolsUnited database from CIMSOURCE GmbH containing over 500,000
components from a variety of tool vendors that you can import into the vendor hierarchy. The
ToolsUnited web page is displayed as a view within Resource Manager. You can enter search criteria
in the Classification Search Dialog, then choose to pass this search query along to ToolsUnited. When you
find the desired component in the ToolsUnited database, you can then import it back into Teamcenter,
map the component to your customer hierarchy, and use this component to build tool assemblies to
work in NX.

5. Adding vendor catalogs
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For more information, see Search and download ToolsUnited GTC package.

Understanding the linking mechanism for vendor data

When you import vendor catalog data, each component has an attribute, 3D Model file name (attribute
ID -159003), that stores a reference to the STEP file containing the 3D data.

In turn, when you map a catalog component to a customer component, the customer component
contains attributes that refer back to the vendor component.

When you open a mapped customer component and initiate the 3D model import, Teamcenter uses this
reference to locate the original catalog component. Teamcenter stores the ICO modification date from
the vendor tool component in the Vendor Reference Date attribute during the mapping.

Understanding the linking mechanism for vendor data
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6. Creating, viewing, and editing
manufacturing documentation
About manufacturing documentation

Teamcenter manufacturing documentation provides rich work instructions and collaboration between
departments, integrated with the planning environment, leveraging Teamcenter data management
capabilities.

There are two ways to create manufacturing documentation:

• Teamcenter Publish

Provides an environment for creating work instructions for manufacturing operations. Teamcenter
Publish enables you to author, distribute, and visualize the most current product and process data. Its
main features include:

• Technical illustrations including text, 2D images, 3D graphics, table, text, and hyperlinks (for
example, a link to a movie file) to improve clarity and enhanced quality on the shopfloor.

• Easy update based on the most current planning data in Teamcenter, reducing rework and update
times.

• Batch processing and scheduling of reports.

• Familiar Microsoft Visio authoring environment allowing WYSIWYG editing.

• Report tab

You can generate HTML reports in the Report view in Resource Manager. You can view the generated
reports using a Web browser. Because the reports are displayed in a Web browser, you can share
them for viewing with others in your organization who may not have access to the Resource Manager
application. A default report is available in the Report view. You can use this as a basis to create a
custom report. Use the style sheets provided with the software as examples for creating your own
customized reports to better meet your business objectives.

The features available to you in the Report view mirror those available in the Report Generator
application.
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Teamcenter Publish

Using Teamcenter Publish

To create or view manufacturing documentation using Teamcenter Publish, install Microsoft Visio. Both
Visio Standard and Visio Professional are certified. You can install Visio before or after the Teamcenter
installation.

The Save as PDF feature is included with Visio and does not require installing the separate PDF add-in.

The administrator creates an alias file that determines the permissible contents of the documentation.
For example, if the administrator uses the default alias file, you can create work instructions and product
manuals, and a view for each of these is available.

When you first select a documentation view, Teamcenter loads the Visualization Illustration and Visio
components. Depending on your workstation, this process may take several seconds to complete and
Teamcenter displays a progress dialog box until it is complete.

Working with publishing tools

You can create publishing pages in the embedded viewer and collect them into portfolios. A typical
publishing page is a work instruction document, and a portfolio may contain all the work instructions
needed at a particular assembly station. By default after installation, Teamcenter provides you with
sample files. To use publishing tools in your environment, you must configure it to suit your needs.

Publishing pages are Visio files that are saved as datasets with the selected BOM line.

Visio documents are constructed using shapes that can appear as text and graphics. A rich library of
shapes are provided in the Visio installation.

The Teamcenter publishing tools extend the shape library to include shapes called assets that you can
link to data in Teamcenter. Assets can display text, tables, images, or a link to a Microsoft Word file or
master form. For example, in Teamcenter you can configure a product assembly, view it, add markups,
and capture the graphics in a product view (snapshot) that you can then display in a 3D asset. If the data
in Teamcenter is subsequently updated, you can update the publishing page to show the changes.

You can organize collections of publishing pages into portfolios, which you can view, publish to HTML
for a Web server or publish to PDF, or print in My Teamcenter using the options that appear in the viewer
tab after you select the portfolio object. A portfolio can contain multiple work instructions, generic
pages, header and footer information, a table of contents, and cover and trailer pages.

Publishing page roles

Publishing page documents can be used for any number of purposes. By default, two roles are provided,
Work Instructions and, when a product structure is selected, Product Manual. Your database may be
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configured to support any number of roles. This documentation refers to the Work Instructions role, but
the behavior of the pane is the same for each role.

Creating and editing publishing pages

Creating and editing publishing pages overview

When you first open the Work Instructions pane, you see a blank page.

You can immediately begin to create a work instruction on this page or you can load a template and
work from there.

The following is an overview of the process for creating a publishing page.

1. Add any static Visio shapes, text or graphics you need to the page.

Creating and editing publishing pages overview
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2. Associate the page with an alias file.

Alias files tell Teamcenter what data to display in different assets on the page and how to find that
data. This step is optional; a default file is loaded.

3. Place the required assets on the page. These are placeholders. You can place the following objects
in a work instruction page, each embedded in an asset of the same name:

• Text that is bound to a property of an object in Teamcenter.

• Tables whose cells map to object properties in Teamcenter.

• 2D images (for example, BMP, GIF or JPEG files)

• 3D geometry assets

These are objects that you create or view in the embedded viewer, such as a factory view or the
desired state of the product at a certain assembly station.

• 2D snapshots

These are dynamic objects that represent a 2D scene (a view of the base image and markups)
that are associated with a BOM line in your product structure.

• Links

You can create a link to a Microsoft Word file or text file.

4. Associate the asset with a transfer mode and an alias name.

The transfer mode and the alias tell Teamcenter how to find the data in the database that is
displayed in the asset.

5. (Optional) Save this page as a template for reuse.

6. Select one or more assets and an object in Teamcenter to populate the assets.

This step traverses the structure to find the desired data or files and places them in the selected
assets.

The objects used to populate assets depend on which structure line is selected.

6. Creating, viewing, and editing manufacturing documentation
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Note:

Be careful when selecting new structures for populating assets. You must first click the Disable
response to selections button  and then select a different structure. If you do not, the scope of
the Work Instruction view changes and Teamcenter attaches the newly created work instruction
dataset to the newly selected structure.

Create a publishing page

1. Right-click the BOM line with which you want to associate the work instructions, for example, the
item revision of an assembly or operation, and choose Open with → Work Instructions.

The selected line is the scope for the work instruction that you create. The new work instruction is
attached to the line that you select here.

Note:

Be careful when selecting new structures. You must first click the Disable response to
selections button  then select a different structure. If you do not, the scope of the
Work Instruction view changes and Teamcenter attaches the newly created work instruction
dataset to the newly selected structure.

2. From the menu commands in the Work Instructions view, choose File → New TI Dataset.

Teamcenter displays the New Dataset dialog box.

3. Type a name and description in the boxes at the bottom of the dialog box and click OK.

Teamcenter creates the new publishing page dataset.

4. To add data placeholders (assets) to the template:

Click To add

Data found in a text file attached to a structure line.

A collection of data found in various properties in tabular
form.

A link to a Microsoft Word file or a text file.

A 2D image or a 2D snapshot attached to a structure
line.

A 3D image attached to a structure line.

5. Drag these placeholders to the desired spot on the page, resizing if necessary.

Create a publishing page
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6. Right-click the asset and choose Bind.

Teamcenter displays the Bind Table Placeholder dialog box.

7. Select the transfer mode and alias to use for the data to populate this asset and click OK.

Note:

The work instructions are attached to the BOM line with a IMAN_MEWorkInstruction
relation.

Binding data

Binding assets overview

There are several different types of placeholders (assets) that you can place on a publishing page. Each
of these must be bound with data from a structure. When you bind the asset, the Bind dialog box
contains a list of transfer modes and a number of choices, called aliases, from which you can select.
The choice you make for each asset defines how Teamcenter finds the data that is displayed in the asset
when you populate it.

Bind textual information

You can bind information found in the text field of an object's properties. You can enter free-form text
within the asset to complement the bound information. For example:

Operator must tighten &&SUM(<alias_1>)&& bolts with torque &&MAX(<alias_2>)&& and any 
other &&alias_3&&.

1. In the Work Instructions view, click .

Teamcenter creates a placeholder for the text on the work instruction page.

2. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

3. Click the Text Tool button  to add free-form text to the asset.

4. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Text Placeholder dialog box.

5. From the Transfer Modes list, select tcm_export transfer mode.

6. Creating, viewing, and editing manufacturing documentation
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You can select only one transfer mode per text alias.

6. In the Aliases list, open the ObjectProperties entry and select the piece of textual information that
you want to embed. You can choose to manipulate the asset data using the list of simple formula.

Each piece of bound data is added to the end of the text asset. You may have to rearrange the
information after binding the data.

7. Click Add.

Tip:

• You can also type the binding directly into the text asset if you know the format.

• You can bind multiple times to create free-form text plus embedded text in one asset.
Switch back and forth between binding and typing free-form text by doing the following:

• Click the Arrow Tool  button and right-click the text asset to access the bind dialog.

• Click the Text Tool button  and select the text asset to type free-form text.

8. Select the object in the structure view containing the text that you want to embed in the
Teamcenter window. For example, if you want to embed the description of a particular item
revision, select that item revision in the structure view.

9. In the Work Instruction view, with the text placeholder still selected, click the Populate Asset
button .

Teamcenter displays the specified text on the work instructions page.

Bind data to display in a table format

Use the table asset to embed multiple pieces of information about a selected object.

1. In the Work Instructions view, click .

Teamcenter creates a placeholder for the table on the work instruction page.

2. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

3. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Table Placeholder dialog box.

Bind data to display in a table format
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4. From the Transfer Modes list, select tcm_export transfer mode.

5. In the Aliases list, open the appropriate alias, and select the type of information you want in the
list and click the plus sign.

If you select multiple entries, the selected objects appear as columns of the table in the same order
as in the Aliases pane.

6. Click OK.

7. Select the revision in the structure view containing the objects that you want to embed in the
Teamcenter window. For example, if you want to embed the ID, name, and description of all
members of an assembly, select the assembly root structure in the structure view.

8. In the Work Instruction view, with the table placeholder still selected, click the Populate Asset
button .

Teamcenter displays the specified information on the work instructions page.

Bind linked data

To bind linked data, a dataset with a .txt file imported into it must exist. In addition, you must be able to
open this .txt file in an associated text editor.

1. In the Work Instructions view, click .

Teamcenter creates a placeholder for the link on the work instruction page.

2. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

3. Right-click the placeholder and choose Bind.

Teamcenter displays the Bind Link Placeholder dialog box.

4. From the Transfer Modes list, select the ExportGraphic transfer mode.

5. From the Aliases list, select LinkedDataset.

6. In the Attachment view, select the text dataset and click Populate in the Work Instructions view.

Teamcenter displays the link on the work instructions page.

6. Creating, viewing, and editing manufacturing documentation
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Bind a 2D image

You can bind a 2D image that is attached to a revision.

1. In the Work Instructions view, click .

Teamcenter creates a placeholder for the image on the work instruction page.

2. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

3. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Image Placeholder dialog box.

4. From the Transfer Modes list, select ExportGraphic transfer mode.

5. In the Aliases list, open the 2DGraphic entry and select file.

6. Open the Attachments view.

7. Select the image that you want to embed.

8. In the Work Instruction view, with the image placeholder still selected, click the Populate Asset
button .

Teamcenter displays the selected image on the work instructions page.

Bind a 2D snapshot

If you embed a 2D snapshot, a 2D geometry asset must exist for it.

1. In the Work Instructions view, click .

Teamcenter creates a placeholder for the image on the work instruction page.

2. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

3. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Image Placeholder dialog box.

Bind a 2D image
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4. From the Transfer Modes list, select ExportGraphic transfer mode.

5. In the Aliases list, open the 2DSnapshot entry and select file.

6. Do one of the following to specify which 2D snapshot should be populated:

• In the Attachments view, select the snapshot.

• In the 2D Viewer view, open the 2D Snapshots Gallery dialog window and select an existing
snapshot.

• In the 2D Viewer view, arrange the snapshot. When you populate the asset, Teamcenter
automatically creates the snapshot for you.

7. In the Work Instruction view, with the image placeholder still selected, click the Populate Asset
button .

Teamcenter displays the 2D snapshot on the work instructions page.

Note:

If you receive an error saying Failed to load Error document (2DSnapshot & file) when
populating a 2D asset, the 2D snapshot does not contain a 2D geometry asset.

Recapture the 2D snapshot with the option to capture 2D geometry asset data turned on.

Bind a 3D asset

1. Open a structure to which you want to attach a work instruction.

2. In the Work Instructions view, click the 3D Graphic button .

Teamcenter creates a placeholder on the work instruction page.

3. In the Work Instructions view, select File → Save TI Illustration.

You must save the work instruction once to create the dataset. If you do not save first, you receive
an error when populating the asset. Once the dataset exists, this step is no longer required, unless
you want to save changes to the work instruction page.

4. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Geometry Asset Placeholder dialog box.

5. From the Transfer Modes list, select ExportGraphic transfer mode.

6. Creating, viewing, and editing manufacturing documentation
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6. In the Aliases list, open the 3DGeometryAsset entry and select file.

7. Do one of the following to specify which 3D geometry should be populated:

• In the Graphics view, open the 3D Product View Gallery dialog box, create a snapshot, then
select it.

Caution:

You must ensure that the Add or Update 3D Geometry Asset option is selected before
you create a snapshot.

• In the Attachments view, select the 3D snapshot.

• In the Graphics view, arrange the snapshot. When you populate the asset, Teamcenter
automatically creates the snapshot for you.

8. In the Work Instruction view, with the placeholder still selected, click the Populate Asset button
.

Teamcenter displays the 3D geometry asset on the work instructions page.

Populate an empty asset

When you populate an asset, you associate Teamcenter data with it.

1. Select the asset.

2. Select the object in Teamcenter to which you want to link the asset.

3. Disable response to selections by clicking .

When selecting structures to populate assets, it is important to understand the role of the Disable
response to selections button. Clicking this button locks the view so that when you select a line in
a different structure, the scope of the view does not change and the work instruction dataset, when
created, is attached to the originally selected structure line. If the view is not locked (it responds to
selection), when you select a line in a different structure to populate an asset, the work instruction
dataset is attached to the newly selected structure line.

4. Click the Populate Asset button  or menu command.

Populate an empty asset
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Working with templates

Creating a publishing page template

Your site may provide publishing page templates whose content can be used as the starting point for the
creation of a new publishing page. A publishing page template is a publishing page dataset that is not
populated with actual data.

A page template may contain standard data such as a company logo, pictures, and required text. It may
also contain empty placeholders, whose content you must fill for each instance of a publishing page you
create from the template.

You can classify templates in the Classification application for easy retrieval.

Classify a template

1. Add the TCPublishingPage business object type to the ics_classifiable_types preference.

2. Create a publishing page template.

3. In the Attachments view, select the template and choose Send to→Classification.

4. In Classification, classify the template.

The template is now available when you create a new publishing page from a template.

Create a publishing page from a template

1. If you know the name of the required template, type it in the Template name box.

If you do not know the name of the template, you can search the database for it. In the Templates
pane at the top of the dialog box, click the Find a Template by name button  next to the
Template name box.

Teamcenter displays the Find by Name dialog box, and you can search by part of the name and
with wildcard (*) characters.

If templates are classified, you can click Classification Search Dialog  to find the template you
require.

2. When you identify the publishing page you want to use as a template, double-click the name to
select it and return to the New Dataset dialog box.

3. (Optional) Click the Add To Favorites button to add the selected template to the list in the
Templates pane above it.
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4. (Optional) Click the Use as Default button to use the specified dataset as the default template if no
TI dataset is loaded.

5. In the File section, select Use Template.

6. Type a name and description in the relevant boxes.

7. Click OK.

Teamcenter creates the new publishing page dataset.

Using default templates

All of the default templates contain 3D geometry assets. You can add the following details to specific
page templates.

Template Purpose

TCPartList Specifies the part list table. When populated, it lists all the parts
under the selected BOM line. It includes the item identifier, item
name, revision identifier, description, and find number of each part
in the list.

TCAssemblyOperation Use this template at the operation level in a manufacturing
structure. It briefly describes the operation, its activities, the
consumed parts, and tools required to perform the operation. The
Activities table lists all the activities under the selected operation,
their descriptions and durations. The consumed parts table lists the
parts consumed by the selected operation, their identifiers, names,
revision identifiers, descriptions, and logical identifiers. The Tools
table lists the set of tools required by the operation, their identifiers,
names, and descriptions.

TCOperationRouting This template lists manufacturing process details, including the
operations under it, the consumed parts of those operations and
the list of tools used in those operations. Use this template at
the process level. The Operations List table lists all the operations
under the selected process. The consumed parts table lists all the
consumed parts under all the operations below the process. The
Resource List table lists all the resources under all the operations
below the process.

TCActivityDetails This template describes the activities under an operation. Use this
template at the operation level of a structure. For each activity, the
name, description, start time, duration, calculated start time, and
calculated duration are listed.

Using default templates
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Template Purpose

TCActivityRouting This template lists manufacturing activity details, including the
operations under it. Use this template at the operation level.

TCActivityToolList This template contains detailed description of the activities in the
structure. It may also be used at the operation level. It lists the
following activity details:

• The Activities Consumed Parts table lists all the activities, their
descriptions, and the parts consumed in each of these activities.

• The Activities Used Resources table lists all the activities, their
descriptions, and resources used in each of the activities.

Updating publishing pages

When an asset is populated, a reference to the selected Teamcenter populating object is stored in the
asset. If the data in Teamcenter changes, you can update the asset to show the changes. Updating is not
automatic; you must explicitly perform an update.

Take, for example, the TcPartList template’s table. Long after you create the publishing page and
populate the table asset, the product structure can be modified. Item names can change or BOM lines
can be added or removed from the line that was used to populate the table. After this happens, you can
update the publishing page to show the changes.

Update an asset

1. Open the page dataset in a publishing page viewer anywhere in Teamcenter.

2. Select the asset and choose Edit → Update Asset from the page viewer menu.

The new contents of the asset are displayed, along with a triangle indicating that the display shows
new (and so far unaccepted) data.

3. Switch between displaying the old and the new data by choosing Show Original Data and Show
New Data from the asset's shortcut menu. The asset is in an uncommitted state. You cannot
update the asset again or repopulate it while it is in this state.

4. Accept or reject the change by choosing Accept New Data or Accept Original Data from the
asset’s shortcut menu. All of the assets on a page can be updated at once using the publishing
page Edit → Update Technical Illustration menu. Other Edit menus let you toggle the display and
accept or reject the changes for all of the assets on the page at once.
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Note:

You cannot update data in the database (other than the publishing page itself) by updating
an asset. Assets can only display what is already in the database. To update a 3D asset, you
must first update the snapshot dataset in the assembly viewer.

Repopulate an asset

An asset that has been populated can be repopulated with a different Teamcenter component.

1. Select the asset in the publishing page view.

2. Select the component in another view, and choose Edit → Populate Asset in the publishing page
view.

3. Switch between displaying the old and the new data by choosing Show Original Data and Show
New Data from the asset's shortcut menu. The asset is in an uncommitted state. You cannot
update the asset again or repopulate it while it is in this state.

4. Accept or reject the change by choosing Accept New Data or Accept Original Data from the
asset’s shortcut menu. All of the assets on a page can be updated at once using the publishing
page Edit → Update Technical Illustration menu command. Other Edit menus let you toggle the
display and accept or reject the changes for all of the assets on the page at once.

Note:

You cannot update data in the database (other than the publishing page itself) by updating
an asset. Assets only can display what is already in the database. To update a 3D asset, you
must first update the snapshot dataset in the Graphics view.

View populating and end objects

The populating object is the one that was selected when the asset was populated. The end object is
the object that is actually displayed in the asset after it is populated. These can be the same object, or
different ones, depending on your alias definition.

You can view these objects.

1. Select the asset in the Work Instructions view.

2. Do one of the following:

• To show the populating object in My Teamcenter, choose Edit → Asset Components → Send to
My Teamcenter → Populating Components.

Repopulate an asset
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• To show the end object in My Teamcenter, choose Edit → Asset Components → Send to My
Teamcenter → End Object.

• To view the populating object in the default viewer without switching applications, choose
Edit → Asset Components → View Populating Components.

• To view the end object in the default viewer without switching applications, choose Edit →
Asset Components → View End Object.

Note:

These menu commands may not work depending on how the alias file is implemented. For more
information, contact your administrator.

Create a new work instruction

1. Select the BOM line with which you want to associate the work instructions, for example, the item
revision of an assembly or operation.

2. Open the Work Instructions view.

3. In the Work Instructions view, choose File → New TI Dataset.

Teamcenter displays the New Document dialog box.

4. If your site uses templates, select the name of a template, enter a dataset name, and click OK.

Note:

The work instructions are attached to the BOM line with a IMAN_MEWorkInstruction
relation.

Add new pages to the work instructions or product manual

• Choose Insert → New Page.

Teamcenter adds a new, blank page to the active work instructions or product manual. You can also
search for an existing page by name or use a Classification search to find a classified page.

Delete pages from the work instructions or product manual

1. Choose Edit → Delete Pages.

Teamcenter displays the Delete Pages dialog box containing a list of available pages.

6. Creating, viewing, and editing manufacturing documentation
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2. Select the page to delete and click OK.

Teamcenter deletes the page from the work instructions or product manual.

Save changes to the work instructions or product manual

• Choose File → Save.

Teamcenter saves any changes that you made.

Reserve space for headers and footers

You reserve space for headers and footers on a publishing page. When you print or export the work
instructions or product manual, any shapes on the publishing page are clipped to the defined margins.

1. Open the work instructions.

2. Choose View → Page Margins.

Teamcenter adds a gray-shaded background at the top, bottom, left, and right of the page.

Add export tags

You can add export tags to a page that are replaced with actual information when you print or export it.
For example, if you select page, the actual page number appears. Additional export tags include date,
long date, document file name, portfolio file name and total number of pages.

1. Open the work instructions or product manual.

2. Choose Insert → Portfolio Export Tag and select a tag from the displayed list. The tag you select
appears on the work instructions or product manual.

3. (Optional) Move or resize the export tag on the work instructions or product manual.

Navigate to another publishing page

Use one of the following methods to navigate to another publishing page:

1. Choose View → Page → Go to.

Teamcenter displays the Select Page dialog box.

2. Select the page to you want to navigate.

- or -

Save changes to the work instructions or product manual
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Use the navigation arrow buttons to browse through the available pages.

Export publishing pages to HTML

1. Choose File → Save as Web Page.

Teamcenter displays the Save As dialog box.

2. Type a name for the exported file and click Save.

Teamcenter displays the Save as Web Page dialog box.

3. Change settings for the following options:

Tab Options Description

General tab Pages to Publish Choose Select All to print all pages or Select
Pages from and then type the page span.

Publishing options Select any of the publishing options, which
appear in the finished Web page to aid
navigation and searching.

Additional options Choose any of the following:

• Automatically open Web page in browser

• Organize supporting files in a folder

• Type text in the Page title box to name the
exported HTML output.

Advanced tab Output formats Select a format for the HTML output.

Provide alternate format
for older browsers

Choose a format from the list.

Target monitor Choose the monitor size.

Host in Web page Select a Web page from the list or browse to a
file.

Style sheet Select a style sheet from the list or browse to a
file.

4. Click OK.

Teamcenter displays the publishing pages as a Web page in your default browser.

6. Creating, viewing, and editing manufacturing documentation

6-18  Resource Manager on Rich Client, Teamcenter 2412
© 2025 Siemens



Export publishing pages to PDF

You can print a portfolio to PDF in My Teamcenter. Before you do this, you must install third party
software capable of creating PDF output.

1. Create a portfolio.

2. Open My Teamcenter.

3. In the File menu on the viewer tab, choose Publish PDF to Database.

Creating a portfolio

About portfolios

Portfolios act as a container for work instructions or product manuals and supporting documents,
such as a table of contents, cover or trailer pages, and header and footer information. Portfolios may
contain a reference to a publishing page or generic page or to an embedded generic page. You can use
portfolios to store document structure information, print multiple publishing pages, and export portfolio
contents to HTML or PDF.

You generate portfolios in Manufacturing Process Planner, Part Planner, Multi-Structure Manager, Service
Planner, or Plant Designer. You manage portfolios in My Teamcenter only.

When managing a portfolio:

• Use container nodes to add an organizational hierarchy to the portfolio. Think of container nodes as
chapters in a book, in which you can separate and group documents. Container nodes are useful for
multiple levels in the table of contents.

• During printing operations, Teamcenter creates the table of contents information in a dynamic page.

• Create generic pages for any information page to add to the portfolio, such as cover or trailer pages.
Generic pages are not considered publishing pages and Teamcenter does not apply headers and
footers to them.

• Add header and footer information to portfolios by creating a special page. Teamcenter copies the
shapes in this page to the published pages during printing and export operations. The same header
and footer appears on every page.

• When adding supporting documents to portfolios, choose from the following options:

• Insert Reference

Select a supporting document for the portfolio to reference.

Export publishing pages to PDF
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• Create

Add a new supporting document that Teamcenter embeds in the portfolio. You can only create and
embed generic pages.

• Embed

Copy a supporting document into the portfolio.

You cannot create portfolios in Resource Manager.

Add a new page in My Teamcenter

When you edit a portfolio in My Teamcenter, you can insert pages by choosing the Insert
Reference→Technical Illustration or Generic Technical Illustration menu commands. In the resulting
dialog box, the Classification search button is not available. To use the Classification search, you must
send the portfolio to Manufacturing Process Planner.

• If you created the portfolio using the Generate Portfolio menu command:

1. Select the portfolio in My Teamcenter and send it to Manufacturing Process Planner.

2. Open the Collaboration Context view and expand the portfolio intermediate data capture.

3. Right-click the portfolio and choose Open With→Viewer.

4. Choose Actions→Insert Reference→Technical Illustration or Generic Technical Illustration.

The Classification search is available.

6. Creating, viewing, and editing manufacturing documentation
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• If you do not generate the portfolio from the menu command, you can view the portfolio in
Manufacturing Process Planner as follows:

1. Create an item.

2. Copy the portfolio dataset and paste it to the item revision.

3. Send the item revision to the Manufacturing Process Planner application.

4. Open the Collaboration Context view and proceed as above. You can copy the dataset from
the Classification Search Dialog to the clipboard and paste it into the portfolio dataset in My
Teamcenter.

Modify header and footer information

1. Select the portfolio  in the Newstuff folder in My Teamcenter.

Teamcenter opens the viewer.

2. Right-click the header and footer page in the portfolio tree and choose Open.

3. Make any necessary changes.

4. Choose File → Post to Technical Portfolio.

5. Click Close.

6. In the viewer, click File → Save.

Creating manufacturing documentation in batch mode overview

You can create and update Teamcenter work instructions and portfolios in batch mode, processing
multiple documents using the Teamcenter Publish Batch dialog box. You do not need to process
individual documents manually. You can schedule these tasks to take place immediately or at a later
date.

Batch processing uses the Dispatcher infrastructure for scheduling create and update features.
Additionally, Dispatcher has built-in status, logging, and error reporting features.

You must set up the batch processing in the Manufacturing Process Planner or Multi-Structure Manager
applications. You can use My Teamcenter to modify the scheduling of the batch process.

Modify header and footer information
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7. Administering Resource Manager
Setting access rights

When setting up resource management, Siemens Digital Industries Software recommends you create
one group, for example, a manufacturing group, for all users involved with resource management.
Using this group, you can set up custom read and write privileges for the group, as well as defining
group-specific workflows and business rules. You should import the Manufacturing Resource Library
(with tools and machines) using this group.

Install NX templates

If you have an empty database with no NX templates installed, you must install these templates before
you can work in the manufacturing environment.

Warning:

Do not perform this procedure if you already have templates stored in the database. They will be
overwritten.

Before you perform this step, ensure that the UGSTRUCTURES feature is installed in your NX installation.
When you complete this procedure, the NX templates are available the first time you enter NX.

1. Open a Teamcenter command prompt window.

2. Type:

cd /d "%UGII_ROOT_DIR%\templates\sample"

tcin_template_setup -u=user -p=password

Store the machining data library in Teamcenter

You can store feeds and speeds data in the database in Teamcenter where it is managed instead of in the
ASCII library in NX. The data is retrievable from the classification hierarchy.
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1. Install the required classes using the manufacturing resource library installer.

2. Convert the NX ASCII files into SML files using the mrm_migrate_machining_data utility.

For example:

mrm_migrate_machining_data -u=user-id -p=password -g=group-
root_dir=d:\NX9.0\MACH\\resource\library\feeds_speeds\ascii\

3. Import the SML files using the smlutility utility.

For example:

smlutility -import -u=user-id -p=password -g=group 
-file=migrated_machining_data.sml -update

7. Administering Resource Manager
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Synchronize attribute values from NX to Teamcenter

When you execute NX Integration functions in Teamcenter, by default, part attributes are not written
into the part file. Using the Update NX Tool Assembly Part File menu command, you can choose to
synchronize various part attributes.

To synchronize attribute values from NX to Teamcenter, you must map attributes using the following
steps:

1. Export the attribute mapping definition from the database:

export_attr_mappings -file=attr_mappings.txt -u=admin-user-name 
-p=password -g=dba

2. Find the following block:

{ Dataset type="UGMASTER"
    # (hard-wired) DB_PART_NAME : "Part Name"
    # (hard-wired) DB_PART_DESC : "Part Description"
}

3. Add this block of information under "Part Description" in the Dataset type="UGMASTER" block
as follows:

{ Dataset type="UGMASTER"
    # (hard-wired) DB_PART_NAME : "Part Name"
    # (hard-wired) DB_PART_DESC : "Part Description"

    { Item type="Mfg0MENCTool"
    ...

Synchronize attribute values from NX to Teamcenter
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The following section maps Setup X, Setup Y, and Setup Z attribute values (required for the Write
part attributes option):

        "CAM_TOOL_ATT_X(1)" : ItemRevision.ICS(-45002:1) /master=both
        "CAM_TOOL_ATT_Y(1)" : ItemRevision.ICS(-45003:1) /master=both
        "CAM_TOOL_ATT_Z(1)" : ItemRevision.ICS(-45004:1) /master=both
  

The following section maps System Tracking Points (required for the Write part attributes
option). You can map nine sets in total:

        "CAM_TOOL_ATT_SYSTP_NAME(1)" : ItemRevision.ICS(-45021:1)  /
master=both
        "CAM_TOOL_ATT_SYSTP_SEQ(1)"  : ItemRevision.ICS(-45022:1)  /
master=both
        "CAM_TOOL_ATT_SYSTP_X(1)"    : ItemRevision.ICS(-45023:1)  /
master=both
        "CAM_TOOL_ATT_SYSTP_Y(1)"    : ItemRevision.ICS(-45024:1)  /
master=both
        "CAM_TOOL_ATT_SYSTP_Z(1)"    : ItemRevision.ICS(-45025:1)  /
master=both
        ...
        "CAM_TOOL_ATT_SYSTP_NAME(9)" : ItemRevision.ICS(-45021:9)  /
master=both
        "CAM_TOOL_ATT_SYSTP_SEQ(9)"  : ItemRevision.ICS(-45022:9)  /
master=both
        "CAM_TOOL_ATT_SYSTP_X(9)"    : ItemRevision.ICS(-45023:9)  /
master=both
        "CAM_TOOL_ATT_SYSTP_Y(9)"    : ItemRevision.ICS(-45024:9)  /
master=both
        "CAM_TOOL_ATT_SYSTP_Z(9)"    : ItemRevision.ICS(-45025:9)  /
master=both
  

The following section maps the Tool Holder definition (required for the Extract Holder Data
option). You can map 23 sets of curves in total:

        "CAM_TOOL_ATT_HLDR_DIA(1)"   : ItemRevision.ICS(-45230:1)  /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(1)"   : ItemRevision.ICS(-45231:1)  /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(1)"  : ItemRevision.ICS(-45234:1)  /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(1)"  : ItemRevision.ICS(-45232:1)  /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(1)"  : ItemRevision.ICS(-45233:1)  /
master=both
        ...
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        "CAM_TOOL_ATT_HLDR_DIA(23)"  : ItemRevision.ICS(-45230:23) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(23)"  : ItemRevision.ICS(-45231:23) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(23)" : ItemRevision.ICS(-45234:23) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(23)" : ItemRevision.ICS(-45232:23) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(23)" : ItemRevision.ICS(-45233:23) /
master=both

Caution:

Replace only the mapping for the tool type (Mfg0MENCTool) to prevent overwriting any
other mapping information that may exist in the file.

4. Save the text file and import it back into the database to define the attribute synchronization:

import_attr_mappings -file=attr_mappings.txt -u=admin-user-name 
-p=password -g=dba

When you now execute the NX Integration functions in Teamcenter, the part attributes are written into
the part file. When you save the part file in NX, the attribute values are transferred to Teamcenter. When
you reload the resource in Teamcenter, the new values are displayed.

NX/Teamcenter attribute mapping file

The original entry in the attribute mapping file is as follows:

{ Dataset type="UGMASTER"
    # (hard-wired) DB_PART_NAME : "Part Name"
    # (hard-wired) DB_PART_DESC : "Part Description"
}

Modify this block to the following:

{ Dataset type="UGMASTER"
    # (hard-wired) DB_PART_NAME : "Part Name"
    # (hard-wired) DB_PART_DESC : "Part Description"

    { Item type="Mfg0MENCTool"
        "CAM_TOOL_ATT_X(1)" : ItemRevision.ICS(-45002:1) /master=both
        "CAM_TOOL_ATT_Y(1)" : ItemRevision.ICS(-45003:1) /master=both
        "CAM_TOOL_ATT_Z(1)" : ItemRevision.ICS(-45004:1) /master=both

        "CAM_TOOL_ATT_SYSTP_NAME(1)" : ItemRevision.ICS(-45021:1) /
master=both

NX/Teamcenter attribute mapping file
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        "CAM_TOOL_ATT_SYSTP_SEQ(1)"  : ItemRevision.ICS(-45022:1) /
master=both
        "CAM_TOOL_ATT_SYSTP_X(1)"    : ItemRevision.ICS(-45023:1) /
master=both
        "CAM_TOOL_ATT_SYSTP_Y(1)"    : ItemRevision.ICS(-45024:1) /
master=both
        "CAM_TOOL_ATT_SYSTP_Z(1)"    : ItemRevision.ICS(-45025:1) /
master=both
                                    
        "CAM_TOOL_ATT_SYSTP_NAME(2)" : ItemRevision.ICS(-45021:2) /
master=both
        "CAM_TOOL_ATT_SYSTP_SEQ(2)"  : ItemRevision.ICS(-45022:2) /
master=both
        "CAM_TOOL_ATT_SYSTP_X(2)"    : ItemRevision.ICS(-45023:2) /
master=both
        "CAM_TOOL_ATT_SYSTP_Y(2)"    : ItemRevision.ICS(-45024:2) /
master=both
        "CAM_TOOL_ATT_SYSTP_Z(2)"    : ItemRevision.ICS(-45025:2) /
master=both
                                    
        "CAM_TOOL_ATT_SYSTP_NAME(3)" : ItemRevision.ICS(-45021:3) /
master=both
        "CAM_TOOL_ATT_SYSTP_SEQ(3)"  : ItemRevision.ICS(-45022:3) /
master=both
        "CAM_TOOL_ATT_SYSTP_X(3)"    : ItemRevision.ICS(-45023:3) /
master=both
        "CAM_TOOL_ATT_SYSTP_Y(3)"    : ItemRevision.ICS(-45024:3) /
master=both
        "CAM_TOOL_ATT_SYSTP_Z(3)"    : ItemRevision.ICS(-45025:3) /
master=both
                                    
        "CAM_TOOL_ATT_SYSTP_NAME(4)" : ItemRevision.ICS(-45021:4) /
master=both
        "CAM_TOOL_ATT_SYSTP_SEQ(4)"  : ItemRevision.ICS(-45022:4) /
master=both
        "CAM_TOOL_ATT_SYSTP_X(4)"    : ItemRevision.ICS(-45023:4) /
master=both
        "CAM_TOOL_ATT_SYSTP_Y(4)"    : ItemRevision.ICS(-45024:4) /
master=both
        "CAM_TOOL_ATT_SYSTP_Z(4)"    : ItemRevision.ICS(-45025:4) /
master=both
                                    
        "CAM_TOOL_ATT_SYSTP_NAME(5)" : ItemRevision.ICS(-45021:5) /
master=both
        "CAM_TOOL_ATT_SYSTP_SEQ(5)"  : ItemRevision.ICS(-45022:5) /
master=both
        "CAM_TOOL_ATT_SYSTP_X(5)"    : ItemRevision.ICS(-45023:5) /
master=both
        "CAM_TOOL_ATT_SYSTP_Y(5)"    : ItemRevision.ICS(-45024:5) /
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master=both
        "CAM_TOOL_ATT_SYSTP_Z(5)"    : ItemRevision.ICS(-45025:5) /
master=both
                                    
        "CAM_TOOL_ATT_SYSTP_NAME(6)" : ItemRevision.ICS(-45021:6) /
master=both
        "CAM_TOOL_ATT_SYSTP_SEQ(6)"  : ItemRevision.ICS(-45022:6) /
master=both
        "CAM_TOOL_ATT_SYSTP_X(6)"    : ItemRevision.ICS(-45023:6) /
master=both
        "CAM_TOOL_ATT_SYSTP_Y(6)"    : ItemRevision.ICS(-45024:6) /
master=both
        "CAM_TOOL_ATT_SYSTP_Z(6)"    : ItemRevision.ICS(-45025:6) /
master=both
                                    
        "CAM_TOOL_ATT_SYSTP_NAME(7)" : ItemRevision.ICS(-45021:7) /
master=both
        "CAM_TOOL_ATT_SYSTP_SEQ(7)"  : ItemRevision.ICS(-45022:7) /
master=both
        "CAM_TOOL_ATT_SYSTP_X(7)"    : ItemRevision.ICS(-45023:7) /
master=both
        "CAM_TOOL_ATT_SYSTP_Y(7)"    : ItemRevision.ICS(-45024:7) /
master=both
        "CAM_TOOL_ATT_SYSTP_Z(7)"    : ItemRevision.ICS(-45025:7) /
master=both
                                    
        "CAM_TOOL_ATT_SYSTP_NAME(8)" : ItemRevision.ICS(-45021:8) /
master=both
        "CAM_TOOL_ATT_SYSTP_SEQ(8)"  : ItemRevision.ICS(-45022:8) /
master=both
        "CAM_TOOL_ATT_SYSTP_X(8)"    : ItemRevision.ICS(-45023:8) /
master=both
        "CAM_TOOL_ATT_SYSTP_Y(8)"    : ItemRevision.ICS(-45024:8) /
master=both
        "CAM_TOOL_ATT_SYSTP_Z(8)"    : ItemRevision.ICS(-45025:8) /
master=both
                                    
        "CAM_TOOL_ATT_SYSTP_NAME(9)" : ItemRevision.ICS(-45021:9) /
master=both
        "CAM_TOOL_ATT_SYSTP_SEQ(9)"  : ItemRevision.ICS(-45022:9) /
master=both
        "CAM_TOOL_ATT_SYSTP_X(9)"    : ItemRevision.ICS(-45023:9) /
master=both
        "CAM_TOOL_ATT_SYSTP_Y(9)"    : ItemRevision.ICS(-45024:9) /
master=both
        "CAM_TOOL_ATT_SYSTP_Z(9)"    : ItemRevision.ICS(-45025:9) /
master=both

        "CAM_TOOL_ATT_HLDR_DIA(1)"  : ItemRevision.ICS(-45230:1) /
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master=both
        "CAM_TOOL_ATT_HLDR_LEN(1)"  : ItemRevision.ICS(-45231:1) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(1)" : ItemRevision.ICS(-45234:1) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(1)" : ItemRevision.ICS(-45232:1) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(1)" : ItemRevision.ICS(-45233:1) /
master=both
                                   
        "CAM_TOOL_ATT_HLDR_DIA(2)"  : ItemRevision.ICS(-45230:2) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(2)"  : ItemRevision.ICS(-45231:2) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(2)" : ItemRevision.ICS(-45234:2) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(2)" : ItemRevision.ICS(-45232:2) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(2)" : ItemRevision.ICS(-45233:2) /
master=both
                                   
        "CAM_TOOL_ATT_HLDR_DIA(3)"  : ItemRevision.ICS(-45230:3) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(3)"  : ItemRevision.ICS(-45231:3) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(3)" : ItemRevision.ICS(-45234:3) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(3)" : ItemRevision.ICS(-45232:3) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(3)" : ItemRevision.ICS(-45233:3) /
master=both
                                   
        "CAM_TOOL_ATT_HLDR_DIA(4)"  : ItemRevision.ICS(-45230:4) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(4)"  : ItemRevision.ICS(-45231:4) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(4)" : ItemRevision.ICS(-45234:4) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(4)" : ItemRevision.ICS(-45232:4) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(4)" : ItemRevision.ICS(-45233:4) /
master=both
                                   
        "CAM_TOOL_ATT_HLDR_DIA(5)"  : ItemRevision.ICS(-45230:5) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(5)"  : ItemRevision.ICS(-45231:5) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(5)" : ItemRevision.ICS(-45234:5) /
master=both
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        "CAM_TOOL_ATT_HLDR_TAPA(5)" : ItemRevision.ICS(-45232:5) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(5)" : ItemRevision.ICS(-45233:5) /
master=both
                                   
        "CAM_TOOL_ATT_HLDR_DIA(6)"  : ItemRevision.ICS(-45230:6) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(6)"  : ItemRevision.ICS(-45231:6) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(6)" : ItemRevision.ICS(-45234:6) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(6)" : ItemRevision.ICS(-45232:6) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(6)" : ItemRevision.ICS(-45233:6) /
master=both
                                   
        "CAM_TOOL_ATT_HLDR_DIA(7)"  : ItemRevision.ICS(-45230:7) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(7)"  : ItemRevision.ICS(-45231:7) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(7)" : ItemRevision.ICS(-45234:7) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(7)" : ItemRevision.ICS(-45232:7) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(7)" : ItemRevision.ICS(-45233:7) /
master=both
                                   
        "CAM_TOOL_ATT_HLDR_DIA(8)"  : ItemRevision.ICS(-45230:8) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(8)"  : ItemRevision.ICS(-45231:8) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(8)" : ItemRevision.ICS(-45234:8) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(8)" : ItemRevision.ICS(-45232:8) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(8)" : ItemRevision.ICS(-45233:8) /
master=both
                                   
        "CAM_TOOL_ATT_HLDR_DIA(9)"  : ItemRevision.ICS(-45230:9) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(9)"  : ItemRevision.ICS(-45231:9) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(9)" : ItemRevision.ICS(-45234:9) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(9)" : ItemRevision.ICS(-45232:9) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(9)" : ItemRevision.ICS(-45233:9) /
master=both
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        "CAM_TOOL_ATT_HLDR_DIA(10)"  : ItemRevision.ICS(-45230:10) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(10)"  : ItemRevision.ICS(-45231:10) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(10)" : ItemRevision.ICS(-45234:10) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(10)" : ItemRevision.ICS(-45232:10) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(10)" : ItemRevision.ICS(-45233:10) /
master=both

        "CAM_TOOL_ATT_HLDR_DIA(11)"  : ItemRevision.ICS(-45230:11) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(11)"  : ItemRevision.ICS(-45231:11) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(11)" : ItemRevision.ICS(-45234:11) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(11)" : ItemRevision.ICS(-45232:11) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(11)" : ItemRevision.ICS(-45233:11) /
master=both
                                 
        "CAM_TOOL_ATT_HLDR_DIA(12)"  : ItemRevision.ICS(-45230:12) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(12)"  : ItemRevision.ICS(-45231:12) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(12)" : ItemRevision.ICS(-45234:12) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(12)" : ItemRevision.ICS(-45232:12) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(12)" : ItemRevision.ICS(-45233:12) /
master=both
                                 
        "CAM_TOOL_ATT_HLDR_DIA(13)"  : ItemRevision.ICS(-45230:13) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(13)"  : ItemRevision.ICS(-45231:13) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(13)" : ItemRevision.ICS(-45234:13) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(13)" : ItemRevision.ICS(-45232:13) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(13)" : ItemRevision.ICS(-45233:13) /
master=both
                                 
        "CAM_TOOL_ATT_HLDR_DIA(14)"  : ItemRevision.ICS(-45230:14) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(14)"  : ItemRevision.ICS(-45231:14) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(14)" : ItemRevision.ICS(-45234:14) /
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master=both
        "CAM_TOOL_ATT_HLDR_TAPA(14)" : ItemRevision.ICS(-45232:14) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(14)" : ItemRevision.ICS(-45233:14) /
master=both
                                 
        "CAM_TOOL_ATT_HLDR_DIA(15)"  : ItemRevision.ICS(-45230:15) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(15)"  : ItemRevision.ICS(-45231:15) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(15)" : ItemRevision.ICS(-45234:15) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(15)" : ItemRevision.ICS(-45232:15) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(15)" : ItemRevision.ICS(-45233:15) /
master=both
                                 
        "CAM_TOOL_ATT_HLDR_DIA(16)"  : ItemRevision.ICS(-45230:16) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(16)"  : ItemRevision.ICS(-45231:16) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(16)" : ItemRevision.ICS(-45234:16) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(16)" : ItemRevision.ICS(-45232:16) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(16)" : ItemRevision.ICS(-45233:16) /
master=both
                                 
        "CAM_TOOL_ATT_HLDR_DIA(17)"  : ItemRevision.ICS(-45230:17) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(17)"  : ItemRevision.ICS(-45231:17) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(17)" : ItemRevision.ICS(-45234:17) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(17)" : ItemRevision.ICS(-45232:17) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(17)" : ItemRevision.ICS(-45233:17) /
master=both
                                 
        "CAM_TOOL_ATT_HLDR_DIA(18)"  : ItemRevision.ICS(-45230:18) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(18)"  : ItemRevision.ICS(-45231:18) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(18)" : ItemRevision.ICS(-45234:18) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(18)" : ItemRevision.ICS(-45232:18) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(18)" : ItemRevision.ICS(-45233:18) /
master=both

NX/Teamcenter attribute mapping file
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        "CAM_TOOL_ATT_HLDR_DIA(19)"  : ItemRevision.ICS(-45230:19) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(19)"  : ItemRevision.ICS(-45231:19) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(19)" : ItemRevision.ICS(-45234:19) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(19)" : ItemRevision.ICS(-45232:19) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(19)" : ItemRevision.ICS(-45233:19) /
master=both

        "CAM_TOOL_ATT_HLDR_DIA(20)"  : ItemRevision.ICS(-45230:20) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(20)"  : ItemRevision.ICS(-45231:20) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(20)" : ItemRevision.ICS(-45234:20) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(20)" : ItemRevision.ICS(-45232:20) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(20)" : ItemRevision.ICS(-45233:20) /
master=both

        "CAM_TOOL_ATT_HLDR_DIA(21)"  : ItemRevision.ICS(-45230:21) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(21)"  : ItemRevision.ICS(-45231:21) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(21)" : ItemRevision.ICS(-45234:21) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(21)" : ItemRevision.ICS(-45232:21) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(21)" : ItemRevision.ICS(-45233:21) /
master=both

        "CAM_TOOL_ATT_HLDR_DIA(22)"  : ItemRevision.ICS(-45230:22) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(22)"  : ItemRevision.ICS(-45231:22) /
master=both
        "CAM_TOOL_ATT_HLDR_UDIA(22)" : ItemRevision.ICS(-45234:22) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(22)" : ItemRevision.ICS(-45232:22) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(22)" : ItemRevision.ICS(-45233:22) /
master=both

        "CAM_TOOL_ATT_HLDR_DIA(23)"  : ItemRevision.ICS(-45230:23) /
master=both
        "CAM_TOOL_ATT_HLDR_LEN(23)"  : ItemRevision.ICS(-45231:23) /
master=both
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        "CAM_TOOL_ATT_HLDR_UDIA(23)" : ItemRevision.ICS(-45234:23) /
master=both
        "CAM_TOOL_ATT_HLDR_TAPA(23)" : ItemRevision.ICS(-45232:23) /
master=both
        "CAM_TOOL_ATT_HLDR_CORR(23)" : ItemRevision.ICS(-45233:23) /
master=both

        "M_Cut_Dia_Min"   : ItemRevision.ICS(-40245) /master=both
        "M_Cut_Dia_Max"   : ItemRevision.ICS(-40244) /master=both
        "M_Cut_Dia_Adj"   : ItemRevision.ICS(-45270) /master=both
        "M_TOOL_CAL_VAL"  : ItemRevision.ICS(-40404) /master=cad
        "M_TCV_CALLBACK"  : ItemRevision.ICS(-40404) /master=iman
    }
}

Caution:

Do not overwrite any other modifications contained within the file.

Enable graphics creation

An administrator typically performs this step.

1. In the Teamcenter Environment Manager (TEM), install the Teamcenter Integration for NX.

2. Restart TEM and install the graphics builder by selecting the NX Graphics Builder option in the NX
Integration section.

3. If you use the Manufacturing Resource Library:

a. Run setup program in the advanced_installations\resource_management\server directory
of the installation image.

b. Select the Manufacturing Resources — Database Population option and provide the
appropriate input to import tools until you reach the Support GRAPHICS BUILDER step.

c. Select Tools.

This step installs the part family templates required to create graphics for the tool components
found in the Manufacturing Resource Library.

d. Complete the installation.

Enable graphics creation
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Note:

When you create graphics using the graphics builder, all part family members are
created with the same item type as the part family template. Therefore, ensure that
your part family templates are of the same item type as the one you specified during the
Manufacturing Resource Library import.

Enable tool retrieval from Teamcenter to NX

An administrator typically performs this step.

1. In the Teamcenter Environment Manager, install the Teamcenter Integration for NX.

2. Run the Manufacturing Resource Library setup program in the
advanced_installations\resource_management\server directory of the installation image,
selecting the Configure NX Library option.

This step copies the cam_part_planner_mrl.dat configuration file to the
MACH\resource\configuration directory in your NX installation.

Setting up and customizing setup sheets

Enable setup sheet generation for resources

1. Ensure that the graphics builder is installed and configured.

2. Set the MRMSetupSheets preference to true.

3. Add the item revisions of the NX part files containing the drawing templates to the
MRMSetupSheetTemplatesMetric or the MRMSetupSheetTemplatesInchpreference depending
on your needs.

4. Add the setup sheet templates to the nxdm_ugs_drawing_templates.pax template PAX file in the
UGII\templates directory in NX. Do this by adding these entries.

5. Set the output format by setting the SETUP_SHEET_OUTPUT_FORMAT NX part attribute to one or
more (separated by commas) of the following formats:

PDF
CGM
PNG
JPEG
JPG
TIFF
TIF
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If you do not specify this attribute, PDF, CGM, and PNG files are generated by default.

Create custom setup sheets

Setup sheets are configured as drawing templates in NX. They hold placeholders for the class attributes
that are replaced with values when you generate a setup sheet for a resource. The attribute placeholders
must be configured in NX following a specific format.

1. Set up the drawing template as specified in the Drawing templates section of the CAD Drafting
Help in the NX Help Collection.

Consider when creating a drawing template that the unit is hard-coded in the template. The unit
delivered with the default setup sheet is metric. If you use inch tool assemblies, you must modify
the hard-coded unit. The tool attribute values are always transferred in the tool assembly ICO unit.

2. In the drawing template in NX, right-click the placeholder for the attribute value and choose Edit
text.

3. In the Text dialog box, edit the placeholder text.

Create custom setup sheets
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The entry always begins with ${ and ends with }.

• Attributes are entered using their attribute ID.

• Key-LOV entries display the attribute key followed by the key value. For example, the key-LOV
-45213 contains the following:

The placeholder for such a key-LOV has the following format:

${-45213} ${-45213_TEXT}

The first entry, ${-45213} displays the key and the second entry, ${-45213_TEXT}, displays its
value. You can create a placeholder for the value only:

${-45213_TEXT}

• Array placeholders must contain an index indicating the array position. For example:

${-45002_1}

4. Add the new template revision to the MRMSetupSheetTemplatesMetric or the
MRMSetupSheetTemplatesInch preference depending on your needs, and to the template PAX
file as explained in Enable setup sheet generation for resources .
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PAX file entries for setup sheets

The NX drawing template part files must be registered in the related NX PAX files, located in the
DRAFTING\templates directory.

Add the following entries to the nxdm_ugs_drawing_templates.pax file, between the last </
PaletteEntry> and </Palette> tags.

<PaletteEntry id="id_mrl_mm_1">
    <References/>
    <Presentation description="MRM General Resource Setup Sheet Template 
Metric"
     name="MRM DRW Resources General Metric">
     <PreviewImage location="@DB/MRM_DRW_resources_general_metric/A" 
type="UGPART"/>
    </Presentation>
    <ObjectData class="DrawingTemplate">
    <TemplateFileType>none</TemplateFileType>
    <Filename>@DB/MRM_DRW_resources_general_metric/A</Filename>
    <Units>Metric</Units>
    <UsesMasterModel>Yes</UsesMasterModel>
    <ItemType>Any</ItemType>
    <RelationType>specification</RelationType>
    </ObjectData>
</PaletteEntry>

<PaletteEntry id="id_mrl_mm_2">
    <References/>
    <Presentation description="MRM Drilling Tool Setup Sheet Template 
Metric"
     name="MRM DRW Tool Assy Drill Metric">
      <PreviewImage location="@DB/MRM_DRW_tool_assy_drill_metric/A" 
type="UGPART"/>
    </Presentation>
    <ObjectData class="DrawingTemplate">
    <TemplateFileType>none</TemplateFileType>
    <Filename>@DB/MRM_DRW_tool_assy_drill_metric/A</Filename>
    <Units>Metric</Units>
    <UsesMasterModel>Yes</UsesMasterModel>

PAX file entries for setup sheets
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    <ItemType>Any</ItemType>
    <RelationType>specification</RelationType>
    </ObjectData>
    </PaletteEntry>

<PaletteEntry id="id_mrl_mm_3">
    <References/>
    <Presentation description="MRM Milling Tool Setup Sheet Template 
Metric"
    name="MRM DRW Tool Assy Mill Metric">
      <PreviewImage location="@DB/MRM_DRW_tool_assy_mill_metric/A" 
type="UGPART"/>
    </Presentation>
    <ObjectData class="DrawingTemplate">
    <TemplateFileType>none</TemplateFileType>
    <Filename>@DB/MRM_DRW_tool_assy_mill_metric/A</Filename>
    <Units>Metric</Units>
    <UsesMasterModel>Yes</UsesMasterModel>
    <ItemType>Any</ItemType>
    <RelationType>specification</RelationType>
    </ObjectData>
</PaletteEntry>

<PaletteEntry id="id_mrl_mm_4">
    <References/>
    <Presentation description="MRM Turning Tool Setup Sheet Template 
Metric"
     name="MRM DRW Tool Assy Turn Metric">
      <PreviewImage location="@DB/MRM_DRW_tool_assy_turn_metric/A" 
type="UGPART"/>
    </Presentation>
    <ObjectData class="DrawingTemplate">
    <TemplateFileType>none</TemplateFileType>
    <Filename>@DB/MRM_DRW_tool_assy_turn_metric/A</Filename>
    <Units>Metric</Units>
    <UsesMasterModel>Yes</UsesMasterModel>
    <ItemType>Any</ItemType>
    <RelationType>specification</RelationType>
    </ObjectData>
</PaletteEntry>

<PaletteEntry id="id_mrl_mm_5">
    <References/>
    <Presentation description="MRM General Tool Setup Sheet Template 
Metric"
    name="MRM DRW Tool General Metric">
        <PreviewImage location="@DB/MRM_DRW_tool_general_metric/A" 
type="UGPART"/>
    </Presentation>
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    <ObjectData class="DrawingTemplate">
    <TemplateFileType>none</TemplateFileType>
    <Filename>@DB/MRM_DRW_tool_general_metric/A</Filename>
    <Units>Metric</Units>
    <UsesMasterModel>Yes</UsesMasterModel>
    <ItemType>Any</ItemType>
    <RelationType>specification</RelationType>
    </ObjectData>
</PaletteEntry>  

<PaletteEntry id="id_mrl_in_1">
    <References/>
    <Presentation description="MRM General Resource Setup Sheet Template 
Inch"
    name="MRM DRW Resources General Inch">
        <PreviewImage location="@DB/MRM_DRW_resources_general_inch/A" 
type="UGPART"/>
    </Presentation>
    <ObjectData class="DrawingTemplate">
    <TemplateFileType>none</TemplateFileType>
    <Filename>@DB/MRM_DRW_resources_general_inch/A</Filename>
    <Units>English</Units>
    <UsesMasterModel>Yes</UsesMasterModel>
    <ItemType>Any</ItemType>
    <RelationType>specification</RelationType>
    </ObjectData>
</PaletteEntry>

<PaletteEntry id="id_mrl_in_2">
    <References/>
    <Presentation description="MRM Drilling Tool Setup Sheet Template 
Inch"
     name="MRM DRW Tool Assy Drill Inch">
      <PreviewImage location="@DB/MRM_DRW_tool_assy_drill_inch/A" 
type="UGPART"/>
    </Presentation>
    <ObjectData class="DrawingTemplate">
    <TemplateFileType>none</TemplateFileType>
    <Filename>@DB/MRM_DRW_tool_assy_drill_inch/A</Filename>
    <Units>English</Units>
    <UsesMasterModel>Yes</UsesMasterModel>
    <ItemType>Any</ItemType>
    <RelationType>specification</RelationType>
    </ObjectData>
</PaletteEntry>

<PaletteEntry id="id_mrl_in_3">
    <References/>
    <Presentation description="MRM Milling Tool Setup Sheet Template 
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Inch"
     name="MRM DRW Tool Assy Mill Inch">
        <PreviewImage location="@DB/MRM_DRW_tool_assy_mill_inch/A" 
type="UGPART"/>
    </Presentation>
    <ObjectData class="DrawingTemplate">
    <TemplateFileType>none</TemplateFileType>
    <Filename>@DB/MRM_DRW_tool_assy_mill_inch/A</Filename>
    <Units>English</Units>
    <UsesMasterModel>Yes</UsesMasterModel>
    <ItemType>Any</ItemType>
    <RelationType>specification</RelationType>
    </ObjectData>
</PaletteEntry>

<PaletteEntry id="id_mrl_in_4">
    <References/>
    <Presentation description="MRM Turning Tool Setup Sheet Template 
Inch"
     name="MRM DRW Tool Assy Turn Inch">
        <PreviewImage location="@DB/MRM_DRW_tool_assy_turn_inch/A" 
type="UGPART"/>
    </Presentation>
    <ObjectData class="DrawingTemplate">
    <TemplateFileType>none</TemplateFileType>
    <Filename>@DB/MRM_DRW_tool_assy_turn_inch/A</Filename>
    <Units>English</Units>
    <UsesMasterModel>Yes</UsesMasterModel>
    <ItemType>Any</ItemType>
    <RelationType>specification</RelationType>
    </ObjectData>
</PaletteEntry>

<PaletteEntry id="id_mrl_in_5">
    <References/>
    <Presentation description="MRM General Tool Setup Sheet Template 
Inch"
     name="MRM DRW Tool General Inch">
      <PreviewImage location="@DB/MRM_DRW_tool_general_inch/A" 
type="UGPART"/>
    </Presentation>
    <ObjectData class="DrawingTemplate">
    <TemplateFileType>none</TemplateFileType>
    <Filename>@DB/MRM_DRW_tool_general_inch/A</Filename>
    <Units>English</Units>
    <UsesMasterModel>Yes</UsesMasterModel>
    <ItemType>Any</ItemType>
    <RelationType>specification</RelationType>
    </ObjectData>
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</PaletteEntry>
   

Setting up site-specific properties to search resources by site

Step 1: set up site-specific properties

1. Ensure that the MRMSiteDataEnabled preference is set to true.

This displays the Create/update site specific data for resources button in the Resource Manager
on Rich Client application.

2. In Resource Manager on Rich Client, open a resource from the tooling library and click Create/
update site specific data for resources.

The first time you click the Create/update resource site data button, Teamcenter creates the
following new classes under the SAM node in the hierarchy along with four new attributes.

Class name ID With these attributes

Resource Site
Specific Data

MRM_SITE_DATA -46003 Resource Location

-46004 Resource Status

-46005 Resource Vendor

-46006 Resource Machine

Status MRM_SITE_DATA_01 Inherits:

-46003 Resource Location

-46004 Resource Status

Vendor MRM_SITE_DATA_02 Inherits:

-46003 Resource Location

-46005 Resource Vendor

Machine MRM_SITE_DATA_03 Inherits:

-46006 Resource Machine

3. Add the class IDs for which you want to create the site-specific properties to the MRMSiteData
preference.

Step 1: set up site-specific properties
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This preference defines the classes used to store the site-specific data for resources. For each class
listed in this preference, a tab is displayed in the Resource Site Data dialog. For example, if the
value of this preference is:

MRM_SITE_DATA_01 (class name: Status)

MRM_SITE_DATA_02 (class name: Vendor)

The dialog box in Resource Manager on Rich Client displays two tabs called Status and Vendor.

The class name and attributes define the title of the tab and the attributes that are displayed in the
tab. You can extend the MRM_SITE_DATA class structure to include any class that suits your needs.
The attributes contained in the classes listed in this preference are the attributes that are displayed
when you create new site-specific properties. For example, the Status class contains two attributes,
and these are displayed when you create new site-specific data on the Status tab.

Step 2: set up the search for the site-specific properties

To set up the search for a specific property, you must create two attributes. The first attribute is added
to the class listed in the MRMSiteData preference. The second attribute is a reference attribute that is
added to the class. For example, for the Resource Status site-specific property, there are two attributes:
a reference attribute (-46002) and a regular attribute (-46004). The regular attribute, -46004, is the one
listed in the MRMSiteData preference. The reference attribute, -46002, is the one added to the class and
for which you can search in the user interface.
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1. Create reference attributes for each attribute for which you want to search.

a. Create an attribute and select Reference Attribute during creation.

b. Click Configure.

c. In the Configure Reference Attribute dialog box, select Related Object.

d. Select the icm0 class in the POM Attribute tree.

e. Select the correct attribute from the POM Attribute list.

This list contains an internal ID for every attribute. The reference attributes are hard-coded
to refer to a specific position of the attributes in the classes named in the MRMSiteData
preference. For example, if the reference attribute refers to the icm0::sm02 attribute,
Teamcenter searches for the value contained in the attribute that is in the second position
of the attributes contained in the classes listed in the MRMSiteData preference.

Step 2: set up the search for the site-specific properties
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Caution:

To avoid unexpected search results, when extending the site-specific data framework,
create subclasses of the MRM_SITE_DATA class and add any new attributes to the
parent MRM_SITE_DATA class allowing them to be inherited to the new subclasses.
When you create a reference attribute referring to the new attribute, Teamcenter then
searches for the new attribute value in the correct position.

f. Select the Mfg0ResourceSiteDataRel relation in the Relations list.

2. Add the reference attribute to each class in which you want to search.

3. Set the ICS_reference_attribute_use_format_for_display to true.

This preference specifies that the format of the reference attribute is used to determine the type of
text field when searching in Resource Manager on Rich Client.

Setting up the NX search dialogs to include new classification
classes and attributes

The search dialogs that are displayed when you search for tools or machines in NX are referred to as the
NX search dialogs. They consist of three dialog boxes, the Library Class Selection, the Search Criteria,
and Search Results dialog boxes. When you search in NX, these dialogs provide you with information
about the tools and machines saved in the Teamcenter database. If you modify classes or attributes in
the Teamcenter database, you must update the NX search dialogs to be able to search for the changed
objects.
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The content of the NX search dialogs is specified by definition (DEF) files. This mechanism is
thoroughly explained in the CAM libraries→Library definition files section of the Manufacturing General
documentation in NX.

You can export the classification hierarchy, its classes and attributes, as well as class and hierarchy
images to such a DEF file using the mrm_export_resources utility.

By default, when you export the classification hierarchy and use the resulting DEF file in NX, all
Teamcenter attributes are shown in the Search Criteria and Search Results dialog boxes. You can
limit the number of attributes shown in these dialog boxes by creating mapping views of your tool
assembly classes in Classification Admin that only contain the attributes that you need in the NX dialog
boxes. To assist you, two mapping view types are delivered in Classification Admin that are used by the
mrm_export_resources utility to create the appropriate DEF files.

View type Description

NXLIB_SearchCriteria Specifies which attributes are displayed in the Search
Criteria dialog box in NX.

NXLIB_SearchResult Specifies which attributes are displayed in the Search Result
dialog box in NX.

Teamcenter lists the attributes that you specify in the NXLIB_SearchCriteria view as parameters of the
DIALOG statement in the DEF file. It writes the attributes that you specify in the NXLIB_SearchResult
view as parameters of the RSET statement. If you do not create an NXLIB_SearchResult view,
Teamcenter automatically uses the same attributes for the Search Result dialog box as it does for
the Search Criteria dialog box. If you do not specify either of these views, all Teamcenter attributes are
displayed in both dialog boxes.

Any time you make changes to the classification hierarchy, you must run the mrm_export_resources
utility to ascertain that these changes are reflected in the NX search dialogs.

Tip:

Use the mrm_export_resources utility to export hierarchy images for use in the NX dialog boxes.

In the Manufacturing Resource Library, the NXLIB_SearchCriteria and NXLIB_SearchResult mapping
views are delivered by default. The NX Search Result dialog does not include site-specific properties.

By default in NX, you cannot search for attributes when searching for machines. To turn on the display
of the NX Search Criteria dialog box where you can search for site-specific properties for the machines,
you must add the following two lines to the ugii_env.dat file:

UGII_CAM_MACHINE_QUERY_DIALOG=yes
UGII_CAM_DEVICE_QUERY_DIALOG=yes

Setting up the NX search dialogs to include new classification classes and attributes
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Manually extend the Classification hierarchy with a new class

If you extend your Teamcenter Classification hierarchy with new tool assembly classes, these must be
reflected in the NX Library dialogs so that you can search in the new classes from within NX. Because NX
supports only a limited number of tool types, you must map every new tool assembly in Teamcenter to a
tool type in NX.

You can extend the hierarchy manually, or you can use the mrm_export_resources utility to perform
these steps automatically.

The following steps show how to manually create a new class, Custom_Mill_Tool, to hold 5-parameter
milling tools. The new class ID is TA_MILL_10_75.

1. Create a new class in the Classification Admin application. Keep in mind
that the NX Library mechanism only reflects tool assemblies found in the
Resource Management→Tools→Assemblies branch of the classification hierarchy.
For the example, you must create the Custom_Mill_Tool class within Resource
Management→Tools→Assemblies→Milling.

2. Add all necessary class attributes. Every tool type within NX requires its own minimum set of
attributes. These are based on the attributes that appear in the tool dialogs within NX CAM.

For more information about the mandatory parameters necessary for a five parameter milling
tool, see CAM Library→Cutter, tool holder, and device libraries→Creating new classes and
subclasses→Attributes for new tool classes and subclasses in the Manufacturing General Help
in the NX Help collection.

Note:

Negative attribute numbers are reserved for Siemens Digital Industries Software attributes. If
you add custom attributes, use positive attribute IDs.

3. Open the MACH\resource\library\tool\inclass\dbc_mrl_tooling_library_tlas_en.def file in an
editor. You can find this file in the directory where NX is installed.

4. Add the new class to the class hierarchy section of this file as explained in Library class hierarchies
in the NX Library Help.

5. If you assigned customer-specific attributes that are required by the NX CAM tools, adjust
the event handler file to map to these attributes in the DBC retrieve procedure in the
dbc_mrl_tooling_library_tlas_en.tcl file.

6. Restart NX and Teamcenter.

The new class now appears in the NX Library dialog boxes when you search for a tool in NX.
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Structure Manager alignment

The preference BOMExcludeFromPackCheck can affect the autopack functionality controlled by
preference PSEAutoPackPref if the value is set to seqno. It is recommended that the value is set to
none to ensure all components of the assembly are consistently displayed.

Preferences required for the Manufacturing Resource Library

The following preferences are required to install and run the Manufacturing Resource Library:

• ICS_hierarchy_sort_option

• MRMPropagationAlternateAttributes

• ICS_root_selector_entries

• ICS_user_defined_button_class

Part Manufacturing BMIDE template

Teamcenter Manufacturing has interfaces to NX CAM, NX CMM, NX Additive Manufacturing,
and Shop Floor Integrate (SFI) RM. The Part Manufacturing Business Modeler IDE (BMIDE)
template, pm0partmanufacturing_template.xml, contains Teamcenter business objects used for those
integrations.

With the presetter business objects, you can store measurement programs for tools and define presetter
groups.

Note:

You create a new measuring program dataset by selecting File→New→Other.

See Create a dataset business object for the procedure to add the new measuring dataset to the
dataset list.

In Teamcenter, the Part Management template includes the business objects needed to store the
definition of presetter groups and measuring programs. Future releases of this template will include
all of the business objects needed for Manufacturing Resource Library, so you only need one template
for general Teamcenter integrated Part Manufacturing tasks.

Note:

This template is installed in the same way as other templates, using the Teamcenter Environment
Manager (TEM).

Structure Manager alignment
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Follow this path in TEM, Configuration Manager→Perform maintenance on an existing
configuration→Add/Remove Features→Extensions→Part Manufacturing→Part Manufacturing
Shopfloor integration, e.g., Presetter and Activity User Data.

If you are installing a new database, choose Add new configuration instead of Perform
maintenance on an existing configuration.
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