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1. What is Resource Manager?
Resource Manager lets NC programmers, process planners, and tool designers store, modify, retrieve,
and manage resource data to create:

• Fixture assemblies, machine setups, and NC programs for machine tools, robots, and measuring
devices.

• Tool assemblies that combine machine tools and robots with their devices.

• Setup sheets for the complete operation.

Resource data can include classification information, Teamcenter items, and additional data such as
associated imported files and links to context information. You define the data using hierarchically
organized class definitions. Each class defines a set of values, or attributes, that typically specify
characteristics of an object.

Example:

The diameter, weight, and length of a tool.

Use class hierarchies to organize and search for your resources as a hierarchically organized collection
that is independent of product structure.

• Resource Management

• Tools

■ Assemblies

◊ Turning Tools

◊ Milling Tools

◊ Drilling Tools

Basic concepts

Use Resource Manager to:

• View resource components and their associated attributes using a variety of views or perspectives.

• Create detailed classification structures of manufacturing data such as tools, machines, fixtures,
assemblies, and components.
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• Create structured resource assemblies used in your manufacturing tasks, propagate component
attributes to your resource assembly, assign workflows to resources, and attach notes and graphics to
resources.

• Classify and search for resource assemblies and resources using the Teamcenter quick search, Object
ID search, or Classification Search Dialog.

• Create and edit manufacturing documentation to support rich work instructions and collaboration
between departments.

1. What is Resource Manager?
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2. Getting started with Resource Manager
Selecting a workspace in Resource Manager

You can create multiple Resource Manager workspace profiles in Active Workspace so that only resource
information and tiles that apply to a specified project are available for the user to use. This allows the
user to quickly find resource information and tiles that are to be used for the specified project.

The default Resource Manager Workspace profiles in Active Workspace are:

Manufacturing: Allows the user to view and use resource information and tiles that are assigned to the
project.

Author: Allows the user to view all of the resource information and tiles in the profile, regardless of the
project.

You access the user attribute panel when you click the (1) user icon. Then select a group profile from the
(2) Group menu or a workspace profile from the (3) Workspace menu.
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Manufacturing Resource Library dashboard

You can open the Manufacturing Resource Library (MRL) dashboard from the Active Workspace home
page.

The MRL dashboard gives you access to information about the classified resources included in the MRL
and their resource types.

Note:

Use the RECENT panel to quickly access and open previously viewed resources.

You can use the DISCUSSIONS panel to communicate with other users.

Resources in the Manufacturing Resource Library main class include:

• Factory Resources

2. Getting started with Resource Manager
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• Fixtures and Devices

• Machines

• Machining Data Library

• Measuring Devices

• New Resources

• Templates

• Tools

• Vendor Catalogs

The dashboard has a bar graph that shows the number of resources by resource type.

Manufacturing Resource Library dashboard
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Use filters to limit the number of resources shown.

2. Getting started with Resource Manager
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The MRL dashboard includes resources that you can view as a list, as a table, or as images.

Note:

When you display the table view, you can sort the resource and attribute columns by clicking a
column header.

You can open a resource by clicking the  Open icon next to the resource name.

These attribute columns appear in the dashboard by default:

• Name

• Description

• Release Status

• Checked-Out

Manufacturing Resource Library dashboard
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• ID

• Revision

• In Process

• Classified in

• Checked-Out By

These attribute columns do not appear in the dashboard by default:

• Alias ID

• Alternate ID

• Smart Discovery Indexed

Note:

You can sort the resource columns by these attributes. You can also click the  Settings icon, and
then select Arrange to choose the columns to display.

View Manufacturing Resource Library data in Active Workspace

Additional steps may need to be performed by an administrator if the Manufacturing Resource Library
(MRL) classes and objects are not visible when you change from using in Teamcenter in the Rich
Client to using MRL in Active Workspace. For more information, see Deploying and administering basic
classification.

2. Getting started with Resource Manager
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3. Finding and visualizing resources
Open existing resources

Resource Manager provides you with two ways to open existing resources. You can:

• Use the quick search at the top of the Active Workspace interface.

• Click the Classification tile to access the Class Navigator, where you can search for an existing
component. Drill down into the classification structure or use the Filter input field.

Structure display options for item type Resource

You can easily examine resource structures in Teamcenter Active Workspace, including the way
components are assembled from the machine side to the workpiece side, by using the Resource or
Resource with Summary options.

The Resource and Resource with Summary options are available for item type Resource and for
Resource subtypes, such as NC Tool.

Once you select Resource or Resource with Summary, the appropriate icon is displayed at the top of
the diagram.

View mode icons:

Resource Mode
Resource Summary Mode
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The Resource mode shows the resource structure as it is mounted from the machine side to the
workpiece side.

1. Resource assembly

2. Tool holder

3. Cutter

4. Inserts

5. Information contained in each node:

• Preview image (depending on availability, the image will be one of these items; preview item
revision image, class icon, symbol of item type)

• Item name

• Item ID

• Revision ID

•  Propagation start point (if component has a PSP assigned)

The Resource with Summary mode shows the resource structure diagram and in the secondary work
area on the right, summary information.

3. Finding and visualizing resources
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1. The information for a node that you select in the Resource is displayed in the Overview tab in the
secondary work area.

2. Commands that control the display of the Resource Item Type are shown above the Resource
window.

3. Tabs that contain information about the selected node are shown at the top of the secondary work
area.

Pack and unpack components

Some resources use multiple occurrences of the same component in the assembly structure. A typical
example is when a resource assembly uses several cutting inserts of the same type.

The system displays these occurrences in a single node by default. When packed, a single node is
displayed and the number of occurrences is shown in the box.

Note:

The component that occurs multiple times must have the same Item ID and sequence number in
each instance for it to pack successfully.

Selecting Unpack separates each occurrence of the component into a separate node.

Structure display options for item type Resource
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Resource with Summary synchronized with 3D Viewer

When you view the Resource with Summary, you can select the 3D tab to display the 3D Viewer. If you
select a component node in the diagram, the component is highlighted in the 3D Viewer. If you select a
component in the 3D Viewer, the component node is highlighted in the diagram.

Note:

To add any custom item type to the Content tab to show all components of an assembly
structure, follow this path: Deployment and Configuration > Configuration and Extensibility
> Configuring Active Workspace features > Active Content configuration in the Active
Workspace Help and see the Help topic Marking archetypes to support structure.

3. Finding and visualizing resources
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Search components

Saving and recalling saved searches

Saving a search

Searches in the Manufacturing Resource Library (MRL) can be saved to Active Workspace for quick
access. You select Pin to Home in the Save Search panel.

Recalling a saved search

You can recall a saved search in one of the following ways:

• Access saved searches from the Home page:

Access saved searches from the MRL Saved Searches tile.

Access saved searches from the tile of a saved search that was pinned to the Home page.

• Access saved searches from the MRL dashboard:

Saving and recalling saved searches
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Access saved searches from Saved Searches on the MRL dashboard header.

Save a search

You can save searches to allow others to view or to quickly recall later.

1. Click the Manufacturing Resource Library tile on Active Workspace.

2. Select Filters  at the top of the results panel to narrow the displayed resources to those you want
to include in your search.

3. Click Save Search  at the top of the results panel.

4. Enter the following information in the Save Search dialog box.

3. Finding and visualizing resources

3-6  Resource Manager on Active Workspace, Teamcenter 2412
© 2025 Siemens



Name Type the name of the new resource. It is recommended that you make the
name unique so users can easily search the database using this term.

Allow others to
view

(Optional) To allow others to view your saved search.

Pin to Home (Optional) To create a tile of the saved search on Active Workspace for quick
access.

5. Click Save.

A message confirms the search is saved.

Visualize resources in 3D in Resource Manager

Visualizing resources in 3D viewer

You can use the 3D viewer to manipulate views, to query and measure parts and features, to view part
and assembly level product and manufacturing information (PMI), and to create 3D sections through
your resources.

For more detailed information about the 3D Visualization capabilities in Active Workspace, see
Visualizing 3D Product Data on the Siemens Support Center.

You can explore 3D data (JT) associated with resources in Resource Manager under either the Part
Manufacturing tab or the Content tab.

3D tab under the Part Manufacturing tab

The 3D tab is available for individual items in a resource assembly in the Part Manufacturing tab.

Note:

The available tabs and their order can differ depending on what templates were imported and
where you are in Active Workspace.

Visualizing resources in 3D viewer
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3D tab under the Content Tab

The 3D tab is available for the full setup in the Content tab for the resource type NC Machining
Revision.

Under the Content tab, you can highlight an individual component in the full setup by selecting the
component in the structure on the left or the graphic on the right.

3. Finding and visualizing resources
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Features for controlling 3D display

Gallery Show a collection of snapshots in the 3D view.

Quick
Measure

Calculate temporary measurements between the
parts or features in an assembly. The default unit is
meters.

Pick Parts/
Pick
Features+

Calculate distances between the selected parts or
selected features such as edges, points, or arc
centers.

Standard
Views

Align the 3D view of the model to a standard
angle. You can choose from the following views:
Top, Bottom, Left, Right, Front, Back, +Isometric,
-Isometric.

Visibility
Controls

Show or hide parts and subassemblies.

All On, All Off, Remove Analysis Results
Enable
Transparent
Selection
Display Mode

Enable to view the selected parts in their original
color and with bounding boxes. Unselected parts
appear transparent. Disable to view the selected
parts in the highlight color and the unselected parts
in their original color.

Fit Fit all of the components to the work area. Selecting
specific components fits the selection to the work
area.

Visualizing resources in 3D viewer
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Pan, Rotate,
Zoom

Pan—Move the 3D view vertically and horizontally
with the mouse to change the center of the view.

Rotate—Rotate the view of the 3D model around the
center of the view with the mouse. This is the default
navigation mode.

Zoom—Zoom in or zoom out of the current work
area with the mouse.

Viewer
Options

Control the view's characteristics, such as the
material, units, and 3D navigation model.

Measure Calculate the minimum distance between the
selected parts of features.

Query Display geometric information of the selected parts
or features.

Section Create and manage sections used to clip portions of
the 3D geometry in the 3D view. This allows users to
view internal elements to expose conditions such as
interference and clearance issues.

PMI Show and hide specific PMI or apply Model Views.

Full Screen Switch to the full-screen view.

Visualize individual resources in 3D viewer

1. Open a resource with the resource type NC Machining Revision.

2. Select the Part Manufacturing tab.

3. Select an item from the list of resources in the Part Manufacturing tab, and then select the 3D tab.

Note:

The 3D tab is only available for resources that have 3D data.

4. Adjust the display of the structure using the features at the top of the graphics window in the 3D
tab.

Visualize resource setup in 3D

1. Open a tool resource.

2. Select the Content tab.

3. Finding and visualizing resources
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3. Select the resource assembly line and then select the 3D tab.

4. Adjust the display of the structure using the features at the top of the graphics window in the 3D
tab.

5. (Optional) Select an individual resource in the assembly to highlight it in the graphics view.

Visualize resource setup in 3D
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3. Finding and visualizing resources

3-12  Resource Manager on Active Workspace, Teamcenter 2412
© 2025 Siemens



4. Populating the manufacturing resource
library
Creating resources

Creating a resource

You can create new or revised resources in the Manufacturing Resource Library (MRL) workspace in the
following ways:

• Create a new resource without classification or attributes.

When a resource is not selected or opened, use More commands →New →Create Resource 
on the primary toolbar to create and manually classify a new resource.

For more information see Create new resources.

• Create a new resource and select to use the classification and attributes of an existing resource.

When a resource is selected or opened, use More commands →New →Create Resource  on
the primary toolbar to create a new resource, but you can select to use the classification and
values of the selected resource.

For more information see Create resources using an existing resource.

• Create a new resource that includes the classification and attributes of an existing resource.

When a resource is selected or opened, use More commands →New →Save As  on the
primary toolbar to create a new resource with the classification and values of the selected
resource.

For more information see Create resources using Save As.

• Create a revision of an existing resource that includes the classification and attributes.

When a resource is selected or opened, use More commands →New →Revise  on the
primary toolbar to revise a resource with the classification and values of the selected resource.

For more information see Create resources using Revise.

• Create a revision of an existing resource and all parent assemblies that includes the classification and
attributes.
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When a resource is selected or opened, use More commands →New →Revise Including Parent
Assemblies  on the primary toolbar to revise a resource, and all parent assemblies, with the
classification and values of the selected resource.

For more information see Revise resources and parent assemblies.

Note:

New and revised resources can be accessed in the New Resources tab on the Manufacturing
Resource Library (MRL) dashboard.

Create new resources

Create new resources without classification or attributes in the Manufacturing Resource Library (MRL)
dashboard workspace.

1. On Active Workspace, click the Manufacturing Resource Library tile.

2. Select More commands →New →Create Resource on the primary toolbar.

3. Select the resource type from the TYPE list, or search for it in the Search field.

4. Enter the Properties for the new resource.

ID Manufacturing Resource Library (MRL) automatically assigns a unique ID that
you can accept or change. If you change it, the new ID must be unique.

Revision MRL automatically assigns a revision letter that you can accept or change.

4. Populating the manufacturing resource library
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Name Type the name of the new resource. Use a unique name so it is easier to search
the database using this term.

Description (Optional) Type a description of the new resource.

5. Click Create.

Note:

• Once the resource is created, it is recommended that you next classify the resource.

• If this resource is a root node for a resource assembly, you can now add components.

Create resources using an existing resource

Create new resources with the classification or values of the selected resource in the Manufacturing
Resource Library (MRL) dashboard workspace.

1. On Active Workspace, click the Manufacturing Resource Library tile.

2. On the MRL dashboard workspace, select or open a resource that includes the classification or
values to be used for the new resource.

3. Select More commands →New →Create Resource  on the primary toolbar.

4. In the Create Resource dialog box, you can select the following:

• Select (1) Classify in Same Class to classify the new resource in the same class as the selected
resource.

• Select (2) Copy Values to copy the values of the selected resource to the new resource.

Note:

Copy Values can be selected only when Classify in Same Class is selected.

Create resources using an existing resource
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5. Select the resource type from the TYPE list, or search for it in the Search field.

6. Enter the Properties for the new resource.

4. Populating the manufacturing resource library
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ID MRL automatically assigns a unique ID that you can accept or change. If you
change it, the new ID must be unique.

Revision If this is a revision of an existing resource, type the next consecutive revision
letter.

Name Type the name of the new resource. Use a unique name so it is easier to search
the database using this term.

Description (Optional) Type a description of the new resource.

7. Click Create.

Note:

If the existing resource is an assembly, the new resource will inherit the components,
classification object (ICO), and structure of the existing resource.

Create resources using Save As

Create new resources with the classification or attributes of the selected or opened resource in the
Manufacturing Resource Library (MRL) workspace.

Procedure

1. On Active Workspace, click the Manufacturing Resource Library tile.

2. On the MRL workspace, select or open a resource that includes the classification or values to be
used for the new resource.

3. Select More commands →New →Save As  on the primary toolbar.

4. In the Save As dialog box, enter the Properties for the new resource.

Name (Optional) Type the name of the new resource. Use a unique name so it is
easier to search the database using this term.

Description (Optional) Type a description of the new resource.

5. Click Save.

Note:

If the existing resource is an assembly, the new resource will inherit the components,
classification object (ICO), and structure of the existing resource.

Create resources using Save As
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Create resources using Revise

Create revised resources with the classification or attributes of the selected or opened resource in the
Manufacturing Resource Library (MRL) workspace.

Procedure

1. On Active Workspace, click the Manufacturing Resource Library tile.

2. On the MRL workspace, select or open a resource that includes the classification or values to be
used for the revised resource.

3. Select More commands →New →Revise  on the primary toolbar.

4. In the Revise dialog box, enter the Properties for the revised resource.

Revision MRL automatically assigns the next consecutive revision letter that you can
accept or change.

Name (Optional) Type the name of the new resource. Use a unique name so it is
easier to search the database using this term.

Description (Optional) Type a description of the revised resource.

5. Click Revise.

Note:

If the existing resource is an assembly, the revised resource will inherit the components,
classification object (ICO), and structure of the existing resource.

Adding vendor catalogs

Working with a vendor catalog

So you can use tools from a vendor catalog, you must download a file or data from the tool vendor and
import it into the Manufacturing Resource Library (MRL).

You can select (1) tool vendor product data, 3D data (STEP files), and tool components, such as drills,
holders, inserts, and adapters, from various tool vendors, using the (2) Generic Tool Catalog (GTC) or
DIN format, and download them to (3) your system.

The tool vendor product data or catalog package files can then be (4) imported directly into the MRL.

4. Populating the manufacturing resource library
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When you import a tool vendor catalog package to the MRL, the system automatically assigns a new
object identifier for the mapped object.

Note:

When you download a DIN tool vendor catalog package from a tool vendor, it is possible to enter
a customer-specific product identifier that you can assign to the mapped object, instead of the
system generated identifier.

This feature can be activated or deactivated. It is activated by default.

• For GTC vendor catalog packages, a GTC vendor catalog package hierarchy must first be uploaded
before the vendor product data can be imported. For more information see Import GTC vendor class
hierarchy.

• For DIN vendor catalog packages, the option to populate the vendor catalog package hierarchy must
be selected in the Teamcenter Configuration Setup before the vendor product data can be imported.

If installing to the MRL for the first time, see Import the class hierarchy.

If upgrading from an earlier MRL version, see Update the class hierarchy.

Working with a vendor catalog
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Note:

For more information on installing or updating the Manufacturing Resource Library, see
Installation overview and workflow.

The DIN formats supported for tool vendor catalog packages are DIN 26100:2017-11 and DIN
26100:2021-05.

To upload larger vendor catalog files, it is best to adjust the Active Workspace upload timeout setting in
file path: AW ROOT/microservices/gateway-nnn/config.json.

Note:

After making changes to the AW ROOT/microservices/gateway-nnn/config.json file, you must
restart the gateway.

• The default upload timeout setting, in milliseconds, is httpRequestResponse: 1800000. The
recommended setting is httpRequestResponse: 7200000.

"timeout": { "httpRequestResponse": 600000, "autoLogout": "30s",
"proxyRequest": "5s" },

It is also recommended that you set QUERY_TIMEOUT to 0 in the serverPool.properties file so that the
server connection does not time out automatically.

After making changes to the serverPool.properties file, you must restart service Teamcenter Server
Manager config1_PoolA to implement the changes.

The tool components can be automatically mapped to existing MRL tool classes.

You can build a tool assembly based on these components, create graphics for it, send it to NX, and use
it to machine parts in NX.

Import GTC vendor class hierarchy

Import a GTC vendor product data hierarchy into the Manufacturing Resource Library (MRL).

Note:

Before a user can import GTC vendor product data, an administrator or dba user must first import
a vendor class hierarchy to the MRL. For additional information see Working with a vendor
catalog.

1. On Active Workspace, click one of the following tiles:

4. Populating the manufacturing resource library
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• Manufacturing Resource Library

• Classification

• Explorer

2. On the primary toolbar, click the Import/Export  icon and select Import Vendor Hierarchy.

3. In the Import Vendor Hierarchy dialog box, do one of the following to select the product
hierarchy:

• If needed, select (1) Choose File to search for the vendor hierarchy package ZIP file that contains
the product hierarchy data, and click Upload.

Import GTC vendor class hierarchy
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Note:

Depending on the size of the ZIP package you select, this action can take time to upload.

• Select the (2) vendor tool catalog hierarchy you want to import from the list of available
packages.

4. Click Import Hierarchy.

5. (Optional) Open the resulting log file to view the import state of individual components.

Import vendor product data

Import vendor product data and tool components into the Manufacturing Resource Library (MRL).

Note:

Before a user can import GTC or DIN vendor product data, an administrator or dba user must first
import a vendor class hierarchy to the MRL. For additional information see Import GTC vendor
class hierarchy or Working with a vendor catalog.

1. On Active Workspace, click one of the following tiles:

• Manufacturing Resource Library

• Classification

• Explorer

2. On the primary toolbar, click the Import/Export  icon and select Import Vendor Products.

4. Populating the manufacturing resource library
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3. In the Import Vendor Products dialog box, take action as needed:

• If needed, select (1) Choose File to search for the vendor package ZIP file that contains the
product data, and click Upload.

Import vendor product data
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Note:

Depending on the size of the ZIP package you select, this action can take time to upload.

• Select the (2) vendor tool catalog package you want to import from the list of available
packages.

• Select the (3) Map Vendor Products check box to map the products from the vendor classes into
the MRL tool component classes.

• Select the (4) Import 3D Model check box to import the 3D data (STEP files) in the vendor tool
catalog package files, if available.

Do not select the Import 3D Model check box when using the NX Import Vendor 3D Graphics
feature in the Manufacturing Resource Library ribbon. For more information, see Managing
tool assemblies between Manufacturing Resource Library and NX.

• Select the (5) item type in the Select item type for the mapped products list. You must first
select Map Vendor Products to make the Select item type for the mapped products option
available.

4. Click Import Data.

Note:

Depending on the size of the package you select, this action can take several hours to
complete.

If multiple target classes are available for any of the imported items, the Map Products for
Multiple Target Classes dialog box opens, allowing you to select the MRL tool component class.

5. In the Map Products for Multiple Target Classes dialog box, view the (1) Source Class, the tool
component class assigned by the vendor, and then take action as needed:

4. Populating the manufacturing resource library
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• In (2) Select Target Class, choose a different tool component class in MRL, for the selected
product.

• Select (3) Do not map so that the tool component class for the component is not mapped in
MRL.

• Select (4) Map Products to confirm the selected tool component classes in MRL.

6. Click Map Products.

7. (Optional) Click Show Imported Products to open the imported components in MRL.

8. (Optional) Click Download Log File to open the resulting log file, allowing you to view the import
state of the individual components.

9. (Optional) Click Show Mapped Products to open the mapped components that were imported in
MRL.

Import vendor product data
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Creating resource assemblies

Creating resource assemblies

In addition to individual components, Resource Manager manages the resource assemblies that are used
by manufacturing tasks. Classified resource components are used to build these resource assemblies.

Generally, tool components cannot be used in a manufacturing process by themselves, so they are
assembled using Resource Manager into resource assemblies. These assemblies are then used in the
manufacturing production process. For example, parts are added to a resource assembly by a tool
designer and then used in a manufacturing process created by a process planner.

There are three main features of a resource assembly:

• Assembly structure

The assembly structure is displayed in a tree hierarchy on the left side of the Resource Manager
application window in the resource view. The tree hierarchy shows the logical structure of how the
different components are assembled to make up the structure. The root node represents the assembly.
Additional components are added to the root node to build the structure.

You can use cut, copy, paste, or drag-and-drop functions to organize components within the structure
hierarchy.

• Assembly attributes

If its root node is selected in the assembly structure, its attributes are shown on the Classification
Properties view. If subassembly or component nodes are chosen, the attribute list in the
Classification Properties view changes and the attributes of the selected object are displayed.

• Graphical representation

The Classification Properties view has two viewing windows on its right-hand side. The upper
window displays an image associated with its class, while the lower window shows an image
associated to the instance, if available.

Create a tool resource assembly

Start with an existing resource or create a new one. In the steps below, you create the new root-node
assembly item.

1. Click the Folders icon  on the Active Workspace Home page.

2. Select More commands →New →Add  on the primary toolbar.

3. Search for NC Tool in the Filter field or select it in the Recent list if available.

4. Populating the manufacturing resource library
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4. Enter a name for the new component in the Add dialog box.

Create a tool resource assembly
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5. Click Add.

Note:

After you add a new component, you can classify it by selecting the Classification tile from the
Active Workspace home page.

For more information on classifying resources, see Active Workspace, Advanced Classification ─
Deployment and Administration.

For more information on creating resources, see Create new resources.
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Methods for adding components to a tool resource assembly

There are several ways to add a component to a resource assembly.

• You click the Add Resource Component  icon on the menu bar above the summary view.

From the Add menu, either add an existing resource or create a new resource.

• You select Add Classified Resource Components.

You then can search the Classification Class Tree hierarchy from the Class Navigator.

Methods for adding components to a tool resource assembly
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• You click Add Resource Components in Workpiece Side  from the assembly node.

From the Add menu, either add an existing resource or create a new resource.

• You add a matching component by selecting a component in the structure and selecting the
Matching Components tab.

Note:

The available tabs and their order can differ depending on what templates were imported and
where you are in Active Workspace.

4. Populating the manufacturing resource library
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From the Matching Components tab, select a matching component from the matches in the
machine side or workpiece side results, and click  Add.

• You can copy and paste a component.

Note:

• After you add a new component, you can classify it by selecting the Classification tile from the
Active Workspace home page.

For more information on classifying resources, see Active Workspace, Advanced Classification ─
Deployment and Administration.

• You must unpack a component before you add a matching component.

Methods for adding components to a tool resource assembly
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Add new components to a tool resource assembly

Start with an existing resource or create a new one.

1. Select Add →Add Resource Component  on the work area toolbar.

2. Select the New tab.

3. Search for NC Tool in the Filter field or select it in the Recent list if available.

4. Populating the manufacturing resource library
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4. Enter a name for the new component in the Name: field.

Add new components to a tool resource assembly
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5. Select Add.
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Note:

After you add a new component, you can classify it by selecting the Classification tile from the
Active Workspace home page.

For more information on classifying resources, see Active Workspace, Advanced Classification ─
Deployment and Administration.

Add existing NC Tool resource component

1. Open or create an NC Tool resource that becomes the root node.

2. Select the Add Resource Component  icon from the menu bar above the summary view or from
one of the nodes in the assembly.

3. Click the Search tab in the Add dialog box.

4. Enter information into the Search input field to begin your search.

5. Find the tool you need in the Results list or use Filters to narrow the search results.

Add existing NC Tool resource component
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6. Once you locate the existing tool you want to add, select Add.

Add existing component by copy and paste

1. Use Search to locate an existing component to add to a tool assembly.

2. Select the component and select Copy  from the One Click Command area on the right side of
the page.

3. Navigate to the tooling assembly to which you want to add the component.

4. Select the node at the appropriate level in the structure.

5. Select Paste  from the One Click Command area on the right side of the page.
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Assigning components the same sequence number

You can navigate a tooling assembly easily, because Resource Manager assigns the same sequence
number to each component when you add two or more identical components to the assembly; for
example, components such as cutting inserts. Having the same sequence number means that the
components are packed into a single node in the resource diagram, which makes the assembly easier to
navigate.

Note:

The sequence number is also assigned automatically when you add a single component.

• When you add two or more components with the same ID to a tooling assembly, they have the same
sequence number.

• When you add additional component to an assembly that already contains a component with the
same ID, the new components have the same sequence number.

Assigning components the same sequence number
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• When you add two or more components with the same ID, the component nodes in the Resource
with Summary and Resource diagrams are automatically packed and the quantity is noted. In the
example (1), the quantity is noted in the packed node by x4 after the name.

• If you already have multiple components with the same ID in the assembly, and the nodes are
expanded when you add the additional components, the new nodes are not packed but have the
same sequence number.
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Creating resource assemblies leveraging resource information

Using existing information for new resource assembly

Use Create Parent Assembly to quickly build a new tool assembly that is based on an existing cutting
tool component.

When you use Create Parent Assembly to create a new tool assembly:

• The tool assembly is automatically classified in the correct tool assembly class.

• The selected tool component is added as a child to the tool assembly structure.

• The propagation start point is assigned to the cutting component.

• The tool assembly is saved to the database. The cutter attribute values, such as the cutting diameter,
corner radius, or tool material, are visible at the assembly level.

Create a parent assembly from a component

Use Create Parent Assembly to create a tool assembly that is automatically classified, based on the
selected component.

Using existing information for new resource assembly
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1. On Active Workspace, click the Manufacturing Resource Library tile.

Note:

This feature is only available for drilling, milling, and turning tool components.

The Manufacturing Resource Library (MRL) dashboard opens.

2. In the MRL dashboard, search for a tool component and select it from the results panel.

3. Select More commands →New →Create Parent Assembly  on the primary tool bar.

The Create Parent Assembly dialog box opens.

4. Populating the manufacturing resource library
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4. In the Create Parent Assembly dialog box, select the TYPE and enter the PROPERTIES.

ID MRL automatically assigns a unique ID that you can accept or change. If you
change it, the new ID must be unique.

Revision If this is a revision of an existing resource, type the next consecutive revision
letter.

Name Type the name of the new resource. Use a unique name so it is easier to search
the database using this term.

Description (Optional) Type a description of the new resource.

5. Click Create.

A message box appears to confirm the tool assembly is created.

Revise resources and parent assemblies

Use Revise Including Parent Assemblies to revise a resource and all parent assemblies.

Revise resources and parent assemblies
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Procedure

1. On Active Workspace, click the Manufacturing Resource Library (MRL) tile.

2. On the Manufacturing Resource Library (MRL) workspace select the resource to revise.

3. Select More commands →New →Revise Including Parent Assemblies  on the primary
toolbar.

A message shows the number of parent assemblies associated with the selected component.

4. Click Revise.

Searching for matching components

You can build a tooling assembly easier and faster in Active Workspace by using the information on the
Matching Components tab. This information allows you to choose from a list of classified objects that fit
with the selected component.
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Note:

The available tabs and their order can differ depending on what templates were imported and
where you are in Active Workspace.

Example:

In the Search results, select D16x35 EndMill_Indexable and select the Matching Components
tab. The components that can be used with the end mill are grouped by components that attach
Upwards, or closer to the machine, and components that attach Downwards, or closer to the
workpiece.

The Matching Components tab is available for item type Resource and for Resource subtypes.

Note:

The template Manufacturing Resource Manager (MRL) must be installed in order for the
Matching Components tab become available. It is installed using the Teamcenter Environment
Manager and is found under Server extensions.

Connection types (CT) and connection point definitions (CPD) must be imported in order
to take advantage of Matching Components. These rules are delivered with MRL and can be
imported using one of two options:

• Import rules and preferences

• Guided Component Search rules for tool components

You access the Matching Components tab from the Home folder, from the Search results page, from
the Item Revision page, and from the assembly content page.

Searching for matching components
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Matching Components from the Home page

Matching Components from the Item Revision page

Matching Components from the assembly content page

You can select the assembly from the assembly content page.

4. Populating the manufacturing resource library
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You can select a component from the assembly content page.

Add matching component to a tool assembly

1. Start with an existing resource assembly or create a new one.

Note:

The assembly must have at least one component.

2. Select a component of the assembly and click the Matching Components tab.

Add matching component to a tool assembly
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Note:

The available tabs and their order can differ depending on what templates were imported and
where you are in Active Workspace.

In this example, there are no matching components in the upwards direction, or the machine side
of the selected component. There are several components that do match the selected component
in the downwards direction, or the workpiece side.

3. Select a matching component from the UPWARDS (MACHINE SIDE) section or the DOWNWARDS
(WORKPIECE SIDE) section and click  Add.

In the example, the bull mill is selected and added to the assembly below the selected component,
on the workpiece side.

4. Populating the manufacturing resource library

4-34  Resource Manager on Active Workspace, Teamcenter 2412
© 2025 Siemens



Add multiple matching components to a tool assembly

1. Open an existing resource assembly or create a new one.

Note:

The assembly must have at least one component.

2. Select a component of the assembly and click the Matching Components tab.

Note:

If the selected component has multiple matching components, such as a milling cutter with
multiple cutters, you are prompted to define or confirm the number of matching components
you are adding.

3. Select the matching component, in this example the H-120_L-12.83_AN-0Deg cutter.

4. Click  Add.

Add multiple matching components to a tool assembly
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Because there is the possibility of adding multiple cutters, the Add dialog box displays additional
information regarding the number of cutters.

• The maximum number of cutters for this indexable face mill (1).

• The number of cutters you specify. The default value is the number of components for which
there are available locations (2).

4. Populating the manufacturing resource library
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Note:

If you have already added two cutters and are adding more, and the maximum number of
cutters is four, the default is two, based on the remaining available locations.

5. Accept the default number of components or enter a smaller number.

6. Click Add.

Positioning components automatically

Auto-positioning when you add a single component

When you add a component to the resource structure, the system automatically positions the 3D
geometry according to the Coordinate System Workpiece Side (CSW) and Machine Side Coordinate
System (MCS) of the component selected in the structure.

Positioning components automatically
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Note:

If there is only one CSW present, the component is automatically placed relative to that coordinate
system. If two or more CSWs are present, the component is added to the first open position.

Auto-positioning when you add multiple components

When you add two or more components to the resource structure and the mating component has two
or more CSWs, the system also automatically positions the 3D geometry based on related coordinate
systems, beginning with the first open position.

Auto-positioning components when you add, remove, or replace a component

When you add, remove, or replace components that have other components attached to them, the
system automatically positions the other components.

In the example above, the component ZYL16CMS12 Milling Head Adapter is removed (1). The
component D16x35_EndMill_Indexable and the cutters attached to it are properly repositioned (2).

The system also automatically handles the positioning if you insert a component that requires a mating
component to move to a different location. For example, if you insert the adapter between the chuck
and the end mill, the system automatically handles the positioning of the components.
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Tip:

Confirm the auto-position setting in NX: File→Utilities→Customer Defaults→Teamcenter
Integration→General→Feature→Product Interfaces is set to Relations.

Create and publish a coordinate system in NX

If you use the Manufacturing Resource Library, the coordinate systems for each component are defined
in the part family templates. In a manual configuration, you must perform the following steps to publish
the coordinate systems from NX to Teamcenter:

1. In NX, create a coordinate system of the Datum CSYS type and give it a name that conforms to the
DIN4003 naming standard.

2. Add the coordinate system to the product interfaces by choosing Tools→Product Interface.

3. Choose File→Options→Save Options and select Save JT Data.

Tip:

Confirm the auto-position setting in NX: File→Utilities→Customer Defaults→Teamcenter
Integration→General→Feature→Product Interfaces is set to Relations.

Create and publish a coordinate system in NX
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DIN4003 coordinate system naming scheme

The DIN4003 standard defines how 3D graphic models for different tool component classes must be
designed. This standard also defines the coordinate systems in the tool components using the following
naming scheme:

MCS

Machine-side coordinate system

CSW

Coordinate system workpiece-side

A tool component always has one MCS and any number of CSWs, depending on its design. If it has
a single CSW, the coordinate system is called CSW. If it has multiple CSWs and dedicated steps (see
example), the coordinate systems are additionally numbered in ascending order, using a system that
is dependent on the shape of the component. The examples provide an introduction to the naming
convention.

Tool component MCS CSW

Insert: DIN4003_76_01
[TC_INSERT_10_00_100]

Pointing toward the
holder

None
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Tool component MCS CSW

Holder: DIN4003_90_02
[TC_TURN_40_00_100]

Pointing toward the
machine adapter

CSW pointing toward the insert

Tool component MCS CSW

Drill: DIN4003_86_04
[TC_DRILL_20_20_100]

Pointing toward the
machine adapter

CSW_1 pointing toward the insert

CSW_2 pointing toward the insert

DIN4003 coordinate system naming scheme
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Tool component MCS CSW

Step drill: DIN4003_86_05
[TC_DRILL_20_20_110]

Pointing toward the
machine adapter

First step: CSW1_1, CSW1_2 (pointing
toward the inserts)

Second step: CSW2_1, CSW2_2 (pointing
toward the inserts)

Third step: CSW3_1, CSW3_2 (pointing
toward the inserts)

Fourth step: CSW4_1, CSW4_2 (pointing
toward the inserts)
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Tool component MCS CSW

Shell end mill:
[TC_MILL_20_20_120]

Pointing toward the
machine adapter

CSW_1, CSW_2, CSW_3, CSW_4, CSW_5,
CSW_6, CSW_7, CSW_8 (all pointing
toward the inserts)

DIN4003 coordinate system naming scheme
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Tip:

Confirm the auto-position setting in NX: File→Utilities→Customer Defaults→Teamcenter
Integration→General→Feature→Product Interfaces is set to Relations.
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Working with multitool assemblies

Overview of multitool assemblies

Multitools are tool assemblies that have more than one cutter.

Multitools save costs by reducing the need for extra tool components, and save setup time between
operations that use different cutters. Using Resource Manager, you can create multitools in a way similar
to the methods for creating other tools. Resource Manager displays the multiple cutters in one assembly.

Overview of multitool assemblies
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Each cutter is assigned its own tool type and is able to have its own attribute propagation start point
(PSP) in the resource bill of materials (BOM) structure.

You can also search specifically for multitools in NX CAM and retrieve them from the Manufacturing
Resource Library (MRL). The required tool parameters are passed from Resource Browser to each cutter
in the multitool assembly. The multitool is then used to create and simulate the tool path.

Multitool classification

Multitools are stored in the existing tool assembly classes. In support of multitools, the following
multitool attributes are available in the assembly classes:

• Multitool [MT]—Identifies a multitool

• Cutter ID [CID]—Unique cutter identifier used for multitools

• Cutter Name [CNA]—Description for a cutter typically used in a multitool

• Index Notch [INN]—Rotation angle around tool axis to position tool cutter

• Turret Rotation [TUR]—Incremental turret rotation angle to position tool cutter

Note:

The attributes Multitool [MT] and Cutter ID [CID] are set to read-only. Resource Manager
automatically updates these attributes.

How Resource Manager handles cutter IDs for multitools

Resource Manager manages multiple cutters by assigning unique cutter IDs for each cutter in the
multitool assembly.

Example:

The multitool with the item revision ID nxt_multi_04_00815/B has three cutters assigned, with
these ID classification objects (ICOs):

• nxt_multi_04_00815/B#1

• nxt_multi_04_00815/B#2

• nxt_multi_04_00815/B#3

When you create multitools, the system first checks if the existing tool has multitool classification objects
attached, and determines the appropriate cutter ID. The default cutter ID is 2, unless more than one
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cutter is already in the assembly. If more than one cutter is present, the next cutter added is assigned the
next available cutter ID number. The assigned cutter ID is stored in the attribute Cutter ID [CID].

ICO assignment for multitools

When you create a multitool assembly, a new ICO is created and attached to the same classified tool item
or revision as the original tool assembly.

By default, the new ICO resides in the same class as the original tool assembly. All shared values
are copied into the new cutter ICO, while all other fields remain initially empty. One exception is the
NX-Tool-Type, which is initialized according to the default value for this class.

Note:

The above condition results in tools having multiple classifications defined to attach cutter ICOs.
We do not recommend that you use multiple classification with tool assemblies in other scenarios.

Create a multitool assembly

Create a multitool assembly from a tool assembly that includes two or more cutters.

1. Open an existing tool assembly, or if needed, assemble a new tool assembly that contains multiple
cutters.

2. (Optional) Add additional cutters to create the multitool.

Create a multitool assembly
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(1)—Root node
(2)—Classification tab
(3)—Hover text that shows additional cutter
attributes

Tip:

Hover over a cutter classification to display additional cutter attributes. This can help you
identify the cutter you want to select.

a. Select the root node and select More commands →Manage →Add Multitool Cutter .

A message confirms that a cutter is added.

b. Select the Classification tab and verify the classification attributes for the cutters.

• You can confirm the multitool has been created when two classifications are present.
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• When a cutter is added, Resource Manager automatically updates the status and cutter ID
attributes in the Multitool Data group, such as Multitool [MT]: 1 Yes and Cutter ID [CID]:
1.

Create a multitool assembly
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3. (Optional) Adjust the classification if needed, or if the cutter uses a different tool type.

a. On the Classification tab, click Replace Classification  next to the specific cutter.

b. Select the needed tool assembly classification in the Classifications group and click Classify.
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4. Enter or adjust the cutter name for each cutter to define tool-specific attribute values.

Select Properties→Tool Description→Multitool Data→Cutter Name [CNA], make changes, and
save.

5. (Optional) Adjust the tool angles for each cutter.

Select Edit Properties  to change or assign other cutter attributes, such as Index Notch [INN] or
Turret Rotation [TUR], make changes, and save.

Create a multitool assembly
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Index Notch [INN] Turret Rotation [TUR]

6. Set the propagation start point (PSP) for each cutter.

Note:

To propagate the correct classification attributes from the insert components to each cutter at
the tool assembly, a propagation start point must be assigned.

For each cutter, the attributes are propagated from the components to the tool assembly.

a. Select the cutter in the resource structure and select More commands →Manage 
→Propagation Start Point (PSP) .
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b. In the Propagation Start Point dialog box, select a cutter, and click Add.

Note:

For the cutter that is selected, the color of the propagation start point icon changes
from gray  to yellow .

Tip:

Hover over a cutter in the Propagation Start Point dialog box to display additional
cutter attributes.

Create a multitool assembly
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Note:

Depending on the cutter selected in the Propagation Start Point dialog box, you can
click Add, Move, or Remove to take further action.

c. If needed, repeat this for each insert or cutter combination.

Deleting multitool cutters

You can remove a cutter from a multitool.

4. Populating the manufacturing resource library
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The following happens when you delete a multitool cutter classification object (ICO) using Remove this
classification :

• Only the selected cutter ICO is deleted.

• The Multitool [MT] attribute in the Multitool Data group automatically updates the status of the
cutters.

Deleting multitool cutters
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Note:

When you remove the second to last cutter, and only a single classification is assigned, the
Multitool [MT] attribute status updates to Multitool [MT]: 0 No and changes the multitool into
a tool.

• The system removes the related propagation start point (PSP)  from the tool assembly.

4. Populating the manufacturing resource library
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5. Using resources to manufacture parts in
NX CAM
Getting started with creating tools in Resource Manager

Guidelines for creating tools

Use Resource Manager to build NC cutting tools that can be used in NX CAM.

In Active Workspace, you can use Create NX Tool Assembly to create or update an NX tool assembly
part file, or to set the following features for use in NX CAM:

• Identify cutting and non-cutting geometry—Identifies the CUTTING or NON_CUTTING groups in
an NX tool component part file. These are displayed in the machine tool builder and saved in the
assembly part file in NX. For more information, see Identify cutting and non-cutting geometry.

• Generate the spinning geometry—Generates a spinning geometry. The information for this
geometry comes from the CUT and NOCUT information of the tool components that are used in
the tool assembly. For more information, see Generate the spinning geometry.

• Set the tool junctions—Adds the tooltip and tool mount junctions to the assembly part file. For more
information, see Set the tool junctions.

• Write NX part attributes—Adds specified tool mount and tooltip junctions into the part properties in
the assembly part file. Also sets the CAM_TOOL_ATT_X, CAM_TOOL_ATT_Y, and CAM_TOOL_ATT_Z
properties. For more information, see Write NX part attributes.

Identifying cutting and non-cutting geometry

Use to identify cutting and non-cutting geometries, or to assign cutting geometry colors, in a tool
component part file.

NX identifies the tool component cutting and non-cutting geometries, as they are defined in the NX
tool component part file, using one of the following attributes, in the following order: Body, Color, and
Feature Group.

Tip:

It is recommended that you assign only a single activity, such as a cutting activity only, a non-
cutting activity only, or a combination of both, to the attributes in a tool component part file.

Opening the tool component part file in NX, you can review the following tool component attributes to
make sure they are properly prepared for later automatic processes:

Resource Manager on Active Workspace, Teamcenter 2412  5-1
© 2025 Siemens



• Body

When you name a body of the tool component part file CUT, the body component is identified as the
cutting geometry. The remaining components are identified as non-cutting geometry.

• Color

Items with the color Light Gray are identified as the cutting geometry. All other colors are identified as
non-cutting geometry.

Specific colors can be assigned to the cutting geometry in the tool component part file.

• Colors that are defined in the DIN Standard

■ Color for CUT: 80% Gray (Light Gray) ± 1 %

Valid Red/Green/Blue (RGB) values: Red: 204 Green: 204 Blue: 204

Note:

The RGB values must be between 202 and 206.

■ Color for NOCUT: 50% Gray (Medium Gray) ± 1 %

Valid Red/Green/Blue (RGB) values: Red: 125 Green: 125 Blue: 125

Note:

The RGB values must be between 125 and 129.

• Colors in NX

The following are colors used in the default NX color palette and are within the tolerance range
that is defined in the DIN standard:

■ Color for CUT: Light Gray

5. Using resources to manufacture parts in NX CAM
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Valid Red/Green/Blue (RGB) values: Red: 204 Green: 204 Blue: 204

■ Color for NOCUT: Medium Gray

Valid Red/Green/Blue (RGB) values: Red: 125 Green: 125 Blue: 125

Note:

Depending on the color palette being used, some colors may have a different appearance, such
as when NX imports a STEP file, a similar matching color from the NX color palette is used.

• Feature Group

The two feature groups include the following:

Identifying cutting and non-cutting geometry
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• The feature group CUT defines the cutting geometry.

NX identifies a cutting feature group when a space character is added before the word
CUT in the name of the cutting feature group, such as add feature group name-space
character-CUT.

• The remaining components are identified as non-cutting geometry.

Note:

Below is an example of a component, such as a drill, that includes cutting and non-cutting
geometries.

• Validation

Using the Machine Tool Builder you can verify that the cutting and non-cutting geometries are
identified properly for the tool assembly.

Tip:

Selecting the CUTTING and NON_CUTTING attributes highlights the corresponding geometry,
as in the following examples:

5. Using resources to manufacture parts in NX CAM
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Generating spinning geometry

By selecting cutting and non-cutting geometries, you can generate a spinning geometry.

Note:

You must define the cutting and non-cutting geometries in Identify cutting and non-cutting
geometry before generating the spinning geometry.

This function is not available for turning tools.

Using the CUTTING_SPUN and NON_CUTTING_SPUN settings in the Machine Tool Builder section, you
can confirm the cutting and non-cutting spinning geometry of a tool assembly.

Generating spinning geometry
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Selecting the CUTTING_SPUN or NON_CUTTING_SPUN setting highlights the corresponding geometry.

Setting tool junctions

You can use set tool junctions to properly build a tool assembly.

5. Using resources to manufacture parts in NX CAM
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• Logical structure and tool holder

Tool holder components are used by the Auto Assembly functionality to find the
TOOL_MOUNT_JUNCTION.

If the tool holder is not properly defined, the TOOL_MOUNT_JUNCTION cannot be found.

A tool holder structure must include the following:

• Only a single tool holder can be positioned directly below the tool assembly root node. Other drill
or insert components must be positioned below the tool holder.

• Below are three different examples of tool assemblies that have the tool holder properly defined:

■ Drilling tool

■ Milling tool (with inserts)

Setting tool junctions
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■ Turning tool

• Turning: tracking point

The tracking point for turning tools must be defined for the tool tip junction. A tool tip junction
tracking point that is not defined in Teamcenter cannot be evaluated by the Create/Update NX Tool
Assembly Part File functionality.

5. Using resources to manufacture parts in NX CAM
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Note:

The 09 Middle value is not supported by the functionality. Instead, it is used as a theoretical
point that does not make sense for the tool path calculation, because this point cannot be
measured by a presetter.

Terms, such as 04 Lower Right and 02 Upper Left, as defined by the tool’s tool mount junction, are
always used for the X/Y-plane.

The tool tip junction is positioned at the same orientation as the tool mount junction. When the tool is
displayed in NX, the X-axis points to the right and the Y-axis points to the top. The cutting geometry,
left, right, upper, and lower tracking point values must be accurate.

Setting tool junctions
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• Tool mount junction

A tool mount junction is defined in the following ways:

• SIEMENS_TOOL_MOUNT

A tool mount junction is always defined by one coordinate system in the tool’s tool holder. For more
information see Logical structure and tool holder.

When a tool holder includes a SIEMENS_TOOL_MOUNT, this is used as the tool’s tool mount
junction.

• MCS

When a tool holder does not include a SIEMENS_TOOL_MOUNT coordinate system, the tool
holder’s MCS coordinate system is used for the tool mount junction.

In NX CAM, the tool's cutting point is on the negative X-axis. Tool components based on DIN4003,
or tools downloaded from tool vendor’s web pages, have a different orientation and the cutting
point is on the positive Z-axis. The Create/Update NX Tool Assembly Part File functionality
automatically transforms the orientation of the tool component’s coordinate system to the
orientation required in NX CAM.

5. Using resources to manufacture parts in NX CAM
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The tool mount junction cannot be evaluated when a tool holder does not include a
SIEMENS_TOOL_MOUNT or a MCS coordinate system.

The SIEMENS_TOOL_MOUNT coordinate system is not mandatory, and the algorithm also works
with components that only have MCS defined.

• NX tool tip junction

The evaluation of the tool tip junction is different for turning tools and drilling and milling tools.

• Turning tools

The tracking point defines the direction from which the tool tip is searched. For more information
see Turning: tracking point.

The presetter algorithm identifies the first point where the cutting component is touched from the
specified direction. This point is used as the tool tip junction.

Note:

The algorithm always evaluates the tool tip junction based on the 3D geometry.

■ The 03 Lower Left tool tip is magnified and highlighted.

Setting tool junctions
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For turning tools, the tool tip and the tool mount junctions must be assigned the same Z-level.

Note:

The algorithm automatically transforms the tool tip junction to the Z-level of the tool mount
junction.

■ The tool tip is highlighted.

■ The tool tip is not directly on the cutting insert, but is on the same Z-level as the tool mount.

5. Using resources to manufacture parts in NX CAM
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■ The tool mount is highlighted.

Setting tool junctions
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• Drilling and milling tools

When a CIP coordinate system is defined in the tool’s cutter component, it is used as the tool tip
junction.

When a CIP coordinate system is not defined, the algorithm evaluates the tool tip junction based on
the 3D geometry.

Note:

The point that is the furthest in the X-axis direction is used as the tool tip junction.

The CIP coordinate system is not mandatory. The algorithm also works with components
without the CIP coordinate system.

For all tool types, the orientation of the tool tip junction is the same as the tool mount junction.

• Validation

You can validate the position and orientation of the tool tip and tool mount junctions in the NX
Machine Tool Builder by using the Edit Machine Component dialog box.

5. Using resources to manufacture parts in NX CAM

5-14  Resource Manager on Active Workspace, Teamcenter 2412
© 2025 Siemens



Selecting Tool Tip highlights the tool tip junction.

The Tool Mount is highlighted when the tool mount junction is selected.

Writing NX part attributes

You can use the Update NX Tool Assembly Part File menu command to select various part attributes.

When you execute NX Integration functions in Teamcenter, by default the part attributes are not written
into the part file.

Writing NX part attributes
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Note:

The Set tool junctions setting in the Update NX Tool Assembly Part File menu command must
be selected to use this function.

Attributes must be mapped before you synchronize Setup X, Setup Y, and Setup Z attribute values from
NX to Teamcenter.

For more information see Synchronize attribute values from NX to Teamcenter.

Note:

When you reload the resource NX Integration functions in Teamcenter, the updated part file
attribute values are displayed.

The setup values are immediately updated in Teamcenter when the Auto Assembly functionality
is used.

Teamcenter and NX Validation

• Validation in Teamcenter

The Nomin. Setup X and Nomin. Setup Y settings are empty and need to be defined before you
create a new Update NX Tool Assembly Part File in Teamcenter.

5. Using resources to manufacture parts in NX CAM
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• Validation in NX

When you create a new Create/Update NX Tool Assembly Part File, and open the part file in NX, the
CAM_TOOL_ATT_X, CAM_TOOL_ATT_Y, and CAM_TOOL_ATT_Z part attributes are displayed with
the proper values.

Writing NX part attributes
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Note:

The Graphics Builder must be configured before you use the Create/Update NX Tool Assembly
Part File.

Create NX tool assembly

After you create a tool assembly, Active Workspace helps you create or update the NX tool assembly part
file. To do this, you capture CAM-related tool information required by the machine tool builder in NX, so
the tool assembly can be used for tool path simulation.

Note:

Before you create the NX tool assembly, confirm that the graphics builder is correctly installed and
configured.

1. Select the root node of the tool assembly.

2. Click Manage  and choose  Create NX Tool Assembly.

Active Workspace displays the Create NX Tool Assembly dialog box.

5. Using resources to manufacture parts in NX CAM
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3. Select options in the dialog box.

Note:

The first option in the Create NX Tool Assembly dialog box is the focus of this procedure and
is required. You can also select the options Extract Holder Data and Create Setup Sheet.

Option Description

Build tool
assembly part
file and add
components

Builds NX tool assembly part file and adds components to the assembly structure.
These steps are mandatory when you create the NX tool assembly.

This option is selected by default and cannot be unselected.

Identify cutting
and non-
cutting
geometry

The solids in the tool components are added to the CUTTING or NON_CUTTING
groups in NX.

These are displayed in the machine tool builder and saved in the assembly part file
in NX.

Generate
spinning
geometry

The CUTTING_SPUN and NON_CUTTING_SPUN geometry are saved with the tool
assembly for milling and drilling tools. The information for this geometry comes
from the CUT and NOCUT information of the tool components that are used in the
tool assembly.

Create NX tool assembly
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Option Description

This option is not available for turning tools.

Set tool
junctions

The tooltip and tool mount junctions are added to the assembly part file.

Write NX part
attributes

If the tool mount and tooltip junctions are defined in the assembly part file, NX
calculates the setup offsets based on these two junctions, and writes them into the
part properties in the part file, setting the CAM_TOOL_ATT_X, CAM_TOOL_ATT_Y,
and CAM_TOOL_ATT_Z properties.

Additionally, NX system tracking points are imported into the resource for milling
and drilling tool assembly classes.

Extract Holder
Data

Tool holder parameters that are required by NX to calculate collision avoidance are
automatically imported into Teamcenter.

Simplify holder
geometry

Outputs fewer holder segments, using a tolerance and ignoring undercut holder
geometry.

Create Setup
Sheet

Generates setup sheets, which are based on templates that are saved with the class.

4. Click Execute.

An NX assembly part file is created in which all tool components are correctly positioned. The part
file includes the additional tooling information. The part properties are mapped to Teamcenter. For
example:

CAM_TOOL_ATT_X is mapped to the resource library attribute -45002 Nomin. Setup X.

CAM_TOOL_ATT_Y is mapped to the resource library attribute -45003 Nomin. Setup Y.

CAM_TOOL_ATT_Z is mapped to the resource library attribute -45002 Nomin. Setup Z (for
turning tools).

Note:

The NX part attribute to Classification mapping must be configured.

Your tooling administrator must enable the synchronization of Setup X, Setup Y, and Setup
Z attribute values.

Refer to the topic Synchronize attribute values from NX to Teamcenter for a list of more
attributes that get mapped.

5. Using resources to manufacture parts in NX CAM
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Obtain data on NX CAM tool assembly

Three options available when you click the Manage  icon provide information for the associated NX
CAM tooling assembly.

Extract holder data

1. Select any node in the tool assembly.

2. Select More commands →Manage →Extract Holder Data .

If the holder data is successfully extracted, you will see the message: Holder data was
successfully extracted.

The holder data is added as classification data for the holder.

Note:

The available tabs and their order can differ depending on what templates were imported and
where you are in Active Workspace.

Note:

The Extract Holder Data command always creates data for a simplified holder.

Obtain data on NX CAM tool assembly
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Create Setup Sheets

1. Select any node in the tool assembly.

2. Select More commands →Manage →Create Setup Sheet .

The setup sheet is available from the Attachments tab.

Determine ability to retrieve tool assembly in NX CAM

1. Select any node in the tool assembly.

2. Select More commands →Manage →Check NX CAM Tool Retrieve .

You see a message indicating whether the tool can be successfully retrieved in NX CAM:

==== Report for tool 
"nxt_mill_7010_100/A-HSK50/M12 Thread Endmill" ====

---- Results from "Check NX CAM tool retrieve":
Tool can be opened in NX-CAM without any errors.

5. Using resources to manufacture parts in NX CAM
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Adding resource items to NX CAM

Using Active Workspace, you can add a Manufacturing Resource Library (MRL) object to NX CAM.

You add resources and devices to an existing NX CAM assembly by selecting the object in MRL and
dragging it to NX CAM.

You can select one or more MRL resources to add to an NX assembly. The following tool structure or Part
Manufacturing object types that can be selected and dragged to NX include:

• (1) Resource, such as a Fixture or Device

• (2) Tool

• (3) Machine

Adding resource items to NX CAM
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When you select a resource that is not a tool or a machine and drag it to an opened NX assembly, the
Retrieve as Device dialog box is displayed.

Retrieve Device adds the resource as a device to the NX CAM Operation Navigation tree.

Add Component adds the resource as a component to the NX CAM Assembly Navigation tree.

Note:

When two or more devices are added to NX, the Retrieve as Device dialog box is displayed for
each object.

MRL resources can be added to the NX CAM assembly from the following MRL locations:

5. Using resources to manufacture parts in NX CAM
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• Manufacturing Resource Library.

• Folders.

• Global search.

• MRL Saved Searches.

• Home.

• Revisions when opened in Active Workspace.

• Part Manufacturing, for NC Setups when opened in Active Workspace, such as NC Machining
Operation Item Revisions.

Managing graphics for use in NX

Graphics for use in NX

You can create, update, or prepare graphics in Active Workspace for use in NX.

Use Active Workspace to prepare graphics for use in NX

You can use Prepare Graphics for NX  in Active Workspace to prepare an object, using a graphics
template, to generate a 3D model. This object can then be used in NX to create graphics using
classification attribute values. For more information, see Prepare a graphic for use in NX.

Note:

After preparing the graphic in Active Workspace, you must then use NX to complete the graphic
creation process. For more information, see Managing tool assemblies between Manufacturing
Resource Library and NX.

If you use Prepare Graphics for NX, you don't need to use the graphics builder.

Use a template to create or update graphics in NX

You can use  Update Graphics in Active Workspace to create or update the graphics of an object using
its classification properties. For more information, see Understanding how you can create graphics for a
class based on templates or Create graphics for a class based on templates.

Graphics for use in NX
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Prepare a graphic for use in NX

In Active Workspace, you can prepare graphics for use in NX without having to use the graphics builder.

Procedure

1. In Active Workspace, click the Manufacturing Resource Library tile.

2. Select or open a resource in the Manufacturing Resource Library (MRL) workspace.

3. Select the Classification tab.

5. Using resources to manufacture parts in NX CAM
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4. Select More commands →Manage →Prepare Graphics for NX  on the primary toolbar.

5. In the Prepare Graphics for NX dialog box, select the template in Template Part:, and optionally,
select the Open in NX check box to open and complete importing the graphic in NX.

Note:

After preparing the graphic in Active Workspace, you must then use NX to complete the
graphic creation process. For more information, see Managing tool assemblies between
Manufacturing Resource Library and NX.

6. Click Create.

Prepare a graphic for use in NX
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Getting started in the Machining Data Library

Using the Machining Data Library

Use the Machining Data Library to view tool, machine, and material data, and to manage data and
reference tables for specific tools, machines, and materials.

Machining Data Library is a user interface in Classification→Class Navigator→Manufacturing
Resource Library→Machining Data Library that you can use to manage data and reference tables
for specific tools, machines, and materials. You can manage cut methods, the material of the cutting
tools, and the type of material to be cut.

The Machining Data Library includes machining data, and feeds and speeds values, along with
classifications for materials, cut methods, and machining data.

You can store machining information in the Machining Data Library using a combination of tool,
machine, material and cut method data.

Data tables allow you to view feeds and speeds information.

5. Using resources to manufacture parts in NX CAM
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In the (1) Properties panel, use (2) Show Reference Object  to view additional information in the (3)
Show Reference Object panel.

Note:

An attribute with Show Reference Object  indicates the information is from another reference
table and can be edited. For more information, see the topics in Edit data table attributes in
Machining Data Library.

Tip:

Use Show All  in the Properties panel to view all available data and reference attributes.

Data tables that contain feeds and speeds information include the following:

• Feeds & Speeds

• Machining Data

• Tool Machining Data

Using the Machining Data Library
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Depending on the data table selected, the following attribute types are available:

Machine Library Reference All data tables

Cut Method Library
Reference

All data tables

Part Material Library
Reference

All data tables

Tool Material Library
Reference

Feeds & Speeds and Machining Data tables

Tool Library Reference Tool Machining Data table only

Reference tables contain cut methods and material information that are dependent on other reference
tables, and include the following:

• Cut Methods

• Part Materials

• Tool Materials

5. Using resources to manufacture parts in NX CAM
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Depending on the reference table selected, the following attribute types are available:

Material Code Part Materials and Tool Machining Data tables

Material Name Part Materials and Tool Machining Data tables

Material Hardness Part Materials and Tool Machining Data tables

Machine Mode Cut Methods table only

Name of Cutting Method Cut Methods table only

Material Description All reference tables

Note:

Attributes in reference tables can be edited. For more information, see Edit reference table
attributes in Machining Data Library.

Edit data table attributes in Machining Data Library

Edit the Machine Library Reference data table attribute

In the Machine Library Reference data table, you can assign or reassign a classification attribute in
Feeds & Speeds, Machining Data, or Tool Machining Data.

Procedure

1. Navigate to the Machine Library Reference data table in Feeds & Speeds, Machining Data, or
Tool Machining Data.

Classification→Class Navigator→Manufacturing Resource Library→Machining Data Library.

Edit the Machine Library Reference data table attribute
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Note:

Data tables contain tool, machine, and material information located in Feeds & Speeds,
Machining Data, and Tool Machining Data.

2. In the Properties panel, click Edit Properties .

3. Click Assign Reference Object  next to the Machine Library Reference attribute.

The Assign panel is displayed.

5. Using resources to manufacture parts in NX CAM
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Note:

Only the (1) Machine tools classification types are displayed.

4. Select the item classification type on the Assign panel.

a. (Optional) Open the classification types and select the desired item.

b. Select the item on the (2) Results panel.

c. (Optional) Use the (3) Classifications panel to verify the classification of the item.

d. Click (4) Assign.

5. Save the attribute assignment in the Properties panel.

Edit the Cut Method Library Reference data table attribute

In the Cut Method Library Reference data table, you can assign or reassign a classification attribute in
Feeds & Speeds, Machining Data, or Tool Machining Data.

Edit the Cut Method Library Reference data table attribute
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Procedure

1. Navigate to the Cut Method Library Reference data table in Feeds & Speeds, Machining Data, or
Tool Machining Data.

Classification→Class Navigator→Manufacturing Resource Library→Machining Data Library.

Note:

Data tables contain tool, machine, and material information located in Feeds & Speeds,
Machining Data, and Tool Machining Data.

2. In the Properties panel, click Edit Properties .

3. Click Assign Reference Object  next to the Cut Method Library Reference attribute.

The Assign panel is displayed.

5. Using resources to manufacture parts in NX CAM
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Note:

Only the (1) Cut Methods classification types are displayed.

4. Select the item classification type on the Assign panel.

a. Select the item on the (2) Results panel.

b. (Optional) Use the (3) Classifications panel to verify the classification of the item.

c. Click (4) Assign.

5. Save the attribute assignment in the Properties panel.

Edit the Part Material Library Reference data table attribute

In the Part Material Library Reference data table, you can assign or reassign a classification attribute in
Feeds & Speeds, Machining Data, or Tool Machining Data.

Edit the Part Material Library Reference data table attribute
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Procedure

1. Navigate to the Part Material Library Reference data table in Feeds & Speeds, Machining Data,
or Tool Machining Data.

Classification→Class Navigator→Manufacturing Resource Library→Machining Data Library.

Note:

Data tables contain tool, machine, and material information located in Feeds & Speeds,
Machining Data, and Tool Machining Data.

2. In the Properties panel, click Edit Properties .

3. Click Assign Reference Object  next to the Part Material Library Reference attribute.

The Assign panel is displayed.

5. Using resources to manufacture parts in NX CAM
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Note:

Only the (1) Part Materials classification types are displayed.

4. Select the item classification type on the Assign panel.

a. Select the item on the (2) Results panel.

b. Click (3) Assign.

5. Save the attribute assignment in the Properties panel.

Edit the Tool Material Library Reference data table attribute

In the Tool Material Library Reference data table, you can assign or reassign a classification attribute in
Feeds & Speeds, Machining Data, or Tool Machining Data.

Procedure

1. Navigate to the Tool Material Library Reference data table in Feeds & Speeds, Machining Data,
or Tool Machining Data.

Edit the Tool Material Library Reference data table attribute
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Classification→Class Navigator→Manufacturing Resource Library→Machining Data Library.

Note:

Data tables contain tool, machine, and material information located in Feeds & Speeds,
Machining Data, and Tool Machining Data.

2. In the Properties panel, click Edit Properties .

3. Click Assign Reference Object  next to the Tool Material Library Reference attribute.

The Assign panel is displayed.
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Note:

Only the (1) Tool Materials classification types are displayed.

4. Select the item classification type on the Assign panel.

a. Select the item on the (2) Results panel.

b. (Optional) Use the (3) Classifications panel to verify the classification of the item.

c. Click (4) Assign.

5. Save the attribute assignment in the Properties panel.

Edit the Tool Library Reference data table attribute

In the Tool Library Reference data table, you can assign or reassign a classification attribute in Feeds &
Speeds, Machining Data, or Tool Machining Data.

Edit the Tool Library Reference data table attribute
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Procedure

1. Navigate to the Tool Library Reference data table in Feeds & Speeds, Machining Data, or Tool
Machining Data.

Classification→Class Navigator→Manufacturing Resource Library→Machining Data Library.

Note:

Data tables contain tool, machine, and material information located in Feeds & Speeds,
Machining Data, and Tool Machining Data.

2. In the Properties panel, click Edit Properties .

3. Click Assign Reference Object  next to the Tool Library Reference attribute.

The Assign panel is displayed.

5. Using resources to manufacture parts in NX CAM
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Note:

Only the (1) Assemblies classification types are displayed.

4. Select the item classification type on the Assign panel.

a. (Optional) Open the classification types and select the desired item.

b. Select the item on the (2) Results panel.

c. (Optional) Use the (3) Classifications panel to verify the classification of the item.

d. Click (4) Assign.

5. Save the attribute assignment in the Properties panel.

Edit reference table attributes in Machining Data Library

In the reference tables, you can add or edit attribute information in Cut Methods, Part Materials, and
Tool Materials.

Edit reference table attributes in Machining Data Library
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Procedure

1. Navigate to the desired reference table in Cut Methods, Part Materials, or Tool Materials.

Classification→Class Navigator→Manufacturing Resource Library→Machining Data Library.

Note:

Reference tables contain machine, cutting, and material information located in Cut Methods,
Part Materials, and Tool Materials classifications.

2. In the Properties panel, click Edit Properties .

3. Enter the attribute properties and save.

5. Using resources to manufacture parts in NX CAM
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6. Managing tooling information
Applying and inheriting attributes

About attribute inheritance

When creating a classification structure, administrators assign attributes to the different classes in the
hierarchy. These attributes describe each class and all subclasses of that class. Each subclass inherits
all the attributes that are contained in the parent class. Setting up the attributes in this way makes
searching more effective. You can select a top class and search for a tool within that class using a
particular value knowing that that attribute is also contained in all the child classes of the class. In the
figure below, you can see that only Attribute E is assigned to the Twist Drills class. All other attributes
are inherited from the parent classes.

Edit component or assembly attributes

1. Select the root node or component node that you intend to modify.

2. Select the Classification tab.

3. (Optional) To edit the class of the selected resource, click Edit Class .
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Note:

The available tabs and their order can differ depending on what templates were imported and
where you are in Active Workspace.

4. (Optional) To edit the properties of the selected resource, click the Edit Properties 

icon.

6. Managing tooling information
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5. Make any necessary changes to the class or properties.

6. Click Save .

Add resource classification and data files to another resource

You can copy the classification and data files of a selected resource and add them to another resource.

1. On Active Workspace, click the Manufacturing Resource Library (MRL) dashboard workspace.

2. On the MRL dashboard workspace, select a resource that includes the classification and data files to
be added to another resource.

3. Select More commands →Manage →Map Classification Object  on the primary toolbar.

4. In the Map Resource dialog box, in the TARGET CLASSIFICATION group, select the target class
from the Select a target class list, or search for it in the Search field.

5. In the 3D MODEL group, select the Copy Dataset from Source Item check box.

Add resource classification and data files to another resource
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6. Select the resource type from the TYPE list, or search for it in the Search field.

6. Managing tooling information
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7. Enter the PROPERTIES for the resource.

ID MRL automatically assigns a unique ID that you can accept or change. If you
change it, the new ID must be unique.

Revision If this is a revision of an existing resource, type the next consecutive revision
letter.

Name Type the name of the new resource. Use a unique name so it is easier to search
the database using this term.

Description (Optional) Type a description of the new resource.

Add resource classification and data files to another resource
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Propagating component attributes to the resource assembly

About attribute propagation

Attribute propagation allows you to automatically populate the values for an assembly from the
structure, instead of manually re-entering component attribute values in each new assembly.

When you assign a propagation start point (PSP), Teamcenter copies attribute values from individual
components to the root node of the assembly. You can then focus your Classification searches on the
assembly class to find the resource data you need to manufacture a particular process or operation.
Because selected component attributes are stored in the assembly class, you do not need to search the
entire component list to find the attribute information you need.

A PSP defines where in the resource structure the component attribute propagation begins. You can set a
PSP at any level in the resource assembly structure. Teamcenter looks to the assigned PSP component for
the attribute value to propagate. If the attribute is not found in that component, the application moves
up the structure hierarchy toward the root node one component at a time, until it finds the attribute.
After the attribute is found, its value is added to the root node and saved with the assembly.

A resource component assigned as a PSP is identified with the PSP icon . When the component is
selected in Classifications, the color of the PSP icon changes to yellow  to indicate the attribute values
for that item are being used.

Note:

The associated attributes for the Drill, identified as the PSP, will propagate to the Twist Drill tool
assembly.

6. Managing tooling information
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A tool assembly can only have a single PSP assigned to the tool assembly structure. A multitool assembly
can have one or more PSPs assigned to the tool assembly structure. A Root node is selected (1).

•  Icon indicates that a PSP with a single classification is assigned to the tool assembly (2).

Used with a tool or multitool assembly.

•  Icon indicates that a PSP with multiple classifications is assigned to the multitool assembly, but the
classification is not selected in the Classifications panel (3).

Used with a multitool assembly.

•  Icon indicates that a PSP with multiple classifications is assigned to the multitool assembly, and the
classification is selected in the Classifications panel (4).

Used with a multitool assembly.

About attribute propagation
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• For more information on assigning a PSP to a tool assembly, see Add a propagation start point to a
tool.

• For more information on assigning one or more PSPs to a multitool assembly, see Add an initial
propagation start point to a multitool or Add additional propagation start points to a multitool.

Using the PSP attribute values, Teamcenter identifies and populates the attribute values for the tool
assembly. Propagated attributes used for the resource assembly structure are identified with an icon 
next to the attribute in the Properties view.

6. Managing tooling information
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Note:

The MRMPropagationAlternateAttributes preference allows you to specify alternate attributes
for propagation.

In some cases, the highest component in the structure contains the attribute that should be propagated
to other components in the structure. You can use a particular preference to identify specific attributes
that should propagate downward rather than upward. For more information see About reverse
attribute propagation.

Understanding propagated attributes

The following table demonstrates attribute propagation. In this example, the user, while in Classification
Admin, specifies the Test Assembly 1 class as an assembly class. Furthermore, in the assembly class,
Attributes 1–5 have the Propagated Property option selected.

Note:

For specific cases that include attributes at the upper levels of a structure that need to be
propagated downward, see About reverse attribute propagation.

Understanding propagated attributes
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When Teamcenter propagates attributes, it begins at the propagation start point (PSP), and then
travels upward through the parent levels looking for attributes to propagate. In the example, the first
component it looks at is Component 4. The component contains Attribute 4, which is a propagated
attribute, so Teamcenter propagates Attribute 4 to the resource assembly, Test Assembly 1. Teamcenter
then looks at the parent of Component 4, which is Component 3, and finds two attributes to
propagate. It then looks at the parent of Component 3, which is Component 1, and finds Attribute
2 to propagate. Component 1 also contains Attribute 1, but this value has already been populated
by Component 3. When Teamcenter is finished with propagating attributes, the top-level resource
assembly, Test Assembly 1, shows the following attribute values:

Attribute Propagated from

Attribute 1 Component 3

Attribute 2 Component 1

Attribute 3 Component 3

Attribute 4 Component 4

Attribute 5 contains no value. Although there is a value assigned to this attribute in Component
2, Component 2 does not lie within the propagation path as it is not a parent or grandparent of
Component 4, the PSP. Similarly, Components 6 and 7 do not lie within the propagation path.

A gray PSP indicates that this PSP is defined in the context of a subassembly. It is not taken into
consideration in the current tool assembly. Subassemblies are highlighted with a colored background in
Resource Manager.

Add a propagation start point to a tool

You can add a propagation start point to a tool to automatically populate the values for an assembly.

6. Managing tooling information
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Procedure

1. Select the component in the hierarchy to which you are adding a propagation start point.

2. Select More commands →Manage →Propagation Start Point (PSP)  on the primary
toolbar.

A message box confirms the propagation start point is added.

A propagation start point icon  is added to the selected component.

Add a propagation start point to a tool
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Add an initial propagation start point to a multitool

Add a propagation start point to a multitool to automatically populate the values for an assembly.

Procedure

1. Select the component in the hierarchy to which you are adding a propagation start point.

6. Managing tooling information
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2. Select More commands →Manage →Propagation Start Point (PSP)  on the primary
toolbar.

3. Select a classification in the Propagation Start Point (PSP) dialog box and click Add.

Add an initial propagation start point to a multitool
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A message box confirms the propagation start point is added.

A propagation start point icon  is added to the selected component.

Add additional propagation start points to a multitool

Add multiple propagation start points to a multitool to automatically populate the values for an
assembly.

Procedure

1. Select the component in the hierarchy to which you are adding a propagation start point.

6. Managing tooling information
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2. Select More commands →Manage →Propagation Start Point (PSP)  on the primary
toolbar.

3. Select a classification in the Propagation Start Point (PSP) dialog box and click Add.

Add additional propagation start points to a multitool
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A message box confirms the propagation start point is added.

A multiple propagation start points icon  is added to the selected component.

Remove a propagation start point

1. Select the component in the hierarchy from which you are removing a propagation start point.

2. Click Propagation Start Point  in the One Click Commands area.

Resource Manager prompts you to confirm the removal of the Propagation Start Point.

6. Managing tooling information
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3. Select Remove.

The Propagation Start Point indicator is removed from the selected component.

About reverse attribute propagation

By default, assembly attributes are propagated bottom-up. Starting from the propagation start point
(PSP) , the components are checked up to the root component to find specific attribute values. The first
component closest to the PSP provides the value applied to each component above it in the structure.
Reverse propagation works in a similar way, but the attributes are propagated downward from the first
component after the PSP.

You can control which attributes are propagated downward by adding the attribute title to the
preference MRMPropagationReverseAttributes. All attributes listed in the preference propagate in
the opposite order: For these attributes, the system checks from the component closest to the root
component down the structure to the component with the PSP. In this case, the value of the component
closest to the root are propagated downward.

About reverse attribute propagation
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7. Managing manufacturing data with Part
Manufacturing
Getting started with Part Manufacturing

Part Manufacturing is a user interface that allows you to create and manage data for NX applications.

Using Part Manufacturing, you can access an overview of resources and activity data that is generated
by the NC programmer, such as NC programs, shop floor documentation, and NC Machining operations,
to manage a CAM setup.

• (1) Resources—Displays the machining operation tools, fixtures, and machines that are assigned to
the Part Manufacturing Operation, such as NC Machining.
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• (2) Activities—Displays the activity groups, individual activities, tasks, and duration of the assigned
tools for each machining program. The NC Program file is also displayed.

You can also download activity files from the Activities panel.

Note:

You can edit certain values in the Activities panel. Double-click a text or value in an activity row.

• (3) Attachments—Displays the attachments available for the resource or activity that you select.

• (4) Preview—Displays a content preview of the file that is selected on the Attachments panel, such
as tool setup sheets or work instructions.

When the Manufacturing profile is selected in the Workspace menu, you can use one of the following
tiles on the Active Workspace home page to quickly create, initiate, or design manufacturing objects for
use in Part Manufacturing. Unless noted, you do not need to select the item type, which is preselected
in the TYPE group list.

CREATE CAM OPERATION—Use to create an NC Machining operation to
manage a CAM setup, or to send to NX CAM to be filled out in detail.

CREATE AM OPERATION—Use to initiate a job task for Additive
Manufacturing to plan a job file for 3D printing.

CREATE INSP OPERATION—Use to create an inspection operation that
can be used in CMM or NX Metrology.

CREATE CAD PART—Use to design a new CAD part that can be used to
manually build an in-stage model.

7. Managing manufacturing data with Part Manufacturing
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Note:

You must select the item type in the TYPE group list.

CREATE RESOURCE—Use to quickly initiate a new resource item.

After you create an operation, you can locate it in the Home Folder. To access the new operation in Part
Manufacturing, click the  Open icon and then select the Part Manufacturing tab.

Add or remove a resource

Add or remove a resource from the Resource panel on the Part Manufacturing tab.

Add a resource

1. Select the Part Manufacturing tab.

Add or remove a resource
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2. Click  Add Resource on the results panel toolbar.

The Add Resource dialog box opens.

3. In the Add Resource dialog box, select the resource type from the TYPE list and enter the
properties.

ID MRL automatically assigns a unique ID that you can accept or change. If you
change it, the new ID must be unique.

Revision If this is a revision of an existing resource, type the next consecutive revision
letter.

Name Type the name of the new resource. Use a unique name so it is easier to search
the database using this term.

Description (Optional) Type a description of the new resource.

4. Click Add.

7. Managing manufacturing data with Part Manufacturing
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A message box appears confirming the resource is added.

Remove a resource

1. Select the Part Manufacturing tab.

2. On the Resources panel, in the Element column, select a resource.

3. Click  Remove Resource on the results panel toolbar.

4. In the confirmation message box, click Remove.

Note:

The resource is removed from the resource structure only, not from the database.

Add or delete an attachment in an operation or revision

In Part Manufacturing, add or delete an attachment in an operation or revision, such as NC Machining
Revision.

Procedure

1. To add an attachment in an operation or revision, select Attachments on the Part Manufacturing
work area toolbar.

2. Click  Add Attachment.

Add or delete an attachment in an operation or revision
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3. In the Add dialog box, use Select File in Upload File to select an item to attach.

4. Enter the properties for the attachment.

Name Type the name of the new attachment. Use a unique name so it is easier to
search the database using this term.

Description (Optional) Type a description of the new resource attachment.

Type Select the file type for the new attachment.

Relation (Optional) Select the file relation type for the new attachment.

5. Click Add.

A message confirms the attachment is added.

6. To delete an attachment from an operation or revision, select Attachments on the Part
Manufacturing work area toolbar.

7. On the Files panel, select an attachment from the Object column.

8. Click  Delete Attachment.

7. Managing manufacturing data with Part Manufacturing
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A message appears to confirm you want to delete the attachment.

9. Click Delete.

Add or delete an attachment in a resource or activity

In Part Manufacturing, add or delete an attachment in a resource or activity item.

Procedure

1. To add an attachment in a resource or activity, select Attachments on the Part Manufacturing
work area toolbar.

2. Select a resource Element or an activity Object.

3. Click  Add Attachment.

4. In the Add dialog box, use Select File in Upload File to select an attachment.

5. Enter the properties for the attachment.

Name Type the name of the new attachment. Use a unique name so it is easier to
search the database using this term.

Description (Optional) Type a description of the new resource attachment.

Add or delete an attachment in a resource or activity
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Type Select the file type for the new attachment.

Relation (Optional) Select the file relation type for the new attachment.

6. Click Add.

A message confirms the attachment is added.

7. To delete an attachment from a resource or activity, select Attachments on the Part
Manufacturing work area toolbar.

8. Select an item on the Resources or activities panel.

9. On the Files panel, select an attachment from the Object column.

10. Click  Delete Attachment.

A message appears to confirm you want to delete the attachment.

11. Click Delete.

Add a parent activity

Add a new parent activity to the Activities panel, on the Part Manufacturing tab.

1. Select the Part Manufacturing tab.

2. Click  Add Activity on the results panel toolbar.

The Add Activity dialog box opens.

7. Managing manufacturing data with Part Manufacturing
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3. In the Add Activity dialog box, select the activity type from the TYPE list and enter the properties.

Name Type the name of the new activity. It is recommended that you make the name
unique so users can easily search the database using this term.

Description (Optional) Type a description of the new activity.

4. Click Add.

A message box appears confirming the activity is created.

Add a child activity

Add a new activity to an existing parent or child activity in the Activities panel, on the Part
Manufacturing tab.

1. Select the Part Manufacturing tab.

2. Select an activity in the Object column on the Activities panel.

3. Click  Add Activity on the results panel toolbar.

Add a child activity
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The Add Activity dialog box opens.

4. In the Add Activity dialog box, select the activity type from the TYPE list and enter the properties.

Name Type the name of the new activity. It is recommended that you make the name
unique so users can easily search the database using this term.

Description (Optional) Type a description of the new activity.

5. Click Add.

A message box appears confirming the activity is created.

Delete an activity

Delete an activity from the Activities panel on the Part Manufacturing tab.

1. Select the Part Manufacturing tab.

2. On the Activities panel, in the Object column, select a parent or child activity.

Note:

When you delete a parent activity, the child activities in the activity are also deleted.

3. Select More commands →Edit →Delete  on the primary toolbar.

7. Managing manufacturing data with Part Manufacturing
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4. In the confirmation message box, click Delete.

The activity is removed from the Activities panel structure and from the database.

Download files from activities

Download a single file from an activity

Download a single activity's file from the Activities panel in Part Manufacturing.

Procedure

1. Select the Part Manufacturing tab.

2. In the Activities panel, expand the activities group that contains the activity file you want to
download.

3. Select the activity that contains the file to download.

4. Select More commands →Share →Download All Files  on the primary toolbar.

A message is displayed confirming the number of files downloaded.

5. Click OK.

Download all files from an activity

Download multiple activity's files from the Activities panel in Part Manufacturing.

Download a single file from an activity
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Procedure

1. Select the Part Manufacturing tab.

2. In the Activities panel, expand the activities group that contains the activity files you want to
download.

3. Select the activity that contains the files to download.

Hold Ctrl and use the left mouse button to select multiple activities.

4. Select More commands →Share →Download All Files  on the primary toolbar.

A message is displayed confirming the number of files downloaded.

5. Click OK.

Download all files from an activity group

Download all files in the activity group from the Activities panel in Part Manufacturing.

Procedure

1. Select the Part Manufacturing tab.

2. In the Activities panel, select the activities group.

3. Select More commands →Share →Download All Files  on the primary toolbar.

7. Managing manufacturing data with Part Manufacturing
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A message is displayed confirming the number of files downloaded.

All files in the activities group are downloaded.

4. Click OK.

Download all files from an activity group
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