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1. Getting started with Multi-Structure
Manager
Getting started with Multi-Structure Manager

Multi-Structure Manager allows you to manage any of the structure types compatible with Teamcenter,
including product structures and manufacturing process structures.

In the Multi-Structure Manager application, you can:

• Collect a subset of data for comparison and analysis purposes, such as for a design study. You
can copy components (for example, piece parts or assemblies) from a base structure into a design
study, called a composition, where you can add new parts and experiment without changing the
original base structure. You can analyze any changes before committing them. Links are maintained
from components placed in the design study back to the original base structure. Any changes in
configuration (revision or variant rule) in the base structure are reflected in the design study. Because
a composition can collect components from different structures, you can use these to design interface
parts such as a mounting bracket that attaches one product to another.

• Capture the state of any structure or part of a structure for subsequent retrieval and viewing. This
captured data does not represent the final released state of the structure, so it is referred to as an
intermediate data capture (IDC). The configuration rules are saved with the structure allowing its
exact state at the time of capture to be reproduced each time it is retrieved. Creating an IDC does not
affect any subsequent changes to the structure or its release by a Workflow process. The captured data
is independent of subsequent changes made to the structure or part.

• Collect a subset of data to send to an external application, for example, Tecnomatix, NX, or third-
party applications. Because Multi-Structure Manager allows the configuration (revision and variant)
to be stored with the structure, this configuration is passed along with the structure to the external
application.

• Open multiple BOM structures, configure these as you would in Structure Manager, perform an
accountability check and then save all of this to a collaboration context.

Your Teamcenter administrator may customize the functionality of your particular collaboration context.

Before you begin

Prerequisites You do not need any special permissions to use the Multi-Structure Manager
application.

Enable Multi-
Structure Manager

Multi-Structure Manager does not need to be enabled before you use it.

If you have trouble accessing Multi-Structure Manager, see your system
administrator; it may be a licensing issue.
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Note:

You can log on to Teamcenter only once. If you try to log on to more than
one workstation at a time, you see an error message.

Configure Multi-
Structure Manager

Multi-Structure Manager does not need to be configured.

Start Multi-Structure
Manager Click Multi-Structure Manager  in the navigation pane. You can also

launch the application by opening an existing collaboration context.

Multi-Structure Manager interface

Multi-Structure Manager interface overview

1 Collaboration pane Shows all open structures in the application.

2 Structure tabs Shows each structure that is currently open. The tab can
contain a product, process, plant, or structure context. You
can open multiple structures at once, including multiple
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products, processes or plants. Each of these structures is
displayed on a different tab.

3 Structure pane Displays all the information pertaining to a structure. You
can split the structure pane into two panes. Each of these
contains a structure pane and data tabs pertaining to the
selected structure. You can align these panes both vertically
and horizontally.

4 Data pane Displays information about the attributes and relations
of the object selected in the structure pane. The tabs
displayed depend on the structure tab selected and the
type of object selected in the structure.

5 Search area Allows you to search for any structure in the database.

Multi-Structure Manager menus

Menu command Purpose

File→New→Collaboration
Context

Allows you to create a new collaboration context.

File→New→Structure Context Allows you to create a new structure context, which may
optionally be associated with a collaboration context. The
types of structure that you can create are defined by your
administrator with the Business Modeler IDE application.

File→New→Configuration
Context

Allows you to create a new configuration context, which
determines the configuration of the structure to which it is
attached.

File→New→Occurrence Group Allows you to create a new occurrence group and add it to the
current structure context or to the currently selected occurrence
group. This menu command is available only if you select a
structure context in the collaboration pane or a structure pane is
open with no object currently selected.

File→New→From Template→Item
From Template

Creates a new item from an existing one.

File→New→Item Inserts an item into the currently selected structure.

File→New→Part Creates a new part.

File→New→Design Creates a new design, that is, a CAD representation of a part or
assembly.

File→New→Snapshot Creates a snapshot of the selected structure.

Multi-Structure Manager menus
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Menu command Purpose

File→New→Folder Allows you to attach a folder to an object in the structure
context. This menu command is available only in the
collaboration and attachments panes.

File→New→Dataset Allows you to attach a dataset to an object in the structure
context. This menu command is available only in the
collaboration and attachments panes.

File→New→Form Allows you to attach a form to an object in the structure context.
This menu command is available only in the collaboration and
attachments panes.

File→New→BOM View Revision Allows you to attach a BOM view revision (BVR) to an object in
the structure context. This menu command is available only in
the collaboration and attachments panes.

File→New→Item Element Creates objects to represent design or manufacturing features
that are not defined as part of the physical structure in the BOM.
Features are implemented as item elements, sometimes called
general design elements (GDEs).

For information about specific item element feature types, see
the appropriate application documentation.

File→New→Non-Revisable Creates a new nonrevisable Tc Link connection (for example,
connection or datum point connection).

File→New→Revisable Creates a new revisable Tc Link connection (for example,
connection or datum point connection).

File→New→Workflow Process Creates a new workflow process with attachments, an
associated process template and the ability to assign tasks to
specific users.

File→New→URL Allows you to attach a URL to an object in the structure context.
This menu command is available only in the collaboration and
attachments panes.

File→New→Envelope Allows you to attach an envelope to an object in the
structure context. This menu command is available only in the
collaboration and attachments panes.

File→Open Opens the selected structure.

File→Open With Selects with which tool an object is opened.

File→Save Saves changes made in Multi-Structure Manager. For example,
you must explicitly save any modifications to BOM view
revisions.
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Menu command Purpose

File→Save As→Save as New
Collaboration Context

Saves the current open objects as a new collaboration context.

File→Save As→Item(Revision) Saves a selected item as a new item revision.

File→Save As→BOM View
Revision

Saves a selected BOM view as a new BOM view.

File→Save As→Replace Assembly
in Context

Creates a new MBOM substructure (kit) from an existing one,
while preserving the alignment of items within the kit.

File→Revise Revises the selected item.

File→Close Closes the currently displayed structure.

File→Print Views, prints, or saves information about the currently selected
structure.

File→Print... Views, prints or saves properties, textual information, graphics
or information associated with the selected item.

File→Unload All Removes all structures from the collaboration pane.

File→Exit Ends your Multi-Structure Manager session.

Edit→Cut Marks the selected lines for removal and copy their contents to
the clipboard. Cut lines are only removed once pasted elsewhere
in the product structure.

Edit→Copy Copies the selected lines to the clipboard.

Edit→Paste Pastes item revisions from the clipboard as components of the
selected lines.

Edit→Delete Deletes a single item or an item and all its children. Optionally,
you can also remove any associated referenced objects. This
command permanently removes any selected item from the
structure and the database.

Edit→Paste Special Pastes components on the clipboard to the selected assembly
(line).

Edit→Paste Substitute Pastes item revisions from the clipboard as substitutes for the
selected (assembly) lines.

Edit→Replace Replaces the selected line with the item revision or item element
on the clipboard.

Edit→Replace... Allows you to browse for an item revision to replace the selected
line.

Multi-Structure Manager menus
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Menu command Purpose

Edit→Split Occurrence Divides an assembly or part represented by the selected line into
two lines, and splits the quantity between them.

Edit→Insert Level Creates an item and inserts it in the current structure as a new
level below the selected line. The number of relative occurrences
of the children is preserved.

Edit→Remove Removes the selected lines from the product structure. Any child
branches of the removed line can be removed or moved up to
the next level. Data including occurrences notes and absolute
occurrences attached to the removed line are lost.

Edit→Purge Permanently removes old versions of a dataset from the
database. You can select whether to purge all old versions or
specific versions of a dataset.

Edit→Latest Displays the latest versions of all datasets in a selected folder.
The Latest menu command updates all version-0 datasets to
reference the latest saved version in the database. This feature
is useful in a network environment when multiple users are
working on the same dataset.

Edit→Change Ownership Changes ownership of one or more objects. Using the Explore
Selected Components option, you can select component
objects and attachments, such as datasets, forms, and part files
for ownership change.

Edit→Toggle In Context Mode Enables or disable editing in context mode, allowing creation of
absolute occurrences for the selected assembly.

Edit→Toggle In Allocation
Context Mode

Allows you to assign directional relationships between specific
instances of an item revision in one product structure and one or
more item revisions in a related structure.

Edit→Variant Condition Creates a variant condition on the selected line.

Edit→Toggle Precise/Imprecise Changes the precision of the selected assembly (line).

Edit→User Setting Changes your group, role or volume assignments, also your
application logging and journaling options.

Edit→Options Changes user interface settings that affect all applications.

View→Refresh Window Synchronizes the currently displayed product structure with the
database. The displayed structure refreshes with changes that
have been made in other sessions and saved since you loaded
the currently displayed product structure.

View→Expand Expands the substructure immediately below the selected lines.

View→Expand Below Expands the complete substructure below the selected lines.
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Menu command Purpose

View→Expand Below... Expands the substructure below the selected lines to a user-
selected level. You can also collapse an expanded substructure
when you choose this option (hide certain child lines).

View→Expand to Type Expands the substructure below the selected lines to a user-
selected type.

For more information, see Expand and collapse a structure.

View→Collapse Below Collapses the complete substructure below the selected lines
(hide all child lines).

View→Show/Hide Occurrence
Groups

Shows or hides any occurrence groups in the structure.

View→Pack Packs the selected lines so that all lines with the same item
revision and find number are displayed as a single line. The
actual quantity of lines appended to the node.

View→Pack All Unpacks the selected packed lines so that they are displayed as
separate lines, one for each occurrence.

View→Unpack Unpacks the selected packed lines so that they are displayed as
separate lines, one for each occurrence.

View→Unpack All Unpacks all lines in the displayed structure.

View→Notes Allows you to view, and edit if permitted, all occurrence notes
for the selected line.

View→Access Views, changes, and/or applies access permissions for a selected
object.

View→Named References Views, opens, imports, or exports the named references of a
selected dataset. You can use the function buttons in the dialog
box to cut or copy a selected reference to the clipboard and
paste references from the clipboard.

View→Properties Allows you to view all properties of the selected line. You can
edit those properties to which you have permission.

View→Organization Displays your Teamcenter organizational structure including the
groups in your enterprise, the roles in each group, and the users
assigned to each role. Organization Management Using Groups,
Roles, and Users explains how a user with dba privileges creates
and manages the information displayed in the organization
chart.

View→Show Unconfigured
Variants

Shows or hides unconfigured variant components.

Multi-Structure Manager menus
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Menu command Purpose

View→Show Unconfigured
Assigned Occurrences

Shows assigned objects that were configured out by the variant
rules of the structures from which the objects were assigned.

You can only use this command with composition structures.

Note:

This command does not automatically refresh. Any
changes to the assigned objects are not reflected in the
structure until you execute this command again.

View→Show Unconfigured
Changes

Shows unconfigured changes. If you hide unconfigured changes,
only those changes configured by the current revision rule are
visible.

View→Show Unconfigured By
Occurrence Effectivity

Shows or hides components that are not configured when using
occurrence effectivity.

View→Show Data Panel Shows or hides the data pane. This menu command is available
if the collaboration pane, structure pane, or data pane is open.

View→Show Collaboration Panel Shows or hides the collaboration pane. This menu command is
always active.

View→Show Second Structure
Panel

Shows or hides the second structure pane. This menu command
is always active.

View→Apply Occurrence Type
Filter

Adjusts the display to show only the objects that you select
using the Select Occurrence Type Filters command. This results
in a more compact and ordered view of very large structures.

View→Select Occurrence Type
Filter

Chooses which objects are visible in the structure. Select the
object types that you want to see.

View→Show GCS Connection
Points

Shows or hides all connection points defined for GCSs (guided
component searches). GCSs are defined with the Classification
Admin application.

Tools→Check-In/Out→ Check-Out Checks a selected component out of the database.

Tools→Check-In/Out→ Check-In Checks a selected component into the database.

Tools→Check-In/Out→ Cancel
Check-Out

Reverts checkout.

Tools→Check-In/Out→ Transfer
Check-Out

Transfers a selected, checked-out component to another user.

Tools→Check-In/Out→
Notification List

Views or edits the list of users who are informed if the selected
component is checked in or checked out.
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Menu command Purpose

Tools→Check-In/Out→ Check-Out
History

Views the history of check out actions for the selected
component.

Tools→ID Display Rule→View/Set
Current

Views the ID display rule currently applied to the selected
structure or set a different ID display rule.

Tools→ID Display Rule→Modify
Current

Modifies the ID display rule currently applied to the selected
structure.

Tools→ID Display Rule→Create/
Edit

Creates a new ID display rule or modify an existing ID rule.

Tools→Project→Assign Assigns the selected structure to a predefined project.

Tools→Project→Remove Removes the selected structure from a project to which it is
assigned.

Tools→Revision Rule→View/Set
Current

Views or sets the revision rule for the currently displayed
structure.

Tools→Revision Rule→Set Date/
Unit/End Item...

Sets the date, unit number, or end item to configure the
structure, if the current rule allows.

Tools→Effectivity→Revision
Effectivity

Views, edits, creates, or copies effectivity data for the item
revision of the selected line. You must have the appropriate
permissions to create or edit effectivity data.

Tools→Revision Rule→Set
Override folder...

Sets an override folder to override item revisions that would
otherwise be selected by other criteria.

Tools→Revision Rule→Modify
Current...

Modifies the current revision rule and apply the modified rule to
the current structure. You can save the change if you have write
access to the original rule.

Tools→Revision Rule→Create/
Edit...

Creates or edits a revision rule.

Tools→Effectivity→ Revision
Effectivity

Views, edits, creates, or copies effectivity data for the item
revision of the selected line. You must have the appropriate
permissions to create or edit effectivity data.

Tools→Effectivity→ Effectivity
Mapping

Views, edits, creates, or copies effectivity mapping for an end
item. Effectivity mappings are needed if you implement nested
effectivity.

Tools→Effectivity→ Occurrence
Effectivity

Views, edits, creates, or copies occurrence date effectivity data
for the occurrence of the selected line, or for multiple lines.
You must have the appropriate permissions to create or edit
effectivity data.
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Menu command Purpose

Tools→Variants→Configure
Variants

Configures or edit a variant structure for the selected top-level
module.

Tools→Variants→Only Configure
Root

When on, displays options only for the top-level module,
regardless of the line selected. Set to off to configure the
structure for a lower level module.

Tools→Variants→Search Searches for an existing variant item.

Tools→Variants→Count Modules Counts the modules defined for the selected variant structure.

Tools→Variants→Unlink Variant
Item

Unlinks a variant item from the generic module item to make
changes.

Tools→Variants→Update Variant
Items

If you make structural changes to a generic item and create a
new item revision, Teamcenter does not automatically propagate
such changes to each associated variant item. Choose this
command to make such changes manually.

Tools→Accountability
Check→Check

Allows you to compare two structures and view the differences
(that is, how one structure uses objects compared to the other
structure). This submenu is active when two structure panes are
visible.

Tools→Accountability
Check→Clear Accountability
Check Display

Removes color highlights created by the accountability check.

Tools→Accountability
Check→Propagation Settings

Allows you to modify the settings governing the propagation
of properties or relations in a partial match after running an
accountability check.

Tools→Accountability
Check→Propagate

Passes along changes from the source structure to the target
structure in a partial match.

Tools→Accountability
Check→Select Unused

Runs the accountability check and shows all occurrences in the
source pane that do not match an occurrence in the target pane
in an occurrence group.

Tools→Accountability
Check→Select Completely Used

Runs the accountability check and shows all occurrences in the
source pane that match more than one occurrence in the target
pane in an occurrence group.

Tools→Accountability
Check→Select Over-used

Runs the accountability check and shows all occurrences in
the source pane that match a corresponding occurrence in the
target pane in an occurrence group.

Tools→Accountability
Check→Partial Compare Results

Displays all properties that were included in the partial compare
criteria that you set in the Partial Match Options pane of the
accountability check.
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Menu command Purpose

Tools→Accountability
Check→Find in Other Structure

Finds the corresponding item in the other panel and selects it.
This also expands the tree automatically.

Tools→Multi-Site Collaboration Controls the data shared with participating sites in a distributed
network. Multi-Site Collaboration allows you to publish and
unpublish objects.

For more information, see Multi-Site Collaboration.

Tools→Import→Objects Imports objects into the database using various import formats.

Tools→Import→From PLMXML Imports objects into the database using the PLM XML format.

For more information, see Systems Engineering ─ Deployment
and Rich Client Usage

Tools→Import→Remote Imports a structure from a remote site in a Multi-Site
Collaboration environment. Search for the remote object in My
Teamcenter.

Tools→Export→Objects Exports objects using a Teamcenter or STEP format. You can also
use this command to export an application interface object.

Tools→Export→To PLMXML Exports the selected structure and its attachments in PLM XML
format to a selected export directory. You must choose the
appropriate transfer mode for the destination system.

Tools→Export→Objects to Excel Exports the selected structure lines to an Excel spreadsheet.

For more information, see Systems Engineering ─ Deployment
and Rich Client Usage.

Tools→Export→Objects to Word Exports the selected structure lines to a Microsoft Word
document.

For more information, see Systems Engineering ─ Deployment
and Rich Client Usage.

Tools→Send Data To Sends selected data to an external application using an
application interface object. Your Teamcenter administrator uses
the Business Modeler IDE application to create new application
interface types associated with a specific application. Each of
these types are available in the Send Data To dialog box.

Tools→Send Additional Data To Sends additional data to a running session of the application
launched using the Send Data To menu command.

Tools→Structure Search Searches a structure using various properties of the structure's
lines. The search is not limited to the loaded lines of the
structure and can search an entire structure without loading it. It
then expands the structure to the found lines.
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Menu command Purpose

Tools→Manage Global Alternates Allows you to define global alternates and a preferred alternate
for the selected component.

Tools→Repair Broken Links Identifies broken links and searches for the possible occurrence
that was originally defined, for example, as a consumed part.

For more information, see About broken links.

Tools→Baseline Copies work in progress (WIP) item revisions. During the
development of a product design, you may need to share such
copies of your working design with other users at the same
or different sites. You can also save your design for future
reference.

For more information, see About baselining or preliminary
structures.

Tools→Address Lists Displays lists of users who participate in workflow processes.

Tools→Connect Connects two selected lines with a revisable or nonrevisable
connection.

Tools→Disconnect Disconnects the currently selected line with a revisable or
nonrevisable connection to another line.

Tools→Save Configuration Allows you to save the current configuration of the structure
pane, overwriting the structure context’s existing configuration.
This menu command is available only if a structure context is
opened.

Tools→Save as New Configuration
Context

Saves the current configuration of the structure pane to a
new configuration context and adds it to the structure context.
This menu command is available only if a structure context is
opened.

Tools→Set View Configuration... Sets the structure pane’s configuration to the previously saved
configuration context. This menu command is available only if a
structure context is opened.

Tools→Restore Configuration Resets a structure pane’s configuration back to its previously
saved configuration context. This menu command is available
only if a structure context is opened.

Tools→Assign When two structure panes are visible, this menu command
allows you to select assemblies or components in one structure
and assign them to an assembly in the other structure as its
children. Once this is done, the absolute occurrences of those
assigned children are shared between the two structures. You
can search for lines that share absolute occurrences between
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Menu command Purpose

different structures from any instance of the assembly or
component.

Note:

You can also right-click on a selected line in the BOM and
choose the Assign menu command to do this; the new
line does not have an occurrence type. Alternatively, if you
choose the Assign As menu command from the shortcut
menu, you can choose an occurrence type for the new
line that is created by the assignment from an additional
shortcut menu.

Tools→Intermediate Data Capture Saves the current structure configuration to a PLM XML format
that you can browse and compare against existing structures.

For information about creating intermediate data captures, see
About intermediate data captures.

Tools→Generate Portfolio Creates a portfolio to hold manufacturing documentation.

For more information, see Using Teamcenter Publish.

Tools→Validate Occurrences Allows you to validate that a selected line and (optionally) any
child lines meet the business rules defined by your administrator
for structure edits.

For information, see Performing on-demand validation.

Tools→Link Structures Assigns occurrences in the MBOM to those in the EBOM based
on absolute occurrence ID properties.

Tools→Structure
Alignment→Completeness
Check→Verify Part Structure

Highlights all part occurrences that are aligned with positioned
designs in green. Part occurrences that do not have links to
positioned designs are highlighted in red.

Tools→Structure
Alignment→Completeness
Check→Clear Display

Removes highlighting after performing a completeness check.

Tools→Structure
Alignment→Publish Data

Creates a snapshot of transformation and shape information on
a source design occurrence and publish it to the destination part
occurrence.

Tools→Structure
Alignment→Create PublishLink

Aligns part and design by creating a publish link between the
selected occurrences

Tools→Structure
Alignment→Delete PublishLink
for source

Removes the link between occurrences aligned between part
and design.
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Menu command Purpose

Tools→Structure Alignment→Add
Target to PublishLink

Adds a new target part occurrence to a publish link.

Tools→Structure
Alignment→Remove Target from
PublishLink

Removes a target part occurrence from the selected publish link.
Removing the target of the publish link does not delete the part
occurrence or the publish link.

Tools→Structure Alignment→Find
PublishLink Source

Identifies all publish links for which the selected occurrence
is a destination. It highlights the linked occurrences in the
companion pane. If it does not find any publish links, it displays
an error message

Tools→Structure Alignment→Find
PublishLink Targets

Identifies all publish links for which the selected occurrence is
a source. It highlights the linked occurrences in the companion
pane. If it does not find any publish links, it displays an error
message

Tools→Structure
Alignment→Open PublishLink
source structure

Opens source structure in the structure pane.

Tools→Structure Alignment→Find
lines with same logical identity

Highlights all lines with the same logical identity as the selected
line, that is, lines that are associated with it by a publish link.

Multi-Structure Manager buttons

Note:

You can add buttons that are not displayed on the main toolbar by right-clicking the toolbar,
choosing the Customize menu command and selecting the buttons you want to add. Once you
have added buttons to the toolbars, they are displayed in future sessions. Consider adding buttons
that:

• You use frequently.

• Provide a shortcut to menu commands that are not primary selections, for example,
Tools→Revision Rule→Set Date/Unit/End Item....

• Show current status, for example, incremental change configuration options.

These standard buttons are located on the main toolbar at the top of the product structure pane.
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Button Purpose

Abort Terminates the current activity.

Cut Cuts the selected lines from the structure and places
them on the clipboard.

Copy Copies the selected lines in the structure and places
them on the clipboard.

Paste Pastes the components from the clipboard as children
of the currently selected (assembly) line in the
structure or into NX.

Delete Deletes the selected object from the database.

Toggle in context mode Enables and disables in context editing.

Save Saves changes you made to the structure since it was
last saved.

Remove Removes the selected lines from the structure
completely and does not place them on the clipboard.

Create item Creates a new item beneath the selected object.

Create occurrence group Creates a new occurrence group.

Unpack the selected line Unpacks the selected packed lines so that they are
displayed as separate lines, one for each occurrence.

Pack the selected line Packs the selected lines so that all lines with the same
item revision and sequence number are displayed as
a single line. The actual quantity of lines appended to
the node.

View/edit note Adds or edits the occurrence notes of the selected line.

Edit the variant condition Views or edits the variant condition on the selected
lines.

Save, set, and load variant
rule.

Views, sets, saves, and loads the variant option values
for the selected line.

Show/hide data panel Displays the data pane that contains the Attachments,
Incremental Change Info, Variants, Viewer,
Referencers, and Supersedure tabs and panes.

Assign across BOM When two structure panes are visible, allows you to
select assemblies or components in the BOM in one
pane and assign them to an assembly in the BOM tree
in the other pane as its children. Once this is done,
the absolute occurrences of those assigned children
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Button Purpose

are shared between the two BOMs. You can search
for lines that share absolute occurrences between
different BOMs from any instance of the assembly or
component.

Note:

You can also right-click a selected line in the
BOM and choose the Tools→Assign menu
command.

Find selected in companion
panel

When you select a component in the BOM in
one structure pane, allows you to search for the
component in the BOM in the other structure pane.
The search follows the closest match rule if it does not
find an exact match.

Send CC to NX Sends the selected collaboration context to NX.

Show allocation navigator
panel

Opens the allocation navigator pane that lists all
allocations created in the current allocation map.

Show IC information for
allocations

Shows any incremental change information that is
available for the current allocation map. This is only
available if incremental change is activate.

Show/hide the second
structure panel

Shows or hides the second structure pane. This button
is always active.

Show/hide the collaboration
panel

Shows or hides the collaboration pane. This button is
always active.

Open or refresh GBC
application

Opens the Graphical BOM Compare application or
refreshes it if it is already open.

Export to Word Exports the contents of a selected object to Microsoft
Word.

The following buttons are displayed at the bottom left corner of the navigation tree pane.

Button Purpose

Open a Collaboration Context
By Name

Browses for and opens a specific collaboration context
by name.

Open a Structure Context By
Name

Browses for and opens a specific structure context by
name.
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Most Recently Used (MRU) List Shows a list of your most recently accessed structures.
If you select an entry from the list, Multi-Structure
Manager loads the structure into the structure pane.
You can configure the number of entries shown in the
MRU list by right-clicking the button and moving the
slider to the desired number.

Open an Occurrence Group by
Name

Browses for and opens a specific occurrence group by
name.

Base View Appearance Search Performs a search based on a cache of configured
product structure, permitting faster searching of the
structure for components configured at a specific date
or unit. The appearance cache allows you to perform
spatial searches, for example, to find all components
within one centimeter of a selected part. You can
combine appearance searches with other queries, for
example, queries for item revision master attributes,
classification attributes, or occurrence notes.

The appearance search is only enabled if your
administrator has configured appearances.

List Substitute Components Adds or removes alternate components or sets the
preferred alternate.

This button is enabled if the selected line may have
alternates, otherwise it is disabled.

Manage Global Alternates Shows a list of the global alternates available for the
selected line. You can add alternates and select a
preferred alternate. The preferred global alternate is
indicated by an asterisk (*).

Find Components in Display Searches for matching lines (components) in the
displayed product structure by entering an expression.
You can search with any combination of the available
properties.

Search for BOM Components
with ID In Context

Searches for absolute occurrences using the identifier
assigned in the ID In Context column of the property
table.

The following buttons are displayed when in allocation mode.

Multi-Structure Manager buttons
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Button Purpose

List Allocation Context
Revisions

Lists all revisions of the current allocation map.

Create and Set New Allocation
Context

Creates a new allocation map.

Revise and Set a currently
loaded Allocation Context
Revision

Creates a new revision of the currently active
allocation map.

Search and Set existing
Allocation Context

Allows you to search for any existing allocation map in
the database.

Most Recently Used Button
(MRU)

Shows a list of the most recently opened allocation
maps.

Clear Allocation Context Removes the current allocation map from the
allocation navigator.

Save Modifications to the
Current Allocation Context

Saves any changes made to the current allocation
map.

Filter Allocations Based on
Types

Filters displayed allocations based on type of
allocation.

Highlight Allocated Lines
Automatically

Highlights the source and target occurrences, as well
as the related allocation in the allocation navigator
when you select any one of these.

Clear BOMLines Selection in
All Structures

Removes selection from all lines in displayed
structures.

The following buttons are available on the Drafting Symbols tab if your administrator has activated it.

Button Purpose

Manually refreshes the editing box.

Adds a frame around the selected characters.

Bolds the selected text.

Italicizes the selected text.

Underlines the selected text.

Sets the color of the selected text.

1. Getting started with Multi-Structure Manager
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Button Purpose

Decreases the size of the selected text.

Increases the size of the selected text.

Subscripts the selected text.

Superscripts the selected text.

Aligns the selected text.

Center aligns the selected text.

Right-aligns the selected text.

Inserts the text you typed in the two boxes to the left of this button.

Inserts a control frame around the selected characters.

Multi-Structure Manager panes

The Multi-Structure Manager interface is divided into various panes.

Pane Purpose

Collaboration pane The collaboration pane displays the collaboration context and any additional
structures currently open in the application in a navigation tree. Any
attachments are shown in the structure pane where you can open them and
view their properties.

Structure pane Each tabbed pane represents an open structure in the application. Closing a
pane unloads the structure. You can load multiple structures simultaneously.

Data pane These panes display information about the attributes and relations of the object
selected in the BOM on the structure tab. The tabs displayed depend on the
structure tab selected and the type of object selected in the BOM.

Second structure
pane

By right-clicking a structure tab, you can open the structure in a second
structure pane. Use this pane to compare structures. You can also open a data
pane for the second structure pane. Close this pane by clicking Show/Hide the
Second Structure Panel .

The contents of the menus and toolbar buttons vary depending on what is selected in each pane.

Multi-Structure Manager panes
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Multi-Structure Manager tabs

The data pane on the right side of the application window contains multiple data tabs, which display
information specific to the object selected on the structure pane. The type of object selected on the
structure pane determines the data tabs available at any given time.

The following sections describe the data tabs that may become available. Not all tabs are available in
all circumstances and their availability depends on the type of structure. Your administrator may also
customize the availability of data tabs at your site.

Standard Teamcenter shortcut menu commands are available for any object in the data tabs.

The following table lists Multi-Structure Manager tabs that are available when the data pane is displayed.

Tab Description

Assembly Viewer Displays an image of the selected line or lines, if a DirectModel dataset is
associated with the object.

The following image types are viewable in this tab:

• DirectModel = imported JT files or JT files created by the translators.
These files must have a Teamcenter rendering relation.

• DirectModelMarkup = captured image of a DirectModel dataset.

• DrawingSheets and Markup = imported CGM files.

• Image = imported TIF, GIF, JPEG and similar file types.

2D Viewer Displays one or many snapshots associated with a line in your product
structure. If there are multiple image datasets attached, you can select
the desired image. You can use the 2D Viewer pane to:

• Create new 2D snapshots.

• Update existing 2D snapshots.

• Apply an existing 2D snapshot to the current view.

• Compare an existing 2D snapshot to the current image.

• Search for existing 2D snapshots by specified attributes.

For more information about using 2D snapshots, see 2D snapshot
overview.

1. Getting started with Multi-Structure Manager

1-20  Multi-Structure Management, Teamcenter 2412
© 2025 Siemens



Tab Description

Referencers Identifies which, if any, other database components reference the object
currently selected on the structure tab.

This tab also displays any assemblies where the selected object appears.

For more information, see Teamcenter Basics.

Attachments Displays the properties of all related components (including the base
item component and all related subcomponents) of the object selected
on the BOM in the structure pane.

Double-click an attachment on this tab to open the designated
application used to edit and view the attachment.

Note:

Activity attachments must be viewed from the Operation
Activities tab.

Class Attributes Shows each attribute that exists in the Classification application for the
object currently selected on the structure tab. It is not enabled if you
select an occurrence group or view.

This data is informational only and cannot be changed on this tab. You
must change the data through the Classification application.

For more information, see Basic Classification on Rich Client ─ Usage.

Object View Allows you to perform 2D markups on the top line selected in the BOM
on the structure pane. This tab is divided into two panes:

• The left pane displays the markup tree table.

• The right pane displays an image of the object.

Click the buttons at the top of the tab to manipulate the image.

Click the buttons at the bottom of the tab to create markup annotations
on the image.

After the image is annotated, click the Printer button to print a sketch of
the image and its markup.

Product Manual Displays a product manual created using the Manufacturing Process
Management publishing feature. See Using Teamcenter Publish.

Work Instructions Displays work instructions created using the Manufacturing Process
Management publishing feature. See Using Teamcenter Publish.

Multi-Structure Manager tabs
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Tab Description

Report Supports the creation of reports for structures. It is not available if you
select an occurrence group or view. The generated report is presented
through a browser window.

You can create customized XSL style sheets or use other formatting tools
to customize both the data content and the report format.

Variants Displays and edit variant options, option defaults, and rule checks
currently defined for the current object. It is not available if you select
an occurrence group or view.

Incremental Change Info Shows the effectivity of a change order as a range of units or dates, and
its release status. The Incremental Change Info tab is enabled when you
select a line or occurrence group in the BOM and an incremental change
order is associated with that line.

TraceLink Displays defining and complying paths for a given object created when
performing requirements management. You can view the predecessors
or successors in an upstream or downstream path. You can also view the
trace links themselves, as independent objects.

Allocations Traceability Displays the allocation source and target graphically.

Linked Occurrence Paths Shows whether the selected BOM line (occurrence) is linked to
something else from its associated product or plant structures. The
complete path is displayed in this tab so you can identify exactly what
is being consumed (for example, the left front or right front wheel).
You can also remove the links or identify a corresponding BOM line in
the associated product/plant tab using menu commands in the shortcut
menu.

Multi-Structure Manager symbols

Symbol Meaning

Item

Item revision (BOM line)

Item element (general design element)

Form

Dataset

BOM view
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Symbol Meaning

Alternate ID

Document

Document revision

DirectModel dataset

NXMaster dataset

NXPart dataset

NXScenario

Variant item

Variant item revision

Incremental change removed

Incremental change added

Separate incremental changes removed and added

Absolute occurrence override removed by incremental change

Absolute occurrence override added by incremental change

Absolute occurrence overrides removed and added by separate
incremental changes

In scope for creation of absolute occurrences

One or more of the absolute occurrences are edited in a context but not
necessarily the current context.

Process

Process revision

Snapshot

Allocation

Multi-Structure Manager symbols
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Symbol Meaning

Allocation map

Allocation map revision

Allocated to

Allocated from

… When displayed in the structure tree after a search, this symbol indicates
the line has hidden children. Click this symbol to load and view the
hidden children.

What are perspectives and views?

Within the rich client user interface, application functionality is provided in perspectives and views.

View The basic display component that displays related information in a UI window.

Perspective A collection of one or more views and their layout.

Some applications use a perspective with multiple views to arrange how functionality is presented.
Other applications use a perspective with a single view.

You can use the HiddenPerspectives preference to prevent the display of some Teamcenter perspectives
in the rich client.

If your site has online help installed, you can access the application and view help from the rich client
Help menu.

Basic concepts about Multi-Structure Manager

Multi-Structure Manager objects

A collaboration context may be considered as a project folder that contains all the information
associated with a project; it may contain references to objects in Teamcenter, including structure
contexts. It is persistent and allows data to be shared by different applications, for example, Teamcenter
and an external application. It consists of one or more structure contexts, each of which may have a
different configuration. The children of a configuration are defined by a configuration context.

A structure context is a configurable structure that consists of one or more root objects sharing the
same configuration. For example, it may be one or more BOMs or assembly structures and their
configurations. In this example, each BOM or assembly may be assigned to a different group or vendor to
manage and build.
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The configuration of the structure context is defined by a configuration context. The structure objects
may have occurrence groups, items, and item revisions. The configuration context stores a set of rules
that determines the configuration of a collaboration context and the entire structure within a structure
context. The rule set may include revision or variant rules.

A composition is a structure that shows the relationship between other structures for modeling a
scenario or manufacturing process. Each structure may have a different configuration. The type of the
structure context determines if it is a composition.

Multi-Structure Manager functions

The collaboration context object consists of one or more structure contexts, each with different
configuration rules. The BOM lines in each structure context are determined by a revision rule or a
variant rule.

Note:

Collaboration and structure objects are work space objects (WSOs), not items. They cannot be
revised, but you can manage them with incremental changes.

Each structure context may include one or more root objects, each of which may be an occurrence
group, an item or an item revision. The item revision may include objects derived from an item or
another item revision. You can attach WSOs to collaboration context and structure context objects.

You can open a collaboration context or a structure context several ways, for example, by dropping
the object on the Multi-Structure Manager button. Within each structure context, you can browse the
structure, modify its content, and create relationships with other structures.

You can open each object in the appropriate data pane to visualize the structure, view or edit its
properties, perform searches, manage incremental changes, and so on.

You can create and manage structures entirely with the Multi-Structure Manager application. You can
also create structures in another application such as Structure Manager or Manufacturing Process
Planner, then manage them with Multi-Structure Manager. If you create a structure in another
application, it retains the characteristics assigned it in the other application when you open it in
Multi-Structure Manager. Consequently, for example, if you create a process structure in Manufacturing
Process Planner, you see the appropriate process structure tabs when you open it in Multi-Structure
Manager.

Types of objects you can open

The following types of objects can be opened in or sent to the Multi-Structure Manager application:

• Collaboration context object

All the collaboration context object's structure contexts are displayed on tabs on the structure pane.

Multi-Structure Manager functions
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• Structure context

The structure context appears on additional tabs on the structure pane. If it does not belong to the
opened collaboration context, the title of its tab shows the name in parentheses, indicating it is a
stand-alone context.

• Item, BOM line, or BOM view

These are opened as temporary structure contexts.

• Intermediate data capture (IDC)

This is opened as a temporary structure context.

• Processes of type Process

This is opened as a temporary structure context.

• Operations of type Operation

This is opened as a temporary structure context.

If an opened structure context is a composition, an asterisk (*) appears before its name on the tab.
The system determines whether an item should be displayed as a composition by referring to the
CCCompositionTypesPref system preference. The default value of this preference is Process, OP. You
can override this default preference and put other item types in the list.

Basic tasks using Multi-Structure Manager

Use Multi-Structure Manager to perform the following tasks:

• View the assembly structure of a products contained within the contexts, navigate around the
structures, and find components in the structures.

For more information, see Working with collaboration contexts.

• Create or open existing contexts, add temporary structures, save contexts, and work with absolute
occurrences.

For more information, see Overview of creating a collaboration context.

• Add components to the product structure, change components belonging to the structure, define
global alternates and substitute components, and perform many other product structure editing tasks.

For more information, see Building and editing product structure.
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• Create occurrence groups and absolute occurrences.

For more information, see Introduction to occurrence groups.

• Track changes using incremental change.

For more information, see Incremental change overview.

• Configure classic or modular variants or search for a variant item, or unlink a variant item from the
structure.

For more information, see Working with variants—overview.

• Search the structure for items on the clipboard, or search by name. You can perform where-used and
where-referenced searches. You can also search for appearances.

For more information, see Searching structures.

• Create and view a preliminary data indicator (PDI) or baseline.

For more information, see About baselining or preliminary structures.

• Create an intermediate data capture (IDC) of any configured structure including a collaboration
context, structure context, or group of BOM lines.

For more information, see About intermediate data captures.

• Compare two structures to ensure all lines in the source structure are consumed in the target
structure.

For more information, see Running accountability checks.

• Create publishing pages, work instructions, or a product manual.

For more information, see Using Teamcenter Publish.

• Create directional relationships between two structures to relate specific aspects of these structures,
such as the functional structure to the logical structure.

For more information, see Allocations overview.

• Import and export data using PLM XML.

For more information, see Importing and exporting structures and items.

Basic tasks using Multi-Structure Manager
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2. Viewing and managing data
Opening the Multi-Structure Manager application

The first time you open Multi-Structure Manager, you see the empty structure pane. You must first create
or open an object before you see the data pane or any of the tabs. The menu bar and toolbar appear
in the standard Teamcenter locations. They contain standard menu commands and also commands that
are specific to collaboration context functionality.

The following figure shows an example of the layout of the Multi-Structure Manager application with the
collaboration pane on the left and a structure pane visible in the center. In this example, the right-most
pane shows incremental change information about the selected structure; this pane may contain other
information, as described in Using the structure pane.

Note:

For more information about viewing and manipulating 2D images in the Viewer pane, see
Working with 2D images.

For more information about viewing and manipulating 3D models and assemblies in the Viewer
pane, see Working with 3D models.

Multi-Structure Manager application, collaboration, and structure panes

Optionally, you can open a data pane for each view tab of a structure tab. By default, the data pane
includes the Referencers and the Object Viewer tab.

Navigating the structure panes

When you first open an object in the Multi-Structure Manager application, the collaboration pane and
a structure pane are displayed. The context displays as the root of the collaboration pane tree; the first
root of the first structure (if any) is shown in the structure panes.
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If the Multi-Structure Manager application is running and you open another component, the opened
component is displayed. However, if the opened component contains the current structure, the display
does not change.

If you open a structure component, the details displayed depend on the previously opened component,
as follows:

• If you open a component for which where there is no structure pane, the structure appears in a new
structure pane.

• If you open a component for which there is already a structure pane, the structure pane is selected.

You can optionally open two structure at the same time in different structure panes. This allows you to
relate objects (occurrences, occurrence groups, views, or items) in one structure to similar objects in the
other structure.

Using the collaboration pane

You can optionally use the collaboration pane to view the open component in a navigation tree. Any
attachments are shown in the collaboration pane, and you can open them and view their properties.

Note:

You can also browse and edit a collaboration context or structure context with My Teamcenter
or Manufacturing Process Planner. Any changes you make in those applications are visible in this
application; similarly, any changes you make here are visible in those applications.

You can hide or show the collaboration pane as necessary by clicking the Show/Hide Collaboration
Panel  button. When you hide the collaboration pane, it remembers the context expansion and
selection to redisplay when you show the collaboration pane again.

The data displayed in the collaboration pane and the structure pane may be independent of each other.
However, if you open a structure component in the collaboration pane, the corresponding data always
appears in the structure pane.

In the collaboration pane, you can:

• Browse and expand the navigation tree.

• Change the current root objects of a structure context. If the objects are not part of the collaboration
context, they are shown as extra lines in the collaboration pane.

• Cut, copy, paste, and delete components in a structure context.

• Remove structures from the collaboration context.
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• View multiple root objects such as items, item revisions, BOM lines. These do not have to be part of
the collaboration context.

• View attachments that are not visible in the BOM. You can view configured and unconfigured
attachments.

• View the variant rules associated with the structures in the collaboration context.

• View and apply the revision rules associated with the structures in the collaboration context.

• Submit an item revision to a predefined workflow. Select the item revision and choose the Workflow
Process menu command. The status of the item changes to reflect success or failure.

Using the structure pane

A structure pane shows the contents of a single structure context (for example, a product or process
structure) in separate panes within the structure pane.

The header bar of each pane in the structure pane contains:

• The name of the structure context component or the opened component.

• The name of the structure context component.

• The names of the rules that apply to the view. Each view may have a revision rule or a variant rule.
A rule appears in parentheses if it differs from or is modified from the rule that is attached to the
structure's configuration context.

The tab label of each pane has parentheses if the structure is not part of a collaboration context
component.

For information about how to save these objects, see Save temporary objects as structure contexts.

Choose the Root Structures box to display a list of the end items or top line items for each root object
in the structure context. If the root is an occurrence group, the top line item is listed, not the occurrence
group. The top line item is listed only once, even if the structure context contains many occurrence
groups (and the item itself) with the same top line.

Each tabbed pane displays the structure of the root component that you selected in the Root Structures
box. The format of the display depends on the type of structure context and the root component. If
the root component is an occurrence group, an assembly view is shown. If it is an item, revision, base
version, or base version revision, a BOM view is shown.

Using the second structure pane

You can split the structure pane in two and use the other structure pane to:

Using the structure pane
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• Reference a line in a separate structure from a composition.

• Find a selected object in the other pane.

• Edit structures in the same way as in the first pane.

• Copy, paste, or drag-and-drop data between structures in the two panes.

• Open multiple structures in different tabs.

Note:

• If you want to compare two configurations of the same structure, you must save the root
structure in two different structure contexts and open these separately.

• Opening a structure in the second pane closes it in the first pane.

When you open the data pane, you can specify whether it should open to the right of the structure pane
or below it. You specify this behavior in the MEDataPanelPosition preference. If you set this preference
to right, the data pane opens to the right of the structure on which you are working. If you set the
preference to bottom, the data pane opens below the structure. The second data pane that opens in the
Attachments and Activities tabs is not affected by this preference and continues to open in the right
side of those panes.

When opening a second structure pane, you can specify that it is opened to the right of the first
structure, instead of below it. You define this behavior in the MESecondStructurePosition preference
that has right or bottom as valid values.

To show and hide the second structure pane:

• Choose View→Show Second Structure Panel.

-or-

Click Show/Hide the Second Structure Panel .

If you have not yet opened a structure in the second pane, the pane is empty when you open it. If you
have opened a structure in the second pane previously, this structure is shown the next time you open
the second pane.

To open a structure in the second structure pane:

1. Right-click the tab of the structure you want to display in the second pane.

2. Choose Open Structure in Second Panel.

2. Viewing and managing data
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Teamcenter closes the structure in the first pane and opens it in the second pane. You can open
multiple structures in separate tabs in the second pane.

If you want to compare two configurations of the same structure, you must save the root structure
in two different structure contexts and open these separately.

Setting up the search for components in other structures

You can select one or more objects in the following areas of the user interface and search for them in a
different structure.

• Lines in a view

• Consumed parts in a process

• An object in the Navigation pane (Favorites, History, Open Items)

• Objects in the Home folder

• Objects in the My Worklist folder

• Items attached to a Teamcenter mail

• Lines in the Summary view

• Objects in the Graphics view

Whether you need to expand a target structure before choosing the Find in Source Structure menu
command depends on the settings of the following two preferences:

MECopyIdInContextToAssignedLine
MECopyIdInContextLowerLevels

Note:

Whether you need to expand a structure before a found component can be highlighted within it
depends on the value of the MEExpandToSelection preference. If this preference is set to false,
you must manually expand the target structure to highlight lines found within that structure.

Find components in open structures

1. Open one structure in the structure pane and the second in the second structure pane.

2. Right-click an item in the source structure.

Setting up the search for components in other structures
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3. Choose Find in Source Structure from the shortcut menu.

Teamcenter searches for the item in the alternate structure and, if successful, highlights it, as
shown in the following figure.

Individual search result

Expand and collapse a structure

1. Select an object in the loaded structure.

2. Do one of the following:

• Choose View → Expand Options → Expand to expand the structure to one level below the
selected line.

• Choose View → Expand Options → Expand Below to expand the entire structure below the
selected line.

2. Viewing and managing data
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Teamcenter expands only to the level of consumed objects.

Note:

This can be time-consuming in very large structures.

• Choose View → Expand Options → Expand Below... and select a level to which you want to
expand the structure.

• Choose View → Expand Options → Expand to Type.

Teamcenter displays the Expand to Type dialog box.

a. In the Type list, select the type to which you want to expand the structure.

The types listed are dependent on the type of selected object and the
MEExpandToBaseTypes preference. The MEExpandToBaseTypes preference is only
applicable to selected processes.

Selected object type Behavior

Process The list contains subtypes of both Process and
Operation.

Operation The Expand to Type command is unavailable.

Plant The list contains subtypes of Plant.

Product The list contains subtypes of Product.

b. Click OK.

Teamcenter expands the tree to the selected type.

• If the expand mechanism reaches the given type in a branch, it stops and moves to the
siblings.

• If the expand mechanism does not find an object of the selected type in the tree, it does
not expand the tree.

• If the expand mechanism does not find an object of the selected type in a branch, the
branch remains collapsed.

3. (Optional) Collapse the structure by choosing one of the following:

• View → Collapse Below to collapse the entire structure.

Expand and collapse a structure
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• View → Expand Options → Expand Below... and selecting the Collapse lower level check box.

Tip:

Each of these commands are also available from the shortcut menu.

Maintain the tab display

To expand and collapse the view of a pane but maintain the accessibility of the tabs, adjust the display
area using the left and right arrows at the top of the vertical bar that divides the data panes. You do not
need to reset the view to select a different tab.

1. Click  to expand the pane.

2. Click the opposite arrow  to return the display to its original settings.

Working with views

About views

Teamcenter offers you a variety of views to help you manage your data. Some of these views originate
with the manufacturing applications, such as:

• Structure Search view

• Process Gantt view

• Accountability Report view

Other views, such as the Impact Analysis view, are common to all Teamcenter applications.

These views have some features in common, such as the ability to change the displayed columns or
filtering the results.

Menus and toolbars within a view behave as if a line is selected in the structure pane. When you select a
structure line in a view, the line is selected in the structure pane and vice versa. If you delete a line in the
view, Teamcenter deletes it from the structure pane. You can drag lines from the view to the structure
pane.

Filter data in the view

You can filter the data in the view based on BOM line properties to show only a subset of the contents in
the table.

2. Viewing and managing data
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1. Click the Menu button  and choose Filter from the view menu commands.

Teamcenter displays the Auto Filter dialog box. This dialog box contains a list of all conditions that
you create to filter data. The dialog box remembers any conditions you create, including those in
other views.

2. Click  to add a new condition line.

Teamcenter displays the Filter Condition Editor dialog box.

3. Create a condition by combining BOM line properties, operators, and available objects and click .

4. (Optional) Remove a condition by clicking .

5. (Optional) Clear a condition by clicking .

6. (Optional) Negate the condition by clicking the !{..} button.

7. Click OK.

Teamcenter displays the new condition in the Auto Filter dialog box.

8. Select the condition that you want to apply to the table.

Teamcenter displays the filtered results in the view table.

Tip:

You can select more than one condition in the Auto Filter dialog box using the Ctrl key. The
search result must fulfill all of the selected conditions (they are joined with the AND Boolean
operator).

9. (Optional) To remove the filter, select All from the condition list or close the Auto Filter dialog box.

Modify the column display

1. Select a line in the table in which you want to modify the columns to make the table the active one
in the view.

This is important in views that contain multiple tables.

2. Click the Menu button  and choose Columns from the view menu commands located in the
top-right corner of the view.

Teamcenter displays the Column Management dialog box.

Modify the column display
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3. Select the desired columns from the Available Properties list and move them to the Displayed
Columns list with the right arrow.

4. (Optional) Modify the order the columns appear in the selected view table using the up and down
arrows.

5. Do one of the following:

• Click Apply to save the current state.

• Click Save and type a name for the column configuration. You can restore a saved column layout
by choosing Apply Column Configuration from the view menu commands and selecting the
saved configuration from the list.

Find in display

1. Click the Menu button  and choose Find in Display from the view menu commands.

Teamcenter displays the Find in Display dialog box.

2. Click  to add a line to the table.

3. Double-click the BOM Line cell of the Property Name column and select the property name by
which to search from the list.

4. Double-click the equal sign to change the operator.

5. Type a value corresponding to the property name, for example, OP if you select Item Type as the
property name.

6. Click Find.

Teamcenter displays the number of matches in the bottom left of the dialog box.

7. Page through the matches using the right and left arrows, or display them all by clicking .

Teamcenter selects the matches in the view.

Sort data in view pane

1. Click the Sort button  at the top right of the view, or select Sort from the view menu commands.

Teamcenter displays the Sort dialog box.

2. Do one of the following:

2. Viewing and managing data
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• Sort by default order by selecting Select default order.

• Specify a different sort order.

a. Select Select below criteria.

b. In each of the three boxes, double-click in the box to select from a list of columns available
in the view table.

You can insert or remove columns from tables.

For more information, see Modify the column display.

c. Select whether to sort the column entries in ascending or descending order.

3. Click OK.

Teamcenter sorts the data in the selected table in the order specified.

Visualizing structures

Ways to visualize structures

You can visualize a structure in several ways.

• The Assembly Viewer pane in the Multi-Structure Manager application allows you to visualize a
structure. The assembly viewer is sometimes referred to as the embedded viewer.

• The rich client Lifecycle Viewer application provides you with nearly all of the visualization tools
offered by the stand-alone viewer, many of which are not available in the embedded viewer
within Teamcenter applications. You open the rich client Lifecycle Viewer application by clicking the
Lifecycle Viewer application icon .

• Stand-alone Lifecycle Visualization provides you with all the functionality of a viewer view or the
Lifecycle Viewer but with support for optional software modules such as Concept, Visualization
Illustration, Quality Producer, and Variation Analysis. Stand-alone Lifecycle Visualization is integrated
with Teamcenter, so you can send data from Teamcenter applications into the stand-alone viewer,
perform analysis, and then save your work back to the database.

Displaying objects by type

Overview of displaying objects by type

You can display or blank objects in the Graphics view based on their type, occurrence type, or a
combination of both. For example, you may want to blank all weld points or display only the parts

Ways to visualize structures
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consumed by a process. In addition, a visualization filter allows you to set the object and/or occurrence
types you want to hide from the display on a more permanent basis.

The types of objects you can blank or display depend on the type of structure on which you are working.
For a process structure, you can display or blank:

• Item types such as Item, WeldPoint, or Workarea. All item types that derive from Item, Workarea,
and PSConnection (including WeldPoint) are supported.

• All available occurrence types such as MEConsumed or ME Weld Point.

• Any combination of these item and occurrence types.

For a product structure, you can display all types that derive from:

• Item

• PSConnection

For a plant structure, you can select all types that derive from the Workarea item type.

The object types to be blanked or displayed in the structure must exactly match the selected types.
Selecting an item does not select every object derived from the Item type.

To reduce the size of this potentially long list of candidates, you can store the commonly used item list in
the MEBlankDisplayTypes preference.

Display/blank objects by type

1. With a structure open in the Graphics view, do one of the following:

• Choose Graphics→Visibility→Display/Blank Selected by Type→Object/Occurrence Type

• Right-click in the viewer pane and choose Display/Blank Selected by Type.

• Right-click a subassembly in the structure tree and choose Display/Blank Selected by Type.

2. Choose the type of object or occurrence type that you want to blank or display.

The entries in this list are dictated by the value in the MEBlankDisplayTypes preference.

The object types that you select are displayed or blanked in the viewer.

Display/blank multiple object types

1. Choose Graphics→Visibility→Display/Blank Selected by Type→Advanced.

2. Viewing and managing data
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2. Select all the object types that you want to display. If you open the dialog box with a process
displayed in the viewer, you can also select occurrence types.

3. (Optional) Select Display only selected types to blank all types other than those selected in the
dialog box.

4. Click OK.

Set the visualization filter

Use the visualization filter to set the object and/or occurrence types you want to permanently hide from
the display.

1. With a structure open in the Graphics view, choose Graphics→Visibility→Define Visualization
Filter, or click the Define Visualization Filter button  in the toolbar.

2. Choose the object or occurrence types that you want to hide permanently from the display.

3. (Optional) Select Apply visualization filter to activate the filter as soon as you close the dialog box.

4. Click OK.

5. (Optional) If you did not activate the filter in step 3, activate it by choosing
Graphics→Visibility→Apply Visualization Filter or clicking the Apply Visualization Filter button

 in the toolbar.

Product view overview

About product views

You can save data in the assembly viewer, including current items, zoom factor, rotation angle, and
pan displacements. You can retrieve a saved product view (sometimes called a 3D snapshot or snapshot
view) during a subsequent session or share it with other users. You can only save or retrieve product
views when a base view structure is displayed in the viewer. You cannot create product views of
occurrence groups.

You can create product views that contain one or more of the following:

• Collaboration contexts

• Structure contexts

• Configurator contexts

• Item revisions (structure lines)

Set the visualization filter

Multi-Structure Management, Teamcenter 2412  2-13
© 2025 Siemens



• 2D and 3D NX CAD and Lifecycle Visualization files

• Motion (VFM) files

• Published documents, including work instructions

Each product view is stored in a dataset containing a thumbnail image file, a PLM XML session file, 3D
markup layers, and the top-level item of the view.

You can configure the structure with revision rules, effectivity, variant rules, and similar techniques. If
appropriate, you can use several Show Unconfigured menu commands to hide unconfigured objects in
the structure and in the viewer. When product views are captured, these view selections are taken into
account; otherwise, potentially unbuildable combinations of parts may be displayed when the view is
restored. You can retrieve the original state of the menu commands and consequently the original state
of the view.

If the product view is attached to a structure and the structure is cloned, the product view functions
correctly in the new (clone) structure. Likewise, product views may be attached to a structure that is
shared with Multi-Site Collaboration.

You can also update product views in the Lifecycle Viewer or stand-alone Lifecycle Visualization. You
send a dynamic product view to one of these applications, and then create a new product view or
update and replace the existing one. When you send the updated product view back to Teamcenter, you
can open it in the assembly viewer.

Your Teamcenter administrator sets the size and presentation of the product views with system
properties and preferences..

Note:

In Teamcenter 8.0, the file format of 3D product views changed. If you open a file that was created
in an earlier Teamcenter version, it is automatically converted to the new format.

Create and save a product view

1. Adjust the content of the viewer window using the pan, rotate, eyeball, and zoom buttons to create
the necessary scene.

2. Select an object in the structure base view window.

3. If necessary, right-click in the viewer menu bar and choose Create Markup.

Teamcenter displays the Create Markup toolbar.

4. Click Create 3D Product Views  on the Create Markup toolbar in the assembly viewer.

2. Viewing and managing data
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Teamcenter displays the Product View Gallery dialog box, which contains thumbnails of any
previously saved product views that are associated with the selected object.

5. Do one of the following:

• Click New Product View .

• Right-click in the window and choose Create New Product View.

You are prompted to enter a name for the product view if the Vis_PV_Show_Name_Dialog user
preference is set to True. If it set to False, Teamcenter generates a name automatically.

Teamcenter saves the product view and its configuration in a dataset. It also adds a thumbnail of
the view to the Product Views dialog box.

Note:

Thumbnails of all product views are not visible at all times, only for those items related to the
selected end item (the top entry in the structure window).

Configure and manage product views

1. Choose Options→Visualization→Product View.

Teamcenter displays the Product View Creation Preferences pane.

2. Set the following preferences as required:

Preference Description

Geometry Asset Determines whether a geometry asset file is added when
a product view is created. This file is required if you want
to export a PLM XML file of the product view. This option
is equivalent to the Vis_PV_Geometry_Asset preference.

Show Product View name dialog If selected, you are prompted for a name each
time you create a product view. If not selected,
Teamcenter generates the name automatically. This
option is equivalent to the Vis_PV_Show_Name_Dialog
preference.

View Toggle Warning Level If selected, Teamcenter displays a warning or prevents
you from continuing if you try to create a product view
when one or more of the View menu commands to show

Configure and manage product views
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Preference Description

unconfigured data is selected. This option is equivalent to
the Vis_PV_InvalidConfigWarnLevel preference.

View Toggles to consider Select the View menu commands to show unconfigured
data that are considered if the View Toggle Warning
Level option is selected. This option is equivalent to the
VisPVBlockingViewToggles preference.

Image Capture Determines if Teamcenter saves a preview image of
the 3D product view when it is created. If you choose
Perform Image Capture (Using Image Export Dialog),
you are prompted for the settings to use. If you choose,
Perform Image Capture (with preferences), it uses
values set in preferences. This option is equivalent to the
Vis_PV_ImageCapture preference.

Image Format: Image Resolution,
Width of image, and Height of
image

Depending on the setting of the Image Capture
option, these options may determine the file format,
resolution, and size of the preview image. If
Perform Image Capture (Using Image Export Dialog)
is set, these options are disabled. These options
are equivalent to the Vis_PV_ImageCaptureType,
Vis_PV_ImageCaptureResolution,
Vis_PV_ImageCaptureWidth, and
Vis_PV_ImageCaptureHeight preferences, respectively.

Thumbnail: Width, Height, and
Quality

Determine the size and resolution of the
thumbnail image created for each product
view. These options are equivalent to the
Vis_PV_ThumbnailWidth, Vis_PV_ThumbnailHeight,
and Vis_PV_ThumbnailQuality preferences, respectively.

Play motion in current view If selected, any motion (VFM) file in the current product
view plays when the view is selected. This option is
equivalent to the Vis_PV_Play_Motion preference.

Configuration rule to use Offers you two choices:

• Use configuration from the current BOM ignores
stored rules and preserves the configuration that was
active before you applied the product view.

• Use configuration from product view considers any
arrangements, effectivity, variant rules, and revision
rules stored with the product view when you apply it.

This option is equivalent to the
Vis_PV_HowTo_Configure_BOM preference.

2. Viewing and managing data
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Note:

Your administrator may configure these preferences with SITE or GROUP protection scope,
rather than USER protection scope. If so, you may be able to view but not change the current
settings.

3. Right-click a selected product view thumbnail in the Product View Gallery dialog box.

Teamcenter displays a shortcut menu.

Note:

You can identify the currently selected product view by the green border (if checked out) or
red border (if not checked out) around its thumbnail.

4. Choose one of the following.

Command Description

New Tab Creates a new tab for the element currently selected in
the structure. This tab is unavailable if no element is
selected in the structure base view window.

Refresh Tab Refreshes the currently selected tab in the product view
gallery to reflect structure configuration changes.

Remove Tab Removes the current tab from the dialog box.

Refresh All Tabs Refreshes all the tabs in the product view gallery to
reflect structure configuration changes.

Remove All Tabs Removes all tabs from the dialog box.

Add Creates a new product view from the current contents of
the viewer.

Apply Applies the configuration of the selected product view to
the viewer.

Delete Deletes the selected product view.

Update Refreshes the stored product view with changes made in
the viewer. This command is enabled only if you check
out the product view dataset.

Rename Displays a dialog box that allows you to change the name
and description of the selected product view. A product
view name appears below each button; the description
appears when the cursor is placed over the button.

Configure and manage product views
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Command Description

If you rename a product view, the order in which
thumbnails are displayed in the Product View Gallery
dialog box changes. Teamcenter generates the default
name of a view from the date and time it was initially
created. It lists available views in alphanumeric order.
You can choose an appropriate new name to move the
view up or down the list.

Enable Multiple Selection Allows you to select more than one product view.

Options Displays the Product View Creation Preferences pane.

Note:

If you right-click any part of the Product View Gallery dialog box (except one of the buttons)
and no product view is selected, the menu commands to apply, update, rename, and delete
the product view are unavailable.

Create product view preview manually

Note:

The menu commands described in this procedure are available only if the Image Capture option
is set to Perform Image Capture (using Image Export dialog). If you do not select this option,
you cannot manually adjust the size, resolution and file format each time you create or update a
product view.

1. Right-click a product view or the Product View Gallery tab and select Image Capture.

Teamcenter enables the capture of 2D images, as indicated by a check mark next to the menu
command.

2. Create or modify the product view.

If you selected Perform Image Capture (using Image Export dialog) previously, Teamcenter
displays the Image Export dialog box.

3. Change the size and file format of the image if necessary, then click OK.

Teamcenter creates the product view using the parameters you entered.

Manage unconfigured data in a product view

You can use several menu commands to show or hide unconfigured objects in the structure and in the
viewer, as follows:

2. Viewing and managing data

2-18  Multi-Structure Management, Teamcenter 2412
© 2025 Siemens



• Show Unconfigured Variants

• Show Unconfigured By Occurrence Effectivity

• Show Unconfigured Changes

• Show Unconfigured Assigned Occurrences

• Show GCS Connection Points

• Apply Occurrence Type Filters

When product views are captured and restored, these view selections are preserved; otherwise,
potentially unbuildable combinations of parts may be displayed when the view is restored. If you choose
to update the configuration from the product view when you reopen it, the saved view selections are
retrieved; if you choose to use the current configuration, the saved view selections are ignored.

To evaluate the configuration of an existing product view, right-click a product view in the Product View
Gallery and choose Show Configuration.

Teamcenter displays a dialog box that shows the assembly configuration when the product view was
created. The name of the product view is shown in the title bar of the dialog box. The dialog box
also lists any Show Unconfigured menu commands that were active at the time the product view was
created.

Retrieve and open an existing product view

• Open the product view in Teamcenter:

1. Select an object in the structure base view window and open the assembly viewer.

2. Click the Create 3D Product Views button on the viewer toolbar.

Teamcenter displays the Product View Gallery dialog box containing thumbnails of available
product views of the selected structure. Only product datasets associated with the currently
selected end item are visible.

3. Right-click below the image area in the Product View Gallery dialog box and select the
configuration that you want to use for the product view.

Retrieve and open an existing product view
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Command Description

Options→Configuration rule to
use→Use configuration from
Current BOM

Applies the product structure configuration that is
currently set to the product view that you are loading.

Options→Configuration rule to
use→Use configuration from
product view

Adopts the configuration that was set at the time the
product view being loaded was created.

4. Do one of the following:

• Select the thumbnail of the product view you want to open and click Apply.

Teamcenter opens the product view and retrieves the saved configuration for the structure
window and viewer. You can then click Cancel to close the dialog box without opening the
product view.

• Select the thumbnail of the product view you want to open and click OK.

Teamcenter opens the product view as before and closes the dialog box immediately.

5. If the product view contains a motion file, replay it by right-clicking the product view and
choosing Load Motion File(s). If Play motion in current view is selected, the motion file is
played against the current structure; otherwise, it is played against the original structure.

• Open the product view in stand-alone Teamcenter lifecycle visualization:

1. Select one or more product view datasets in the Attachments tab.

2. Click the Send to Lifecycle Visualization  button.

Checking product views in and out

After you create a product view (3D snapshot), you can check it into the Teamcenter database to make
it available to other users. To refresh or delete an existing product view, you must first check it out to
prevent other users from inadvertently overwriting your changes.

You can identify a checked out product view by a green frame around the thumbnail image in the
Product View Gallery dialog box. Similarly, you can identify a checked in product view by a red frame
around the thumbnail.

Check out product view dataset

Select a product view and choose Tools→Check-In/Out→Check-Out.

2. Viewing and managing data
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Teamcenter applies a checkout lock to the dataset, allowing you to refresh or delete the product view.
Other users cannot refresh or delete the product view while you have checked it out.

Note:

If you close the Product View Gallery dialog box while you still have datasets checked out,
Teamcenter displays a request for confirmation that you want to continue. If you do, all active
checkout locks are canceled.

The Check-Out command is enabled only if you select a product view that is not checked out by
another user.

Check in product view dataset

Select the product view you checked out and choose Tools→Check-In/Out→Check-In.

Teamcenter removes the checkout lock from the dataset, allowing other users to update or delete the
product view.

Cancel checkout of product view dataset

Select the checked out product view and choose Tools→Check-In/Out→Cancel Check-Out.

Teamcenter removes the checkout lock from the dataset, allowing other users to update or delete the
product view.

Refresh a product view

You can refresh a saved product view of the current structure at any time with changes you make during
the current session in one of the following ways:

• Right-click the product view gallery and choose Refresh Tab to update the 3D snapshot in the
selected tab to reflect any structure configuration changes.

• Right-click the product view gallery and choose Refresh All Tabs to update the 3D snapshots in all
tabs to reflect any structure configuration changes.

• Right-click the product view and click the refresh product view button, which is the center graphical
button in the middle row of buttons.

• Right-click the product view and choose Apply.

Note:

The Apply command and refresh button are only enabled if you check out the product view.

Check in product view dataset
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Send a product view to an external viewer

Select one or more product views in the structure tree and choose File→Open in TcVis or right-click and
choose Send to→Lifecycle Viewer.

The selected viewer opens the product view with a configured structure. If you already have a 3D
document active, Teamcenter allows you to open your product view or merge it into the active
document, if the formats are compatible.

Note:

This method is not available if an incremental change is applied to the structure.

Note:

You can also select multiple product views in the product view gallery and send them to the
Lifecycle Viewer or stand-alone Lifecycle Visualization. The product views open one at a time and
any configuration of the original structure is retained.

Delete a product view

1. Click the floppy disk button on the Viewer toolbar.

Teamcenter displays the Product Views dialog box.

2. Select the thumbnail of the product view you want to delete and click the delete product view
button, which is the right graphical button in the middle row of buttons. Alternatively, you can
right-click in the window and choose Delete.

Teamcenter deletes the product view and its associated dataset.

Working with 2D snapshots

2D snapshot overview

2D snapshots are dynamic objects that represent a 2D scene (a view of the base image and markups)
but are more than just image captures. You can have one or many snapshots associated with a BOM line
in your product structure. When you select a BOM line, Teamcenter displays the attached image dataset
in the 2D Viewer pane. If there are multiple images attached, you can select the desired image dataset.
You can:

• Use 2D snapshots to load base images and markups into the 2D Viewer pane and restore the saved
positioning information.

• Populate assets in technical illustrations with 2D snapshots.
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• Query 2D snapshots to find related item revisions and technical illustrations.

• Update 2D snapshots to reflect changes in base images and markups.

• Print 2D snapshots from Teamcenter.

• Send 2D snapshots to Lifecycle Viewer or a standalone application viewer.

You can create 2D snapshots from any file displayed in the 2D viewer.

To work with 2D snapshots in the 2D Viewer pane, you must activate the 2D Snapshots toolbar.

The 2D snapshot mechanism works best when the BOM structure used has a one-to-one relationship
between BOM lines and image datasets. Although the functionality works when this condition is not
satisfied, the user interaction is not as clean. This is especially true when the image datasets are revised.
As a result, Siemens Digital Industries Software recommends as a best practice to maintain a one-to-one
relationship between image datasets and BOM lines when establishing the BOM structure, if possible.

If you open the 2D Snapshot Gallery from Manufacturing Process Planner, see Manufacturing Process
Planning ─ Usage.

Create or add a 2D snapshot

1. Open an item revision with one or more attached image datasets (for example, a PDF file).

2. Click  to display the data pane.

3. Click the 2D Viewer tab.

The 2D viewer displays the first image dataset attached to the item revision.

4. If necessary, switch to the correct image dataset.

5. Navigate to the desired page if the base image contains multiple pages by selecting it from the
Page List section of the navigation tree.

6. Zoom and pan to the region of interest.

7. Create necessary markups.

8. Click  to open the Snapshot Gallery dialog box.

9. Click Add  or right-click in the Snapshot Gallery dialog box and choose Add.

10. (Optional) If you have activated the Attributes dialog box, define attributes for the 2D snapshot.

Create or add a 2D snapshot
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Note:

Teamcenter opens the Attributes dialog box automatically each time you create a 2D
snapshot when you choose Options→Show Attributes Form on Add.

Select an image dataset for viewing

If there are multiple image datasets attached to an item revision, you can select which one to use.

1. In the 2D Snapshots toolbar, click . .

Teamcenter displays the Select Dataset dialog box.

2. Select the desired image dataset from the list and click OK.

Open a 2D snapshot in the Lifecycle Viewer or a standalone application
viewer

1. Click  to open the Snapshot Gallery dialog box.

2. Select a snapshot.

3. Do one of the following:

• Select Send to Lifecycle Viewer in the context menu.

• Select Open in Lifecycle Visualization in the context menu.

• Click the Start/Open in Lifecycle Visualization  button in the toolbar.

Note:

This button is not available when incremental change is in effect.

Apply an existing 2D snapshot

1. With an item revision selected, click  in the 2D Snapshots toolbar in the 2D Viewer pane.

Teamcenter opens the Snapshot Gallery dialog box.

2. Do one of the following:

• Double-click a 2D snapshot in the list.

2. Viewing and managing data
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• Select the desired snapshot and click Apply.

Teamcenter opens the snapshot in the 2D Viewer pane. In addition, any markups, zoom, pan, and
rotation information active at the time the snapshot was created are also visible in the 2D Viewer
pane.

Populate the snapshot gallery

1. With an item revision selected, click  in the 2D Snapshots toolbar in the 2D Viewer pane.

Teamcenter opens the Snapshot Gallery dialog box.

2. From the shortcut menu, choose one of the following.

Choose To

Show All Load all 2D snapshots for the item revision of the selected BOM line
into the Snapshot Gallery dialog box.

Search Search all 2D snapshots for those containing specific attributes.

The results of the search are added to the Snapshot Gallery dialog
box.

Options→Show All on
Open

Load all snapshots associated with the selected BOM line when the
Snapshot Gallery is opened.

Search for a 2D snapshot

1. With an item revision selected, click  in the 2D Snapshots toolbar in the 2D Viewer pane.

Teamcenter opens the Snapshot Gallery dialog box.

2. From the shortcut menu, choose Search.

Teamcenter displays the Snapshot Search dialog box.

3. In the form, type values to define attributes for the 2D snapshot.

4. Click Search.

Teamcenter displays the results of the search in the Snapshot Gallery dialog box.

Populate the snapshot gallery
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Tip:

Display all snapshots associated with an item revision by choosing Show All from the
shortcut menu.

Update an existing 2D snapshot

You can only update a 2D snapshot if you have checked out the selected snapshot. You can only check
out a 2D snapshot if the selected snapshot was created from the currently open item revision. If you
have a different item revision open, use the Add or Replace menu commands.

1. Search for the desired 2D snapshot from the current item revision.

2. Select the image by double-clicking or clicking Apply.

3. Choose Check-In/Out→Check-Out from the shortcut menu.

4. Make any necessary changes to the view such as changing the zoom, panning into a different area
of the drawing, and adding or changing markups.

5. In the Snapshot Gallery dialog box, click Update.

Teamcenter updates the 2D snapshot with the changes that you made in the viewer.

6. Check in the 2D snapshot by choosing Check-In/Out→Check-In.

Tip:

Any changes you make in the 2D snapshot are not saved to the database until you check
in the snapshot. If you make a mistake with the markup, choose Check-In/Out→Cancel
Check-Out to revert the snapshot to its original state.

Replace a 2D snapshot

When you are working with multiple item revisions and the selected 2D snapshot is based on an item
revision older than the one you currently have open, you can replace the selected 2D snapshot with a
new one, and the old 2D snapshot remains associated with the old item revision.

1. With the snapshot that you want to replace open in the 2D viewer, and a newer item revision
than the one associated with the selected snapshot open, right-click the snapshot in the Snapshot
Gallery dialog box and choose Replace.

Teamcenter associates the newly created snapshot with the currently open item revision, leaving
the original snapshot associated with the original item revision.

2. Viewing and managing data
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2. (Optional) Define attributes for the 2D snapshot.

Note:

Teamcenter opens the Attributes dialog box automatically each time you create a 2D
snapshot when you choose Options→Show Attributes Form on Add.

Rename a 2D snapshot

1. Select a 2D snapshot in the Snapshot Gallery.

2. Choose Check-In/Out→Check-Out from the shortcut menu.

3. Choose Rename from the shortcut menu.

Teamcenter opens the Rename Snapshot dialog box.

4. Type the new name of the snapshot and click OK.

5. Check the snapshot back in by choosing Check-In/Out→Check-In from the shortcut menu.

Delete a 2D snapshot

1. Search for the 2D snapshot that you want to delete.

2. Select the snapshot and choose Delete from the shortcut menu or click .

Teamcenter deletes the selected 2D snapshot.

Note:

Teamcenter can only delete 2D snapshots that are not referenced by an existing document.

Compare a 2D snapshot to the current image

You can visually compare the current image with a 2D snapshot that was captured from a previous
revision of the base image dataset.

1. Open a newer item revision that contains a reference to the 2D snapshot that you want to
compare.

2. Select a 2D snapshot created from a previous revision in the 2D Snapshot Gallery.

3. Right-click the selected snapshot and choose Compare.

Rename a 2D snapshot
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4. Click the Compare Layers button.

Teamcenter displays the Compare Layer List dialog box.

5. Click OK

Teamcenter opens the current image dataset to the same view that was used to capture the 2D
snapshot in the previous revision and applies the same markup. You can then visually compare any
differences in the two image datasets.

6. Right-click the selected snapshot and choose End Compare.

Check out/check in a 2D snapshot

1. Search for the 2D snapshot that you want to check out.

2. Right-click the desired snapshot and choose Check-In/Out→Check-Out.

Teamcenter displays the CheckOut dialog box.

3. Click Yes to check out the snapshot.

Teamcenter automatically checks out the current version of the snapshot from the database to
prevent you from unintentionally overwriting another user's changes.

Tip:

Note that the checked-out 2D snapshot now has a green or red (if it is currently selected)
border in the Snapshot Gallery dialog box and its name is displayed in an italic font.

Define attributes for a 2D snapshot

You can define attributes that Teamcenter uses to search the 2D snapshots in the Attributes dialog box.

The checkin and checkout for the snapshot attributes are independent from the checkin and checkout
for the snapshot itself. You do not need to check out the snapshot to edit its attributes. Even if you have
the snapshot checked out, you still need to check out the attributes form to edit it.

1. In the 2D Snapshot Gallery dialog box, right-click the desired snapshot and select Snapshot
Attributes.

2. In the Attributes dialog box, click Check-Out and Edit.

3. In the CheckOut dialog box, click Yes.

2. Viewing and managing data
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4. Enter values into the boxes. By default, revision ID and page number of the base image are already
provided. Your administrator can configure which attributes are available by creating a custom form
and setting the VisSnapshot2DFormName Business Modeler IDE constant.

5. Click Save.

Teamcenter saves these attributes with the 2D snapshot.

6. Click Check-In to check in the changes or Cancel Check Out to discard the changes.

7. (Optional) To have Teamcenter display the Attributes dialog box each time you create a 2D
snapshot, choose Options→Show Attributes Form on Add.

Create custom forms for 2D snapshots

If you want to use custom 2D snapshot forms, your administrator must do the following:

1. Create a new business object with Vis_Snapshot_2D_Form as the parent.

2. Define the VisSnapshot2DFormName business object constant.

3. Set this constant to the name of the extended form.

Note:

When adding the new custom form, you must not modify the form storage class name that is
automatically set (name_of_custom_formStorage).

Create a 2D geometry asset

If you want to embed a 2D snapshot in a work instruction, you must create a 2D geometry asset for the
snapshot. You can create work instructions using Teamcenter Publish.

1. Right-click a 2D snapshot in the Snapshot Gallery dialog box.

2. Choose Options→Capture 2D Geometry Asset.

3. (Optional) Modify the graphic quality of the 2D geometry asset by choosing Options→Modify 2D
Geometry Asset Settings and adjusting the slider to the desired quality.

4. Create the 2D snapshot.

Teamcenter creates the 2D geometry asset while creating the snapshot.

Create custom forms for 2D snapshots
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Comparing structures graphically

About comparing structures graphically

You can compare two structures (BOMs) and view the results to identify differences. The BOMs can
contain different types of objects, such as mechanical parts, electrical parts, routes, and connections.
You can use the graphical comparison capability with released BOMs or with structures that are
configured by effectivity.

You can compare an assembly with an assembly, a part with a part, or two revisions of the same
assembly. If you compare two revisions of an assembly, Teamcenter identifies the following supersedure
information:

• Adds

These are objects that are in the target assembly but not in the source assembly. They have been
added to the assembly.

• Cancels

These are objects that are in the source assembly but not in the target assembly. They have been
removed from the assembly.

• Moves

These are objects that are in different positions in the source assembly and target assembly. Any
object whose transform matrix differs between the source and target is identified as repositioned.

• Reshapes

These are objects that have alternate representations between the source assembly and target
assembly. Any object identified with a UG ALTREP note type is identified as reshaped.

• Common

These are objects that are in both the source assembly and target assembly.

Compare two BOMs

1. Choose View → Show Second Structure Panel to open the second structure pane.

2. Open the two BOMs in the separate structure panes, with the source in the one pane and the target
in the other.

3. Apply any revision rules or effectivity needed to configure the structures for the comparison.

2. Viewing and managing data

2-30  Multi-Structure Management, Teamcenter 2412
© 2025 Siemens



4. Choose Tools → Graphical BOM Compare.

Teamcenter analyzes the BOMs to identify any differences and displays the Graphical BOM
Compare dialog box containing a visual indication of those differences.

Depending on the type of comparison, you can use the tools and controls in the window to change
the view and examine differences more closely.

If you compare two versions of an assembly under change control (for example, a problem item
and an affected item of an engineering change), Teamcenter displays a list of supersedures.

5. Click Close to close the window on completion.

Set color options

You can change the default colors in which differences and supersedures are displayed in the Graphical
BOM Compare dialog box as follows:

1. Choose Edit → Options.

Teamcenter displays the Options dialog box.

2. Choose Change Management → BOM Tracking from the list of options.

Teamcenter shows the list of current colors assigned to the Graphical BOM Compare dialog box.

3. To change the color assigned to a difference type, double-click the current color assignment.

Teamcenter displays the palette of available colors. Click the required new color and click OK or
Apply to change the color; alternatively, you can click Cancel to exit without changing the color.

Working with markups

Adding and deleting markups

When an image is loaded in the viewer, you can add markup layers to the image. You can mark up JT
files that are attached to DirectModel datasets or schematic geometries. You can also view images in
JPEG or BMP formats that are attached to a schematic geometry. To view and mark up schematics, your
administrator must set the TC_Schematic_BOMView_Types preference to on.

Markups are text or graphical elements that you draw in the viewer with your model or schematic. 3D
markups display on 3D layers.

Markups may include lines, rectangles, polygons, ellipses, inset images, and text.

Set color options
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Anchored text markups can include part information and metadata attributes.

To create or modify markups, display the relevant toolbar by right-clicking the Lifecycle Visualization
base toolbar and choose the appropriate command from the shortcut menu.

Note:

If you are working with schematics, only a limited set of functions are available. The following
options do not apply to schematics: edit color/translucency, insert, view control, export 3D,
reposition, rotate, PMI, clearance, cross-section, navigation, and visibility.

Working with 3D and schematic markups

Create a 3D markup dataset

You need to create a DirectModel3DMarkup dataset to store 3D markups of structures or assemblies.

Note:

You MUST HAVE at least the Teamcenter lifecycle visualization standard configuration installed to
work with 3D markups.

1. Load the structure or assembly (DirectModel dataset) in the viewer.

Teamcenter displays the model and the Lifecycle Visualization toolbar.

2. Click the Create Markup  button.

Teamcenter displays the Create Markup3D Dataset dialog box.

3. In the dialog box, type a name for the dataset in the Dataset Name box.

4. (Optional) Type a description of the dataset.

5. Click OK.

Teamcenter creates the DirectModel3DMarkup dataset and attaches it to the DirectModel
dataset.

You can create multiple DirectModel3DMarkup datasets under a single structure or assembly. Each
DirectModel3DMarkup dataset can contain multiple markup layers.

2. Viewing and managing data
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Note:

Markup layers are stored as VPL files.

Draw 3D markups

Perform the following steps to draw markups on structures, assemblies, or schematics:

1. On the 3D Markup toolbar, click Enable Markup .

2. (Optional) To change colors, fill styles, line and edge styles and sizes, and font styles and sizes, click
Preferences .

3. (Optional) To draw a filled ellipse, polygon, rectangle, or text markup, click Fill .

4. (Optional) To attach the markup to a point on the model or schematic click Anchor .

Anchored markups display, hide, and move with their attached parts. Anchored text markups are
attached to parts with leader lines.

5. (Optional) Create or select a layer for the markup. If you do not have a markup layer, one is created
when you add the first markup.

6. Specify the markup type by clicking the corresponding button on the 3D Markup toolbar.

Teamcenter changes the cursor to indicate the type of markup.

7. Place the markup in one of these ways:

To place this markup Perform these actions

Line a. (For an anchored markup) Select a point on the model
or schematic.

b. In the viewer, drag the mouse pointer to draw a line.

c. (Optional) To draw a horizontal or vertical line, press
and hold the shift key as you drag.

Polyline a. (For an anchored markup) Select a point on the model
or schematic.

b. In the viewer, click to place one endpoint.

Draw 3D markups
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To place this markup Perform these actions

c. (Optional) To draw horizontal or vertical polyline
segments, press and hold the shift key.

d. Click to place each vertex.

e. Double-click to place the last vertex.

Freehand line a. (For an anchored markup) Select a point on the model
or schematic.

b. In the viewer, drag the mouse pointer to draw.

Rectangle a. (For an anchored markup) Select a point on the model
or schematic.

b. In the viewer, click to place one corner.

c. Drag the mouse pointer, and then release to place the
opposite corner.

d. (Optional) To draw a square, press and hold the shift key
as you drag.

Polygon a. (For an anchored markup) Select a point on the model
or schematic.

b. In the viewer, click to place each vertex.

c. (Optional) To draw horizontal or vertical segments,
press and hold the shift key as click.

d. Double-click to place the last vertex.

Ellipse a. (For an anchored markup) Select a point on the model
or schematic.

b. In the viewer, drag the mouse pointer to draw.

c. (Optional) To draw a circle, press and hold the shift key
as you drag the mouse pointer.

Inset image a. In the Open dialog box, select the image dataset and
click Open.
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To place this markup Perform these actions

b. (For an anchored markup) Select a point on the model
or schematic.

c. In the viewer, drag the mouse pointer to place and size
the image.

Text a. (For an anchored text markup) Select a point on the
model or schematic. Teamcenter displays the Markup
Text dialog box.

b. (Optional for an anchored text markup) In the Markup
Text dialog box, click Advanced to add part information
or metadata attributes.

c. (For a floating text markup) Click a point in the viewer to
place the text markup. Teamcenter displays the Markup
Text dialog box.

d. (Optional) Change the font, size, and style of the text.

e. (Optional) To change the shape in which the text
appears, from the Bounding shape list, choose the
None, Rectangle, or Circle.

f. Type the text of the markup in the Text box.

g. Click OK.

URL a. Place a text or inset image markup.

b. Right-click the markup, and choose Properties.

c. In the Properties dialog box, click the Hyperlink tab.

d. In the Link Specification box, type the URL, or click
Browse and browse to the appropriate file path. You can
link to any type of file. The application that is associated
with the file type opens and displays the file.

e. Click OK.

f. To navigate to the URL or launch the referenced file,
double-click the link.

Draw 3D markups
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To place this markup Perform these actions

Note:

When you open a URL for an animation (VAN) file, the
animation plays automatically.

To create a URL markup that opens the default E-mail
program and addresses a message, type mailto: in the
Address box. When you double-click the link, the E-mail
program is launched and a message is addressed to the
specified address.

The markup appears in the viewer, with a list of markups under the selected markup layer. If Teamcenter
displays an asterisk (*) before the markup layer name, changes were made to the markup layer since it
was last saved.

Note:

If you open a 3D model that includes an anchored text markup that is anchored to an item that has
been removed from the current 3D model or moved to a different structure in the same 3D model,
when the 3D model file opens, the leader line does not appear and the text of the 3D markup
appears in red.

Create a 3D markup layer

Create a 3D markup layer using one of the following methods:

Initial markup layer

1. Ensure a 3D markup is visible.

2. Click the Save Layers ( ) button on the Lifecycle Visualization base toolbar.

The system displays the Save Layer dialog box.

3. Type a name for the new layer in the Name box and click OK.

Teamcenter displays the new layer in the Markup Layers list.

Note:

The Markup Layers list does not display until you create a 3D layer.

Additional markup layers
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1. Right-click in the Markup Layers list and choose New Layer from the shortcut menu.

Teamcenter displays the Save Layer dialog box.

2. Type a name for the new layer in the Name box and click OK.

Teamcenter displays the new layer in the Markup Layers list.

Note:

The Markup Layers list does not appear until you create a 3D layer.

Open 3D markup layers

• Select a 3D Markup dataset.

Teamcenter opens the Markup Layers list containing the saved layers for the dataset.

Save 3D markup layers

When you create or edit a 3D layer, an asterisk (*) appears before the name of the layer in the Markup
Layers list until you save the layer. When you save the layer, the asterisk disappears until the layer is
edited again.

Save 3D layers together or separately. Perform the following steps to save layers:

1. From the Markup Layers list, select the layer that you want to save.

2. Right-click and choose Save Layer from the shortcut menu.

Teamcenter removes the asterisk next to the layer name in the list.

Delete 3D markup layers

1. Right-click the DirectModel3DMarkup dataset in the tree.

Teamcenter displays the Dataset Object menu.

2. Choose Named References.

Teamcenter displays the Named References dialog box.

3. In the named reference table, select the markup layer that you want to delete.

4. Click the Cut  button.

Open 3D markup layers
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Teamcenter removes the layer from the named reference list.

5. Click the Close button.

Teamcenter closes the Named References dialog box.

Control the display of 3D markup layers

To Perform these actions

Display or hide 3D layers Select or clear the state indicator to the left of the layer name in the
Markup Layers list.

Save all layers Save all the 3D layers, separately, with their current file names.

Save layer Save the selected 3D layer.

Save layer as Save the selected 3D layer with a new file name.

Capture view Capture the orientation of the model and markup as seen in the
viewer for the selected layer.

Apply view Restore the captured view for the layer selected.

Hide view Hide the captured view for the layer selected.

Working with 2D markups

View 2D images

1. Select the DirectModel dataset in the navigation tree or Properties table and click the Viewer tab.

Note:

To view a named reference of the DirectModel dataset, right-click the dataset in the tree,
choose Visualize Named Reference from the Dataset Object menu, and choose the named
reference file that you want to view.

Teamcenter displays a message indicating that you are about to view a JT assembly and verifying
that you want to download all the components of the assembly.

2. Click OK to download the components.
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3. Click the Image Capture  button in the viewer pane. The Create Markup Layer dialog

box appears, allowing you to create a DirectModelMarkup dataset and attach it to the original
DirectModel dataset as a markup relationship. The Viewer pane now contains a Markup Layers
tree to the left of the graphical display.

Compare 2D image layers

You can compare image layers when you want to:

• Display common areas and differences.

• Display the common areas of both layers, one of the comparison layers, or all of the comparison
layers.

• Change the colors of one or both image layers in your comparison.

1. Choose two 2D image datasets in the navigation tree.

2. Choose Compare 2D Images from the View menu.

Teamcenter displays the images in the Viewer tab and displays the 2D Compare toolbar.

3. Perform one of the following tasks:

To Perform these actions

Display only the compare layer
(common areas of both layers)

Click the Display Compare Layer button  on the 2D
Compare toolbar. Only the compare layer is displayed in
the Viewer tab. The information that is common to both
layers is drawn in black.

Display one layer and not the other Click the Display 1st Layer button  or the Display

2nd Layer button .

Display all comparison layers Click the Display All Layers button . All the
comparison layers are displayed. Unless you have
changed the color preferences, the first layer is green;
the second layer is red; the comparison layer is black.

Create 2D markups

1. Select the 3D format (DirectModel) of the object that you want to revise.

2. Click the 2D Markup button  in the viewer pane.

Compare 2D image layers
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Teamcenter displays the Create Markup Layer dialog box.

3. Type the name of the markup layer that you are creating in the Name box.

4. Select the type of file from the File Type list.

5. Type a brief explanation of the markup layer's purpose and content in the Description box and click
OK.

The new markup layer can be found in the Properties table, or by expanding the DirectModel
object in the tree.

Create 2D markup layers

You can use DirectModelMarkup and Markup datasets to create a new markup layer for a 2D format
image, as follows:

1. In the navigation tree, select a DirectModelMarkup or Markup dataset for the object that you
want to revise and click the Viewer tab.

2. Mark up the 2D image using the markup toolbar.

3. Save the markup layer in the new dataset component.

4. Click the Save 2D Markup button .

Teamcenter displays the Save Layer dialog box.

5. Type the name of the layer that you are creating in the Name box and click OK.

Teamcenter generates a 2D file, stores it in the current dataset and displays it in the Markup
Layers tree. If multiple markup layers are created in the same session, they can all be saved
simultaneously. Teamcenter displays a separate Save Layer dialog box for each saved layer.

Expand partially loaded structures

When Teamcenter displays a BOM or manufacturing view containing the results of a search, the siblings
of the node you searched for are hidden so the search results are displayed quickly. Each hidden node is
represented by a … symbol enclosed in a box. The ancestors of the found node are loaded and visible.

The following figure shows how a partly loaded structure displays in the engineering BOM. In this
example, three nodes are hidden and these nodes are siblings of the stud-031–18x075/A node found by
the search.
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Partially loaded structure in engineering BOM

About process configuration

A manufacturing process plan consists of three interconnected structures:

• Product

• Processes and operations

• Work area

Configuration management helps you define and apply variant rules to each of these structures
independent of the other structures.

Because the process structure can have its own lifecycle and variability, lines in a process can configure
out in one of the following ways:

• By occurrence effectivity

If you add an operation with occurrence effectivity, it is configured out when it is not effective. Show
these lines using View→Show Unconfigured Data→Show Unconfigured by Occurrence Effectivity.

The default state of this button is determined by the
MEShowUnconfiguredOccurrencesEffectivityDefaultState preference.

• By incremental change effectivity

If you make changes with an incremental change (IC) and if it carries effectivity, the changes
related to it are configured out if it is not effective. Show these changes by choosing View→Show
Unconfigured Data→Show Unconfigured Changes.

About process configuration
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The default state of this button is determined by the MEShowUnconfiguredChangesDefaultState
preference.

• By variants/options

If a BOM line carries a variant condition making it valid for a certain set of options, it is configured
out for a different option set for which it is not valid. Show these lines by choosing View→Show
Unconfigured Data→Show Unconfigured Variants. Using this menu command also shows objects
that were configured out using effectivity.

The default state of this button is determined by the MEShowUnconfiguredVariantsDefaultState
preference.

• By reference window

If you have a composition-type process, a line (for example, a consumed item) may be configured
out because it is configured out in the reference or parent window on which it is based. Teamcenter
does not differentiate why it was configured out in the other window. Show these lines by choosing
View→Show Unconfigured Data→Show Unconfigured Assigned Occurrences. In this case, the
lines are gone from this process window because they are configured out of the parent structure. It is
irrelevant whether they are configured out of the parent structure because of occurrence effectivity,
incremental change effectivity, or variants/options.

The default state of this button is determined by the
MEShowUnconfiguredAssignedOccurrencesDefaultState preference.

The following preferences play a role in what processes you see when child processes are configured out:

• controllingOccsForProcessConfiguration

• typeAndRuleForProcessConfiguration

Reconciling broken links

About broken links

Changes to the product or plant structure are not automatically updated in the process tree where the
occurrence is referenced. This results in a broken link. With this feature, you can identify broken links
and search for the possible occurrence that was originally defined, for example, as a consumed part.

When you expand a process to display linked items, each link line includes a symbol indicating the state
of the reference:
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Symbol Description

Occurrence is linked to a product or plant structure.

Link is broken.

Occurrence is linked to a product or plant structure that
is not currently loaded, or a product or plant structure is
loaded but not currently configuring the process structure.

Note:

Teamcenter retrieves the status of a link from a run-time property, Mfg0LinkState.

When performing the search for broken links, Teamcenter searches through process structures that you
specify and looks for broken links. It then looks through product or plant structures that you specify
for likely candidates to repair these links. The search is based on criteria that you can specify in the
MPP_DefaultCandidateSearchCriteria preference. Once found, you can have Teamcenter repair these
links automatically, or you can choose to select candidates manually from the candidates list.

Your administrator can save search criteria for you to use. You can further modify these criteria and save
your modifications to the saved criteria.

When there are many broken links and each broken link has many candidates, a large amount of
memory is required for high-speed processing. If the total number of broken links and candidates is too
large, for example, 32,000 lines, the memory usage may be a concern if you are performing the search
on an underpowered computer. To speed up the search, divide the search scope into smaller pieces to
reduce memory usage; for example, select subnodes instead of the root node.

The following properties are supported in a search for broken links:

• A selection of BOM line properties:

Item Id
Find number
Quantity
Usage Address
Reference Designator
Position Designator

• All types of occurrence notes

• Any extended or custom properties your administrator creates

• Properties found on the weld attribute form

About broken links
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Identify broken links

1. Open the process in which you want to search for broken links.

2. Open the product/plant structure in which you are looking for likely link candidates in the second
pane by right-clicking the tab and choosing Open Structure in Second Panel.

3. Select a product or plant structure as the scope for the candidate search. You can select multiple
lines.

4. Select a process or operation as the scope for the broken link search.

Teamcenter searches from the selected object down through all leaf nodes. If you do not make a
selection, Teamcenter uses the root node as the scope for the search.

5. Choose Tools→Repair Broken Links.

Teamcenter displays the Repair Broken Links dialog box.

6. Modify the scope for the broken link candidate search by adding or removing product structure
lines. Do this by selecting them in the product structure and clicking Set/Add current selection .

7. (Optional) Modify the search criteria.

8. To set a revision rule, click Alternative Revision Rule.

You can choose to view or set the revision rule, enter the end unit/date, or set an override folder.

9. Choose whether you want to perform a quick or a more thorough search in the Structures
Traversal section.

Click To

Visible Structure Search through the launched, loaded structure (all the
currently expanded and visible lines). The quick search does
not include nodes that have never been expanded (that is,
nodes that are not loaded) or are hidden due to effectivity or
variant conditions.

Full Structure Search through the complete tree in the launched structures,
loading as necessary. The search expands collapsed
(unloaded) nodes; it does not include nodes hidden due to
effectivity or variant conditions.

10. To search for broken links only, and not perform the more time-consuming candidate search, clear
Include Candidates.
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11. To have Teamcenter repair the links automatically, select Automatic Repair.

Teamcenter searches for eligible candidates in the product or plant structure and, if only one
candidate is found, automatically creates a relationship of the same type as the broken link
between the process line and the lone candidate.

12. Click Search.

Teamcenter searches for all broken links from the selected process node down to the leaf nodes
and displays them in the Broken Links list. If you select Include Candidates, it also searches for all
candidates that fulfill the search criteria and displays them in the Candidates list.

If you select a line in the process structure on which to perform the search with multiple broken
links in the substructure, and Automatic Repair is active, all broken links for which Teamcenter
finds a unique candidate are repaired.

Repair broken links

1. Search for broken links.

2. Select the broken link that you want to repair from the Broken Links list.

3. (Optional) Click Show in Tree to see the line containing the broken link highlighted in the process
structure.

4. Select the candidate to which you want to relink the process line in the Candidates list.

5. (Optional) Click Show in Tree to see the candidate for repair highlighted in the product or plant
structure.

6. Click Repair.

Teamcenter relinks the process line to the product or plant line and the symbol is updated in the
Broken Links list to show the link is no longer broken. You can select multiple pairs of broken links/
candidates before clicking the Repair button. Teamcenter remembers your choices and processes
all the pairs that you select.

Modify search criteria

By default, when searching for candidates to repair broken links, Teamcenter examines the properties
listed in the search criteria that you select from the Stored Criteria list. If the criteria of a perspective
candidate match the values in the search criteria, the candidate is proposed as a replacement.

1. Select a search criteria from the Stored Criteria list.

The choices shown are saved by your administrator.

Repair broken links
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2. Click Edit beside the Stored Criteria box and add BOM line properties by clicking the Add 
button.

Teamcenter adds new properties to the criteria list in the order in which they are displayed in the
columns of the process view. To display more properties, you must first add new columns with the
desired properties to the process view.

Note:

If a property is added by a preference, its name is displayed as the internal property name.

3. Designate whether the properties should be considered as mandatory or optional by clicking in the
cell and selecting a value.

4. Enter a property value.

You can use the * wildcard symbol or a space between characters.

5. (Optional) Save the modified search criteria by clicking Save Criteria.

You can only modify search criteria that were saved by your administrator. You cannot modify the
MPP_DefaultCandidateSearchCriteria search criteria.

Working with packed lines

Packing or unpacking structure lines

Grouping multiple identical components in one level of an assembly is known as packing. You can pack
components if they satisfy all of the following requirements:

• They have the same item revision.

• They have the same find number.

• None have variant conditions or they all have the same variant condition.

For example, if a bicycle designer is working on a wheel hub design, it is time-consuming to negotiate
50 individual spokes within the wheel assembly, if each spoke is identical except for its position. All that
is necessary is a Spoke x 50 entry.

Note:

A customizer can use an ITK function to register a different algorithm for packing criteria.
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Restrictions on packed lines

The following restrictions apply to all lines in the structure that are packed:

• You cannot edit the Quantity value.

• If any of the packed lines have notes, the notes are replaced by the text Packed Notes. If none of the
packed lines has notes, the notes are blank. In both cases, you cannot edit the notes.

• Item and item revision attributes such as part name, weight, and cost remain visible and can be edited
if you have the appropriate permissions.

• You can modify the find number. Any such modification applies to each line in the structure and is
visible if the structure is unpacked.

• If any of the packed lines has a substitute, the packed line shows Packed Substitutes in the
Substitute column. The pack count includes the substitutes.

Pack structure lines

To pack lines in the structure that meet the packing criteria, select any one of the lines and choose Pack
in the View menu. Alternatively, you can click the Pack button in the toolbar.

In the case of the bicycle example, this action collapses the 50 lines in the product structure into one
line representing all spokes and indicated by the  image. A x 50 property is appended in the node of
the single line and the Quantity box shows the value 50. Teamcenter shows a Y character in the Packed
column, if that column is displayed.

Note:

Teamcenter makes no distinction made between the sum of a number of separate occurrences or
an aggregate occurrence displayed in the Node column or the Quantity column. However, the
Pack Count column shows the number of lines that have been packed.

Unpack structure lines

To unpack lines in the structure, right-click the single packed line and choose the Unpack menu
command, or press the CTRL+N keys. The packed line separates into individual structure lines, each
with its own set of attributes. You can edit these individual attributes.

By default, all components are initially packed to save space.

You can change this behavior by editing the Pack by Default preference.

Restrictions on packed lines
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Pack all or unpack all lines

Choose Pack All or Unpack All from the View menu to pack or unpack all lines in the currently selected
window, if the necessary packing conditions are met.

Note:

• Unpack All unpacks all packed lines in the currently expanded structure.

• Unpack All does not unpack or expand lines in unexpanded structure.

• After selecting Unpack All, the unpacked lines are in an unexpanded state.

Packing or unpacking lines with reference designators

You can pack or unpack product structure lines that include reference designators. For example, if
you pack eight occurrences of the same part with different reference designators, the Ref Designator
property column shows a concatenated set of reference designators, for example, C1, C5-7, C10,
C14-16. You cannot edit the reference designators of packed lines.

Note:

There are additional rules that determine general packing rules, as described previously. This
preference only controls reference designator packing.

You can also unpack packed lines that include concatenated reference designators. Each unpacked line
shows a single reference designator, for example, C1.

Teamcenter validates the correct reference designator format. All reference designators must be in the
format prefix number, where prefix is a string of one or more uppercase letters and number is an integer.

You can search for reference designator values. As with other product structures searches, this is a
wildcard search; if you search for C1, the system actually searches for *C1*. You can also include
reference designators in structure comparisons.

You can specify the reference designator values in the International Organization for Standardization
(ISO) and in the American Society of Mechanical Engineers (ASME) formats. In the ASME format, the
reference designator value is in the capital letter followed by a number and suffix letter. For example,
S1A.

Add to favorites

1. Right-click a line in the structure pane and choose Add to Favorites.

The Favorites dialog box appears.

2. Viewing and managing data
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2. Click OK.

The object is displayed in the Favorites list in the navigator pane.

Assign components or assemblies

If two structure panes (sometimes called companion panes) are visible, you can select any assembly or
component in the BOM tree in one pane and assign it to the BOM tree in the other pane as its children.
When you do this, the BOMs share the absolute occurrences of the assigned children. This allows you to
search between the BOMs to locate these shared absolute occurrences. You can make such assignments
in two ways:

• Select the assembly or component and choose Tools→Assign. You can also right-click the selected
item and choose Assign from the shortcut menu.

-or-

Right-click the selected item and choose Assign As from the shortcut menu. You can then specify the
occurrence type for the assigned component.

Working with collaboration context rules

Managing rules

You can manage cloning and variant rules associated with a collaboration context. You can cut and
paste rules to the configuration associated with a configuration context or structure context in the
collaboration pane. You can also modify the revision and variant rules associated with a structure
context with the Tools→Save Configuration menu command as follows:

• To modify the rules associated with the BOM view, use the revision rule and variant rule buttons and
menu commands. You can save the modified configuration as the structure context's configuration by
choosing Tools→Save Configuration.

Caution:

Modifying a revision rule or variant rule affects your view, but does not affect the structure
configuration in the database until you explicitly save the changes.

• You can set the BOM view's rules to the same rules as any other configuration in the database by
clicking Set View Configuration, then browsing to the required configuration. You can then save
these rules to the structure context's configuration by choosing Tools→Save Configuration.

• You can modify the rules, then choose Tools→Save Configuration to create a new configuration. You
can modify the structure's configuration by clicking the Paste to Structure button on the Save dialog
box.

Assign components or assemblies
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Managing variant rules

A structure may be configured according to selected options defined through variant rules. These variant
rules are then applied to the structure. In addition, revision rules and the release status of a component
also dictate what is configured for a given top-level end item. Any changes to a product structure
affect the manufacturing steps needed to manufacture that product. Process structures are automatically
configured by removing operations that consume items not configured from the product structure.

Any BOM lines containing variant conditions are indicated with a variant symbol next to the BOM entry.

Assign variant conditions

Use the following steps to add variant conditions to a structure to configure these items independent of
the end item:

1. To apply the variant conditions, select a line in the structure pane.

2. Choose Edit→Variant, or click the Variant button on the toolbar.

The dialog box appears to allow you to define variant conditions for the selected object.

Apply variant rules

Use the following steps to apply existing variant conditions to structures:

1. To apply the variant rules, select a line in the structure pane.

2. Choose Tools→Variant Rule, or click the Variant Rule button on the toolbar.

Enter the value for the variant rule in the dialog box.

3. Click OK or Apply to configure the current structure using this variant rule.

Viewing a process structure

If you have a process structure contained within a collaboration context, you can use the cc_writer
utility to send this structure to Teamcenter lifecycle visualization mockup for viewing.

For more information, see Teamcenter Utilities.

Manage drafting symbols and GDT symbols

Your administrator can configure any form to contain geometric dimensioning and tolerance symbols
or rich text in forms. You can include geometric dimensioning and tolerance symbols in any box of a
form but, in practice, this is done in fields intended for engineering data. For example, a box titled Work

2. Viewing and managing data
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Instruction is a good candidate for geometric dimensioning and tolerance symbols, while a box titled
Quantity is not.

To Do this

Add or edit symbols in a form 1. Display the form in the Viewer tab.

2. Click Edit.

Teamcenter displays the Change GD&T Symbols
dialog box.

Add or edit drafting symbols 1. Click the Drafting Symbols tab.

2. Click one or more of the predefined symbol buttons.

Add or edit GDT symbols 1. Click the GDT Symbols tab.

2. Click one or more of the predefined symbol buttons.

Format rich text Use the buttons on the Drafting Symbols tab.

Save changes and exit Click Edit.

Manage drafting symbols and GDT symbols
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3. Working with collaboration contexts
Overview of creating a collaboration context

There are two methods used to create a collaboration context:

• Top down:

1. Create an empty collaboration context.

2. Create empty structure contexts within the collaboration context.

3. Fill up the content of the new structure context by inserting items.

• Bottom up:

1. Open desired objects.

2. Save these objects as structure contexts.

3. Save all structure contexts in the session to a new collaboration context or move structure
contexts into an existing collaboration context.

You can create a collaboration context for each instance of a collaboration between applications within
Teamcenter or between Teamcenter and an external application. For example, if your Teamcenter
system connects to a Tecnomatix system, you must define a single collaboration context to allow the
two systems to share data.

Create a new collaboration context

How you create collaboration contexts depends on the method you use to build your collaboration
context structure.

• If you use a top down method:

1. Choose File→New→Collaboration Context.

Teamcenter displays the New Collaboration Context dialog box.

2. Choose a collaboration context type from the list.

• Your administrator can create additional types as necessary with the Business Modeler IDE
administration application.
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• Teamcenter places the types of collaboration context you previously created in the Most
Recently Used list.

3. (Optional) Select Open on Create.

If you select this option, Teamcenter opens the new collaboration context in the application
directly after creation.

Tip:

If you do not select this option, you can find the new collaboration context in the Newstuff
folder in My Teamcenter.

4. Click Next.

5. Type a name in the Name box.

Mandatory parameters are marked by a red asterisk.

6. (Optional) Type a description of the collaboration context.

7. Click Finish.

Note:

You can create a collaboration context in Multi-Structure Manager, Manufacturing Process
Planner, Part Planner, Multi-BOM Management, and My Teamcenter.

If you selected Open on create, Teamcenter displays the context as a top-level line. If a collaboration
context was previously open, Teamcenter closes it and loads the new collaboration context.

Teamcenter always stores the new collaboration context in the Newstuff folder in My Teamcenter.

• If you use a bottom-up approach to creating collaboration contexts, you can also create a new
collaboration context that contains an existing structure context.

1. Select the structure context in the collaboration pane.

2. Choose File→Save as→Save as New Collaboration Context.

For more information, see Save objects as collaboration contexts.

3. Working with collaboration contexts
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Save objects as collaboration contexts

You can save loaded structures, including studies, to a new collaboration context. Teamcenter creates
a structure context from each loaded structure that you include in the collaboration context if is not
already contained in a structure context.

1. Select a root line of an object in the collaboration pane and choose File→Save as→Save as New
Collaboration Context.

Teamcenter displays the Save as New Collaboration Context dialog box.

2. Type a name and description for the new collaboration context in the Name and Description
boxes.

3. Select a type of context from the list. Click More to see a complete list of structure context types.

Your administrator can create new collaboration context business objects (types) in the Business
Modeler IDE.

4. For each structure in the list on the left that you want to save, enter the following
information. Your administrator can change the existing defaults for this information in the
Default_StructureContext_Type preference.

• Name of the structure context

• (Optional) Description

• Type of the structure context

• Type of the configuration context to be created for this structure context

If the structure is already a part of a structure context, you can see this information when you
select the structure in the structure list. Even if a structure is already part of a structure context,
Teamcenter creates a new structure context for the structure that is based on the existing one and
includes any modifications made to the current structure.

5. (Optional) If you want to save loaded structures to a new collaboration context that captures linked
released studies or all studies, review the Include Studies list and select the studies to include.

6. (Optional) Select the Open On Create option to open the new collaboration context in the
collaboration pane.

Note:

When you open a new collaboration context, any currently open one is unloaded.

Save objects as collaboration contexts
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• The new collaboration context is opened.

• Any root structure that is participating in the new collaboration context is no longer displayed as
a separate root, but only as part of the new collaboration context.

• Any other collaboration context containing structure context objects that were chosen to
participate in the new collaboration context object are unloaded.

7. Click OK.

Teamcenter collects all of these structure contexts into the new collaboration context. In addition,
it creates a configuration context within the structure context containing the revision and variant
rules currently applied to the object. It clones or references the revision and variant rules of the
existing structure, according to the following rules:

• If the current revision rule is saved as public, it creates a reference to it.

• If the current revision rule is modified and not saved, it clones the modified rule to create a
private revision rule for the configuration context.

• If the current variant rule is saved as public, it creates a reference to it.

• If the current variant rule is modified and not saved, it clones the modified rule to create a private
variant rule for the configuration context. If the variant rule is cloned, it is not linked to the top
line item in the structure.

Each new structure context refers to all of the occurrence groups that have manufacturing views
(visible tabs) when you save it.

Note:

If you try to save a structure that is configured by multiple variant rules, you must set the
DisableSaveSOS preference to true.

Overview of creating a structure context

You can create a structure context and add it to the current collaboration context. You can create
any valid structure context, including a product or process to include in a collaboration context. If no
collaboration context is open, Teamcenter adds the new structure context to the database for later
assignment.

The structure context may be a composition, depending on its type. Items in a composition structure
may have relationships to other structures or to absolute occurrences and occurrence groups.

If the structure context is a composition:

3. Working with collaboration contexts
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• Each target line in the structure context refers back to the source line, as indicated by the  symbol.
You can use the Tools→Find in other panel command to identify the related source from the target
or vice versa.

• Occurrence data is retrieved from the source line to the target line when you open the target structure
context; it is not copied. Absolute transforms, absolute occurrence identifiers, and variant conditions
are retrieved; occurrence notes are not retrieved.

• No absolute occurrence identifiers are created during assignments. However, if you specify an
absolute occurrence identifier in the source, Teamcenter shows it in the ID at All Levels property
column, not on the top level.

• If you change occurrence data on the source, the change is inherited by the target unless you override
the corresponding data on the target.

• If you change occurrence data on the target, Teamcenter does not change the corresponding data on
the source. This allows you to reposition lines in the target, for example, to move assemblies to give a
different structure or insert lines to represent consumables.

Note:

When you change item or item revision attributes (for example, the revision master form), the
values Teamcenter displays depend on the revision rule that configures the source and target.
These attributes are independent of occurrence data.

• Revision or variant rules applied to the source also configure the target.

If the structure context is not a composition:

• The target line in the structure context does not refer back to the source line. However, you can use
the Tools→Find in other panel command to identify the related source from the target, or vice versa.

• Occurrence data is copied from the source line to the target line, including absolute transforms,
absolute occurrence identifiers, variant conditions, and occurrence notes.

• The absolute occurrence identifier is populated during the assignment process and, if you already
enter a value in the source, the same value is copied to the target. If the value is empty, the source is
populated with the UID.

• If you change occurrence data on the source, the change is not propagated to the target.

• If you change occurrence data on the target, Teamcenter does not change the corresponding data on
the source.

Overview of creating a structure context
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• When you change item or item revision attributes (for example, the revision master form), the
values Teamcenter displays depend on the revision rule that configures the source and target. These
attributes are independent of occurrence data.

• If you change occurrence data on the target, Teamcenter does not change the corresponding data on
the source. This allows you to reposition lines in the target, for example, to move assemblies to give a
different structure or insert lines to represent consumables.

Note:

When you change item or item revision attributes (for example, the revision master form), the
values Teamcenter displays depend on the revision rule that configures the source and target.
These attributes are independent of occurrence data.

• Revision or variant rules applied to the source have no impact on the target.

Create a structure context

1. Choose File→New Structure Context.

Note:

You can create a structure context in My Teamcenter by clicking File→New→Structure
Context to open the New Structure Context dialog box.

Teamcenter displays the New Structure Context dialog box.

2. Select a structure context type from the list.

Teamcenter places the types of structure context you previously created in the Most Recently Used
list.

3. Click Next.

4. Type a name in the Name box.

Mandatory parameters are marked by a red asterisk.

5. (Optional) Type a description of the collaboration context.

6. Choose a configuration context:

a. Click Configuration Context .

Teamcenter displays the Find Configuration Context by Name dialog box.

3. Working with collaboration contexts

3-6  Multi-Structure Management, Teamcenter 2412
© 2025 Siemens



b. Type the name or part of the name of the configuration context in the Name box.

c. Click Find.

Teamcenter displays the contexts matching the name criteria in the table.

d. Double-click a context in the results table.

Teamcenter closes the dialog box and displays the name of the context in the New Structure
Context dialog box.

7. Click Finish.

The new structure context appears as a line in the BOM under the current collaboration context.
If you did not select a configuration context in the previous step, Teamcenter creates a structure
context with the system's default configuration, which is generally:

• The default revision rule, typically Latest Working.

• No variant rule.

Adding objects to a structure context

You can add objects to the current structure context as development progresses.

If the structure context is defined as a composition, the structure context can show references to
occurrences and occurrence groups that composition structures such as processes and operations may
include.

You can add the following objects:

• Root objects

You can add occurrence groups, items, and item revisions to the current structure context, including:

• Product items
• Product and factory views
• Processes
• Classified resources

To create and add a new root object, choose the appropriate menu command, File→New→Item or
File→New→Occurrence Group.

To add an existing root object, copy and paste it into the structure context in the Multi-Structure
Manager collaboration pane.

Adding objects to a structure context
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• Objects in the structure

You can add objects to the structure context by creating new objects or by making copies of existing
objects using the copy and paste menu commands. The copy is related to the currently selected line in
the BOM.

• Attachments

If the attachments pane is visible, you can attach folders, forms, BOM view revisions, URLs,
envelopes, and datasets to a BOM line or its related components. To insert an attachment, choose
the appropriate File→New menu command, for example, File→New→Folder, then browse to the
location of the attachment file.

Note:

You can check out the objects to prevent other users modifying them while you are adding them
to the structure context.

Create new items or subassemblies

When you create any new item or subassembly, you can add it to the current structure context as
follows:

1. Select the structure in the collaboration pane.

2. Choose the appropriate menu command, File→New→Item or File→New→Occurrence Group.
The new item or subassembly pastes to the selected structure which (by default) is the root.

Create a new item in a structure context

You can create a new item as a new root object in the current structure context or you can add it below
the selected line in the current structure context.

Note:

You cannot create a new Process, OP, or work area.

• Select the structure context in the collaboration pane and choose File → New → Item.

Save objects as collaboration contexts

You can save all loaded objects to a new collaboration context.

1. Choose File→Save as→Save as New Collaboration Context.

3. Working with collaboration contexts
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Teamcenter opens the Save as New Collaboration Context dialog box.

2. Specify a name and optional description for the new collaboration context.

3. In the Structure Contexts list, select which of the loaded structures to save to the new
collaboration context. These structures can include structure context objects, items, item revisions,
BOM views, or BOM view revisions.

Before creating the new collaboration context, Teamcenter creates a structure context from each
loaded structure that you include in the collaboration context if is not already contained in a
structure context. Therefore, for each structure in the list on the left that you want to save, you
must enter the following information. You can change the existing defaults for this information in
the Default_StructureContext_Type preference.

• Name of the structure context

• (Optional) Description

• Type of the structure context

• Type of the configuration context to be created for this structure context

If the structure is already a part of a structure context, the information above is automatically
populated when you select the structure in the structure list.

4. Select Open on Create if you want the new collaboration context to open when you close the
Save as New Collaboration Context dialog box. If you choose not to, the object is created in the
Newstuff folder in My Teamcenter.

5. Click Save.

Teamcenter collects all of these structure contexts into the new collaboration context.

Modifying the configuration of a structure context

Setting structure context configuration

You can associate the rules defined in a configuration context with one or more structure contexts. Once
associated, the rules are persistent and become active each time you open the structure context.

When the configuration context is active, the content shown for the displayed structure context depends
on the configuration rules

You can select a structure context in the collaboration pane and change configurations from the menu
commands. You must save any changes to make them permanent.

Setting structure context configuration
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You can change the configuration of a structure view as follows:

• Edit the structure view or select different revision or variant rules at any time.

• View a structure using any configuration context in the database.

• Save the current view configuration in the structure's configuration context under a new name by
choosing Tools→Save Configuration.

• Restore the view configuration in the configuration context assigned to the structure.

Create or edit the configuration context

1. Choose File→New→Configuration Context.

Teamcenter displays the New Configuration Context dialog box.

2. Enter the following information:

Box Description

Name Specify the name of the configuration context.

Type Choose the appropriate configuration context type from the list.
By default, only the ConfigurationContext type is available; your
administrator may create additional types as necessary with the
Business Modeler IDE administration application.

Revision rule Choose a revision rule from the list.

Variant rule (Optional) Choose a variant rule to apply to the structure context.

3. Attach the configuration context to one or more structure contexts as required.

Edit a configuration context

1. Select the required configuration context.

2. Use the cut and paste options to modify it.

3. Save the changes by choosing Tools→Save Configuration

4. (Optional) Save the context under a new name by choosing Tools→Save Configuration....

3. Working with collaboration contexts
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Add, remove, and move structure contexts

• Add an existing structure context to the current collaboration context using the copy and paste menu
commands.

• Remove an existing structure context from the current collaboration context by using the cut options.

• Move structure contexts by dragging them from one location to another in the structure.

Opening additional objects in the session

You can send additional objects to a Multi-Structure Manager session that do not appear in the current
collaboration context. This is useful in cases where you only want to perform a temporary analysis, such
as an accountability check between two BOMs or IDCs, instead of storing a new object in the database.
These temporary objects appear in their own tabs with their names in parentheses to signify that they
are not a part of the current collaboration context. If you have not yet opened a collaboration context, all
tabs titles appear in parentheses.

The types of objects that you can send as temporary structures to Multi-Structure Manager are:

• Structure context objects
• IDC objects
• Items
• Item revisions
• BOM lines
• BVRs

Note:

You do not have to create structure contexts for these before sending them to Multi-Structure
Manager.

Save temporary objects as structure contexts

1. Right-click the tab containing the temporary object.

2. Choose Save as a Structure Context.

Teamcenter displays the New SC dialog box.

3. Type a name for the structure context in the Name box.

4. Choose the appropriate structure context type from the list of symbols at the left. Your
administrator determines which structure context types are listed in this dialog box. New business
objects (types) are created in Business Modeler IDE.

Add, remove, and move structure contexts
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5. (Optional) Type a description of the structure context in the Description box.

6. (Optional) Set the configuration to a previously stored configuration context by clicking  and
searching for the configuration context.

7. Click OK.

The new structure context appears as a line in the BOM under the current collaboration context
and can be identified by a  symbol. If you did not select a configuration context in the previous
step, Teamcenter creates a structure context with the system's default configuration which is
generally:

• The default revision rule, typically Latest Working.

• No variant rule.

8. (Optional) Add the new structure context to the existing collaboration context by using cut and
paste or drag and drop in the collaboration pane.

Creating a design study using a composition

Creating a design study using a composition

A composition is a special kind of structure context that contains components added from one or more
structure contexts, each of which may contain a different product structure. You can use a composition
to create a design study based on one or more products stored in structure contexts. Compositions are
also used for manufacturing processes containing data from both product and plant structures.

Create a design study

1. Create a new structure context. Ensure that this structure context type is designated as
CompositionContext.

The new composition appears in a tab with an asterisk beside its name denoting that it is a
composition.

Tip:

Your administrator can create custom composition type structure contexts by selecting the is
composition option when creating a new structure context business object in the Business
Modeler IDE.

2. Create a new root item within the composition.

3. Open the structure context on which you want to base the composition.

3. Working with collaboration contexts
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4. Open the new composition in the second structure pane.

5. Assign components from the structure context to the composition using either copy and paste or
drag-and-drop. The components assigned to the composition are marked by the  symbol.

Configuring compositions

When you configure the source structure, it automatically configures the assigned components in the
composition in the second structure pane. This applies to both variant and revision configuration. You
can set revision rules on the composition, but that only configures revisions of items that have been
added directly into the composition (rather than assigned from the source structure). This is useful if
you are designing a new part in the study for which you have several revisions and which you want to
configure.

Note:

If you want to configure the assigned components in the composition, you must do this in the
source structure.

Adding items directly to composition

If you do not want to impact the source structure, you must add new items directly to the composition.
Do this, for example, by adding the component to the clipboard in My Teamcenter and pasting it into
the composition. If items are added to the composition in this way, they are not affected by the source
structure. Therefore, you can move components in the composition without moving the components in
the source.

Note:

If you move the components that are added to the composition (for example, using
Graphics→Transformation→Persistent Transformation or in NX), Teamcenter creates an
absolute occurrence override transform in the composition.

Assigning occurrence groups to compositions

You can create collections of components in the source in an occurrence group (created against
the source). You can then assign that occurrence group to the composition in the same way that
components in the source structure are assigned. This is equivalent to assigning each of the components
in the occurrence directly. The advantage is that the components in the occurrence group can be
managed as a group, for example, to reposition or hide them.

Configuring compositions
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Creating structures from templates

Creating structures from templates

You can create a new product structure from a template, if your system includes templates for these
structures. Cloning rules may be defined that determine the actions taken when you create a new
structure from a template, as follows:

• Clone

The new structure includes a copy of the object that is referenced by the template.

• Reference

The new structure references the same object that is included in the template.

• Ignore

The new structure does not include or reference the object.

• Map

The system maps the template to a replacement structure. For example, this allows you to create a
process structure from an existing process or from a process template. Optionally, this rule may be
allowed by a second, default, action: Reference, or Ignore.

By applying the relevant cloning rules when you create the structure, Teamcenter maps occurrences in
the template to absolute occurrences in the actual structure.

Create a product structure from a template

1. Ensure that the necessary Product.Template variables are defined in the preferences, as described
in Getting Started With Manufacturing. These variables contain the rules that determine how the
objects in the template are mapped to the objects in the new product structure.

2. Select the product and choose File→New→From Template→Item from Template.

Teamcenter displays the New Item dialog box.

3. Click the Choose Template tab.

4. Type the name of the template in the Template ID box. Alternatively, you can browse to the
template you require or to another product structure to clone.

3. Working with collaboration contexts
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5. Confirm that the Use Template check box is selected.

6. Select a revision rule from the Revision Rule list.

For more information about configuring with revisions, see Structure Management on Rich Client
─ Usage.

7. Select an effectivity by clicking Set Date/Unit/End Item.

For more information about creating effectivities, see Getting Started With Product Structure.

8. Do one of the following:

• Click Process all variants to traverse the structure considering all unconfigured variants.

• Click Process configured to only process the configured structure. You must specify a variant
rule when you choose this option. The structure is configured using the variant rule and
unconfigured variants are not considered during cloning.

9. From the Cloning Rule list, select a rule.

10. (Optional) Select Carry over future incremental changes.

If you select this option, you must set the date in cloning dialog. If you do not check this option,
cloning copies the configured structure only.

11. (Optional) Select Show as new root to create the cloned structure as a top-level object.

12. Click OK or Apply to create the new structure from the template you choose.

At the end of any cloning operation, if new incremental changes are created as part of cloning
process, Teamcenter displays a dialog box listing the new incremental changes.

Create a product structure from a template
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4. Building and editing product structure
Building and editing product structure

You can create the product structure manually in Teamcenter or you can import it from your CAD
system. When you import a structure, Teamcenter keeps the structure synchronized with any changes to
the native CAD design. After you create the structure, you modify it as necessary to reflect any changes
to the product design.

Using Save As to save a BOM view revision

In most cases, you do not explicitly save a BOM view with the Save As command because Teamcenter
automatically copies the BOM view revision whenever you choose the Save As command for an item
revision. However you may sometimes want to save the BOM view with a different type, for example, if
you create a BOM view revision of another view type or copy a structure to another item.

When you save a structure with the Save As command, the workspace objects it comprises are renamed
by default, including the item identifier, the revision identifier, and any variant rule.

If you select an item revision with multiple views (rather than a BOM view revision) and choose this
command, Teamcenter makes a copy of each view type.

Create a new BOM view revision from an existing BOM view
revision

1. Select the line containing the BOM view revision in the product structure tree.

2. Choose File→Save As→BOM View Revision.

Teamcenter displays the Save BOM View Revision As dialog box.

3. Specify a view type that is not already been created for the item. You select the view type from a
list of values defined by the administrator.

The precision of the BOM view revision is the same as the BOM view revision you copied. If you
want to change the precision, choose Edit→Toggle Precise/Imprecise.

To add a similar structure to another item revision, choose the File→Save As→BOM View Revision
menu command to create a new BOM view revision in a different item. Specify the target item identifier
and revision in the Item and Revision boxes of the dialog box. This action copies the occurrence
attributes, including the find number, notes, quantity, substitutes, and variant conditions into the new
BOM view revision.
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Note:

Variant conditions are copied if you use modular variants but not if you use classic variants.

Adding components to the product structure

You can add components to the product structure in the following ways:

• Copying and pasting objects

Allows you to copy references to existing items, parts, and designs.

• Add a component to an assembly

Allows you to enter the item identifier by specifying (for example) the number of components to add.

• Create a new item or item revisions

Allows you to use a top-down approach by simultaneously modelling structure and creating new
items, parts, and designs.

If you manage parts and CAD designs separately, you must publish links between them as an
appropriate time.

For more information, see Aligning CAD designs and parts.

If another user is editing a single level assembly within the product structure, Teamcenter prevents you
making changes until the other user has saved their changes. A warning message identifies the other
user working on the assembly. This safeguard does not prevent you making changes to other assemblies
that are not being worked on.

Optionally, Teamcenter can validate the structure by verifying that you add only appropriate
child items and item elements (GDEs). If you attempt to make an invalid addition, Teamcenter
displays an error message stating that you cannot add the selected child item to the current
parent item. To enable validation, your Teamcenter administrator sets the TCEnforceSingleType and
TCAllowedChildTypes_Item Type/GDE Type preferences, as described in the Teamcenter Environment
Variables.

Copying and pasting objects

The Teamcenter clipboard is shared by all applications, including NX. Consequently, for example, objects
you place on the clipboard by copying them in My Teamcenter may subsequently be pasted into the
product structure in Multi-Structure Manager.

4. Building and editing product structure
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You can also edit the product structure with the Remove, Copy, and Paste commands. When you
paste an item or item revision from the clipboard, Teamcenter creates corresponding components in the
selected assembly in the product structure. Multi-Structure Manager only allows you to paste items and
item revisions (including parts, designs, and their revisions); other objects are ignored if you attempt to
paste them.

Copying and pasting occurrence attributes of components

When you copy a component from an assembly and then paste it elsewhere, the occurrence attributes
(for example, the quantity and any notes) are also copied and pasted. However, the find number is
not copied as Teamcenter automatically generates the find number according to the position of the
component in the target assembly. If the component has an associated substitute list, this is also copied
and pasted.

If you paste the component into My Teamcenter, rather than Multi-Structure Manager, Teamcenter
pastes the lines as individual item revisions.

Note:

You cannot view occurrence attributes such as quantity or notes in My Teamcenter.

Copy and paste using the BOM line shortcut menu

If you right-click a line in the product structure, Teamcenter displays the BOM line shortcut menu is
displayed, allowing you to:

• Choose the Copy command to copy the line to the clipboard. This is the same action as pressing the
Ctrl+C shortcut keys, choosing Edit→Copy, or clicking Copy  on the toolbar.

• Choose the Paste command to paste the contents of the clipboard as components of the line. This is
the same action as pressing the Ctrl+V shortcut keys, choosing Edit→Paste, or clicking Paste  on
the toolbar.

• Chose the View command to view the properties of the line. This is the same action as choosing
View→Properties or clicking Properties  on the toolbar.

Note:

You do not need to explicitly select the line before right-clicking it.

Copy and paste an item or item revision

1. Select and copy the item or item revision (including parts, designs, and their revisions) from
elsewhere in the product structure displayed in Multi-Structure Manager or from another

Copying and pasting occurrence attributes of components
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application such as My Teamcenter. You can copy the item or item revision by clicking Copy ,
choosing Edit→Copy or pressing the Ctrl+C keys. This action places the item or item revision on the
clipboard.

2. In Multi-Structure Manager, select the assembly into which you want to add the component.

3. Paste the item or item revision by clicking Paste , choosing Edit→Paste or pressing the Ctrl+V
keys.

Pasting does not remove the object from the clipboard. Therefore, you can click Paste  again to add
another line of the same item revision to the assembly. Another Copy operation replaces the previous
clipboard contents with the new object.

Add a component to an assembly

You may want to specify additional data about the use of a component as you add it to the structure, for
example, a quantity or find number. You can do this by choosing the Add... command to insert a new
component.

1. Select the assembly to which you want to add the component.

2. Choose Edit→Add... and Teamcenter displays the Add dialog box.

Use the upper pane of the dialog box to specify the component to add and the view type, if
multiple views exist. Use the lower pane of the dialog box to specify the occurrence information.

3. Complete the dialog box as follows:

• Enter the component item identifier directly, or search for the item by its identifier or name. You
cannot enter the item name, but Teamcenter displays the name as confirmation that you entered
the required identifier.

• Optionally, specify the revision according to its precision, as follows.

• If the parent assembly BOM view revision is imprecise, the Revision box is disabled and you
cannot specify a revision.

Note:

When the component is added to the structure and displayed in Structure Manager, the
actual revision is determined by the revision (configuration) rule. If there is not a revision
that satisfies the revision rule, the revision is shown as ???.

• If the parent assembly BOM view revision is precise, you are creating a precise occurrence. The
Revision box is enabled and you can specify a revision.

4. Building and editing product structure
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• Choose Component or Selected Assembly. You can also define substitute components.

• Set the view type if there are multiple views of the component; you do not want the default view
type. You can select another view type from the list of views created for the component.

• Specify any of the following occurrence attributes:

• Number of Occurrences

Specify the number of lines to add to the structure. The default selection is 1.

• Quantity Per Occurrence

Specify the quantity associated with each line in the structure.

■ If the item has a unit of measure defined, the units are displayed next to the Quantity per
Occurrence box and you can enter a fractional value (for example, 1.5). If the units are
displayed as Each, the box shows the number of parts and you must enter a whole number.

■ If the quantity box is blank, the default value is 1 for items that have no unit of measure or
0 for items with a unit of measure. These values are used in quantity rollups, for example,
when lines in the structure are packed.

Note:

You can enter the string A/R or a to specify a quantity value of As Required.

• Find Number

Edit the find number if necessary.

Note:

Find numbers are automatically generated according to the scheme defined for your
site with the PS_new_seqno_mode preference. The default scheme increments the find
number by 10 as each new component is added. However, after the find number crosses
the value 2147483647, for every new line added, the find number starts from 8 and is
incremented by 1 instead of 10.

4. If you specified an item ID that is shared by multiple objects, Teamcenter displays the Select
Unique Item dialog box.

Select the object you require from the list.

Teamcenter returns to the Add dialog box.

Add a component to an assembly
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5. Click OK or Apply to add the component to the assembly.

Paste a component

You can specify additional data about the use of a component as you add it to the structure, for
example, a quantity or find number.

• Choose the Paste... command to insert an existing component that you copied to the clipboard into
the structure.

Teamcenter prepopulates the Component ID (Revision) and Name boxes of the Paste... dialog box
with item or item revision information from the clipboard.

Create a new item or item revisions

You can create an item revision and structure it as an assembly, by adding new components one item or
part at one time. This technique is useful when doing top-down modeling. You must have write access
to the BOM view revision to create the new item revision.

1. Select the parent assembly in the product structure tree.

2. Choose File→New→Item or File→New→Part.

Teamcenter displays the Create Item or Create Part dialog box.

3. Enter the necessary parameters in the dialog box and click OK.

Teamcenter creates the new item or part (or its revision) and adds it as a component of the
selected assembly.

Note:

If you add parts or part assemblies to an assembly, you can subsequently publish links to the
associated CAD designs, as described in Introduction to aligning CAD and BOM. This step is not
necessary if you add items or item revisions, as you can attach CAD designs directly.

Copy multiple views

If you copy an item revision with more than one view type from another rich client application and paste
it into the structure in Multi-Structure Manager, Teamcenter uses the following rules to determine the
view type to which the new occurrence refers.

• If a specific view type is copied from the other application, Teamcenter uses the same view.

• If no view type is copied, Teamcenter displays a list of all the available view types for that item.

4. Building and editing product structure
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If you copy a line from the structure in Multi-Structure Manager that represents a specific BOM view
revision and paste it into another BOM in Multi-Structure Manager, the new occurrence references the
same BOM view revision as you copied.

Restructuring and editing the product structure

Restructuring and editing the product structure

You can restructure a representation, including a BOM view, occurrence group, structure context, or
composition. You must revise a frozen product structure before restructuring. Restructuring edits the
product structure in downstream views (for example, manufacturing) while preserving the derived
occurrence structure and data related to specific occurrences of parts and assemblies. Restructuring is
disabled for product structures that contain CAD designs because it can make the CAD data invalid.

During restructuring operations, Teamcenter maintains the integrity of incremental changes, classic
or modular variants, and structure relationships. Teamcenter displays warnings when it encounters
absolute occurrences attributes and data.

If you have edits pending to a product structure, you must save the edits before you open the structure
in another application.

In addition to restructuring, you can edit individual properties on any line, subject to the following
limitations:

• Restructuring is not permitted on lines that have pending edits.

• Property edits are associated with a relative occurrence and are marked as pending until they are
saved to the database.

• Property edits are highlighted only if you use the column editor. If you use other methods of changing
properties (for example, the Properties dialog box), these edits are not visually highlighted in the
properties table. However, Teamcenter still retains the details of such edits until you save or revert
them.

• Use the PS_structure_change_condition preference to specify actions as structure edits. For
example, by default, changing a reference designator is not considered as a structure edit, but you
can add this action to the preference. NX requires reference designator changes to be considered as
structure edits.

• If any note in the list of notes is edited, the All Notes field shows a … icon with a red strike-through. It
does not show the exact original value.

• Edits to the absolute or relative transformation matrix are not highlighted.

• You cannot edit the first property column (BOM Line).

Restructuring and editing the product structure
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• If you cut more than one BOM line to the clipboard and then modify the BOM lines on the clipboard,
this action changes the ownership of the remaining BOM lines. For example, if you cut two BOM lines
and then remove one of these lines from the clipboard, the status of the remaining line changes from
pending cut to pending copy. If you want to modify the BOM lines that are the subject of a cut action,
repeat the cut action on the required BOM lines, rather than modifying the contents of the clipboard.

• If you remove a line that contains one or more unsaved changes to its substructure, the system does
not automatically save those changes.

• By default, if you cut or copy a line and then paste it to a new location, incremental change elements
(ICEs) are not copied. This may necessitate significant manual recreation of data if you are cutting
or copying many lines together. To automatically copy ICEs, the administrator must set two Business
Modeler IDE constants:

• Fnd0EnableIceCarryOver business object constant

When moving, copying, or assigning a line from one location to another, this constant determines if
the ICEs are carried forward. You must set this constant to true on both the source location’s parent
and the target location’s parent.

• Fnd0AttrICEsToExclude property constant

Defines the occurrence attributes that Teamcenter does not copy to the target location for
occurrence attribute changes.

These settings apply to in-context changes made to structure lines, their attachments, and their
occurrence attributes.

Note:

Restructuring primitive actions include:

• Removing a level (removing a line and keeping child lines)

• Inserting a level (including pasting a line as a parent of selected lines)

• Moving a line to a new location (for example, cut and paste actions)

• Splitting an occurrence

• Replacing data in context

Only the last two actions make copies of the absolute occurrence data; the other actions share the
existing absolute occurrence data.

In certain cases, restructuring may cause valid reports of broken links, as shown in the following
examples:

4. Building and editing product structure
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Example 1:

A
+-----------B
            +-----------C (APN1 in context of A)
                        +-------------D

If you remove level C, the structure becomes:

A
+-----------B
            +-----------D

The link to C is lost. This is correctly reported as a broken link.

Example 2:

A
+---------E
+---------B
          +---------C
                    +-----------D(APN1 in context of B)

If you move D to E, it is outside of the context of B and APN1 is lost. This is correctly reported as a
broken link.

Example 3:

A
+-----------B
|           +-----------C
|                       +-------------D(APN2 in context of A)
+-----------B
|           +-----------C 
|                       +-------------D(APN1 in context of A)
+-----------D
+-----------D

If you move C to D, the system cannot determine which D to move the APN to without user interaction.
It skips the APN and logs an error message.

Example 4:

A
+-----------B
            +-----------C 
                        +-------------D(APN1 in context of B)

Restructuring and editing the product structure
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If you remove level B, it becomes:

A
+-----------C
            +-----------D

The link to D is lost. This is correctly reported as a broken link.

Insert a level in the structure

You can create an item and insert it in the current structure as a new level below the selected line. The
number of relative occurrences of the children is preserved. If you select more than one line, they must
share the same parent.

1. Select the parent line of the new level and choose Edit→Insert Level.

Teamcenter displays the Insert Level dialog box.

2. Enter the item identifier and other attributes of the new item. If the inserted item is new, you must
insert it with a quantity of 1.

3. On completion, click OK or Apply.

Teamcenter creates the new item and inserts it as a new level. The selected branches become
children of the inserted level, while the inserted level becomes a branch of the original parent. All
existing variant conditions, notes, absolute occurrences, and other data is moved down with the
selected branches. The default quantity of the new level is 1, meaning that no quantity change
occurs.

Note:

You can only insert a level if the line represents a standard business object type. If the line
represents a custom type, copy it to the clipboard and choose Paste Special. Teamcenter pastes it
as a new level above the currently selected line.

Remove a level from the structure

1. Select the affected line and choose Edit→Remove or click Remove .

Teamcenter displays the Remove dialog box.

2. Click Yes to confirm removal of the line. The total number of instances is preserved at the end of
this action. Any options of the removed lines are moved up and variant conditions are merged.

4. Building and editing product structure
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If you try to remove a level that would result in option definitions becoming inconsistent (for example,
options that are referenced by a parent line), Teamcenter displays an error message.

Move a node to another branch

You can move a selected node from one branch to another. All substructure and occurrence data moves
with the node.

1. Move a node using any of the following methods:

• Cut and paste using the Edit→Cut and Edit→Paste menu commands.

• Cut and paste using the Ctrl+X and Ctrl+V shortcut keys.

Caution:

Do not try to move a node by dragging the line to its new position. Teamcenter performs a
copy action when you drag a line.

Teamcenter displays the Paste dialog box.

2. Do one or more of the following:

• Change the item ID and revision ID.

• Change the view type, if applicable.

• Select if the line should be pasted as a component of the selected assembly line, as a substitute
for the selected line, or as a new level above the selected line.

• Specify the number of occurrences, quantity per occurrence, and find number.

3. Click OK or Apply to complete moving the line.

Caution:

If you cut a line and edit tracking is enabled, the line is displayed in red with a strike-through
until you commit the edits. Do not attempt to edit or work with this line, or you may obtain
unpredictable results. If you want to edit or work with a line that is marked as cut, revert changes
to the line by choosing Edit→Revert Edit first.

Similarly, do not edit or work with a marked line in another structure editor such as Multi-Structure
Manager. Always complete and save your work on the structure before you open it in another
structure editor.

Move a node to another branch
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Replace a node

You can replace an item representing a node in the structure with another item. All data associated with
the original node is preserved.

Note:

Your system administrator sets the PS_replace_with_substructure preference to determine if
any substructure below the node is replaced. If this preference is true, the node and its entire
substructure (if any) are replaced without prompting. If it is false, Teamcenter displays an error
message and does not complete the replacement action.

You cannot use the Replace feature on any type of process or consumed line in manufacturing
structures.

1. Select the line to replace and choose Edit→Replace Node or click .

Teamcenter displays the Replace Node dialog box.

2. Enter the item identifier and other attributes of the item that replaces the existing item.

3. Click OK or Apply.

Teamcenter replaces the existing item.

If you have edit highlighting turned on, the number of the original part is shown in red, strike-
through text.

Split an occurrence

You can split a line that represents several occurrences into two branches. The new branch and the
original (changed) branch initially have the same notes, variant conditions, and other data, but you can
subsequently modify them independently. The quantity on the original line before the split must be
greater than 1.

1. Select the occurrence line and choose Edit→Split Occurrence.

Teamcenter displays the Split Occurrence dialog box.

2. Enter the quantity for the new line that results from the split and click OK or Apply.

Fix in-structure associations

1. Select the top line of the edited structure and choose Tools→Fix In-Structure
Associations→Current Level or Tools→Fix In-Structure Associations→All Levels.

4. Building and editing product structure
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Teamcenter displays a dialog box containing a list of invalid associations. The scope of the invalid
associations depends on whether you chose the current level or all levels.

2. Select the first invalid association and click Remove.

Teamcenter removes the selected association from the structure.

3. Repeat the previous step for each of the other invalid associations in turn.

Note:

Any associations that you do not remove manually remain in the structure.

Performing on-demand validation

Your administrator can configure Teamcenter to enforce any rules imposed by the organization on what
types of content are allowed in the structure. You cannot add content or make other structure edits that
would violate the defined business rules.

The following types of restrictions on content within a structure are enforced:

• Only certain item classes or types may exist anywhere in a structure.

• Only certain item classes or types may be children of others.

• Only certain item classes or types may be parents of others.

• Properties of the parent or child object must satisfy specified values or be NULL.

For allowable substitutes in a given BOM line, the same restrictions that apply to the primary part
occurrence are applied to the substitute.

Validations are provided for the following operations:

• Creating a new occurrence

• Adding a substitute for a given occurrence

• Cloning (duplicating) a structure

• Importing or exporting a structure

• Revise and baseline

Performing on-demand validation
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Note:

Teamcenter validates only the first two operations in real time.

When you save edits, Teamcenter validates that they do not violate the defined business rules and, if
they do, displays an error message and does not save the changes.

Optionally, you can perform an on-demand validation of property updates at any time by right-clicking
a top line with substructure and choosing Tools→Validate Occurrences. If no issues are found,
Teamcenter displays a confirmation and saves a validation log. If issues are found, it displays a list
of errors.

Note:

The administrator uses the Business Modeler IDE to define these business rules on explicitly stated
classes. Any subclasses or subtypes of these classes inherit the same rules.

Your administrator must also create and set the following preferences:

• PS_Default_Rev_For_Occ_Cond_Validation

Defines the default revision rule when a child item is used for validation.

• PS_Bypass_Occurrence_Condition

Configures the system to bypass occurrence condition validation for defined actions or
operations.

Managing global alternates

Global alternates overview

A global alternate part is interchangeable with another part in all circumstances, regardless of where
the other part is used in the product structure. A global alternate applies to any revision of the part and
is independent of any views.

Note:

If the parts are interchangeable only in specific products or assemblies, use substitutes rather than
global alternates.

Parts and their global alternates are related only in a single direction. For example, if part A has three
global alternates (parts B, C, and D), then B, C, and D are each a global alternate of A. However, part A is
not an alternate of B, C, or D, as shown next.

4. Building and editing product structure
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Global alternates – single direction

One part can be a global alternate of more than one other part. For example, part B may be a global
alternate of parts E and F, as well as a global alternate of part A, as shown next.

Global alternates – multiple alternates

Global alternate relationships are not shared. For example, part C is not a global alternate of part B, even
though they are both global alternates of part A, as shown next.

Global alternates overview
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Global alternates – nonsharing

Likewise, global alternate relationships are not chained. For example, if part B is a global alternate of
part A, and part C is a global alternate of part B, part C is not a global alternate of part A, as shown next.

Global alternates – chaining

List global alternates

1. Select a line in the product structure. If it has global alternates, this is indicated by the  icon.

2. Click Global Alternates  at the bottom of the pane.

Teamcenter displays the Global Alternate dialog box, which lists all the global alternatives of the
selected item. The preferred global alternate (if any) is marked with a check mark.

Note:

You can also list global alternates in My Teamcenter.

Add global alternates

1. List the global alternates (if any) of the item for which you want to add one or more global
alternates.

2. In the Global Alternate dialog box, click Open .

4. Building and editing product structure
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Teamcenter displays the Open by Name dialog box.

3. Search for the item that you want to define as a global alternate of the selected item.

4. If you want to define more than one global alternate of the selected item, repeat the previous step
for each global alternate.

Note:

You cannot add the same item as the global alternate more than once. Teamcenter displays a
Cannot create duplicate alternates of same item message if you attempt this action.

Remove global alternates

1. List the global alternates of the item from which you want to remove one or more global alternates.

2. In the Global Alternate dialog box, select one or more global alternates to remove and click
Remove.

Teamcenter removes the selected global alternates from the list.

Note:

If you remove all the global alternates from an item, the corresponding line in the product
structure no longer shows the  icon.

Set or unset preferred global alternate

1. List the global alternates of the item from which you want to remove one or more global alternates.

2. In the Manage Global Alternates dialog box, select a global alternate and click Prefer.

Teamcenter designates the selected global alternate as preferred and places a check mark next to it
in the list.

To remove the preferred designation from a global alternate, select it and click Prefer again. Teamcenter
removes the check mark next to it in the list of global alternates.

Changing components

Changing components

Any modification you make to the product structure changes the BOM view revision in the
parent assembly. Modifications that change the BOM view include adding, deleting, or substituting

Remove global alternates
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components; adding a substitute component; or changing any of the occurrence attributes, for example,
a note or find number.

You must have write access to the BOM view revision to make such modifications. You may not have
write access for one of several reasons, including:

• Another user is modifying the BOM view revision and the changes are not yet saved. In this case,
Teamcenter displays an error message, stating who is currently modifying the BOM view revision.

• The BOM view revision is protected against write access, for example, because it is released.

You can create a new view type by choosing the Save command in two situations:

• To create a new view type, based on an existing view within the same item revision.

• To make a copy of a view into another item revision.

When you choose File→Save As for a selected item revision, Teamcenter creates a physical copy of the
BOM view revision.

Remove components

1. Select the component or group of components to remove from the product structure tree.

2. Choose Edit→Remove, or press Ctrl+R.

Teamcenter removes the selected components from the structure. If you select a line that has
substitutes, these are also removed.

Note:

This action does not place the selected line or lines on the clipboard.

Move a component to another assembly

1. Select the component or group of components to move to another assembly

2. Click Cut  on the toolbar, choose Edit→Cut, or press Ctrl+X to place the selected components on
the clipboard. Teamcenter grays out the affected component lines.

3. Select the target assembly.

4. Click Paste  on the toolbar, choose Edit→Paste, or press the Ctrl+P shortcut keys. New
component lines appear under the selected assembly, and the grayed-out lines are removed from
the structure.

4. Building and editing product structure
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Note:

Lines grayed out after a Cut command are not actually removed from the structure until you paste
them elsewhere in the structure. If you place another object on the clipboard before pasting, the
grayed-out lines are restored to their previous state and are removed from the clipboard.

Replace a component

You can make the following replacements in a product structure:

• Replace a component without losing the occurrence data.

You can change an item revision in an assembly by cutting out the old item revision and pasting in
the new item revision. However, this method breaks the occurrence link to the old component, so
you lose any occurrence attributes including notes and the find number of the old component. A
replacement retains the occurrence data.

• Change the revision of a component item in precise assemblies.

• Change the view type.

If the component has multiple views and you want the parent assembly to reference a different view,
you can edit to the parent assembly to change the view type.

You cannot replace one component with two or more components. However, you can select multiple
components and replace each with a single component.

Note:

Teamcenter does not verify if the replacement request is valid for your business data. If necessary,
check the validity of the replacement action with the Teamcenter administrator.

1. Select the component to replace in the product structure.

2. (Optional) Copy the replacement component to the clipboard. This action prepopulates the
Replace Component dialog box with the item identifier and revision of the replacement
component.

3. Choose Edit→Replace. Teamcenter displays the Replace dialog box. The lower pane of the dialog
box contains details of the selected component to replace.

4. In the upper pane of the dialog box, enter the item identifier of the replacement component. If
you copied the replacement component to the clipboard, the item ID and revision boxes are already
populated with those of the copied component. You can change the identifier if required, but not
the item name; the item name is derived from the item identifier you enter.

Replace a component
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You can specify a revision in some circumstances, depending on whether the parent assembly BOM
view revision of the component replaced is precise or imprecise:

• If the BOM view revision of the parent assembly is precise, you can specify a revision. In this
situation, you can use the replace command to replace one component item revision with
another item revision or to replace the component with a revision of a different item. If an item is
taken from the clipboard, Teamcenter determines the revision by the revision rule.

• If the BOM view revision of the parent assembly is imprecise, you cannot specify the revision. In
this situation, you use the replace command to replace one component item with another item.

If there is not a revision that satisfies the revision rule when you add the component to the
structure, Teamcenter displays the revision as ???.

5. (Optional) Use the bottom section of the Replace Component dialog box to change the scope of
the replacement by clicking one of the following:

• Single Component

Replaces only the selected component.

• All in Parent Assembly

Replaces all components of the selected item revision that are in the parent assembly.

If the component to replace has multiple views, Teamcenter uses the default view type. If no default is
defined, Teamcenter displays an error message and you must specify a view type in the Replace... dialog
box.

Alternatively, to replace one or more items (parts) or item elements for another:

1. Select one or more source lines that represent items or item elements, and choose Edit→Copy.

2. Select target lines that represents the same types of item or item element and choose Edit→Paste.
If you copied more than one source line to the clipboard, but only selected a single target line,
Teamcenter displays the Select Object for Replace dialog box. Otherwise, it replaces the targets
with the sources and updates the find numbers, as appropriate. If you attempt to replace an item
or item element with a line of another type, Teamcenter displays an error message and does not
replace any of the selected lines.

3. If Teamcenter displays the Select Object for Replace dialog box, select the required source from
those listed and click Replace.
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Working with substitute components

Defining substitute components

Substitute components are parts that are interchangeable with a particular component in an assembly.
Substitutes are often defined for manufacturing purposes, allowing use of the substitute if the preferred
part is unavailable, for example, due to a stock shortage.

You define a substitute for a single occurrence in an assembly and not for an item. In general, you
control a change to an item of this nature by making the changes selectively for each assembly, using
a where used search to identify each instance of the item. Do not use substitutes to address marketing
variations of a product—use variants or modular variants for this purpose.

You can define more than one substitute for each component. One of the substitutes is designated the
preferred substitute and is displayed in the structure. You can see the other substitutes by clicking the
Substitutes button. You can change the preferred substitute at any time.

Note:

If you are working in NX and perform a roll-up calculation (for example, cost or weight), the
calculation uses the preferred substitute.

If you add a substitute, you modify the BOM view revision and you consequently must have write
access to the BOM view revision. You can change the preferred substitute any time during a session (for
example, to view the change in NX), but you can only save the change if you have write access to the
BOM view revision.

Substitutes of one occurrence all share the same occurrence attributes, for example, find number,
quantity, and notes, as specified for the substituted part.

Substitute components are item revisions in a precise assembly and items for an imprecise assembly. In
an imprecise assembly, the revision rule selects the correct revision of a substitute component.

Display substitute components for a line

Teamcenter identifies the lines in the product structure with substitute components by a  icon. If the
line has substitute components, it has the Has Substitutes property set to Y.

1. Select the line in the product structure tree.

2. Click List Substitutes .

Teamcenter displays the List Substitutes dialog box. This allows you to view the available
substitutes.

Defining substitute components
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If a substitute part has an underlying structure, it is still represented as a leaf part when displayed as a
separate substitute line.

Create substitute component

1. Copy the substitute item revision to the clipboard in Multi-Structure Manager or another
application.

2. Select the line in the product structure in Multi-Structure Manager for which you want to define this
item revision as a substitute.

You can also add a substitute to more than one line in a single operation by selecting all the
necessary line. If the lines are packed, unpack them before you select them.

3. Choose Edit→Paste Substitute to paste the substitute directly. You can also choose Edit→Paste
and click As Substitute of Selected Line in the resulting dialog box.

Remove a substitute component

You can remove a substitute part that has related substitutes from the product structure. When you do
this, Teamcenter:

• Notifies you about all the related substitute parts of the selected substitute.

• Notifies owners of the parent BVRs of all related parts by Teamcenter e-mail.

• Changes or removes all relations in which the selected substitute parts participate to ensure
consistency.

• Removes the selected substitute part from the substitute part list.

1. Select the required line in the product structure tree.

2. Click List Substitutes  and Teamcenter displays the List Substitutes dialog box.

3. Select the substitute component you want to remove and click  (Remove).

You can also press Shift+Ctrl to select more than one substitute in the list for removal. If you
remove all listed substitutes, the line in the product structure is no longer marked as having
substitutes.

Change the preferred substitute

1. Select the required line in the product structure tree.
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2. Click the List Substitutes .

Teamcenter displays the List Substitutes dialog box.

3. Select the item to be the preferred substitute and click Prefer.

Teamcenter displays the item identifier of the selected substitute and adds the original preferred
substitute to the list.

Alternatively, you can right-click the required line and click Set Preferred Substitute to display a list
of the substitute components. Click the new preferred substitute.

4. If you have write access to the BOM view revision, you can save this change to the structure. If you
do not have write access, Teamcenter warns that you cannot save the preferred substitute but you
can make a temporary change. The ability to make a temporary change is useful if you want to
visualize one of the nonpreferred substitutes in the structure.

Managing substitute part relationships

Relate substitute parts

If there are dependencies between substitute part selections, you can relate the substitute part of one
occurrence with substitute parts of the other occurrence. You can define these relationships for any
occurrence in any BOM view revision.

Such relationships are bidirectional. For example, you can relate substitute A of the lower bearing in
the product structure to substitute B of the upper bearing, if the selection of B depends on the current
selection of A. The same dependency applies to the selection of B as the upper bearing; that is, A must
always be the lower bearing if B is selected as the upper bearing, and B must always be the upper
bearing if A is selected as the lower bearing. However, Teamcenter does not enforce this relationship, if
you choose to override it in a particular structure configuration.

To relate substitutes, you must have write access to the parent BOM view revisions of the selected BOM
lines. If you do not have permission to modify either of the parents, you cannot relate the substitute
parts.

1. In the product structure tree, select the two BOM lines that represent the applicable occurrences
and choose Tools→Related Substitute→Relate. Teamcenter displays the View/Create Related
Substitutes dialog box.

2. Verify the parent BOM lines and selected substitute items are those you want to relate. You can also
click the Preview button to check the relation to be created.

3. When you are satisfied that the correct relationship is selected, click the Create button to confirm
the selection. Teamcenter creates the relationship between the proposed substitutes and saves it in
the database; it is not necessary to explicitly save changes to the product structure. If you create an
incorrect relationship, click the Reset button to reset the changes.

Relate substitute parts
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Note:

The Related Substitute menu command is only visible if your site administrator sets the
PSE_enable_related_substitutes preference to True.

When you save a product structure that includes related substitute parts as a new structure, all
substitute part relations are carried forward.

Relate substitutes with existing substitutes

1. Click the Preview button before you create the relation to verify if previous relations exist and their
effect on the relation you propose to create.

For example, the 000005 Substitute A for Lower Bearing line in the BVR is already related to the
000014 – Substitute A for Fuel Pipe line. If you try to relate the 000005 Substitute A for Lower
Bearing line to another line, 000006 Substitute A for Upper Bearing, and click the Preview
button, Teamcenter displays the following new relation:

000002/A-view:000003:10 ->000005 – Substitute A for Lower Bearing
000002/A-view:000003:20 ->000006 – Substitute A for Upper Bearing
000012/A-view:000013:150 ->000014 – Substitute A for Fuel Pipe

2. Click the Create button to commit the relation. In the previous example, Teamcenter relates
substitute A for the lower bearing, substitute A for the upper bearing and substitute A for the fuel
pipe.

Edit a substitute part relationship

You can change or remove the relationship between substitute related parts, as follows:

1. In the product structure tree, select a BOM line with related substitutes and choose Tools→Related
Substitutes→Relate. Teamcenter displays the View/Create Related Substitutes dialog box.

2. Click the Show Related button and Teamcenter shows all the related substitute parts for the
selected substitute in the right-hand pane of the dialog box.

3. Select the relation to edit and click the Cut  button to remove it, or click the Modify button to
change the relation.

Note:

To modify substitute part relationships, you must have write access to the parent BOM view
revisions of the selected BOM lines. If you do not have permission to modify either of the parents,
you cannot modify the substitute part relationships.
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View the related substitutes of a selected BOM line

Choose Tools→Relate Substitutes→View Related. Teamcenter displays all defined relations in a dialog
box for information purposes; you cannot change the relations in this dialog box.

Create a structure from a template

Note:

Ensure that the necessary Product.Template cloning preferences are defined. These preferences
contain the rules that determine how the objects in the template are mapped to the objects in the
new plant structure.

1. Choose File→New→From Template and the type of structure that you want to create.

2. Click the Choose Template tab.

3. In the Template ID box, enter the ID of the structure that you want to use as a template and press
Enter.

You can also browse to the template you want to clone using Resource Manager, either by name or
by searching for a template in the Classification Search Dialog if it is classified.

Teamcenter assigns a new ID in the Process ID box.

4. (Optional) Rename the new structure in the Name box.

5. Click the Configuration tab.

6. Select a revision rule from the Revision Rule list.

7. Select an effectivity by clicking Set Date/Unit/End Item.

8. Do one of the following:

• Click Process all variants to traverse the structure considering all unconfigured variants.

• Click Process configured to only process the configured structure. You must specify a variant
rule when you choose this option. The structure is configured using the variant rule and
unconfigured variants are not considered during cloning.

9. From the Cloning Rule list, select a rule.

10. If you are creating a process from a template,

View the related substitutes of a selected BOM line
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• Choose the product to which you want to map the consumed products by selecting it in the
Product Reference Structure list.

• Choose the work area to which you want to map the consumed work areas by selecting it in the
Plant Reference Structure list.

This allows you to clone a process and map the consumed objects to different structures from the
one chosen in the prototype.

11. (Optional) Select Carry over future incremental changes.

If you select this option, you must set the date in the cloning dialog. If you do not select this option,
cloning copies the configured structure only.

12. (Optional) Select Show as new root to create the cloned structure as a top-level object.

13. Click OK or Apply to create the new structure from the template you choose.

At the end of any cloning operation, if new incremental changes are created as part of cloning
process, Teamcenter displays a dialog box listing the new incremental changes.

Use item elements

An item element (sometimes called a general design element) represents an interface, characteristic or
feature of a component in the structure. For example, it may represent a weld point on a bracket that
is welded to a parent assembly. The item element is shown in the product structure as a separate line
under the associated component and is represented by the  image.

Do any of the following:

• Create an item element

1. Select the assembly in the product structure with which you want to associate the item element.

2. Choose File→New→Item Element.

Teamcenter displays the New Item Element dialog box.

3. Enter the name of the item element and click OK.

Teamcenter creates the new item element and adds it as an item element line in the product
structure.
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Note:

You cannot create a new item element by copying an existing item element. Consequently,
the File→Save As and File→Save As→BOM View Revision menu commands are not available
when an item element is selected.

• Remove item elements

1. Select the item element you want to remove from the product structure.

2. Choose Edit→Remove.

Teamcenter displays the Removing Lines dialog box.

3. Click OK to confirm removal of the selected item elements.

• Copy and paste item elements

You can copy and paste item elements in the same way as other lines in the product structure.

To copy an item element, choose Edit→Copy to copy a selected item element to the clipboard.

To paste an item element, choose Edit→Paste to paste a copied item element from the clipboard into
the product structure.

• Replace item elements

1. Select one or more item elements (source lines) from the structure and choose Edit→Replace.

2. Select one or more (item elements) target lines in the structure and choose Edit→Paste.

If you copied more than one source line to the clipboard, but only selected a single target
line, Teamcenter displays the Select Object for Replace dialog box. Otherwise, it replaces the
target item elements with the source item elements and updates the instance numbers, as
appropriate. If you attempt to replace a target item element with a source item element of
another type, Teamcenter replaces only those lines where the source is a subtype of the target
type. Otherwise, it displays an error message and does not replaces any lines.

3. If Teamcenter displays the Select Object for Replace dialog box, select the required source item
element from those listed and click Replace.

• View notes on item elements

You can view a note associated with an item elements, select the item element and choose
View→Notes.

Use item elements
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Create a connection

To create a connection between lines with a PSConnection relationship:

1. Choose File→New→Connection→Revisable to create a revisable connection.

Teamcenter displays the New Connection wizard.

2. Choose the connection type and its options, then click Finish.

Teamcenter creates the connection as an item element.

3. Select the lines in the product structure you want to connect and the connection, then choose
Edit→Connect.

Note:

You can also right-click the lines and choose Connect.

Create a link

To create a link between lines with a GDELinkLine relationship:

1. Choose File→New→Connection→Non-Revisable to create a non- revisable connection (link).

Teamcenter displays the New Link wizard.

2. Enter a name and description, then click Finish.

Teamcenter creates the new link.

3. Select the lines in the product structure you want to link and the link, then choose Edit→Connect.

Note:

You can also right-click the selected lines and choose Connect.

Remove a connection or link

1. Select the lines in the product structure you want to disconnect. You cannot remove a connection
or link if the top line of the structure is connected.

2. Choose Edit→Disconnect to remove the connection or link between the selected lines. You can
also right-click the lines and choose Disconnect.
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Delete a single item from the product structure

1. Select the item in the product structure.

2. Choose Edit→Delete or press the Delete key.

Teamcenter displays a request for confirmation.

3. Click OK to confirm and remove the item from the product structure.

Note:

This action permanently removes the item from the Teamcenter database if you have read-
write permissions to the item.

Delete multiple assemblies or items

You can delete all items in the product structure below a selected line. This process is called a recursive
deletion and may be useful if you want to delete several nested assemblies or items from the structure at
the same time.

When you request a recursive deletion, Teamcenter verifies if the items below the selected line can be
deleted. You can only delete an item if it meets the following criteria:

• The item or one of its revisions is referenced by an occurrence of any view of any revision of any other
item in the structure.

• The item and its revisions are not referenced by any other occurrences outside the structure.

• You have delete permission for the item and all its revisions.

• Neither the item or any of its revisions is checked out or otherwise locked.

1. Select the line in the product structure below which you want to delete all items and assemblies,
then choose Edit→Delete or click the Delete button.

Teamcenter displays the Delete dialog box.

2. Click the Recursive Delete button and Teamcenter displays an Explore Selected Component
dialog box. The Recursive Delete button appears only if you select a single item for deletion.

3. Select any associated objects to delete (for example, datasets) in the Explore dialog box and click
OK.

Delete a single item from the product structure
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Teamcenter displays the dialog box listing items and any associated objects selected for deletion.
The list of items includes both items that can be deleted and items that cannot be deleted. If
Teamcenter determines that an item cannot be deleted, it displays the reason.

If you set suitable types or relations with the Type or Relation buttons, Teamcenter automatically
checks all these objects for deletion in the dialog box. Alternatively, you can click the Select All
button to select all objects for deletion.

4. Click Yes in the Delete dialog box to begin deleting all applicable items and the selected associated
objects. Teamcenter shows the status of the deletion process in the status bar.

You can pause deletion process by clicking the Stop button at any time. You can terminate the
deletion process by clicking the Abort button.

5. When the deletion process is complete, Teamcenter displays an updated Explore dialog box. This
contains a flattened list of all the items in the substructure of the originally selected item. Any
duplicates are removed and any items that Teamcenter could not remove are indicated.

Work with requirements and trace links

Link requirements

Use trace links to associate requirements with items, item revisions, and absolute occurrences that
satisfy the requirements. To create, view, or delete trace links, you must enable the trace link features.

Note:

This procedure sets the Tracelink_Edit_enabled preference to true. That setting also enables the
trace link features in other Teamcenter applications such as My Teamcenter, Systems Engineering,
and Multi-Structure Manager.

1. Choose Edit→Options.

Teamcenter displays the Options dialog box.

2. Select Systems Engineering.

3. Select the Trace Link Mode check box.

Create trace links

1. Select one or more source objects.
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Note:

If you select only one source object, you can create trace links to multiple target objects. If
you select multiple source objects, you can create trace links to only one target object.

2. Choose Tools→Start Tracelink, click the Start Trace Link Creation button  on the toolbar, or
right-click the selection and choose Start Tracelink.

You can also choose Edit→Copy, click the Copy button  on the toolbar, or right-click the
selection and choose Copy.

3. Select one or more target objects.

4. Specify the trace link subtype and name by doing one of the following:

• To accept the default subtype and name, choose Tools→End Tracelink, click the End Trace Link
Creation button  on the toolbar, or right-click the selection and choose End Tracelink.

You can also choose Tools→Paste Tracelink, click the Create Trace Link using Copy Paste
button  on the toolbar, or right-click the selection and choose Paste Tracelink.

• To assign a custom subtype and name:

a. Choose Tools→End Tracelink, click the End Trace Link Creation with Subtype button 
on the toolbar, or right-click the selection and choose End Tracelink....

The Create Trace Link with Subtype dialog box appears.

b. In the list of subtypes on the left, select the subtype to assign to each trace link.

c. In the Name box, type the name to assign to each trace link.

In the Description box, you can type plain text as additional information.

A trace link symbol  is shown for each defining and complying object. To view a defining or
complying path, generate a traceability report.

Create trace links

1. Select one or more source objects, for example, a requirement.

Create trace links
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Note:

If you select only one source object, you can create trace links to multiple target objects. If
you select multiple source objects, you can create trace links to only one target object.

2. Choose Tools→Trace Link→Start Trace Link, click the Start Trace Link Creation button  on the
toolbar, or right-click the selection and choose Trace Link→Start Trace Link.

You can also choose Edit→Copy, click the Copy button  on the toolbar, or right-click the
selection and choose Copy.

3. Select one or more target objects, for example, an item, item revision, or absolute occurrence.

4. Specify the trace link subtype and name by doing one of the following:

• To accept the default subtype and name, choose Tools→Trace Link→End Trace Link, click the
End Trace Link Creation button  on the toolbar, or right-click the selection and choose Trace
Link→Trace Link→End Trace Link.

• To assign a custom subtype and name:

a. Choose Tools→Trace Link→End Trace Link, click the End Trace Link Creation with
Subtype button  on the toolbar, or right-click the selection and choose Trace Link→End
Trace Link....

The Create Trace Link with Subtype dialog box appears.

b. In the list of subtypes on the left, select the subtype to assign to each trace link.

c. In the Name box, type the name to assign to each trace link.

In the Description box, you can type plain text as additional information.

A trace link icon  is shown in the Trace Link column for each defining and complying object.
View a defining or complying path in the Trace Links view.

Tip:

You can change the business object icon so that when an object has an associated trace link,
the trace link icon appears overlaid on the object's icon in Structure Manager.
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Create trace links on absolute occurrences

When creating trace links with manufacturing objects, either the source or the target must be
a requirements object. The following procedure describes creating a trace link between a source
manufacturing absolute occurrence and a target requirement object. You can also perform the linking in
the opposite direction.

1. Right-click the structure line that is the context of the edit. This line must be an ancestor of the
structure line that will be the source line for the trace link.

2. Choose Set In Context.

Teamcenter displays the  symbol in front of the line and colors the line green to show that the
item is the context for the creation of absolute occurrences. In addition, Teamcenter grays out all
siblings of the selected context and you cannot create absolute occurrences for these lines. The
in-context item is also identified in the title bar of the structure tree.

3. Select the source line, or select multiple objects by using the standard Windows functions.

4. Choose Tools→Trace Link→Start Tracelink, click Start Trace Link Creation  on the toolbar, or
right-click the selection and choose Trace Link→Start Tracelink.

5. From the Requirements view, select the target requirement(s) for the trace link and specify the
trace link subtype and name by doing one of the following:

• To accept the default subtype and name, choose Tools→Trace Link→End Tracelink, click the
End Trace Link Creation  button on the toolbar, or right-click the selection and choose Trace
Link→End Tracelink.

• To assign a custom subtype and name:

a. Choose Tools→Trace Link→End Tracelink, click End Trace Link Creation with Subtype
 on the toolbar, or right-click the selection and choose Trace Link→End Tracelink.

The Create Trace Link dialog box appears.

b. In the list of subtypes on the left, select the subtype to assign to each trace link.

c. In the Name box, type the name to assign to each trace link.

d. (Optional) In the Description box, type additional information.

You can view trace links in the Traceability view or by creating a traceability report.

Create trace links on absolute occurrences
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Generate a traceability report

A traceability report displays defining and complying relationships for an object. You use this report to
view the defining and complying paths of trace links.

1. In the structure pane, select the object for which you want to generate the report.

2. Choose Edit→Traceability Report, click the Traceability Report button  on the toolbar, or
right-click the object and choose Edit→Traceability Report.

The Traceability Report window appears.

Generate a traceability report

1. In the structure pane, select one or more objects for which you want to generate the report.

2. Choose Tools→Trace Link→Traceability Report→Defining or choose Tools→Trace
Link→Traceability Report→Complying.

Choose either the Defining or Complying option depending on whether you want a report of the
objects that define, or the objects that comply, with the selected objects in the structure.

The Traceability Report window appears.

Note:

• The direct trace link symbol  indicates that the trace link relates to the selected object
itself.

For more information about direct trace links, see Systems Engineering ─ Deployment
and Rich Client Usage.

• The indirect trace link symbol  indicates that the trace link relates to the revision or
item that is associated with the selected object.

For more information about indirect trace links, see Systems Engineering ─ Deployment
and Rich Client Usage.

Tip:

To generate a traceability report showing both the defining and complying objects associated with
the selected object, click the Generate a Traceability report button  in the toolbar.
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Export traceability information to Excel in a structure view

1. Open the structure with trace links in a structure view.

For example, send a structure to the Structure Manager view, the Requirements view, or another
structure view.

2. Choose Tools→Export→Objects To Excel.

Teamcenter displays the Export To Excel dialog box.

3. Under Output, do one of the following:

• For a standard Excel file that is not connected to Teamcenter, click Static Snapshot.

• For an interactive live Excel file that is connected to Teamcenter, click Live integration with
Excel (Interactive).

• For a live Excel file that is not connected to Teamcenter, click Live integration with Excel (Bulk
Mode).

You can accumulate changes and later connect the file to Teamcenter.

• To export the data to an Excel file that also contains import processing information on a separate
sheet, click Work Offline and Import.

• To check out objects while exporting to live Excel, select Check out objects before export.

Note:

The checkout applies to all objects being exported. Use this option carefully if you are
exporting a large set of objects or perhaps an entire product structure.

4. Under Output Template:

a. Select Export All Visible Columns to export all the columns in the applicable structure view.

Note:

Verify the Trace Links or Trace Link column property appears in the structure view.

Export traceability information to Excel in a structure view
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b. Select Use Excel Template to activate the template list.

In the list, select the template that specifies the data that you want to export.

5. Click Copy URL.

Note:

• Copy URL is unavailable if you select more than one object to export.

• Copy URL is unavailable if you select any of the following dialog box options:

• Work Offline and Import

• Export All Visible Columns

• Export All Objects in View

The export file is generated and the URL Generated message is displayed, confirming
that the URL is in your Windows Clipboard and showing the URL details.

6. Click OK to generate the export Excel file.

Excel opens a temporary file. You can create a permanent file by choosing File→Save As in Excel to
display the Save As dialog box.

If you save a live Excel file, you can open it later in My Teamcenter to reconnect it to the database.

Note:

Values that you cannot change in Teamcenter are unavailable in the cells of the live Excel file.

Delete a trace link

1. In the Traceability Report window, select the trace link in the Defining Object or Complying
Object column.

If necessary, click the Show Tracelink button  to display the defining and complying trace links.

2. Click the Delete Tracelink button  at the bottom of the window.

Teamcenter deletes the trace link from the database.
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Delete a trace link

1. Open in the Traceability view, or generate a traceability report, that includes the trace link object
you want to delete.

Note:

For occurrence objects, be sure to select the occurrence object in the correct context.

2. Click the Show Trace Link button  at the bottom of the report or Traceability
view.

3. Expand the object to view all trace links.

4. Select the Trace Link object you want to delete.

Note:

The Relation Type column indicates Trace Link as the type.

5. Click the Delete Trace Link button  at the bottom of the traceability report or Traceability view.

6. Click Yes to delete the trace link.

Delete a trace link
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The trace link is deleted from the workspace object or from the occurrence object, in context, and
from the Teamcenter database.

7. Click Yes to refresh the window.

Note:

You may need to do one of the following also:

• Right-click the object with the trace link symbol and choose Refresh.

• Press the F5 key

• Choose View→Refresh
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5. Working with occurrence groups
Introduction to occurrence groups

Occurrence groups help you scope data from a very large structure to a more manageable structure that
contains only those objects that you currently need for your work. If you have a very large structure, for
example, you can create subsets of this structure in occurrence groups that are tailored to the needs of
different departments.

An occurrence group structure is attached to the main structure (the base view) and can only hold
occurrences from that structure. An occurrence under an occurrence group is the same occurrence
as in the main structure. Making changes in the occurrence group structure is the same as making
these changes in the main structure. You can think of an occurrence group as holding shortcuts
to the occurrences in the main structure. You can have multiple shortcuts to the same occurrence,
that is, you can assign the same occurrence to multiple occurrence groups. You can create multiple
occurrence group structures, each one holding a different list of occurrence groups and a different list of
occurrences from the main structure.

Note:

You can create incremental change information about occurrence groups and their content
(children). However, configuring the view to show or hide configured changes does not work
for this information. Only incremental change information that is common with the base view (in
the item structure) is filtered.

Create an occurrence group

1. Select a line in the base view.

2. Choose File → New → Occurrence Group or click .

Teamcenter displays the New Occurrence Group dialog box.

3. Select the type of occurrence group.

4. Type a name and description of the new occurrence group and click OK.

Teamcenter creates a new root occurrence group and displays it as a new tab next to the Base
View tab.

5. Copy components, subassemblies, and other occurrence groups from the source view and paste
them into the new occurrence group.
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Create an occurrence group within an existing occurrence group

1. Select an existing occurrence group within an occurrence group structure.

2. Choose File→New→Occurrence Group.

Teamcenter displays the New Occurrence Group dialog box.

3. Type a name and description of the new occurrence group and click OK.

Teamcenter creates a new occurrence group under the selected occurrence group.

Configuring an occurrence group structure

An occurrence group structure holds shortcuts to the original occurrences in the base view. Therefore,
all configurations applied on the base view are also applied on all occurrence group structures, and vice
versa.

Removing a line under an occurrence group

When working in an occurrence group structure, the Remove Line command can have two different
meanings depending on the selected object:

• Selecting an occurrence directly under an occurrence group

The Remove Line command removes the occurrence from that specific occurrence group. The
occurrence still remains in the base view. Any other shortcut to this occurrence under another
occurrence group is not removed.

• Selecting an occurrence that is not directly under an occurrence group (that is, a part below an
assembly under the occurrence group)

The Remove Line command removes the occurrence from its parent assembly. This also affects the
base view and any other occurrence group containing this assembly. Moreover, if this occurrence was
also directly assigned under an occurrence group, it is automatically removed from that occurrence
group.

Creating a new occurrence under an occurrence group

When working in an occurrence group structure, you can also add a new occurrence by using either the
New command or by copying and pasting. Adding an occurrence to an occurrence group also adds it to
the base view as follows:

• If the new object is created directly under an occurrence group, it is added to the root object in the
base view.

5. Working with occurrence groups
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• If the new object is created under an occurrence in an occurrence group, it also appears under the
same occurrence in the base view.

Show or hide an occurrence group structure

If you have multiple occurrence groups attached to a base view, you can decide which one to show and
which to hide.

1. Right-click the main tab of the structure and select Show/Hide Occurrence Groups.

Teamcenter displays a dialog box listing all available occurrence groups.

2. Select the one you want to show or hide.

Alternatively, select None or All.

If you loaded a structure directly, this mode is not saved for the next session. If you loaded
a structure within a structure context, the list of visible occurrence groups is managed by the
structure context. The last state is saved and loaded in the next session.

Synchronizing occurrence group configuration with the base view

There are several points to note about synchronizing the occurrence group configuration with the base
view configuration.

• The configuration between the occurrence group and the base view is synchronized.

• Setting the revision rule, effectivity, occurrence type filter, variant configuration, and show
unconfigured data in the occurrence group changes this configuration in the base view, and vice
versa.

• All the occurrence groups that are not currently visible are updated when they become visible.

Show or hide an occurrence group structure
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6. Managing absolute occurrences
Managing absolute occurrences (in-context editing)

An absolute occurrence is a specific instance of a component or assembly in a structure. It may be
independent of the top-level assembly and only meaningful in the context of a lower level assembly.
For example, you may have four occurrences of a wheel in the design of a vehicle; you can label one of
those occurrences as left rear wheel, which is an absolute occurrence of the wheel. When you open a
window containing the structure, each absolute occurrence is represented by a single line.

To create an absolute occurrence, you edit the occurrence line in context with respect to the assembly
in which the absolute occurrence data is meaningful. Hence, the creation of absolute occurrences is
sometimes referred to as editing in context.

Note:

Do not confuse the arbitrary context in which you create absolute occurrences with a specific
collaboration context or structure context. You can create absolute occurrences in the context of
any top line item, except for the immediate parent of the line.

Absolute occurrences are not the same as appearances. Absolute occurrences are generated when
you build the structure (edit in context) and do not have associated spatial information.

A component or subassembly that appears in more than one product structure can have the same
absolute occurrence in each structure.

You cannot create absolute occurrences directly, only by converting a relative occurrence and editing
its properties. Similarly, you cannot delete absolute occurrences directly. You cannot create absolute
occurrences on substitutes.

An absolute occurrence may appear more than once in the structure, depending on the context in which
you created it.

Interpreting absolute occurrence data

The following figure shows how absolute occurrences appear in the structure when in context editing is
enabled.
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Absolute occurrences in a structure

Note the following lines in this structure:

Line Purpose

20487187/C (view) The immediate parent that is in context for absolute
occurrence edits.

The line is also color-coded in the structure and in the title
bar of the pane where the current context is shown. The
color is green in this example but may be changed by your
administrator.

Lines that are not in the current context are grayed out.
Similarly, the out-of-context parts corresponding to the
grayed out lines may also be grayed-out in the viewer. You
cannot create absolute occurrences from grayed-out lines in

6. Managing absolute occurrences

6-2  Multi-Structure Management, Teamcenter 2412
© 2025 Siemens



Line Purpose

the current context and you cannot edit an existing property
value on such lines.

Lines below 20487187/C (view) are generally not grayed
out and are in context.

20367635_101/B (view) This is a standard occurrence note. It is in context and may
be edited.

20367635_201/A This occurrence note is not in context because it is not in all
occurrences of the immediate parent assembly.

20367635_3/A The overriding note value in the context of 20487187 only
for this specific occurrence of the parent.

To obtain more information about edited absolute
occurrence data, place the cursor over any cell containing
the  icon. The tool tip banner shows the context in
which the edited data is valid.

By default, the assembly viewer highlights only those items in the assembly that are in scope in the
selected context; items that are not in context are shown grayed out. The administrator may optionally
change this behavior so that all items are shown.

The structure contains icons that indicate the status of the structure lines as follows:

Icon Indicates

A line containing this icon is the context for the creation of certain
absolute occurrences. The line is also color-coded in the structure and in
the title bar of the pane where the current context is shown.

A line that contains this icon has one or more of the absolute
occurrences edited in a context but not necessarily the current context.

A property cell containing this icon is already edited in a context; the
current absolute occurrence data is shown in the cell. Each cell that
contains data for a specific absolute occurrence includes this icon.

A line that contains this icon before its name is a target for editing data
in the current context. Look for a  icon in one or more properties
cells of the same line to identify if the necessary edits are already made.

Note:

This icon identifies a target in the current context. It may not
appear in the same line if you select a different context.

Interpreting absolute occurrence data
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Icon Indicates

A line that contains this icon has an in-context edit made by an
incremental change. The edit may be an add, remove, or both.

A cell that contains this icon has an in-context edit removed by an
incremental change.

A cell that contains this icon has an in-context edit added by an
incremental change.

A cell that contains this icon has in-context edits added and removed by
an incremental change.

Showing and hiding the in-context line

You can show or hide the line that is the context of a particular in-context edit.

To show the line:

1. Click in a property cell, then click outside the same property cell. Ensure you do not select another
property cell.

Note:

Right-clicking when editing the value in a cell has no effect.

2. Hover the cursor over the same property cell, right-click, and then choose Show/Hide In-Context
BOM Line from the menu.

Structure Manager shows the in-context line highlighted in yellow and the editable property cells
are highlighted similarly.

To hide the line, click outside the property cell you edited, right-click, and then choose Show/Hide
In-Context BOM Line from the menu.

Structure Manager hides the previously highlighted in-context line.

Create absolute occurrences

To create an absolute occurrence, you must enable in-context editing mode and edit the properties of an
occurrence, as follows:

1. If necessary, expand the structure by choosing View→Expand Below.

6. Managing absolute occurrences
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2. Select the top line that is the context of this edit and choose Edit→Toggle In-Context Mode. You
can also right-click the line and choose Set In-Context, or click the  button on the toolbar.

If a line in the displayed structure is marked with a  icon and colored green, it is the item that is
the context for the creation of absolute occurrences. if a line is grayed out, it is not in the selected
context and you cannot create absolute occurrences for these lines. The in-context item is also
identified in the title bar of the structure tree.

• You cannot enable in-context editing mode for a line that has no children.

• You cannot create an absolute occurrence in the context of its immediate parent.

• You cannot change the value of a property that is already overridden at a higher level.

3. Click the cell in the lower line containing the property you want to enter or edit. You must select
one of the following supported properties:

• Suppressed
• Position constrained
• Suppression constrained
• Any GRM relation impacted by preferences
• Any occurrence note
• Quantity
• Find number
• Occurrence type
• Variant conditions
• Variant formula
• Absolute transformation matrix
• Unit of measure
• Is designed in place
• Requires positioned design

Caution:

Ensure you have selected in-context editing mode. If this mode is not selected, the change is
made to every instance of the selected item anywhere in the assembly.

4. Type the required new value and press the Enter key. A  icon on the line indicates one of its
property cells has an absolute occurrence override.

Note:

If you create an absolute occurrence override of a property and the same property is already
overridden at a lower level in the structure, the new, higher level value replaces the existing value.

Create absolute occurrences
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Conversely, you cannot edit an individual property value if the same property is overridden at a
higher level in the structure.

Identify absolute occurrences

You can assign identifiers to absolute occurrences and these identifiers are displayed in two columns in
the property table, as follows:

• ID In Context (Top Level)

Shows only the identifier assigned to the line in the context of the loaded top-level line. You can add
or edit an identifier by double-clicking in this cell and typing the necessary value.

Note:

Any absolute occurrence identifiers defined at a lower level than the currently selected top-level
line are not visible.

If in-context editing mode is disabled, the top-level line is always considered the in-context line.

• ID In Context (All Levels)

Shows the identifiers assigned to the line in all contexts. You cannot edit this column.

Change absolute occurrence override data

You can change the override data for an existing absolute occurrence at any time. For example, you may
want to change the quantity assigned to a structure line to correct a previous error. It is not necessary
to enable context editing to make such changes, ensure only the correct context is selected, then
double-click the property cell and edit the value.

Note:

If you want to define relative occurrence data for a property that is already defined in context,
remove the absolute occurrence data from the property first.

Remove absolute occurrence override data

You can remove override data from an absolute occurrence without entering replacement data. To do
this, right-click the property to remove (that is, select the relevant cell) and choose the Remove In
Context Override command.

6. Managing absolute occurrences
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Deselect in-context editing mode

When you are not creating or editing absolute occurrence data, consider deselecting in-context editing
mode to avoid inadvertent changes. Do this by choosing Edit→Toggle In-Context Mode or clicking the

 button in the toolbar.

Associating data with absolute occurrences

About associating data with absolute occurrences

During the design process, an engineer may attach data such as a CAD design file, viewer (JT) file,
classification information, and specifications to an item revision. The actual usage of the item revision in
the structure, including its transformation, is tied to an occurrence.

You can attach data to a specific instance of an item revision in the structure, which is represented by an
absolute occurrence. You can attach data that is unique to the absolute occurrence, or information that
is already attached to the associated item revision or occurrence. Examples of data that you may want to
attach to a specific absolute occurrence include:

• Cost data

• Transformations

• Quantity

• Variant conditions (not modular variant expressions)

• Viewer information

• Name and ID

• Occurrence note, type, or find number

• Instance number

• Find number

• Occurrence position constrained

• Occurrence suppressed

For example, you may want to attach a different occurrence note to each absolute occurrence to specify
additional assembly work instructions.

Deselect in-context editing mode
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The level of the absolute occurrence in the structure determines the precedence of data you attach to
it. Data attached at a high or mid-level in the structure override the corresponding data at lower levels;
data attached to an absolute occurrence at the lowest level does not override data elsewhere.

Associate a dataset or form with an absolute occurrence

1. Ensure you have selected in-context editing mode by choosing Edit→Toggle In-Context Mode,
right-clicking the structure line, and choosing Set In Context; or clicking the  button on the
toolbar.

2. Select the line containing the absolute occurrence with which you want to associate a new
instance-specific dataset or form, then click the Attachments tab in the data pane.

3. If you are associating a new dataset or form, create it by choosing File→New→Dataset or
File→New→Form, respectively.

If you are replacing an existing dataset or form, select it in the Attachments tab. You can then
search for and insert a replacement dataset or form.

Associate a transformation with an absolute occurrence

Note:

You cannot associate a transformation (positioning information) with an absolute occurrence in
Teamcenter manufacturing process management; you can only make the initial association in
Structure Manager.

1. Ensure you have selected in-context editing mode by choosing Edit→Toggle In-Context Mode,
right-clicking the structure line, and choosing Set In Context; or clicking the  button on the
toolbar.

2. Select the line containing the absolute occurrence for which you want to change the
transformation.

3. Click the Graphics tab and choose Graphics→Transformation→Persistent Transformation.

4. Change the position of the affected component and save the changes.

Associate an occurrence note with an absolute occurrence

1. Ensure you have selected in-context editing mode by choosing Edit→Toggle In-Context Mode,
right-clicking the structure line, and choosing Set In Context; or clicking the  button on the
toolbar.

6. Managing absolute occurrences
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2. Select the line containing the absolute occurrence with which you want to associate an occurrence
note.

3. Choose View→Notes, or click the Notes button on the toolbar.

Teamcenter displays the Notes dialog box.

4. Type the properties of the note and click OK.

Apply a variant condition to an absolute occurrence

1. Ensure you have selected in-context editing mode by choosing Edit→Toggle In-Context Mode,
right-clicking the structure line, and choosing Set In Context; or clicking the  button on the
toolbar.

2. Select the line containing the absolute occurrence with which you want to associate a variant
condition.

3. Choose Edit→Variant Condition or click the Edit Variant Conditions  button on the menu bar.

Teamcenter displays the Variant Condition dialog box.

4. Add a new variant condition to the absolute occurrence or edit the existing variant condition.

View attachments associated with an absolute occurrence

To view all the attachments associated with an absolute occurrence, select the line containing the
absolute occurrence and choose the Attachments pane. All the attachments to the absolute occurrence
are shown below the absolute occurrence.

Note:

If incremental change orders are used at your site, attachments associated with unconfigured
changes may be hidden. To view all absolute occurrence data, choose View→Show Unconfigured
Changes and set unconfigured changes to on.

Associating occurrence data in the context of a composition

A composition is a structure that comprises components from different top lines, in the context of a
configured top-level assembly. It is represented by a single line in the structure. It can contain a set
of occurrences, absolute occurrences, occurrence group and filtered occurrences (a filtered occurrence
references occurrence groups from the item it instantiates). For example, a composition may contain the
design view and the process view of the same assembly.

Apply a variant condition to an absolute occurrence
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When you view a composition, the revision rule and variant conditions for the referenced window
configure the occurrences, if they are linked to a referring window by a corresponding absolute
occurrence for the relevant top level. The occurrence groups are configured according to the
configuration of absolute occurrences in the top level.

You can associate data to any of the absolute occurrences in the occurrence group, in the context of
the composition. You can subsequently view the data associated with absolute occurrences included in
occurrence groups in the structure.

If the content (members) of an occurrence group in the composition is changed in another location,
your view of the occurrence group is refreshed. Such changes may be made in the source or in another
instance of the group that is referenced in a composition.

You can change an occurrence group in the composition (for example, adding or removing members)
without having to return to the source view. Any changes you make to the composition are proliferated
to all other instances of the occurrence group.

Create occurrence groups in a composition

You can create occurrence groups containing absolute occurrences in a composition, as shown in the
following figure.

Occurrence groups in a composition

The absolute occurrences for this composition are as follows:

6. Managing absolute occurrences
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Component Absolute occurrence Parent

Process A1 None

Operation 1 A2 A1

Resource 1 A3 A2

Consumed Item C1 A4 A2

Consumed Item C2 A5 A2

Occurrence group 1 A6 A2

Occurrence for S1 A7 A6

Occurrence for S11 A8 A7

Occurrence for C5 A9 A8

Occurrence group 1 (2) A10 A2

Occurrence for C5 A12 A8

The absolute occurrence of C5 in occurrence group 1 contains a copy of the entire path to the referring
occurrence. This is necessary to map this instance of C5 to the corresponding instance in the product. If
the path is already copied for another absolute occurrence, it is reused and not recopied.

You can configure a structure in a composition by associating a configurator context with it. You can
paste or drag the configurator context onto the referenced structure, and the configurator context
object appears as an attachment to the top line of the structure. Alternatively, you can right-click the
configurator context and choose Attach Configurator Context to send it to the referenced structure.

Add components in a context

You can add components to a structure in the context of the top level. These components are then
visible when you select the top line of the structure. The following examples show how resources may
be attached to a structure:

Welding_Cell 1

Robot from
Classification

Standard Definition

Welding Gun 1→Added in context of cell 1

Welding_Cell 2 Robot from
Classification

Add components in a context
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Standard Definition

Welding Gun 1→Added in context of cell 2

Factory 1

Welding Cell 1

Robot

Support Column 1→Added in context of Factory1

Welding Cell 2

When you open factory 1, you see welding gun 1 in the context of cell 1 and support column 1 in the
context of factory 1. If you view the same robot in My Teamcenter, none of these components are visible
as they are not part of a standard robot.

To do this, you can create an absolute occurrence in the context of a top-level item. Add welding gun 1
in the context of cell 1 by adding an absolute occurrence to cell 1 under the robot.

Note:

When you create an absolute occurrence for a top-level item, you also create absolute occurrences
for all children of a parent under which you add the component.

Data precedence

About data precedence

You can associate data with an item revision or absolute occurrence. You can create the absolute
occurrence in the context of a top-level item.

The following figure shows how visualization (JT) files may be attached to items.

Attaching visualization files to items

6. Managing absolute occurrences
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In this example, you can see file1.jt in the viewer in My Teamcenter without any context. However,
when you view the same item revision (ItemRev1) in the context of TopItem1, you see the JT file
(file2.jt) that is associated with the corresponding absolute occurrence (appr1) in the context of item
TopItem1/A.

You can associate a different JT file as an override if TopItem1 is revised from revision A to revision B.

Data is associated with an absolute occurrence in the context of a specified revision. When you revise an
item, the data associated with the previous revision is copied and you can change it as necessary.

Propagate override data

You can associate data to absolute occurrences in the context of an intermediate level, as well as in the
context of the top level, as shown in the following figure.

Propagate override data

In this example, ItemRev1 has two override JT files, file2.jt and file3.jt. The file2.jt file is added in the
context of TopItem1/A, while the file3.jt file is added in the context of S11/A. Consequently, if you view
ItemRev1 in the context of TopItem1/A, you see the file2.jt file.

Override data in the context of a composition

You can associate data to a composition in the context of an operation or process setup. The following
figure shows how you may override data in the context of a setup.

Propagate override data
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Override occurrence data in the context of a composition

This structure contains occurrences (Resource 1, and consumed items C1 and C2) and a collection of
absolute occurrences (occGroup1). This collection consists of absolute occurrences a6 and a7 which
Teamcenter configures if you load Product 1. Thus, a6 and a7 in the process structure are absolute
occurrences in the context of occGroup1. The consumed item C1 is an occurrence in the setup for
Operation 1 and is linked to absolute occurrence a4 in Product 1.

Note:

The process structure may also have its own absolute occurrences.

You can override data in the context of the process. You can also override data in the context of Product
1 through the absolute occurrences in the occurrence groups. The override data is controlled by a rule
that allows you to attach JT files at a top level and at an intermediate level. Consequently, a JT file
attached to c5 under Occurrence Group 1 in the context of the Operation 1 BOM view revision (BVR)
overrides the default file, and also the file associated with a6 in the product 1 BVR.

If you create absolute occurrences for the process structure and (assuming P6 is the occurrence for C5),
the data attached to P6 in the context of Process overrides data attached to a6 in the context of the
Product 1 BVR.

Override data in multiple contexts

You can create absolute occurrence data on a single line in more than one context. For example, you
may want to override the find number in the context of the top-level assembly and the quantity in the
context of a lower level assembly. Make these in-context edits in turn, ensuring you have selected the
correct context (line) each time. The system shows the relevant absolute occurrence data for the current
context and consequently data that applies to other contexts is hidden.

6. Managing absolute occurrences

6-14  Multi-Structure Management, Teamcenter 2412
© 2025 Siemens



Note:

You cannot change the value of a property that is already overridden in a higher level context.

Understanding ID in context and assigned products

When assigning a product to a process or copying processes or operations from one process structure
to another, Teamcenter can assign the same ID in context (IDIC) to the structure lines in the source
and target structure. Doing so provides a method for Teamcenter to find the assigned objects in the
other structure, for instance, when using the Find in Other Structure menu command or running an
accountability check.

This mechanism is controlled by two preferences:

• MECopyIdInContextToAssignedLine

If set to True, Teamcenter copies any existing in-context IDs to the target structure when assigning a
product to a process or copying a process or operation from one structure to another. If an in-context
ID does not exist, Teamcenter creates one on the source and copies it to the target object. Any
generated IDs are unique within the source and target structures.

If set to False, no in-context ID is copied.

• MECopyIdInContextLowerLevels

If set to True, Teamcenter copies any existing in-context IDs of consumed items under subprocesses
and suboperations to the target structure when copying a process or operation from one structure to
another. If an in-context ID does not exist, Teamcenter does not create one.

If set to False, no in-context ID gets copied for the consumed items under subprocesses and
suboperations, even if one is present.

Note:

The MECopyIdInContextLowerLevels preference is considered only if
MECopyIdInContextToAssignedLine is set to True.

In the following example, if you copy process P1.1 from Proc1 in the upper pane to Proc4 in the lower
pane:

• Teamcenter only generates an in-context ID for the process that is being copied. It never generates an
in-context ID for subprocesses, suboperations, or their consumed items, regardless of the settings for
these preferences.

• If MECopyIdInContextToAssignedLine = false and MECopyIdInContextLowerLevels = false,
Teamcenter does not copy any in-context ID.

Understanding ID in context and assigned products
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Note:

For P1.1, the ID is not generated at the source if it is not present (in the following example, it is
already generated).

After copying, under the Proc4 process, note that there are no in-context IDs in the ID In Context
(Top Level) column.

• If MECopyIdInContextToAssignedLine = true and MECopyIdInContextLowerLevels = false, the
in-context ID for P1.1 and I1.1 only are copied. The existing in-context ID for I1.2 is not copied
because I1.2 is the consumed item of a lower level.

Note:

For P1.1, the in-context ID is generated at the source if it is not present and then copied. For
I1.1, the ID is not generated if it is not present.

6. Managing absolute occurrences
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• If MECopyIdInContextToAssignedLine = true and MECopyIdInContextLowerLevels = true, the IDs
for P1.1, I1.1, and I1.2 are all copied.

Note:

For P1.1 the ID is generated at the source if it is not present and then copied. For I1.1 and I1.2,
if the ID is not present, it is not generated, but if it is present, it is copied.

Understanding ID in context and assigned products
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7. Associating the EBOM and MBOM
Assign occurrences between structures

1. Open the source and target structures in companion panes.

2. Configure the source and target appropriately. The root lines of the structures provide the context
for assignments.

3. Choose Tools→Link Structures.

Teamcenter links the source root and the target root. When these structures are linked, all
further assignments into the target from the source create logically equivalent occurrences. The
occurrences in the two are associated based on the AbsOccID property (also known as the in-
context ID) and the defined properties copied from the source to the target.

Note:

The MEAlignedPropertiestoExcludeFromInitialization preference defines the list of BOM
line properties that are not copied to an aligned target occurrence when it is initialized.

4. Rearrange the target for manufacturing purposes. The aligned occurrences and their properties
remain linked.

Note:

If you assign a line containing children from the source to the target, only the parent
line is given an IDIC. If you remove that parent line from that target, the children move
up a level in the hierarchy, but because they do not have an IDIC, they do not show up
as a match when running an accountability check between the two structures. Use the
MECreateIdInContextforAssignedchildlines preference to specify that Teamcenter assigns
an IDIC to the child lines when assigning the parent from the source to the target.

Carrying forward in-context attachments

If you work with source and target structures, when you assign structures from the MBOM to the EBOM,
you can carry forward attachments that are associated in-context in the EBOM. The same information
is available in the bill of processes (BOP), when MBOM occurrences with in-context information are
assigned to the BOP.

Three preferences manage in-context attachments. One preference manages how in-context
attachments from the MBOM are made available in the BOP. Your Teamcenter administrator sets the
preference values. It is helpful to know how these preference values control the behavior of in-context
attachments in your environment.
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Caution:

If preference values are not set, attachments are not carried over when you perform an assign
operation.

• MEAssignAttachmentAndRelationToUseInCopyRule – indicates which datasets are carried forward as
in-context attachments, and whether the datasets are treated as a reference or a copy.

For example, set the value to DirectModel:IMAN_Rendering:Reference to carry forward flexible
(deformable) parts as in-context attachments referenced in the MBOM.

• MEAssignAttachmentContext – sets the context for the in-context attachment of an assigned
occurrence from the EBOM to the MBOM, as either set the top line of the MBOM or a direct parent of
the occurrence assigned from the EBOM to the MBOM.

• MEAssignPropertiesInContext – carries forward the in-context overridden value of a property on an
occurrence or its child in an EBOM when assigning that occurrence from the EBOM to the MBOM. This
feature is supported for the absolute transform matrix (bl_plmxml_abs_xform) only.

• MEAssign_support_incontext_below_consumed – makes in-context datasets available as attachments
and transforms overrides for child lines of consumed lines from the MBOM to the BOP.

Rolling up variant conditions

You can optionally propagate rolled-up variant conditions when you assign parts from a source to a
target part structure or from a product BOP to a plant BOP. As a result, the BOM lines in the target or
plant BOP hold the same variant conditions as the corresponding BOM lines in the source or product
BOP. Teamcenter copies the variant condition on the source line, rolls up the variant conditions of all
parents of the source line, and then propagates the rolled-up variant condition to the target line, as
shown.
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The top levels of the source and target must be linked for correct propagation of rolled-up variant
conditions. Teamcenter calculates the rolled-up variant condition by traversing from the source line
to the linked top or up to the installation assembly level, and then adding together all the variant
conditions found during the traversal.

If the source line does not have variant conditions, Teamcenter calculates the rolled-up variant condition
by considering the variant conditions of the parent and all levels above.

The accountability check is modified to recalculate the rolled-up variant condition on the source line and
compare it with the variant condition already stored on the associated target line. It then reports any
partial match discrepancies between the variant conditions.

By default, rolling up of variant conditions is disabled and must be enabled by
setting the Rollup_Variant_Feature site preference to true. You should also set the
RollUp_Variant_Traverse_Level_Is_InstallationAssembly preference to determine the level to which
rolled-up variant conditions are calculated. If this preference is set to TRUE, Teamcenter calculates the
rolled-up variant condition by traversing up to the installation assembly level in the structure. If the
preference does not exist or is set to FALSE, it calculates the rolled-up variant condition by traversing up
to the linked top.

If the rolled up variant expression is too long, your administrator can create the
Rollup_Variant_Optimized_Format preference and set it to TRUE. Teamcenter then optimizes the rolled
up variant expression for storage and display.

Rolling up variant conditions
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The following installation assembly preferences must also be set:

• PortalDesignContextIsInstallationAssemblyMethod

• PortalDesignContextIsInstallationAssemblyMethod.hasIRType.Type

• PortalDesignContextIsInstallationAssemblyMethod.has_bomline_prop.name

• PortalDesignContextIsInstallationAssemblyMethod.has_bomline_prop.value

Note:

For the EBOM/MBOM scenario, Teamcenter calculates a rolled-up variant condition only if an
assignment is made from the EBOM to the MBOM and both structures are linked.

Rolled-up variant condition supports the Teamcenter Product Configurator and classic model, not
with modular variants.

The rolled-up variant condition is saved in optimized form in the database but, when you view it,
you see a summation (AND calculation) of all variant conditions from the source line to the linked
top. Consequently, the rolled-up variant condition displayed on the target line may contain some
redundant clauses. This helps you decompose the variant condition to its constituent building
block expressions.

Additional preference settings:

• Set PSM_enable_product_configurator to true.

• Set Rollup_Variant_Feature to true.

• Add bl_formula to the MEAlignedPropertiesList preference.

• Make sure bl_formula is not in any preferences beginning with MEAlignedPropertiesToExclude...

Run an alignment check

Perform an alignment check

If a source structure linked to a target structure is modified, broken links or other anomalies may occur.
To identify and resolve such issues, run an alignment check to assess the alignment (logical equivalence)
of occurrences in the source and target.

1. Open the two structures in separate structure views. Teamcenter considers all contexts for the lines
in scope. The check compares specific properties of the logically equivalent occurrences that are
under the designated scope.

2. If packed lines are present, unpack the structures before performing the alignment check.

7. Associating the EBOM and MBOM

7-4  Multi-Structure Management, Teamcenter 2412
© 2025 Siemens



3. Select a line in the source structure as scope for the alignment check.

4. Choose Tools→Alignment Check .

Teamcenter opens the Alignment Check dialog box with the source structure already selected.

5. In the target structure, select the line you want as scope and click Add selected  in the
Alignment Check dialog box.

6. Click OK.

Teamcenter initiates the assessment and, when it is complete, displays the Structure Alignment
Check dialog box showing the results.

The upper table shows all pairs of occurrences, regardless of whether they match. Pairs with
matched data are marked with a  symbol, while pairs with mismatched data are marked with a

 symbol.

The lower table shows all the properties of the currently selected pair of occurrences, allowing you
to visually identify mismatched properties.

Note:

The MEAlignedPropertiestoExcludeFromDetection preference defines the list of any BOM
line properties that are not compared between aligned occurrences.

7. (Optional) Click Save As Report in the dialog box.

Teamcenter displays a Structure Alignment Check Report dialog box that allows you to choose a
name or accept the default report name.

8. (Optional) Synchronize the data of all occurrence pairs or selected occurrence pairs, as follows:

a. Choose each pair of occurrences whose data you want to synchronize by selecting the
corresponding check boxes in the V column of the Alignment Check Results table in the
Structure Alignment Check dialog window. To select all lines for synchronization, click .

b. Click Update.

Teamcenter updates the properties of the target lines of all selected pairs. After the update
completes, the Match status of the selected pairs is updated and the corresponding check
boxes disabled.

If any of the selected pairs cannot be synchronized, Teamcenter displays an error message.

Perform an alignment check
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Note:

The MEAlignedPropertiestoExcludeFromSync preference defines the list of BOM line
properties that are not copied to an aligned target occurrence when it is synchronized.

Note:

The results of the alignment check may be incorrect and an attempt to synchronize aligned
occurrences may fail if the precision of aligned occurrences does not match, that is, one
occurrence is precise and the other is imprecise.

Teamcenter assumes you use the same unit of measure (UOM) value for the same item
throughout the system. The comparison does not check if the quantity differs between
occurrences because different UOMs are used. In this case, the result may indicate a mismatch, but
it would be incorrect to update the quantity without also updating the UOM value.

Compare properties

You can optionally identify individual properties that are mismatched between the source and target
lines. This avoids the necessity to inspect all the properties of the mismatched lines to determine if
synchronization is required.

1. Run the structure alignment check as described in Perform an alignment check.

Teamcenter displays the Structure Alignment Check dialog box.

2. In the Alignment Check Results list, select the appropriate structure line and click Show in Tree.

Teamcenter highlights the source line in the main pane.

3. Select a row in the Alignment Check Results list, and then select the Show only mis-matched
properties check box.

Teamcenter updates the Properties Comparison list to show only those properties that are
mismatched.

Note:

If you do not select the Show only mis-matched properties check box, all properties
are shown and mismatched properties are highlighted in bold. The properties are listed in
alphabetic order after the Object property, which is always listed first.

4. (Optional) Click Update Selected.

Teamcenter updates the mismatched properties, synchronizing the source and target line pairs
selected in the Alignment Check Results list.

7. Associating the EBOM and MBOM
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Finding and interpreting alignment reports

• Alignment reports are stored in the My Teamcenter Newstuff folder if the
MEAlignmentCheckReportLocation preference is set to False or are attached to the item revision
of the top line of the structure if it is set to True.

You can retrieve an existing alignment check report for a selected occurrence (structure line) from the
Newstuff folder or by clicking the Attachments tab in the data pane when the top line of the MBOM
is selected.

• If a report with the specified name already exists, the TC_CRF_overwrite_existing_dataset_content
preference controls if the existing report is overwritten. If this preference is set to 1, the existing
contents are replaced, otherwise the new report is appended.

• The creation and format of the report is determined by the following preferences:

• MEAlignmentCheckReportDefinition

This preference specifies the name of the report definition object that controls creation of the
report. The default value is AlignmentCheckReportDefinition.

• MEAlignmentCheckReportStylesheet

This preference specifies the name of the style sheet used when creating alignment check reports.
A default style sheet is provided, but you can create your own style sheet using the Report Builder
application. The default value is AlignmentCheckReport.xsl.

• The report format is similar to that provided for the accountability check, as described in Running
accountability checks. However, you should note the following differences:

• The Source column includes no indentation because the alignment check only considers aligned
nodes.

• The Target column cannot contain multiple targets. Instead, multiple target lines may be listed for
a source line.

• The Match column may show a mismatch, even though the user already performed an update
action. This occurs if the comparison properties differ from the synchronization properties. In this
case, the column shows if the update action was performed successfully, not whether the lines now
match.

Save and replace in context

The manufacturing engineer can create a new target substructure from an existing one, while
preserving the occurrence information on the line. Typically, this is done to create a new subassembly

Finding and interpreting alignment reports
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when it is not possible to revise the existing subassembly, possibly because the existing target is still in
use on the shop floor.

This situation arises in the aerospace industry to create a new kit from an existing one. It is also useful
when manually creating an target from a source in cases where you do not want to use a different item
type for manufacturing parts. Use this menu command on each level in the structure for which you want
to create a manufacturing-specific part.

• Select the top line of the subassembly and choose File→Save As→Replace Assembly In Context.

Teamcenter creates a copy of the subassembly and propagates existing alignments to the copy. All
relationships of the items in the kit are preserved, regardless of GRM rules. Options and variant rules
are not carried over from the original line.

If this action is performed in the context of an incremental change, it is recorded.

7. Associating the EBOM and MBOM
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8. Managing changes
Incremental change overview

You can control changes to a structure by revising the affected items. Because many changes may
be small and not related to each other, Teamcenter allows you to create incremental changes to add
components to and remove them from the structure. Each incremental change consequently comprises
several individual and possibly unrelated revisions to a component, occurrence, or attachment in the
structure.

An incremental change groups several individual changes that can be released simultaneously to a
baseline of the process or product. You can define an effectivity for an incremental change, allowing (for
example) all changes related to the production of a new model to be implemented simultaneously. You
normally assign an effectivity expressed as a date range or sequence of serial numbers to the change,
ensuring that all grouped additions and removals happen at the same time.

An incremental change may have revisions, and you can configure the various components, occurrences
and attachments to a specific revision by applying appropriate revision rules.

Understanding change objects

You can create a change object to control changes within a collaboration context. The change object
affects the structures shown in the collaboration pane and each structure pane. You can configure
different effectivity dates or numbers for each of these panes with their revision rules. Any attachments
to the structure are also affected by these revision rules.

You can make changes to any structure by adding an occurrence to it or removing an occurrence from it
without creating a new revision through these incremental changes. The change object is identified by a
unique change ID. The change ID is an effectivity identifier either in terms of a date or a serial number.
Serial numbers are identified with an end item.

You can attach more than one change object for the same type of change to a structure. For
example, you can attach a new dataset associated with the first change order, which is effective from
1-March-2011 to 30-March-2011, you can later add another dataset for a second change object of the
same type, which is effective from 1-June-2011 to 30-June-2011. Teamcenter prevents you making
duplicate changes by attaching the same change object more than once.

You can also create a baseline item revision by configuring all the incremental changes.

A single change can add or remove multiple objects from an item or item revision. A single object can
be added to an item or item revision with different effectivities by several changes, and removed with
different effectivities by several other change objects.
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Show or hide incremental change management

Using incremental change management is optional. To use it, your administrator must set the
Incremental_Change_Management preference to true. When this preference is set to false, the
incremental change toolbar is not visible and any loaded items or relationships under incremental
change control display in a different color.

Turn off incremental change tracking

Click the  button in the incremental change toolbar.

Teamcenter changes the Active IC box to display No Active IC. No edits are tracked.

Setting up incremental change

Before using incremental change, you must complete several setup procedures, including creating the
necessary change types, providing users with access, defining releases statuses, and writing revisions
rules.

Customize buttons

Incremental changes are displayed by icons at the beginning of a structure line. When you add or
remove a structure line, Teamcenter displays a plus or minus icon in front of the respective line.

• Customize when incremental change icons are displayed by choosing Tools→Incremental
Change→Display Icons and selecting the contexts in which you want to see the icons.

• Choose Tools→Incremental Change→Display Icons→Hide/Remove Icons to always hide the display
of the icons in the tree structure.

• If your administrator sets the MoveICCreationToMenu preference to True, the  button on
the incremental change toolbar is hidden. If this button is not visible, use the Incremental
Change→Create menu command to create a new incremental change, unless this command is
suppressed.

Create a new incremental change

1. Click the Create Incremental Change button .

Teamcenter displays the Create/Revise Incremental Change dialog box.

2. Click the IC Attributes tab and set the following incremental change attributes:
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• Type an ID and revision for the change object. Alternately, click Assign to let the system assign
this information for you.

• (Optional) Type a description for the incremental change.

• Select a change type from the Incremental Change Type list. Note that some of these types
may be for general changes, not incremental changes.

3. Click the Effectivity tab and specify whether to set effectivity for the incremental change using unit
serial numbers or dates by doing one of the following:

Note:

You cannot specify an effectivity until the incremental change is released. An incremental
change may be released by a workflow process that is specific for your company or site.

If you do not specify an effectivity, Teamcenter creates the change object without a status.

The administrator determines the initial release status of all new incremental changes by setting a
site preference. If the preference is not set, you cannot set effectivity while creating the incremental
change. You must release the incremental change (revision) separately with the appropriate
process. Once the release status is attached, you can set the effectivity on the incremental change.

• Click Units and specify the range of serial numbers to which the effectivity is to be applied. You
can also click one of the following buttons:

• UP button to define an unlimited effectivity from a starting number. For example, typing 1-UP
means the change is effective from unit 1 upward.

• SO button to define an effectivity until all stock is exhausted. For example, typing 1-SO means
the change is effective from unit 1 until no stock remains.

Tip:

The tooltip provides you with more information about the formatting for this entry.

• Click Dates to set effectivity based on calendar dates. Multiple date ranges can be entered. To set
a date:

• Type the start and end dates for the effectivity period into the From Date and To Date cells in
the date table.

• Select a date in the calendar table and click Set Date to specify both the From Date and the
To Date entries.

When the correct effectivity is shown, click OK.

Create a new incremental change
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4. If unit effectivity is set, populate the End Item box on the Effectivity tab using one of the following
methods:

• From the list of most recently used end items

• Using the Search function to open an item by name or ID

• By pasting an item from the clipboard

5. Click OK to finish creating a new incremental change and close the dialog box, or click Cancel to
cancel the operation.

Teamcenter creates a copy of the new incremental change in your New Stuff folder.

6. At an appropriate time, the designated user or a workflow process approves the change object by
adding the release status. The change object is now locked and you cannot use it to track further
changes to the process or operation.

Note:

You can use a Workflow handler that renames the status and retains the effectivity, for
example, the add_status handler with a –remove option.

Showing unconfigured changes

You can configure the display of the tree table to show the following:

• All components and attachments.

• Only those components and attachments that are configured by the current revision rule.

To control the display of unconfigured changes:

• Choose View→Show Unconfigured Changes to toggle between showing all lines or only those set
by the current revision rule.

Note:

You can add a button to implement this function to the toolbar, allowing you to easily see
the current mode. To do this, right-click the toolbar, choose Customize, and click the required
button.

To identify changes made in the current context, click the Changed by Current IC Edit Context column
header to re-sort the structure into changed and unchanged lines. This allows you to more easily identify
the changes made to the structure in the current context.

8. Managing changes
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Find and make active an existing change object

When an incremental change is active, all edits are made in the context of that incremental change.
Teamcenter shows the ID and name of the incremental change in the incremental change toolbar. If the
Incremental Change pane states No Active IC, no incremental change is active.

1. Click the Select an Incremental Change context button .

Teamcenter displays the Select an Incremental Change context dialog box.

2. Type either the name or ID of the change object to be displayed. You can use wildcard search
characters, if necessary.

3. Click Find.

All change objects matching your selection criteria are displayed in the dialog box. Use the
navigation buttons at the bottom of the dialog box to navigate the list.

4. To select an incremental change object for display, double-click the change object in the dialog box
list.

View or edit information about an incremental change

Do one of the following:

• Click the View/edit current IC information button .

• Click More IC Info in the Incremental Change data tab.

Teamcenter displays the View/edit Change dialog box, which includes the following tabs:

• IC Attributes shows the change object name, description, and tag type.

• Incremental Changes shows the individual changes to components, attachments, created/deleted
data, and occurrence notes that are tracked against this incremental change.

• Effectivity allows you to view and edit the effectivity of the change object if you have the access
permission to do so. Double-click a specific release status to open a dialog box containing all the
effectivity information for the selected release status.

• Intents displays the intents for which the incremental change is valid.

You can create a new intent by clicking the Intent button and typing the appropriate information in
the Create Intent dialog box. You can then add the intent to the incremental change by ensuring it
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appears in the Intent to add box and clicking +. You can also search for existing intents and add them
to the incremental change.

Note:

To make the Intents tab visible, set the EnableIntents preference to true.

You can also use the icons on a structure line to identify adds, removes, and absolute occurrences. For
attachments, these icons are displayed in the Attachments pane, not the main pane.

View incremental changes for a structure

To view all the incremental changes associated with a structure, select a line in the structure and click
the Incremental Change Info data tab. For each line, this pane lists:

• Type

For attachments only, specifies the type of incremental change, create, delete, add, or remove. Note
that edits to attachments are shown as create types.

• IC Context

Specifies the incremental change objects affecting the structure, listed in the order they are applied.

• Release Status

Specifies the release status of the incremental change object, for example, Production.

• Effectivity

Specifies the date or unit number effectivity of the incremental change.

• IC Configured By

Specifies the revision rule that configures the incremental change for this structure. This allows you to
see if an incremental change is configured and, if so, how it is configured.

For attachment changes, the affected lines and changed relationships are also listed. For occurrence
attribute changes, the affected attributes and changed values are also listed.

To see more information about an incremental change, double-click the line in this pane; Teamcenter
displays the changes made by the incremental change.
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Find recently used change objects

Click the Most Recently Used button ( ) to display a list of previously used incremental changes from
which you can choose.

Track attachments with incremental changes

You can create an attachment to an item revision and track its status with an incremental change object,
as follows:

1. Ensure you have created the appropriate incremental change object and that it is active. The active
incremental change is shown in the Incremental Change Edit Context box in the incremental
change toolbar.

2. Click the Attachments pane.

3. Select the structure line corresponding to the item revision under which you want to create the
attachment.

4. Select the root node (item revision) in the Attachments pane.

5. Create a new attachment by choosing File→New→Dataset/Form.

Alternatively, you can attach an existing object by copying the dataset or form to the clipboard,
then pasting it to the root node (item revision) in the Attachments pane.

Note:

• If you open, check out, and then close a form associated with an item revision in the context of
an incremental change, the checkout not retained on the form.

• When open, check out, save, and then close a form associated with an item revision in the
context of an incremental change, the checkout is retained on the form.

Track changes to an attachment

To track changes (edits) made to an attachment, select the attachment (dataset or form) and choose
Tools→Incremental Change→Edit Attachment.

Teamcenter also tracks edits if you double-click the dataset or form. With a dataset, the change is
tracked when you open the form to edit; with a form, the change is tracked only when you click OK or
Apply. Teamcenter tracks the changes by creating a copy of the dataset or form.

The Attachments pane displays the appropriate version of the attachment according to the configured
incremental change against which the edits were tracked.

Find recently used change objects
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Note:

You can view the original, unchanged attachment in My Teamcenter.

If you open an attachment, check it out, and then close it, the checkout lock is not retained. The
checkout is retained only if you save the attachment at least once before closing it.

Track the creation or deletion of an attachment

You can track the creation of a dataset or form against an incremental change, so that the attachment
itself has an effectivity that is derived from the effectivity of the incremental change; this is in addition to
the effectivity applied by the incremental change that attaches the attachment to an item revision. This
feature may be useful if the attachment is attached to more than one item revision.

• To track the creation of an attachment, select the attachment in the Attachments pane and choose
Tools→Incremental Change→Create on Object.

• To track the deletion of an attachment, select the attachment in the Attachments pane and choose
Tools→Incremental Change→Delete on Object.

Track changes retrospectively

If you forgot to activate an incremental change, you can retrospectively track changes by making the
incremental change active and doing one of the following:

• Select the item or attachment that you wanted to track as added and choose Tools→Incremental
Change→Add.

• Select the item or attachment that you wanted to track as removed and choose Tools→Incremental
Change→Remove.

Teamcenter saves edits immediately to the database. It is not necessary to choose the Save Changes
command.

You can only make changes to the active incremental change, that is, the one shown in the Incremental
Change Edit Context box in the incremental change toolbar. If you try to edit an incremental change
that is not configured by the current revision rule, Teamcenter displays an error message.

Remove incremental changes

You can remove individual incremental changes one of two ways, from the Incremental Change
Information pane or with an Incremental Change menu command.

8. Managing changes
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Note:

You require write access to edit structures with incremental changes in this way.

For structure and attachment changes:

• If the corresponding change is a remove, Teamcenter deletes it.

• If the corresponding change is an add and the user has write access to the parent BVR, Teamcenter
deletes the add but not the occurrence. If you want to remove the occurrence, choose Edit→Remove.
If the user does not have write access, the deletion request fails.

For occurrence attribute changes, if the change to undo is an add and it is the only change to the
attribute, the change and the override value are both deleted. In other cases, only the change is deleted.

Remove changes from an item with the Remove Changes command

1. To remove changes to an occurrence, select the corresponding structure line.

To remove changes to a dataset or form, select it in the Attachments pane.

2. Choose Tools→Incremental Change→Remove Changes.

Teamcenter displays the Remove Incremental Changes dialog box.

3. Select the check box next to each change you want to remove, or click Select All to remove all
changes, then click OK.

Note:

Occurrence attributes are not displayed in the Remove Incremental Changes dialog box; you can
only undo them from the Incremental Change Information pane.

Remove an individual change from the incremental change
information pane

1. In the Incremental Change Information pane, select the structure line of the occurrence or
attachment whose changes you want to remove.

2. Select the change to undo and click Undo Change, depending on the change type that you want to
remove. You can undo multiple changes in a single operation.

Remove changes from an item with the Remove Changes command
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Split an incremental change

You may want to change the effectivity of some of the incremental change elements in an incremental
change. As all elements of an incremental change have the same effectivity, you can only accomplish
this by moving some of the incremental change elements into a different incremental change. To do
this, choose Tools→Incremental Change→Split. You can move the incremental changes to an existing
change object or create a new change object for the purpose.

Exporting and importing incremental change data

About exporting and importing incremental change data

You can export changes (deltas) to the structure if they are tracked by incremental changes in two
formats—TC XML using a briefcase file or PLM XML. Teamcenter allows you to export the structure
changes alone (not the entire structure) without needing to create a new revision. The exported
changes contain all the relevant data required by the importing site to achieve the same structure
configuration as exists at the exporting site. You can export multiple independent, dependent, or
overlapping incremental changes in a single action.

When you use this feature, you must ensure the structure is configured with the required effectivity
and revision rules before initiating the export. Effectivity and revision rules are not exported with the
changes; you must ensure they are identical in the exporting and importing sites separately.

Teamcenter tracks and exports the following changes when they are tracked by incremental changes:

• Adding a new or existing line to the structure

• Adding a new or existing subassembly to the structure

• Removing a line or subassembly from the structure

• Modifying relative occurrence properties

• Creating or modifying absolute occurrence properties

• Adding a new or existing attachment to a line, for example, a form or dataset

• Deleting an attachment

• Modifying an attachment

When exporting incremental change data using PLM XML:

• The structure must be fully configured.
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• Any related changes that are not tracked by an incremental change are not considered for export.

• Changes in the context of incremental changes are considered as export candidates. For example, if
you add, modify or remove a structure line in the context of an incremental change, all of its parents
up to the top level are exported in addition to the affected line. However, the siblings of lines affected
by the incremental changes are not exported.

• If you add, modify, or remove a subassembly under an incremental change, its children exported even
though they are not directly affected under the incremental change.

You can create an incremental baseline for a structure that was already exported. This action creates
a new revision of the structure. As active changes are carried forward into the new incremental
change baseline revision, you may add new incremental change elements (ICEs) affecting the new
structure revision to the incremental change revision that is the parent of the original active ICEs. (This
incremental change revision may already be exported for the original structure.) Because the new ICEs
do not affect the revision of the structure that was exported when you perform a TC XML export, they
are exported as a stub. The incremental baseline action has no additional effect on the export of the
original structure and the incremental change revisions that affect it.

Export incremental change data using a briefcase file

1. Choose Tools→Export→To Briefcase.

Teamcenter displays the Export To Briefcase Via Global Services dialog box.

2. Click the Display/Set export options button  in the bottom right-hand corner of the dialog box.

Teamcenter displays the TIE Export Configured Export Default dialog box.

3. Select the check box corresponding to each of the export options you want to use and then click
OK.

Teamcenter closes the TIE Export Configured Export Default dialog box.

4. In the Export To Briefcase Via Global Services dialog box, enter all the required information
including Reason, Target Sites, Option Set, Briefcase Package Name, Revision Rule, and Variant
Rule, and then click OK.

Note:

Ensure you select the TIEConfiguredExportDefault transfer option set to export incremental
change based deltas.

Teamcenter displays the Remote Export Options Setting confirmation dialog box.

5. Click Yes.

Export incremental change data using a briefcase file
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Teamcenter starts the export of the product structure using the options you entered.

Import incremental change data using a briefcase file

1. Choose Tools→Import→From Briefcase.

Teamcenter displays the Import from Briefcase Without Global Services dialog box.

2. Navigate to or type the path and file name of the briefcase file in the Briefcase File box. Select
TIEConfiguredImportDefault from the Option Set list.

3. Click the Display/Set export options button  and select the desired options.

4. (Optional) Select the Site Check-In after import box. If you select this box, all objects that are
checked out to the unmanaged site are checked in during the import process. Otherwise, you must
check them in individually after they are imported.

5. Click Yes to begin the import.

Note:

The importing site does not verify it has the same base structure against which the delta was
calculated.

If you select a collaboration context for export of incremental change deltas, the export file
includes the structure context and configurator contexts contained in it, as well as the configured
incremental change data.

Export incremental change data using PLM XML

1. Choose Tools→Export→To PLMXML.

Teamcenter displays the PLMXML Export dialog box.

2. Enter the required export directory, file name, choose the appropriate IC delta transfer mode (for
example, ConfiguredDataExportDefault), and then click OK.

Teamcenter displays a confirmation message if the export is successfully completed. It generates
the output PLM XML file in directory the location shown in the PLMXML Export dialog box.

Import incremental change data using PLM XML

1. Choose Tools→Import→From PLMXML.

Teamcenter displays the PLMXML Import dialog box.

8. Managing changes

8-12  Multi-Structure Management, Teamcenter 2412
© 2025 Siemens



2. Enter the name of the PLM XML file to import, choose the appropriate IC delta transfer mode (for
example, ConfiguredDataImportDefault), select the required incremental change context, and
then click OK.

Teamcenter displays a confirmation message if the import is successfully completed. It imports only
changes to the structure, as captured in the exported PLM XML file.

Create an incremental change baseline item revision

Changes to a process plan can be managed by making incremental changes, which are tied to
incremental change objects. This enables you to track and configure the changes without forcing you
to create a new revision. After making several sets of incremental changes, you may want to roll up
the changes made into a new baseline revision. The baseline item revision allows you to create a new
revision of an item by capturing all the changes made using incremental change objects until the
configuration date or unit number. The baseline item revision can be created at any stage.

Note:

Incremental change baselines are not the same as structure baselines created with
Tools→Baseline.

1. Select an item revision and choose Tools→Incremental Change→Incremental Change Baseline.

Teamcenter displays the Baseline dialog box.

2. Type a name and a description. Teamcenter displays the selected item revision and revision ID by
default. These boxes cannot be edited.

3. Click OK.

Modify a process or plant structure

If a process structure or plant structure is write-protected, you can still modify its structure with
incremental changes. You can also add datasets or forms to an item revision or remove them from
a revision by defining an incremental change.

Create an incremental change baseline item revision
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9. Managing variants
Working with variants—overview

Variant configuration allows you to create options (for example, color) and allowed values for each
option. You can then associate these options with an item revision. For example, you might create an
option called color with allowed values of red and blue. You usually implement variant configuration
against a top-level assembly, but it is possible to implement them anywhere in the structure. You can
then define a variant condition on those occurrences subject to variant rules. A variant rule is a set
of options and values (for example, color = red, material = cotton) that is stored in the database. For
example, you can specify only load IF option color = red in the variant rule. You can also set multiple
variant rules. These are then evaluated using an OR expression. For example, color = red or color =
green. To configure a particular variant of the assembly or product, you must set the appropriate variant
rules.

Although Teamcenter provides you with two methods to create variants, modular or classic,
Siemens Digital Industries Software recommends that you use only classic variants when working
with manufacturing. To ensure that the variant mode always opens in the classic mode, set the
PSEVariantsMode preference to legacy.

For more information about creating variants, see Structure Management on Rich Client ─ Usage.

Configure, view, or edit variant data

1. Choose Tools→Variants.

2. Choose one of the following commands:

• Configure

Allows you to configure or edit a variant structure for a selected top-level module. Applicable to
classic variants and modular variants.

For more information, see Test product configuration.

• Only configure root

Set to on to only display options for the top-level module, regardless of the line selected. Set to
off to configure the structure for a lower level module. Only applicable to modular variants.

When working with the manufacturing view of the product, you would not configure the
structure for a lower level module. However, you may want to do this for debugging purposes to
check that all options are set in the lower-level modules when the top-level module is completely
set (this verifies all options have a value). To do this, set the Only configure root option to off.
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Otherwise, you set Only configure root to on, and the Configuration dialog box only displays
options for the top-level module, regardless of the BOM line selected.

• Search

Allows you to search for a variant item. This option is only applicable to modular variants.

For more information, see Search for a variant item.

• Count Modules

Allows you to count the module defined for the selected variant structure. This option is only
applicable to modular variants.

• Unlink variant item

Allows you to unlink a variant item from the generic module item. This option is only applicable
to modular variants.

For more information, see Unlink variant items.

• Update variant item

Allows you to manually propagate changes to associated variant items when you create a new
item revision of a generic item.

Test product configuration

Before working with the manufacturing view of a product, you may want to test the product is
completely authored. To do this, set all option values for the relevant variant of the module, select
each lower-level module (possibly starting at the lowest-level modules), and check that all the option
values are set correctly.

1. Select the BOM line representing a module and choose Tools→Variants→Configure.

Teamcenter displays the Configuration dialog box, allowing you to confirm all the option values
are set.

2. Repeat the previous step for each module in turn. The Configuration dialog box is updated
dynamically, and it is not necessary to redisplay it each time you select a new module.

3. If any lower level module is not completely configured, see the Structure Management on Rich
Client ─ Usage for information about how to define further constraints in the higher level modules
or present lower level options to the top level module, as required.

9. Managing variants
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Search for a variant item

A variant item is a specific variant of a completely configured module, for example, a door assembly.
Variant items are physical parts with no variability and may be allocated a manufacturing part number.

You cannot manufacture modules themselves. Modules may have a large number of options,
potentially resulting in a correspondingly large number of product permutations, not all of which
can be manufactured. You may want to reuse permutations that have previously been manufactured,
particularly if significant work was invested in creating the associated technical documentation,
drawings, and manufacturing data. You can attach such associated data to the variant items.

1. Choose Tools→Variants→Search.

Teamcenter displays the Variant Item Search dialog box. The dialog box contains a table that
shows the public options of the selected module, including the option name and a default value (if
set). You can display further details about the options (for example, the allowed values and option
type) in a tool tip by positioning the cursor over the option name.

2. Define variant item requirements, that is, the option values to find, in the Required Value column.
To increase the chances of finding the variant item, define search requirements as loosely as
possible, as follows:

• Do not provide requirements for nonessential options. Enter value requirements for logical
options and freeform string options (allowable values not defined) in the same way as you set
configuration values. Leave the value blank, select a single value for a logical option or type a
string value.

• Select multiple allowable values for enumerated string options from the list. Each time you click
a value, Teamcenter adds it to the dialog box. Click a value again to remove it from the dialog
box.

• Enter ranges for numeric options. When you type in requirements for numeric options, a parser
checks that the entered value conforms to the modular variant language (MVL) syntax. It also
checks that the ranges are within the allowable values of the option. Examples of allowable
numeric ranges are:

• <=200, >500

• 100200

• -5–10, <20

For information about MVL, see the Structure Management on Rich Client ─ Usage.

3. After you specify the requirements, execute a query for matching variant items by clicking the
Search button. Teamcenter displays the search results at the bottom of the dialog box showing the
matching variant items.

Search for a variant item
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If the query is successful, the identifiers and names of variant items whose values match the search
criteria populate the list next to the Search button. If more than 25 variant items are found,
Teamcenter displays a message recommending you refine the search requirements.

The search only finds linked variant items—unlinked variant items may have structure changes and
would therefore not be applicable.

4. If the variant item search is successful, Teamcenter loads the first variant returned by the query and
shows its values in the Value Found column. You can select a different variant item from the list,
and Teamcenter loads it and updates the Value Found column. If you alter the search requirements
in any way, Teamcenter changes the summary above the Search button to indicate you should
execute the query again.

Unlink variant items

You may want to unlink the variant items from the generic module item so that you can change the
variant item. This is desirable if you use the generic structure as a quick way to create variant items for a
particular customer order and the generic order is then customized for the specific order.

1. Choose Tools→Variants→Unlink Variant Item.

Teamcenter displays the Unlink Variant Item dialog box.

2. Click Yes to confirm deletion of the variant item. When you unlink variant items, they are not
found during a variant item search, because they have evolved and may not be appropriate for the
purpose. However, if appropriate, you can reuse it in the structure for a new order.

Note:

You cannot relink a variant item after you have unlinked it from the generic module.

9. Managing variants
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10. Searching structures
Searching a structure for items on the clipboard

You can search a currently active BOM structure for any item that you previously placed on the clipboard.
To do this, choose Tools→Find Clipboard Items to search the structure for all instances of an item
on the clipboard. Teamcenter selects and highlights the corresponding line in the structure if it finds a
match.

If the item on the clipboard has no BOM information, the search is unsuccessful. For example, if you
copy an item to the clipboard with the Copy Line Item menu command, no BOM information is copied
and this search does not find a match. If you copy the item with the Copy menu command, the
associated BOM information is also copied and the search finds a match.

You can search for occurrence groups in this way, in addition to individual items.

Searching for the closest match

When you search for a component across BOMs, Teamcenter looks for the closest match. This allows you
to search for a component in one BOM that is a close match but not identical to a component in the
other BOM. If it finds any instance of the component in the second BOM that has the same path from
the top line item, it stops; otherwise, it detects if there are any instances of the component in the second
BOM that share the same absolute occurrence of the component in the first BOM.

Search in context

The default search context with an opened BOM tree is the root line of the tree. However, you can
choose to make any BOM line in the tree the search context by making it the absolute occurrence
context. Once you have done this, the system searches in the context of this BOM line when it performs
a search or accountability check. The result is the same as if the search or accountability check is done
on a tree (with in context mode turned off) with this BOM line as the root. A BOM line has a valid context
as long as occurrence paths with respect to the underlying item of this line have been stored for its
children.

This rule is overridden if you choose the search ALL LOADED contexts in target option on the
Accountability Check dialog box. When this option is set, the system searches all contexts it finds
in the tree, no matter if the in context mode is set or not. In this case, the system checks every loaded
BOM line to see whether it has a valid context associated, and then that context is searched.

1. Select the desired BOM line.

2. Click  to turn on the in context mode.
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3. Type the ID (name) of a predefined absolute occurrence in the text box next to the In Context
Search button  at the bottom of the pane.

4. Click .

Find related component in other structure

When a component has been assigned from one structure to another, you can find the related
component in the source or target. You can search for occurrence groups in this way, in addition to
individual items. To initiate a search:

1. Select a line in the structure.

2. Copy it to the clipboard.

3. Click the Find Selected in Other Panel ( ) button. Teamcenter selects and highlights the
corresponding line in the alternate structure if it finds a match.

When you search between structures in this way and an exact match is not found, the system
identifies the closest match, as described in Searching a structure for items on the clipboard.

Search by name

You can search for and open a collaboration context or structure context by name or object ID.

1. Click one of the following:

Button To open a

Collaboration context

Structure context

2. Type a new structure name or ID.

Note:

You can type an asterisk (*) as a wildcard character if you do not know the entire name or ID.

3. Click Find or press the Enter key.

All products that match your search criteria are listed in a table in the open structure dialog box.

10. Searching structures

10-2  Multi-Structure Management, Teamcenter 2412
© 2025 Siemens



4. Double-click a structure in the table. It is opened in the structure pane.

Perform a where-used search

You can search a structure context or collaboration context to identify where an item selected in the
structure hierarchy is used.

A where-used search must take into account the revision rule when searching the structures. You can
choose to search for:

• All revisions

Reports all item revisions that have an occurrence of the source item revision. This displays all possible
combinations of usage that could possibly occur; depending on the revision rules, not all paths may
be realized.

• Only the configured revision

You select a revision rule to apply. The search result is filtered to include only those revisions that
are configured by the selected revision rule. This rule is applied at each level of the structure, up
to and including the top level. Any intermediate level nonconfigured revisions referenced by precise
occurrences are also displayed.

1. Select an object in a structure tab.

2. Click the Referencers data tab and set the Where box to Where Used.

3. Set the Where-Used Rule box as required:

• Click All to report all revisions.

• Click the required Revision Rule from those listed to report only the configured revisions.

4. Set the Where-Used Depth box as required:

• One Level to report immediate parent objects only.

• All Levels to report all objects up to the top-level product.

• Top Level to report final objects only.

5. On the Referencers tab, double-click the object for the search. The results of the search display on
this tab.

6. Double-click any of the resulting objects to continue the where-used search.

Perform a where-used search
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Search by where-referenced criteria

You can search a structure context or collaboration context to identify where an item selected in the
structure hierarchy is referenced.

1. Select an item from the tree hierarchy on a structure tab.

2. Click the Referencers data tab and set the Where box to Referenced.

3. Double-click the object for the search to display the results in this tab.

4. Double-click any of the resulting objects to continue the where-referenced search.

Searching appearance sets by spatial and attribute criteria

Searching for appearances

You can search large products by spatial and attribute criteria and display the results in the navigation
tree and the viewer. You can search a configuration of an end item for which an appearance set is
already defined. (An appearance set is a collection of objects that defines the usage of every part
included in an end item.) Your Teamcenter administrator defines appearance sets, but typically only for a
few end items that represent large assemblies to allow fast searches.

When you search BOM lines on a large product, you can restrict the search to a specific spatial region.
For example, you may want to find all parts that are located within two centimeters of part X. To
allow spatial searches, Teamcenter maintains spatial data in addition to the appearance set. Maintaining
spatial data is optional and you can create appearance sets without spatial information).

You can only search if an appearance set exists that matches the active BOM. An appearance set
matches the current BOM if the following are true:

• Your Teamcenter administrator has created the necessary appearance sets.

• The end item of the appearance set corresponds to the top (root) line of the BOM.

• The view of the appearance set is the same as the current BOM window.

• The revision rule (for example, Pending) of the appearance set corresponds to the revision rule of the
current BOM window (for example, Pending as of 1-Jan-200X).

Start an appearance search

1. Click the Appearance Search button in the toolbar.

Teamcenter displays the Search dialog box.
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2. Use the Search dialog box to specify one or more of the following search criteria:

• Item name

• Classification family or attributes

• Occurrence notes

• Spatial information

To specify search criteria, click the button to the right of the appropriate box and type the necessary
information in the window. If you enter several criteria, all are included in the search. For example,
you can search for all bolts with a name starting with bo and within 3 cm of another part.

3. Click the Search  button to start the search.

Teamcenter displays a list of results matching your search criteria.

Note:

Click the Clear All  button to clear any previously specified criteria.

4. If you choose an entry from the results list, the system highlights it in the current structure, if the
item appears in the BOM.

You can hide or show the search criteria pane with the Appearance Search button on the toolbar.

Search by item identifier

• To search for an item when you know the item identifier, type the identifier in the Item ID box.

• Use wildcards if you do not know the item identifier. For example, you can type 57h* in the Item ID
box to find all items whose identifiers start with 57h.

• To specify advanced item attribute criteria, click the button to the right of the Item ID box to display
the Item Attributes dialog box.

Search by classification data

You can search for appearances that are assigned to a Classification category. Click the button to the
right of the Classification box and Teamcenter displays the Family Attributes dialog box.

Search by item identifier
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Note:

Classification searches are available only if you create two or more Classification categories.

To search by category:

1. Click the button at the top of the Family Attributes dialog box.

Teamcenter displays a list of all available Classification classes.

2. Double-click a listed class to select it.

3. Repeat the previous steps as necessary if you want to search more than one class. For example, if
you select the Bolt class and the Nut class, Teamcenter finds all items that are classified as a bolt or
a nut.

If you select a single class, you can further refine the search to include specific attribute values. For
example, if you select the Bolt class and want to locate a particular size of bolt, do the following:

1. Click the Bolt line in the Family Attributes dialog box.

Teamcenter displays the Classification Attribute Criteria dialog box.

2. Click the Add button and specify additional attribute criteria. You can specify multiple attribute
criteria; for example, you could specify thread=.25 and Lock_Wire=1.

Searching by occurrence notes

Your Teamcenter administrator defines those occurrence notes that are mapped to appearance attributes
for a given appearance set. You can use these mapped occurrence notes as search criteria.

For example, a mapped occurrence note may indicates if a given part is used on the interior or exterior
of the product. You can search by occurrence notes to identify all brackets on the exterior.

Similarly, a mapped occurrence note may be a number that references a specific illustration in a service
manual that describes how to disassemble the part. You can then search by occurrence notes for all
parts illustrated in the appropriate section of the manual.

Searching by spatial data

Teamcenter supports two types of spatial filters:

• Proximity
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Limits the search to parts that are within a given distance of a specified part. For example, you could
search for all parts within ten centimeters of part X.

• 3D Box

Displays a translucent green box at a default location in the viewer. Use the Spatial Filtering dialog
box to define the origin and size of the box. The search returns all parts partially or completely
enclosed by the 3D box.

Use the Search Type buttons in the Spatial Filtering dialog box to select one of these search types.

Note:

You can use altreps to define different physical configuration shapes for a flexible part such as a
tube or hose. Any spatial search takes into account the alternate geometric shape of a flexible part
by accessing the dataset that corresponds to the altrep defined on the occurrence object.

The Spatial Searching dialog box enables you to visualize mixed unit assemblies, that is,
assemblies composed of parts defined in both inches and millimeters. The dialog box displays
the units that are in effect when you enter dimensional values (for example, spatial distance in the
Spatial Searching dialog box).

Define a spatial filter with the 3D box

1. Click the Spatial Filter button in the search pane.

Teamcenter displays the Spatial Filtering dialog box.

2. In the Spatial Filtering dialog box, click the Search Type button labeled 3D Box.

Teamcenter displays a green box at a default location in the viewer.

3. Select one or more parts in the viewer, then click Center to Selected.

Teamcenter repositions the 3D box so that it encloses the selected parts.

4. In the Spatial Filtering dialog box, edit the origin and size of the box, so that it is oriented with
respect to the global axes of the end item.

5. Click OK to start the search.

The 3D box remains visible during the search although the associated dialog box closes. The search
returns all matching parts that are partially or completely enclosed in the 3D box.

Define a spatial filter with the 3D box
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Define a proximity filter

1. Click the Spatial Filter button in the search pane.

Teamcenter displays the Spatial Filtering dialog box.

2. In the Spatial Filtering dialog box, click the Search Type button labeled Proximity.

3. Select graphically or in the navigation tree one or more base parts.

4. In the Spatial Filtering dialog box, type a proximity distance. The search is limited to those parts
within the specified proximity distance. To satisfy the proximity condition, any portion of a part
must be within the proximity distance; the complete part may not be within the proximity distance.

5. Click OK to start the search.

Performing advanced structure searches

About advanced structure searches

The Structure Search view helps you perform a multitude of searches. The search mechanism searches
a structure using various properties of the structure's lines. The search is not limited to the loaded lines
of the structure and can search an entire structure without loading it. It then reports the results in the
Structure Search Results view and partially expands the structure to the found lines.

Note:

A partial expand occurs only if the Expand to Selection option in the Manufacturing section of
the Options dialog box (Edit→Options) is selected.

You can:

• Search large process, product, plant, or occurrence group structures with spatial criteria, or with a
combination of spatial and attribute criteria. Spatial searches are particularly useful for end items that
represent large processes containing a large number of lines, allowing you to focus quickly on the
manufacturing needs of a particular area or part of the product.

Note:

The search does not return matches found in occurrence groups that are assigned to an
occurrence group.

• Search for features in a structure based on different search criteria such as searching for weld points
assigned to specific processes or arc welds connected to specific parts.
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• Perform a search for objects found in a specific classification class or containing a specific classification
attribute value.

• Store the search criteria and search results in the Structure Search view. These can then be reloaded
or shared by different users.

For more information about common view features, see About views.

Making attribute searches

You can search structures for all objects that contain the following:

• Item and item revision attributes

You can refine the search by including attributes of the item or item revision. Typically, this is the item
ID, but you can use any attributes stored on the item master or revision master forms.

• Occurrence notes

You can refine the search with values for occurrence attributes (occurrence notes).

• Attributes of forms

You can refine the search with the attributes of forms that are attached to an item, item revision,
in-context form, or their subclasses.

Making spatial searches

A spatial search, also referred to as a cacheless search, allows you to enter search criteria as numerical
values or by dragging a search box in the viewer to find those objects that are within these spatial
boundaries. Teamcenter displays the results of the search as a list of matching occurrences (structure
lines). Selecting an entry in the list highlights the occurrence in the structure tree pane and in the
embedded viewer.

You can refine spatial searches with other attribute searches.

You must complete certain installation and configuration steps before you can run spatial searches.

Making classification searches

You can extend your search to include classification attributes. This is called a classification ad hoc
search. You can search through classified data and find objects contained within a class you specify and
containing attribute values that you specify.

Making attribute searches
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Perform a structure search

1. Open the structure and select the top line against which you want to search.

You can select a process, operation, product, plant or occurrence group. You can also select
multiple top lines in the same structure or substructure.

2. Do one of the following:

• Choose Tools→Structure Search.

• Choose Structure Search from the shortcut menu.

Teamcenter displays the Structure Search view.

The structure line you select represents the scope of the search and is listed in the Scopes box.

3. (Optional) Click  to add more lines to the search scope or clear the scope.

• Select a line in the structure and click  in the Scopes dialog box to add a scope.

• Select a line in the Scopes dialog box and click  to remove the line from the scope.

• Click Clear  in the Scopes dialog box to clear all scopes.

The columns names and widths that are initially displayed in the scope
list are configured by the MEAdvancedSearchResultsViewColumnsShownPref and
MEAdvancedSearchResultsViewColumnsShownWidthPref preferences.

4. (Optional) Load an existing search by clicking Open Search  to load a saved search.

5. From the Query type list, select a search type.

Note:

The available search types depend on the structure type you are searching.

6. Use the criteria sections to specify the search criteria pertaining to the type of search you selected.

Click the ... button to the right of each individual search criteria box and enter search criteria in
the resulting dialog box. All the criteria you enter are combined so that you can, for example,
search for all bolts whose name starts with bo and are within 3 centimeters of another part.
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7. Select Show results in a new tab if you want to display each set of results in its own tab in the
Structure Search Results view. If this check box is not selected, Teamcenter overwrites the results
of the last search in the same pane.

Note:

The Show results in a new tab check box is not visible on the Structure Search view until
after the first structure search is performed.

8. Click Search  to begin the search.

Teamcenter starts the search and loads the lines into the Structure Search Results view.

You can manage the search results in the Structure Search Results view.

9. (Optional) Select a line in the Structure Search Results view to highlight the corresponding item
or item revision in the structure tree and the embedded viewer.

Tip:

The Display and Blank commands in the shortcut menu control the visibility of the search
results in the embedded viewer.

10. (Optional) Click Clear  to clear individual search criteria from the search, or click Clear All to
clear all criteria from the Structure Search view.

11. (Optional) Save the structure search.

Save a structure search

You can store a search and, optionally, its results for future reuse. You can also allow other users access
to this search.

Teamcenter saves the search in a SearchStructureContext object that includes a saved configuration. If
you reload a saved search, the configuration in effect at the time of storage is also loaded.

Teamcenter saves the following configuration information at the time of storage:

• Current revision rule (with the effective date, end item, or unit number)

• Variant rule

• Effectivity group objects

• State of the Show Unconfigured buttons

Save a structure search
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• If the search is performed on a process structure and any part of the search contains lines from a
composition structure, the configuration of those related composition structures

1. After entering search criteria and running a search, do one of the following:

• Click  on the toolbar of the Structure Search view, or choose Save from the View Menu to
save a new search, or update a loaded search with new criteria and results.

• Choose Save As from the View Menu to save the search under another name. This may be
necessary if, for example, you do not have write access to the original saved search but still want
to modify it.

2. Enter a name and, optionally, a description for the search.

3. Select one of the following.

Option Action

Search definitions Saves the entries in the Structure Search view.

Search definitions and consistent
results

Saves the entries in the Structure Search view and
additionally, all results that are compatible with the
current scope of the search.

4. To grant read-only access to other users for this search, select the Is shared? check box.

This allows other users to select and run this saved search when they load saved searches. Other
users cannot modify this search. They must use the Save As command to save any modifications.

5. Specify the location in the database to store the search by clicking Create in and selecting a folder.

By default, Teamcenter stores the search in the My Saved Searches folder in My Teamcenter. You
can create other folders to organize your searches by clicking New Folder.

6. Click OK.

Rename an existing search

1. With a search open in the Structure Search view, choose Save As from the View Menu.

2. Click Create in to expand the Save Search dialog box.

3. Select the search that you want to rename from the Existing Saved Searches list and click
Rename.

4. Type a new name for the search and click OK.
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Assign access rights to a saved search

1. With a search open in the Structure Search view, choose Save As from the View Menu.

2. Click Create in to expand the Save Search dialog box.

3. Select the search for which you want to modify access rights from the Existing Saved Searches list
and click Access.

4. Click the Get access control list. button  in the lower-right corner of the Access dialog box.

The system displays the ACL Control List dialog box.

5. In the ACL Control List dialog box, choose the entry that you want to modify.

Note:

You can only change entries you have created or entries you have been given permission to
change by the Teamcenter administrator.

6. Grant or deny privileges for the type of accessor by double-clicking in the column corresponding to
the privilege you want to modify.

• Select the check mark  to grant a privilege.

• Select  to deny the privilege.

Note:

To clear a privilege box, double-click in the box and choose the blank entry from the list.

7. Click OK to save the list.

Load a saved search

Teamcenter saves the search in a SearchStructureContext object that includes a saved configuration. If
you load a saved search, the configuration in effect at the time of storage is also loaded.

1. Do one of the following:

a. Load a recently used search.

• In the Structure Search view, click the down arrow beside the Open Search .

Assign access rights to a saved search
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Teamcenter displays the most recently used searches.

• Select one of the searches listed.

Teamcenter displays the Open Saved Search dialog box where you can specify load
options.

b. Load a search not recently used.

A. In the Structure Search view, click Open Search .

Teamcenter opens the Open Saved Search dialog box listing all the saved search objects
belonging to you. The Revision Rule, Variant Rule and Effectivity Group columns show
the information of the primary structure (for example, in the case of a process structure
where configurations of composition structures are also stored).

If you want to see the saved searches belonging to other users, select Show searches
shared by other users.

B. (Optional) View the detailed configuration of a search object by right-clicking it in the list
of searches and choosing Show Configuration.

The resulting Configuration dialog box shows the configuration of all composition
structures associated with the primary structure.

C. (Optional) Filter the list of searches by clicking .

D. (Optional) Click the arrow beside the Change your view button  and select the
format in which you want to display the saved searches. The tree view allows you to
display the folders that you create in the Save Search dialog box, and the table view
displays all the searches in list form.

10. Searching structures

10-14  Multi-Structure Management, Teamcenter 2412
© 2025 Siemens



Tree view Table view

2. Select a load option.

• Load search criteria only

Loads only search definitions so you can reuse a complex definition on a different structure
or scope. If the criteria includes the proximity search (and, therefore, a proximity part, which
is structure dependent), you must have the same structure open to load the proximity part;
otherwise, Teamcenter ignores the proximity criteria.

• Load search criteria and scope

Loads the search definitions and the original search scope so you can re-execute the search and
to display refreshed results.

• Load search criteria, scope and results

Loads everything that is available in the saved search (scopes, definitions, and results). This
option is selected by default. If the object selected in the table does not have results stored,
Teamcenter loads only the search criteria and scope by default.

3. Click OK.

Teamcenter loads the object including those parameters that you specified. The loaded structure
lines represent the current state of the structure. These may differ from the lines that were saved
with the object. Consider these situations:

• If structure line properties or occurrence notes were changed after saving, the new values of
the properties or occurrence notes are displayed in the loaded results. You do not receive any
indication about changed values or inconsistent results.

Load a saved search
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• If the item revision was changed after saving the results and the Latest Working revision rule is
set, the new revision is displayed. You do not receive any indication about changed item revision
or inconsistent results.

• If the structure line was deleted or moved to other place after saving, the saved BOM line is
loaded in the results. Teamcenter displays information about inconsistent results in a tooltip on
the result tab. You must then update the saved search.

• If changes include a later revision of the top-line item,Teamcenter considers the structure to be
the same structure and tries to find all the search result lines in the structure.

Open a copied search

When you save a search, by default, Teamcenter stores it in the My Saved Searches folder in My
Teamcenter. You can copy this search and open it in Manufacturing Process Planner, Multi-Structure
Manager, or Multi-BOM Management. You can also add the saved search to the Favorites list and copy it
from there.

1. Find the desired search in My Teamcenter and copy it.

2. In the Structure Search view, click Open the copied search object .

Teamcenter displays the Load Search dialog box asking if you want to apply the saved
configuration to the search.

3. Choose Yes to run the copied search or No to select a new search.

Filter data in the Auto Filter dialog box

The Auto Filter dialog box narrows down the search results according to conditions that you create in
the Filter Condition Editor.

• The ALL option displays properties for all the children of the object currently selected in the
component view.

• You can use the Filter Condition Editor to create condition expressions for filtering the display.

• Expressions cannot be edited after they are listed in the Auto Filter dialog box, but they can be
deleted.

• Teamcenter retains your filter condition expressions until you delete them.

To create conditions, click Add a new search condition  to display the Filter Condition Editor.
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• To create an initial condition expression, select a property column value and a logical operator, and
then enter an object value or select one from the list of objects displayed in the table, and then click
Add a new search condition .

Note:

The = = operator tests for an exact match. The = operator tests for a match but is not case
sensitive.

• To expand the expression with additional conditions, use the ADD and OR operators.

• Click Remove the selected condition(s)  to delete the selected condition line.

• Click Clean all the conditions  to delete the entire expression.

• Click ...not meet the condition(s)  to negate the selected condition.

• Click OK to add the condition expression to the Auto Filter dialog box.

Update a saved search

After loading a search, do one of the following:

• Rerun the search to get the latest results.

• Modify the search definitions and click  to update the same saved object with new data. If you
loaded a shared search belonging to another user, you must have write access to update the search.

• If you load both search definitions and results and modify the search definition, rerun the search to
update the saved search object.

• Save the modified search as a new object by using the Save As menu command.

• Change whether the search is shared.

1. In My Teamcenter, find the search in the My Saved Searches folder.

2. Edit the Is Shared? search object property.

Delete a saved search

Do one of the following:

• In My Teamcenter:

Update a saved search
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1. Expand the My Saved Searches folder.

2. Select the search object you want to delete.

3. Click  in the toolbar.

• In the Structure Search view:

1. Open the Save Search dialog box.

2. Click Create In.

3. Select the search object you want to delete.

4. Click Delete on the right.

• In the Structure Search view:

1. Open the Load Search dialog box.

2. Select the search object you want to delete.

3. Click in the Load Search dialog box.

If you delete the search object currently loaded in the Structure Search view, the search context
is cleared from the view.

Entering search criteria

About search criteria

Each type of query that you select has its own criteria that you can use to define a search. You can
always refine your search by combining it with one or more of the criteria in the general criteria section.

Alternatively, you can load a saved search which populates the search criteria from the data stored in the
search.

Enter item ID or item attributes search criteria

To search for items whose identifiers, names, attributes, or types match a specific pattern:

1. Type an item ID or item name directly into the boxes. For example, you can type 57h* into the Item
ID box to find all items whose ID starts with 57h.

When you click outside the box, Teamcenter enters the search criteria into the Item attributes box.
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2. Click ... beside the Item attributes box to specify additional attributes to be taken into
consideration for the search. The search result must fulfill all specified search criteria.

You can also immediately open the Item Attributes dialog box without previously specifying an
item ID or name.

3. (Optional) Filter the search with saved search criteria by clicking Change.

Teamcenter displays the Change Search dialog box. You can choose any of your saved searches or
system-defined searches to filter the basic search results.

Note:

The Search and the Clear All buttons are available only after entering criteria in the Item
attributes box. You cannot perform a search or save one until this box is populated.

Enter occurrence note search criteria

• Click the ... button to the right of the Occurrence Notes box to search for specific occurrence note
values.

Your administrator can define occurrence notes and associate them with particular structure lines. You
can use these mapped occurrence notes as search criteria.

For example, a mapped occurrence note may contain an interior/exterior flag that indicates if a given
part is used on the interior or exterior of the product. You could then search for all parts on the
exterior of the product or, by refining the search with other criteria, for all exterior brackets.

Similarly, a mapped occurrence note may contain a number that references an illustration in the work
instruction manual that describes how to assemble the part. You can search for all parts illustrated in
the appropriate section of the manual.

Enter spatial filter search criteria

Enter the spatial search criteria

1. Click the ... button to the right of the Spatial Filter box.

Teamcenter displays the Spatial Criteria dialog box, allowing you to define one of two types of
spatial filters and optional target parts.

Note:

The spatial filter option is disabled if Teamcenter is not configured for cacheless searches or if
the necessary NX or JT files are not available.

Enter occurrence note search criteria
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2. (Optional) Select the Use selections from table check box above the Target Parts table if you
want to search against specified target parts.

3. Use the Proximity and 3D box radio buttons in the Spatial Criteria dialog box to select a search
type, and then click OK to save the selections.

• Proximity

Limits the search to parts within a specified proximity distance, for example, all parts within 10
centimeters of part X.

• 3D box

Allows you to define a three dimensional box in the embedded viewer and search for parts
completely inside, completely outside or intersecting the box. Use the Spatial Criteria dialog box
to define the coordinates and size of the box.

Note:

If you are making appearance searches, you can only search inside and intersecting the
box when TruShape filtering is selected.

Note:

You can use altreps (alternative representations) to define different physical configurations or
shapes of a flexible part such as a tube or hose. Spatial searching takes into account an alternate
geometric shape of a flexible part by searching the dataset that corresponds to the altrep defined
on the occurrence object.

Define a proximity filter

1. In the Spatial Criteria dialog box, select the Proximity button.

2. (Optional) Select True Shape filtering if you want to test items with intersecting bounding boxes
to identify if they have TruShape volumes that intersect the TruShape volumes of the selected
objects. Depending on the TruShape parameters configured, Teamcenter displays the geometry of
each object as regular cubes (voxels) to provide a simplified representation of the actual shape.
TruShape searches return more accurate results but may take longer to complete.

3. Define a proximity value in the Distance box in the Spatial Criteria dialog box and click OK.

Teamcenter limits the search to those parts within the defined proximity of the parts selected in the
viewer or structure tree. A part is considered within the proximity if any portion of it is within the
specified distance; the part may not be completely within the specified distance.
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Define a spatial filter with a 3D box

Note:

This procedure requires a mockup license for the viewer and is not available with the base license.

1. In the Spatial Criteria dialog box, select the 3D box button.

Teamcenter displays a brown bounding box at a default location in the viewer.

2. (Optional) Select True Shape Filtering if you want to test items with intersecting bounding boxes
to identify if they have TruShape volumes that intersect the TruShape volumes of the selected
objects. Depending on the TruShape parameters configured, Teamcenter displays the geometry of
each object as regular cubes (voxels) to provide a simplified representation of the actual shape.
TruShape searches return more accurate results but may take longer to complete.

3. Make the following selections to define the location and size of the 3D box:

• Slider increment

Specifies the actual distance equivalent to one increment of the Maximum and Minimum sliders
and spinners.

• Extents

Determines how Teamcenter constructs the bounding box from the values you specify, as
follows:

• Centroid and size

Allows you to specify the bounding box with coordinates of the centroid and lengths in X, Y,
and Z directions. It is oriented with respect to the global axes of the end item.

• Origin and size

Allows you to specify the bounding box with coordinates of the origin and lengths in X, Y, and
Z directions.

• Minimum and Maximum

Allows you to specify the bounding box with minimum and maximum coordinates. This is the
default selection.

• Maximum and Minimum sliders and spinners

Allow you to manually define the maximum and minimum extents of the bounding box.

Define a spatial filter with a 3D box

Multi-Structure Management, Teamcenter 2412  10-21
© 2025 Siemens



• Find Parts

Allows you to specify if parts returned by the search are fully contained inside or fully outside the
bounding box.

• Include parts intersecting the box

If checked, the search returns parts that intersect the bounding box, as well as parts that are fully
inside or outside it. This option is enabled only if you select the True Shape filtering option.

Note:

If you use appearance searches, this option is always checked.

• Enable 3D manipulators

If checked, drag handles are displayed on the bounding box, allowing you to move and resize it
manually. You can then drag the 3D manipulator to resize or reposition the bounding box.

4. (Optional) Do any of the following to move and resize the bounding box with the manipulators:
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To Do this

Move the manipulator parallel to a face. Drag the face of the manipulator.

Move the manipulator perpendicular to a
face.

Press Ctrl as you drag the face.

Constrain the move to one axis. Press Shift as you drag a face.

Resize the manipulator uniformly. Drag a corner of the manipulator.

Resize the manipulator along one axis. Press Ctrl as you drag a corner of the manipulator.

5. (Optional) Click Build from selections to construct a bounding box containing all target parts
specified in the Target Parts table, or selected in the tree or viewer.

6. Click OK to save the search criteria.

The 3D box remains visible while the search is active, even if the Spatial Criteria dialog box is not
open.

Note:

You can visualize mixed unit assemblies in the Spatial Search dialog box, that is, assemblies
composed of parts defined in both Imperial (English) and metric units. The dialog box uses the
appropriate units when you type in dimensional values, for example, spatial distance in the
Spatial Criteria dialog box.

Use target parts

As an alternative to manually generating the spatial search bounding box with the spinner and slider
controls, you can construct a bounding box quickly and accurately from a table of target parts. You can
use this method for proximity or 3D bounding box searches.

Note:

Generic objects such as GDE elements, GDE link lines, interface definitions, and processes are not
valid participants in spatial searches. Consequently, they are not added to the target parts table.
If you try to add a generic object to the target parts table, Teamcenter displays an error message
indicating the BOM line is invalid.

However, you can add valid generic objects such as signals and designs to the target parts table. If
you select these objects in the table or perform a search on them, Teamcenter displays a warning
message indicating that they do not have associated bounding boxes.

Note:

The target parts table is not available if you are making appearance-based searches.

Use target parts
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1. Select the Use selections from table check box.

Teamcenter enables the Target Parts table and its associated buttons.

Note:

If you select Use selections from table, any selections in the tree or viewer are ignored.

2. Select the structure tab that is the current scope for the structure search, select a product line in
the structure, and click the + button to add selected part in the Target Parts table.

To remove a target part, select it in the table and click the – button.

To clear the table of all entries, click .

3. Once all the required target parts are listed to the table, click OK. Alternatively, if you are defined a
3D box search, click Build from selections.

Teamcenter draws a bounding box enclosing all the target parts in the viewer.

4. Perform a spatial search.

Teamcenter displays the Search Results pane containing the results of the spatial search.
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Defining granularity of spatial searches

By default, spatial searches return piece parts, that is, parts rather than assemblies. However, you may
want the search to return a higher level assembly. For example, if you have small assemblies consisting
of parts welded together, you may want to treat the assembly as a unit, rather than returning some of its
individual parts.

You can change the search granularity by modifying the TruShape voxel size in NX to only return larger
assemblies. You can also disable TruShape voxel searches completely, if the results still provide useful
information. The coarser the search results, the more quickly they are displayed.

Enter classification search criteria

1. Click the ... button to the right of the Classification box.

Defining granularity of spatial searches

Multi-Structure Management, Teamcenter 2412  10-25
© 2025 Siemens



Teamcenter displays the Classification dialog box.

2. Click  to open the classification hierarchy.

3. Double-click a class name to select it from the tree.

Teamcenter adds a line to the table containing the name of the class you select.

4. Specify the system of measurement.

The systems available here (metric, nonmetric, or both) depend on the system in which the class is
stored in the Classification Admin application.

5. In the Property Name column, click the cell containing the name of the class.

Teamcenter displays a list of all the attributes within the class.

6. Select the class and attribute with which you want to search.

7. Click the cell containing the = sign and select an operator.

8. In the Searching Value column, select the cell and type a value for the attribute for which you
want to search.

9. (Optional) Click  to create an additional search parameter.

The lines of the table, each representing an individual search parameter, are joined by the AND
operator.

10. Click OK.

Teamcenter displays the classification search parameters in the main section of the Search view.

Filter search with form attributes

You can filter searches using the criteria of forms attached to the items or item revisions.

1. Click the ... button to the right of the Form Attributes box.

Teamcenter displays the Form Attributes dialog box.

2. Enter the form attributes for the search, including any mathematical operators.

a. Select the relation, parent, and form type for which you want to search.
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b. Click  to add a line.

c. Enter or modify the property name, operator, or searching value by clicking in those cells in
the table.

Teamcenter displays the form type and search values as a string in the format similar to the
following example:

“ItemRev:BVRSyncInfo:last_struct_mod=value1 AND ItemRev:BVRSyncInfo:
last_Sync_date=value2”

Manage search results

About search results

Search results are displayed in the Structure Search Results view. This view has two sections:

• Search Criteria section

This section displays the scope and the search criteria that you specified in the Structure Search view.
The contents of this section vary depending on which type of search you ran and which criteria you
entered.

• Search Result section

This section contains a table of individual lines representing the search results. Teamcenter displays
the search results as individual lines without indication of any structure.

Each time you run a new search in the Structure Search view, you can specify whether you want the
search results to open in a new tab in the Structure Search Results view or replace the contents of the
current tab. If you move from result to result (tab to tab), you can update the search criteria displayed in
the Structure Search view using the Repopulate Criteria button.

When Teamcenter displays the result of a search, the selection in the search results table is synchronized
with the selection in the structure view. When you select an object in the Structure Search Results
view:

• If the object is expanded in the structure that is being searched, Teamcenter automatically selects and
shows the object in the originating structure.

• If the object is not expanded, the synchronization depends on the MEExpandToSelection preference.
If the value is true, the application partially expands the object and shows it in the originating tree.
Otherwise, the selection is not synchronized in the originating structure.

About search results
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The same part may be listed many times in the search results if it has multiple occurrences in the end
item that match the search criteria. For example, the same bolt may be used seven times in the end item
and, if all seven usages satisfy the defined proximity filter, the bolt appears seven times in the search
results.

Lines in the search results table are actual BOM lines, and you can use the same shortcut menu
commands for these objects as you do for any structure line in the structure pane.

The Structure Search view is dependent on the configuration changes applied to the originating tree
structure, such as showing configured or unconfigured, revision rules, or configuration by occurrence
group. Changing the configuration of the structure pane causes the Structure Search Results view to
clear all relevant tabs.

Removing a line from the originating structure removes only this line from the results list. Unloading
the originating tree structure from the application causes the Structure Search view to clear all relevant
tabs.

If you unload the originating tree structure from the application, causes the Structure Search view to
close all associated tabs. The same thing happens if you change the configuration of the originating
structure.

View and manage the search results

In the Structure Search Results view, do one of the following:

• View search result lines in original structure.

Use the Find in Source Structure and Find in Other Structure shortcut menu commands to find the
search result line in the structures loaded in the structure pane.

• Copy or drag lines from the search results table.

You can copy and paste lines from the search results table to structures in the structure view. In
addition, you can drag lines from the search results table to structures in the structure view. When
doing this, the behavior is the same as if you drag the line from the searched structure itself. If you
drag the search result line to a structure other than the searched structure, it is as though you copied
the line in the searched structure and pasted it into a new structure.

• In the Search Criteria section, click Repopulate Criteria. This is useful if you navigate between
several search result tabs. As only one Structure Search view is available, you can use the
Repopulate Criteria button to update the Structure Search view with the search criteria active for
the current Structure Search Results tab.

• Customize the column display.

1. Click the View Menu button  and choose Columns from the view menu commands located in
the top-right corner of the Structure Search Results view.
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Teamcenter displays the Column Management dialog box.

2. Select the desired columns from the Available Properties list and move them to the Displayed
Columns with the right arrow.

3. (Optional) Modify the order the columns appear in the search results table using the up and
down arrows.

4. Click Save.

The columns names and widths that are initially displayed in the search results
list are configured by the MEAdvancedSearchResultsViewColumnsShownPref and
MEAdvancedSearchResultsViewColumnsShownWidthPref preferences.

5. (Optional) Save the column layout by choosing Save Column Configuration in the view menu
commands. You can restore a saved column layout by choosing Apply Column Configuration
and selecting the saved configuration from the list.

• Find individual search results.

Choose the Find in Display command from the view menu commands to define criteria and apply
them to the results list. Objects fulfilling those criteria are selected in the results list.

• Copy selected table data to the operating system clipboard. You can then paste this into any
document, for example a Word or Excel document.

• Export to Word and Excel.

Choose the Objects to Word or Objects to Excel View Menu commands to export search results to
Microsoft Word or Excel.

• Sort the search results.

You can sort the search results by clicking on the column header or by clicking the Sort button  to
open the Sort dialog box to define a more advanced sort. You can specify a primary, secondary, and
tertiary sort order for the columns.

• Hide the display of an object in the viewer.

You can hide or display a search result line in the assembly viewer. Select an object from the results
list, and choose Display option from the shortcut menu. If the assembly viewer is open, the user sees
the selected object in the graphical viewer beside the originating tree.

View and manage the search results
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11. Releasing preliminary structures
About baselining or preliminary structures

You can release intermediate structure data for other users or suppliers to review or consume. An
intermediate data release or baseline of in-progress data is sometimes called a preliminary data indicator
(PDI).

You must create a baseline (PDI) of the related product structure and plant structure before you create a
baseline of the process structure. This allows you to reproduce the process structure when necessary by
applying the appropriate product and plant configuration rules that were applied when you created the
PDI.

Creating PDIs

When you create a PDI, Teamcenter traverses each child of the structure, creates a new item revision
under a specified baseline revision ID, and releases the new item revision. It does not include any
occurrence groups in the structure in the PDI.

Creating a dry run

Before creating a new item revision for a PDI, you can optionally make a dry run to validate the
baseline. Teamcenter provides detailed status information about the structure. If there are any errors
in the structure, Teamcenter displays their details, halts the baseline process, and does not release the
structure. Your administrator can set a preference that determines if validation is always required before
you create the baseline, or if you can validate the structure only when you consider it necessary.

Creating precise and imprecise baselines

Depending on the configuration of your structure, you can create the baseline as a precise structure or
an imprecise structure. If you want a precise structure of a process, you must also baseline the product
structure and plant structure first to be able to reproduce the revision status of the PDI in the future. In
this case, all the relevant structures (product, plant and process) must be precise to allow their accurate
reproduction in future sessions.

Viewing a PDI

You can view a PDI immediately when the baseline is created. However, the revision rule is not
automatically applied when the baseline is loaded, and you must apply it manually.

You can also view the baseline in My Teamcenter and choose the appropriate item revision from the list
of available item revisions. You can distinguish baseline revisions from other released revisions by the
specific revision ID format as described in Create a baseline of a structure.
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After applying the proper configuration rule, you can save the baseline structure and view it in the
collaboration pane.

Create a baseline of a structure

1. Open the structure revision.

2. Select the top line of the structure and choose Tools→Baseline.

Teamcenter checks if you can create a baseline of the selected revision. If not, Teamcenter displays
the reason (for example, you cannot create a baseline from an existing baseline). Otherwise,
Teamcenter displays the Baseline dialog box, showing the item ID, baseline revision, and baseline
name.

3. Enter the following information in the Baseline dialog box.

Box Entry

Description Type a description of the baseline.

Baseline Template Choose a baseline release procedure template
from the list of available procedures. Your
administrator defines the available procedures
with the Baseline_release_procedures
preference.

Job Name Note the job name. The job name is
automatically generated and you cannot change
it. Your administrator defines the naming
scheme in the Business Modeler IDE application,
as described in the BMIDE for Data Model
Design.

Baseline Label Type an alphanumeric string that represents the
baseline label. Teamcenter uses the label you
enter as the name of the baseline folder. This
box is only displayed if your site uses baseline
labels.

Job Description Type a description of the PDI job.

Open On Create Select this check box if you want Teamcenter to
open the baseline for viewing when it is created.
You must apply the revision rule manually when
the baseline is open.

Dry Run Creation Select this check box if you only want to validate
the structure as suitable for creating a baseline.
If you clear this check box, Teamcenter validates
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Box Entry

the structure and creates an item revision for the
baseline.

Note:

Your administrator can set
the Baseline_dryrun_always system
preference to determine if a dry run is
always required.

Precise Baseline Select the type of baseline to create— precise or
imprecise. Your site may be configured to allow
only precise baselines, depending on the setting
of the Baseline_precise_bvr preference.

4. Click OK or Apply to create the baseline. Alternatively, you can click Cancel to exit without creating
a baseline.

Teamcenter optionally creates a baseline folder to hold the baseline. Your administrator specifies if
a folder is created by setting the baseline_create_snapshot_folder preference.

If the value of this preference is 0, the baseline folder name is in the format
Baseline_ItemId_BaselineRevId and may be truncated to 32 characters, if necessary. The folder
is attached to the top structure.

If the value of this preference is 1, the baseline folder name is the alphanumeric string you entered
in the Baseline Label box in the Baseline dialog box.

Note:

In addition to setting this preference, you must set the Snapshot relationship
on the item revision to make the snapshot folder visible. Do this by choosing
Edit→Options→General→Item Revision and adding Snapshot to the Shown Relations
column of both the General and Related Object tabs.

Caution:

If you expand the baseline item revision below a certain level, the application displays
duplicate objects.

5. Save the revision rule for the product structure, process structure, and plant structure by saving the
structure as a collaboration context. After you do this:

• The product root item is the baseline product.

Create a baseline of a structure
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• The plant root item is the plant baseline.

• The process root item is the process baseline.
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12. Managing intermediate data captures
About intermediate data captures

An intermediate data capture (IDC) is a PLM XML file that contains an exported structure with the
configuration in effect at the time the IDC is created. An IDC may contain any configured structure
including a collaboration context, structure context, or group of BOM lines. You can manage the PLM
XML file in the same way as any other workspace object, including assigning it to a workflow, assigning
it a release status, running accountability checks, and controlling access privileges with Access Manager.

After you create an IDC, it appears as a separate tab in the data pane and an entry for it appears in the
collaboration pane.

After creation, you can compare an IDC to existing structures. For example, if you create an IDC from a
product structure, and then make modifications in that product structure, you can run an accountability
check that compares the IDC to the modified structure to see the modifications.

To compare IDCs with each other or another structure, each line being compared must contain an
in-context ID. Your administrator can run the bom_expand utility to ensure that each relevant line in the
structure is stamped with an in-context ID.

When you create an IDC, Teamcenter uses transfer modes to export the structure and alias files to
determine what to include in the IDC viewer. If you want to export custom objects or properties to the
IDC, you must ensure that a transfer mode exists that contains clauses that includes these objects. You
must also ensure that the alias files are modified to include the desired objects. If you want to see these
objects or properties in the IDC viewer in the rich client, you must modify the alias files so that the
viewer can extract them from the request object’s XML. The location of the various alias files is found in
the following preferences:

• Structure_Alias_File

• Attachment_Alias_File

• Dataset_Alias_File

For more information about using transfer modes, see Tc XML and PLM XML Configuration for Data
Import and Export.

An intermediate data capture structure is view-only. You cannot make changes to this structure.

Capture structures in an IDC

1. Select the root object in the structure and choose Tools→Intermediate Data Capture. You can
capture BOM lines, an occurrence group, a structure context with multiple roots, or a collaboration
context containing multiple structures.
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Teamcenter displays the New Intermediate Data Capture dialog box.

2. Select the type of IDC you want to create in the list on the left.

3. Type the name and optional description of the intermediate data capture, and select the
appropriate transfer mode name from the list.

4. To open the IDC in Part Planner, select Open on Create. If you do not select this option, you can
find the IDC in the Newstuff folder in My Teamcenter.

5. Click OK or Apply.

Teamcenter validates the objects you selected. If any of the objects cannot be captured,
Teamcenter displays an error message, otherwise it creates the PLM XML file containing the IDC
and displays it in a structure view.

6. (Optional) Open the IDC in the Viewer view in My Teamcenter or in the Object View tab in Multi-
Structure Manager to see a list of the captured states, including their descriptions and creation
dates.

7. (Optional) If you make changes to the originally captured structure, create a new captured state in
My Teamcenter or Multi-Structure Manager by clicking Add State.

Edit an IDC

You can edit the content of an IDC by adding or removing a root object, or by updating it to a new state.

If you change a file that an IDC references, Teamcenter keeps a copy of the original file so the integrity of
the IDC is maintained.

1. Send the IDC to Multi-Structure Manager.

2. Click the Viewer tab. The viewer shows the state of the captured data and the root object that the
IDC contains. You can then do any of the following:

• Click Add State and create a new state from the captured root objects.

• Click Remove State and remove a state from the captured root objects.

• Click Update State to update the IDC from the currently selected root objects.

Save an IDC in a collaboration context

1. Select the IDC in the Multi-Structure Manager collaboration pane.

12. Managing intermediate data captures
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2. Do one of the following:

• Drag the IDC and drop it onto the collaboration context object in the collaboration pane.

• Copy the IDC and paste it into the collaboration context object in the collaboration pane.

Viewing the structure in an IDC

You can view the captured structure in an IDC with My Teamcenter or Multi-Structure Manager. When
you send or copy an IDC from My Teamcenter to Multi-Structure Manager, you can paste it under the
existing root object, if one is open. If no root object is open, the IDC itself becomes the root object. In
this case, the IDC is visible in a new tab. If the IDC contains more than one state of the structure, you can
choose the desired state from the Captured States? list.

You can send more than one capture of the same structure to Multi-Structure Manager in turn. In this
case, Teamcenter creates a tab for each IDC, allowing you to select, view, and compare them.

View attachments in an IDC

• To view attachments in an IDC, select the appropriate node in the structure and choose View→Show/
Hide Data Panel or click the Show/Hide Data Panel button  on the toolbar.

Teamcenter shows any attachments to the node such as datasets or forms in the Attachments pane.
You can open an attachment for viewing or editing by double-clicking it.

View the properties of an IDC

• To view the attributes or properties of an selected node in the captured structure in an IDC, choose
View→Properties or right-click on the node and choose Properties. Your administrator can define the
properties that are visible.

Comparing captured structures

When running accountability checks, you can compare two structures. For example, you can compare
the current structure with the structure in an IDC to identify changes to the structure, attachments or
attributes. You can also compare two IDCs by running accountability checks.

Viewing the structure in an IDC
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13. Accountability check between
structures
Running accountability checks

You can compare two structures to ensure all lines in the source structure are accounted for in the
target structure. For example, you can compare the EBOM structure to the MBOM structure to ensure all
parts and assemblies are assigned or compare the product structure and the process structure to ensure
that all occurrences of product components and features are used in the process structure as consumed
items. You can compare the entire assembly or only a subassembly to the process structure. These types
of comparison are performed using an accountability check.

Any differences found during the comparison are reported, as they may indicate problems in
manufacturing the product to its specification. However, an imbalance between the structures may
not necessarily indicate a problem with the structure itself.

An accountability check or comparison:

1. Traverses the source structure.

2. For each line in the source, finds one or more matching lines in the target structure, according to
defined equivalence criteria.

3. For each pair of equivalent lines, identifies if there is a full match or a partial match. A partial match
exists if one or more aspects of the structures that you compare are not equal.

4. Colors each line in the structures and, if you have the correct license, opens the Accountability
Check Result view displaying the full matches, partial matches, and unmatched lines.

The following differences are reported:

• Lines in the source structure that do not have counterparts in the target

• Lines in the source that have more than one counterpart in the target

• Lines in the target that do not have counterparts in the source

• Lines in the source whose counterparts in the target have some significant difference, for example, a
different quantity

The analysis is done on the structures as they are configured in the rich client. You can run the analysis
with any combination of configuration options on both structures.
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When setting up the accountability check feature, a power user generally creates favorites—a collection
of typical options and settings for different situations. An administrator can publish these favorites for
different groups or roles so that regular users can then select one of them to quickly run the comparison.

Types of structures you can compare

Using an accountability check, you can compare the following pairs of source and target structures:

• EBOM and MBOM to see which of the EBOM parts are aligned to the MBOM

• Product and product

• Process and product to see if all parts are consumed

• Process and process

• Process and plant

The following is an overview of the types of structures you can compare.

Run an advanced accountability check

As an advanced user, you can set a variety of options before you run an advanced accountability check.
If you save these options as favorites, you can repeat the advanced accountability check using the same
options.

Note:

To run an advanced accountability check, you must have two linked source and target structures
to compare. These are typically a source engineering bill of materials (EBOM) generated from
a design BOM that is exported from a CAD application such as NX or CATIA, and a target
manufacturing BOM (MBOM) created for specific manufacturing needs from the EBOM. When
the EBOM is updated, the MBOM must be compared and updated as well. This is the purpose of
an advanced accountability check: the two structures must be examined to ensure that they share
equivalent BOM lines.

1. Open a source and target structure in two different panes using the Open Structure in Second
Panel menu command.

2. (Optional) Change the source or target object at any time by selecting the desired line in the
structure and clicking the respective Set/add current selection button . You can add multiple
scope lines from the same structure or remove a scope line by selecting it and clicking .

13. Accountability check between structures
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3. Ensure that you correctly selected the source and target objects. If not, switch the source and target
by clicking the Switch Source Target button.

4. Click the Inclusion Rules tab, and do one of the following:

• Select Search currently expanded source lines to run the accountability check on the selected
lines and all visible lines below the selected lines. Additionally, you can choose to run the
accountability check on all the lowest visible (expanded) lines under the selected scope line by
selecting Compare lowest visible level of source.

• a. Select Search lines per filtering rule to expand the source and target structures and only
consider a subset of the lines during the accountability check.

b. Select the Source filtering rule. For a description of the filtering rules, move your mouse
over the list. The rules along with their short descriptions are displayed.

You can specify to which level in a structure you want the check to consider by selecting Limit
search in source/target to first x levels and typing a value for x.

Note:

For information about filtering rules, see Managing filter rules in the Tc XML and PLM XML
Configuration for Data Import and Export.

Note:

When you set these options, the values take effect in all applications that support
accountability checks.

5. (Optional) If you know the source and target scope lines to be different because these lines are
source and target specific, select the Do not compare selected lines check box .

Run an advanced accountability check
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In the advanced accountability check results, the selected scope lines do not appear as missing in
target and missing in source.

6. Click the Reporting tab and set the result reporting options.

7. Click the Equivalence tab and set the equivalence options.

8. Click the Partial Match tab and specify the partial match criteria.

9. Click OK to run the accountability check.

Teamcenter displays the Accountability Check view.

Note:

The number of lines returned in the accountability check is limited by the value of the
MEAccountabilityCheckAllowableReturnedLines preference. If the number of lines to
return exceeds the preference value, a message will be displayed notifying you that there
are more lines to be returned, and that an Accountability Check Excel report has been created
and stored, thus saving the work.

10. After running the accountability check, examine the results and make any necessary modifications
to the structure.

11. Rerun the check using the same settings by clicking  in the Accountability Check view.

Note:

• Rerunning an accountability check does not recreate an accountability check report or a
result reported in an occurrence group.

• For information about narrowing the scope of the accountability check, see the PLMXML
Export Import Administration Guide.

Set the result reporting options

The accountability check displays its results by highlighting the checked objects in the structure pane in
a variety of colors that you can change, if desired. To help users who cannot differentiate colors well, a
tool tip shows the name of the color. If the name is not available, the tooltip displays the RGB value.

1. Open the accountability check dialog box.

2. Click the Reporting tab.

3. Select one of the following:

13. Accountability check between structures
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• Report in occurrence groups

Teamcenter can store and display the result of the accountability check in an additional tab in
the structure pane grouped by anomaly. This result is only computed for the source item and is
stored in the database as a structure of UsageCompareResultView objects related to the item of
the source revision. You can specify the name for the result of the check. By default, it is named
Compare Result.

• Report the selected check criteria

Teamcenter offers you two methods to visualize the results of the accountability check. You can
select one or both of the following:

• Select Color the compared objects to color the line and the matching lines according to the
match results and color scheme that you set in the Reporting section.

• Select Printable report to capture the results of the accountability check in an Excel
spreadsheet.

4. Check the display options you require:

Option Description

Full Match If the object (occurrence) in the source structure has one
and only one equivalent in the target structure, both
objects are set to the same background color. If you
also selected the Partial Match option, a full match also
means that all partial match criteria of the equivalent
objects match, for example, properties or relations, if you
use enterprise BOP structures. The default color is green.

Partial Match For equivalent objects (occurrences), if one or more
partial match criteria are not identical, both objects are
set to the same background color. The default color is
yellow.

Multiple Match If objects have more than a single equivalent in either
structure and all properties of the source objects are
identical to the properties of target objects, all objects
are set to the same background color. The default color is
orange.

Set the result reporting options
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Option Description

Only available when you do not use net effectivity.

Multiple Partial Match If objects have more than a single equivalent in either
structure and in addition, one or more properties are
not identical, all objects are set to the same background
color. The default color is pink.

Only available when you do not use net effectivity.

Missing Target If occurrences of the source structure are not found in
the target, the source objects are set to this color. The
default color is red.

Missing Source If occurrences of the target structure are not found in the
source structure, the target objects are set to this color.
The default color is light blue.

5. (Optional) Change the default color by clicking  next to the color.

6. Set the colors by choosing a color swatch, and setting HSB (hue, saturation, brilliance) or RGB (red,
green, blue) values.

Set the equivalence options

1. Open the accountability check dialog box.

2. Click the Equivalence tab.

3. Select the comparison options you require:

Option Description
Equivalent
Logical
Designator

If you use enterprise BOP structures, the accountability check takes process
logical designators into consideration as an additional comparison criteria
when checking the process, operation, or partition lines for equivalence.

This check box is available only when both structures are enterprise BOP
structures.

Equivalent
PublishLink
Connection

If you use publish links, the accountability check highlights occurrences that
are mapped using publish links. If a part occurrence is set to not require
positioned design, it is also taken into consideration.

13. Accountability check between structures
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Note:

When checking accountability between structures, the direction of tracelinks is not
considered.

Specify partial match criteria

You can specify which data to compare between equivalent lines. You can choose to compare a specific
set of properties or, if you are comparing enterprise BOP structures, you can additionally compare any
relation type of these lines to other lines. For example, you can compare assignment or predecessor
relations.

1. Click the Partial Match tab.

2. On the Properties tab, select Consider values of properties when searching for a partial match.

3. Choose the properties that you want included in the accountability check by selecting them in the
Available Properties list and clicking  to move them to the Selected Properties list.

The accountability check matches lines in the source and target that have the same properties as
those you select in the Selected Properties list. Your administrator determines which properties
are available for selection in the AdditionalAccountabilityCheckProperties preference. Any
differences in the selected properties are identified as differences between the structures.

The values of the DefaultAccountabilityCheckProperties preference are ignored.

Viewing check results in the Accountability Check view

About the Accountability Check view

When you run the accountability check, Teamcenter displays the results in the Accountability Check
view. This view lists the problematic lines in the source and target and provides a list of conflict details.
Lines that are colored in the source and target structures are also colored in the view. Fully matched
lines are not listed by default.

Note:

Displaying fully matched lines in large structures can clutter the view

Lines in the Accountability Check view behave in the same fashion as lines in the source and target
structures. If you remove a line in the view, Teamcenter removes the line from the source or target. You
can copy lines from the view into the clipboard, drag them to another structure, or send them to another
application.

Specify partial match criteria
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When you select or target line that is marked as having net effectivity or being a partial match,
Teamcenter displays the conflicts in a third pane at the bottom of the view.

When you select a line in the source section of the Accountability Check view, you can click the
Equivalent Lines tab in the target section of the view to find the lines in the target structure that match
the selected source line, and vice versa. These lines are then selected in the visible structure views.

When you work through the accountability check results, resolving conflicts, the accountability check
results are not updated—the lines remain highlighted in the original check colors. To update the lines,
you must rerun the accountability check. You can do this using the same settings by clicking  in the
Accountability Check view.

Note:

The Accountability Check view is not displayed when one or both of the structures being
compared is an intermediate data capture.

Display the partial compare results

After running an accountability check, you can view the partial compare results. Do one of the following:

• Select a partial match line in either the Source or Target section of the Accountability Check view.

Teamcenter displays the partial compare results in the Partial Match section at the bottom of the
view.

• Right-click a partial match line in the structure pane and choose Partial Compare Results, or choose
Tools→Accountability Check→Partial Compare Results.

Teamcenter displays the Partial Compare Results dialog box.

View settings used to run the accountability check

You can display a read-only listing of the settings in force when you ran the accountability check report.

• Click .

Teamcenter opens the Accountability Check Settings dialog box displaying the scope and
configuration in effect at the time the check was made. This is not necessarily the same as the
currently active configuration.

Filter accountability check results

When you run the accountability check, you can select check criteria in the Accountability Check dialog
box. After running the report, you may find that the Accountability Check view shows too many results

13. Accountability check between structures
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and the display is cluttered. You can filter out some of the check criteria in the view to make it more
readable without having to rerun the accountability check.

1. Click Filter.

2. Clear the categories that you want to hide in the view and click OK.

Teamcenter displays only those categories that are selected in the Filter dialog box. The filter button is
turned on when you remove the check mark from any categories to indicate that filtering is applied.

Clear display

You can reset all background colors on objects in the active window and their corresponding objects in
the process window to the default colors.

• Choose Tools→Accountability Check→Clear Accountability Check Display.

Note:

The command works only if either the source view or the target view is the active window.

Filtering and expanding source and target structures

You can narrow the scope of the accountability check by limiting it to only the lines pertinent to your use
case.

By default, Teamcenter presents you with a set of inclusion rules. Your administrator can modify these
inclusion rules or create new ones to suit your business needs.

For more information about configuring the inclusion rules, see Configuring the inclusion rules.

Note:

When running the accountability check based on inclusion rules, there is no need to expand or
unpack any of the structures. This improves the performance of the check.

When running the accountability check without inclusion rules, you must first expand and unpack
the compared lines in the source structure.

For more information, see Expanding structures to check.

Specifying levels for comparison

If you use inclusion rules, you can limit the number of levels that the accountability check considers for
comparison. In the following figure, processes C1 (ID = 034730) and C2 (ID = 034731) are selected as
the source in an accountability check. To specify a level, run an advanced accountability check.

Clear display
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If you specify a level of 1, the accountability check considers the following items for comparison:

c11, c12

c21, c22

If you specify a level of 2, the accountability check considers the following items:

c11, c12, c21, c22

c111, c112, c121, c122, c211, c212, c221, c222

Accountability check of variant structure

If you optionally propagate rolled-up variant conditions from the EBOM to the MBOM or from the
product BOP to the plant BOP, the accountability check recalculates the rolled-up variant condition on
the source line and compares it with any occurrence variant condition already stored on the associated
target line. It then reports any partial match discrepancies between the variant conditions. To allow this
check, you must add the Variant Formula (bl_formula) property to the list of properties in the partial
match criteria in the MEAdditionalPropagatableProperties preference. The comparison is based on
logical equivalence and is not a string comparison, for example:

• If you compare Color=red & Size=medium with Size=medium & Color=red, these variant conditions
are logically equivalent.

• If you compare Color=red & Size=medium with Color=red & Size=medium & Color=red, these
variant conditions are logically equivalent.

In the following example, you assign the EBOM to the MBOM and roll up the variants:

13. Accountability check between structures
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EBOM:

EGen1.1  Load if Option A = “abc”
    EGen 1.1.1  Load if Option B = “fgh”
      Part 1
      Part 2
    EGen 1.1.2  Load if Option B = “ijk” 
      Part 3
      Part 4
EGen1.2  Load if Option A = “cde”
    EGen 1.2.1  Load if Option B = “fgh”
      Part 5
      Part 6
    Part 7  Load if Option B = “ijk”

MBOM:

Part 1  Load if Option A = “abc” AND Option B = “fgh”
Part 2  Load if Option A = “abc” AND Option B = “fgh”
Part 4  Load if Option A = “abc” AND Option B = “ijk”
Part 5  Load if Option A = “cde” AND Option B = “fgh”
MGen 1.1
  Part 3  Load if Option A = “abc” AND Option B = “ijk”
  Part 4  Load if Option A = “abc” AND Option B = “ijk”
  Part 7  Load if Option A = “cde” AND Option B = “ijk”

If you perform an accountability check and specify parts only, all colors except full match, and rolled up
variant condition as a partial match option, the result shows no differences.

You then modify the parts under EGen 1.1.2 in the EBOM as follows:

Egen 1.1.2  Load if Option B = “lmn” – changed the variant condition
  Part 3  Load if Option C = “opq” –added the variant condition
  Part 4 – no change
  Part 8 – added the line

(You changed the variant condition to line 1, added the variant condition to part 3, made no changes to
part 4, and added part 8.)

If you now perform an accountability check, it identifies that Part 3 is a partial match, Part 4 is also a
partial match, and Part 8 is missing in the target. A tabular report shows the following results for the
checked objects.

Accountability check of variant structure
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Source Target Match
Variant condition
rollup

123456/A;1-Part 3 123456/A;1-Part 3 X X

123457/A 1-Part 4 123457/A 1-Part 4 X X

1234569/A 1-Part 8 *** Not Found X

The check assumes lines are equivalent due to a user performing an assign action (that is linking them)
and not simply by having the same in-context ID. When you run an accountability check on equivalent
lines with the same in-context ID, it considers rolled up variant conditions on the source line and
compares them with the occurrence variant condition on the target line. This may give unexpected
results when comparing the Variant Formula property, and you should take care when propagating
such differences.

For example, EBOM Top (000029) and MBOM Top (000035) are linked. The assigned line EBOM Sub
Assembly (000031) has a rolled-up variant condition.

If you change the in-context ID of Part1 in the MBOM to make it equivalent to SubAssembly in the
EBOM, the accountability check shows Part1 as a mismatched line, even though it is not assigned. This
occurs because the rolled up variant condition on the source line is compared with occurrence variant
condition on the target line. As the target line is not assigned, it does not have a rolled-up variant
condition.
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If you select Part1 and choose to propagate differences from the source to the target, Part1 receives
the rolled-up variant condition of the source. This occurs because, although the line is not assigned, it
has the same underlying occurrence. Part1 is now configured but not with the variant configuration you
originally intended.

Expanding structures to check

Whether or not you need to expand a target structure before running an accountability check depends
on the settings of the following two preferences:

MECopyIdInContextToAssignedLine

MECopyIdInContextLowerLevels

For more information, see Understanding ID in context and assigned products.

Note:

If there are packed lines in the source window, the accountability check may report incorrect
results for the quantity of an absolute occurrence of a component that is packed to a sibling. To
avoid this situation, always unpack all lines before starting an accountability check.

Create a printable Excel report

Teamcenter can create a printable Excel report containing the results of an accountability check. If you
have write access to the target structure, Teamcenter stores the Excel file as a dataset on the top-level
item revision of the target structure. If you do not have write access, Teamcenter stores the Excel file in
the Newstuff folder.

1. Open the Accountability Check dialog box.

2. Select all necessary options to create the accountability report.

3. Click the Reporting tab and select Report the selected check criteria.

Expanding structures to check
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4. Select Printable report.

5. Assign a name for the new dataset.

If a dataset of this name and type already exists in the item revision, Teamcenter opens a dialog
box where you can change the name or replace the dataset with the new one. You can change this
behavior in the TC_CRF_overwrite_existing_dataset_content preference. If this preference is set
to 1 (true), Teamcenter does not remove the dataset but replaces the content.

6. Click OK.

Teamcenter creates a report containing:

• General information such as the date and time of the check and the user ID and name.

• Compare options.

• Context data such as the source top level item, the target top level item, incremental change,
and revision and variant rules.

• Accountability check results such as the source name, target name, match status, and all
the checked properties. Multiple matched objects and missing source objects are displayed in
separate sections.

Teamcenter adds the Excel file to a dataset attached to the target structure.

Note:

If you use the MEAccountabilityCheckEnableNetEffectivity preference to report net
effectivity mismatches, the Excel report also reports those mismatches.

Customize the Excel report

1. Create your own XSL style sheet.

13. Accountability check between structures
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2. Add it to the Accountability Check Report (TC_2007_00_CUS_RPT_0002) report in the Report
Builder application.

3. Modify the AccountabilityCheckReportStylesheetName preference to contain the name of the
new style sheet.

Note:

If you created a custom style sheet prior to upgrading to Teamcenter 11.4 or greater, by default,
the Excel report uses a new style sheet called acc_chk_rpt_excel.xsl. Your customized stylesheet
must have a different, unique name (for example, my_acc_chk_rpt_excel.xsl). When the value of
the preference MEAccountabilityCheckReportCombineLines is true (default), the generated xml
file will not support legacy stylesheets. To generate legacy data xml files, change the preference
value to false.

Reporting the check result in occurrence groups

Alternatively to reporting the accountability check results in colors, Teamcenter can report anomalies in
occurrence groups that are displayed in an additional tab in the structure pane. These occurrence groups
are stored as persistent objects in the database.

If you compare the base view of the entire product structure or a subassembly, the accountability check
searches for every BOM line in the process plan. If you compare the manufacturing view of the product
or a subassembly, the check only searches for a line in the process plan if the line's direct parent is
an occurrence group. In the manufacturing view, if the BOM line's direct parent is not an occurrence
group, you must allocate it to the view as a component of a subassembly in the original EBOM. For
example, component C is part of subassembly A in the EBOM, while subassembly A is assigned to the
manufacturing view under occurrence group G. Consequently, C also appears in the manufacturing view
under A, then under G. The direct parent of A is an occurrence group, while the direct parent of C is A,
which is not an occurrence group. When you compare structures, the utility searches for A but not for C.
Typically, if you did not allocate to the manufacturing view, you would not expect to consume it in the
process.

The scope of the comparison depends on the selections you made in the Accountability Check dialog
box, as described in Run an advanced accountability check.

Generate the results grouped by anomaly

1. To generate the report:

a. Open the Accountability Check dialog box.

b. On the Reporting tab, click Report in occurrence group.

c. Click OK.

Reporting the check result in occurrence groups
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The Create Compare Result View dialog is displayed.

d. Modify the system generated Name and Description as required.

The Name of the result view is displayed as the name of the additional tab. Multiple result
views can be displayed at a time. If a view with the same name exists, the system displays a
message asking if the result view should be overwritten or renamed. In this case, you must
have write access to overwrite the existing view.

e. Click OK.

Teamcenter creates UsageCompareResultView objects for each type of anomaly and displays
them in the Compare Result tab.

Teamcenter creates occurrence groups for each type of anomaly and displays them in the Compare
Result tab (an occurrence group tab). The names of the anomalies are fixed and are as follows:

• Unused/Under-used

Contains all occurrences in the source pane that do not match an occurrence in the target pane.

• Completely Used
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Contains all occurrences in the source pane that match a corresponding occurrence in the target
pane.

• Over-used

Contains all occurrences in the source pane that match more than one occurrence in the target
pane.

• Partial Match

Contains all occurrences in the source pane that have mismatched properties compared to their
corresponding occurrence in the target pane.

2. (Optional) Expand the subgroups to view the items contained in these groups and take appropriate
action.

You must rerun the accountability check to view any changed results.

Generate the results grouped by anomaly

Multi-Structure Management, Teamcenter 2412  13-17
© 2025 Siemens



13. Accountability check between structures

13-18  Multi-Structure Management, Teamcenter 2412
© 2025 Siemens



14. Configuring structures by occurrence
effectivity
About occurrence effectivity

The effectivity of an occurrence can be expressed as a date range or a range of units with respect to
an end item. An occurrence can have multiple expressions comprising date effectivity, unit effectivity, or
both. Multiple unit effectivity expressions may reference the same end item or different end items. If no
occurrence effectivity is specified, the occurrence is considered to be always effective; that is, it is not
constrained by any effectivity definition.

Occurrence effectivity is used principally for two purposes:

• To reflect changes to the structure over time as new parts replace old ones.

• To explicitly state the content of a unit or range of units as a means of managing the variability of the
product. This technique is an alternative to using options and variants to configure the parts needed
to fulfill a particular offering.

Occurrence effectivity is frequently used by manufacturers of military and aerospace products. The end
item may correspond to a serial number or the tail number of an aircraft.

For example, there may be different hydraulic cylinders in the landing gear of an aircraft, depending
on whether the aircraft is certified for unimproved runways. There may be additional differences to the
aircraft to meet this purpose, such as debris deflectors, wheels, and tires. Using options and variants,
you could define an option called RW_Class = Paved or Gravel, and there would be a variant rule on
stouter cylinder to configure it in for the Gravel option. Using occurrence effectivity, the unit number
of each aircraft unit that is certified for operation on gravel runways (for example, units 3-6, 17, 33-45)
would be used in the effectivity specified for parts such as stouter cylinders. The effectivity of the regular
cylinder would be specified using the other units (unit 1-2, 7-16, 18-32, 46-up).

Understanding occurrence effectivity

Understanding occurrence effectivity

Several occurrences may share an effectivity. When you edit the effectivity range on one occurrence,
Teamcenter applies the change to all occurrences. (This is generally the reason for sharing effectivity.)

You can also pack occurrences if they share the same unit or date range and access protection status.
Packed occurrences are displayed in a similar way to packed structure lines.

You cannot import or export structures containing occurrence effectivity. If you require individual
structure nodes to have effectivity, consider the use of incremental change.
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If an occurrence does not have an associated effectivity object, Teamcenter assumes it is always effective
and it is configured regardless of the date or unit number set by the revision rule, as shown in the
following figure.

If you do not split effectivities, you can optionally use the Configuration Item check box to indicate the
end item, although Teamcenter does not enforce this use.

Occurrence effectivity rule

When you create an effectivity condition on an occurrence, you change the parent BOM view
revision. Consequently, you must have write access to the BOM view revision. However, you can make
subsequent changes to the effectivity range if you have write access to the effectivity object, allowing
you to edit effectivity data after the structure is released.

Note:

The import or export of a structure containing legacy occurrence effectivities is not supported.
If you require individual structure nodes to have effectivity, consider using incremental change
instead of occurrence effectivity. Structures managed with incremental change can be imported
and exported using Multi-Site Collaboration.

Validating effectivity

You should check that effectivity ranges are consistent within the whole structure, ensuring that
effectivity ranges lower down the structure lie within ranges higher up. You may not be aware of the
constraints higher up the structure when you initially specify effectivity ranges at lower levels.

14. Configuring structures by occurrence effectivity
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Teamcenter does not perform this validation automatically but you can include it as part of a workflow
process that approves the effectivity ranges. In certain cases, this validation may not be appropriate, for
example, when the structure is shared between different products.

Defining mutually exclusive effectivity ranges

If you intend to define occurrences as mutually exclusive, manually check that they do not have
overlapping effectivity ranges. For example, in the following figure, there are two different types of
dynamo and it would be wrong to configure two dynamos at the same time.

Mutually exclusive effectivity ranges

When specifying effectivity, you can make the association between the occurrences clearer by using the
same find number or attaching a special effectivity note to each.

Understanding unit net effectivity

For a large and complex structure, it is useful to understand the net effectivity of components within
the structure. A lower level component may have been originally specified for any effectivity or a large
range, but a narrower range applied at a higher level in the structure can reduce the net range for that
component line.

Unit net effectivity can be considered as the intersection of an occurrence’s unit occurrence effectivity
with its parent’s calculated unit net effectivity, from the specified structure line up to the top of the
structure. For a line without an underlying occurrence (top line of a structure), there is no occurrence
effectivity. This line is considered unconstrained and always configured. The unit net effectivity of a line
that has no unit occurrence effectivity is equivalent to its parent’s calculated unit net effectivity.

• If the line has only date effectivity expressions, these are ignored and the unit net effectivity is the
same as its parent’s calculated net effectivity.

• If there are multiple unit effectivity expressions with the same end item, these expressions are merged
before intersection with the parent’s calculated net effectivity.

Defining mutually exclusive effectivity ranges
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• The intersection is taken with respect to the end item designations of the parent’s unit net effectivity
expressions. Unit effectivity expressions whose end items do not match any in the parent’s unit net
effectivity are ignored.

• If there is no intersection of the line’s unit occurrence effectivity and the parent’s unit net effectivity,
the line’s unit net effectivity is set empty (fully constrained).

• The unit net effectivity of a line whose parent’s unit net effectivity is empty also has an empty unit net
effectivity, regardless of the line’s unit occurrence effectivity.

• The unit net effectivity of a particular component line is calculated when you display the line and is
not persisted in subsequent sessions.

Effectivity flow-down reporting helps the user understand effectivity ranges and the impact of changes,
especially as the complexity of the effectivity increases through the structure.

Calculate unit net effectivity

To calculate the net occurrence effectivity of a selected structure line, choose
Tools→Effectivity→Occurrence Effectivity→Calculate Net Effectivity.

Teamcenter displays the occurrence effectivity, unit net effectivity, and net effective occurrence
configured (EOC) information for the selected line.

The unit net EOC is set to true if the occurrence would be configured in based on the comparison of
its calculated unit net effectivity with the revision rule occurrence effectivity entry. Teamcenter performs
this comparison at run time and it is not persisted.

14. Configuring structures by occurrence effectivity
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Note:

If you select a root line or more than one line, an error message is displayed.

Configuring by occurrence effectivity

If the revision rule controlling the configuration of a structure contains an entry for occurrence
effectivity, occurrences for which no occurrence effectivity is specified are configured, together with
occurrences whose effectivity expressions match some part of the revision rule occurrence effectivity
entry. If Show Unconfigured By Occurrence Effectivity is selected, an occurrence may be shown or
hidden, depending on occurrence effectivity (which may be a greater range than unit net effectivity).

The calculated net effectivity is also compared with the revision rule occurrence effectivity entry.

• If the unit net effectivity of a line is unconstrained, the unit net-EOC is true, regardless of any
occurrence effectivity entry in the revision rule.

• If the unit net effectivity of a line is empty, the unit net-EOC is false, regardless of any occurrence
effectivity entry in the revision rule.

• For a line whose unit net effectivity is not unconstrained or empty, its unit net-EOC is false if there is
no occurrence effectivity entry in the revision rule.

• If there is an occurrence effectivity entry in the revision rule, the unit net-EOC is true only if the unit
net effectivity matches some part of the revision rule occurrence effectivity entry.

• Any date effectivity expressions in the revision rule occurrence effectivity entry are ignored for the unit
net-EOC comparison. A date range is not considered as a scope for unit net effectivity,

You may explicitly set an occurrence effectivity entry in the existing revision rule by choosing Revision
Rule→Set Date/Unit/End Item…. You can then set a unit range defining the scope of effective
occurrences you want to review. The Unit Net-EOC property shows whether the computed net
effectivity is in that scope.

Using effectivity cutback

While defining a product managed with occurrence effectivity, the effectivity decisions evolve as the
product content itself is developed. The design engineer makes decisions for effectivity ranges that
reflect the implementation plan for when additional or replacement parts should be included in the bill
of materials.

In general, there are many technical and logistical decisions that go into setting the date or unit range of
the effectivity. To support this process, the engineer must understand the chain of effectivity for a given
part. The engineer may choose to adjust the effectivity ranges when necessary. Over the life cycle of
development and service of the product, customers using occurrence effectivity replace parts with other
parts. As these changes are made, the historical chain of effectivity must remain consistent.

Configuring by occurrence effectivity
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When a new occurrence of a part is specified as a replacement for an existing occurrence in a structure,
the effectivity of the replaced part should be reduced (cut back) so that it does not overlap with the
effectivity of the replacing part.

When a part with occurrence effectivity is replaced and cut back, prior generations that were replaced by
the cutback part should also be considered for cutback, if the range of the newest replacement overlaps
effectivity.

Note:

Effectivity cutback is only supported with unit effectivity, not with date effectivity.

The following actions are supported by effectivity cutback:

• Replacing N parts with M replacements and updating ranges of effectivity. The historical chain of
effectivity retains the N:M relationship, in case a future cutback operation needs to fully span the
content of a link in the chain to cut it back.

• Validating prior replacements in the history of effectivity and updating accordingly.

• Enabling efficient updates to effectivity ranges after a replacement.

The following example shows how effectivity cutback occurs when an engineer modifies an assembly
that is managed with occurrence effectivity.

1. The engineer specifies replacement parts P21, P22, and P23 for parts P11 and P12 with a unit range
of 10-up.

The system adds the occurrences P21, P22, and P23 effective unit 10-up The effectivity of P11 and
P12 is cut back to the portion of the range not set on the replacements, namely units 1-9.

2. The engineer indicates parts P31,P32, and P33 are specified as replacements to P21, P22, and P23
for a range starting at unit 5.

The system determines from the chain of effectivity and replacements that P21, P22, and P23 are
replacements.

The full range of effectivity is overlapped, so P21, P22, and P23 are no longer in effect. The span of
replacement is complete, so the parts previously replaced are considered and P11 and P12 are cut
back accordingly to 1-4.

3. The engineer specifies P42 as a replacement for P32 for a range within the span of effectivity of
P32.

P42 is effective for the range specified (units 20-30) and the replaced occurrence split to 5-19, and
31-up.

14. Configuring structures by occurrence effectivity
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4. The engineer adjusts the effectivity range of P42 to units 22-32.

The effectivity of P42 is updated to the new range.

5. A reviewer or the engineer validates the effectivity chain of P42.

The system evaluates the effectivity of P42 against the parts it replaced or is replaced by. It
identifies:

• A gap

Unit 20,21 does not include replaced (P32) or replacing (P42) parts.

• An overlap

Units 31 and 32 include both replaced (P32) and replacing (P42) parts.

6. The engineer replaces a part where only a portion of the historical replacement chain is changing.

While a cutback of P33 by replacing part P43 is unambiguous, there is not an unambiguous action
to take on P11 and P12 because P33 is only a subset of the historical chain:

(P11,P12):(P21, P22, P23):(P31, P32, P33)

After replacing an occurrence and performing a cutback of the replaced part, the effectivity range of a
part can be adjusted. If the new range overlaps with the effectivity of any parts in the historical chain of
effectivity, the system issues a warning.

The following table shows how effectivity cutback occurs in this scenario.

Step Task
Part
P11

Part
P12

Part
P21

Part
P22

Part
P31

Part
P32

Part
P33

Part
P42

Part
P43

1 Initial
state

1-up 1-up

2 Replace
P11 &
P12
with
P21,
P22,P23
at unit
10

1-9 1-9 10-up 10-up

Using effectivity cutback
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Step Task
Part
P11

Part
P12

Part
P21

Part
P22

Part
P31

Part
P32

Part
P33

Part
P42

Part
P43

3 Replace
P21,
P22,
P23
with
P31,
P32,
P33 at
unit 5

1-4 1-4 5-up 5-up 5-up

4 Replace
P32
with
P42 for
units
20-30

1-4 1-4 5-up 5-up 5-up 20-30

5 Adjust
effectivi
ty of
P42 to
units
22- 32

Warning 22-32

6 Replace
P33
with
P43 for
units 3-
7

Error Error 8-up 3-7

When a link in a chain of occurrence effectivities is completely overlapped (that is, a complete cutback
is made of its entire range) it is logically removed from the structure. The system informs the user there
is no effectivity for that occurrence. A logically removed occurrence can be removed from the structure
and removed from historical chains of effectivity used for evaluation of future cutback operations. In this
situation, the change history is the only way to know the part ever existed in the structure.

14. Configuring structures by occurrence effectivity
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Editing occurrence effectivity

To edit occurrence effectivity data, your Teamcenter user name must be included in the appropriate
effectivity user group and role that the administrator defines.

Associate existing effectivity to an occurrence

Note:

Use this approach only when you want the effectivity to be the same for all occurrences sharing
this effectivity object. If you edit the effectivity object's date or unit number ranges, Teamcenter
applies this change to all occurrences that reference it.

1. Select the line in the structure representing the occurrence with which you want to associate
effectivity.

2. Choose Tools→Effectivity→Occurrence Effectivity→View, Create and Edit.

Teamcenter opens the Occurrence Effectivity dialog box.

3. In the Effectivity ID box, type the identifier of the effectivity object you want to associate with
the occurrence, and press the Enter key. Alternatively, you can search for the effectivity object by
clicking Search  adjacent to the Effectivity ID box.

Teamcenter populates the date or unit number table with the ranges from the effectivity object.

4. Click OK and Teamcenter associates the effectivity with the occurrence.

Create effectivity on multiple occurrences

Create and associate the same effectivity with several occurrences by selecting the appropriate line
in the structure and choosing Tools→Effectivity→Occurrence Effectivity→Create on Multiple BOM
Lines. The effectivity may be:

• Shared

Shared effectivity must have an ID. If you are creating shared effectivity, ensure the Use shared
effectivity check box is selected.

• Unshared

Unshared effectivity has no ID. If you are creating unshared effectivity, ensure the Use shared
effectivity check box is cleared.

Editing occurrence effectivity
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Modify the effectivity of an occurrence

Note:

Any changes you make affect all occurrences sharing the same effectivity object.

1. Select the line in the structure representing the occurrence whose effectivity you want to modify.

2. Choose Tools→Effectivity→Occurrence Effectivity→View, Create and Edit.

Teamcenter opens the Occurrence Effectivity dialog box.

3. In the Occurrence Effectivity dialog box, choose Units or Dates effectivity, as appropriate, and
define the effectivity range.

• If defining unit effectivity, type the desired effectivity range in the Units box. Use the - character
within a continuous range, and the , character to separate discontinuous ranges. For example,
the unit range 1-5,7-9 defines effectivity for units 1 through 5, and 7 through 9 (but not effective
for unit 6).

• If defining date effectivity, select a cell in the From or To column, select a date from the calendar
(and optionally type a time), and click Set Date to place that date in the selected cell. Click
the Clear Date button to remove the date from the currently selected cell. Repeat this step for
additional cells until you have entered all the desired date ranges.

• Click the UP button to add the and up (open-ended effectivity) condition to the end of the unit
or date effectivity range. If you are defining date effectivity,

• Click the SO button to add the stock out condition to the end of the unit or date effectivity
range.

Note:

Teamcenter interprets UP and SO conditions as open-ended for revision configuration
purposes. The revision is considered effective for any value greater than or equal to the
unit or date value immediately preceding the UP or SO. Stock out indicates that existing
stocks of a component revision should be used up before the next revision.

• Check the Apply Access Manager effectivity protection check box to apply the predefined
access rules to this effectivity.

• (Optional) For date effectivity, use the End Item dialog box to define an end item to qualify
the effectivity range. You must use this with unit effectivity to specify a product, module, or
subsystem that carries the unit number to which this effectivity refers. You can select an end
item in one of the following ways:

14. Configuring structures by occurrence effectivity
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• Clicking Open by Name  adjacent to the End Item box and searching for an item by
identifier and/or name.

• Copying an item to the clipboard before opening the Occurrence Effectivity dialog box and
clicking Paste  adjacent to the End Item box.

• Clicking MRU  adjacent to the End Item box.

Note:

If you want to remove the entered end item, click Clear  adjacent to the End Item box.

4. Click OK to save the occurrence effectivity data you entered.

Remove effectivity from an occurrence

1. Select the line in the structure representing the occurrence whose effectivity you want to remove.

2. Choose Tools→Effectivity→Occurrence Effectivity→View, Create and Edit.

Teamcenter displays the Occurrence Effectivity dialog box.

3. Click Remove to clear all boxes, including the identifier.

4. Click OK and Teamcenter removes the effectivity object from the selected occurrence. Any other
occurrences sharing this effectivity retain their references to the effectivity object.

Copying occurrences with effectivity

When you save a BOM view revision with a different name (perform a Save As action), Teamcenter
copies any occurrences that reference an effectivity object to the new BOM view revision. Thus, the
same effectivity ranges apply to the copied structure.

When you copy, cut or paste, Teamcenter does not reproduce any references to effectivity objects in the
copy occurrences.

Setting the date for occurrence effectivity

Teamcenter configures the occurrence effectivity by the date defined in the current revision rule.
Teamcenter uses an explicit date entry, if the current rule contains one. If the rule has no date entry,
the effective date defaults to today, but you can manually set a different date using the Tools→Revision
Rule→Set Date/Unit/End Item menu command.

You can choose to show only the configured occurrences, or all occurrences. You can toggle this setting
by choosing View→Show Unconfigured by Occurrence Effectivity. If you display the EOC - Effective

Remove effectivity from an occurrence
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Occ. Config'd column in the structure properties, occurrences that are configured show a Y. If the
occurrences are not configured, the column is blank.

Occurrences are configured if:

• The effectivity range encompasses the date specified by the current revision rule.

• They have no effectivity object. Such occurrences are always configured, regardless of date.

Combining occurrence effectivity and variant configuration

Variant and occurrence date effectivity are occurrence-based configuration methods that operate
independently. The View menu includes separate commands to show or hide occurrences that are
unconfigured by the two methods. In some cases, you may want to view a specific variant of the product
at a particular effective date. In this case, you hide occurrences that are unconfigured by both date and
variants. Similarly, you may want to view a generic product at a particular date, in which case, you
would hide occurrences unconfigured by date only. To show how a single variant changes with effective
date, you can hide unconfigured variants only.

Configuring occurrences with multi-unit configuration

About multi-unit configuration

Teamcenter allows you to configure product structure occurrences of an assembly based on specified
multiple end items and the unit effectivity ranges for each of those end items. You can do impact
analysis and eliminate the duplicate work required to maintain different product structures and
complicated manual reconciliation.

A combination of multiple end items and range of units for each end item used to configure product
structure occurrences is referred to as a multi-unit configuration.

The administrator at your site enables this feature. It allows you to:

• Specify multi-unit configurations and save them as effectivity groups.

• Save a combination of effectivity groups and revision rule as a configurator context. You can use the
saved configurator context to apply the effectivity groups and revision rule to configure occurrences.

• View the configured structure in Lifecycle Visualization, CAD tools, and the embedded viewers of
appropriate rich client applications.

• Configure occurrences by matching the occurrence effectivity with the multi-unit configuration.

• Configure occurrences that are added and deleted by incremental changes by matching the
incremental change effectivity with the multi-unit configuration.

14. Configuring structures by occurrence effectivity
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Note:

Teamcenter displays the Revision Rule Entry value for an incremental change (IC) configured
by a multi-unit configuration as Effectivity Group. Therefore, ignore the status of this check box
in the IC Information pane.

When an occurrence has occurrence effectivity and it is removed in the context of an IC,
the occurrence is not configured if the multi-unit configuration matches the effectivity of the
removing IC. This occurs whether the occurrence effectivity matches partially or completely with
the multi-unit configuration.

Multi-unit configuration does not support nested effectivity and effectivity mapping.

Create a new effectivity group

1. In My Teamcenter, choose File→New→Item.

Teamcenter displays the New Item dialog box.

2. Select Effectivity Group, enter the necessary name, description, and identifier, and then click
Finish.

Teamcenter creates the base revision of the new effectivity group. (Effectivity groups cannot be
revised, and you are unable to create further revisions of the new group.)

Capture a multi-unit configuration and save it to an effectivity group

1. In My Teamcenter, right-click an effectivity group revision and choose View/Edit Multi-Unit
Configuration.

Teamcenter displays the View/Edit Multi Unit Configuration dialog box with the View/Edit Multi
Unit Configuration pane visible.

Note:

The Most Recently Used option is not available in this dialog box. Also, the Open By Name
box is not available on the Effectivity Groups pane in this dialog box.

Caution:

This is a modeless dialog box. It allows you to copy items from other locations, such as your
Favorites folder, and paste them into the dialog box. However, it also allows you to perform
other actions, such as Revise and Close commands in My Teamcenter with the dialog box
open.

Create a new effectivity group
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If you open this dialog box using View/Edit in the Set Date/Unit/End Item dialog box
(Effectivity Groups tab), the dialog box is modal and does not allow you to paste between
applications.

2. Enter the necessary end item and unit range information, and then click Add, Edit, Remove, or
Undo to update the effectivity group, as follows:

• To add an end item unit range, enter the end item ID and the effective unit range and click the
Add button. You can also search or browse for an end item to populate the End Item box. You
can also copy the end item from your Favorites folder in My Teamcenter and paste it here. You
can specify a combination of units or unit ranges in comma-separated format.

• To remove an end item unit range, select it in the table and click Remove.

• To edit an end item unit range, select it in the table and the system populates the End Item
ID and Unit Range boxes from the selected entry. After you make the required changes, click
Modify.

• To revert the last change made in the dialog box, click Undo.

Note:

Undo allows you to go back one level to the previous state in the dialog box. Thereafter,
any subsequent clicks on the Undo button cause the dialog box to toggle between its
current state and previous state.

Note:

You can view and edit effectivity groups with certain limitations. Use the View/Edit button in the
Effectivity Groups pane of the Set Date/Unit/End Item dialog box to add or modify the end items
by manually typing the necessary data. You cannot search for or copy and paste end items here.

Set an effectivity group to configure occurrences

You set an effectivity group or groups to configure the product structure occurrences in addition to the
revision rule.

1. Load the assembly to configure and choose Tools→Revision Rule→Set Date/Unit/End Item.

Teamcenter displays the Set Date/Unit/End Item dialog box.

2. Enter the effectivity group identifier in the Effectivity Group box, and then click Replace, Insert, or
Append to update the list of groups.

14. Configuring structures by occurrence effectivity
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Note:

To remove an effectivity group from the list, select it and click Remove.

3. (Optional) To view the multi-unit configuration on an effectivity group, select it and click View/Edit.
The system displays the View/Edit Multi Unit Configuration dialog box, as described previously. If
you have the necessary access privileges, you can also modify the configuration.

When you apply the configuration, the system matches the occurrence effectivities configured for
each occurrence with the multi-unit configuration set in the effectivity groups. Any occurrence whose
occurrence effectivity is valid for any of the end item and unit range entries in the effectivity groups
is displayed. An occurrence is loaded only once even if its effectivity matches more than one end item
entry in the effectivity groups set in the session.

Caution:

You can configure product structures with incremental changes using effectivity groups. However,
only limited support is provided to configure occurrences with incremental changes using multi-
unit configuration and the following limitations apply.

• You can configure only the addition and deletion of occurrences using effectivity groups. Other
edits in the context of incremental change cannot be configured.

• An add occurrence edit is effective if the multi-unit configuration partially overlaps the
effectivity of the incremental change.

• A remove occurrence edit is effective if the multi-unit configuration completely overlaps or is
within the limits of the effectivity of the incremental change. That is, a partial overlap is not
sufficient to configure the remove edit. If there are multiple remove incremental changes,
Teamcenter compares each of them with the multi-unit configuration separately. (It does
not calculate the total remove effectivity and compare a single value with the multi-unit
configuration.)

• Teamcenter evaluates the configuration of an occurrence based on an incremental change
independently of its occurrence effectivity.

• If Teamcenter finds competing incremental changes (one adding the occurrence and the other
removing it) and both can be configured with effectivity groups, it gives precedence to the add
occurrence edit.

The following examples show how occurrence effectivity and incremental change interact.

Set an effectivity group to configure occurrences
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Structur
e
line
number

Type

Occurrence
effectivity
(explicit or
implied)

Effectivity on
removing IC1
and removing
IC2

Multi-unit
configuration
set on BOM
window Result

1 Componen
t

EndItem(1-20) IC1(-) →
EndItem1(1-9)
IC2(-) →
EndItem(10-20)

EndItem1(1-9) Occurrence not
configured.

2 Componen
t

EndItem(1-20) IC1(-) →
EndItem1(1-9)
IC2(-) →
EndItem(10-20)

EndItem1(1-20) Occurrence
configured as
Teamcenter
checks occurrence
effectivity, multi-
unit configuration,
and each
incremental
change
individually.

Customizing occurrence effectivity

You can customize Teamcenter behavior when the user applies or sets occurrence effectivity on a BOM
line.

To allow customization of the behavior when setting effectivity on an occurrence, the bl_occ_effectivity
BOM line property is modifiable, and a setter method is provided on this property. Use the setter method
of the property to attach an extension point if required.

14. Configuring structures by occurrence effectivity
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15. Creating, viewing, and editing
manufacturing documentation
About manufacturing documentation

Teamcenter manufacturing documentation provides rich work instructions and collaboration between
departments, integrated with the planning environment, leveraging Teamcenter data management
capabilities.

Teamcenter Publish provides an environment for creating work instructions for manufacturing
operations. It enables you to author, distribute, and visualize the most current product and process
data. Its main features include:

• Technical illustrations including text, 2D images, 3D graphics, table, text, and hyperlinks (for example,
a link to a movie file) to improve clarity and enhanced quality on the shopfloor.

• Easy update based on the most current planning data in Teamcenter, reducing rework and update
times.

• Batch processing and scheduling of reports.

• Familiar Microsoft Visio authoring environment allowing WYSIWYG editing.

For more information, see Using Teamcenter Publish.

Using Teamcenter Publish

To create or view manufacturing documentation using Teamcenter Publish, install Microsoft Visio. Both
Visio Standard and Visio Professional are certified. You can install Visio before or after the Teamcenter
installation.

The Save as PDF feature is included with Visio and does not require installing the separate PDF add-in.

The administrator creates an alias file that determines the permissible contents of the documentation.
For example, if the administrator uses the default alias file, you can create work instructions and product
manuals, and a tab for each of these is available in the data pane.

When you first select a documentation view, Teamcenter loads the Visualization Illustration and Visio
components. Depending on your workstation, this process may take several seconds to complete and
Teamcenter displays a progress dialog box until it is complete.
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Working with publishing tools

You can create publishing pages in the embedded viewer and collect them into portfolios. A typical
publishing page is a work instruction document, and a portfolio may contain all the work instructions
needed at a particular assembly station. By default after installation, Teamcenter provides you with
sample files. To use publishing tools in your environment, you must configure it to suit your needs.

Publishing pages are Visio files that are saved as datasets with the selected BOM line.

Visio documents are constructed using shapes that can appear as text and graphics. A rich library of
shapes are provided in the Visio installation.

The Teamcenter publishing tools extend the shape library to include shapes called assets that you can
link to data in Teamcenter. Assets can display text, tables, images, or a link to a Microsoft Word file or
master form. For example, in Teamcenter you can configure a product assembly, view it, add markups,
and capture the graphics in a product view (snapshot) that you can then display in a 3D asset. If the data
in Teamcenter is subsequently updated, you can update the publishing page to show the changes.

You can organize collections of publishing pages into portfolios, which you can view, publish to HTML
for a Web server or publish to PDF, or print in My Teamcenter using the options that appear in the viewer
tab after you select the portfolio object. A portfolio can contain multiple work instructions, generic
pages, header and footer information, a table of contents, and cover and trailer pages.

Publishing page roles

Publishing page documents can be used for any number of purposes. By default, two roles are provided,
Work Instructions and, when a product structure is selected, Product Manual. Your database may be
configured to support any number of roles. This documentation refers to the Work Instructions role, but
the behavior of the pane is the same for each role.

Creating and editing publishing pages

Creating and editing publishing pages overview

When you first open the Work Instructions pane, you see a blank page.
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You can immediately begin to create a work instruction on this page or you can load a template and
work from there.

The following is an overview of the process for creating a publishing page.

1. Add any static Visio shapes, text or graphics you need to the page.

2. Associate the page with an alias file.

Alias files tell Teamcenter what data to display in different assets on the page and how to find that
data. This step is optional; a default file is loaded.

3. Place the required assets on the page. These are placeholders. You can place the following objects
in a work instruction page, each embedded in an asset of the same name:

Creating and editing publishing pages overview
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• Text that is bound to a property of an object in Teamcenter.

• Tables whose cells map to object properties in Teamcenter.

• 2D images (for example, BMP, GIF or JPEG files)

• 3D geometry assets

These are objects that you create or view in the embedded viewer, such as a factory view or the
desired state of the product at a certain assembly station.

• 2D snapshots

These are dynamic objects that represent a 2D scene (a view of the base image and markups)
that are associated with a BOM line in your product structure.

• Links

You can create a link to a Microsoft Word file or text file.

4. Associate the asset with a transfer mode and an alias name.

The transfer mode and the alias tell Teamcenter how to find the data in the database that is
displayed in the asset.

5. (Optional) Save this page as a template for reuse.

6. Select one or more assets and an object in Teamcenter to populate the assets.

This step traverses the structure to find the desired data or files and places them in the selected
assets.

You can detach the Work Instructions tab to get a movable window. You can then select a different
structure line in the Teamcenter window that you can use to create assets on the publishing page.

Caution:

While the Work Instruction tab is still attached, you cannot select a new structure line from
which to create assets. Until you detach the tab, all assets in the page are populated with objects
attached to the selected BOM line.

Create a publishing page

1. Select the BOM line with which you want to associate the work instructions, for example, the item
revision of an assembly or operation.

15. Creating, viewing, and editing manufacturing documentation
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2. Click the Work Instructions tab in the data pane.

3. From the menu commands in the Work Instructions pane, choose File → New TI Dataset.

Teamcenter displays the New Dataset dialog box.

4. Type a name and description in the boxes at the bottom of the dialog box and click OK.

Teamcenter creates the new publishing page dataset.

5. To add data placeholders (assets) to the template:

Click To add

Data found in a text file attached to a structure line.

A collection of data found in various properties in tabular
form.

A link to a Microsoft Word file or a text file.

A 2D image or a 2D snapshot attached to a structure
line.

A 3D image attached to a structure line.

6. Drag these placeholders to the desired spot on the page, resizing if necessary.

7. Right-click the asset and choose Bind.

Teamcenter displays the Bind Table Placeholder dialog box.

8. Select the transfer mode and alias to use for the data to populate this asset and click OK.

Note:

The work instructions are attached to the BOM line with a IMAN_MEWorkInstruction
relation.

Binding assets

Binding assets overview

There are several different types of placeholders (assets) that you can place on a publishing page. Each
of these must be bound with data from a structure. When you bind the asset, the Bind dialog box
contains a list of transfer modes and a number of choices, called aliases, from which you can select.

Binding assets overview
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The choice you make for each asset defines how Teamcenter finds the data that is displayed in the asset
when you populate it.

Bind textual information

You can bind information found in the text field of an object's properties. You can enter free-form text
within the asset to complement the bound information. For example:

Operator must tighten &&SUM(<alias_1>)&& bolts with torque &&MAX(<alias_2>)&& and any 
other &&alias_3&&.

1. Detach the Work Instructions tab.

2. In the detached tab, click .

Teamcenter creates a placeholder for the text on the work instruction page.

3. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

4. Click the Text Tool button  to add free-form text to the asset.

5. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Text Placeholder dialog box.

6. From the Transfer Modes list, select tcm_export transfer mode.

You can select only one transfer mode per text alias.

7. In the Aliases list, open the ObjectProperties entry and select the piece of textual information that
you want to embed. You can choose to manipulate the asset data using the list of simple formula.

Each piece of bound data is added to the end of the text asset. You may have to rearrange the
information after binding the data.

8. Click Add.

Tip:

• You can also type the binding directly into the text asset if you know the format.

15. Creating, viewing, and editing manufacturing documentation
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• You can bind multiple times to create free-form text plus embedded text in one asset.
Switch back and forth between binding and typing free-form text by doing the following:

• Click the Arrow Tool  button and right-click the text asset to access the bind dialog.

• Click the Text Tool button  and select the text asset to type free-form text.

9. With the Work Instruction tab still detached, select the object in the structure pane containing the
text that you want to embed in the Teamcenter window. For example, if you want to embed the
description of a particular item revision, select that item revision in the structure pane.

10. In the detached Work Instruction tab, with the text placeholder still selected, click the Populate
Asset button .

Teamcenter displays the specified text on the work instructions page.

Bind data to display in a table format

Use the table asset to embed multiple pieces of information about a selected object.

1. Detach the Work Instructions tab.

2. In the detached tab, click .

Teamcenter creates a placeholder for the table on the work instruction page.

3. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

4. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Table Placeholder dialog box.

5. From the Transfer Modes list, select tcm_export transfer mode.

6. In the Aliases list, open the appropriate alias, and select the type of information you want in the
list and click the plus sign.

If you select multiple entries, the selected objects appear as columns of the table in the same order
as in the Aliases pane.

7. Click OK.

Bind data to display in a table format
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8. With the Work Instruction tab still detached, select the revision in the structure pane containing
the objects that you want to embed in the Teamcenter window. For example, if you want to embed
the ID, name, and description of all members of an assembly, select the assembly root structure in
the structure pane.

9. In the detached Work Instruction tab, with the table placeholder still selected, click the Populate
Asset button .

Teamcenter displays the specified information on the work instructions page.

Bind linked data

To bind linked data, a dataset with a .txt file imported into it must exist. In addition, you must be able to
open this .txt file in an associated text editor.

1. Detach the Work Instructions tab.

2. In the detached tab, click .

Teamcenter creates a placeholder for the link on the work instruction page.

3. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

4. Right-click the placeholder and choose Bind.

Teamcenter displays the Bind Link Placeholder dialog box.

5. From the Transfer Modes list, select the ExportGraphic transfer mode.

6. From the Aliases list, select LinkedDataset.

7. In the Attachment tab of the Teamcenter window, select the text dataset and click Populate.

Teamcenter displays the link on the work instructions page.

Bind a 2D image

You can bind a 2D image that is attached to a revision.

1. Detach the Work Instructions tab.

2. In the detached tab, click .

15. Creating, viewing, and editing manufacturing documentation
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Teamcenter creates a placeholder for the image on the work instruction page.

3. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

4. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Image Placeholder dialog box.

5. From the Transfer Modes list, select ExportGraphic transfer mode.

6. In the Aliases list, open the 2DGraphic entry and select file.

7. With the Work Instruction tab still detached, open the Attachments tab in the Teamcenter
window.

8. Select the image that you want to embed.

9. In the detached Work Instruction tab, with the image placeholder still selected, click the Populate
Asset button .

Teamcenter displays the selected image on the work instructions page.

Bind a 2D snapshot

If you embed a 2D snapshot, a 2D geometry asset2D geometry asset must exist for it.

1. Detach the Work Instructions tab.

2. In the detached tab, click .

Teamcenter creates a placeholder for the image on the work instruction page.

3. Save the work instruction.

You must always save a work instruction once to create the dataset before you can populate an
asset.

4. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Image Placeholder dialog box.

5. From the Transfer Modes list, select ExportGraphic transfer mode.

Bind a 2D snapshot
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6. In the Aliases list, open the 2DSnapshot entry and select file.

7. With the Work Instruction tab still detached, but working In the Teamcenter window, do one of
the following to specify which 2D snapshot should be populated:

• In the Attachments tab, select the snapshot.

• In the 2D Viewer tab, open the 2D Snapshots Gallery dialog window and select an existing
snapshot.

• In the 2D Viewer tab, arrange the snapshot. When you populate the asset, Teamcenter
automatically creates the snapshot for you.

8. In the detached Work Instruction tab, with the image placeholder still selected, click the Populate
Asset button .

Teamcenter displays the 2D snapshot on the work instructions page.

Note:

If you receive an error saying Failed to load Error document (2DSnapshot & file) when
populating a 2D asset, the 2D snapshot does not contain a 2D geometry asset.

Recapture the 2D snapshot with the option to capture 2D geometry asset data turned on.

Bind a 3D asset

1. Open a structure to which you want to attach a work instruction.

2. Detach the Work Instructions tab.

3. In the detached tab, click the 3D Graphic button .

Teamcenter creates a placeholder on the work instruction page.

4. In the detached tab, select File → Save TI Illustration.

You must save the work instruction once to create the dataset. If you do not save first, you receive
an error when populating the asset. Once the dataset exists, this step is no longer required, unless
you want to save changes to the work instruction page.

5. Right-click the placeholder and select Bind.

Teamcenter displays the Bind Geometry Asset Placeholder dialog box.

6. From the Transfer Modes list, select ExportGraphic transfer mode.

15. Creating, viewing, and editing manufacturing documentation
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7. In the Aliases list, open the 3DGeometryAsset entry and select file.

8. With the Work Instruction tab still detached, but working in the Teamcenter window, do one of
the following to specify which 3D geometry should be populated:

• In the Assembly Viewer tab, open the 3D Product View Gallery dialog box, create a snapshot,
then select it.

Caution:

You must ensure that the Add or Update 3D Geometry Asset option is selected before
you create a snapshot.

• In the Attachments tab, select the 3D snapshot.

• In the Assembly Viewer tab, arrange the snapshot. When you populate the asset, Teamcenter
automatically creates the snapshot for you.

9. In the detached Work Instruction tab, with the placeholder still selected, click the Populate Asset
button .

Teamcenter displays the 3D geometry asset on the work instructions page.

Populate an empty asset

When you populate an asset, you associate Teamcenter data with it.

1. Select the asset.

2. Select the object in Teamcenter to which you want to link the asset.

3. Detach the Work Instruction tab by right-clicking it and selecting Detach data tab.

4. Click the Populate Asset button  or menu command.

Creating a publishing page template

Your site may provide publishing page templates whose content can be used as the starting point for the
creation of a new publishing page. A publishing page template is a publishing page dataset that is not
populated with actual data.

A page template may contain standard data such as a company logo, pictures, and required text. It may
also contain empty placeholders, whose content you must fill for each instance of a publishing page you
create from the template.

You can classify templates in the Classification application for easy retrieval.

Populate an empty asset

Multi-Structure Management, Teamcenter 2412  15-11
© 2025 Siemens



Classify a template

1. Add the TCPublishingPage business object type to the ics_classifiable_types preference.

2. Create a publishing page template.

3. In the Attachments view, select the template and choose Send to→Classification.

4. In Classification, classify the template.

The template is now available when you create a new publishing page from a template.

Create a publishing page from a template

1. Click the relevant tab in the data pane (for example, Work Instructions) and choose File→New TI
Dataset.

Teamcenter displays the New Dataset dialog box.

2. If you know the name of the required template, type it in the Template name box.

If you do not know the name of the template, you can search the database for it. In the Templates
pane at the top of the dialog box, click the Find a Template by name button  next to the
Template name box.

Teamcenter displays the Find by Name dialog box, and you can search by part of the name and
with wildcard (*) characters.

If templates are classified, you can click Classification Search Dialog  to find the template you
require.

3. When you identify the publishing page you want to use as a template, double-click the name to
select it and return to the New Dataset dialog box.

4. (Optional) Click the Add To Favorites button to add the selected template to the list in the
Templates pane above it.

5. (Optional) Click the Use as Default button to use the specified dataset as the default template if no
TI dataset is loaded.

6. In the File section, select Use Template.

7. Type a name and description in the relevant boxes.

8. Click OK.

15. Creating, viewing, and editing manufacturing documentation
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Teamcenter creates the new publishing page dataset.

Using default templates

All of the default templates contain 3D geometry assets. You can add the following details to specific
page templates.

Template Purpose

TCPartList Specifies the part list table. When populated, it lists all the parts
under the selected BOM line. It includes the item identifier, item
name, revision identifier, description, and find number of each part
in the list.

TCAssemblyOperation Use this template at the operation level in a manufacturing
structure. It briefly describes the operation, its activities, the
consumed parts, and tools required to perform the operation. The
Activities table lists all the activities under the selected operation,
their descriptions and durations. The consumed parts table lists the
parts consumed by the selected operation, their identifiers, names,
revision identifiers, descriptions, and logical identifiers. The Tools
table lists the set of tools required by the operation, their identifiers,
names, and descriptions.

TCOperationRouting This template lists manufacturing process details, including the
operations under it, the consumed parts of those operations and
the list of tools used in those operations. Use this template at
the process level. The Operations List table lists all the operations
under the selected process. The consumed parts table lists all the
consumed parts under all the operations below the process. The
Resource List table lists all the resources under all the operations
below the process.

TCActivityDetails This template describes the activities under an operation. Use this
template at the operation level of a structure. For each activity, the
name, description, start time, duration, calculated start time, and
calculated duration are listed.

TCActivityRouting This template lists manufacturing activity details, including the
operations under it. Use this template at the operation level.

TCActivityToolList This template contains detailed description of the activities in the
structure. It may also be used at the operation level. It lists the
following activity details:

• The Activities Consumed Parts table lists all the activities, their
descriptions, and the parts consumed in each of these activities.

Using default templates
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Template Purpose

• The Activities Used Resources table lists all the activities, their
descriptions, and resources used in each of the activities.

Example — Populate assets using the TcPartList template

Teamcenter delivers several templates that are ready for you to use. The following is an example of how
to use the TcPartList template.

1. Load a product assembly. To use the 3D asset, you must load an assembly that displays parts in the
assembly viewer.

2. Select a BOM line to which you want to add a publishing page. You can select the top line, if
necessary.

3. Turn on the data tab and click the Work Instruction tab or some other publishing page tab.

4. Detach the Work Instruction tab by right-clicking it and choosing Detach data tab.

5. In the publishing page tab, select File→New TI Dataset.

6. In the dialog box, find the TcPartList template by name and use it as the starting template.

7. Specify a dataset name and click OK. The template should appear in the publishing page viewer.

8. Populate the table assets by selecting the node (BOM line) whose data you want to populate in the
table asset component in the left-hand navigation tree. Then select the table asset component in
the publishing page pane and choose Edit→Populate Asset.

15. Creating, viewing, and editing manufacturing documentation
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9. Populate the 3D geometry asset as follows:

a. Select the viewer tab.

b. Turn on parts and use the 3D viewer to manipulate the view until it shows what you want to
see in the asset. Include markups if desired.

c. Ensure that a BOM line is still selected, then select the 3D asset in the publishing page viewer
and select the Populate button. This creates a new snapshot (product view) dataset and
populates the asset with it. You can also populate a 3D asset from an existing snapshot.
However, the dataset must have an asset file attached to it. Asset file creation is an option; use
the named reference dialog to determine whether or not the dataset has an asset file.

• Select a snapshot dataset in the Attachments tab or in another application.

• Select a 3D snapshot (product view) in the Product Views dialog box of the assembly
viewer. Asset file creation is controlled by a menu in this dialog box.

Example — Populate assets using the TcPartList template
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Updating publishing pages

When an asset is populated, a reference to the selected Teamcenter populating object is stored in the
asset. If the data in Teamcenter changes, you can update the asset to show the changes. Updating is not
automatic; you must explicitly perform an update.

Take, for example, the TcPartList template’s table. Long after you create the publishing page and
populate the table asset, the product structure can be modified. Item names can change or BOM lines
can be added or removed from the line that was used to populate the table. After this happens, you can
update the publishing page to show the changes.

Update an asset

1. Open the page dataset in a publishing page viewer anywhere in Teamcenter.

2. Select the asset and choose Edit → Update Asset from the page viewer menu.

The new contents of the asset are displayed, along with a triangle indicating that the display shows
new (and so far unaccepted) data.

3. Switch between displaying the old and the new data by choosing Show Original Data and Show
New Data from the asset's shortcut menu. The asset is in an uncommitted state. You cannot
update the asset again or repopulate it while it is in this state.

4. Accept or reject the change by choosing Accept New Data or Accept Original Data from the
asset’s shortcut menu. All of the assets on a page can be updated at once using the publishing
page Edit → Update Technical Illustration menu. Other Edit menus let you toggle the display and
accept or reject the changes for all of the assets on the page at once.

15. Creating, viewing, and editing manufacturing documentation
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Note:

You cannot update data in the database (other than the publishing page itself) by updating
an asset. Assets can only display what is already in the database. To update a 3D asset, you
must first update the snapshot dataset in the assembly viewer.

Repopulate an asset

An asset that has been populated can be repopulated with a different Teamcenter component.

1. Select the asset in the detached publishing page viewer.

2. Select the component in the rich client window, and choose Edit → Populate Asset in the
publishing page window.

3. Switch between displaying the old and the new data by choosing Show Original Data and Show
New Data from the asset's shortcut menu. The asset is in an uncommitted state. You cannot
update the asset again or repopulate it while it is in this state.

4. Accept or reject the change by choosing Accept New Data or Accept Original Data from the
asset’s shortcut menu. All of the assets on a page can be updated at once using the publishing
page Edit → Update Technical Illustration menu command. Other Edit menus let you toggle the
display and accept or reject the changes for all of the assets on the page at once.

Note:

You cannot update data in the database (other than the publishing page itself) by updating
an asset. Assets can display only what is already in the database. To update a 3D asset, you
must first update the snapshot dataset in the assembly viewer.

View populating and end objects

The populating object is the one that was selected when the asset was populated. The end object is
the object that is actually displayed in the asset after it is populated. These can be the same object, or
different ones, depending on your alias definition.

You can view these objects.

1. Select the asset in the Work Instructions pane.

2. Do one of the following:

• To show the populating object in My Teamcenter, choose Edit → Asset Components → Send to
My Teamcenter → Populating Components.

Repopulate an asset
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• To show the end object in My Teamcenter, choose Edit → Asset Components → Send to My
Teamcenter → End Object.

• To view the populating object in the default viewer without switching applications, choose
Edit → Asset Components → View Populating Components.

• To view the end object in the default viewer without switching applications, choose Edit →
Asset Components → View End Object.

Note:

These menu commands may not work depending on how the alias file is implemented. For more
information, contact your administrator.

Create a new work instruction

1. Select the BOM line with which you want to associate the work instructions, for example, the item
revision of an assembly or operation.

2. Click the Work Instructions tab in the data pane.

3. In the Work Instructions tab, choose File → New TI Dataset.

Teamcenter displays the New Document dialog box.

4. If your site uses templates, select the name of a template, enter a dataset name, and click OK.

Note:

The work instructions are attached to the BOM line with a IMAN_MEWorkInstruction
relation.

Add new pages to the work instructions or product manual

• Choose Insert → New Page.

Teamcenter adds a new, blank page to the active work instructions or product manual. You can also
search for an existing page by name or use a Classification search to find a classified page.

Delete pages from the work instructions or product manual

1. Choose Edit → Delete Pages.

Teamcenter displays the Delete Pages dialog box containing a list of available pages.

15. Creating, viewing, and editing manufacturing documentation
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2. Select the page to delete and click OK.

Teamcenter deletes the page from the work instructions or product manual.

Save changes to the work instructions or product manual

• Choose File → Save.

Teamcenter saves any changes that you made.

Reserve space for headers and footers

You reserve space for headers and footers on a publishing page. When you print or export the work
instructions or product manual, any shapes on the publishing page are clipped to the defined margins.

1. Open the work instructions.

2. Choose View → Page Margins.

Teamcenter adds a gray-shaded background at the top, bottom, left, and right of the page.

Add export tags

You can add export tags to a page that are replaced with actual information when you print or export it.
For example, if you select page, the actual page number appears. Additional export tags include date,
long date, document file name, portfolio file name and total number of pages.

1. Open the work instructions or product manual.

2. Choose Insert → Portfolio Export Tag and select a tag from the displayed list. The tag you select
appears on the work instructions or product manual.

3. (Optional) Move or resize the export tag on the work instructions or product manual.

Navigate to another publishing page

Use one of the following methods to navigate to another publishing page:

1. Choose View → Page → Go to.

Teamcenter displays the Select Page dialog box.

2. Select the page to you want to navigate.

- or -

Save changes to the work instructions or product manual
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Use the navigation arrow buttons to browse through the available pages.

Export publishing pages to HTML

1. Choose File → Save as Web Page.

Teamcenter displays the Save As dialog box.

2. Type a name for the exported file and click Save.

Teamcenter displays the Save as Web Page dialog box.

3. Change settings for the following options:

Tab Options Description

General tab Pages to Publish Choose Select All to print all pages or Select
Pages from and then type the page span.

Publishing options Select any of the publishing options, which
appear in the finished Web page to aid
navigation and searching.

Additional options Choose any of the following:

• Automatically open Web page in browser

• Organize supporting files in a folder

• Type text in the Page title box to name the
exported HTML output.

Advanced tab Output formats Select a format for the HTML output.

Provide alternate format
for older browsers

Choose a format from the list.

Target monitor Choose the monitor size.

Host in Web page Select a Web page from the list or browse to a
file.

Style sheet Select a style sheet from the list or browse to a
file.

4. Click OK.

Teamcenter displays the publishing pages as a Web page in your default browser.

15. Creating, viewing, and editing manufacturing documentation
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Export publishing pages to PDF

You can print a portfolio to PDF in My Teamcenter. Before you do this, you must install third party
software capable of creating PDF output.

1. Create a portfolio.

2. Open My Teamcenter.

3. In the File menu on the viewer tab, choose Publish PDF to Database.

Detach the Work Instructions tab

Detaching the Work Instructions tab allows you to change the source of the assets. Until you detach
this tab, all assets that you populate pertain to the originally selected structure line.

1. Right-click the tab on the data pane.

2. Choose Detach data tab.

Teamcenter separates the tab as a floating window on top of the application that you can enlarge
and reposition as necessary.

The detached tab remains visible unless you delete the component tracked by the tab or select
another component in the navigation tree. You can also close the detached window manually by
clicking the x button in the corner of the window. Teamcenter does not remember the selection of
detached tabs between sessions.

Creating a portfolio

About portfolios

Portfolios act as a container for work instructions or product manuals and supporting documents,
such as a table of contents, cover or trailer pages, and header and footer information. Portfolios may
contain a reference to a publishing page or generic page or to an embedded generic page. You can use
portfolios to store document structure information, print multiple publishing pages, and export portfolio
contents to HTML or PDF.

You generate portfolios in Manufacturing Process Planner, Part Planner, Multi-Structure Manager, Service
Planner, or Plant Designer. You manage portfolios in My Teamcenter only.

When managing a portfolio:

Export publishing pages to PDF
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• Use container nodes to add an organizational hierarchy to the portfolio. Think of container nodes as
chapters in a book, in which you can separate and group documents. Container nodes are useful for
multiple levels in the table of contents.

• During printing operations, Teamcenter creates the table of contents information in a dynamic page.

• Create generic pages for any information page to add to the portfolio, such as cover or trailer pages.
Generic pages are not considered publishing pages and Teamcenter does not apply headers and
footers to them.

• Add header and footer information to portfolios by creating a special page. Teamcenter copies the
shapes in this page to the published pages during printing and export operations. The same header
and footer appears on every page.

• When adding supporting documents to portfolios, choose from the following options:

• Insert Reference

Select a supporting document for the portfolio to reference.

• Create

Add a new supporting document that Teamcenter embeds in the portfolio. You can only create and
embed generic pages.

• Embed

Copy a supporting document into the portfolio.

Create a portfolio

1. Select the BOM line to which you want to associate the portfolio, which may be a configured item
or process revision or occurrence in the structure. The portfolio contains the publishing pages that
are attached to the BOM line’s child lines.

2. In the Teamcenter window, choose Tools → Generate Portfolio.

Teamcenter displays the Generate Technical Portfolio dialog box.

3. In the dialog box, enter a name and select a role such as Work Instructions and click OK.

Teamcenter creates a portfolio dataset that contains all of the appropriate pages. The portfolio
is created under an intermediate data capture (IDC). If a structure context is opened, the IDC is
attached to the structure context. Otherwise it is stored in the New Stuff folder.

4. (Optional) To view the portfolio, select it in My Teamcenter and click the viewer tab.
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Tip:

Note the menu and toolbars in the Viewer pane. These commands help you manage
portfolios.

Create container nodes

You can create one or more container nodes in the portfolio in My Teamcenter in the viewer.

1. Select the portfolio  in the Newstuff folder in My Teamcenter.

Teamcenter opens the viewer.

2. Using the menu commands within the Viewer view, do one of the following:

• Choose Actions → Create and select Container Node.

• On the Technical Portfolio toolbar, click the Create container button .

Create the table of contents

You can create the table of contents for a portfolio in My Teamcenter in the viewer.

1. Select the portfolio  in the Newstuff folder in My Teamcenter.

Teamcenter opens the viewer.

2. Using the menu commands in the viewer, do one of the following:

• Choose Actions → Create and select Table of Contents Placeholder.

• On the Technical Portfolio toolbar, click the Create table of contents button .

Add a generic page

You can add a generic page to a portfolio in My Teamcenter in the Portfolio pane.

1. Select the portfolio  in the Newstuff folder in My Teamcenter.

Teamcenter opens the Portfolio pane.

2. Select an area to place the generic page.

3. Using the menu commands within the Portfolio pane, do one of the following:

Create container nodes
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• Choose Actions → Create, Actions → Insert Reference or Actions → Embed, and select
Generic Page.

Note:

You cannot search using the classification search if working in My Teamcenter.

• On the Technical Portfolio toolbar, click the Create generic page button .

Create a header and footer page

You can create a header and footer page in a portfolio in My Teamcenter in the viewer. Teamcenter
copies the shapes in this page to the published pages during printing and export operations. The same
header and footer appears on every page.

1. Select the portfolio  in the Newstuff folder in My Teamcenter.

Teamcenter opens the viewer.

2. Select an area in the portfolio to place the header and footer page.

3. Using the menu commands within the viewer, do one of the following:

• Choose Actions → Create, Actions → Insert Reference or Actions → Embed, and select
Header/Footer Definition Page.

• On the Technical Portfolio toolbar, click the Create header/footer data button .

Teamcenter opens a new viewer window with a blank page.

4. Using the commands in the new window, choose t Insert → Portfolio Export Tag and select one of
the following:

• Date

• Long Date

• Document File Name

• Portfolio File Name

• Pages

• Total Number of Pages

Teamcenter creates a placeholder for the object on the page.
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5. Move the placeholder to the desired position.

6. When you have placed all desired export tags, choose File → Post to Technical Portfolio.

7. Click Close.

8. In the viewer, click File → Save.

Modify header and footer information

1. Select the portfolio  in the Newstuff folder in My Teamcenter.

Teamcenter opens the viewer.

2. Right-click the header and footer page in the portfolio tree and choose Open.

3. Make any necessary changes.

4. Choose File → Post to Technical Portfolio.

5. Click Close.

6. In the viewer, click File → Save.

Add a work instruction

1. Select an area in the portfolio to place the work instructions.

2. Do one of the following:

• Choose Actions → Insert Reference and select Technical Illustration.

• On the Technical Portfolio toolbar, click the Technical Illustration button.

The system displays the Insert Page dialog box.

3. Click the Find a page by name button and type the name of the work instruction that you want to
add.

4. Click Open. The work instruction you chose appears in the tab.

Publish a portfolio to HTML

You can publish a portfolio on a Web server by exporting its contents in HTML format. This allows
consumer users access to work instructions or product manuals from any Web browser.

Modify header and footer information
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1. Choose File → Publish Zip to Database.

The system displays the Publish to HTML Options dialog box.

2. Edit the export options in these ways:

Tab Options Description

General tab Destination Folder Specify the destination folder where the
export data is written by clicking Save.

Note:

Specifying the destination folder is
the only required selection in this
dialog box. All other options in
this dialog box are discretionary
selections.

Create zip file Create a ZIP file of all export data. Click the
Browse button to specify the location of
the ZIP file. Use this option to allow users
without access to Teamcenter to view the
data.

Use title page
template

Use a template file for the main HTML title
page. Click the Browse button to choose
the HTML file.

Replace or remove
logo

By default, the HTML output includes the
Siemens Digital Industries Software logo.
To replace the default Siemens Digital
Industries Software logo graphic, click the
Browse button to locate a replacement
graphic. To remove the default Siemens
Digital Industries Software logo graphic,
click the Remove button.

Export
Options tab

Stop if error occurs Stop the export operation if an error is
encountered.

Produce flat output Remove the portfolio structure and
document hierarchy.

Publishing options Indicate specific control panes to be
included in the HTML output for each
published page.
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Tab Options Description

• Choose Show Details to display custom
shape properties.

• Choose Go to Page to include navigation
for multi-page work instructions or
product manual.

• Choose Search to enable the ability to
search shapes.

• Choose Pan and Zoom to enable
panning and zooming on a page.

Note:

The Publishing Options option is
only applicable if you select VML
for the Output format (VML is the
default). VML output only displays
Publishing Options if you use the
Internet Explorer browser.

Advanced
Options tab

Output formats Choose the primary output format for the
exported published pages.

Provide alternate
format for older
browsers

Indicate a secondary output format for
exported published pages, used for older
browsers.

Display options Select a target monitor size.

3. Click OK.

The Report Definition wizard displays the status of the export operation.

Note:

Name lists the supporting documents in the portfolio; Status indicates if the supporting
documents were exported.

4. Click Next.

The system displays the Create Report Output dialog box.

5. Create a standard or custom report output format.

Publish a portfolio to HTML
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Publish a portfolio to PDF

You can create a PDF file from the portfolio that is attached as a dataset provided you have Microsoft
Office installed.

1. Select the portfolio  in the Newstuff folder in My Teamcenter.

Teamcenter opens the viewer.

2. Using the menu commands in the viewer, choose File → Publish PDF to Database

Teamcenter creates the PDF and attaches it to the portfolio dataset. You can view it in the viewer.

Creating manufacturing documentation in batch mode

Creating manufacturing documentation in batch mode overview

You can create and update Teamcenter work instructions and portfolios in batch mode, processing
multiple documents using the Teamcenter Publish Batch dialog box. You do not need to process
individual documents manually. You can schedule these tasks to take place immediately or at a later
date.

Batch processing uses the Dispatcher infrastructure for scheduling create and update features.
Additionally, Dispatcher has built-in status, logging, and error reporting features.

Create or update publishing pages in batch mode

1. Select one or multiple lines in a structure.

These objects are typically processes, operations, items, or activities that can have publishing pages
associated with them. You can select one or more Teamcenter objects for direct batch processing or
specify that each object is to be treated as a root object and its children traversed.

2. In Manufacturing Process Planner, choose Advanced → Publish Batch.

Teamcenter opens the Publish Batch dialog box.

3. Enter the parameters for the Set Role and Scope step.

a. Select the paste relation used between the new page and its associated end object from the
Publishing Page Role list.

The roles available are set in the TCPUBLISH_BATCH_ROLE preference.

This information is required.

15. Creating, viewing, and editing manufacturing documentation
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b. Select the type of action you want to perform from the Batch Task section.

• Select Create and Update to initiate a create task with an update option. The batch task
creates pages where they do not exist and updates pages that do exist.

• Select Update Only to only update existing pages.

c. Specify the scope of the page creation in the Batch Process Scope section.

• Select Process entire structure to have the create task traverse the entire structure of each
selected structure, even if a child line of a structure is selected.

• Select Process selected lines to create a page for the selected object(s) only. If you want
to create a page for the selected object and all its child objects, additionally select Process
selected lines substructure.

4. Enter the parameters for the Set Update Parameters step.

• Select Update All to:

• Generate all missing pages.

Teamcenter generates a new page for each new object it encounters.

• Update populated assets.

Teamcenter checks that all assets display the most current data.

• Populate unpopulated assets.

Teamcenter associates data with any empty assets.

• Process all asset types.

Teamcenter performs these activities on all asset types found in the work instruction.

• Select Selective Update Options to only perform specific update actions.

5. Associate classes with templates in the Select Types and Templates step.

The Mark class types to process list displays the types of objects that can have publishing pages
associated with them.

The Mark templates to be used with list contains templates that you associate with a class or type
by selecting both the class and the template.

Create or update publishing pages in batch mode
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If you select None in the templates list, the class or type is not processed.

A type level association overrides the class level definition.

6. (Optional) Add more templates to the templates list.

a. Click Add Templates.

b. Type a template name in the Template Name box.

c. Click Search by Name to search in the database for a template or Search by Class to search
the classification hierarchy for a classified template.

d. (Optional) If you are going to use this template repeatedly, add it to a favorites list by clicking
Add to Favorites.

e. Do one of the following:

• Click Add to add the current selection to the Mark templates to be used with class/type
list.

• Click OK to close the dialog box and keep changes to the favorites list.

• Click Cancel to close the dialog box without keeping changes to the favorites list.

7. (Optional) Enter the parameters for the Define Portfolio Parameters step.

A portfolio is a container for work instructions. You can use portfolios to store document structure
information, print multiple publishing pages, and export portfolio contents to HTML.

a. Select Generate a Portfolio.

b. Type a name for the portfolio in the Portfolio Name box.

c. Type a description of the portfolio in the Portfolio Description box.

d. (Optional) Select Use a template to select a template from the database.

For more information about using templates, see step 6.

8. Enter the parameters for the Schedule the Batch Process step.

You can schedule the batch process for a specific date and time.

• Select Immediate to initiate the task at the current date and time. Clicking Finish on any page
without previously selecting scheduling parameters also initiates the task immediately.

15. Creating, viewing, and editing manufacturing documentation
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• Select Scheduled to select a specific start date and time.

• Select Periodical to schedule a task that recurs at a specific date and time. You can specify a
recurrence pattern on a daily, weekly, monthly, or yearly basis.

9. Click Finish.

Update a portfolio in batch mode from My Teamcenter

You can schedule a portfolio for updating in batch mode in My Teamcenter.

1. Open My Teamcenter.

2. Right-click a portfolio dataset and choose Batch Update Pages.

Teamcenter opens the Publish Batch dialog box where you can schedule the batch process for a
specific date and time.

3. Enter the parameters for the Schedule the Batch Process step.

• Select Immediate to initiate the task at the current date and time. Clicking Finish on any page
without previously selecting scheduling parameters also initiates the task immediately.

• Select Scheduled to select a specific start date and time.

• Select Periodical to schedule a task that recurs at a specific date and time. You can specify a
recurrence pattern on a daily, weekly, monthly, or yearly basis.

Update a portfolio in batch mode from My Teamcenter
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16. Working with allocations
Allocations overview

An allocation represents a directional relationship between a specific instance of an item revision in one
product structure and one or more item revisions in a related structure. For example, you might relate
lines in the functional structure to the logical structure or the logical structure to lines in the physical
structure. These relationships may span multiple configurations and revisions of both structures. They
may change according to the overall configurations or the specific revisions that are configured into the
structures.

A group of allocations that map together two or more structures is referred to as an allocation map
or allocation context. An allocation map is a Teamcenter object that can be revised separately from
the structures that it maps. However, depending on your business rules, you may want to revise the
allocation map at the same time as you revise the associated structures.

For more information about allocations, see Getting Started With Product Structure.

Set up Multi-Structure Manager to use allocations

Siemens Digital Industries Software recommends that you create a collaboration context containing
structure contexts representing each of the product representations that you want to associate with
allocations. The advantage to doing this is that you automatically save the product configuration of each
representation with the collaboration context so that when you reopen it, you have the same state that
you had when creating the allocations.

1. Create a new collaboration context of type CCObject.

Caution:

Do not use the MECollaborationContext type as this does not support the creation of
allocations.

2. For each product representation that you have for your product, create a structure context.

3. In My Teamcenter, copy the root items for each product representation and paste them into the
structure contexts in Multi-Structure Manager.

Activate the allocation navigator pane

1. Choose Edit→Toggle In Allocation Context Mode.

2. Click Show Allocation Navigator Panel .
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Find allocations belonging to a BOM revision

1. In My Teamcenter, right-click the BOM view and choose Where Allocated.

The BOM view is displayed in the Where Allocated view.

2. Double-click the BOM view.

The Where Allocated view displays all allocation maps associated with that BOM view as well as
the other BOM views participating in the allocations.

3. Specify the depth of the search by selecting a level from the Depth list.

4. (Optional) Right-click an allocation context object and choose Send to→Multi-Structure Manager
from the shortcut menu.

Teamcenter launches Multi-Structure Manager and loads the products structures and allocation sets
associated with the selected allocation context object.

Find all allocation map revisions

1. Click List Allocation Context Revisions .

A list of all allocation map revisions associated with a specific allocation map is displayed.

2. Double-click the desired allocation map revision.

Find an existing allocation map

1. Click Search and Set Existing Allocation Context .

2. Type a name or ID in the boxes. You can use wildcard characters.

3. Click Find  .

Create an allocation map

Before you create individual allocations, you must create an allocation map that serves as a container to
hold all related allocations.

1. In the Allocation pane, click .

Teamcenter displays the New AllocationMap dialog box.

16. Working with allocations
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2. Select the type of allocation that you want to create. By default, this list contains only
AllocationMap. Your administrator can add more allocation types as necessary.

3. Click Next.

4. Type an allocation map ID and revision level.

5. (Optional) Type a name and description.

6. (Optional) Enter a unit of measure.

7. Click Finish.

The new allocation map appears in the allocation navigator. Each allocation you create appears as a
child of this allocation map.

Create allocations between occurrences

1. Select one or more lines in the structure as source components from one or more products
structures.

2. Choose Allocate from from the shortcut menu.

3. Select one or more lines as target components from one or more products structures.

4. Choose Allocate to or Allocate to... from the shortcut menu.

• If you choose Allocate to, the system automatically generates a name and uses the default
allocation subtype.

• If you choose Allocate to..., you are prompted to specify a name for the allocation. Type a name
or leave the box blank and the system generates one for you.

You cannot select source and target from the same structure.

5. (Optional) Enter allocation properties.

For more information, see Specify and edit allocation properties.

6. Click OK.

Teamcenter displays the allocated from symbol  in front of the source occurrence and the
allocated to symbol  in front of the target occurrence in the structures.

Create allocations between occurrences
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Create allocations using drag-and-drop

1. Choose Tools→Toggle In Allocation Drag N Drop Mode. If you neglect to activate this menu
command, the drag-and-drop action creates manufacturing assignment relationships.

2. Select an occurrence as source components from a structure.

3. Drag-and-drop the occurrence onto a target occurrence in another structure.

Teamcenter automatically generates a name for the allocation.

Create allocations between any absolute occurrences in context

By default, Teamcenter creates allocations at the top-level context, but you can create allocations in a
subassembly in context by setting the absolute occurrence context in the BOM window to the desired
context.

1. Select the occurrence that you want to have as the top-level context and click In Context Mode
. In-context editing mode is enabled for this line and all its children.

2. Select the source occurrences and choose Allocate from from the shortcut menu.

3. Select the occurrence that you want to have as the top-level context in another structure and click
In Context Mode . In-context editing mode is enabled for this line and all its children.

4. Select the target occurrences and choose Allocate to from the shortcut menu.

This is equivalent to opening the individual subassemblies at the desired context level separately and
creating allocations between them.

Modify allocations

Modifying allocations allows you to add an additional target or source to the existing allocation.

1. Ensure that Highlight Allocated Lines Automatically  is turned off.

2. In the allocation navigator pane, select the allocation that you want to modify.

3. Right-click the source or target of the allocation that you want to modify.

4. Choose Modify Allocation→Add Allocate From or Add Allocate To to add a new source or target.

-or-
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If the allocation exists, choose Modify Allocation→Remove Allocated From or Remove Allocated
To to remove a source or target.

Revise allocation maps

1. In the allocations pane, click .

2. Click Yes in the AllocationContext Revise confirmation dialog box.

Teamcenter opens the New AllocationContext dialog box with the next revision level
automatically displayed.

3. (Optional) Type a new name, description, or select a new unit of measure.

4. Click Finish.

5. Click Close.

The next revision of the allocation map opens in the allocation navigator. By default, this contains
all the allocations from the previous revision. Your system administrator can change this behavior
in the ALLOC_map_copy_allocations preference.

Specify and edit allocation properties

1. Select the allocation whose properties you want to edit.

Tip:

If you click Highlight Allocated Lines Automatically , the source and target occurrences,
as well as the related allocation in the allocation navigator, all highlight automatically when
you select any of the others.

2. Choose Properties from the shortcut menu.

The Properties dialog box is displayed where you can add or modify properties.

Delete allocations

1. Right-click desired allocation in the allocation navigator.

2. Choose Remove Allocation Line from the shortcut menu.

The allocation is removed from the list of allocations and the symbols are removed from the
occurrences.

Revise allocation maps
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Delete allocation maps

1. Click Clear Allocation Context .

Teamcenter asks if you to confirm that you want to remove the allocation map.

2. Click OK.

Associating allocations with an incremental change

1. Ensure that incremental change is enabled by checking that the
Incremental_Change_Management preference is set to true.

For more information about working with preferences, see Teamcenter Environment Variables.

2. Open or create a new incremental change.

For more information about incremental change, see Incremental change overview.

3. Add, modify or remove allocations.

4. Optionally, click View/edit current IC information on the incremental change context bar to view
the recorded allocation changes.

Edit allocations in an incremental change

1. Ensure allocations incremental change is enabled (the Incremental_Change_Management
preference is set to true).

2. Create a new incremental change or open an existing one.

3. Select the occurrence for which you want to see associated allocations and choose Show
Allocations in Allocations Navigator from the shortcut menu.

The allocation navigator pane shows a list of allocations associated with the selected occurrence.

4. Select the desired allocation.

The corresponding source and target components are highlighted in the product structure.

5. Modify or delete source or target components associated with the allocation, or delete the
allocation. These modifications are shown in the incremental change.

16. Working with allocations
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Compile a traceability report

1. Choose a source or target allocation.

2. Click Show/Hide the data panel .

3. In the data pane, click the Allocations Traceability tab.

4. Select To or From in the Allocated As box.

5. Double-click the allocation in the Allocations Traceability pane to reveal the source/target and the
allocation to which these belong.

Filter allocations by type

You can limit the type of allocations shown in a structure as follows:

1. Choose View→Show Only Selected Allocation Types or click .

Teamcenter displays the Filter Allocations by Type dialog box.

2. Select the allocation types that you want to see from the Available Allocation Types list.

3. Click the plus sign to add these types to the Selected Allocation Types list.

4. Click OK.

Only those allocation types that you selected in the Filter Allocations by Type dialog box are
shown in the allocation navigator.

Submit allocations or allocation maps to a workflow

You can send an allocation or an allocation map through a workflow. If you release an allocation map,
you cannot modify existing allocations, nor add or remove any allocations from the allocation map.
Releasing an allocation map does not add all allocations to the workflow process as targets unless the
process templates are set up to do this. Once the allocation map is released, the status flag only appears
for the allocation map and not for the individual allocations. Releasing an allocation does not prevent
the allocation map from being modified; you can add new allocations or remove existing allocations
from the allocation map. You cannot, however, modify or delete the released allocation.

Releasing an allocation does not prevent the allocation map from being modified; you can add new
allocations or remove existing allocations from the allocation map. You cannot, however, modify or
delete the released allocation.

Compile a traceability report
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Submit an allocation map to a workflow

1. Select the desired allocation map from the allocation navigator pane.

2. Choose Insert→Process from the menu.

The Workflow process dialog box is displayed.

3. Select the appropriate process template for your needs.

Submit an allocation to a workflow

1. Select the occurrence associated with the allocation to be released.

2. Choose Show Allocations from the shortcut menu.

3. Select the allocation to be released from the allocation navigator pane.

4. Choose Insert→Process.

The Workflow process dialog box is displayed.

5. Select the appropriate process template for your needs.

Apply effectivity to an allocation

1. Select the occurrence associated with the allocation for which you want to add effectivity.

2. Choose Show Allocations from the shortcut menu.

3. Select the released allocation from the allocation navigator pane.

4. Choose Tools→Effectivity from the menu.

For more information about setting effectivity, see About occurrence effectivity.

Sharing allocations to other sites

You can share allocations to other sites using Multi-Site Collaboration.

For more information about using this, see Multi-Site Collaboration.

16. Working with allocations
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Importing and exporting allocations

You can import and export allocations using PLM XML.

For more information about using PLM XML, see Tc XML and PLM XML Configuration for Data Import
and Export.

Configuring allocations

You can configure an allocation just as you can configure a structure. By associating conditions with the
allocation relationships, you can configure various allocations in and out of a product.

For more information about configuring allocations, see Getting Started With Product Structure.

Importing and exporting allocations
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17. Importing and exporting structures and
items
Exporting items or structures

Multi-Structure Manager uses PLM XML to export and import data. To use this, appropriate transfer
modes must be created that select the correct data to export. You create these transfer modes in the
PLM XML application.

For more information, see Tc XML and PLM XML Configuration for Data Import and Export.

You can export any of the following from a collaboration context:

• BOM lines

Any components attached to the BOM line are also exported.

• Product structure

If the product structure includes multiple views, all the views are also exported.

• Operations

Any consumed items, resources, and plant data attached to the process structure are also exported.

• Process structure

• Plant structure

• Structure context

• The complete collaboration context and all the structure contexts it contains

There are various methods used to export structures.

For more information about importing structures, see Teamcenter Basics.

Importing a structure

You can import any of the following into a collaboration context:

• A product structure and its assembly views
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• A process (BOM) structure

• A plant (BOM) structure

• A collaboration context and the structure contexts it contains

There are various methods used to import structures.

For more information about importing structures, see Teamcenter Basics.

Importing and exporting collaboration contexts using Multi-Site
Collaboration

You can use Multi-Site Collaboration to share structures with other sites. If you use it to share
collaboration context objects, take the following into consideration:

• When using saved revision rules, export all revision rules at the original site using plmxml_export
–xml_file=file_name –class=revisionrule and use plmxml_import –xml_file=file_name at the
importing site before using Multi-Site Collaboration with collaboration or structure context objects.
Unsaved or modified revision rules are handled automatically.

• Export individual structures prior to exporting a collaboration or structure context to get the proper
revisions of the objects in the structures.

• The configuration context does not affect which revisions are exported if you export a BOM with a
collaboration or structure context.

Using the Application Interface Viewer

About the Application Interface Viewer

The Application Interface Viewer allows you to monitor and administer data exchanges between
Teamcenter and an external application using the Application Interface (AI) service functionality.

For more information about the AI Service, see Services Reference on Support Center.

The data exchanges between Teamcenter and the external application are in PLM XML format, and the
data may represent a project, product, process, or other data structure. The Application Interface Viewer
is intended for use by administrators and other skilled users who have an understanding of the AI service
functionality and PLM XML syntax.

The Application Interface Viewer allows you to do the following:

• View an application interface object that manages the data in an import or export transaction.

17. Importing and exporting structures and items
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• Create a synchronization request and track its state and status. The synchronization request captures
the data to export to the external application.

• Create a publish request and track its state and status. The publish request captures the data to import
into Teamcenter.

Understanding Application Interface Viewer objects

The following objects are used in the Application Interface Viewer:

Object Description

Application interface
object

A persistent workspace object that is the repository for the import and
export transactions between Teamcenter and the external application for a
predefined and configured structure. It contains:

• An ordered list of request objects.

• The transfer mode (import or export).

• The root or top-level object of the structures to exchange. This may
be any object that is valid to import into or export from Teamcenter,
for example, a structure context, a folder, or an item (including all its
revisions).

• Tracking information to allow updates of changed data (deltas).

Master record object A persistent POM object that captures information about import and export
data. Teamcenter can detect changes to his information and export only
changed data.

Sync request object A persistent workspace object that tracks the data, state, and status of
a request to export data from Teamcenter. The synchronization request
contains the PLM XML file holding the imported data. It also contains state
and status information that allows you to monitor the request from creation
to completion.

Publish request object A persistent workspace object that tracks the data, state, and status of
a request to publish data in Teamcenter. The publish request contains
the PLM XML file holding the imported data. It also contains state and
status information that allows you to monitor the request from creation to
completion.

Transfer mode object A persistent workspace object that is a repository of details of one type of
translation. It captures a set of filters, and property sets that define a PLM
XML translation on import or export.

Understanding Application Interface Viewer objects
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Types of tracking requests

The Application Interface Viewer allows you to track three types of requests:

• Synchronization request

This is associated with a single data export transaction.

• Publish request

This is associated with a single data import transaction.

• Notify request

This informs the Teamcenter and external application users of the success or failure of the transaction.

The import or export of data may take significant time, depending on the size of the structure. Each
request transitions through several states and you can monitor these states to determine the status of
the request. The possible request states are:

State Request status

New The request is created but not yet processed.

Processing PLM XML data creation is in progress, or a PLM XML file import has
begun.

Pending Processing is complete and communication of the synchronization
request is in progress, or the synchronization request is complete,
but the Publish request is not processed.

Communicating Teamcenter and the external application are exchanging data.

Completed Processing of the transaction request is complete but not necessarily
successful.

Rejected The transaction request is rejected. Teamcenter maintains the
history of requests, unless you explicitly delete them.

Interpreting request status

Each request may have one of the following status values:

Status value Meaning

Normal No errors have been detected.

Warning An error was detected, but processing continued.

17. Importing and exporting structures and items
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Status value Meaning

Severe A failure occurred and processing terminated.

Abort The transaction was interrupted.

The following table lists the possible status transitions and the resulting actions.

Cause New state New status Actions taken

Severe failure
during processing.
Transaction cannot
recover.

Completed Severe For a synchronization
request, Teamcenter
deletes the request. For
a publish request, the
completed processing is
undone and the request
remains in the queue.

Recoverable failure
during processing.

Pending Warning For a synchronization
request, Teamcenter
deletes the request. For
a publish request, the
completed processing is
undone. You may resume
the transaction at any
time when the cause is
rectified.

Failure during
communication.

Communicating
(unchanged)

Warning You may resume the
transaction at any time.

The user aborted
communication.

Communicating
(unchanged)

Abort You may resume the
transaction at any time.

A reject request
is initiated by a
user with write
permission to the
request.

Rejected Normal You can delete the
request from the queue.

Invalid access
rights or the object
is locked.

Unchanged Warning You may resume the
transaction at any time
when the cause is
rectified.

Allowable states transitions

The following table lists the permissible state transitions for a synchronization request. It also shows
when application interface objects and requests are locked for update.

Allowable states transitions
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Initial state New state Changed by Preconditions Object locking

None. New An application
interface object
when a request
creation is
initiated by a
user or workflow
action.

The requestor
must have write
access to the
application
interface object.

None.

New Processing An application
interface object
during
generation of
PLM XML for the
request.

None. The application
interface object
is locked for
updating.

Processing Pending An application
interface object
after processing
is complete.

The request is
successfully
processed.

The application
interface object
is unlocked.

Pending Communicating AI service on a
call to start data
exchange.

The request has
export access
rights.

The request is
locked to
update and to
retrieve files.

Communicatin
g

Completed AI service on a
call to end data
exchange.

The file transfer
is complete.

The request is
unlocked.

The following table lists the permissible state transitions for a Publish request. It also shows when
application interface objects and requests are locked for update.

Initial state New state Changed by Preconditions Object locking

None. New An application
interface object
when a request
creation is
initiated by a
user or an AI
service request
to create a
Publish request.

The requestor
must have write
access to the
application
interface object.
There must be no
pending
synchronization
request.

None.

New Communicatin
g

AI service on a
call to start a
data exchange.

None. The request is
locked to update

17. Importing and exporting structures and items
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Initial state New state Changed by Preconditions Object locking

and to retrieve
files.

Communicatin
g

Pending AI service on a
call to end a data
exchange.

The file transfer
is complete.

The request is
unlocked.

Pending Processing An application
interface object
triggered by a
user or workflow
action.

The request has
import access
rights to the
request object.
There must be no
pending
synchronization
request.

The application
interface object
is locked for
updating.

Processing Completed An application
interface object
after processing
is complete.

Processing is
complete.

The application
interface object
is unlocked.

Share data with the external application

1. Select one or more BOM lines.

2. Request that the associated data is sent to the external application by choosing Tools→Export
objects→AppInterface.

3. Select the relevant application interface type from the list.

Teamcenter:

a. Creates a new structure context containing an occurrence group for the selected BOM lines,
and assigns the window configuration to the structure context.

b. Creates a new application interface object and attaches the structure context to it.

c. Attaches the import and export transfer modes associated with the external application to the
application interface object.

d. Traverses the structure context according to its configuration and export transfer mode, then
creates the necessary PLM XML data.

e. Creates a master record of all the objects it created and attaches them to the application
interface object.

Share data with the external application
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f. Creates a synchronization request and attaches the PLM XML file to this request.

g. Attaches the synchronization request to the application interface object.

4. The external application is launched and Teamcenter passes it the application interface object and
user identifications. It then:

a. Logs on using the AI service.

b. Retrieves the PLM XML file and the corresponding datasets.

c. Sets the synchronization request state to Completed.

d. Logs off using the AI service. The application interface object, synchronization request, and
corresponding data are deleted.

You can monitor the progress of these transactions with the Application Interface Viewer.

Open the Application Interface Viewer

1. Select an application interface in the navigation tree.

2. Click the Viewer tab.

Teamcenter opens the Application Interface Viewer showing details about the selected application
interface transactions.

When the Application Interface Viewer opens, it shows a table of all request transactions with the
external application. For each request object, the following information is shown by default:

• Name

• Request Type

• Last Modified Date

• Last Modified By

• Processed Date

• Processed By

• Status

• Status Description

17. Importing and exporting structures and items
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• State

• State Description

Note:

You can customize how the table of requests displays by right-clicking in the table columns. You
can then add, remove, and reposition columns in the table. You can also define criteria for sorting
data in the table, and create and modify data display filters.

Control transactions

1. Open the Application Interface Viewer.

2. Use the following buttons on the viewer to control transactions:

Add Sync

Allows you to create a new synchronization request and add it to the table of requests.

Add Publish

Allows you to create a new publish request and add it to the table of requests.

Process

Allows you to accept the request currently selected in the table. It is disabled if a request is not
selected.

Reject

Rejects the currently selected request.

Delete

Deletes the currently selected request.

Refresh

Refreshes the status of all requests in the table.

Export

Allows you to export the PLM XML file associated with the request to a specified folder.

Using incremental changes with requests

You can use incremental change orders to manage changes to the application interface data.

• Any such incremental change data is sent to the external system when the user initiates a
synchronization request.

• Similarly, data changes caused by a publish request may result in incremental changes.

Control transactions
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Note:

If a request object in the viewer has incremental changes associated with it, the corresponding
entry in the table is colored blue.

Administering data transfers

Export data through the application interface

To send structure data to synchronize with the external application, you can create a new
synchronization request and append it to a new or available application interface object, as follows:

1. Choose Tools→Export→AppInterface and choose the appropriate application interface type for
the external application.

The system displays the Application Interface Export dialog box.

2. In the dialog box, specify the following data:

• Request Name

Type a unique name for the synchronization request.

• Request Description

Type a unique description for the synchronization request.

• Root Objects

Displays the list of root objects such as structures to export.

• Check Out Objects?

Select this check box to check out affected objects (structures) when data export commences. By
default, the objects are not checked out.

• Complete or Delta

By default, only changed data is exported, depending on how your preferences are set. Select
this check box to export all data.

Note:

If you create a new application object, only complete data may be exported.

17. Importing and exporting structures and items
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• Set Request State on Completion

Select if the request state is set to Pending or Complete when the export process is complete.
This allows you to track import and export activity with the Application Interface Viewer when
the user manually updates data with import or export actions.

• (Optional) Select the Is Incremental Export check box to export only changes to large
structures. This check box is only available if the AI_Incremental_Export preference is set to
true.

3. Click the Existing AI Objects button to display and choose from a list of objects to export, or click
New to create a new application interface object. If you create a new object, the system displays a
New AI Object dialog box, where you must define the following:

• Name

Type a unique name for the new application interface object.

• Request Description

Enter a type for the new application interface object.

• Transfer Mode

Choose a transfer mode from a list of all transfer modes in the database that are marked as
incremental.

• Site Name

Choose a site name from the list of available sites.

• Check Out Objects?

Select this check box to check out affected objects when data export commences. By default, the
objects are not checked out.

4. After you define the necessary data, click OK or Apply to create a new publish request, generate
PLM XML data, and append it to the queue of requests in the specified application interface object.

Import data through the application interface

To import structure data and update Teamcenter with the imported data, you can create a new publish
request and append it to a new or existing application interface object, as follows:

1. Choose Tools→Import→Import Through AI.

Import data through the application interface
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Teamcenter displays the Application Interface Import dialog box.

2. In the Application Interface Import dialog box, specify the following data:

• Request Name

Type a unique name for the publish request.

• Request Description

Type a unique description for the publish request.

• Check In Objects?

Check this check box to check in affected objects when data import commences. By default, the
objects are not checked in.

• Change Order

Optionally, you can create a new change order or associate an existing one with the import
process to track the incremental changes resulting from the imported data.

3. Click the Existing AI Objects button to display and choose from a list of existing objects to import,
or click New to create a new application interface object.

If you create a new object, Teamcenter displays a New AI Object dialog box, where you must
define the following:

• Name

Type a unique name for the new application interface object.

• Description

Enter a type for the new application interface object.

• Transfer Mode

Choose a transfer mode from a list of all transfer modes in the database that are marked as
incremental.

• Site Name

Choose a site name from the list of available sites.

17. Importing and exporting structures and items
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4. After you define the necessary data, click OK or Apply to create a new publish request and append
it to the queue of requests in the specified application interface object.

Create a synchronization request

1. To create a new synchronization request, click the Add Sync button.

The system displays the Request Creation dialog box.

2. Define the following:

• Request Name

Type a unique name for the synchronization request.

• Request Description

Type a unique description for the synchronization request.

• Full Update or Partial Update

Choose Full Update to update all the data you specified when you created the application
interface. Choose Partial Update to update only preselected structures.

• Complete or Delta

By default, only changed data is exported, depending on how your preferences are set. Select
this check box to export all data.

Note:

If you create a new application object, only complete data may be exported.

• Check Out Objects?

Check this check box to check out affected objects when data export commences. By default, the
objects are not checked out.

3. Click OK or Apply to create a new synchronization request.

Process a publish request

1. Click the Process button.

Teamcenter displays the Publish Request Process dialog box.

Create a synchronization request
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2. Define the following:

• Request Name

Type a unique name for the publish request.

• Request Description

Type a unique description for the publish request.

• Request State for read only

Enter the required state of the publish request for a read-only transaction.

• Request Status for read only

Enter the required status of the publish request for a read-only transaction.

• Change Order

Optionally, you can create a new change order or associate an existing one with the import
process, to track the resulting incremental changes.

• Effectivity

Click this tab to edit the effective units or dates.

3. Click OK or Apply to process a publish request.

17. Importing and exporting structures and items
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18. Releasing a collaboration context
Releasing a collaboration context

Teamcenter does not provide any default workflow processes for releasing collaboration contexts and
structure contexts. Your administrator must create the necessary workflows for your site, as described in
the Workflow Designer on Rich Client.

Caution:

If a collaboration context or a structure context is referenced by another object, it may be released
when that object is released.
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19. Aligning CAD and BOM
Introduction to aligning CAD and BOM

Anyone who manages parts and designs separately must align the CAD designs and the BOM at
appropriate times, using the techniques described in Aligning CAD designs and parts.

If you use Teamcenter product master management (Product Master Management), you must use the
specific methods described in Aligning CAD and BOM for BOM-Driven Digital Mockups.

For information about Product Master Management, see Managing Your Product Master in the Product
Master Management collection.

Reconciling two views of a product

Aligning CAD designs and parts

At some stage of its life cycle, a business part typically has a design solution developed for it. The
business part and the design solution may have different life cycles.

• One part may have several corresponding design representations, for example, flexible parts.

• Conversely, a single design model can represent multiple parts, for example, colored parts. Also, you
may want to organize the part structure and the design structure differently, depending on your
business practices.

When the part and the design structures are independent, you must reconcile these two views of the
product. For an occurrence of part, you must know the corresponding positioned design; that is the
occurrence of the design positioned in the context of the product. Likewise, you may want to visualize
the positioned design from the part structure; that is, reconcile the position and shape needed from the
design.

You can align any types of items that are appropriate for your business practices, for example, parts with
CAD designs, or parts with documents.

• You can globally associate a part and a design, in which case all revisions of the part and design are
automatically associated. The association between the items is revision independent.

• Alternatively, you can choose to evaluate the alignment each time the part or design is revised.
This configuration ensures the design can always be correctly visualized wherever it occurs in the
structure.
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Caution:

Before aligning items, ensure that master forms are attached to all item and item revision business
objects. Otherwise, the alignment process may be unsuccessful.

You can optionally automate the alignment so that when the user creates a design, Teamcenter
automatically creates the corresponding part. To do this, you define the source, target, and relationship
of the automated creation process in the Business Modeler IDE, for example, Part, Design and
TC_Is_Represented_by. You can also use custom source and target types. Alternatively, you can
configure the creation of a design to trigger a workflow that notifies a part engineer to manually create
the corresponding part.

• When you revise a part, you decide whether to carry forward existing associations with design
revisions. By default, all associations with Represented By relationships are carried forward.
Conversely, when you create a new revision of a design, the existing associations with parts are
not carried forward by default. This allows the designer to determine manually when to make the new
revision visible to the BOM engineer.

• To allow automatic propagation of a new design revision to the associated part revision, add a
TC_Is_Represented_By,Part Revision,LookLeft string to the AutoCopyRel business object constant
on the design revision object with the Business Modeler IDE. However, propagating the design
revision to the part revision does not automatically make it the primary revision, that is, the revision
displayed in the viewer. The primary revision is controlled by the maturity level, as described later.

Note:

Automatic propagation assumes an association between a single design and a single part. If a
design revision is associated with several revisions of the same part, the latest mature revision
is carried forward. If a design revision is associated with revisions of different parts, nothing is
propagated.

After aligning the structures, you publish the occurrence data.

• You publish occurrence data between source and destination absolute occurrences of two
representations. Teamcenter takes a snapshot of the source occurrence data and creates a publish
link to the destination occurrence. For example, you can publish transform and shape information
from a source design occurrence to a destination part occurrence. If the source occurrence data is
already published, Teamcenter updates the snapshot with the new information.

• A publish link may associate a source design occurrence with more than one target part occurrence.
For simplicity, the following procedures assume you are working with a single target part occurrence,
but multiple targets are permitted depending on your product structure.

19. Aligning CAD and BOM
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Note:

If you associate multiple targets, Teamcenter may automatically mark one of the part occurrences
as primary, based on an assessment of the maturity of the design occurrence and its latest
revision.

You publish links in Multi-Structure Manager, but you can also create and view associations in My
Teamcenter.

The parts and designs may be included in a collaboration context, but this is not required.

Create a publish link

When you align a part occurrence and a design occurrence, you create a publish link between them, and
Teamcenter copies information from the source occurrence to the target occurrence.

1. Open the structures containing the part and design in two different structure panes.

2. Set any equivalent absolute occurrence context needed on each structure.

3. Select the design line and the part line, ensuring the source line is dimly highlighted and the target
line is brightly highlighted. That is, when you create a publish link from a design occurrence to a
part occurrence, the line representing the design is dimly highlighted and the line representing the
part is brightly highlighted.

4. Choose Tools→Structure Alignment→Create Publish Link.

Teamcenter create a publish link between the selected occurrences, indicating they are now
aligned.

If you select an inappropriate occurrence type, the system displays an error message that a publish
action is not supported for one of the selected types.

Note:

Configure alignable types by setting the PUBLISH_AlignableSourceTypes and
PUBLISH_AlignableTargetTypes preferences.

5. To add another target part occurrence to this publish link, select the design occurrence and choose
Tools→Structure Alignment→Add Targets to Publish Link.

Publish occurrence information

You can capture transformation and shape information on a source design occurrence and publish it to
the destination part occurrence.

Create a publish link
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1. Select the structure line corresponding to the source design occurrence.

2. Choose Tools→Structure Alignment→Publish Data.

The system displays the Publish Data dialog box.

3. Select the transform check box to publish transform data or the shape check box to publish shape
data and click OK. You can select both transform and shape data, if appropriate.

Tip:

When you publish only transform data, the transformation values for the design and part
structures match, but the transformation is not applied to the part in the graphics window.

When you publish both transform and shape data, both are updated.

19. Aligning CAD and BOM
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Teamcenter checks if a publish link already exists for the selected source. If it exists, Teamcenter
locates the destination occurrence with the same logical identify and publishes a snapshot of the
selected information to it. If it does not exist, you are prompted to create the necessary publish link,
as described in Create a publish link.

4. If the underlying revisions of the part occurrence and design occurrence are not already associated
globally, Teamcenter prompts you to associate them. Click Yes to create the global association;
otherwise click No.

Note:

Teamcenter validates that the logical identity of the part and design occurrences are the same if a
logical identity is defined for the design occurrence. If not, it terminates the publish process.

If the design occurrence has no logical identity, Teamcenter sets the usage address and position
designator to the same as that of the part occurrence.

Find occurrence with publish link

1. Open the structures containing the part occurrences and design occurrences in two different
structure panes.

2. Select a structure line that represents a part occurrence or design occurrence.

Find occurrence with publish link
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3. Choose Tools→Structure Alignment→Find Publish Link Source to identify the source design
occurrence, or choose Tools→Structure Alignment→Find Publish Link Targets to identify the
target part occurrence.

Teamcenter identifies all publish links for which the selected occurrence is a source or destination,
as applicable. It highlights the linked occurrences in the companion pane. If it does not find any
publish links, it displays an error message.

Note:

You can also use the accountability check to identify linked occurrences, as described in Checking
the integrity of the structure. Select the Treat occurrences with Publish Link as SAME check box
if you use this method.

Remove target from publish link

1. Open the structures containing the part occurrence and design occurrence in two different
structure panes.

2. Set the appropriate absolute occurrence context needed on each structure.

3. Select the part occurrence with the publish link to remove.

4. Choose Tools→Structure Alignment→Remove Target from Publish Link.

Teamcenter removes the target part occurrence from the selected publish link. Removing the target
of the publish link does not delete the part occurrence or the publish link.

To add a new target part occurrence to this publish link, select the design occurrence and choose
Tools→Structure Alignment→Add Targets to Publish Link.

Delete publish link from source

1. Select the source design occurrence and choose Tools→Structure Alignment→Delete Publish
Link for Source.

Teamcenter displays the Unpublish data dialog box.

2. Select Transform or Shape to unpublish the corresponding data and then click OK.

Teamcenter deletes the publish link associated with the selected design occurrence. It does not
delete the design occurrence or the part occurrence.
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Find occurrences with the same logical identity

1. Open the structures containing the part occurrences and design occurrences in two different
structure panes.

2. Select a part occurrence or design occurrence.

3. Choose Tools→Structure Alignment→Find Lines with Same Logical Identity.

Teamcenter highlights all lines with the same logical identity as the selected line. These lines may
be associated with it by a publish link.

Checking the integrity of the structure

You can run the following checks to verify the integrity of the structure you built:

• Accountability check

You can open two associated structures and run an accountability check to verify if all occurrences in
the publish link are mapped.

For information about how to make an accountability check, see Running accountability checks.

When running an accountability check for this purpose, select the Treat occurrences connected via
Publish Link as same check box and clear the Treat same absolute occurrence as same check box.

Occurrences of a part that do not require a design have publish links and are shown as Missing
source. Use the Requires Positioned Design column in one of the structure editor applications to
identify such occurrences. Take care to differentiate occurrences that require a positioned design and
do not yet have a publish link from those that do not require a design at all.

Note:

The default properties for the accountability check are controlled by the
DefaultAccountabilityCheckProperties preference. Select the exact properties for comparison
in the Accountability Check dialog box.

• Completeness check

You can run a completeness check on a part structure to identify if all part occurrences that require
aligned designs have them. The check also identifies if a transform or shape is published and a
primary design is associated with the part.

The number of levels in the structure that the completeness check traverses is determined by the
value of the PartStructureDepthForCompletenessCheck preference.

Find occurrences with the same logical identity
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Perform completeness check on part structure

• Open the part structure and choose Tools→Structure Alignment→Completeness Check→Verify
Part Structure.

Teamcenter highlights all part occurrences in one of the following colors:

• Red

Part occurrences that require a positioned design that is not yet aligned.

• Green

Part occurrences that have the required positioned design or do not require a positioned designed.

• No color change

Skipped occurrence (an occurrence that is not a part type).

Caution:

This check does not check the completeness of the structure, except for the complete alignment
required for a positioned design.

Viewing the positioned design from the part structure

Checking the integrity of the structure

Checking the integrity of the structure

You can run the following checks to verify the integrity of the structure you built:

• Accountability check

You can open two associated structures and run an accountability check to verify if all occurrences in
the publish link are mapped.

For information about how to make an accountability check, see Running accountability checks.

When running an accountability check for this purpose, select the Treat occurrences connected via
Publish Link as same check box and clear the Treat same absolute occurrence as same check box.

Occurrences of a part that do not require a design have publish links and are shown as Missing
source. Use the Requires Positioned Design column in one of the structure editor applications to
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identify such occurrences. Take care to differentiate occurrences that require a positioned design and
do not yet have a publish link from those that do not require a design at all.

Note:

The default properties for the accountability check are controlled by the
DefaultAccountabilityCheckProperties preference. Select the exact properties for comparison
in the Accountability Check dialog box.

• Completeness check

You can run a completeness check on a part structure to identify if all part occurrences that require
aligned designs have them. The check also identifies if a transform or shape is published and a
primary design is associated with the part.

The number of levels in the structure that the completeness check traverses is determined by the
value of the PartStructureDepthForCompletenessCheck preference.

Perform completeness check on part structure

• Open the part structure and choose Tools→Structure Alignment→Completeness Check→Verify
Part Structure.

Teamcenter highlights all part occurrences in one of the following colors:

• Red

Part occurrences that require a positioned design that is not yet aligned.

• Green

Part occurrences that have the required positioned design or do not require a positioned designed.

• No color change

Skipped occurrence (an occurrence that is not a part type).

Caution:

This check does not check the completeness of the structure, except for the complete alignment
required for a positioned design.

Perform completeness check on part structure
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ALLOC_Group_Allocation_Types

DESCRIPTION

For use with allocation functionality. Specifies the allocation types that can be used in the specified
allocation map. For example, ensure the Allocation_One allocation type is created only in association
with the AllocationMap_one allocation map by setting this preference to:

AllocationMap_one:Allocation_One

VALID VALUES

Allocation map type:Allocation type,Allocation type

Where Allocation map type is a valid Teamcenter allocation map type, and all Allocation type entries are
valid Teamcenter allocation types.

DEFAULT VALUES

AllocationMap:Allocation

DEFAULT PROTECTION SCOPE

Site preference.
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ALLOC_Product_Representation_Types

DESCRIPTION

For use with allocation functionality. Specifies which BOM view types can be used to create allocations
in the specified allocation map. For example, ensure allocations are created only between Process and
View types for the AllocationMap_one allocation context by setting this preference to:

AllocationMap_one:Process,View

VALID VALUES

Allocation map type:View type1,View type2

Where Allocation map type is a valid Teamcenter allocation map type, and all View type entries are valid
subtypes of Teamcenter views.

DEFAULT VALUES

AllocationMap:view,CAEAnalysis,Process,Setup

DEFAULT PROTECTION SCOPE

Site preference.

ALLOC_Product_Representation_Types
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ALLOC_Target_Occurrence_Types

DESCRIPTION

For use with allocation functionality. Specifies which components can be used as target components for
a given allocation type.

VALID VALUES

Allocation type::Target component type

Where Allocation type is a valid Teamcenter allocation type, and Target component type is a valid
Teamcenter object type used in a product structure.

DEFAULT VALUES

Allocation:Item,PSConnection,PSSignal,RouteLocation,GeneralDesign Element,
GeneralDesignElementLink

DEFAULT PROTECTION SCOPE

Site preference.
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ALLOC_Source_Occurrence_Types

DESCRIPTION

For use with allocation functionality. Specifies the components that can be used as source components
for a given allocation type.

VALID VALUES

Allocation type::Source component type

Where Allocation type is a valid Teamcenter allocation type, and Source component type is a valid
Teamcenter object type used in a product structure.

DEFAULT VALUES

Allocation:Item,PSConnection,PSSignal,RouteLocation,GeneralDesign Element,
GeneralDesignElementLink

DEFAULT PROTECTION SCOPE

Site preference.
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ALLOC_source_target_cardinality

DESCRIPTION

For use with allocation functionality. Specifies the cardinality permitted between a given allocation type
and other product structure object types.

Note:

Specify valid target components for a particular allocation type using the
ALLOC_Target_Occurrence_Types preference. Specify valid source components for a particular
allocation type using the ALLOC_Source_Occurrence_Types preference.

The system supports multiple sources and targets for allocation using cardinality functionality. The
system supports the following allocation relationships:

One-to-one
Many-to-one
One-to-many
Many-to-many

Example:

For example, you can use this preference to enforce a cardinality allowing the Network_Port type
allocation to participate only in one-to-one relationships. Allocations using this type can contain
only a single source and a single target. To do so, set this preference to:

Network_Port::1,1

VALID VALUES

Allocation
subtype::1,1

Where Allocation subtype specifies the allocation type; this specified allocation
type can only be used in one-to-one relationships.

Allocation
subtype::1,n

Where Allocation subtype is a valid Teamcenter object type; this specified object
type can be used in one-to-many relationships.

Allocation
subtype::n,1

Where Allocation subtype is a valid Teamcenter object type; this specified object
type can be used in many-to-one relationships.

Allocation
subtype::n,n

Where Allocation subtype is a valid Teamcenter object type; this specified object
type can be used in many-to-many relationships.

DEFAULT VALUES

Allocation::n,n
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DEFAULT PROTECTION SCOPE

Site preference.

ALLOC_source_target_cardinality
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ALLOC_map_copy_allocations

DESCRIPTION

For use with allocation functionality. Determines whether the allocation set is carried forward when the
allocation map is saved as a new allocation map, or revised. By default, the allocation set is carried
forward during either of these actions. Prevent the allocation set from being carried forward by setting
this preference with the names of the revision action (saveAs, or Revise) which you do not want to
carry forward the allocation set.

VALID VALUES

saveAs The allocation set is not carried forward when the allocation map is saved as a new
allocation map.

Revise The allocation set is not carried forward when the allocation map is revised.

DEFAULT VALUES

saveAs
Revise

DEFAULT PROTECTION SCOPE

Site preference.
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Default_StructureContext_Type

DESCRIPTION

Determines which type of structure context is created when saving a loaded object as a context.

VALID VALUES

Accepts one or more strings as values; each string must be a valid type and be of the following format:

item_type:structure_context_type

DEFAULT VALUES

Process:ProcessContext

OP:ProcessContext

Workarea:PlantContext

Item:ProductContext

GenericBOP:ProcessContext

ProductBOP:ProcessContext

Mes0STXLibrary:ProcessContext

DEFAULT PROTECTION SCOPE

Site preference.
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PartStructureDepthForCompletenessCheck

DESCRIPTION

Determines how many levels Teamcenter traverses when you perform a completeness check of the part
structures resulting from CAD BOM alignment.

VALID VALUES

Accepts any numeric value. If you enter 0 or a negative value, a completeness check is not performed.

DEFAULT VALUES

10000

DEFAULT PROTECTION SCOPE

User preference.

NOTES

If you change the value of this preference, you must restart the Teamcenter server for the change to take
effect.

A. Multi-Structure Manager preferences

A-10  Multi-Structure Management, Teamcenter 2412
© 2025 Siemens



MEDataPanelPosition

DESCRIPTION

Specifies where to open the data pane of a structure, either to the right of the structure or below the
structure.

VALID VALUES

right Displays the data pane to the right of the structure.

bottom Displays the data pane below the structure.

DEFAULT VALUES

bottom

DEFAULT PROTECTION SCOPE

All.

MEDataPanelPosition
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