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1. Introduction to Retail Footwear and
Apparel
About Retail Footwear and Apparel

Retail Footwear and Apparel is a solution tailored to manage products in the retail industry, which is ever
evolving and fast paced. New products or styles are launched continuously throughout the year. Product
choices and colors change frequently, with the fashion trends and seasons. As a result, making the
products available in the market on time is crucial. For example, winter clothing must be made available
in stores toward the end of fall, before the onset of winter. It is stocked through winter, spanning a short
seasonal time frame. It is therefore important that buyers collaborate with the different partners who
manufacture the products. Further, costs are evaluated to find the correct price that meets both product
quality and profit margin targets.

Using Retail Footwear and Apparel, you can:

• Manage product and material costs.

• Manage the product planning and product development process.

• Capture fashion data and technical design data.

• Collaborate internally and across the supply chain.

Working with Retail Footwear and Apparel

Accessing the commands and tools panel

On a wide-screen display, commands and tools appear in toolbars along the top and down the sides of
Active Workspace.

Information

Displays the information task panel for the selected object.

The information displayed is based on the selected object, such as sample
request, your group and role, and the site configurations.

Submit to Workflow

Creates a new workflow process for the selected item.

Save Search

Saves your search criteria.
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Save As or Revise

Creates a new revision of the object or a new object with a new ID.

Replace File

Replaces an existing dataset file with an identically named file.

Organizing your data

You can use favorites to track the objects you access frequently, such as samples, sample requests,
forms, or processes.

1 Various navigation tabs appear under the page title.

For example, on the Favorites page, the My Favorites and Recent tabs are available.

My Favorites Displays all the objects you flagged as a favorite.

Recent Displays recently visited objects.

2 One-step commands are displayed above the work area.

3 The list area displays a list of parts, documents, or other objects relevant to the
current page.

4 The work area displays details about the selected object when the List with
summary display option is selected. The details that are displayed depend on the
type of object selected.

1. Introduction to Retail Footwear and Apparel
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Note:

If there are more tabs to be displayed than the available space, a right-chevron
 is displayed.

• Tap or click the chevron to switch between the available tabs. The content
area is not updated unless the active tab switches to another.

• Tap or click a partially displayed tab, indicated by ellipses , to fully display
the tab and to update the content area.

Access frequently used items

You can create a shortcut to your frequently accessed items by pinning the tiles on the home page.

1. Select the object you want to add to the home page.

You can add an object from locations such as your Home folder, favorites, or search results.

2. In the toolbar, click the Pin  button.

The selected object appears as a tile on your home page.

Similarly, you can pin a notification message to the Active Workspace window.

Arrange the tiles displayed on the home page

Tiles are arranged in groups on the home page. You can drag and drop tiles to create new groups,
rearrange the tiles within a group, or move tiles between groups.

To select a tile to be moved, right-click with the mouse, or press and hold on touch devices.

Move a tile from one group to another

1. Select a tile.

2. Drag it to the new group and position near an existing tile, until you see the outline indicating the
new tile position.

Access frequently used items
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3. Drop the tile in the new position.

Move a tile and create a new group

1. Select a tile.

2. Drag it to an area between existing groups until you see the vertical bar indicating the new group
position.

1. Introduction to Retail Footwear and Apparel
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3. Drop the tile.

The tile is displayed in the new group.

Resize a tile

1. Right-click the tile you want to resize, or left-click and hold the tile until you see an arrow button in
the lower-right corner of the tile.

On a touch device, tap and hold a tile to enter edit mode.

2. Click the arrow button in the lower-right corner of the tile.

Depending on the current size of the tile, the tile either becomes smaller or larger in size.

Some tiles, such as Inbox, display different information depending on the tile size.

3. To save your changes, click in a blank area on the home page.

Modify sample requests using the work area commands and tools

On a wide-screen display, commands and tools appear in toolbars along the top and down the sides of
Active Workspace pages.

One-step command icons appear in a toolbar at the top of the work area. Use these commands to edit
and update the relevant elements, such as sample requests and point of measure (POM) details.

Modify sample requests using the work area commands and tools
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Search for information

You can search for information in Active Workspace by either using text or shape. You can then save
these searches. You can also view the results as a list and in the form of a bar chart that displays the
search results by type.

1. On the home page, enter the search criteria in the Search box with suggestions and filter
categories.

2. Select the request or task to view the details in the Overview tab.

3. Click the Attachments tab to view the files attached with the search result.

You can also define and save your search criteria.

Change the password

1. On your homepage, select Profile.

2. Click Change Password.

3. In the Change Password panel:

a. Type your current password.

b. Enter a new password.

c. Retype the new password to confirm it.

4. Click Change.

1. Introduction to Retail Footwear and Apparel
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Reassigning tasks

Scenarios for reassigning tasks

You can balance your workload or manage assignments for others if they are out of the office. You can
do this by designating certain users or groups as surrogates. To do this, you must set up surrogates to
perform the workflow tasks on your behalf. Similarly, you can perform the tasks of the other users for
whom you are a surrogate. Once you have set up surrogates, you can reassign the tasks to them.

In other cases, you might want to reassign tasks altogether to a different user. If you are the responsible
party or a privileged user, you can reassign any task that has not already been started. For example,
if you are the initiator of a process, the tasks of selecting a signoff team and performing signoffs are
automatically assigned to you. You may want to reassign one task or both these tasks to another user.
You can also assign all future tasks in the workflow to the user.

Set up surrogates for your tasks

You can assign your tasks and sample requests to other users. To designate these users as surrogates:

1. Select the INBOX tile on the home page and in the My Tasks tab, select the task that you want to
reassign to a surrogate and click Open .

2. In the Overview tab, in the Properties section, select Assignee to specify surrogates for this task.

3. In the My Surrogates section, click Add Surrogate .

4. In the Add Surrogate section, specify the Start Date and time.

5. Specify the End Date and time and click Add  to add users.

6. (Optional) Enter the filter criteria to search for the relevant user.

7. Select the user to add them to the list of surrogates.

8. (Optional) Similarly, add more users to the list of surrogates and click the Add button at the bottom
of the Add Surrogate section.

The surrogate receives an email in their inbox with details about the user for whom they have been
assigned as surrogates.

To remove a surrogate, in the My Surrogates section, select the relevant surrogate and click Remove
Surrogate .

Reassign tasks to other users

To reassign your tasks to a different user:

Scenarios for reassigning tasks
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1. Search for and open the sample request that you want to reassign.

2. In the right pane, click .

3. In the Reassign Task section, click Users, enter the filter criteria, and press Enter.

4. Select the user to whom you want to reassign the task, specify any specific Comments, and click
Reassign.

1. Introduction to Retail Footwear and Apparel
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2. Exploring the Active Workspace
interface
Using Active Workspace on different devices

Active Workspace is a web-based client for Teamcenter that runs in a browser on traditional computers
using mouse and keyboard inputs and on touch displays found on contemporary Windows devices, and
on OS X and Android tablets and smart phones.

• On touch-enabled devices, you can use standard touch gestures to navigate and select commands and
objects.

• On a desktop or laptop computer, you can use the left mouse button to select commands and objects
and the keyboard for shortcuts or tabbing through the interface.

• In the Viewer view, you can use the left mouse button while pressing the Control (pan) or Shift
(zoom) keys to modify the default geometry navigation controls.

• In some situations you can use the right mouse button to enable additional commands, as
described in context in the user documentation such as the instructions for arranging columns
in a table display, resizing tiles, and working with data in the Relations and Architecture tabs.
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Note:

The standard keyboard shortcuts for cut, copy and paste (Ctrl+X, Ctrl+C, Ctrl+V) are supported
when those commands are available on the page.

Working in narrow mode and on a mobile device

The user interface adapts to the available space, whether running on a computer monitor, tablet, phone,
or within another application.

As the available space is reduced, layout or functionality adjusts to it. For example, tables are available
for a wide layout, but are replaced by lists of tiles in a narrow layout, and commands move from the
sides of a wide layout to the bottom of a narrow layout.

Note:

When you are working with files on iOS, Android, or Windows Phone systems, the device controls
the Browse button and provides a dialog that lets you choose how you want to locate files. These
systems may also let you select a camera to directly import images.

2. Exploring the Active Workspace interface
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Using the narrow interface

The narrow interface uses a one-panel system for displaying features.

1 Primary toolbar

Displays the available commands, such as Home  and Sign Out . Other
commands are available from other locations in the user interface.

Note:

Sign Out  is available only on the home page.

2 Global search

Working in narrow mode and on a mobile device
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Searching

When you use search in the narrow interface, the list of search results appears as shown in the following
figure.

1 Pages available with Search

2 Displays the number of search results and the filtering breadcrumbs.

3 Displays the list of search results.

Tap a result object to replace the search results list with information about the object.

4 Primary toolbar with available commands.

2. Exploring the Active Workspace interface
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Viewing details

Tap an object in any primary work location, such as search results or a folder, to display the secondary
work area with details about the selected object.

1 Displays tabs containing details about the selected object. The information that
displays is based on the selected object, your group and role, and the site
configurations.

If there are too many tabs to display in the available space, a right-chevron  is
displayed.

• Tap the right-chevron button  to select summary information tabs from a menu
such as Overview and Where Used.

Working in narrow mode and on a mobile device
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The content area does not update unless you select a new tab from the menu.

The information displayed is based on the selected object, your group and role, and
site configurations.

• Tap a partially displayed tab, indicated by ellipses, to fully display the tab and
update the content area.

2 Primary toolbar with available commands.

When the number of available commands exceeds the available space, you can tap
More  to display more.

Opening objects

In any location in the narrow interface, tap Open  to display the menu.

2. Exploring the Active Workspace interface
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Select Open to open the object, or select another option available on your device.

Setting up your user environment

User properties

This topic introduces several fundamental concepts that are important for new users to know about
when getting started with Active Workspace. If you have used Teamcenter rich client these concepts
should be familiar to you.

Active Workspace and Teamcenter users work within a context which is a combination of several user
properties:

• Group

• Role

• Program

• Project

• Workspace

You can control some aspects of data presentation within a context by setting these additional
properties:

• Revision rule

• ID Display rule

Depending on your position in your organization, you may need to work in different contexts at different
times. Your assignments for group, role, and project by your administrator should reflect that, in which
case you can easily switch contexts during your session. You can also manage some properties from your
user profile page. The following sections provide more information.

Group

A group is a named set of users who share one or more specific types of work in common, and
who have the same access permissions for data and locations. Groups may be synchronized with the
company's user authentication system. Users may be assigned to more than one group. Assignment of
users to groups is done by administrators or privileged users. In an automotive engineering context, you
might see group names such as Drivetrain, Electronics, HVAC, and Simulations

If you are assigned to more than one group, you can set one as your default group at log-on in your
profile page. You can quickly switch to another group by clicking your profile icon and selecting it in the
Group list in the pop-up. The list contains only the groups of which you are a member.

User properties
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Role

A role defines a specific job function within a group. Roles are attached to groups and users are assigned
to one or more roles within a group. You can set your default role for groups of which you are a member
in your profile page. In an automotive engineering context, you might see role names such as Designer,
Engineer, Tester, and Approver.

Program

A program provides organizations a means to define, organize, and manage large bodies of work that
have a lifecycle and which come and go over time. Program names may denote a product or product
family. For example, in an automotive engineering context, you might see program names such as
Mid-size Car, Compact Car, Light Truck, and Compact SUV. However, programs may be about something
more abstract. The decision is up to the organization. For more information about programs, see What
are projects and programs?

Project

A project is a component of a program. Programs typically have multiple projects, each of which has a
lifecycle. Administrators can assign users, roles, or groups to a project thereby controlling access to the
project's data. Typically, if you are not a member of a project, you cannot see or work with the data.
In an automotive engineering context, you might see project names such as Mid-size Car Powertrain or
Compact SUV Infotainment.

To view projects to which you have access. You can use the PROJECTS tile on the Home page, or the
Projects folder in Explorer. If you have the necessary permissions you can also create projects and
programs and manage your project teams by correlating groups of users, potentially at different physical
sites, with your product data. You can quickly switch to a different project by clicking your profile icon on
the global header and selecting it in the Project list in the user proprieties pop-up. For more information
about projects, see What are projects and programs?

2. Exploring the Active Workspace interface
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Workspace

A workspace is an out-of-the-box configuration that controls which commands users see and which
pages they can access when they log on. Workspaces are mapped by administrators to a group, a role,
or a group-role combination. You are always assigned at least one workspace via your group and role
assignments.

Information about your workspace assignments, the commands you can run and what data you can
access in each workspace should be provided by your organization. If you are assigned to more than
one workspace, you can change to a different one by clicking your profile icon on the global header
and selecting it in the Workspace list in the pop-up. If you are assigned to only one workspace, the
Workspace list does not appear.

Revision rule

A revision is a unique, specific iteration of a previously created object such as a part, an assembly, or
a document. In Active Workspace, your current revision rule determines which revision of an object will
be returned by a search or shown in a product structure. For example, you can choose whether to load
working revisions or release revisions.

A privileged user or an administrator can configure revision rules. You can select the revision rule you
want to use in your user properties, displayed when you click your profile icon. For more information see
Change your revision display.

ID Display rule

Identifier (ID) display rules let you select the context in which items and item revisions are displayed for
you. If no rule is applied, the initial identifier attribute is displayed. For more information see Create and
change ID display rules.

View and change your user properties

User properties determine your current working context. You can change your context by setting
different values in your user properties.

Procedure

1. In the global header, click your profile icon.

A pop-up panel appears displaying the current settings of your user properties.

View and change your user properties
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2. In the panel, change the value in one or more properties.

For example, if you want a different workspace, select it in the Workspace property.

Note:

The properties displayed in the pop-up can vary depending on your group and role. For
example, if only one workspace is configured for your role, the Workspace property is not
present.

Manage your User Profile

Your user profile page enables you to provide information about yourself that other users can see,
and also set a number of defaults and personal preferences that are applied when you work in Active
Workspace. This topic explains how to access the page and describes the most common settings that
new users may want to adjust.

Open your profile for editing

1. On the global header, click your profile icon and select Manage Profile.

Your user profile page displays.

2. Select the Overview tab if it is not already selected.

2. Exploring the Active Workspace interface
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3. On the primary toolbar, select More commands  > Edit  > Start Edit .

Set your default group

You can set your default group, your default role in each group, and your default volume.

In the User Memberships section, select your default group from the Default Group list (1). Once the
defaults are set, you can quickly switch your current group and role in the pop-up options that display
when you click your profile icon

Set your default volume

In the User Membershipssection, select your default volume from the Default Volume list (2).

If you are only assigned one volume, the list is disabled and you cannot select another volume.

Manage your User Profile
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Set your default group roles

The User Memberships section displays a table of groups and roles (3) where you can set your default
role for each group. The Group column values are static. The Default Role column provides a list of roles
for each group.

Set your default role for a group by clicking in the Default Role column (4) on the group's row and
selecting a role from the list. You can leave the Default Role empty for groups where you have no role.

Set your default units

The Units section displays your current Unit Display Set. This defines the unit of measure displayed for
various types of data such as Parameters. If the unit of measure defined by the data author differs from
the set you choose, displayed data is converted to the unit of measure you select here. If you want to
use a different set, select it in the list.

New unit display sets can be configured as needed. The default Unit Display Set options are as follows:

• As Authored - This set contains units created by the author of the data.

• Metric Display Set - This set contains metric units, such as meter and kilogram.

• Metric(SI) Display Set - This set contains metric units, such as meter, kilogram, second, ampere, kelvin,
candela, and mole.

• Non-Metric Display Set - This set contains non-metric units, such as foot and pound.

This graphic shows an example of a user updating the unit display set from As Authored to Metric
Display Set.

This graphic shows the results of a user updating the user profile to the Metric Display Set.

2. Exploring the Active Workspace interface
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Note:

This functionality is only available in Parameter Management for Teamcenter 2406.

Upload a profile picture

You can upload an image file from your computer to appear in the profile icon in the global header when
you are logged in, and to other users in various contexts. It is not necessary for the page to be in edit
mode.

1. In the Picture section, click Add Profile Picture.

2. In the Add Profile Picture panel either...

• Click Choose File and select an image file on your computer, or...

• Drag an image file from your computer's file explorer to the Upload box.

3. Click Update Profile Picture.

Save your settings

When you are finished, select More commands  >Edit  > Save Edits .

Change your password

When the Teamcenter installation is configured to use Security Services, passwords are managed by an
external identity service provider such as lightweight directory access protocol (LDAP) rather than by
Teamcenter.  In this circumstance, you cannot change your password yourself using any Teamcenter
client. If passwords are managed by Teamcenter, you can follow these steps to change your password.

Change your password
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1. On the global header, click your profile icon and select Manage Profile.

Your user profile page displays.

2. On the primary toolbar, select More commands  > Manage   > Change Password .

3. In the Change Password panel, type your current password.

4. Type your new password.

5. Type your new password again in the Confirm New Password box.

The Change button displays when all three fields are populated with valid values.

6. Click Change.

Change your group, role, or project for your session

As you work, you may need to change your current group, role or project. For example, you might need
to switch your group from Manufacturing to Engineering to accomplish some task.

1. Click your profile icon.

2. Select your existing project, group, or role.

Note:

Although your account may not be configured to display a project, you can view your projects
and your project team by selecting the PROJECTS tile on the home page.

2. Exploring the Active Workspace interface
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Tip:

You can toggle the option to display your session settings on any page by enabling Display
session settings at the bottom of the page.

3. From the list of available options, select the one you want.

Example:

In your current session, if you change your current group from Manufacturing to Engineering,
your role is set to the default role specified for the Engineering group. If no default role is
specified, then the first role in the list is used.

Note:

Your selected group and role are set for your current session only; the default values for your
group and role are not updated.

You can manage your default group and role values on your user profile page (global
header > profile icon > Manage Profile).

Select your geography

You should set your declared geographic location in your profile. This is especially important if some
data is restricted to certain geographic areas.

Select your geography
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1. On the global header, click your profile icon and select Manage Profile.

Your user profile page displays.

2. On the primary toolbar, select More commands  > Edit  > Start Edit .

3. In the LOCATION section, select your declared geography from the User Declared Geography list.

The values are case sensitive.

4. On the primary toolbar, select More commands  > Edit  > Save Edits .

Tip:

You can cancel pending changes from the Edit  menu.

Set or change your company location assignment

If your administrator has created and assigned company locations, you can set, clear, or change your
company location assignment.

1. On the global header, click your profile icon and select Manage Profile.

Your user profile page displays.

2. On the primary toolbar, select More commands  > Manage   > Location Code .

The Location Code panel displays.

3. Type your location in the Available Locations box to filter and find your location code.

Note:

The associated location code may contain the filtered string. For example, "Mi" is contained in
the location code, Milwaukee, associated with Wisconsin. It is also contained in the location
code, Milford, associated with Ohio.

Tip:

To set your location to a value not in this list, type the location you want to assign to yourself
in the Location Code box. The following message is displayed:
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Location Code "zzz" does not exist for any Company Location. 
Do you want to set a new location with that code?
  

Click Set.

4. Select a location and click Set.

Change location on parts and documents

When you create a new part or a document, your company location appears as a value in the Current
Location Code box on that part or document. If your system configuration allows, you can change the
location code to another existing code.

Change your revision display

A revision is a unique, specific iteration of a previously created object such as a part, an assembly, or a
document.

• A revision can have associated CAD models, drawings, or specifications that are applicable only to that
revision.

• Revision display is controlled by revision rules.

For example, Latest Working is a standard default revision rule for design engineers, while a
manufacturing engineer may prefer to use the Latest Released revision rule.

• Revision rules are configured by administrators to specify which revisions of parts and assemblies
display.

• Revision rules determine how items and item revisions display in tables, and what happens when you
copy and paste an item revision into a table. For more information, see How dynamic item revisions
work in folders, item relations, and paste actions.

Multiple revisions of an object can clutter your display. You can select the rule that best meets your
needs.

1. On the global header, click your profile icon.

A pop-up containing session settings displays.

2. Click the current Revision Rule and then select the desired rule from the list.

Change your revision display
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Create and change ID display rules

Identifier (ID) display rules let you select the context in which items and item revisions are displayed for
you. If no rule is applied, the initial identifier attribute is displayed.

Create an ID display rule

You can create a custom ID display rule to display objects with alternate IDs for a specified ID context.

1. From the Home Page, click the ID DISPLAY RULES tile.

The ID Display Rule page opens and displays any existing rules.

2. Click More Commands  > New   > Create ID Display Rule .

The Create ID Display Rule panel opens.

3. Enter a Name for the rule and then select the rule Contexts from the list.

4. (Optional) Click Use As Default to set the new rule as the default ID display rule.

5. (Optional) Click Set As Current to set the new rule as your current display rule after it's created.

6. Click Create to create the new display rule. The new rule now appears on your ID Display Rule
page.

Change your ID display rule

When you have created alternate IDs for objects, you can change your ID Display Rule to display these
custom IDs in your bill of materials instead of the default value for the revision object.

1. Click your profile icon to display your session settings.

Tip:

You can optionally display the session settings as a bar at the bottom of the browser window
to always keep it visible. This is helpful if you need to cycle through many ID display or
revision rules.

2. Click the down arrow next to ID Display Rule and then select the rule you want to apply.

2. Exploring the Active Workspace interface
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Note:

The available ID display rules are based on the alternate ID context configured by your
administrator.

Your alternate IDs now display for the revision object.

View ID display rule information

You can quickly view information on an ID display rule when viewing it from a list of your existing rules.

1. Click your profile icon to display your user properties.

2. Click the down arrow next to ID Display Rule.

3. Instead of selecting a rule, hover over it and then click the Information icon .

The ID Display Rule page opens and displays the details on the rule.

Change your data privacy options

Siemens Digital Industries Software collects information about the use of Active Workspace by its users.
The information on these policies is displayed on the Data Privacy tab of your user profile. You can
choose to Agree to share your information, or Decline to opt out.

• The Digital Product Experience program collects and uses user data to provide a personalized user
experience.

• The Product Excellence Program collects and uses user data to improve product features and
functionality to better meet customers' needs.

You can click the link to the Siemens Trust Center from the program details to view detailed
information on how the programs work and what data is sent to Siemens. A link to the Siemens Digital
Industries Software Data Privacy Notice is also provided on the page.

1. Click Settings  to expand the settings menu.

Change your data privacy options
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2. Click Data Privacy from the menu.

The Data Privacy tab of your user profile is displayed.

3. Review the information for the selected programs, and then select Agree or Decline.

Tip:

Changes you make take effect the next time you log on to Active Workspace.

Viewing access rights

If your administrator has enabled the Access tab and granted you access, you can view access rights on
a selected object by clicking the Access tab.

The tab contains three sections.

Access rights
context

Filters for user, group, role and project define the context in which user rights to the
currently selected object are evaluated.

Initially, the filters are set for the current user session context. You (and those users
who have been granted permission by means of BMIDE conditions) can use the lists to
select another combination of user, group, role and project for which you want to view
the associated access rights for the currently selected object.
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Changes to these lists are applied when you click Show Access Rights.

ACCESS
RIGHTS

Lists the operations granted to the filtered combination of user, group, role and project.

ASSOCIATED
RULES

Lists the rules associated with the given object and selected operation.

Example:

In this example, user Ed can view his access rights and associated rules for his role as designer
in the Engineering group working on a motor shaft. Here Ed can see what rule grants him copy
privileges for item revisions on which he is working.

Autosave table edits

You can select the option to automatically save changes made to tables. When this option is enabled and
you edit a table cell by double-clicking it, the changes made to the cell are automatically saved when you
click off the cell.

• If you edit a table with autosave off, you must save the changes made to the table cells by clicking
Save Edits.

• Some table cells may not support autosave. You must manually save changes made to these table
cells.

• Some tables may only support autosave editing. In this case, changes made to the cells are
automatically saved, even if you have autosave turned off in your profile.

Autosave table edits
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• If you enable Autosave Tables while you have unsaved table edits, the system prompts you to Save or
Discard the table edits before enabling autosave.

1. In the global header Session controls, click Settings .

2. Click Autosave Tables  to turn on auto saving of changes made to table cells.

Note:

Autosave Tables is enabled for all users by default.

Page layouts and navigation

Home page

Your home page contains tiles and toolbars that run commands enabling you perform tasks and access
data. Examples include exploring your folders, viewing schedules, opening your Inbox, accessing help
documents, and running reports. Your administrator configures the home page based on your role. This
allows the home page to be customized for easier and faster navigation, placing your most frequently-
used commands on your home page.
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1 Global header: On the home page, the header includes the Teamcenter location, global search (4),
and session controls (5).

2 Global navigation: Your entry point for various features and data access. These commands are always
available. Tooltips provide a short description of each command. The icons you see may vary from
those shown in the figure, depending on your role and how the page is configured for it. If there is
insufficient space to show all available commands due to your screen resolution or the vertical size of
the client window, the More Commands  icon appears in the last icon position. Click it to reveal
the hidden commands in a pop-up menu.

The Home  icon opens your home page.
3 Tiles: These provide access to commonly-needed features and data. The tiles on your home page may
differ from the figure based on your specific configuration. Some commands may be present in both
global navigation and a tile. You can move and resize tiles to suit your needs. You can pin and unpin
tiles, and pin objects to your home page as tiles.

4 Global search: Search for data objects in your Teamcenter system. You can access saved searches and
the Advanced Search feature from here.

5 Session controls:

• Change notifications: View and search active changes, if any, and set the active change context.

Home page
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• Environment indicator: In infrastructure that has multiple deployments or deployment types — test
and development, for example — an administrator can optionally configure and enable this chip to
show which environment you are currently using.

• Alerts : Notifications of specific items that have changed. Also notifies you when a background
process completes. If there are many alerts you can search the list.

• Teamcenter AI Chat : Teamcenter Artificial Intelligence (AI) Chat allows you to ask questions
and provides summarized answers with source materials from indexed and embedded file contents
to which you have access. Appears only if configured by an administrator.

• Settings :

• Choose Compact or Comfortable display format.

• Show or hide text labels for commands in global navigation.

• Access logging options and record a log file to share with an administrator.

• Toggle automatic saving of table edits.

• Assess system performance with Monitoring.

• View online help.

• The icon shown here is a default image. If the current user has added a profile picture it appears in
the circle at the bottom of navigation. Otherwise the first letter of the user name appears there.

Note:

If there is insufficient space to show all of the bottom-position icons due to your screen
resolution or the vertical size of the client window, an ellipsis (…) appears in the last icon
position. Clicking it reveals the hidden icons.

Profile: Open your user profile page, view and change your session settings, toggle display of
session settings at the bottom of the page, and sign out of Active Workspace.

Session settings include: Project, Group, Role, Workspace, ID Display Rule and Revision Rule.

Tip:

If you have uploaded a profile picture to your user profile, a thumbnail of it displays in the
global header. Otherwise a default graphic displays.
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Related topics

Arrange tiles

Resize a tile

Pin an object to the home page

Unpin a tile from the home page

Explorer

The EXPLORER tile on the Home page, and the Explorer  icon in global navigation open a tree view
that provides access to all your folders, their subfolders, and data in folders from a single entry point.

1 Command in navigation that opens the Explorer page.
2 Favorites - Always first in the tree regardless of sorting applied to the tree. Contains references to

objects that you have saved as favorites for quick access.
3 Active Folders - Collects all of the active folders that you can access. Active folders are saved search

criteria that return the latest available matching results.

Explorer
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4 Home. Your personal home folder. Selected by default, with relevant commands enabled on the
toolbar when you open Explorer. Content varies for each user. In general, it displays references to
objects and information that are relevant to your work.

5 Project Data - Displays the projects of which you are a member and enables you to view the content
of a selected project.

6 Overview of the properties of the selected folder.
7 Content in the selected folder. Home and Favorites can display any object in the system. Active

Folders and Project Data are query folders that display referenced objects matching the search
criteria.

Note that the Contents section is not present when the Project Data folder is selected.
8 Layout Manager - enables rearranging of the panes in the page to your preferred view.

Open folders in the tree by selecting them and clicking Open  on the primary toolbar. You can also
open subfolders from the table displayed in the Contents section by hovering over a folder in the Object
column and clicking Open .

Related topics

Organize searches with active folders

Introduction to objects and object types

Using projects
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Page layouts

Different pages in Active Workspace have varying layouts of the main page components. This topic
presents a few of the main page layouts to help you understand them and the terms you will find used in
documentation.

Home page layout

1 Global header

2 Global navigation

3 Work area and tiles

4 Global search

5 Session controls

For a more in-depth information see the Home page topic.

Search page layout

The results page displays the objects matching the criteria entered in Global search.

Page layouts
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1 Results panel toolbar

Shows a count of found objects, the search scope, and any applied filters. Also
contains the primary toolbar with commands applicable to the context.

2 Filters panel

Enables you to narrow the search results. When closed you can reopen it by clicking
Filters .

3 Results panel toolbar

Commands applicable to the search results displayed in the results panel.

4 In-context search

Search the list of found objects in the results panel (5).

5 Results panel

Lists the objects matching the search criteria entered in Global search.

6 Object information

Displays information about the object currently selected in the results panel (5) and
enables you to open edit it.

7 Tabs

Provide access to different categories of information about the object selected in the
results panel (5).
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Object page layout

This page displays when you open an object.

1 Object information and options

Enables viewing and selection of revision, revision date, group and variant rule.

2 Primary toolbar

Contains commands applicable in the context.

3 Work area toolbar

Contains commands applicable to the object.

4 Work area

The area not occupied by Global navigation and the Global header. Some of the
content can vary depending on the type of object you have opened.

5 Tabs

Provide access to different categories of information about the selected object.

Task panels

Some commands open a task panel. Typically, these panels display over the top of the information in the
work area. Examples include Add panel, Create Change panel, and Trace Link panel.

Page layouts
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Other commands, such as search Filters , display a panel on the left.

Notification and error messages

The system displays notification messages. You can pin a message so that it continues to appear in the
window, and you can refer to the message text later during your work session.

Example:

Navigating to a new location or selecting a new object, such as a physical part or a file, does not dismiss
the message. You must unpin the message to dismiss it.

The system also displays error messages. These cannot be pinned.

Example:

Move and resize panels

As you work with data objects, you may open panels to perform your task. Some panels, such as the
Information panel, can be undocked and moved around the browser window. When undocked hey can
also be resized.
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When you re-dock a panel to return it to its default location, the next time you undock the panel, it
returns to its last undocked size and position.

Procedure

The following steps show how to undock the Information panel. Other panels that can be undocked
work in the same way when opened.

1. When viewing an object, click Information  on the primary toolbar.

The Information panel opens.

2. To undock the panel, click Undock  in the upper-right corner of the panel.

The panel undocks and can now be moved around the browser window.

3. Do any of the following:

• To move the panel, place your cursor in the panel header and then click and drag the panel to
your desired location in the browser window.

• To resize the panel horizontally, place your cursor on the right or left edge of the panel and then
click and drag to resize it.

• To resize the panel vertically, place your cursor on the bottom of the panel and then drag to
resize it.

• To resize the entire panel, click the bottom-right corner of the panel and then drag to resize it.

• To return the panel to its default size and location, click Dock .

Move and resize panels
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Toolbars and commands

Pages in the user interface may include three different toolbars.

1 Results panel toolbar

2 Work area toolbar

3 Primary toolbar

Results panel toolbar

The results panel toolbar includes commands associated with the data displayed in the results area.
As the data changes, the commands available in the toolbar change. Some commands are grouped
together as a stack of commands under an icon with a small triangle under the command icon.

Note:

Depending on the size of your browser window and display resolution, the More Commands
 command may display on the results panel toolbars. Clicking the icon displays additional

commands that are hidden due to sizing constraints.
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Work area toolbar

The work area toolbar includes commands associated with the data displayed in the work area. As the
data changes, the commands available in the toolbar change.

Primary toolbar

The primary toolbar includes commands associated with the data displayed on the page. As the data
changes, the commands available in the toolbar change.

Tip:

If you don't see the command you need, try looking for it in More Commands .

Command context menus

You can access commands in the context of the items you are working with by right-clicking on the
items in a table or a list to access the commands. Depending on the area of the application you are
in, the available commands are different. For example, right-clicking on a schedule task gives you a
completely different set of in context commands versus clicking on a part in a structure.

The following graphic shows the commands in the context of a document in the search results list.

Toolbars and commands
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Note:

Context menus are not available on touch devices.

Selecting single or multiple objects

In Active Workspace you can select objects one at a time or several at once.

Select a single object

To select a single object, click on it. The object highlights to indicate that it is selected.

Select multiple objects

There are two methods to select multiple objects. In both cases, objects are highlighted to indicate
selection.

1. You can use Selection Mode  located in the results panel toolbar.

Once you click or touch Selection Mode , you can:

• Click or touch any object to select it.

• Shift-click to select a range of objects.

• Select All / Clear Selections . This is a toggle. Clicking it once selects all displayed objects.
Clicking it again, clears the selection on all the displayed objects and exits the multiselect mode.
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2. The second method is to click, Shift-click, or Ctrl-click objects without using Selection Mode .

• Click or touch any object to select it. Any previously selected objects are deselected.

• Ctrl-click nonconsecutive objects to select them.

• Shift-click to select a range of objects.

• Select All / Clear Selections  is not available without using Selection Mode .

Note:

In search results, when you select multiple objects using either of the described methods you can
see information about them, but you cannot open or download any of the selected objects. You
must select a single object to open or download it.

Header information

The Global header is always present. It shows you your current context and provides global search,
session information and settings, and access to your user profile. The main components of the Global
header are:

• Location information

• Page links

• Global search

• Session controls

1 Location
2 Global search
3 Session controls

In some locations, the Global header provides links to one or more pages.

Search result pages:

Inbox pages:

Header information
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Session controls

• (1) Change notifications: View and search active changes, if any, and set the active change context.

• (2) Environment indicator: In infrastructure that has multiple deployments or deployment types —
test and development, for example — an administrator can optionally configure and enable this chip
to show which environment you are currently using.

• (3) Alerts : Notifications of specific items that have changed. Also notifies you when a background
process completes. If there are many alerts you can search the list.

• (4) Settings :

• Choose Compact or Comfortable display format.

• Show or hide text labels for commands in global navigation.

• Access logging options and record a log file to share with an administrator.

• Toggle automatic saving of table edits.

• Assess system performance with Monitoring.

• View online help.

• (5) Profile: Open your user profile page, view and change your session settings, toggle display of
session settings at the bottom of the page, and sign out of Active Workspace.

Session settings include: Project, Group, Role, Workspace, ID Display Rule and Revision Rule.
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Tip:

If you have uploaded a profile picture to your user profile, a thumbnail of it displays in the global
header. Otherwise a default graphic displays.

Related topics

Home page

Navigate your workspace using breadcrumbs

Navigate your workspace using breadcrumbs

Locations can have a breadcrumb showing where you are within a folder structure or a part structure
in Explorer. Breadcrumbs mainly serve to show your current context, but you can also use them to
navigate the structure.

Move to a different folder location

Click the folder name.

You move to the selected folder location.

Move to a different branch within a selected folder

Click the chevron  to display the child folders of a currently-selected folder in a drop-down list. Select a
folder in the list to navigate to it in Explorer.

Navigate your workspace using breadcrumbs
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Expand or shrink breadcrumbs area

You can expand or shrink the header area preceding the breadcrumbs. Drag the separator just before the
first breadcrumb to shrink or expand the space before the breadcrumbs area.

Items preceding the breadcrumbs become hidden and appear when you click More...

Viewing data

View folders and object structures

When folders are opened in the Explorer , they are displayed in a tree view that shows all elements of
the folders in a parent-child relationship. You can expand or collapse the nodes in the tree as needed.
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In a tree view, when you select a structure, an object within a structure, or a folder, its details are
displayed in the adjoining work area.

List, Table, Image and Tree views

In Search results, Inbox, Changes, and opened Folders you can view the displayed objects as a list, a
table, or a collection of images. You can edit some data in the Table view.

The list and table of objects in search results appear as follows, respectively.

List, Table, Image and Tree views

Retail Footwear and Apparel ─ Fundamentals, Teamcenter 2412  2-39
© 2025 Siemens



2. Exploring the Active Workspace interface

2-40  Retail Footwear and Apparel ─ Fundamentals, Teamcenter 2412
© 2025 Siemens



Note:

Table view is not available in narrow-interface mode.

Images in search results appear as follows.

List, Table, Image and Tree views
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In opened Folders you can also view the data as a tree.
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Related topic: Using the relations Tree view to browse related objects

Tip:

The Explorer  always displays data in a tree view.

Using the relations Tree view to browse related objects

The relations Tree  view presents system-generated folders that collect related objects of different
types such as attachments or specifications. It enables you to browse through the objects and perform
some operations with them, such as Add  and Copy .

Relations Tree view in Explorer

When a folder is selected in Explorer , you can view and browse the relations tree folders in the
Contents section by selecting Tree  and expanding the first node in the Object column.

Using the relations Tree view to browse related objects
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Relations Tree view in the Inbox

When an item such as a task or a change is selected in the Inbox , you can view and browse the
relations tree folder in the Targets section by selecting Tree  and expanding the first node in the
Object column.

Relations tree folder operations

• You can add items to folders in the relations Tree view by clicking Add .

• In Explorer , you can copy an item you select in the main tree and paste it into a relations tree
folder in the Tree view of the Contents section using Copy  and Paste , or by dragging.

• You can view information about an object selected in the relations Tree view by clicking Information
.

• You can customize the columns in the table when the Tree  view is displayed.

• You can sort the relations tree folders according to type using the Type column header.

Tip:

You cannot cut, copy, or delete the relations tree folders themselves.
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Open folders and select the view

When you navigate to and select a folder in Explorer, you can open it and choose a view mode. Each
view mode displays the folder contents in a different way.

The available view modes are List, Table, Table, Tree, and Tree.

1. From the navigation, select Explorer .

2. Select the folder that you want to open from the tree view.

3. Click Open .

The folder displays the contents in the default view mode.

4. (Optional) Change the view of the contents by selecting the required view mode from the list.

The tab in the header displays the currently-open folder (1). You can change the view mode using
the selector (2)

Open folders and select the view
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Note:

Folders always open in the default view mode.

Using Layout Manager

Layout Manager enables you to change the layout of the page you are currently viewing. You can
switch to a recently-used layout, a layout that you have explicitly saved, or another selection from the
layouts available for the current page.

To display the panel, click Layout Manager  on the primary toolbar. To close it, click the toolbar icon
again or anywhere outside the panel.
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1 The Recent section displays up to four of your most recently used layout
arrangements.

You can save a layout arrangement displayed in this section by hovering over a
layout arrangement and clicking Save .

2 The Saved section displays your saved layout arrangements.

Once you have saved eight arrangements, you must delete at least one before you
can save another. To delete, hover over a layout arrangement and click Remove .

3 The More Layouts section displays all available layout arrangements. The layouts
vary depending on the page you are on.

Note:

Some pages, the Explorer page, for example, have only a few available layouts and the Recent
and Saved sections are not present.

Storage of layout information

Page layout information is stored locally. The first time you open a page in a browser or device, or if
you open the same URL in a different browser or device, the default layout configured on the server is
applied. When you select a different layout, it is then applied each time you return to the same page
until you select another layout. Saved layout information is lost if you clear your local storage. Revisit the
page and select one or more layouts. This adds them to the Recent section and you can optionally save
them from there.

Using Layout Manager
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Tip:

You must clear your client browser storage to access any new layout configurations published on
the server. Your administrator can inform you about newly available layouts.

Working with tables

Edit data in tables

Tables are a common way of displaying data in the user interface. It is important to have a basic
understanding of the main table features and how you can edit data in tables.

There are two ways to edit data while you are in the table view.

• Click Edit , tab through cells and expand or collapse the objects with child elements. After making
your changes, click Save Edits.

• Directly edit table cells by double-clicking them. If Autosave Tables is enabled in your user properties,
when you click off the cell, the changes are saved automatically. If this is not enabled, you must click
Save Edits to save your changes to the table.

You can click a column header and then select Hide Column to hide an entire table column. To show the
column again, click  to the right of the column headings to open the Arrange panel. From here, you
can add the hidden column back to the table.

You can sort the data in the table by clicking the column header and choosing to sort by ascending,
descending, or no sorting. If a table column contains values of dissimilar data types, the table sorts
based on the string values for the data.

Some tables do not save customizations made to the table, such as hiding, freezing, or resizing columns.
They also may not support modification of column arrangements and drag and drop functionality. Any
changes made to these types of tables are lost when the table is reloaded.

For more information on working with tables, see the following topics.

List, Table, Image and Tree views

Arrange, wrap text, and save the order of columns

Modify table and tree appearances

Add table columns in real time

Automatically save table settings
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Autosave table edits

You can select the option to automatically save changes made to tables. When this option is enabled and
you edit a table cell by double-clicking it, the changes made to the cell are automatically saved when you
click off the cell.

• If you edit a table with autosave off, you must save the changes made to the table cells by clicking
Save Edits.

• Some table cells may not support autosave. You must manually save changes made to these table
cells.

• Some tables may only support autosave editing. In this case, changes made to the cells are
automatically saved, even if you have autosave turned off in your profile.

• If you enable Autosave Tables while you have unsaved table edits, the system prompts you to Save or
Discard the table edits before enabling autosave.

1. In the global header Session controls, click Settings .

2. Click Autosave Tables  to turn on auto saving of changes made to table cells.

Note:

Autosave Tables is enabled for all users by default.

Modify table and tree appearances

You can modify the display of tables and tree views in several ways.

Autosave table edits
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• Change column widths.

• Hide columns.

• Freeze and unfreeze columns.

Change column widths

You can easily change the column widths for either Table or Tree views.

Tap or hover at the far-right of a column in the column header to display the column divider indicator
and drag it to the left or the right.

Hide Columns

Columns that contain information that you do not need can be hidden from the table view.

To hide columns, click the column header, then click Hide.
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Freeze and Unfreeze columns

The first column is frozen by default for Table and Tree views. This is indicated by a dark right column
border.

To freeze additional columns, click the column header, then click Freeze.

The column (and all the columns to the left) are frozen, meaning they are not part of the horizontal
scrolling region.

To unfreeze columns, click the column header and click Freeze again.

Modify table and tree appearances
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Note:

You can't unfreeze the first column in the Table or Tree views.

Add columns to a table

When viewing a table or tree, select More Columns in the Arrange panel to load all available properties
and display selected ones as table columns. See Add table columns in real time.

Arrange, wrap text, and save the order of columns

You can use the Arrange panel to reorder, hide, or display columns in either the Table or Tree view.

The Arrange panel contains the Available Columns that can be added to the table or tree and the
Displayed Columns, which are the columns currently displayed.

Tip:

Adding or removing columns from the Displayed Columns list enables the Save as new
arrangement check box so you can quickly save your customized column configuration so
that you can easily apply it to views in future sessions.

The Arrange panel

To open this panel, click the Table Settings  icon to the right of the column headings and select
Arrange.
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Show All / Show Common

Displays all available properties as columns or only the common properties for the
objects in the table.

Move up

Arrange, wrap text, and save the order of columns
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Select one or more column names in the Displayed Columns list, then click  to
move the selected column(s) upward in the list.

You can optionally drag the selected column(s) instead of using the icon.

Move down

Select one or more column names in the Displayed Columns list, then click to
move the selected column(s) downward in the list.

You can optionally drag the selected column(s) instead of using the icon.

Column arrangements

Select a saved column arrangements to apply it to the view.

Column arrangements you create (1) appear at the top of the list above the dividing
line after the Default arrangement. You can only delete column arrangements you
create.

Column arrangements created by administrators (2) appear below the divider.
You cannot delete or modify them. However, you can save them as new column
arrangements which you can modify.

Add

Select one or more columns in the Available Columns list on the left. Then click 
to add the selected column(s) to the Displayed Columns list.

You can optionally drag the selected column(s) instead of using the icon.

Remove

Select one or more columns in the Displayed Columns list on the right. Then click
 to remove the selected column(s) from the list.

You can optionally drag the selected column(s) instead of using the icon.
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Note:

If the properties list is long, you can type a property name in the Filter field to display a specific
property.

You can select multiple columns to move groups of columns up or down the list by doing the following:

• Shift-click to select a range of columns if they are in consecutive order.

• Ctrl+click nonconsecutive columns to select them.

Note:

If search results are obtained from a set of external data, such as from a non-Teamcenter database,
you may not be able to sort items in a column because the data model for these items does not
conform to the Teamcenter properties displayed in the column headings.

You can also drag column headings to rearrange the column order of a table.

Note:

Some tables do not save customizations made to the table, such as hiding or freezing a column, or
support making changes to the column arrangements. Any changes made to these tables are lost
when the table is reloaded. These tables also do not have the Arrange option in the table settings.

Save your column arrangement

When you change the current column arrangement by adding, removing or reordering columns in the
Arrange panel, the system creates a copy of the column arrangement including your changes, selects
the Save as new arrangement option, and prefills the Name box appending "_copy" to the name of the
current column arrangement. For example, if you modify a column arrangement named BOM basic, the
prefilled name is Bom basic_copy. You can optionally change the prefilled name and save your changes
in the panel as a new column arrangement by clicking Save and Arrange.

This saves your column arrangement so you can apply it in the future. You can click Column
Arrangements  on the Arrange panel to see a list of all your saved column arrangements.

Reload the default column arrangement

You can reset a table to its default column arrangement by opening the Arrange panel, clicking Column
Arrangements, and selecting Default in the list.

Arrange, wrap text, and save the order of columns
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Note:

• Default is always first in the list of column arrangements and you cannot delete it.

• Administrators can define different Default column arrangements for different contexts. If you
are a member of more than one group, or if you have different roles with a group, the columns
displayed in the Default column arrangement can differ depending on your current group and
role selection in your session controls. If you do not see an arrangement you are expecting it is
probably configured for a context different from your current one.

• When you hover above Default in the list of column arrangements, a tooltip indicates the scope
of the arrangement. Possible scopes are: workspace, group, role, and site.

• The Default column configuration in object set tables is always driven by the user’s XRT
properties.
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• For information about work contexts and session controls, see User properties and Change
your group, role, or project for your session.

Wrap table text

You can toggle text wrapping to have text in table cells automatically start at a new line once it reaches
a certain length. This helps tables with large amounts of text look cleaner and makes reading the data
easier.

Click  to the right of the column headings and then select Wrap Text to enable text wrapping for the
table. The command remains highlighted to show that wrapping is enabled. You can click it again to
turn it off.

Automatically save table settings

Some table settings for some types of tables save automatically when you change them and are restored
on next access. Persistence of table settings differs somewhat depending on the type of table.

• An objectSet table in Summary view: the last settings in effect for column sorting, text wrap and
saved filters save automatically when you navigate away. The settings are restored the next time you
access the same table and they persist until you change them.

• Primary work area tables: settings for text wrap, column sorting, and column arrangement persist
automatically only if a server-side column configuration for the table exists.

• Search results table: changes you make to table settings do not persist when you navigate away.

Add table columns in real time

Create, save, and open different column arrangements to control which columns appear in tables and
trees. When viewing a table or tree, the default column arrangement appears if you have not previously
viewed the table. If you viewed the table previously, you see the last column arrangement used. You
can open a different column arrangement, or add more columns to a table you are currently viewing to
create a new column arrangement.

Add table columns in real time
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• Use the Arrange panel to add more columns to a table you are viewing by adding properties to the
Displayed Columns list (3).

• You select the properties you want to add as table columns from the Available Columns list (1).

• If a property you want to add does not appear in the list, you can click More Columns (2) to load
more properties.

• The Show Common icon (4) switches between displaying all properties or only common properties.
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Procedure

1. While viewing a table, open Table Settings  > Arrange.

The Arrange panel opens. The properties appearing in the Displayed Columns list are those
shown as table columns by the current column arrangement. Properties in the Available Columns
list, if any, are available in the current configuration, but are not displayed as table columns.

2. If a property you want to display as a table column doesn't appear in the Available Columns list,
click More Columns to load more properties.

The Available Columns list populates with available properties of the object types in the current
column arrangement.

3. In the Available Columns list, double-click an item to add it to the Displayed Columns list.

If multiple list items have the same name, you can hover over them to see the distinguishing type
in a tooltip.

Use the search box above the Available Columns list to filter the items. You can search for names
of properties or names of object types.

You can optionally drag items from one list to the other.

The Save as new arrangement check box becomes selected and the name of the current column
arrangement is written to the Name box with _copy appended to it.

4. Optionally edit the value in the Name box and click Arrange to save your changes as a new column
arrangement.

If you do not want to save your changes click Close.

Results

The properties you added to the Displayed Columns section now appear as columns in the table.

Column arrangements you create (1) appear at the top of the list above the dividing line after the
Default arrangement. You can only delete column arrangements you create.

Column arrangements created by administrators (2) appear below the divider. You cannot delete or
modify them. However, you can save them as new column arrangements which you can modify.

Add table columns in real time
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Filter data in a table column

You can filter the data within a table column so you can easily see the data that is important to you.

Tip:

Column filtering is not supported in Table view in advanced search results.

Note:

You can click a column header and then select Hide Column to hide an entire table column. To
show the column again, click the cog wheel icon  and select Arrange to open the Arrange
panel. There you can add the hidden column back to the table.

To access the filtering, click anywhere in the header of the table column to filter. There are four types
of filters available depending on the types of data; text filtering, facet filtering, date filtering, and
number filtering. The available filtering depends on the data your are viewing. Some columns do not
support filtering. Others do not support facet filtering.

To remove filters:

• To clear an individual column filter, click Clear.

• To clear all filters, click the Table Settings icon to the right of the column headings and then select
Clear all filters.
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Text filtering

Text filtering enables filtering for any table column that contains text.

• Do not use wild cards. Just enter a text string to filter on and click Filter.

• You don't need to differentiate between upper and lower case.

• When you enable facet filtering by clicking Show Filters for the column, the list of values
automatically narrows as you type the text.

• The default matching mode for text filtering is contains, which shows all values that contain the
specified filter criteria. You can change to other matching modes, such as Does not contain, Begins
with, Ends with, Equals, and Does not equal.

Filter data in a table column
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Facet filtering

Facet filtering displays all the available values in table columns, based on the current table values and
the filter criteria entered.

Click Show Filters to view the values for the table column. You can select the values you want to filter
by, and then click Filter to show only the selected values.

Date filtering

Date filtering enables filtering for table columns that contain dates.
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You can set a single date or a date range using the pop-up calendar.

Number filtering

Number filtering enables filtering for table columns containing numeric data.

Filter data in a table column
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Keep filters between views

Unlike other settings such as sorting and text wrap, filters you set do not automatically persist when
you navigate away. After you have set filters, if you want to save them so that they are reapplied
automatically next time you view the table, select the Table Settings  icon to the right of the column
headings and then select Keep Filters.

The state of the Keep Filters option persists until you deselect it or select Clear all filters. The state of
the Keep Filters option is also cleared, and the option is hidden if you remove all the table filters using
Clear all filters or the column menu.

Note:

Saving column filters is not supported in Table view in advanced search results.

Exporting tables to Microsoft Excel

You can quickly export data from tables to Microsoft Excel format to share the data with others who do
not have access to it through your Teamcenter infrastructure and clients.

1. On the table you want to export, click Excel Round-trip  > Export to Excel .

The Export to Excel panel opens. The table columns are automatically added to the export and are
displayed in the same order as the table.

2. Do any of the following:

• To rearrange the order of the table columns prior to export, select the column you want to move
and then click Move up  or Move Down  to change the order.

• To remove a column, select it and then click Delete .

• To view a list of all the columns for the table, click Add Properties. Columns that are selected
for export are checked. Any columns deleted from the export or which were hidden in Active
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Workspace are unchecked. You can restore a hidden or deleted column by selecting it and then
clicking Add.

3. Click Export. The system automatically generates a file name and downloads the Excel
spreadsheet.

Note:

If your browser is set to ask you where to save files before downloading, you can change the
automatically generated file name and save location of the Excel file before downloading it.

Guided navigation using the Teamcenter Assistant

The Teamcenter Assistant

The Teamcenter Assistant  suggests the next possible actions to perform and provides the relevant
data required to perform them. These suggestions are based on the context, history, and usage
frequency of actions performed by other previous users belonging to the same role and group.

When you perform tasks using Active Workspace, the system remembers the commands and the
sequence in which the tasks are performed. The next time you, or other users who belong to the
same role and group as you, log on, the system displays a set of commands based on the learning. You
can either accept the commands suggested in the panel to complete your tasks or ignore them. The
Assistant dynamically updates the sequence of tasks performed in each session. It learns the command
usage and recommends the relevant command depending on the context for subsequent sessions.

Experienced users can log on using Active Workspace with special user credentials and train the
Assistant on their preferred way of completing their tasks.

The Assistant panel displays your recent data, your team's recent data, your favorites, and the contents
of the clipboard.

By suggesting the next logical commands, the Assistant helps to:

The Teamcenter Assistant
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• Improve your efficiency by reducing the cognitive load.

• Minimize the number of mouse clicks required to perform your tasks.

• Reduce the total time required to complete a task.

Train the Assistant

You can use the Tutor Mode to train the Assistant to learn a preferred way to complete a task.

1. Log on using the credentials of a user profile that is specifically set up for training the Assistant.

2. In the global navigation area, click Assistant .

3. Click  to pin the Assistant panel.

4. Turn on the Tutor Mode and start performing the steps required to complete your workflow.

The system records your preferred way of completing the task.
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5. Turn off the Tutor Mode when you complete your task.

Now, when other users log on, the system recommends the commands that were used in the Tutor
Mode. This can help companies leverage the experience of experts and standardize the use of good
practices.

The Assistant panel

When you log on, you can view the Assistant icon in the global navigation area.

The Assistant panel
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1 View up to 10 commands suggested by the Assistant panel.

These command suggestions are specific to a user. If the current user is logging on for the first time,
the system generates the suggestions from the history of other users belonging to the same group
and role.

2 Like or dislike commands suggested in the panel to prioritize the use of one command another.

The availability of these options can be configured by an administrator.
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3 View the location of the suggested command.

The availability of this option can be configured by an administrator.
4 Choose options from the drop-down list to change the data displayed in the Assistant panel.

My Recent – View your recently created or modified data.

You can view up to 20 objects. The number of objects you want to display can be configured by
an administrator.

Team Recent- View the data created or modified by users in the same group and project.

You can view up to 20 objects. The number of objects you want to display can be configured by
an administrator.

The types of objects you want to display can be configured by an administrator.

Favorites – View your favorites.

Clipboard – View the clipboard data.

The Tutor Mode is available when users log on using a specific user profile that is set up for training the
Assistant and when they pin the Assistant panel. Use this mode to train the Assistant to complete tasks
in a preferred way.

The availability of the Tutor Mode can be configured by an administrator.

The Assistant panel
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Modifying your home page

Resize a tile

You can customize the Home page in various ways to optimize your working experience. One
customization is resizing the tiles.

1. Right-click the tile you want to resize, or left-click and hold the tile until you see an arrow button in
the lower-right corner of the tile.

On a touch device, tap and hold a tile to enter edit mode.
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2. Click the arrow button in the lower-right corner of the tile.

Depending on the current size of the tile, the tile either shrinks to a smaller size or grows to a large
one.

Some tiles, like the Inbox, display different information depending on the tile size.

3. To save your changes, click in a blank area on the home page.

Arrange tiles on the home page

Tiles are arranged in groups on the home page. You can rearrange the tiles within a group, move tiles
between existing groups or move a tile to create a new group.

Move a tile within its group

1. Hover over the tile you want to move.

2. Click and hold down the left mouse button, or press and hold a tile on touch devices to select the
tile for moving.

3. Drag the tile to a different position in the group, until you see the outline indicating the new tile
position.

4. Drop the tile in the new position.

Move a tile to an existing group

1. Hover over the tile you want to move.

2. Click and hold down the left mouse button, or press and hold a tile on touch devices to select the
tile for moving.

3. Drag the tile to a different group and position it near an existing tile, until you see the outline
indicating the new tile position.

Arrange tiles on the home page
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4. Drop the tile in the new position.

Move a tile and create a new group

1. Hover over the tile you want to move.

2. Click and hold down the left mouse button, or press and hold a tile on touch devices to select the
tile for moving.

3. Drag the tile to an area between existing groups until you see the vertical bar indicating the new
group position.
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4. Drop the tile.

The tile appears in the new group.

Pin an object to the home page

You can pin objects to your home page to more easily access them when needed.

1. Select the object you want to add to your home page. You can add the object from locations such
as your Home folder, favorites, or search results.

2. On the primary toolbar, click Manage  > Pin to Home .

The object is pinned to your home page. Object data, such as the ID, revision, and description
display above the pinned object.

Note:

If the text for the pinned object is long, some of it will not display above the object. You can
hover over it to see all of the text.

Unpin a tile from the home page

You can pin objects to your home page to easily access them when needed. You can unpin pinned
objects later on if you wish.

1. Right-click a tile, or left-click and hold a tile until you see additional controls on the corners of the
tile.

Pin an object to the home page
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On a touch device, tap and hold a tile to enter edit mode.

2. Click unpin  in the upper right corner of the tile.

Note:

If you do not see unpin  in the upper right corner of the tile, an administrator has protected
the tile to prevent it being unpinned.

To unpin an object from the home page while you are on a different page, select the pinned object and
click More Commands  > Manage   > Unpin from Home .

Note:

Administrators can repin default tiles.

2. Exploring the Active Workspace interface
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3. Finding data using Active Workspace
Searching for data

Throughout a product's life cycle, you need to keep track of multiple drawings, attachments, and item
revisions. There is no need to remember folders or directories where this data is located because you
can use several search and filter options to locate any data stored in Teamcenter.

In addition to locating all possible results, you can refine your search, save and pin your search, and
export your results. During your project, you may want to see all matches that contain the name of the
project you are working on. Or you may want to search the database for parts with a similar shape or
size.

Return matches to a text search

Place your cursor into the Search box located in the top right corner in the application window.

• Begin entering your search term in the search box.

Suggestions and Recent Searches are displayed according to what you type. Recent searches are
saved during your current session unless you choose Clear.

Index term stemming is applied to all indexed fields. For example, a search for shielding tile also
returns objects with the string shield tile in any indexed field.

• Click Saved Search to access your list of saved searches.

• Click Advanced Search to return matches using advanced search queries.

All search results appear in the Results tab.
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To refine your search:

• Narrow the scope of your search with a prefilter.

Prefilter lists are configured by your administrator. For example, you might see Any Owner and Any
Category lists.

• Refine your search criteria using operators, keywords, and other techniques.

• Ignore common words in your search criteria.

Work with your search results:

• Choose a view for your results.

• Filter your results.

Apply filters from a list of categories and properties. You can remove filters using the breadcrumb in
the header area.

• Display results by category in a chart.

• Apply highlights for matching search terms or use filter colors.

• Save and pin your search criteria, including your filters and chart view, to use or refine later.

You can pin the search and access it from your home page. You can also access your saved search
from the Saved page in the Search header and share it with others.

• Export your search results to Microsoft Excel or Microsoft Word.

3. Finding data using Active Workspace
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You can also personalize your search settings to change the behavior of the Filters panel and how
results are displayed.

Return matches using advanced search

Your tasks may require you to search often and always against the same fields. For example, each week
you may want to ensure that approved parts were not changed. You search for all objects in various
projects that were modified the previous week with a Release Status of Approved.

Instead of typing your search criteria for multiple fields into the search box, you have the option of
using predefined queries that provide you with just the fields you want to search against. For example,
select a query, enter your search criteria into the fields for Name, Description, Created After, Created
Before, and Release Status.

Several predefined queries are provided for your use. You can work with and create queries.

Select an option in Display to refine the list of queries:

• All: All predefined queries and queries you created.

• Public: Only predefined queries.

• Private: Only queries you created.

You can choose a search from Preferred Searches in the Advanced Search panel. Preferred searches
are displayed first. You can add or remove a query by selecting it and clicking Preferred.

You can refine your advanced search using wildcard characters, delimiters, and cascading lists of
values.

Find summarized answers of complex information using Teamcenter AI Chat

You may need to quickly access safety, compliance, regulation, and more information while working in
Active Workspace. With Teamcenter Artificial Intelligence (AI) Chat, you can ask questions in a panel
and receive summarized answers with source materials. Teamcenter AI Chat is enabled and configured
by your administrator.

Receive targeted results using natural language search

You may need to quickly access specific information. With natural language search, you can search
using conversation language instead traditional syntax to receive targeted, relevant results
immediately. Natural language search is enabled and configured by your administrator.

Searching for data
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Return matches with a similar shape and size

When building an assembly, you might want to search for existing components that match a similar
shape or size. If the object is indexed for Shape Search, your search results can also display these similar
objects.

Shape Search is enabled and configured by your administrator.

Organize your searches

You will likely use a combination of text searches and template searches to find the data you need. To
organize, save, and share these searches in one place, use active folders.

Refining your search

You can refine your searches with operators, keywords, and other techniques to narrow your results.

• Return matches with patterns using a wildcard

• Particularize matches using special characters

• Expand searches with Boolean operators

• Specify property searches

• Specify date searches

• Apply keywords to search criteria

• Ignore common words in searches

Return matches with patterns using a wildcard

You can use the * wildcard to return all results matching the initial search term.

By default, the search adds an implied wildcard asterisk (*) character to the end of each search term.
Entering HDD 0500 automatically performs a search for HDD* 0500*. This search returns all results
starting with HDD and 0500, such as HDD 050002 or HDDA 050055.

You can use the * wildcard to search for characters in individual search terms. Using * does not support
search phrases as it does not apply to spaces between terms. For example, fue*conomy does not find
fuel economy, but fue* *conomy does.

You can use the * wildcard with NOT to search for empty properties. For example, NOT "Release
Status":* returns all matches without a release status.

3. Finding data using Active Workspace
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You can use the * wildcard with NOW for date searches. For example, "last modified date":[* TO
NOW] returns everything until the present day. NOW must be all uppercase.

Siemens Digital Industries Software recommends that the wildcard (*) be used cautiously for non-
indexed structure search because it might adversely impact search performance.

Particularize matches using special characters

You can return exact matches using quotation marks (" "). Without quotation marks, index term
stemming is applied to all indexed fields and the search returns matches with the string from the stem
word in any indexed fields.

For example, a search for "Shielding Tile" returns objects with the string shielding tile in any indexed
fields. A search for shielding tile also returns objects with the string shield tile in any indexed fields.

You can specify the matches returned by using the following special characters. Be sure to enclose your
search criteria in quotation marks (" ").

( ) { } [ ] - :

Numerical value range searches can be inclusive [ ], exclusive { }, or mixed ([ } or { ]), using syntax
similar to other property or date searches.

Expand searches with Boolean operators

You can use Boolean operators to expand searches by including associated terms or prohibiting specific
terms.

The default Boolean operator applied for all keywords in a search term is set by your administrator.

Search for two terms

AND bolt AND nut returns objects with the words bolt and nut in any indexed fields.

Prohibit a term from the search

NOT bolt NOT nut (or bolt –nut) returns objects that contain bolt but do not contain nut in
any of their indexed fields.

Search for terms with multiple associations

AND (OR) "Part revision" AND (Dan OR Sally) returns objects that are a part revision or contain
a part revision associated with users named Dan or Sally.

Particularize matches using special characters
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(AND) OR (chrome AND matte) OR aluminum returns objects that either contain both chrome
and matte together or aluminum.

AND AND
(OR)

"Dan Designer" AND "Engineering Group" AND (motor OR "main axle") returns
objects that contain both Dan Designer and Engineering Group in addition to motor
or main axle.

Specify property searches

You can search for indexed properties of objects. You can specify property searches using the special
characters listed in this topic.

Colon (:) owner:john

Search on indexed property values using the property display name. Display names
must be separated from search values by the colon (:) character.

Quotation
marks and
colons (“”:)

"Group ID":engineering

Use quotation marks for display names with spaces and property values with spaces.

Quotation
marks for
property
values with
parentheses.

If the property is:

Name: (test)

Then enter the search criteria:

Name: "(test)"

Numerical
value range

ID:[000001 TO 000050]

Search for a range of numerical property values using TO and [ ].

ID: [000001 TO 000050] OR ID:[000075 TO 000100]

You can combine date range with other search tools for more precision, for example,
AND, OR, and “ ”.

Numerical value range searches can be inclusive [ ], exclusive { }, or mixed ([ } or { ]),
using syntax similar to other property-specific searches.

Combine
property and
term
searches

"group id":engineering motor itemrevision

This search finds objects that have engineering as the group ID property and that have
the words motor and itemrevision in any indexed fields.

3. Finding data using Active Workspace
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Name-value
property
search

Your organization can create name-value properties to display name-value pairs in a
tabular format. These name-value pairs represent characteristics not defined in the
persistent properties for a business object.

Consider that your company has created a MyNameValueProperty name-value
property. A search for MyNameValueProperty.name:a5_part_id returns everything
with a MyNameValueProperty name-value property having a a5_part_id name.

MyNameValueProperty.name:a5_part_id AND
MyNameValueProperty.value:000075 returns everything with the
MyNameValueProperty name-value property having a a5_part_id name with a value
of 000075.

When you search for the value of the name-value property, you must use the AND
operator or separate the name expression and the value expression with a space. While
you can search for the name portion of a name-value property by itself, you cannot
search for the value portion by itself.

You cannot use the OR operator with the value portion. The default operator is always
AND.

The provided name and value expressions must be in pairs and in order. That is, each
value expression must be preceded by its corresponding name expression. A name
expression cannot be supplied after its value expression.

Valid: MyNameValueProperty.name:a5_part_id AND
MyNameValueProperty.value:000075

Invalid: MyNameValueProperty.value:000075 AND
MyNameValueProperty.name:a5_part_id

All other search operators apply. For example, you can search for display names using
" " and numerical ranges using [ TO ], and perform wildcard searches with * (the
asterisk).

Specify date searches

You can specify date searches using the following special characters.

Search date
range

Date searches are property specific, and the search format is year, month, and day, as in
2015-08-24.

Date range searches can be inclusive [ ], exclusive { }, or mixed ([ } or { ]}, using syntax
similar to other property-specific searches.

Specify date searches
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Date searches can use the asterisk (*) wildcard or the NOW keyword, which represents
the current date and time in minutes and seconds and can include other properties.

Inclusive date search: "Date Modified":[2015-08-24 TO 2015-08-26] returns
everything from August 24 to August 26, including August 24 and August 26.

Exclusive date search: "Date Modified":{2015-08-24 TO 2015-08-26} returns
everything from August 25, excluding August 24 and August 26.

Mixed date search: "Date Modified":{2015-08-24 TO 2015-08-26], returns everything
from August 25 to August 26, excluding August 24 and including August 26.

Date search
with
wildcard (*)
and NOW

"Date Modified":[* TO NOW] returns everything until the present day (NOW must be
all uppercase).

Mixed date
searches
with NOW

"Date Modified":{2015-08-25 TO NOW] "date released":{2015-08-25 TO NOW]
name:screw

"Date Modified":{2015-08-25 TO NOW] bolt

Date search
with time

You can include the time with the date value, in the format year-month-day-hours-
minutes-seconds:

"YYYY/mm/ddTHH:MM:SS"

Be sure to enclose the date and time value within quotation marks, for example,
"2012-12-11T23:59:59”

The date and time format is supported by simple search, name-value property search,
and table property search.

Apply keywords to search criteria

You can apply supported keywords to your search criteria to return specific results.

Search
objects
owned or
last modified
by the
logged-in
user

Owner:$ME returns results for all objects owned by the logged-on user.

"Last Modifying User":$ME returns results for all object modified by the logged-on
user.

Search
objects for
your group

"Group ID":$MY_GROUP returns results for objects with your group in the group ID
property.

3. Finding data using Active Workspace
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or your
project

"Projects":$MY_PROJECT returns results for objects with your project ID.

Search a
time frame
based on
days

"Creation Date":$TODAY returns results for all objects created today.

"Date Modified":$YESTERDAY returns results for all objects modified yesterday.

ItemRevision AND "Date Modified":$LAST_7_DAYS returns results for all item revision
objects modified in the last seven days.

You can use any numerical value.

Search a
time frame
based on
weeks

"Date Modified":$THIS_WEEK returns results for all objects modified in the current
week.

ItemRevision AND "Creation Date":$LAST_WEEK returns results for all item revision
objects created in the last week.

The week keyword does not support a numerical value.

Search a
time frame
based on
months

"Creation Date":$THIS_MONTH returns results for all objects created in the current
month.

Owner:$ME AND "Date Modified":$LAST_MONTH returns results for all objects
owned by the logged-on user and modified in the last 30 or 31 days, depending on
the month.

"Last Modifying User":$ME AND "Date Modified":$LAST_3_MONTHS returns results
for all objects last modified by the logged-in user and modified in the last three months.

You can use any numerical value.

Search a
time frame
based on
years

"Creation Date":$THIS_YEAR returns results for all objects created in the current year.

ChangeRequestRevision AND "Creation Date":$LAST_YEAR returns results for all
change request revision objects created in the last year.

The year keyword does not support a numerical value.

Ignore common words in searches

If your search phrase contains a common word, such as the, and, for, or a, it may be ignored in your
search criteria. Your administrator can configure which words are interpreted as common words.

If common words occur in a search phrase inside quotation marks, you may not find an exact match.
Using quotation marks around your search phrase has the following effects:

Ignore common words in searches
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• If a common word occurs between keywords in a search phrase enclosed in quotation marks, it is
replaced by a wild card in the query.

For example, if you search for "Parts and sprockets", search checks if a single property contains both
Parts and sprockets. Your search results might include Parts sprockets and Parts large sprockets.

If you search for Parts and sprockets without quotation marks, search checks if multiple properties
match Parts or sprockets and returns the object only if it matches both. Your search results might
include an object containing a property, Parts and sprockets. Or, your search results can include an
object containing the property Parts and another property, sprockets.

• If a common word occurs at the beginning or end of a search phrase inside quotation marks, it is
ignored.

For example, if you search for "The parts and sprockets for", The and for are ignored.

Return matches using advanced search

Advanced search provides predefined queries that help you search quickly by displaying only the fields
you need. Use an advanced search query if you often search against the same set of fields.

For example, maybe you often search for item revisions with different item IDs, created after a certain
date, and with a specific Release Status. You can use the Item Revision query and enter your search
criteria into the Item ID, Created After, and Release Status fields.

To access all available advanced search queries, click Advanced Search from the Search box or from the
ADVANCED SEARCH tile to open Advanced Search. The most recently used query is displayed.

To use advanced search:

• Several predefined queries are provided for your use. You can work with and create queries.

Select an option in Display to refine the list of queries:

• All: All predefined queries and queries you created.

• Public: Only predefined queries.

• Private: Only queries you created.

• Prioritize your frequently used advanced search queries by assigning them as Preferred.

• Enter any additional criteria to narrow the results.

• Press Alt +Enter to add a line to a search criteria field. Press Enter to run the search.

3. Finding data using Active Workspace
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• Refine your advanced search using wildcard characters, delimiters, and cascading lists of values.

When viewing your results you can:

• Choose a view for your search results.

• Export your search results to Microsoft Excel or Microsoft Word.

• Save and pin your search criteria to use later.

Access saved searches from your home page or from the Saved page of the Search header.

Working with advanced search queries

Using custom advanced search queries increases the efficiency of your searches by narrowing your
criteria and expediting your results when you often search the same set of fields.

Queries you created and queries provided by your administrator, known as predefined queries, are
available in the list. Select an option in Display to refine the list of queries:

• All: All predefined queries and queries you created.

• Public: Only predefined queries.

• Private: Only queries you created.

You can also search the list to find a particular query.

In Query Builder, you can do the following:

Action Description
Create a query You can create a query from scratch or using an existing query as a starting point.

Select a Search Type from the available list of business type objects, such as Item
Revision. Build queries by selecting criteria from the following available lists to add
and customize clauses:

• Standard: Properties defined on the search type, properties inherited from parent
types, or referenced properties.

• Relations: Properties that are not defined on the search type, but associated to
the search type through a relation.

Run-time properties, table properties, and compound properties are not supported.
Edit a query you
created

Select the query and click Edit .

Working with advanced search queries
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Action Description
Run a search
using a query

Select the query and click Preview Query .

Search results are returned in the same manner as running the search query in
Advanced Search.

Delete a query
you created

Select the query and click More Commands  > Edit  > Delete .

Import a query You can import a query saved in an XML file into Active Workspace.
Export a query You can export a query to an XML file for sharing.

Create an advanced search query

Create custom advanced search queries in Active Workspace to increase the efficiency of your searches
by narrowing your criteria and expediting your results.

Procedure

1. Click the Query Builder tile on the home page.

2. Choose one of the following ways to create the query:

• To start from scratch:

• Click Create Query .

• Enter a Name, and optionally, enter a Description, and select a Search Type.

• Click Create.

• To start with an existing query:

• Select an existing query and click Save As .

• Enter a new Name, and if applicable, update the Search Type and Description.

• Click Save.

The new query appears in the list.

If the Search Type is Item Revision or a subtype of Item Revision, you can select a revision rule in
Properties to be included in your query.

3. In Criteria, select Add Clause .

3. Finding data using Active Workspace
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4. In the Add Clause panel, select Standard or Relations to display the applicable criteria.

• Standard: Refers to properties defined on the search type, properties inherited from parent
types, or referenced properties.

• Relations: Refers to properties that are not defined on the search type, but associated to the
search type through a relation.

To learn more about properties, review the Teamcenter data model.

5. Find your desired properties. You can:

• Search for specific properties. Parent properties must be expanded in the list for a child property
to appear in the search results.

• Choose to exhibit Display Names or Internal Names for the properties.

• Choose to display Type Properties, which are those defined on your search type, or All
Properties. For unreferenced properties, you can select which type you want the property to
reference.

6. Select your criteria and click Add after each selection.

7. After you have added all desired criteria, click Close.

The Criteria table may be edited.

8. Customize your query clauses in the Criteria table using Boolean rules, Operators, and Default
Values.

Boolean rules Create a custom query by combining clauses using the Boolean rules AND/OR.
When you use AND clauses together, both must be satisfied to return a match.
When you use OR clauses together, either can be satisfied to return a match.

Property
Internal
Name

View the internal name of the property.

Localization
Key

View the localization key used to look up user entry names. The value in
this column can be modified and must be unique for each instance of the
same property internal name. The localization key-value pairs are defined in
qry_user_entry_names_locale.xml.

Display As View the property names as they appear in the search form.
Operator Specify one of the following logical operators in each search clause.

= Equal to

!= Not equal to

Create an advanced search query
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> Greater than

>= Greater than or equal to

< Less than

<= Less than or equal to

IS_NULL Reference property value is not set (blank). You may also specify
=$NULL.

IS_NOT_NUL
L

Reference property must have a value. You may also specify !
=$NULL.

Default Value Enter a default value for a search clause. If you selected IS_NULL or IS_NOT_NULL
as the operator, the default value cannot be edited. For date properties, you can
select a date and time as the default value.

You can use one of the following variables as a default value for the end user who
is running the query.

• $USERID

• $USERNAME

• $GROUP

Caution:

Do not use multiple variables for the default value as the required delimiters
may impact the query.

9. Click Save .

Export an advanced search query

You can export a query to share it with other Teamcenter sites.

Procedure

1. Click the Query Builder tile on the home page.

2. Select a query.

3. Click Export Query .

The exported file is downloaded.

3. Finding data using Active Workspace
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Import an advanced search query

You can import existing query data that is saved in an XML file.

Procedure

1. Click the Query Builder tile on the home page.

2. Click Import Query .

3. Click Choose File.

4. Select the applicable .xml file.

5. Click Open.

6. Click Import.

Refining your advanced search

You can refine your advanced search to obtain the most accurate results.

• Replace unknown characters with wildcards in an advanced search

• Return matches for multiple criteria using delimiters with advanced search

• Narrow your advanced search with cascading lists of values

Replace unknown characters with wildcards in an advanced search

Advanced searches are predefined queries. The more criteria you enter, the more specific your search
results become. Advanced searches are not case sensitive.

You can use wildcard characters, the asterisk (*) and the question mark (?), to match single or multiple
characters in specific positions of a search string.

Asterisk * The asterisk searches for the root of a word followed by one or more characters.

Question
mark ?

The question mark searches for the root of a word with the question mark as a
substitute for another character. For example, a search for Anders?n might return
anderson, Andersen, and andersin.

You can apply the $NULL keyword to a particular search criteria field to return matches with no value for
that attribute.

Import an advanced search query
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Return matches for multiple criteria using delimiters with advanced search

You can search for multiple pieces of information at the same time by using delimiters. The default
delimiters are SEMICOLON, NEWLINE, and TAB. Your administrator can add or remove available
delimiters.

To use an enabled delimiter character, insert it between multiple search criteria. For example, a search
for HDD-0548;HDD-0544 using the SEMICOLON delimiter displays results for both criteria in the same
search results table.

Narrow your advanced search with cascading lists of values

You can narrow the results of your advanced search by selecting a specific value for the property.

If a property has a cascading list of values (LOVs), you must expand all parent values and select a child
value. For example, to search for the component C1, expand P1 and F1 and select C1.

Finding summarized answers of complex information using
Teamcenter AI Chat

While working in Active Workspace, you may need to quickly access your Teamcenter information,
including safety, compliance, regulation, or other information. If configured by your administrator,
Teamcenter Artificial Intelligence (AI) Chat allows you to ask questions and provides summarized
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answers with source materials. These answers are provided from file contents and requirements that
are both indexed and embedded and to which you have access.

You can access Teamcenter AI Chat in a panel at any time using the Chat  in the global header.

In the Chat panel, use Knowledge Source  to select one or more knowledge sources that apply to
your search.

Use natural language to type your question and click Submit  or press Enter to run the search.

Teamcenter AI Chat searches your knowledge source and provides a summarized answer to your
question and the relevant source materials.

You can Copy  the summarized answer for future use.

You can click on the applicable link to open the source material in Active Workspace.

Receive targeted results using natural language search

While working in Active Workspace, you may need to quickly access specific information. If configured
by your administrator, natural language search allows you to search using conversational language
instead of the traditional syntax to receive targeted, relevant results immediately.

You can use natural language search at any time by clicking Natural Language next to the global
search box.

In the global search box, enter your search criteria using natural language. Search criteria should
include indexable properties.

If you have a prefilter selected, it will be honored in the search results unless the search criteria you
entered is contradictory.

You can hover over the number of search results found for information on how natural language search
interpreted your query.

Examples

The following shows the difference between using syntax and using natural language to search for all
item revisions modified within the dates specified, owned by the user, with a released status.

• Using syntax:

itemrevision AND "Date Modified":[2024-01-01 TO 2024-09-30] AND owner:me AND "Release
Status":Released

• Using natural language search:

My released item revs modified from Jan to Sept this year

The following list gives several examples of searching using natural language:

Receive targeted results using natural language search
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• If you search for My change notices, natural language search returns results in which the Owner is
your user ID and the Type is Change Notices.

• If you search for Released part revision, natural language search returns results in which the Release
Status is Released and the Type is Part Revisions.

• If you search for Harness connectors weighing < 0.1, natural language search returns results in
which the Type is Harness connectors and the Weight is less than 0.1.

• If you select Part Revision in the Category prefilter and search for:

• Item revisions modified last year, natural language search ignores the prefilter and returns results
in which the Type is Item revisions and the Modified date is within the last year.

• Modified last year, natural language search honors the prefilter and returns results in which the
Type is Part revisions and the Modified date is within the last year.

Return matches with similar shape and size

If shape search is configured, you can activate it prior to performing a search by clicking the SHAPE
SEARCH tile. To activate it after a search, select Shape in the header area. If you are in the Purchasing
User role, you can also access shape search as the home page in the Pricing Comparison workspace.

In Shape Search, select an object indexed for shape search and click Search Similar.

Depending on the configuration set by your administrator, shape search results may include item
revisions, design revisions, and part revisions. The Shape Similarity column indicates if the result is
Identical  (98-100%), Very Similar  (80-98%) or Similar  (less than 80%).

In the Filters panel, you can choose to apply similarity and size filters to your shape search results.
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• The Shape Similarity slider specifies the level of similarity for matching results. Moving from identical
to similar broadens the search and retrieves more results.

• The Size slider specifies the minimum and maximum size for matching results. Size is a percentage of
the referenced object and not a specific dimension.

You can export your shape search results from the table view.

Work with search results

When you enter a search term in the Search box in the global header, the indexing engine finds objects
relevant to your input and returns a listing of these objects. This listing is called Search Results. This
topic explains how you can view and work with the search results.

Result views

• View your results in a list, a table, or by images.

• In table view, you can:

• Modify how to display tables.

• Organize your view using the arrange panel.

• Sort any column by ascending or descending values. Click on the column header and select Sort
Ascending or Sort Descending.

Sorting on columns for non-indexable properties may be limited based on the threshold of results
configured by your administrator.

Column sorting is not supported for all columns in advanced search.

• Filter any column in table view. Click the column header to view the filtering options.

Columns for non-indexable properties do not support facet filtering. Filtering on columns for
non-indexable properties may be limited based on the threshold of results configured by your
administrator.

Column filtering is not supported for advanced search.

• Switching between views preserves the sort order and selected items in your results. If you enter a
new search, the sort order returns to the default order.

• In list view, snippets may show the location of search terms within file content for returned items. The
snippet is displayed as a phrase under the object. Snippets provide assistance in determining where
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the search term is matched, especially if the displayed object name or description has no match.
Snippet availability is configured by your administrator.

Toolbars

From the search results panel toolbar, you can perform a variety of actions.

• For all search types, you can click  to save your search to reuse later.

• For searches using the search box :

• Click Filters  to apply property values to refine the results.

• Click  to choose:

■ Highlighting to highlight the search term in the results. Highlights are available for keywords
and property values.

■ Color Filtering to associate colors with the most common filter values. Some search results
objects also display the corresponding filter value color in the results list.

• Click Search Settings  to configure your personal search preferences.

Tip:

Depending on your display resolution and panel sizing, some command icons may be hidden. Click
More commands  on any toolbar to reveal hidden commands.

Explore the primary toolbar to display commands that perform actions or open associated task
panels.

Column sorting and filtering

You can sort any column in table view by ascending or descending values. Click on the column header
and select Sort Ascending or Sort Descending.

You can filter any column in table view. Click the column header to view the filtering options.

Columns for non-indexable properties do not support facet filtering.

Column filtering is not available for advanced search.

Filter search results

On the search Results page, you can apply available filters to narrow your search results using the
Filters panel.
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Display or close the Filters panel by clicking Filters . Selected filters are also displayed in the search
breadcrumb.

Filter behavior is initially configured by your administrator, but you can change a few filter panel
settings yourself.

Tips for using filters

• Search results are refreshed automatically when a filter is selected. To change this behavior, you can
display the feature on the Filters panel by clicking Search Settings and selecting Show Auto-update
Filters Option.

• If Auto-update Filters is selected on the Filters panel, search results continue to refresh
automatically when a filter is selected.

• If Auto-update Filters is not selected on the Filters panel, multiple search filters may be selected.
You can hold Shift and select the first and last options to select multiple filters in a row. Click Filter
to refresh the search results.

• You can search the list of properties by entering text in Filter By Property. You can also search the list
of property values using the search box for the filter.

• If you run the search again, filters and in-content search terms are cleared. If you save your search, the
selected filter values are preserved.

• The More and Less commands may be displayed at the end of a property list. You can expand or
reduce the length of the list.

• If Color Filtering is selected, colors are associated with objects in the results that match the most
common filter values.

Some objects may not display the corresponding filter value color. Typically, this happens when the
properties are not defined in the data model template.

• The bar chart appears in all results views when no search result item is selected.

Apply a filter to the results from the Chart by list, which displays the results by property value, or from
the Filters panel. The chart and the search results lists display the same color code for a selected filter
property.

The filter selections persist for the chart throughout the session unless you change them. You can
reset the default behavior by logging off and logging on again.

• If you run a saved search, you can filter the Updated Results to the objects that are New, Modified,
or Unchanged since the last time you ran the search.

Filter search results
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Filtering by dates and ranges

Filtering
dates

When a property displays date boxes, you can enter the start and end dates. Dates take
the form DD-MMM-YYYY, for example, 29-Aug-2016. An empty value means the date
range is open.

When the filter displays the dates, they are grouped as follows:

If there is: The date filters are
grouped in:

More than one year of
data

One-year increments

Between one month
and one year of data

One-month increments

Between one week and
one month of data

One-week increments

One week of data One-day increments

When you click on a date range, the date filters change to the next filter grouping.

Your administrator specifies which day of the week is the first day.

Filtering
numeric
ranges

When a property displays numeric range boxes, you can enter start and end numeric
range values.

Numeric values take the form From- To, for example, .1- 1.5. An empty value means
the numeric range is open.

Filtering Multi-Site search results

If Multi-Site Collaboration is enabled at your site, you can filter Object Directory Services (ODS) published
record objects from multiple locations. At Multi-Site locations, the Filters panel displays the Search Site
property, where you can filter the search results to either Local or Remote. The Search Site is also
displayed in the search breadcrumbs.

• Local displays the results that are indexed at the local site, which includes objects that were indexed
from remote sites.

If there are no published records available, then only local results are displayed.

• Remote displays the results that are indexed only from remote sites. Choosing Remote lets you
choose results specific to the sites listed in the associated Remote Sites filter.
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Personalize your search settings

You can configure your personal search preferences. In the results panel, click Search Settings  to
view the configurable areas.

FILTERS section

Configures the Filters panel behavior.

Hide filters with only Unassigned values

Hides filters with values that are not assigned to any of the results. Clear the check box to display
filters that have no assigned values in the search results.

Limiting expanded filters takes precedence over hiding unassigned filters. When you hide
unassigned values and also specify a list of filters for Limit filters to expand, you may see
unassigned values for filters in the Filters to Expand list.

Sort filter values

By count sorts the filter value lists by total occurrences.

Alphabetically sorts the filter value lists in alphabetical order.

Sort date-filter values

Latest First sorts the date-filter value lists chronologically with the latest first.

Oldest First sorts the filter value lists chronologically with the oldest first.

By count sorts the date-filter value lists by total occurrences.

Display qualified group names

Displays names in the Group ID filter category according to the group hierarchy, including subgroup
names. For example, if you have an Engineering group with subgroups for United States and
Europe, the Group ID filter category may show values for Engineering, Engineering.US, and
Engineering.Europe

If you change this setting after running a search, you must remove any selected Group ID filters
from the breadcrumb and reapply the filters for accurate results.

If you change this setting after saving a search or creating an active folder, including project folders,
you must remove any selected Group ID filters and reapply the filters for accurate results.

1. Access the saved search or folder.

2. Click the Group ID filter.

Personalize your search settings
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3. Click Edit.

4. Remove the selected filter and reapply the filter.

5. Click Save.

Show Auto-update Filters Option

Displays the Auto-update Filters Option on the Filters panel.

If Auto-update Filters is selected on the Filters panel, search results continue to refresh
automatically when a filter is selected.

If Auto-update Filters is not selected on the Filters panel, multiple search filters may be selected.
Click Filter to refresh the search results.

Open Filter Panel automatically with Search

Opens the Filter panel automatically with search results.

Show the more project data folder

Organizes all data that is assigned to a project but not applicable to the available object type folders
into a More project data folder in the project folder.

Filter Wildcard

Choose a wildcard (*) method to apply when searching property values.

Both leading and trailing wild cards applies the wildcard characters to the beginning and end
of your search term.

No wild card searches only for exact matches to your search term.

Trailing wild card applies the wildcard to the end of your search term.

Leading wild card applies the wildcard to the beginning of your search term.

Display filters as

You can specify whether filters display as a list or in groups. The list of available filters and initial
settings are configured by your administrator.

List displays all available filters in a list.

Group organizes filters inside predetermined groups. Groups of filters are configured by your
administrator.

Expand

When filters are selected to display as a List, you can specify which filters are expanded. When filters
are selected to display as a Group, you can specify which groups are expanded.
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Selected Filters allows you to select specific filters from the available list to be expanded. By
default, the Category and Type filters are always expanded.

All Filters expands all filters in the list.

Selected Groups allows you to select specific groups to be expanded from the available list.

All Groups expands all groups in the list.

Update Filter Values

On "Enter" Key Press runs the filter search after you enter text and press Enter.

As you type displays matching filter values as you enter text.

RESULTS section

Configures search results behavior.

Include results from files

Includes results found in the file content of returned items.

Clear the check box to display only matches found in the item name.

Show text snippet with results

Displays a snippet of the text matched from the file content.

This option is only available if Include results from files is selected.

Tip:

Use Highlighting  on the results panel toolbar to display or hide highlighting on matches in
the results list.

In summary view

Show summary of first result displays information about the first returned result in the right pane.

Show chart of results displays the values for the chart filter category in the right pane.

Work with breadcrumbs

Breadcrumbs display information about results for all search types in the page header area.
Breadcrumbs provide a quick view of all selected filters or applied criteria for your search results.

Work with breadcrumbs
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Work with search breadcrumbs

The search Results page displays the filters that are applied to search results. Related filter values are
grouped together in the breadcrumb, regardless of the order in which you choose them. Search criteria
entered in Find in this content appear in the breadcrumb.

When several filters are selected, you can click More at the end of the breadcrumb to display additional
selected filters.

The lock icon appears in the breadcrumb if there are unreadable results. Hover over the icon to view the
number of unreadable results.

Click  next to a filter to remove it.

Click Clear at the end of the breadcrumb to remove all filters.

Work with advanced search breadcrumbs

The advanced search results page displays the criteria that are applied to advanced search results.

Hover over the breadcrumb to display all criteria applied to the advanced search results.

Note:

The applied criteria cannot be edited in the breadcrumb.

Saving searches

All your searches, including advanced searches, can be saved and appear on the Saved search page
available from the header. From the results toolbar, click Save Search .

Saving your searches has many benefits:

• Save all your search criteria to use later.
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• Share saved searches with other users.

• Pin saved searches to your home page for quick access.

• Update saved searches when your criteria changes.

• From Advanced search, you can choose from a list of preferred searches that you tag as frequently
used.

Tip:

Even if a search is not saved, you can choose a search from the Recent Searches list. These are
saved by the system during your current session.

Save a search

You can save a keyword search or an advanced search to access the search at another time.

Procedure

1. Once you have run a search, click Save Search .

2. In the Save Search panel, enter a Name for the search.

3. (Optional) Select Allow others to view if you want to allow other users to view your search.

4. (Optional) Select Pin to Home to pin the search to Home as a tile.

5. Click Save.

Retrieving a saved search

You can access a saved search multiple ways:

• Click the SAVED SEARCHES tile on the home page to open the Saved search list.

• Click the Saved page on the Search header to open the Saved search list.

You can refine the list using Filters .

Select a search from the list to display its information.

• Overview displays key information about the selected search, including its search criteria and owner.

Click on the values in Criteria, Filters, or Chart By to access Rules.

Save a search
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The results are displayed in the CONTENTS section.

In the CONTENTS section, you can Export to Excel .

• Rules displays the current search criteria and the returned results. You can set or update the search
criteria rules if you have permission.

Run a search by clicking Open .

When you run a Keyword Search, the Filters panel includes an Updated Results filter. You can choose
objects that are New, Modified, or Unchanged since the last time you ran the search.

Work with your saved search

Once you have saved your search, you can modify it in several ways. You cannot modify saved searches
that were not saved by you.

Edit your saved search

1. Select the saved search and click More commands  > Edit  > Summary .

2. Make your updates and click Save .

Pin or unpin your saved search

To pin your saved search to a tile, select the saved search and click More commands  > View  > Pin
Search .

Unpin your saved search in one of the following ways:

• Select the saved search and click More commands  > View  > Unpin Search .

• From the home page, right-click the search tile to display controls on the corners. Click Unpin .

Delete your saved search

To delete a saved search that you created, select the saved search and click More commands  >
Edit   > Delete.

Export search results

From the Table view of your search results, you can export rows to Microsoft Excel or Microsoft Word.

Activate Selection Mode  on the results panel toolbar. You can also Select All or Clear Selections
using .
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1. When your items are selected, choose More commands  > Import/Export  > Export .

2. In the Export panel, choose how to export your search results.

As Shown Exports the results to Microsoft Excel. The displayed columns and sort order are
applied to the output.

All Results exports the entire list up to the maximum number configured for your
site, regardless of what is selected. Choosing all results may include results not yet
displayed.

Selected Results exports selected rows.

Template Exports the results to Microsoft Excel or Microsoft Word, and your selected view
and template are applied to the output.

All Results exports the entire list up to the maximum number configured for your
site, regardless of what is selected. Choosing all results may include results not yet
displayed.

Selected Results exports selected rows.

Both Excel and Word export the selected results using a specified view and
template.

The Template option is not available for shape search results.

3. Click Export and provide a location to save the file.

Organize searches with active folders

View active folders

Active folders save predefined search criteria and return the latest available matching results. You can
create search criteria for active folders that generate results automatically. Then you can navigate,
organize, and share these active folders.

You can create a hierarchy of related active folders to group similar searches together. A new active
folder adopts the criteria of its parent by default. You can create a parent active folder with common
search criteria and then refine this criteria for a set of child active folders.

Find your active folders

Open Explorer  from the global navigation or from the EXPLORER tile on the home page. By default,
Active Folders contains the Recently Modified active folder with sample searches in nested folders:

View active folders
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By Me Returns your recently modified data. The criteria and the results are displayed in the
Overview.

By My Group Returns your group's recently modified data. The criteria and the results are displayed in
the Overview.

If you are listed as the Owner of the folder, you can update the Name and Description of the active
folder by clicking Edit .

Review and customize your active folders

When you select an active folder, the work area displays information about a selected folder.

Overview Displays key information about the selected active folder, including its search criteria
and owner. The results are displayed in CONTENTS.

In CONTENTS, you can Export To Excel .

Rules Displays the current search criteria and the returned results for the folder. You can set
or update the search criteria rules if you have permission.

Shared With Set or update with whom you want to share an active folder, if you have permission.
You can filter the list, select multiple entries to add to the list, or remove entries from
the list.

Create an active folder

You can create an active folder several ways. The active folder is created as a child of your current folder
selection. By default, the active folder inherits the search criteria of its parent and the parent folder no
longer retains this search criteria. You can then further refine the active folder's search criteria and add
other child folders.

Add an active folder

1. In Explorer, select an active folder.

2. Click Add Active Folder .

3. Enter a name for the active folder in the Name field.

4. Optionally, you can enter a description for the active folder in the Description field.

5. Click Add.

If the new folder is a child, it inherits the parent folder settings.
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Create an active folder template

1. In Explorer, select an existing active folder.

2. Click More commands  > Import/Export  > Export Active Folder as Template .

This action creates an XML file containing the folder's hierarchy, rules, and sharing information.

Import an active folder

1. In Explorer, select an existing active folder.

2. Click More commands  > Import/Export  > Import Active Folder .

3. Select an active folder XML file with a folder definition, including hierarchy, rules, and sharing
information.

4. Click Import.

You can also import an active folder that is not shared with you. If you run the search, user
permissions are applied to the results and may not return what you expect.

If you import an active folder more than once but to a different location, the new folder is a copy of
the previously imported folder. They are synchronized in the background, and changes made to one
folder are made to the other.

Update the rules of an active folder

When a new active folder is created, it inherits the search rules from the parent folder. In the Rules tab,
refine the rule using the work area toolbar for an active folder. A change affects only the selected active
folder. The action has no effect on any other folder in the hierarchy.

Procedure

1. Click Edit  to refine an existing rule or replace it.

2. Select Keyword, Advanced, or Saved search.

3. Enter any applicable search criteria.

4. Click Search .

5. Click Save  to save your changes.

Update the rules of an active folder
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Share an active folder

If you have permission, you can share an active folder. You may share both Organization and Projects
choices for a single active folder. Sharing permissions determine whether someone can make a change
to a shared active folder. The owner is always displayed for a shared folder. If the owner is a group, you
must be a member of the group to make a change.

Procedure

1. Click Shared With and choose Organization or Projects.

2. Enter a search term and click Search  to see a list of matches.

If you choose a category, nested children are included.

3. Click Add  and Remove  to edit the items in the SHARED WITH list.

Your selections are saved automatically.
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4. Working with data
Creating and revising data

Introduction to objects and object types

Object is a generic term used to describe any part, design, document or other entity that may be stored
in your system.

As you work, you see the thumbnail images for different object types. For example:

Image Object type

Folder

Item Revision

Document

If you don't recognize an icon, you can open the object and see the Type in the PROPERTIES section.

Note:

To mark an object as a favorite, open the object and select Manage   > Add To Favorites . This
places a link to the object in your Favorites folder, accessible from the EXPLORER tile on the Home
page.

How items and item revisions work with Favorites and the home page

You will see different behavior for Favorites and Pin to Home based on the current revision rule of the
user session and whether you add/pin an item or an item revision.

Favorites with items and item revisions

What you see when you favorite an item or item revision depends on three rules.
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If: Then:

1. You add an item to Favorites. Favorites will display the configured item revision.

2. You add a configured item revision to Favorites. Favorites will display the configured item revision.

3. You add a superseded item revision to
Favorites.

Favorites will display the superseded item
revision.

Let's look at a few examples to see how this works with the following scenario.

Item 026355

Item revision 026355 revision A (superseded revision)

Item revision 026355 revision B (superseded revision)

Item revision 026355 revision C (configured revision)

Revision rule = Latest Working

If you add this to Favorites. Then this is what you see in Favorites.

Example 1 Item- 026355 Item revision- 026355 revision C

(the configured revision)

Example 2 Item revision- 026355 revision C

(the configured revision)

Item revision- 026355 revision C

(the configured revision)

Example 3 Item revision- 026355 revision C

(the configured revision) and then make a
revision D.

Item revision- 026355 revision D

(the new configured revision)

Example 4 Item revision- 026355 revision A

(a superseded revision)

Item revision- 026355 revision A

(a superseded revision)

Example 5 Item revision- 026355 revision B

(a superseded revision)

Item revision- 026355 revision B

(a superseded revision)

Remove from Favorites

You open either the item or the configured item revision to remove the configured item revision from
Favorites.

You open the specific superseded item revision to remove it from Favorites.

4. Working with data
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Pin to Home with items and item revisions

Pin to Home uses the same rules as Add to Favorites.

Let's look at a few examples to see how Pin to Home works with the following scenario.

Item 026355

Item revision 026355 revision A (superseded revision)

Item revision 026355 revision B (superseded revision)

Item revision 026355 revision C (configured revision)

Revision rule = Latest Working

If you pin to home Then this is what you see on the home
page.

Example 1 Item- 026355 Item revision- 026355 revision C

(the configured revision)

Example 2 Item revision- 026355 revision C

(the configured revision)

Item revision- 026355 revision C

(the configured revision)

Example 3 Item revision- 026355 revision C

(the configured revision) and then make a
revision D.

Item revision- 026355 revision D

(the new configured revision)

Example 4 Item revision- 026355 revision A

(a superseded revision)

Item revision- 026355 revision A

(a superseded revision)

Example 5 Item revision- 026355 revision B

(a superseded revision)

Item revision- 026355 revision B

(a superseded revision)

Superseded icon

Item revisions that have been superseded and are no longer the configured item revision are labeled
with a visual indicator. Hover on the visual indicator and you see information about the configured
revision.

How items and item revisions work with Favorites and the home page
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How dynamic item revisions work in folders, item relations, and paste actions

The system can be configured by your administrator to only show the most recent item revisions in
folders and tables, such as in the attachments for an object. If this is enabled, and you have your revision
display rule set to Latest, you only see the most recent item revisions, even if the revision you originally
pasted into a folder or related to an object has changed since you added it.

Note:

Revisions are displayed based on your revision display rule. Because of this, different revisions may
display for your selection based on which rule you choose.

Keep the following in mind about how revisions appear when dynamic revisions are enabled:

• If you relate a non-configured or out-of-date revision, then this revision is related and the displayed
revision does not change.

• If you relate a configured revision, then the item is related and the displayed revision automatically
changes to your currently selected configured revision.

Folders

Items in your folders that you or other users revise are automatically updated to the most recent
revision. This allows you to always see the most current revision of your items when browsing through
your folders.

For example, you create a new document in your home folder that is revision A. Later, you revise this
document and it is now revision B. The next time you browse your home folder, the new revision B
displays. You can then select the item and view previous revisions on the History tab if necessary.

4. Working with data
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Note:

Automatic updating of item revisions in folders is enabled by default. Your administrator can
change this to prevent items from automatically updating to the new revision. In that case, any
non-configured or out-of-date revisions pasted into your folders display with a warning icon letting
you know the revision is not current.

Viewing a table

When you view a table, the display of items and item revisions depends on whether or not the table Is
controlled by revision rules defined by an administrator, and if revision rules are defined, which one you
select in your session settings.

• If an item is present in a table controlled by revision rules, the table displays the item revision selected
by the rules.

• If a specific item revision is present in a table controlled by revision rules, then that revision is always
displayed regardless of any revision rules.

• If a table is not controlled by revision rules, the table displays what is present, whether that is an item
or an item revision.

Note:

An administrator must configure how tables show revisions as described in Active Workspace
Customization: objectSet tables and revision rules.

How dynamic item revisions work in folders, item relations, and paste actions

Retail Footwear and Apparel ─ Fundamentals, Teamcenter 2412  4-5
© 2025 Siemens



Relating an item revision by copy and paste

When you paste a copied item revision into a table:

• If the target table is not controlled by revision rules, then the copied item revision is pasted.

• If the target table is controlled by revision rules and the pasted item revision does not match the one
that the revision rule would have chosen, then the copied item revision is pasted.

• If the target table is controlled by revision rules and the pasted item revision does match the one
chosen by the rule, then the item itself is pasted.

Access your content quickly

Use Quick Access  to quickly view objects you recently worked with, data saved to the clipboard, and
data tagged as favorites from any page.

Note:

This command is hidden by default in some Workspaces. Administrators may also hide it
elsewhere in the system configuration.

• Navigate to Quick Access from the global navigation and select Quick Access .

Tip:

Assuming the command is not hidden in the configuration, you may need to select More
Commands  to reveal the command. This can depend on your screen resolution and how
many other commands are configured to appear in the navigation panel.

• Easily view the content by expanding and collapsing the three sections of data.

• Drag items from Quick Access  to places like your home folder or to a product structure.

• Select items in the panel to work with.

Open a part, document, or other object

To view or otherwise work with a data object you need to open it. Once opened, you can view detailed
information such as properties, access attachments, and perform various operations.

1. Select a part, document, or other object you want to open.

2. Click Open  on the selection tile.

4. Working with data
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Note:

You can also make a selection and click Open   > Open in New Window  or Open in New
Tab  from the primary toolbar.

Based on your browser settings, an attached file attached may open immediately, or you may be
prompted to download or save the file.

Note:

If an administrator has enabled the Data Share Manager, a dialog box may appear asking you
to install the Data Share Manager on your client to manage file uploads and downloads.

Create / Add a part, document, or other object

If you have the requisite user permissions you can create new data objects.

1. Open the folder in which you want to create a new object such as a part or document.

For example, open your Home folder.

2. Select More Commands  > New   > Add .

The Add panel opens.

3. (Optional) To keep the Add panel open so that you can continue to add objects without opening
the panel each time, click Pin Panel  to pin the panel to your workspace.

You can click Unpin Panel  to unpin the panel from your workspace.

Create / Add a part, document, or other object

Retail Footwear and Apparel ─ Fundamentals, Teamcenter 2412  4-7
© 2025 Siemens



4. Select the type of object you want to create from the Type list. The most recently used types are
displayed at the top of the list.

You can also search for a type using the Search box.

The types that display are configured by the system administrator.

If you are creating a new attachment, you can upload an existing file as an attachment to the
new object. In the FILE ATTACHMENTS section of the Add panel, click Choose File and select the
desired file. The system automatically sets the type to the file type that matches the file extension. If
there is more than one choice, it selects the configured default, but you can change the selection.

Note:

If an administrator has enabled the Data Share Manager, a dialog box may appear asking you
to install the Data Share Manager on your client to manage file uploads and downloads.

5. Enter properties.

The properties vary depending on the type being created. These properties are configured by style
sheets, which are maintained by the administrator.

Add is highlighted when all required fields are entered.

6. Click Add.

The newly created object is placed at the top of the current list, list with summary, or table display
for easy access. If you create a single new object, the object is automatically selected. The object is
placed in the expected sort order once you navigate away from this location or apply filters.

Note:

If you pinned the panel to your workspace, the Add panel remains open, the Revision and
Name values carry forward, and the ID value increments.

Add a classified object to a selected folder

The Classification tab allows you to search for classified objects. If you want to classify objects, open the
Classification location.

1. Select the folder to which you want to add a classified object.

2. Click New   > Add .

If you don't see the command, click More Commands  in the global header.

4. Working with data
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3. Click the Classification tab .

4. Select a class and drag the pane  to twice its width to display search results or to select the
Filter button to further refine the results.

Add a classified object to a selected folder
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5. Drag the pane to three times its width to view the classification properties of the selected object.

4. Working with data
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6. Click Add to add the classified object to the folder.

Change ownership of a data object

Data objects are assigned an owner. By default, the user who creates an object is the owner, but
ownership can be changed. You can only change the owner of an object if you have appropriate
permissions, including the Write permission.

Ownership of related objects

Many objects have related objects. When you change the ownership of an object that has related
objects, the ownership of some or all related objects may need to transfer to the new owner at the same
time. There are two options for transferring ownership:

1. Automated rule-based ownership transfer. Your administrator defines system-based rules that
govern ownership transfer of related objects when the ownership of the parent object changes.
Your administrator should publish these rules, and you should understand them before changing

Change ownership of a data object
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the ownership of an object. If there are many related objects this is the fastest option, provided
that the rules deliver the desired outcome.

2. Manual control of ownership transfer. When changing the ownership of an object that has related
objects, you can explicitly transfer ownership of some, all, or none of those related objects to the
new owner. This action overrides the ownership transfer rules defined by the administrator. This
method can be time consuming if there are many related objects.

Procedure

1. Select one or more objects.

2. Click More Commands  > Manage   > Change Owner .

3. In Change Owner, select the new owner in the User section.

You can use the search box to search the list for a specific user. You can Filter  the Users list by
type, group, or role. Ownership of all related objects will transfer to this user along with the parent
object.

4. If you want to transfer ownership of all related objects according to the administrator-defined rules,
click Change and skip the remaining steps.

5. If you want to explicitly specify ownership of related objects, expand Related Objects.

Any related objects appear in a table.

4. Working with data
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6. If related objects are displayed, select the ones whose ownership you want to change and deselect
the ones whose ownership you do not want to change.

7. Click Change.

You can see the change of ownership in the object Properties.

Note:

You cannot change the owner of the following object types:

• Answer

• Att0MeasurableAttributeInt

• Comment

• CostValue

• Fixed Cost

• RateModifier

• Rating

• Required Qualification

• ResourceAssignment

• Schedule

Change ownership of a data object
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• Helpful

• Measurable Attribute

• Measurable Attribute Boolean

• Measurable Attribute Double

• Measurable Attribute String

• Proxy Task

• Question

• Schedule Audit

• Schedule Deliverable

• Schedule Member

• Schedule Task Deliverable

• ScheduleTask

• Task

• TaskDependency

Check out and check in data objects

Before you can modify an object or its properties you must check it out. Other users cannot modify an
object that is checked out to you. When you finish working with an object you have checked out, you
should check it in.

You need to be granted the requisite permissions to be able to check out objects.

1. Select a part, document, or other object you want to check out. For example, select something
from the list of search results.

2. Click More Commands  > Edit   > Check Out .

The selection displays a Checked-Out property set to Y.

To check a selection back in, click More Commands  > Edit   > Check In .

To cancel the checkout, click More Commands  > Edit   > Cancel Checkout .

Also see Check out and check in objects when using Multi-Site Collaboration.

Edit data object properties

You can modify the properties of parts, documents, and other objects provided you have the required
permissions. You can edit properties in various panels and tables.

The properties you can edit vary based on how your administrator configured the style sheets.

1. Open the part, document, or other object whose properties you want to edit.

4. Working with data
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2. Select More Commands  > Edit   > Start Edit .

The Edit  button appears only when you select something you can modify. In some panels, such
as the Information panel, an Edit  button is available for quick edits.

Tip:

To retain changes you must click Save before you navigate away.

The properties that you can edit are enabled for editing.

3. Type or modify the properties as necessary.

When you modify a property value, the field background changes color to indicate that your edit
has not been saved.

4. Select More Commands  > Edit   > Save Edits  to save your changes.

To cancel your edits, you can select More Commands  > Edit   > Cancel Edits .

Add multiple language properties for an object

When you are viewing the properties for an object some fields, such as the Name and Description,
allow you to edit the localization information for those fields to add additional languages for the
property. In addition, you can also set the status of the additional languages to track if they are pending,
approved, or invalid.

Add multiple language properties for an object
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1. When viewing the properties for an object, click Edit Localization  next to the property you want
to add different languages to.

The Edit Localization panel opens. The Master Value section of the panel displays the property
you are editing and it's default language.

2. In the Translation Languages section, click Add  to display a list of available languages.

4. Working with data
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3. From the list of languages, click the checkbox next to each language you want to add to the
property. For each language you select, a new row is added in the panel.

4. Enter the translation text for each language and set the Status as necessary. You can choose to set
the status to Approved, Pending, In-Review, or Invalid.

5. Click Save to save your changes and close the panel.

Delete a translated property value

You can delete a translated property value when it is no longer needed.

1. When viewing the properties for an object, click Edit Localization  next to the property with the
language you want to delete.

2. In the Translation Languages section, click Remove Language  next to the language you want
to remove.

Alternatively, you can also deselect a language from the list of available languages to remove its
translation.

3. Click Save to save your changes and close the panel.

Modify a table property

Properties identify specific characteristics about an object, such as the color and trim package of a
selected make and model of car. Certain object properties are best represented using an editable table
format. This topic describes the available editing actions available to you.

For example, a table format is useful when collecting repetitive data such as employee contact
information. Table properties can be found anywhere that a property can be located, but most often
table properties are located on the Overview or Table Property tab.

Modify a table property
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Note:

A table property is defined and configured in the Business Modeler IDE by an administrator. Some
table properties may be configured to be noneditable, in which case, the following steps do not
apply.

You can complete the following actions on a table property:

Add a row

1. Open an object such as an assembly.

The properties of the object display in a table.

2. Click Edit  .

3. Click Add   to add a row to the property table.

4. Add the appropriate data in the cells of the new row.

5. Click Edit   > Save Edits .

Remove a row

1. Open an object such as an assembly.

The properties of the object display in a table.

2. Click to highlight the row to delete.

3. Right-click and select Remove .

Duplicate a row

1. Open an object such as an assembly.

The properties of the object display in a table.

2. Click Edit  .

3. Click a cell in the row to duplicate.

4. Click More Commands  > Duplicate .

5. Make any changes to the data in the cells of the duplicated row.
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6. Click Save Edits .

Modify data in a row

1. Open an object such as an assembly.

The properties of the object display in a table.

2. Click Edit  .

3. Click each cell to modify the data in that cell.

4. Click Edit   > Save Edits .

Define properties in addition to the object's configured properties

You can add properties to objects that are in addition to the configured properties. For example, in an
automotive environment you can define variable properties for each vehicle, such as model, weight, and
manufacture date. Or in a shipping environment, you can define a package's weight, shipping address,
and size. These are properties that are defined ad hoc and associated with the object.

This functionality must be configured by an administrator.

1. Search for the object using the search box, or navigate to it in your folder structure.

2. (Optional) Filter the list to quickly find the desired object.

3. Click Open .

4. Click the appropriate tab.

The tab reflects the name defined by your administrator for your organization. Most often, the tab
name reflects the type of information you are defining.

5. Click Edit .

6. Click Add .

7. In the Create panel, define the Type, Name, and Value for the property you are adding. Refer to
the five supported property types in the following list.

Note:

The field values that display on the Create panel reflect the selected Type and Value, where
Name is the name of the property you are defining.

Define properties in addition to the object's configured properties
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You cannot define the same name for multiple property types.

Type Value
String An alphanumeric character string.
Double A numeric value containing a decimal point.
Boolean A binary variable; either true or false.
Date A date and time selected from the calendar and time pickers.
Integer A numeric value

8. Click Add.

The name and value are added to the table.

9. Click Save .

Autofill properties in a table

Copy the content of a selected table cell to a range of cells above or below the selected cell.

1. Display the table and click Edit  .
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2. In the table, select a cell and, if the cell is empty, enter the content to be copied.

3. Move the mouse cursor over the cell to display the small fill-down box in the lower-right corner of
the cell, then place the cursor over the small box to display the large plus sign (+).

4. With the plus sign displayed, press the left mouse button and drag up or down to select the cells to
fill.

5. Release the mouse button.

6. Click Save  to save your changes.

The changes are saved, except for objects that you do not have Write privileges to modify
properties.

Autofill properties in a table
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Drag objects between browser windows

You can copy some objects by dragging them between windows of the same browser. You can open
some objects by dragging them between windows of different browsers.

Copy or open parts, documents, or other objects from a location loaded in one browser window to
another accepting object or location in another browser window.

Tip:

When dragging an object, click, hold, and move the object in a single fluid motion. If you do not
move quickly enough, the system assumes you want to select multiple objects.

If dropping onto a location or object is not allowed, the cursor displays a cancel  symbol.

Drag to copy

You can drag an object between two windows of the same browser (Google Chrome, for example),
when both windows are running Active Workspace, to copy the object from one window to an accepting
object in the other. An accepting object is one that supports a relationship with the object being
dragged. You cannot copy by dragging objects between windows of different browsers - between
Google Chrome and Mozilla Firefox, for example.

Drag to open

You can use drag between windows of different browsers (between Firefox and Chrome, for example) to
open a selected part, document, or other object.

For example, you can select an object, such as a part or document in a list, and drag that object to the
URL address box in another browser. This opens Active Workspace in the second browser's window and
opens the object there.

Drag objects in lists and tables

You can drag one or more parts, documents, and other objects from, to, or within tables and lists rather
than performing copy and paste operations.

• Drag into an accepting list or table to create a new entry in the list, or a new row appended to the end
of the table.

When you drag, you see an outline around the target table or list indicating where you are allowed to
drop.
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• Drag onto an accepting object (table row or list item.) In this case, the accepting object highlights
indicating where you are allowed to drop.

Tip:

When dragging an object, click, hold, and move the object in a single fluid motion. If you do not
move quickly enough, the system assumes you want to select multiple objects.

An accepting object is one that supports a relationship with the object being dragged and
dropped. If dropping onto a location or object is not allowed, the cursor displays a cancel 
symbol.

You can drag one or more objects onto a table to create a new table row.

1. Drag the object to the target table's header row.

A bounding box appears to indicate you can create a new row with the dragged object.

2. Release the object to create the new table row.

You can drag parts, documents, or other objects onto an accepting table row and have that row create
appropriate relationships to those objects.

For example, you can release a dragged document onto a part in a table, and the document becomes a
child of the part.

Drag objects in lists and tables
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Create alias IDs and alternate IDs

Alias IDs and alternate IDs allow you to better manage your part data, such as supplier part numbers,
customer naming standards, and legacy part names. Alias IDs and alternate IDs are associated with the
Teamcenter object. You can then search and filter for these IDs to quickly find the objects, or set your ID
Display Rule to display them as you work with a part.

Note:

When creating an alias ID or alternate ID, you must choose an ID context. This is configured by
your administrator.

Create an Alias ID

An alias defines the ID of an object you do not have direct control over, such as supplier part numbers.
It can also be used when the same ID can be applied to more than one object, such as a service part
number. You create an alias when the part is similar to the current part and it can be used as a substitute
in the product structure.

1. Search for and open the item revision you want to create the alias ID for.

2. Click More Commands  > New   > Create Alias ID .

The Create Alias ID panel opens.

3. Choose the Context and Type for the alias ID and enter the ID properties.

4. Click Create.

The related object now shows the newly created alias ID in the ALIAS IDS section of the Overview
tab.

Create an Alternate ID

An alternate ID defines additional IDs for an object. However, the alternate ID relates to only one unique
identifiable object. Alternate IDs are often used to create different part numbers as an object evolves or
to create a part number for a part used across multiple organizations. You create an alternate ID when
the part is identical to the current part and you want to create your own naming scheme instead of
using the existing one.

1. Search for and open the item revision you want to create the alternate ID for.

2. Click More Commands  > New   > Create Alternate ID 

3. Choose the Context and Type for the alternate ID and enter the ID properties.
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4. Click Create.

The related object now shows the newly created alternate ID in the ALTERNATE IDS section of the
Overview.

Creating new data or revisions from existing data

Creating new data from existing data

Data items in Teamcenter are called objects. An object describes a part, assembly, design, document or
other entity stored in your system. You can create new objects from existing objects and new revisions
of existing objects.

By default, a new object or revision includes all objects related to the original existing object. However,
you can review and specify the disposition of all related objects during the process of creating a new
object or revision. For example, if you want to create a new assembly from an existing assembly, or
a new revision of an existing assembly, you can specify what happens with all its parts, including
subassemblies and their parts.

You can:

• Specify a name and description for the new object.

• Include or exclude related objects such as parts or documents.

• Reference objects related to the original object rather than copy them as new objects. (In a new
revision, a reference can optionally point to the latest revision of the related object.)

• Save related objects as new related objects, each with a new ID, name and description.

When viewing an opened object, Advanced Copy Options in the Save As dialog box and theRevise
dialog box contain a table where you specify your choices for the new object or revision, respectively.

The Action column specifies the disposition of all objects that are related to the object being saved as a
new object.

Creating new data from existing data
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Related topics

• Create a new object from an existing object

Creating new data from existing data
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• Create a new revision of an existing object

• Introduction to objects and object types

Create a new object from an existing object

Data items in Teamcenter are called objects. An object describes a part, design, assembly, document
or other entity stored in your system. You can create new objects from existing objects. By default, the
new object contains references to all objects related to the original existing object. You can review and
specify the disposition of the related objects during the procedure.

Related topics:

• Creating new data from existing data

• Create a new revision of an existing object

• Introduction to objects and object types

Procedure

1. Open the object from which you want to create a new object. If the object has multiple revisions,
select the revision on which to base the new object.

2. Click More Commands  > New  > Save As .

The Save As panel opens.

3. Enter a name for the new object in the Name box.

4. Enter a description of the new object in the Description box.

5. If you want to change the default disposition of some or all related objects in the new object,
click Advanced Copy Options, review the table of related objects and make changes in the Action
column.
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The available actions for related objects are:

• Remove: The selected related object will not be included in the related objects of the new
object.

Create a new object from an existing object
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• Reference: Create a reference to the current revision of the related object in the related objects
of the new object. This is the default for all related objects.

• Save As: Create another new object related to the new object with the same relationship.

6. In the Projects section, click Add Project , select a project as owner of the new object, and click
Assign.

Tip:

You can use Search to filter the list of projects.

7. Click Save to create and save the new object.

Create a new revision of an existing object

Data items in Teamcenter are called objects. An object describes a part, design, document or other
entity stored in your system. You can create new revisions of existing objects using Active Workspace. By
default, the new revision contains references to all objects related to the original existing object. You can
review and specify the disposition of the related objects during the procedure.

Related topics:

• Creating new data from existing data

• Create a new object from an existing object

• Introduction to objects and object types

Procedure

1. Open the object for which you want to create a new revision.

2. On the Primary toolbar, select More Commands  > New  > Revise .

The Revise panel opens.

3. Optionally modify the Revision, Name and Description.

These inputs are automatically populated when the panel opens.

4. If you want to change the default disposition of some or all related objects in the new object,
click Advanced Copy Options, review the table of related objects and make changes in the Action
column.
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The available actions for related objects are:
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• Reference: Create a reference to the current revision of the related object in the new revision
(the default for all related objects). If the referenced object is subsequently revised, the new
revision (of the existing object) will not see revisions of the related object.

• Save As: Create a new related object in the new revision.

• Remove: The related object will not be included in the new revision of the existing object.

• Revise: Create a new revision of the related object in the new revision of the existing.

• Reference latest: Create a reference to the latest revision of the related object in the new
revision. If the referenced object is subsequently revised, the revision you are creating will always
see the latest revision of the related object.

5. In the PROJECTS section, click Add Project , select a project as owner of the new object, and
click Assign.

Tip:

You can use SEARCH to filter the list of projects.

6. Click Revise to create and save the new revision.

Working with attachments

Add attachments to a data object

You can attach files and documents to data objects. You can add existing items via search or by selecting
from recently viewed or favorite objects. You can optionally attach a new object that you create during
the attachment procedure.

1. Locate and open the object to which you want to attach another file or document. For example:

• Perform a search and select something in the search results list.

• Select an inbox task.

• Open a folder where you want to add an object.

2. Locate the Add to  icon in the work area of the Overview tab.

For example, in the default configuration there is an Attachments tab for item revisions. This tab
has Files and Documents sections to which attachments can be added.

3. Click Add to  to display the Add panel.

4. Working with data

4-32  Retail Footwear and Apparel ─ Fundamentals, Teamcenter 2412
© 2025 Siemens



4. In the Add panel, choose the objects you want to add by doing one of the following.

• Click Search.

The search only returns results that you can relate to the displayed item. You can also filter search
results in the task panel.

• Click Palette to select from the Favorites, Recent, or Clipboard sections.

The Clipboard section displays objects previously copied to the paste buffer using Copy .
These are preselected at this point. Otherwise, select the desired objects.

• Click New to create a new object:

a. Select the type of object you want to create either from the list of recently used object
types or from the full list of available object types. You can also refine the results using
Filters.

If you are creating a new file attachment, you can upload an existing file as an attachment
to the new object. Click the Select File button and select the desired file. The system
automatically sets the object type to the file type that matches the file extension. If there is
more than one choice, the system selects the default. You can change the selection.

b. Enter the properties for the new object.

The properties vary depending on the type of object being created. These properties are
configured by style sheets, which are maintained by the system administrator.

Note:

Required properties are designated with a red asterisk next to the text box.

5. (Optional) When multiple relation types are available for the object being added, select the desired
relation from the list displayed at the bottom of the Add panel.

The available options vary based on the object set selected.

6. Click Add.

Replace an attached file or document

You can replace an attached file when it is out of date and no longer relevant to the item is it attached
to. You can replace the attachment with an updated version of the file or with a different file altogether.

1. Search for and open the object with the attachment you want to replace.

Replace an attached file or document
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2. Click the Attachments tab.

3. Select the attachment that you want to replace.

4. Click More Commands  > Edit  > Replace File .

The Replace panel is displayed.

5. Click Select File to select the file to replace.

6. Click Replace.

Replace an attached document

In addition to replacing attached files for an object, you can also replace attached documents.

1. Search for and open the object with the document you want to replace.

2. In the Documents section, select and open the document you want to replace.

The Overview tab for the document is displayed.

3. In the Files section, select the file you want to replace.

4. Click More Commands  > Edit  > Replace File .

The Replace panel is displayed.

5. Click Select File to select the file to replace.

6. Click Replace.

Replace files using Data Share Manager

If you have Teamcenter Data Share Manager installed perform the following steps to replace files.

1. To display the attachments for an object, open the object.

2. Click the Attachments tab.

3. Select the dataset to replace.

4. Click More Commands  > Edit  > Replace File to display the Replace panel. If you are
replacing a single file, the Data Share Manager application window is displayed.
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If you are replacing a file in a dataset that has multiple files, select the file in the Replace panel and
click Replace. The Data Share Manager application window is displayed.

5. In the Data Share Manager application window, locate or enter the replacement file. Then, click
Upload. The selected file is uploaded and replaces the previously attached file. The Data Share
Manager displays the upload status.

Note:

See Upload or download large data files for more information on using Teamcenter Data Share
Manager without leaving the client environment.

Find more information about the Data Share Manager in System Administration→File Management
System in the Teamcenter help collection.

Download and open attached files

You can download attached files and potentially open them in the same operation, depending on
browser settings. You can optionally download multiple files in a single download operation.

1. Display an object that has attachments.

2. Select the attachment.

3. Do any of the following:

• Select the attachment and click Download File .

Based on your browser settings, the file may open immediately or you may be prompted to
download or save the file.

Note:

To open attachments in the Safari browser, be sure to turn off the pop-up blocker. This is
especially true on iPads running Safari.

• Right-click the attachment and then select Copy File Download Link  to copy the download
link to the Teamcenter and OS clipboard. You can then share the link with others, or paste it into
your browser's address bar to download the file.

Note:

If your administrator has enabled reference lists, such as in a table for an item revision
and its subtypes, on the Information panel of an attachment, or in the Properties of an

Download and open attached files
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object and its subtypes, all referenced files are hyperlinks. You can click the link to quickly
download the referenced file.

Download multiple files at once

1. Display an object's attachments.

2. Do any of the following to select multiple files:

• Ctrl-click each file you want to select.

• Click Selection Mode and then click the check box next to each file you want to select.

• Click Select All to select all files.

3. Click More Commands  > Share   > Download .

A message appears showing you how many of the selected files were downloaded.

Note:

The saved location of the downloaded files and the ability to download more than one file at a
time varies depending on your browser and its settings.

View and download previous file versions

You can view and download previous file versions of files displayed in the Attachments tab for an object,
or when viewing the properties of the attachment. This allows you to download old file versions, or
restore an older version so it becomes the latest version of the file.

1. Search for an object and then navigate to the Attachments tab.

2. In the FILES section, select the attached file with the previous version you want to view.

3. Click More Commands  > View   > Show Dataset Versions .

You can also use the above command when viewing the properties for an attached file.

The Dataset Versions panel opens.

4. In the VERSIONS section, select the file version to view its properties and a preview of the file.

5. Do any of the following as necessary:

• Click Download Version to download the selected version to your computer.
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• Click Restore Version to make the selected version the latest version of the file. A new version is
automatically created and displayed in the VERSIONS section.

6. Close the Dataset Versions panel when you are finished.

Open related drawings

You can view drawings attached to an item revision in the Attachments of an open data object.

1. Open an object that has drawings attached to an item revision.

2. Select the desired item revision and then select Open .

3. Select the Attachments tab.

All of the drawings related to the item revision appear under Files.

View and mark up your attachments using the universal viewer

Use the universal viewer to view object attachments. The universal viewer appears in an object's
Overview tab if there are attachments for the object, or in a workflow task's Overview tab if there
is an associated attachment. The universal viewer can appear in other areas, depending on how your
administrator has configured Active Workspace for your site.

The universal viewer supports the following file types.

• PDF- Markup is available.
• Text
• HTML- Markup is available.
• Microsoft Office files- Editing is available depending on how Office Online configuration is set up.
• Image (JPEG, PNG, GIF, BMP, SnapShotViewData, and UGMASTER)
• Direct Model

Note:

The file types and the functionality supported will depend on how your administrator configures
the universal viewer for your site.

Open related drawings
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Example of an image with the universal viewer

1 The document header identifies the document's name, file type, and last date and
time the document was modified. Click the document name to open the file.

2 The work area toolbar contains the commands specific to the type of file or document
displayed.

3 If a selected object has multiple attachments, click  or  to scroll backward and
forward through all the attachments.

4 Review the document or file image that is displayed the viewer.

4. Working with data

4-38  Retail Footwear and Apparel ─ Fundamentals, Teamcenter 2412
© 2025 Siemens



Example of a PDF document with the universal viewer

Your options using the universal viewer vary, based on the type of file you are viewing. Typical
commands on this toolbar include the following.

Markup You can mark up a PDF or image file from within the
universal viewer.

Create Highlight Markup Mark up a text by highlighting it.

Create Freehand Markup Mark up a document by drawing freehand.

Checkout Check out an Office document so it can be edited.

Cancel Checkout Cancel the check out on an Office document and throw
away any changes.

View and mark up your attachments using the universal viewer
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Checkin Check in the Office document to save any changes. There is
no separate save command necessary.

Full Screen View the Office document in full-screen mode. This allows
the universal viewer to take over the full browser window
for the display.

Upload or download large data files

The Teamcenter Data Share Manager (DSM) application provides a way for you to upload and download
large data files without interrupting your work.

The following apply:

• You can close the client application window and the browser while the DSM is loading file data
without interrupting the loading process.

• The DSM application automatically resumes loading data after interruptions, such as network or
power outages.

Note:

You (or your administrator) must install the DSM application on your machine, and you
must have a valid license key. Find DSM installation and detailed user instructions in System
Administration→File Management System in the Teamcenter help.

Before using the Data Share Manager

1. Ensure that the Data Share Manager and a license key are installed on your local machine. Contact
your administrator for assistance.

2. Ensure that your Data Share Manager user session values are selected in Active Workspace.

a. Click your profile icon.

b. In the panel that opens, select Manage Profile.

c. Under Data Share Manager, make sure that the Data Share Manager is installed on this
device and Use Data Share Manager on this device check boxes are selected.
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Note:

These values remain selected until you clear your browser cache or change browser
applications. If you clear your cache or switch to a different browser, you must select these
values again before using the DSM.

Upload a large data file

1. Navigate to the object to which you want to upload the data file.

2. Click the Attachments tab.

3. Define the data file type that you want to upload (for example, PDF, Word, or Excel).

a. Click Add to .

b. In the Add panel, select the file type of the data file that you want to upload.

c. In the Name box, define the name of the file you want to upload.

d. Click Add.

4. In the message that appears on the window, click Open.

5. Select the desired file to upload.

a. From the task bar on your computer, open the Data Share Manager application window.

b. In the Data Share Manager application window, enter the path or file location, or click … to
navigate to the file to upload, and then click Upload.

The collapsed Data Share Manager window appears at the bottom of your window, showing
the number of files that you have uploaded or downloaded.

6. Click Open in the Data Share Manager window.

Upload or download large data files
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7. Use the Data Share Manager application to manage your uploaded files. Find information about the
Data Share Manager in System Administration→File Management System in the Teamcenter help.

Download a large data file

1. Navigate to the object with the attached data file that you want to download.

2. Click the Attachments tab.

3. Click Download File  on the file that you want to download.

4. Click Open on the message that appears on the window.

The collapsed Data Share Manager window appears at the bottom of your window, showing the
number of files that you have uploaded or downloaded.

5. Click Open on the Data Share Manager window.

6. Use the Data Share Manager application to manage your downloaded files. Find more information
on the Data Share Manager in System Administration→File Management System in the
Teamcenter help.

Working with named references

Named references overview

Named references are objects that relate to a specific data file. In other words, a named reference is a file
attached to a Teamcenter dataset.

• Datasets are Teamcenter data objects that manage data files (operating system files) created by other
software applications.

• Each dataset can manage multiple operating system files as separate "named references".

• Active Workspace has some support for Teamcenter datasets, named references, and dataset tools.

• Teamcenter administrators can define named references and optionally restrict some file types from
being uploaded to a dataset.

For more information see Upload, download, and export named references.

Upload, download, and export named references

Named references are objects that relate to a specific data file, normally an attachment. The named
references for an opened attachment object appear in the Named References tab of the Information
panel. You can run upload, download and export operations on named references.

4. Working with data
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Prerequisites

To download or export named references, an object must have one or more attachments, and a selected
attachment must have one or more named references.

Procedure

1. Locate an object such as a part and open it.

2. On the work area toolbar, select Attachments.

The Files section displays existing attachments as tiles.

3. In the Files section, select an attachment tile.

4. On the primary toolbar, select Information  to open the Information panel.

5. In the Information panel, select the Named References tab.

Results

Named references appear in a table. You can now select a named reference and run any of these
commands:

• Download  selected files.

• Upload  a file to the selected dataset.

You can run the commands from the Named References toolbar. Its appearance can vary according to
your screen resolution.

The commands may appear as icons only or icons plus a text label. Some icons may be hidden if there
is insufficient space, in which case an ellipsis (…) appears on the toolbar. Select it to reveal hidden
commands.

Tip:

Resizing the Information panel wider can reveal hidden commands on the toolbar.

Upload, download, and export named references
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Exploring relations between objects

Using Relations

You can use Relations to view objects and the relations between objects in a graphical format.

• See or hide incoming and outgoing relations.

• Choose what objects or relations appear in the work area. You can do this by using the Legend panel
or by applying filters based on object properties.

• Use an overview map to navigate large structures.

• Change the layout of the network display.

Tips for using Relations

• Double-click the background to resize the network to fit all content in the display.

• Use the left mouse button to drag the network around the display area. To move an individual object,
click the object first and then drag it using the left mouse button.

• Use the roller on your mouse to zoom in and out of the network. The more you zoom in, more
detailed information is displayed.

• Point the mouse over an object in the network to display additional details, such as the object name.
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• Point the mouse over an edge (that is, a line connecting two objects) to display the type of
relationship between the objects.

• Select an object, edge, or port and then click Info  to get more information about it.

You cannot see the  button if the edge has no properties.

• To print a network, click Open in...  to open in print view.

View data related to an object

This topic explains the procedure for viewing data related to an object.

1. Search for an object using the search feature.

2. From the list of search results, select the object for which you want to view the related data.

This is the root object.

3. Select Relations.

By default, the object and its immediate relations appear.

View data related to an object
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Tip:

Depending on your display resolution and the size of your browser window, Relations may
be hidden. Click the chevron to expose it.

You can do the following actions:

Action Ways to perform the action

Expand and collapse objects Click arrows inside the objects to expand or
collapse incoming relations

Click arrows inside the objects to expand or
collapse outgoing relations

Use the one-step command bar

Show and hide objects Using Legend

Clicking the icon of the object

Make hidden objects visible Using the Relations panel

Filter objects Using the Filter panel

Highlight objects Using Legend

In the diagram, highlight objects that have
relations going in the same direction.
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Action Ways to perform the action

Navigate the diagram Using the overview map

Change the layout of the diagram Using the layout command

4. Click the arrows inside the objects to show or hide relations:

Shows all the incoming relations.

Shows all the outgoing relations.

Hides the incoming relations for the object.

Hides the outgoing relations for the object.

Hides all the incoming relations or shows all the incoming relations, as applicable.

Hides all the outgoing relations or shows all the outgoing relations, as applicable.

5. You can also show incoming and outgoing relations from the one-step command toolbar as
follows:

Select an object and click one the following buttons in the one-step command toolbar.

Shows incoming relations. In the list that appears, select the number of levels to be
displayed.

Shows outgoing relations. In the list that appears, select the number of levels to be
displayed.

6. Click the icon of an object to hide the object.

The object fades away until it is hidden. You can cancel the hide action by clicking its icon again
before it is hidden.

View data related to an object
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7. To show the object that you hid by clicking on its icon or to hide objects in the graph, select an
object and click Relations .

In the Relations panel:

• Objects whose icons are grayed out are hidden in the graph. Click the objects to make them
visible.

• Objects whose icons are not grayed out are visible in the graph. To hide objects, click them.

8. Using the Legend panel, you can highlight and hide objects and relations.

Click Legend  to display the Legend panel and then click Views.

The colors of the object types and relations listed in the Legend panel correspond to those of the
object border and edges, respectively, in the work area.

1. Click the colored square next to the object or relation
name to hide or show objects or relations in the work
area.

Note:

The root object cannot be hidden. Orphan objects,
that is, objects whose predecessors are hidden, are
also hidden.

2. Select the object or relation name to select the object or
relation in the work area.

Use Ctrl + click in the menu to select multiple objects or
relations.

If you select or undo the selection of an object in the
work area, the corresponding object type is selected in or
cleared from the Legend pane.

When you expand a selected object in the work area, all
other selections for objects are cleared.

3. The number within the parentheses denotes the number
of expanded objects or relations that are visible.

The  icon at the bottom right corner indicates that objects and relations are hidden in the graph.
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9. You can choose the objects that you wish to see in the work area by filtering them based on their
properties such as object type or owner.

a. Click Legend  to display the Legend pane and then click
Filter.

b. Click the property of the object that you want to use as a filter,
for example, under the Type property, click Item Revision.

c. To remove a filter, click the selected property.

Note:

The root object cannot be filtered out. Orphan objects, that
is, objects whose predecessors are hidden, are also filtered
out.

The  icon at the bottom right of the page indicates that a filter is
applied.

10. You can investigate the relations between objects at two ends in the diagram as follows:

a. Select an object in the graph.

b. Press the Shift key and select another object in the graph.

Objects with similar relations going in the same direction are highlighted.

11. Use the overview map to navigate easily in cases where there is a large network of objects and
relations.

Click the lower right corner of the work area to view the overview map of the network .

Move the rectangle in the overview map to browse the network.

.

12. Click  in the one-step command toolbar to change the layout of the network display.

You can display the content using various layout types, such as top to bottom and left to right.

View data related to an object
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Managing object relationships and traceability with trace links

Trace links overview

Traceability provides a connection between data objects. For Model-Based Systems Engineering, this
means connecting our structure elements together.

Trace links establish the traceability among structure elements and in which one object takes
precedence over another. A trace link establishes a directional relationship between two objects.

For example, creating links between requirements, between system model blocks, and between each
other. When the requirements and system modeling are complete, users have complete traceability
from requirements, to functions, to logical and physical objects allowing users to see the decision,
requirements and alternatives that lead to a particular design alternative.

The trace link Start (defining object such as a requirement), is the trace link source. The End (the
complying object such as a system model block), is the target. In this relationship, the Start defines a
condition with which the other End must comply, that is, must partially or completely fulfill.

Create a trace link

You can create trace links between objects such as requirements and system model blocks. You can
create a one-to-many or a many-to-one trace link relationship, but not a many-to-many relationship.

1. Ensure that you have the objects that you want to link in the results pane.

2. Click More Commands  > New  > Create Trace Link .

If you want to create multiple trace links, click Pin  in the Create Trace Link panel. Pinning keeps
the Trace Link panel open after you create a trace link. You can then create another trace link by
changing the Start or End objects.

3. Drag the selected objects to either the Start or End panels.

To remove an object from the trace link, select it in either the Start or End panel, and then click
Remove .

4. Select the Type, and then click Create.

Create a trace link using Copy and Paste

One way to create trace links is by using Copy and Paste.

1. Ensure that you have the objects that you want to link in the results pane.
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2. Select one or more objects, and then click  to copy the selected objects to the clipboard.

You can copy objects from one browser window and paste into another window.

3. Click More Commands  > New  > Create Trace Link .

4. Click Paste  in either the Start or the End panel.

5. Select the Type, and then click Create.

Sharing data

Sharing Teamcenter data with other sites

Product design and development often includes groups of people scattered across multiple locations.
Even with different responsibilities, these groups of people might rely on the same product data to
perform their roles.

• Several groups within your company might rely on having access to a project's latest updates as they
work on different aspects of the project. These groups may be on site or in other parts of the world.

• Outside organizations, such as suppliers supporting OEMs, may have similar data requirements. The
suppliers may need a mix of read and write access to the data as they may be responsible for the
development of certain parts of the project.

• Some groups may be downstream customers with applications that leverage your data as part of their
business processes.

• You may be combining or archiving existing sites as the company structure changes or projects are
retired.

Active Workspace provides several ways to share data to meet these needs:

Sharing Teamcenter data with other sites
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Typical uses of each data sharing solution

Data Sharing
Solution Typical Use
Multi-Site
Collaboration

A company has engineering sites in Tokyo and Detroit. They also have manufacturing
sites in Detroit. All of the sites are connected on a network.

The engineering sites regularly share data as they design and develop products. At
the end of each workday at the engineering sites (which are 11 hours apart), they use
Multi-Site to make sure each site has the most recent product data updates. When the
product development completes, the engineering sites use Multi-Site to push the final
engineering data to the manufacturing sites.

Briefcase and TC
XML

An OEM produces a complex product with a component that has its design
outsourced to a supplier. The supplier does not have access to the network the OEM
uses.

The OEM packages the component data the supplier is responsible for and shares
the Briefcase file using secure FTP. The supplier imports the data and updates it with
changes and new parts. The supplier then repackages the parts data in a Briefcase file
and sends it to the OEM for review and integration with the overall product.

PLM XML An OEM works with a supplier that uses a PLM solution other than Teamcenter. To
exchange product data, the companies need a common data format.

The OEM converts the relevant product data to PLM XML which has a published SDK
and uses a product-neutral data model. The supplier converts the PLM XML into the
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Data Sharing
Solution Typical Use

data model their PLM tools use, imports the data, and modifies it as necessary. The
supplier converts the modified data back to PLM XML and returns it to the OEM.

Bulk data
migration tools

A company has several organizations relying on Teamcenter for their daily work
activities. System availability is critical. The company plans to update Teamcenter and
Active Workspace to the most recent versions, but they want to ensure the updates
cause minimal down time.

The company creates a Teamcenter test environment using the updated versions of
Teamcenter and Active Workspace. They use the bulk extract tools to get a copy of the
product data from their production environment. They then use the bulk copy tools to
populate their test environment with the production data copy. There, they perform a
battery of tests to ensure the new versions of Teamcenter and Active Workspace work
as expected with their product data.

Where do I go from here?

 Administrator

Configure your organization for sharing objects
packaged in Briefcase files

See the section on how to configure Briefcase
file sharing.

Monitor any issues your organization may be
having when sharing Teamcenter data using
Multi-Site

See Multi-Site Dashboard to view the issues in
your Multi-Site federation using charts, graphs,
and detailed object reports.

Monitor your organization's history of
Teamcenter data sharing using Multi-Site and
Briefcase file

See Monitor data exchange transactions to view
and analyze your organization's history of Multi-
Site and Briefcase transactions using charts,
graphs, and detailed object reports.

Configure your organization for sharing
Teamcenter data using PLM XML

See the section on how to configure PLM XML.

Populate a Teamcenter environment with data Refer to the section on bulk loading product
data.

 Business User

Import or export Teamcenter data packaged as
Briefcase files

Get information on using Briefcase files.

Import or export Teamcenter data using the
open PLM XML interchange format

See the section on how to share data using
PLM XML.

Share Teamcenter data with others in your
organization using Multi-Site Collaboration

Refer to the section describing Multi-Site
Collaboration.

Sharing Teamcenter data with other sites
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Sharing data using Briefcase files

Using Briefcase files

You can collaborate with other sites by sharing objects using Briefcase files. Select the objects to share
with the other sites, export the objects to a Briefcase file, and provide that file to the other site. If you use
Briefcase checkout to allow objects to be updated at another site, the objects can be updated at that
site, returned to your site, and checked back in.

For example:

• Share data with Teamcenter supplier sites that are online (connected) or offline (unconnected). Other
sites can optionally update the objects and return them to you.

• Share data with Teamcenter sites in your own organization that are not connected (offline).

• Exchange data with organizations that are not using Teamcenter (unmanaged sites).

• Exchange data with Teamcenter sites using different data models than yours.

You can export objects of the types specified by your administrator. You cannot export objects using
Briefcase files in the design context when using Supplier Collaboration.

You can also view and analyze your organization's history of Briefcase transactions using charts, graphs,
and detailed object reports. See Monitor data exchange transactions.

Export objects using Briefcase files

You can share objects with other sites by exporting them to Briefcase files and providing the files to the
other sites. If you use Briefcase checkout to allow objects to be updated at another site, the objects can
be updated at that site, returned to your site, and checked back in.

You can export objects of only those types specified by your administrator.

Export data to a Briefcase file

1. If the target site is intended to modify the exported data, grant modification rights to the target site
using either Briefcase checkout to grant temporary modification rights (excluding revise rights) or
by transferring ownership of the objects.

2. Select one or more items or assemblies to be exported to the target site. These selections become
separate root items in the exported Briefcase.

3. Select More commands  > Import/Export  > Export to Briefcase  to display the Export to
Briefcase panel.
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4. Specify the export properties on the Export to Briefcase panel.

Property Description
Target Select Teamcenter if you are sharing data with a site managing its data with

Teamcenter.

Select Briefcase Browser if you are sharing data with an unmanaged site.
Unmanaged sites can open the Briefcase file with Briefcase Browser.

Target Site Enter the name of the site to which you are exporting data.
Transfer
Option Set

Select the transfer option set to use when exporting the objects.

Low-level configured and unconfigured transfer option sets are available when
exporting to a Teamcenter target site. High-level configured transfer option sets are
available for exporting to a Briefcase Browser target site. The available configured
transfer option sets are controlled by your administrator.

Depending on the selected transfer option set, you can specify additional options
such as Revision Rule and Variant Rule on the panel and override other options.
Update those values as necessary for your export.

Briefcase
Name

Accept the default file name or update it as necessary.

Delta Export Set Delta Export to Yes to export modified objects tracked by configured
incremental change as a partial structure export.

Force Re-
Export

Set Force Re-Export to Yes to repeat the same root object's most recent configured
export using the specified values of Transfer Option Set, Revision Rule, and
Variant Rule.

Validate Set Validate to Yes to specify that the exported data be validated and a summary
report generated during export.

If you set Validate to Yes, optionally click Validate Only to simulate an export of
the data with the current settings. You receive an alert when the report of the
simulated export is generated. No Briefcase file is generated. Review the report as
described in Review the export report later in this topic.

5. Click Export to create the Briefcase file. You receive an alert when the export is complete.

If Validate is set to Yes and errors that impact data integrity occur during the export, a Briefcase file
is not created. Review the validation report as described in Review the export report for details.

Review the export report

You receive a report alert when your export or validation run completes. Click on the alert to view the
report of the export or validation. All recent alerts are available from the Subscription tile.

The Properties section of the report includes details such as a list of the objects exported, the target
site, transfer option set used, and so on. Under Related Objects, click on the export log entry or
validation report entry to view additional details.

Export objects using Briefcase files
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Transfer the exported Briefcase file

The Target Object section of the export report contains a link to the exported Briefcase file. You can
preview the Briefcase file and compare it to other Briefcase files from the report.

Download the file and transfer it to the target site by email or other means.

Import objects from Briefcase files

You can import objects packaged in Briefcase files that have been exported from their owning sites to
your Teamcenter (managed) site and provided to you. (Unmanaged sites without Teamcenter can use
Briefcase Browser to open and work with Briefcase files.)

Use Briefcase files in the following scenarios:

• You may be a supplier receiving objects from an OEM that you update locally and provide back to
the OEM. In this scenario, the objects you are to change have been checked out to your site for
modification. Update them and then create a Briefcase file containing the updated files and send it to
the OEM.

• Ownership of certain objects is now being handled by your site. The objects have been marked for
ownership transfer and are included in a Briefcase file you import to your site.

• Objects you have previously exported to another site have been updated by that site, and they are
being returned to you in a Briefcase file.

Before importing objects from Briefcase files, you can preview the file contents and compare the file
contents to those in other Briefcase files (such as previously exported Briefcase files).

You cannot import objects using Briefcase files in the design context when using Supplier Collaboration.

Import objects from Briefcase files

1. Select the Awb0Element root business object or the folder into which you wish to import the
objects from the Briefcase file.

If you are importing objects modified that were previously exported to another site, select the
object or folder from which the objects were originally exported.

2. Click More commands  > Import/Export  > Import from Briefcase to display the Import from
Briefcase panel.

3. Use Choose File to locate the Briefcase file on your local system.

4. Select the transfer option set to use when importing the file. Override any options as necessary.
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5. Set Validate to Yes to specify that the imported data be validated prior to importing objects.

If Validate is set to Yes and errors occur during the validation, a report is generated, but no objects
are imported

A Validate Only button becomes available on the panel. Optionally click Validate Only to simulate
an import of the data with the current settings. You receive an alert when the report of the
simulated import is generated. No Briefcase file contents are imported. Review the report as
described in Review the import report later in this topic.

6. Click Import to import the objects from the Briefcase file.

If Validate is set to Yes and errors that impact data integrity occur during the import run, the
objects from the Briefcase file are not imported.

You receive an alert when the import run is complete. Review the report as described in Review the
import report.

7. Review the selected folder for the imported objects.

If you are a site that has been granted permission to edit objects owned by the owning site, those
objects are checked out in the folder.

If your site owns the objects that were updated at another site, check in the objects.

Review the import report

You receive a report alert when your import or validation run completes. Click on the alert to view the
report of the import or validation. (All recent alerts are available from the Subscription tile.)

Under Target Object, download the import log which includes details such as a list of the objects
imported, the transfer option set used, and so on.

Under Related Objects in the Properties section of the report, click on the validation report entry to
review the optional validation report.

Check out objects for modification at another site

You can use Briefcase files to check out an object for updating at another site (such as a supplier site).
This process is referred to as a Briefcase checkout. Briefcase checkout grants temporary modification
rights (excluding revise rights) to the target site. These objects are included in an exported Briefcase file
provided to the other site.

Briefcase checkouts help OEMs and suppliers collaborate for the following purposes:

• Adding or modifying datasets at a supplier site.

Check out objects for modification at another site
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• Adding or modifying components (ps occurrences) at a supplier site.

• Modifying metadata (attribute values) of workspace objects at a supplier site. Modification of non-
workspace objects, items, and item revisions is not supported.

Keep these objects checked out as long as you want the remote site to have modification rights. If the
Briefcase checkouts are canceled at the owning site, any changes made at the remote site cannot be
checked in.

• You can perform Briefcase checkouts only on objects of the types specified by your administrator.

• You must have permission to check out and modify an object to perform a Briefcase checkout.

• You cannot check out an object for a site if it is already checked out locally or to another site.

• You cannot check out objects in Briefcase files in the design context when using Supplier
Collaboration.

Check out objects using Briefcase Check Out

1. Select one or more objects you want to check out.

2. Select More commands  > Edit  > Briefcase Check Out to open the Briefcase Check Out
panel.

3. Chose a target site.

Check Teamcenter if the target site is a managed site using Teamcenter. Check Briefcase Browser
to check out the objects to an unmanaged site.

4. Set Target Site to the name of the target site.

The selected objects can only be updated at the site specified, even when included in a Briefcase
file that is supplied to other sites.

5. Click Check Out to check out the objects to the target site.

Objects checked out to a target site are identified with a  icon. Hover over it to see the check out
status.

Check in objects using Briefcase Check In

After you import a Briefcase file containing objects that were checked out using Briefcase checkout,
you can check in the objects to your site.

• You can check in objects in Briefcase files that have been checked out for your site.
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• You can check in objects in Briefcase files when you are the user who checked out the objects in the
original Briefcase file. An administrator also can check in these objects when another user checked out
the objects.

• You cannot check in objects in Briefcase files when in the design context when using Supplier
Collaboration.

Select the objects that you want to check in to your site and select Edit  > Briefcase Check In. The
objects are checked in.

Cancel a Briefcase checkout

If you used Briefcase checkout to check out an object to a site and need to cancel the checkout, select
the object and select Edit  > Cancel Briefcase Check Out.

You can cancel your own Briefcase checkouts, but only an administrator can cancel a Briefcase checkout
when another user performed the checkout. When a Briefcase checkout is canceled, any changes made
at the other site cannot be checked in.

Transfer ownership of objects to other sites

Before using Briefcase to export objects, you can specify (mark) which objects are to be exported with
their ownership transferred to the target site.

Marking objects for ownership transfer before the export improves data exports by letting you:

• Precisely identify which objects will have their ownership transferred

• Verify that the ownership of the objects can be transferred

• Lock those items against ownership transfer from a different session or by a different user in this same
session

When you mark an object for ownership transfer, ownership of its entire island of objects is transferred
upon export. That is, the principal object and the additional objects on which it depends for its correct
functional definition and usage within Teamcenter, including item revisions, are owned by the target site
upon export. If you mark an item revision for ownership transfer, the full item is marked for ownership
transfer. By transferring ownership of the entire island of objects, the target site can edit the parent
object without access issues. Ownership is transferred only for direct child objects of the parent object.

Ownership is transferred after the successful export of all revisions of the object, including revisions not
explicitly included in the export. Objects can be marked for ownership transfer when:

• The object is owned by your site and is not be replica object.

• The object is modifiable at the owning site.

Transfer ownership of objects to other sites
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• The object is not checked out.

• An administrator has specified that the object type can be marked for ownership transfer.

Ownership transfer is not available in the design context when using Supplier Collaboration.

Mark objects for ownership transfer

1. Select the objects to be marked for ownership transfer.

2. Select More commands  > Manage  > Transfer Ownership to display the Transfer
Ownership panel.

3. Select one of the following items.

• Select Teamcenter if you are transferring ownership to a site managing its data with
Teamcenter.

• Select Briefcase Browser if you are transferring ownership to an unmanaged site.

4. Set Target Site to the name of the site to which you are transferring ownership.

5. Click Transfer.

The objects are marked for ownership transfer. Ownership is transferred when the Briefcase file is
exported.

View objects currently marked for ownership transfer

On the owning site, click More commands  > View   > Pending Ownership Transfers. A list of
all objects marked for ownership transfer is displayed. If you have an object selected and marked for
ownership transfer, it is highlighted in the list.

Optionally filter the list of items by entering a specific target site. Only those objects with ownership
marked for transfer to the specified site are displayed.

Cancel ownership transfer

On the owning site, click More commands  > View   > Pending Ownership Transfers. A list of all
objects marked for ownership transfer is displayed.

Select the items for which you want to cancel ownership transfer and select Cancel Ownership Transfer
. Ownership is retained at the current site and is not transferred when the Briefcase is exported.

4. Working with data

4-60  Retail Footwear and Apparel ─ Fundamentals, Teamcenter 2412
© 2025 Siemens



Preview and compare Briefcase files

Preview and compare Briefcase files to quickly inspect their contents before importing the data to your
Teamcenter site. You can preview and compare briefcase files with each other or with the data in your
Teamcenter database.

Preview a Briefcase file

Click a Briefcase file to inspect the Briefcase file's contents and information such as the file's name,
description, owning site, and checkout status.

Briefcase contents can be mapped to different objects and structures upon import. You can preview how
the Briefcase contents will appear after the mappings are applied by choosing the transfer option set
with the appropriate transformation rules defined. The objects in the Briefcase preview are displayed
according to the defined rules.

Compare Briefcase files

1. Choose More commands  > View   > Compare Briefcases  to display the Compare
Briefcases panel. Specify Briefcase files to compare in any of the following ways:

• Use any of the Search  methods to find the Briefcase files you want to compare and drag the
Briefcase files to the Compare Briefcases panel.

• Instead of dragging the Briefcase files, you can click Add  under SOURCE to search for the first
Briefcase file to compare. Select the file and click Add. Perform the same steps to add a second
Briefcase file under TARGET.

• You can copy a Briefcase file using Active Workspace and then click Paste in the Compare
Briefcases panel to specify the Briefcase as the SOURCE or TARGET Briefcase.

• You can also select one or more Briefcase files before choosing More commands  >
View   > Compare Briefcases. The Briefcase files are automatically added to the Compare
Briefcases panel.

2. Briefcase contents can be mapped to different objects and structures upon import. To compare
Briefcase contents as they appear after mapping, choose SOURCE and TARGET transfer option
sets that have the appropriate transformation rules defined. The objects in the Briefcases are
transformed according to those rules before comparing.

3. Click Compare.

A comparison of the two Briefcases is displayed. Expand and collapse the hierarchy of items to
compare them. Color-coded bars identify changed objects in the briefcases:

• Red identifies items not in the Briefcase or Teamcenter database.

Preview and compare Briefcase files
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• Green identifies new items.

• Yellow identifies items that are changed.

Compare a Briefcase file to your site's current Teamcenter data

1. Select the source Briefcase file to compare using any of the methods detailed in Compare Briefcase
files earlier in this section.

2. Select Current State in the TARGET area of the Compare Briefcases panel and click Compare.

Comparing Briefcase files using Current State is available when using Teamcenter 13.3 or later.

Sharing data using PLM XML

PLM XML overview

PLM XML is an open standard for exchanging product life cycle information using several supported
XML schemas. Data represented in these schemas includes product structure, geometry, visualization,
features, application associativity, data ownership, and deltas (changes).

Export and import PLM XML when you need to share Teamcenter data with organizations not using
Teamcenter or for use with third-party applications. You can use PLM XML to share Teamcenter objects
such as items, datasets, BOMs, forms, and folders. You can also use PLM XML to share system data such
as business rules and organization data.

Using transfer mode objects created using PLM XML/TC XML Export Import Administration, you can
tightly control the scope, versions, and formats of the data being shared by applying closure (traversal)
rules, filter rules, action rules, and property set rules.

Export data as PLM XML

You can export assemblies, subassemblies, and items as PLM XML. The PLM XML, along with any
attached CAD (or other) data files, is exported to a .zip file for delivery to offline sites.

You can export objects of any type supported by the PLM XML schemas and specified by your
administrator.

Export the data to a .zip file

1. Select the assembly, subassembly, or items to be exported and click More commands  > Import/
Export  > PLM XML Export  to display the PLM XML Export panel.

2. Accept the default exported PLM XML file name or update it as necessary.

3. Select the transfer mode containing the rules appropriate for your export.
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4. Specify the configuration rules to use when exporting the objects.

• When you export from a product structure, the configuration rules specified for the entire
product structure are used to configure the exported data. To change the configuration of the
exported objects, adjust the revision and variant rules selected above the product structure as
appropriate.

• When you export from outside of a product structure (for example, from search results or
a folder), specify the rules used to configure the exported data in the PLM Export panel as
appropriate.

5. (Optional) Specify export languages to export as appropriate.

6. Click Export to create the exported PLM XML file. The export begins and you receive an alert when
the export is complete.

Review the export report

You receive a report alert when your export completes. Click the alert to view the export report. Access
all recent alerts from the Subscription tile.

The Properties section of the report includes details about the export such as the type of export, export
completion status, and transfer mode used. Under Related Objects, click on the export log entry to view
a detailed list of actions and results from the export.

Transfer the exported .zip file

The Target Object section of the export report contains a link to the .zip file containing the exported
PLM XML. Download the file and transfer it to the target site by email or other means.

Import PLM XML data

You can import objects and assemblies as PLM XML. The PLM XML, along with any attached CAD (or
other) data files, is imported from a .zip file. This .zip file can be one that was previously created by
exporting data to PLM XML using Active Workspace. If the .zip file was created using the Teamcenter rich
client or another application, ensure that the .zip file meets the following criteria:

• The .plmxml file in the root of the .zip file must have the same base name as the .zip file.

• The folder containing dataset files in the .zip file must have the same name as the .zip file's base
name.

Import objects in a PLM XML .zip file

1. Select the folder into which you wish to import the contents of the .zip file.

Import PLM XML data
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Be aware that even when your site is configured to copy the root objects of the import file to a
new folder under the Newstuff folder, the data is still imported into this selected folder and not the
Newstuff folder. (This result is different than when importing PLM XML using the Teamcenter rich
client.)

If the PLM XML was created by an application other than Teamcenter, be aware of how root objects
are imported by Active Workspace:

• Imported root objects are determined by the traverseRootRefs value of the Header element in
the .zip file's .plmxml file.

• If the .plmxml file contains no traverseRootRefs value, all of the WorkspaceObjects in
the .plmxml file are treated as root objects.

• When importing a BOMLine, its underlying Item is treated as the root object.

2. Click More commands  > Import/Export  > Import PLM XML to display the Import PLM XML
panel.

3. Use Choose File to locate the .zip file on your local system.

4. Select the transfer mode containing the rules appropriate to use when importing the file.

5. Click Import to import the objects in the .zip file. The import begins and you receive an alert when
the import is complete.

Review the import report and objects

You receive a report alert when your import is complete. Click on the alert to view the report. (Access all
recent alerts from the Subscription tile.)

Related Objects shows the folder in which the objects were imported, In Target Object, view a detailed
list of actions and results during the import.

Open the Active Workspace folder in which the objects were imported and review the imported
structure.

Sharing data using PDX files

Using PDX files

Export your Teamcenter data in PDX format when you want to share product data and attachments with
business partners who are not running Siemens Digital Industries Software products.

PDX (Product Data eXchange) data is a standardized file format that can be viewed by PDX viewer
applications such as PDXplorer, or used by other systems that support the PDX data format.

4. Working with data
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Exported PDX data includes assemblies, objects, and attachments. The exported data is packaged in a
compressed file ready for delivery to business partners.

For information about configuring and customizing the PDX export from Active Workspace, in the
Teamcenter Administration help, see Configure PDX data sharing.

To export data as PDX files using Active Workspace, in the Active Workspace Fundamentals help, see
Share objects as PDX files.

Share objects as PDX files

PDX (Product Data eXchange) data is a standardized file format that can be viewed by PDX viewer
applications such as PDXplorer, or used by other systems that support the PDX data format. You can
share Teamcenter data as PDX files using Active Workspace.

1. Locate and select one or more objects or assemblies from your site to share as PDX data. You can
select and share only objects of the types allowed by your site as PDX data.

If you select more than one line within an assembly, the entire assembly is exported.

If you select multiple assemblies or items from separate assemblies, the exported file contains
multiple root assemblies.

2. Click More commands  > Import/Export  > Export PDX . The Export PDX panel is displayed
listing several properties that must be set to export the Teamcenter data.

3. From the Transfer Option Set list, select the transfer option set to use when sharing objects as PDX
data. The transfer option set defines the scoping rules for exporting your data to PDX. The available
option sets can be used only to export PDX data, and vary depending on your site's configuration.

4. Your Teamcenter data is exported in a single compressed file. Specify a file name for the exported
PDX file.

5. Specify the configuration rules to use when exporting the objects.

• When you export from a product structure, the configuration rules specified for the entire
product structure are used to configure the exported data. To change the configuration of the
exported objects, adjust the revision and variant rules selected above the product structure as
appropriate.

• When you export from outside of a product structure (for example, from search results or
a folder), specify the rules used to configure the exported data in the Export PDX panel as
appropriate.

6. Optionally limit the number of BOM levels exported to PDX by setting BOM Levels to Export to a
value of 1 to the maximum level of the structure.

Share objects as PDX files
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7. If Vendor Filter is available, click it to select the vendors for which info is exported. Selecting no
vendors will exclude all manufacturer parts and contact information for all vendors related to the
selected objects or assemblies from being exported.

If Vendor Filter is not available, manufacturer parts and contact information for all vendors related
to the selected objects or assemblies is exported.

8. Review and adjust the transfer options by clicking Override Options on the Export PDX panel.
The available options vary depending on the configuration of the selected transfer option set. The
settings you choose remain selected for future PDX exports in your current session our until you
clear your browser cache.

9. Click Export to create the exported PDX file. The export begins and you receive an alert when the
export is complete.

Review the export report

You receive a report alert when your export completes. Click the alert to view the export report. Access
all recent alerts from the Subscription tile.

The Properties section of the report includes details about the export such as the type of export, export
completion status, and transfer option set used. Under Related Objects, click on the export log entry to
view a detailed list of actions and results from the export.

Transfer the exported .pdx file

The Target Object section of the export report contains a link to the .pdx file containing the exported
data. Download the file and transfer it to the business partners who are not running Siemens Digital
Industries Software products.

Sharing data using Multi-Site Collaboration

Multi-Site Collaboration overview

Multi-Site Collaboration is an optional feature installed by your administrator. It enables you to securely
share and manage product data across multiple sites in your enterprise.

With Multi-Site Collaboration, primary Teamcenter objects exist at one site (the owning site). You can
publish primary objects, making them available to other sites in your organization (remote sites) for
use. You can then share these objects for replication at specific remote sites, choosing options such
as transferring ownership with the objects, sharing only certain versions of objects, and sharing BOM
structures related to the objects. Remote sites then receive the objects, which are stored as object
replicas at those sites.

Sharing data using Multi-Site Collaboration delivers several benefits:
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4-66  Retail Footwear and Apparel ─ Fundamentals, Teamcenter 2412
© 2025 Siemens



Provides access to data across the enterprise

Store, locate, view, and use information from any site within your Multi-Site federation; create
references among objects at multiple sites; and build product structures using assemblies and
subassemblies from multiple sites.

Ensures data integrity

When an object is initially created and saved, that instance is considered the primary object unless
there is a transfer of ownership. Updates between primary objects and replicas are synchronized.
Only the primary object can be replicated. You cannot replicate replicas.

Provides data security

To ensure that no unauthorized replicas are created, specific sites are authorized to take transfer of
ownership. Tracking information is stored with the primary object if it is transferred.

Supports auditing and tracking

To ensure that there is only one instance of a primary object, only one site can accept transferred
ownership. A primary object cannot be deleted until all replicas are deleted. This ensures referential
integrity across the Multi-Site federation.

Administrators can view and analyze your organization's history of Multi-Site transactions using charts,
graphs, and detailed object reports. See Monitor data exchange transactions.

Publish objects for access from remote sites

Sites in a distributed network must have some reliable way of controlling which data they want to
share with the rest of the network. With Multi-Site Collaboration, you control this by publishing and
unpublishing objects.

Publishing objects

Publishing an object makes that object available to other sites, allowing them to make local replicas of
the object. When you publish an object, a publication record is created in the ODS (Object Directory
Services) database that can then be read and searched by other Multi-Site Collaboration sites. Until you
publish an object, it can only be accessed at the local owning site. Other sites cannot access the object.

Publish an object by selecting it, clicking More commands  > Share  > Publish, and checking one
or more servers to use for publishing. (If your site uses more than one server, consult with your system
administrator for recommendations on the best server to use.) Once published, you can transfer the
object to remote sites.

Unpublishing objects

Unpublishing an object reverts an object to be accessible only by the local owning site.

Unpublish an object by clicking More commands  > Share  > Unpublish and checking the servers
from which the object is to be unpublished. Once unpublished, if the object is still replicated on a

Publish objects for access from remote sites
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remote site, it will be shown with a . Hover over the  to see the object's status. A best practice is to
remove replicas of unpublished objects from remote sites.

Share objects with other sites using Multi-Site Collaboration

If your organization is using Multi-Site Collaboration, you can share objects from your (local) site
with other (remote) sites in your Multi-Site network, creating replica objects at these other sites. When
sharing, you can specify how site ownership, object ownership, and other transfer options are handled.
Local objects must be published to be shared using Multi-Site Collaboration.

Use the following steps to share objects from your site with a remote site.

1. Locate and select an object from your site to share.

When you search for items, search results include ItemRevision object types by default. Consider
using Advanced Search to locate Item object types.

To share a specific revision of an object, select the revision on the History tab. You can also choose
an item from the Where Used tab and select a specific revision or all revisions of the object.

2. Click More commands  > Share  > Share with Sites . The Share with Sites pane is
displayed listing target sites and several transfer options.

3. From the Destinations list, check one or more remote sites to be used as target destinations when
transferring the selected object. The Destination list filters as you type; type the first few characters
of the site's name to display the site you want.

4. For Option Set, select the transfer option set to use when sharing objects. The transfer option set
defines the configuration rules when transferring data between sites. The available option sets vary
depending on your site's configuration.

5. Use the following information to update the remaining settings on the Share with Sites pane as
necessary. Then, click Share to share the selected objects with the destination sites. You receive a
notification when the transfer completes.

Transfer site ownership to the destination site

To transfer site ownership of the selected objects to the destination site, click Transfer Site Ownership.
When you transfer site ownership, all revisions of an item will be shared.

If you transfer an item revision with a sequence, its sequence manager is also transferred.

Siemens Digital Industries Software recommends that you leave Transfer Site Ownership unchecked.
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Share only modified objects

To share a workspace object only when it has been modified since the last time it was exported to the
destination site, click Modified Only.

For example, if only the specification dataset was modified, the specification dataset is shared and the
remaining items are not. When sharing with multiple destination sites, an object is shared if it has been
modified since the last export to any of the selected destination sites.

Share different or additional revisions

When you click More commands  > Share  > Share with Sites  with an item selected, you
can share that item or choose to share a specific revision of the item such as the latest revision, latest
working revision, latest release revision, and so on. On the Share with Sites pane, select the revision of
the item to share from the Revision list.

When you click More commands  > Share  > Share with Sites  with a specific item revision
selected, you can share that revision. Optionally, click All Revisions on the Share with Sites pane to
share all versions of the selected item revision.

Share an item and BOM

When you click More commands  > Share  > Share with Sites  with an item revision selected,
you can share that item along with a related configured BOM structure. On the Share with Sites pane,
check Include Structure and select the revision and variant rules defining the appropriate revisions of
parts and assemblies in the product structure to share.

If you check Include Structure with All Revisions selected, the related unconfigured BOM structure is
shared.

Share item relations

An item or item revision can be related to data, such as datasets, forms, folders, and other items and
item revisions. Relations describe how the other data is associated with the item or item revision.

To share related data, from the Relations list on the Share with Sites pane, check each object relation
to also share with the destination sites.

Change ownership of shared objects

Optionally change the owner of the transferred object once it is transferred to the remote site. Under
OWNER on the Share with Sites pane, click Replace , check the new owner, and click Replace.

Modify transfer options

Review and adjust the transfer options by clicking Override Options on the Share with Sites pane.

Share objects with other sites using Multi-Site Collaboration
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The available options vary depending on the configuration of the selected transfer option set. You can
modify the options available to override by editing the transfer option sets as described in PLM XML/TC
XML Export Import Administration.

Receive and update objects from remote sites using Multi-Site Collaboration

Use the following steps to import objects recently shared to your site and to update replica objects
at your local site. When updating, you can specify how site ownership, object ownership, and other
transfer options are handled.

Use the following steps to share objects from your site with a remote site.

1. Locate and select one or more replica objects. Replicas on your site are identified with a . Hover
over the  to see the name of the remote site.

Objects in a product structure that have not yet been received from their sites will be listed with the
name <REMOTE OBJECT>.

2. Click More commands  > Share  > Receive from Site . The Receive from Site pane is
displayed listing several transfer options.

3. Select the transfer option set to use when receiving the objects. The transfer option set defines the
configuration rules when transferring data between sites. The available option sets vary depending
on your site's configuration.

4. Use the following information to update the remaining settings on the Receive from Site pane as
necessary. Then, click Receive to update the selected objects at your site. You receive a notification
when the update completes.

To view the updated objects in a product structure, click Expand > Unpack All.

Transfer site ownership to your site

To transfer site ownership of the selected objects to your site, click Transfer Site Ownership. When you
transfer site ownership, all revisions of an item will be shared.

If you transfer an item revision with a sequence, its sequence manager is also transferred.

Siemens Digital Industries Software recommends that you leave Transfer Site Ownership cleared.

Update only modified objects

To update a workspace object only when it has been modified since the last time it was received, click
Modified Only.
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Update different or additional revisions

When you click More commands  >Share  > Receive from Site  with an item selected, you can
update that item or choose to update a specific revision of the item such as the latest revision, latest
working revision, and latest release revision. On the Receive from Site pane, select the revision of the
item to update from the Revision list.

When you click More commands  > Share  > Receive from Site  with a specific item revision
selected, you can share that revision. Optionally, click All Revisions on the Receive from Site pane to
update all versions of the selected item revision.

Update an item and BOM

When you click More commands  > Share  > Receive from Site  with an item revision selected,
you can update that item along with a related configured BOM structure. On the Share from Site pane,
check Include Structure and select the revision and variant rules defining the appropriate revisions of
parts and assemblies in the product structure to update.

If you check Include Structure with All Revisions selected, the related unconfigured BOM structure is
updated.

Update item relations

An item or item revision can be related to data, such as datasets, forms, folders, and other items and
item revisions. Relations describe how the other data is associated with the item or item revision.

To update related data, from the Relations list on the Receive from Site pane, check each object
relation to also update.

Modify transfer options

Review and adjust the transfer options by clicking Override Options on the Receive from Site pane.

The available options vary depending on the configuration of the selected transfer option set. You can
modify the options available to override by editing the transfer option sets as described in PLM XML/TC
XML Export Import Administration.

Check out and check in objects when using Multi-Site Collaboration

When using Multi-Site Collaboration, Siemens Digital Industries Software recommends you check out
and modify only master objects. The check-out and check-in of objects managed with Multi-Site
Collaboration is the same as in the case of other objects.

If necessary, you can also check out and modify replica objects (identified with a ) on other sites in
your Multi-Site federation. When checking out and checking in replica objects, be aware of the following
items:

Check out and check in objects when using Multi-Site Collaboration
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• When you check out and check in a remote item, certain related objects such as item revisions and
datasets are also checked out and checked in. The list of related items checked out and checked in is
determined by the values specified in the MultiSiteCICORule closure rule.

• You cannot directly check out and check in remote objects from Structure Manager. Check the remote
objects in and out from outside of the product structure. For example, select the object in the product
structure, click the History tab, select the object, and click More commands  > Edit   > Checkout

.

• When a replica object is checked out at a remote site, the object cannot be checked out at the master
site.

• When you check in replica objects, the updated data is sent to the master site. Doing so ensures
consistent data across your organization.

• When you check in a modified structure, you are prompted whether to check in the entire structure
and whether to retain ownership of the components at the master site.

When checking in replica objects, you have the following options:

Check in an item revision and BOM

Check Include Structure to check in the item revision and any other new or changed components in the
related configured BOM structure.

Retain object ownership of new components

To keep site ownership local for any newly created objects being checked in, click Retain Ownership
of Components. If not, ownership of the newly created objects is transferred to the primary site upon
checkin.

Check in data linked to the object using relations

To check in changes to related data, such as datasets, forms, folders, and other items and item revisions,
from the Relations list, select each object relation to also check in at the remote site.

Comparing object properties

You can compare common properties of objects.

• Select multiple objects from the list.
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Note:

While in a comparison display from a list, you can use the list to select additional objects or
remove objects.

• To arrange properties in a comparison display, click Table Settings  to the right of the column
headings and choose Arrange to display the Arrange panel.

Note:

The columns available for display are specified by administrators.

When you navigate away from a comparison display, changes made using the Arrange panel
are not retained.

Alternately, to change the column order for closer comparison to another column, click and hold in
the header row, and then drag the column to the desired location.

Note:

While in a comparison display, you can select a column and click Information  to display the
object panel to edit properties for that object, or use any other available command and complete
the desired action.

Tracking changes to objects

As an object goes through the change process, the changes (additions, modifications, revisions,
deletions, and replacements) can be tracked to make it easier for you to see what properties of
the object were modified as part of the requested change. You can view these changes by clicking
View   > Show Redlines on the object.

Tracking changes to objects
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Note:

The changes are highlighted only if your site administrator has enabled change highlighting in the
system configuration.

When you show redlines, changes are displayed on the object using the following highlighting methods:

• Deleted parts are highlighted with a red strikethrough.

• Added parts are highlighted with a green italic font.

• For replaced or revised parts, old and new values are shown side by side.

For more information on tracking changes, in the Change Management help, see Review active or
closed changes for a structure.

Synchronize workflow tasks in Outlook

Synchronize your Teamcenter workflow tasks in Microsoft Outlook so that both your Outlook tasks and
Teamcenter workflow tasks appear in the Outlook task list. This is an easy way to view all your work
tasks displayed in a single list. Open a Teamcenter workflow task to complete the task (or reassign the
task) using Active Workspace.

1. In Outlook, click Tasks.

2. In the Teamcenter tab, click Synchronize Tasks .

3. To review your Teamcenter Inbox in Outlook, click a Teamcenter task.

4. Alternatively, to open Active Workspace in an Outlook window:

a. Double-click a Teamcenter task.

b. Click the Teamcenter tab.

c. Select Perform Task on the Teamcenter tab to display the Inbox in a task panel.

5. Complete the task using Active Workspace.
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Generating and viewing reports

Generate and view predefined reports

Generating reports using Teamcenter predefined reports

You can use Teamcenter predefined reports to generate various types of item, summary, and custom
reports.

Summary and item reports are static reports. They are generated from the persistent properties in a
database. Custom reports are dynamic reports and are generated from the runtime properties in a
database.

• Item report: These are generated in the context of a specific object, for example, reports that show
the BOM list for an item or the workflow sign-off for an item.

• Summary report: These reports collate and summarize similar information, for example, reports that
show entries for all the employees, the items belonging to a user, or the release status of items. These
are generated from Teamcenter saved queries and you need not have to select any objects to run
these reports.

• Custom report: These reports address special cases such as complex processing or calculations done
through custom code or API functions, or when the data comes from external sources. For example,
the reports administrator can create a custom report that generates and displays the BOM line
attributes of a product structure. The BOM line information in the report you generate can change
depending on the type of revision rule applied before generating this report.

Generating reports using Reporting and Analytics

If Reporting and Analytics is installed and deployed in your Teamcenter environment, you can:

• Define and create new Reporting and Analytics reports.

• Edit reports, charts, and layouts without launching a separate application.

• Configure charts with customized styles, dimensions, and measures.

Generate an item, summary, or a custom report

You can generate an item report, summary report or a custom report, or Reporting and Analytics
reports.

Generate an item report

1. Search for an item and select the item revision.

Generating reports using Teamcenter predefined reports
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2. Choose More Commands  > New  > Generate Report .

3. Select a predefined report.

4. Specify the appropriate criteria or make the appropriate selections.

5. Select a style sheet.

You can select a style sheet with an _html or an _excel suffix to generate the report in HTML or MS
Excel format, respectively.

6. (Optional) To save a report, specify a file name in the Save to File Name box.

You can view this report later from the My Reports or the Printouts tab.

7. (Optional) To generate the report asynchronously, select the Run in Background check box.

By default, this check box is selected if the reports administrator has enabled the Run in Async
check box while defining a report.

8. To create the report, click Generate.

9. To access your saved or asynchronously generated reports, click the PRINTOUTS tile on the home
page.

The reports are available from the Printouts tab.

Some reports can be generated only asynchronously. This depends on how the administrator
configures the report template at your site. Asynchronously generated reports are available from
the Printouts tab.

Generate a summary report or a custom report

Currently, there is no command to select a summary or custom report specifically. When you select a
report from the Templates tab, the Overview tab displays the properties of the report including the
name and the description. Type: 0 indicates a summary report and Type: 2, a custom report.

1. On the HOME page, click the REPORTS tile.

2. Click the Templates tab, select a summary or custom report, and click Open .

Alternatively, click the Templates tab, select a summary or custom report, and choose More
Commands  > New  > Generate Report .

3. To quickly access a summary or custom report, click Search, for example, change. Then, select the
report and click Open .

4. Working with data

4-76  Retail Footwear and Apparel ─ Fundamentals, Teamcenter 2412
© 2025 Siemens



4. For summary reports, specify the appropriate criteria or make the appropriate selections in REPORT
FILTERS.

5. Select a style sheet.

You can select a style sheet with an _html or an _excel suffix to generate the report in HTML or MS
Excel format, respectively.

6. (Optional) To save a report, specify a file name in the Save to File Name box.

You can view this report later from the My Reports or the Printouts tab.

7. (Optional) To generate the report asynchronously, select the Run in Background check box.

By default, this check box is selected if the reports administrator has enabled the Run in Async
check box while defining a report.

8. To create the report, click Generate.

9. To access your saved or asynchronously generated reports, click the PRINTOUTS tile on the home
page.

The reports are available from the Printouts tab.

Some reports can be generated only asynchronously. This depends on how the administrator
configures the report template at your site. Asynchronously generated reports are available from
the Printouts tab.

Generate Reporting and Analytics reports

If Reporting and Analytics is installed and deployed, you can generate a new report or view a snapshot.
A snapshot is a report that contains layout information and query results retrieved at a specific point in
time. Snapshots are automatically created based on a schedule and saved to a location or server. You can
analyze multiple snapshots, captured on previous occasions, to help identify trends based on historical
data.

Note:

Reporting and Analytics is not supported for custom reports.

1. Click New to generate a new report, specify filter criteria, and click Run to generate the report.

OR

Generate an item, summary, or a custom report
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Click Add to Queue to add the report to the queue to generate the report in the background. You
receive an email with the link to the report after successful completion. The generated report is
also available in the Snapshots area.

2. (Optional) To edit a Reporting and Analytics report, open the report, click Settings and then click
Edit on the toolbar.

3. (Optional) Add new widgets, styles, dimensions, and measures to the report.

4. Click Save to save your changes.

5. (Optional) To export the report as an email, PDF, HTML, Excel, PowerPoint, or a text file, click
Settings and select the format to which you want to export.

Generate active reports

Active reports overview

Active reports are report definitions that identify the content you want to include in reports. You can
create report definitions for active summary reports and active item reports dynamically and add them
to the database. You can select a layout and add charts and a table. After previewing and saving an
active report, you can search for it and rerun the saved report to fetch the latest data from the database.

• Active summary reports collate and summarize similar information, for example, reports that show
entries for all the employees, the items belonging to a user, or the items released in the current
month.

• Active item reports are generated in the context of a specific object, for example, reports that show all
solution items for a selected Change Revision or all attachments for a selected Item Revision.

Some business objects such as programs do not have the Reports tab enabled by default. In such cases,
you cannot view the Active item report. The reports administrator or a user with DBA privileges can
modify style sheets to enable this tab. For more information, see Report Builder on Support Center.
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View My Dashboard reports

1. On the Home page, click the Reports tile.

By default, the available reports are displayed as thumbnails in My Dashboard.

2. To open the report, hover over the report title until a link appears, and click the title link to open it.

Alternatively, click More Commands > Open.

View My Dashboard reports
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3. Drill down the report to find specific data.

Example:

a. Open the My Modified Objects report.

b. In the Objects By my Login Group pie chart, click the area specific to a group, for example,
the Engineering group. The chart and the table area show objects specific to the Engineering
group. Click the following button to close this view.

c. In the Objects by Type area, click the Item Revision line chart. The Item Revision chart area
shows the Objects By my Login Group pie chart specific to item revisions.

The table shows the item revisions by name, ID, group ID, and the last modifying user. If the
objects have a release status, the Object by Release pie chart displays how many objects are
unassigned or released.

4. (Optional) Open the report and if the report contains data in a tabular format at the bottom, click
the table header of the column you want to sort and choose the appropriate option. You can also
select an operator for further filtering. The valid operators are Contains, Does not contain, Begins
with, Ends with, Equals, and Does not equal. For example, for a BOM readiness report, you can
select Contains and type released to find the released item revisions.
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5. (Optional) To remove the report from My Dashboard, select the report tile, choose More
Commands, and select Remove.

6. To add a report from My Dashboard, click Add , search for the report in the Add Report panel,
select it, and click the Add button.

If you select an active item report, you must specify the item related to this report. To do so, click
the Add button in the ITEM area of the Add Report panel, search for the item, select it, and click
the Add Report button.

7. Display the table tile on My Dashboard.

You can optionally display the table tile on My Dashboard for an existing summary or item report.

View My Dashboard reports
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You can open an object or sort, hide, or freeze columns directly from the table tile. Additionally,
you can select multiple objects from the table tile, copy them, or add them to My Changes, or
perform some other similar action.

a. In Templates, select the report for which you want to display the table tile on My Dashboard.

b. Choose More Commands > Edit  > Edit Report and select Set Layout.

c. In Table, if you have not selected columns, select them as appropriate, select Template, click
Edit, select Table from Thumbnail list, and click Save.

In reports, you can set one of the three charts or the table as the thumbnail.

d. Navigate to My Dashboard.

The report you modified displays the table tile.

8. Directly edit the report columns for reports with tables as thumbnails.

a. To edit report columns directly from the dashboard view, select a report with a table as a
thumbnail, click More Options > Edit.

b. Click the appropriate editable column and make the necessary changes.

c. To save your changes, click More Options > Save Edits.

9. Export reports with tables as thumbnails to Microsoft Excel directly from the dashboard view.

a. To perform an export to directly from the dashboard view, select a report with a table as a
thumbnail, click More Options, and choose Export to Excel.

b. To add properties, click Add Properties to add or remove additional properties that you want
to display in the exported spreadsheet.
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c. Click Downloads in your browser to open the exported file.

Duplicate an existing template and modify it to create a new report

Only the owner of the templates can edit them. However, other users can duplicate existing templates
and modify them to create new reports.

1. On the Home page, click the REPORTS tile.

2. Choose the Templates page, search for the template you want to duplicate, and select it.

3. To duplicate the template, choose More Commands  > New  > Save As .

4. Change the name, description, and ID as appropriate, and click the Save button.

You cannot edit default report templates containing custom data providers such as Workflows
initiated by my groups.

5. Search and open the template you duplicated.

6. Choose More Commands  > Edit  > Edit Report .

7. Make the required changes and save the template.

Share report templates across users, roles, groups, and projects

You can share the templates you create across users, roles, groups, and projects.

When you create a report template, it is not available by default for other users to use. You must share
report templates you create across users, roles, groups, and projects. The report templates you share are
available in the Templates tab and the Generate Report panel.

Procedure

1. On the Home page, click the Reports tile, and choose Templates.

2. Search for the template you have created, select it, and choose More Commands > Share > Share.

3. To share this template with all users, choose All users (Public).

4. Share this template with selected users.

You can share templates with selected users, roles, or groups in the organization, or across projects.

a. To share this template with selected users, choose Selected users only.

Duplicate an existing template and modify it to create a new report
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b. From the Available section, select Users, Organization, or Projects as appropriate.

c. Make the appropriate selections from Available and click  to move them to Shared With.

5. To share the template, click Save.

Create and generate an active summary report

You can create summary reports to collate and summarize similar information, for example, reports that
show entries for all the employees, the items belonging to a user, or the release status of items.

The process for creating and generating an active summary report is as follows:

Example:

Create a report for all business objects created by the current logged-on user for the current
month. This is a generic report and it can be used by another user to view the business objects
created by that user.

Procedure

1. (Optional) Create the report definition and add the data for the report.

a. On the HOME page, click the REPORTS tile.

b. In My Dashboard or Templates, choose More Commands  > New  > Create Report .

c. To create a summary report, from the Type list, select Active summary report. This is the
default type.

d. Search for the data you want in the report.
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In this example, a report is created for all business objects created by the current logged-on
user for the current month.

A. In the Search Data panel, search for the data you want to include in the report.

For example, type Owner:$ME and click Search to fetch all the objects owned by the
currently logged-on user. The keyword for this is $ME.

To further filter your search criteria, for example, to fetch all objects created this month,
modify the query as Owner:$ME AND "Creation Date":$THIS_MONTH and click Search.

Search criteria examples:

All item revision objects created in the
last seven, fourteen, or thirty days

• ItemRevision AND "Date
Modified":$LAST_7_DAYS

• ItemRevision AND "Date
Modified":$LAST_14_DAYS

• ItemRevision AND "Date
Modified":$LAST_30_DAYS

All item revision objects created in the
current or last one year

• ItemRevision AND "Date
Modified":$THIS_YEAR

• ItemRevision AND "Date
Modified":$LAST_YEAR

All objects created by the logged-on
user in this month or last one month

• Owner:$ME AND "Date
Modified":$THIS_MONTH

• Owner:$ME AND "Date
Modified":$LAST_MONTH

All released objects in the last three
months

"Release Status":* AND "Date
Released":$LAST_3_MONTHS

Dashboard for objects modified by the
logged-on user in the current year

"Last Modifying User":$ME AND
"Group ID":$MY_GROUP AND "Date
Modified":$THIS_YEAR

All change requests, change notices,
or problem reports created in the
current year

ChangeRequestRevision AND
"Creation Date":$THIS_YEAR

OR

ChangeNoticeRevision AND "Creation
Date":$THIS_YEAR

OR

ProblemReportRevision AND "Creation
Date":$THIS_YEAR

B. To include the data in the report, click Save.

Create and generate an active summary report
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2. Select a layout for the report and add charts.

You must first create the report definition and add the data for the report before you can select a
layout and add charts and a table.

a. Specify a report title.

b. Specify the number of charts you want to add for this report by selecting the appropriate
option.

c. Select Bar Chart, Pie Chart, or Line Chart for the type of chart you want to create.

d. To create a layout for the report, click Edit  above the chart.

e. To add a property for the chart, from the Chart On list, select a value, for example, Status.

f. Specify a title for the chart type or accept the default title.

g. To save this chart type, click Save.

h. To add the second and third charts, repeat the above steps. You can choose other properties
for the second and the third chart, for example, State and Priority, respectively.

You can add additional chart properties depending on how the administrator has configured
your Teamcenter environment. Consult your administrator for more information.

i. After creating more than one chart, to move the chart, click … More Commands and select
the appropriate option.

3. To display the data in a tabular format, add a table for the report.

a. In the Table area, click Table Settings  > Arrange.

b. From Available Columns, select column name properties such as Object, Task Type,
Description, State, and Status, and click  to move them to Displayed Columns.

c. (Optional) To rearrange the columns in the table, in the Column Name area, select a column
name, click the column widget, and move the column up or down.

d. To save the column arrangement, click Arrange.

4. Working with data

4-86  Retail Footwear and Apparel ─ Fundamentals, Teamcenter 2412
© 2025 Siemens



Note:

(Optional) You can add additional columns to the table depending on how the administrator
has configured your Teamcenter environment. Consult your administrator for more
information.

4. Save the report as a template.

a. To save the report as a template, click Save as Template .

b. (Mandatory) Specify a name for the report.

c. (Optional) Include a description.

d. (Mandatory) Specify an ID for the report or accept the default ID for the report.

e. (Optional) Specify a Thumbnail for the report or accept the default value.

f. (Optional) To include the report in My Dashboard, select the Add to Dashboard check box.

g. Click Save.

5. Edit the report from the Templates page.

a. Navigate to the Templates location.

b. Search for the report definition you want to edit, select it, and choose More Commands  >
Edit  > Edit Report .

c. Make the necessary changes and save the report.

6. Generate the report.

a. From the Templates page, select the report you want to generate.

b. To generate the report, click Open .

The report is generated by fetching the latest data from the database.

7. Export the table area of the report to Microsoft Excel.

a. To open the report from any dashboard, hover over the report title until a link appears, and
click the title link to open it. Alternatively, select the report and click More Commands >
Open.

Create and generate an active summary report
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From Templates, select the report and click Open.

b. Click Export to Excel above the table area of the report.

c. Click Add Properties and deselect the properties that you do not want to be displayed in the
exported report.

d. To download the report, click Export.

e. Click Downloads in your browser to open the exported file.

Perform a search and convert the search results to an active summary report

You can perform a search and convert the search results to a summary report.

Summary reports are used to collate and summarize similar information, for example, reports that show
entries for all the employees, the items belonging to a user, or the release status of items.

Procedure

1. Create a search.

a. Perform a search, for example, type change in the search box.

b. Select a filter, for example, ChangeRequest from the Category filter.

c. Select other filters as appropriate.
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2. Create the report.

a. Choose More Commands > New > Create Report.

b. Select Active summary report and click Create.

3. Select a layout for the report and add charts.

You must first create the report definition and add the data for the report before you can select a
layout and add charts and a table.

a. Specify a report title.

b. Specify the number of charts you want to add for this report by selecting the appropriate
option.

c. Select Bar Chart, Pie Chart, or Line Chart for the type of chart you want to create.

d. To create a layout for the report, click Edit  above the chart.

e. To add a property for the chart, from the Chart On list, select a value, for example, Type.

f. Specify a title for the chart type or accept the default title.

g. To save this chart type, click Save.

h. To add the second and third charts, repeat the above steps. You can choose other properties
for the second and the third chart, for example, Owner and Change Maturity, respectively.

You can add additional chart properties depending on how the administrator has configured
your Teamcenter environment. Consult your administrator for more information.

Perform a search and convert the search results to an active summary report
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4. To display the data in a tabular format, add a table for the report.

a. In the Table area, click Table Settings  > Arrange.

b. From Available Columns, select column name properties such as Object, Type, Owner,
Disposition, Closure, Maturity, Group ID, and Creation Date and click  to move them to
Displayed Columns.
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c. (Optional) To rearrange the columns in the table, in the Column Name area, select a column
name, click the column widget, and move the column up or down.

d. To save the column arrangement, click Arrange.

e. (Optional) You can add additional columns to the table depending on how the administrator
has configured your Teamcenter environment. Consult your administrator for more
information.

5. Save the report as a template.

a. To save the report as a template, click Save as Template .

b. (Mandatory) Specify a name for the report.

c. (Optional) Include a description.

Perform a search and convert the search results to an active summary report
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d. (Mandatory) Specify an ID for the report or accept the default ID for the report.

e. (Optional) Specify a Thumbnail for the report or accept the default value.

f. (Optional) To include the report in My Dashboard, select the Add to Dashboard check box.

g. Click Save.

6. Generate the report.

a. From the Templates page, select the report you want to generate.

b. To generate the report, click Open .

The report is generated by fetching the latest data from the database.

7. Export the table area of the report to Microsoft Excel.

a. To open the report from any dashboard, hover over the report title until a link appears, and
click the title link to open it. Alternatively, select the report and click More Commands >
Open.

From Templates, select the report and click Open.

b. Click Export to Excel above the table area of the report.

c. Click Add Properties and deselect the properties that you do not want to be displayed in the
exported report.

d. To download the report, click Export.

e. Click Downloads in your browser to open the exported file.

Create and generate an active item report from various sublocations

You can create and generate an active item report by selecting an object from any sublocation other
than Reports.

Procedure

1. From the Home page, click Advanced Search.

2. Select an appropriate option such as Item Revision, specify other parameters as appropriate,and
click Search.

3. Create the report.
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a. Select an object from the search results and click More Commands > New > Create Report;
OR

b. On the Home page, you can choose Explorer, Changes, Programs, or Schedules, select an
object, and click More Commands > New > Create Report.

4. To create the report, click Create.

5. Add relations for the report.

a. To add the relations, click Add and click Pin Panel to add multiple relations.

The system displays all the possible relations of the source object.

Column name Description
Relation (Object) Displays the relation name and the type of object this particular relation

returns.
Relation Type Displays the relation type such as primary, secondary, reference, or

referenced by.
Count Displays the number of objects that are related.

b. Select the appropriate relation object and click Add. Keep adding relations as appropriate.

6. Select a layout for the report and add charts

You must first create the report definition and add the data for the report before you can select a
layout and add charts and a table.

a. Specify a report title.

b. Specify the number of charts you want to add for this report by selecting the appropriate
option.

c. Select Bar Chart, Pie Chart, or Line Chart for the type of chart you want to create.

d. To create a layout for the report, click Edit.

e. To add a property for the chart, from the Chart On list, select a value, for example, State.

f. To add the second and third charts, repeat the above steps. You can choose other properties
for the second and the third chart, for example, Status and Work Complete Percent,
respectively.

You can add additional chart properties depending on how the administrator has configured
your Teamcenter environment. Consult your administrator for more information.

Create and generate an active item report from various sublocations
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g. Specify a title for the chart type or accept the default title.

h. To save this chart type, click Save.

i. After creating more than one chart, to move the chart, click … More Commands and select
the appropriate option.

7. To display the data in a tabular format, add a table for the report.

a. In the TABLE area, click Table Settings > Arrange.

b. From Available Columns, select column name properties such as State, Status, Object,
Finish Date, Schedule, and Actual Start Date, and click  to move them to Displayed
Columns.

c. (Optional) To rearrange the columns in the table, in the Column Name area, select a column
name, click the column widget, and move the column up or down.

d. To save the column arrangement, click Arrange.

8. Add filters to the relations you have added.

a. To add the relations, click Add and click Pin Panel to add multiple relations.

The system displays all the possible relations of the source object.

Column name Description
Relation (Object) Displays the relation name and the type of object this particular relation

returns.
Relation Type Displays the relation type such as primary, secondary, reference, or

referenced by.
Count Displays the number of objects that are related.

b. Select the appropriate relation object and click Add. Keep adding relations as appropriate.

9. Save the report as a template.

a. To save the report as a template, click Save as Template.

b. (Mandatory) Specify a name for the report.

c. (Optional) Include a description.

d. Click Save.
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10. Edit the report from Templates.

a. Navigate to the Templates location.

b. Search for the report definition you want to edit, select it, and choose More Commands >
Edit  > Edit Report.

c. Make the necessary changes and save the report.

11. Generate the report.

a. Search for the object for which you want to generate the report.

b. Select the object, and choose More Commands > New  > Generate Report.

c. Select the report you created and click Generate.

The report is generated by fetching the latest data from the database.

12. Drill down the report to find specific data.

a. To open the report from any dashboard, hover over the report title until a link appears, and
click the title link to open it. Alternatively, select the report and click More Commands >
Open.

From Templates, select the report and click Open.

b. Select a specific area of the chart, for example, Complete in the State or Status charts.

The chart and the table area show objects specific to the selection.

c. Click the State Complete button to close this view.

d. Click the bar chart in the Work Complete Percent area.

The chart and the table area show objects specific to the selection.

e. Click the Work Complete Percent button to close this view.

13. Export the table area of the report to Microsoft Excel.

a. To open the report from any dashboard, hover over the report title until a link appears, and
click the title link to open it. Alternatively, select the report and click More Commands >
Open.

From Templates, select the report and click Open.

Create and generate an active item report from various sublocations
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b. Click Export to Excel above the table area of the report.

c. Click Add Properties and deselect the properties that you do not want to be displayed in the
exported report.

d. To download the report, click Export.

e. Click Downloads in your browser to open the exported file.

Create an active item report for a program

You can create an active item report for a program.

The process for creating and generating an active item report is as follows:

Procedure

1. Search for the program, select it, apply appropriate filters, click More Commands > New > Create
Report and select Active item report.
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Alternatively, create the report definition and add the data for the report by performing the
following steps:

a. On the HOME page, click the REPORTS tile.

b. In My Dashboard or Templates, choose More Commands > New  > Create Report.

c. To create an item report, from the Type menu, select Active item report.

d. Search for the data you want to include in the report in the Search Item panel, select it, and
click Select.

Example:

Create an active item report for a program
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2. Add relations for the report.

a. To add the relations, click Add and click Pin Panel to add multiple relations.

The system displays all the possible relations of the source object.

Column name Description
Relation (Object) Displays the relation name and the type of object this particular relation

returns.
Relation Type Displays the relation type such as primary, secondary, reference, or

referenced by.
Count Displays the number of objects that are related.

b. Select the appropriate relation object and click Add. Keep adding relations as appropriate.
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Example:

3. Select a layout for the report and add charts

You must first create the report definition and add the data for the report before you can select a
layout and add charts and a table.

a. Specify a report title.

b. Specify the number of charts you want to add for this report by selecting the appropriate
option.

c. Select Bar Chart, Pie Chart, or Line Chart for the type of chart you want to create.

d. To create a layout for the report, click Edit.

Create an active item report for a program
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e. To add a property for the chart, from the Chart On list, select a value, for example, State.

f. To add the second and third charts, repeat the above steps. You can choose other properties
for the second and the third chart, for example, Status and Work Complete Percent,
respectively.

You can add additional chart properties depending on how the administrator has configured
your Teamcenter environment. Consult your administrator for more information.

g. Specify a title for the chart type or accept the default title.

h. To save this chart type, click Save.

i. After creating more than one chart, to move the chart, click … More Commands and select
the appropriate option.

4. To display the data in a tabular format, add a table for the report.

a. In the TABLE area, click Table Settings > Arrange.

b. From Available Columns, select column name properties such as State, Status, Object,
Finish Date, Schedule, and Actual Start Date, and click  to move them to Displayed
Columns.

c. (Optional) To rearrange the columns in the table, in the Column Name area, select a column
name, click the column widget, and move the column up or down.

d. To save the column arrangement, click Arrange.
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5. Add filters to the relations you have added. You can add filters, for example, to display only
schedules that are in progress or display only tasks that are complete or not started.

a. To display only schedules that are in progress in the report you are creating, select Edit
Relations and click Add Filter.

The system displays a warning message.

b. Select Keep to retain dependent relations.

c. Select In Progress from the State filter and click Add Filter.

d. To display only tasks that are complete or not started in the report you are creating, repeat
step a and step b.

e. Select Completed and Not Started from the State filter and click Add Filter.

Create an active item report for a program
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6. Save the report as a template.

a. To save the report as a template, click Save as Template.

b. (Mandatory) Specify a name for the report.

c. (Optional) Include a description.

d. Click Save.

7. Edit the report from Templates.

a. Navigate to the Templates location.

b. Search for the report definition you want to edit, select it, and choose More Commands >
Edit  > Edit Report.

c. Make the necessary changes and save the report.

8. Generate the report.
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a. Search for the object for which you want to generate the report.

b. Select the object, and choose More Commands > New  > Generate Report.

c. Select the report you created and click Generate.

The report is generated by fetching the latest data from the database.

9. Drill down the report to find specific data.

a. To open the report from any dashboard, hover over the report title until a link appears, and
click the title link to open it. Alternatively, select the report and click More Commands >
Open.

From Templates, select the report and click Open.

b. Select a specific area of the chart, for example, Complete in the State or Status charts.

The chart and the table area show objects specific to the selection.

c. Click the State Complete button to close this view.

d. Click the bar chart in the Work Complete Percent area.

The chart and the table area show objects specific to the selection.

e. Click the Work Complete Percent button to close this view.

10. Export the table area of the report to Microsoft Excel.

a. To open the report from any dashboard, hover over the report title until a link appears, and
click the title link to open it. Alternatively, select the report and click More Commands >
Open.

From Templates, select the report and click Open.

b. Click Export to Excel above the table area of the report.

c. Click Add Properties and deselect the properties that you do not want to be displayed in the
exported report.

d. To download the report, click Export.

e. Click Downloads in your browser to open the exported file.

Create an active item report for a program
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Create an active item report for scheduled tasks

You can create an active item report for scheduled tasks.

The process for creating and generating an active item report is as follows:

Procedure

1. (Optional) Create the sample data for scheduled tasks.

The following procedures are optional. These tasks have a schedule object as the parent in this
example. At your site, you can search for the appropriate object to add as the sample source to
validate the related data.

a. On the HOME page, click the Schedules tile.

b. Choose More Commands > New  > Create Schedule > Schedule and specify the name as
Test_Schedule.

c. Specify information as appropriate and click Create.

d. Open the schedule you created, click the Tasks tab, click Add Schedule Task  and select
Schedule Task.

e. Specify the name, add other information as appropriate, and click Add.

2. Create the report definition and add the data for the report.

a. On the HOME page, click the REPORTS tile.
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b. In My Dashboard or Templates, choose More Commands > New  > Create Report.

c. To create an item report, from the Type menu, select Active item report.

3. Search for the data you want to include in the report.

a. To search for the item you want to include in the report, type, search for a schedule in the
Search Item panel, select it, and click Select.

In this example, you can search for Test_Schedule as per the sample data you created.

b. To add the relations, click Add and click Pin Panel to add multiple relations.

The system displays all the possible relations of the source object.

Column name Description
Relation (Object) Displays the relation name and the type of object this particular relation

returns.
Relation Type Displays the relation type such as primary, secondary, reference, or

referenced by.
Count Displays the number of objects that are related.

Create an active item report for scheduled tasks
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c. Select the appropriate relation object and click Add. Keep adding relations as appropriate.

4. Select a layout for the report and add charts

4. Working with data

4-106  Retail Footwear and Apparel ─ Fundamentals, Teamcenter 2412
© 2025 Siemens



You must first create the report definition and add the data for the report before you can select a
layout and add charts and a table.

a. Specify a report title.

b. Specify the number of charts you want to add for this report by selecting the appropriate
option.

c. Select Bar Chart, Pie Chart, or Line Chart for the type of chart you want to create.

d. To create a layout for the report, click Edit.

e. To add a property for the chart, from the Chart On list, select a value, for example, Status.

f. Specify a title for the chart type or accept the default title.

g. To save this chart type, click Save.

h. To add the second and third charts, repeat the above steps. You can choose other properties
for the second and the third chart, for example, State and Priority, respectively.

You can add additional chart properties depending on how the administrator has configured
your Teamcenter environment. Consult your administrator for more information.

i. After creating more than one chart, to move the chart, click … More Commands and select
the appropriate option.

5. To display the data in a tabular format, add a table for the report.

a. In the TABLE area, click Table Settings > Arrange.
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b. From Available Columns, select column name properties such as Object, Task Type,
Description, State, and Status, and click  to move them to Displayed Columns.

c. (Optional) To rearrange the columns in the table, in the Column Name area, select a column
name, click the column widget, and move the column up or down.

d. To save the column arrangement, click Arrange.

6. Save the report as a template.

a. To save the report as a template, click Save as Template.

b. (Mandatory) Specify a name for the report.

c. (Optional) Include a description.

d. Click Save.

7. Edit the report from Templates.

a. Navigate to the Templates location.

b. Search for the report definition you want to edit, select it, and choose More Commands >
Edit  > Edit Report.

c. Make the necessary changes and save the report.

8. Generate the report.

a. Search for the object for which you want to generate the report.

b. Select the object, and choose More Commands > New  > Generate Report.

c. Select the report you created and click Generate.

The report is generated by fetching the latest data from the database.

d. (Optional) Create another schedule task.

A. Open the schedule you created, click the Tasks tab, click Add Schedule Task , and
select Schedule Task.

B. Specify a name, add other information as appropriate, and click Add.

C. (Optional) Run the report again to see the new scheduled task.
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9. Export the table area of the report to Microsoft Excel.

a. To open the report from any dashboard, hover over the report title until a link appears, and
click the title link to open it. Alternatively, select the report and click More Commands >
Open.

From Templates, select the report and click Open.

b. Click Export to Excel above the table area of the report.

c. Click Add Properties and deselect the properties that you do not want to be displayed in the
exported report.

d. To download the report, click Export.

e. Click Downloads in your browser to open the exported file.

Create an active item report for change requests

You can create an active item report for change requests.

The process for creating and generating an active item report is as follows:

Procedure

1. (Optional) Create the sample data for the change request.

The following procedures are optional. These change requests have part revisions as a problem
item in this example. At your site, you can search for the appropriate object to add as the sample
source to validate the related data.

Create an active item report for change requests
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a. Select Explorer and choose More Commands > New  > Add > Part and specify the name
as Test_Part.

b. In Explorer, select the part you created and choose More Commands > New  > Create
Change > Change Request, fill the required boxes, and click Create and Submit.

c. Open the change request and choose the Affected Items tab. It displays the Test_Part part
revision. In this example, while creating the report, a backward traversal rule is being created
from the part revision to the change request.

d. Open the part revision and choose the Changes tab. This part has a relation type of Problems
with the change request you created.

2. Create the report definition and add the data for the report.

a. On the HOME page, click the REPORTS tile.

b. In My Dashboard or Templates, choose More Commands > New  > Create Report.

c. To create an item report, from the Type list, select Active item report.

3. Search for the data you want to include in the report.

a. To search for the item you want to include in the report, click Search Item.

For example, type Test_Part to search for a part in the Search Item panel, select it, and click
Select.
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b. To add the relations, click Add Relations and click Pin Panel to add multiple relations.

The system displays all the possible relations of the source object.

Column name Description
Relation (Object) Displays the relation name and the type of object this particular relation

returns.
Relation Type Displays the relation type such as primary, secondary, reference, or

referenced by.
Count Displays the number of objects that are related.

c. Select the appropriate relation object and click Add. Keep adding relations as appropriate.
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4. Select a layout for the report and add charts.

You must first create the report definition and add the data for the report before you can select a
layout and add charts and a table.
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a. Specify a report title.

b. Specify the number of charts you want to add for this report by selecting the appropriate
option.

c. Select Bar Chart, Pie Chart, or Line Chart for the type of chart you want to create.

d. To create a layout for the report, click Edit.

e. To add a property for the chart, from the Chart On list, select a value, for example, Status.

f. Specify a title for the chart type or accept the default title.

g. To save this chart type, click Save.

h. To add the second and third charts, repeat the above steps. You can choose other properties
for the second and the third chart, for example, State and Priority, respectively.

You can add additional chart properties depending on how the administrator has configured
your Teamcenter environment. Consult your administrator for more information.

i. After creating more than one chart, to move the chart, click … More Commands and select
the appropriate option.

5. To display the data in a tabular format, add a table for the report.

a. In the TABLE area, click Table Settings > Arrange.
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b. From Available Columns, select column name properties such as Maturity, Disposition,
Closure, and Creation Date, and click  to move them to Displayed Columns.

c. (Optional) To rearrange the columns in the table, in the Column Name area, select a column
name, click the column widget, and move the column up or down.

d. To save the column arrangement, click Arrange.

Note:

(Optional) You can add additional columns to the table depending on how the administrator
has configured your Teamcenter environment. Consult your administrator for more
information.

6. Save the report as a template.

a. To save the report as a template, click Save as Template.

b. (Mandatory) Specify a name for the report.

c. (Optional) Include a description.

d. Click Save.

7. Edit the report from Templates.

a. Navigate to the Templates location.

b. Search for the report definition you want to edit, select it, and choose More Commands >
Edit  > Edit Report.

c. Make the necessary changes and save the report.

8. Generate the report.

a. Search for the object for which you want to generate the report.

b. Select the object, and choose More Commands > New  > Generate Report.

c. Select the report you created and click Generate.

The report is generated by fetching the latest data from the database.

d. (Optional) Create another schedule task.
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A. Open the schedule you created, click the Tasks tab, click Add Schedule Task , and
select Schedule Task.

B. Specify a name, add other information as appropriate, and click Add.

C. (Optional) Run the report again to see the new scheduled task.

9. Export the table area of the report to Microsoft Excel.

a. To open the report from any dashboard, hover over the report title until a link appears, and
click the title link to open it. Alternatively, select the report and click More Commands >
Open.

From Templates, select the report and click Open.

b. Click Export to Excel above the table area of the report.

c. Click Add Properties and deselect the properties that you do not want to be displayed in the
exported report.

d. To download the report, click Export.

e. Click Downloads in your browser to open the exported file.

Using Projects

What are projects and programs?

Companies have programs that usually include cross-functional teams. These programs can have a
collection of related projects under them, each of which focuses on a specific tangible output.

A typical project comprises a group of users each having one or more roles.

What are projects and programs?
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Using Projects allows you to organize your data and control access to collections of related data,
which may be accessible to multiple organizations. These organizations can include project teams,
development teams, suppliers, and customers.

Why do I want to use Projects?

You can view and manage your projects in either the Projects or the Explorer location. Use the
PROJECTS tile or the EXPLORER tile to access these locations.

If you are a privileged team member, you can manage your projects and programs by assigning or
removing objects from them. If you are a project or team administrator, you can manage your team
members. As a project administrator, you can also modify the properties of your project or program.

You must use the rich client to delete projects and programs. You must also use the rich client to create
and manage single-level hierarchical projects.

What privileges do project administrators and team members have?

The following table describes the privileges of the administrators and team members for any project.
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Add, remove, or
assign status to
members, including
team administrator

Assign or remove
objects from projects
and programs View objects

Project Administrator Yes Yes Yes
Team Administrator1 Yes Yes Yes
Privileged team
member

Yes Yes

Non-privileged team
member

Yes

Browsing projects and project data

You can view the projects of which you are a member and browse categorized lists of the data in those
projects.

You can view project information in both the Projects and Explorer locations using the respective tiles
to access each location.

Viewing project information in Projects

In the Projects location, you can view the projects of which you are a member in a list or table view.

Overview displays the details of the Properties and Team Members for the project.

Open a project to view the project data contents.

Viewing project information in Explorer

In the Explorer location, expand the Project Data folder to view the projects of which you are a
member.

The view displays a folder for each of your projects. You can expand these folders to browse different
types of data objects in those projects.

1 Each project or program can have multiple team administrators. Having multiple team administrators allows you to
balance resource management tasks for large projects.

Browsing projects and project data
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A list of folders representing projects of which you are a member (2) appears under the Project Data
folder (1). Each project folder expands to show folders for object types (3). You can expand each object
type folder to see the objects of that type in the selected project. The default object types are Items,
Parts, Documents, Change requests, and Files. Project data that is assigned to the project but does not
apply to the available object type folders can be displayed in two ways:

• By default, in a More project data folder in the project folder.

• As a list in the project folder. To organize the project data as a list in the project folder, access the
Search Settings panel and clear Show the more project data folder.

Note:

An administrator can customize the folder content, so what you see when you expand it might
differ from the default. Be aware that the Project Data folder appears in the tree even if your
organization does not use projects.

Create a project or program

You can create a new project or a program in Projects or Explorer. In Projects, you can also leverage
an existing project or program to create another. If configured by your administrator, all users can create
projects and programs.

Add a new project or program

1. Complete one of the following according to the location in which you are creating the project:
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• In Projects, verify you do not have a project selected and click Add Project .

• In Explorer, select the Project Data folder and click Create Project .

To create multiple projects or programs, click Pin Panel  on the Add Project panel.

2. Enter the ID and name of the new project or program.

Project and program names must be unique within your site. Also, they cannot be the same as any
group within your site.

3. (Optional) Add a description.

4. (Optional) Select a project category from the drop-down list: Internal, Partner, or Supplier.

Project categories allow you to control access to objects in a project without using access control
rules.

5. Select either Project (default) or Program.

6. Click Add.

Your newly created project or program:

• Appears at the top of the projects list in Projects.

• Appears in alphabetical order in the Project Data folder in Explorer.

• Is set to Active and Visible, as shown in Properties.

• Shows you as both the Project Administrator and Team Administrator, as shown in Team
Members.

Leverage your existing project or program

1. From the Projects location, select an existing project or program for which you are a Project
Administrator or have DBA privileges.

2. Click Save As .

To create multiple projects or programs, click Pin Panel  on the Save As New Project panel.

3. Edit the ID and name of the new project or program to make them unique.

Project and program names must be unique within your site. Also, they cannot be the same as any
group within your site.

Create a project or program
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4. (Optional) Modify the description.

5. (Optional) Modify the project category by selecting a project category from the drop-down list:
Internal, Partner, or Supplier.

Project categories allow you to control access to objects in a project without using access control
rules.

6. (Optional) Select Include project data and libraries to include project data and libraries.

7. Click Save.

Your newly created project or program appears at the top of the Projects list and is highlighted.
By default, the newly created project or program is set to Active and Visible, as shown in the
PROPERTIES section.

By default, the project or program team, along with the accompanying metadata, is copied to the
newly created project or program.

If you selected Include project data and libraries, you can open your newly created project and
select the Contents tab to verify the project data and libraries were successfully included.

Modify projects and programs

Edit project and program properties

You can modify project or program properties to accommodate changes to the project.

• In Projects, in the Overview tab for the project, click Edit .

• In Explorer, in the Advanced tab for the project, click Edit .

In the Properties section, you can modify your project and program properties when you may want to:

• Change project category. For example, you could change the project category from Internal to
Supplier.

• Remove Active status if your project or program is no longer active.

• Remove Visible status if your project or program is no longer active.

Add objects or assemblies to a project

As your project progresses, you may need to add objects or assemblies. Project-level security is assigned
to an object or assembly when you add it to a project.
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You can add objects to a project in which you are a privileged member in the following ways:

• Assign a project to an object or assembly.

• Add an object to a project.

• Upload a file to a project.

• Drag and drop an object into a project.

Assign a project to an object or assembly

1. Select one or more parts, documents, or other objects.

2. Click More commands  > Manage   > Projects .

The Projects panel is displayed with Member of and Owning tabs.

3. You can add projects to the object in the following ways:

• In the Owning tab, select a project from the Available list and click Add Project  to move the
project to both the Member of and Owning project lists.

• In the Member of tab, select a project from the Available list and click Add Project  to move
the project to the Member of project list.

4. Associate the objects with This Revision or All Revisions.

If All Revisions is selected, the project is assigned to the object and all revisions.

5. If the object is an assembly, select either Entire Structure to add the structure or Level to add the
item.

6. If the object is a folder, you can select whether to assign the project to Folders Only or to Folders
and Content.

7. Click Save.

Add an object to a project

1. In Explorer, expand the Project Data folder.

2. Select the project folder to which you want to add an object.

3. Click Add .

Add objects or assemblies to a project
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4. In the Add panel, select the object you want to add in one of the following ways:

• Use New to create a new object for the project. Select the Type and enter the applicable
Properties.

• Use Palette to select an existing object that was recently accessed or saved.

• Use Search to find an existing object.

5. Click Add.

The object is added to the project. Depending on the configuration set by your administrator for the
project data folders, a few minutes may pass until the object is categorized into the applicable folder in
the project folder.

Upload a file to a project

1. In Explorer, expand the Project Data folder.

2. Select the project folder to which you want to add an object.

3. Click Upload .

4. Select the file you want to upload.

5. Click Add.

The uploaded file is added to the applicable object type folder in the project folder.

Drag and drop an object into a project

1. In Explorer, expand the Project Data folder.

2. Expand the folder that contains the object you want to add to a project.

3. Click on the object you want to add and drag it to the applicable project folder.

The object is added to the applicable object type folder in the project folder.

Add folders to a project

As your project progresses, you may want to add folders to your project. Project-level security is assigned
to a folder when you add it to a project.

You can add just a folder or a folder and its contents to a project in which you are a privileged member
using one of the following methods:
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• Copy and paste a folder into a project.

• Drag and drop a folder into a project.

• Assign a project to a folder.

Copy and paste a folder into a project

1. In Explorer, select one or more folders you want to add to a project.

2. Right-click and select Copy.

3. In the Project Data folder, select the project to which you want to add the folder.

4. Right-click and select Paste.

5. When the message is displayed:

• Select Folder Only to add only the folder to the project.

• Select Folder and Content to add the folder and all its contents to the project.

Drag and drop a folder into a project

1. In Explorer, expand the Project Data folder.

2. Select one or more folders you want to add and drag it to the applicable project folder.

3. When the message is displayed:

• Select Folder Only to add only the folder to the project.

• Select Folder and Content to add the folder and all its contents to the project.

Assign a project to a folder

When a folder is assigned to a project, you can add the folder content to the project. This is useful if the
folder was previously assigned to the project without content or if additional content has been added to
the folder outside the project.

1. In Explorer, select one or more folders currently assigned to a project in which you want to add the
folder content the project.

2. Right-click and select Assign project to folder content.

Add folders to a project
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3. Select the project to which the folder and its contents should be added.

4. Click Save.

Remove objects from a project

As your project progresses, you may need to remove objects or assemblies. Project-level security is
removed from an object or assembly when you remove it from a project.

Unassign a project from an object or assembly

1. Select one or more parts, documents, or other objects.

2. Click More commands  > Manage   > Projects .

The Projects panel is displayed with Member of and Owning tabs.

3. You can remove the selected objects from a project.

• In the Owning tab, select a project from the Available list and click Replace to replace the
owning project.

• In the Member of tab, select a project and click Remove Project  to move the project to the
Available project list.

4. Associate the objects with This Revision or All Revisions.

5. Click Save.

Remove an object from a project

1. In Explorer, expand the Project Data folder.

2. Expand the project folder from which you want to remove an object.

3. Select the object type folder from which you want to remove an object.

4. In Contents, select the object you want to remove.

5. Click Remove .

6. If the object is a folder, do the following when the message is displayed:

• Select Folder Only to remove only the folder from the project.

4. Working with data
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• Select Folder and Content to remove the folder and all its contents from the project.

Manage project team members

You can manage your project team members to streamline collaboration, ensure everyone has access to
the latest project information, and maintain clear communication.

As the creator of the project or program, you are automatically assigned both Project Administrator and
Team Administrator status. You can add, remove, or assign a status to users, roles, or groups.

• In Projects, select a project to view and manage your Team Members.

• In Explorer, select a project folder and navigate to Members to view and manage your Team
Members.

You can perform search, sort, and facet filtering on each of the columns (Name, Type, and Status) to
locate specific team members.

Add a user, role, or group to your project

1. In Team Members, click Add .

2. Search and filter to find the groups, roles, or users you want to add to the project.

3. In Results, select the groups, roles, and users you want to add to the project.

4. Click Add.

Add a user, role, or group to multiple projects

1. In Projects, click Selection Mode  to enable multiple selections.

2. Select the projects to which you want to add team members.

3. Click Add Team Members above the project list.

4. Search and filter to find the group, role, or user you want to add to the projects.

5. Click Add.

Remove a user, role, or group from your project

1. In Team Members, select the group, role, or user you want to remove from the project.

2. Click Remove .

Manage project team members
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Assign a status to a user in your project

1. In Team Members, select the group, role, or user to which you want to assign a status.

2. Select a status for the group, role, or user:

• Set Non-privileged  allows users to view objects.

• Set Privileged  allows users to view objects and add or remove objects.

• Set Team Administrator  allows users to view objects, add or remove objects, and manage
team members.

Assign a default project for your team member

1. In Team Members, select the group, role, or user to which you want to assign a default project.

2. Click Set Default Project.

The user can confirm their default project from the global header by clicking the profile icon.

Assign a project during a Save As operation

If you are a privileged member of one or more projects, you can assign objects, such as parts and
documents, to projects during a Save As operation.

1. Select a part, document, or another object.

2. Click More commands  > New   > Save As .

3. From the PROJECTS section, click Add Project .

4. Select one or more projects from the list of available projects.

5. Click Assign to assign the selected projects to the new item.

6. Click Save to save the projects added.

You can verify the projects that were assigned from the PROJECTS section of the Overview tab of
the newly created item.

Assign a project when creating a revision

If you are a privileged member of one or more projects, you can assign objects, such as parts and
documents, to projects.
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1. Select a part, document, or another object.

2. Click More commands  > New   > Revise. .

3. From the Revise dialog box, ensure Revision is set correctly.

4. From the PROJECTS section, click Add Project .

5. Select one or more projects from the list of available projects.

6. Click Assign to assign the selected projects to the new object.

7. Click Save to assign the projects to the new revision.

You can verify the projects that were assigned from the PROJECTS section of the Overview tab of
the newly created object.

Set or change an owning program

You can set the owning program on an object to control access to data.

• You must be a privileged user with Assign to Project access for the selected objects.

• The autoAssignToProject extension must be configured for object types.

• You can select one or more objects (for example, item or item revision) and set an owning program,
if the selected objects do not have an owning program already set. Once set, the owning program is
set for all related objects if propagation rules are defined for the respective relation. The projects list is
also updated.

• You can change the owning program of an object.

Set an owning program

You can set an owning program for an object to control access to data. Once set, the owning program
is set for all related objects if propagation rules are defined for the respective relation. The projects list is
also updated.

1. Select one or more objects.

Note:

You can select multiple objects and assign the owning program. However, the Owning
tab displays the owning program only when the selected objects have the same owning
program.

Set or change an owning program
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2. Click Manage   > Projects .

3. Select the Owning tab to display the list of available projects.

4. Select an owning program and click Set .

5. Click Save.

In the Overview tab, the Owning Project and Projects fields in the PROJECTS section are updated
with the owning project information.

Change an owning program

1. Select one or more objects.

Note:

You can select multiple objects and assign the owning program. However, the Owning
tab displays the owning program only when the selected objects have the same owning
program.

2. Click Manage   > Projects .

3. Select the Owning tab to view the owning program.

4. From the list of available programs, select the new owning program. A Replace icon  appears.

5. Click Save.

In the Overview tab, the Owning Project and Projects fields in the PROJECTS section are updated
with the owning project information.
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5. Using Subscriptions
Overview of subscriptions

Subscriptions are objects you are following using the Follow  command.

When the objects you are following are changed, for example, when your data is modified by another
user or as the release status of an item revision changes, you receive notifications in near real time
using external email, news feed, or both. In addition to these notifications, Alerts  notifies you when
subscription notifications are received.

Basic concepts

Use the Subscription feature to be notified of events, such as:

• An item or item revision is checked in or checked out (site or remote) or canceled.
• An item is modified or deleted.
• New subscription recipients.

Follow a single object

You can subscribe to follow a single object. When you no longer need to subscribe to the object, you can
unfollow the subscription.

1. Select an object to follow and click More commands  > Share  > Follow .

The Follow panel is displayed listing the default event types (Assign Status, Attach, and New Item
Revision).

2. Select the event type you want to follow.

a. Click Edit  next to the My Events check box to view your selected events and the available
events.
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b. From Available Events, select an event from the event list and click Add to selected events
.

If you are already subscribed to an event type, that event type does not appear in the
Available Events list.

c. Click Back .

3. Optionally, you can edit the object name.

4. Select the Frequency of the subscription. The default is Immediately.

• Immediately (not collated)

• Daily (daily digest)

• Weekly (weekly digest)

5. Select the Priority of the subscription. The default is Normal.

• Normal

• High

• Low

6. (Optional) In the Followers section, click Add Follower  to find a user to add as a follower. Filter
or scroll to find the user you want to add as a follower. Select the user by their group and role and
click Add. You can select and add multiple followers.

When you unfollow the object, any followers you added will be unfollowed. Also, any followers you
add to an object can unfollow the object at any time.

7. Click Follow.

Your subscription appears in My Subscriptions.

Follow multiple objects

You can subscribe to follow multiple objects at a time. When you no longer need to subscribe to the
objects, you can unfollow the subscription.

Procedure

1. Select the objects you wish to follow and click More commands  > Share  > Follow .

5. Using Subscriptions
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Event Type lists the types common to all selected objects. The number of objects to which you can
subscribe at one time is configured by your administrator.

2. From Event Type, select the event type you want to follow.

3. Select the Frequency of the subscription. The default is Immediately.

• Immediately (not collated)

• Daily (daily digest)

• Weekly (weekly digest)

4. Select the Priority of the subscription. The default is Normal.

• Normal

• High

• Low

5. (Optional) In the Followers section, click Add Follower  to find a user to add as a follower. Filter
or scroll to find the user you want to add as a follower. Select the user by their group and role and
click Add. You can select and add multiple followers.

When you unfollow the object, any followers you added will be unfollowed. Also, any followers you
add to an object can unfollow the object at any time.

6. Click Follow.

Your subscription appears in My Subscriptions.

Follow an object type

You can follow an object type, for example, Item or ItemRevision.

1. Select a subscription in My Subscriptions.

2. Click More commands  > Share   > Follow Type .

3. In the Follow Type panel, select the event type from Other you want to follow. Then, select the
frequency and the priority. You can also add other users as followers.

4. Select the Frequency of the subscription. The default is Immediately.

Follow an object type

Retail Footwear and Apparel ─ Fundamentals, Teamcenter 2412  5-3
© 2025 Siemens



• Immediately (not collated)

• Daily (daily digest)

• Weekly (weekly digest)

5. Select the Priority of the subscription. The default is Normal.

• Normal

• High

• Low

6. (Optional) In the Followers section, click Add Follower  to find a user to add as a follower. Filter
or scroll to find the user you want to add as a follower. Select the user by their group and role and
click Add. You can select and add multiple followers.

When you unfollow the object, any followers you added will be unfollowed. Also, any followers you
add to an object can unfollow the object at any time.

7. Click Follow.

Your subscription appears in My Subscriptions.

Follow multiple events on an object

You can use the My Events list to follow multiple events on an object. However, the number of objects
to which you can subscribe at one time is configured by your administrator.

1. Select an item revision, for example, Hard Drive Assembly, and click More commands  >
Share   > Follow .

The Follow panel opens with My Events checked.

2. Click Edit  to view selected events and available events.

Three events, Assign Status, Attach, and New Item Revision, are configured by default.

3. You can scroll through the Available Events list and select additional events to follow. Click Add to
selected events .

4. Once you have a selected list of events to follow, click Back .

5. Select the My Events check box to follow all the configured events and click Follow.

5. Using Subscriptions
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If an event type, such as New Item Revision, does not appear in the Event Type list, it is because it
is not applicable for the selected object. Also, any non-applicable and already-subscribed-to events
are filtered out.

Unfollow a subscription in My Subscriptions

You can subscribe to follow a single object, multiple objects, an object type, or events on objects. When
you no longer need to subscribe to the objects, you can unfollow the subscription.

Procedure

1. Click the SUBSCRIPTIONS tile.

2. Select My Subscriptions to view your subscriptions.

3. Select the subscriptions you want to unfollow and click Unfollow . If you have only one
subscription selected, you can also click Unfollow from the Followers area.

4. From the confirmation dialog box, click Unfollow.

Both you and any followers you added to the subscription will no longer follow the object.

Unfollow a subscription in Added as Follower

You can subscribe to follow a single object, multiple objects, an object type, or events on objects. When
you no longer need to subscribe to the objects, you can unfollow the subscription.

Procedure

1. Click the SUBSCRIPTIONS tile.

2. Select Added As Follower.

3. Select the subscriptions you want to unfollow and click Unfollow . If you have only one
subscription selected, you can also click Unfollow from the Followers area.

Only you will be removed as a follower. The user who added you as a follower on the object will
continue to follow the object.

4. From the confirmation dialog box, click Unfollow.

View notifications using Alerts

Alerts  notifies you when specific items have changed. A number on the Alerts  appears when
notifications are received. If this button is not visible, your administrator has disabled it.

Unfollow a subscription in My Subscriptions
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Click Alerts  to view various types of notifications, such as:

• Print (indicating asynchronous print jobs are ready).
• News Feed (indicating a change has taken place on an object or activity to which you are subscribed).
• Document Management (indicating document rendering is complete or document property updates

are complete).

You can click on the category, for example, News Feed, to see details on the notifications.

If you click an object, the target page for the object displays.

• When you click on a notification, the counter decreases by one (1).
• To clear all notifications, click Clear.
• A maximum of 10 alerts is displayed per category.

View and delete notifications and subscriptions

You can view and optionally delete notifications and subscriptions using the SUBSCRIPTION tile.

1. From the home page, click the SUBSCRIPTION tile.

2. From the Subscriptions page, use the following:

• News Feed to view and delete your notifications.
• My Subscriptions to view and delete subscriptions that you configured.

5. Using Subscriptions
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• Added As Follower to view and delete subscriptions to which you have been added as a
follower.

Filter your news feed notifications

From the News Feed tab on the Subscriptions page, you can filter your news feed notifications to easily
access the notifications you want to view.

When notifications are available, the Filters panel is open by default. Once you close the Filters panel in
a session, it remains closed for that session.

1. Click the SUBSCRIPTIONS tile.

2. Click News Feed to display your notifications.

3. If the Filters panel is not already displayed, click Filters  to display it. The Filters panel shows
categories of subscription notifications, such as: Message Type and Event.

4. Select from the different categories. For example, by selecting Subscription Manager, you only see
notifications pertaining to Subscription Manager.

5. To save your filter selection for later use, click Save Filter Selection. Notifications from the saved
filter are loaded when the News Feed tab is displayed.

To modify the saved filter selection, change the filter selection and save it.

Managing your subscriptions

Add followers to your subscriptions

You can add followers to existing subscriptions.

1. Click the SUBSCRIPTIONS tile.

2. Click My Subscriptions to display your existing subscriptions.

3. Select the subscription to which you want to add followers.

Notice that your name already appears in the table in the Followers section of the Overview tab of
the item to which you have subscribed.

4. Click Edit .

5. In the Followers section, click Add Follower .

Filter your news feed notifications
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6. Filter for or scroll to the user you want to follow your subscription.

7. Select the user by their group and role. You can select multiple users. Click Add.

8. Click Save  to save the followers displayed in the Followers table.

The users you added as followers can now view their new subscription by clicking Added As
Follower on the Subscriptions page.

Add an expiration date to your subscriptions

You can add an expiration date to each of your subscriptions if your administrator enabled the expiration
date feature.

1. Click the SUBSCRIPTIONS tile.

2. Click My Subscriptions and select an existing subscription.

3. Click Edit  to edit the Properties section. Add an expiration date for the desired subscription.

Note:

If you want to change your subscription to inactive, clear the Is Active check box.

4. Click Save .

Change the owner of your subscription

You can change the owner of your subscription. This is helpful if you are leaving the project or the
company.

1. Click the SUBSCRIPTIONS tile.

2. Click My Subscriptions and select an existing subscription.

3. Click More commands  > Manage  > Change Owner .

4. Select the new owner on the Change Owner panel and click Transfer.

This immediately removes the subscription from your My Subscriptions list.

5. Using Subscriptions
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Temporarily transfer notification of your subscriptions

You can temporarily transfer notification of your subscriptions. This is especially helpful if you are going
to be out of the office for a period of time. You can select a colleague to take over as owner of the
subscription during that time.

1. Click the SUBSCRIPTIONS tile.

2. Click My Subscriptions and select an existing subscription.

3. Click More commands  > Share  > Transfer Notification .

4. From the Transfer Notification panel, select the start and end dates for the transfer notifications
and add a follower as a temporary notifier.

5. Click Transfer to save your changes.

The following fields in the Properties section are updated:

• Temporary Notifier

• Temporary Notification Start Date

• Temporary Notification End Date

Set your subscription notification method and retention time

You can specify how you want to receive your subscription notifications and specify how long your
notifications are retained.

Use the Subscriptions section on your Profile page to:

• Set your subscription notification method.

You can receive your subscription notifications in near real time using either external email, news feed
or both depending on your notification method.

• Set your news feed retention time.

You can indicate whether you want to retain your news feed for a few days or if you want to keep your
news feed messages indefinitely.

Temporarily transfer notification of your subscriptions
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Set your subscription notification method

1. From your Profile page, click More commands  > Edit  > Start Edit .

2. From the Notification Method list in the Subscriptions section, select one of the notification
methods.

3. (Optional) Select the option of receiving daily and weekly digests that collate all notifications.

4. Click More commands  > Edit  > Save Edits  to save your selections.

Set your news feed retention time

You can specify whether you want to retain your news feed for a few days or if you want to keep your
news feed messages indefinitely.

1. From your Profile page, click More commands  > Edit  > Start Edit .

2. In the Retain News Feed (In Days) field, enter the number of days you want to keep your news
feed messages.

Leave this field empty (the default) to retain news feed messages indefinitely.

3. Click More commands  > Edit  > Save Edits .

5. Using Subscriptions
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