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1. Managing ECAD designs in Teamcenter
Teamcenter Electronic Design Automation (EDA) integrates Siemens EDA electronic computer aided
design (ECAD) applications with Teamcenter to allow the ECAD designers to move design data into and
out of Teamcenter and manage ECAD part library data in Teamcenter.

Teamcenter EDA supports ECAD design integration and ECAD part library integration. Both these
integrations are separate functionalities and run separately. You can install them either together or
separately, depending on your requirement.

An ECAD designer can use the design integrations that embed Teamcenter menus into the ECAD
design tool to open and save native design files, access approved parts, generate visualization files,
share fabrication and assembly data, create a bill of materials (BOM) containing both mechanical and
electrical parts, and collaborate with other domains and suppliers. In the ECAD tools that do not support
embedded EDA integrations, Teamcenter Gateway for EDA is used for integration instead.

Where do I go from here?

 Administrator See the Xpedition and PADS Integration With
Teamcenter documentation for instructions on
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how to install and configure Teamcenter EDA for
Siemens EDA ECAD applications.

 Administrator See the Installing and Configuring EDA Gateway
for (Non-Siemens EDA) ECAD Applications
documentation for instructions on how to install
and configure EDA Gateway for (non-Siemens
EDA) ECAD applications.

 Library Administrator See Managing Xpedition or PADS Part Library in
Teamcenter for instructions on how to manage
ECAD part library data in Teamcenter.

 ECAD Designer

How do I to access designs in Teamcenter? Once your Teamcenter client is ready for
use and integrated with your ECAD tool, see
the information available in the section on
accessing Teamcenter from your ECAD tool.

Save design files in Teamcenter You can save schematic, PCB, and simulation
designs toTeamcenter. View the list of
commands for saving design files in
Teamcenter.

How can I use the cache and staging directories
in EDA?

The EDA staging directory holds designs
for checkin and checkout operations with
Teamcenter, while the cache stores data
temporarily. See the section on working with
the cache and staging directories for details.

How do I compare BOMs? You can compare the components in the ECAD
design with the components of the same design
in Teamcenter. The section on Comparing
ECAD design BOMs with Teamcenter has
information on this.

Access ECAD designs in Active Workspace Follow the steps provided in the section on how
to open a design in Active Workspace.

Collaborate on the designs across different
domains

EDA allows engineers from different domains to
work on the same BOM and collaborate on the
design creation. The collaboration functionality
is only available for PCB designs. To understand
this better, go through the overview of
collaboration across domains.

1. Managing ECAD designs in Teamcenter
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2. Accessing Teamcenter menu from your
ECAD tool
Prerequisites to enable Teamcenter menu in your ECAD tool

Your Teamcenter client must be up and running and integrated with your ECAD tool before you can use
Teamcenter for managing your designs. This is a one-time process.

If your design tool supports embedding the Teamcenter menu in the user interface, you must enable the
Teamcenter menu on the EDA client for your design tool.

If your design tool does not support embedding the Teamcenter menu, you must configure Teamcenter
Gateway for EDA to perform basic Teamcenter functions, such as opening, checking out, and saving
designs, including schematic designs with or without variants.

Before you enable the menu, verify that:

• The Teamcenter server is operational.

• The Teamcenter rich client or thin client is installed and functional in a two-tier or four-tier setup.

• The ECAD tool installation is complete.

• The TCEDAECAD_ROOT user environment variable was created by the installer and that it points to
the directory where EDA is installed.

• The JAVA_HOME environment variable exists and points to a supported 32-bit or 64-bit JAVA
installation.

Access Teamcenter menu from your ECAD tool

The steps to access the Teamcenter menu commands differ across ECAD tools. Follow the steps given
below to access the Teamcenter menu commands from within your ECAD tool to perform ECAD
operations.

If you are using Xpedition Designer:

Click File and choose the applicable Teamcenter operation from the following options:

• Save to Teamcenter
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• Open from Teamcenter

• Check-In/Out

If you are using Xpedition EDM Design Cockpit:

Choose Actions → Teamcenter.

2. Accessing Teamcenter menu from your ECAD tool
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If you are using Mentor PADS Designer:

Click Teamcenter on the toolbar.

If you are using PADS Layout or PADS Logic

Choose Tools→Basic Scripts→Teamcenter.

From the Teamcenter EDA dialog box, select the operations as required.

Access Teamcenter menu from your ECAD tool
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If the Teamcenter menu is not listed under Tools, perform the steps explained in the Enable Teamcenter
menu in PADS Layout or PADS Logic topic.

Enable Teamcenter menu in PADS Layout or PADS Logic

For Mentor PADS Laout or PADS Logic, if the Teamcenter menu is not listed under Tools, perform the
following steps:

Procedure

1. Add the Mentor PADS application by completing the following steps. This is a one-time procedure.

a. Create Windows shortcuts to the launching scripts located in %TCEDAECAD_ROOT%
\PADS\wnti\bin. You can place these shortcuts on your desktop.

b. Launch PADS Logic and choose Tools→Basic Scripts→Basic Scripts.

c. Click Load File and browse to the Teamcenter.bas customization script located in the
%TCEDAECAD_ROOT%\PADS\wnti\vb directory.

d. Click Open and choose the In Menu command.

e. Click Close and quit the application.

2. From PADS Logic and PADS Layout, choose Tools→Basic Scripts→Teamcenter to display the
Teamcenter palette menu in Mentor PADS.

2. Accessing Teamcenter menu from your ECAD tool
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The palette menu appears on the PADS editing window at the top. You can select any of the
Teamcenter actions by choosing the menu commands.

You can remove the palette menu by clicking Close.

Perform the above steps for the Mentor PADS Layout to activate the Teamcenter menu.

View the EDA task worklist

Choose Teamcenter→Inbox.

The My Worklist view is displayed.

Note:

Refer to the Access Teamcenter menu from your ECAD tool topic for the initial steps to access the
Teamcenter menu commands specific to your ECAD tool to perform the ECAD operation.

View the EDA task worklist
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3. Log on to Teamcenter
When you are not logged on to Teamcenter and you choose any Teamcenter command in your ECAD
design tool, the EDA Login dialog box is displayed.

Note:

The Login dialog box may be hidden behind your design tool dialog box. Minimize or move other
dialog boxes to reveal the Login dialog box.

1. In the Teamcenter Login dialog box, type your user name, password, role, and group (if applicable).

2. Click Login.

3. To log off from EDA, choose Teamcenter→Logout.

The next time you choose a command from the Teamcenter menu, you are prompted to log on.

It is always a good practice to use the Logout command when you complete working in the application.

The Logout command only releases the Teamcenter license. To release the ECAD tool license, use the
ECAD tools.
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3. Log on to Teamcenter
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4. Change your user group or role
1. Navigate to any EDA wizard such as Save As or Revise.

2. Click the link with your name, group, and role.

3. In the User Settings dialog box, change the Group and Role as required and click OK.
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4. Change your user group or role
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5. Managing ECAD designs in Teamcenter
Open a design in Teamcenter from the ECAD tool

To search for a design dataset file in Teamcenter and open it for reference (read-only) or modification
(read and write):

1. In the ECAD design tool, choose Teamcenter→Open.

If prompted, log on.

Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

2. In the Open Design dialog box, browse to the design you want to open.

You can also search for designs based on Type or Criteria.

3. In the ECAD design tool, choose Teamcenter→Design Info.

The design information is displayed.

4. To open the dataset for modification, select the Check-out check box.

5. Click OK.

The dataset opens in the design tool.

Open design related datasets in Teamcenter from the ECAD tool

1. In the ECAD design tool, choose Teamcenter→Open.

If prompted, log on.

Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.
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2. In the Open Design dialog box, browse to the design for which you want to open the related
datasets.

3. (Optional) To open related design files, choose one of the following from Open Related Datasets:

• Blank (do not download)

If the related dataset is not in your cache or is checked out by someone else, you can choose the
blank space or Reference.

• Reference (download only for reference)

If the dataset is already in your cache for reference, Reference is unavailable.

• Check-out (download and check out)

If the dataset is checked out, Check-out is unavailable.

4. Click OK.

The dataset opens in the design tool.

Check out a design

The Check-Out command is used to make revisions to the designs in the staging directory that are saved
in Teamcenter and are in a checked-in state. When you check out the design, a check-out lock is placed
on the design in Teamcenter so that no one else can open it for modification. The Check-out check box
is disabled if you already have a checked-out version of the design in your staging directory or if the
dataset is already checked out to you or someone else.

You can only check out the latest version of the design. You can view earlier versions of a design using
the Open command.

When a design is checked out, the CO (check out) column in Teamcenter displays a Y.

1. If you want to revise a design that you have not worked on before, and the design is therefore not
in your staging directory, choose Teamcenter→Open to search for the design. Then, to open the
design for modification, select the Check-out check box.

Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

5. Managing ECAD designs in Teamcenter
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2. In the ECAD design tool, open the schematic, PCB, or simulation design located in your staging
directory that you checked in previously and want to revise now.

3. Choose Teamcenter→Check-out .

4. In the Check-out dialog box, type an identification number for the check out in the Change ID box
and type a description in the Comments box.

Click OK.

5. Verify that the checkout status of the design in Teamcenter is Y.

The Check-out dialog box is not displayed if the EDA_SkipCheckoutDialog preference is set
to True. If this preference is not defined, Teamcenter uses the Confirm_checkout_suppressed
preference to control whether the Check-out dialog box is displayed.

Cancel a checkout

Perform the following steps to cancel an existing checkout lock on the design in Teamcenter. This
reverts the opened design to the version prior to the checkout. Only the ECAD designer who originally
performed the checkout action can cancel the checkout.

Warning:

Canceling a checkout overwrites the modified design files in the staging directory with the last
checked-in design files.

1. In the ECAD design tool, choose Teamcenter→Cancel Check-Out.

Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

2. In the Cancel Check out dialog box, select the Remove working files from local storage check
box if you want to remove the design files from the staging directory.

Removing working files from local storage only removes the design files. These are the files that are
saved to Teamcenter and then opened from Teamcenter. Other files created while working with the
design are not removed when this check box is selected. The design files associated with related
designs are not removed either.

3. Click OK.

An Open Design dialog box displays the following message:

Cancel a checkout
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Directory directory-name already exists, do you want to overwrite this 
directory?

4. Click OK if you want to replace the current version of the design with the previously checked-out
version.

The check-out lock is removed, and the design is reverted to its previous state.

Check in designs

Use the Check-In command to save the design changes back in Teamcenter. Ensure that you edit and
check in the design from the same workstation where you had initially downloaded and checked out the
design. Even if you open the design on another workstation, you must not edit, save, and check in the
design from that workstation. The design must be checked in only from the workstation where it was
checked out.

1. To save any changes made to a design in Teamcenter, choose Teamcenter→Check-In.

The Check-In dialog box appears.

Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

2. If you see the message This item is not known to Teamcenter in your design
tool, the design has not been previously saved in Teamcenter. To save the design, choose
Teamcenter→Save As.

3. If you see the message The design has not been checked out for this operation
in your design tool, the design has not been checked out from Teamcenter. Check out the design,
make modifications, and then choose the Check-In command.

4. Select the Save BOM check box to indicate whether to save a BOM with the design.

5. Select the Remove working files from local storage check box to indicate if you want to remove
the design files from the staging directory after check in.

6. Click Finish.

The design is checked in to Teamcenter and replaces the previous version.

5. Managing ECAD designs in Teamcenter
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6. Working with EDM projects
Create an EDM project from a Teamcenter design

To create an EDM project from a Teamcenter design:

1. Click the http://<EDM_SERVER_HOST>:<PORT>/xdm URL to open the EDM portal web application,
where:

• EDM_SERVER_HOST is the host name of the EDM server where it is installed.

• PORT is the port number on which the EDM server is running, for example, http://
edm_server_machine_name.net.plm.eds.com:31000/xdm.

2. Navigate to the folder where you want to create a new EDM project for a Teamcenter design.

3. Select More Commands  > New   > Add .

The Add panel opens.

4. In the Add panel, select the Teamcenter design that you want to associate to the project, for
example, EDA Printed Circuit Assembly.

5. Specify the details for the new EDM project in the Add panel and click Add.

6. Select the project and click Create New EDM Project on the toolbar.
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7. In the Create New EDM Project dialog box, specify the Project Name and select Xpedition
Enterprise Template for your EDM project.

8. Click Create.

A new EDM project associated with the Teamcenter design is created in Xpedition EDM.

Associate an EDM project board to a Teamcenter design

To associate an EDM project to a Teamcenter design:

1. Navigate to the web address of your EDM Portal and open a design in EDM Collaborate from Active
Workspace.

6. Working with EDM projects
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2. Navigate to the folder where you want to create a new EDM project to associated with the existing
project in EDM.

3. Select More Commands  > New   > Add .

The Add panel opens.

4. In the Add panel, select the Teamcenter design that you want to associate to the project, for
example, EDA Printed Circuit Assembly.

5. Specify the details for the new EDM project in the Add panel and click Add.

6. Select the project and click Associate on the toolbar.

7. In the Select Board Container to Associate dialog box, select the EDM project or Board that you
want to associate with the design.

Associate an EDM project board to a Teamcenter design
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8. Click Select.

The EDM project in Xpedition EDM is associated with the Teamcenter design.

To disassociate an EDM project from the Teamcenter design:

1. Select the project and click Disassociate on the toolbar.

2. Click Yes to disassociate the EDM project from the Teamcenter design.

6. Working with EDM projects
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7. Saving designs
Saving designs to Teamcenter

You can save schematic, PCB, and simulation designs to Teamcenter. The following commands are used
for saving designs:

Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD tool
topic for the initial steps to access the Teamcenter menu commands specific to your ECAD tool to
perform the ECAD operation.

• Use Save to save changes to the current design, without creating a copy or a new revision.

• Use Save As to save a new design based on the current design. The design must not exist in
Teamcenter.

• Use Save Derived Data to save updated derived data. If the parent object is released, you can revise
the parent object.

• Use Revise to create a new revision of the current design. The design must already exist in
Teamcenter.

• Use Check-In to check the current design into Teamcenter.

Save a new design in Teamcenter

The steps to save a new dual model design or a new combined model design to Teamcenter are similar.
To save a dual model design, you must additionally provide information about the schematic items.

1. In the ECAD design tool, open a design (dual or combined model) for modification and make the
desired changes to the design.

2. In the ECAD design tool, navigate to Teamcenter→Save As and, if prompted, log on.

Teamcenter displays the Design Information wizard dialog box.

Note:

The PWB ID and name default to the values provided by the design tool. Teamcenter appends
the value of DefaultPWBSuffix to each value.
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Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

3. On the Design Information dialog box, click the Assign Project link to assign a Teamcenter project
to the design. If a default project is assigned to a user, the default project name is displayed instead
of the Assign Project link.

4. From the Assign Projects dialog box, select one or more projects that you want to assign to the
design and click OK. All projects assigned to the user in Teamcenter will be displayed for selection.

5. Enter the information for design items as follows:

a. Select the check box next to the items you want to save. The check box has three states:
selected, cleared, and partially selected.

7. Saving designs
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• The selected check box indicates that the item and all its child nodes are selected for the
update.

• The cleared check box indicates that neither the item nor any child node is selected for the
update.

• The partially selected check box indicates that the item is selected but at least one of its
child nodes is not selected.

b. You can double-click a specific field to update the name and ID for any editable item manually.
Not all fields are editable.

c. Double-click the relevant cell in the Select Option column and choose Save as new to create
a new PCA item in Teamcenter.

OR

Choose Select existing to save it to an existing PCA item in Teamcenter. If you choose Select
existing, you must browse to the relevant PCA item.

d. Double-click the relevant cell in the Select Option column and choose Save as new to create
a new PWB item in Teamcenter.

OR

Choose Select existing to save it to an existing PWB item in Teamcenter. If you choose Select
existing, you must browse to the relevant PWB item.

e. (For dual model designs only) Double-click the relevant cell in the Select Option column and
choose Save as new to create a new schematic item in Teamcenter.

OR

Choose Select existing to save it to an existing schematic item in Teamcenter. If you choose
Select existing, you must browse to the relevant schematic item.

Save a new design in Teamcenter
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f. (For dual model designs only) Expand the Schematic node to enter or update the information
for the Design node.

g. Select the BOM check box to save a bill of materials (BOM) with the design item. Double-click
within the Select Option column to specify whether to save a BOM from the PCB or from the
schematic or to not save a BOM.

h. Select the Viewable check box to save the neutral SCH (XSCH) file with the design.

i. To save variants, specify all the required details the same way.

6. (Optional) Click Assign ID to generate IDs for all the items that have a blank ID field and are
selected for saving.

7. (Optional) Click Details to view or enter additional information for the items.

8. To revert the changes to the design information tree, click Reset. All fields are restored to their
initial rendering state. Any changes made to the Details dialog box are also reverted.

When a row is selected, the reset action reverts all changes made to the selected row.

When none of the rows is selected, the reset action reverts all the changes made to the design
information tree.

9. (Optional) Select Check-In to check in the PCA and PWB when the design is saved.

10. (Optional) Select Remove working files from local storage to delete the associated files from your
workstation after the design is checked in. This check box is unavailable if you do not select the
Check-In check box.

11. Click Finish to save the design or Next to proceed to the BOM compare results.

If you had earlier selected the option to Check-In your designs, your design is saved and checked in
to Teamcenter. The save operation may take several minutes.

To view the BOM compare option, you must configure the EDA_BOMCompareOnSave preference.
If not configured, the BOM compare option may not be available on your Save or Revise wizard.

Save or revise updated designs in Teamcenter

You can check out and open a design for modification in the ECAD tool. Once you update the file, you
can save the new version of the updated design.

Use the Save command to save a new version of an opened and checked-out design to Teamcenter. The
revision remains the same.

7. Saving designs
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Use the Teamcenter→Revise command to create a new revision. If an item is in the released state, it
can be revised but it cannot be saved.

1. In the ECAD design tool, open a design for modification and make the desired changes to the
design.

2. In the ECAD design tool, navigate to Teamcenter→Save and if prompted, log on.

Alternatively, select Teamcenter→Revise.

Teamcenter displays the Design Information wizard dialog box.

Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

3. On the Design Information dialog box, click the Assign Project link to assign a Teamcenter project
to the design. If a default project is assigned to a user, the default project name is displayed instead
of the Assign Project link.

4. From the Assign Projects dialog box, select one or more projects that you want to assign to the
design and click OK. All projects assigned to the user in Teamcenter will be displayed for selection.

Save or revise updated designs in Teamcenter
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5. Enter the information for design items as follows:

a. Select the check box next to the items you want to save. The check box has three states:
selected, cleared, and partially selected.

• The selected check box indicates that the item and all its child nodes are selected for the
update.

• The cleared check box indicates that neither the item nor any child node is selected for the
update.

• The partially selected check box indicates that the item is selected but at least one of its
child nodes is not selected.

b. Double-click the relevant cell in the Select Option column and choose Save to save the
changes.

OR

7. Saving designs
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Choose Revise in the Select Option column to save a new revision of a released item. If an
item is in the released state, then it is shown with a lock icon. A released item can be revised
but it cannot be saved.

c. Select the BOM check box to save a bill of materials (BOM) with the design item. Double-click
within the Select Option column to specify whether to save a BOM from the PCB or from the
schematic or to not save a BOM.

d. Select the Viewable check box to save the neutral SCH (XSCH) file with the design.

e. To save variants, specify all the required details the same way.

6. (Optional) Click Assign ID to generate IDs for all the items that have a blank ID field and are
selected for saving.

7. (Optional) Click Details to view or enter additional information for the items. Details tab is enabled
only if you are saving an item.

If you are revising an item, the Details tab is disabled. You cannot modify component or attribute
values while revising any item.

Save or revise updated designs in Teamcenter
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8. To revert the changes to the design information tree, click Reset. All fields are restored to their
initial rendering state. Any changes made to the Details dialog box are also reverted.

When a row is selected, the reset action reverts all changes made to the selected row.

When none of the rows is selected, the reset action reverts all the changes made to the design
information tree.

9. (Optional) Select Check-In to check in the design items when the design is saved.

10. (Optional) Select Remove working files from local storage to delete the associated files from your
workstation after the design is checked in. This check box is unavailable if you do not select the
Check-In check box.

11. Click Finish to save the design or Next to proceed to the BOM compare results.

If you had earlier selected the option to Check-In your designs, your design is saved and checked in
to Teamcenter. The save operation may take several minutes.

To view the BOM compare option, you must configure the EDA_BOMCompareOnSave preference.
If not configured, the BOM compare option may not be available on your Save or Revise wizard.

7. Saving designs
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Save derived data

1. In the ECAD design tool, open a design that has been previously saved to Teamcenter.

2. Choose Teamcenter→Save Derived Data.

Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

3. In the Save Derived Data dialog box, select the derived files that you want to update.

4. (Optional) Click Details to view or enter additional information for the items. Update the
information for derived files as required. Not all fields are editable.

5. In the Select Options column, select Save to update the current revision. If you want to create a
new revision, select Revise.

6. To revert the changes made to the design information tree, click Reset. All fields are restored to
their initial rendering state. Any changes made to the Details dialog box are also reverted.

When a row is selected, the reset action reverts all changes made to the selected row.

When none of the rows is selected, the reset action reverts all the changes made to the design
information tree.

7. Click Finish.

Save derived data
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8. Verify that the new dataset files are saved with the design in Teamcenter by using the rich client to
access Teamcenter.

In the Business Modeler IDE specification of a derived item, if the Add to BOM property is selected and if
the ECAD tool supports a base BOM, the derived item is added to the CCABaseBOM object. If the ECAD
tool does not support a base BOM, the derived item is added to each CCAVariantBOM object.

For more information about working with derived data, see Business Modeler IDE.

Save derived data with a revised parent object

In some cases, saving the derived data may not be possible with the existing parent object. For example,
if the parent object is in the Released state, you may need to save the derived data with a revised parent
object.

1. In the ECAD design tool, open a design that has been previously saved to Teamcenter.

2. Choose Teamcenter→Save Derived Data.

Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

3. In the Save Derived Data dialog box, select the Derived Files section.

4. To save the derived data with a revised parent object, select the parent object in the top row and
choose Revise in the Select Option list.

5. Click Finish.

Update only BOM data without changing any design dataset files

1. In the ECAD design tool, open a design for modification and make the required changes to the BOM
information.

2. In the ECAD design tool, navigate to Teamcenter→Save As and, if prompted, log on.

Teamcenter displays the Design Information wizard dialog box.

7. Saving designs
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Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

3. Select the BOM check box to save a bill of materials (BOM) with the design item. Double-click
within the Select Option column to specify whether to save a BOM from the PCB or from the
schematic or to not save a BOM.

4. Double-click a specific field to update the name and ID for any editable item manually. Not all fields
are editable.

5. Click Finish to save the updated BOM.

Filter items in the design information display

The Filter Data Type dialog box narrows down the items that are displayed in the Design Information
view based on the data type. You can apply a filter to display only the data types you are interested in.

• Select All displays all data types.

• Derived Files displays all derived files irrespective of the status of other check boxes.

• Derived Items displays all derived items irrespective of other check boxes.

The following examples explain how filtering works:

• If both check boxes, PCA and Derived Items, are selected, all derived items and all PCA items are
displayed.

• If the PCA check box is clear but the Derived Items check box is selected, all derived items including
the PCA derived items are displayed.

• If the PCA check box is selected and the Derived Items check box is clear, all PCA items will be
displayed but no derived items are displayed.

The data type filter only controls the design information that is displayed on the screen. It does not affect
the selection state of the design item, irrespective of whether the design item is displayed or hidden.

Apply filters to a data type

1. Click Filter  on the Data Type column.

2. In the Filter Data Type dialog box, select the data type you want to display.

Filter items in the design information display
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3. Click OK.

Remove filters

1. Click Filter  on the Data Type column.

2. On the Filter Data Type dialog box, clear the selected check boxes.

Convert a nonvariant design to a variant design

When an ECAD designer modifies an existing nonvariant ECAD design from Teamcenter, adds the first
variants, and saves it back into Teamcenter as a variant design, the Save As wizard appears with the
PCABase fields enabled. This allows the system to collect the necessary information to convert the
Teamcenter design from the single PCA representation to a multiple PCA representation. The same
procedure applies whether you save or revise the nonvariant design.

1. In the ECAD design tool, navigate to Teamcenter→Save As or Teamcenter→Revise and, if
prompted, log on.

Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

2. In the Design Information dialog box, select the nonvariant design that you want to convert to a
variant design.

3. Click Assign PCA.

4. Click Assign ID.

5. Click Finish.

The design is saved and checked in to Teamcenter if you selected Check-In. A Save progress indicator
appears, showing that a save operation is in progress. It may take several minutes for a save operation to
complete.

The process for saving Mentor Xpedition EDM designs

The following process describes how to save designs from Xpedition EDM Design to Teamcenter.

Before you can save designs to Teamcenter, the administrator must do the following in EDM Design
Client:

7. Saving designs
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Prerequisites

• Create EDM configuration rules for Teamcenter

Configuration rules define what data is allowed in the baseline and defines how the data is stored in
EDM. For example, you must define EDM configuration rules for saving different types of data such as
BOM, EDIF, ODB++, and derived data.

You should use the configuration rules provided by Teamcenter.

• Create EDM Baseline Profiles

Baseline Profiles allow you to define a group of files to be processed together in EDM.

Saving designs

1. Create or modify a schematic or a PCB design and save it in an EDM project.

2. Using the EDM Design client, create a project baseline that contains the design and the required
(additional) files.

3. Using EDM Design client, export the baseline as an EDX package.

4. Move the exported EDX package to the EDA staging location design directory for the design.

5. Using the Teamcenter Gateway for EDA, select the Mentor EDX Design configuration, and save a
new design or save, check in, or revise existing designs in Teamcenter.

Verifying if the design is successfully saved

• A new PCA item is created with an item ID matching the one for the EDM project name or the ID you
specified.

• A new PWB item related to the PCA revision is created with the EDAHasPWB relation.

• A new design dataset is created and related to the PCA revision with an IiMAN_specification relation.

• The EDX package file is attached to the dataset.

The ECAD designer must manage the design check out locks in both EDM and Teamcenter. When a
design status is Work in Process (WIP) in EDM, the ECAD designer should not check in the design to
Teamcenter. The ECAD designer must provide the necessary BOM output files that Teamcenter requires.

Variant designs require BOM files. These files must be generated with Mentor Partlister by using the
configuration file provided in the TCEDAECAD_ROOT\MentorEDXDesCon directory. Generating the EDIF
and ODB++ files is optional.

The process for saving Mentor Xpedition EDM designs
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Note:

Design attribute mapping and the Save As Copy function of designs that already exist in
Teamcenter are not supported.

Save a Mentor Xpedition EDM board design to Teamcenter

1. In the ECAD client, select an EDM design baseline to be saved to Teamcenter.

2. Click Create EDX... and enter the required information in the Create EDX... dialog box.

3. If prompted, log on to Teamcenter.

Teamcenter displays the Save As... dialog box.

4. Enter an ID, a revision, and a name for the PCA item and the PWB item.

Alternatively, you can click Assign All. Teamcenter generates values for both PCA and PWB.

5. The EDX package is saved and checked in to Teamcenter.

Allow or restrict check in while saving a new file

On the Save As wizard, the Check-in check box is enabled or disabled based on the
EDA_ForceCheckInOptionDefault preference value.

Set the EDA_ForceCheckInOptionDefault preference to True to disable the Check-in check box on the
Save As wizard. Set the preference to False to enable the Check-in on the Save As wizard. Once the
check box is enabled, users can change the selection.

The default selection of Check-in check box is set using the EDA_CheckInOptionDefault preference.

Allow or restrict saving a BOM with the design item

You can select BOM check box to indicate whether to save a BOM with the design.

Initially, the check box may be disabled for your site. The availability and default state of the BOM check
box depends on the applicable preference setting. To control the BOM check box behavior during the
save operation, set the preferences as following.

• Set the EDA_SchematicBOMOptionDefault preference for schematic designs.

• Set the EDA_PcbBOMOptionDefault preference for PCB designs.

7. Saving designs
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• Set the EDA_CombinedBOMOptionDefault preference for combined model designs.

Note:

EDA does not support Teamcenter substitute parts specified for ECAD components in a Teamcenter
BOM view revision (BVR).

When one or more substitute parts for ECAD component instances are encountered during the
EDA update of a Teamcenter BVR as part of a save operation, the condition is reported to the
designer and update of that BVR is skipped. The BVR will not be in sync with the ECAD BOM until
the substitute parts are removed from the Teamcenter BVR and the design is saved to Teamcenter
again.

You can use the BOM Compare feature to identify the substitute parts for the ECAD component.
You can identify the substitute parts in the BOM Compare report by checking any results that
contain PART NUMBERS DIFFER.

Allow or restrict saving the neutral SCH (XSCH) file with the design
item

You can select Viewable check box to indicate whether to save the neutral SCH (XSCH) file with the
design item.

Initially, the check box may be disabled for your site. The availability and default state of the Viewable
check box depends on the applicable preference setting. To control the Viewable check box behavior
during the save operation, set the preferences as following.

• Set the EDA_SchematicViewableOptionDefault preference for schematic designs.

• Set the EDA_PcbViewableOptionDefault preference for PCB designs.

• Set the EDA_CombinedViewableOptionDefault preference for combined model designs.

Allow or restrict saving the neutral SCH (XSCH) file with the design item
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8. Working with the cache and staging
directories
Working with the staging and cache directories

The EDA staging directory holds designs for check in and check out with Teamcenter, and the cache
directory is where temporary data is stored.

The cache and staging directories are created automatically when you select a command on the
Teamcenter menu and log on for the first time. If a user wants the cache directory, or staging directory
to be changed, the administrator can do so by editing the TCEDAClient.properties file. However,
Siemens Digital Industries Software does not recommend this. This can be a one-time change that
should be undertaken only if absolutely necessary.

Teamcenter EDA requires that you create and work on designs in the staging directory only. All design
datasets including schematic, PCB, and simulation data files must be saved in a single design root folder.
If you have designs in another directory, copy them to the staging directory and then work on them
exclusively from the staging directory.

Refresh a design

The cache and staging directories temporarily hold data as designs move between your design tool and
Teamcenter. Occasionally, you may need to refresh a design to synchronize the local copy of the design
with the latest in Teamcenter or clear the cache to remove all local copies of designs that you are not
working with.

Refreshing a design updates the staging directory with the latest version of the currently opened design.
No refresh is done if the design is checked out for modification and has the Teamcenter check out lock
applied.

1. In the ECAD design tool, open a design that has already been checked in.

2. In the ECAD design tool, choose Teamcenter→Refresh.

3. If the design is the latest version available, a dialog box appears asking if you want to force a
refresh.

However, if there is a newer design found on Teamcenter, you are notified that the older design is
out-of-date and must be refreshed.

4. Click OK in the notification dialog box.

If the design was out-of-date, the newer design replaces it in the cache and staging directories.
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Clear the cache

Use the Purge Working Files command to clear the client cache of non checked-outch designs of the
current configuration type and remove copies of these designs from the client staging directory. The
designs that are checked out and/or have related datasets checked out are not affected.

Caution:

Do not make manual changes to the cache. If you manually delete the cache without using the
Purge Working Files command, you are blocked from making any further changes to designs.

1. In the ECAD design tool, choose Teamcenter→Purge Working Files.

The Purge Working Files dialog box is displayed.

2. Choose the designs you want to purge by selecting the check boxes in the Purge column.

You can also click the Select All button to select all designs or click the Deselect All button to clear
all designs.

3. Click OK.

All data is removed from the cache and staging directories except for those designs with check out
locks and those designs that have related datasets checked out.

Caution:

Related data that has never been saved to Teamcenter is deleted if the primary data is checked in.

8. Working with the cache and staging directories
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9. Compare BOMs
Comparing ECAD design BOMs with Teamcenter

The ECAD design component compare feature compares the components in an ECAD design with the
components of the same design in Teamcenter. Changes could have occurred in the Teamcenter BOM
to account for component cost, component availability, manufacturing issues, and so on, which are not
reflected in the previously saved ECAD design.

This feature displays part number differences in component instances between the ECAD design BOM
and a Teamcenter design revision BOM. After you check out an ECAD design, as a first step, you can
compare differences between the previously saved ECAD design BOM and the corresponding current
Teamcenter BOM.

Component instances, each identified by a reference designator, are compared to determine if the ECAD
design part numbers match the corresponding Teamcenter product structure occurrence item IDs. This
helps you resolve any differences and perform the necessary component instance additions, removals,
or substitutions.

You can compare single PCA designs and multiple PCA designs. An ECAD design BOM can also be
compared with another unrelated Teamcenter item revision BOM.

View BOM compare results when saving an updated design

The ECAD user can set the EDA_BOMCompareOnSave preference to view the BOM compare results
when saving an updated design to Teamcenter.

The valid values for the EDA_BOMCompareOnSave preference are:

• Always: The BOM Compare page will always be shown. This is the default value.

• DiffOnly: The BOM Compare page will be shown only if there are differences.

• Never: The BOM Compare option will not be shown with Save or Revise wizards.

The EDA_BOMCompareOnSave preference syntax is as follows:

<preference name="EDA_BOMCompareOnSave" type="String" array="false" 
disabled="false" protectionScope="User" envEnabled="false">
<preference_description>Controls whether the BOM Compare Result page
 is shown on the EDA save dialog during save operations.
</preference_description>
<context name="Teamcenter">
<value>ALWAYS</value>
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</context>
</preference>

1. In the ECAD design tool, open a design for modification and make the desired changes to the
design.

2. In the ECAD design tool, choose Teamcenter→Revise or Teamcenter→Save and, if prompted, log
on.

Teamcenter displays the Design Information wizard dialog box.

Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

3. Update the information for design items as required.

4. Click Next to proceed to the ECAD Design Component BOM Compare Results. The comparison
results are displayed based on the EDA_BOMCompareOnSave preference. Check the Result
column to see the BOM comparison results.

5. Click Back to go to the Design Information.

6. Click Finish to save the design.

Compare ECAD design and Teamcenter BOM component instances

1. Check out the design you want to work on. This ECAD design becomes the source for the
comparison.

2. In the ECAD design tool or Teamcenter Gateway for EDA, choose Teamcenter→BOM Compare.

If you are working on a single PCA design, the specified ECAD design BOMs are generated, the
Teamcenter item revision BOM is retrieved, compared, and the comparison results are displayed.

If you are comparing a multiple PCA design with two or more variants and/or the ECAD design BOM
source must be specified for a combined model design, the ECAD Design Component Compare
dialog box is displayed.

9. Compare BOMs
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Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

3. Specify the comparison criteria.

If you are comparing a multiple PCA design with two or more variants, you must select the variants
using the Base/Variant list.

If you are comparing a combined model design, you must specify the BOM option as schematic or
PCB.

4. Click OK.

The specified ECAD design BOMs are generated, the Teamcenter item revision BOM is retrieved,
compared, and the comparison results are displayed. The Teamcenter item revision is the target
of the comparison. The BOM Compare results for selected components are displayed in following
colors for different scenarios:

Operation Color code Result
No change No color MATCH
Added Part Green NOT IN TC BOM
Deleted Part Red NOT IN DESIGN BOM
Updated Part Blue CHANGES REF DES
Updated Part number Blue PART NUMBERS DIFFERS

Compare ECAD design and Teamcenter BOM component instances
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Note:

By default, only the component instances with differences are displayed. You can choose to
display all results by selecting the Show all components check box.

5. Click Browse to select a different Teamcenter target item revision for comparison.

6. Click Create CSV File if you want to generate a comma-separated value (CSV) file containing the
comparison results.

You can share this CSV file with others to aid in reconciliation.

Note:

The file is created in the selected location and follows this file naming convention:

BOMCompare_target item_id target item_revision_id.csv

The header line of the CSV file replaces the fixed target ID and source ID headings used in the
results tables with the actual target PCA item ID or revision ID and the source design item ID,
respectively.

9. Compare BOMs
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7. Click Close to exit the ECAD Design Component Compare dialog box, after you have finished
viewing all the specified comparison results.

Compare ECAD design and Teamcenter BOM component instances
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10. Access ECAD designs in Active
Workspace
Open a design in Active Workspace

To search for a design dataset file in Teamcenter and open it for reference (read-only) or modification:

1. In the ECAD design tool, choose Teamcenter→Open.

If prompted, log on.

Active Workspace opens the design. If no design is selected or design is not found, the home page
is displayed. You must have Active Workspace installed and configured for the Open command to
work.

Note:

If you are using a different ECAD tool, refer to the Access Teamcenter menu from your ECAD
tool topic for the initial steps to access the Teamcenter menu commands specific to your
ECAD tool to perform the ECAD operation.

2. In the Open Design dialog box, browse to the design you want to open.

You can also search for designs using the search type and search criteria.

3. To open the design dataset for modification, click Open For Modification.

The file is checked out and no one else can modify it.

To open a read-only copy, click Open For Reference. A design opened only for viewing cannot be
modified or revised.

Note:

If the dataset is already checked out to you or someone else, the Open for modification
button is disabled and the CO (check out) column in Teamcenter displays a Y.

4. (Optional) To open related design files, select the Open Related Design check box.

The choices in the list are Blank (do not download), Reference (download only for reference), and
Check-out (download and check out).

Navigate to a new design
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(Optional) When opening a design for the first time, you can navigate to the Active Workspace home
page and then search for the design.

1. In the ECAD design tool, choose Teamcenter→Design Info.

When no design is selected or a design is not found, the home page is displayed.

2. On the home page, browse to the design you want to open. You can also search for designs using
the search type and search criteria.

View key design metrics in Active Workspace

When a design is loaded in Active Workspace, the associated design metrics can be viewed in the
Overview tab. These metrics are read-only and cannot be edited. You can use these to measure design
quality and design progress.

Note:

Viewing key design metrics in Active Workspace is currently not supported for Xpedition Direct and
EDM.

Some examples of the design metrics are:

• Component placement

• Connectivity

• Routing

• Online hazards

• Constraints

Open a design in EDM Collaborate from Active Workspace

When you access a PCA EDM board design from Active Workspace, you are provided an option to open
the design in the EDM Collaborate tool. To enable the launch of this tool from Active Workspace, the
hosting URL for EDM server must be specified using the EDA_EDMHosting.URL preference.

In Active Workspace, choose Open→Open in EDM. The EDM Collaborate tool is launched in a new tab,
and the design is opened in this tool.

10. Access ECAD designs in Active Workspace
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View the requirements linked to a circuit card assembly revision

The requirements of your product are stored in Teamcenter. A circuit card assembly or a schematic
revision can be linked to the product design requirements using a tracelink. The links may be a direct
link, an indirect link, or a mix of both.

1. Select the circuit card assembly in Active Workspace.

2. Click the Requirement tab. The linked requirements are displayed. If the requirements are not
displayed, check whether the tracelink is created between the product design requirements and the
Circuit Card Assembly.

The Requirement tab is not available in the occurrence management sublocation within the
Content tab.

3. Select a linked requirement to view its description.

View the schematic and PCB designs in Active Workspace

You can view the schematic and PCB designs in Active Workspace. The Viewer tab must be
enabled in Active Workspace and the hosting URL for EDM server must be specified using the
EDA_EDMHosting.URL preference.

The Viewer tab is displayed only if the design is saved using EDM Design Cockpit and has the necessary
information to be viewed in Active Workspace.

If the PCB design exists, it is displayed by default.

Note:

Viewing the schematic and PCB designs in Active Workspace is supported for Xpedition EDM
designs only from with the EDM Collaborate embedded Active Workspace user interface.

1. Search for the ECAD design you want to view, and open the design from the list of results.

2. Click Viewer tab to see more information.

Active Workspace loads data from the EDM database. By default, the PCB design view is displayed.

3. Use the icons in the ECAD tool within the Viewer to switch between PCB and Schematic views.

Create a new revision within Active Workspace

You can use the Save As or Revise commands to create new revisions of EDA objects in Active
Workspace.

View the requirements linked to a circuit card assembly revision
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Create a new revision of an existing design object

1. Navigate to the design item for which you want to create a new revision.

2. Select the design and click Revise.

3. Click the Revision tab.

4. Enter the properties for the new revision and click Revise.

A new revision is created with the same ID. You cannot enter a different ID when you create a new
revision of an existing object.

Create a new object from an existing object

1. Navigate to the design item from which you want to create a new object.

2. Select the design and click Save As.

3. Click the New tab.

4. Enter the properties for the new object and click Create.

Submit a design to a workflow in Active Workspace

1. Select the design that you want to submit to the new workflow and choose Teamcenter→Design
Info.

Active Workspace opens the design.

If no design is selected or design is not found, the home page is displayed. You must navigate to
the design in Active Workspace.

Note:

Refer to the Access Teamcenter menu from your ECAD tool topic for the initial steps to access
the Teamcenter menu commands specific to your ECAD tool to perform the ECAD operation.

2. Click Submit to Workflow.

3. Accept the default workflow name or type your own.

4. From the Workflow Template list, select a template for the new workflow.

10. Access ECAD designs in Active Workspace
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If a default workflow exists for the content type, it is automatically specified as the workflow
template.

5. Enter a description for the new workflow.

6. Click Submit.

7. Click the Workflow tab to view the workflow status of the design. In Active Workspace, the
Workflow tab is visible only for the design items that are part of a workflow process.

Submit a design to a workflow in Active Workspace
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11. Collaborating across domains
Manage ECAD design collaboration files

Overview of collaboration across domains

Any electrical design, for example, a PCB, is collaboration between two domains, namely, electrical and
mechanical.

A typical PCB design is as follows:

• A mechanical engineer creates a board outline and places several components that can have an
impact on the mechanical geometry, such as connectors, LEDs, or potentiometers.

• The electrical engineer places the electrical components on the PCB.

• If there are changes in the board components, the engineers change the components from their
domain. For example, the mechanical engineer can change a component in case the design has
changed, or the electrical engineer can change a component due to an update in the schematic.

• The placement locations of components are changed when there are issues with the placement.
For instance, when there are collisions in the housing or there are zones with thermal, vibration or
moisture issues.

EDA allows engineers from different domains to work on the same BOM and collaborate on the design
creation.

The collaboration is accomplished using the Teamcenter Issue Management functionality. Active
Workspace is used to create collaboration objects. A simplified collaboration process works as follows:

• When there are issues that need to be addressed, for example, a proposal to change the board
components, an engineer creates a collaboration issue.

Based on the organization's issue management process, the issue is assigned to participants or to the
relevant stakeholders.

• To share design files with participants from the other domain, the engineer publishes the design file.
The mechanical engineer then receives a notification.

An IDF or IDX file is attached to the collaboration issue. IDF and IDX files are data neutral formats that
can be read by most ECAD and MCAD tools. Use of IDX files is recommended.

• The engineer from the other domain then downloads the design files, updates it, and publishes the
changes.
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• When the design is ready for review or release, the engineers can create a collaboration issue to
review or release the design.

Note:

The collaboration functionality is only available for PCB designs.

In the embedded mode, this capability is available to all connectors. In Gateway mode, library
configuration do not support Collaboration or Issue Manager action. In non-library configuration,
some are setup to not support Collaboration but all support Issue Manager actions.

Initiate a design or a part workflow

1. Select the design you want to submit to the new workflow and choose Teamcenter→Design
Workflow.

Alternatively, to initiate a part workflow, select the design you want to submit to the new workflow
and choose Teamcenter→Part Workflow.

2. In the Initiate Design Workflow dialog, select the design you want to submit to the new workflow,
and click Submit to Workflow.

3. Accept the default workflow name or type your own.

4. From the Workflow Template list, select a template for the new workflow.

If a default workflow exists for the content type, it is automatically specified as the workflow
template.

5. Enter a description for the new workflow.

6. Click Submit.

Create a collaboration issue

The Issue Management functionality in Active Workspace is used to manage collaboration issues. A
collaboration issue can only be an issue report object.

1. Select or open the design for which you want to create a collaboration issue and choose
Teamcenter→Design info.

The Active Workspace opens the design If it is saved in Teamcenter. If not, you must navigate to the
design in the Active Workspace.

2. In Active Workspace, click Create Change.

11. Collaborating across domains
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3. Select the type of change you want to create.

4. Enter the properties for the object.

For example, specify the item ID, revision, synopsis, and description of the collaboration issue.

5. (Optional) To add supporting objects and reference documents, to the right of Attachments, click

.

6. Perform one of the following:

• If you want to continue editing later, click Save.

• If you want to send it for resolution now, click Submit.

The collaboration issue is sent through the default workflow for resolution. Check your Inbox for
any tasks. Depending on how your organization's change process is configured, reviewers may
be automatically assigned. If a workflow is not configured for issues, you can manually create
one in Active Workspace.

Create a collaboration issue
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Publish collaboration files

Active Workspace is used to publish IDF or IDX files (for collaboration) to Teamcenter.

1. Select or open the design for which you want to publish a collaboration file and choose
Teamcenter→Design info.

The Active Workspace opens the design If it is saved in Teamcenter. If not, you must navigate to the
design in the Active Workspace.

2. In the Active Workspace, click the Attachments tab and to the right of Files, click .

3. Browse to the file that you want to publish, and specify the name, description, file type, and
relation type for the file that you want to publish.

We recommend choosing the EDAIdf dataset to upload the IDF or IDX file.

4. Click Add.

Download collaboration files

Active Workspace is used to download the collaboration files from Teamcenter.

1. Choose Teamcenter→Design info.

The Active Workspace opens the design If it is saved in Teamcenter. If not, you must navigate to the
design in the Active Workspace.

2. Click the Attachments tab.

3. Select the file you want to download and click .

Create issues

The Issue Management functionality in the Active Workspace is used to create and manage issues.

You can use Issue Manager for schematic and PCB designs.

1. Select a design for which you want to create a collaboration issue and choose
Teamcenter→Design Info.

2. In the Active Workspace, click Create Change .

11. Collaborating across domains
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3. Select the type of issue you want to create.

4. Enter the properties for the object.

For example, specify the item ID, revision, synopsis, and description of the collaboration issue.

5. (Optional) To add supporting objects and reference documents, to the right of Attachments, click

.

6. Do one of the following:

• If you want to continue editing later, click Save.

• If you want to send the issue for resolution instantly, click Submit.

The issue is sent through the default workflow for resolution. Check your Inbox for any tasks.
Depending on how your organization's change process is configured, reviewers may also be
automatically assigned. If the workflow is not configured for issues, you can manually create a
workflow in the Active Workspace.

Manage IDX exchange through Teamcenter Co-design

Overview of IDX exchange through Teamcenter Co-design

ECAD and MCAD designers collaborating on the electromechanical products must work in an integrated
design development environment that allows close collaboration between the ECAD and MCAD tools
during the design development process.

Overview of IDX exchange through Teamcenter Co-design
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Teamcenter EDA supports this ECAD and MCAD collaboration between Xpedition and NX using the IDX
format to easily exchange electromechanical data. The collaboration allows you, as a design engineer,
to communicate incremental design changes throughout the design process. The IDX file captures
and tracks the proposed incremental design changes initiated by the designers in the ECAD-MCAD
collaboration.

ECAD MCAD collaboration using IDX file format requires:

• An IDX baseline file that contains a base PCB reference design for further incremental changes. Both
ECAD and MCAD designers must start from the same IDX baseline to synchronize the design process.

• IDX incremental files that contain incremental changes from the last synchronization.

• IDX response files that contain information about the incremental changes incorporated or rejected by
the designers.

The incremental exchange of data between ECAD and MCAD designers is done multiple times until the
design is ready for use in manufacturing.

Exchange design change proposals and 3D model data using Co-Design

Co-Design in Teamcenter provides a collaborative environment for the ECAD and MCAD designers to
create and respond to the design change proposals effectively and accurately. You, as an ECAD designer,
can associate collaborative designs, participants working on those designs, and the incremental design
changes of the PCB design to a single Co-Design object to ensure synchronization between the
electrical and the mechanical board design projects. The design changes may include adding, removing,
modifying, and relocating components or editing the board outline.

11. Collaborating across domains
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Co-Design facilitates the exchange of product assembly 3D models between NX and Xpedition using
Teamcenter services. The MCAD designers can export the 3D models and assembly files from NX to Co-
Design in Teamcenter. The ECAD designer can import these assembly files from Co-Design to Xpedition.
In addition, and ECAD designer can also initiate an exchange of 3D files from Xpedition to NX. This
happens when new components are added to the PCB design in Xpedition and the 3D representation of
those components is not available in NX.

Create a new Co-Design for a design object

A project leader creates a Co-Design object for a project and adds ECAD and MCAD designs to it. The
design engineers from the ECAD and MCAD domain can collaborate using this Co-Design object.

1. In Active Workspace, search for a design the ECAD-MCAD design engineers want to collaborate on.

2. Select the design and click More Commands  > New   > Create Co-Design.

Teamcenter creates a Co-Design for the selected design.

3. Click any of the below tabs as required to continue working with the Co-Design object.

a. Overview – Shows the details about the object creation date, last modifying user, and so on.

b. Proposal – Lists all ongoing and completed proposals related to the Co-Design.

c. Participants – Lists the design owner, proposed reviewers, and other users responsible for the
designs. This tab is configurable.

4. You can also discuss issues and exchange ideas while collaborating on the ECAD-MCAD designs.

After creating a Co-Design object for an ECAD or MCAD design, you can add other designs for
collaboration to this Co-Design object.

Add designs to a Co-Design object

1. Search for and open the Co-Design object to which you want to add a design.

2. Select More Commands  > New   > Add Design.

3. In the Add panel, enter keywords to Search for the required design, or select a design from the
CLIPBOARD, FAVORITES, or RECENT list.

4. Select the design and click Add.

5. To remove a design from the Co-Design object, select the design and click Edit > Remove Design.

Create a new Co-Design for a design object
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All the users and participants associated with the ECAD and MCAD designs are now listed under the
Participants tab. You can also add more participants and users to the Co-Design.

Add participants to a Co-Design object

When a design is added to a Co-Design object, the owner of the design, the reviewers, and the users
assigned as responsible party and associated with the designs are automatically added as participants. If
you are the owner of a design, you can add other participants to the design.

To add participants to the list of Approver and Proposed Responsible Party for a design:

1. Select the design to which you want to add participants.

2. In the Approver or Proposed Responsible Party list, click the Add  button.

3. Search for and add participants as required.

To remove a participant, select the participant in the list and then click Edit > Remove Participants.

Discuss issues and exchange ideas for the designs

You can perform the following tasks to discuss issues and ideas for your ECAD designs with multiple
users.

Create a new discussion

You can create a discussion on the design object in Active Workspace. However, if you create a
discussion on one of the children of a product structure, your discussion is attached to the revision
and not to the occurrence of the revision.

1. Select the design object you want to discuss and click Discuss  on the toolbar to display the
Discuss panel.

2. Click New Discussion  to begin a new discussion on the selected object.

3. (Optional) Click Add Participant  to add a participant to the discussion. Select the participant
and click Add.

4. (Optional) Click the Add Source  to add an additional source object to the discussion.

5. (Optional) Click the Private Message box to limit the participants in the discussion. Click Add
Participant to add a participant to the discussion. Only the selected participants are able to
participate in the discussion. In addition, participants in a private message are automatically set
to follow the discussion.

6. Compose the message.

11. Collaborating across domains
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From within the Message area, you can select:

• Bold

• Font name

• Text color

• Background color

• Insert image (GIF, JPEG, JPG, and PNG)

7. Click Create to create the discussion on the object.

The new discussion appears on the Discuss panel. Each discussion has a timestamp, and new
discussions appear at the top of the list. As the creator of the discussion, you are automatically
set to follow all replies to the new discussion.

View and reply to a discussion

1. To view the discussion on an object, click Discuss  on the toolbar to display the Discuss
panel.

2. (Optional) If the discussion is a private message, you can hover over the people icon to
determine the recipients of the discussion message.

3. You can Follow or Unfollow all of the discussions on the selected object or just the selected
discussion, create a new discussion, or click either Reply or Advanced to reply to a discussion.

Follow a discussion

Follow  allows you to receive notifications when new discussions or replies are made in relation to
the source object. This is particularly useful if you want to see responses to an object you own.

Note:

You can receive notifications on all discussions or a particular discussion.

1. Select the object and click Discuss  on the toolbar to display the Discuss panel.

2. To receive notifications:

• On all discussions about the object, click Follow  next to the name of the selected object.

• On a particular discussion, click Follow within the selected replies.

When you follow a discussion, you are notified of replies via the Alerts button on the global
navigation toolbar.

Discuss issues and exchange ideas for the designs
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Unfollow a discussion

To unfollow a particular discussion or all discussions on a source object at any time to stop receiving
notifications, click Unfollow next to the selected discussion or discussions.

Delete a discussion

Note:

You can only delete a discussion if your administrator has given you the necessary privileges to
perform this action.

1. Select the object and click Discuss  on the toolbar to display the Discuss panel and its
discussions.

2. Select the discussion you wish to delete and click Delete.

A confirmation message appears. Click Delete to delete the selected discussion, including all
replies.

Design change proposal process using Co-Design in Teamcenter

A high-level process to exchange design change proposals across domains using the Co-Design object
along with the Teamcenter ECAD and MCAD published services is provided below:

Consider that the ECAD designer is initiating the design changes proposal and that the MCAD designer
will review and then accept or reject the changes. However, these tasks can be initiated either by the
ECAD designer or the MCAD designer.

1. The ECAD designer submits a design change proposal through the ECAD design tool Xpedition.

• In the Co-Design > Proposal section in Active Workspace, a new proposal with the associated
IDX file is added to the Ongoing proposals.

• The task maturity of this proposal is set as Submitted.

• A new Review Proposal task is assigned to the MCAD designer. The owner of the MCAD design
receives a notification for this task in the Inbox of the embedded Active Workspace menu in the
MCAD tool NX.

2. On receiving the notification about the task, the MCAD designer uses the Teamcenter services to
download the proposal.

• The Review Proposal task remains in the MCAD designer’s Inbox in the embedded Active
Workspace.

• The task maturity is updated to In Review.

11. Collaborating across domains
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3. The MCAD designer reviews the changes in the design tool and accepts or rejects the changes
as required. The MCAD designer uses the Teamcenter services to update this information in the
Co-Design.

• The task maturity is updated to Reviewed.

• The Review Proposal task notification in the MCAD designer’s Inbox is closed automatically.

• A new Process Response task is assigned to the ECAD designer. A notification is generated in the
Inbox of the embedded Active Workspace menu Xpedition.

4. On receiving the Process Response task notification in the Inbox, the ECAD designer uses
Teamcenter services to download the reviewed information from Teamcenter. The rejected design
changes are rolled back on the ECAD design and the designs in both domains are in sync.

• The task maturity is updated to Processed.

• In the Co-Design>Proposal section, the proposal is moved from the Ongoing list to the
Completed list.

• The Process Response task notification in the ECAD designer’s Inbox is closed automatically.

Design change proposal process using Co-Design in Teamcenter
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12. Setting debug levels to identify issues
arising during an EDA operation
Teamcenter log files assist you in troubleshooting your setup. Sometimes, you may want more
information about the errors in your log files to trouble shoot an issue during an EDA operation. To
gather this additional error information, you must get the TcEDA and SOA logs in debug mode. You can
define the debug level for logs in the log4j2.properties file located in the TC_ROOT\eda directory.

To change the debug level, change the values of the rootLogger.level and logger.soa.level properties
to the DEBUG level.

After changing the debug levels for these properties, you can perform the EDA operation that is failing.
The detailed TcEDA and SOA logs will be generated at the %Temp%\eda folder.

Xpedition and PADS Design Management, Teamcenter 2412  12-1
© 2025 Siemens



You can share these logs with your Teamcenter administrator for further actions.

12. Setting debug levels to identify issues arising during an EDA operation
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