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1. What is Content Management?
Content Management is a component content management system for the creation of technical
documentation. Technical publications consist of XML and SGML text components, which are stored
in the Teamcenter database along with any referenced graphics used in the publications. The structure
and content of a publication is validated by schemas, such as DITA or Docbook. The publication layout
is implemented with stylesheets, which allows the same content to be formatted for different media,
such as print, web, or interactive applications. Content developed as individual topics may be reused by
reference in multiple publications.

Content Management works in conjunction with several publishing and editing tools, which enable
publications to be generated for both online and print formats. Content Management includes support
for multiple language versions and includes the ability to manage topics through translations and
release cycles.

Three types of Content Management solutions are available:

• Base Content Management, which can be used with traditional and custom DTDs and schemas such
as DocBook and Structured Product Labeling (SPL).

• S1000D Content Management, which enables management of documentation for either issue
2.2/2.3, 4.0, 4.1, 4.2, or 5.0 of the S1000D standard.

• DITA Content Management, which enables management of documentation for the DITA standard,
through version 1.3, including specialization and support for DITA Open Toolkit (OT) version 2.4.6.

Note:

Editing tools are supported only on Windows clients. S1000D issue 2.3 is supported only on Linux
and Windows. DITA publishing is supported only on Linux and Windows.

Separate from the Content Management solution, the document management functionality in
Teamcenter enables you to manage documents created by other software applications, such as
Microsoft Word, Microsoft Excel, and other programs.

Before Content Management can be used for authoring publications, the application administrator must
complete several tasks to prepare Content Management for authors.

Pre-configured administration data is included in the TC_ROOT\contmgmtbase_data\data,
TC_ROOT\contmgmts1000d_data\data, TC_ROOT\contmgmts1000d40_data\data, and
TC_ROOT\contmgmtdita_data\data folders.

Two types of users access Content Management:

• Content Management administrators create and manage objects that enable content authoring.
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• Content authors use Content Management to create and manage technical documentation.

1. What is Content Management?
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2. Steps administrators must perform
before you can use Content Management
• Set the appropriate access privileges to define the data objects that users can access in the

application.

• Install Content Management.

• Prepare Content Management for authors.
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3. Using Teamcenter XMetaL Client to
manage content
Teamcenter XMetaL Client is an optional application that integrates XMetaL Author with Content
Management for authoring and managing technical publications. Authors log in to Teamcenter using
the XMetaL interface and can perform most authoring tasks and the workflow signoff task, without
using the Teamcenter interface.

To install XMetaL Client, download and unzipTC_INSTALL_DIR\additional_applications\xmetal_install.zip.
Open the xmetal_installfolder and run setup.exe.

For configuration instructions, see the Teamcenter XMetaL Client Administrator’s Guide
located on the local drive where XMetaL Client is installed, for example: c:\Program Files
(x86)\Siemens\Teamcenter10\XMetaLPlugin\XMetal\CRCL\adapters
\Teamcenter\docs. For instructions on using Teamcenter XMetaL Client, see the Teamcenter XMetaL
Client Help available from the Help menu in Teamcenter XMetaL Client.

If you are using Teamcenter XMetaL Client, do not install the XMetaL plugin in the Teamcenter interface.

Note:

Once installed, this plugin requires the user to associate the XMetaL application to the aw___ file
that is downloaded to the browser. A browser update may be needed. After that, the file should
automatically launch into XMetaL without requiring the user to double click the aw___.
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3. Using Teamcenter XMetaL Client to manage content
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4. Content Management interface
Content Management views

1 Publication Structure view Enables you to navigate, create, and maintain the
structure of a publication with XML or SGML
components, by adding, relating, removing, and moving
topics. The state of the Publication Structure view
may be set to persist between logins using the
ctm0RestoreStateOfPubStructure preference.

2 Summary view Displays the property information of the selected object.

The Summary view is also used with other Teamcenter
solutions.
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3 Preview view Used to display either published content (Publish Content)
or the XML or SGML markup of a publication (Show
Content).

4 Impact Analysis view Provides graphical where-used and where-referenced search
capabilities for topics, graphics, and administrative objects.

The Impact Analysis view is also used with other
Teamcenter solutions.

5 Details view When a component is selected in the Home component
view or the Publication Structure view, displays the objects
at the level below the selected object, which may be system
objects used to support the selected object.

The Details view is also used with other Teamcenter
solutions.

Content Management icons

Icon Description

Comparing tool

Composed document

Composed document revision

DITA Base

DITA Concept

DITA Dynamic Map

DITA Reference

DITA Static Map

DITA Task

DITA Topic

Editing tool

Graphic

4. Content Management interface
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Icon Description

Graphic attribute mapping

Graphic revision

Graphic option

Graphic option revision

Graphic priority list

Graphic translation

Graphic translation revision

Language item

Procedure

Publication

Publication revision

Publication type

Publishing tool

Reference topic type

Reviewer document

Reviewer document revision

Schema

Schema revision

Style type

Stylesheet

Stylesheet revision

Content Management icons
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Icon Description

Topic

Topic type

Transformation policy

Translation

Translation revision

Translation delivery

Translation delivery revision

Translation office

Translation office revision

Translation order

Translation order revision

Viewing tool

XML attribute mapping

XML schema

XML schema revision

4. Content Management interface
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5. Basic concepts for using Content
Management
Understanding the following basic concepts will help you use the features of Content Management.

Data objects are unique in Content Management

Items and item revisions are the fundamental data objects used to manage information in Teamcenter.
Content Management uses specific types of items and item revisions, including topics, topic revisions,
publications, and publication revisions in Base Content Management, and S1000D and DITA items
in those solutions. Content Management also uses administration objects for defining the authoring
environment, such as topic types, XML attribute mappings, and schemas.

Some administration objects—stylesheets, schemas, procedures, and translation offices—have item
revisions. Content Management objects are managed like other Teamcenter objects.

You perform some tasks with these objects in the Home component view; however you use the
Publication Structure view to create and maintain the contents of publications.

Topics are the basic component of publications

In Base Content Management, a topic is a component that may be part of one or more publications.
A topic may contain text, tables, graphics, and subtopics. The term topic is also used in Content
Management to refer to certain S1000D and DITA objects.

Content versions track edits to a topic

In addition to the revision ID and sequence ID appended to topics, each topic revision has a content
version. The content version is a number that increases each time the content of the topic is edited.
When a topic is first created, its content version is -1. After the content is edited once, the content
version increases to 0, and then to 1, and so on. The content version of a topic revision is displayed
in the Summary view. When a topic has a translation, you can compare the content version of the
topic to the content version of the translation to determine if the topic has changed since the topic was
translated. When you edit the content of a topic, you can save it without increasing the content version,
which is useful when a topic has a related translated topic and you want the versions of the two to
remain synchronized.

Publications are the complete structure and content of technical documents

In Base Content Management, a publication object holds all the contents of a traditional XML
publication. A publication contains topics and subtopics, such as the cover page, back page, header,
footer, and sections or chapters. DITA and S1000D Content Management solutions have unique
publication-type objects that are used to create technical documentation.
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The type of topics you can add to specific locations in a publication is defined by the Content
Management administrator in an underlying hierarchical structure of publication types and topic types
created according to the schemas your company uses.

Schemas define the building blocks of XML and SGML documents

Schemas define the basic structure of elements and attributes used in structured documents. When you
relate publication and topic types to schemas in Content Management, the XML or SGML content is
validated against the schema files that are defined by the Content Management administrator. A DTD is
an example of a schema type.

Stylesheets control the format of documents

A stylesheet contains formatting information used to render, edit, or transform a topic or document. A
style type is used to organize and manage the stylesheets associated with publications. These objects are
defined by the Content Management administrator.

A graphic item may have several graphic options

A graphic item is the main object representing a set of different file types, or graphic options, for the
same illustration. For example, a graphic item may be named piston, and it may have several associated
graphic options named piston.jpg, piston.gif, and piston.bmp, which all represent the same illustration
in different formats.

When you start an editing or publishing process, the Content Management system selects the applicable
graphic option from the graphic, based on how the graphic options are defined by your application
administrator. For example, during the publishing process, the graphic option selected may be a high-
resolution .eps file registered with the PDF usage in the topic; and if the graphic item has a .png file
registered with the VIEW usage, Content Management may display it in the topic for editing.

Integration with third-party tools enable you to author content

Content Management integrates tools, which are installed on each client, to support the following
authoring tasks:

• Publishing

Publishing tools render content to PDF, HTML, XHTML, and other proprietary formats, based on the
stylesheets and applications you have available.

• Editing

Editing tools are used to author and edit XML and SGML content and are launched when topics are
opened for editing.

• Comparing

5. Basic concepts for using Content Management
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Comparing tools are used to compare differences in topics.

• Viewing

Viewing tools are used to run an external tool to view topics. This is useful when a quick or remote
preview session is needed, without the processing time required to generate a PDF document or other
process-intensive stylesheet.

Note:

Cortona3D Teamcenter Integration is a third-party tool that provides the capability to author
publications that are linked with assembly and part data in Teamcenter. The Cortona3D tool
utilizes Content Management software but provides its own interface.

Composed documents assemble documents for reviewing

A composed document is created when you publish content. It contains a publication or topic with
all its child topics collected in one file. A reviewer document is the same type of document, named
differently so that it can be used to distinguish documents between those that have been processed
through the review process (composed documents) and those that have not (reviewer documents).
These documents can be exported and imported for content review outside of the system.

Workflows can aid in document review

You can design Teamcenter workflow process templates that incorporate your company's business
practices and procedures. Your company can use these workflows to process topics through release
cycles and between participants.

You can use Teamcenter workflows for document reviews by using Workflow Designer and Workflow
Viewer.

You can manage content in different languages

Content Management manages multiple language versions of topics and publications, for example:
English, Russian, and Simplified Chinese.

Several object types are used for translations:

• Translations

A translation is an object created with the content of a topic in a different language than the original.
Translations indicate the language and topic for which they are created. A translation is related to the
source topic from which it is derived.

• Translation orders

Content Management on Rich Client ─ Usage, Teamcenter 2412  5-3
© 2025 Siemens



A translation order is an object in the translation process used to provide information to the translator.
It contains basic information, such as the translation office assigned and the requested delivery date.

• Translation deliveries

A translation delivery contains the translation topics and has an associated .zip file that can be
exported and sent to the translation company.

• Graphic translations

Graphic translations are objects that are created when graphic options are imported. They store the
language property associated with a graphic option when it is imported. Graphic translations are
related to the original (master language) graphic items and to the graphic options with the associated
translation languages.

5. Basic concepts for using Content Management
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6. Search for Content Management objects
You can use system defined searches to search in Teamcenter for existing content, graphics, and
administration objects.

1. Choose Advanced from the quick Search menu at the top of the navigation pane.

2. On the Search pane toolbar, click  to select a search type.

3. Click More to display the system defined searches.

4. Under System Defined Searches, select the object you want to search for.

Content Management objects are listed with the Content Management prefix.

5. Click OK.

The dialog box that contains the object properties appears.

6. Type the values for the object properties that you want to search for.

7. Click  to search.
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7. Creating Base Content Management
content
Overview of Base Content Management content

The Base Content Management solution is used to work with traditional XML or SGML topics and
publications. You can create topic and publication objects directly in Content Management, and you can
create topics in an editing tool.

A publication is the root level topic in a document structure and contains topics and subtopics.
Depending on the topic types available in your schema and defined by your application administrator,
the publication you create may contain such topics as a cover page, back page, header, footer, and
manual contents, which may consist of several subtopics such as sections or chapters. You may also
create standard topics, such as legal notices or warranty statements, which can be reused in all your
publications.

Here is an example of a publication structure:
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Create a topic or template in Base Content Management

Note:

You can also create a new topic by adding the valid XML elements in another topic that is open
in an editing tool. When you save and check in edited content, new topics are created in Content
Management with the appropriate relationships to the publication structure you are working in.

1. Select either a folder, publication, or topic in which you want to create the new topic, and then
either click New Author Item... , or choose File→New→New Author Item.

Note:

You can select a folder in the Home component view or a publication or topic in either the
Home component view or the Publication Structure view.

2. In the New Author Item dialog box, expand Complete List, click Topic, and then click Next.

3. Enter the following:

In this box Do this

Select Topic Type Select the topic type to associate with the new topic. The topic type
determines which schema is used to validate the topic and which
stylesheets are used when a tool is launched to edit or publish the
topic. If you are creating a topic in an existing publication from the
Publication Structure view, the list of topic types is limited to the
topic types that are valid for the associated schema.

Note:

• The topic type may already be selected, or the options may
be limited to a specific topic type group, depending on how
the ctm0TopicTypeGroup preference is set.

• If no options are listed, your administrator must create topic
types.

ID Either type an ID for the topic, or leave the box blank so that the next
available item ID is automatically assigned.

Revision Either type a revision number for the topic, or leave the box blank so
that the next available revision is automatically assigned.

Name Type the item name for the topic.

Document Title Type the document title of the topic.

7. Creating Base Content Management content
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In this box Do this

Master Language
Reference

Select the master language of the topic.

Is this a template Select whether this topic will be used as a topic template:

True = This topic is a topic template.

False = This topic is not a topic template.

Reference only Store a value to indicate whether this topic should be copied or
referenced when it is referenced by another topic that is used as
template.

True = This topic should be a reference to its original when it is
referenced by another topic that is used as template.

False = This topic should be copied when it is referenced by another
topic that is used as template.

Example:

You are creating topic A which will be used in publication F.
Publication F is used as a template to create publication G.
If this option is set to True for topic A, publication G should
contain topic A as a reference. If this option is set to False for
topic A, publication G should contain topic B, which is copy of
topic A.

Note:

Use this only to store a value; the system does not read this
value during the creation of content from a template topic.

4. Click Finish.

The dialog box clears so you can create another topic.

5. When you are done creating topics, close the dialog box.

Create a publication or template in Base Content Management

1. Select a folder in the Home component view in which you want to create the new publication, and
then either click New Author Item... , or choose File→New→New Author Item.

2. In the New Author Item dialog box, expand Complete List, click Publication, and then click Next.

Create a publication or template in Base Content Management
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3. Enter the following:

In this box Do this

Select Publication Type Select the type of publication, from the list of those defined
in your system.

Note:

If no options are listed, your administrator must create
publication types.

ID Either type an ID for the topic, or leave the box blank so that
the next available item ID is automatically assigned.

Revision Either type a revision number for the topic, or leave the
box blank so that the next available revision is automatically
assigned.

Name Type the item name for the topic.

Document Title Type the title of the publication.

Master Language Reference Select the publication's master language.

Is this a template Select whether this topic will be used as a publication
template:

True = This topic is a publication template.

False = This topic is not a publication template.

4. Click Finish.

The dialog box clears so you can create another publication.

5. When you are done creating publications, close the dialog box.

Create a new topic based on an existing topic revision

1. Select the topic revision from which you want to create the new topic, and then choose File→Save
As→Item(Revision).

2. In the Save Topic Revision As dialog box, enter the following:
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For this option Do this

Name Type the name for the new topic revision.

Document Title Type the document title of the topic revision.

Is this a template Select whether this topic will be used as a topic template:

True = This topic is a topic template.

False = This topic is not a topic template.

Reference only Store a value to indicate whether this topic should be copied or
referenced when it is referenced by another topic that is used as
template.

True = This topic should be a reference to its original when it is
referenced by another topic that is used as template.

False = This topic should be copied when it is referenced by another
topic that is used as template.

Example:

You are creating topic A which will be used in publication F.
Publication F is used as a template to create publication G.
If this option is set to True for topic A, publication G should
contain topic A as a reference. If this option is set to False for
topic A, publication G should contain topic B, which is copy of
topic A.

Note:

Use this only to store a value; the system does not read this
value during the creation of content from a template topic.

3. Click Next.

4. For the Define Attached Objects step, click Next to accept the selected values.

Caution:

Do not modify the Copy Option.

5. For the Related Objects information step, enter the properties for the new dataset and topic:

a. Expand the dataset and the topic information.

b. Type the Name for the new dataset and new topic.

Create a new topic based on an existing topic revision
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Tip:

This is the topic item level, not the topic revision.

c. (Optional) Type a Description for the new dataset and new topic.

d. (Optional) Type an ID or click Assign to create an ID for the topic.

e. Click Next.

6. (Optional) For the Assign Project Page step, assign the topic revision to one or more projects.

7. Click Finish.

Create a new publication based on an existing publication revision

When you create a new publication using the Save As option, you create a new publication and
publication revision with references to the same topics as in the original publication.

1. Select the publication revision from which you want to create the new publication, and then
choose File→Save As→Item(Revision).

2. In the Save Publication Revision As dialog box, enter the following:

For this option Do this

Name Type the name for the new publication revision.

Document Title Type the document title of the publication revision.

Is this a template Select whether this topic will be used as a publication template:

True = This topic is a publication template.

False = This topic is not a publication template.

3. Click Next.

4. For the Define Attached Objects step, click Next to accept the selected values.

5. For the Related Objects information step, enter the properties for the new publication:

a. Expand the publication information.

b. Type the Name for the new publication.
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Tip:

This is the publication item level, not the publication revision.

c. (Optional) Type a Description for the new publication.

d. (Optional) Type an ID or click Assign to create an ID for the publication.

e. Click Next.

6. (Optional) For the Assign Project Page step, assign the publication revision to one or more
projects.

7. Click Finish.

Create a new publication based on an existing publication revision
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8. Creating DITA content
Overview of DITA content

DITA (Darwin Information Typing Architecture) is an XML-based architecture for developing technical
publications. It includes an architectural specification, language specification, and DTD and schema
implementations of the language. If you have installed the DITA Content Management solution, you
can manage documentation for the DITA architecture. The DITA solution also includes Base Content
Management features. The way you relate, create, and edit content differs between the Content
Management solutions; however you can use the Publication Structure view to organize DITA content.
For more information about DITA, see OASIS Standards.

Content Management supports these objects through DITA version 1.3:

Note:

DITA publishing is supported only on Linux and Windows.

The contents of anchorref elements are not included in documents published with DITA Open
Toolkit 2.4.6 publishing tools.

• DITA maps

A DITA map is an object that contains references to DITA topics and organizes the topics into
hierarchies, tables, or groups. Maps can also be used to produce outlines or tables of contents.
A map can contain any combination of references to DITA topics, DITA tasks, DITA concepts, DITA
references, and other DITA maps. A DITA map includes metadata to describe properties such as
audience, platform, and product. Maps are used to create documents that result in separate XML files
in output processing. The <map> element is used in the XML to define a map. You can import existing
DITA maps to the Content Management application, which includes any references to DITA topics they
may contain. You can work with two types of maps:

• DITA Dynamic Map

You can add, delete, and organize topics in a DITA dynamic map in Content Management and edit
contents in an editing tool. A DITA bookmap is a special type of dynamic map, used to organize
DITA content into a book format. The <bookmap> element is used in the XML to define a bookmap.

• DITA Static Map

You can edit topic references in a DITA static map in an editing tool but not in Content
Management. In version 9.0 and later, static maps are primarily used only for content migrated
from earlier versions.

• DITA Base
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A DITA base object, also referred to as a DITA composite object, is a top-level container for multiple
topics used to create documents that result in one XML file in output processing. A DITA base object
can contain any combination of DITA topics, DITA tasks, DITA concepts, and DITA references. A DITA
base object can be opened for editing XML content. The content opens in the editing tool as one XML
file containing all its related files. The <dita> element is used in the XML to define a DITA base object.

• DITA topics

A DITA topic is one unit of content that contains the information for a single subject. The DITA
architecture includes the following four topic types:

• DITA Topic 

A DITA topic, also referred to as a generic or unspecialized topic type, provides the base for
specialized topic types and does not meet the definition of a concept, reference, or task topic.

• DITA Concept Topic

A DITA concept topic is a specialized topic type that provides background information to aid in the
understanding of a product, interface, or task.

• DITA Reference Topic

A DITA reference topic is a specialized topic type that provides quick access to facts.

• DITA Task Topic

A DITA task topic is a specialized topic type that provides step-by-step instructions for completing a
task.

Create a DITA item

1. Select the location in which you want to create the new DITA item, and then either click New
Author Item... , or choose File→New→New Author Item.

Note:

You can select a folder in the Home component view or a DITA map or topic in either the
Home component view or Publication Structure view.

2. In the New Author Item dialog box, expand Complete List and click one of the following:

• DITA Base

• DITA Concept

8. Creating DITA content
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• DITA Dynamic Map

Note:

Use this option to create a DITA bookmap.

• DITA Reference

• DITA Static Map

• DITA Task

• DITA Topic

3. Click Next.

4. In the New Author Item dialog box, enter the following:

In this box Do this

Select Topic Type Select the topic type to associate with the new object. The topic type
determines which schema is used to validate the object and which
stylesheets will be used when a tool is launched to edit or publish the
content.

Note:

• The topic type may already be selected, or the options may
be limited to a specific topic type group, depending on how
the ctm0TopicTypeGroup preference is set.

• If no options are listed, your administrator must create topic
types.

ID Either type an ID for the object, or leave the box blank so that the
next available item ID is automatically assigned.

Revision Either type a revision number for the object, or leave the box blank so
that the next available revision is automatically assigned.

Name Type the item name for the object.

Document Title Type the document title of the object.

Master Language
Reference

Select the master language of the object.

Is This A Template Select whether this object will be used as a template:

Create a DITA item
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In this box Do this

True = This object is a template.

False = This object is not a template.

Reference only Use this indicator to set whether this object will be copied or
referenced when it is referenced by another object that is used as
template.

True = This object will be a reference to its original when it is
referenced by another object that is used as template.

False = This object will be copied when it is referenced by another
object that is used as template.

DITA Audience Select the audience to assign to this object.

DITA Importance Select the level of importance to assign to this object.

DITA Other Properties Select other properties to assign to this object.

DITA Platform Select the platform to assign to this object.

DITA Product Select the product to assign to this object.

Relation Selection
(appears only when you
are relating a DITA topic
to another topic of the
same type from the
Publication Structure
view)

Select the type of relationship to create between the parent and child
topics:

• Composable Reference

When a composable reference appears in the editing tool, you see
only a reference to the topic. However, when a topic is published
with a composable reference to another topic, the published topic
includes all the content from the referenced topic.

• Topic to Topic

When a topic-to-topic relation appears in the editing tool, you see
all the content from the related topic. Additionally, when a topic
is published with a topic-to-topic relation to another topic, the
published topic includes all the content from the related topic.

Reference Topic Type
(appears only when the
value of the Relation
Selection is Composable
Reference)

Select the type of reference to create between the two objects:

Example:

• Topicset map to topic

Use when defining a topicset element that references a set of
topics.
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In this box Do this

• Topicref map to topic

Use when adding topics to maps, using the topicref element.
When the map is published, the topics appear in the output.

• Keydef map to topic

Use when adding topics to maps, using the keydef element.
By default, when the map is published, the topics do not
appear in the output, although you can configure them to
appear.

Key Name Type the value to assign to the keys attribute.

5. Click Finish.

Create a new DITA item based on an existing one

1. Select the revision of the DITA item from which you want to create the new DITA item, and then
choose File→Save As→Item(Revision).

2. In the Save As dialog box, enter the following:

For this option Do this

Name Type the name for the new DITA item.

DITA Audience Select the audience to assign to this item.

DITA Importance Select the level of importance to assign to this item.

DITA Other Properties Select other properties to assign to this item.

DITA Platform Select the platform to assign to this item.

DITA Product Select the product to assign to this item.

3. Click Next.

4. For the Related Objects information step, enter the properties for the new dataset and item:

a. Expand the dataset and the item information.

b. Type the Name for the new dataset and new item.

Create a new DITA item based on an existing one
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Tip:

This is the item level, not the item revision.

c. (Optional) Type a Description for the new dataset and new item.

d. (Optional) Type an ID or click Assign to create an ID for the item.

5. Click Finish.

Working with DITA content references (conrefs)

What are DITA conrefs?

When you have DITA content that must appear in more than one DITA topic or map, you can use DITA
conrefs to reuse the content. When you publish, referenced content appears in the elements you create
in topics or maps. When you edit content, the modifications are reflected everywhere it is referenced.

You can reference an entire topic or an element from a topic.

When you import a document with a DITA conref, the filename in the conref must be in the format
item_id.dita for topics and item_id.ditamap for maps.

Example:

conref="X000001.dita#X000001"

conref="X000001.dita#X000001/para1"

conref="X000124.ditamap"

conref="X000124.ditamap#topic1"

Add a DITA conref to reference an element

1. Open the topic or map that contains the content you want to reuse in another topic or map.

2. In the editing tool, add an ID to the element of the content you want to reference. For example,
if you want to reference the text of a paragraph, create an ID in the id attribute of the paragraph
element.

3. Save the change to the topic or map.

4. Open the topic or map in which you want the referenced content to appear.
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5. Add a new element where you want the reference to appear, and leave it empty. For example, if
you are referencing the text of a paragraph, create a new paragraph element.

6. In the Publication Structure view, right-click the topic or map you want to reference, in which you
just created the ID, and choose Copy for Editor→DITA Content Reference.

7. In the editing tool, paste the reference in the empty element in the content, and replace the
placeholder text with the ID of the element you are referencing. The way you paste the reference
depends on the type of tool you are using:

• In a plain text editor or an XML editor with a plain text view, when you paste the reference, it
appears within the element as in this example of a reference to a topic:

conref="X000006.dita#X000006/<?replace_with_element_id?>"

Or in this example of a reference to a map:

conref="X000124.ditamap#<?replace_with_element_id?>"

You replace the placeholder text. For example:

conref="X000006.dita#X000006/para1"

conref="X000124.ditamap#topic1"

• If you are working in an XML editor view showing XML as tags, the reference is pasted as
text instead of markup, so you must edit it accordingly. In XMetaL Author, you can paste the
reference in the element’s conref attribute in the Attribute Inspector, and edit it to appear as
follows:

8. Add the attributes to set whether the conref is fixed or floating. For example:

• In a plain text editor:

conref="X000006.dita#X000006/para1" rev="A" base="fixed"

conref="X000006.dita#X000006/para1" rev="CURRENT" base="floating"

• In an XML editor:

Add a DITA conref to reference an element
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9. Save the changes to the topic or map.

10. To view the relationship between the topics, in the Home component view, right-click the
referenced topic and choose Properties On Relation.

The Properties dialog box shows the relation type between the topics.

Add a DITA conref to reference another topic

1. In the Publication Structure view, right-click the topic you want to reference and choose Copy for
Editor→DITA Content Reference.

2. Open the topic or map in which you want the referenced content to appear.

3. In the editing tool, paste the reference in the topic element in the content. The way you paste the
reference depends on the type of tool you are using:

• In a plain text editor or an XML editor with a plain text view, when you paste the reference, it
appears within the element as in this example:

conref="X000001.dita#X000001/<?replace_with_element_id?>"

Or in this example of a reference to a map:
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conref="X000124.ditamap#<?replace_with_element_id?>"

In this case, you remove the placeholder text. For example:

conref="X000001.dita#X000001"

conref="X000124.ditamap"

• If you are working in an XML editor view showing XML as tags, the reference is pasted as
text instead of markup, so you must edit it accordingly. In XMetaL Author, you can paste the
reference in the element’s conref attribute in the Attribute Inspector, and edit it to appear as
follows:

4. Add the attributes to set whether the conref is fixed or floating. For example:

• In a plain text editor:

conref="X000001.dita#X000001" rev="A" base="fixed"

conref="X000124.ditamap" rev="CURRENT" base="floating"

• In an XML editor:

5. Save the changes to the topic.

Relate DITA topics

If you are using the DITA 1.2 or 1.3 administration data included with Content Management, multiple
reference topic types are available for topics and maps. When you relate a DITA 1.2 or 1.3 topic to
another topic or map, you must select the reference topic type. You may also use this feature if you are
not using the DITA 1.2 or 1.3 administration data but your administrator has defined multiple reference
topic types for DITA topics.

1. Relate a topic to another topic or map by dragging it to the other topic or map in the Publication
Structure view.

Relate DITA topics
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Note:

If you select a topic item, not a topic revision, the most current revision is moved.

2. From the Reference Topic Type list, select the type of reference to create between the two objects.

3. In the Key Name box, type the value to assign to the keys attribute.

4. Click Finish.

Add topics to a DITA relationship table

The DITA relationship table (reltable) enables you to manage related topic links in publications using
a single map. The relationships defined in the table appear in lists of related topics in the published
output. For more information about relationship tables, see OASIS Standards.

1. In a DITA dynamic map in an editing tool, use standard DITA elements and attributes to create a
relationship table.

2. For each topic you want to add to the table, in the Publication Structure view, right-click the topic,
and choose Copy for Editor→Reference To DITA Map.

3. In the editing tool, paste the reference in the relcell element in the relationship table.

The cell is populated with the tag name from the type of topic you copied the reference from, for
example: topicref. The href, navtitle, and type attributes are populated in the element.

4. Edit the tag if it is not the correct element.

8. Creating DITA content
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5. Add more attributes, if necessary, such as linking.

The output creates related links to topics in the same row, but not the same cell.

Example:

The output for the task topic looks like this:

The output for one of the concept topics looks like this:

Working with DITA keyrefs

DITA keyrefs are an indirect addressing mechanism available in DITA 1.2 and 1.3, in which you store
symbolic names for topic file paths in one map. When you change a topic’s path in this one place, all
references to the topic are automatically updated.

To use the keyref attribute, you define the keys attribute in a map on an element that references
another topic or map, such as the topicref or keydef elements. You can define keys in the same map
you use for your deliverable, or you can create and reference a map specifically for defining keys. In the
keys attribute you define a name for a topic’s file and in the href attribute you define the file’s path.

Working with DITA keyrefs
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Example:

<topicref keys="tools" href="tools_needed.dita"/>

or

<keydef keys="tools" href="tools_needed.dita"/>

To create references to the topic from another topic, you use the keyref attribute.

Example:

<link keyref="tools"/>

In the above example, the link defined by the keyref goes to the tools_needed.dita file. If the location of
the file changes later, you update the keys definition in the map, and all the references in all the topics
with the tools keyref automatically point to the new file location.

For more information about DITA keyrefs, see the DITA XML.org website.

In Content Management, you can define keyrefs in several ways:

• When you create a new topic in a selected map, in the New Author Item dialog box you define the
Reference Topic Type and Key Name, which is the value of the keys attribute.

• When you relate DITA topics, you drag the topic for which you want to define the keys to the map in
which you want to define it. In the Reference Topic Type Selection dialog box, select the Reference
Topic Type and type the Key Name, which is the value of the keys attribute.

• When you edit the content in an editing tool, you can add the XML elements and attributes to define
keyrefs.

Validate DITA keyrefs

When you define DITA keyrefs and create references to them, you can validate the keyrefs to make sure
they are set up correctly.

You can also set the Cdi0KeyrefValidation preference to true so that keyrefs used in topics referenced
in maps are always validated during import and when you save changes and close the file in an editing
session.

1. Select the map that defines the keys for the keyrefs.

2. Choose Tools→Reference Validation.
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The validation finds keyrefs used in the map's topics and verifies that the keys are defined in the
map.

A message appears indicating whether the keyrefs are valid.

Create DITA value filter using a Ditaval topic

DITA value filters are used to filter topics in a DITA map when you publish it, based on certain attributes
in the topics. For example, you can exclude topics whose audience attribute is advanced or expert, so
that the map includes only those topics whose audience is beginner.

Your administrator may create DITA value filters that you can apply to content when you publish it. In
Content Management for DITA 1.3, you may also create your own DITA value filters by creating topics
with the Ditaval topic type.

Create a DITA value filter

1. Create a DITA Topic.

• For the topic type, select DITA 1.3 Ditaval.

• Enter only the required values. Do not select value filters at the bottom of the dialog box.

2. Edit the topic, and define the value filters using the DITA val element according to the OASIS
Standards.

3. Drag the DITA value filter topic to any place in the structure of a map in the Publication Structure
view.

Apply DITA value filters when publishing

1. Begin the steps to publish the map.

DITA value filters created by your administrator appear in the DITA Value Filters list.

2. Choose Find DITAVALs.

The DITA value filter topics that were added to the map appear in the DITA Value Filter Topics in
the Map list.

3. Select or clear the check boxes for the DITA value filters, from either list, that you want to use to
publish the map.

Create DITA value filter using a Ditaval topic
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Review broken links in DITA OT output

When you publish content, a log file is created. If you publish with a DITA Open Toolkit (OT) tool, you can
review the log file for any errors with broken references or links between topics.

1. After you publish content, choose Translation→Administration Console.

2. In the Dispatcher Request Administration Console, select the line containing the publish request
and click .

3. In the Translation Request Properties dialog box, click the Files tab.

4. Select the log file and click Export.

5. In the Save As dialog box, select the location to save the log file.

6. Open the log file with a text editor, and search for the errors that provide the information about the
broken links.
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9. Creating S1000D content
Overview of S1000D content

If you have installed the S1000D Content Management solution, you can manage documentation for
the S1000D standard. The S1000D solution also includes base Content Management features. The way
you relate, create, and edit content differs between the Content Management solutions. You can use the
Publication Structure view to organize S1000D content.

Note:

To import SGML data for authoring in the S1000D solution, the Content Management S1000D
SGML Parser feature must be selected in Teamcenter Environment Manager (TEM) when you
install Teamcenter.

The dialog boxes you use to create S1000D objects contain all the data required by the S1000D
specification. These items become elements in the resulting SGML or XML object. For example, the
SGML or XML files contain the elements of the identification and status section that is required in certain
objects. The content of the objects is created in an editing tool.

To download sample content that you can view or import, see www.S1000D.org, which includes the
sample XML content and illustrations for a fictional bike for the most recent S1000D versions.

Content Management supports these objects for S1000D version 2.3 (SGML objects) and issues 4.0, 4.1,
4.2, and 5.0 (XML objects):

Note:

S1000D issue 2.3 is supported only on Linux and Windows.

• Data Module

A data module is a self-contained information unit. Every data module contains an identification
and status section and a content section that contains text and illustrations. Content Management
supports the standard S1000D data modules types, including BREX, procedural type, and descriptive
type.

• Data Module List (DML)

A data module list (DML) identifies the data modules in a project. It contains an identification and
status section and the data module requirement list content. The DML object can be related to data
module objects, but it is not required. When you relate data modules to it, the DML can be used to
group data modules together in a compiled dataset.

• Data Dispatch Note (DDN)
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A data dispatch note (DDN) contains information about the sender, receiver, and content of a
dispatch. It can be related to many data modules. When the relation to a data module is made,
additional SGML or XML code is automatically added to the DDN about the data module. A data
module can be related to many DDNs.

• Publication Module

A publication module defines the content and the structure of a publication. It contains an
identification and status section and a content section that contains references to data modules, other
publication modules, and legacy technical publications. The publication module for S1000D content is
not the same type of object as the publication topic type used in Base Content Management.

• Commentary 

A commentary, or comment, is used to report issues on data modules during the verification process
and the in-service phase of the product. It contains an identification and status section and a content
section that contains the original comment and/or a response to a comment. A comment can be
related to a data module, publication module, DML, or DDN; it must have at least one of these
relations.

• In Process Review Form

An in-process review form contains the review of data modules by the customer or the contractor.

• SCORM Content Package

A SCORM content package contains the content and metadata for e-learning developed in accordance
with the Sharable Content Object Reference Model (SCORM) standard.

• Standard Numbering System (SNS)

An S1000D standard numbering system (SNS) structure defines the numbering scheme used in data
modules for specific S1000D projects.

Create an S1000D item

1. Select the location in which you want to create the new S1000D object, and then either click New
Author Item... , or choose File→New→New Author Item.

Note:

You can select a folder in the Home component view or an S1000D object in either the
Home component view or Publication Structure view.

2. In the New Author Item dialog box, expand Complete List and click the item you want to create.
All S1000D items are listed with the S1000D prefix.
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3. Click Next.

4. In the New Author Item dialog box, enter the data for the object you are creating, according to the
S1000D standard.

For more information on the S1000D standard, see www.S1000D.org.

Note:

When you create an S1000D 2.3 data module, you must enter one of the two following
groups of options, even though they may not be marked as required:

• System Difference Code, Chapter Number, Section Number, Subsection, and Subject

• Support Equipment Variant Code, Equipment Category and Sub-Category Code,
Equipment Identification Code, Component Identification Code, Extension Code, and
Extension Producer

5. Click Finish.

If any of the attributes that comprise the item ID are not valid for the associated schema, a message
box appears indicating which fields are invalid. For example, when creating a data module, the
Model Identifier and System Code values are validated, but the Security Class value is not.

Create a new S1000D item based on an existing one

1. Select the revision of the S1000D item from which you want to create the new S1000D item, and
then choose File→Save As→Item(Revision).

2. In the Save As dialog box, modify the data for the new item you are creating, according to the
S1000D standard.

For more information on the S1000D standard, see www.S1000D.org.

Note:

Any changes you make to the codes that comprise the Export File Name are automatically
updated in the Export File Name when the new item is created. For example, if you change
the Item Location Code, that character in the Export File Name is updated when the item is
saved to the database.

Create a new S1000D item based on an existing one
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When you create an S1000D 2.3 data module, you must enter one of the two following
groups of options, even though they may not be marked as required:

• System Difference Code, Chapter Number, Section Number, Subsection, and Subject

• Support Equipment Variant Code, Equipment Category and Sub-Category Code,
Equipment Identification Code, Component Identification Code, Extension Code, and
Extension Producer

3. Click Next.

4. For the Define Attached Objects step, click Next to accept the selected values.

5. For the Related Objects information step, enter the properties for the new S1000D item:

a. Expand the dataset and the S1000D item information.

b. Type the Name for the new dataset and new S1000D item.

Tip:

This is the item level object, not the revision.

c. (Optional) Type a Description for the new dataset and new S1000D item.

d. (Optional) Type an ID or click Assign to create an ID for the S1000D item.

e. Click Next.

6. (Optional) For the Assign Project Page step, assign the S1000D item to one or more projects.

7. Click Finish.

9. Creating S1000D content
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If any of the attributes that comprise the item ID are not valid for the associated schema, a message
box appears indicating which fields are invalid. For example, when creating a data module, the
Model Identifier and System Code values are validated, but the Security Class value is not.

Adding data modules to DMLs, DDNs, and publication modules

You can relate data modules to a data module list (DML), a data dispatch note (DDN), or a publication
module (PM) to group data module references together in one document. When you relate a data
module to a DML, DDN, or PM in Content Management, SGML, or XML elements from the data module
are added to the DML, DDN, or PM.

To relate data modules to DMLs, PMs, and DDNs in S1000D 4.0, 4.1, 4.2, and 5.0, you must create a
content topic as a child of the DML, PM, or DDN. Also, for PMs and DDNs, you must then create an
additional topic.

Example:

To relate data modules to DMLs in S1000D 2.2/2.3, you relate the data modules directly to the DMLs. For
DDNs, you must create a topic with a delivery list topic type as a child of the DDN. You then relate data
modules to the delivery list topic.

You can also create an S1000D data module list by using a saved search.

Note:

Once any data module is related to a data module list, the saved search is no longer used for that
data module list.

Adding data modules to DMLs, DDNs, and publication modules
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Relate data modules

You can relate data modules to a data module list (DML), a data dispatch note (DDN), or a publication
module (PM).

1. Right-click the data module, and choose Copy for Editor→Data Module Reference.

If more than one reference type is defined in your system, the Reference Topic Type Selection
dialog box appears.

2. From the Reference Topic Type list, select the type of reference to create between the data
module and the object you are relating it to.

3. Click Finish.

4. Click in a valid location in the content in the editing tool, and choose Paste.

Creating the structure of an S1000D publication module

To create the structure of an S1000D publication module, you assemble the hierarchy of objects, such as
in this example.

Example:

• Publication Module

9. Creating S1000D content
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• PM Content topic

■ PM Entry topic

◊ Front Matter data module (title page appears as first page)

■ PM Entry topic

◊ Other supported data module type (see list below)

■ PM Entry topic

◊ Other supported data module type (see list below)

With the S1000D stylesheets provide upon installation, you can create the following types of S1000D
publication modules for publishing to PDF or XHTML format. Your administrator can also create
stylesheets for publishing additional S1000D publication types. The objects you add to the hierarchy
and the stylesheets you use determine the contents of the publication modules.

• Service bulletin publication module - references service bulletin data modules

• Illustrated parts publication - references illustrated parts data modules

• General publication module - references one or more types of data modules. The following types are
supported. If you include unsupported data modules in the publication module, the output includes
text explaining that the type is unimplemented.

Descriptive

Fault

Illustrated parts data

Creating the structure of an S1000D publication module
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Procedure

Schedule

Service bulletin

Front matter

Air crew

Contents of published S1000D publication modules

You can publish three types of S1000D publication modules to PDF or XHTML format. If you use
the stylesheets provided upon installation and assemble the publication modules with the following
structure, the published content contains the following:

Service bulletin publication module

• Front matter content:

Title page

Table of contents for each referenced data module in the publication module

List of effective pages

List of effective data modules

Highlights, which includes reasons for updates and changes

• Content for each service bulletin data module:

Table of contents

List of tables

List of figures

Service bulletin content

• Acronym and term indices

Illustrated parts publication module

• Front matter content:

9. Creating S1000D content
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Title page

Table of contents for each referenced data module in the publication module

List of effective pages

List of effective data modules

Highlights, which includes reasons for updates and changes

• Content for each description data module:

Description content

• Content for each illustrated parts data module:

Illustrated parts content

• Acronym and term indices

General publication module

• Front matter content:

Title page

Table of contents for each referenced data module in the publication module

List of effective pages

List of effective data modules

Highlights, which includes reasons for updates and changes

• Content for each referenced data module:

Table of contents

List of tables

List of figures

Data module content

• Acronym and term indices

Contents of published S1000D publication modules
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Using saved searches to create data module lists

You can use saved searches to generate S1000D data module lists. If you use a saved search in a data
module list, when you export or publish the data module list, the data modules in the saved search
will be included, as if they were related to the data module list. This is particularly useful for large data
module lists.

Note:

The saved search must be related to the topic in the data module list that contains the data
module references. For example, in an S1000D 4.0 data module list this is the topic of the topic
type dmlContent. In the Home component view, the saved search is related to the dmlContent
topic revision.

When you relate data modules to data module lists using a saved search, they are related only as
references. In the Publication Structure view, the data modules do not appear under the data module
list. However, if you open the data module list for edit, and then save it, any data modules referenced
from the saved search will be directly related to the data module list and will appear under the data
module list in the Publication Structure view.

Note:

Once any data module is related to the data module list, the saved search is no longer used for
that data module list.

You cannot use a saved search to compose non-S1000D objects.

Create a data module list using a saved search

1. Search for the data modules you want to include in the data module list.

2. Create a saved search that includes the data modules.

3. In the Home component view, drag the saved search to the appropriate object:

• For S1000D 2.3, drag it to the data module list revision.

• For S1000D 4.0, 4.1, 4.2 and 5.0, drag it to the topic under the data module list that stores all
the references.

Note:

The data module must be a valid one for the data module list, as defined by your
organization’s schemas. If it is not valid, the data module is not added to the data module list
when published.

9. Creating S1000D content
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Apply project-specific standard numbering system (SNS) codes to a
new data module

An S1000D standard numbering system (SNS) structure defines the numbering scheme used in data
modules for specific S1000D 4.0, 4.1, 4.2 and 5.0 projects. Your administrator creates an SNS structure
for you to use. When you create a new data module in Content Management, you select a node of an
SNS structure to apply its data module code (DMC) values and other data module detail values to the
data module.

When you import a data module or graphic that use SNS codes, they are related to the appropriate note
in the SNS structure based on their SNS. Objects that don’t use an SNS, such as data dispatch notes,
publication modules, and graphics with commercial and government entity (CAGE) codes, are related to
the top node of the SNS structure.

Nodes in an SNS structure define the values for systems, subsystems, assemblies, and disassemblies.

1. Right-click the SNS structure in the Home component view or Search Results view, and choose
Show in Publication Structure.

2. In the Publication Structure view, select the node of the structure whose values you want to use
for the data module you are creating.

3. Create the data module.

Values in New Author Item dialog box are populated from the SNS structure node you selected.

Import a data management requirement list

A data management requirement list (DMRL) identifies the data modules planned for a specific project.
You can import a DMRL to Content Management to create data module objects for all data modules
identified in the DMRL. You can import the data modules to a selected folder or as objects associated
with a standard numbering system (SNS) structure.

To import a DMRL:

1. Prepare the .csv file.

2. Import the DMRL.

Prepare the .csv file

1. Use a text editor to create a .csv file to create a DMRL that lists the data modules you want to create
in Content Management. Microsoft Office Excel is not recommended for this, since it may remove
leading zeros.

Apply project-specific standard numbering system (SNS) codes to a new data module
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A sample .csv file is included in the administration data provided with the Content Management
installation:

TC_ROOT\contmgmts1000d40_data\data\admin\bulkImportDataModule.csv

2. Include the following values, in the order listed. Use a comma for any optional value that is blank.

Model identification code

System difference code

System code

Subsystem code

Sub-subsystem code

Assembly code

Disassembly code

Disassembly code variant

Information code

Information code variant

Item location code

Language

Extension code (optional)

Extension Producer (optional)

Learn Code (optional)

Learn Event Code (optional)

Technical Name

Information Name (optional)

Security classification

Topic type

9. Creating S1000D content
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Originator name

Originator CAGE code

Responsible partner company name

Responsible partner company CAGE code

Example:

This is one line representing a data module:

S1000DBIKE, TEMP, DA2, 0, 0, 00, 00, AB, 042, A, A, English US, , , , ,
Temp System,
Temp Description, 01, Description-4-1, ORG Name, ORG41, RPC Name, RPC41

Import the DMRL

1. Do one of the following:

• Select the folder in which you want to place the imported DMRL.

• Associate the DMRL with an SNS structure:

a. In the Home component view or Search Results view, right-click the SNS structure to
which you want to associate the DMRL, and choose Show in Publication Structure.

b. In the Publication Structure view, select the node of the structure whose values you want
to use for the DMRL you are importing.

2. Choose Tools→Import→S1000D Project Data→Data Management Requirement List (DMRL).

3. In the Bulk Import dialog box, browse to and select the .csv file containing the DMRL.

4. Click OK.

If you did not choose an SNS structure to associate the DMRL with, the Import Status dialog box
appears, indicating that no SNS node was selected. Click either Continue to continue with the
import or Cancel to cancel the import.

When the import is complete, the Import Results dialog box appears, indicating the import
completed successfully.

Import a data management requirement list
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Create a data module delivery

The data dispatch note (DDN) and data module list (DML) are used to create a delivery to transfer a set
of project data modules between organizations. You create a delivery by first choosing a DML. During
the process of creating the delivery, a DDN is created in Content Management, and a .zip file is created
with the contents of the delivery. The DDN provides the metadata and the list of data modules in a CSDB
transfer package.

When you create a delivery for a project, you can choose to deliver all data modules, only released data
modules, only those not in last official delivery, or all data modules that have changed since the last
delivery.

1. Select the DML for which you want to create a delivery, and choose Tools→Export→Incremental
Delivery.

2. In the Incremental Delivery dialog box, do the following:

For this option Do this

Language Select the language you want to use for the exported
content.

Graphic Mode Select one of the following to indicate how the content
references the graphic names:

Caution:

If you are using the S1000D administration data
provided in the Content Management installation,
select Public ID.

• Public ID

The public identifiers of the graphics are used in the
content to reference the graphics.

• Import Original Name

The original names of the graphics are used in the
content to reference the graphics. These are the file names
of the graphics before they are imported into Content
Management.

• XML Number

9. Creating S1000D content
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For this option Do this

The XML numbers of the graphics are used in the content
to reference the graphics. When you choose this option,
graphics are included in the export.

• Graphic Name

The names of the graphics are used in the content to
reference the graphics. The graphic name is the name of
the imported file without the file suffix. This option can be
used when you want to import the publication or topic
including graphics into another Content Management
environment. When you choose this option, graphics are
included in the export.

Graphic Priority (For graphic
modes Public ID or Import
Original Name only)

Select the graphic priority to determine in what order the
topic's graphic options are selected for the output, based on
the graphic usages set on the graphic option.

Note:

Graphic usages are set when a graphic is imported.

Transform Policy If you would like to apply an XML transformation policy to the
content you are exporting, select it from the list.

A transformation policy can be used to modify content
when it is published or exported. For example, it could
convert units of measure, such as US standard to metric.
Your administrator must create a transform policy before it is
available for you to use from this dialog box.

Content Select any of the following to choose the contents of the .zip
file:

• Include Supporting Data

Includes the schemas for the exported topics.

• Include Graphic Data

Includes the graphics embedded in the exported topics.

Delivery Select one of the following to choose the data modules to
include in the delivery:

• Full Official

Create a data module delivery
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For this option Do this

Includes only the data modules that have been released.

• Full Unofficial

Includes all data modules.

• Incremental Official

Includes all released data modules not in the last full
official delivery.

• Incremental Unofficial

Includes any data modules that changed since the last full
official delivery.

3. Click Next.

4. In the Data Dispatch Note for Incremental Delivery dialog box, enter the data for the delivery
you are creating.

Tip:

For the Document Title, enter a title that helps you identify the contents, for example,
include Full Official in the title if it is a full official delivery.

5. Click Next.

6. In the next Data Dispatch Note for Incremental Delivery dialog box, enter the contact
information for the delivery you are creating.

7. Click Finish.

8. In the Save As dialog box, select the folder in which to save the .zip file for the delivery.

The DDN is created and related to the DML.

Validate data modules against a BREX data module

When authoring using the S1000D standard, you validate data modules against a business rules
exchange (BREX) data module to verify that the data modules conform to a project's business rules.
Content Management provides a validation tool, with which you can validate a single data module,
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a group of selected data modules, or all data modules in a data module list, data dispatch note, or
publication module.

Your administrator can integrate a third-party editing tool through the ContMgmtS1000D40Service
SOA service to validate a data module against a BREX data module from within the tool. Information
about SOA services is provided in the Services Reference.

Note:

To access the Services Reference, install the Teamcenter developer references when you install
Teamcenter online help, or go to https://support.sw.siemens.com.

1. Select one or more data modules, a data dispatch note, or a publication module, choose
Tools→BREX Validation, and then choose one of the following:

• Run In Background

Runs the validation while you perform other tasks in Teamcenter. When the validation is
completed, a log file is attached to each data module you selected.

• Wait for Results

Runs the validation while you wait for it to be completed. You cannot perform other tasks in
Teamcenter while it is running. When the validation is completed, a log file is created.

When the validation is completed, the BREX Validation dialog box appears, providing you with the
option to view the log file. The log file lists the number of data modules that passed and failed the
validation.

2. Click either Yes to show the log file, or No to close the dialog box without showing the log file.

S1000D workflow templates

Teamcenter provides workflow templates to automate processes for the S1000D 4.0, 4.1, 4.2, or 5.0
standard. You can modify the templates to meet your organization’s requirements. The workflows can be
used only for the Content Management objects specified below.

Content Management Comment Process

Use with: Commentary 4.0/4.1/4.2/5.0 objects

S1000D commentaries, or comments, are used to report issues for data modules, publication modules,
data module lists, and data dispatch notes. After a comment is created and related to the object with the
issue, this workflow is created with the comment as an attachment and is used to track the review and
acceptance or rejection of the comment.

S1000D workflow templates
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In the provided workflow template, a task is assigned to the Engineering Designer resource pool. Most
likely, your application administrator will modify this to a resource pool created for your organization.
A resource pool is a group/role combination to which members can be subscribed. When a task is sent
to a resource pool, a notification is sent to its members. Notification is sent to all members, subscribed
members, or none based on the EPM_resource_pool_recipients preference. Once a member of the
resource pool claims the task, it is removed from all other resource pool members’ tasks and appears in
the assigned member’s task list.

Content Management Data Module Process

Use with: Data Module 4.0/4.1/4.2/5.0 objects

This workflow manages the data module development process, including assigning an author and
various reviewers, authoring the data module, and reviewing the data module.

Data module properties such as Issue Number, In Work, and Quality Assurance Status, are updated
during the workflow steps according to the S1000D specification. For example, the Quality Assurance
Status of the data module, stored in the <qa> element, is updated when the data module completes
first verification. The <firstVerification> element includes an attribute to indicate the type of verification:
table top (tabtop), on object (onobject), or both (ttandoo). The In Work attribute is incremented each
time the data module is sent back to the author to update.

This workflow requires these participants to be assigned: author, peer reviewer, engineering reviewer,
and editorial reviewer.

Content Management Exchange Export Process

Use with: Data Dispatch Note 4.0/4.1/4.2/5.0 objects

Data dispatch notes are created to exchange data modules with partners or OEMs. This workflow
manages the process of validating the S1000D objects in the data dispatch note and exporting the
S1000D objects.

Content Management ICN Process

Use with: Illustration Request topics

As you develop publications, you may include illustrations in the content. This workflow manages the
graphic creation process, including determining if an existing or new graphic is to be used, requesting a
graphic, assigning an illustrator, and approving the graphic.

This workflow requires participants to be assigned. The lead author must be assigned at the start of
the workflow. The illustrator is assigned during the workflow only if a new graphic is required. Since
this workflow uses the dynamic participants, illustrator and lead author, you must route a topic in the
workflow. This can be a topic type created by your organization or the provided illustration request topic
modified to meet your needs.

9. Creating S1000D content
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To enable the creation of illustration request topics, the administrator must import the illustration
request topic type, available in the TC_ROOT\contmgmts1000d40_data\data\admin folder.

To create an illustration request topic:

1. Choose File→New→New Author Item, and select Topic.

2. In the New Author Item dialog box, choose Illustration Request from the Select Topic Type list.

Content Management Publication Module Plan

Use with: Publication Module 4.0/4.1/4.2/5.0 objects

Publication modules define the content and structure of a publication. This workflow manages the
development, review, and approval of a publication module.

Content Management Publication Module Ready for Release

Use with: Publication Module 4.0/4.1/4.2/5.0 objects

This workflow manages the review and approval of a publication module as an entire document. The
publication module properties Issue Number, In Work, and Quality Assurance Status are updated
during the workflow steps according to the S1000D specification.

S1000D workflow templates
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10. Create a topic or publication from a
template
1. In the Publication Structure view, click Open Topic By ID .

2. In the ID box, type a string to find the template’s ID.

3. From the Is Template list box, select true.

4. Click Find .

5. Double-click the template in the result list to open it in the Publication Structure view.

6. Select the topic or publication, and choose File→Duplicate to create a new topic or publication.
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11. Copying content
Copy a topic

You can copy a topic in several ways. Copying is a quick way to create new topics or reuse the same
topics in different locations.

You can copy a topic with or without its related topics in either the Home component view or the
Publication Structure view. You can also copy topics into content in an editing tool, by either creating a
new copy of a topic or by creating a reference to a source topic.

The location you are copying the topic to must be valid for the schema.

Do one of the following to copy a topic:

To copy this way Do this

Copy a topic or topic revision and its related
topics, and paste it either in a folder in the
Home component view or in a structure in the
Publication Structure view, creating another
instance of the same topic and the same
related topics.

Note:

When you paste a topic item, not a topic
revision, in the Publication Structure
view, the most current revision of the
topic is used.

1. Right-click the topic, and choose Copy.

2. Right-click the location where you want to insert
the topic and choose Paste.

Note:

If more than one reference type is defined in
your system for the object type, the Reference
Topic Type Selection dialog box appears.
Select the reference type, and click Finish.

Copy the content of a topic and any related
topics from the Publication Structure view
into another topic in an editing tool, creating
new content without a reference(s) to the
source topic(s).

1. In the Publication Structure view, right-click the
topic, and choose Copy For Editor→Composed
Content as Clone.

2. Click in a valid location in the content in the
editing tool, and choose Paste.

Copy a topic and any related topics from the
Publication Structure view into another topic
in an editing tool, creating a reference(s) to
the source topic(s).

1. In the Publication Structure view, right-click the
topic, and choose Copy For Editor→Composed
Content as Reference.

2. Click in a valid location in the content in the
editing tool, and choose Paste.
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To copy this way Do this

Note:

You create the same result by dragging the
topic into the Publication Structure view from
another view.

Duplicate an existing publication or topic
structure to create a new structure. You
can create the new structure with new
objects, references to existing objects, or a
combination of both.

1. In the Publication Structure view, right-click the
structure, and choose File→Duplicate.

2. Use the Duplicate dialog box to select the
options for the new structure.

3. Click OK.

Duplicate a publication or topic structure

Duplicate an existing publication or topic structure to create a new structure based on all or portions of
the existing structure. You can create the new structure with new objects, references to existing objects,
or a combination of both. You can duplicate an entire publication structure or a structure of topics and
subtopics within a publication.

Note:

This feature cannot be used for S1000D structures.

When you duplicate a structure that contains a topic with a reference to another topic, the reference is
preserved between the new topics when both target and source topics are duplicated.

Example:

If you duplicate the 000132/B;1-headlamp_parts structure and its two topics, and the 000133/
A;1-overview topic contains a link to the 000135/A;1-lightbulb topic, in the new structure 000160/
A;1-headlamp_parts, the 000161/A;1-overview topic will contain a link to 000162/A;1-lightbulb.
However, if you choose to duplicate 000132 and 000135, but not 000133, the link in 000133 will
continue to point to 000135 and not 000162, so the 000133 topic may need to be modified to
work correctly where it exists.

11. Copying content
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1. Open the publication or topic structure in the Publication Structure view.

2. Select the top line of the structure, and choose File→Duplicate.

3. In the Duplicate dialog box, select or clear the check box for each line to select the contents of the
new structure:

• If an item is selected, the item is copied to create a new object in the new structure.

• If an item is not selected, a reference to the original object is created in the new structure.

Tip:

To select all objects in the structure, select the Duplicate all items check box.

4. Choose one of the following methods to assign IDs to the duplicated items that are included in the
new structure:

• Automatically assign new IDs to all items.

Do nothing in the New Item ID by Selection and Default ID Mapping sections.

• Assign new IDs by selecting the items you want to assign them to.

a. Use the Ctrl key and click to select the items in the structure to which you want to assign
IDs.

Duplicate a publication or topic structure
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b. In the New Item ID by Selection section, either select Assign New IDs to automatically
assign IDs, or enter one or more of the following:

Prefix Adds a prefix to the original ID of each duplicated item, for example,
new_.

Suffix Adds a suffix after the original ID of each duplicated item, for example
_A1.

Replace

With

Replaces a specified substring in the original ID with another defined
string in the duplicated ID. For example, you could replace template
with new.

c. Click Apply.

• Assign new IDs by using the Default check boxes in the structure.

a. Select the Default check box for each item in the structure to which you want to assign IDs.

b. In the Default ID Mapping section, either select Assign New IDs to automatically assign
IDs, or enter one or more of the following:

Prefix Adds a prefix to the original ID of each duplicated item, for example,
new_.

Suffix Adds a suffix after the original ID of each duplicated item, for example
_A1.

Replace

With

Replaces a specified substring in the original ID with another defined
string in the duplicated ID. For example, you could replace template
with new.

c. Click Apply.
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5. Assign items to projects as desired.

6. Click OK.

Duplicate a publication or topic structure
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12. Create a new revision of a topic
When you want to save a topic as it is and also work on a new version of the topic, you create a
new revision of the topic using the Revise menu command and dialog box. The new revision has an
incremented revision number.

• To create a revision for one topic:

1. Select the topic revision and choose File→Revise.

2. Use the Revise dialog box to further define the new topic revision.

• To create revisions for multiple topics:

1. Use the Ctrl key to select the topics and then choose File→Revise.

2. Use the Multiple Object Revise dialog box to edit the names of the new topic revisions.

Note:

To enable the ability to edit names of new topic revisions using the Multiple Object Revise
dialog box, the Multiple_revise_dialog_visible preference must be set to true. If this
preference is set to false, you may still revise multiple topics, but you cannot edit the
names.
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13. Working with a publication structure
Working in the Publication Structure view

Use the Publication Structure view to create and maintain the contents of publications.

From the Publication Structure view, you can:

• Add and move topics to build the structures of publications

• Remove topics from publications

• Open publications and topics for editing

• Publish publications and topics

Add publications to the Publication Structure view

• Add topics, topic structures, and publications to the Publication Structure view using one of the
following methods:

Note:

If you select a topic or publication item, not a topic or publication revision, the most current
revision is selected.

• In the Home component view, double-click the publication or topic.

• Use the Show In Publication Structure command.

■ Right-click the publication or topic in the Home component view, Impact Analysis view, or
Search Results view, and choose Show In Publication Structure.

• Click the Open Topic by ID button.

1. In the Publication Structure view, click Open Topic By ID .

2. In the ID box, type a string to find the ID of the publication or topic in the structure.

3. Click Find .

4. Double-click the topic or publication in the result list.

• Click the Most Recently Used (MRU) button.
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This button opens any of the last four publication structures you opened. This list is saved across
sessions.

1. In the Publication Structure view, click Most Recently Used (MRU) .

2. Click the topic or publication you want to open.

• Click a link.

■ Click a link in the Open Items, History, or Favorites sections of the navigation pane.

Add and move topics to build publications

Caution:

Do not attempt to modify the Occurrence Type assigned to topics. This may cause content
processing functions to fail.

Note:

When you add and move some DITA topics to another topic or map, you must select the
reference topic type.

• Add and move topics in the following ways:

• In the Publication Structure view, drag topics within publications.

Note:

When you move a topic to a new location in a publication, the location must be valid for the
type of topic you are moving and the defined schema. If a location you point to is not valid, a
message appears.

• In the Publication Structure view, drag topics and create specific relationship types:

Note:

Depending on the topic types you are working with and how they are configured in your
system, this method may not be available.

1. Select the topic you want to relate to another topic, and begin dragging it.

2. Press and hold Ctrl+Shift.

3. When the topic is over the topic you want to relate it to, release the mouse button, and then
release Ctrl+Shift.

13. Working with a publication structure
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4. In the Relation Selection dialog box, from the Relation Selection list box, select the relation
type.

5. If you want the selected relation type to be the default in this dialog box for future relation
selections, select Save selection to preferences.

6. Click Finish.

• Drag topics from the Home component view to publications in the Publication Structure view.

Note:

If you select a topic item, not a topic revision, the most current revision is moved.

• Cut and paste objects using Teamcenter functionality.

• Add or edit the XML elements in the publication when it is open in an editing tool.

Remove a topic from a publication in the Publication Structure view

When you remove a topic from a publication, its child topics are also removed.

1. In the Publication Structure view, right-click the topic you want to remove, and choose Remove.

2. In the Remove dialog box, click Yes.

Remove a topic from a publication in the Publication Structure view
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14. Working with topic relationships
Types of topic relationships

When you create the structure of a publication and place topics within other topics, parent and child
topics are related. You can relate a topic to many parent topics, creating multiple instances of the same
topic. Whenever the topic is modified at one location, the modifications are reflected in all locations
where the topic is referenced.

Relationships between topics are created when topics are created or moved in the Publication
Structure view. The following two types of relationships exist between topics in Content Management.
However, depending on the reference types created by your administrator and the topic types you are
working with, you may have only one of these types in your system.

• Topic-to-topic relation

When a topic-to-topic relation appears in the editing tool, you see all the content of the related topic.
Also, when a topic is published with a topic-to-topic relation to another topic, the published topic
includes all the content of the related topic. The Occurrence Type in the Publication Structure view
appears as DC_TopicTopicR for this relation type.

Note:

This relationship type is also created when topics are copied using the Copy For
Editor→Composed Content as Reference function in the Teamcenter client and then pasted in
the editing tool.

• Composable reference

When a composable reference appears in the editing tool, you see only a reference to the topic.
However, when a topic is published with a composable reference to another topic, the published topic
includes all the content of the referenced topic. The Occurrence Type in the Publication Structure
view appears as DC_ComposableReferenceR for this relation type.

Viewing related objects

Ways to view related Content Management objects

Objects are related to other objects for different purposes. For example, parent and child topics are
related, and topics have related graphics, documents, and translations. You can view related objects in
these ways:

• View related topics in the Publication Structure view. This is a specialized view of Content
Management objects and their relationships to other Content Management objects.
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• View all related objects in the Relation Browser view. This view graphically displays objects and
their related items. It is available for multiple Teamcenter applications.

• View all related objects in the Impact Analysis view. This view graphically displays objects and their
related items and can be used to perform where-referenced analyses. For example, it can be used to
understand the impact of change. It is available for multiple Teamcenter applications.

View related topics in the Publication Structure view

1. In the Home component view, right-click the topic or publication, or the specific revision, and
choose Show In Publication Structure.

Note:

If you select a topic or publication item, not a topic or publication revision, the most current
revision is selected.

2. In the Publication Structure view, right-click a topic and choose one of the following expand
options:

• Expand

Displays one level below the topic you selected.

• Expand Below

Displays all levels below the topic you selected.

• Expand Below...

Displays a dialog box for you to select the number of levels you want to display.

• Collapse Below

Hides all the levels below the topic you selected.

View related objects in the Relation Browser

• Right-click the object you want to view in the Relation Browser and choose Send To→Relation
Browser.

View related objects in the Impact Analysis view

• Select the object you want to view, and click the Impact Analysis tab.
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Validate content references

When you import content that references another object, such as a topic that references another topic,
and the referenced object does not exist in Content Management, then the reference is unresolved. If
you later import the referenced content, you can resolve the broken reference between the two objects.

The reference validation tool checks content for any broken references in Base, DITA, and S1000D
content and creates references between topics that are imported or created at different times. You can
validate references on a selected object or on a selected structure for all topics in the structure.

• Select the object revision and choose Tools→Reference Validation.

State of the content references Result

No unresolved references are found or resolved. The Reference Validation Successful message
box appears.

Unresolved references are found, and Content
Management resolves all the references between
all objects.

The references are created and you can see
the objects related to one another in Content
Management.

Unresolved references are found, and Content
Management cannot resolve one or more of the
references.

The Reference Validation message box appears
listing the content references that cannot be
resolved.

Validate content references
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15. Editing content
Using an editing tool to edit content

The XML or SGML content of topics, including S1000D and DITA objects, is created and edited in
an editing tool. You can also create a new topic within an existing topic by using an editing tool.
Examples of editing tools compatible with Content Management include: XMetaL Author, FrameMaker,
and XMLSpy. The editing tool that is launched when you open a topic, structure of topics, or publication
depends on the tool selected in the Edit preferences.

When the content opens with the editing tool, it is saved in a local folder. Your editing tool can be
disconnected from Teamcenter and your work with the content performed offline. While the editing
tool is disconnected from Teamcenter, functions such as Teamcenter CMS→Save and Close are not
available. To save edited and newly created topics to the database, the editing tool must be connected
to Teamcenter. Editing tools are connected to Teamcenter when they are launched from the Teamcenter
rich client. The local folder is typically:

C:\Documents and Settings\user name\Teamcenter\contmgmt\version number\edit\editing tool

Note:

Editing tools are supported only on Windows clients.

Create and edit content in an editing tool

You edit the content of topics in an editing tool. You can also create new topics by adding the valid
XML elements to topics that are open in an editing tool. When you save and check in edited content,
new topics are created in Content Management with the appropriate relationships to the publication
structure you are working in.

Note:

If you save a topic with a graphic that does not exist in Teamcenter, a warning message appears
indicating the graphic cannot be found. The next time you edit the topic the graphic name in the
XML is appended with .error.

The Teamcenter CMS menu is not available in all editing tools.

1. In the Publication Structure view, do one of the following:

• Edit a topic:

a. Right-click the topic, and choose Edit→Edit Topic.

b. In the Check-Out dialog box, click Yes.
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• Edit a topic without downloading referenced topics:

Tip:

For topics with many references, this saves time.

a. Right-click the topic, and choose Edit→Edit Topic Without Referenced Topics.

b. In the Check-Out dialog box, click Yes.

• Edit a structure of topics:

a. Right-click the parent topic, and choose Check-out Structure.

b. In the Check-Out dialog box, click Yes.

c. Right-click the main topic you are working with, and choose Edit→Edit Topic.

The content opens with the editing tool and is saved in a local folder. In the Publication Structure
view, the topics you check out appear as checked out , and the topic you choose to edit appears
in edit mode . The Teamcenter CMS menu appears in the editing tool's menu bar.

2. In the editing tool, edit the content and create new topics as necessary, as the schema structure
allows.

3. When you are done editing the content and creating new topics within the topic, do one of the
following:

Note:

If you try to save and close a topic that references another topic that was removed,
Teamcenter displays a message warning you that you cannot save the topic.

To do this Do the following For this result

Save your
changes without
closing the file.

Use the editing tool's
options for saving files.

The file you are editing is updated on your
local drive, the file remains unchanged in the
database, and the content version of edited
topics is not changed.

Save your
changes and
close the file.

Do one of the following:

• In the editing tool, choose
Teamcenter CMS→Save
and Close.

The editing tool closes the file, the edited file
is updated in the database, and its content
version increases. Any new topics are created,
the relationships between topics are created,
and the new topics appear in the Publication
Structure view.

15. Editing content
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To do this Do the following For this result

• Use the editing tool's
options for saving files,
and then in the
Publication Structure
view, right-click the topic,
and choose Edit→Save
And Close Edit.

Save your
changes, close
the file, and
maintain the
translations.

Do one of the following:

• In the editing tool, choose
Teamcenter CMS→Save
with same Translation
and Close.

• Use the editing tool's
options for saving files,
and then in the
Publication Structure
view, right-click the topic,
and choose Edit→Save
With Same Translation
and Close Edit.

The editing tool closes the file and the edited
file is updated in the database, but the content
version of edited topics does not increase. This
is useful when a topic has a related translated
topic and you want the versions of the two
to remain synchronized. Any new topics are
created, the relationships between topics are
created, and the new topics appear in the
Publication Structure view.

Close the file
without saving
your changes.

Do one of the following:

• Choose Teamcenter
CMS→Close.

• In the Publication
Structure view, choose
Edit→Cancel Edit.

The editing tool closes the file, the file remains
unchanged in the database, and the content
version of edited topics is not changed.

4. In the Publication Structure view, right-click the topmost topic, and choose Edit→Check-in
Structure.

Set editing tool preferences

Use the Edit preferences to select the editing tool you use to edit content. Before you can set these
preferences, your editing tool must be installed, and your application administrator must set up the tools
for editing content.

These preferences apply to only your user account on your client computer. They do not affect other
users' client computers or your user account on other computers. These preferences do not affect other
Teamcenter applications.

Set editing tool preferences
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Note:

• Editing tools are supported only on Windows clients.

• If the editing tool is not starting after you set these preferences, click Restart Tool Message
Server in the Preferences dialog box to assign a new port for the editing tool.

1. Choose Window→Preferences.

2. In the Preferences dialog box, expand Teamcenter, expand Content Management, and expand
and select Edit.

Tip:

Use the type filter text box to list preferences you are looking for by typing the name or part
of the name of the preference. Click  to clear the box.

3. From the Editor list, select the editing tool to start when you choose to edit a topic.

Note:

If the editing tool has been installed and set up by your application administrator but it does
not appear in the list, click Reload Tools, click OK to close the Preferences dialog box, and
then re-open the dialog box and begin again.

4. Select one of the following editing tools, which you are setting the preferences for:

• Other Editors

• Framemaker

• XMLSpy

• XMetal

5. In the Path box, if the path to the tool's start file is different on this client than the one defined for
the tool path in the editing tool object, type or browse to and select the path to the location of the
start file on this client. For example: C:\Program Files\XMetaL 9.0\Author.

6. Click Install to install on the client any required plug-in for the tool. Typically, this installation is
required only once per client.

15. Editing content
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Note:

This applies only to FrameMaker, XMLSpy, and XMetaL.

7. Click Apply.

8. Click OK to close the Preferences dialog box.

Teamcenter CMS menu options

When you work with content in one of the following editing tools, the Teamcenter CMS menu appears
on the toolbar.

• Altova XMLSpy

• Adobe Structured FrameMaker

• JustSystems XMetaL Author

The following describes the actions that can be performed from the Teamcenter CMS menu:

Tip:

If you are using XML Spy and the Teamcenter CMS menu does not appear on the toolbar, in Edit
preferences, for the XML Spy tool, click Uninstall and then click Install to reinstall the required
plug-in. Then in XML Spy, choose Tools→Customize→Toolbars, and then select Reset All.

Menu option Function

Close Closes the editing tool without saving changes. The topic
is no longer in edit mode in Content Management. The
edit icon no longer appears in front of the topic in the
Publication Structure view.

Save and Close Saves all changes and closes the editing tool. The content
version of edited topics is increased. The saved file is stored
in the database. The topic is no longer in edit mode in
Content Management. The edit icon no longer appears in
front of the topic in the Publication Structure view.

Save with same Translation and
Close

Functions like Save and Close, except that the content
version of edited topics is not increased, so its version
remains the same as the version of any related translated
topics.

Publish Saves all changes and displays the Publish dialog box for the
object.

Teamcenter CMS menu options
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16. Working with links between topics
Types of topic links

A navigation link is text within a published topic, which when clicked, accesses another topic or another
location within the same topic. You can insert two types of navigation links into a topic:

• Floating navigation link

A floating navigation link enables you to create a link to the most current version of a topic.

• Fixed navigation link

A fixed navigation link enables you to create a link to a specific version of a topic.

For both types of links, you can create a link to content below the topic level, for example, to a table
or figure within a topic. When you do this, you can create a link to another topic or to another location
within in the same topic.

Before you can use navigation links, your application administrator must enable this functionality.

Add a navigation link to a topic

1. In the Publication Structure view, right-click the topic you want to link to, choose Copy For Editor,
and then choose one of the following:

• Floating Navigation Link, to create link that always links to the most current version of the
selected topic.

Example:

At the time you create a link to a topic, the topic's version is A.1, and the link accesses
version A.1 of the topic. Later, when the topic's version increases to B.1, the link then
accesses version B.1 of the topic.

• Fixed Navigation Link, to create a link to the version of the topic it exists at now.

Example:

At the time you create a link to a topic, the topic's version is A.1, and the link accesses
version A.1 of the topic. Later, when the topic's version increases to B.1, the link still
accesses version A.1 of the topic.

2. Open the topic in which you want to insert the link, if it is not already open.
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3. In the editing tool, click in a valid location in the content, and choose Paste.

In Content Management, the link is related to the topic as a content reference, and the link appears
in the content. For example:

Floating navigation link:

<xref href="X000151.xml" linktyp="floating" version=
"CURRENT">Creating a topic</xref>

Fixed navigation link:

<xref href="X000151.xml" linktyp="fixed" version="B">Creating a 
topic</xref>

In the Publication Structure view, links appear in the structure with an Occurrence Type of Topic
Content Reference or Topic Cross Reference, depending on how your application administrator
set up navigation links.

Add a link to content within a topic

1. Open the topic that you want to create a link to, if it is not already open.

2. Go to the location in the topic that you want to create a link to, for example a title, table, or
paragraph tag, and add an ID value to the tag. The value must begin with a letter.

Example:

<title id="addrecord">Adding a record</title>

In this example, you use the ID that you are attaching to the title to create a link to this topic
that goes directly to this title.

3. In the Publication Structure view, right-click the topic you want to link to (the one you just added
the ID to), choose Copy For Editor, and then choose one of the following:

• Floating Navigation Link, to create link that always links to the most current version of the
selected topic.

Example:

At the time you create a link to a topic, the topic's version is A.1, and the link accesses
version A.1 of the topic. Later, when the topic's version increases to B.1, the link then
accesses version B.1 of the topic.
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• Fixed Navigation Link, to create a link to the version of the topic it exists at now.

Example:

At the time you create a link to a topic, the topic's version is A.1, and the link accesses
version A.1 of the topic. Later, when the topic's version increases to B.1, the link still
accesses version A.1 of the topic.

4. Open the topic in which you want to insert the link, if it is not already open.

5. In the editing tool, click in a valid location in the content, and choose Paste.

6. In the href value of the link, at the end of the XML number, add a forward slash and the ID you
created in step 2, which you are creating the link to.

Example:

<xref href="X000152.xml/addrecord" linktyp="floating" version=
"CURRENT">Adding a record</xref>

In Content Management, the link is related to the topic as a content reference.

In the Publication Structure view, links appear in the structure with an Occurrence Type of Topic
Content Reference or Topic Cross Reference, depending on how your application administrator
set up navigation links.

Add a link to content within a topic
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17. Importing and exporting documents
Prerequisites for importing documents

If you have existing XML or SGML content outside of the Content Management application, you can
import it to Content Management from a local or network drive.

Prerequisites for importing documents are as follows:

• All graphics referenced in the document must be imported to the database.

• The structure of the document must match the topic type structure (and its schemas) defined in the
application.

• The document must have the language attribute defined in order to relate it to other documents and
graphics. If the language attribute is not defined before you import a document, you can define the
language attribute after the import by modifying the document’s properties.

• (Optional) When the structure of the document is different from the topic type structure (and its
schemas) defined in Content Management, an XSLT stylesheet that converts the document(s) being
imported into a valid structure can be used. To use this stylesheet on import, it must exist in Content
Management.

• When you import a document with a DITA conref, the filename in the conref must be in the format
item_id.dita for topics and item_id.ditamap for maps.

Example:

conref="X000001.dita#X000001"

conref="X000001.dita#X000001/para1"

conref="X000124.ditamap"

conref="X000124.ditamap#topic1"

• To import SGML data for authoring in the S1000D solution, the Content Management S1000D
SGML Parser feature must be selected in Teamcenter Environment Manager (TEM) when you install
Teamcenter.
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Import a document

Note:

When importing, if your property values contain non-ASCII characters, you may get an error about
exceeding the allowed length even though your property value is within the length limit. This is
due to the fact that non-ASCII characters may take more storgae space depending on the encoding
used, for example, if you use the UTF-8 encoding, all ASCII characters are one byte but most
Japanese characters are three bytes.

Import existing XML or SGML content to work with it in the Content Management application. Imported
documents are placed in a folder according to how your user interface (UI) options are set.

1. Complete the prerequisites for importing documents.

2. Choose Tools→Import→Document.

3. In the Import Documents from File dialog box, do the following:

For this option Do this

From Directory Browse to and select the folder containing the document you
want to import.

File names a. (Optional) Select the Show all Files check box to show
the hidden files in the folder.

b. Select the check box for each document that you want
to import.

Tip:

Click Select All or Deselect All to select or
deselect all files listed.

Stylesheet If the content being imported must be transformed, either
because it is not valid for any existing topic type or because
data in the content must be changed, select a stylesheet to
use for the import. If this option is not available, then no
stylesheet of this type exists.

When the XML document being imported matches the
structure of a topic type and its related schema defined in
the system, select (No StyleSheet) because no part of the
document is to be transformed before import.

17. Importing and exporting documents
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For this option Do this

Graphic Attribute Mapping Select the appropriate graphic attribute mapping defined by
your application administrator.

Graphic Mode If the XML document contains references to graphics, select
one of the following options to indicate how the document
references the graphic names:

Note:

You must import the graphics to be referenced
before importing the document that refers to the
graphics. How these graphics are imported and named
determines which option you choose.

• Public ID

The public identifiers of the graphics are used in the XML
document to reference graphics.

• Import Original Name

The names of the graphics when imported are used in the
XML document to reference graphics.

• XML Number

The XML numbers of the graphics are used in the XML
document to reference graphics.

• Graphic Name

The names of the graphics with or without the file
extensions are used in the XML document to reference
graphics.

Reuse Existing Topic Select the following options to indicate how the import
searches for and handles topics already existing in the
database or if you want to use the ID or XML number of the
imported topic as its item ID in Teamcenter.

Note:

If none of these options are selected, all topics are
imported as new objects with new item IDs, regardless

Import a document

Content Management on Rich Client ─ Usage, Teamcenter 2412  17-3
© 2025 Siemens



For this option Do this

of whether topics with identical item IDs or content
already exist in the database.

• Find by XML Number

Select this option to search the database for a topic with
the same item ID as the ID or XML number of topics in
the document you are importing. If a topic is not found
with the same item ID, then the ID or XML number of
the topic is used as the item ID instead of being auto-
generated. Also, the imported file name is stored in the
topic’s Original Imported Name property.

If your documents use content references, you must select
this option to ensure content references are preserved
for Base Content Management and DITA documents, since
content references use item ID/XML numbers.

• Overwrite existing

If a topic exists in the database with the same item ID
as the ID or XML number of the topic being imported,
selecting this option causes the topic in the database to be
replaced with the one that is being imported.

If this option is not selected, a message appears indicating
that a topic with the same ID already exists in the
database.

Use this option to preserve content references, since
references use the item ID.

Note:

This option can be selected only when the Find by
XML Number option is selected.

• Find by Content

Select this option to search the database for topics with
the same content as that in any of the topics you are
importing. When a topic is found with the exact content,
(including tags and attribute values) as the one being
imported, the topic is not imported.
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For this option Do this

Topic content includes attributes, such as a revision. For
example, if you import a topic with the same ID and
choose Find by Content with a change in the revision
attribute in the topic content, Teamcenter creates a new
topic.

4. Click Finish.

Import a DITA map

Import a DITA map to bring the map into the Content Management application. When you import a DITA
map, the DITA topics it references are also imported. Imported objects are placed in a folder according to
how your user interface (UI) options are set in the rich client.

Note:

When importing, if your property values contain non-ASCII characters, you may get an error about
exceeding the allowed length even though your property value is within the length limit. This is
due to the fact that non-ASCII characters may take more storgae space depending on the encoding
used, for example, if you use the UTF-8 encoding, all ASCII characters are one byte but most
Japanese characters are three bytes.

When you import a document with a DITA conref, the filename in the conref must be in the format
item_id.dita for topics and item_id.ditamap for maps.

Example:

conref="X000001.dita#X000001"

conref="X000001.dita#X000001/para1"

conref="X000124.ditamap"

conref="X000124.ditamap#topic1"

1. Choose Tools→Import→DITA Map.

2. In the Import DITA Map from File dialog box, do the following:

Import a DITA map
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For this option Do this

From Directory Browse to and select the folder containing the maps you
want to import.

File names a. (Optional) Select the Show all Files check box to show
the hidden files in the folder.

b. Select the check box for each document that you want
to import.

Tip:

Click Select All or Deselect All to select or
deselect all files listed.

Stylesheet If the map being imported must be transformed, either
because it is not valid for any existing topic type or because
data in the content must be changed, select a stylesheet to
use for the import. If this option is not available, it indicates
that stylesheet of this type does not exist.

When the XML document being imported matches the
structure of a topic type and its related schema defined in
the system, select (No StyleSheet) because no part of the
document must be transformed before import.

Graphic Attribute Mapping Select the appropriate graphic attribute mapping defined by
your application administrator.

Graphic Mode If the content being imported contains references to
graphics, select one of the following options to indicate how
the content references the graphic names:

Note:

You must import the graphics to be referenced before
importing the document that refers to the graphics.

• Public ID

The public identifiers of the graphics are used in the
content to reference graphics.

• Import Original Name

The names of the graphics when imported are used in the
content to reference graphics.

17. Importing and exporting documents
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For this option Do this

• XML Number

The XML numbers of the graphics are used in the content
reference graphics.

• Graphic Name

The names of the graphics with or without the file
extensions are used in the content to reference graphics.

Reuse Existing Topic Select the following options to indicate how the import
searches for and handles topics already existing in the
database, or if you want to use the ID or XML number of
the imported topic as its item ID in Teamcenter.

Note:

If none of these options are selected, all topics are
imported as new objects with new item IDs, regardless
of whether topics with identical item IDs or content
already exists in the database.

• Find by XML Number

Select this option to search the database for a topic with
the same item ID as the ID or XML number of topics in the
document you are importing. If a topic is not found with
the same item ID, then the ID or XML number of the topic
is used as the item ID instead of being autogenerated.

• Overwrite existing

If a topic exists in the database with the same item ID
as the ID or XML number of the topic being imported,
selecting this option causes the topic in the database to be
replaced with the one that is being imported.

If this option is not selected, a message appears indicating
that a topic with the same ID already exists in the
database.

Use this option to preserve content references as
references use the item ID.

Import a DITA map
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For this option Do this

Note:

This option can be selected only when the Find by
XML Number option is selected.

• Find by Content

Select this option to search the database for topics with
the same content as any of the topics you are importing.
When a topic is found with the exact content (including
tags and attribute values) as the one being imported, the
topic is not imported.

3. Click Finish.

Export a topic or publication

Export an XML or SGML document to transfer it from one Content Management system to another or to
work with it in another application. When you export a document, it is saved in a .zip file.

1. Select the topic or publication you want to export, and choose Tools→Export→Document.

2. In the Export Composition dialog box, do the following:

For this option Do this

Language Select the language you want to use for the exported
content.

Graphic Mode Select one of the following to indicate how the content
references the graphic names:

Note:

• The way you export graphics impacts whether the
references to graphics can be resolved when the
exported content is imported into another system.

• To include graphics in the export, select either
Public ID or Import Original Name. If you select
XML Number or Graphic Name, graphics are not
exported.

17. Importing and exporting documents

17-8  Content Management on Rich Client ─ Usage, Teamcenter 2412
© 2025 Siemens



For this option Do this

• These characters are invalid in the public ID or
original import name of graphics: /|~`’,;:\"*?
<>. When you export a topic containing graphics
with these characters, they are converted to an
underscore ( _ ).

• Public ID

The public identifiers of the graphics are used in the
content to reference the graphics.

• Import Original Name

The original names of the graphics are used in the
content to reference the graphics. These are the file names
of the graphics before they are imported into Content
Management.

• XML Number

The XML numbers of the graphics are used in the content
to reference the graphics.

• Graphic Name

The names of the graphics are used in the content to
reference the graphics. The graphic name is the name of
the imported file without the file suffix. This option can be
used when you want to import the publication or topic
including graphics into another Content Management
environment.

Graphic Priority (For graphic
modes Public ID or Import
Original Name only)

Select the graphic priority to determine in what order the
topic's graphic options are selected for the output, based on
the graphic usages set on the graphic option.

Note:

Graphic usages are set when a graphic is imported.

Transform Policy If you would like to apply an XML transformation policy to the
content you are exporting, select it from the list.

A transformation policy can be used to modify content
when it is published or exported. For example, it could
convert units of measure, such as US standard to metric.

Export a topic or publication
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For this option Do this

Your administrator must create a transform policy before it is
available for you to use from this dialog box.

Content Select any of the following to choose the contents of the .zip
file:

• Include Main Content

Includes the XML files for the topic content.

• Include Supporting Data

Includes the schemas for the exported topics.

• Include Graphics Data

Includes the graphics embedded in the exported topics.

References Select any of the following to choose the content to include
in the export:

• Include Content References

Includes topics that are referenced by the topic or
publication you are exporting.

• Include Compose References

Includes topics that are referenced by composable
reference relations. Composable topic references are
created by relating topics in the Teamcenter client. This
reference type is typically used to enable the creation of
DITA dynamic maps and S1000D data dispatch notes, data
module lists, and publication modules.

3. Click Finish.

4. In the Save As dialog box, select the folder in which to save the exported content.

17. Importing and exporting documents
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18. Publishing and previewing content
Overview of publishing and previewing content

When you publish a topic or publication, Content Management renders it to the selected output format,
based on the stylesheets and applications you have available. This may be HTML, XHTML, PDF, or a
proprietary format.

To view content in the Preview view, you publish it using the InternalViewer tool. You may also
view topics with viewing tools installed on the client and set up in Content Management by the
application administrator. These are useful when a quick or remote preview session is needed, without
the processing time required to generate a PDF document.

You can set Publish Content preferences to specify the default publishing tool, style type, and
language displayed in the Publish dialog box when you select a topic to be published.

When you publish content through a publishing server, you can use the Dispatcher request
administration console to monitor the publishing progress.

Before you publish a topic or publication, you can view the estimated file size.

Set publishing preferences

Use the Publish Content preferences to set window preferences for how items are published.

These preferences apply to only your user account on your client computer. They do not affect other
users' client computers or your user account on other computers. These preferences do not affect other
Teamcenter applications.

1. Choose Window→Preferences.

2. In the Preferences dialog box, expand Teamcenter, and then expand Content Management.

3. Click Publish Content.

4. From the Default Publish Tool list, select the default publishing tool displayed in the Publish
dialog box when you select a topic to be published.

5. From the Default Style Type list, select the default style type displayed in the Publish dialog box
when you select a topic to be published.

6. From the Default Language list, select the default language displayed in the Publish dialog box
when you select a topic to be published.
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7. Click Apply.

8. Click OK to close the Preferences dialog box.

Publish and preview output

1. Do one of the following:

• In Teamcenter right-click the topic, publication, or map revision, and choose either Publish
Content or Tools→Publish Content.

• With the topic, publication, or map revision open in an editing tool, choose Teamcenter
CMS→Publish.

2. In the Publish dialog box, do the following:

For this option Do this

Tool Select the publishing tool for the type of output you are generating.
The available tools depend on the tools that have been installed
on your computer and set up in the system by your application
administrator.

StyleType Select the style type (collection of stylesheets) to be used to
publish the content. The style types are set up by your application
administrator.

Language Select the language in which to publish the resulting output.

Note:

If the translation of the selected language does not exist,
Content Management publishes the content in the master
language. Or, if a Fallback Language is defined and a
translation is available, the content is published in that
language.

Compose Version
Selection

Select the version of the content to be published.

Note:

This option is not available when you publish from the
Publication Structure view, as the content is published with
the revision rule in effect for the view. However, you can
apply a different revision rule in the view.

18. Publishing and previewing content
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For this option Do this

Translation Version
Selection

Select the translated version of the content to be published when a
language other than the master language is selected:

• Match Topic

If the latest content version in the master language is the same
as the latest content version of the translation, the translation is
selected for publishing. Otherwise the master language is used.

• Latest Received

The latest received translation in the selected language is
selected for publishing regardless of the content version in
the master language. However, if no translation exists for the
selected language, the master language is used.

• Received

The latest received translation in the selected language with a
content version older than or equal to the master language
version is selected for publishing. If all translation content
versions are newer, or if no translation exists for the selected
language, the master language is used. This option is typically
used when you publish an older version of the content and you
do not want to include translations that have newer content.

Resulting File Folder Browse to and select the folder in which the published document
will be stored. This path is saved and is displayed the next time the
Publish dialog box appears.

This option is available only for client-side publishing tools other
than InternalViewer.

Resulting File Name Type the name of the file (without a suffix). By default, the XML
number of the topic, document, or map is used.

This option is available only for client-side publishing tools other
than InternalViewer.

Register Result (Not
available with all tools)

If you want to create a composed or reviewer document, select the
type:

• Composed Document

A composed document that has completed the review process.

• Reviewer Document

Publish and preview output
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For this option Do this

A composed document that must be submitted to a workflow for
review.

Transform Policy If you would like to apply an XML transformation policy to the
content you are publishing, select it from the list.

A transformation policy can be used to modify content when it
is published or exported. For example, it could convert units of
measure, such as US standard to metric.

Schema Validation Select how publication should be done based on the schema
validation results. You can select from the following options:

• Publish with validation errors

• Do not publish on validation errors

• Publish without validation

Note that the schema validation options that you see may differ
depending on how your administrator has configured it.

DITA Value Filter Topics in
the Map

To use author-defined DITA value filters:

a. Click Find DITAVALs.

b. Select the filters to apply to the map.

DITA Value Filters To use DITA value filters defined by your administrator, select the
filters to apply to the map.

Publish to File System
Note:

This option appears only if your application administer has
enabled publishing to a file system.

Select the check box to publish the output to a folder on your
network. If you do not know the location of the publish folder,
contact your application administrator.

Note:

If you select this option, you must also select Register Result.

View Select the check box to display the output in the Preview view.

18. Publishing and previewing content
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For this option Do this

This option is not available for all tools and output types. The check
box is selected automatically when you use a tool that displays
output in the Preview view.

3. To display the estimated size of the published file before you publish it, click Estimate Size.

The size is estimated from the XML and any included graphics file sizes. This can be different from
the final output size since different file formats have different compression schemes.

4. Click Finish.

Preview content in XML or SGML

You can view the XML or SGML markup of a topic or publication without opening it in an editing tool.

• In the Home component view, right-click the topic or publication and choose Show Content.

The content’s XML or SGML appears in the Preview view.

Preview content in XML or SGML

Content Management on Rich Client ─ Usage, Teamcenter 2412  18-5
© 2025 Siemens



Understanding publishing results

Note:

When you publish content through a publishing server, you can use the Dispatcher request
administration console to monitor the publishing progress.

Content published to the Preview view

When you publish content using the InternalViewer tool, it appears in the Preview view.

Content in composed and reviewer documents

You can create a composed or reviewer document when you publish content. The composed
document revision or reviewer document revision is related to the topic you selected for publishing,
and the dataset (.zip file) created by the process is related to the composed or reviewer document
revision. For certain types of output, such as PDF, the output file is also related to the composed or
reviewer document revision as a dataset. The owner of the output file is the same as the owner of the
document revision. You may need to refresh the file structure after publishing to see the composed or
reviewer document related to the publication or topic.

When you publish the same content multiple times, newer composed or reviewer documents overwrite
existing ones if you select the same options when you publish. However, if you publish content with
one or more different options selected in the Publish dialog box, an additional composed or reviewer
document revision is created and related to the topic or publication you selected for publishing. These
options include: Language, Compose Version Selection, Style Type, DITA Filter Value, and Transform
Policy.

Additional composed or reviewer documents are also created each time you publish content with
different variants.

Content published to a file system

You can publish output to a file system if your application administrator has configured your system to
support that. Each time you publish the same revision of a topic or publication, the output file replaces
the one stored in the system folder. However, if you revise content that you published to the file system,
and then publish it again, the system creates a folder for the newly revised files. The folder structure
contains folders for: the content type of the renditions (such as HTML or PDF), the item ID of the topic
or publication, the language, and a subfolder for each revision published. The first time you publish the
topic or publication it is saved in folder A. After you revise and publish it again, it is saved in folder B, and
so on. The most recent revision of the published content is also saved in a folder named CURRENT. The
folder names do not necessarily correspond to revision levels of the content they contain.

18. Publishing and previewing content
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Note:

To publish output to a file system, your application administer must configure your system to
enable publishing to a file system.

Example:

Understanding publishing results
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19. Using variants for publications
The process for using variants in Content Management

Variants allow you to create publications that include topics based on the variant configuration you set
on the publication and the variant conditions you set on the items in the publication. For example,
you can create a car owner manual for various trim levels, S (standard), LX (luxury sedan), and LE
(limited edition), and include topics for the features included with the trim levels, such as power seats,
navigation system, and sunroof. When you publish the publication, the resulting composed document in
the Home component view indicates the variants that were selected when it was published.

Variants in Content Management work for publications in a similar way as they do for product structures
in Structure Manager. In fact, in Content Management you can use options that are defined in Structure
Manager.

Although Teamcenter provides you with two methods to create variants, modular or classic, only classic
variants are supported in Content Management. To ensure that the variant mode always opens in the
classic mode, set the PSEVariantsMode preference to legacy.

To configure variants for publications, you follow this process:

1. Create or find options to use for the configuration of the publication.

2. Add variant conditions to topics in the publication.

3. Set variant rules for the different variations of the publication structure.

Create variant options for publications

The first step in configuring variants for a publication is creating the options for the publication structure.

Example:

You are creating a publication for a car owner manual. The car is manufactured with the following
trim levels:

• S (standard), which includes a 2.0 L engine, manual transmission, cloth seats, and 4-speaker
sound system.

• LS (luxury sedan), which includes a 2.4 L engine, automatic or manual transmission, cloth or
leather seats, and 6-speaker sound system.
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• LE (limited edition), which includes a 2.4 L engine, automatic transmission, leather seats, and a
premium sound system.

Instead of creating new options, you could choose options created in the product structure in Structure
Manager. The Structure Management on Rich Client ─ Usage provides an example of a product
structure from which you could choose options.

Options have a string type or a numeric type and a name. The type of option you can create depends on
the settings of the PSM_classic_variants_text_families and PSM_classic_variants_numeric_families
preferences.

Note:

Since Content Management supports only classic variants, ensure the PSEVariantsMode
preference is set to legacy.

1. Open the publication in the Publication Structure view.

2. Choose View→Show/Hide Data Panel or click Show/Hide Data Panel .

3. In the data pane, click the Variants tab and select the line representing the owning publication or
topic revision to store the variant data. Typically this is the top-level item in the structure, in this
example, a publication for the car owner manual. You can also create variants at different levels of
the publication structure, as you might in the product structure.

4. Click the Options branch in the variant data tree.

5. In the Option dialog box, enter the necessary options, for example:

a. In the Name box, type trim level.

b. Optionally, enter the information about the trim level option in the Description box.

c. In the Value box, type an allowed value (LE) and press Enter or + (plus).

The value appears in the list of allowed values.

d. Enter the other allowed values, typing each and then pressing Enter for each one (S, LS).

6. Click Create  to create the option. A + (plus) symbol appears against the Options branch in the
variant data tree indicating that Teamcenter created the options.

7. Repeat steps 5 and 6 to define other options on the publication, for example model year (2013,
2014, 2015).

19. Using variants for publications
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8. Click Save  to save the changes. If you forget to do this, Teamcenter prompts you when you
select another line in the publication.

True appears in the Has Classic Variant Data (HCVD) column for the publication line.

9. Repeat steps 3 through 8 to define options on other topics in the structure. For example, you could
create a section of the manual for the operation of a trailer towing package, and set options on the
section for the different types of towing packages.

Copying and modifying options

Create new options from existing options

When an option has values similar to those on an existing option, it may be quicker to create the new
option values from those of the existing option:

1. If necessary, choose View→Show/Hide Data Panel or click the Show/Hide Data Panel  button
on the toolbar.

Teamcenter opens the data pane.

2. Click the Variants tab and select the option to copy in the Options branch of the variant data tree.

Teamcenter displays the Option dialog box, prepopulated with the values and name of the original
option.

3. In the Option dialog box, type a new name for the option (duplicate names within an item are not
allowed) and modify the values as required.

4. Click Create  to create the new option.

5. Click Save  to save the changes.

Change option values

1. If necessary, choose View→Show/Hide Data Panel or click the Show/Hide Data Panel  button
on the toolbar.

Teamcenter opens the data pane.

2. Click the Variants tab and select the structure line with the item revision that owns (stores) the
option whose values you want to change. If you are unsure of the owning item, you can identify
this from the Variant Rule dialog box.

3. Expand the Options branch in the variant data tree.

Create new options from existing options
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4. Select the option whose values you want to change.

Teamcenter displays the allowed values in the Option dialog box.

5. In the Option dialog box, do one of the following:

• Enter another allowed value and press the Enter key.

• Select the value and click – (minus button) to remove an allowed value from an option.

6. Click Modify  and Teamcenter updates the contents of the selected option.

7. Click Save  to save the changes.

Note:

Any variant data that references removed option values can no longer be set as these values are
not available for selection. You typically create a new revision of the item if you need to preserve
the historic data.

You can set the PS_variant_value_protect preference to protect variant values from unauthorized
modifications.

If a value is obsolete but is still referenced by a variant rule, default, derived default, or variant
condition, it is represented by a <?> icon.

Rename an option

1. If necessary, choose View→Show/Hide Data Panel or click the Show/Hide Data Panel  button
on the toolbar.

Teamcenter opens the data pane.

2. Click the Variants tab and select the option to rename in the Options branch of the variant data
tree.

3. Type a new name and click Modify  to modify the option.

4. Click Save  to save the changes.

Note:

You cannot rename an option that is used in more than one revision of the item or in any
expression.

19. Using variants for publications
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Also, you cannot rename an option that is shared between sites in a Multi-Site Collaboration
environment.

Remove an option

To remove an option from its owning item revision:

1. If necessary, choose View→Show/Hide Data Panel or click the Show/Hide Data Panel  button
on the toolbar.

Teamcenter opens the data pane.

2. Click the Variants tab and select the option to remove in the Options branch of the variant data
tree.

3. Click Delete  in the Option dialog box.

Note:

You cannot remove an option that is used in any expression.

Deleting an option

When you delete (remove) an option, you remove it only from the item revision. When you remove the
option from the last item revision that owns it, you are (in effect) deleting the option.

• You cannot remove an option from an item revision to which you do not have write access.

• You cannot delete an option that is used in a variant condition. If you attempt to do this, Teamcenter
displays an error message that lists all the revisions that have occurrences with variant conditions
referencing that option.

Working with option defaults

Default options allow you to preset option values in the variant rule. The preset value may be:

• Fixed

A fixed default value is a value that you specify. For example, the option engine could have a default
value set to 2.0 L.

• Derived

Remove an option
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A derived default is a value that is set to a value that depends on a condition. For example, the option
seats could have a value set to leather if trim level = LX.

Defaults are owned by an item revision, like other variant data. Use the Variant Rule dialog box to
identify the item a default was set on and whether the default is fixed or derived.

You can identify if an item has variant data attached by viewing the HVD - Has Variant Data column in
the Publication Structure view.

You can override option values or reinstate them as necessary.

You specify fixed and specify derived option defaults for publications in a similar way as you do in
Structure Manager.

Add variant conditions to topics in the publication

After you define the options for the publication structure, you add variant conditions to the topics in
the publication. For example, if you have a topic for the operation of the manual transmission you can
assign a condition to the topic that will include it in the owner manuals for the cars with a manual
transmission.

You create variant conditions in the scope of a specific option. If you move the structure line out of the
scope of the option referenced in the variant condition, the variant condition is not retained.

1. Ensure you have displayed the Variant Formula column in the Publication Structure view.

2. Select the topic for which you want to create variant conditions.

3. Click Variant Condition , or double-click either the Variant Conditions or Variant Formula
property cells.

Teamcenter displays the Variant Condition dialog box. The upper part of the dialog box shows the
individual clauses that comprise a variant condition. You can use the buttons to move clauses up
or down, delete a clause, or bracket clauses. The lower part of the dialog box allows you to define
a clause, and you can use the following buttons to control how a clause is added to the list in the
upper area:

• Replace 

• Insert 

• Append 

• Clear 

19. Using variants for publications
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4. Click  next to the Option box, to view the available options, and click the option you want to
work with, for example, trim level. Only the options currently loaded in the Publication Structure
view are listed, because their owning item is loaded or they are used in a variant condition in the
structure.

The (Owning) Item box is automatically populated.

5. Use the following operators to construct a variant condition:

= Equal to
! = Not equal to
> Greater than
> = Greater than or equal to
< Less than
< = Less than or equal to

Note:

If you use >, > =, <, or < = operators, the values of the associated option must be numeric
and only decimal values are permitted.

Not (!) is higher than AND (&); AND (&) higher than OR (|). That is, A OR B AND A = A OR (B
AND A).

6. From the Value list, select the value for the option, for example, LS.

7. Click Append .

The clause is added to the list. It clears the Value box and shows the option's owning item.

8. To add to the list of clauses, click either AND or OR, and repeat the above steps to select another
option.

Teamcenter displays the second clause in the list in the upper part of the dialog box.

Teamcenter constructs a variant condition from the defined clauses joined by AND and OR
operators. When a configuration depends on more than one option, you can configure complex
variant conditions.

Note:

If you are only specifying one clause in a condition, you can set the AND switch or the OR
switch.

Add variant conditions to topics in the publication
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9. Click OK to create the variant condition on the occurrence.

Modifying variant conditions

Insert a clause before another clause

1. Specify the new clause.

2. Select the clause before which you want to insert the new clause.

3. Click Insert .

Teamcenter inserts the new clause above the selected clause.

Replace a clause

Replacing a clause can be very useful with large compound conditions containing many clauses because
this action does not change the order. Preserving clause order maintains the algebra and makes
scanning for occurrences with similar conditions easier.

1. Specify the replacement clause.

2. Select the clause to replaced in the list.

3. Click Replace .

Teamcenter replaces the original clause with the new one.

Copy a clause

1. Select the clause to copy and click Copy . You can also double-click the clause. This action
copies the option name, value, and operator setting to the boxes and sets the And / Or button in
the lower part of the dialog box.

2. Edit the value and/or operator, set the appropriate AND or OR button, and append the clause.

3. Select an existing clause and click Replace  to replace the existing clause. You can also click

Insert  to place the clause above the selected clause.

19. Using variants for publications
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Note:

You can use Copy in conjunction with Replace, as a convenient way to edit variant conditions.

Remove a clause

To remove a clause, select the clause and click Delete .

Move a clause

To change the position of a clause within a condition, select the clause and click Up  or Down .

You can move multiple clauses in a single operation by selecting a range of clauses before clicking the
appropriate arrow button.

Group a clause

You can change the grouping of clauses by adding and removing brackets, as follows:

Note:

Teamcenter supports multiple levels of grouping.

To add brackets around a range of clauses, select the range of clauses and click (…).

To remove brackets from around a range of clauses, select the range of clauses, including the lines that
contain both the opening and closing brackets, and click (…).

Remove a variant condition from an occurrence

1. Select the structure line representing the occurrence and click Edit Variant Condition  on the
toolbar.

Teamcenter displays the Variant Condition dialog box.

2. Select all of the clauses in the Variant Condition dialog box and click Delete  to remove all the
clauses.

3. Click OK to apply the change to the occurrence (that is, effectively remove the variant condition).

Remove a clause
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Setting variant rules on publications

Set a variant rule

After you create options and variant conditions, you can set a variant rule on a publication structure to
create a configuration of the publication based on the selected options.

1. Select the top level line in the publication in the Publication Structure view.

2. Click Variant Rule  or choose Tools→Variants→Configure Variants.

The Variant Rule dialog box appears. If the Configure dialog box appears instead, click .

3. Find the option you want to set (for example, trim level), and from the Value list, select the value
for the option (for example, LE).

The state of the option changes from Unset to Set by User.

4. Repeat step 3 to set additional options on the publication.

To see the variant rule applied to the publication as you select the options, click Apply.

5. When you are done setting the variant rule, click OK.

The variant rule is applied to the publication, and the topics are included or excluded based on the
rule.

Unset a variant rule

1. Select the top level line in the publication in the Publication Structure view.
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2. Click Variant Rule  or choose Tools→Variant Rule.

The Variant Rule dialog box appears. If the Configure dialog box appears instead, click .

3. Find the option you want to unset (for example, trim level), and from the Value list, select a blank
value.

The state of the option changes from Set by User to Unset.

4. Repeat step 3 to unset additional options on the publication.

To see the variant rule applied to the publication as you unset the options, click Apply.

5. When you are done working with the variant rule, click OK.

The variant rule is applied to the publication, and the topics are included or excluded based on the
rule.

Working with variant rule checks

Variant rule checks allow you to define combinations of option values that are not allowed. A variant
rule check consists of a condition (for example, trim level = LX AND transmission = manual) and an
error message (for example, Incompatible trim level and transmission). Teamcenter displays an error
message containing the condition and message if the rule check is triggered when you set values in the
variant rule.

Set variant rule check

1. Open the data pane by choosing View→Show/Hide Data Panel or clicking Show/Hide Data Panel
.

2. On the data pane, click the Variants tab.

Working with variant rule checks
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3. Select the line representing the owning publication or topic revision on which you want to set the
rule check.

4. Select the Rule Checks branch in the variant data tree.

Teamcenter displays the Rule Check dialog box.

5. In the Warning Text box, enter an error message, for example, Incompatible trim level and
transmission.

6. Define the relevant variant condition, for example, trim level = LX AND transmission = manual.

7. Click Create .

Teamcenter creates the rule check.

8. Expand the Rule Check branch and verify the new rule check is added below any that already
existed, for example:

ERROR Incompatible trim level and transmission IF trim level = LX 
AND transmission = manual

9. If you need to change the rule check, select it in the Rule Check branch of the variant data tree.
Teamcenter displays the Rule Check dialog box, allowing you to change any of the boxes.

10. Click Modify  to apply the changes.

11. Click Save  to save the changes.

A Y appears in the Has Variant Data (HVD) column of the properties table, if variant data was not
already created.

Modify a rule check

1. Select the rule check you want to change in the Rule Check branch of the variant data tree.

Teamcenter displays the Rule Check dialog box containing details of the rule check.

2. In the dialog box, change the appropriate boxes.

3. Click Modify  to apply the changes.

4. Click Save  to save the changes.
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Delete rule checks

1. Select the rule check to delete in the Rule Check branch of the variant data tree.

Teamcenter displays the Rule Check dialog box.

2. In the dialog box, click Delete  and the selected rule check disappears.

3. Click Save  to save the changes.

Show and hide unconfigured components

When you are working with the publication structure, you can choose to show all the topics in the
structure or hide the topics with variant conditions that are not configured for the current variant rule.

The ability to show or hide unconfigured components is determined by the setting of the
PSEShowUnconfigdVarPref preference.

1. With the publication in the Publication Structure view, show or hide all unconfigured components

by clicking Show Unconfigured Variants  or by choosing View→Show Unconfigured

Variants, to toggle between the two settings.

2. Use the VOC - Variant Occ. Config'd column to identify the configured components. This column
shows a Y if the component is configured, is blank if it is not configured, or ? if Teamcenter cannot
determine if it is configured. The ? indicator appears when a variant condition contains options that
are unset in the variant rule.

Delete rule checks
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20. Comparing topics
How topics are compared in Content Management

You can use a third-party comparing tool to view the differences between two topics. You can compare
different topics or two revisions of the same topic; however the topics you compare must be the same
topic type. If your comparing tool supports the merging of content, you can perform the merge in the
tool and then save the changes to the database.

When you compare two revisions of the same topic and open them at the same time, the latest revision
is selected as the left side topic, which means that it appears on the left side of the window in the
comparing tool. If you are merging content, the left side topic is the one that receives and stores the
merged content. When you open topics individually for comparing, the first topic you select is the left
side.

Compare two revisions of the same topic

When you use this method to compare two revisions of the same topic, the one with the latest revision is
selected as the left topic.

1. In the Home component view, hold the Shift key as you click each of the two topic revisions you
want to compare, so that they are both selected. Then right-click one of the topic revisions and
choose Compare/Merge→Launch Compare.

2. If you do not have the left side topic checked out, the Compare: Selection dialog box appears. Do
one of the following:

• If you will not be saving merged content, select Continue Compare.

• If you want the option to save merged content, select Cancel Compare, and then check out the
left side topic.

Depending on the how your comparing tool is set up, both topics may open in the comparing tool,
or a dialog box may appear so that you can select the files to open.

3. Use the comparing tool to view the differences in the topics and merge any differences if necessary
(if the tools supports merging of the contents).

4. If you merged the topics, save the changes in the comparing tool, and in Teamcenter, right-click the
topic that is checked out and choose Compare/Merge→Save Merged Result.

5. Check in the topic.

6. Close the comparing tool.
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Compare two different topics

Use this method to compare two different topics. You can also use this method to compare two revisions
of the same topic if you want to select which of the two revisions is opened as the left topic.

1. In the Home component view, right-click the topic revision of the first topic you want to compare,
and choose Compare/Merge→Select as Left Side to Compare.

2. If you do not have the topic checked out, the Compare: Selection dialog box appears. Do one of
the following:

• If you will not be saving merged content, select Continue Compare.

• If you want the option to save merged content, select Cancel Compare, and then check out the
left side topic.

Depending on the how your comparing tool is set up, the topic may open in the comparing tool, or
a dialog box may appear so that you can select the file to open.

3. Right-click the topic revision for the second topic in the comparison, and choose Compare/
Merge→Launch Compare.

4. Use the comparing tool to view the differences in the topics and merge any differences if necessary
(if the tools supports merging of the contents).

5. If you merged the topics, save the changes in the comparing tool, and then in Teamcenter, right-
click the topic that is checked out and choose Compare/Merge→Save Merged Result.

6. Check in the topic.

7. Close the comparing tool.
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21. Working with documents for review
Overview of composed and reviewer documents

Composed and reviewer documents contain all the contents of a topic, topic structure, or publication
you select to publish. You can use composed and reviewer documents to distribute content to subject
matter experts or other reviewers or to retain the published documents’ compiled XML for future use.
Composed and reviewer documents contain the same content; they are named differently so you can
choose an appropriate name for the business practice you are using it for.

You can use Teamcenter workflows for document reviews by using Workflow Designer and Workflow
Viewer.

The composed document revision or reviewer document revision is related to the topic or publication
you selected for publishing, and a dataset (.zip file) created by the process is related to the document
revision. The .zip file contains the XML file and all supporting files, such as schemas and stylesheets.
For certain types of output, such as PDF, the output file is also related to the composed or reviewer
document revision as a dataset.

When you publish the same content multiple times, newer composed or reviewer documents overwrite
existing ones if you select the same options when you publish. However, if you publish content with
one or more different options selected in the Publish dialog box, an additional composed or reviewer
document revision is created and related to the topic or publication you selected for publishing. These
options include: Language, Compose Version Selection, Style Type, DITA Filter Value, and Transform
Policy.

Additional composed or reviewer documents are also created each time you publish content with
different variants.

Example:

In this example the topic was published three times with different languages selected (am=US
English, and fr=French) or with different variants, which are shown under ConfigurationContext.
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Create a composed or reviewer document

To create a composed or reviewer document:

• Select the desired Register Result option when you publish content.

View a composed or reviewer document

If a topic has a composed or reviewer document, you can view it with a tool you have installed. You must
have markup capabilities enabled and the markup privilege.

• Select the document revision and choose File→View/MarkUp.

Exporting and importing composed documents

If a topic has a composed (or reviewer) document, it has a related .zip file that contains the XML file and
all supporting files.

You can export the .zip file and unzip and edit its contents outside of Teamcenter, and then import it
back to the system. You can import the content either as a composed document in a .zip file or as an
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XML document. When you import an XML document, the edited topic content replaces the content in
the system. When you import a .zip file, the topic content is not replaced.

Export a composed document

1. Right-click the composed or reviewer document you want to export, and choose Named
References.

2. In the Named References dialog box, select the .zip file for the document and click Download....

3. In the Downloading File dialog box, browse to and select the location where you want to save
the .zip file, and click Download.

4. Close the Named References dialog box.

Import a composed document as an XML document

Import the content of a composed document as an XML document if you made changes to the
composed document after you exported it and you want to import the changes to the appropriate
topics.

• Follow the steps to import a document, being sure to:

• Browse to and select the .xml file containing the composed document.

• Select the Find by XML Number option.

Import a composed document as a named reference

Import a composed document as a named reference if you do not want to import changes to the
content of the composed document’s components.

1. Right-click the composed or reviewer document you want to import, and choose Named
References.

2. In the Named References dialog box, select the .zip file for the document and click Upload....

Export a composed document

Content Management on Rich Client ─ Usage, Teamcenter 2412  21-3
© 2025 Siemens



3. In the Upload File dialog box, browse to and select the .zip file you want to import, and click
Upload.

4. Close the Named References dialog box.
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22. Using graphics in your content
Overview of graphics in Content Management

To use graphics that are created in graphic editing programs, you must import them to Content
Management. To edit an imported graphic, you must check it out and edit it in the graphic editing
program.

A graphic item is a top level graphic object that has one or more graphic files related to it. Graphic
objects related to the graphic item are called graphic options. Graphic options have related graphic files,
or images. You can import multiple graphic images for different uses. For example, you can import a
higher-resolution image, such as an .eps file, for publishing to PDF, and a smaller resolution image, such
as a .png file, for displaying the graphic in the XML edit tool during an editing session. Beginning in
Teamcenter 10.0, you can import JT files to use as graphic options in Content Management.

When you import a graphic option, you select the language to associate with it, which is imported as its
Language Reference property. If you choose more than one language, a graphic option is imported for
each language. You can also select Multilanguage for the Language option for a graphic that can be
used for any language translation.

Note:

• The naming convention used for graphics impacts whether you can resolve the graphic
references when you import XML content that contains those references. Your Content
Management administrator should provide guidelines for working with graphics to match the
configuration enabled in XML attribute mappings.

• The S1000D standard does not require you to associate a language with graphics, and the
sample S1000D graphic attribute mapping does not support multiple languages for graphics.

• DITA OT publishing tools support the following image formats, although .tif and .png formats
may not be supported for PDF output:

.jpg

.gif

.bmp

.tif

.eps

.svg
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.png

Set tagging preferences for graphics

Use the Graphic Link Clipboard preference to set the tagging to be used in the editing tool when
a graphic is copied and pasted from Content Management to the editing tool. When graphic options
are pasted into content and the content is saved to the database, the content is decomposed and the
graphic option is substituted with the graphic item, so that other graphic options can be used when the
content is subsequently composed.

This preference applies to only your user account on your client computer. It does not affect other
users' client computers or your user account on other computers. This preference does not affect other
Teamcenter applications.

1. Choose Window→Preferences.

2. In the Preferences dialog box, expand Teamcenter, and then expand Content Management.

3. Click Graphic Link Clipboard.

4. From the list box, select the option for the publication standard you are using:
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Note:

If a new option must be added to the list or an existing option must be updated, contact your
administrator to update the graphic tagging options.

• DocBook (for the DocBook standard or a similar XML standard)

• DITA

• S1000D 4.x

The text box displays the tagging used in the editing tool when a graphic is copied from Content
Management and pasted to content in the editing tool.

5. Click Apply.

6. Click OK to close the Preferences dialog box.

Import graphics

To use graphics that are created in graphic editing programs, you must import them to Content
Management. Imported graphics are placed in a folder according to how your user interface (UI) options
are set in the rich client.

1. Choose Tools→Import→Graphic.

2. In the Import Graphic Options dialog box, do the following:

For this option Do this

From Directory Browse to and select the folder from which graphics are to be
imported.

File names Select the check box for each graphic file that you want to
import.

Tip:

Click Select All or Deselect All to select or deselect all
files listed.

Graphic Usage Do one of the following:

• Select the Use Graphic Usages from Graphics Mapping
check box to use the graphic usages defined in the
ctm0GraphicUsagePref preference.

Import graphics
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For this option Do this

• Select the graphic usages that you want to assign to this
graphic option:

Caution:

Each graphic option of the same graphic file must
have unique usages. For example, do not import
piston.png and piston.gif both with the VIEW option.

If the graphic will be used for
this purpose

Select this graphic
usage

Icon in published output ICON

High-resolution graphic in
printed output

PDF

Graphic in a resolution
appropriate for the printer where
it will be printed

PRINT

Small-scale image THUMBNAIL

Low-resolution image, typically
for viewing only

VIEW

Image to appear in a Web
browser

WEB

Graphic Attribute Mapping Select the appropriate graphic attribute defined by your
application administrator.

Graphic Classname Select one of the following:

• Graphic—for non-S1000D content.

• S1000D Graphic—for S1000D content.

Language Select the languages for the graphics being imported, or
choose Multilanguage if the graphics have no specific
language associated with them. A separate graphic option
will be imported for each language you choose.

Note:

For S1000D graphics, select the site master language.
The S1000D standard does not require you to associate
a language with graphics, and the sample S1000D
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For this option Do this

graphic attribute mapping does not support multiple
languages for graphics.

Overwrite Mode Select one of the following:

Note:

If you select neither overwrite mode, the graphic will
be imported as a new graphic if a graphic option
with the same Original Imported Name property and
graphic usage does not already exist in the system.

• Skip existing

The graphics are not imported if they already exist in
Content Management.

• Overwrite existing

If the graphics already exist in Content Management, they
are overwritten.

If you select Overwrite existing, select one of the
following usage handling options:

Tip:

To view the usages associated with an existing
graphic option, right-click the graphic option
revision, and choose View Properties.

Note:

Edit, publish, and export functions always use the
latest revision of graphic options. If you revise a
graphic, the new revision appears in all content that
references the graphic. If you want to change a
graphic but you do not want the graphic updated
in all content, you must import the changed graphic
as a new graphic with a different name.

• Keep

The usages of the existing graphics are retained.

Import graphics
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For this option Do this

• Merge

The usages of the existing graphics are retained, and
the new usages selected for this import are added to
the graphics. For example, if a graphic being imported
already exists with the VIEW and WEB usages, and the
selected usages in the Import Graphic Options dialog
box are THUMBNAIL and ICON, the graphic is saved with
the VIEW, WEB, THUMBNAIL, and ICON usages after the
import.

• Overwrite

The usages of the existing graphics are removed and
replaced by the usages selected in the Import Graphic
Options dialog box.

3. Click Finish.

Preview a graphic

• Preview graphics in the following ways:

• Select the graphic option or graphic option revision and open the Summary view. The graphic
appears in the Preview area.

• Right-click the graphic option revision, and choose Show Content.

• Right-click the graphic option or graphic option revision, and choose Open with→Image Preview.

Insert a graphic into a topic

You can insert a graphic option reference into a topic that is open in the editing tool.

In the Publication Structure view, the graphic appears in the structure with an Occurrence Type of
Content Graphic Reference or Composable Graphic Reference.

Note:

When you paste a graphic option into content and you save the content to the database, the
content is decomposed and the graphic option filename is substituted with the graphic item, so
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that other graphic options can be used when the content is subsequently composed. The graphic
tag that is pasted is dependent on the Graphic Link Clipboard preference.

If you save a topic with a graphic that does not exist in Teamcenter, a warning message appears
indicating the graphic cannot be found. The next time you edit the topic the graphic name in the
XML is appended with .error.

1. Search for the graphic.

2. Right-click the appropriate graphic option revision, and choose Copy For Editor→Graphic Content.

3. In the editing tool, right-click the valid position where you want to insert the graphic, and choose
Paste.

The graphic reference is inserted in the topic’s XML, using the tag information from your Graphic
Link Clipboard preference and the identifying information for the graphic file.

4. (Optional) To use a version of the graphic other than the current version, add the appropriate value
to the version attribute in the editing tool.

Add a Lifecycle Visualization graphic to a topic

You can save 2D images or 3D models in Teamcenter lifecycle visualization so that they can be used as
2D graphics in print and online publications that are managed in Content Management. You insert the
graphics into topics when they are open in the editing tool from Content Management.

If the 3D model changes, you can recapture the image in Teamcenter lifecycle visualization to update it
in Content Management.

1. In Teamcenter, send a 2D image or 3D model to the standalone application viewer or the Lifecycle
Viewer.

2. In Teamcenter lifecycle visualization, choose File tab→Publish 2D graphic to Teamcenter Content
Management.

Note:

This option is available only if the graphic is stored in Teamcenter.

3. In the Graphic Option dialog box, do the following:

For this option Do this

Name Type a name for the graphic.

Graphic Usage Do one of the following:

Add a Lifecycle Visualization graphic to a topic

Content Management on Rich Client ─ Usage, Teamcenter 2412  22-7
© 2025 Siemens



For this option Do this

• Select the Use Graphic Usages from Graphics Mapping
check box to use the graphic usages defined in the
ctm0GraphicUsagePref preference.

• Select the graphic usages that you want to assign to this
graphic option:

Caution:

Each graphic option of the same graphic file must
have unique usages. For example, do not use
piston.png and piston.gif both with the VIEW option.

If the graphic will be used for
this purpose

Select this graphic
usage

Icon in published output. ICON

High-resolution graphic in
printed output.

PDF

Graphic in a resolution
appropriate for the printer where
it will be printed.

PRINT

Small-scale image. THUMBNAIL

Low-resolution image, typically
for viewing only.

VIEW

Image to appear in a Web
browser.

WEB

Graphic Attribute Select the appropriate graphic attribute defined by your
application administrator.

Graphic Classname Select one of the following:

• Graphic—for non-S1000D content.

• S1000D Graphic—for S1000D content.

Language Select the languages for the graphics being saved, or choose
Multilanguage if the graphics have no specific language
associated with them. A separate graphic option will be saved
for each language you choose.
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For this option Do this

Note:

For S1000D graphics, select the site master language.
The S1000D standard does not require you to associate
a language with graphics, and the samplesample
S1000D graphic attribute mapping does not support
multiple languages for graphics.

Overwrite Mode Select one of the following:

Note:

If you select neither overwrite mode, the graphic will
be saved as a new graphic if a graphic option with the
same Original Imported Name property and graphic
usage does not already exist in the system.

• Skip existing

The graphics are not saved if they already exist in Content
Management.

• Overwrite existing

If the graphics already exist in Content Management, they
are overwritten.

If you select Overwrite existing, select one of the
following usage handling options:

Tip:

To view the usages associated with an existing
graphic option, right-click the graphic option
revision, and choose View Properties.

Note:

Edit, publish, and export functions always use the
latest revision of graphic options. If you revise a
graphic, the new revision appears in all content that
it is referenced in. If you want to change a graphic
but you do not want the graphic updated in all

Add a Lifecycle Visualization graphic to a topic
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For this option Do this

content, you must save the changed graphic as a
new graphic with a different name.

• Keep

The usages of the existing graphics are retained.

• Merge

The usages of the existing graphics are retained, and
the new usages selected for this save are added to
the graphics. For example, if a graphic being saved
already exists with the VIEW and WEB usages, and the
selected usages in the Graphic Options dialog box are
THUMBNAIL and ICON, the graphic is saved with the
VIEW, WEB, THUMBNAIL, and ICON usages.

• Overwrite

The usages of the existing graphics are removed and
replaced by the usages selected in the Graphic Options
dialog box.

4. Click Next.

5. In the Export Image dialog box, adjust the settings as needed.

Tip:

A resolution of 72 DPI is suitable for images to display on a monitor (email and web pages).
Use a resolution of at least 300 DPI for print content.

6. Click Finish.

Note:

If your organization uses watermarks, a watermark page may appear before you can click
Finish.

The graphic is saved in Teamcenter.
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7. In Content Management, search for the graphic, and then move it to the folder where you want to
store it.

8. Right-click the graphic option revision, and choose Copy For Editor→Graphic Content.

9. In the editing tool, right-click the valid position in the topic where you want to insert the graphic,
and choose Paste.

The graphic reference is inserted in the topic’s XML, using the tag information from your Graphic
Link Clipboard preference and the identifying information for the graphic file.

Edit a graphic option

To edit a graphic, you must check it out and edit it in a graphic editing program. However, you can do
this without re-importing the graphic.

Note:

Edit, publish, and export functions always use the latest revision of graphic options. If you revise
a graphic, the new revision appears in all content that it is referenced in. If you want to change
a graphic but you do not want the graphic updated in all content, you must import the changed
graphic as a new graphic with a different name.

1. Double-click the graphic option image you want to edit.

The graphic is checked out and opens in the default program for the file type.

2. Edit the graphic and save the changes.

3. Close the program you used to edit the graphic.

The graphic is checked in.

Edit a graphic option
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Update a graphic option using Named References

If a graphic changes or you want to change the graphic usage or graphic language, you can update
the graphic option image using the Named References option. When you update a graphic option, it is
updated in every topic in which it is referenced.

1. If you want to retain the original graphic option, select the graphic option revision, and choose
File→Revise, and then follow these steps with the new graphic option revision.

Edit, publish, and export functions always use the latest revision of graphic options. If you revise a
graphic, the new revision appears in all content that it is referenced in.

2. Right-click the graphic option image you want to update, and choose Named References.

3. In the Named References dialog box, select the graphic name and click  to delete the
referenced file.

4. Click Upload....

5. In the Upload File dialog box, browse to and select the new graphic file to replace the one you
deleted.

6. Click Upload.

7. When the new referenced file appears in the Named References dialog box, click Close.

Update the graphic usage for a graphic option

Graphic usages are assigned to graphic options when you import them, but you can update the usages
for an existing graphic option.

Caution:

Each graphic option of the same graphic item must have unique usages. For example, do not
import piston.png and piston.gif both with the VIEW option.

1. Right-click the graphic option revision, and choose Edit Properties.
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2. Click Yes to confirm the checkout.

3. Click All to show all properties.

4. In the Graphic Usages box, edit the graphic usages.

5. Click Save and Check-In, and click Yes to confirm the check-in.

Perform a where-used search for a graphic option

A where-used search identifies all the publications that contain a specific graphic option.

1. Select the graphic option revision in the Home component view.

2. Select the Impact Analysis view.

3. Select Used from the Where option list, located in the upper left of the pane.

Perform a where-used search for a graphic option
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23. Managing content in different
languages
Content translation process

You can manage translations of individual topics or topics at any level in a publication structure.
Managing a translation begins with creating a translation order, in which you choose the translation
office that will perform the translation. Then you create a translation delivery to select the languages
and create a .zip file to contain the content to be translated and any supporting files. You export the .zip
file, and send it to the translator. When the content is translated and returned, you import it back into
the system.

If necessary, you can use a Teamcenter workflow to manage translations according to your
organization’s business practices.

Once a translation exists in the system, you can work with a translated topic as you would any other
topic. Each translated topic is related to the original topic in the master language. Content versions are
used to determine if content has changed since it was translated.

When creating a translation delivery, you can choose to include the graphics associated with the topics
to be translated.

Note:

Graphics are not managed the same way topics are during the translation process. Graphic options
have an associated language property. When you edit and publish content in a language other
than the master language, the graphics that match the language are selected. When a graphic
does not exist for the language, the master language graphic option is used.

View the status of translation order content

You can use a report to review the status of a translated topic or publication to determine if translated
content is at the same content version as the master language content. If the master language content
has been edited since the translation order was created, the translation order content will have a
different content version than the master language content.

1. In either the Home component view or the Publication Structure view, right-click the topic or
publication revision that has the related translation order, and choose Translation Status.

2. In the Browse dialog box, browse to the location where you want to save the report, which is a .csv
file, and click Save.

3. Open the .csv file in Microsoft Excel to review the translation statuses for the topics in the
translation order.
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The report shows each topic’s master language content version and translated language content
version. The In Sync? column reports Y or N to indicate whether the two versions are out-of-
sync. Out-of-sync versions indicate updates were made to the master language content since the
translation order was created.

Create a translation order

The first step in managing the translation process in Content Management is to create a translation
order, which provides information to the translator about the translation service being requested.

1. Do one of the following to display a dialog box to create the translation order:

• In either the Home component view or the Publication Structure view, right-click the topic or
publication revision to be translated, and choose Translation Order.

• In the Home component view, select the topic or publication revision to be translated, and then
either click New Author Item... , or choose File→New→New Author Item.

In the New Author Item dialog box, expand Complete List, click Translation Order, and then
click Next.

2. In the dialog box, do the following:

For this option Do this

ID Either type an ID for the translation order, or leave the box
blank so that the next available item ID is automatically
assigned.

Revision Either type a revision for the translation order, or leave the
box blank so that the next available revision is automatically
assigned.

Name Type a name for the translation order.

Order Title Type a title for the translation order.

Order Description Type a description of the translation order.
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For this option Do this

Translation Office Reference Select the translation office responsible for translating this
order.

Request Delivery Date Click the calendar button, and then select the date that you
want the translation returned.

3. Click Finish.

4. (Optional) Submit the translation order to a Teamcenter workflow.

5. Create the files for content delivery to a translator.

Create the files for content delivery to a translator

To deliver content to a translator, you create a translation delivery. A translation delivery collects into
a .zip file all the files that a translator needs to translate the content. When you create a translation
delivery, the following objects are created in Content Management:

• Translation delivery, related to the translation order

• Translations, related to the translation delivery and the original topic

• A .zip file containing the content to be translated and any selected supporting files, which you can
export and send to the translation company

1. Right-click the translation order revision and choose Create Translation Delivery.

2. In the Create Translation Delivery dialog box, do the following:

For this option Do this

Includes Select the items to include in the translation delivery .zip file:

• Include Graphics

Includes the graphics that are referenced in the content.

• Include Supporting Data

Includes the schemas with which the XML files can be
validated.

• Include Published Content

Create the files for content delivery to a translator
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For this option Do this

Includes related composed documents.

Delivery Modes Select the items that you want to include in the translation
delivery .zip file:

• Deliver Composed Topic

Includes the content in one composed document.

• Deliver Decomposed Topic

Delivers the content as separate topics.

• Deliver Out-of-Sync Topics Only

Delivers only topics that were modified since the last
translation. (The content version of the translated topic
is not current with the master language version and the
content version is greater than -1.)

When you select this option, the topics must be delivered
decomposed, so you cannot select this option along with
the Deliver Composed Topic option.

You can view the status of translation order content to
determine if the content has out-of-sync topics.

• Deliver Topics Already Out for Translation

Includes all out-of-sync topics, even those that have
already been sent for translation.

If this is not selected, only the topics that have not yet
been sent for translation will be included.

This option is only available when you select the Deliver
Out-of-Sync Topics Only option.

Available Languages Select each language you want the content translated to,
and then click  to move the languages to the Selected
Languages list.

Selected Languages Select each language, and then select Review next to each
language that you would like to flag for a review when
translated content is returned.
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3. Click Finish.

The Delivery Type property for the translation delivery is set to Submittal.

4. Export the translation delivery.

Export the translation delivery

You export the translation delivery .zip file to a local or network drive, so that you can send the files to be
translated to the translator.

1. Select the translation delivery revision, and choose Tools→Export→Translation.

2. In the Browse dialog box, browse to the location where you want to save the .zip file, and click
Save.

3. Send the .zip file to the translation office for translating.

Tasks performed by the content translator

When a translator receives the translation delivery as a ZIP file, it contains the following:

• A .txt file listing the topics to be translated and the languages they are to be translated in.

• The ...original folder containing the topics (as XML files) to be translated in the master language.

• The ...translated folder as a placeholder for the translated topics.

• The ...translationSource folder containing the topics to be translated.

• The ...supportingData folder containing the schemas with which the XML files can be validated.

• The ...graphics folder containing the graphics referenced in the content, if graphics were included in
the translation order when it was created.

The translation process is as follows:

1. The translators translate the topics in either the translated\decompose or the
translated\compose folder. If both the decompose and compose folders were included in the
delivery, they delete the one that they are not using.

The topics are edited using an editing tool. These files may be validated with the respective
schemas included in the translation order.

Export the translation delivery
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2. When the translation of the files is completed, they create a ZIP file with the same organization
structure as the original ZIP file and with the translated content in the appropriate objects and
folders.

3. Once completed, the send the ZIP file back to the appropriate Content Management user.

Import translated content

When you receive translated files from the translator, you import the translated data into Content
Management. The translations can then be tested by previewing or publishing them in the appropriate
language.

1. When you receive a translation from a translator, save the attached .zip file to a local or network
drive.

Note:

The .zip file from the translator must contain the original folder structure of the translation
delivery and the translations results contained in the translated folder, as described in Tasks
performed by the content translator.

2. Choose Tools→Import→Translations.

3. In the Receive Translations dialog box, click  to browse to and select the folder containing
the .zip file you received from the translation office.

4. In the Translation zip files box, select the check box for each .zip file you want to import.

Tip:

Click Select all or Deselect all to select or deselect all files listed.

5. Click Finish.

The translations are updated with the translated content, and the Translation Received property
on the translations is set to TRUE. Also, a new translation delivery object is created with the
Delivery Type property set to Delivery. A check mark appears next to received translations.
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Edit a translation topic

You can edit a translation topic before you send it the translator (in the master language) or after
it is received from the translator and imported to Content Management (in the translated language).
Once you save and check in your edits, the Content Version Reference on the translation is set to the
Content Version of the master language topic.

Caution:

If you edit translation content after it is sent to the translator but before it is returned and
imported, once you import the translated content, any edits you made to the source will be
overwritten.

1. In the Home component view, right-click the translation revision, and choose Edit→Edit
Translation.

2. In the Check-Out dialog box, click Yes.

The topic opens with the editing tool and is saved in a local folder. The topic appears as checked
out , and in edit mode . The Teamcenter CMS menu appears in the editing tool's menu bar.

3. In the editing tool, edit the content as necessary, as the schema structure allows.

4. When you are done editing the topic, do one of the following:

To do this Do the following For this result

Save your
changes and
close the file.

Do one of the following:

• In the editing tool, choose
Teamcenter CMS→Save
and Close.

• Use the editing tool's
options for saving files,
and then in the Home
component view, right-

The editing tool closes the file, the edited file
is updated in the database, and its content
version reference is set to the content version
of the master language topic.

Edit a translation topic
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To do this Do the following For this result

click the translation
revision, and choose
Edit→Save and Close
Edit.

Then right-click the
translation revision,
and choose Check-In/
Out→Check In.

Close the file
without saving
your changes.

Do one of the following:

• Choose Teamcenter
CMS→Close.

• In the Home component
view, right-click the
translation revision, and
choose Edit→Cancel
Edit.

Then right-click the
translation revision,
and choose Check-In/
Out→Cancel Checkout.

The editing tool closes the file, the file remains
unchanged in the database.
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