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1. Overview of Content Management
Content Management is a component content management system for the creation of technical
documentation. Technical publications consist of XML and SGML text components, which are stored
in the Teamcenter database along with any referenced graphics used in the publications. The structure
and content of a publication is validated by schemas, such as DITA or Docbook. The publication layout
is implemented with stylesheets, which allows the same content to be formatted for different media,
such as print, web, or interactive applications. Content developed as individual topics may be reused by
reference in multiple publications.

Content Management works in conjunction with several XML editing and publishing tools, which enable
publications to be generated for both online and print formats. Content Management includes support
for multiple language versions and includes the ability to manage topics through translations and
release cycles.

In Active Workspace, support for general XML schemas, the DITA standard, and the S1000D standard is
available. The DITA administrative data available out of the box enables management of documentation
for the DITA standard through version 1.3, including specialization and support for DITA Open Toolkit
(OT) version 2.4.6.5. Several versions of S1000D administrative data are available, including 4.0, 4.1,
4.2 and 5.0.

 Administrator Install and setup Content Management

 Business User

Author using DITA See how to author DITA content.
Author using S1000D See how to author S1000D content.
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Publish content See how to publish content.
Manage translations See how to manage translations.

1. Overview of Content Management
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2. Authoring DITA content
Overview of DITA content

Darwin Information Typing Architecture (DITA) is an XML-based architecture for developing technical
publications. It includes an architectural specification, language specification, and DTD and schema
implementations of the language. If you have installed the DITA Content Management solution, you
can manage documentation for the DITA architecture. For more information about DITA, see OASIS
Standards.

Content Management provides DITA administrative data and authoring objects through DITA version 1.3:

Note:

DITA publishing is supported only on Linux and Windows.

The contents of anchorref elements are not included in documents published with DITA Open
Toolkit 2.4.6 publishing tools.

• DITA maps

A DITA map is an object that contains references to DITA topics and organizes the topics into
hierarchies, tables, or groups. These maps can be used to generate outlines or the table of contents.
A map can contain any combination of references to DITA topics, DITA tasks, DITA concepts, DITA
references, and other DITA maps. A DITA map includes metadata to describe properties such as the
audience, platform, and product. Maps are used to create documents that result in separate XML files
while processing the output.

The <map> element is used in the XML to define a map. You can import existing DITA maps to the
Content Management application, which includes any references to DITA topics they may contain. You
can work with two types of maps:

• DITA Dynamic Map

You can add, delete, and organize topics in a DITA dynamic map in Content Management and edit
the contents in an editing tool. A DITA bookmap is a special type of dynamic map, used to organize
DITA content into a book format. The <bookmap> element is used in the XML to define a bookmap.

• DITA Static Map

You can edit topic references in a DITA static map in an editing tool but not in Content
Management. Starting in versions 9.0 and later, static maps are primarily used only for content
migrated from earlier versions.

• DITA Base
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A DITA base object, also referred to as a DITA composite object, is a top-level container for multiple
topics used to create documents that result in a single XML file in output processing. A composite is
typically reused as is and is not modified when referenced from different DITA maps.

A DITA base object can contain any combination of DITA topics, DITA tasks, DITA concepts, and DITA
references. It can be opened for editing XML content. The content opens in the editing tool as a single
XML file containing all its related files. The <dita> element is used in the XML to define a DITA base
object.

• DITA topics

A DITA topic is a single unit of content that contains the information on a single subject. The DITA
architecture includes the following four topic types:

• DITA Topic 

A DITA topic, also referred to as a generic or unspecialized topic type, provides the base for
specialized topic types and does not meet the definition of a concept, reference, or task topic.

• DITA Concept Topic

A DITA concept topic is a specialized topic type that provides background information to aid in the
understanding of a product, interface, or task.

• DITA Reference Topic

A DITA reference topic is a specialized topic type that provides quick access to facts.

• DITA Task Topic

A DITA task topic is a specialized topic type that provides step-by-step instructions for completing a
task.

Create a DITA topic

1. Go to any folder and choose More Commands  > New  > Add. Alternatively, you can click Add
 in the work area.

2. In the New tab of the Add panel, search for the term DITA from the TYPE list.

3. Choose from the list of DITA topic types:

2. Authoring DITA content
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DITA topic type Description

DITA Abstract Map This is a behind-the scenes object. Users must not use this topic type.

DITA Base This is a top-level container for multiple topics used to create
documents that result in a single XML file during output processing.

DITA Concept Topic This is a specialized topic type that provides background information
to aid in the understanding of a product, interface, or task.

DITA Dynamic Map This is used for organizing topics in a map.

DITA Embedded Topic This is a topic type that is embedded within a parent topic.

DITA Reference Topic This is a specialized topic type that provides quick access to facts.

DITA Static Map This is used for organizing topics in a map. It is mainly used for
content migrated from previous versions.

DITA Task Topic This is a specialized topic type that provides step-by-step instructions
for completing a task.

DITA Topic This is a generic or unspecialized topic type.

4. From the Topic Type list, select the topic type to associate with. The topic type determines which
schema is used to validate the DITA topic and which stylesheets are used when a tool is launched to
edit or publish the content.

Note:

The topic type may already be selected or the options may be limited to a specific topic type
group, depending on how the ctm0TopicTypeGroup preference is set.

5. Specify the Revision, Name, and Document Title and other properties of the topic.

6. Select the Template check box to specify whether the DITA topic is to be used as a template.

7. Select the Reference Only check box to specify whether the DITA topic must be referenced when
it is referenced by another topic that is used as template. If this check box is not selected, the DITA
topic is copied.

8. Click Add.

Create a DITA topic based on an existing topic

1. Open a DITA topic and choose More Commands  > New  > Save As.

2. In the Save As panel add the required information as follows:

Create a DITA topic based on an existing topic
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For this option Do this

Name Type the name for the topic.

Document Title Type the name for the new DITA document.

Is a Template Select the Template check box to specify whether the DITA topic is
to be used as a template.

Reference only Select the Reference Only check box to specify whether the DITA
topic must be referenced when it is referenced by another topic
that is used as template. If this check box is not selected, the DITA
topic is copied.

DITA Audience Select the audience to assign to this topic.

DITA Importance Select the level of importance to assign to this topic.

DITA Other Properties Select other properties to assign to this topic.

DITA Platform Select the platform to assign to this topic.

DITA Product Select the product to assign to this topic.

3. If the DITA topic has child topics, you can also save the child topics. To save the child topics:

a. Select the Specify children to duplicate check box and click Select.

b. Select the child topics you wish to save and click Save.

c. In the Save panel choose the ID Naming Rule.

2. Authoring DITA content
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4. Click Save.

To view the new topics, search for the topic in Teamcenter.

Create child topics for DITA topics

1. Open a DITA topic, go to the Content tab, and choose Add  > Child.

In the Add Child panel, you can create a new topic, or you can add an existing topic as a child.

2. Create a new topic.

a. Click the New tab and select the DITA topic type from the TYPE list.

The topic type determines which schema is used to validate the DITA topic and which
stylesheets are used when a tool is launched to edit or publish the content.

Note:

By default, the parent topic type is selected. The topic type options may be limited to
a specific topic type group, depending on how the ctm0TopicTypeGroup preference is
set.

b. From the Topic Type list, select the type of reference to create between the parent topic and
the child topic.

c. Select the master language from the Master Language list.

d. Specify the Revision, Name, Document Title and other properties of the topic.

e. Click Add.

3. Add an existing topic:

Create child topics for DITA topics
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Click the Palette or Search tabs and select or search for an existing DITA topic.

Click any of the following options to add the topic as a child topic:

• Add: A reference is added to the original topic, and the topic appears as a child.
• Add Copy: A copy of the original topic is created and referenced. The new topic appears as a

child.

Import a DITA map

Note:

When importing, if your property values contain non-ASCII characters, you may get an error about
exceeding the allowed length even though your property value is within the length limit. This is
due to the fact that non-ASCII characters may take more storage space depending on the encoding
used, for example, if you use the UTF-8 encoding, all ASCII characters are one byte but most
Japanese characters are three bytes.

You can import a DITA map with all its child topics as follows:

1. Select or open a topic or a publication and choose More Commands  > Import/Export  >
Import DITA Map.

2. Update the DITA Map panel as follows:

For this option Do this

Choose File Select the DITA map which is in a ZIP format.

DITA Map File Name The file name is automatically assigned based on the ZIP file
that you selected in the previous step.

Caution:

Ensure that the DITA Map File Name has the same as
the name of the DITA map you are importing. If the file
names are different, the import fails.

Graphic Attribute Mapping Select how the graphic file names are mapped:

• Default Graphic Attribute Mapping

Select this option to map the graphic file name as is.

• Default Graphic Attribute Mapping without suffix

2. Authoring DITA content
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For this option Do this

Select this option to map a part of the importing graphic
file name, excluding the suffix.

Select this option if the file names contain more than one
separator, for example, wheel.right.jpg.

GRAPHIC MODE If the topic contains references to graphics, select one of the
following options to indicate how the topic references the
graphic names:

Note:

You must import the graphics to be referenced before
importing the topic that refers to the graphics. How
these graphics are imported and named determines
which option you choose.

• Public ID

The public identifiers of the graphics are used by the topic
to reference graphics.

• Original Name

The original names of the graphics are used by the topic to
reference graphics.

• XML Number

The XML numbers of the graphics are used by the topic to
reference graphics.

• Graphic Name

The names of the graphics with or without the file
extensions are used by the topic to reference graphics.

REUSE EXISTING TOPIC Select the following options to indicate how the import
searches for and handles topics already existing in the
database or if you want to use the ID or XML number of the
imported topic as its item ID in Teamcenter.

Import a DITA map
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For this option Do this

Note:

If none of these options are selected, all topics are
imported as new topics, regardless of whether identical
topics or content already exist in the database.

• Find by XML Number

Select this option to search the database for a topic with
the same ID as the ID or XML number of the topics you are
importing. If a topic with the same ID is not found, the ID
or XML number of the topic is used as the ID instead of an
auto-generated ID.

If your documents use content references, you must select
this option to ensure content references are preserved
because content references use item ID/XML numbers.

• Find by Content

Select this option to search the database for topics with
the same content as that in any of the topics you are
importing. When a topic is found with the exact content
(including tags and the attribute values) as the one being
imported, the topic is not imported.

3. To assess the impact of the DITA map and its associated topics, and to see what changes will occur,
click Preview Impact.

This command generates an impact report that shows the item ID, the item type, the items
impacted by the import, the changes, and an explanation of the changes that will occur.

After the report is generated, you can download it in HTML format. You can access the report in the
Alerts section, and it is also timestamped and saved in the Newstuff folder.

Note:

If you do not see the report in the Alerts section, contact your system administrator to
configure Teamcenter Dispatcher for asynchronous processing.

4. To incorporate the changes shown in the impact preview report, click Import in the Preview
section.

The Import Content panel appears with the options that you selected previously.

2. Authoring DITA content
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5. Click Choose File to reselect the DITA map files to import, and then click Import.

The DITA map and its associated topics are imported to the folder you selected.

Import a DITA map
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2. Authoring DITA content
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3. Authoring S1000D content
Overview of authoring S1000D content

S1000D is an international specification for technical publications that use a Common Source Database
(CSDB). To download sample content that you can view or import, see www.S1000D.org, which includes
the sample XML content and illustrations for a fictional bike.

Content Management supports these objects for S1000D:

• Data Module

A data module is a self-contained information unit. Every data module contains an identification
and status section and a content section that contains text and illustrations. Content Management
supports the standard S1000D data module types, including Business Rules Exchange (BREX),
procedural type, and descriptive type.

• Data Module List

A data module list (DML) identifies the data modules in a project. It contains an identification and
status section and the data module requirement list content. The DML object can be related to data
module objects, but it is not required. When you relate data modules to it, the DML can be used to
group data modules together in a compiled dataset.

• Data Dispatch Note

A data dispatch note (DDN) contains information about the sender, receiver, and content of a
dispatch. It can be related to several data modules. When related to a data module, additional SGML
or XML code is automatically added to the DDN about the data module. A data module can be related
to multiple DDNs.

• Publication Module

A publication module defines the content and the structure of a publication. It contains an
identification and status section and a content section that contains references to data modules, other
publication modules, and legacy technical publications. The publication module for S1000D content is
not the same type of object as the publication topic type used in Base Content Management.

• Commentary

A commentary, or comment, is used to report issues on data modules during the verification process
and the in-service phase of the product. It contains an identification and status section and a content
section that contains the original comment and may include a response to a comment. A comment
can be related to a data module, publication module, DML, or DDN. It is important to note that it must
have at least one of these relations.
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• Illustration Control Number

The illustration control number (ICN) is used to manage graphics and to ensure that the graphic is
compliant with S1000D graphic guidelines.

• In-Process Review Form

An in-process review form contains the review of the data modules provided by the customer or the
contractor.

• Sharable Content Object Reference Model Content Package

A package that contains the content and metadata for e-learning developed in accordance with the
Sharable Content Object Reference Model (SCORM) standard.

• Standard Numbering System

An S1000D standard numbering system (SNS) structure defines the numbering scheme, program, and
organization data used in data modules for specific S1000D projects.

With the S1000D solution:

• Administrators can setup S1000D by installing S1000D support, creating or importing SNS structures,
and other configurations. For more information, see Content Management Administration in the
Teamcenter help collection.

• Authors can:

• Administrators can set up S1000D by installing S1000D support, creating or importing SNS
structures, and performing other configurations.

• Authors can:

■ Create or import S1000D data module types. These data modules can be associated with an SNS.
When you associate a data module with an SNS, many of the properties that make up the data
module code (DMC), are automatically set for the data module.

■ Author content in an XML editor such as XMetaL.

■ Validate the data modules using BREX data modules.

■ Create and associate a publication module with data modules and SNS.

■ Publish S1000D content in a format such as PDF, HTML, or other formats. Note, that
administrators have to set up the publication process.

3. Authoring S1000D content
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■ Create DML and DDN for exchanging data with partners.

■ Import DMRL for importing data from partners.

■ Use other Content Management and Teamcenter features such as translations, reviews, and
workflows.

Import illustrations

You can import illustrations (ICNs) so that they are available for reuse by publications.

1. Go to any folder and choose More Commands  > Import/Export  > Import Content.

2. In the Import Content panel, from the CONTENT TYPE list select Graphic.

3. Update as follows:

For this option Do this

Choose File Select the graphics that you want to import.

Graphic Attribute Mapping Select the applicable graphic attribute map that matches your
standard.

Graphic Classname Choose S1000D Graphic.

OVERWRITE MODE Select one of the following:

• Skip existing

The graphics are not imported if they already exist in
Teamcenter.

• Overwrite existing

If the graphics already exist in Content Management, they
are overwritten.

GRAPHIC USAGES Select the relevant option for the graphic based on its
intended use:

Import illustrations
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For this option Do this

If the graphic will be
used for this purpose

Select this option

High-resolution
graphics in printed
output

PDF

Image intended to
appear on a web
browser

Web

Graphics in a
resolution appropriate
for printing

Print

Low-resolution
images, typically for
viewing only

View

Icons in the published
output

Icon

Small-scale images Thumbnail

Original version of the
graphic

Source

LANGUAGE Select the languages for the graphics being imported.

4. Click Import.

The graphics are imported to the selected folder. You can view the graphic in the Viewer and use the
Markup mode to add markup to the graphics.

Import S1000D data modules against an SNS

Note:

Ensure that the administrator has imported or created the SNS structure.

1. Go to a folder and choose More Commands  > Import/Export  > Import Content.

2. Update the panels as follows:

3. Authoring S1000D content
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For this option Do this

Choose File Select the S1000D data modules that you want to import.

Graphic Attribute Mapping Choose a S1000D version from the list.

Selecting one of these options ensures that the data module
content is mapped to the Teamcenter object.

GRAPHIC MODE If the topic contains references to graphics, select one of the
following options to indicate how the topic references the
graphic names:

Note:

You must import the graphics to be referenced before
importing the topic that refers to the graphics. How
these graphics are imported and named accordingly
determines which of the following options you choose.

• Public ID

The public identifiers of the graphics are used by the topic
to reference graphics.

• Original Name

The original names of the graphics are used by the topic to
reference graphics.

• XML Number

The XML numbers of the graphics are used by the topic to
reference graphics.

• Graphic Name

The names of the graphics with or without the file
extensions are used by the topic to reference graphics.

REUSE EXISTING TOPIC Select the following options to indicate how the import
searches for and handles topics that already exist in the
database and whether to use the ID or XML number of the
imported topic as its item ID in Teamcenter.

Import S1000D data modules against an SNS
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For this option Do this

Note:

If none of these options are selected, all topics are
imported as new topics, regardless of whether identical
topics or content already exist in the database.

• Find by XML Number

Select this option to search the database for a topic with
the same ID as the ID or XML number of the topics you are
importing. If a topic with the same ID is not found, the ID
or XML number of the topic is used as the ID instead of an
auto-generated ID.

If your documents use content references, you must select
this option to ensure that content references are preserved
because content references use item ID/XML numbers.

• Find by Content

Select this option to search the database for topics having
the same content as the topics you are importing. When a
topic is found with the exact content (including tags and
the attribute values) as the one being imported, the topic
is not imported.

3. Click Import.

The data modules are imported to your selected folder and associated with the SNS. Search for the SNS
to see the data modules associated with it.

Create an S1000D data module against an SNS

Note:

You can create a data module without associating it to an SNS. However, creating data modules
against an SNS is more efficient as the data module properties are automatically filled in from the
SNS.

1. Open the SNS and select a disassembly node.

2. Click Add  > Child.

3. Authoring S1000D content
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3. In the Add Child panel, under the Type list, ensure that S1000D Data Module 4.X/5.X is selected.

4. Update the panels as follows:

a. In the REFERENCES section:

A. Choose the data module type from the Topic Type list.

B. Choose the language from the Master Language list.

b. In the DATA MODULE CODE section, fill in the data module code details that are not filled in
automatically from the SNS.

c. In the PROPERTIES section, specify a name for the data module in the Technical Name box.

d. In the OTHER DATA MODULES DETAILS section, specify the remaining details.

5. Click Add.

The data module appears under the SNS node.

Create an S1000D data module independently

1. Go to a folder and choose More Commands  > New  > Add Content.

2. In the Add Content panel, select S1000D Data Module 4.X/5.X.

3. Update the Add Content panel with the mandatory information and click Create.

The data module is created in the selected folder.

Create an S1000D data module based on an existing module

1. Open a data module and choose More Commands  > New  > Save As.

2. In the Save As panel add the required information.

3. If the Advanced Copy Options section, select what information you want to keep, reference, or
remove.

You can choose from the following options:

Create an S1000D data module independently
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Option Description
Remove Removes the content.
Save As Saves a copy of the content.
Reference References the content.

4. Click Save.

Validate a data module using the business rules exchange data
module

When authoring using the S1000D standard, you validate data modules against a business rules
exchange (BREX) data module to verify that the data modules conform to a project's business rules.
Content Management provides a validation tool with which you can validate a single data module, a
group of selected data modules, or all data modules in a data module list (DML), data dispatch note
(DDN), or publication module.

To validate a data module using BREX:

1. Select one or more data modules, a data dispatch note, or a publication module.

2. Choose More Commands  > Manage  > BREX Validation.

3. Authoring S1000D content
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3. In the BREX Validation panel, choose Run in Background option to run the validation while you
perform other tasks in Teamcenter. When the validation is complete, results are displayed in the
Alerts panel, and they are attached to the data module in Teamcenter as an additional log file.

If you do not choose this option, the validations runs while you wait for it to be completed. You
cannot perform other tasks in Teamcenter while it is running. The results are displayed after the
validation.

Click Validate.

Depending on the validation option you choose, the validation results are either displayed or you are
notified about the results in the Alerts panel.

Import publication modules

1. Go to a folder and choose More Commands  > Import/Export  > Import Content.

2. Update the panels as follows:

For this option Do this

Choose File Select the publication modules that you want to import.

Graphic Attribute Mapping Select the attribute map that corresponds with your version
of S1000D.

GRAPHIC MODE If the module contains references to graphics, select one of
the following options to indicate how the topic references the
graphic names:

Note:

You must import the graphics to be referenced before
importing the module that refers to the graphics. How
these graphics are imported and named accordingly
determines which option you choose.

• Public ID

The public identifiers of the graphics are used by the
module to reference graphics.

• Original Name

The original names of the graphics are used by the module
to reference graphics.

Import publication modules
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For this option Do this

• XML Number

The XML numbers of the graphics are used by the module
to reference graphics.

• Graphic Name

The names of the graphics with or without the file
extensions are used by the module to reference graphics.

REUSE EXISTING TOPIC Select the following options to indicate how the import
searches for and handles topics that already exist in the
database and whether to use the ID or XML number of the
imported topic as its item ID in Teamcenter.

Note:

If neither of these options are selected, all modules
are imported as new modules, regardless of whether
identical topics or content already exist in the database.

• Find by XML Number

Select this option to search the database for a module with
the same ID as the ID or XML number of the topics you are
importing. If a module with the same ID is not found, the
ID or XML number of the module is used as the ID instead
of an auto-generated ID.

If your documents use content references, you must select
this option to ensure content references are preserved
because they use item ID/XML numbers.

• Find by Content

Select this option to search the database for modules
containing the same content as any of the modules you
are importing. When a module is found with the exact
content (including tags and the attribute values) as the
one being imported, the module is not imported.

3. Click Import.

The publications modules are imported to the folder you selected, and the data modules and
illustrations related to the publication module are also created.

3. Authoring S1000D content
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Create a publication module

1. Go to a folder and choose More Commands  > New  > Add Content.

2. In the Add Content panel, select S1000D PUBLICATION MODULE 4.X/5.X.

3. Update the Add Content panel with the mandatory information and click Create.

The publications module is created in the folder you selected. You must associate data modules and
illustrations with this publication module to create a publication.

Building a publication by associating data modules to the
publication module

You can associate a data module to a publication module in one of the following ways:

• Paste a data module to a publication module.

• Use the Add command and create a child by searching for or pasting a data module.

Adding data modules to a publication structure follows the rules of the XML schema for that
publication module. Specific types of data modules can only be pasted in certain areas. Check with your
administrator if you are having problems creating relationships between data modules and pmEntry
objects.

Publish S1000D content

1. Select a data module or a publication module, and choose More Commands  > Share  >
Publish Topic.

Create a publication module
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2. Update the Publish Topic panel as follows:

For this option Do this

Tool Select the publishing tool for the type of output you are
generating. The selection depends on the tools installed
on your computer and set up in the system by your
application administrator.

Style Type Select the style type (collection of style sheets) to be
used to publish the content. The style types are set by
your application administrator.

Language Select the language in which to publish the resulting
output.

Translation Version Select the translated version of the content to be
published when a language other than the master
language is selected:

• Latest Received

The latest received translation in the selected
language is selected for publishing regardless of the
content version in the master language. However, if no
translation exists for the selected language, the master
language is used.

• Match Topic

If the latest content version in the master language
is the same as that in the translation, the translation
is selected for publishing. Otherwise, the master
language is used.

• Received

The latest received translation in the selected
language with a content version older than or as
current as the master language version is selected
for publishing. If all translation content versions are
newer, or if no translation exists for the selected
language, the master language is used. This option
is typically used when you publish an older version
of the content and you do not wish to include
translations that have newer content.

Register Result If you want to create a composed document or a
reviewer document, select the type accordingly:

3. Authoring S1000D content

3-12  Content Management on Active Workspace ─ Usage, Teamcenter 2412
© 2025 Siemens



For this option Do this

• Composed Document

A composed document contains the full content of
the document. It can be exported, sent for publishing
again, or stored as a final document.

• Reviewer Document

A composed document that can be submitted to a
workflow for review.

Transformation Policy To apply an XML transformation policy to the content you
are publishing, select the policy from the list.

A transformation policy can be used to modify content
when it is published or exported. For example, it could
convert units of measure, such as US standard to metric.
Your administrator must create a transform policy before
it is available for you to use.

3. To display the estimated size of the published file before you publish it, select Check to calculate
the estimated size after publish check box.

The size is estimated based on the sizes of the XML content and any included graphic files. This
may be different from the final output size as different file formats have different compression
schemes.

4. In the Schema Validation section depending on how your administrator has setup how publication
should be done based on the schema validation results, a schema validation option will be enabled
automatically or you can select from the following options:

Validation option Result
Publish with validation
errors

Publish the content even if schema validation errors exist. A log is
provided with errors to support correcting content.

Do not publish on
validation errors

If validation errors exist, publish will not complete. A log is provided
with errors to support correcting content.

Publish without
validation

Publish without checking schema validation on content. Publish will
complete unless other errors prevent compilation and publish.

5. Click Publish.

Refresh your browser to see the published results. The published files appear in the Viewer section.

Publish S1000D content
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Create Data Module Lists and export them to partners

A data module list can be used to share the data modules with partners.

Create a data module list

1. Go to a folder and choose More Commands  > New  > Add Content.

2. In the Add Content panel and select S1000D DATA MODULE LIST 4.X/5.X.

3. Update the Add Content panel with the mandatory information and click Create.

3. Authoring S1000D content
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The data module is created in the folder you selected.

Associate data modules and other content to the data module list

You can associate a data module or a data dispatch note to a data module list in one of the following
ways:

• Paste a data module to a publication module.

• Use the Add command and create a child by searching for or pasting a data module.

Export a data module list

1. Open a data module list and choose More Commands  > Import/Export  > Export Topic.

2. Update the panels as follows:

For this option Do this

Language Select the language you want to use for the exported
content.

CONTENT Select any of the following to choose the contents of the .zip
file:

• Include Main Content

Includes the XML files for the topic content.

• Include Supporting Data

Includes the schemas for the exported topics.

• Include Graphic Data

Includes the graphics embedded in the topics.

Transformation Policy To apply an XML transformation policy to the content you are
exporting, select the policy from the list.

A transformation policy can be used to modify content when
it is published or exported. For example, it could convert
units of measure, for example, from US standard to metric.
Your administrator must create a transform policy before it is
available for you to use.

REFERENCES Select any of the following to choose the content to include
in the export:

Create Data Module Lists and export them to partners
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For this option Do this

• Include Content References

Includes topics that are referenced by the topic or the
publication you are exporting.

• Include Compose References

Includes topics that are referenced by composable
reference relations. Composable topic references are
created by relating topics in Teamcenter. This reference
type is typically used to enable the creation of DITA
Dynamic Maps and publication modules.

GRAPHIC MODE Select one of the following to indicate how the content
references the graphic names:

Note:

• The way you export graphics impacts whether the
references to graphics can be resolved when the
exported content is imported into another system.

• To include graphics in the export, select either
Public ID or Import Original Name. If you select
XML Number or Graphic Name, graphics are not
exported.

• The characters /|~`’,;:\"*?<> are invalid when used
in the public ID or in the original import name of
the graphics. When you export a topic containing
graphics with these characters, they are converted to
an underscore ( _ ).

• Public ID

The public identifiers of the graphics are used by the topic
to reference graphics.

• Original Name

The original names of the graphics are used by the topic to
reference graphics.

• XML Number

3. Authoring S1000D content
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For this option Do this

The XML numbers of the graphics are used by the topic to
reference graphics.

• Graphic Name

The names of the graphics with or without the file
extensions are used by the topic to reference graphics.

Graphic Priority Select the graphic priority to determine in what order the
topic's graphic options are selected in the output. This is
based on the graphic usage options that you selected when
you imported the graphic.

3. Click Export.

The data module list is downloaded through your browser as a ZIP file. Save the data module list and
send it to the translator.

Filter the S1000D structure using closure rules

You can filter your S1000D structure using closure rules.

Procedure

1. Open your S1000D structure.

2. From the Expansion list, choose any of the following closure rules:

• ContMgmt_Skip_BREX_and_Applicab

Hides BREX rules and applicability.

• ContMgmt_Skip_BREX

Hides BREX rules.

• ContMgmt_Skip_Applicability

Hides applicability.

The S1000D structure is filtered using the closure rule that you selected.

Filter the S1000D structure using closure rules
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Import Data Module Lists (DML)

1. Go to a folder and choose More Commands  > Import/Export  > Import Content.

2. Update the panels as follows:

For this option Do this

Choose File Select the Data Module Lists that you want to import.

Graphic Attribute Mapping Select the attribute map that corresponds with your version
of S1000D.

GRAPHIC MODE If the module contains references to graphics, select one of
the following options to indicate how the topic references the
graphic names:

Note:

You must import the graphics to be referenced before
importing the module that refers to the graphics. How
these graphics are imported and named accordingly
determines which option you choose.

• Public ID

The public identifiers of the graphics are used by the
module to reference graphics.

• Original Name

The original names of the graphics are used by the module
to reference graphics.

• XML Number

The XML numbers of the graphics are used by the module
to reference graphics.

• Graphic Name

The names of the graphics with or without the file
extensions are used by the module to reference graphics.

REUSE EXISTING TOPIC Select the following options to indicate how the import
searches for and handles topics that already exist in the

3. Authoring S1000D content
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For this option Do this

database and whether to use the ID or XML number of the
imported topic as its item ID in Teamcenter.

Note:

If neither of these options are selected, all modules
are imported as new modules, regardless of whether
identical topics or content already exist in the database.

• Find by XML Number

Select this option to search the database for a module with
the same ID as the ID or XML number of the topics you are
importing. If a module with the same ID is not found, the
ID or XML number of the module is used as the ID instead
of an auto-generated ID.

If your documents use content references, you must select
this option to ensure content references are preserved
because they use item ID/XML numbers.

• Find by Content

Select this option to search the database for modules
containing the same content as any of the modules you
are importing. When a module is found with the exact
content (including tags and the attribute values) as the
one being imported, the module is not imported.

3. Click Import.

The Data Module Lists are imported to the folder you selected.

Import a data management requirement list

A data management requirement list (DMRL) identifies the data modules planned for a specific project.
When you import a DMRL, data modules specified in the DMRL are created in Teamcenter. The data
modules are imported to the folder you selected or associated with a standard numbering system (SNS)
structure.

To import a DMRL:

1. Prepare the .csv file.

Import a data management requirement list
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2. Import the DMRL.

Prepare the .csv file

1. Use a text editor to create a .csv file to create a DMRL that lists the data modules you want to create
in Content Management. Microsoft Office Excel is not recommended for this as it may remove
leading zeros.

A sample .csv file is included in the administration data provided with the Content Management
installation:

TC_ROOT\contmgmts1000d40_data\data\admin\bulkImportDataModule.csv

2. Include the following values in the order listed. Use a comma for any optional value that is blank.

Model identification code

System difference code

System code

Subsystem code

Sub-subsystem code

Assembly code

Disassembly code

Disassembly code variant

Information code

Information code variant

Item location code

Language

Extension code (optional)

Extension Producer (optional)

Learn Code (optional)

Learn Event Code (optional)

3. Authoring S1000D content
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Technical Name

Information Name (optional)

Security classification

Topic type

Originator name

Originator CAGE code

Responsible partner company name

Responsible partner company CAGE code

Example:

This is a line representing a data module:

S1000DBIKE, TEMP, DA2, 0, 0, 00, 00, AB, 042, A, A, English US, , , , ,
Temp System,
Temp Description, 01, Description-4-1, ORG Name, ORG41, RPC Name, RPC41

Import the DMRL

1. Go to any folder and choose More Commands  > Import/Export  > Import Content.

2. In the Import Content panel, choose DMRL.

3. In the Import Content panel click Choose File and select the .csv file.

4. Click Import.

The DMRL is imported to the folder you selected or associated with an SNS.

Import a data management requirement list
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4. Using Oxygen XML Editor and Oxygen
XML Author
Overview of using XML Editor and XML Author with Teamcenter

You can open DITA content from Teamcenter in XML Editor and XML Author.

Note:

You can find the supported versions of XML Editor and XML Author in the Teamcenter Integrations
Availability Matrix. For more information, refer to the Hardware and Software Certifications
knowledge base article on https://support.sw.siemens.com.

To do this, you must integrate XML Editor and XML Author with Teamcenter as follows:

• Install the Teamcenter plugin for Oxygen XML.

• Configure XML Editor and XML Author to connect to Teamcenter.

• Ensure that your administrator enables the Open in Oxygen command.

This integration allows you to:

• Open Teamcenter XML topics and data modules in XML Editor and XML Author from Teamcenter.

• Author content in XML Editor and XML Author and save the content back to Teamcenter.

• Create a topic in XML Editor and XML Author.

• Add topic and graphic references in XML Editor and XML Author.

• Remove a topic reference in XML Editor and XML Author.

• Create content references for reuse between DITA topics in XML Editor and XML Author

• Reference a graphic from Teamcenter in XML Editor and XML Author

• Log on to Teamcenter from XML Editor and XML Author.

• Log out of Teamcenter from XML Editor and XML Author.
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Install and configure the integration with XML Editor and XML
Author

Integrate XML Editor and XML Author with Teamcenter by installing the
Teamcenter plugin for Oxygen

To integrate XML Editor and XML Author with Teamcenter, you must install the Teamcenter plugin for
Oxygen on your desktop.

Prerequisites

Ensure that XML Editor and XML Author is already installed on your desktop.

You can find the supported versions of XML Editor and XML Author in the Teamcenter Integrations
Availability Matrix. For more information, refer to the Hardware and Software Certifications knowledge
base article on https://support.sw.siemens.com.

Procedure

1. Download and unzip the Teamcenter-install-kit\additional_applications\oxygen_install.zip file.

Open the oxygen_install folder and run the setup.exe executable.

2. Click Next until you reach the Select Features dialog box.

In the Select Features dialog box, select the Teamcenter Client Communication System (TCCS)
option to install FCC and TCCS.

4. Using Oxygen XML Editor and Oxygen XML Author
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Select this option only if FCC and TCCS do not already exist on your machine or you want a new
instance of FCC and TCCS.

3. Click Next.

4. In the Choose Destination Location dialog box, type or browse to the JRE folder.

You can find supported versions of JAVA in the Teamcenter Integrations Availability Matrix. For
more information, refer to the Hardware and Software Certifications knowledge base article on
https://support.sw.siemens.com.

Click Next.

5. In the Teamcenter FCC Parent Settings dialog box, click Add and type FSC details such as the host
and port values.

Click OK.

Integrate XML Editor and XML Author with Teamcenter by installing the Teamcenter plugin for Oxygen
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6. In the Teamcenter FCC Parent Settings dialog box, verify the FCC parent settings and click Next.

7. Choose the folder where the Teamcenter plugin for Oxygen Editor must be installed.

Click Next.

4. Using Oxygen XML Editor and Oxygen XML Author
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8. In the Start Copying Files dialog box, click Next.

Results

After you finish running the installer, a Teamcenter menu becomes available in XML Editor and XML
Author.

Configure the connection between XML Editor and XML Author and
Teamcenter

You can configure the connection to Teamcenter in XML Editor and XML Author by specifying the
Teamcenter server URL information.

Procedure

1. In XML Editor and XML Author, click Teamcenter> Configure Repository.

2. Type the Teamcenter server URL in the Teamcenter URL box and click OK.

Configure the connection between XML Editor and XML Author and Teamcenter

Content Management on Active Workspace ─ Usage, Teamcenter 2412  4-5
© 2025 Siemens



Configuring schemas in Oxygen

To ensure all users are working with the right schemas, administrators must ensure that the same
schemas that are used in Teamcenter are also accessible in XML Editor and XML Author.

Configure graphic references for working with graphics in XML Editor and
XML Author

You can specify graphic references in XML Editor and XML Author. This definition applies the appropriate
tags for a specific topic type when you paste a graphic reference.

Procedure

1. In XML Editor and XML Author, click Options > Preferences.

2. In the Preferences dialog box, navigate to Plugins > Teamcenter Content Management >
Graphic References.

4. Using Oxygen XML Editor and Oxygen XML Author
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3. To add new graphic references, in the Preferences dialog box, click Add.

4. In the New Graphic Reference dialog box add the following information:

• Document Type

Specifies the publication standard such as Docbook or ATA.

• Root Element

Configure graphic references for working with graphics in XML Editor and XML Author
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(Optional) Specifies the root element of the document where the graphic reference element
schema is applied. If you do not specify the root element the graphic reference element schema
is applied to all documents in the document type.

If your document type has multiple graphic elements, you can use the root element to specify
where the different graphic elements should be used.

• Graphic Reference Element

Specifies the graphic information to be used.

The format of specifying the graphic element data is:

<imagedata image-attribute="attribute-flag"/>

Example:

<imagedata fileref="%f"/>

You can use the following attribute flags

Attribute flag Description
%f Graphic URL of filename
%e Graphic file extension
%s Graphic option system ID

You can use multiple attributes in the graphic reference. Note that at least one attribute must
contain the %f flag.

Uninstall the Teamcenter plugin for Oxygen

You can uninstall the Teamcenter plugin for Oxygen by running the plugin again. Note that if you are
running a new version of the plugin, the plugin is updated and not uninstalled.

Procedure

1. Run the setup.exe executable.

2. In the dialog box that asks if you want to remove the application, select Yes.

3. Click Finish.

4. Using Oxygen XML Editor and Oxygen XML Author
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Author content using XML Editor and XML Author

Log on to Teamcenter from XML Editor and XML Author

To save the changes that you make in XML Editor and XML Author, you must first log on to Teamcenter
from XML Editor and XML Author.

Procedure

1. Choose an option:

• If you are not logged on to Teamcenter and you try to close a topic with changes, a dialog
appears with the Login command. Click the Login command.

• In XML Editor and XML Author, click Teamcenter > Login.

2. In the Teamcenter Login dialog box, type your Teamcenter credentials and click OK.

Results

A confirmation dialog box specifies that the logon to Teamcenter is successful.

Open content in XML Editor and XML Author from Teamcenter

You can open content and its references from Teamcenter in XML Editor and XML Author.

The following topic describes how to open DITA content and its references in Teamcenter.

Procedure

1. Select a DITA topic and click Open > Open in Oxygen.

A file named openinoxygen.awoctm is downloaded on your computer. Depending on how your
browser is configured, this file may automatically launch XML Editor and XML Author. Refer to your
browser documentation on how to automatically open downloaded files.

If XML Editor and XML Author is not launched automatically, click the downloaded
openinoxygen.awoctm file to open XML Editor and XML Author.

2. If the content you are trying to open has children, a dialog box appears, asking if you want to edit
the child or the referenced content.

Log on to Teamcenter from XML Editor and XML Author
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Click Yes if you want to check out this content or No if you only want to check out only the selected
topic type and open the other content in read-only mode.

The topics are checked out and you can start authoring the topics that you have permission for.

Tip:

When you save the topic in XML Editor and XML Author, the topics are checked into Teamcenter. If
you want to continue authoring content without checking in the content after every save action,
you can work in offline mode by logging out of Teamcenter.

When you are ready to check in content, you can log back into Teamcenter.

Check out content from XML Editor and XML Author

You can check out content that is in Teamcenter from XML Editor and XML Author.

Procedure

1. Open a document or topic in XML Editor and XML Author.

2. Click Check-out.

The topic is checked out in Teamcenter.

Cancel a checkout from XML Editor and XML Author

You can cancel a checkout from XML Editor and XML Author.

Procedure

1. Select a topic that is checked out and close the document.

2. Choose an option:

• In the Save dialog box, choose Cancel Checkout.

4. Using Oxygen XML Editor and Oxygen XML Author
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• Click the Cancel Checkout command.

The topic is no longer checked out in Teamcenter.

Add a new topic in XML Editor and XML Author in a DITA map

You can add a new topic In XML Editor and XML Author, under a DITA map that was opened from
Teamcenter.

Procedure

1. In XML Editor and XML Author, open a DITA map, and select File > New.

2. In the New dialog box, choose a topic type, type a title, and choose a location to save the file.

Note that this location must be where the topic map is downloaded.

Add a new topic in XML Editor and XML Author in a DITA map
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3. Click Create.

4. Update the topic and click Save.

Results

The topic is created with a new topic ID. You can search for this topic in Teamcenter.

After creating this topic, you can add this topic as a reference to another topic or topic map.

4. Using Oxygen XML Editor and Oxygen XML Author
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Add a reference to a topic or map in XML Editor and XML Author

In XML Editor and XML Author, you can add a reference to a topic or a map from Teamcenter.

Procedure

1. In Teamcenter, select a topic or map and choose More Commands  > Manage  > Copy As
Reference .

2. Choose an option:

• In the DITA Maps Manager navigation pane in XML Editor and XML Author, right-click a topic.

• Right-click anywhere while working in a topic.

3. Choose an option:

• Paste from Teamcenter > Paste as link

This option adds a link to the referenced item and the topic or map is added in Oxygen.

• Paste from Teamcenter > Paste as xref

This option adds a reference to the topic or map and the topic or map is added in Oxygen.

4. Click File > Save to save the file.

Results

The topic is added to the specified location in the topic map.

Remove a topic reference in XML Editor and XML Author

You can remove a topic reference in a map from XML Editor and XML Author.

Procedure

1. In the DITA Maps Manager navigation pane, right-click the topic reference that you want to
remove and choose Remove Reference(s).

Add a reference to a topic or map in XML Editor and XML Author
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Create content references for reuse between DITA topics in XML Editor and
XML Author

In XML Editor and XML Author, you can reuse content from elements, such as a paragraph, in other
topics by using a content reference (conref).

You can reuse content from elements in other topics either by pasting the reused content as a content
reference or by reusing the content.

Procedure

1. Open the topic containing the source, which is the content you are reusing, and the target, which
is the topic where you want to place the conref.

2. Reuse content in one of these ways:

• Paste the reused content as a content reference.

• Reuse the content.

Results

The conref is created in the target topic.

Reference a graphic from Teamcenter in XML Editor and XML Author

You can paste a graphic that is saved in Teamcenter from XML Editor and XML Author.

Procedure

1. Select a Graphic option revision and choose More Commands  > Manage > Copy As Reference.

2. In XML Editor and XML Author, open the topic in Author mode. Place the cursor where you want to
add the graphic, right-click, and choose Paste from Teamcenter > Paste as Image.

Results

The graphic image is downloaded to XML Editor and XML Author if the graphic image does not exist
there, and a graphic reference is added to the topic at the selected location. Supported topics are DITA
and S1000D. If the editor supports image viewing, the image is visible in the editor after pasting it.

4. Using Oxygen XML Editor and Oxygen XML Author
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Save content from XML Editor and XML Author to Teamcenter without
checking in the content

When working in XML Editor and XML Author, you can save your changes to Teamcenter without
checking in content.

Procedure

1. Update the content in XML Editor and XML Author.

2. Choose an option:

• Click File > Save.

• Close the tab in XML Editor and XML Author and click Save in the Save dialog box.

Check in content from XML Editor and XML Author to Teamcenter

You can check in the document in the following ways:

Procedure

1. Close the document.

2. Choose an option:

• In the dialog box that appears, click Check-in.

• Click the Check-in command.

3. If you have checked out child topics, a dialog box appears, asking if you also want to check in the
referenced content.

Click Yes to check in referenced content or No to check in only the selected topic type.

Log out from Teamcenter from XML Editor and XML Author

You can log out of Teamcenter from XML Editor and XML Author.

Procedure

1. In XML Editor and XML Author, click Teamcenter > Log Out.

Save content from XML Editor and XML Author to Teamcenter without checking in the content
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4. Using Oxygen XML Editor and Oxygen XML Author

4-16  Content Management on Active Workspace ─ Usage, Teamcenter 2412
© 2025 Siemens



5. Creating and editing content using
XMetal
Overview of using an editing tool to create and edit content

The XML content of topics is created and edited in an editing tool. The XMetaL Author editing tool is
supported with Teamcenter.

To use this, you must install XMetaL Author on your local machine and also install the Teamcenter
XMetaL Client.

Caution:

Once you install the Teamcenter XMetaL Client, you will not be able to use the Teamcenter rich
client on your local machine because the Teamcenter XMetaL Client uses its own FMS.

Create and edit content using XMetaL

1. Select or open a topic or a publication and click Open  > Open in XMetaL.

Depending on your browser, the content is downloaded and the Login to Teamcenter dialog box
appears.

2. Log on to Teamcenter.

3. In XMetaL, choose Repository > Check Out Document or in the Resource Manager section,
right-click a topic and choose Check Out Document.

In the XMetaL Author Enterprise dialog box, choose if you want to check out the structure as well.

4. Edit the content in XMetaL.

5. After editing the content, choose Repository > Check In Document.

In the dialog box confirming the change, click Yes.

6. In the XMetaL Author Enterprise dialog box, choose if you want to check in the structure.
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Note:

You can perform other operations in the XMetaL application such as creating a new topic and
publishing the topic. For more information, in the XMetaL application, click Help in the left-side
navigation pane.

5. Creating and editing content using XMetal
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6. Delete a graphic
You can delete a graphic option that is not referenced by any topic. A graphic option contains the
graphic and other associated elements such as translations. Note that you can only delete a graphic
option and not a graphic option revision.

Procedure

1. In Teamcenter, by default, you see the graphic option revision in the Explorer tab.

To get to the graphic option, select the graphic option revision and then click the Where Used tab.

The graphic option is available in the References section.

2. Select the graphic option and then click Open .

3. Select More Commands  > Edit  > Delete .

The graphic and its associated graphic options such as translations and datasets are deleted.

If the graphic is referenced by a topic, the graphic is not deleted and you get an error message.
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7. Importing and exporting content types
Import topics

1. Select or open a topic or a publication and choose More Commands  > Import/Export  >
Import Content.

2. Update the Import Content panel as follows:

For this option Do this

Choose File Select the topics to import.

Graphic Attribute Mapping Select how the graphic file names are mapped:

• Default Graphic Attribute Mapping

Select this option to map the graphic file name as is.

• Default Graphic Attribute Mapping without suffix

Select this option to map a part of the importing graphic
file name, excluding the suffix.

Use this option if file names contain more than one
separator, for example, wheel.right.jpg.

GRAPHIC MODE If the topic contains references to graphics, select one of the
following options to indicate how the topic references the
graphic names:

Note:

You must import the graphics to be referenced before
importing the topic that refers to the graphics. How
these graphics are imported and named determines
which option you choose.

• Public ID

The public identifiers of the graphics are used by the topic
to reference graphics.

• Original Name
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For this option Do this

The original names of the graphics are used by the topic to
reference graphics.

• XML Number

The XML numbers of the graphics are used by the topic to
reference graphics.

• Graphic Name

The names of the graphics with or without the file
extensions are used by the topic to reference graphics.

REUSE EXISTING TOPIC Select the following options to indicate how the import
searches for and handles topics already existing in the
database or if you want to use the ID or XML number of the
imported topic as its item ID in Teamcenter.

Note:

If none of these options are selected, all topics are
imported as new topics, regardless of whether identical
topics or content already exist in the database.

• Find by XML Number

Select this option to search the database for a topic with
the same ID as the ID or XML number of the topics you are
importing. If a topic with the same ID is not found, the ID
or XML number of the topic is used as the ID instead of an
auto-generated ID.

If your documents use content references, you must select
this option to ensure content references are preserved
because content references use item ID/XML numbers.

• Find by Content

Select this option to search the database for topics with
the same content as that in any of the topics you are
importing. When a topic is found with the exact content,
(including tags and attribute values) as the one being
imported, the topic is not imported.

7. Importing and exporting content types
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For this option Do this

Topic content includes attributes, such as a revision. For
example, if you import a topic with the same ID and
choose Find by Content with a change in the revision
attribute in the topic content, Teamcenter creates a new
topic.

3. To assess the impact of the topics and to see what changes will occur, click Preview Impact.

This command generates an impact report that shows the item ID, the item type, the items
impacted by the import, the changes, and an explanation of the changes that will occur.

After the report is generated, you can download it in HTML format. You can access the report in the
Alerts section, and it is also timestamped and saved in the Newstuff folder.

Note:

If you do not see the report in the Alerts section, contact your system administrator to
configure Teamcenter Dispatcher for asynchronous processing.

4. To incorporate the changes shown in the impact preview report, click Import in the Preview
section.

The Import Content panel appears with the options that you selected previously.

5. Click Choose File to reselect the topics to import, and then click Import.

The topics are imported to the folder you selected.

Import graphics

1. Select or open a topic or a publication and choose More Commands  > Import/Export  >
Import Content.

2. Update the Import Content panel as follows:

For this option Do this

CONTENT TYPE Choose Graphic.

Choose File Select the graphics to import.

Graphic Attribute Mapping Select how the graphic file names are mapped:

• Default Graphic Attribute Mapping

Import graphics
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For this option Do this

Select this option to map the graphic file name as is.

• Default Graphic Attribute Mapping without suffix

Select this option to map a part of the importing graphic
file name, not including the suffix.

If file names contain more than one separator, for
example: wheel.right.jpg, use this option.

Graphic Classname Select Graphic.

OVERWRITE MODE Select one of the following:

• Skip existing

The graphics are not imported if they already exist in
Teamcenter.

• Overwrite existing

If the graphics already exist in Content Management, they
are overwritten.

GRAPHIC USAGES Select the relevant option for the graphic based on its
intended use:

If the graphic will be
used for this purpose

Select this option

High-resolution
graphics in printed
output

PDF

Image intended to
appear on a Web
browser

Web

Graphics in a
resolution appropriate
for the printer where it
will be printed

Print

Low-resolution
images, typically for
viewing only

View

7. Importing and exporting content types
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For this option Do this

If the graphic will be
used for this purpose

Select this option

Icons in the published
output

Icon

Small-scale images Thumbnail

Original version of the
graphic

Source

LANGUAGE Select the languages for the graphics being imported.

3. If you want to assess the impact of the graphic and see what changes will occur, click Preview
Import.

This command generates an impact report that shows the item ID, item type, items impacted by
the import, and an explanation of the changes that will occur.

After the report is generated, it is available for download in the HTML format. You can access the
report in the Alerts section, and it is also timestamped and saved in the Newstuff folder.

4. Click Import.

The graphic is imported to the folder you selected.

Export topics

You can export an XML document in order to work with it in another application. When you export a
document, it is saved in a ZIP file.

1. Select or open a topic or a publication and choose More Commands  > Import/Export  >
Export Topic.

2. Update the Export Topic panel as follows:

For this option Do this

Language Select the language you want to use for the exported
content.

CONTENT Select any of the following to choose the contents of the .zip
file:

• Include Main Content

Export topics
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For this option Do this

Includes the XML files for the topic content.

• Include Supporting Data

Includes the schemas for the exported topics.

• Include Graphic Data

Includes the graphics embedded in the topics.

Transformation Policy To apply an XML transformation policy to the content you are
exporting, select the policy from the list.

A transformation policy can be used to modify content
when it is published or exported. For example, it could
convert units of measure, such as US standard to metric.
Your administrator must create a transform policy before it is
available for you to use.

References Select any of the following to choose the content to include
in the export:

• Include Content References

Includes topics that are referenced by the topic or the
publication you are exporting.

• Include Compose References

Includes topics that are referenced by composable
reference relations. Composable topic references are
created by relating topics in Teamcenter. This reference
type is typically used to enable the creation of DITA
Dynamic Maps and publication modules.

GRAPHIC MODE Select one of the following to indicate how the content
references the graphic names:

Note:

• The way you export graphics impacts whether the
references to graphics can be resolved when the
exported content is imported into another system.

• To include graphics in the export, select either
Public ID or Import Original Name. If you select

7. Importing and exporting content types
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For this option Do this

XML Number or Graphic Name, graphics are not
exported.

• These characters are invalid when used in the public
ID or in the original import name of the graphics: /|
~`’,;:\"*?<>. When you export a topic containing
graphics with these characters, they are converted
to an underscore ( _ ).

• Public ID

The public identifiers of the graphics are used by the topic
to reference graphics.

• Original Name

The original names of the graphics are used by the topic to
reference graphics.

• XML Number

The XML numbers of the graphics are used by the topic to
reference graphics.

• Graphic Name

The names of the graphics with or without the file
extensions are used by the topic to reference graphics.

Graphic Priority Select the graphic priority to determine in what order the
topic's graphic options are selected for the output. This is
based on the graphic usage options that you selected when
you imported the graphic.

3. Click Export.

Export topics
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8. Publishing and previewing content
Overview of publishing and previewing content

Publishing allows you to render a topic or publication to a selected output format such as HTML, XHTML,
PDF, or a proprietary format. Along with the output format, the composed XML file is also generated.

When publishing topics and documents, you can choose between the options composed and reviewer
as the output. Composed and reviewer documents contain all the contents of a topic, topic structure,
or publication you select to publish. You can use these to distribute content to subject matter experts
or other reviewers or to retain the compiled XML of the published document for future use. Composed
and reviewer documents contain the same content; they are named differently so that you can choose
an appropriate name for the business practice you are using it for.

When you publish the same content (with the same options) multiple times, the newer versions
overwrite the existing ones. However, if you publish content with a different tool or with one or more
different options, an additional composed or reviewer document is created. These options include Tool,
Language, Translation Version Selection, Style Type, Register Result, and Transformation Policy.

Once published, the artifact is available in the Publications section. Open it to see the list of published
files and associated documents. The rendered documents are available in the Files section, and the
associated documents are available in the References section. The rendered PDF document can be
previewed in the Viewer section.
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The following associated documents are listed in the References section:

• The XML file composed before formatting

• The ZIP dataset containing the composed XML used during publishing

• A log of all specific topics or maps included and their versions

• Configuration context used during publishing

8. Publishing and previewing content
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• DITA values applied to the composed file

• The original topic

Automatically generate PDF or HTML files containing your DITA
topic or data module changes

You can review your changes to a DITA topic or a data module without manually publishing by checking
in the topic or module. The publishing tool configured by your system administrator automatically
publishes a PDF or HTML file.

Procedure

1. Check out a DITA topic or data module and make the required changes.

2. Check in the updated topic or data module from the Explorer section in Teamcenter, or from an
authoring application.

The topic is published, and you get a notification for the published topic in the Alerts section. The
published topic is listed in the Publications section.

Note:

If you do not see the notification in the Alerts section, contact your system administrator to
configure Teamcenter Dispatcher for asynchronous processing.

3. Select the publication and then click Open .

The generated PDF or HTML file is listed in the Files section.

4. Click the file.

The file contents are displayed in PDF or HTML format in the Viewer section in Teamcenter.

Publish a topic

1. Open a DITA topic, topic map, or publication, and navigate to the Content tab, and choose More
Commands  > Share  > Publish Topic.

2. Update the information within Publish Topic as follows:

For this option Do this

Tool Select the publishing tool for the type of output you are
generating. The available tools depend on the tools that

Automatically generate PDF or HTML files containing your DITA topic or data module changes
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For this option Do this

have been installed on your computer and set up in the
system by your application administrator.

Style Type Select the style type (collection of stylesheets) to be used
to publish the content. The style types are set by your
application administrator.

Language Select the language in which to publish the resulting
output.

Compose Version Select the revision rule for the publication. The default
revision rule is the Global revision rule that is selected
from the Revision list in Teamcenter.

Translation Version Select the translated version of the content to be
published when a language other than the master
language is selected:

• Latest Received

The latest received translation in the selected
language is selected for publishing regardless of the
content version in the master language. However, if no
translation exists for the selected language, the master
language is used.

• Match Topic

If the latest content version in the master language
is the same as that in the translation, the translation
is selected for publishing. Otherwise, the master
language is used.

• Received

The latest received translation in the selected
language with a content version older than or as
current as the master language version is selected
for publishing. If all translation content versions are
newer, or if no translation exists for the selected
language, the master language is used. This option
is typically used when you publish an older version
of the content and you do not wish to include
translations that have newer content.

Register Result If you want to create a composed or a reviewer
document, select the type accordingly:

8. Publishing and previewing content
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For this option Do this

• Composed Document

A composed document contains the full content of
the document. It can be exported, sent to publishing
again, or stored as a final document.

• Reviewer Document

A composed document that can be submitted to a
workflow for review.

Transformation Policy To apply an XML transformation policy to the content you
are publishing, select the policy from the list.

A transformation policy can be used to modify content
when it is published or exported. For example, it could
convert units of measure, such as US standard to metric.
Your administrator must create a transform policy before
it is available for you to use.

3. To display the estimated size of the published file before you publish it, select Check to calculate
the estimated size after publish check box.

The size is estimated based on the sizes of the XML content and any included graphic files. This
may be different from the final output size as different file formats have different compression
schemes.

4. In the Schema Validation section depending on how your administrator has setup how publication
should be done based on the schema validation results, a schema validation option will be enabled
automatically or you can select from the following options:

Validation option Result
Publish with validation
errors

Publish the content even if schema validation errors exist. A log is
provided with errors to support correcting content.

Do not publish on
validation errors

If validation errors exist, publish will not complete. A log is provided
with errors to support correcting content.

Publish without
validation

Publish without checking schema validation on content. Publish will
complete unless other errors prevent compilation and publish.

5. Click Publish.

Refresh your browser to see the published results. The published files appear in the Publications section.

Publish a topic
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Open the published files to view the rendered documents and the associated files.

8. Publishing and previewing content
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9. Managing content translations
The content translation process

You can manage the translation of individual topics or topics at any level in a publication structure.
Managing a translation begins with creating a translation order from a selected topic or publication.
You then choose the translation office that performs the translation. Once this is done, you create a
translation delivery to select the languages and create a ZIP file to hold the content to be translated and
any supporting files. You export the ZIP file and send it to the translator. When the content is translated
and returned, you import it back into the system.

If necessary, you can use a Teamcenter workflow to manage translations according to your
organization’s business practices.

Once a translation exists in the system, you can work with a translated topic as you would any other
topic. Each translated topic is related to the original topic in the master language. Content versions are
used to determine if the content has changed since it was translated previously. The content version of
a topic is displayed in the Overview page. When a topic has a translation, you can compare the content
version of the topic to that of the translation to determine if the topic has changed since the topic was
translated.

When creating a translation delivery, you can choose to include the graphics associated with the topics
to be translated.
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Note:

Graphics are not managed the same way topics are during the translation process. Graphic options
have an associated language property. When you edit and publish content in a language other
than the master language, the graphics that match the language are selected. When a graphic
does not exist for the language, the master language graphic option is used.

Create a translation order

The first step in managing the translation process in Content Management is to create a translation
order, which provides information to the translator about the translation service being requested.

1. Open a topic or a publication and choose More Commands  > New  > Create Translation
Order.

2. Update the dialog boxes in the Create Translation Order panel as follows:

For this option Do this

Name Type a name for the translation order.

Title Type a title for the translation order.

Description Type a description for the translation order.

Translation Office Select the translation office responsible for translating this
order.

Your administrator creates the Translation Office.

Requested Delivery Date Click the calendar button, and select the date by which you
want the translation to be returned.

3. Click Create.

The translation order appears in the TRANSLATIONS section of your topic or publication.

The topic or publication and all its children are included in the translation order.

Create a translation delivery to send files to the translator

To deliver content to a translator, you create a translation delivery. It collects all the files that a translator
needs to translate the content within a ZIP file. When you create a translation delivery, the following
objects are created in Content Management:

• Translation delivery, related to the translation order

9. Managing content translations
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• Translations, related to the translation delivery and the original topic

• A ZIP file containing the content to be translated and any selected supporting files, which you can
export and send to the translation company

You can choose if you want to translate the entire content or only the content that has not been
translated or that has not been sent for translation.

To create a translation delivery:

1. Open a translation order and choose More Commands  > New  > Create Translation
Delivery.

2. Update the dialog boxes in the Create Translation Delivery panel as follows:

For this option Do this

Include Select the items to include in the translation delivery .zip file:

• Include Graphics

Includes the graphics that are referenced in the content.

• Include Supporting Data

Includes the schemas with which the XML files can be
validated.

• Include Published Content

Includes related composed documents.

Delivery Select the items that you want to include in the translation
delivery .zip file:

• Deliver Composed Topic

Includes the content in one composed document.

• Deliver Decomposed Topic

Delivers the content as separate topics.

When you select this option, the following options appear:

• Deliver Out-of-Sync Topics Only

Create a translation delivery to send files to the translator
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For this option Do this

Delivers only topics that were modified since the last
translation. Ensure that the content that you will send
for translation is not the same as that of the master
language.

• Deliver Topics Already Out for Translation

Includes all out-of-sync topics, even those that have
already been sent for translation.

If this is not selected, only the topics that have not yet
been sent for translation will be included.

This option is only available when you select the Deliver
Out-of-Sync Topics Only option.

Languages Select all the languages you want the content to be
translated in.

3. Click Create.

The translation order appears in the REFERENCES section of your translation delivery.

The Delivery Type property for the translation delivery is set to Submittal.

Export the translation delivery and send it to the translator

You export the translation delivery ZIP file to a local or a network drive so that you can send the files to
be translated to the translator.

• Open a translation delivery and choose More Commands  > Import/Export  > Export
Translation.

The translation delivery is downloaded through your browser as a ZIP file. Save the translation delivery
and send it to the translator.

The ZIP file contains the content to be translated and any selected supporting files.

Tasks performed by the content translator

When a translator receives the translation delivery as a ZIP file, it contains the following:

• A .txt file listing the topics to be translated and the languages they are to be translated in.

9. Managing content translations
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• The ...original folder containing the topics (as XML files) to be translated in the master language.

• The ...translated folder as a placeholder for the translated topics.

• The ...translationSource folder containing the topics to be translated.

• The ...supportingData folder containing the schemas with which the XML files can be validated.

• The ...graphics folder containing the graphics referenced in the content, if graphics were included in
the translation order when it was created.

The translation process is as follows:

1. The translators translate the topics in either the translated\decompose or the
translated\compose folder. If both the decompose and compose folders were included in the
delivery, they delete the one that they are not using.

The topics are edited using an editing tool. These files may be validated with the respective
schemas included in the translation order.

2. When the translation of the files is completed, they create a ZIP file with the same organization
structure as the original ZIP file and with the translated content in the appropriate objects and
folders.

3. Once completed, the send the ZIP file back to the appropriate Content Management user.

Import translated content

When you receive translated files from the translator, you import the translated data into Content
Management. The translations can then be tested by previewing or publishing them in the appropriate
language.

1. Open a topic or publication and choose More Commands  > Import/Export  > Import
Translation.

2. In the Translation panel, click Choose File and choose the ZIP file that contains the translated
content.

Note:

The ZIP file from the translator must contain the original folder structure of the translation
delivery and the translations results present in the translated folder.

3. Click Import.

Import translated content
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The translation is associated with the translation order in the References section, and the Delivery Type
property value changes to Delivery from the value Submittal.

9. Managing content translations
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