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1. Getting started with Design Context
Getting started with Design Context

Repeatable Digital Validation (RDV) allows a designer to accurately model specific product assembly
configurations and use the results with analytical and visualization tools to facilitate learning and
decision making.

The Design Context application allows the user to quickly focus on a particular work part in the RDV
environment and any other parts affected within the context of a change to that part.

When you have identified your parts, you can view them in the embedded viewer in Structure Manager
or a CAD tool or send them to Lifecycle Visualization. You can also perform clearance analysis in
Structure Manager or Lifecycle Visualization. Design Context also interoperates with Platform Designer
to manage changes to the design solutions in the product.

Before you begin

Prerequisites The Design Context user must have read access to the program node and
product structure.

Enable Design Context Design Context does not need to be enabled before you use it, but during
installation, the cacheless search engine option must be selected.

If you have trouble accessing Design Context, see your system administrator;
it may be a licensing issue.

Note:

You can log on to Teamcenter only once. If you try to log on to more
than one workstation at a time, you see an error message.

Configure Design
Context

Before using Design Context, you must:

• Configure cacheless search. For details, see Structure Indexing Using
Cacheless Search.

• Set the RDV and Design Context options, as described in Setting Design
Context options.

Start Design Context Click Design Context  in the navigation pane.
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Design Context interface

Design Context interface

The Design Context interface comprises the following windows.

Context Definition window Allows you to define the context for your session.

For more information, see Context Definition window.

Configure Work Part Context
window

Allows you to configure the work part context with revision rules
and variant rules.

For more information, see Configure Work Part Context window.

Configure Filter window Allows you to search the product context using background part
appearances you create by applying a combination of zone,
proximity, and part attribute search filters.

For more information, see Configure Filter window.

Context Definition window:
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1 Product Items pane Lists all product items available. These are items that
represent the product, as defined by the product item
properties preferences.

2 Selected Product Contexts pane Shows the available product contexts for the
selected product item. Product item revisions that
are grouped into product contexts, as defined
in the PortalDesignContextProductContextProperties
preference.

3 WorkParts pane Allows you to enter the target work parts (optional).

4 EngChange Revision Allows you to enter an engineering change (EC) revision.
This action automatically populates the Work Parts list with
work parts associated with the EC revision.

5 Processes Allows you enter a workflow process ID. This action
automatically populates the Work Parts list with work parts
associated with the workflow process.

Configure Work Part Context window:

Design Context interface
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1 Select Revision Rule box Allows you to apply a revision rule to the product context
selected in the first window.

2 Set Variant Rule button Allow you to apply a variant rule to the product context.
The variant rule is applied to the target and background
parts. Do not apply a variant rule if you use the valid
overlays only option.

3 Part Appearances pane Shows the currently configured work part appearances.

Configure Filter window:

1 Zone Filter pane Allows you to filter the product context by selecting a zone
filter (bounding box or a plane zone).

2 Attribute filter pane Allow you to filter the product context by selecting an
attribute filter.

3 Proximity menu Allows you to filter the product context by selecting a
proximity filter. Target BOM lines must be displayed in the
Target Part Appearances pane. You can refine the search
by selecting Valid overlays only, Append parts, and True
shape filtering, if appropriate.

1. Getting started with Design Context
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4 Target Part Appearances pane Shows the target parts.

5 Target Part Installation
Assemblies pane

Shows the target installation assemblies.

6 Background Part Appearances
pane

Shows the background parts.

7 Background Part Installation
Assemblies pane

Shows the background installation assemblies.

Design Context uses the Teamcenter rich client interface. For general information about the rich client
interface, refer to Teamcenter Basics.

Context Definition window

The Context Definition window displays when you first launch the Design Context application and
allows you to define the context for your session. This window is sometimes called the first window of
the Design Context application.

Element Description

Selected Product
Contexts list

Displays the product contexts available for the selected product item.

Note:

You can also drag a product context object from another
application such as My Teamcenter or Structure Manager and drop
it onto Design Context.

Product Items tab Displays product items available in the database. Design
Context searches the database according to the setting of the
PortalDesignContextProductItemProperties preference. You can search
in all product contexts.

Find tab Displays a saved query form used to locate product items.

Work Parts box Specifies an item ID for locating work parts. The matching work parts are
listed below this box in the Work Parts list.

Work Parts list Displays the items found by entering a work part item ID in the Work
Parts box.

EngChange Revision box Specifies a change ID or search string for locating engineering changes.
The matching engineering change revisions are listed below this box in
the EngChange Revision list. This action also populates the Work Parts
list with the work parts associated with the added engineering changes.

Context Definition window
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Element Description

EngChange Revision list Displays the added engineering changes in addition to those associated
with the added work parts or workflow process.

Processes box Specifies a process ID or search string for locating workflow processes.
The matching workflow processes are listed below this box in the
Processes list. This action also populates the Work Parts list with the
work parts associated with the added workflow processes.

Processes list Displays the added workflow processes, as well as those associated with
the added work parts or engineering changes.

The following buttons appear three times, once for each of the work parts, engineering change
revision, and workflow processes lists.

Add button Appends the specified item revision, change object, or workflow process
to the list.

Replace button Replaces the selected item revision, change object, or workflow process
with one specified in the text box corresponding the list.

Remove button Removes the selected entry from the list.

Configure Work Part Context window

Use the Configure Work Part Context window to select and configure appearances of work parts. This
window is sometimes called the second window of the Design Context application.

Element Description

Select Product Context
box

Displays the product contexts selected in the Context Definition
window. If there is more than one context, choose the appropriate
context from the list.

Select Revision Rule box Displays all revision rules in the database associated with the selected
product context. You can select one of these rules from the dropdown list
to configure appearances of work parts for the selected product context.

Set Variant Rule button Displays the Variant Rule dialog box that allows you to set a variant rule
for the selected product context to configure the work part appearances.

Part Appearances list Displays the work part appearances, configured by the combination of
product context, revision rule, and variant rule.

Installation Assembly list Displays the installation assemblies in which the work parts appear.

1. Getting started with Design Context
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Configure Filter window

Use the Configure Filter window to configure background part appearances by applying a combination
of zone, proximity, and part attribute search filters. This window is sometimes called the third window of
the Design Context application.

Element Description

Product Context
title area

Displays the configuration selected in the Configure Work Part Context
window, including the date and time that the corresponding cache was last
updated. The selected revision and variant rules are also shown.

Append check box If checked, the results of filtering for background part appearances in this
window are added to the existing set of background appearances.

Valid Overlays
Only check box

Disables loading of otherwise physically mutually exclusive background
parts and target parts. Teamcenter automatically filters out those matching
background parts known to never coexist in any possible variant combination
with any one of the target appearances.

Proximity filter Defines the physical distance around the work part appearance within which
background part appearances are selected.

Zone filter table Specifies the zone within the assembly to filter the background part
appearances. Zones are created in the NX top-level CAD model and can be box
zones or plane zones.

Attribute filter
table

Specifies the NX part attributes used to filter the background part appearance
queries.

Target Part
Appearances

Displays the target part appearances based on the designated filters.

Target Part
Installation
Assemblies

Displays the installation assemblies associated with the target part appearances.

Background Part
Appearances

Displays the background part appearances related to the target parts, based on
the settings of the zone, proximity, attribute, and other filters.

Background
Part Installation
Assemblies

Displays the installation assemblies associated with the background part
appearances.

Clear button Clears the displayed search criteria, allowing you to enter new ones.

Back button Returns to the Configure Work Part Context (second) window.

Update button Initiates a search for work part appearances based on the filter settings. When
the search is complete, you can send the configuration to Structure Manager

Configure Filter window

Design Context, Teamcenter 2412  1-7
© 2025 Siemens



Element Description

for viewing or analysis in the embedded viewer, NX, or a Lifecycle Visualization
application.

Remote search
check box

If you work in a Multi-Site Collaboration environment, includes remote sites
identified by the site administrator in the search.

What are perspectives and views?

Within the rich client user interface, application functionality is provided in perspectives and views.

View The basic display component that displays related information in a UI window.

Perspective A collection of one or more views and their layout.

Some applications use a perspective with multiple views to arrange how functionality is presented.
Other applications use a perspective with a single view.

You can use the HiddenPerspectives preference to prevent the display of some Teamcenter perspectives
in the rich client.

If your site has online help installed, you can access the application and view help from the rich client
Help menu.

Design Context menus

Design Context menus

Note:

Your administrator can show or hide menu commands using Command Suppression. This guide
contains information about all menu commands that are available when the system is delivered.

For more information about Command Suppression, see Teamcenter Administration.

For information about the Window menu, see Teamcenter Basics.

File menu

Menu command Purpose

New→Zone Creates box and plane zones that are used to define search zones.
Box and plane zones are based on predefined form types shipped with
Teamcenter. You can search parts that are above, below or intersecting

1. Getting started with Design Context
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Menu command Purpose

a plane; likewise, you can search parts that are inside, outside, or
interfering with a box.

Save PLMXML Saves the currently active context (top-level item revision and configured
BOM lines) to a PLM XML file.

Open in Lifecycle
Visualization

Opens the configured work parts and background parts in Lifecycle
Visualization.

Open in NX Opens the configured work parts and background parts in NX.

Save Structure Context
Object

If chosen from the first window, saves the current structure context
(current work parts and the active product item revision) to the active
context object.

If chosen from the second or third window, saves the current revision
rule and variant rule in the modified form to the structure context object
(SCO). The SCO also contains information from the first window.

If chosen from the third window, all filters used in the last search are
saved to the SCO. The SCO also contains information from the first and
second windows.

Save Structure Context
Object As

Saves the contents of the currently loaded SCO to a new SCO, including
any changes to work parts, revision rule, variant rules, and filters made in
the current Design Context session.

Close Closes Design Context and optionally saves your settings, including:

• Selected product contexts, work parts, and change objects.

• Revision rules and variant rules.

• The last five proximity, zone, and attribute filter settings.

Exit Exits the rich client and all applications that are running in the session.
You can optionally save your Design Context settings, including:

• Selected product contexts, work parts, and change objects.

• Revision rules and variant rules.

• The last five proximity, zone, and attribute filter settings.

File menu
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Edit menu

Menu command Purpose

Copy Allows you to copy selected objects (BOM lines) and paste them
into another application such as Structure Manager or Multi-Structure
Manager. For example, you can copy selected installation assemblies and
paste them into Structure Manager as a private assembly. This command
is disabled in the first window of the Design Context application.

Cut Allows you to remove selected objects (BOM lines) and paste them
elsewhere.

Delete Removes selected objects (BOM lines).

Remove Design from
Product

Removes a selected CAD design from an installation assembly. This
command is used only when your site utilizes Platform Designer.

Replace Design in
Product

Replaces a CAD design in an installation assembly attached to
an architecture breakdown element with another CAD design. This
command is used only when your site utilizes Platform Designer.

User Settings Displays the User Settings dialog box, allowing you to view, define and
change settings for a group, role, project or volume. You can also enable
or disable application logging and journaling, if you have the appropriate
privileges.

Options Configures your Design Context session. You can show or hide the
properties displayed for product contexts or product items. You can also
set general options, including search and interoperability settings, and
edit Teamcenter preferences.

For more information, see Set general options.

View menu

Menu command Purpose

Show Unconfigured
Variants

Shows or hides variants that are not configured by the current options.

Show Unconfigured By
Date

Shows or hides components that are not configured by the set date
(occurrence date effectivity).
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Tools menu

Menu command Purpose

Revision Rule→View/Set
Current

Allows you to view or set the revision rule for the currently displayed
structure. This command is available only in the first window.

Revision Rule→Set Date/
Unit/End Item

Sets the date, unit number, or end item in the current revision rule to
configure the structure.

Revision Rule→Set
Override Folder

Sets an override folder to configure the structure, if the current revision
rule allows.

Revision Rule→Modify
Current

Modifies the current revision rule and apply the modified rule to the
current structure. You can save the change if you have write access to the
original rule. This command is available only in the first window.

Revision Rule→Create/
Edit

Creates or edits a revision rule. This command is available only in the first
window.

Export Configured NX
Assembly

Displays the Export Configured NX Assembly dialog box. This command
allows you to export NX part files corresponding to the selected BOM
lines in Design Context. It allows you to specify the name of the
directory in which to place the compressed file of exported NX parts.
This command is available only in the Configure Filter window.

Clearance Analysis Allows you to view stored clearance analysis results for previous
clearance analysis processes. To use this command, integrated clearance
management (ICM) must be installed and the clearance database
configured for background clearance calculations.

It also allows you to request a real time clearance analysis of a selected
set of parts or to view clearance analysis results for previous real time
requests. To use this command, integrated clearance management (ICM)
must be installed and the clearance database configured.

For more details, see Performing clearance analysis and proximity
filtering.

Design Context buttons

Button Purpose

Soft abort If enabled, allows you to terminate the current
operation without closing Design Context or losing
data.

Copy Copies a workspace object reference from the Design
Context application onto the clipboard.

Tools menu
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Button Purpose

Paste Moves a workspace object reference from the clipboard
into the Design Context application.

Start/Open in NX Opens the configured work parts and background parts
in NX.

Replace Design in
Product

Replaces the selected design in the product structure
with another design. Use this button only when your
site utilizes Platform Designer.

Start/Open in Lifecycle
Visualization

Opens the configured work parts and background parts
in Lifecycle Visualization.

Ad-Hoc Configuration Allows you to configure a Design Context session
by retrieving a PLM XML dataset sent from My
Teamcenter.

Synchronize with
Structure Manager

Synchronize the configured work and background parts
with Structure Manager. You can visualize the selected
components in the embedded viewer and they are also
highlighted in the Structure Manager properties view.

Send to NX Allows you to launch the PLM XML file created by
the ad-hoc functionality directly in NX, rather than
needing to interoperate using Lifecycle Visualization.
This button is available only in the second and third
windows.

Basic concepts

Design Context allows you to make fast searches for background parts within a certain proximity that is
defined by filters. To obtain search results, you follow this process:

• Select a product item.

• Configure revisions of components.

• Configure variants of the assembly.

• Review the set of target components.

• Apply filters to retrieve the background components.

• Initialize the display of components in the embedded viewer in Structure Manager, CAD or Lifecycle
Visualization.
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• Save the current session to a structure context object (SCO) for subsequent retrieval in Design
Context, NX, or a Lifecycle Visualization application.

Basic tasks

Use Design Context to perform the following basic tasks:

• Create box zones and planes. Use box and plane zones to filter and refine searches for target parts.

For detailed information, see Creating box and plane zones.

• Define product context and work parts to work on in the current session. Define the context for a
design or design review session by defining the list of work parts and the product context within
which these parts are configured.

For detailed information, see Defining product context and work parts.

• Configure work part appearances. Narrow the focus of your search by applying revision rules and
variant rules to configure the appearances of the parts within the product context.

For detailed information, see Managing work part appearances.

• Filter part appearances. Filter the background part appearances for the target work parts You can
filter background part appearances by proximity to the work part, component attributes, filters,
Classification filters, saved query filters, plane or box zone based filters or occurrence notes filters.

For detailed information, see Filtering part appearances.

• Work with parts in the defined context. After you configure the context for the work parts that are the
focus of your design or design review session, you can open the entire context in NX or a Lifecycle
Visualization application.

For detailed information, see Working with parts in the defined context.

• Manage changes to the product. Replace components in the product.

For detailed information, see Managing changes to the product.

• Perform clearance analysis and proximity filtering or view results. Perform clearance analysis in the
stand-alone Lifecycle Visualization application or the embedded viewer.

For detailed information, see Performing clearance analysis and proximity filtering.

• Create a structure context object (SCO) containing a saved virtual product context configuration and
replicate it at remote sites.

Basic tasks
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For detailed information, see Step 4: Save product configuration as a structure context object
(optional).
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2. Setting Design Context options
Setting Design Context options

You can set Design Context options to match your company's business practices. When you choose
these options from the Edit menu, Teamcenter displays the Options dialog box allowing you to modify
relevant preferences.

Note:

In addition to setting these options, you must set the Design Context preferences listed in the
Administration Data Report before starting work with Design Context.

Set general options

1. Choose Edit→Options.

Teamcenter displays the Options dialog box.

2. In the dialog box, expand the Design Context folder and select the General item.

Teamcenter displays the General options on the right of the dialog box.

Menu command Purpose

Automatically determine
Variant Rule set if a
maximum of ___ Target
Appearances

Specifies the maximum number of target appearances for the Valid
Overlays Only check box in the Filter Configuration window. This
option limits the processing time Teamcenter spends determining
and evaluating the set of variant rules configuring a set of target
appearances.

Automatically determine
Variant Rule set if
a maximum of ___
Relevant Options

Similar to the previous option, specifies the maximum number of relevant
options.

Maximum Number of
Matches Allowed ___
Wildcard Searches

Specifies the maximum number of items, for example, work parts,
change objects, or change request jobs, that a query can match. Input
provided in the Context Definition window can cause new objects to be
loaded. If you enter wildcard characters in these boxes when performing
a product item search, response times may be unacceptably long.

Maximum Number of
Matches Allowed ___
Structure Manager
Searches

Specifies the maximum number of assembly components that a Design
Context search can match. Input provided in the Context Configuration
window or Filter Configuration window can cause new objects to load.
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Menu command Purpose

If you enter wildcard characters in these boxes, response times may be
unacceptably long.

Product Structure
Interoperability Options

You can set the following options separately for interoperability with CAD
and Lifecycle Visualization:

• Prune Tree

Makes branches of the structure that do not contain any components
invisible to the application into which the context is loaded. This is
essential for extremely large structures, as it decreases load time.

• Suppress Components

Used in conjunction with Prune Tree to suppress the loading of
potential structure lines components other than those explicitly
selected. This is beneficial, because you may not know that the
selected structure line is, for example, an assembly with 180,000
components.

• Hide Components

Used in conjunction with Prune Tree to load, but not display, the
components of a selected assembly.

Show “Open in Structure
Manager” Command

Shows or hides the Interoperate with Structure Manager button .

Select Search Engine
for Product Structure
Searches

Shows the currently selected search engine (cacheless search) and
should not be changed.

Refine Cacheless Search Select the Use True Shape search check box to search with TruShape
data as well as bounding box data.

Structure Context Object
entries

You can set the following options separately to configure how
Teamcenter handles structure context objects:

• Include newly added Component Instance

Select to include any newly added structure lines when a context
object is reloaded.

• Automatically synchronize and prune DesignContext selections
with Structure Manager

2. Setting Design Context options
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Menu command Purpose

Select to enable automatic synchronization and pruning if you
interoperate with Structure Manager.

3. After you set the general options, click Apply to apply the options to your current session and
retain the Options dialog box. Alternatively, you can click OK to apply the options to your current
session and close the dialog box.

Set product context property options

To arrange the product context properties in the table of selected contexts in the Context Definition
window:

1. Choose Edit→Options and Teamcenter displays the Options dialog box.

2. In the dialog box, expand the Design Context folder and choose Product Context. Teamcenter
displays the Product Context options on the right of the dialog box.

3. Define the list of displayed properties by moving them between the Shown and Hidden lists. Select
a property in the list and click the left-arrow or right-arrow button to move it from one list to the
other.

4. Optionally, define the display order of the properties by selecting a property and clicking the
up-arrow or down-arrow. The property at the top of the Shown list is the furthest left in the table
display.

5. Click Apply to apply the options to your current session and retain the Options dialog box.

Click OK to apply the options to your current session and exit the dialog box.

Set product item property options

When you set product item property options, you select the properties to display in the table of selected
product items in the Context Definition window and the order in which they are displayed:

1. Choose Edit→Options and Teamcenter displays the Options dialog box.

2. In the dialog box, expand the Design Context folder and select the Product Item item. Teamcenter
displays the Product Item options on the right of the dialog box.

3. Define the list of displayed properties by moving them between the Shown and Hidden lists.
Select a property in the list and click the left-arrow or right-arrow button to move it from one list to
the other.

Set product context property options
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4. Optionally, define the display order of the properties by selecting a property and clicking the
up-arrow or down-arrow. The property at the top of the Shown list is the furthest left in the table
display.

5. Click Apply to apply the options to your current session and retain the Options dialog box.

Click OK to apply the options to your current session and dismiss the dialog box.

Enable search result synchronization with Structure Manager

You can optionally synchronize search results shown in Design Context to Structure Manager and
any structure lines that are selected in Design Context are also highlighted in Structure Manager.
You can enable this automatic synchronization by setting the DesignContext_PSE_Synchronization
preference to True. If synchronization is enabled, the status bar continuously shows the status of the
synchronization process. If you enable this option, performance when working in large assemblies may
be adversely affected.

By default, this is a user preference; you can modify it for the current session by changing the
Automatically synchronize and prune DesignContext selections with Structure Manager option.

For more information, see Set general options.

Note:

Any siblings of the structure lines shown in Design Context are not initially shown in Structure
Manager to allow quicker loading.

2. Setting Design Context options
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3. Defining product context and work parts
Defining product context and work parts

Defining product context and work parts

The first step in configuring the context of a design or design review session is to define the product
context. You select the product context in which the work part appearances are configured from a
predefined list of product items. You can select product items from the Product Items tab. In addition,
you can optionally select particular work parts, an engineering change or a Workflow process to narrow
the scope of the search.

If you use the cacheless search mechanism, you can refine the search and potentially limit the number of
matches by configuring the structure with a revision rule. You can do this in one of two ways:

• Choose Tools→Revision Rule→View/Set Current on the first window.

• Click the Set Revision Rule  button on the second window.

Teamcenter displays the View/Set Current Revision Rule dialog box, allowing you to select and apply
one of the defined revision rules. The selected revision rule is shown in the status bar of the second
window.

Step 1: Select product context (product items)

1. From the Product Items tab located in the upper-right corner of the Context Definition window,
select one or more product items.

The number of product items displayed in the table is determined by preferences set by your
administrator. If you do not see the item you are looking for, use the Find tab to locate the item, as
follows:

a. Click the Find tab.

Teamcenter displays a saved query form, as defined by your administrator.

b. Type search criteria to locate the product item.

c. Execute the query by doing one of the following:

• Click the Add (+) button to execute the query and add the product items found to the
Selected Product Contexts list.

Design Context, Teamcenter 2412  3-1
© 2025 Siemens



• Click the SetList button to clear the contents of the Product Items list, execute the query
and display the query results in the Product Items list.

• Click the Append button to execute the query and append the results to the Product Items
list.

2. Click the Add (+) button, and Teamcenter adds the selected product items to the list of product
contexts. You can also double-click individual lines to add the corresponding product items to the
list.

Step 2: Select work parts

Step 2: Select work parts

You can use engineering change management and Workflow processes to help define the work parts
list. You can automatically populate the work parts list with the item revisions referenced by a Change
Management object such as a change order, by specifying its identifier. Similarly, you can automatically
populate the work parts list with the item revisions referenced by a workflow process by specifying its
name. You can also select item revisions in other Teamcenter applications and send or copy and paste
them into Design Context.

Optionally, use one of the methods described next to select the specific parts to be the focus of your
session.

Copy and paste objects from My Teamcenter

1. Select one or more item revisions or change objects in the My Teamcenter navigation tree or
Properties table and choose Edit→Copy. Teamcenter copies the objects to the clipboard.

2. Switch to Design Context and choose Edit→Paste. Teamcenter pastes the item revisions into
the WorkParts list. Changes are pasted into the EngChange Revision list and the item revisions
associated with the changes automatically populate the WorkParts list.

Tip:

To copy and paste a single item revision or change object, right-click the object, and choose Copy.

Enter an item revision ID or search string in the WorkParts box

1. Type an item revision ID or partial ID and wildcard (*) character in the WorkParts box located in the
lower-left corner of the Context Definition window.

2. Press the Enter key or click the add (+) button.

3. Defining product context and work parts

3-2  Design Context, Teamcenter 2412
© 2025 Siemens



If you enter an item revision ID, Teamcenter displays the item revision in the WorkParts list,
and any changes or processes that reference the item revision in the EngChange Revision and
Processes lists.

If you type a search string, Teamcenter displays all matches for the item revision ID, along with the
corresponding changes and processes.

Enter a change ID or search string in the EngChange Revision box

1. Type an change ID or partial ID and wildcard (*) character in the EngChange Revision box located
in the bottom-center of the Context Definition window.

2. Press the Enter key or click the add (+) button.

If you enter a change ID, Teamcenter adds the change object to the EngChange Revision list, and
any item revisions or processes referenced by the change object are displayed in the WorkParts and
Processes lists.

If you type a search string, Teamcenter displays all matches for the change object, and the
corresponding item revisions and processes. If the change references revisions of Product Items,
Teamcenter automatically adds them to the Selected Product Context list.

Enter a Workflow process ID or search string in the processes box

1. Type the name of a workflow process or partial name and wildcard (*) character in the Processes
box, located in the lower-right corner of the Context Definition window.

2. Press the Enter key or click the add (+) button.

If you enter a process name, Teamcenter adds the process object to the Processes list, and any objects
targeted by the process are displayed in the WorkParts and EngChange lists.

If the process references revisions of Product Items, Teamcenter automatically adds them to the
Selected Product Context table.

Step 3: Edit the WorkParts list

Step 3: Edit the WorkParts list

• If you performed a search in step 2, it may be necessary to edit the WorkParts list to remove or
replace entries.

Remove entries from the WorkParts, EngChange Revision or Processes list

• Select the entries and click the Remove button.

Enter a change ID or search string in the EngChange Revision box
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Note:

Because work parts, changes, and processes are related, removing an entry from one list
automatically removes the corresponding entries from the other lists.

Replace an entry in the WorkParts, EngChange Revision, or Processes list

1. Type the exact identifier of the replacement item revision, change object, or process.

2. Select the entry in the list that is replaced by the specified object.

3. Click the Replace button.

Step 4: Save product configuration as a structure context object (optional)

Step 4: Save product configuration as a structure context object (optional)

Once the product context and work parts are configured, you can save it as a structure context object
(SCO). An SCO stores the definition of a virtual product context configuration in the Teamcenter
database, including the search filter criteria and results. Storing the product context configuration in
this way after defining it once in Design Context avoids the need to configure the same product context
each time you or another user wants access to the same session context configuration. You can share an
SCO with other users at the same site or you can replicate it at remote sites.

How you save the SCO depends on the basis of the current session.

If the current session is based on an
existing SCO:

If the current session is not based
on an existing SCO and is not in the
context of an engineering change:

If the current session is not based on
an existing SCO, but is in the context
of a change:

Choose the File→Save Structure
Context Object menu command, and
the existing SCO is updated with the
changes you made during the session.
Current work parts and the active
product item revision overwrite any
existing work parts and product item
revisions previously stored in the SCO.

Note:

To save any changes to revision
rules and variant rule, choose
this menu command from the
second window of the Design
Context application.

Store changes in a new stand-alone
SCO, as follows:

1. Choose the File→Save
Structure Context Object
menu command.

Teamcenter displays the Save
Structure Context Object
dialog box.

2. In the dialog box, type a name
and description for the new
SCO.

3. Select the type of SCO you want
to create from the Type list.

Store changes in a new SCO in a pseudo
folder, as follows:

1. Choose the File→Save Structure
Context Object menu command.

Teamcenter displays the Save
Context Object As dialog box.

2. Type a name and description for
the new SCO and click OK.

Teamcenter stores the changes
you made during the session in a
pseudo folder.

3. Defining product context and work parts
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If the current session is based on an
existing SCO:

If the current session is not based
on an existing SCO and is not in the
context of an engineering change:

If the current session is not based on
an existing SCO, but is in the context
of a change:

Note:

The list includes all SCO
types defined in the
system, some of which
may be inappropriate for
saving an RDV context
object.

4. Store the SCO on the clipboard,
in your Newstuff folder, or both
by selecting the appropriate
check box.

5. Click OK or Apply to store the
changes in the database as a
new stand-alone SCO.

Note:

The name of pseudofolder
is defined in the
DesignContextRDVContex
t ObjectAddToECObject
Pseudo FolderPreference
preference. If this
preference is set, the SCO is
saved directly to the
pseudofolder. If this
preference is not set, you
can choose to store the SCO
on the clipboard, in your
Newstuff folder or both, as
before.

Note:

Saving the SCO also saves the search criteria so that the search can be replayed at a later date. The
search criteria are saved regardless of whether you have previously run the search.

Open a stored structure context object

• Open the stored structure context object (SCO) that you saved, and then paste it to Design Context
or use the Send To command from another application, for example, Multi-Structure Manager.
Alternatively, you can paste a folder, mail envelope, or change object containing a stored context
object. Choose SCO Evaluation Dynamic to update the contents of the SCO with any changes or SCO
Evaluation Static otherwise.

Teamcenter opens the stored SCO, launches the configured context in Design Context, applies the
stored search filter criteria, and opens the structure in the first window of the application.

Note:

SCOs can be replicated by remote sites to your location, as well as being shared between users at
your site. Likewise, you can replicate SCOs to remote sites.

Create a new structure context object from an existing structure context object

If the current session is not in the context of an engineering change:

1. Choose File→Save Structure Context Object As.

Open a stored structure context object
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Teamcenter displays the Save Context Object As dialog box.

2. In the dialog box, type a name and description for the new SCO. Store the SCO on the clipboard, in
your Newstuff folder, or both by selecting the appropriate check box, then click OK.

Teamcenter stores the changes you made during the session to the database in a new standalone
SCO.

If the current session is in the context of an engineering change:

1. Choose File→Save Structure Context Object As.

Teamcenter displays the Save Context Object As dialog box.

2. Type a name and description for the new SCO and click OK.

Teamcenter stores the changes you made during the session in a pseudofolder.

Note:

The name of pseudofolder is defined in the
DesignContextRDVContextObjectAddToECOObjectPseudo FolderPreference preference.
If this preference is set, the SCO is saved to the named pseudofolder. If this preference is
not set, you can choose to store the SCO on the clipboard, in your Newstuff folder, or both.

After you complete defining the product contexts and work parts, click Next to proceed to the Configure
Work Part Context window.

Search remote sites

If you work in a Multi-Site Collaboration environment, you can optionally include products or programs
that are mastered or replicated at other sites in the search.

1. In the Search Panel (third window), select the Remote search check box to include other sites in
the scope of the search in addition to the other search criteria.

2. Click Update to run the search.

If the search finds remote BOM lines that are not replicated at the local site, Teamcenter displays a
number remote bomlines found. Do you want to import? dialog box.

3. Optionally, click More... in the dialog box to display a list of the remote lines found.

4. To import the remote lines, click Yes in the dialog box.

Teamcenter displays an Import Remote dialog box that shows details of the lines to import.

3. Defining product context and work parts
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5. Click All and then click OK to import all the remote lines.

Alternative, you can click None and then click OK to not perform an import of the remote lines.

You must have permissions to the remote site and the selected objects to successfully complete the
import action.

Note:

The remote sites to search are configured in the QS_remote_master_site and
QS_remote_master_site_override preferences.

Search remote sites
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4. Managing work part appearances
Managing work part appearances

After you define the product context and work parts that are the focus of your session, you can narrow
the focus even further by applying revision rules and variant rules to configure the appearances of the
parts within the product context.

Product configuration specialists define revision rules containing parameters that determine the revision
of the product item against which the work part appearances are configured. You apply these revision
rules to (for example) select working revisions. You can also select revisions by specific status (according
to status precedence) or select the latest revision with any status (by date released). For detailed
information about revision rules, see Structure Management on Rich Client ─ Usage.

Variant rules are collections of option values that configure a particular variant of the selected revision
of the product context. For detailed information about variant rules, see Structure Management on Rich
Client ─ Usage.

Note:

Siemens Digital Industries Software recommends that NX users who author CAD models work with
an overlay of all physically mutually exclusive variants, rather than applying variant rules. This
avoids unintentionally unconfiguring components relevant to the session.

Configuring work part appearances

After you define the product context and work parts that are the focus of your session, you can use
revision rules and variant rules to configure the work part appearances within the product context.

Initially, the Part Appearances list in the Configure Work Part Context window displays the product
structure lines corresponding to the appearances of the work parts defined in the Context Definition
window. Additionally, the Installation Assemblies list displays the lines of the installation assemblies,
if applicable, that correspond to the part appearances. These lists change dynamically to reflect the
application of revision and variant rules, depending on how you configure work part appearances.

Configure work part appearances

1. From the Select Product Context list, select the product context for which you want to configure
the work part appearances. This list represents the product items that you added to the Product
Contexts list in the Context Definition window. Selecting a product context limits the search for
work part appearances to those found in the assembly corresponding to this product context.

2. Select a revision rule that corresponds to the selected product context. Selecting a revision rule
further limits the search for appearances of the previously defined work parts by searching only
revisions of the product item that fit the criteria established in the revision rule.
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3. Optionally, click the Set Variant Rule button to apply variant rules to configure the work part
appearances.

When applying variant rules, some components may no longer be valid within the product
context. If a displayed component is not selected by the new variant rule, Teamcenter removes
the component, and potentially other related components.

4. Click the Next button to proceed to the Configure Filter window.

4. Managing work part appearances
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5. Filtering part appearances
Filtering part appearances

After you define the product context and configured the work parts list, you can filter the background
part appearances to include in your session. Filtering out unrequired part appearances improves
response times and makes it easier to interpret displayed information. Locate the required part
appearances by performing spatial or attribute searches for product structure occurrences within the
configured product context.

Filtering the background part appearances for the target work parts, as defined in the Configure
Work Part Context window, is the final step in configuring the context for a design or design review
session. See Managing work part appearances for additional information on selecting target work part
appearances. You can filter background part appearances by proximity to the work part, Classification
attributes, occurrence notes, or form attributes.

You can display the resulting appearances in NX or Lifecycle Visualization.

Your administrator configures the available Design Context options for background part appearances.
For example, zone filters may not be available at your site.

Note:

Siemens Digital Industries Software recommends applying proximity and attribute filters to limit
the scope of searches within a product context or zone. If no proximity distance is set, the scope of
the attribute search is the entire product as configured by the revision rule. Significant degradation
in system performance may be experienced if searches are performed without proximity and
attribute filtering.

Configure filtering of background part appearances

Configure filtering of background part appearances

1. (Optional) Select the Valid Overlays Only check box located in the upper-right side of the
Configure Filter window.

This option allows Teamcenter to load otherwise physically mutually exclusive parts, filtering out
those known to never coexist in any possible variant combination with any one of the target
appearances.

Note:

The Valid Overlays Only option only analyzes classic variants; any defined modular variants
are ignored.
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Note:

When you select the Valid Overlays Only check box, Teamcenter determines the minimum
number of variant rules that cover all product variants in which the target components can
exist. However, these rules are not applied until you click the Update button to filter the
background components.

2. (Optional) Select Append Parts to append the results of the search for background appearances to
the existing list.

3. Apply any combination of the following filters.

Note:

There is no priority with which Teamcenter applies these filters. All the filter conditions are
combined to configure the background parts.

Filter Purpose Action

Proximity Specifies the physical
distance from the work
part appearance within
which background part
appearances are selected.

Note:

The displayed
values are only
approximations.

Select a predefined numeric value from the list.

Zone Filter Specifies the zone in
the assembly within
which background part
appearances are selected.

Multiple zone filters are
implicitly combined using a
logical AND.

Zones must be created in
the NX top-level CAD model
before you can apply zone
filters.

Adding zone filters

a. Click the add (+) button to add a line to
the zone filter list.

b. Click the cell in the left column of the
new row and select from the list of
known zones in the NX top-level part.

c. Click the cell in the right column of the
row and select from the list of valid
operators for the zone.

Removing zone filters

5. Filtering part appearances
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Filter Purpose Action

Select a row and click the remove (–) button
to remove the filter from the table.

Saved Query Performs a predefined
search with the items
or item revisions by
which background part
appearances are selected.
The search is saved as a
saved query tab at the top
of the window.

Note:

If you exceed the
maximum number of
possible tabs, a new
search is not saved.

Select the filtering items and
item revisions by performing
a saved query.

a. Click the Saved Query tab.

b. Select Item Saved Queries or Item Revision
Saved Queries from the list.

c. Enter known data regarding the desired item
or item revision in the query boxes.

For more information about running saved
queries, see Teamcenter Basics.

Mapped
Attributes

Performs a search with
the occurrence notes by
which background part
appearances are selected.
The search is saved as a
saved query tab at the top
of the window.

You define the actual
attributes on the parts in
Structure Manager.

a. Click the add (+) button to add a line to the
Mapped Attributes filter list.

b. Click the Attribute column, and select an
attribute from the list.

c. Click the Operator column, and select an
operator to apply to the attribute value.

d. Enter an attribute value in the Value column.

Classification
Attributes

Performs a search with
the Classification attributes
by which background part
appearances are selected.
The search is saved as a
saved query tab at the top
of the screen.

a. Click the add (+) button to add a line to the
Classification Attributes filter list.

b. Click the Search Classification Class button
to display the Class Selection dialog box.

c. From the Class Selection dialog box, select
classified attributes, based on Classification
classes, by which to filter your search.

Configure filtering of background part appearances
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Filter Purpose Action

Selecting a class populates the Property
Name box of the Classification Attributes
filter list.

d. Click the Operator column, and select an
operator to apply to the attribute value.

e. Enter a search value in the Searching Value
column.

Note:

The Saved Query, Mapped Attributes, and Classification Attributes tabs are enabled only
when applicable. For example, if your site is using a QPL search engine, only attribute
searches are supported. In such a situation, the Attribute Filter box displays, rather than the
three tabs mentioned previously.

To modify any of the attribute filters, do any of the following:

• Click the add (+) button to add a line to the attribute filter list.

• Click the Attribute column, and select an attribute from the list.

• Click the Operator column, and select an operator to apply to the attribute value, for example,
LIKE, Begins with, or Contains.

The LIKE operator is used in conjunction with a wildcard character. For example, a search for
the name attribute using the = operator combined with a wildcard character, *, yields any
objects with a one-character long name of *. Using the LIKE operator combined with a wildcard
character, *, yields all objects with any value for the name attribute.

• Enter an attribute value in the Value column.

Note:

The Saved Query, Mapped Attributes, and Classification Attributes tabs are enabled only
when applicable.

4. Click the Update button.

This action overwrites the existing background part appearance list unless you selected the
Append Parts option located in the upper-left section of the window.

5. Filtering part appearances
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Teamcenter searches the product structure for background part appearances that match the
selected filter criteria within the defined product context. The background part appearances and
their corresponding installation assembly appearances are displayed in the lists in the bottom
section of the window. There may be an appreciable delay before the search completes if you are
working with large assemblies.

You can now send these appearances to NX as the basis of a design session or to Lifecycle
Visualization for clearance or proximity analysis, as described in Defining product context and work
parts.

If the number of matches exceeds the limit set by the
PortalDesignContextMaxMatchingBOMLines preference, Teamcenter displays a warning but you
can choose to continue.

Understanding the Valid Overlays Only option

The Valid Overlays Only option allows users to work in the context of product structure lines that
truly coexist when variants are configured. Using static variant rules may not allow the configuring of a
valid engineering context for the following reasons; this is especially true in complex structures that are
configured by several variant rules:

• Some options may be left unset. This may cause unwanted components to load even though they are
mutually exclusive with the engineering context.

• All options are set. This may cause components to be configured out even though they can coexist
with the components in the engineering context.

• Creating a variant rule requires expertise in the variant model of the product. In many cases, this
variant model changes over time and users may not have sufficient knowledge to set a variant rule
that correctly configures the engineering context. (Correctly implies that no required component is
configured out and no unrequired component is configured in.)

You can optionally use Platform Designer to assist in populating the variant conditions. However, you
can also apply them directly.

The Valid Overlays Only option dynamically generates variant rules and applies them to the loaded
context so that unnecessary lines are omitted from the context.

For example, if you have three lines (A, B, and C) in a product assembly, they may have the following
variant conditions:

load A if ENG=V8 || V6
load B if ENG=V6
load C if ENG=V6
load D if ENG=Diesel

Understanding the Valid Overlays Only option
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The OR variant condition means that it is not possible to find a single variant rule that configures the
context for all its background part appearances. Any variant rule is forced to choose V6 or V8 but never
both. The Valid Overlays Only option, however, calculates two variant rules, one with V8 and one with
V6. This issue is described in the second bullet previously.

In the example, ENG is a variant family with three possible values, V6, V8, and Diesel. It is not valid
to simply leave ENG unset. If ENG is left unset, the background of A would include D, even though D
is not available for any product variant in which A can occur. This issue is described in the first bullet
previously.

To summarize:

Target Background

A B; C

B A

C A

D —

When you select a saved variant rule in the Design Context second window and also select the Valid
Overlays Only option, Teamcenter applies the selections in a cumulative manner, similar to other search
criteria. As a result, it is possible to select a contradictory combination of zone filters. Design Context
does not check the validity of the selected filters.

Caution:

If you use this option, do not set any variant rules in the Design Context second window unless
you have detailed knowledge of the product variant model. Any manually set variant value is
superimposed on the calculated variant rules. Consequently, the Valid Overlays Only option may
return fewer variant rules because those not compatible with the manually set variant values are
not returned. Components compatible with your engineering context may then be inadvertently
discarded, possibly causing changes that are not buildable to be made or overlooked.

In the same window, ensure you clear the Show Unconfigured Variants check box.

The following examples illustrate situations where you may choose the Design Context valid overlays
only option:

• Example 1

You are working on a project to design a fuel filter system for gasoline engines. Therefore, you may
want to load an overlay of the 3.1 liter V6 and the 3.3 liter V6, which are mutually exclusive, but not
the diesel engines. By selecting the Valid Overlays Only option in the Design Context configuration
filtering window, the system filters out diesel engines because their variant conditions specify that
they cannot coexist with the gasoline fuel filter system in any possible variant.

5. Filtering part appearances
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• Example 2

While working on a 16-gallon fuel tank, you want to load nearby parts and to see an overlay of
all floor panel and rear axle variants; however, you do not want to load the 20-gallon fuel tank. By
selecting the Valid Overlays Only option, you can filter out the 20-gallon tank but load all valid
variants of floor panels and rear axles.

Note:

The Valid Overlays Only option only analyzes classic variants; any defined modular variants are
ignored.

It also takes into account rule checks but ignores any derived default values.

Understanding the Valid Overlays Only option
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6. Creating box and plane zones
Creating box and plane zones

You can create box and plane zones within Teamcenter to filter searches. Box and plane zones are
specified in the RDVBoxZoneFilter and RDVPlaneZoneFilter forms delivered with Teamcenter. Create
zones by using the forms to define the dimensions, location, and orientation of the zone.

Zones appear as lines in the product structure. Save zone forms in Structure Manager, after which you
can view these zones in the Configure Filter window in Design Context, using them to further filter
appearance set searches.

Note:

You can search for components by zone, and then select the installation assemblies of all
components in that zone. If you choose Edit→Copy, you can copy the selected installation
assemblies and paste them into Structure Manager as a private assembly.

When creating zones, you define the coordinates of the boxes and planes, if applicable, as described in
Define zone dimensions.

Create box and plane zones

Zones are created in the context of a product context. To create box or plane zones in Teamcenter,
complete steps 1 and 2 in Configure work part appearances, then do the following:

1. In the Configure Work Part Context window, choose File→New→Zones, and Teamcenter displays
the New Zone dialog box.

2. Click the RDVBoxZoneFilter or RDVPlaneZoneFilter icon in the left column of the New Zone
dialog box to create a new box zone or plane zone, respectively.

If the desired zone option is not displaying in the left column, click More....

3. Type a name and description in the Name and Description boxes, then click OK. Teamcenter
creates a new zone form whose coordinates have not yet been defined; it is not yet saved to the
database.

4. In Structure Manager, select the zone you just created. The zone displays at the bottom of the
assembly whose product context you selected in step 1 of Configure work part appearances.

5. Click the Properties button in the toolbar and Teamcenter displays the GDE Line Properties dialog
box.
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6. In the GDE Line Properties dialog box, click the link next to the Item/Revision/GDE Object: entry.
Teamcenter displays the Properties dialog box containing the zone's properties.

7. Use the Properties dialog box to define the coordinates of the box or plane zone, using the
mathematical formulas explained in Define zone dimensions.

You must enter data in every box. If necessary, overwrite the default 0.00000000 with 0.0.

8. In the Properties dialog box, click OK and Teamcenter closes the dialog box. The zone coordinates
are now defined and the zone is saved to the database.

9. In the GDE Line Properties dialog box, click OK and Teamcenter closes the dialog box.

10. Click OK and Teamcenter closes the zone's Properties dialog box.

11. Click Save on the Structure Manager toolbar and Teamcenter saves the zone form to the database.

Once the form data is saved to the database, you can use the zone data in Design Context to filter
searches. See step 3 of Configure work part appearances.

Define zone dimensions

Define zone dimensions

Box and plane zones filter appearance set searches.

1. Define the dimensions, location, and orientation of a zone. Enter the dimensions in the same unit
of measure (metric or imperial) as used in the NX design to allow NX to synchronize the assembly
units to Teamcenter; do not mix units.

Tip:

The factor to scale assembly units to meters is available from the assy_units property of BOM
view revisions. If you create an assembly from the metric seed part, the unit scaling factor
in the assy_units property of BOM view revisions is 0.001. In this case, a value of 1 means
0.001 meters.

Note:

Older NX assemblies or CAD data from other CAD systems determine the
unit scaling factor from the PS_assume_legacy_transform_units preference. If
PS_assume_legacy_transform_units is set to INCHES, a value of 1 means 0.0254 meters. If
PS_assume_legacy_transform_units is set to any other value, 1 means 0.001 meters.

6. Creating box and plane zones
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For example, if you want to create a plane zone that is parallel to the XY plane (the
floor plane) and is 2 feet above the ground, you must first convert 2 feet into assembly
coordinates. If the assembly coordinates are MILLIMETERS, the distance above ground is
therefore 2 * 25.4 mm = 50.8mm or simply 50.8.

2. Specify the direction that is perpendicular to the desired plane—in the previous example, the XY or
floor plane. You have two options:

{ 0.0, 0.0, 1.0 }

or

{ 0.0, 0.0, -1.0 }

Choose the appropriate option depending on whether you want to search for components above or
below the plane. In the example, above means on the side of the plane to which the normal vector
points. If above means towards the sky, you specify the normal vector as { 0.0, 0.0, 1.0 }.

Defining box zones

You define box zones with the following parameters:

• Coordinates of a base point (x, y, z coordinates). This defines a corner of the box in 3D.

• Each length as a 3D vector with x, y, and z coordinates. Each 3D vector must have at least one
coordinate not equal to 0.0. None of the three vectors may be parallel to any of the other vectors
(linear independence) For example, you may have a box that is aligned with the X, Y, and Z directions
of the coordinate system. If the box is X units wide, Y units deep, and Z units high, it has the following
edge vectors: (X, 0.0, 0.0) (0.0, Y, 0.0) (0.0, 0.0, Z).

The right-hand rule is a simple method to determine the sequence of axes in a Cartesian coordinate
system. If the thumb, index finger, and middle finger of the right hand are held so that they form three
right angles, the thumb indicates the X-axis, the index finger the Y-axis, and the middle finger the Z-axis.

Defining box zones
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If you are using cacheless search, the results obtained differ according to whether you enable TruShape
data analysis, as follows.

Search type
Result with TruShape analysis not
enabled

Result with TruShape analysis
enabled

Within box Objects within and interfering with
the box

Objects within the box

Interferes with box Objects within and interfering with
the box

Objects within and interfering with
the box

Outside box Objects outside and interfering with
the box

Objects outside the box

Defining plane zones

Typically, you search one or more planes zones to identify BOM lines that satisfy the search criteria. You
can optionally combine a plane zone search with other search types, for example, a box zone search.

You define plane zones with the following parameters:

• Coordinates of a base point (x, y, z coordinates). This defines a point that is part of the plane. You can
specify any point you want on the plane.

• Parameters of a normal vector that is perpendicular to the plane (lengths in x, y, z directions).

6. Creating box and plane zones
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You can search for BOM lines that are above, below or intersect with the defined plane zone. The results
in each case are shown in the following diagram.

Each search type returns the following results.

Search type Objects found

Below plane 1, 2, 3, 4, 5, 6

Above plane 7, 9

Intersects plane 8

Defining plane zones
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Note:

You can optionally perform plane zone searches with TruShape data analysis enabled. If you do
not select this option, Teamcenter uses bounding box computations to perform the search. If you
are using cacheless search, the results obtained differ according to whether you enable TruShape
data analysis, as follows.

Search type
Result with TruShape analysis
not enabled

Result with TruShape analysis
enabled

Below plane Objects below and intersecting
the plane

Objects below the plane

Above plane Objects above and intersecting
the plane

Objects above the plane

Intersects plane Objects below and intersecting
the plane

Objects intersecting the plane

6. Creating box and plane zones
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7. Working with parts in the defined
context
Working with parts in the defined context

After you configure the context for the work parts that are the focus of your design or design review
session, you can open the entire context in:

• NX

• The embedded viewer in Structure Manager or other rich client application

• Stand-alone Lifecycle Visualization

Alternatively, you can select certain parts in the third window and send them in the same way.

Load work parts and configure background parts

• Click the appropriate button in the Design Context toolbar to launch the application (for example,
Send to NX  or Start/Open in Lifecycle Visualization ) and Teamcenter displays the context.

Note:

The applications to which you can send your Design Context data are determined by your
administrator and are defined by Design Context interoperability preferences.

Export a context configuration to NX

You can export a fully configured assembly context to NX to use in a design session. To do this, choose
the Tools→Export Configured NX Assembly menu command and Teamcenter displays the Export
Configured NX Assembly dialog box.

1. Type the item or item revision name of the assembly to export in the Item ID/Revision - Name box.

2. Type the desired revision rule in the Revision Rule box.

3. Enter the name of the directory to which Teamcenter exports the assembly, or use the Browse
button to locate the directory.

4. Optionally, select the Checkout the target part datasets check box to check out the target work
part datasets. Regardless of whether this box is checked, the BOM view revision is also checked
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out if the target part contains a UGMASTER or UGPART dataset. However if the target part is
UGALTREP dataset, it does not check out the BOM view revision.

5. Optionally, select a naming convention for the exported file. Type a prefix in the Add Prefix box,
which is added to the exported part names, or select Auto Translate to automatically translate the
names of exported parts from database format to native format.

When all entries are correct, click OK and Teamcenter exports the assembly. You are notified if the export
process is successful. If load errors of NX parts are encountered, the cloning utility ignores the problem
parts and continues to the next part.

Note:

System administrators should not cancel checkouts resulting from this export. Doing so prevents
modified parts from being imported back into the Teamcenter database.

Note:

Parts exported in this manner may be imported back into the Teamcenter database using the NX
Integration nxmgr_selective_export utility.

7. Working with parts in the defined context
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8. Managing changes to the product
Managing changes to the product

You must keep your Design Context data valid if changes are made to the product design. Changes that
require an update of the Design Context data are the addition of a new component and the replacement
of a design.

Add a new component in the installation assembly

If a new component is added to an installation assembly and the absolute occurrence identifier matches
the architecture element, Teamcenter creates a new occurrence in the structure, then registers named
variant expressions (NVEs) and sets the variant condition on the occurrence.

When the product structure contains the installation assembly with the new occurrence, you can
configure the product for the new component by applying an appropriate variant rule to the top level
node.

Replace a design in a product

If you are using Platform Designer to help you manage the variability of your product, you can replace
your CAD-designed solution in the product structure with another design using the Replace Design in
Product wizard. This wizard assists you in finding the correct design based on the variability associated
with the architecture breakdown element. The resulting design solution carries design usage properties
such as shape, position, effectivity, or variant expressions.

1. Select the top-level architecture object under which you want to insert the component.

2. Click Replace Design in Product .

The Replace Design in Product dialog box appears.

3. Locate the product item revision by defining your search criteria in the search fields and clicking
.

4. Select the product item to which you want to add the component and click Next.

5. Select the product context to which you want to add the component from within the Product
Context table and click Next.

6. Select the design item you want to add. Locate the item by entering either the name or component
ID and clicking . Alternatively, you can paste an item from the clipboard. If an item has many
revisions, you can narrow the choice using Revision display filter.
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7. Click Next.

8. Select the top-level architecture you want associated with the product context from the
Architecture list. The system presents the architecture breakdown elements belonging to the
architecture breakdown that you selected.

9. Select the architecture element for which the selected item revision is a solution. Locate the
architecture element by entering its ID in the Architecture Element ID box and clicking . Select
the architecture element from within the search results in the bottom panel. Wildcards can be used
in this search.

The list associated with the Architecture field includes all architecture breakdowns that contain
an architecture element matching the absolute occurrence identifier of the occurrence you want
to replace . If the occurrence does not have an absolute occurrence identifier, the list includes
all architecture breakdowns for the selected product context. If the absolute occurrence identifier
was edited manually, Teamcenter matches the solution occurrence to replace to the architecture
element containing an absolute occurrence with the appropriate absolute occurrence identifier.

The list next to the Architecture Element box contains the absolute occurrence identifier of the
occurrence to replace , if Teamcenter can find the corresponding architecture breakdown element.
If you change the architecture element identifier to correspond to an architecture element that is
not its parent of the pre-populated value, Teamcenter displays a warning message when you click
Next. No error message is displayed if the Architecture Element box is blank.

This field may be pre-populated if your site administrator has defined the ArchitectureType
_generic_id_mapping preference.

10. Click Next.

11. In the top part of the panel, select a named variant expression (NVE) to define the variant condition
for the component.

12. (Optional) In the bottom part of the panel, further define the conditions under which this solution
is valid by selecting additional splitting NVEs. These are added to the existing NVEs to further
qualify the design that you select.

13. Click Finish and the component data is added to the architecture breakdown.

Your design solution is also added to the product structure and can be viewed in Design Context
and Structure Manager.

8. Managing changes to the product
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9. Performing clearance analysis and
proximity filtering
Performing clearance analysis and proximity filtering

You can use the product structure data in Design Context to perform clearance analysis in conjunction
with the ClearanceDB feature in the stand-alone Lifecycle Visualization application or the embedded
viewer in the rich client. To do this, you must install the integrated clearance management (ICM) system
and configure the clearance database. To use this capability, you must have JT files in Teamcenter to
represent all the applicable parts (the ICM can accept any pruned or full product structure provided it is
represented by a JT file). Any parts for which JT data is not available are not included in the clearance
analysis.

For information about ICM and the configuration of the clearance database, see ClearanceDB
Administration.

You can perform clearance analysis in two modes:

• Real-time mode

In this mode, you manually select target and background BOM lines in Design Context, then manually
invoke a clearance analysis that Teamcenter performs in real time. Typically, you choose this option to
make on-the-fly clearance calculations after design changes or prior to releasing a part. Teamcenter
runs these calculations in the background, allowing you to continue with other work while you are
waiting for the results. The results are stored in a structure context, allowing you to retrieve them in
future sessions.

• Database query mode

Your administrator configures a cron job that performs clearance analysis periodically as a background
task, typically every night. The cron job invokes the Clearance.exe executable that performs the
actual analysis. Clearance issues identified by the database query task are stored in the database and
you can view them from Design Context. As there is a significant delay before you can view the results
of a database query analysis, it is not suitable for real-time analysis of changes.

You can also reopen results that you have previously saved in a structure context object (SCO).

If you do not select particular BOM lines, Teamcenter considers all BOM lines in the target appearances
in Design Context as target parts.

Perform clearance analysis

The general process for analyzing clearances is as follows:
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1. Specify target parts, which are typically parts you own. You initially configure the structure by
specifying variant rules and revision rules in Structure Manager. You can then use filters and
selections in Design Context to identify target parts.

2. Find the applicable background, which are all parts within a selected proximity of the target parts.

3. Check target and background parts for clashes.

4. Perform real-time analysis or query the clearance database for issues.

5. Send violating part pairs to Structure Manager or Teamcenter lifecycle visualization mockup for
further clearance analysis.

Note:

For more information about how to examine clearance issues in the viewer, see Performing
Clearance analysis in Working With 3D Models in the Teamcenter lifecycle visualization help.

Perform database query mode analysis

Your administrator configures the scope of a database query analysis; you can only view the results.
However, because Teamcenter runs a database query analysis against the entire product, you can
identify clearance issues that a particular part may have with any other part in the product.

1. Choose Tools→Clearance Analysis.

Teamcenter displays the Clearance Analysis dialog box.

2. Select Query the database for existing results and click Start Analysis.

After a delay that depends on the quantity of stored data, Teamcenter displays the retrieved
clearance issues in one of the Issues panes, as described in Reviewing clearance issues.

Request a real-time clearance analysis of selected lines

1. Optionally, select the product structure lines of interest in the third Design Context window. If you
do not select any lines, Teamcenter includes all appearances in the third Design Context window in
the analysis.

2. Choose Tools→Clearance Analysis.

Teamcenter displays the Clearance Analysis dialog box.

3. Select Perform Real-Time Clearance Analysis and click Start Analysis.

9. Performing clearance analysis and proximity filtering
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A progress bar shows the percentage completion of the calculation and you can click Cancel above
the progress bar to terminate the process if necessary. After a delay that depends on the scope
of the query, Teamcenter displays the clearance issues in one of the Issues panes, as described in
Reviewing clearance issues.

4. Click OK on the form.

Optionally, Teamcenter may create an structure context object (SCO) in your Newstuff folder
containing information about the session. You can open the SCO in a subsequent session to
retrieve the selected product structure lines and analysis results. For details of how to retrieve data
from an SCO, see Open clearance results in an SCO.

Note:

Creation of an SCO is optional and occurs only if the RDVCreateSCOForClearance preference
is set to true.

Open clearance results in an SCO

1. In your Newstuff folder, right-click the SCO containing the results required and choose Send
To→Design Context.

Teamcenter opens the results in the first Design Context window.

2. Click Finish.

Teamcenter opens the third Design Context window.

Note:

Click Yes on any confirmation dialog boxes that are displayed.

3. Choose Tools→Clearance Analysis.

Teamcenter displays the Clearance Analysis dialog box.

4. Select Display Cached Results from SCO and click Start Analysis.

After a delay that depends on the quantity of stored data, Teamcenter displays the retrieved
clearance issues in one of the Issues panes, as described in Reviewing clearance issues.

Reviewing clearance issues

You can obtain clearance issue data in three ways:

Open clearance results in an SCO
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• View the issues resulting from the most recent database query clearance analysis, as described in
Perform database query mode analysis.

• Run a real-time clearance calculation manually, as described in Request a real-time clearance analysis
of selected lines.

• Open stored clearance issue data from a SCO, as described in Open clearance results in an SCO.

In each case, Design Context presents the issues in the following panes:

• Target-Target Issues

Shows clearance issues among all the appearances in the Design Context target appearances table in
the third window. The specific issue between each pair of parts is listed.

• Target-Background Issues

Shows clearance issues among target parts against all the appearances in the Design Context
background appearances table in the third window. The specific issue between each pair of parts
is listed.

• Target-Other Issues

In the Issues panes, Teamcenter displays each pair of parts that violate one of the defined clearance
rules. All violations are shown in the context of the selected target part appearance or appearances. For
each violation, the following information is listed:

• The full description of each part.

• Result

The calculated violation with respect to the requirement.

• Requirement

The required clearance.

• Location

The x,y,z coordinates of the violation.

Communicating to Design Context

To view the associated parts in the embedded viewer, select one or more issues and click the
Communicate to Design Context button.

9. Performing clearance analysis and proximity filtering
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Teamcenter highlights the relevant BOM lines in Design Context, allowing you to perform further
analysis, as follows:

• View the parts associated with the selected issues in the embedded viewer.

• View the parts associated with the selected issues in stand-alone Teamcenter lifecycle visualization
mockup by clicking the Launch in Lifecycle Visualization button .

• Synchronize the BOM lines with Structure Manager by clicking the Synchronize with Structure
Manager button .

Send an issue to Workflow

You can send an issue to a predefined Workflow process to ensure the problem is resolved.

• Select a row in one of the Issues panes and click the Start Workflow button.

Teamcenter creates an engineering change item for the selected issue and submits it to the Workflow
process. The engineering change item includes the following information:

• The rule that was violated.

• The parts that violated the rule. (They are added to the Problem Items folder.)

• The product where the violation occurs.

• The configuration of the product where the violation occurs.

• The lowest common ancestor of the two parts. (They are added to the Affected Items folder.)

• The top-level revision item of the product and configuration context object. (They are added to the
Reference folder.)

Send an issue to Workflow
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